Общие сведения о средстве веб-развертывания для диспетчера служб IIS

Средство веб-развертывания (Web Deploy) выполняет синхронизацию конфигурации служб IIS, содержимого, SSL-сертификатов и прочих типов данных из указанного пользователем сайта или сервера в указанное пользователем назначение. Также можно развертывать такие объекты, как разделы реестра, которые по умолчанию не включаются.

Делегирование службы управления

В IIS Manager Web Deploy добавляет на уровне сервера доступную только администраторам функцию, именуемую делегированием службы управления, которая позволяет с высокой точностью управлять действиями, связанными с развертыванием, предпринимаемыми удаленными пользователями. Дополнительные сведения см. в разделе Страница «Делегирование службы управления».

Экспорт и импорт приложений

В области IIS Manager Действия с помощью мастера экспорта пакета приложения можно создавать сжатые файлы (пакеты), содержащие сайты, приложения и содержимое. Дополнительные сведения см. в разделе Страницы мастера "Экспорт пакета приложения" и "Экспорт пакета сервера".

После экспорта пакета можно воспользоваться мастером импорта пакета приложения для установки содержимого пакета в другое расположение. Дополнительные сведения см. в разделе Страницы мастера "Импорт пакета приложения" и "Импорт пакета сайта или сервера".

Функции командной строки

Программа Msdeploy.exe и набора средств веб-развертывания предоставляет множество мощных функций командной строки. Для получения краткой справки о возможностях программы Msdeploy.exe введите в командной строке msdeploy -help. Более подробная справка представлена на веб-странице Средство веб-развертывания (возможно, на английском языке).

Дополнительные материалы в Интернете

IIS.NET: средство веб-развертывания (страница может быть на английском языке)

IIS.NET: средство веб-развертывания — форум (страница может быть на английском языке)

IIS.NET: средство веб-развертывания — блог группы разработчиков (страница может быть на английском языке)


Справка по пользовательскому интерфейсу средства веб-развертывания

IIS Manager предоставляет описание всех элементов пользовательского интерфейса каждой страницы, каждого диалогового окна и каждой страницы мастера в IIS Manager. Для просмотра данной справки нажмите клавишу F1 на активной странице компонента, в диалоговом окне или на странице мастера.

В этом разделе

Страница «Делегирование службы управления»

Страницы мастера "Экспорт пакета приложения" и "Экспорт пакета сервера"

Страницы мастера "Импорт пакета приложения" и "Импорт пакета сайта или сервера"


Страница «Делегирование службы управления»

Страница делегирования службы управления используется для определения правил, управляющих правами развертывания удаленных пользователей. Эта страница может использоваться только администраторами и отображается только на уровне сервера.

Элементы пользовательского интерфейса

Имя элемента | Описание
Поставщик | Отображает поставщика или поставщиков, в отношении которых применяется правило.
Путь | Отображает путь, к которому применяется правило.
Тип пути | Отображает тип пути. Возможные значения: PathPrefix, StringPrefix, StringSuffix, ConnectionString и RegularExpression.
Действия | Отображает предпринимаемые правилом действия. Типичные значения для поставщиков Web Deploy: «Чтение», «Запись» и «*».
Тип удостоверения | Отображает тип удостоверения, от имени которого выполняется правило. Возможные значения: CurrentUser, ProcessIdentity и SpecificUser.
Имя пользователя | Отображает имя пользователя, если в качестве типа удостоверения выбран тип SpecificUser. Если выбран тип CurrentUser или ProcessIdentity, имя пользователя не отображается.
Состояние | Показывает, включено или отключено правило. Можно включить или выключить правило, нажав кнопку Включить правило или Выключить правило в панели Действия.

Элементы панели «Действия»

Имя элемента | Описание
Добавление правила… | Открывает диалоговое окно Добавление правила. Щелкните данный элемент, если требуется добавить правило. Дополнительные сведения см. в разделе Диалоговое окно «Добавление правила» (делегирование службы управления).
Добавить пользователя в правило… | Открывает диалоговое окно Добавление пользователя в правило. Дополнительные сведения см. в разделе Диалоговое окно «Добавление пользователя в правило».
Изменить… | Открывает диалоговое окно Изменение правила. Дополнительные сведения см. в разделе Диалоговые окна "Добавление правила" и "Изменение правила".
Удалить | Удаляет выбранное правило делегирования или пользователя правила делегирования.
Выключить правило | Выключает выбранное правило делегирования.
Включить правило | Включает выбранное правило делегирования.
Изменить параметры… | Открывает диалоговое окно Изменение параметров компонентов. Дополнительные сведения см. в разделе Диалоговое окно «Изменение параметров компонентов» (делегирование службы управления).


Диалоговое окно «Добавление правила» (делегирование службы управления)
См. также

Диалоговое окно Выбор шаблона правила используется для выбора шаблона для создания пользовательского правила делегирования. Можно выбрать пустой шаблон или предварительно установленный шаблон, предназначенный для конкретного сценария.

Элементы пользовательского интерфейса

Установленные шаблоны

Имя элемента Описание

Пустое правило

Создает пустое правило, которое затем можно настроить.

Развертывание только содержимого

Создает правило, позволяющее выполнять только развертывание содержимого. Правило позволяет любому пользователю, авторизованному службой WMSvc, публиковать содержимое по пути, для которого у него уже есть разрешение от службы WMSvc. Правило может быть изменено с целью ограничения доступа указанием конкретного пути или пользователя. Это правило использует поставщика contentPath, который выполняет синхронизацию содержимого веб-сайта. Дополнительные сведения см. в статье о поставщике contentPath Web Deploy (возможно, на английском языке).

Развертывание приложения с содержимым

Создает правило, позволяющее выполнять развертывание приложений. Этот шаблон не включает правило пометки папки как приложения, но часто используется в сочетании с таким правилом. Правило позволяет любому пользователю, авторизованному службой WMSvc, публиковать приложение по пути, для которого у него уже есть разрешение от службы WMSvc. Правило может быть изменено с целью ограничения доступа указанием конкретного пути или пользователя. Данное правило использует поставщиков contentPath и iisApp. Дополнительные сведения см. в статьях Поставщик contentPath Web Deploy (возможно, на английском языке) и Поставщик iisApp Web Deploy (содержимое страницы может отображаться на английском языке).

Развертывание баз данных

Создает правило, позволяющее выполнять развертывание баз данных. Правило разрешает любому пользователю, авторизованному службой WMSvc, публиковать данные в любой базе данных, к которой предоставлен доступ. Шаблон указывает, что используется учетная запись CurrentUser, означающая, что для проверки подлинности пользователя на сервере баз данных будет использована строка подключения. Правило может быть изменено с целью ограничения доступа указанием конкретного сервера баз данных или имени пользователя. Это правило использует поставщика dbFullSql, позволяющего первичную публикацию баз данных из локальной базы данных развертывания сервера SQL Server в удаленную базу данных на сервере SQL Server. Дополнительные сведения см. в статье о поставщике dbFullSql Web Deploy (возможно, на английском языке).

Пометка папок как приложений

Создает правило, помечающее папку как приложение. Правило разрешает любому пользователю, авторизованному службой WMSvc, помечать папку как приложение. Если пользователь не является администратором, необходимо изменить тип удостоверения на учетную запись, имеющую право доступа для записи в файл ApplicationHost.config. По умолчанию к этому правилу применяется тип удостоверения SpecificUser. Данное правило использует поставщик createApp, требуемый для пометки папок как приложений (его функциональность также включена в поставщик iisApp). Дополнительные сведения см. в статье о поставщиках Web Deploy (возможно, на английском языке).

Задание разрешений для приложений

Создает правило, задающее списки управления доступом для пути приложения. Правило позволяет любому пользователю, авторизованному службой WMSvc, задавать списки управления доступом для пути приложения, для которого у него уже есть разрешение от службы WMSvc. Шаблон указывает, что используется учетная запись CurrentUser, означающая, что для изменения списков управления доступом пользователь должен иметь соответствующие разрешения. Правило может быть изменено с целью ограничения доступа указанием конкретного пути или пользователя. Это правило использует поставщика setAcl, который задает разрешения для конечной папки. Дополнительные сведения см. в статье о поставщике setAcl Web Deploy (возможно, на английском языке). .

Резервное копирование и восстановление баз данных (используя проверку подлинности SQL)

Создает правило, выполняющее резервное копирование и восстановление баз данных, используя проверку подлинности SQL. Правило позволяет любому пользователю, авторизованному службой WMSvc, создавать или восстанавливать резервную копию базы данных, к которой он уже имеет доступ. Операции резервного копирования и восстановления выполняются от имени конкретного удостоверения пользователя с использованием проверки подлинности SQL. Правило может быть изменено с целью ограничения доступа указанием конкретной базы данных или конкретного набора пользователей.

Примечание
Используйте этот шаблон с расширением диспетчера баз данных IIS. Дополнительные сведения о диспетчере баз данных IIS см. в статье Диспетчер баз данных (возможно, на английском языке).

Резервное копирование и восстановление баз данных (используя встроенную систему безопасности Windows)

Создает правило, выполняющее резервное копирование и восстановление баз данных, используя проверку подлинности Windows. Правило позволяет любому пользователю, авторизованному службой WMSvc, создавать или восстанавливать резервную копию базы данных, к которой он уже имеет доступ. Правило может быть изменено с целью ограничения доступа указанием конкретной базы данных или конкретного набора пользователей.

Примечание
Используйте этот шаблон с расширением диспетчера баз данных IIS. Дополнительные сведения о диспетчере баз данных IIS см. в статье Диспетчер баз данных (возможно, на английском языке).

См. также

Понятия

Страницы мастера "Импорт пакета приложения" и "Импорт пакета сайта или сервера"

Другие ресурсы

Поставщики Web Deploy


Диалоговые окна "Добавление правила" и "Изменение правила"

Диалоговые окна Добавление правила и Изменение правила используются для добавления (или изменения) правил делегирования.

Элементы пользовательского интерфейса

Имя элемента | Описание
Поставщики | Используйте раскрывающийся список для выбора поставщиков, которых необходимо включить или исключить из правила, а затем щелкните кнопку со стрелкой для применения изменений. Поставщики отображаются в виде списка (разделитель — запятая). Дополнительные сведения о поставщиках Web Deploy см. в статье Поставщики Web Deploy (возможно, на английском языке).
Действия | Используйте раскрывающийся список для выбора действий, которые необходимо включить или исключить из правила, а затем щелкните кнопку со стрелкой для применения изменений. Действия отображаются в виде списка (разделитель — запятая). Типичные значения для Web Deploy: «Чтение», «Запись» и «*».
Тип пути | В раскрывающемся списке выберите тип пути. Возможные значения: PathPrefix, StringPrefix, StringSuffix, ConnectionString и RegularExpression. Дополнительные сведения о регулярных выражениях см. в статье Регулярные выражения (статья может быть на английском языке).
Путь | Укажите путь, к которому следует применять правило.
Тип удостоверения | В раскрывающемся списке выберите тип удостоверения для правила. Выбранное удостоверение будет выполнять правило. Возможные значения: CurrentUser, ProcessIdentity и SpecificUser. Значение CurrentUser указывает на то, что будет использоваться удостоверение текущего пользователя. Значение ProcessIdentity указывает на то, что будет использоваться удостоверение локальной службы WMSvc. Значение SpecificUser указывает на то, что будет использоваться особое удостоверение, заданное пользователем. Если выбрано значение SpecificUser, необходимо предоставить учетные данные с помощью кнопки Задать набор учетных данных.
Указать учетные данные | Включает кнопку Установить при выборе типа удостоверения SpecificUser.
Установить | Открывает диалоговое окно Задание учетных данных, позволяющее указать имя и пароль для удостоверения SpecificUser. Дополнительные сведения см. в разделе Диалоговое окно «Задание учетных данных».


Диалоговое окно «Задание учетных данных»
См. также

Диалоговое окно Задание учетных данных используется для предоставления имени пользователя и пароля для пользователя Windows, выполняющего правило.

Элементы пользовательского интерфейса

Имя элемента | Описание
Имя пользователя | Введите имя пользователя Windows.
Пароль | Введите пароль.
Подтверждение пароля | Введите пароль повторно для подтверждения.

См. также

Понятия

Диалоговые окна "Добавление правила" и "Изменение правила"


Диалоговое окно «Добавление пользователя в правило»

Диалоговое окно Добавление пользователя к правилу используется для разрешения или запрещения пользователю доступа к правилу.

Элементы пользовательского интерфейса

Имя элемента | Описание
Имя | Введите имя пользователя.
Тип доступа | Выберите тип доступа, предоставляемый конкретному пользователю. Возможные значения: «Разрешить» и «Отказать».
Роль? | Установите этот флажок, если указанное имя является псевдонимом группы пользователей, которой разрешен или запрещен доступ к правилу.


Диалоговое окно «Изменение параметров компонентов» (делегирование службы управления)

Диалоговое окно Изменение параметров компонентов используется для разрешения администраторам обхода правил делегирования, а также для включения записи невыполненных запросов в журнал.

Элементы пользовательского интерфейса

Имя элемента Описание

Позволять администраторам обходить правила

Установите этот флажок, чтобы разрешить администраторам обходить заданные правила делегирования.

Включить журналы трассировки невыполненных запросов для службы делегирования

Установите этот флажок, чтобы включить ведение журнала невыполненных запросов.

Предупреждение
Для работы данной функции требуется модуль трассировки невыполненных запросов (если он не установлен, необходимо установить его).


Страницы мастера "Экспорт пакета приложения" и "Экспорт пакета сервера"

Страница «Выбор содержимого пакета»

Страница «Выбор параметров»

Страница «Сохранение пакета»

Диалоговое окно "Пароль шифрования"

Страница хода экспорта и сводки


Страница «Выбор содержимого пакета»
См. также

Страница Выбор содержимого пакета мастера экспорта пакета приложения используется для просмотра компонентов, включаемых в создаваемый пакет.

Пакеты могут содержать такие компоненты, как параметры реестра, COM, сборки глобального кэша сборок или сертификаты. Для установки этих компонентов на сервере необходимо быть членом группы администраторов или иметь необходимые для этого права. Для установки только содержимого права администратора не требуются.

Элементы пользовательского интерфейса

Имя элемента Описание

Содержимое пакета

Список компонентов, включаемых в пакет. Здесь можно указать, какие компоненты пакета необходимо включить в пакет, установив рядом с соответствующими компонентами флажки. Например, можно включить или исключить базу данных SQL или сборку глобального кэша сборок, установив или сняв соответствующие флажки.

Внимание
Некоторые компоненты могут быть обязательными для приложений. В случае исключения таких компонентов из установки приложение после установки может работать неправильно.

Атрибуты

Отображает в правой части атрибуты выбранного файла, каталога или компонента. Эти значения доступны только для чтения.

Управление компонентами…

Открывает диалоговое окно Управление компонентами. Позволяет выбрать компоненты, которые необходимо включить. Дополнительные сведения см. в разделе Диалоговое окно «Управление компонентами».

Дополнительные параметры…

Открывает диалоговое окно Дополнительные параметры. Здесь можно задавать параметры операции и правила. Дополнительные сведения см. в разделе Диалоговое окно «Дополнительные параметры» (экспорт).

См. также

Понятия

Страницы мастера "Экспорт пакета приложения" и "Экспорт пакета сервера"

Другие ресурсы

Экспорт пакета через диспетчер IIS (материал в сети)


Диалоговое окно «Управление компонентами»
См. также

Диалоговое окно Управление компонентами мастера экспорта пакета приложения используется для добавления в пакет таких компонентов, как COM-объекты или сборки глобального кэша сборок.

Элементы пользовательского интерфейса

Заголовки столбцов

Имя элемента Описание

Имя поставщика

Задает компонент, который необходимо упаковать. У каждого компонента есть поставщик. Выберите имя поставщика в раскрывающемся списке поля. Для просмотра описания поставщика задержите курсор мыши над его именем. Например, если выбран поставщик dbFullSql, будет упакован путь сценария или строка подключения. Дополнительные сведения о поставщиках см. в статье Поставщики Web Deploy (содержимое страницы может отображаться на английском языке).

Важно
Если выполняется упаковка веб-сайта, поставщик iisApp (выбранный по умолчанию) помечает веб-сайт как приложение в назначении. Если необходимо упаковать веб-сайт и всю связанную с ним конфигурацию (имя пула приложений, расположение каталога содержимого, сертификаты), используйте поставщика appHostConfig. Если используется поставщик iisApp, веб-сайт станет приложением в назначении, наследующем все свои параметры (имя пула приложений, расположение каталога содержимого) от сайта, в котором он установлен.

Путь

Задает путь к компоненту, предоставляющему данные для пакета. Например, если выбран поставщик dbFullSql, путь может задавать сценарий (например, C:\SQLfiles\installSQL.sql) или строку подключения (например, Data Source=.\sqlexpress;Integrated Security=SSPI;Initial Catalog=db1).

Параметры поставщика

Указывает параметры, которые нужно использовать для выбранного поставщика. Перейдите в поле и, нажав кнопку обзора (…), откройте диалоговое окно Параметры поставщика. Дополнительные сведения см. в разделе Диалоговое окно «Параметры поставщика».

Кнопки

Имя элемента | Описание
Удалить | Удаляет выбранную запись.
Вверх | Перемещает выбранную строку на одну позицию вверх. Записи устанавливаются в порядке следования в списке. Для некоторых поставщиков порядок записей важен. Например, сценарий создания таблицы должен выполняться раньше сценария ее заполнения.
Вниз | Перемещает выбранную строку на одну позицию вниз. Записи устанавливаются в порядке следования в списке.

См. также

Понятия

Страница «Выбор содержимого пакета»
Страницы мастера "Экспорт пакета приложения" и "Экспорт пакета сервера"


Диалоговое окно «Параметры поставщика»
См. также

Диалоговое окно Параметры поставщика используется для указания параметров выбранного поставщика. Не все поставщики имеют настраиваемые параметры.

Элементы пользовательского интерфейса

Имя элемента | Описание
Имя параметра | Отображает имя параметра выбранного поставщика. Здесь перечислены только параметры, относящиеся к выбранному поставщику.
Значение параметра | Введите или выберите значение для параметра. Если доступен раскрывающийся список, то возможные значения параметра будут представлены в нем. В поле описания предоставлены сведения о допустимых значениях, которые требуется ввести.
Описание параметра | Отображает описание выбранного параметра для данного поставщика. Поле предоставляет сведения о том, какие значения допустимы для данного параметра.

См. также

Понятия

Диалоговое окно «Управление компонентами»
Страница «Выбор содержимого пакета»
Страницы мастера "Экспорт пакета приложения" и "Экспорт пакета сервера"

Другие ресурсы

Параметры поставщика Web Deploy


Диалоговое окно «Дополнительные параметры» (экспорт)
См. также

Диалоговое окно Дополнительные параметры мастера экспорта пакета приложения используется для настройки параметров пакета.

Элементы пользовательского интерфейса

Дополнительные параметры

Имя элемента Описание

Зашифровать пароль

Нажмите … , чтобы открыть диалоговое окно Зашифровать пароль и задать буквенно-цифровой пароль, управляющий доступом к свойствам безопасности в конфигурации IIS.

MS Deploy автоматически определяет, присутствует ли зашифрованный объект, такой как пул приложений со специальным удостоверением, в файлах конфигурации на уровне сервера (например, ApplicationHost.config или Machine.config). Если зашифрованный объект присутствует, необходимо предоставить пароль для этого объекта. Если предоставленный пароль неверный, операция экспорта выполнена не будет.

Важно
Web Deploy не проверяет файлы Web.config на наличие зашифрованных объектов.

Включить ACL

Выберите значение True, если списки управления доступом указанного пути будут скопированы из исходного в конечное расположение; в противном случае выберите значение False. Этот параметр касается файловой системы, реестра и метабазы и только следующих поставщиков: appHostConfig, contentPath, iisApp, metaKey, webServer и webServer60. Значение по умолчанию: false.

Расширение ссылки

Щелкните поле, расположенное справа, а затем щелкните стрелку, чтобы отобразить раскрывающийся список расширений ссылок. Выберите в списке расширения, которые следует применить к операции (или отключить). Расширения ссылок включают конкретные виды данных в операцию или исключают их. Доступные расширения Web Deploy: AppPoolExtension, CertificateExtension, ContentExtension, FrameworkConfigExtension и HttpCertConfigExtension. Эти расширения выбраны по умолчанию. Дополнительные сведения о расширениях ссылок см. в статье Расширения ссылок Web Deploy (возможно, на английском языке).

Повторные попытки

Укажите число попыток, предпринимаемых поставщиком в случае сбоя. Число попыток по умолчанию: 5. Интервал между попытками по умолчанию равен одной секунде. Параметр количества попыток может использоваться только с поставщиком contentPath.

Интервал между попытками

Укажите значение в миллисекундах. Введенное значение определяет интервал времени между попытками поставщика. Значение по умолчанию: 1000 (одна секунда). Этот параметр может использоваться только с поставщиком contentPath.

Уровень трассировки

Выберите в раскрывающемся списке значение, указывающее уровень детализации журнала сообщений об ошибках. Возможные значения: «Отключено», «Ошибка», «Предупреждение», «Сведения» и «Подробные сведения». Значение по умолчанию: «Сведения». Значение «Отключено» означает, что сообщения об ошибках в журнал не заносятся. Значение «Подробные сведения» означает, что в журнал вносятся все сообщения.

Параметры синхронизации

Имя элемента Описание

Правила

Открывает диалоговое окно Включение или отключение правил, в котором можно указать правила для операции. Дополнительные сведения см. в разделе Диалоговое окно "Включение или отключение правил".

WhatIf

Щелкните раскрывающийся список, чтобы выбрать True или False. True указывает, что операция будет запущена без фактического выполнения изменений. Этот параметр можно использовать для просмотра результатов операции, если все ее части выполнены успешно. Значением по умолчанию является False.

Примечание
Команда, кажущаяся выполненной успешно с параметром WhatIf, может дать сбой при выполнении без параметра WhatIf. Это может произойти в случае возникновения непредвиденных ошибок в работе. Например, из-за того, что в процессе выполнения операции с параметром WhatIf запись данных не выполняется, ошибка разрешения записи выявлена не будет. Параметр WhatIf показывает только то, что произойдет в случае успешного выполнения всех операций команды.

См. также

Понятия

Страница «Выбор содержимого пакета»
Страницы мастера "Экспорт пакета приложения" и "Экспорт пакета сервера"


Диалоговое окно "Включение или отключение правил"
См. также

Диалоговое окно Включение или отключение правил используется для включения или отключения правил, влияющих на результат операции синхронизации. Чтобы сгруппировать правила в категории по состоянию (включено или отключено), в раскрывающемся списке Сгруппировать по выберите пункт Состояние (чтобы просмотреть правила в алфавитном порядке, выберите в списке пункт Без группирования).

Элементы пользовательского интерфейса

Заголовки столбцов

Имя элемента | Описание
Имя | Перечисляет имена правил синхронизации, которые можно включить или отключить. Правила, отмеченные полужирным шрифтом, включены по умолчанию. Правила с затенением отключены по умолчанию. Для включения или выключения правило необходимо выбрать и нажать кнопку Включить правило или Выключить правило соответственно. Дополнительные сведения об этих правилах см. в статье Правила Web Deploy (возможно, на английском языке).

Кнопки

Имя элемента | Описание
Включить правило | Включает выбранное правило.
Выключить правило | Выключает выбранное правило.

См. также

Понятия

Страницы мастера "Экспорт пакета приложения" и "Экспорт пакета сервера"
Страницы мастера "Импорт пакета приложения" и "Импорт пакета сайта или сервера"


Страница «Выбор параметров»
См. также

Страница Выбор параметров мастера экспорта пакета приложения используется для добавления или удаления параметров из пакета. Параметр может быть задан атрибуту при создании пакета. Позднее, при установке пакета, пользователь может указать для параметра другое значение и оно будет присвоено атрибуту. Для каждого поставщика параметры создаются автоматически.

Элементы пользовательского интерфейса

Заголовки столбцов

Имя элемента | Описание
Имя | Перечисляет имена параметров, добавленных с помощью диалогового окна «Добавление параметра». Для изменения параметра необходимо щелкнуть его дважды или выбрать и нажать кнопку Изменить.
Тип | Отображает тип параметра для параметризируемого атрибута.
Область | Отображает область для параметризируемого атрибута.
Сопоставление | Отображает соответствующее выражение, определяющее параметризируемый атрибут.

Кнопки

Имя элемента Описание

Добавить параметр

Открывает диалоговое окно Добавление параметра. Оно позволяет добавлять параметры и задавать их свойства. Дополнительные сведения см. в разделе Диалоговые окна «Добавление параметра» и «Изменение параметра».

Добавить запись параметра

Открывает диалоговое окно Добавление записи параметра. Это окно позволяет настраивать тип, область и сопоставленное значение для параметра. Дополнительные сведения см. в разделе Диалоговое окно «Добавление записи параметра». Эта кнопка доступна только при условии, что выбран параметр или запись параметра.

Изменить

Если выбран параметр, то эта кнопка откроет диалговое окно Изменение параметра. Оно позволяет изменять свойства существующих параметров. Дополнительные сведения см. в разделе Диалоговые окна «Добавление параметра» и «Изменение параметра».

Если выбрана запись параметра, то эта кнопка откроет диалговое окно Изменение записи параметра. Дополнительные сведения см. в разделе Диалоговое окно «Изменение записи параметра».

Удалить

Удаляет выбранный параметр.

Вверх

Перемещает выбранный параметр на одну позицию вверх в списке параметров. Параметры обрабатываются в порядке следования в списке.

Вниз

Перемещает выбранный параметр на одну позицию вниз в списке параметров. Параметры обрабатываются в порядке следования в списке.

См. также

Понятия

Страницы мастера "Экспорт пакета приложения" и "Экспорт пакета сервера"


Диалоговые окна «Добавление параметра» и «Изменение параметра»
См. также

Диалоговое окно Добавление параметра или Изменение параметра используется для добавления нового параметра в пакет приложения или для изменения существующего параметра.

Элементы пользовательского интерфейса

Имя элемента Описание

Имя

Введите имя параметра. Например, Строка подключения.

Значение по умолчанию

Введите значение по умолчанию для параметра. В дальнейшем, при развертывании пакета, параметр получит это значение, если пользователем не будет присвоено иное. Например, если в качестве имени параметра введено значение Строка подключения, для значения по умолчанию можно использовать строку Data Source=.\SQLExpress;Database=Test;Integrated Security. Эта запись не обязательна.

Важно
Если необходимо потребовать от пользователя предоставление значения для параметра, не указывайте значение по умолчанию.

Теги

Укажите пользовательские атрибуты, разделяя их запятыми. Теги — это необязательные атрибуты параметра, на которые позднее можно создавать ссылки. Например, параметр может быть помечен как пароль, чтобы пользовательский интерфейс не отображал его значение. Эта запись не обязательна. При использовании примера, приведенного в описании элемента Значение по умолчанию, можно использовать теги SQL, SQLConnectionString для параметра строки подключения.

Описание

Введите описание параметра. Например: «Это строка подключения к базе данных, используемой приложением. Если в вашей среде используется другой сервер SQL Server или база данных, измените строку соответственно». Описание помещается в файл Parameters.xml, находящийся в пакете, и может быть отображено по команде msdeploy -verb:getParameters -source:package=<имя_файла_пакета>, введенной в командной строке.

Тип

Выберите тип проверки параметра (необязательное действие). Допустимые значения: «Нет», «Регулярное выражение», «Перечисление» или «Логическое» Значение по умолчанию: «Нет». Если выбран другой тип проверки параметра (не «Нет»), то значение, указанное пользователем для параметра, будет проверяться на соответствие указанным условиям. Если указаны значения «Регулярное выражение» или «Перечисление», то необходимо указать строку проверки (в поле Строка проверки).

Строка проверки

Введите регулярное выражение или список значений перечисления (разделитель - запятая). Дополнительные сведения о регулярных выражениях см. в статье Регулярные выражения (содержимое страницы может отображаться на английском языке).

См. также

Понятия

Страница «Выбор параметров»
Страницы мастера "Экспорт пакета приложения" и "Экспорт пакета сервера"


Диалоговое окно «Добавление записи параметра»
См. также

Диалоговое окно Добавление записи параметра используется для указания типа, области и значения сопоставления для параметра.

Элементы пользовательского интерфейса

Имя элемента | Описание
Тип | Используйте раскрывающийся список для выбора типа параметра, который необходимо использовать для параметризируемого атрибута. Возможные типы параметра: Файл XML, Текстовый файл, Позиция в текстовом файле, Путь поставщика, Атрибут развертывания, Привязка назначения и Целевой виртуальный каталог. Например, если создан параметр строки подключения, в списке можно выбрать тип Файл XML, поскольку строка подключения располагается внутри файла Web.config, который имеет формат XML.
Область | Укажите область для параметризируемого атрибута. Значение является обязательным регулярным выражением. Например, если тип параметра — Xml File, то для области можно использовать регулярное выражение \\web.config$. Первая обратная косая черта экранирует вторую, а символ доллара ($) завершает строку сопоставления в конце строки. Так, в результате получаем область, имеющую вид «\web.config». Дополнительные сведения о регулярных выражениях см. в статье Регулярные выражения (статья может быть на английском языке).
Сопоставление | Введите выражение, определяющее параметризируемый атрибут. Это значение зависит от типа. В некоторых случаях это может быть регулярное выражение или выражение XPath. Тип Xml File требует, чтобы значением сопоставления было выражение XPath. В приведенном выше примере можно использовать выражение XPath //строки_подключения/add/@строка_подключения для сопоставления со строкой подключения внутри файла Web.config.

См. также

Понятия

Страница «Выбор параметров»
Страницы мастера "Экспорт пакета приложения" и "Экспорт пакета сервера"


Диалоговое окно «Изменение записи параметра»
См. также

Диалоговое окно Изменение записи параметра используется для изменения типа, области и сопоставленного значения для параметра. Если параметр еще не создан, см. раздел Диалоговые окна «Добавление параметра» и «Изменение параметра».

Элементы пользовательского интерфейса

Имя элемента | Описание
Тип | Для изменения типа параметра используйте раскрывающийся список. Возможные типы параметра: Файл XML, Текстовый файл, Позиция текстового файла, Путь поставщика, Атрибут развертывания, Привязка назначения и Целевой виртуальный каталог. Например, если создан параметр строки подключения, в списке можно выбрать тип Файл XML, поскольку строка подключения располагается внутри файла Web.config, который имеет формат XML.
Область | Измените область для параметризируемого атрибута. Значение является обязательным регулярным выражением. Например, если тип параметра — Xml File, то для области можно использовать регулярное выражение \\web.config$. Первая обратная косая черта экранирует вторую, а символ доллара ($) завершает строку сопоставления в конце строки. Так, в результате получаем область, имеющую вид «\web.config». Дополнительные сведения о регулярных выражениях см. в статье Регулярные выражения (статья может быть на английском языке).
Сопоставление | Измените выражение, определяющее параметризируемый атрибут. Это значение зависит от типа. В некоторых случаях это может быть регулярное выражение или выражение XPath. Тип Xml File требует, чтобы значением сопоставления было выражение XPath. В приведенном выше примере можно использовать выражение XPath //строки_подключения/add/@строка_подключения для сопоставления со строкой подключения внутри файла Web.config.

См. также

Понятия

Страница «Выбор параметров»
Страницы мастера "Экспорт пакета приложения" и "Экспорт пакета сервера"


Страница «Сохранение пакета»
См. также

Страница Сохранение пакета мастера экспорта пакета приложения используется для указания имени файла и расположения для сохранения пакета.

Элементы пользовательского интерфейса

Имя элемента | Описание
Путь к пакету | Задайте имя файла для пакета. Имя файла должно иметь расширение «.zip».
Обзор... | Для выбора расположения, в которое нужно сохранить пакет, нажмите кнопку обзора.

См. также

Понятия

Страницы мастера "Экспорт пакета приложения" и "Экспорт пакета сервера"


Диалоговое окно "Пароль шифрования"
См. также

Диалоговое окно Пароль шифрования мастера экспорта пакета приложения используется для предоставления пароля для содержимого, имеющего параметры, помеченные как защищенные.

Элементы пользовательского интерфейса

Имя элемента | Описание
Пароль | Введите пароль, который будет требоваться позднее при импорте. Если для параметров, помеченных как защищенные, пароль не предоставлен, экспортировать пакет не удастся.
Подтверждение пароля | Введите пароль повторно для подтверждения.

См. также

Понятия

Страницы мастера "Экспорт пакета приложения" и "Экспорт пакета сервера"


Страница хода экспорта и сводки
См. также

Для отслеживания состояния процесса экспорта (и просмотра сводки по данной операции или подробной информации о ней, после завершения работы мастера) используется страница Ход экспорта и сводка мастера экспорта приложения.

Элементы пользовательского интерфейса

Имя элемента Описание

Состояние

В области Состояние отображается выполняемая в данный момент операция (например, выполнение копирования файла или сценария базы данных). Если приложение содержит такие элементы, как пароли или сертификаты, требующие шифрования, в ходе экспорта могут появляться запросы о вводе пароля. Необходимо помнить, что операция экспорта может занять много времени, если объем данных велик или если данные экспортируются на удаленный сервер.

Сводка

Предоставляет обзор выполненных действий, включая ошибки, возникшие в процессе создания приложения.

Важно
Вкладка Сводка не содержит полный список выполненных действий или обнаруженных ошибок. Более подробные сведения можно найти на вкладке Подробные сведения.

Подробные сведения

Предоставляет подробный список выполненных действий. В случае возникновения ошибок список будет содержать подробные сведения о них, которые могут использоваться для устранения неполадок.

См. также

Понятия

Страницы мастера "Экспорт пакета приложения" и "Экспорт пакета сервера"


Страницы мастера "Импорт пакета приложения" и "Импорт пакета сайта или сервера"

Страница "Выбор пакета"

Диалоговое окно "Пароль расшифровки"

Страница «Выбор содержимого пакета»

Диалоговое окно «Дополнительные параметры» (импорт)

Страница «Выбор базы данных»

Страница «Ввод данных о пакете приложения»

Страница «Перезапись существующих файлов»

Страница хода установки и сводки


Страница "Выбор пакета"
См. также

Страница Выбор пакета используется для выбора существующего пакета, который нужно установить на сайт или сервер.

Элементы пользовательского интерфейса

Имя элемента | Описание
Путь к пакету | Указывает расположение пакета, который необходимо установить на сайте или сервере.
Examinar… | Для выбора расположения пакета, который необходимо импортировать, нажмите кнопку обзора.

См. также

Понятия

Страницы мастера "Импорт пакета приложения" и "Импорт пакета сайта или сервера"


Диалоговое окно "Пароль расшифровки"
См. также

Диалоговое окно Пароль расшифровки мастера импорта пакета приложения используется для предоставления пароля для содержимого, имеющего параметры, помеченные как защищенные.

Элементы пользовательского интерфейса

Имя элемента | Описание
Пароль | Введите пароль, требуемый для расшифровки содержимого пакета. Пароль требуется, поскольку некоторые параметры при создании пакета были помечены как защищенные. Если пароль, использованный при создании пакета, не предоставить, импортировать пакет не удастся.

См. также

Понятия

Страницы мастера "Импорт пакета приложения" и "Импорт пакета сайта или сервера"


Страница «Выбор содержимого пакета»
См. также

Страница Выбор содержимого пакета мастера импорта пакета приложения используется для просмотра компонентов, включенных в пакет, выбранный на странице Выбор пакета.

Пакеты могут содержать такие компоненты, как параметры реестра, COM, сборки глобального кэша или сертификаты. Для установки этих компонентов на сервере необходимо быть членом группы администраторов или иметь необходимые для этого права. Для установки только содержимого права администратора не требуются.

Элементы пользовательского интерфейса

Имя элемента Описание

Содержимое пакета

Список компонентов, включаемых в пакет. Здесь можно указать, какие компоненты пакета необходимо развертывать, установив рядом с соответствующими компонентами флажки. Например, можно включить или исключить базу данных SQL или сборку глобального кэша сборок, установив или сняв соответствующие флажки.

Внимание
Некоторые компоненты могут быть обязательными для приложений. В случае исключения таких компонентов из установки приложение после установки может работать неправильно.

См. также

Понятия

Страницы мастера "Импорт пакета приложения" и "Импорт пакета сайта или сервера"


Диалоговое окно «Дополнительные параметры» (импорт)
См. также

Диалоговое окно Дополнительные параметры мастера импорта пакета приложения используется для настройки параметров пакета.

Элементы пользовательского интерфейса

Дополнительные параметры

Имя элемента Описание

Пароль расшифровки

Открывает диалоговое окно Пароль расшифровки, используемое для ввода пароля, требуемого для расшифровки содержимого пакета.

В процессе импорта Web Deploy автоматически определяет, присутствует ли зашифрованный объект, такой как пул приложений со специальным удостоверением, в файлах конфигурации пакета на уровне сервера (например, ApplicationHost.config или Machine.config). Если зашифрованный объект присутствует, необходимо предоставить пароль для этого объекта. Если предоставленный пароль неверен, импорт выполнен не будет.

Включить ACL

Выберите значение True, если списки управления доступом указанного пути будут скопированы из исходного в конечное расположение; в противном случае выберите значение False. Этот параметр касается файловой системы, реестра и метабазы и только следующих поставщиков: appHostConfig, contentPath, iisApp, metaKey, webServer и webServer60. Значение по умолчанию: False.

Расширение ссылки

Щелкните поле, расположенное справа, а затем щелкните стрелку, чтобы отобразить раскрывающийся список расширений ссылок. Выберите в списке расширения, которые следует применить к операции (или отключить). Расширения ссылок включают конкретные виды данных в операцию или исключают их. Доступные расширения Web Deploy: AppPoolExtension, CertificateExtension, ContentExtension, FrameworkConfigExtension и HttpCertConfigExtension. Эти расширения выбраны по умолчанию. Дополнительные сведения о расширениях ссылок см. в статье Расширения ссылок Web Deploy (возможно, на английском языке).

Повторные попытки

Укажите число попыток, предпринимаемых поставщиком в случае сбоя. Число попыток по умолчанию: 5. Интервал между попытками по умолчанию равен одной секунде. Параметр количества попыток может использоваться только с поставщиком contentPath.

Интервал между попытками

Укажите значение в миллисекундах. Введенное значение определяет интервал времени между попытками поставщика. Значение по умолчанию: 1000 (одна секунда). Этот параметр может использоваться только с поставщиком contentPath.

Уровень трассировки

Выберите в раскрывающемся списке значение, указывающее уровень детализации журнала сообщений об ошибках. Возможные значения: «Отключено», «Ошибка», «Предупреждение», «Сведения» и «Подробные сведения». Значение по умолчанию: «Сведения». Значение «Отключено» означает, что сообщения об ошибках в журнал не заносятся. Значение «Подробные сведения» означает, что в журнал вносятся все сообщения.

Параметры синхронизации

Имя элемента Описание

Правила

Открывает диалоговое окно Включение или отключение правил, в котором можно указать правила для операции. Дополнительные сведения см. в разделе Диалоговое окно "Включение или отключение правил".

WhatIf

Щелкните раскрывающийся список, чтобы выбрать True или False. True указывает, что операция будет запущена без фактического выполнения изменений. Этот параметр можно использовать для просмотра результатов операции, если все ее части выполнены успешно. Значением по умолчанию является False.

Примечание
Команда, кажущаяся выполненной успешно с параметром WhatIf, может дать сбой при выполнении без параметра WhatIf. Это может произойти в случае возникновения непредвиденных ошибок в работе. Например, из-за того, что в процессе выполнения операции с параметром WhatIf запись данных не выполняется, ошибка разрешения записи выявлена не будет. Параметр WhatIf показывает только то, что произойдет в случае успешного выполнения всех операций команды.

См. также

Понятия

Страница «Выбор содержимого пакета»
Страницы мастера "Импорт пакета приложения" и "Импорт пакета сайта или сервера"


Страница «Выбор базы данных»
См. также

Страница Выбор базы данных используется для выбора базы данных, которую будет использовать устанавливаемый пакет. Данная страница отображается только если в пакете доступно несколько типов баз данных.

Примечание
Если в пакете доступно несколько типов баз данных, но на странице Выбор содержимого пакета установлен флажок только для одного типа баз данных (и сняты флажки для всех остальных типов), данная страница отображаться не будет.

Элементы пользовательского интерфейса

Имя элемента | Описание
Выберите базу данных, которая будет использоваться | Выберите тип базы данных, который будет использоваться данной установкой. Допустимые значения: SQL, MySQL, VistaDB, SQLite, «Неструктурированный файл» или «Без базы данных». Доступность той или иной базы данных зависит от содержимого устанавливаемого пакета. Сопоставление с поставщиками имеется только у SQL и MySQL. Дополнительные сведения см. в статьях Поставщик dbFullSql Web Deploy (возможно, на английском языке) и Поставщик MySQL Web Deploy (возможно, на английском языке).
Создать новую или использовать существующую базу данных | Щелкните Создать новую базу данных или Использовать существующую базу данных, чтобы создать базу данных или использовать существующую соответственно. Данный элемент доступен только для баз данных типа SQL или MySQL.

См. также

Понятия

Страницы мастера "Импорт пакета приложения" и "Импорт пакета сайта или сервера"
Страница «Ввод данных о пакете приложения»


Страница «Ввод данных о пакете приложения»
См. также

Страница Ввод данных о пакете приложения мастера импорта пакета приложения используется для указания значений параметров, объявленных в пакете. Для каждого параметра на странице предусмотрено поле. Набор полей, отображенных на странице, зависит от набора объявленных в пакете параметров.

Элементы пользовательского интерфейса

Имя элемента | Описание
<Имя параметра> | Укажите значение для параметра, необходимого для установки пакета. Сведения могут включать полный путь к сайту, куда необходимо установить приложение, учетные данные пользователя или имя базы данных для приложения. Можно изменить значение пути приложения, указав, куда это приложение следует устанавливать, например Default Web Site/NewApp.

См. также

Понятия

Диалоговое окно «Изменение строки подключения»


Диалоговое окно «Изменение строки подключения»
См. также

Диалоговое окно Изменение строки подключения используется для указания строки подключения и учетных данных для нее.

Элементы пользовательского интерфейса

Имя элемента | Описание
SQL Server | Выберите этот параметр для использования указанного сервера SQL Server.
Сервер | Укажите путь или строку подключения к серверу, которые необходимо использовать (например, .\SQLExpress).
База данных | Укажите имя базы данных, которую необходимо использовать (например, Test).
Использовать встроенную систему безопасности Windows | Выберите этот параметр для использования встроенной системы безопасности Windows. Встроенная система безопасности Windows передает учетные данные ASP.NET, не требуя повторной проверки подлинности, если пользователь уже выполнил вход в Windows. Такой метод проверки подлинности работает лучше всего, если и клиент, и сервер располагаются в одном и том же домене.
Указать учетные данные | Выберите этот параметр для использования указанных пользователем учетных данных. Нажмите кнопку Установить, чтобы открыть диалоговое окно Задание учетных данных и укажите имя пользователя и пароль.
Настроить | Выберите этот параметр для указания настраиваемого пути или строки подключения к используемому серверу (например, Server=.\SQLExpress;Database=Test;Integrated Security=true).

См. также

Понятия

Страницы мастера "Импорт пакета приложения" и "Импорт пакета сайта или сервера"
Страница «Ввод данных о пакете приложения»


Страница «Перезапись существующих файлов»
См. также

Страница Перезапись существующих файлов используется, чтобы принять решение, нужно ли добавлять новые файлы в назначение или перезаписывать существующие и удалять те, для которых нет пар в пакете приложения.

Элементы пользовательского интерфейса

Имя элемента | Описание
Нет, просто добавить файлы пакета приложения в назначение. | Выберите этот вариант для сохранения существующих файлов в назначении и добавления новых файлов из пакета приложения.
Да, удалить в назначении все дополнительные файлы и папки, отсутствующие в пакете приложения. | Выберите этот вариант для удаления из назначения всех файлов, которые не включены в пакет приложения.

См. также

Понятия

Страницы мастера "Импорт пакета приложения" и "Импорт пакета сайта или сервера"


Страница хода установки и сводки
См. также

Для отслеживания состояния процесса импорта (и просмотра сводки по данной операции или подробной информации о ней, после завершения работы мастера) используется страница Ход установки и сводка.

Элементы пользовательского интерфейса

Имя элемента Описание

Состояние

В области Состояние отображается выполняемая в данный момент операция (например, выполнение копирования файла или сценария базы данных). Если приложение содержит такие элементы, как пароли или сертификаты, требующие расшифровки, в ходе импорта могут появляться запросы о вводе пароля. Необходимо помнить, что операция импорта может занять много времени, если объем данных велик или если данные импортируются с удаленного сервера.

Сводка

Предоставляет обзор выполненных действий, включая ошибки, возникшие в процессе установки приложения.

Важно
Вкладка Сводка не содержит полный список выполненных действий или обнаруженных ошибок. Более подробные сведения можно найти на вкладке Подробные сведения.

Подробные сведения

Предоставляет подробный список выполненных действий. В случае возникновения ошибок список будет содержать подробные сведения о них, которые могут использоваться для устранения неполадок.

См. также

Понятия

Страницы мастера "Импорт пакета приложения" и "Импорт пакета сайта или сервера"