IIS Yöneticisi İçin Web Dağıtımı Aracı'na Genel Bakış

Web Dağıtım Aracı (Web Dağıtımı), kullanıcı tarafından belirtilen bir site veya sunucudan kullanıcı tarafından belirtilen bir hedef IIS yapılandırmasını, içeriği, SSL sertifikalarını ve diğer veri türlerini eşitler. Varsayılan olarak dahil edilmeyen kayıt defteri anahtarları gibi nesneleri de dağıtabilirsiniz.

Yönetim Hizmeti Temsilcisi Atama

IIS Manager uygulamasında, Web Dağıtımı sunucu düzeyinde Yönetim Hizmeti Temsilcisi Atama adı verilen ve yüksek bir hassaslık derecesiyle uzak kullanıcıların gerçekleştirebileceği dağıtım eylemlerini denetlemenizi sağlayan yöneticilere özel bir özellik ekler. Daha fazla bilgi için bkz. Yönetim Hizmeti Temsilcisi Atama Sayfası.

Uygulamaları Verme ve Alma

IIS Manager Eylemler bölmesinden, sitelerinizi, uygulamalarınızı ve içeriğinizi kapsayan sıkıştırılmış dosyalar (paketler) oluşturmak için aracın Uygulama Paketi Verme Sihirbazı'nı kullanabilirsiniz. Daha fazla bilgi için bkz. Uygulama Paketi Verme ve Sunucu Paketi Verme Sihirbazı Sayfaları.

Bir paketi verdikten sonra, Uygulama Paketi Alma Sihirbazı'nı kullanarak paket içeriğini farklı bir konuma yükleyebilirsiniz. Daha fazla bilgi için bkz. Uygulama Paketi Alma ve Sunucu ve Site Paketi Alma Sihirbazı Sayfaları.

Komut satırı özellikleri

Web Dağıtımı Aracı'nın Msdeploy.exe yürütülebilir programı birçok güçlü komut satırı özelliği sunar. Msdeploy.exe özelliklerinin özet bir yardımı için, Komut İstemi penceresinde msdeploy -help yazın. Ayrıntılı çevrimiçi yardım için, bkz. Web Dağıtımı Aracı (sayfa İngilizce olabilir).

Ek Çevrimiçi Kaynaklar

IIS.NET: Web Dağıtımı Aracı (sayfa İngilizce olabilir)

IIS.NET: Web Dağıtımı Aracı Forumu (sayfa İngilizce olabilir)

IIS.NET: Microsoft Web Dağıtımı Ekip Blogu Postaları (sayfa İngilizce olabilir)


Web Dağıtımı Aracı Kullanıcı Arabirimi (UI) Yardımı

IIS Manager, tüm özellik sayfaları, iletişim kutuları ve IIS Manager içindeki sihirbaz sayfalarında yer alan kullanıcı arabirimi (UI) öğelerinin tümü için açıklamalar sağlar. Bu yardımı görüntülemek için etkin özellik sayfasında, iletişim kutusunda veya sihirbaz sayfasında F1 tuşuna basın.

Bu Bölümde

Yönetim Hizmeti Temsilcisi Atama Sayfası

Uygulama Paketi Verme ve Sunucu Paketi Verme Sihirbazı Sayfaları

Uygulama Paketi Alma ve Sunucu ve Site Paketi Alma Sihirbazı Sayfaları


Yönetim Hizmeti Temsilcisi Atama Sayfası

Yönetim Hizmeti Temsilcisi Atama sayfasını uzak kullanıcı dağıtım haklarını denetleyen kuralları belirtmek için kullanın. Yönetim Hizmeti Temsilcisi Atama sayfası yalnızca yöneticiler tarafından kullanılabilir ev yalnızca sunucu düzeyinde görünür.

Kullanıcı Arabirimi Öğeleri

Öğe Adı | Açıklama
Sağlayıcı | Kuralın uygulandığı sağlayıcıyı veya sağlayıcıları görüntüler.
Yol | Kuralın uygulandığı yolu görüntüler.
Yol Türü | Yolun türünü görüntüler. Olası değerler PathPrefix, StringPrefix, StringSuffix, ConnectionString ve RegularExpression'dır.
Eylemler | Kuralın gerçekleştireceği eylemleri görüntüler. Web Dağıtımı sağlayıcıları için olağan değerler Read, Write ve * değerleridir.
Kimlik Türü | Kuralın altında çalışacağı kimlik türünü görüntüler. Olası değerler CurrentUser, ProcessIdentity ve SpecificUser'dır.
Kullanıcı Adı | Kimlik türü olarak SpecificUser seçildiğinde kullanıcı adını görüntüler. Kimlik türü CurrentUser veya ProcessIdentity olduğunda, hiçbir kullanıcı adı görüntülenmez.
Durum | Kuralın etkin mi yoksa devre dışı mı olduğunu görüntüler. Eylemler bölmesinde Kuralı Etkinleştir'i veya Kuralı Devre Dışı Bırak'ı tıklatarak kuralı etkinleştirebilir veya devre dışı bırakabilirsiniz.

Eylemler Bölmesi Öğeleri

Öğe Adı | Açıklama
Kural Ekle… | Kural Ekle iletişim kutusunu açar. Kural eklemek için bu seçeneği belirleyin. Daha fazla bilgi için bkz. Kural Ekle İletişim Kutusu (Yönetim Hizmeti Temsilcisi Atama).
Kurala Kullanıcı ekle… | Kurala Kullanıcı Ekle iletişim kutusunu açar. Daha fazla bilgi için bkz. Kurala Kullanıcı Ekle İletişim Kutusu.
Düzenle… | Kuralı Düzenle iletişim kutusunu açar. Daha fazla bilgi için bkz. Kural Ekle veya Düzenle İletişim Kutuları.
Kaldır | Seçili temsil kuralını veya temsil kuralı kullanıcısını kaldırır.
Kuralı Devre Dışı Bırak | Seçili temsil kuralını devre dışı bırakır.
Kuralı Etkinleştir | Seçili temsil kuralını etkinleştirir.
Özellik Ayarlarını Düzenle… | Özellik Ayarlarını Düzenle iletişim kutusunu açar. Daha fazla bilgi için bkz. Özellik Ayarlarını Düzenle İletişim Kutusu (Yönetim Hizmeti Temsilcisi Atama).


Kural Ekle İletişim Kutusu (Yönetim Hizmeti Temsilcisi Atama)

Kural Şablonu Seç iletişim kutusunu özel bir temsil kuralı oluşturmak amacıyla kullanabileceğiniz bir şablon seçmek için kullanın. Boş bir şablon veya belirli senaryolar için tasarlanmış yüklü bir şablonu seçebilirsiniz.

Kullanıcı Arabirimi Öğeleri

Yüklü Şablonlar

Öğe Adı Açıklama

Boş Kural

Özelleştirebileceğiniz boş bir şablon oluşturur.

Yalnızca İçeriği Dağıt

İçerik dağıtımına olanak veren bir kural oluşturur. Kural, Web Yönetimi Hizmeti (WMSvc) tarafından yetkilendirilmiş herhangi bir kullanıcının önceden WMSvc yetkisine sahip olduğu bir yolda içerik yayımlamasını sağlar. Kural, erişimi belirli bir yol veya kullanıcı ile sınırlayacak şekilde düzenlenebilir. Bu kural Web sitesi içeriğiyle eşitlenen contentPath sağlayıcısını kullanır. Daha fazla bilgi için, bkz. Web Dağıtımı contentPath Sağlayıcısı (sayfa İngilizce olabilir).

İçeriğe Sahip Uygulamalar Dağıtma

Uygulama dağıtımlarına olanak veren bir kural oluşturur. Bu şablon bir klasörü uygulama olarak işaretleyen bir kural içermez, ancak genellikle bu tür bir kurallar birlikte kullanılır. Kural, WMSvc tarafından yetkilendirilmiş herhangi bir kullanıcının önceden WMSvc yetkisine sahip olduğu bir yolda uygulama yayımlamasını sağlar. Kural, erişimi belirli bir yol veya kullanıcı ile sınırlayacak şekilde düzenlenebilir. Bu kural contentPath ve iisApp sağlayıcılarını kullanır. Daha fazla bilgi için, bkz. Web Dağıtımı contentPath Sağlayıcısı (sayfa İngilizce olabilir). ve Web Dağıtımı iisApp Sağlayıcısı (sayfa İngilizce olabilir).

Veritabanı Dağıtma

Veritabanı dağıtımına olanak veren bir kural oluşturur. Kural, WMSvc tarafından yetkilendirilmiş herhangi bir kullanıcının erişimi olan herhangi bir veritabanında yayımlamasını sağlar. Şablon kullanılmakta olan hesabın CurrentUser olduğunu belirtir, bu da veritabanı sunucusunda kullanıcının kimliğini doğrulamak için bağlantı dizesinin kullanılacağını belirtir. Kural, erişimi belirli bir veritabanı sunucusu veya ad ile sınırlayacak şekilde düzenlenebilir. Bu kural, veritabanlarının yerel bir SQL Server geliştirme veritabanından uzakta barındırılan bir SQL Server veritabanına ilk defa yayımlanmasına olanak tanıyan dbFullSql sağlayıcısını kullanır. Daha fazla bilgi için, bkz. Web Dağıtımı dbFullSql Sağlayıcısı (sayfa İngilizce olabilir).

Klasörleri Uygulama Olarak İşaretleme

Bir klasörü uygulama olarak işaretleyen bir kural oluşturur. Kural, WMSvc tarafından yetkilendirilmiş herhangi bir kullanıcının bir klasörü uygulama olarak işaretlemesini sağlar. Kullanıcı bir yönetici değilse, kimlik türünü ApplicationHost.config dosyasına yazma erişimi olan bir kimlik türüne değiştirmeniz gerekir. Bu kural için varsayılan kimlik türü SpecificUser'dır. Bu kural, klasörleri uygulama olarak işaretlemek için gereken ve işlevleri iisApp sağlayıcısında bulunan createApp sağlayıcısını kullanır. Daha fazla bilgi için, bkz. Web Dağıtımı Sağlayıcıları (sayfa İngilizce olabilir).

Uygulamaların İzinlerini Ayarlama

Bir uygulama yolu için ACL'leri ayarlayan bir kural oluşturur. Kural, WMSvc tarafından yetkilendirilmiş herhangi bir kullanıcının önceden WMSvc yetkisine sahip olduğu bir uygulama yolunda dosya sistemi ACL'lerini ayarlamasını sağlar. Şablon, kullanılmakta olan hesabın kullanıcının ACL'leri değiştirebilmesi için gerekli izinlere sahip olması gerektiği anlamına gelen CurrentUser olduğunu belirtir. Kural, erişimi belirli bir yol veya kullanıcı ile sınırlayacak şekilde düzenlenebilir. Bu kural hedef klasörde izinleri ayarlayan setAcl sağlayıcısını kullanır. Daha fazla bilgi için, bkz. Web Dağıtımı setAcl Sağlayıcısı (sayfa İngilizce olabilir). .

Veritabanlarını Yedekleme ve Geri Yükleme (SQL Kimlik Doğrulaması Kullanarak)

SQL kimlik doğrulaması kullanarak veritabanlarını yedekleyen ve geri yükleyen bir kural oluşturur. Kural, WMSvc tarafından yetkilendirilmiş herhangi bir kullanıcının önceden erişime sahip olduğu bir veritabanının yedeğini oluşturmasını ve geri yüklemesini sağlar. Yedekleme ve geri yükleme işlemleri SQL kimlik doğrulaması kullanan belirli bir kullanıcı kimliği olarak gerçekleştirilir. Kural, erişimi belirli bir veritabanı ve belirli bir kullanıcı kümesi ile sınırlayacak şekilde düzenlenebilir.

Not

Bu şablonu IIS Veritabanı Yöneticisi uzantısıyla kullanın. IIS Veritabanı Yönetici hakkında daha fazla bilgi için bkz: Veritabanı Yöneticisi (sayfa İngilizce olabilir).

Veritabanlarını Yedekleme ve Geri Yükleme (Windows Tümleşik Güvenliği Kullanarak)

Windows kimlik doğrulaması kullanarak veritabanlarını yedekleyen ve geri yükleyen bir kural oluşturur. Kural, WMSvc tarafından yetkilendirilmiş herhangi bir kullanıcının önceden erişime sahip olduğu bir veritabanının yedeğini oluşturmasını ve geri yüklemesini sağlar. Kural, erişimi belirli bir veritabanı ve belirli bir kullanıcı kümesi ile sınırlayacak şekilde düzenlenebilir.

Not

Bu şablonu IIS Veritabanı Yöneticisi uzantısıyla kullanın. IIS Veritabanı Yönetici hakkında daha fazla bilgi için bkz: Veritabanı Yöneticisi (sayfa İngilizce olabilir).

Ayrıca Bkz.

  • Uygulama Paketi Alma ve Sunucu ve Site Paketi Alma Sihirbazı Sayfaları
  • Web Dağıtımı Sağlayıcıları (sayfa İngilizce olabilir)


Kural Ekle veya Düzenle İletişim Kutuları

Kural Ekle ve Kuralı Düzenle iletişim kutularını temsil kuralları eklemek ve düzenlemek için kullanın.

Kullanıcı Arabirimi Öğeleri

Öğe Adı | Açıklama
Sağlayıcılar | Kurala eklemek veya kuraldan kaldırmak istediğiniz sağlayıcıları seçmek veya temizlemek için açılan listeyi tıklatın, sonra değişiklikleri kabul etmek için aşağı açılan oku tıklatın. Sağlayıcılar virgülle ayrılmış bir liste olarak görüntülenir. Web Dağıtımı sağlayıcıları hakkında daha fazla bilgi için, bkz. Web Dağıtımı Sağlayıcıları (sayfa İngilizce olabilir).
Eylemler | Kurala eklemek veya kuraldan kaldırmak istediğiniz eylemleri seçmek veya temizlemek için açılan listeyi tıklatın, sonra değişiklikleri kabul etmek için aşağı açılan oku tıklatın. Eylemler virgülle ayrılmış bir liste olarak görüntülenir. Web Dağıtımı için olağan değerler Read, Write ve * değerleridir.
Yol Türü | Açılan listeden bir yol türü seçin. Olası değerler PathPrefix, StringPrefix, StringSuffix, ConnectionString ve RegularExpression'dır. Normal ifadeler hakkında daha fazla bilgi için, bkz. Normal İfadeler (sayfa İngilizce olabilir).
Yol | Kuralın uygulanacağı yolu yazın.
Kimlik Türü | Açılan listeden kuralın kimlik türünü seçin. Seçilen kimlik kuralı yürütür. Olası değerler CurrentUser, ProcessIdentity ve SpecificUser'dır. CurrentUser geçerli kullanıcının kimliğini belirtir. ProcessIdentity, WMSvc yerel hizmet kimliğinin kullanılacağını belirtir. SpecificUser, belirteceğiniz özel kimliğin kullanılacağını belirtir. SpecificUser'ı seçerseniz, Kimlik Bilgileri Belirt Ayarla düğmesini kullanarak kimlik bilgilerini sağlamanız gerekir.
Kimlik Bilgilerini Belirt | Kimlik türü olarak SpecificUser'ı seçtiğinizde Ayarla düğmesini etkinleştirir.
Ayarla | SpecificUser kimliği için kullanıcı adı ve parolayı belirtmenizi sağlayan Kimlik Bilgilerini Ayarla iletişim kutusunu açar. Daha fazla bilgi için bkz. Kimlik Bilgilerini Ayarla İletişim Kutusu.


Kimlik Bilgilerini Ayarla İletişim Kutusu

Kimlik Bilgilerini Ayarla iletişim kutusunu kuralı yürütecek bir Windows kullanıcısının kullanıcı adını ve parolasını belirtmek için kullanın.

Kullanıcı Arabirimi Öğeleri

Öğe Adı | Açıklama
Kullanıcı adı | Bir Windows kullanıcısının kullanıcı adını yazın.
Parola | Parolayı yazın.
Parolayı onayla | Parolayı onaylamak için yeniden yazın.

Ayrıca Bkz.

  • Kural Ekle veya Düzenle İletişim Kutuları


Kurala Kullanıcı Ekle İletişim Kutusu

Kullanıcı Kuralı Ekle iletişim kutusunu bir kullanıcının bir kurala erişimine izin vermek veya reddetmek için kullanın.

Kullanıcı Arabirimi Öğeleri

Öğe Adı | Açıklama
Ad | Kullanıcı adını yazın.
Erişim Türü | Belirtilen kullanıcıya verilecek erişim türünü yazın. Olası değerler İzin Ver ve Reddet'tir.
Rol mü? | Belirttiğiniz kullanıcı erişimine izin verilecek veya erişimi reddedilecek bir grup kullanıcının diğer adıysa bu onay kutusunu seçin.


Özellik Ayarlarını Düzenle İletişim Kutusu (Yönetim Hizmeti Temsilcisi Atama)

Özellik Ayarlarını Düzenle iletişim kutusunu yöneticilerin temsilci atama kurallarını atlamasına izin vermek ve başarısız isteklerin günlüğe yazılmasını etkinleştirmek için kullanın.

Kullanıcı Arabirimi Öğeleri

Öğe Adı Açıklama

Yöneticilerin kuralları atlamasına izin ver

Yöneticilerin belirtilen temsilci atama kurallarını atlamasına izin vermek için bu seçeneği seçin.

Temsilci hizmeti için başarısız istek izleme günlüklerini etkinleştir

Başarısız istek günlüğünü etkinleştirmek için bu seçeneği kullanın.

Uyarı

Bu özelliği kullanmak için, başarısız istek izleme modülü yüklenmiş olmalıdır.


Uygulama Paketi Verme ve Sunucu Paketi Verme Sihirbazı Sayfaları

Paket İçeriğini Seç Sayfası

Parametre Seç Sayfası

Paketi Kaydet Sayfası

Şifreleme Parolası İletişim Kutusu

Verme İlerleme Durumu ve Özeti Sayfası


Paket İçeriğini Seç Sayfası

Uygulama Paketi Verme Sihirbazı'nın Paket İçeriğini Seç sayfasını oluşturmak istediğiniz pakette bulunan bileşenleri görüntülemek için kullanın.

Paketler kayıt defteri ayarları, COM, GAC derlemeleri veya sertifikalar gibi bileşenler içerebilir. Bu bileşenleri sunucunuza yüklemek için, Administrators grubunun üyesi olmanız veya uygun yetkinin size atanmış olması gerekir. Yalnızca içerik yüklemek için yönetici kullanıcı haklarınız olması gerekmez.

Kullanıcı Arabirimi Öğeleri

Öğe Adı Açıklama

Paket içeriği

Paketinizde bulunan bileşenleri listeler. Paketinize nelerin ekleneceğini uygun bileşenlerin onay kutularını seçerek veya temizleyerek belirtebilirsiniz. Örneğin, karşılık gelen onay kutusunu seçerek veya temizleyerek bir SQL veritabanını veya GAC derlemesini dahil edebilir veya hariç tutabilirsiniz.

Dikkat

Bazı bileşenler uygulama için gerekli olabilir. Bu bileşenlerin onay kutularını temizlerseniz, uygulama yüklendikten sonra doğru çalışmayabilir.

Öznitelikler

Sağ bölmede seçili dosyanın, dizinin veya bileşenin özniteliklerini görüntüler. Bu değerler salt okunudur.

Bileşenleri Yönet…

Bileşenleri Yönet iletişim kutusunu açar. Bu, dahil etmek istediğiniz bileşenleri seçmenizi sağlar. Daha fazla bilgi için bkz. Bileşenleri Yönet İletişim Kutusu.

Gelişmiş Ayarlar…

Gelişmiş Ayarlar iletişim kutusunu açar. bu, işlem ayarlarını ve kurallarını belirtmenizi sağlar. Daha fazla bilgi için bkz. Gelişmiş Ayarlar İletişim Kutusu (Verme).

Ayrıca Bkz.

  • Uygulama Paketi Verme ve Sunucu Paketi Verme Sihirbazı Sayfaları
  • IIS Yöneticisi Aracılığıyla Bir Paketi Verme (çevrimiçi kaynak) (sayfa İngilizce olabilir)


Bileşenleri Yönet İletişim Kutusu

Uygulama Paketi Verme Sihirbazı'nın Bileşenleri Yönet iletişim kutusunu paketinize COM nesneleri veya GAC derlemeleri gibi bileşenler eklemek için kullanın.

Kullanıcı Arabirimi Öğeleri

Sütun Başlıkları

Öğe Adı Açıklama

Sağlayıcı Adı

Pakete eklemek istediğiniz bileşeni belirtir. Her bileşenin bir sağlayıcısı vardır. Bir sağlayıcı adı seçmek üzere açılan listeyi kullanmak için alanı tıklatın. Bir sağlayıcının açıklamasını görmek için imleci sağlayıcının üzerinde bekletin. Örneğin, dbFullSql öğesini seçerseniz, bir komut dosyasının veya bağlantı dizesinin yolunu paketlersiniz. Sağlayıcılar hakkında daha fazla bilgi için, bkz. Web Dağıtımı Sağlayıcıları (sayfa İngilizce olabilir).

Önemli

Bir Web sitesini paketliyorsanız, iisApp sağlayıcısı (varsayılan olarak seçilidir) Web sitesini hedefte bir uygulama olarak işaretler. Web sitesini ve ilişkili tüm içeriğini (uygulama havuzu adı, içerik dizinin konumu ve varsa sertifikalar gibi) paketlemek istiyorsanız, appHostConfig sağlayıcısını kullanın. iisApp sağlayıcısını kullanırsanız, Web sitesi hedefte, tüm ayarlarını (uygulama havuzu adı ve içerik dizini gibi) içine yüklendiği siteden devralan bir uygulama haline gelir.

Yol

Paket için veri sağlayacak bileşenin yolunu belirtir. Örneğin, dbFullSql öğesini seçerseniz, yol C:\SQLfiles\installSQL.sql gibi bir komut dosyası veya Data Source=.\sqlexpress;Integrated Security=SSPI;Initial Catalog=db1 gibi bir bağlantı dizesi belirtebilir.

Sağlayıcı Ayarları

Seçilen sağlayıcı için kullanmak istediğiniz sağlayıcı ayarlarını belirtir. Gözatma (…) düğmesini kullanarak Sağlayıcı Ayarları iletişim kutusunu açmak için alanı tıklatın. Daha fazla bilgi için bkz. Sağlayıcı Ayarları İletişim Kutusu.

Düğmeler

Öğe Adı | Açıklama
Kaldır | Seçili girişi siler.
Yukarı Taşı | Seçili satırı listede yukarıya taşır. Girişler listede bulundukları sıraya göre yüklenir. Bazı sağlayıcılar için girişlerin sırası önemlidir. Örneğin, bir tabloyu dolduran komut dosyasından önce tabloyu çalıştıran komut dosyası çalıştırılmalıdır.
Aşağı Taşı | Seçili satırı listede aşağıya taşır. Girişler listede bulundukları sıraya göre yüklenir.

Ayrıca Bkz.

  • Paket İçeriğini Seç Sayfası
  • Uygulama Paketi Verme ve Sunucu Paketi Verme Sihirbazı Sayfaları


Sağlayıcı Ayarları İletişim Kutusu

Sağlayıcı Ayarları iletişim kutusunu seçili sağlayıcıyla ilgili ayarları belirtmek için kullanın. Tüm sağlayıcıların ayarları yoktur.

Kullanıcı Arabirimi Öğeleri

Öğe Adı | Açıklama
Ayar adı | Seçili sağlayıcıya ait ayarın adını görüntüler. Yalnızca seçili sağlayıcı için uygun olan ayarlar listelenir.
Ayar değeri | Ayarın değerini yazın veya seçin. Bir açılan liste varsa, bu ayar için kullanılabilecek değerler listede bulunur. Yazmanız gereken değerler için, açıklama kutusu kabul edilebilir değerlerle ilgili bilgi sağlar.
Ayar açıklaması | Sağlayıcı için seçili ayarın açıklamasını görüntüler. Ayar için izin verilen değerlerle ilgili bilgi sağlar.

Ayrıca Bkz.

  • Bileşenleri Yönet İletişim Kutusu
  • Paket İçeriğini Seç Sayfası
  • Uygulama Paketi Verme ve Sunucu Paketi Verme Sihirbazı Sayfaları
  • Web Dağıtımı Sağlayıcı Ayarları (sayfa İngilizce olabilir)


Gelişmiş Ayarlar İletişim Kutusu (Verme)

Uygulama Paketi Verme Sihirbazı'nın Gelişmiş Ayarlar iletişim kutusunu paketinizin ayarlarını belirtmek için kullanın.

Kullanıcı Arabirimi Öğeleri

Gelişmiş Seçenekler

Öğe Adı Açıklama

Parolayı Şifrele

IIS yapılandırmasındaki güvenli özelliklere erişimi denetlemek amacıyla alfasayısal bir parola belirtmek üzere Parolayı Şifrele iletişim kutusunu açmak için … düğmesini tıklatın.

Web Dağıtımı, sunucu düzeyi yapılandırma dosyalarında (örneğin, ApplicationHost.config veya Machine.config) özel bir kimliği olan bir uygulama havuzu gibi şifrelenmiş bir nesnenin bulunup bulunmadığını otomatik olarak algılar. Şifrelenmiş nesne varsa, nesne için bir parola sağlamanız gerekir. Doğru parolayı belirtmezseniz verme işlemi başarısız olur.

Önemli

Web Dağıtımı Web.config dosyalarında şifrelenmiş nesne olup olmadığını denetlemez.

ACL'leri Ekle

Belirttiğiniz yolun ACL'leri kaynaktan hedefe kopyalanacaksa True'yu seçin, aksi halde False'u seçin. Bu ayar sistem dosyaları, kayıt defteri ve metatabanı ve yalnızca şu sağlayıcılar için geçerlidir: appHostConfig, contentPath, iisApp, metaKey, webServer ve webServer60. Varsayılan değer False'tur.

Bağlantı Uzantısı

Sağdaki alanı tıklatın ve sonra bağlantı uzantıları açılan listesini görüntülemek için oku tıklatın. İşleme uygulamak istediğiniz bağlantı uzantılarını etkinleştirmek veya devre dışı bırakmak için listedeki uzantıları seçin veya temizleyin. Bağlantı uzantıları bir işlemde özel veri türlerini dahil eder veya hariç tutar. Kullanılabilen Web Dağıtımı uzantıları: AppPoolExtension, CertificateExtension, ContentExtension, FrameworkConfigExtension ve HttpCertConfigExtension. Bu uzantılar varsayılan olarak seçilidir. Bağlantı uzantıları hakkında daha fazla bilgi için, bkz. Web Dağıtımı Bağlantı Uzantıları (sayfa İngilizce olabilir).

Yeniden Deneme Sayısı

Sağlayıcının bir hatadan sonra kaç kez yeniden deneyeceğini yazın. Varsayılan yeniden deneme sayısı 5'tir. Varsayılan olarak, yeniden denemeler arasında birer saniye vardır. Yeniden deneme sayısı ayarı yalnızca contentPath sağlayıcısıyla kullanılabilir.

Yeniden Deneme Aralığı

Milisaniye cinsinden bir değer yazın. Değer sağlayıcının yeniden denemeleri arasındaki süreyi belirler. Varsayılan: 1000 (bir saniye). Bu ayar yalnızca contentPath sağlayıcısıyla kullanılabilir.

İzleme Düzeyi

Açılan listeden hata iletisi günlüklerindeki ayrıntı düzeyini belirten bir değer seçin. Olası değerler Off, Error, Warning, Info ve Verbose'dur. Varsayılan: Info. Off, hiçbir hata iletisinin günlüğe yazılmayacağı anlamına gelir. Verbose, tüm iletilerin günlüğe yazılacağı anlamına gelir.

Eşitleme Seçenekleri

Öğe Adı Açıklama

Kurallar

İşlem için kullanılacak kuralları belirtmenizi sağlayan Kuralları Etkinleştir veya Devre Dışı Bırak iletişim kutusunu açar. Daha fazla bilgi için bkz. Kuralları Etkinleştir veya Devre Dışı Bırak İletişim Kutusu.

WhatIf

Açılan listeyi tıklatın ve True veya False öğesini seçin. True, işlemin gerçekte herhangi bir değişiklik yapılmadan çalışacağını belirtir. Bir işlemin tüm bölümleri başarılı olursa bu ayarı işlemin sonuçlarını görmek için kullanabilirsiniz. Varsayılan değer: False.

Not

WhatIf ayarıyla başarılı bir şekilde çalışıyor gibi görünen bir komut WhatIf ayarı kullanılmadan çalıştırıldığında başarısız olabilir. Bu, işlem sırasında beklenmeyen hatalar çıkarsa olabilir. Örneğin, WhatIf işlemi sırasında hiçbir veri yazılmadığından, yazma izni ile ilgili hatalar algılanamaz. WhatIf ayarı yalnızca komuttaki tüm işlemler başarılı olduğunda ne olacağını gösterir.

Ayrıca Bkz.

  • Paket İçeriğini Seç Sayfası
  • Uygulama Paketi Verme ve Sunucu Paketi Verme Sihirbazı Sayfaları


Kuralları Etkinleştir veya Devre Dışı Bırak İletişim Kutusu

Kuralları Etkinleştir veya Devre Dışı Bırak iletişim kutusunu bir eşitleme işleminin sonucunu etkileyen kuralları etkinleştirmek veya devre dışı bırakmak için kullanın. Kuralları devre dışı ve etkin kategorilerinde gruplandırmak için Gruplandırma Ölçütü açılan listesinden Durum'u seçin veya kuralları alfabetik sırada görüntülemek için Gruplandırma Yok'u seçin.

Kullanıcı Arabirimi Öğeleri

Sütun Başlıkları

Öğe Adı | Açıklama
Ad | Etkinleştirebileceğiniz veya devre dışı bırakabileceğiniz etkinleştirme kurallarının adlarını listeler. Kalın yazılan kurallar varsayılan olarak etkindir; gölgeli metinle yazılan kurallar varsayılan olarak devre dışıdır. Bir kuralı etkinleştirmek veya devre dışı bırakmak için kuralı seçip Kuralı Etkinleştir veya Kuralı Devre Dışı Bırak düğmelerini kullanabilirsiniz. Bu kurallar hakkında daha fazla bilgi için, bkz. Web Dağıtımı Kuralları (sayfa İngilizce olabilir).

Düğmeler

Öğe Adı | Açıklama
Kuralı Etkinleştir | Seçili kuralı etkinleştirir.
Kuralı Devre Dışı Bırak | Seçili kuralı devre dışı bırakır.

Ayrıca Bkz.

  • Uygulama Paketi Verme ve Sunucu Paketi Verme Sihirbazı Sayfaları
  • Uygulama Paketi Alma ve Sunucu ve Site Paketi Alma Sihirbazı Sayfaları


Parametre Seç Sayfası

Paketinize parametre eklemek veya paketinizden parametre çıkarmak için Uygulama Paketi Verme Sihirbazı'nın Parametre Seç sayfasını kullanın. Paketi oluştururken parametrelere öznitelik atayabilirsiniz. Daha sonra, paket yüklenirken kullanıcı parametre için özel bir değer belirtebilir ve özniteliğe bu yeni değer atanır. Her sağlayıcı için otomatik olarak parametreler oluşturulur.

Kullanıcı Arabirimi Öğeleri

Sütun Başlıkları

Öğe Adı | Açıklama
Ad | Parametre Ekle iletişim kutusunu kullanarak eklediğiniz parametrelerin adlarını listeler. Bir parametreyi düzenlemek için parametreyi çift tıklatabilir veya parametreyi seçip Düzenle'yi tıklatabilirsiniz.
Tür | Parametreleştirilecek özniteliğin parametre türünü görüntüler.
Kapsam | Parametreleştirilecek özniteliğin kapsamını görüntüler.
Eşleşme | Parametreleştirilecek özniteliği tanımlayacak eşleşen ifadeyi görüntüler.

Düğmeler

Öğe Adı Açıklama

Parametre Ekle

Parametre Ekle iletişim kutusunu açar. Bu, bir parametre eklemenizi özelliklerini ayarlamanızı sağlar. Daha fazla bilgi için bkz. Parametre Ekle veya Düzenle İletişim Kutusu.

Parametre Girişi Ekle

Parametre Girişi Ekle iletişim kutusunu açar. Bu, seçilen parametre için Tür, Kapsam ve Eşleşme değerlerini yapılandırmanızı sağlar. Daha fazla bilgi için bkz. Parametre Girişi Ekle İletişim Kutusu. Bu seçenek bir parametre veya parametre girişi seçtiğinizde etkinleştirilir.

Düzenle

Bir parametre seçiliyse, bu düğme Parametreyi Düzenle iletişim kutusunu açar. Bu, varolan bir parametrenin özelliklerini düzenlemenizi sağlar. Daha fazla bilgi için bkz. Parametre Ekle veya Düzenle İletişim Kutusu.

Bir parametre girişi seçiliyse, bu düğme Parametre Girişini Düzenle iletişim kutusunu açar. Daha fazla bilgi için bkz. Parametre Girişini Düzenle İletişim Kutusu.

Kaldır

Seçili parametreyi kaldırır.

Yukarı Taşı

Seçili parametreyi parametre listesinde yukarıya taşır. Parametreler listede bulundukları sıraya göre işlenir.

Aşağı Taşı

Seçili parametreyi parametre listesinde aşağıya taşır. Parametreler listede bulundukları sıraya göre işlenir.

Ayrıca Bkz.

  • Uygulama Paketi Verme ve Sunucu Paketi Verme Sihirbazı Sayfaları


Parametre Ekle veya Düzenle İletişim Kutusu

Parametre Ekle iletişim kutusunu veya Parametreyi Düzenle iletişim kutusunu uygulama paketiniz için yeni bir parametre eklemek veya varolan bir parametreyi düzenlemek amacıyla kullanın.

Kullanıcı Arabirimi Öğeleri

Öğe Adı Açıklama

Ad

Parametreniz için bir ad yazın. Örneğin, Bağlantı Dizesi.

Varsayılan Değer

Parametre için bir varsayılan değer yazın. Daha sonra paket dağıtıldığında, kullanıcı farklı bir değer belirtmedikçe parametre bu değere sahip olur. Örneğin, parametre adı olarak Bağlantı Dizesi yazdıysanız, varsayılan değer olarak Data Source=.\SQLExpress;Database=Test;Integrated Security kullanabilirsiniz. Bu giriş gerekli değildir.

Önemli

Kullanıcının parametre için bir değer sağlamasını istiyorsanız, varsayılan değer belirtmeyin.

Etiketler

Virgüller ayrılmış bir özel öznitelikler listesi yazın. Etiketler, parametre için daha sonra başvuruda bulunulabilen isteğe bağlı özniteliklerdir. Örneğin, kullanıcı arabiriminin parola değerini görüntülememesi için parametreniz parola olarak etiketlenebilir. Bu giriş gerekli değildir. Varsayılan Değer öğesinin açıklamasındaki örneğe devam edersek, Bağlantı Dizesi parametresi için SQL, SQLConnectionString etiketlerini kullanabilirsiniz.

Açıklama

Parametreniz için bir açıklama yazın. Örneğin, "Bu bağlantı dizesi uygulamanızın kullandığı veritabanı içindir. Ortamınızda farklı bir SQL sunucusu veya veritabanı varsa lütfen bunu değiştirin." Açıklama paketin içindeki Parameters.xml dosyasına yerleştirilir ve komut isteminde msdeploy -verb:getParameters -source:package=<PaketDosyasıAdı> yazılarak görüntülenebilir.

Tür

İsteğe bağlı olarak parametre doğrulama türünü seçin. Olası değerler None, Regular Expression, Enumeration veya Boolean'dır. Varsayılan değer: None. None dışında bir parametre doğrulma türü seçerseniz, kullanıcının parametre için sağladığı değerin belirttiğiniz koşulları sağlayıp sağlamadığı denetlenir. Regular Expression'ı veya Enumeration'ı seçerseniz, Doğrulama Dizesi kutusunda bir doğrulama dizesi sağlamanız gerekir.

Doğrulama Dizesi

Bir normal ifade veya virgüller ayrılmış bir numaralandırma değerleri listesi yazın. Normal İfadeler hakkında daha fazla bilgi için, bkz. Normal İfadeler (sayfa İngilizce olabilir).

Ayrıca Bkz.

  • Parametre Seç Sayfası
  • Uygulama Paketi Verme ve Sunucu Paketi Verme Sihirbazı Sayfaları


Parametre Girişi Ekle İletişim Kutusu

Parametre Girişi Ekle iletişim kutusunu parametrenizin Tür, Kapsam ve Eşleşme değerlerini belirtmek için kullanın.

Kullanıcı Arabirimi Öğeleri

Öğe Adı | Açıklama
Tür | Parametreleştirilecek öznitelik için kullanmak istediğiniz parametre türünü seçmek için açılan listeyi kullanın. Olası parametre türleri Xml Dosyası, Metin Dosyası, Metin Dosyası Konumu, Sağlayıcı Yolu, Dağıtım Özniteliği, Hedef Bağlama ve Hedef Sanal Dizin'dir. Örneğin, bir Bağlantı Dizesi parametresi oluşturduysanız, bağlantı dizesi XML biçiminde olan Web.config dosyasında bulunacağından açılan listeden Xml File'ı seçebilirsiniz.
Kapsam | Parametreleştirilecek özniteliğin kapsamını girin. Bu değer gerekli bir normal ifadedir. Örneğin, parametre türü Xml File ise, kapsam için \\web.config$ normal ifadesini kullanabilirsiniz. İlk ters eğik çizgi ikinci ters eğik çizginin kaçış karakteridir ve dolar işareti ($) eşleşme dizesini satır sonunda durdurur. Böylece, kapsam sonuçta "\web.config" olacaktır. Normal ifadeler hakkında daha fazla bilgi için, bkz. Normal İfadeler (sayfa İngilizce olabilir).
Eşleşme | Parametreleştirilecek özniteliği tanımlayacak ifadeyi yazın. Bu değer türe bağılıdır. Bazı durumlarda bir normal ifade veya bir XPath ifadesi olur. Xml File türü eşleşen değerin XPath ifadesi olmasını gerektirir. Önceki örneği devam ettirirsek, Web.config dosyasındaki bağlantı dizesiyle eşleştirmek için //connectionStrings/add/@connectionString XPath ifadesini kullanabilirsiniz.

Ayrıca Bkz.

  • Parametre Seç Sayfası
  • Uygulama Paketi Verme ve Sunucu Paketi Verme Sihirbazı Sayfaları


Parametre Girişini Düzenle İletişim Kutusu

Parametre Girişini Düzenle iletişim kutusunu parametrenizin Tür, Kapsam ve Eşleşme değerlerini düzenlemek için kullanın. Henüz bir parametre oluşturmadıysanız, bkz. Parametre Ekle veya Düzenle İletişim Kutusu.

Kullanıcı Arabirimi Öğeleri

Öğe Adı | Açıklama
Tür | Parametre türünü değiştirmek için açılan listeyi kullanın. Olası parametre türleri Xml Dosyası, Metin Dosyası, Metin Dosyası Konumu, Sağlayıcı Yolu, Dağıtım Özniteliği, Hedef Bağlama ve Hedef Sanal Dizin'dir. Örneğin, bir Bağlantı Dizesi parametresi oluşturduysanız, bağlantı dizesi XML biçiminde olan Web.config dosyasında bulunacağından açılan listeden Xml File'ı seçebilirsiniz.
Kapsam | Parametreleştirilecek özniteliğin kapsamını düzenleyin. Bu değer gerekli bir normal ifadedir. Örneğin, parametre türü Xml File ise, kapsam için \\web.config$ normal ifadesini kullanabilirsiniz. İlk ters eğik çizgi ikinci ters eğik çizginin kaçış karakteridir ve dolar işareti ($) eşleşme dizesini satır sonunda durdurur. Böylece, kapsam sonuçta "\web.config" olacaktır. Normal ifadeler hakkında daha fazla bilgi için, bkz. Normal İfadeler (sayfa İngilizce olabilir).
Eşleşme | Parametreleştirilecek özniteliği tanımlayacak ifadeyi düzenleyin. Bu değer türe bağılıdır. Bazı durumlarda bir normal ifade veya bir XPath ifadesi olur. Xml File türü, eşleşen değerin XPath ifadesi olmasını gerektirir. Önceki örneği devam ettirirsek, Web.config dosyasındaki bağlantı dizesiyle eşleştirmek için //connectionStrings/add/@connectionString XPath ifadesini kullanabilirsiniz.

Ayrıca Bkz.

  • Parametre Seç Sayfası
  • Uygulama Paketi Verme ve Sunucu Paketi Verme Sihirbazı Sayfaları


Paketi Kaydet Sayfası

Uygulama Paketi Verme Sihirbazı'nın Paketi Kaydet sayfasını paketinizi kaydederken kullanılacak dosya adını ve konumu belirtmek için kullanın.

Kullanıcı Arabirimi Öğeleri

Öğe Adı | Açıklama
Paket yolu | Paketiniz için bir ad yazın. Dosya adının dosya adı uzantısını .zip olmalıdır.
Gözat… | Paketinizi kaydetmek istediğiniz konumunu belirtmek için Gözat düğmesini tıklatın.

Ayrıca Bkz.

  • Uygulama Paketi Verme ve Sunucu Paketi Verme Sihirbazı Sayfaları


Şifreleme Parolası İletişim Kutusu

Uygulama Paketi Verme Sihirbazı'nın Parolayı Şifrele sayfasını güvenli olarak işaretlenmiş ayarları olan paket içeriği için parola sağlamak amacıyla kullanın.

Kullanıcı Arabirimi Öğeleri

Öğe Adı | Açıklama
Parola | Daha sonra paket alınırken istenecek parolayı yazın. Güvenli olarak işaretlenen ayarlar için bir parola sağlamazsanız paketi veremezsiniz.
Parolayı onayla | Parolayı onaylamak için yeniden yazın.

Ayrıca Bkz.

  • Uygulama Paketi Verme ve Sunucu Paketi Verme Sihirbazı Sayfaları


Verme İlerleme Durumu ve Özeti Sayfası

Uygulama Verme Sihirbazı'nın Verme İlerleme Durumu ve Özeti sayfasını, verme işleminin durumunu izlemek ve sihirbaz tamamlandıktan sonra işlemin özetini ve ayrıntılı bilgilerini görüntülemek için kullanın.

Kullanıcı Arabirimi Öğeleri

Öğe Adı Açıklama

Durum

Durum alanında, gerçekleştirilmekte olan işlem (örneğin, bir dosya kopyalama veya veritabanı komut dosyası işlemi) görüntülenir. Verme işlemi sırasında, uygulama şifreleme gerektiren parola veya sertifika gibi öğeler içeriyorsa bir parola girmeniz istenebilir. Veri miktarı çoksa veya verileri uzaktaki bir sunucuya veriyorsanız, verme işleminin uzun sürebileceğini unutmayın.

Özet

Gerçekleştirilen eylemlere genel bir bakış sağlar; oluşturma işlemi sırasında oluşan hatalar buna dahildir.

Önemli

Özet sekmesi gerçekleştirilen eylemlerin veya oluşan hataların tamamının listesini içermez. Ayrıntılar sekmesini tıklatarak daha ayrıntılı bilgi bulabilirsiniz.

Ayrıntılar

Gerçekleştirilen eylemlerin ayrıntılı bir listesini sağlar. Herhangi bir hata oluşmuşsa, bu sekmeyi tıklattığınızda sorun giderme için kullanabileceğiniz ayrıntılı hata bilgileri gösterilir.

Ayrıca Bkz.

  • Uygulama Paketi Verme ve Sunucu Paketi Verme Sihirbazı Sayfaları


Uygulama Paketi Alma ve Sunucu ve Site Paketi Alma Sihirbazı Sayfaları

Paketi Seç Sayfası

Şifre Çözme Parolası İletişim Kutusu

Paket İçeriğini Seç Sayfası

Gelişmiş Ayarlar İletişim Kutusu (Alma)

Veritabanı Seç Sayfası

Uygulama Paketi Bilgilerini Gir Sayfası

Varolan Dosyaların Üzerine Yaz Sayfası

Yükleme İlerleme Durumu ve Özeti Sayfası


Paketi Seç Sayfası

Paketi Seç sayfasını, sitenize veya sunucunuza yüklemek istediğiniz varolan bir paketi seçmek için kullanın.

Kullanıcı Arabirimi Öğeleri

Öğe Adı | Açıklama
Paket yolu | Sitenize veya sunucunuza yüklemek istediğiniz paketin konumunu belirtir.
Gözat… | Almak istediğiniz paketin konumunu belirtmek için Gözat düğmesini tıklatın.

Ayrıca Bkz.

  • Uygulama Paketi Alma ve Sunucu ve Site Paketi Alma Sihirbazı Sayfaları


Şifre Çözme Parolası İletişim Kutusu

Uygulama Paketi Alma Sihirbazı'nın Şifre Çözme Parolası sayfasını güvenli olarak işaretlenmiş ayarları olan paket içeriği için parola sağlamak amacıyla kullanın.

Kullanıcı Arabirimi Öğeleri

Öğe Adı | Açıklama
Parola | Paket içeriğinin şifresini çözmek için gereken parolayı yazın. Paket oluşturulurken bazı ayarlar güvenli olarak işaretlendiğinden parola gereklidir. Paket oluşturulurken belirtilen parolayı girmezseniz paketi alamazsınız.

Ayrıca Bkz.

  • Uygulama Paketi Alma ve Sunucu ve Site Paketi Alma Sihirbazı Sayfaları


Paket İçeriğini Seç Sayfası

Uygulama Paketi Alma Sihirbazı'nın Paket İçeriğini Seç sayfasını Paket Seç sayfasında seçtiğiniz pakette bulunan bileşenleri görüntülemek için kullanın.

Paketler; kayıt defteri ayarları, COM, GAC derlemeleri veya sertifikalar gibi bileşenler içerebilir. Bu bileşenleri sunucunuza yüklemek için, Administrators grubunun üyesi olmanız veya uygun yetkinin size atanmış olması gerekir. Yalnızca içerik yüklemek için yönetici kullanıcı haklarınız olması gerekmez.

Kullanıcı Arabirimi Öğeleri

Öğe Adı Açıklama

Paket içeriği

Pakette bulunan bileşenleri listeler. Paketten nelerin dağıtılacağını uygun bileşenlerin onay kutularını seçerek veya temizleyerek belirtebilirsiniz. Örneğin, karşılık gelen onay kutusunu seçerek veya temizleyerek bir SQL veritabanını veya GAC derlemesini dahil edebilir veya hariç tutabilirsiniz.

Dikkat

Bazı bileşenler uygulama için gerekli olabilir. Bu bileşenlerin onay kutularını temizlerseniz, uygulama yüklendikten sonra düzgün çalışmayabilir.

Ayrıca Bkz.

  • Uygulama Paketi Alma ve Sunucu ve Site Paketi Alma Sihirbazı Sayfaları


Gelişmiş Ayarlar İletişim Kutusu (Alma)

Uygulama Paketi Alma Sihirbazı'nın Gelişmiş Ayarlar iletişim kutusunu paketinizin ayarlarını belirtmek için kullanın.

Kullanıcı Arabirimi Öğeleri

Gelişmiş Seçenekler

Öğe Adı Açıklama

Şifre Çözme Parolası

Paket içeriğinin şifresini çözmek için gereken parolayı yazmanızı sağlayan Şifre Çözme Parolası iletişim kutusunu açar.

Bir alma işlemi sırasında, Web Dağıtımı, paketin sunucu düzeyi yapılandırma dosyalarında (örneğin, ApplicationHost.config veya Machine.config) özel bir kimliği olan bir uygulama havuzu gibi şifrelenmiş bir nesnenin bulunup bulunmadığını otomatik olarak algılar. Şifrelenmiş nesne varsa, nesne için bir parola sağlamanız gerekir. Doğru parolayı belirtmezseniz alma işlemi başarısız olur.

ACL'leri Ekle

Belirttiğiniz yolun ACL'leri kaynaktan hedefe kopyalanacaksa True'yu seçin, aksi halde False'u seçin. Bu ayar sistem dosyaları, kayıt defteri ve metatabanı ve yalnızca şu sağlayıcılar için geçerlidir: appHostConfig, contentPath, iisApp, metaKey, webServer ve webServer60. Varsayılan ayar False değeridir.

Bağlantı Uzantısı

Sağdaki alanı tıklatın ve sonra bağlantı uzantıları açılan listesini görüntülemek için oku tıklatın. İşleme uygulamak istediğiniz bağlantı uzantılarını etkinleştirmek veya devre dışı bırakmak için listedeki uzantıları seçin veya temizleyin. Bağlantı uzantıları bir işlemde özel veri türlerini dahil eder veya hariç tutar. Kullanılabilen Web Dağıtımı uzantıları: AppPoolExtension, CertificateExtension, ContentExtension, FrameworkConfigExtension ve HttpCertConfigExtension. Bu uzantılar varsayılan olarak seçilidir. Bağlantı uzantıları hakkında daha fazla bilgi için, bkz. Web Dağıtımı Bağlantı Uzantıları (sayfa İngilizce olabilir).

Yeniden Deneme Sayısı

Sağlayıcının bir hatadan sonra kaç kez yeniden deneyeceğini yazın. Varsayılan yeniden deneme sayısı 5'tir. Varsayılan olarak her yeniden deneme arasında bir saniye beklenir. Yeniden deneme sayısı ayarı yalnızca contentPath sağlayıcısıyla kullanılabilir.

Yeniden Deneme Aralığı

Milisaniye cinsinden bir değer yazın. Değer sağlayıcının yeniden denemeleri arasındaki süreyi belirler. Varsayılan: 1000 (bir saniye). Bu ayar yalnızca contentPath sağlayıcısıyla kullanılabilir.

İzleme Düzeyi

Açılan listeden hata iletisi günlüklerindeki ayrıntı düzeyini belirten bir değer seçin. Olası değerler Off, Error, Warning, Info ve Verbose'dur. Varsayılan: Info. Off, hiçbir hata iletisinin günlüğe yazılmayacağı anlamına gelir. Verbose, tüm iletilerin günlüğe yazılacağı anlamına gelir.

Eşitleme Seçenekleri

Öğe Adı Açıklama

Kurallar

İşlem için kullanılacak kuralları belirtmenizi sağlayan Kuralları Etkinleştir veya Devre Dışı Bırak iletişim kutusunu açar. Daha fazla bilgi için bkz. Kuralları Etkinleştir veya Devre Dışı Bırak İletişim Kutusu.

WhatIf

Açılan listeyi tıklatın ve True veya False öğesini seçin. True, işlemin gerçekte herhangi bir değişiklik yapılmadan çalışacağını belirtir. Bir işlemin tüm bölümleri başarılı olursa bu ayarı işlemin sonuçlarını görmek için kullanabilirsiniz. Varsayılan değer: False.

Not

WhatIf ayarıyla başarılı bir şekilde çalışıyor gibi görünen bir komut WhatIf ayarı kullanılmadan çalıştırıldığında başarısız olabilir. Bu, işlem sırasında beklenmeyen hatalar çıkarsa olabilir. Örneğin, WhatIf işlemi sırasında hiçbir veri yazılmadığından, yazma izni ile ilgili hatalar algılanamaz. WhatIf ayarı yalnızca komuttaki tüm işlemler başarılı olduğunda ne olacağını gösterir.

Ayrıca Bkz.

  • Paket İçeriğini Seç Sayfası
  • Uygulama Paketi Alma ve Sunucu ve Site Paketi Alma Sihirbazı Sayfaları


Veritabanı Seç Sayfası

Veritabanı Seç sayfasını sitenize yüklemekte olduğunuz paket için kullanılacak veritabanı seçeneklerini seçmek için kullanın. Bu sayfa yalnızca pakette birden fazla veritabanı türü varsa görünür.

Not

Bu sayfa, pakette birden fazla veritabanı türü varsa, ancak Paket İçeriğini Seç sayfasında biri hariç tüm veritabanı türleri için onay kutularınız temizlemişseniz de görünür.

Kullanıcı Arabirimi Öğeleri

Öğe Adı | Açıklama
Kullanmak istediğiniz veritabanını seçin | Yüklemeniz için kullanılacak veritabanı türünü seçin. Kullanılabilen veritabanı türleri SQL, MySQL, VistaDB, SQLite, Flat File veya No Database'dir. Yüklemekte olduğunuz paketin içeriği hangi veritabanı seçeneklerinin görüneceğini belirler. Yalnızca SQL ve MySQL seçeneklerinin ilişkili sağlayıcıları vardır. Daha fazla bilgi için, bkz. Web Dağıtımı dbFullSql Sağlayıcısı (sayfa İngilizce olabilir) ve Web Dağıtımı MySQL Sağlayıcısı (sayfa İngilizce olabilir).
Yeni oluştur veya varolan veritabanını kullan | Yeni bir veritabanı oluşturmak için Yeni veritabanı oluştur'u veya varolan bir veritabanını kullanmak için Varolan veritabanını kullan'ı seçin. Bu seçenek yalnızca veritabanı türü olarak SQL veya MySQL seçildiğinde kullanılabilir.

Ayrıca Bkz.

  • Uygulama Paketi Alma ve Sunucu ve Site Paketi Alma Sihirbazı Sayfaları
  • Uygulama Paketi Bilgilerini Gir Sayfası


Uygulama Paketi Bilgilerini Gir Sayfası

Uygulama Paketi Alma Sihirbazı'nın Uygulama Paketi Bilgilerini Gir sayfasını pakette bildirimi yapılmış parametrelerin değerlerini belirtmek için kullanın. Her parametrenin sayfada bir alanı vardır. Sayfada görüntülenen alanlar pakette bildirilmiş olan parametrelere bağlıdır.

Kullanıcı Arabirimi Öğeleri

Öğe Adı | Açıklama
<Parametre Adı> | Paketinizi yüklemek için gerekli olan parametrenin değerini belirtin. Bu bilgiler uygulamanızı yüklemek istediğiniz konumun tam site yolunu, kullanıcı kimlik bilgilerini veya uygulamanızın veritabanının adını içerebilir. Örneğin, uygulamanın yüklenmesi gereken uygulama yolu değerini (Varsayılan Web Sitesi/YeniUygulama gibi) değiştirebilirsiniz.

Ayrıca Bkz.

  • Bağlantı Dizesini Düzenle İletişim Kutusu


Bağlantı Dizesini Düzenle İletişim Kutusu

Kullanmak istediğiniz bağlantı dizesini ve kimlik bilgilerini belirtmek için Bağlantı Dizesini Düzenle iletişim kutusunu kullanın.

Kullanıcı Arabirimi Öğeleri

Öğe Adı | Açıklama
SQL Sunucusu | Belirttiğiniz bir SQL sunucusunu kullanmak için bu seçeneği seçin.
Sunucu | Kullanmak istediğiniz sunucusunun yolunu veya bağlantı dizesini yazın (örneğin, .\SQLExpress).
Veritabanı | Kullanmak istediğiniz veritabanının adını yazın, (örneğin, Test).
Windows Tümleşik Güvenliğini Kullan | Windows Tümleşik Güvenliğini kullanmak için bu seçeneği seçin. Windows Tümleşik Güvenliği, kullanıcı Windows'da oturum açmış durumdaysa kullanıcı kimlik bilgilerini yeniden doğrulamadan ASP.NET'e geçirir. Bu kimlik doğrulama yöntemi istemci ve sunucu aynı etki alanındaysa en iyi sonucu verir.
Kimlik bilgilerini belirt | Kullanıcı tarafından belirtilen kimlik bilgilerini kullanmak için bu seçeneği seçin. Kimlik Bilgilerini Ayarlar iletişim kutusunu açmak ve kullanıcı adınızı ve parolanızı belirtmek için Ayarla'yı tıklatın.
Özel | Kullanmak istediğiniz sunucu için özel bir yol veya bağlantı dizesi belirtmek için bu seçeneği seçin (örneğin, Server=.\SQLExpress;Database=Test;Integrated Security=true).

Ayrıca Bkz.

  • Uygulama Paketi Alma ve Sunucu ve Site Paketi Alma Sihirbazı Sayfaları
  • Uygulama Paketi Bilgilerini Gir Sayfası


Varolan Dosyaların Üzerine Yaz Sayfası

Varolan Dosyaların Üzerine Yaz sayfasını yeni dosyaların hedefin sonuna eklenmesine ya da varolan dosyaların üzerine yazılıp uygulama paketinde karşılığı olmayan dosyaların silinmesine karar vermek için kullanın.

Kullanıcı Arabirimi Öğeleri

Öğe Adı | Açıklama
Hayır, uygulama paketindeki dosyaları hedefin sonuna ekle. | Hedefte varolan dosyaları korumak ve uygulama paketinden yeni dosyalar eklemek için bu seçeneği belirleyin.
Evet, hedef klasördeki uygulama paketinde olmayan tüm fazla dosyaları ve klasörleri sil. | Hedefte bulunup da uygulama paketinde bulunmayan tüm dosyaları silmek için bu seçeneği belirleyin.

Ayrıca Bkz.

  • Uygulama Paketi Alma ve Sunucu ve Site Paketi Alma Sihirbazı Sayfaları


Yükleme İlerleme Durumu ve Özeti Sayfası

Yükleme İlerleme Durumu ve Özeti sayfasını alma işleminin durumunu izlemek ve sihirbaz tamamlandıktan sonra işlemin özetini ve ayrıntılı bilgilerini görüntülemek için kullanın.

Kullanıcı Arabirimi Öğeleri

Öğe Adı Açıklama

Durum

Durum alanında gerçekleştirilmekte olan işlem (örneğin, bir dosya kopyalama veya veritabanı komut dosyası işlemi) görüntülenir. Alma işlemi sırasında, uygulama şifre çözme gerektiren parola veya sertifika gibi öğeler içeriyorsa bir parola girmeniz istenebilir. Veri miktarı çoksa veya verileri uzaktaki bir sunucudan alıyorsanız alma işleminin uzun sürebileceğine unutmayın.

Özet

Gerçekleştirilen eylemlere genel bir bakış sağlar; yükleme işlemi sırasında oluşan hatalar buna dahildir.

Önemli

Özet sekmesi gerçekleştirilen eylemlerin veya oluşan hataların tamamının listesini içermez. Ayrıntılar sekmesini tıklatarak daha ayrıntılı bilgi bulabilirsiniz.

Ayrıntılar

Gerçekleştirilen eylemlerin ayrıntılı bir listesini sağlar. Herhangi bir hata oluşmuşsa, bu sekme tıklatıldığında sorun giderme için kullanabileceğiniz ayrıntılı hata bilgilerini gösterilir.

Ayrıca Bkz.

  • Uygulama Paketi Alma ve Sunucu ve Site Paketi Alma Sihirbazı Sayfaları