IIS 관리자용 웹 배포 도구 개요

웹 배포 도구(웹 배포)는 IIS 구성, 콘텐츠, SSL 인증서 및 기타 형식의 데이터를 사용자가 지정한 사이트 또는 서버에서 사용자가 지정한 대상으로 동기화합니다. 기본적으로 포함되어 있지 않은 레지스트리 키와 같은 개체를 배포할 수도 있습니다.

관리 서비스 위임

IIS Manager에서 웹 배포는 원격 사용자가 수행할 수 있는 배포 작업을 더 정확하게 제어할 수 있는 관리 서비스 위임이라는 관리자 전용 기능을 서버 수준에 추가합니다. 자세한 내용은 관리 서비스 위임 페이지를 참조하십시오.

응용 프로그램 내보내기 및 가져오기

IIS Manager 작업 창에서 이 도구의 응용 프로그램 패키지 내보내기 마법사를 사용하여 사이트, 응용 프로그램 및 콘텐츠가 들어 있는 압축 파일(패키지)을 만들 수 있습니다. 자세한 내용은 응용 프로그램 패키지 내보내기 및 서버 패키지 내보내기 마법사 페이지를 참조하십시오.

패키지를 내보낸 후 응용 프로그램 패키지 가져오기 마법사를 사용하여 패키지의 콘텐츠를 다른 위치에 설치할 수 있습니다. 자세한 내용은 응용 프로그램 패키지 가져오기 및 서버 또는 사이트 패키지 가져오기 마법사 페이지를 참조하십시오.

명령줄 기능

웹 배포 도구의 Msdeploy.exe 실행 프로그램은 여러 가지 강력한 명령줄 기능을 제공합니다. Msdeploy.exe 기능에 대한 요약 도움말을 보려면 명령 프롬프트 창에서 msdeploy -help를 입력합니다. 더 자세한 온라인 도움말은 웹 배포 도구(페이지는 영문일 수 있음)를 참조하십시오.

추가 온라인 리소스

IIS.NET: 웹 배포 도구(페이지는 영문일 수 있음)

IIS.NET: 웹 배포 도구 포럼(페이지는 영문일 수 있음)

IIS.NET: Microsoft 웹 배포 팀 블로그 게시(페이지는 영문일 수 있음)


웹 배포 도구 UI(사용자 인터페이스) 도움말

IIS Manager에서는 IIS Manager에 있는 각 기능 페이지, 대화 상자 및 마법사 페이지의 모든 UI(사용자 인터페이스) 요소에 대한 설명을 제공합니다.이 도움말을 표시하려면 활성화된 기능 페이지, 대화 상자 또는 마법사 페이지에서 F1 키를 누르십시오.

이 섹션의 내용

관리 서비스 위임 페이지

응용 프로그램 패키지 내보내기 및 서버 패키지 내보내기 마법사 페이지

응용 프로그램 패키지 가져오기 및 서버 또는 사이트 패키지 가져오기 마법사 페이지


관리 서비스 위임 페이지

관리 서비스 위임 페이지를 사용하여 원격 사용자 배포 권한을 제어하는 규칙을 지정할 수 있습니다. 관리 서비스 위임 페이지는 관리자만 사용할 수 있으며 서버 수준에서만 표시됩니다.

UI 요소

요소 이름 | 설명
공급자 | 규칙이 적용되는 공급자를 표시합니다.
경로 | 규칙이 적용되는 경로를 표시합니다.
경로 유형 | 경로 유형을 표시합니다. 가능한 값은 PathPrefix, StringPrefix, StringSuffix, ConnectionString 및 RegularExpression입니다.
작업 | 규칙이 수행할 작업을 표시합니다. 웹 배포 공급자의 경우 일반 값은 읽기, 쓰기 및 *입니다.
ID 유형 | 규칙을 실행할 ID 유형을 표시합니다. 가능한 값은 CurrentUser, ProcessIdentity 및 SpecificUser입니다.
사용자 이름 | SpecificUser가 ID 유형으로 선택된 경우 사용자 이름을 표시합니다. ID 유형이 CurrentUser 또는 ProcessIdentity인 경우에는 사용자 이름이 표시되지 않습니다.
상태 | 규칙의 활성화 여부를 표시합니다. 작업 창에서 규칙 활성화 또는 규칙 비활성화를 클릭하여 규칙을 활성화하거나 비활성화할 수 있습니다.

작업 창 요소

요소 이름 | 설명
규칙 추가… | 규칙 추가 대화 상자를 엽니다. 규칙을 추가하려면 이 옵션을 선택합니다. 자세한 내용은 규칙 추가 대화 상자(관리 서비스 위임)를 참조하십시오.
규칙에 사용자 추가… | 규칙에 사용자 추가 대화 상자를 엽니다. 자세한 내용은 규칙에 사용자 추가 대화 상자를 참조하십시오.
편집… | 규칙 편집 대화 상자를 엽니다. 자세한 내용은 규칙 추가 또는 편집 대화 상자를 참조하십시오.
제거 | 선택한 위임 규칙 또는 위임 규칙 사용자를 제거합니다.
규칙 비활성화 | 선택한 위임 규칙을 비활성화합니다.
규칙 활성화 | 선택한 위임 규칙을 활성화합니다.
기능 설정 편집… | 기능 설정 편집 대화 상자를 엽니다. 자세한 내용은 기능 설정 편집 대화 상자(관리 서비스 위임)를 참조하십시오.


규칙 추가 대화 상자(관리 서비스 위임)
참고 항목

규칙 템플릿 선택 대화 상자를 사용하여 사용자 지정 위임 규칙을 만드는 데 사용할 수 있는 템플릿을 선택할 수 있습니다. 빈 템플릿을 선택하거나 특정 시나리오에 맞게 설계되어 설치된 템플릿을 선택할 수 있습니다.

UI 요소

설치된 템플릿

요소 이름 설명

빈 규칙

사용자 지정할 수 있는 빈 규칙을 만듭니다.

콘텐츠만 배포

콘텐츠 배포를 활성화하는 규칙을 만듭니다. 이 규칙은 WMSvc(웹 관리 서비스) 권한이 있는 모든 사용자가 이미 WMSvc 권한이 있는 경로에 콘텐츠를 게시할 수 있도록 합니다. 규칙을 편집하여 특정 경로 또는 사용자로 액세스를 제한할 수 있습니다. 이 규칙은 웹 사이트 콘텐츠를 동기화하는 contentPath 공급자를 사용합니다. 자세한 내용은 웹 배포 contentPath 공급자(페이지는 영문일 수 있음)를 참조하십시오.

콘텐츠와 함께 응용 프로그램 배포

응용 프로그램 배포를 활성화하는 규칙을 만듭니다. 이 템플릿은 폴더를 응용 프로그램으로 표시하는 규칙을 포함하지는 않지만 그러한 규칙과 결합하여 사용되는 경우가 많습니다. 이 규칙은 WMSvc 권한이 있는 모든 사용자가 이미 WMSvc 권한이 있는 경로에 응용 프로그램을 게시할 수 있도록 합니다. 규칙을 편집하여 특정 경로 또는 사용자로 액세스를 제한할 수 있습니다. 이 규칙은 contentPath 및 iisApp 공급자를 사용합니다. 자세한 내용은 웹 배포 contentPath 공급자(페이지는 영문일 수 있음) 및 웹 배포 iisApp 공급자(페이지는 영문일 수 있음)를 참조하십시오.

데이터베이스 배포

데이터베이스 배포를 활성화하는 규칙을 만듭니다. 이 규칙은 WMSvc 권한이 있는 모든 사용자가 액세스 권한이 있는 모든 데이터베이스에 게시할 수 있도록 합니다. 이 템플릿은 사용 중인 계정을 CurrentUser로 지정하므로 데이터베이스 서버에서 사용자를 인증하는 데 연결 문자열이 사용됩니다. 규칙을 편집하여 특정 데이터베이스 서버 또는 이름으로 액세스를 제한할 수 있습니다. 이 규칙은 로컬 SQL Server 배포 데이터베이스에서 원격으로 호스트된 SQL Server 데이터베이스로 처음에 데이터베이스를 게시할 수 있도록 하는 dbFullSql 공급자를 사용합니다. 자세한 내용은 웹 배포 dbFullSql 공급자(페이지는 영문일 수 있음)를 참조하십시오.

폴더를 응용 프로그램으로 표시

폴더를 응용 프로그램으로 표시하는 규칙을 만듭니다. 이 규칙은 WMSvc 권한이 있는 모든 사용자가 폴더를 응용 프로그램으로 표시할 수 있도록 합니다. 사용자가 관리자가 아닌 경우 ID 유형을 ApplicationHost.config 파일에 대한 쓰기 액세스 권한이 있는 계정으로 변경해야 합니다. 이 규칙의 기본 ID 유형은 SpecificUser입니다. 이 규칙은 createApp 공급자를 사용하는데, 이 공급자는 폴더를 응용 프로그램으로 표시하는 데 필요하며 이 공급자의 기능은 iisApp 공급자에 포함되어 있습니다. 자세한 내용은 웹 배포 공급자(페이지는 영문일 수 있음)를 참조하십시오.

응용 프로그램에 대한 권한 설정

응용 프로그램 경로에 대한 ACL을 설정하는 규칙을 만듭니다. 이 규칙은 WMSvc 권한이 있는 모든 사용자가 이미 WMSvc 권한이 있는 응용 프로그램 경로에 대해 파일 시스템 ACL을 설정할 수 있도록 합니다. 이 템플릿은 사용 중인 계정을 CurrentUser로 지정하므로 사용자는 권한을 부여받아야 ACL을 변경할 수 있습니다. 규칙을 편집하여 특정 경로 또는 사용자로 액세스를 제한할 수 있습니다. 이 규칙은 대상 폴더에 대한 권한을 설정하는 setAcl 공급자를 사용합니다. 자세한 내용은 웹 배포 setAcl 공급자(페이지는 영문일 수 있음)를 참조하십시오. .

데이터베이스 백업 및 복원(SQL 인증 사용)

SQL 인증을 사용하여 데이터베이스를 백업 및 복원하는 규칙을 만듭니다. 이 규칙은 WMSvc 권한이 있는 모든 사용자가 이미 액세스 권한이 있는 데이터베이스의 백업을 만들거나 복원할 수 있도록 합니다. 백업 및 복원 작업은 SQL 인증을 사용하여 특정 사용자 ID로 수행됩니다. 규칙을 편집하여 특정 데이터베이스 및 특정 사용자 집합으로 액세스를 제한할 수 있습니다.

참고
이 템플릿은 IIS 데이터베이스 관리자 확장과 함께 사용하십시오. IIS 데이터베이스 관리자에 대한 자세한 내용은 데이터베이스 관리자(페이지는 영문일 수 있음)를 참조하십시오.

데이터베이스 백업 및 복원(Windows 통합 보안 사용)

Windows 인증을 사용하여 데이터베이스를 백업 및 복원하는 규칙을 만듭니다. 이 규칙은 WMSvc 권한이 있는 모든 사용자가 이미 액세스 권한이 있는 데이터베이스의 백업을 만들거나 복원할 수 있도록 합니다. 규칙을 편집하여 특정 데이터베이스 및 특정 사용자 집합으로 액세스를 제한할 수 있습니다.

참고
이 템플릿은 IIS 데이터베이스 관리자 확장과 함께 사용하십시오. IIS 데이터베이스 관리자에 대한 자세한 내용은 데이터베이스 관리자(페이지는 영문일 수 있음)를 참조하십시오.

참고 항목

개념

응용 프로그램 패키지 가져오기 및 서버 또는 사이트 패키지 가져오기 마법사 페이지

기타 리소스

웹 배포 공급자(페이지는 영문일 수 있음)


규칙 추가 또는 편집 대화 상자

규칙 추가 및 규칙 편집 대화 상자를 사용하여 위임 규칙을 추가하고 편집할 수 있습니다.

UI 요소

요소 이름 | 설명
공급자 | 드롭다운 목록을 클릭하여 규칙에서 추가하거나 제거할 공급자를 선택하거나 선택을 취소한 다음 드롭다운 화살표를 클릭하여 변경 내용을 적용합니다. 공급자는 쉼표로 구분된 목록으로 표시됩니다. 웹 배포 공급자에 대한 자세한 내용은 웹 배포 공급자(페이지는 영문일 수 있음)를 참조하십시오.
작업 | 드롭다운 목록을 클릭하여 규칙에서 추가하거나 제거할 작업을 선택하거나 선택을 취소한 다음 드롭다운 화살표를 클릭하여 변경 내용을 적용합니다. 작업은 쉼표로 구분된 목록으로 표시됩니다. 웹 배포의 일반 값은 읽기, 쓰기 및 *입니다.
경로 유형 | 드롭다운 목록에서 경로 유형을 선택합니다. 가능한 값은 PathPrefix, StringPrefix, StringSuffix, ConnectionString 및 RegularExpression입니다. 정규식에 대한 자세한 내용은 정규식(페이지는 영문일 수 있음)을 참조하십시오.
경로 | 규칙이 적용될 경로를 입력합니다.
ID 유형 | 드롭다운 목록에서 규칙에 대한 ID 유형을 선택합니다. 선택한 ID로 규칙이 실행됩니다. 가능한 값은 CurrentUser, ProcessIdentity 및 SpecificUser입니다. CurrentUser를 선택하면 현재 사용자의 ID가 사용됩니다. ProcessIdentity를 선택하면 WMSvc 로컬 서비스 ID가 사용됩니다. SpecificUser를 선택하면 사용자가 지정하는 특수 ID가 사용됩니다. SpecificUser를 선택하는 경우 자격 증명 지정 설정 단추를 사용하여 자격 증명을 제공해야 합니다.
자격 증명 지정 | SpecificUser를 ID 유형으로 선택하면 설정 단추가 활성화됩니다.
설정 | SpecificUser ID에 대한 사용자 이름 및 암호를 지정할 수 있는 자격 증명 설정 대화 상자를 엽니다. 자세한 내용은 자격 증명 설정 대화 상자를 참조하십시오.


자격 증명 설정 대화 상자

자격 증명 설정 대화 상자를 사용하여 규칙을 실행할 Windows 사용자의 사용자 이름과 암호를 지정할 수 있습니다.

UI 요소

요소 이름 | 설명
사용자 이름 | Windows 사용자의 사용자 이름을 입력합니다.
암호 | 암호를 입력합니다.
암호 확인 | 확인을 위해 암호를 다시 입력합니다.

참고 항목

개념

규칙 추가 또는 편집 대화 상자


규칙에 사용자 추가 대화 상자

규칙에 사용자 추가 대화 상자를 사용하여 규칙에 대한 사용자 액세스를 허용하거나 거부할 수 있습니다.

UI 요소

요소 이름 | 설명
이름 | 사용자 이름을 입력합니다.
액세스 유형 | 지정된 사용자에게 제공할 액세스 유형을 선택합니다.가능한 값은 허용 및 거부입니다.
역할 여부 | 지정한 사용자 이름이 액세스가 허용되거나 거부될 사용자 그룹에 대한 별칭이면 이 확인란을 선택합니다.


기능 설정 편집 대화 상자(관리 서비스 위임)

기능 설정 편집 대화 상자를 사용하여 관리자가 위임 규칙을 무시할 수 있도록 허용하고 실패한 요청에 대한 로깅을 활성화합니다.

UI 요소

요소 이름 설명

관리자가 규칙을 무시하도록 허용

관리자가 지정된 위임 규칙을 무시할 수 있도록 허용하려면 이 옵션을 선택합니다.

위임 서비스에 대한 실패한 요청 추적 로그 사용

실패한 요청 정보에 대한 로깅을 사용하려면 이 옵션을 선택합니다.

경고
이 기능을 사용하려면 실패한 요청 추적 모듈을 설치해야 합니다.


응용 프로그램 패키지 내보내기 및 서버 패키지 내보내기 마법사 페이지

패키지 콘텐츠 선택 페이지

매개 변수 선택 페이지

패키지 저장 페이지

암호화 암호 대화 상자

내보내기 진행률 및 요약 페이지


패키지 콘텐츠 선택 페이지

응용 프로그램 패키지 내보내기 마법사의 패키지 콘텐츠 선택 페이지를 사용하여 만들려는 패키지에 포함된 구성 요소를 볼 수 있습니다.

패키지에는 레지스트리 설정, COM, GAC 어셈블리 또는 인증서와 같은 구성 요소가 포함될 수 있습니다. 이러한 구성 요소를 서버에 설치하려면 Administrators 그룹의 멤버이거나 적절한 권한을 위임받아야 합니다. 콘텐츠만 설치하는 경우에는 관리자 사용자 권한이 필요하지 않습니다.

UI 요소

요소 이름 설명

패키지에 포함된 항목

패키지에 포함된 구성 요소가 표시됩니다. 해당 구성 요소 확인란을 선택하거나 선택을 취소하여 패키지에 포함할 항목을 지정할 수 있습니다. 예를 들어 해당 확인란을 선택하거나 선택을 취소하여 SQL 데이터베이스 또는 GAC 어셈블리를 포함하거나 제외할 수 있습니다.

주의
일부 구성 요소는 응용 프로그램에 반드시 필요할 수 있습니다. 이러한 구성 요소 확인란의 선택을 취소하면 설치 후 응용 프로그램이 제대로 작동하지 않을 수 있습니다.

특성

오른쪽 창에 선택한 파일, 디렉터리 또는 구성 요소의 특성을 표시합니다. 이 값은 읽기 전용입니다.

구성 요소 관리…

구성 요소 관리 대화 상자를 엽니다. 여기에서 포함할 구성 요소를 선택할 수 있습니다. 자세한 내용은 구성 요소 관리 대화 상자를 참조하십시오.

고급 설정…

고급 설정 대화 상자를 엽니다. 여기에서 작업 설정 및 규칙을 지정할 수 있습니다. 자세한 내용은 고급 설정 대화 상자(내보내기)를 참조하십시오.

참고 항목

개념

응용 프로그램 패키지 내보내기 및 서버 패키지 내보내기 마법사 페이지

기타 리소스

IIS 관리자를 통해 패키지 내보내기(온라인 리소스)(페이지는 영문일 수 있음)


구성 요소 관리 대화 상자

응용 프로그램 패키지 내보내기 마법사의 구성 요소 관리 대화 상자를 사용하여 COM 개체 또는 GAC 어셈블리 등의 구성 요소를 패키지에 추가할 수 있습니다.

UI 요소

열 제목

요소 이름 설명

공급자 이름

패키지로 만들 구성 요소를 지정합니다. 각 구성 요소에는 공급자가 있습니다. 드롭다운 목록을 사용할 필드를 클릭하여 공급자 이름을 선택합니다. 공급자 이름을 마우스로 가리켜서 해당 공급자에 대한 설명을 봅니다. 예를 들어 dbFullSql을 선택하는 경우 스크립트 경로 또는 연결 문자열을 패키지로 만듭니다. 공급자에 대한 자세한 내용은 웹 배포 공급자(페이지는 영문일 수 있음)를 참조하십시오.

중요
웹 사이트를 패키지로 만드는 경우 기본적으로 선택되는 iisApp 공급자는 해당 웹 사이트를 대상의 응용 프로그램으로 표시합니다. 웹 사이트와 모든 관련 구성(예: 응용 프로그램 풀 이름, 콘텐츠 디렉터리의 위치 및 인증서)을 패키지로 만들려면 appHostConfig 공급자를 사용합니다. iisApp 공급자를 사용하는 경우 대상에서 웹 사이트는 설치되는 사이트의 모든 설정(예: 응용 프로그램 풀 이름 및 콘텐츠 디렉터리)을 상속하는 응용 프로그램이 됩니다.

경로

패키지에 데이터를 제공하는 구성 요소의 경로를 지정합니다. 예를 들어 dbFullSql을 선택하는 경우 경로는 C:\SQLfiles\installSQL.sql과 같은 스크립트 또는 Data Source=.\sqlexpress;Integrated Security=SSPI;Initial Catalog=db1과 같은 연결 문자열을 지정할 수 있습니다.

공급자 설정

선택한 공급자에 사용할 공급자 설정을 지정합니다. 찾아보기(…) 단추를 사용할 필드를 클릭하여 공급자 설정 대화 상자를 엽니다. 자세한 내용은 공급자 설정 대화 상자를 참조하십시오.

단추

요소 이름 | 설명
제거 | 선택한 항목을 삭제합니다.
위로 이동 | 선택한 행을 목록에서 위로 이동합니다. 항목은 목록에 표시된 순서대로 설치됩니다. 일부 공급자의 경우 항목의 순서가 중요합니다. 예를 들어 테이블을 만드는 스크립트는 테이블을 채우는 스크립트보다 먼저 실행되어야 합니다.
아래로 이동 | 선택한 행을 목록에서 아래로 이동합니다. 항목은 목록에 표시된 순서대로 설치됩니다.

참고 항목

개념

패키지 콘텐츠 선택 페이지
응용 프로그램 패키지 내보내기 및 서버 패키지 내보내기 마법사 페이지


공급자 설정 대화 상자

공급자 설정 대화 상자를 사용하여 선택한 공급자에 대한 설정을 지정할 수 있습니다. 일부 공급자에는 설정이 없습니다.

UI 요소

요소 이름 | 설명
설정 이름 | 선택한 공급자에 대한 설정의 이름을 표시합니다. 선택한 공급자와 관련이 있는 설정만 표시됩니다.
설정 값 | 설정 값을 입력하거나 선택합니다. 드롭다운 목록을 사용할 수 있으면 설정에 사용할 수 있는 값이 목록에 표시됩니다. 값을 입력해야 하는 경우 설명 상자에 사용할 수 있는 값에 대한 정보가 제공됩니다.
설정 설명 | 공급자에 대해 선택한 설정의 설명을 표시합니다. 설정에 허용되는 값에 대한 정보가 제공됩니다.

참고 항목

개념

구성 요소 관리 대화 상자
패키지 콘텐츠 선택 페이지
응용 프로그램 패키지 내보내기 및 서버 패키지 내보내기 마법사 페이지

기타 리소스

웹 배포 공급자 설정


고급 설정 대화 상자(내보내기)

응용 프로그램 패키지 내보내기 마법사의 고급 설정 대화 상자를 사용하여 패키지 설정을 지정할 수 있습니다.

UI 요소

고급 옵션

요소 이름 설명

암호화 암호

…를 클릭하여 IIS 구성에서 속성을 보호하도록 액세스를 제어하는 암호화 암호 대화 상자를 열면 영숫자 암호를 지정할 수 있습니다.

웹 배포 도구는 사용자 지정 ID가 있는 응용 프로그램 풀과 같은 암호화된 개체가 서버 수준 구성 파일(예: ApplicationHost.config 또는 Machine.config)에 있는지 자동으로 검색합니다. 암호화된 개체가 있는 경우 개체에 대한 암호를 제공해야 합니다. 올바른 암호를 지정하지 않으면 내보내기 작업에 실패합니다.

중요
웹 배포 도구는 Web.config 파일에서 암호화된 개체를 확인하지 않습니다.

ACL 포함

지정한 경로의 ACL이 원본에서 대상으로 복사되는 경우 True를 선택하고, 그렇지 않으면 False를 선택합니다. 이 설정은 파일 시스템, 레지스트리, 메타베이스 및 공급자 중 appHostConfig, contentPath, iisApp, metaKey, webServer 및 webServer60에 적용됩니다. 기본값은 false입니다.

링크 확장

오른쪽의 필드를 클릭한 다음 화살표를 클릭하여 링크 확장 드롭다운 목록을 표시합니다. 목록에 있는 확장을 선택하거나 선택을 취소하여 작업에 적용할 링크 확장을 활성화하거나 비활성화합니다. 링크 확장은 작업에서 특정 종류의 데이터를 포함하거나 제외합니다. 사용 가능한 웹 배포 확장은 AppPoolExtension, CertificateExtension, ContentExtension, FrameworkConfigExtension 및 HttpCertConfigExtension입니다. 이러한 확장은 기본적으로 선택됩니다. 링크 확장에 대한 자세한 내용은 웹 배포 링크 확장(페이지는 영문일 수 있음)을 참조하십시오.

재시도 횟수

공급자가 실패 후 재시도하는 횟수를 입력합니다. 기본 재시도 횟수는 5입니다. 기본적으로 각 재시도 사이에는 1초의 간격이 유지됩니다. 재시도 횟수 설정은 contentPath 공급자에서만 사용할 수 있습니다.

재시도 간격

값을 밀리초 단위로 입력합니다. 이 값은 공급자 재시도 사이의 시간 간격을 지정합니다. 기본값은 1000(1초)입니다. 이 설정은 contentPath 공급자에서만 사용할 수 있습니다.

추적 수준

오류 메시지 로그의 세부 정보 수준을 지정하는 값을 드롭다운 목록에서 선택합니다. 가능한 값은 Off, Error, Warning, Info 및 Verbose입니다. 기본값은 Info입니다. Off이면 오류 메시지가 로그에 기록되지 않습니다. Verbose이면 모든 메시지가 로그에 기록됩니다.

동기화 옵션

요소 이름 설명

규칙

작업 규칙을 지정할 수 있는 규칙 활성화 또는 비활성화 대화 상자를 엽니다. 자세한 내용은 규칙 활성화 또는 비활성화 대화 상자를 참조하십시오.

WhatIf

드롭다운 목록을 클릭하여 True 또는 False를 선택합니다. True는 실제로 작업을 변경하지 않고 실행하도록 지정합니다. 이 설정을 사용하여 작업의 모든 부분이 성공한 경우의 작업 결과를 볼 수 있습니다. 기본값은 False입니다.

참고
WhatIf 설정을 사용하여 성공적으로 실행되는 명령을 WhatIf 설정을 사용하지 않고 실행하는 경우 명령이 실패할 수도 있습니다. 작업 중 예기치 못한 오류가 발생한 경우 이러한 일이 발생할 수 있습니다. 예를 들어 WhatIf 작업 중에는 데이터를 쓰지 않으므로 쓰기 권한 오류는 검색되지 않습니다. WhatIf 설정은 명령의 모든 작업이 성공한 경우에 발생하는 결과만 보여 줍니다.

참고 항목

개념

패키지 콘텐츠 선택 페이지
응용 프로그램 패키지 내보내기 및 서버 패키지 내보내기 마법사 페이지


규칙 활성화 또는 비활성화 대화 상자

규칙 활성화 또는 비활성화 대화 상자를 사용하여 동기화 작업의 결과에 영향을 미치는 규칙을 활성화하거나 비활성화할 수 있습니다. 묶는 방법 드롭다운 목록에서 상태를 선택하여 규칙을 활성화 범주와 비활성화 범주로 묶거나 그룹화 안 함을 선택하여 사전순으로 규칙을 봅니다.

UI 요소

열 제목

요소 이름 | 설명
이름 | 활성화하거나 비활성화할 수 있는 동기화 규칙 이름이 표시됩니다. 굵게 표시된 규칙은 기본적으로 활성화되고 텍스트에 음영이 표시된 규칙은 기본적으로 비활성화됩니다. 규칙을 선택하고 규칙 활성화 또는 규칙 비활성화 단추를 사용하여 규칙을 활성화하거나 비활성화할 수 있습니다. 규칙에 대한 자세한 내용은 웹 배포 규칙(페이지는 영문일 수 있음)을 참조하십시오.

단추

요소 이름 | 설명
규칙 활성화 | 선택한 규칙을 활성화합니다.
규칙 비활성화 | 선택한 규칙을 비활성화합니다.

참고 항목

개념

응용 프로그램 패키지 내보내기 및 서버 패키지 내보내기 마법사 페이지
응용 프로그램 패키지 가져오기 및 서버 또는 사이트 패키지 가져오기 마법사 페이지


매개 변수 선택 페이지

응용 프로그램 패키지 내보내기 마법사의 매개 변수 선택 페이지를 사용하여 패키지에 매개 변수를 추가하거나 제거할 수 있습니다. 패키지를 만들 때 매개 변수를 특성에 할당할 수 있습니다. 나중에 패키지가 설치되면 사용자가 매개 변수에 사용자 지정 값을 지정할 수 있으며 이 새 값이 특성에 할당됩니다. 매개 변수는 각 공급자에 대해 자동으로 생성됩니다.

UI 요소

열 제목

요소 이름 | 설명
이름 | 매개 변수 추가 대화 상자를 사용하여 추가한 매개 변수 이름을 표시합니다. 매개 변수를 두 번 클릭하거나 매개 변수를 선택한 다음 편집을 클릭하여 매개 변수를 편집할 수 있습니다.
유형 | 매개 변수화할 특성의 매개 변수 유형을 표시합니다.
범위 | 매개 변수화할 특성의 범위를 표시합니다.
일치 | 매개 변수화할 특성을 식별할 일치 식을 표시합니다.

단추

요소 이름 | 설명
매개 변수 추가 | 매개 변수 추가 대화 상자를 엽니다. 여기에서 매개 변수를 추가하고 해당 속성을 설정할 수 있습니다. 자세한 내용은 매개 변수 추가 또는 편집 대화 상자를 참조하십시오.
매개 변수 항목 추가 | 매개 변수 항목 추가 대화 상자를 엽니다. 여기에서 선택한 매개 변수의 유형, 범위 및 일치 값을 구성할 수 있습니다. 자세한 내용은 매개 변수 항목 추가 대화 상자를 참조하십시오. 매개 변수 또는 매개 변수 항목을 선택하면 이 옵션이 활성화됩니다.
편집 | 매개 변수를 선택하면 이 단추로 매개 변수 편집 대화 상자를 열 수 있습니다. 여기에서 기존 매개 변수의 속성을 편집할 수 있습니다. 자세한 내용은 매개 변수 추가 또는 편집 대화 상자를 참조하십시오. 매개 변수 항목을 선택하면 이 단추로 매개 변수 항목 편집 대화 상자를 열 수 있습니다. 자세한 내용은 매개 변수 항목 편집 대화 상자를 참조하십시오.
제거 | 선택한 매개 변수를 제거합니다.
위로 이동 | 선택한 매개 변수를 매개 변수 목록에서 위로 이동합니다. 매개 변수는 목록에 표시된 순서대로 처리됩니다.
아래로 이동 | 선택한 매개 변수를 매개 변수 목록에서 아래로 이동합니다. 매개 변수는 목록에 표시된 순서대로 처리됩니다.

참고 항목

개념

응용 프로그램 패키지 내보내기 및 서버 패키지 내보내기 마법사 페이지


매개 변수 추가 또는 편집 대화 상자

매개 변수 추가 대화 상자 또는 매개 변수 편집 대화 상자를 사용하여 응용 프로그램 패키지에 대한 새 매개 변수를 추가하거나 기존 매개 변수를 편집할 수 있습니다.

UI 요소

요소 이름 설명

이름

매개 변수의 이름을 입력합니다.예를 들어 연결 문자열을 입력합니다.

기본값

매개 변수의 기본값을 입력합니다.나중에 패키지가 배포되면 사용자가 다른 값을 지정하지 않는 한 매개 변수가 이 값을 가집니다.예를 들어 매개 변수 이름으로 연결 문자열을 입력한 경우 기본값으로 Data Source=.\SQLExpress;Database=Test;Integrated Security를 사용할 수 있습니다.이 항목은 필수 사항이 아닙니다.

중요
사용자가 매개 변수 값을 제공하도록 요구하려면 기본값을 지정하지 마십시오.

태그

사용자 지정 특성을 쉼표로 구분한 목록을 입력합니다.태그는 나중에 참조할 수 있는 매개 변수의 선택적 특성입니다.예를 들어 사용자 인터페이스에서 암호 값을 표시하지 않도록 매개 변수에 암호 태그를 지정할 수 있습니다.이 항목은 필수 사항이 아닙니다.기본값 요소 설명에 있는 예의 경우 연결 문자열 매개 변수에 대해 SQL, SQLConnectionString 태그를 사용할 수 있습니다.

설명

매개 변수에 대한 설명을 입력합니다.예를 들어 "응용 프로그램에서 사용하는 데이터베이스에 대한 연결 문자열입니다.사용자 환경에서 다른 SQL 서버 또는 데이터베이스를 사용하는 경우 연결 문자열을 변경하십시오."를 입력합니다.이 설명은 패키지 내부의 Parameters.xml 파일에 포함되고 명령 프롬프트에서 msdeploy -verb:getParameters -source:package=<PackageFileName>을 입력하여 표시할 수 있습니다.

유형

필요에 따라 매개 변수 유효성 검사 유형을 선택합니다.가능한 값은 없음, 정규식, 열거형 또는 부울입니다.기본값은 없음입니다.매개 변수 유효성 검사 유형을 없음 이외의 값으로 선택한 경우 사용자가 매개 변수에 제공한 값이 지정한 조건에 만족하는지 여부가 확인됩니다.정규식이나 열거형을 선택한 경우 유효성 검사 문자열 상자에 유효성 검사 문자열을 입력해야 합니다.

유효성 검사 문자열

정규식 또는 쉼표로 구분한 열거형 값을 입력합니다.정규식에 대한 자세한 내용은 정규식(페이지는 영문일 수 있음)을 참조하십시오.

참고 항목

개념

매개 변수 선택 페이지
응용 프로그램 패키지 내보내기 및 서버 패키지 내보내기 마법사 페이지


매개 변수 항목 추가 대화 상자

매개 변수 항목 추가 대화 상자를 사용하여 매개 변수의 유형, 범위 및 일치 값을 지정할 수 있습니다.

UI 요소

요소 이름 | 설명
유형 | 드롭다운 목록을 사용하여 매개 변수화할 특성에 사용할 매개 변수 유형을 선택합니다. 가능한 매개 변수 유형은 XML 파일, 텍스트 파일, 텍스트 파일 위치, 공급자 경로, 배포 특성, 대상 바인딩 및 대상 가상 디렉터리입니다. 예를 들어, 연결 문자열 매개 변수를 만든 경우 연결 문자열은 XML 형식인 Web.config 파일 내부에 포함되므로 드롭다운 목록에서 Xml 파일을 선택할 수 있습니다.
범위 | 매개 변수화할 특성의 범위를 입력합니다. 이 값은 필수 정규식입니다. 예를 들어, Xml File이 매개 변수 유형이면 해당 범위에 대해 정규식 \\web.config$를 사용할 수 있습니다. 첫 번째 백슬래시는 두 번째 백슬래시를 이스케이프하고, 달러 기호($)는 줄의 끝에서 일치 문자열을 중지합니다. 따라서 "\web.config"가 결과 범위가 됩니다. 정규식에 대한 자세한 내용은 정규식(페이지는 영문일 수 있음)을 참조하십시오.
일치 | 매개 변수화할 특성을 식별할 식을 입력합니다. 이 값은 유형에 따라 다릅니다. 경우에 따라 이 값은 정규식이나 XPath 식이 됩니다. Xml File 유형에서는 일치 값이 XPath 식이어야 합니다. 이전 예의 경우 XPath 식 //connectionStrings/add/@connectionString을 사용하여 Web.config 파일 내부의 연결 문자열 항목과 일치 여부를 비교할 수 있습니다.

참고 항목

개념

매개 변수 선택 페이지
응용 프로그램 패키지 내보내기 및 서버 패키지 내보내기 마법사 페이지


매개 변수 항목 편집 대화 상자

매개 변수 항목 편집 대화 상자를 사용하여 매개 변수의 유형, 범위 및 일치 값을 편집할 수 있습니다. 매개 변수를 아직 만들지 않은 경우에는 매개 변수 추가 또는 편집 대화 상자를 참조하십시오.

UI 요소

요소 이름 | 설명
유형 | 드롭다운 목록을 사용하여 매개 변수 유형을 변경합니다. 가능한 매개 변수 유형은 XML 파일, 텍스트 파일, 텍스트 파일 위치, 공급자 경로, 배포 특성, 대상 바인딩 및 대상 가상 디렉터리입니다. 예를 들어, 연결 문자열 매개 변수를 만든 경우 연결 문자열은 XML 형식인 Web.config 파일 내부에 포함되므로 드롭다운 목록에서 Xml 파일을 선택할 수 있습니다.
범위 | 매개 변수화할 특성의 범위를 편집합니다. 이 값은 필수 정규식입니다. 예를 들어 Xml 파일이 매개 변수 유형이면 범위에 대해 정규식 \\web.config$를 사용할 수 있습니다. 첫 번째 백슬래시는 두 번째 백슬래시를 이스케이프하고, 달러 기호($)는 줄의 끝에서 일치 문자열을 중지합니다. 따라서 "\web.config"가 결과 범위가 됩니다. 정규식에 대한 자세한 내용은 정규식(페이지는 영문일 수 있음)을 참조하십시오.
일치 | 매개 변수화할 특성을 식별할 식을 편집합니다. 이 값은 유형에 따라 다릅니다. 경우에 따라 이 값은 정규식이나 XPath 식이 됩니다. Xml File 유형에서는 일치 값이 XPath 식이어야 합니다. 이전 예의 경우 XPath 식 //connectionStrings/add/@connectionString을 사용하여 Web.config 파일 내부의 연결 문자열 항목과 일치 여부를 비교할 수 있습니다.

참고 항목

개념

매개 변수 선택 페이지
응용 프로그램 패키지 내보내기 및 서버 패키지 내보내기 마법사 페이지


패키지 저장 페이지

응용 프로그램 패키지 내보내기 마법사의 패키지 저장 페이지를 사용하여 패키지를 저장할 때 사용할 파일 이름 및 위치를 지정할 수 있습니다.

UI 요소

요소 이름 | 설명
패키지 경로 | 패키지의 파일 이름을 입력합니다.파일 이름 확장명은 .zip이어야 합니다.
찾아보기… | 패키지를 저장할 위치를 지정하려면 찾아보기 단추를 클릭합니다.

참고 항목

개념

응용 프로그램 패키지 내보내기 및 서버 패키지 내보내기 마법사 페이지


암호화 암호 대화 상자

응용 프로그램 패키지 내보내기 마법사의 암호화 암호 대화 상자를 사용하여 보안으로 표시된 설정이 있는 패키지 콘텐츠에 암호를 제공할 수 있습니다.

UI 요소

요소 이름 | 설명
암호 | 나중에 패키지를 가져올 때 필요한 암호를 입력합니다. 보안으로 표시된 설정에 대해 암호를 제공하지 않으면 패키지를 내보낼 수 없습니다.
암호 확인 | 확인을 위해 암호를 다시 입력합니다.

참고 항목

개념

응용 프로그램 패키지 내보내기 및 서버 패키지 내보내기 마법사 페이지


내보내기 진행률 및 요약 페이지

응용 프로그램 내보내기 마법사의 내보내기 진행률 및 요약 페이지를 사용하여 내보내기 프로세스의 상태를 모니터링하고 마법사가 종료된 뒤 작업의 요약 및 자세한 정보를 볼 수 있습니다.

UI 요소

요소 이름 설명

상태

상태 영역에는 파일 복사 또는 데이터베이스 스크립트 작업 등 수행 중인 현재 작업이 표시됩니다. 응용 프로그램에 암호화가 필요한 암호 또는 인증서와 같은 항목이 포함되어 있으면 내보내기 프로세스를 수행하는 동안 암호를 입력하라는 메시지가 표시됩니다. 데이터가 크거나 데이터를 원격 서버로 내보내는 경우 내보내기 작업에 시간이 많이 걸릴 수 있습니다.

요약

만들기 프로세스 중 발생한 오류를 비롯하여 수행된 작업에 대한 개요를 제공합니다.

중요
요약 탭에는 수행된 작업이나 발생한 오류에 대한 내용이 모두 포함되어 있지는 않습니다. 세부 정보 탭을 클릭하면 더 자세한 내용을 볼 수 있습니다.

세부 정보

수행된 작업에 대한 자세한 목록이 제공됩니다. 오류가 발생한 경우 이 탭을 클릭하면 문제 해결에 사용할 수 있는 자세한 오류 정보가 표시됩니다.

참고 항목

개념

응용 프로그램 패키지 내보내기 및 서버 패키지 내보내기 마법사 페이지


응용 프로그램 패키지 가져오기 및 서버 또는 사이트 패키지 가져오기 마법사 페이지

패키지 선택 페이지

암호 해독 암호 대화 상자

패키지 콘텐츠 선택 페이지

고급 설정 대화 상자(가져오기)

데이터베이스 선택 페이지

응용 프로그램 패키지 정보 입력 페이지

기존 파일 덮어쓰기 페이지

설치 진행률 및 요약 페이지


패키지 선택 페이지

패키지 선택 페이지를 사용하여 사이트 또는 서버에 설치할 기존 패키지를 선택할 수 있습니다.

UI 요소

요소 이름 | 설명
패키지 경로 | 사이트 또는 서버에 설치할 패키지의 위치를 지정합니다.
찾아보기… | 가져올 패키지 위치를 지정하려면 찾아보기 단추를 클릭합니다.

참고 항목

개념

응용 프로그램 패키지 가져오기 및 서버 또는 사이트 패키지 가져오기 마법사 페이지


암호 해독 암호 대화 상자

응용 프로그램 패키지 가져오기 마법사의 암호 해독 암호 대화 상자를 사용하여 보안으로 표시된 설정이 있는 패키지 콘텐츠에 암호를 제공할 수 있습니다.

UI 요소

요소 이름 | 설명
암호 | 패키지 콘텐츠의 암호를 해독하는 데 필요한 암호를 입력합니다.패키지를 만들 때 일부 설정이 보안으로 표시되었으므로 암호가 필요합니다.패키지를 만들 때 지정한 암호를 제공하지 않으면 패키지를 가져올 수 없습니다.

참고 항목

개념

응용 프로그램 패키지 가져오기 및 서버 또는 사이트 패키지 가져오기 마법사 페이지


패키지 콘텐츠 선택 페이지

응용 프로그램 패키지 가져오기 마법사의 패키지 콘텐츠 선택 페이지를 사용하여 패키지 선택 페이지에서 선택한 패키지에 포함된 구성 요소를 볼 수 있습니다.

패키지에는 레지스트리 설정, COM, GAC 어셈블리 또는 인증서와 같은 구성 요소가 포함될 수 있습니다. 이러한 구성 요소를 서버에 설치하려면 Administrators 그룹의 멤버이거나 적절한 권한을 위임받아야 합니다. 콘텐츠만 설치하는 경우에는 관리자 사용자 권한이 필요하지 않습니다.

UI 요소

요소 이름 설명

패키지에 포함된 항목

패키지에 포함된 구성 요소가 표시됩니다. 해당 구성 요소 확인란을 선택하거나 선택을 취소하여 패키지에서 배포할 항목을 지정할 수 있습니다. 예를 들어 해당 확인란을 선택하거나 선택을 취소하여 SQL 데이터베이스 또는 GAC 어셈블리를 포함하거나 제외할 수 있습니다.

주의
일부 구성 요소는 응용 프로그램에 반드시 필요할 수 있습니다. 이러한 구성 요소 확인란의 선택을 취소하면 설치 후 응용 프로그램이 제대로 작동하지 않을 수 있습니다.

참고 항목

개념

응용 프로그램 패키지 가져오기 및 서버 또는 사이트 패키지 가져오기 마법사 페이지


고급 설정 대화 상자(가져오기)

응용 프로그램 패키지 가져오기 마법사의 고급 설정 대화 상자를 사용하여 패키지 설정을 지정할 수 있습니다.

UI 요소

고급 옵션

요소 이름 | 설명
암호 해독 암호 | 암호 해독 암호 대화 상자를 열고 패키지 콘텐츠의 암호를 해독하는 데 필요한 암호를 입력합니다. 가져오기 작업 중 웹 배포 도구는 사용자 지정 ID가 있는 응용 프로그램 풀과 같은 암호화된 개체가 패키지의 서버 수준 구성 파일(예: ApplicationHost.config 또는 Machine.config)에 있는지 자동으로 검색합니다. 암호화된 개체가 있는 경우 개체에 대한 암호를 제공해야 합니다. 올바른 암호를 지정하지 않으면 가져오기 작업에 실패합니다.
ACL 포함 | 지정한 경로의 ACL이 원본에서 대상으로 복사되는 경우 True를 선택하고, 그렇지 않으면 False를 선택합니다. 이 설정은 파일 시스템, 레지스트리, 메타베이스 및 공급자 중 appHostConfig, contentPath, iisApp, metaKey, webServer 및 webServer60에 적용됩니다. 기본값은 False입니다.
링크 확장 | 오른쪽의 필드를 클릭한 다음 화살표를 클릭하여 링크 확장 드롭다운 목록을 표시합니다. 목록에 있는 확장을 선택하거나 선택을 취소하여 작업에 적용할 링크 확장을 활성화하거나 비활성화합니다. 링크 확장은 작업에서 특정 종류의 데이터를 포함하거나 제외합니다. 사용 가능한 웹 배포 확장은 AppPoolExtension, CertificateExtension, ContentExtension, FrameworkConfigExtension 및 HttpCertConfigExtension입니다. 이러한 확장은 기본적으로 선택됩니다. 링크 확장에 대한 자세한 내용은 웹 배포 링크 확장(페이지는 영문일 수 있음)을 참조하십시오.
재시도 횟수 | 공급자가 실패 후 재시도하는 횟수를 입력합니다. 기본 재시도 횟수는 5입니다. 기본적으로 각 재시도 사이에는 1초의 간격이 유지됩니다. 재시도 횟수 설정은 contentPath 공급자에서만 사용할 수 있습니다.
재시도 간격 | 값을 밀리초 단위로 입력합니다. 이 값은 공급자 재시도 사이의 시간 간격을 지정합니다. 기본값은 1000(1초)입니다. 이 설정은 contentPath 공급자에서만 사용할 수 있습니다.
추적 수준 | 오류 메시지 로그의 세부 정보 수준을 지정하는 값을 드롭다운 목록에서 선택합니다. 가능한 값은 Off, Error, Warning, Info 및 Verbose입니다. 기본값은 Info입니다. Off이면 오류 메시지가 로그에 기록되지 않습니다. Verbose이면 모든 메시지가 로그에 기록됩니다.

동기화 옵션

요소 이름 설명

규칙

작업 규칙을 지정할 수 있는 규칙 활성화 또는 비활성화 대화 상자를 엽니다. 자세한 내용은 규칙 활성화 또는 비활성화 대화 상자를 참조하십시오.

WhatIf

드롭다운 목록을 클릭하여 True 또는 False를 선택합니다. True는 실제로 작업을 변경하지 않고 실행하도록 지정합니다. 이 설정을 사용하여 작업의 모든 부분이 성공한 경우의 작업 결과를 볼 수 있습니다. 기본값은 False입니다.

참고
WhatIf 설정을 사용하여 성공적으로 실행된 것으로 보이는 명령을 WhatIf 설정을 사용하지 않고 실행하는 경우 명령이 실패할 수도 있습니다. 작업 중 예기치 못한 오류가 발생한 경우 이러한 일이 발생할 수 있습니다. 예를 들어 WhatIf 작업 중에는 데이터를 쓰지 않으므로 쓰기 권한 오류는 검색되지 않습니다. WhatIf 설정은 명령의 모든 작업이 성공한 경우에 발생하는 결과만 보여 줍니다.

참고 항목

개념

패키지 콘텐츠 선택 페이지
응용 프로그램 패키지 가져오기 및 서버 또는 사이트 패키지 가져오기 마법사 페이지


데이터베이스 선택 페이지

데이터베이스 선택 페이지를 사용하여 설치하는 패키지에 사용할 데이터베이스 옵션을 선택할 수 있습니다. 패키지에 사용 가능한 데이터베이스 형식이 둘 이상인 경우에만 이 페이지가 표시됩니다.

참고
패키지에 사용 가능한 데이터베이스 형식이 둘 이상이더라도 패키지 콘텐츠 선택 페이지에서 하나의 데이터베이스 형식에 대해서만 확인란을 선택한 경우에는 이 페이지가 표시되지 않습니다.

UI 요소

요소 이름 | 설명
사용할 데이터베이스를 선택하십시오. | 설치에 사용할 데이터베이스 형식을 선택합니다. 가능한 데이터베이스 형식은 SQL, MySQL, VistaDB, SQLite, Flat File 또는 데이터베이스 없음입니다. 설치하는 패키지 콘텐츠에 따라 데이터베이스 옵션이 다르게 표시됩니다. SQL 및 MySQL 옵션에만 연결된 공급자가 포함되어 있습니다. 자세한 내용은 웹 배포 dbFullSql 공급자(페이지는 영문일 수 있음) 및 웹 배포 MySQL 공급자(페이지는 영문일 수 있음)를 참조하십시오.
새 데이터베이스 만들기 또는 기존 데이터베이스 사용 | 새 데이터베이스 만들기를 선택하여 새 데이터베이스를 만들거나 기존 데이터베이스 사용을 선택하여 기존 데이터베이스를 사용합니다. 이 옵션은 데이터베이스 형식으로 SQL 또는 MySQL을 선택한 경우에만 활성화됩니다.

참고 항목

개념

응용 프로그램 패키지 가져오기 및 서버 또는 사이트 패키지 가져오기 마법사 페이지
응용 프로그램 패키지 정보 입력 페이지


응용 프로그램 패키지 정보 입력 페이지

응용 프로그램 패키지 가져오기 마법사의 응용 프로그램 패키지 정보 입력 페이지를 사용하여 패키지에 선언된 매개 변수의 값을 지정할 수 있습니다.각 매개 변수에 대한 필드가 페이지에 표시됩니다.페이지에 표시되는 필드는 패키지에 선언된 매개 변수에 의해 결정됩니다.

UI 요소

요소 이름 | 설명
<매개 변수 이름> | 패키지를 설치하는 데 필요한 매개 변수 값을 지정합니다.이 정보에는 응용 프로그램을 설치할 전체 사이트 경로, 사용자 자격 증명 또는 응용 프로그램 데이터베이스 이름이 포함될 수 있습니다.예를 들어 응용 프로그램 경로 값을 변경하여 응용 프로그램을 설치할 위치를 기본 웹 사이트/NewApp와 같이 지정할 수 있습니다.

참고 항목

개념

연결 문자열 편집 대화 상자


연결 문자열 편집 대화 상자

연결 문자열 편집 대화 상자를 사용하여 사용할 연결 문자열 및 자격 증명을 지정할 수 있습니다.

UI 요소

요소 이름 | 설명
SQL 서버 | 지정하는 SQL 서버를 사용하려면 이 옵션을 선택합니다.
서버 | 사용할 서버의 경로 또는 연결 문자열을 입력합니다(예: .\SQLExpress).
데이터베이스 | 사용할 데이터베이스의 이름을 입력합니다(예: Test).
Windows 통합 보안 사용 | Windows 통합 보안을 사용하려면 이 옵션을 선택합니다.Windows 통합 보안에서는 사용자가 이미 Windows에 로그인한 경우 재인증을 요청하지 않고 사용자 자격 증명을 ASP.NET에 전달합니다.이 인증 방법은 클라이언트와 서버가 같은 도메인에 있는 경우에 가장 잘 작동합니다.
자격 증명 지정 | 사용자가 지정한 자격 증명을 사용하려면 이 옵션을 선택합니다.설정을 클릭하여 자격 증명 설정 대화 상자를 열고 사용자 이름 및 암호를 지정합니다.
사용자 지정 | 사용할 서버의 사용자 지정 경로 또는 연결 문자열을 지정하려면 이 옵션을 선택합니다(예: Server=.\SQLExpress;Database=Test;Integrated Security=true).

참고 항목

개념

응용 프로그램 패키지 가져오기 및 서버 또는 사이트 패키지 가져오기 마법사 페이지
응용 프로그램 패키지 정보 입력 페이지


기존 파일 덮어쓰기 페이지

기존 파일 덮어쓰기 페이지를 사용하여 새 파일을 대상에 추가할지 아니면 기존 파일을 덮어쓰고 응용 프로그램 패키지에 포함되지 않은 파일을 삭제할지를 결정할 수 있습니다.

UI 요소

요소 이름 | 설명
아니요, 응용 프로그램 패키지의 파일을 대상에 추가합니다. | 이 옵션을 선택하면 대상에서 기존 파일을 보존하고 응용 프로그램 패키지의 새 파일을 추가합니다.
예, 대상에서 응용 프로그램 패키지에 속하지 않은 모든 기타 파일 및 폴더를 삭제합니다. | 응용 프로그램 패키지에 포함되지 않은 파일을 대상에서 삭제하려면 이 옵션을 선택합니다.

참고 항목

개념

응용 프로그램 패키지 가져오기 및 서버 또는 사이트 패키지 가져오기 마법사 페이지


설치 진행률 및 요약 페이지

설치 진행률 및 요약 페이지를 사용하여 가져오기 프로세스의 상태를 모니터링하고 마법사가 종료된 뒤 작업의 요약 및 자세한 정보를 볼 수 있습니다.

UI 요소

요소 이름 설명

상태

상태 영역에는 파일 복사 또는 데이터베이스 스크립트 작업 등 수행 중인 현재 작업이 표시됩니다.응용 프로그램에 암호 해독이 필요한 암호 또는 인증서 등의 항목이 포함되어 있으면 가져오기 프로세스를 수행하는 동안 암호를 입력하라는 메시지가 표시됩니다.데이터가 크거나 데이터를 원격 서버에서 가져오는 경우 가져오기 작업에 시간이 많이 걸릴 수 있습니다.

요약

설치 프로세스 중 발생한 오류를 비롯하여 수행된 작업에 대한 개요를 제공합니다.

중요
요약 탭에는 수행된 작업이나 발생한 오류에 대한 내용이 모두 포함되어 있지는 않습니다.세부 정보 탭을 클릭하면 더 자세한 내용을 볼 수 있습니다.

세부 정보

수행된 작업에 대한 자세한 목록이 제공됩니다.오류가 발생한 경우 이 탭을 클릭하면 문제 해결에 사용할 수 있는 자세한 오류 정보가 표시됩니다.

참고 항목

개념

응용 프로그램 패키지 가져오기 및 서버 또는 사이트 패키지 가져오기 마법사 페이지