Visão geral da Ferramenta de Implantação da Web para o Gerenciador do IIS

A Ferramenta de Implantação da Web (Web Deploy) sincroniza a configuração do IIS, o conteúdo, os certificados SSL e outros tipos de dados de um site especificado pelo usuário para um destino especificado pelo usuário. Também é possível implantar objetos, como chaves de registro, que não estão incluídos por padrão.

Delegação de Serviço de Gerenciamento

No IIS Manager, o Web Deploy adiciona um recurso exclusivo de administradores no nível do servidor chamado Delegação de Serviço de Gerenciamento, que permite que você controle com alto nível de precisão as ações que os usuários remotos podem realizar. Para obter mais informações, consulte Página Delegação de Serviço de Gerenciamento.

Exportação e Importação de Aplicativos

No painel IIS Manager Ações, você pode usar o Assistente de Exportação do Pacote de Aplicativo da ferramenta para criar arquivos compactados (pacotes) contendo seus sites, aplicativos e conteúdos. Para obter mais informações, consulte Páginas do Assistente de Exportação de Pacote de Aplicativo e Exportação de Servidor.

Após a exportação de um pacote, você pode usar o Assistente de Importação do Pacote de Aplicativo para instalar os conteúdos do pacote em uma localização diferente. Para obter mais informações, consulte Páginas do Assistente de Importação de Pacote de Aplicativo e Importação de Servidor ou Pacote de Site.

Recursos de linha de comando

O programa executável Msdeploy.exe da Ferramenta de Implantação da Web oferece diversos recursos avançados de linha de comando. Para ajuda do resumo sobre os recursos do Msdeploy.exe, digite msdeploy -help em uma janela de Prompt de Comando. Para mais ajuda detalhada online, consulte Web Deployment Tool (pode estar disponível somente em inglês).

Recursos Online Adicionais

IIS.NET: Ferramenta de Implantação da Web

IIS.NET: Fórum da Ferramenta de Implantação da Web

IIS.NET: Publicações no blog da equipe de Implantação da Web da Microsoft


Ajuda da interface do usuário da Ferramenta de Implantação da Web

IIS Manager fornece descrições de todos os elementos da interface do usuário em todas as página de recurso, caixas de diálogo e páginas do Assistente em IIS Manager. Para exibir a ajuda, pressione F1 na página de recurso, caixa de diálogo ou página do Assistente ativa.

Nesta seção

Página Delegação de Serviço de Gerenciamento

Páginas do Assistente de Exportação de Pacote de Aplicativo e Exportação de Servidor

Páginas do Assistente de Importação de Pacote de Aplicativo e Importação de Servidor ou Pacote de Site


Página Delegação de Serviço de Gerenciamento

Use a página Delegação de Serviço de Gerenciamento para especificar as regras que controlam os direitos de implantação do usuário remoto. A página Delegação de Serviço de Gerenciamento só pode ser usada por administradores e aparece somente no nível do servidor.

Elementos da interface do usuário

Nome do elemento | Descrição
Provedor | Exibe o provedor ou os provedores aos quais a regra se aplica.
Caminho | Exibe o caminho ao qual a regra se aplica.
Tipo de Caminho | Exibe o tipo de regra do caminho. Os valores possíveis são PathPrefix, StringPrefix, StringSuffix, ConnectionString e RegularExpression.
Ações | Exibe as ações a serem executadas pela regra. Para os provedores Web Deploy, os valores típicos são Leitura, Gravação e *.
Tipo de Identidade | Exibe o tipo de identidade na qual a regra será executada. Os valores possíveis são CurrentUser, ProcessIdentity e SpecificUser.
Nome de Usuário | Exibe o nome de usuário quando SpecificUser for selecionado como tipo de identidade. Quando o tipo de identidade é CurrentUser ou ProcessIdentity, nenhum nome de usuário é exibido.
Estado | Exibe se a regra está habilitada ou não. Para habilitar ou desabilitar a regra, clique em Habilitar Regra ou Desabilitar Regra no painel Ações.

Elementos do painel Ações

Nome do elemento | Descrição
Adicionar Regra… | Abre a caixa de diálogo Adicionar Regra. Selecione essa opção para adicionar uma regra. Para obter mais informações, consulte Caixa de diálogo Adicionar Regra (Delegação de Serviço de Gerenciamento).
Adicionar Usuário à Regra… | Abre a caixa de diálogo Adicionar Usuário à Regra. Para obter mais informações, consulte Caixa de diálogo Adicionar Usuário à Regra.
Editar... | Abre a caixa de diálogo Editar Regra. Para obter mais informações, consulte Caixas de diálogo Adicionar ou Editar Regra.
Remover | Remove a regra de delegação ou o usuário de regra de delegação selecionado.
Desabilitar Regra | Desabilita a regra de delegação selecionada.
Habilitar Regra | Habilitar a regra de delegação selecionada.
Editar Configurações de Recurso... | Abre a caixa de diálogo Editar Configurações de Recurso. Para obter mais informações, consulte Caixa de diálogo Editar Configurações de Recurso (Delegação de Serviço de Gerenciamento).


Caixa de diálogo Adicionar Regra (Delegação de Serviço de Gerenciamento)

Use a caixa de diálogo Selecionar Modelo de Regra para escolher um modelo que pode ser usado para criar uma regra de delegação personalizada. Você pode optar por um modelo em branco ou por um modelo instalado projetado para cenários específicos.

Elementos da interface do usuário

Modelos instalados

Nome do elemento Descrição

Regra em branco

Cria uma regra em branco personalizável.

Implantar Somente Conteúdo

Cria uma regra que habilita a implantação de conteúdo. A regra habilitará qualquer usuário do WMSvc (Serviço de Gerenciamento da Web) autorizado a publicar conteúdo em um caminho no qual o usuário já possua autorização WMSvc. É possível editar a regra para restringir o acesso a um caminho ou usuário específico. Essa regra usa o provedor contentPath, que sincroniza o conteúdo do site. Para obter mais informações, consulte Web Deploy contentPath Provider (pode estar disponível somente em inglês).

Implantar aplicativos com conteúdo

Cria uma regra que habilita as implantações de aplicativo. Este modelo não inclui uma regra para marcar uma pasta como um aplicativo, mas é bastante usada combinada a essa regra. A regra habilitará qualquer usuário WMSvc autorizado a publicar um aplicativo em um caminho no qual o usuário já possua autorização WMSvc. É possível editar a regra para restringir o acesso a um caminho ou usuário específico. Essa regra usa os provedores contentPath e iisApp. Para obter mais informações, consulte Web Deploy contentPath Provider (pode estar disponível somente em inglês) e Web Deploy iisApp Provider (pode estar disponível somente em inglês).

Implantar bancos de dados

Cria uma regra que habilita a implantação de um banco de dados. A regra habilita todos os usuários WMSvc autorizados a publicar em qualquer banco de dados ao qual tenham acesso. O modelo especifica que a conta que está sendo usada é CurrentUser, o que significa que a cadeia de conexão será usada para autenticar o usuário no servidor do banco de dados. Uma regra pode ser editada para restringir o acesso para um servidor de banco de dados ou nome específicos. Essa regra usa o provedor dbFullSql, o que permite a publicação de bancos de dados pela primeira vez de um banco de dados de desenvolvimento SQL Server local para um banco de dados SQL Server hospedado remotamente. Para obter mais informações, consulte Web Deploy dbFullSql Provider (pode estar disponível somente em inglês).

Marcar pastas como aplicativos

Cria uma regra que marca uma pasta como um aplicativo. A regra habilitará qualquer usuário WMSvc autorizado a marcar uma pasta como um aplicativo. Se o usuário não for um administrador, será necessário alterar o tipo de identidade para uma conta que tenha acesso de gravação ao arquivo ApplicationHost.config. O tipo de identidade padrão para a regra é SpecificUser. Essa regra usa o provedor createApp, o que é necessário para marcar pastas como aplicativos e cuja funcionalidade está incluída no provedor iisApp. Para obter mais informações, consulte Web Deploy Providers (pode estar disponível somente em inglês).

Definir Permissões para Aplicativos

Cria uma regra que define ACLs para um caminho de aplicativo. A regra habilitará qualquer usuário WMSvc autorizado a definir ACLs do sistema de arquivos para um caminho no qual o usuário já possua autorização WMSvc. O modelo especifica que a conta que está sendo usada é CurrentUser, o que significa que o usuário precisa ter permissões antes que possa alterar as ACLs. É possível editar a regra para restringir o acesso a um caminho ou usuário específico. A regra usa o provedor setAcl, que define permissões em uma pasta de destino. Para obter informações, consulte Web Deploy setAcl Provider (pode estar disponível somente em inglês) .

Backup e Restauração de Banco de Dados (Usando a Autenticação SQL)

Cria uma regra que faz o backup e restaura bancos de dados usando a autenticação SQL. A regra habilitará qualquer usuário WMSvc autorizado a criar ou restaurar um backup do banco de dados ao qual o usuário já possua acesso. As operações de backup e restauração serão executadas como uma identidade de usuário específico usando a autenticação SQL. A regra pode ser editada para restringir o acesso a um banco de dados ou grupo de usuários específico.

Observação

Use esse modelo com a extensão Gerenciador de Banco de Dados do IIS. Para obter mais informações sobre o IIS Database Manager, consulte Gerenciador de Banco de Dados.

Backup e Restauração de Bancos de Dados (Usando a Segurança Integrada do Windows)

Cria uma regra que faz backup e restaura bancos de dados usando a autenticação do Windows. A regra habilitará qualquer usuário WMSvc autorizado a criar ou restaurar um backup do banco de dados ao qual o usuário já possua acesso. A regra pode ser editada para restringir o acesso a um banco de dados ou grupo de usuários específico.

Observação

Use esse modelo com a extensão Gerenciador de Banco de Dados do IIS. Para obter mais informações sobre o IIS Database Manager, consulte Gerenciador de Banco de Dados.

Consulte também

  • Páginas do Assistente de Importação de Pacote de Aplicativo e Importação de Servidor ou Pacote de Site
  • Web Deploy Providers (pode estar disponível somente em inglês)


Caixas de diálogo Adicionar ou Editar Regra

Use as caixas de diálogo Adicionar Regra e Editar Regra para adicionar e editar regras de delegação.

Elementos da interface do usuário

Nome do elemento | Descrição
Provedores | Clique na lista suspensa para marcar ou desmarcar os provedores que deseja adicionar ou remover da regra e clique na seta suspensa para aceitar as alterações. Os provedores serão exibidos em uma lista separada por vírgula. Para obter mais informações sobre os provedores Web Deploy, consulte Provedores Web Deploy (pode estar disponível somente em inglês).
Ações | Clique na lista suspensa para selecionar ou desmarcar as ações que deseja adicionar ou remover da regra e clique na seta suspensa para aceitar as alterações. Os ações serão exibidas em uma lista separada por vírgula. Os valores comuns para Web Deploy são Leitura, Gravação e *.
Tipo de Caminho | Selecione um tipo de caminho na lista suspensa. Os valores possíveis são PathPrefix, StringPrefix, StringSuffix, ConnectionString e RegularExpression. Para obter mais informações sobre expressões regulares, consulte Expressões regulares.
Caminho | Digite o caminho ao qual a regra se aplicará.
Tipo de Identidade | Selecione o tipo de identidade da regra a partir da lista suspensa. A identidade selecionada executará a regra. Os valores possíveis são CurrentUser, ProcessIdentity e SpecificUser. CurrentUser especifica que a identidade do usuário atual será usada. ProcessIdentity especifica que a identidade do serviço local WMSvc será usada. SpecificUser especifica que uma identidade especial designada por você será usada. Se você selecionar SpecificUser, deve fornecer as credenciais usando o botão Especificar Credenciais Definir.
Especificar Credenciais | Habilita o botão Definir quando você seleciona SpecificUser como o tipo de identidade.
Definir | Abre a caixa de diálogo Definir Credenciais, que permite que você especifique um nome de usuário e senha para a identidade SpecificUser. Para obter mais informações, consulte Caixa de diálogo Definir Credenciais.


Caixa de diálogo Definir Credenciais

Use a caixa de diálogo Definir Credenciais para fornecer um nome de usuário e senha para um usuário Windows que executará a regra.

Elementos da interface do usuário

Nome do Elemento | Descrição
Nome de usuário | Digite o nome de usuário de um usuário Windows.
Senha | Digite a senha.
Confirmar senha | Digite a senha novamente para confirmá-la.

Consulte também

  • Caixas de diálogo Adicionar ou Editar Regra


Caixa de diálogo Adicionar Usuário à Regra

Use a caixa de diálogos Adicionar Usuário à Regra para permitir ou negar o acesso de um usuário a uma regra.

Elementos da interface do usuário

Nome do elemento | Descrição
Nome | Digite o nome de usuário.
Tipo de Acesso | Seleciona o tipo de acesso que deve ser concedido ao usuário especificado. Os valores possíveis são Permitir e Negar.
É uma função? | Marque esta caixa de seleção se o nome de usuário especificado for um alias para um grupo de usuários que terá acesso permitido ou negado.


Caixa de diálogo Editar Configurações de Recurso (Delegação de Serviço de Gerenciamento)

Use a caixa de diálogo Editar Configurações de Recurso para permitir que todos os administradores ignorem as regras de delegação e habilitar o registro em log de solicitações falhas.

Elementos da interface do usuário

Nome do elemento Descrição

Permitir que administradores ignorem regras

Selecione essa opção para permitir que os administradores ignorem as regras de delegação especificadas.

Habilitar logs de rastreamento de solicitações falhas para o serviço de delegação

Selecione essa opção para habilitar o registro em log de informações de solicitações falhas.

Aviso

Para usar esse recurso, o módulo de rastreamento de solicitações falhas deve estar instalado.


Páginas do Assistente de Exportação de Pacote de Aplicativo e Exportação de Servidor

Página Selecionar o Conteúdo do Pacote

Página Selecionar Parâmetros

Página Salvar Pacote

Caixa de diálogo Criptografar Senha

Página Progresso e Resumo da Exportação


Página Selecionar o Conteúdo do Pacote

Use a página Selecionar o Conteúdo do Pacote do Assistente de Exportação de Pacote de Aplicativo para exibir os componentes incluídos no pacote que você deseja criar.

Os pacotes podem conter componentes como as configurações do Registro, COM, assemblies GAC ou certificados. Para instalar esses componentes no servidor, você deve ser membro do grupo Administradores ou ter sido delegado a autoridade apropriada. Não é necessário ter direitos de usuário administrador para instalar somente conteúdo.

Elementos da interface do usuário

Nome do elemento Descrição

Pacote contém

Lista os componentes incluídos no pacote. Você pode especificar o que deseja incluir no pacote marcando ou desmarcando as caixas de seleção do componente apropriado. Por exemplo, você pode incluir ou excluir um banco de dados SQL ou um assembly GAC marcando ou desmarcando a caixa de seleção correspondente.

Cuidado

Alguns componentes podem ser obrigatórios para o aplicativo. Se você desmarcar as caixas de seleção desses componentes, o aplicativo poderá não funcionar corretamente após a instalação.

Atributos

Exibe, no painel direito, os atributos do arquivo, diretório ou componente selecionado. Esses valores são somente leitura.

Gerenciar Componentes…

Abre a caixa de diálogo Gerenciar Componentes. Isso permite que você selecione os componentes que deseja incluir. Para obter mais informações, consulte Caixa de diálogo Gerenciar Componentes.

Configurações Avançadas...

Abre a caixa de diálogo Configurações Avançadas. Isso permite que você especifique regras e configurações de operação. Para obter mais informações, consulte Caixa de diálogo Configurações Avançadas (Exportar).

Consulte também

  • Páginas do Assistente de Exportação de Pacote de Aplicativo e Exportação de Servidor
  • Export a Package through IIS Manager (recurso online; pode estar disponível somente em inglês)


Caixa de diálogo Gerenciar Componentes

Use a caixa de diálogo Gerenciar Componentes do Assistente de Exportação de Pacote de Aplicativo para adicionar componentes, como objetos COM ou assemblies GAC, ao seu pacote.

Elementos da interface do usuário

Títulos de coluna

Nome do elemento Descrição

Nome do Provedor

Especifica o componente que você deseja empacotar. Cada componente tem um provedor. Clique no campo para usar a lista suspensa para selecionar um nome de provedor. Focalize um nome de provedor para ver uma respectiva descrição. Por exemplo, se você selecionar dbFullSql, empacotará o caminho de um script ou uma cadeia de conexão. Para obter mais informações sobre os provedores, consulte Web Deploy Providers (pode estar disponível somente em inglês).

Importante

Se você estiver empacotando um site, o provedor iisApp (selecionado por padrão) marcará o site como um aplicativo no destino. Se desejar empacotar um site e todas as suas configurações relacionadas (como o nome do pool de aplicativos, a localização do diretório de conteúdo e todos os certificados), use o provedor appHostConfig. Se você usar o provedor iisApp, o site se tornará um aplicativo no destino que herda todas as suas configurações (como nome do pool de aplicativos e o diretório de conteúdo) do site em que está instalado.

Caminho

Especifica o caminho do componente que fornecerá os dados para o pacote. Por exemplo, se você selecionar dbFullSql, o caminho poderá especificar um script como C:\SQLfiles\installSQL.sql ou uma cadeia de conexão como Data Source=.\sqlexpress;Integrated Security=SSPI;Initial Catalog=db1.

Configurações do Provedor

Especifica as configurações do provedor que você deseja usar para o provedor selecionado. Clique no campo para usar o botão Procurar (…) para abrir a caixa de diálogo Configurações do Provedor. Para obter mais informações, consulte Caixa de diálogo Configurações do Provedor.

Botões

Nome do elemento | Descrição
Remover | Exclui a entrada selecionada.
Mover para Cima | Move a linha selecionada para cima na lista. As entradas serão instaladas na ordem em que aparecem na lista. A ordem das entradas é importante para alguns provedores. Por exemplo, é necessário executar um script para criar uma tabela antes de criar um script para preenchê-la.
Mover para Baixo | Move a linha selecionada para baixo na lista. As entradas serão instaladas na ordem em que aparecem na lista.

Consulte também

  • Página Selecionar o Conteúdo do Pacote
  • Páginas do Assistente de Exportação de Pacote de Aplicativo e Exportação de Servidor


Caixa de diálogo Configurações do Provedor

Use a caixa de diálogo Configurações do Provedor para definir configurações específicas para o provedor selecionado. Nem todos os provedores possuem configurações.

Elementos da interface do usuário

Nome do elemento | Descrição
Nome da configuração | Exibe o nome da configuração para o provedor selecionado. Somente as configurações relevantes ao provedor selecionado são listadas.
Valor da configuração | Digite ou selecione um valor para a configuração. Se uma lista suspensa estiver disponível, os valores possíveis para a configuração aparecerão nela. Para os valores que devem ser digitados, a caixa de descrição fornece informações sobre os valores aceitáveis.
Descrição da configuração | Exibe uma descrição da configuração selecionada para o provedor. Fornece informações sobre os valores permitidos para a configuração.

Consulte também

  • Caixa de diálogo Gerenciar Componentes
  • Página Selecionar o Conteúdo do Pacote
  • Páginas do Assistente de Exportação de Pacote de Aplicativo e Exportação de Servidor
  • Configurações do provedor Web Deploy


Caixa de diálogo Configurações Avançadas (Exportar)

Use a caixa de diálogo Configurações avançadas do Assistente de Exportação do Pacote de Aplicativo para especificar as configurações para seu pacote.

Elementos da interface do usuário

Opções avançadas

Nome do elemento Descrição

Criptografar Senha

Clique em … para abrir a caixa de diálogo Criptografar Senha para especificar uma senha alfanumérica que controla o acesso a propriedades protegidas na configuração do IIS.

O Web Deploy detecta automaticamente se um objeto criptografado, como um pool de aplicativos com uma identidade personalizada, está presente nos arquivos de configuração no nível do servidor (por exemplo, ApplicationHost.config ou Machine.config). Se um objeto criptografado estiver presente, você deve fornecer uma senha para ele. Se a senha correta não for especificada, o processo de exportação falhará.

Importante

O Web Deploy não verifica objetos criptografados em arquivos Web.config.

Incluir ACLs

Marque Verdadeiro se as ACLs do caminho especificado serão copiadas da origem para o destino. Caso contrário, marque Falso. Essa configuração se aplica ao sistema de arquivos, ao registro e à metabase e somente aos seguintes provedores: appHostConfig, contentPath, iisApp, metaKey, webServer, e webServer60. O padrão é falso.

Extensão de Link

Clique no campo à direita e em seguida clique na seta para mostrar a lista suspensa de extensões de link. Marque ou desmarque as extensões na lista para habilitar ou desabilitar as extensões de link que deseja aplicar à operação. As extensões de link incluem ou excluem tipos específicos de dados em uma operação. As extensões Web Deploy disponíveis são AppPoolExtension, CertificateExtension, ContentExtension, FrameworkConfigExtension e HttpCertConfigExtension. Essas extensões estão selecionadas por padrão. Para obter mais informações sobre extensões de link, consulte Web Deploy Link Extensions (pode estar disponível somente em inglês).

Tentativas de Repetição

Digite o número de vezes que o provedor tentará novamente após uma falha. O número padrão de tentativas é 5. Por padrão, existe um intervalo de um segundo entre cada tentativa. As tentativas de repetição só podem ser usadas com o provedor contentPath.

Intervalo de tentativas

Digite um valor em milissegundos. O valor especificará o intervalo de tempo entre as tentativas de repetição do provedor. O padrão é 1000 (um segundo). Essa configuração só pode ser usada com o provedor contentPath.

Nível de Rastreamento

Selecione um valor a partir da lista suspensa para especificar o nível de detalhe nos logs das mensagens de erro. Os valores possíveis são Desativado, Erro, Aviso, Informações e Detalhado. O padrão é Informações. Desativado significa que não serão registradas mensagens de erro. Detalhado significa que todas as mensagens de erro serão registradas.

Opções de sincronização

Nome do elemento Descrição

Regras

Abre a caixa de diálogo Habilitar ou Desabilitar Regras que permite que você especifique regras para a operação. Para obter mais informações, consulte Caixa de diálogo Habilitar ou Desabilitar Regras.

WhatIf

Clique na lista suspensa para marcar True ou False. True especifica que a operação será executada sem que seja feita qualquer alteração. Será possível usar essa configuração para ver os resultados de uma operação se todas as partes da operação tiverem êxito. O valor padrão é False.

Observação

Um comando que parece ter sido executado com êxito com a configuração WhatIf pode falhar quando for executado sem usar essa configuração. Isso pode acontecer se erros inesperados ocorrerem durante a operação. Por exemplo, como não são gravados dados durante uma operação WhatIf, os erros de permissão de gravação não serão detectados. A configuração WhatIf mostra somente o que irá acontecer se todas as operações no comando tiverem êxito.

Consulte também

  • Página Selecionar o Conteúdo do Pacote
  • Páginas do Assistente de Exportação de Pacote de Aplicativo e Exportação de Servidor


Caixa de diálogo Habilitar ou Desabilitar Regras

Use a caixa de diálogo Habilitar ou Desabilitar Regras para habilitar ou desabilitar regras que afetam o resultado da operação de sincronização. Selecione Estado na lista suspensa Agrupar por para agrupar regras nas categorias habilitadas e desabilitadas ou Sem Agrupamento para exibir as regras em ordem alfabética.

Elementos da interface do usuário

Títulos de coluna

Nome do elemento | Descrição
Nome | Lista os nomes das regras de sincronização que você pode habilitar ou desabilitar. As regras que estão em negrito estão habilitadas por padrão, as regras que estão em cinza estão desabilitadas por padrão. Para habilitar ou desabilitar uma regra, selecione a regra e use os botões Habilitar Regra ou Desabilitar Regra. Para obter mais informações sobre essas regras, consulte Web Deploy Rules (pode estar disponível somente em inglês).

Botões

Nome do elemento | Descrição
Habilitar Regra | Habilita a regra selecionada.
Desabilitar Regra | Desabilita a regra selecionada.

Consulte também

  • Páginas do Assistente de Exportação de Pacote de Aplicativo e Exportação de Servidor
  • Páginas do Assistente de Importação de Pacote de Aplicativo e Importação de Servidor ou Pacote de Site


Página Selecionar Parâmetros

Use a página Selecionar Parâmetros do Assistente de Exportação de Pacote de Aplicativo para adicionar ou remover parâmetros do seu pacote. É possível atribuir um parâmetro a um atributo quando o pacote é criado. Posteriormente, quando o pacote é instalado, o usuário pode especificar um valor personalizado para o parâmetro e esse novo valor será designado ao atributo. Os parâmetros são gerados automaticamente para cada provedor.

Elementos da interface do usuário

Títulos de coluna

Nome do elemento | Descrição
Nome | Lista os nomes dos parâmetros já adicionados usando a caixa de diálogo Adicionar Parâmetro. Para editar um parâmetro, clique duas vezes no parâmetro ou selecione-o e clique em Editar.
Tipo | Exibe o tipo de parâmetro do atributo que será parametrizado.
Escopo | Exibe o escopo do atributo que será parametrizado.
Correspondência | Exibe a expressão correspondente que identificará o atributo a ser parametrizado.

Botões

Nome do elemento Descrição

Adicionar Parâmetro

Abre a caixa de diálogo Adicionar Parâmetro. Isso permite adicionar um parâmetro e definir suas propriedades. Para obter mais informações, consulte Caixa de diálogo Adicionar ou Editar Parâmetro.

Adicionar Entrada de Parâmetro

Abre a caixa de diálogo Adicionar Entrada de Parâmetro. Isso permite configurar os valores de Tipo, Escopo e Correspondência do parâmetro selecionado. Para obter mais informações, consulte Caixa de diálogo Adicionar Parâmetro de Entrada. Essa opção é habilitada quando um parâmetro ou uma entrada de parâmetro é selecionada.

Editar

Se um parâmetro está selecionado, esse botão abre a caixa de diálogo Editar Parâmetro. Isso permite editar as propriedades de um parâmetro existente. Para obter mais informações, consulte Caixa de diálogo Adicionar ou Editar Parâmetro.

Se uma entrada de parâmetro está selecionada, esse botão abre a caixa de diálogo Editar Entrada de Parâmetro. Para obter mais informações, consulte Caixa de diálogo Editar Entrada de Parâmetro.

Remover

Remove o parâmetro selecionado.

Mover para Cima

Move o parâmetro selecionado para cima na lista de parâmetros. Os parâmetros são processados na ordem em que aparecem na lista.

Mover para Baixo

Move o parâmetro selecionado para baixo na lista de parâmetros. Os parâmetros são processados na ordem em que aparecem na lista.

Consulte também

  • Páginas do Assistente de Exportação de Pacote de Aplicativo e Exportação de Servidor


Caixa de diálogo Adicionar ou Editar Parâmetro

Use as caixas de diálogo Adicionar Parâmetro ou Editar Parâmetro para adicionar um novo parâmetro ao seu pacote de aplicativo ou editar um parâmetro existente.

Elementos da interface do usuário

Nome do elemento Descrição

Nome

Digite um nome para o seu parâmetro. Por exemplo, Cadeia de Conexão.

Valor Padrão

Digite um valor padrão para o parâmetro. Quando o pacote é implantado posteriormente, o parâmetro terá esse valor a menos que o usuário especifique um valor diferente. Por exemplo, se você digitou Cadeia de Conexão como o nome do parâmetro, você pode usar Data Source=.\SQLExpress;Database=Test;Integrated Security como valor padrão. Essa entrada não é obrigatória.

Importante

Para obrigar o usuário a fornecer um valor para o parâmetro, não especifique um valor padrão.

Marcas

Digite uma lista de atributos personalizados separados por vírgulas. As marcas são atributos opcionais do parâmetro que podem ser referenciados posteriormente. Por exemplo, seu parâmetro pode ser marcado como uma senha para que uma interface do usuário não exiba o valor da senha. Essa entrada não é obrigatória. Usando o exemplo na descrição do elemento Valor Padrão, você pode usar as marcas SQL, SQLConnectionString para o parâmetro Cadeia de Conexão.

Descrição

Insira uma descrição para seu parâmetro. Por exemplo, "Essa é a cadeia de conexão para o banco de dados usado pelo seu aplicativo. Altere-o se seu ambiente possuir um servidor SQL ou um banco de dados diferente". A descrição será colocada no arquivo Parameters.xml dentro do pacote e pode ser exibida em um prompt de comando digitando msdeploy -verb:getParameters -source:package=<Nome_do_arquivo_do_pacote>.

Tipo

Opcionalmente, selecione um tipo de validação de parâmetro. Valores possíveis são Nenhum, Expressão Regular, Enumeração ou Boolean. O valor padrão é Nenhum. Se um tipo de validação de parâmetro diferente de Nenhum for selecionado, o valor do parâmetro fornecido pelo usuário será verificado para conferir se ele corresponde às condições especificadas. Se Expressão Regular ou Enumeração forem selecionados, uma cadeia de validação deve ser fornecida na caixa Cadeia de Validação.

Cadeia de Validação

Digite uma expressão regular ou uma lista de valores de enumeração separados por vírgulas. Para obter mais informações sobre Expressões Regulares, consulte Expressões Regulares.

Consulte também

  • Página Selecionar Parâmetros
  • Páginas do Assistente de Exportação de Pacote de Aplicativo e Exportação de Servidor


Caixa de diálogo Adicionar Parâmetro de Entrada

Use a caixa de diálogo Adicionar Entrada de Parâmetro para especificar os valores de Tipo, Escopo e Correspondência do parâmetro.

Elementos da interface do usuário

Nome do elemento | Descrição
Tipo | Use a lista suspensa para selecionar o tipo de parâmetro que você deseja usar para o atributo que será parametrizado. Os tipos de parâmetro possíveis são Arquivo Xml, Arquivo de Texto, Posição do Arquivo de Texto, Caminho do Provedor, Atributo de Implantação, Associação de Destino e Diretório Virtual de Destino. Por exemplo, se você criar um parâmetro de Cadeia de Conexão, é possível selecionar Arquivo Xml na lista suspensa, pois a cadeia de conexão estará localizada em um arquivo Web.config, que está no formato XML.
Escopo | Insere um escopo para o atributo que será parametrizado. Esse valor é uma expressão regular obrigatória. Por exemplo, se Xml File é o tipo de parâmetro, é possível usar a expressão regular \\web.config$ para o escopo. A primeira barra invertida é o caractere de escape da segunda barra invertida e o cifrão ($) interrompe a sequência de correspondência no final da linha. Assim, "\web.config" será o escopo resultante. Para obter mais informações sobre expressões regulares, consulte Expressões regulares.
Correspondência | Digite uma expressão que identificará o atributo a ser parametrizado. Esse valor depende do tipo. Em alguns casos, será uma expressão regular ou uma expressão XPath. O tipo Xml File requer que o valor correspondente seja uma expressão XPath. Seguindo o exemplo anterior, você pode usar a expressão XPath //cadeias_de_Conexão/adicionar/@cadeia_de_Conexão para corresponder à cadeia de conexão em um arquivo Web.config.

Consulte também

  • Página Selecionar Parâmetros
  • Páginas do Assistente de Exportação de Pacote de Aplicativo e Exportação de Servidor


Caixa de diálogo Editar Entrada de Parâmetro

Use a caixa de diálogo Editar Entrada de Parâmetro para editar os valores de Tipo, Escopo e Correspondência do parâmetro. Caso ainda não tenha criado um parâmetro, consulte Caixa de diálogo Adicionar ou Editar Parâmetro.

Elementos da interface do usuário

Nome do elemento | Descrição
Tipo | Use a lista suspensa para alterar o tipo de parâmetro. Os tipos de parâmetro possíveis são Arquivo Xml, Arquivo de Texto, Posição do Arquivo de Texto, Caminho do Provedor, Atributo de Implantação, Associação de Destino e Diretório Virtual de Destino. Por exemplo, se você criar um parâmetro de Cadeia de Conexão, é possível selecionar Arquivo Xml na lista suspensa, pois a cadeia de conexão estará localizada em um arquivo Web.config, que está no formato XML.
Escopo | Edita um escopo para o atributo que será parametrizado. Esse valor é uma expressão regular obrigatória. Por exemplo, se Arquivo Xml é o tipo de parâmetro, é possível usar a expressão regular \\web.config$ para o escopo. A primeira barra invertida é o caractere de escape da segunda barra invertida e o cifrão ($) interrompe a sequência de correspondência no final da linha. Assim, "\web.config" será o escopo resultante. Para obter mais informações sobre expressões regulares, consulte Expressões regulares.
Correspondência | Edita a expressão que identifica o atributo a ser parametrizado. Esse valor depende do tipo. Em alguns casos, será uma expressão regular ou uma expressão XPath. O tipo Xml File requer que o valor correspondente seja uma expressão XPath. Seguindo o exemplo anterior, você pode usar a expressão XPath //cadeias_de_Conexão/adicionar/@cadeia_de_Conexão para corresponder à cadeia de conexão em um arquivo Web.config.

Consulte também

  • Página Selecionar Parâmetros
  • Páginas do Assistente de Exportação de Pacote de Aplicativo e Exportação de Servidor


Página Salvar Pacote

Use a página Salvar Pacote do Assistente de Exportação de Pacote de Aplicativo para especificar um nome e uma localização de arquivo para usar quando salvar o pacote.

Elementos da interface do usuário

Nome do elemento | Descrição
Caminho do pacote | Digite o nome de arquivo do pacote. O nome do arquivo deve possuir uma extensão de nome de arquivo .zip.
Procurar... | Clique no botão Procurar para especificar a localização onde você deseja salvar seu pacote.

Consulte também

  • Páginas do Assistente de Exportação de Pacote de Aplicativo e Exportação de Servidor


Caixa de diálogo Criptografar Senha

Use a caixa de diálogo Criptografar Senha do Assistente de Exportação de Pacote de Aplicativo para fornecer uma senha para o conteúdo do pacote que possui configurações marcadas como seguras.

Elementos da interface do usuário

Nome do elemento | Descrição
Senha | Digite a senha que será solicitada quando o pacote for importado posteriormente. Se você não fornecer uma senha para as configurações marcadas como seguras, não poderá importar o pacote.
Confirmar senha | Digite a senha novamente para confirmá-la.

Consulte também

  • Páginas do Assistente de Exportação de Pacote de Aplicativo e Exportação de Servidor


Página Progresso e Resumo da Exportação

Use a página Progresso e Resumo da Exportação do Assistente de Exportação do Aplicativo para monitorar o status do processo de exportação e exibir informações resumidas e detalhadas da operação após a conclusão do assistente.

Elementos da interface do usuário

Nome do elemento Descrição

Status

A área Status exibe a operação em execução no momento (por exemplo, uma operação de cópia de arquivo ou de script de banco de dados). Durante o processo de exportação, uma senha poderá ser solicitada se o aplicativo contiver itens como senhas ou certificados que necessitam de criptografia. Lembre-se de que a operação de exportação pode demorar muito tempo caso a quantidade de dados seja grande ou caso você esteja exportando dados para um servidor remoto.

Resumo

Fornece uma visão geral das ações realizadas, incluindo os erros ocorridos durante o processo de criação.

Importante

A guia Resumo não contém uma lista completa das ações realizadas ou dos erros ocorridos. Para obter informações mais detalhadas, clique na guia Detalhes.

Detalhes

Fornece uma lista detalhada das ações realizadas. Se houver qualquer erro, quando você clicar nessa guia, ela mostrará informações detalhadas sobre o erro que podem ser usadas para solução de problemas.

Consulte também

  • Páginas do Assistente de Exportação de Pacote de Aplicativo e Exportação de Servidor


Páginas do Assistente de Importação de Pacote de Aplicativo e Importação de Servidor ou Pacote de Site

Página Selecionar Pacote

Caixa de diálogo Descriptografar Senha

Página Selecionar o Conteúdo do Pacote

Caixa de diálogo Configurações Avançadas (Importação)

Página Selecionar Banco de Dados

Página Inserir Informações do Pacote de Aplicativo

Página Substituir Arquivos Existentes

Página Progresso e Resumo da Instalação


Página Selecionar Pacote

Use a página Selecionar o Pacote para selecionar um pacote existente que você deseja instalar no site ou servidor.

Elementos da interface do usuário

Nome do elemento | Descrição
Caminho do pacote | Especifica a localização do pacote que você deseja instalar no site ou servidor.
Procurar... | Clique no botão Procurar para especificar a localização do pacote que você deseja importar.

Consulte também

  • Páginas do Assistente de Importação de Pacote de Aplicativo e Importação de Servidor ou Pacote de Site


Caixa de diálogo Descriptografar Senha

Use a caixa de diálogo Descriptografar Senha do Assistente de Importação de Pacote de Aplicativo para fornecer uma senha para o conteúdo do pacote que possui configurações marcadas como seguras.

Elementos da interface do usuário

Nome do Elemento | Descrição
Senha | Digite a senha que é requerida para descriptografar o conteúdo do pacote. A senha é obrigatória, uma vez que algumas configurações foram marcadas como seguras quando o pacote foi criado. Se a senha especificada quando o pacote foi criado não for fornecida, você não poderá importar o pacote.

Consulte também

  • Páginas do Assistente de Importação de Pacote de Aplicativo e Importação de Servidor ou Pacote de Site


Página Selecionar o Conteúdo do Pacote

Use a página Selecionar o Conteúdo do Pacote do Assistente de Importação do Pacote de Aplicativo para exibir os componentes incluídos no pacote selecionado na página Selecionar Pacote.

Os pacotes podem conter componentes como as configurações do Registro, COM, assemblies GAC ou certificados. Para instalar esses componentes no servidor, você deve ser membro do grupo Administradores ou ter sido delegado a autoridade apropriada. Não é necessário ter direitos de usuário administrador para instalar somente conteúdo.

Elementos da interface do usuário

Nome do elemento Descrição

Pacote contém

Lista os componentes incluídos no pacote. Para especificar o que você deseja implantar do pacote, marque ou desmarque as caixas de seleção do componente apropriado. Por exemplo, você pode incluir ou excluir um banco de dados SQL ou um assembly GAC marcando ou desmarcando a caixa de seleção correspondente.

Cuidado

Alguns componentes podem ser obrigatórios para o aplicativo. Se você desmarcar as caixas de seleção desses componentes, o aplicativo poderá não funcionar corretamente após a instalação.

Consulte também

  • Páginas do Assistente de Importação de Pacote de Aplicativo e Importação de Servidor ou Pacote de Site


Caixa de diálogo Configurações Avançadas (Importação)

Use a caixa de diálogo Configurações Avançadas do Assistente de Importação do Pacote de Aplicativo para especificar as configurações do seu pacote.

Elementos da interface do usuário

Opções avançadas

Nome do elemento Descrição

Senha de Descriptografia

Abre a caixa de diálogo Descriptografar Senha que permite que você digite a senha necessária para descriptografar o conteúdo do pacote.

Durante uma operação de importação, o Web Deploy detecta automaticamente se um objeto criptografado, como um pool de aplicativos com uma identidade personalizada, está presente nos arquivos de configuração do pacote no nível do servidor (por exemplo, ApplicationHost.config ou Machine.config). Se um objeto criptografado estiver presente, você deve fornecer uma senha para ele. Se a senha correta não for especificada, o processo de importação falhará.

Incluir ACLs

Marque Verdadeiro se as ACLs do caminho especificado serão copiadas da origem para o destino. Caso contrário, marque Falso. Essa configuração se aplica ao sistema de arquivos, ao registro e à metabase e somente aos seguintes provedores: appHostConfig, contentPath, iisApp, metaKey, webServer, e webServer60. O padrão é False.

Extensão de Link

Clique no campo à direita e em seguida clique na seta para mostrar a lista suspensa de extensões de link. Marque ou desmarque as extensões na lista para habilitar ou desabilitar as extensões de link que deseja aplicar à operação. As extensões de link incluem ou excluem tipos específicos de dados em uma operação. As extensões Web Deploy disponíveis são AppPoolExtension, CertificateExtension, ContentExtension, FrameworkConfigExtension e HttpCertConfigExtension. Essas extensões estão selecionadas por padrão. Para obter mais informações sobre extensões de link, consulte Web Deploy Link Extensions (pode estar disponível somente em inglês).

Tentativas de Repetição

Digite o número de vezes que o provedor tentará novamente após uma falha. O número padrão de tentativas é 5. Por padrão, existe um intervalo de um segundo entre cada tentativa. As tentativas de repetição só podem ser usadas com o provedor contentPath.

Intervalo de Tentativas

Digite um valor em milissegundos. O valor especificará o intervalo de tempo entre as tentativas de repetição do provedor. O padrão é 1000 (um segundo). Essa configuração só pode ser usada com o provedor contentPath.

Nível de Rastreamento

Selecione um valor a partir da lista suspensa para especificar o nível de detalhe nos logs das mensagens de erro. Os valores possíveis são Desativado, Erro, Aviso, Informações e Detalhado. O padrão é Informações. Desativado significa que não serão registradas mensagens de erro. Detalhado significa que todas as mensagens de erro serão registradas.

Opções de sincronização

Nome do elemento Descrição

Regras

Abre a caixa de diálogo Habilitar ou Desabilitar Regras que permite que você especifique regras para a operação. Para obter mais informações, consulte Caixa de diálogo Habilitar ou Desabilitar Regras.

WhatIf

Clique na lista suspensa para marcar True ou False. True especifica que a operação será executada sem que seja feita qualquer alteração. Será possível usar essa configuração para ver os resultados de uma operação se todas as partes da operação tiverem êxito. O valor padrão é False.

Observação

Um comando que parece ter sido executado com êxito com a configuração WhatIf pode falhar quando for executado sem usar essa configuração. Isso pode acontecer se erros inesperados ocorrerem durante a operação. Por exemplo, como não são gravados dados durante uma operação WhatIf, os erros de permissão de gravação não serão detectados. A configuração WhatIf mostra somente o que irá acontecer se todas as operações no comando tiverem êxito.

Consulte também

  • Página Selecionar o Conteúdo do Pacote
  • Páginas do Assistente de Importação de Pacote de Aplicativo e Importação de Servidor ou Pacote de Site


Página Selecionar Banco de Dados

Use a página Selecionar Banco de Dados para selecionar as opções de banco de dados que deseja usar para o pacote sendo instalado. Essa página aparece apenas se houver mais de um tipo de banco de dados disponível no pacote.

Observação

Ela também não será exibida se houver mais de um tipo de banco de dados disponível no pacote, mas você tiver desmarcado todas as caixas de seleção da página Selecionar o Conteúdo do Pacote menos a de um tipo de banco de dados.

Elementos da interface do usuário

Nome do elemento | Descrição
Escolher o banco de dados que você deseja usar | Selecione o tipo de banco de dados para sua instalação. Os tipos de banco de dados possíveis são SQL, MySQL, VistaDB, SQLite, Arquivo Simples ou Nenhum Banco de Dados. O conteúdo do pacote que está sendo instalado determinam quais opções de banco de dados são exibidas. Apenas as opções SQL e MySQL possuem provedores associados. Para obter mais informações, consulte Web Deploy dbFullSql Provider (pode estar disponível em inglês) e Web Deploy MySQL Provider (pode estar disponível somente em inglês).
Criar um novo banco de dados ou usar um banco de dados existente | Selecione Criar novo banco de dados para criar um novo banco de dados ou Usar banco de dados existente para usar um banco de dados existente. Essa opção é habilitada apenas quando SQL ou MySQL foram selecionados como tipo de banco de dados.

Consulte também

  • Páginas do Assistente de Importação de Pacote de Aplicativo e Importação de Servidor ou Pacote de Site
  • Página Inserir Informações do Pacote de Aplicativo


Página Inserir Informações do Pacote de Aplicativo

Use a página Inserir Informações sobre o Pacote de Aplicativo do Assistente de Importação de Pacote de Aplicativo para especificar valores para os parâmetros declarados no pacote. Cada parâmetro possuirá um campo na página. Os campos exibidos na página dependem dos parâmetros que foram declarados no pacote.

Elementos da interface do usuário

Nome do elemento | Descrição
<Nome do Parâmetro> | Especifica um valor para o parâmetro necessário para instalar seu pacote. Essas informações podem incluir o caminho integral do site onde você deseja instalar seu aplicativo, credenciais do usuário ou o nome do banco de dados para seu aplicativo. Por exemplo, você pode alterar o valor do caminho do aplicativo para especificar onde o aplicativo deve ser instalado, por exemplo Site Padrão/Novo_Aplicativo.

Consulte também

  • Caixa de diálogo Editar Cadeia de Conexão


Caixa de diálogo Editar Cadeia de Conexão

Use a caixa de diálogo Editar Cadeia de Conexão para especificar a cadeia e as credenciais de conexão que você deseja usar.

Elementos da interface do usuário

Nome do elemento | Descrição
SQL Server | Selecione essa opção para usar um SQL Server especificado por você.
Servidor | Digite o caminho ou cadeia de conexão do servidor deseja usar (por exemplo, .\SQLExpress).
Banco de Dados | Digite o nome do banco de dados que deseja usar (por exemplo, Teste).
Usar Segurança Integrada do Windows | Selecione essa opção para usar a Segurança Integrada do Windows. A Segurança Integrada do Windows passa as credenciais do usuário para ASP.NET sem solicitar nova autenticação se o usuário já estiver conectado ao Windows. Este método de autenticação funciona melhor se o cliente e o servidor estiverem no mesmo domínio.
Especificar credenciais | Selecione essa opção para usar credenciais especificadas pelo usuário. Clicar em Definir para abrir a caixa de diálogo Definir Credenciais e especificar seu nome de usuário e senha.
Personalizar | Selecione essa opção para especificar uma cadeia de conexão ou caminho personalizado para o servidor que deseja usar (por exemplo, Server=.\SQLExpress;Database=Test;Integrated Security=true).

Consulte também

  • Páginas do Assistente de Importação de Pacote de Aplicativo e Importação de Servidor ou Pacote de Site
  • Página Inserir Informações do Pacote de Aplicativo


Página Substituir Arquivos Existentes

Use a página Substituir Arquivos Existentes para decidir se deseja acrescentar novos arquivos ao destino ou substituir os arquivos existentes e excluir os que não possuem equivalentes no pacote do aplicativo.

Elementos da interface do usuário

Nome do elemento | Descrição
Não, só acrescente os arquivos no pacote do aplicativo ao destino. | Selecione essa opção para manter os arquivos existentes no destino e adicionar os novos arquivos a partir do pacote do aplicativo.
Sim, exclua todos os demais arquivos e pastas no destino que não estão no pacote do aplicativo. | Selecione essa opção para excluir qualquer arquivo no destino que não esteja incluído no pacote do aplicativo.

Consulte também

  • Páginas do Assistente de Importação de Pacote de Aplicativo e Importação de Servidor ou Pacote de Site


Página Progresso e Resumo da Instalação

Use a página Progresso e Resumo da Instalação do Assistente de Exportação do Aplicativo para monitorar o status do processo de importação e exibir informações resumidas e detalhadas sobre a operação após a conclusão do assistente.

Elementos da interface do usuário

Nome do elemento Descrição

Status

A área Status exibe a operação em execução no momento (por exemplo, uma operação de cópia de arquivo ou de script de banco de dados). Durante o processo de importação, poderá ser solicitada uma senha se o aplicativo contiver itens como senhas ou certificados que necessitam de descriptografia. Lembre-se de que a operação de importação poderá demorar muito tempo se a quantidade de dados for grande ou se você estiver importando dados de ou para um servidor remoto.

Resumo

Fornece uma visão geral das ações realizadas, incluindo erros ocorridos durante o processo de instalação.

Importante

A guia Resumo não contém uma lista completa das ações realizadas ou dos erros ocorridos. Para obter informações mais detalhadas, clique na guia Detalhes.

Detalhes

Fornece uma lista detalhada das ações realizadas. Se houver qualquer erro, quando você clicar nessa guia, ela mostrará informações detalhadas sobre o erro que podem ser usadas para solução de problemas.

Consulte também

  • Páginas do Assistente de Importação de Pacote de Aplicativo e Importação de Servidor ou Pacote de Site