Información general de la Herramienta de implementación web para el Administrador de IIS

La Herramienta de implementación web (implementación web) sincroniza la configuración de IIS, contenido, certificados SSL y otros tipos de datos desde un sitio o servidor especificado por el usuario hasta un destino especificado por el usuario. También permite implementar objetos, como claves del Registro, que no se incluyen de forma predeterminada.

Delegación de servicios de administración

En IIS Manager, la implementación web agrega en el nivel de servidor una característica solo para administradores, denominada Delegación de servicios de administración, que permite controlar con mayor precisión las acciones de implementación que pueden realizar los usuarios remotos. Para obtener más información, consulte Delegación de servicios de administración (Página).

Exportar e importar aplicaciones

Desde el panel Acciones de IIS Manager, puede usar el Asistente para exportar paquete de aplicación para crear archivos comprimidos (paquetes) que contengan sitios, aplicaciones y contenido. Para obtener más información, consulte Exportar paquete de aplicación y Exportar paquete de servidor (Páginas de asistente).

Después de exportar un paquete, puede usar el Asistente para importar paquete de aplicación para instalar el contenido del paquete en una ubicación diferente. Para obtener más información, consulte Importar paquete de aplicación e Importar paquete de servidor o sitio (Páginas de asistente).

Características de la línea de comandos

El programa ejecutable Msdeploy.exe de la Herramienta de implementación web ofrece muchas características eficaces de la línea de comandos. Para ver una ayuda resumida de las características de Msdeploy.exe, escriba msdeploy -help en una ventana del símbolo del sistema. Para obtener más ayuda detallada en línea, consulte Herramienta de implementación web (puede estar en inglés).

Recursos adicionales en línea

IIS.NET: Herramienta de implementación web (puede estar en inglés)

IIS.NET: Foro de la Herramienta de implementación web (puede estar en inglés)

IIS.NET: Posts del blog del equipo de implementación web de Microsoft (puede estar en inglés)


Ayuda de la interfaz de usuario de la Herramienta de implementación web

IIS Manager proporciona descripciones de todos los elementos de la interfaz de usuario en cada página de características, cuadro de diálogo y página de asistente de IIS Manager. Para que se muestre esta ayuda, presione la tecla F1 en la página de características, página de asistente o cuadro de diálogo activos.

En esta sección

Delegación de servicios de administración (Página)

Exportar paquete de aplicación y Exportar paquete de servidor (Páginas de asistente)

Importar paquete de aplicación e Importar paquete de servidor o sitio (Páginas de asistente)


Delegación de servicios de administración (Página)

Use la página Delegación de servicios de administración para especificar las reglas que controlarán los derechos de implementación de los usuarios remotos. Solo los administradores pueden usar la página Delegación de servicios de administración, que únicamente aparece en el nivel de servidor.

Elementos de la interfaz de usuario

Nombre de elemento | Descripción
Proveedor | Muestra el proveedor o proveedores a los que se aplica la regla.
Ruta de acceso | Muestra la ruta de acceso a la que se aplica la regla.
Tipo de ruta de acceso | Muestra el tipo de ruta de acceso. Los valores posibles son PathPrefix, StringPrefix, StringSuffix, ConnectionString y RegularExpression.
Acciones | Muestra las acciones que realizará la regla. Para los proveedores de implementación web, los valores habituales son Read, Write y *.
Tipo de identidad | Muestra el tipo de identidad bajo el que se ejecutará la regla. Los valores posibles son CurrentUser, ProcessIdentity y SpecificUser.
Nombre de usuario | Muestra el nombre de usuario cuando se ha seleccionado SpecificUser como tipo de identidad. Cuando el tipo de identidad es CurrentUser o ProcessIdentity, no se mostrará un nombre de usuario.
Estado | Muestra si la regle está habilitada o deshabilitada. Para habilitar o deshabilitar una regla, haga clic en Habilitar regla o Deshabilitar regla en el panel Acciones.

Elementos del panel Acciones

Nombre de elemento | Descripción
Agregar regla… | Abre el cuadro de diálogo Agregar regla. Seleccione esta opción para agregar una regla. Para obtener más información, consulte Agregar regla (Cuadro de diálogo) (Delegación de servicios de administración).
Agregar usuario a regla… | Abre el cuadro de diálogo Agregar usuario a regla. Para obtener más información, consulte Agregar usuario a regla (Cuadro de diálogo).
Modificar… | Abre el cuadro de diálogo Modificar regla. Para obtener más información, consulte Agregar o Modificar regla (Cuadros de diálogo).
Quitar | Quita la regla de delegación seleccionada o el usuario de regla de delegación.
Deshabilitar regla | Deshabilita la regla de delegación seleccionada.
Habilitar regla | Habilita la regla de delegación seleccionada.
Modificar configuración de característica… | Abre el cuadro de diálogo Modificar configuración de característica. Para obtener más información, consulte Modificar configuración de característica (Cuadro de diálogo) (Delegación de servicios de administración).


Agregar regla (Cuadro de diálogo) (Delegación de servicios de administración)
Consulte también

Use el cuadro de diálogo Seleccionar plantilla de regla para seleccionar una plantilla que puede usar para crear una regla de delegación personalizada. Puede elegir una plantilla en blanco o una plantilla instalada diseñada para escenarios específicos.

Elementos de la interfaz de usuario

Plantillas instaladas

Nombre de elemento Descripción

Regla en blanco

Crea una regla en blanco que se puede personalizar.

Implementar sólo contenido

Crea una regla que habilita la implementación de contenido. La regla permitirá a cualquier usuario autorizado del servicio de administración web (WMSvc) publicar contenido en una ruta de acceso para la que el usuario tenga una autorización de WMSvc. La regla puede modificarse para restringir el acceso a una ruta de acceso o un usuario concretos. Esta regla usa el proveedor contentPath, que sincroniza el contenido del sitio web. Para obtener más información, consulte Proveedor contentPath de implementación web (puede estar en inglés).

Implementar aplicaciones con contenido

Crea una regla que habilita las implementaciones de aplicaciones. Esta plantilla no incluye una regla para marcar una carpeta como aplicación, pero se suele usar con ese tipo de reglas. La regla permitirá a cualquier usuario autorizado del servicio de administración web (WMSvc) publicar una aplicación en una ruta de acceso para la que el usuario tenga una autorización de WMSvc. La regla puede modificarse para restringir el acceso a una ruta de acceso o un usuario concretos. Esta regla utiliza los proveedores contentPath e iisApp. Para obtener más información, consulte Proveedor contentPath de implementación web (puede estar en inglés) y Proveedor iisApp de Microsoft Deploy (puede estar en inglés).

Implementar bases de datos

Crea una regla que habilita la implementación de bases de datos. La regla permitirá a cualquier usuario autorizado deWMSvc publicar en cualquier base de datos a la que tenga acceso. La plantilla especifica que se usa la cuenta CurrentUser, lo que significa que se usará la cadena de conexión para autenticar al usuario en el servidor de bases de datos. La regla puede modificarse para restringir el acceso a un servidor de bases de datos o un nombre concretos. Esta regla usa el proveedor dbFullSql, que habilita la publicación de bases de datos por primera vez desde una base de datos de implementación de un servidor SQL Server local en una base de datos de SQL Server hospedada de forma remota. Para obtener más información, consulte Proveedor dbFullSql de implementación web (puede estar en inglés).

Carpetas marcadas como aplicaciones

Crea una regla que marca una carpeta como aplicación. La regla permitirá a cualquier usuario autorizado deWMSvc marcar una carpeta como aplicación. Si el usuario no es un administrador, tendrá que cambiar el tipo de identidad a una cuenta que tenga acceso de escritura al archivo ApplicationHost.config. El tipo de identidad predeterminado para esta regla es SpecificUser. Esta regla utiliza el proveedor createApp, que es necesario para marcar las carpetas como aplicaciones y cuya funcionalidad se incluye en el proveedor iisApp. Para obtener más información, consulte Proveedores de implementación web (puede estar en inglés).

Establecer permisos para aplicaciones

Crea una regla que establece las ACL para una ruta de acceso de aplicación. La regla permitirá a cualquier usuario autorizado de WMSvc establecer las ACL del sistema de archivos para una ruta de acceso de aplicación para la que el usuario tenga una autorización de WMSvc. La plantilla especifica que la cuenta que se usa es CurrentUser, lo que significa que el usuario necesita tener permisos para poder cambiar las ACL. La regla puede modificarse para restringir el acceso a una ruta de acceso o un usuario concretos. Esta regla usa el proveedor setAcl, que establece los permisos en una carpeta de destino. Para obtener más información, consulte Proveedor setAcl de implementación web (puede estar en inglés). .

Copia de seguridad y restauración de bases de datos (con autenticación de SQL)

Crea una regla que hace una copia de seguridad de las bases de datos y las restaura usando la autenticación de SQL. La regla permitirá a cualquier usuario autorizado de WMSvc crear o restaurar una copia de seguridad de la base de datos a la que el usuario tenga acceso. Las operaciones de copia de seguridad y restauración se realizarán como una identidad de usuario específica con la autenticación de SQL. La regla puede modificarse para restringir el acceso a una base de datos y un conjunto de usuarios concretos.

Nota
Use esta plantilla con la extensión Administrador de bases de datos de IIS. Para obtener más información acerca del Administrador de bases de datos de IIS, consulte Administrador de bases de datos (puede estar en inglés).

Copia de seguridad y restauración de bases de datos (con seguridad integrada de Windows)

Crea una regla que hace una copia de seguridad de las bases de datos y las restaura usando la autenticación de Windows. La regla permitirá a cualquier usuario autorizado de WMSvc crear o restaurar una copia de seguridad de la base de datos a la que el usuario tenga acceso. La regla puede modificarse para restringir el acceso a una base de datos y un conjunto de usuarios concretos.

Nota
Use esta plantilla con la extensión Administrador de bases de datos de IIS. Para obtener más información acerca del Administrador de bases de datos de IIS, consulte Administrador de bases de datos (puede estar en inglés).

Consulte también

Conceptos

Importar paquete de aplicación e Importar paquete de servidor o sitio (Páginas de asistente)

Otros recursos

Proveedores de implementación web (puede estar en inglés)


Agregar o Modificar regla (Cuadros de diálogo)

Use los cuadros de diálogo Agregar regla y Modificar regla para agregar y modificar las reglas de delegación.

Elementos de la interfaz de usuario

Nombre de elemento | Descripción
Proveedores | Haga clic en la lista desplegable para seleccionar o desactivar los proveedores que desee agregar o quitar de la regla; después, haga clic en la flecha desplegable para aceptar los cambios. Los proveedores se mostrarán en una lista delimitada por comas. Para obtener más información acerca de los proveedores de implementación web, consulte Proveedores de implementación web (puede estar en inglés).
Acciones | Haga clic en la lista desplegable para seleccionar o desactivar las acciones que desee agregar o quitar de la regla; después, haga clic en la flecha desplegable para aceptar los cambios. Las acciones se mostrarán en una lista delimitada por comas. Los valores habituales para la implementación web son Read, Write y *.
Tipo de ruta de acceso | Seleccione un tipo de ruta de acceso en la lista desplegable. Los valores posibles son PathPrefix, StringPrefix, StringSuffix, ConnectionString y RegularExpression. Para obtener más información acerca de las expresiones regulares, consulte Expresiones regulares (puede estar en inglés).
Ruta de acceso | Escriba la ruta de acceso a la que se aplicará la regla.
Tipo de identidad | Seleccione el tipo de identidad para la regla en la lista desplegable. La identidad seleccionada ejecutará la regla. Los valores posibles son CurrentUser, ProcessIdentity y SpecificUser. CurrentUser especifica que se usará la identidad del usuario actual. ProcessIdentity especifica que se usará la identidad del servicio local WMSvc. SpecificUser especifica que se usará una identidad especial que se designe. Si selecciona SpecificUser, debe proporcionar las credenciales mediante el botón Especificar credenciales Establecer.
Especificar credenciales | Habilita el botón Establecer cuando se selecciona SpecificUser como tipo de identidad.
Establecer | Abre el cuadro de diálogo Establecer credenciales, que permite especificar un nombre de usuario y una contraseña para la identidad SpecificUser. Para obtener más información, consulte Establecer credenciales (Cuadro de diálogo).


Establecer credenciales (Cuadro de diálogo)

Use el cuadro de diálogo Establecer credenciales para proporcionar un nombre de usuario y una contraseña para un usuario de Windows que ejecutará la regla.

Elementos de la interfaz de usuario

Nombre de elemento | Descripción
Nombre de usuario | Escriba el nombre de un usuario de Windows.
Contraseña | Escriba la contraseña.
Confirmar contraseña | Vuelva a escribir la contraseña para confirmarla.

Consulte también

Conceptos

Agregar o Modificar regla (Cuadros de diálogo)


Agregar usuario a regla (Cuadro de diálogo)

Use el cuadro de diálogo Agregar usuario a regla para conceder o denegar a un usuario el acceso a una regla.

Elementos de la interfaz de usuario

Nombre de elemento | Descripción
Nombre | Escriba el nombre del usuario.
Tipo de acceso | Seleccione el tipo de acceso que concederá al usuario especificado. Los valores posibles son Permitir y Denegar.
¿Es una regla? | Seleccione esta casilla de verificación si el nombre de usuario que especificó es un alias para un grupo de usuarios a los que se permitirá o denegará el acceso.


Modificar configuración de característica (Cuadro de diálogo) (Delegación de servicios de administración)

Use el cuadro de diálogo Modificar configuración de característica para permitir a los administradores omitir las reglas de delegación y habilitar el registro de las solicitudes con error.

Elementos de la interfaz de usuario

Nombre de elemento Descripción

Permitir a los administradores omitir reglas

Seleccione esta opción para permitir a los administradores omitir las reglas de delegación especificadas.

Habilitar registro de traza de solicitudes con error para el servicio de delegación

Seleccione esta opción para habilitar el registro de la información de solicitudes con error.

Advertencia
Para usar esta característica, debe estar instalado el módulo de seguimiento de solicitudes con error.


Exportar paquete de aplicación y Exportar paquete de servidor (Páginas de asistente)

Seleccione el contenido del paquete (Página)

Seleccionar parámetros (Página)

Guardar paquete (Página)

Contraseña de cifrado (Cuadro de diálogo)

Progreso y resumen de la exportación (Página)


Seleccione el contenido del paquete (Página)

Use la página Seleccione el contenido del paquete del Asistente para exportar paquete de aplicación para ver los componentes que se incluyen en el paquete que desea crear.

Los paquetes pueden contener información como la configuración del Registro, COM, ensamblados GAC o certificados. Para instalar estos componentes en el servidor, debe ser miembro del grupo Administradores o tener delegada la autoridad adecuada. No necesita derechos de usuario administrador para instalar sólo contenido.

Elementos de la interfaz de usuario

Nombre de elemento Descripción

El paquete contiene

Muestra los componentes que se incluyen en el paquete. Para especificar lo que desea incluir en el paquete, seleccione o desactive las casillas de componentes adecuadas. Por ejemplo, para incluir o excluir una base de datos de SQL o un ensamblado GAC seleccione o desactive la casilla correspondiente.

Precaución
La aplicación puede necesitar ciertos componentes. Si desactiva las casillas correspondientes a esos componentes, la aplicación puede no funcionar correctamente después de la instalación.

Atributos

Muestra, en el panel derecho, los atributos del archivo, directorio o componente seleccionado. Estos valores son de solo lectura.

Administrar componentes…

Abre el cuadro de diálogo Administrar componentes, que permite seleccionar los componentes que se desea incluir. Para obtener más información, consulte Administrar componentes (Cuadro de diálogo).

Configuración avanzada…

Abre el cuadro de diálogo Configuración avanzada, que permite especificar la configuración de operaciones y las reglas. Para obtener más información, consulte Configuración avanzada (Cuadro de diálogo) (Exportar).

Consulte también

Conceptos

Exportar paquete de aplicación y Exportar paquete de servidor (Páginas de asistente)

Otros recursos

Exportar un paquete a través del administrador de IIS (recurso en línea) (puede estar en inglés)


Administrar componentes (Cuadro de diálogo)

Use el cuadro de diálogo Administrar componentes del Asistente para exportar paquete de aplicación para agregar componentes al paquete, como, por ejemplo, objetos COM o ensamblados GAC.

Elementos de la interfaz de usuario

Encabezados de columna

Nombre de elemento Descripción

Nombre de proveedor

Especifica el componente que desea empaquetar. Cada componente tiene un proveedor. Haga clic en el campo y use la lista desplegable para seleccionar un nombre de proveedor. Mantenga el mouse sobre un nombre de proveedor para ver su descripción. Por ejemplo, si selecciona dbFullSql, empaquetará la ruta de acceso de un script o una cadena de conexión. Para obtener más información acerca de los proveedores, consulte Proveedores de implementación web (puede estar en inglés).

Importante
Si está empaquetando un sitio web, el proveedor iisApp (seleccionado de forma predeterminada) marcará el sitio web como aplicación en el destino. Si desea empaquetar un sitio web y toda su configuración relacionada (por ejemplo, en nombre del grupo de aplicaciones, la ubicación del directorio de contenido y los certificados), use el proveedor appHostConfig. Si usa el proveedor iisApp, en el destino, el sitio web se convertirá en una aplicación que hereda toda su configuración (por ejemplo, el nombre del grupo de aplicaciones y el directorio de contenido) del sitio en el que se instaló.

Ruta de acceso

Especifica la ruta de acceso del componente que proporcionará los datos para el paquete. Por ejemplo, si selecciona dbFullSql, la ruta de acceso puede especificar un script como C:\ArchivosSQL\instalaciónSQL.sql, o una cadena de conexión como Origen de datos=.\sqlexpress;Seguridad integrada=SSPI;Catálogo inicial=db1.

Configuración de proveedores

Especifica la configuración de proveedores que se desea usar para el proveedor seleccionado. Haga clic en el campo y use el botón Examinar (…) para abrir el cuadro de diálogo Configuración de proveedores. Para obtener más información, consulte Configuración de proveedores (Cuadro de diálogo).

Botones

Nombre de elemento | Descripción
Quitar | Elimina la entrada seleccionada.
Subir | Sube la fila seleccionada en la lista. Las entradas se instalarán en el orden en el que aparecen en la lista. El orden de las entradas es importante para ciertos proveedores. Por ejemplo, un script para crear una tabla debe ejecutarse antes que un script para rellenarla.
Bajar | Baja la fila seleccionada en la lista. Las entradas se instalarán en el orden en el que aparecen en la lista.

Consulte también

Conceptos

Seleccione el contenido del paquete (Página)
Exportar paquete de aplicación y Exportar paquete de servidor (Páginas de asistente)


Configuración de proveedores (Cuadro de diálogo)

Use el cuadro de diálogo Configuración de proveedores para especificar la configuración del proveedor seleccionado. No todos los proveedores tienen configuraciones.

Elementos de la interfaz de usuario

Nombre de elemento | Descripción
Nombre de configuración | Muestra el nombre de la variable configuración del proveedor seleccionado. Solo se muestra la configuración relevante para el proveedor seleccionado.
Valor de configuración | Escriba o seleccione el valor para la opción de configuración. Si hay una lista desplegable disponible, los valores posibles para la opción estarán en la lista. Para los valores que debe escribir, el cuadro de descripción proporciona información sobre los valores aceptables.
Descripción de la configuración | Muestra una descripción de la configuración seleccionada para el proveedor. Proporciona información acerca de qué valores se permiten para la configuración.

Consulte también

Conceptos

Administrar componentes (Cuadro de diálogo)
Seleccione el contenido del paquete (Página)
Exportar paquete de aplicación y Exportar paquete de servidor (Páginas de asistente)

Otros recursos

Configuración de proveedores de implementación web (puede estar en inglés)


Configuración avanzada (Cuadro de diálogo) (Exportar)

Use el cuadro de diálogo Configuración avanzada del Asistente para exportar paquete de aplicación con el fin de especificar la configuración del paquete.

Elementos de la interfaz de usuario

Opciones avanzadas

Nombre de elemento Descripción

Cifrar contraseña

Haga clic en … para abrir el cuadro de diálogo Cifrar contraseña con el fin de especificar una contraseña alfanumérica que controlará el acceso a las propiedades seguras de la configuración de IIS.

La implementación web detecta automáticamente si está presente un objeto cifrado, como un grupo de aplicaciones con una identidad personalizada, en los archivos de configuración del nivel de servidor (por ejemplo, ApplicationHost.config o Machine.config). Si hay un objeto cifrado, debe proporcionar una contraseña para él. Si no especifica la contraseña correcta, la operación de exportación generará un error.

Importante
La implementación web no comprueba los archivos Web.config para ver si hay objetos cifrados.

Incluir ACL

Seleccione True si las ACL de la ruta de acceso que especifique se van a copiar desde el origen al destino; de lo contrario, seleccione False. Esta configuración se aplica al sistema de archivos, al Registro y a la metabase, y solo se aplica a los siguientes proveedores: appHostConfig, contentPath, iisApp, metaKey, webServer y webServer60. El valor predeterminado es False.

Extensión de vínculos

Haga clic en el campo de la derecha y, a continuación, en la flecha para mostrar la lista desplegable de las extensiones de vínculos. Seleccione o desactive las extensiones de la lista para habilitar o deshabilitar las extensiones de vínculos que desee aplicar a la operación. Las extensiones de vínculos incluyen o excluyen tipos específicos de datos en una operación. Las extensiones de implementación web disponibles son AppPoolExtension, CertificateExtension, ContentExtension, FrameworkConfigExtension y HttpCertConfigExtension. Estas extensiones están seleccionadas de forma predeterminada. Para obtener más información acerca de las extensiones de vínculos, consulte Extensiones de vínculos de implementación web (puede estar en inglés).

Reintentos

Escriba el número de veces que el proveedor volverá a intentar la operación tras un error. El número predeterminado de reintentos es 5. De forma predeterminada, se produce un retardo de un segundo entre cada reintento. La configuración de reintentos solo se puede usar con el proveedor contentPath.

Intervalo de reintento

Escriba un valor en milisegundos. Este valor especificará el intervalo de tiempo entre reintentos del proveedor. El valor predeterminado es 1000 (un segundo). Esta configuración solo se puede usar con el proveedor contentPath.

Nivel de traza

Seleccione en la lista desplegable un valor que especifique el nivel de detalle que desea en los registros de mensajes de error. Los valores posibles son Off, Error, Warning, Info y Verbose. El valor predeterminado es Info. Off significa que no se registrarán mensajes de error. Verbose significa que se registrarán todos los mensajes.

Opciones de sincronización

Nombre de elemento Descripción

Reglas

Abre el cuadro de diálogo Habilitar o deshabilitar reglas, que permite especificar reglas para la operación. Para obtener más información, consulte Habilitar o deshabilitar reglas (Cuadro de diálogo).

WhatIf

Haga clic en la lista desplegable para seleccionar True o False. True especifica que la operación se ejecutará sin realizar realmente ningún cambio. Puede usar este valor para ver los resultados de una operación si todas las partes de ella se han ejecutado correctamente. El valor predeterminado es False.

Nota
Un comando que parece ejecutarse correctamente con el valor WhatIf puede generar errores cuando se ejecuta sin usar este valor. Esto puede ocurrir si se generan errores inesperados durante la operación. Por ejemplo, dado que no se escriben datos durante una operación WhatIf, no se detectarán los errores de permisos de escritura. El valor WhatIf muestra únicamente lo que ocurrirá si todas las operaciones del comando se ejecutan correctamente.

Consulte también

Conceptos

Seleccione el contenido del paquete (Página)
Exportar paquete de aplicación y Exportar paquete de servidor (Páginas de asistente)


Habilitar o deshabilitar reglas (Cuadro de diálogo)

Use el cuadro de diálogo Habilitar o deshabilitar reglas para habilitar o deshabilitar reglas que afectan al resultado de una operación sincronizada. Seleccione Estado en la lista desplegable Agrupar por para agrupar las reglas en las categorías habilitada o deshabilitada, o Sin agrupar para ver las reglas en orden alfabético.

Elementos de la interfaz de usuario

Encabezados de columna

Nombre de elemento | Descripción
Nombre | Muestra los nombres de las reglas de sincronización que se pueden habilitar o deshabilitar. Las reglas en negrita están habilitadas de forma predeterminada; las reglas en texto atenuado están deshabilitadas de forma predeterminada. Para habilitar o deshabilitar una regla, selecciónela y use los botones Habilitar regla o Deshabilitar regla. Para obtener más información acerca de estas reglas, consulte Reglas de implementación web (puede estar en inglés).

Botones

Nombre de elemento | Descripción
Habilitar regla | Habilita la regla seleccionada.
Deshabilitar regla | Deshabilita la regla seleccionada.

Consulte también

Conceptos

Exportar paquete de aplicación y Exportar paquete de servidor (Páginas de asistente)
Importar paquete de aplicación e Importar paquete de servidor o sitio (Páginas de asistente)


Seleccionar parámetros (Página)

Use la página Seleccionar parámetros del Asistente para exportar paquete de aplicación para agregar o quitar parámetros del paquete. Puede asignar un parámetro a un atributo cuando cree el paquete. Más adelante, cuando el paquete esté instalado, el usuario puede especificar un valor predeterminado para el parámetro; el nuevo valor se asignará al atributo. Se generan parámetros automáticamente para cada proveedor.

Elementos de la interfaz de usuario

Encabezados de columna

Nombre de elemento | Descripción
Nombre | Muestra los nombres de los parámetros que se han agregado mediante el cuadro de diálogo Agregar parámetro. Para modificar un parámetro, haga doble clic en él o selecciónelo y, a continuación, haga clic en Modificar.
Tipo | Muestra el tipo de parámetro para el atributo que se parametrizará.
Ámbito | Muestra el ámbito para el atributo que se parametrizará.
Coincidir con | Muestra la expresión coincidente que identifique el atributo que se parametrizará.

Botones

Nombre de elemento Descripción

Agregar parámetro

Abre el cuadro de diálogo Agregar parámetro. Permite agregar un parámetro y establecer sus propiedades. Para obtener más información, consulte Agregar o Modificar parámetro (Cuadro de diálogo).

Agregar entrada de parámetro

Abre el cuadro de diálogo Agregar entrada de parámetro. Permite configurar los valores Tipo, Ámbito y Coincidir con para el parámetro seleccionado. Para obtener más información, consulte Agregar entrada de parámetro (Cuadro de diálogo). Esta opción está habilitada cuando se selecciona un parámetro o una entrada de parámetro.

Modificar

Si hay un parámetro seleccionado, este botón abre el cuadro de diálogo Modificar parámetro, que permite modificar las propiedades de un parámetro existente. Para obtener más información, consulte Agregar o Modificar parámetro (Cuadro de diálogo).

Si hay una entrada de parámetro seleccionada, este botón abre el cuadro de diálogo Modificar entrada de parámetro. Para obtener más información, consulte Modificar entrada de parámetro (Cuadro de diálogo).

Quitar

Quita el parámetro seleccionado.

Subir

Sube el parámetro seleccionado en la lista de parámetros. Los parámetros se procesan en el orden en el que aparecen en la lista.

Bajar

Baja el parámetro seleccionado en la lista de parámetros. Los parámetros se procesan en el orden en el que aparecen en la lista.

Consulte también

Conceptos

Exportar paquete de aplicación y Exportar paquete de servidor (Páginas de asistente)


Agregar o Modificar parámetro (Cuadro de diálogo)

Use el cuadro de diálogo Agregar parámetro o Modificar parámetro para agregar un nuevo parámetro para el paquete de aplicación o modificar un parámetro existente.

Elementos de la interfaz de usuario

Nombre de elemento Descripción

Nombre

Escriba un nombre para el parámetro. Por ejemplo, Cadena de conexión.

Valor predeterminado

Escriba un valor predeterminado para el parámetro. Cuando se implemente el paquete más adelante, el parámetro tendrá este valor a menos que el usuario especifique uno diferente. Por ejemplo, si escribió Cadena de conexión para el nombre del parámetro, puede usar Origen de datos=.\SQLExpress;Base de datos=Prueba;Seguridad integrada para el valor predeterminado. Esta entrada no es obligatoria.

Importante
Si desea exigir que el usuario proporcione un valor para el parámetro, no especifique un valor predeterminado.

Etiquetas

Escriba una lista delimitada por comas de los atributos personalizados. Las etiquetas son atributos opcionales del parámetro a los que se puede hacer referencia más adelante. Por ejemplo, el parámetro podría etiquetarse como contraseña para que la interfaz de usuario no muestre el valor de contraseña. Esta entrada no es obligatoria. Si usa el ejemplo de la descripción del elemento Valor predeterminado, puede usar las etiquetas SQL, CadenaConexiónSQL para el parámetro Cadena de conexión.

Descripción

Escriba una descripción para el parámetro. Por ejemplo, "Esta es la cadena de conexión para la base de datos usada por su aplicación. Cámbiela si su entorno tiene un servidor SQL o una base de datos diferente". La descripción se colocará en el archivo Parameters.xml, dentro del paquete, y puede mostrarse en un símbolo del sistema escribiendo msdeploy -verb:getParameters -source:package=<NombreArchivoPaquete>.

Tipo

Opcionalmente, seleccione un tipo de validación de parámetro. Los valores posibles son Ninguno, Expresión regular, Enumeración o Booleano. El valor predeterminado es Ninguno. Si selecciona un tipo de validación de parámetro distinto de Ninguno, se comprobará el valor que el usuario proporciona para el parámetro con el fin de ver si cumple las condiciones especificadas. Si selecciona Expresión regular o Enumeración, debe proporcionar una cadena de validación en el cuadro Cadena de validación.

Cadena de validación

Escriba una expresión regular o una lista delimitada por comas de valores de enumeración. Para obtener más información acerca de las expresiones regulares, consulte Expresiones regulares (puede estar en inglés).

Consulte también

Conceptos

Seleccionar parámetros (Página)
Exportar paquete de aplicación y Exportar paquete de servidor (Páginas de asistente)


Agregar entrada de parámetro (Cuadro de diálogo)

Use el cuadro de diálogo Agregar entrada de parámetro para especificar los valores de Tipo, Ámbito y Coincidir con del parámetro.

Elementos de la interfaz de usuario

Nombre de elemento | Descripción
Tipo | Use la lista desplegable para seleccionar el tipo de parámetro que desea usar para el atributo que se parametrizará. Los tipos de parámetros posibles son Archivo XML, Archivo de texto, Posición de archivo de texto, Ruta de acceso de proveedor, Atributo de implementación, Enlace de destino y Directorio virtual de destino. Por ejemplo, si ha creado un parámetro Cadena de conexión, podría seleccionar Archivo XML en la lista desplegable porque la cadena de conexión estará dentro de un archivo Web.config, que está en formato XML.
Ámbito | Escriba un ámbito para el atributo que se parametrizará. Este valor es una expresión regular necesaria. Por ejemplo, si el tipo de parámetro es Xml File, podría usar la expresión regular \\web.config$ para el ámbito. La primera barra invertida produce un escape a la segunda barra invertida y el signo de dólar ($) detiene la cadena de coincidencia al final de la línea. Por tanto, "\web.config" será el ámbito resultante. Para obtener más información acerca de las expresiones regulares, consulte Expresiones regulares (puede estar en inglés).
Coincidir con | Escriba una expresión que identifique el atributo que se parametrizará. Este valor depende del tipo. En algunos casos será una expresión regular o una expresión XPath. El tipo Xml File requiere que el valor coincidente sea una expresión XPath. Siguiendo el ejemplo anterior, podría usar la expresión XPath //cadenasConexión/agregar/@cadenaConexión para buscar una entrada coincidente en la cadena de conexión dentro de un archivo Web.config.

Consulte también

Conceptos

Seleccionar parámetros (Página)
Exportar paquete de aplicación y Exportar paquete de servidor (Páginas de asistente)


Modificar entrada de parámetro (Cuadro de diálogo)

Use el cuadro de diálogo Modificar entrada de parámetro para modificar los valores de Tipo, Ámbito y Coincidir con del parámetro. Si no ha creado todavía un parámetro, consulte Agregar o Modificar parámetro (Cuadro de diálogo).

Elementos de la interfaz de usuario

Nombre de elemento | Descripción
Tipo | Use la lista desplegable para cambiar el tipo de parámetro. Los tipos de parámetros posibles son Archivo XML, Archivo de texto, Posición de archivo de texto, Ruta de acceso de proveedor, Atributo de implementación, Enlace de destino y Directorio virtual de destino. Por ejemplo, si ha creado un parámetro Cadena de conexión, podría seleccionar Archivo XML en la lista desplegable porque la cadena de conexión estará dentro de un archivo Web.config, que está en formato XML.
Ámbito | Modifique un ámbito para el atributo que se parametrizará. Este valor es una expresión regular necesaria. Por ejemplo, si el tipo de parámetro es Archivo XML, podría usar la expresión regular \\web.config$ para el ámbito. La primera barra invertida produce un escape a la segunda barra invertida y el signo de dólar ($) detiene la cadena de coincidencia al final de la línea. Por tanto, "\web.config" será el ámbito resultante. Para obtener más información acerca de las expresiones regulares, consulte Expresiones regulares (puede estar en inglés).
Coincidir con | Modifique la expresión que identificará el atributo que se parametrizará. Este valor depende del tipo. En algunos casos será una expresión regular o una expresión XPath. El tipo Xml File requiere que el valor coincidente sea una expresión XPath. Siguiendo el ejemplo anterior, podría usar la expresión XPath //cadenasConexión/agregar/@cadenaConexión para buscar una entrada coincidente en la cadena de conexión dentro de un archivo Web.config.

Consulte también

Conceptos

Seleccionar parámetros (Página)
Exportar paquete de aplicación y Exportar paquete de servidor (Páginas de asistente)


Guardar paquete (Página)

Use la página Guardar paquete del Asistente para exportar paquete de aplicación para especificar un nombre de archivo y una ubicación que desee usar cuando guarde el paquete.

Elementos de la interfaz de usuario

Nombre de elemento | Descripción
Ruta de acceso del paquete | Escriba un nombre de archivo para el paquete. El nombre de archivo debe tener una extensión de nombre de archivo .zip.
Examinar… | Haga clic en el botón Examinar para especificar la ubicación en la que desee guardar el paquete.

Consulte también

Conceptos

Exportar paquete de aplicación y Exportar paquete de servidor (Páginas de asistente)


Contraseña de cifrado (Cuadro de diálogo)

Use el cuadro de diálogo Contraseña de cifrado del Asistente para exportar paquete de aplicación para proporcionar una contraseña para el contenido del paquete que se haya marcado como segura.

Elementos de la interfaz de usuario

Nombre de elemento | Descripción
Contraseña | Escriba la contraseña que se requerirá cuando se importe el paquete más adelante. Si no proporciona la contraseña para las configuraciones marcadas como seguras, no podrá exportar el paquete.
Confirmar contraseña | Vuelva a escribir la contraseña para confirmarla.

Consulte también

Conceptos

Exportar paquete de aplicación y Exportar paquete de servidor (Páginas de asistente)


Progreso y resumen de la exportación (Página)

Use la página Progreso y resumen de la exportación del Asistente para exportar aplicación con el fin de supervisar el estado del proceso de exportación y ver un resumen e información detallada de la operación una vez finalizado el asistente.

Elementos de la interfaz de usuario

Nombre de elemento Descripción

Estado

El área Estado muestra la operación que se está realizando actualmente (por ejemplo, una operación de copia de archivo o de script de base de datos). Durante el proceso de exportación, se le puede pedir una contraseña si la aplicación contiene elementos como contraseñas o certificados que requieren cifrado. Tenga en cuenta que la operación de exportación puede llevar mucho tiempo si la cantidad de datos es grande o si se están exportando datos a un servidor remoto.

Resumen

Proporciona información general sobre las acciones realizadas, incluidos los errores que se hayan generado durante el proceso de creación.

Importante
La ficha Resumen no contiene una lista exhaustiva de las acciones realizadas o de los errores que se han generado. Para buscar información más detallada, haga clic en la ficha Detalles.

Detalles

Proporciona una lista detallada de las acciones que se han realizado. Si se han generado errores, al hacer clic en esta ficha se mostrará información detallada del error que puede usar para solucionar problemas.

Consulte también

Conceptos

Exportar paquete de aplicación y Exportar paquete de servidor (Páginas de asistente)


Importar paquete de aplicación e Importar paquete de servidor o sitio (Páginas de asistente)

Seleccionar paquete (Página)

Contraseña de descifrado (Cuadro de diálogo)

Seleccione el contenido del paquete (Página)

Configuración avanzada (Cuadro de diálogo) (Importar)

Seleccionar base de datos (Página)

Especifique la información del paquete de aplicación (Página)

Sobrescribir archivos existentes (Página)

Progreso y resumen de la instalación (Página)


Seleccionar paquete (Página)

Use la página Seleccionar paquete para seleccionar un paquete existente que desee instalar en el sitio o en el servidor.

Elementos de la interfaz de usuario

Nombre de elemento | Descripción
Ruta de acceso del paquete | Especifica la ubicación del paquete que desea instalar en el sitio o en el servidor.
Examinar… | Haga clic en el botón Examinar para especificar la ubicación del paquete que desee importar.

Consulte también

Conceptos

Importar paquete de aplicación e Importar paquete de servidor o sitio (Páginas de asistente)


Contraseña de descifrado (Cuadro de diálogo)

Use el cuadro de diálogo Contraseña de descifrado del Asistente para importar paquete de aplicación para proporcionar una contraseña para el contenido del paquete que se haya marcado como segura.

Elementos de la interfaz de usuario

Nombre de elemento | Descripción
Contraseña | Escriba la contraseña que se requiere para descifrar el contenido del paquete. Se requiere una contraseña porque algunas configuraciones se marcaron como seguras cuando se creó el paquete. Si no proporciona la contraseña especificada al crear el paquete, no podrá importarlo.

Consulte también

Conceptos

Importar paquete de aplicación e Importar paquete de servidor o sitio (Páginas de asistente)


Seleccione el contenido del paquete (Página)

Use la página Seleccione el contenido del paquete del Asistente para importar paquete de aplicación para ver los componentes que se incluyen en el paquete que seleccionó en la página Seleccione el paquete.

Los paquetes pueden contener información como la configuración del Registro, COM, ensamblados GAC o certificados. Para instalar estos componentes en el servidor, debe ser miembro del grupo Administradores o tener delegada la autoridad adecuada. No necesita derechos de usuario administrador para instalar sólo contenido.

Elementos de la interfaz de usuario

Nombre de elemento Descripción

El paquete contiene

Muestra los componentes que se incluyen en el paquete. Para especificar lo que desea implementar desde el paquete, seleccione o desactive las casillas de componentes adecuadas. Por ejemplo, para incluir o excluir una base de datos de SQL o un ensamblado GAC seleccione o desactive la casilla correspondiente.

Precaución
La aplicación puede necesitar ciertos componentes. Si desactiva las casillas correspondientes a esos componentes, la aplicación puede no funcionar correctamente después de la instalación.

Consulte también

Conceptos

Importar paquete de aplicación e Importar paquete de servidor o sitio (Páginas de asistente)


Configuración avanzada (Cuadro de diálogo) (Importar)

Use el cuadro de diálogo Configuración avanzada del Asistente para importar paquete de aplicación con el fin de especificar la configuración del paquete.

Elementos de la interfaz de usuario

Opciones avanzadas

Nombre de elemento Descripción

Contraseña de descifrado

Abre el cuadro de diálogo Contraseña de descifrado, que le permite escribir la contraseña necesaria para descifrar el contenido del paquete.

Durante una operación de importación, la implementación web detecta automáticamente si está presente un objeto cifrado, como, por ejemplo, un grupo de aplicaciones con una identidad personalizada, en los archivos de configuración del nivel de servidor del paquete (por ejemplo, ApplicationHost.config o Machine.config). Si hay un objeto cifrado, debe proporcionar una contraseña para él. Si no especifica la contraseña correcta, la operación de importación generará un error.

Incluir ACL

Seleccione True si las ACL de la ruta de acceso que especifique se van a copiar desde el origen al destino; de lo contrario, seleccione False. Esta configuración se aplica al sistema de archivos, al Registro y a la metabase, y solo se aplica a los siguientes proveedores: appHostConfig, contentPath, iisApp, metaKey, webServer y webServer60. El valor predeterminado es False.

Extensión de vínculos

Haga clic en el campo de la derecha y, a continuación, en la flecha para mostrar la lista desplegable de las extensiones de vínculos. Seleccione o desactive las extensiones de la lista para habilitar o deshabilitar las extensiones de vínculos que desee aplicar a la operación. Las extensiones de vínculos incluyen o excluyen tipos específicos de datos en una operación. Las extensiones de implementación web disponibles son AppPoolExtension, CertificateExtension, ContentExtension, FrameworkConfigExtension y HttpCertConfigExtension. Estas extensiones están seleccionadas de forma predeterminada. Para obtener más información acerca de las extensiones de vínculos, consulte Extensiones de vínculos de implementación web (puede estar en inglés).

Reintentos

Escriba el número de veces que el proveedor volverá a intentar la operación tras un error. El número predeterminado de reintentos es 5. De forma predeterminada, se produce un retardo de un segundo entre cada reintento. La configuración de reintentos solo se puede usar con el proveedor contentPath.

Intervalo de reintento

Escriba un valor en milisegundos. Este valor especificará el intervalo de tiempo entre reintentos del proveedor. El valor predeterminado es 1000 (un segundo). Esta configuración solo se puede usar con el proveedor contentPath.

Nivel de traza

Seleccione en la lista desplegable un valor que especifique el nivel de detalle que desea en los registros de mensajes de error. Los valores posibles son Off, Error, Warning, Info y Verbose. El valor predeterminado es Info. Off significa que no se registrarán mensajes de error. Verbose significa que se registrarán todos los mensajes.

Opciones de sincronización

Nombre de elemento Descripción

Reglas

Abre el cuadro de diálogo Habilitar o deshabilitar reglas, que permite especificar reglas para la operación. Para obtener más información, consulte Habilitar o deshabilitar reglas (Cuadro de diálogo).

WhatIf

Haga clic en la lista desplegable para seleccionar True o False. True especifica que la operación se ejecutará sin realizar realmente ningún cambio. Puede usar este valor para ver los resultados de una operación si todas las partes de ella se han ejecutado correctamente. El valor predeterminado es False.

Nota
Un comando que parece ejecutarse correctamente con el valor WhatIf puede generar errores cuando se ejecuta sin usar este modo. Esto puede ocurrir si se generan errores inesperados durante la operación. Por ejemplo, dado que no se escriben datos durante una operación WhatIf, no se detectarán los errores de permisos de escritura. El valor WhatIf muestra únicamente lo que ocurrirá si todas las operaciones del comando se ejecutan correctamente.

Consulte también

Conceptos

Seleccione el contenido del paquete (Página)
Importar paquete de aplicación e Importar paquete de servidor o sitio (Páginas de asistente)


Seleccionar base de datos (Página)

Use la página Seleccionar base de datos para seleccionar las opciones de base de datos que desee usar para el paquete que está instalando. Esta página únicamente aparece si hay más de un tipo de base de datos disponible en el paquete.

Nota
Esta página tampoco aparecerá si hay más de un tipo de base de datos disponible en el paquete y se han desactivado las casillas de verificación de la página Seleccione el contenido del paquete para todos los tipos de base de datos excepto uno.

Elementos de la interfaz de usuario

Nombre de elemento | Descripción
Elija la base de datos que desea usar | Seleccione el tipo de base de datos para la instalación. Los tipos de base de datos posibles son SQL, MySQL, VistaDB, SQLite, Archivo plano o Sin base de datos. El contenido del paquete que se está instalando determina las opciones de base de datos que aparecen. Solo las opciones SQL y MySQL tienen proveedores asociados. Para obtener más información, consulte Proveedor dbFullSql de de implementación web (puede estar en inglés) y Proveedor MySQL de implementación web (puede estar en inglés).
Crear una nueva base de datos o usar una base de datos existente | Seleccione Crear nueva base de datos para crear una nueva base de datos o Usar base de datos existente para usar una base de datos existente. Esta opción solo está habilitada cuando se ha elegido SQL o MySQL como tipo de base de datos.

Consulte también

Conceptos

Importar paquete de aplicación e Importar paquete de servidor o sitio (Páginas de asistente)
Especifique la información del paquete de aplicación (Página)


Especifique la información del paquete de aplicación (Página)

Use la página Especifique la información del paquete de aplicación del Asistente para importar paquete de aplicación para especificar los valores de los parámetros declarados en el paquete. Cada parámetro tendrá un campo en la página. Los campos que aparecerán en la página dependerán de los parámetros que se han declarado en el paquete.

Elementos de la interfaz de usuario

Nombre de elemento | Descripción
<Nombre de parámetro> | Especifique un valor para el parámetro que se requiere para instalar el paquete. Esta información puede incluir la ruta de acceso completa del sitio en el que desea instalar la aplicación, las credenciales de usuario o el nombre de la base de datos de la aplicación. Por ejemplo, puede cambiar el valor de ruta de acceso de la aplicación para especificar dónde debe instalarse, por ejemplo, Sitio web predeterminado/NuevaApl.

Consulte también

Conceptos

Modificar cadena de conexión (Cuadro de diálogo)


Modificar cadena de conexión (Cuadro de diálogo)

Use el cuadro de diálogo Modificar cadena de conexión para especificar la cadena de conexión y las credenciales que desea usar.

Elementos de la interfaz de usuario

Nombre de elemento | Descripción
Servidor SQL | Seleccione esta opción para usar el servidor SQL que especifique.
Servidor | Escriba la ruta de acceso o la cadena de conexión del servidor que desee usar (por ejemplo, .\SQLExpress).
Base de datos | Escriba el nombre de la base de datos que desee usar (por ejemplo, Prueba).
Usar seguridad integrada de Windows | Seleccione esta opción para usar la seguridad integrada de Windows. La seguridad integrada de Windows pasa las credenciales de usuario a ASP.NET sin necesidad de volver a autenticar al usuario si este ya ha iniciado sesión en Windows. Este método de autenticación funciona mejor si el cliente y el servidor están en el mismo dominio.
Especificar credenciales | Seleccione esta opción para usar las credenciales especificadas por el usuario. Haga clic en Establecer para abrir el cuadro de diálogo Establecer credenciales y especificar su nombre de usuario y contraseña.
Personalizada | Seleccione esta opción para especificar una ruta de acceso personalizada o una cadena de conexión para el servidor que desee usar (por ejemplo, Server=.\SQLExpress;BaseDeDatos=Prueba;Seguridad integrada=true).

Consulte también

Conceptos

Importar paquete de aplicación e Importar paquete de servidor o sitio (Páginas de asistente)
Especifique la información del paquete de aplicación (Página)


Sobrescribir archivos existentes (Página)

Use la página Sobrescribir archivos existentes para decidir si desea anexar nuevos archivos al destino o sobrescribir los archivos existentes, y eliminar los archivos que no tienen homólogos en el paquete de aplicación.

Elementos de la interfaz de usuario

Nombre de elemento | Descripción
No, solo anexar los archivos del paquete de la aplicación al destino. | Seleccione esta opción para mantener los archivos existentes en el destino y agregar nuevos archivos desde el paquete de aplicación.
Sí, eliminar los archivos y carpetas extra del destino que no están en el paquete de la aplicación. | Seleccione esta opción para eliminar cualesquiera archivos del destino que no están incluidos en el paquete de la aplicación.

Consulte también

Conceptos

Importar paquete de aplicación e Importar paquete de servidor o sitio (Páginas de asistente)


Progreso y resumen de la instalación (Página)

Use la página Progreso y resumen de la instalación para supervisar el estado del proceso de importación y ver un resumen e información detallada de la operación una vez finalizado el asistente.

Elementos de la interfaz de usuario

Nombre de elemento Descripción

Estado

El área Estado muestra la operación que se está realizando actualmente (por ejemplo, una operación de copia de archivo o de script de base de datos). Durante el proceso de importación, se le puede pedir una contraseña si la aplicación contiene elementos como contraseñas o certificados que requieren descifrado. Tenga en cuenta que la operación de importación puede llevar mucho tiempo si la cantidad de datos es grande o si se están importando datos de un servidor remoto.

Resumen

Proporciona información general sobres las acciones realizadas, incluidos los errores que se hayan generado durante el proceso de instalación.

Importante
La ficha Resumen no contiene una lista exhaustiva de las acciones realizadas o de los errores que se han generado. Para buscar información más detallada, haga clic en la ficha Detalles.

Detalles

Proporciona una lista detallada de las acciones que se han realizado. Si se han generado errores, al hacer clic en esta ficha se mostrará información detallada del error que puede usar para solucionar problemas.

Consulte también

Conceptos

Importar paquete de aplicación e Importar paquete de servidor o sitio (Páginas de asistente)