用于 IIS 管理器的 Web 部署工具概述

Web 部署工具 (Web Deploy) 可以将 IIS 配置、内容、SSL 证书和其他类型的数据从用户指定的站点或服务器同步到用户指定的目标。您还可以部署默认情况下未包括的对象，如注册表项。

管理服务委派

在 IIS Manager中，Web Deploy 在服务器级别上添加了一种仅限管理员使用的功能，叫做“管理服务委派”。通过使用此功能，您可以非常精确地控制远程用户可以采取的部署操作。有关详细信息，请参阅“管理服务委派”页。

导出和导入应用程序

在 IIS Manager的“操作”窗格中，可以使用该工具的“导出应用程序包”向导创建包含您的站点、应用程序和内容的压缩文件（包）。有关详细信息，请参阅“导出应用程序包”和“导出服务器包”向导页。

导出包后，可以使用“导入应用程序包”向导将包的内容安装在其他位置。有关详细信息，请参阅“导入应用程序包”和“导入服务器或站点包”向导页。

命令行功能

Web 部署工具的 Msdeploy.exe 可执行程序提供了许多强大的命令行功能。有关 Msdeploy.exe 功能的摘要帮助，请在“命令提示符”窗口中键入 msdeploy -help。有关更多详细的联机帮助信息，请参阅 Web 部署工具（可能为英文页面）。

其他联机资源

IIS.NET：Web 部署工具（可能为英文页面）

IIS.NET：Web 部署工具论坛（可能为英文页面）

IIS.NET：Microsoft Web 部署团队博客帖子（可能为英文页面）


Web 部署工具用户界面 (UI) 帮助

IIS Manager提供 IIS Manager中的每一功能页、对话框和向导页上的所有用户界面 (UI) 元素的描述。若要显示该帮助，请在活动功能页、对话框或向导页上按 F1。

本节内容

“管理服务委派”页

“导出应用程序包”和“导出服务器包”向导页

“导入应用程序包”和“导入服务器或站点包”向导页


“管理服务委派”页

使用“管理服务委派”页可指定用于控制远程用户部署权限的规则。“管理服务委派”页只能由管理员使用，且只在服务器级别上显示。

UI 元素

元素名称 | 描述
提供程序 | 显示规则适用的一个或多个提供程序。
路径 | 显示规则适用的路径。
路径类型 | 显示路径的类型。可能的值有：PathPrefix、StringPrefix、StringSuffix、ConnectionString 和 RegularExpression。
操作 | 显示规则将采取的操作。Web Deploy 提供程序的典型值有“读取”、“写入”和“*”。
标识类型 | 显示运行规则将使用的标识的类型。可能的值有：CurrentUser、ProcessIdentity 和 SpecificUser。
用户名 | 当选择 SpecificUser 作为标识类型时，会显示用户名。当标识类型为 CurrentUser 或 ProcessIdentity 时，将不显示用户名。
状态 | 显示规则是处于启用状态还是禁用状态。可以通过单击“操作”窗格中的“启用规则”或“禁用规则”来启用或禁用规则。

“操作”窗格元素

元素名称 | 描述
添加规则… | 打开“添加规则”对话框。选择此选项可添加规则。有关详细信息，请参阅“添加规则”对话框（管理服务委派）。
将用户添加到规则… | 打开“将用户添加到规则”对话框。有关详细信息，请参阅“将用户添加到规则”对话框。
编辑… | 打开“编辑规则”对话框。有关详细信息，请参阅“添加或编辑规则”对话框。
删除 | 删除所选委派规则或委派规则用户。
禁用规则 | 禁用所选委派规则。
启用规则 | 启用所选委派规则。
编辑功能设置… | 打开“编辑功能设置”对话框。有关详细信息，请参阅“编辑功能设置”对话框（管理服务委派）。


“添加规则”对话框（管理服务委派）
另请参阅

使用“选择规则模板”对话框可选择用来创建自定义委派规则的模板。可以选择空白模板，也可以选择为特定方案设计的已安装模板。

UI 元素

已安装的模板

元素名称 描述

空白规则

创建一个可以自定义的空白规则。

仅限部署内容

创建一个允许部署内容的规则。该规则可以允许任何 Web 管理服务 (WMSvc) 已授权的用户，将内容发布到该用户已经具有 WMSvc 授权的路径。可以编辑该规则来限制对特定路径或用户的访问。该规则使用 contentPath 提供程序，后者用于同步网站内容。有关详细信息，请参阅 Web Deploy contentPath 提供程序（可能为英文页面）。

部署应用程序及内容

创建一个允许部署应用程序的规则。此模板不包括用于将文件夹标记为应用程序的规则，但是它通常与此类规则组合使用。该规则可以允许任何 WMSvc 已授权的用户，将应用程序发布到该用户已经具有 WMSvc 授权的路径。可以编辑该规则来限制对特定路径或用户的访问。该规则使用 contentPath 和 iisApp 提供程序。有关详细信息，请参阅 Web Deploy contentPath 提供程序（可能为英文页面）和 Web Deploy iisApp 提供程序（可能为英文页面）。

部署数据库

创建一个允许部署数据库的规则。该规则可以允许任何 WMSvc 已授权的用户在其可以访问的任何数据库中进行发布。该模板指定所用帐户为 CurrentUser，这表示将使用连接字符串在数据库服务器上验证用户身份。可以编辑该规则来限制对特定数据库服务器或名称的访问。该规则使用 dbFullSql 提供程序，后者允许将数据库从本地 SQL Server 开发数据库首次发布到远程承载的 SQL Server 数据库。有关详细信息，请参阅 Web Deploy dbFullSql 提供程序（可能为英文页面）。

将文件夹标记为应用程序

创建一个用于将文件夹标记为应用程序的规则。该规则可以允许任何 WMSvc 已授权的用户将文件夹标记为应用程序。如果用户不是管理员，则您必须将标识类型更改为具有 ApplicationHost.config 文件的写入权限的帐户。该规则的默认标识类型为 SpecificUser。该规则使用 createApp 提供程序，该提供程序要求将文件夹标记为应用程序，其功能包括在 iisApp 提供程序中。有关详细信息，请参阅 Web Deploy 提供程序（可能为英文页面）。

设置对应用程序的权限

创建一个用于为应用程序路径设置 ACL 的规则。该规则可以允许任何 WMSvc 已授权的用户，为该用户已经具有 WMSvc 授权的应用程序路径设置文件系统 ACL。该模板指定所用帐户为 CurrentUser，这表示用户必须拥有权限才能更改 ACL。可以编辑该规则来限制对特定路径或用户的访问。该规则使用 setAcl 提供程序，后者用于设置目标文件夹的权限。有关详细信息，请参阅 Web Deploy setAcl 提供程序（可能为英文页面） .

备份和还原数据库(使用 SQL 身份验证)

创建一个通过使用 SQL 身份验证来备份和还原数据库的规则。该规则可以允许任何 WMSvc 已授权的用户，创建或还原该用户已经具有访问权限的数据库的备份。将使用 SQL 身份验证以特定的用户标识执行备份和还原操作。可以编辑该规则来限制对特定数据库和一组特定用户的访问。

备注
此模板可以与 IIS 数据库管理器扩展一起使用。有关 IIS 数据库管理器的详细信息，请参阅数据库管理器（可能为英文页面）。

备份和还原数据库(使用 Windows 集成安全性)

创建一个通过使用 Windows 身份验证来备份和还原数据库的规则。该规则可以允许任何 WMSvc 已授权的用户，创建或还原该用户已经具有访问权限的数据库的备份。可以编辑该规则来限制对特定数据库和一组特定用户的访问。

备注
此模板可以与 IIS 数据库管理器扩展一起使用。有关 IIS 数据库管理器的详细信息，请参阅数据库管理器（可能为英文页面）。

另请参阅

概念

“导入应用程序包”和“导入服务器或站点包”向导页

其他资源

Web Deploy 提供程序（可能为英文页面）


“添加或编辑规则”对话框

使用“添加规则”和“编辑规则”对话框可添加和编辑委派规则。

UI 元素

元素名称 | 描述
提供程序 | 单击下拉列表，选择或清除要在规则中添加或从中删除的提供程序，然后单击下拉箭头接受更改。提供程序将在以逗号分隔的列表中显示。有关 Web Deploy 提供程序的详细信息，请参阅 Web Deploy 提供程序（可能为英文页面）。
操作 | 单击下拉列表，选择或清除要在规则中添加或从中删除的操作，然后单击下拉箭头接受更改。操作将在以逗号分隔的列表中显示。Web Deploy 的典型值有“读取”、“写入”和“*”。
路径类型 | 从下拉列表中选择一个路径类型。可能的值有：PathPrefix、StringPrefix、StringSuffix、ConnectionString 和 RegularExpression。有关正则表达式的详细信息，请参阅正则表达式（可能为英文页面）。
路径 | 键入规则将应用的路径。
标识类型 | 从下拉列表中选择规则的标识类型。所选标识将执行规则。可能的值有：CurrentUser、ProcessIdentity 和 SpecificUser。CurrentUser 指定将使用当前用户的标识。ProcessIdentity 指定将使用 WMSvc 本地服务标识。SpecificUser 指定将使用您指定的特殊标识。如果选择 SpecificUser，则必须通过使用“指定凭据”的“设置”按钮提供凭据。
指定凭据 | 选择 SpecificUser 作为标识类型时，会启用“设置”按钮。
设置 | 打开“设置凭据”对话框，通过该对话框，您可以指定 SpecificUser 标识的用户名和密码。有关详细信息，请参阅“设置凭据”对话框（委派规则）。


“设置凭据”对话框（委派规则）

使用“设置凭据”对话框可为执行规则的 Windows 用户提供用户名和密码。

UI 元素

元素名称 | 描述
用户名 | 键入 Windows 用户的用户名。
密码 | 键入密码。
确认密码 | 再次键入密码进行确认。

另请参阅

概念

“添加或编辑规则”对话框


“将用户添加到规则”对话框

使用“将用户添加到规则”对话框可允许或拒绝用户访问规则。

UI 元素

元素名称 | 描述
名称 | 键入用户名。
访问类型 | 选择为指定用户提供的访问类型。可能的值有“允许”和“拒绝”。
是否为角色? | 如果指定的用户名是将被允许或拒绝访问的一组用户的别名，请选中此复选框。


“编辑功能设置”对话框（管理服务委派）

使用“编辑功能设置”对话框可允许管理员绕过委派规则，启用失败请求的记录。

UI 元素

元素名称 描述

允许管理员绕过规则

选择此选项可允许管理员绕过指定的委派规则。

为委派服务启用失败请求跟踪日志

选择此选项可启用失败请求信息的记录。

警告
要使用此功能，必须安装失败请求跟踪模块。


“导出应用程序包”和“导出服务器包”向导页

“选择包的内容”页（创建包）

“选择参数”页

“保存包”页

“加密密码”对话框

“导出进度和摘要”页


“选择包的内容”页（创建包）

使用“导出应用程序包”向导的“选择包的内容”页，可查看要创建的包中包括的组件。

包可以包含诸如注册表设置、COM、GAC 程序集或证书之类的组件。要在服务器上安装这些组件，您必须是管理员组的成员，或者必须已经委派给您相应的权限。如果只安装内容，则无需管理员用户权限。

UI 元素

元素名称 描述

包中包含

列出包中包括的组件。通过选择或清除相应的组件复选框，可以指定要包括在包中的组件。例如，通过选择或清除对应的复选框，可以包括或排除 SQL 数据库或 GAC 程序集。

注意
有些组件可能是应用程序必需的组件。如果清除这些组件的复选框，则在安装后应用程序可能无法正常工作。

特性

在右窗格中显示所选文件、目录或组件的特性。这些值为只读。

管理组件…

打开“管理组件”对话框。这样可以选择要包括的组件。有关详细信息，请参阅“管理组件”对话框。

高级设置…

打开“高级设置”对话框。通过该对话框，您可以指定操作设置和规则。有关详细信息，请参阅“高级设置”对话框（导出）。

另请参阅

概念

“导出应用程序包”和“导出服务器包”向导页

其他资源

通过 IIS 管理器导出包（联机资源）（可能为英文页面）


“管理组件”对话框

使用“导出应用程序包”向导的“管理组件”对话框可向包中添加组件（如 COM 对象或 GAC 程序集）。

UI 元素

列标题

元素名称 描述

提供程序名称

指定要打包的组件。每个组件都有一个提供程序。单击该字段可使用下拉列表选择一个提供程序名称。将鼠标悬停在提供程序名称上可查看该提供程序的描述。例如，如果选择“dbFullSql”，则将打包脚本或连接字符串的路径。有关提供程序的详细信息，请参阅 Web Deploy 提供程序（可能为英文页面）。

重要事项
如果要打包网站，则 iisApp 提供程序（默认情况下处于选定状态）会在目标上将该网站标记为应用程序。如果要打包网站及其所有相关配置（如应用程序池名称、内容目录的位置和所有证书），请使用 appHostConfig 提供程序。如果使用 iisApp 提供程序，则该网站将变成目标上的应用程序，并从安装它的站点继承其所有设置（如应用程序池名称和内容目录）。

路径

指定将为包提供数据的组件的路径。例如，如果选择“dbFullSql”，则路径可以指定脚本（如 C:\SQLfiles\installSQL.sql）或连接字符串（如 Data Source=.\sqlexpress;Integrated Security=SSPI;Initial Catalog=db1）。

提供程序设置

指定要用于所选提供程序的提供程序设置。单击该字段可使用浏览 (…) 按钮打开“提供程序设置”对话框。有关详细信息，请参阅“提供程序设置”对话框。

按钮

元素名称 | 描述
删除 | 删除所选项。
上移 | 在列表中将所选行向上移动。条目将按它们在列表中出现的顺序进行安装。条目的顺序对于某些提供程序很重要。例如，用于创建表的脚本应该在用于填充表的脚本之前运行。
下移 | 在列表中将所选行向下移动。条目将按它们在列表中出现的顺序进行安装。

另请参阅

概念

“选择包的内容”页（创建包）
“导出应用程序包”和“导出服务器包”向导页


“提供程序设置”对话框

使用“提供程序设置”对话框可指定所选提供程序的设置。并不是所有的提供程序都具有设置。

UI 元素

元素名称 | 描述
设置名称 | 显示所选提供程序设置的名称。仅列出与所选提供程序相关的设置。
设置值 | 键入或选择设置的值。如果下拉列表可用，可能的设置值将会出现在列表中。对于必须键入的值，描述框提供有关可接受的值的信息。
设置描述 | 显示提供程序的所选设置的描述。提供有关该设置所允许的值的信息。

另请参阅

概念

“管理组件”对话框
“选择包的内容”页（创建包）
“导出应用程序包”和“导出服务器包”向导页

其他资源

Web Deploy 提供程序设置（可能为英文页面）


“高级设置”对话框（导出）

使用“导出应用程序包”向导的“高级设置”对话框可指定包的设置。

UI 元素

高级选项

元素名称 描述

加密密码

单击“…”打开“加密密码”对话框可指定一个字母数字密码，该密码可以控制访问 IIS 配置中的安全属性。

Web Deploy 自动检测服务器级别的配置文件（例如，ApplicationHost.config 或 Machine.config）中是否存在加密对象（如具有自定义标识的应用程序池）。如果存在加密对象，则必须提供对象的密码。如果未指定正确的密码，则导出操作将失败。

重要事项
Web Deploy 不检查 Web.config 文件中是否存在加密对象。

包括 ACl

如果所指定路径的 ACL 将从源复制到目标，请选择“True”；否则，选择“False”。此设置适用于文件系统、注册表和元数据库，且仅适用于以下提供程序：appHostConfig、contentPath、iisApp、metaKey、webServer 和 webServer60。默认值为 false。

链接扩展

单击右侧的字段，然后单击箭头可显示链接扩展的下拉列表。选择或清除列表中的扩展可启用或禁用要应用于操作的链接扩展。链接扩展在操作中包括或排除特定种类的数据。可用的 Web Deploy 扩展有：AppPoolExtension、CertificateExtension、ContentExtension、FrameworkConfigExtension 和 HttpCertConfigExtension。默认情况下，这些扩展处于选定状态。有关链接扩展的详细信息，请参阅 Web Deploy 链接扩展（可能为英文页面）。

重试次数

键入提供程序操作失败后将重试的次数。默认的重试次数为 5。默认情况下，在各重试之间有 1 秒的延迟。重试次数的设置只能用于 contentPath 提供程序。

重试间隔

键入一个以毫秒为单位的值。该值将指定提供程序尝试重试的时间间隔。默认值为 1000（1 秒）。此设置只能用于 contentPath 提供程序。

跟踪级别

从下拉列表中选择一个值，该值用于指定错误消息日志中详细信息的级别。可能的值有“关闭”、“错误”、“警告”、“信息”和“详细”。默认值为“信息”。“关闭”表示将不记录错误消息。“详细”表示将记录所有消息。

同步选项

元素名称 描述

规则

打开“启用或禁用规则”对话框，通过该对话框指定操作的规则。有关详细信息，请参阅“启用或禁用规则”对话框。

WhatIf

单击下拉列表以选择 True 或 False。True 指定将在不实际进行任何更改的情况下运行操作。如果操作的所有部分均成功，则可以使用此设置查看操作的结果。默认值为 False。

备注
对于使用 WhatIf 设置似乎成功运行的命令，在不使用 WhatIf 设置的情况下运行它可能会失败。如果在操作期间出现意外错误，则会发生这种情况。例如，由于在 WhatIf 操作期间未写入数据，因此不会检测到写入权限错误。WhatIf 设置仅显示命令中的所有操作都成功时将发生的情况。

另请参阅

概念

“选择包的内容”页（创建包）
“导出应用程序包”和“导出服务器包”向导页


“启用或禁用规则”对话框

使用“启用或禁用规则”对话框可启用或禁用影响同步操作结果的规则。从“分组依据”下拉列表中选择“状态”可将规则分为禁用和启用两类，或者选择“不进行分组”以字母数字顺序查看规则。

UI 元素

列标题

元素名称 | 描述
名称 | 列出可以启用或禁用的同步规则的名称。默认启用以粗体显示的规则；默认禁用以带阴影文本显示的规则。可以通过选择规则，然后使用“启用规则”或“禁用规则”按钮来启用或禁用规则。有关这些规则的详细信息，请参阅 Web Deploy 规则（可能为英文页面）。

按钮

元素名称 | 描述
启用规则 | 启用所选规则。
禁用规则 | 禁用所选规则。

另请参阅

概念

“导出应用程序包”和“导出服务器包”向导页
“导入应用程序包”和“导入服务器或站点包”向导页


“选择参数”页

使用“导出应用程序包”向导的“选择参数”页，可向包中添加或从包中删除参数。在创建包时，可以为特性分配参数。然后，当安装完包之后，用户可以为参数指定自定义值，并为该特性分配新值。自动为每个提供程序生成参数。

UI 元素

列标题

元素名称 | 描述
名称 | 列出通过使用“添加参数”对话框添加的参数的名称。可以通过双击参数，或者通过选择参数然后单击“编辑”来编辑参数。
类型 | 显示将进行参数化的特性的参数类型。
范围 | 显示将进行参数化的特性的范围。
匹配 | 显示用于标识要进行参数化的特性的表达式。

按钮

元素名称 | 描述
添加参数 | 打开“添加参数”对话框。通过此对话框可以添加参数和设置其属性。有关详细信息，请参阅“添加参数”或“编辑参数”对话框。
添加参数项 | 打开“添加参数项”对话框。通过此对话框可以配置所选参数的“类型”、“范围”和“匹配”值。有关详细信息，请参阅“添加参数项”对话框。选择参数或参数项时会启用此选项。
编辑 | 如果选择了参数，此按钮会打开“编辑参数”对话框。通过此对话框可以编辑现有参数的属性。有关详细信息，请参阅“添加参数”或“编辑参数”对话框。 如果选择了参数项，此按钮会打开“编辑参数项”对话框。有关详细信息，请参阅“编辑参数项”对话框。
删除 | 删除所选参数。
上移 | 在参数列表中，将所选参数向上移动。参数将按照它们在列表中的出现顺序进行处理。
下移 | 在参数列表中，将所选参数向下移动。参数将按照它们在列表中的出现顺序进行处理。

另请参阅

概念

“导出应用程序包”和“导出服务器包”向导页


“添加参数”或“编辑参数”对话框

使用“添加参数”对话框或“编辑参数”对话框，可为应用程序包添加新参数或编辑现有参数。

UI 元素

元素名称 描述

名称

键入参数的名称。例如，连接字符串。

默认值

键入参数的默认值。之后部署包时，除非用户指定其他值，否则参数将包含此值。例如，如果键入了连接字符串作为参数名称，则可以使用 Data Source=.\SQLExpress;Database=Test;Integrated Security 作为默认值。此条目不是必需条目。

重要事项
如果希望要求用户提供参数的值，则不要指定默认值。

标记

键入自定义特性的列表，该列表以逗号分隔。“标记”是以后可以引用的参数的可选特性。例如，可以将参数标记为密码，这样用户界面将不会显示密码值。此条目不是必需条目。通过使用“默认值”元素描述中的示例，可以将标记 SQL, SQLConnectionString 用于连接字符串参数。

描述

输入参数的描述。例如，“这是应用程序使用的数据库的连接字符串。如果您的环境中具有其他 SQL 服务器或数据库，请对其进行更改。”描述将包含在包内的 Parameters.xml 文件中，如果在命令提示符中键入 msdeploy -verb:getParameters -source:package=<PackageFileName>，则可以显示该描述。

类型

可以随意选择参数验证类型。可能的值有“无”、“正则表达式”、“枚举”或“布尔值”。默认值为“无”。如果您选择“无”以外的参数验证类型，则会对用户提供的参数值进行检查，以确定其是否满足您所指定的条件。如果您选择“正则表达式”或“枚举”，则必须在“验证字符串”框中提供验证字符串。

验证字符串

键入正则表达式或以逗号分隔的枚举值列表。有关正则表达式的详细信息，请参阅正则表达式（可能为英文页面）。

另请参阅

概念

“选择参数”页
“导出应用程序包”和“导出服务器包”向导页


“添加参数项”对话框

使用“添加参数项”对话框可指定参数的“类型”、“范围”和“匹配”值。

UI 元素

元素名称 | 描述
类型 | 使用该下拉列表可以为将进行参数化的特性选择要使用的参数类型。可能的参数类型有：“Xml 文件”、“文本文件”、“文本文件位置”、“提供程序路径”、“部署特性”、“目标绑定”和“目标虚拟目录”。例如，如果创建“连接字符串”参数，则可以选择下拉列表中的“Xml 文件”，因为将在 XML 格式的 Web.config 文件内查找连接字符串。
范围 | 输入将进行参数化的特性的范围。此值为必需的正则表达式。例如，如果参数类型为 Xml File，则可以使用正则表达式 \\web.config$ 表示范围。第一个反斜杠将第二个反斜杠转义，而美元符号 ($) 在行尾停止匹配字符串。因此，“\web.config”将是得到的范围。有关正则表达式的详细信息，请参阅正则表达式（可能为英文页面）。
匹配 | 键入用于标识要进行参数化的特性的表达式。此值取决于类型。在某些情况下，它将是正则表达式或 XPath 表达式。Xml File 类型要求匹配值是 XPath 表达式。按照前面的示例，可以使用 XPath 表达式 //connectionStrings/add/@connectionString 匹配 Web.config 文件内的连接字符串条目。

另请参阅

概念

“选择参数”页
“导出应用程序包”和“导出服务器包”向导页


“编辑参数项”对话框

使用“编辑参数项”对话框可编辑参数的“类型”、“范围”和“匹配”值。如果尚未创建参数，请参阅“添加参数”或“编辑参数”对话框。

UI 元素

元素名称 | 描述
类型 | 使用该下拉列表可更改参数类型。可能的参数类型有：“Xml 文件”、“文本文件”、“文本文件位置”、“提供程序路径”、“部署特性”、“目标绑定”和“目标虚拟目录”。例如，如果创建“连接字符串”参数，则可以选择下拉列表中的“Xml 文件”，因为将在 XML 格式的 Web.config 文件内查找连接字符串。
范围 | 编辑将进行参数化的特性的范围。此值为必需的正则表达式。例如，如果参数类型为“Xml 文件”，则可以使用正则表达式 \\web.config$ 表示范围。第一个反斜杠将第二个反斜杠转义，而美元符号 ($) 在行尾停止匹配字符串。因此，“\web.config”将是得到的范围。有关正则表达式的详细信息，请参阅正则表达式（可能为英文页面）。
匹配 | 编辑用于标识要进行参数化的特性的表达式。此值取决于类型。在某些情况下，它将是正则表达式或 XPath 表达式。Xml File 类型要求匹配值是 XPath 表达式。按照前面的示例，可以使用 XPath 表达式 //connectionStrings/add/@connectionString 匹配 Web.config 文件内的连接字符串条目。

另请参阅

概念

“选择参数”页
“导出应用程序包”和“导出服务器包”向导页


“保存包”页

使用“导出应用程序包”向导的“保存包”页，可指定保存包时要使用的文件名和位置。

UI 元素

元素名称 | 描述
包路径 | 键入包的文件名。该文件名必须具有 .zip 文件扩展名。
浏览… | 单击浏览按钮可指定要保存包的位置。

另请参阅

概念

“导出应用程序包”和“导出服务器包”向导页


“加密密码”对话框

使用“导出应用程序包”向导的“加密密码”对话框，可为已标记为安全设置的包内容提供密码。

UI 元素

元素名称 | 描述
密码 | 键入以后导入包时需要提供的密码。如果不能为标记为安全的设置提供密码，则无法导出包。
确认密码 | 再次键入密码进行确认。

另请参阅

概念

“导出应用程序包”和“导出服务器包”向导页


“导出进度和摘要”页

使用“导出应用程序”向导的“导出进度和摘要”页可监视导出过程的状态，并在向导结束后查看操作的摘要和详细信息。

UI 元素

元素名称 描述

状态

“状态”区域显示当前执行的操作（例如，文件复制或数据库脚本操作）。在导出过程中，如果应用程序包含诸如要求加密的密码或证书之类的项，则系统可能会提示您输入密码。请注意，如果数据量很大，或者如果将数据导出到远程服务器，则导出操作可能需要很长时间。

摘要

提供已执行操作的概述，包括创建过程中出现的任何错误。

重要事项
“摘要”选项卡不包含已执行操作的详尽列表或出现的错误的详尽列表。可以通过单击“详细信息”选项卡查找更详细的信息。

详细信息

提供已执行操作的详细列表。如果出现任何错误，则单击此选项卡会显示可用于故障排除的详细错误消息。

另请参阅

概念

“导出应用程序包”和“导出服务器包”向导页


“导入应用程序包”和“导入服务器或站点包”向导页

“选择包”页

“解密密码”对话框

“选择包的内容”页

“高级设置”对话框（导入）

“选择数据库”页

“输入应用程序包信息”页

“覆盖现有文件”页

“安装进度和摘要”页


“选择包”页

使用“选择包”页可选择要在站点或服务器上安装的现有包。

UI 元素

元素名称 | 描述
包路径 | 指定要在站点或服务器上安装的包的位置。
浏览… | 单击浏览按钮可指定要导入的包的位置。

另请参阅

概念

“导入应用程序包”和“导入服务器或站点包”向导页


“解密密码”对话框

使用“导入应用程序包”向导的“解密密码”对话框，可为有安全设置的包内容提供密码。

UI 元素

元素名称 | 描述
密码 | 键入解密包内容所需的密码。密码是必需的，因为在创建包时某些设置已标记为安全。如果不能提供创建包时所指定的密码，则无法导入包。

另请参阅

概念

“导入应用程序包”和“导入服务器或站点包”向导页


“选择包的内容”页

使用“导入应用程序包”向导的“选择包的内容”页，可查看在“选择包”页上所选择的包中包含的组件。

包可以包含诸如注册表设置、COM、GAC 程序集或证书之类的组件。要在服务器上安装这些组件，您必须是管理员组的成员，或者必须已经委派给您相应的权限。如果只安装内容，则无需管理员用户权限。

UI 元素

元素名称 描述

包中包含

列出包中包括的组件。通过选择或清除相应的组件复选框，可以指定要从包中部署的组件。例如，通过选择或清除对应的复选框，可以包括或排除 SQL 数据库或 GAC 程序集。

注意
有些组件可能是应用程序必需的组件。如果清除这些组件的复选框，则在安装后应用程序可能无法正常工作。

另请参阅

概念

“导入应用程序包”和“导入服务器或站点包”向导页


“高级设置”对话框（导入）

使用“导入应用程序包”向导的“高级设置”对话框可指定包的设置。

UI 元素

高级选项

元素名称 | 描述
解密密码 | 打开“解密密码”对话框，通过该对话框键入解密包内容所需的密码。 在导入操作过程中，Web Deploy 自动检测包的服务器级别配置文件（例如，ApplicationHost.config 或 Machine.config）中是否存在加密对象（如具有自定义标识的应用程序池）。如果存在加密对象，则必须提供对象的密码。如果未指定正确的密码，则导入操作将失败。
包括 ACl | 如果所指定路径的 ACL 将从源复制到目标，请选择“True”；否则，选择“False”。此设置适用于文件系统、注册表和元数据库，且仅适用于以下提供程序：appHostConfig、contentPath、iisApp、metaKey、webServer 和 webServer60。默认值为 False。
链接扩展 | 单击右侧的字段，然后单击箭头可显示链接扩展的下拉列表。选择或清除列表中的扩展可启用或禁用要应用于操作的链接扩展。链接扩展在操作中包括或排除特定种类的数据。可用的 Web Deploy 扩展有：AppPoolExtension、CertificateExtension、ContentExtension、FrameworkConfigExtension 和 HttpCertConfigExtension。默认情况下，这些扩展处于选定状态。有关链接扩展的详细信息，请参阅 Web Deploy 链接扩展（可能为英文页面）。
尝试重试 | 键入提供程序操作失败后将重试的次数。默认的重试次数为 5。默认情况下，在各重试之间有 1 秒的延迟。尝试重试的设置只能用于 contentPath 提供程序。
重试间隔 | 键入一个以毫秒为单位的值。该值将指定提供程序尝试重试的时间间隔。默认值为 1000（1 秒）。此设置只能用于 contentPath 提供程序。
跟踪级别 | 从下拉列表中选择一个值，该值用于指定错误消息日志中详细信息的级别。可能的值有“关闭”、“错误”、“警告”、“信息”和“详细”。默认值为“信息”。“关闭”表示将不记录错误消息。“详细”表示将记录所有消息。

同步选项

元素名称 描述

规则

打开“启用或禁用规则”对话框，通过该对话框指定操作的规则。有关详细信息，请参阅“启用或禁用规则”对话框。

WhatIf

单击下拉列表以选择 True 或 False。True 指定将在不实际进行任何更改的情况下运行操作。如果操作的所有部分均成功，则可以使用此设置查看操作的结果。默认值为 False。

备注
对于使用 WhatIf 设置似乎成功运行的命令，在不使用 WhatIf 设置的情况下运行它可能会失败。如果在操作期间出现意外错误，则会发生这种情况。例如，由于在 WhatIf 操作期间未写入数据，因此不会检测到写入权限错误。WhatIf 设置仅显示命令中的所有操作都成功时将发生的情况。

另请参阅

概念

“选择包的内容”页
“导入应用程序包”和“导入服务器或站点包”向导页


“选择数据库”页

使用“选择数据库”页可选择要用于所安装的包的数据库选项。只有当包中有多个数据库类型时，此页面才会显示。

备注
如果包中有多个数据库类型，但已在“选择包的内容”页上清除所有其他数据库类型的复选框，只保留一种数据库类型，则也不会显示此页面。

UI 元素

元素名称 | 描述
选择要使用的数据库 | 为安装选择数据库类型。可能的数据库类型有“SQL”、“MySQL”、“VistaDB”、“SQLite”、“平面文件”或“无数据库”。所安装的包的内容决定哪些数据库选项会显示出来。只有 SQL 和 MySQL 选项具有关联的提供程序。有关详细信息，请参阅 Web Deploy dbFullSql 提供程序（可能为英文页面）和 Web Deploy MySQL 提供程序（可能为英文页面）。
创建新数据库或使用现有数据库 | 选择“创建新数据库”创建新的数据库，或选择“使用现有数据库”以使用现有数据库。仅当选择 SQL 或 MySQL 作为数据库类型时，才会启用此选项。

另请参阅

概念

“导入应用程序包”和“导入服务器或站点包”向导页
“输入应用程序包信息”页


“输入应用程序包信息”页

使用“导入应用程序包”向导的“输入应用程序包信息”页可指定已在包中声明的参数的值。每个参数在该页上都具有一个字段。在页上出现的字段取决于已在包中声明的参数。

UI 元素

元素名称 | 描述
<参数名称> | 指定安装包所需的参数的值。此信息可以包括要安装应用程序的完整站点路径、用户凭据或应用程序的数据库名称。例如，可以更改应用程序路径值，以指定应该安装应用程序的位置，如：默认网站/NewApp。

另请参阅

概念

“编辑连接字符串”对话框


“编辑连接字符串”对话框

使用“编辑连接字符串”对话框可指定要使用的连接字符串和凭据。

UI 元素

元素名称 | 描述
SQL 服务器 | 选择此选项可使用您指定的 SQL 服务器。
服务器 | 键入要使用的服务器路径或连接字符串（例如，.\SQLExpress）。
数据库 | 键入要使用的数据库的名称（例如，Test）。
使用 Windows 集成安全性 | 选择此选项可使用 Windows 集成安全性。如果用户已登录到 Windows，则 Windows 集成安全性会将用户凭据传递到 ASP.NET，而不需要重新验证身份。此身份验证方法最适合于客户端和服务器处于同一域的情况。
指定凭据 | 选择此选项可使用用户指定的凭据。单击“设置”可打开“设置凭据”对话框并指定您的用户名和密码。
自定义 | 选择此选项可指定要使用的服务器的自定义路径或连接字符串（例如，Server=.\SQLExpress;Database=Test;Integrated Security=true）。

另请参阅

概念

“导入应用程序包”和“导入服务器或站点包”向导页
“输入应用程序包信息”页


“覆盖现有文件”页

使用“覆盖现有文件”页可确定要将新文件附加到目标，还是要覆盖现有文件并删除在应用程序包中没有对应项的文件。

UI 元素

元素名称 | 描述
否，仅将应用程序包中的文件附加到目标。 | 选择此选项可将现有文件保留在目标上，并添加来自应用程序包的新文件。
是，删除目标上不属于应用程序包的所有多余文件和文件夹。 | 选择此选项可删除目标上未包括在应用程序包中的任何文件。

另请参阅

概念

“导入应用程序包”和“导入服务器或站点包”向导页


“安装进度和摘要”页

使用“安装进度和摘要”页可监视导入过程的状态，并在向导结束后查看操作的摘要和详细信息。

UI 元素

元素名称 描述

状态

“状态”区域显示当前执行的操作（例如，文件复制或数据库脚本操作）。在导入过程中，如果应用程序包含密码或证书等需要解密的项，则系统可能会提示您输入密码。请注意，如果数据量很大，或者如果从远程服务器导入数据，则导入操作可能需要很长时间。

摘要

提供已执行操作的概述，包括安装过程中出现的任何错误。

重要事项
“摘要”选项卡不包含已执行操作的详尽列表或出现的错误的详尽列表。可以通过单击“详细信息”选项卡查找更详细的信息。

详细信息

提供已执行操作的详细列表。如果出现任何错误，则单击此选项卡会显示可用于故障排除的详细错误消息。

另请参阅

概念

“导入应用程序包”和“导入服务器或站点包”向导页