IIS 管理員的 Web Deployment Tool 概觀

Web Deployment Tool (Web Deploy) 可將使用者指定之站台或伺服器上的 IIS 設定、內容、SSL 憑證及其他資料類型，同步處理至使用者指定的目的地。########## 您也可以部署預設未包含的物件，例如登錄機碼。

管理服務委派

在 IIS Manager中，Web Deploy 會在伺服器層級加入一個僅限系統管理員操作的功能，稱為「管理服務委派」，這個功能可讓您高度精準地控制遠端使用者可以採取的部署動作。 如需詳細資訊，請參閱管理服務委派頁面。

匯出及匯入應用程式

在 IIS Manager的 [動作] 窗格中，您可以使用此工具的 [匯出應用程式封裝精靈] 來建立壓縮檔案 (封裝)，其中可包含您的站台、應用程式和內容。 如需詳細資訊，請參閱匯出應用程式封裝和匯出伺服器封裝精靈頁面。

匯出封裝後，就可以使用 [匯入應用程式封裝精靈]，將封裝的內容安裝至其他位置。 如需詳細資訊，請參閱匯入應用程式封裝和匯入伺服器或站台封裝精靈頁面。

命令列功能

Web Deployment Tool 的 Msdeploy.exe 執行檔提供許多強大的命令列功能。 如需 Msdeploy.exe 功能的摘要說明，請在命令提示字元視窗輸入 msdeploy -help。 如需詳細的線上說明，請參閱 Web Deployment Tool (英文)。

其他線上資源

IIS.NET：Web Deployment Tool (英文)

IIS.NET：Web Deployment Tool 論壇 (英文)

IIS.NET：Microsoft Web Deployment 團隊部落格文章 (英文)


Web Deployment Tool 使用者介面 (UI) 說明

IIS Manager 提供 IIS Manager 中各功能頁、對話方塊及精靈上之所有使用者介面 (UI) 元素的描述。若要顯示此說明，請在作用中的功能頁、對話方塊或精靈網頁上按 F1。

本節內容

管理服務委派頁面

匯出應用程式封裝和匯出伺服器封裝精靈頁面

匯入應用程式封裝和匯入伺服器或站台封裝精靈頁面


管理服務委派頁面

使用 [管理服務委派] 頁面，可以指定用來控制遠端使用者部署權限的規則。 [管理服務委派] 頁面只會出現在伺服器層級，而且只有系統管理員可以操作。

UI 元素

元素名稱 | 描述
提供者 | 顯示規則所套用的一個或多個提供者。
路徑 | 顯示規則所套用的路徑。
路徑類型 | 顯示路徑的類型。 可能的值包括 [PathPrefix]、[StringPrefix]、[StringSuffix]、[ConnectionString] 及 [RegularExpression]。
動作 | 顯示規則將採取的動作。 如果是 Web Deploy 提供者，常見的值包括 [讀取]、[寫入] 及 [*]。
識別類型 | 顯示執行規則的識別類型。 可能的值包括 [CurrentUser]、[ProcessIdentity] 及 [SpecificUser]。
使用者名稱 | 顯示選取 SpecificUser 做為識別類型時的使用者名稱。 識別類型為 CurrentUser 或 ProcessIdentity 時，不會顯示使用者名稱。
狀態 | 顯示規則啟用或停用。 您可以按一下 [動作] 窗格中的 [啟用規則] 或 [停用規則]，即可啟用或停用規則。

動作窗格元素

元素名稱 | 描述
新增規則... | 開啟 [新增規則] 對話方塊。 選取此選項以新增規則。 如需詳細資訊，請參閱新增規則對話方塊 (管理服務委派)。
新增使用者至規則… | 開啟 [新增使用者至規則] 對話方塊。 如需詳細資訊，請參閱新增使用者至規則對話方塊。
編輯… | 開啟 [編輯規則] 對話方塊。 如需詳細資訊，請參閱新增或編輯規則對話方塊。
移除 | 移除選取的委派規則或委派規則使用者。
停用規則 | 停用選取的委派規則。
啟用規則 | 啟用選取的委派規則。
編輯功能設定… | 開啟 [編輯功能設定] 對話方塊。 如需詳細資訊，請參閱編輯功能設定對話方塊 (管理服務委派)。


新增規則對話方塊 (管理服務委派)
另請參閱

使用 [選取規則範本] 對話方塊，可選取可用來建立自訂委派規則的範本。 您可以選擇空白範本或者專為特定案例設計的已安裝範本。

UI 元素

已安裝範本

元素名稱 描述

空白規則

建立可進行自訂的空白規則。

僅部署內容

建立可進行內容部署的規則。 規則會准許任何 Web Management Service (WMSvc) 授權的使用者將內容發行至使用者具有 WMSvc 授權的路徑。 規則可編輯成將存取權限制為特定的路徑或使用者。 此規則使用 contentPath 提供者，它會與網站內容同步處理。 如需詳細資訊，請參閱 Web Deploy contentPath 提供者 (英文)。

部署含內容的應用程式

建立可進行應用程式部署的規則。 此範本不含可將資料夾標記為應用程式的規則，但常與此類規則搭配使用。 規則會准許 WMSvc 授權的使用者將應用程式發行到該使用者具有 WMSvc 授權的路徑。 規則可編輯成將存取權限制為特定的路徑或使用者。 此規則使用 contentPath 和 iisApp 提供者。 如需詳細資訊，請參閱 Web Deploy contentPath 提供者 (英文) 和 Web Deploy iisApp 提供者 (英文)。

部署資料庫

建立可進行資料庫部署的規則。 規則會准許任何 WMSvc 授權的使用者發行至他們可以存取的任何資料庫。 範本會指定使用的帳戶為 CurrentUser，這表示將使用連接字串來驗證資料庫伺服器的使用者。 規則可編輯成將存取權限制為特定的資料庫伺服器或名稱。 此規則使用 dbFullSql 提供者，可協助從本機 SQL Server 開發資料庫首次發行資料庫至遠端裝載的 SQL Server 資料庫。 如需詳細資訊，請參閱 Web Deploy dbFullSql 提供者 (英文)。

將資料夾標記為應用程式

建立可將資料夾標記為應用程式的規則。 規則會准許任何 WMSvc 授權的使用者將資料夾標記為應用程式。 如果使用者不是系統管理員，則必須將識別類型變更為對 ApplicationHost.config 檔案有寫入權限的帳戶。 此規則的預設識別類型是 SpecificUser。 此規則使用 createApp 提供者，該提供者需要將資料夾標記為應用程式，且其功能均內含於 iisApp 提供者。 如需詳細資訊，請參閱 Web Deploy 提供者 (英文)。

設定應用程式的權限

建立可設定應用程式路徑之 ACL 的規則。 規則會准許任何 WMSvc 授權的使用者能夠針對使用者有 WMSvc 授權的應用程式路徑設定檔案系統 ACL。 範本會指定使用的帳戶為 CurrentUser，這表示使用者必須具有使用權限後才能變更 ACL。 規則可編輯成將存取權限制為特定的路徑或使用者。 此規則使用 setAcl 提供者，它會設定目的資料夾的權限。 如需詳細資訊，請參閱 Web Deploy setAcl 提供者 (英文)。 .

備份和還原資料庫 (使用 SQL 驗證)

建立可使用 SQL 驗證來備份和還原資料庫的規則。 規則會准許任何 WMSvc 授權的使用者為該使用者有權存取的資料庫建立或還原備份。 備份和還原作業將以使用 SQL 驗證的特定使用者識別身分執行。 規則可編輯成將存取權限制為特定資料庫和特定使用者集合。

備註
請使用此範本搭配 IIS Database Manager 擴充程式。 如需 IIS Database Manager 的詳細資訊，請參閱 資料庫管理員 (英文)。

備份和還原資料庫 (使用 Windows 整合式安全性)

建立可使用 Windows 驗證來備份和還原資料庫的規則。 規則會准許任何 WMSvc 授權的使用者為該使用者有權存取的資料庫建立或還原備份。 規則可編輯成將存取權限制為特定資料庫和特定使用者集合。

備註
請使用此範本搭配 IIS Database Manager 擴充程式。 如需 IIS Database Manager 的詳細資訊，請參閱 資料庫管理員 (英文)。

另請參閱

概念

匯入應用程式封裝和匯入伺服器或站台封裝精靈頁面

其他資源

Web Deploy 提供者 (英文)


新增或編輯規則對話方塊

使用 [新增規則] 和 [編輯規則] 對話方塊，可以新增和編輯委派規則。

UI 元素

元素名稱 | 描述
提供者 | 按一下下拉式清單，可選取或清除您要新增至規則或從規則移除的提供者，再按一下下拉箭號即可接受變更。 提供者會以逗號分隔的清單顯示。 如需 Web Deploy 提供者的詳細資訊，請參閱 Web Deploy 提供者 (英文)。##########
動作 | 按一下下拉式清單，可選取或清除您要新增至規則或從規則移除的動作，再按一下下拉箭號即可接受變更。 動作會以逗號分隔的清單顯示。 Web Deploy 常見的值包括 [讀取]、[寫入] 及 [*]。
路徑類型 | 從下拉式清單選取路徑類型。 可能的值包括 [PathPrefix]、[StringPrefix]、[StringSuffix]、[ConnectionString] 及 [RegularExpression]。 如需規則運算式的詳細資訊，請參閱規則運算式 (英文)。
路徑 | 輸入要套用規則的路徑。
識別類型 | 從下拉式清單選取規則的識別類型。 將由選取的識別來執行規則。 可能的值包括 [CurrentUser]、[ProcessIdentity] 及 [SpecificUser]。 [CurrentUser] 會指定將使用目前使用者的識別。 [ProcessIdentity] 會指定將使用 WMSvc 本機服務識別。 [SpecificUser] 會指定將使用您指定的特殊識別。 如果選取 [SpecificUser]，則必須使用 [設定] 中的 [指定認證] 按鈕提供認證。
指定認證 | 選取 [SpecificUser] 做為識別類型時，啟用 [設定] 按鈕。
設定 | 開啟 [設定認證] 對話方塊，可為 SpecificUser 識別指定使用者名稱和密碼。 如需詳細資訊，請參閱設定認證對話方塊。


設定認證對話方塊

使用 [設定認證] 對話方塊，可為執行規則的 Windows 使用者提供使用者名稱和密碼。

UI 元素

元素名稱 | 描述
使用者名稱 | 輸入 Windows 使用者的使用者名稱。
密碼 | 輸入密碼。
確認密碼 | 再次輸入密碼以進行確認。

另請參閱

概念

新增或編輯規則對話方塊


新增使用者至規則對話方塊

使用 [新增使用者至規則] 對話方塊可允許或拒絕使用者存取規則。

UI 元素

元素名稱 | 描述
名稱 | 輸入使用者名稱。
存取類型 | 選取要給予指定使用者的存取類型。可能的值包括 [允許] 和 [拒絕]。
是角色嗎? | 如果您指定的使用名稱是使用者群組的別名 (而您想允許或拒絕其存取)，請選取此核取方塊。


編輯功能設定對話方塊 (管理服務委派)

使用 [編輯功能設定] 對話方塊，可讓系統管理員略過委派規則，並啟用記錄失敗的要求。

UI 元素

元素名稱 描述

允許系統管理員略過委派規則

選取這個選項可允許系統管理員略過指定的委派規則。

啟用委派服務的失敗要求追蹤記錄檔

選取這個選項可以啟用失敗要求資訊的追蹤功能。

警告
若要使用此功能，必須先安裝失敗要求追蹤模組。


匯出應用程式封裝和匯出伺服器封裝精靈頁面

選取封裝的內容頁面

選取參數頁面

儲存封裝頁面

加密密碼對話方塊

匯出進度與摘要頁面


選取封裝的內容頁面

使用 [匯出應用程式封裝精靈] 的 [選取封裝的內容] 頁面，可檢視您要建立之封裝中所包含的元件。

封裝可以包含元件，例如登錄設定、COM、GAC 組件或憑證。 若要在伺服器上安裝這些元件，您必須是 Administrators 群組的成員，或必須已獲委派適當的授權。 若只是安裝內容，則不需要系統管理員的使用者權限。

UI 元素

元素名稱 描述

封裝包含

列出封裝包含的元件。 您可選取或清除適當的元件核取方塊，指定要納入封裝的項目。 例如，若要包含或排除 SQL 資料庫或 GAC 組件，請選取或清除對應的核取方塊。

注意
某些元件是應用程式的必要項目。 如果清除這些元件的核取方塊，應用程式在安裝後可能無法正確運作。

屬性

在右側窗格顯示所選取檔案、目錄或元件的屬性。 這些值是唯讀的。

管理元件...

開啟 [管理元件] 對話方塊。 這可讓您選取要包含的元件。 如需詳細資訊，請參閱管理元件對話方塊。

進階設定...

開啟 [進階設定] 對話方塊。 這可讓您指定作業設定及規則。 如需詳細資訊，請參閱進階設定對話方塊 (匯出)。

另請參閱

概念

匯出應用程式封裝和匯出伺服器封裝精靈頁面

其他資源

透過 IIS 管理員匯出封裝 (線上資源) (英文)


管理元件對話方塊

使用 [匯出應用程式封裝精靈] 的 [管理元件] 對話方塊，新增元件 (例如 COM 物件或 GAC 組件) 至您的封裝。

UI 元素

欄位標題

元素名稱 描述

提供者名稱

指定您要封裝的元件。 每個元件都有提供者。 按一下欄位即可使用下拉式清單來選取提供者名稱。 將游標暫留在提供者名稱上，則可檢視該提供者的描述。 例如，如果選取 [dbFullSql]，會封裝指令碼或連接字串的路徑。 如需提供者的詳細資訊，請參閱 Web Deploy 提供者 (英文)。

重要
如果正在封裝網站，iisApp 提供者 (預設會選取) 會將網站標記為目的地上的應用程式。 如果要封裝網站及其所有相關設定 (例如應用程式集區名稱、內容目錄的位置以及任何憑證)，請使用 appHostConfig 提供者。 如果使用 iisApp 提供者，網站會變成目的地上的應用程式，並繼承其所安裝站台的所有設定值 (例如應用程式集區名稱和內容目錄)。

路徑

指定元件的路徑，以便提供封裝資料。 例如，如果選取 [dbFullSql]，則路徑可指定指令碼 (如 C:\SQLfiles\installSQL.sql) 或連接字串 (如 Data Source=.\sqlexpress;Integrated Security=SSPI;Initial Catalog=db1)。

提供者設定

指定要用於已選取之提供者的提供者設定。 按一下欄位即可使用瀏覽 (…) 按鈕來開啟 [提供者設定] 對話方塊。 如需詳細資訊，請參閱提供者設定對話方塊。

按鈕

元素名稱 | 描述
移除 | 刪除選取的項目。
上移 | 將選取的列往清單上方移動。 項目是按照它們出現在清單中的順序進行安裝。 項目的順序對某些提供者而言很重要。 例如，應該先執行建立表格的指令碼，再執行填入表格的指令碼。
下移 | 將選取的列往清單下方移動。 項目是按照它們出現在清單中的順序進行安裝。

另請參閱

概念

選取封裝的內容頁面
匯出應用程式封裝和匯出伺服器封裝精靈頁面


提供者設定對話方塊

使用 [提供者設定] 對話方塊可以指定所選取提供者的設定。 並非所有提供者都需要進行設定。

UI 元素

元素名稱 | 描述
設定名稱 | 顯示所選取提供者的設定名稱。 只會列出與所選取提供者相關的設定。
設定值 | 輸入或選取設定的值。 如果下拉式清單可以使用，則設定的可能值將會列在清單中。 若是您必須輸入的值，描述方塊會提供可接受值的相關資訊。
設定描述 | 顯示所選取提供者設定的描述。 提供此設定允許值的相關資訊。

另請參閱

概念

管理元件對話方塊
選取封裝的內容頁面
匯出應用程式封裝和匯出伺服器封裝精靈頁面

其他資源

Web Deploy 提供者設定 (英文)


進階設定對話方塊 (匯出)

使用 [匯出應用程式封裝精靈] 的 [進階設定] 對話方塊，可以指定封裝的設定值。

UI 元素

進階選項

元素名稱 描述

加密密碼

按一下 […] 即可開啟 [加密密碼] 對話方塊，可以指定用來控制存取的英數密碼，以保護 IIS 設定中的內容。####################

Web Deploy 會自動偵測伺服器層級設定檔案 (例如 ApplicationHost.config 或 Machine.config) 中是否有加密物件，例如具有自訂識別的應用程式集區。 如果有加密物件，您必須提供物件的密碼。 如果您未指定正確的密碼，匯出作業會失敗。

重要
Web Deploy 不會檢查 Web.config 檔案中是否有加密物件。

包含 ACL

如果您指定之路徑的 ACL 要從來源複製至目的地，請選取 [True]，否則請選取 [False]。 此項設定適用於檔案系統、登錄與 Metabase，而且僅適用於下列提供者：appHostConfig、contentPath、iisApp、metaKey、webServer 及 webServer60。 預設值為 False。

連結擴充功能

按一下右側欄位，再按一下箭號，即可顯示連結擴充功能的下拉式清單。 選取或清除清單中的擴充功能，可啟用或停用您要套用至作業的連結擴充功能。 連結擴充功能會在一項作業中包含或排除特定的資料種類。 可用的 Web Deploy 擴充功能包括 AppPoolExtension、CertificateExtension、ContentExtension、FrameworkConfigExtension 及 HttpCertConfigExtension。########## 根據預設，會選取這些擴充功能。 如需連結擴充功能的詳細資訊，請參閱 Web Deploy 連結擴充功能 (英文)。

重試嘗試

輸入提供者在失敗後可以重試的次數。 預設的重試次數是 5。根據預設，每次重試之間都會有一秒鐘的延遲。 重試嘗試設定只適用於 contentPath 提供者。

重試間隔

輸入以毫秒為單位的值。 此值代表提供者每次重試嘗試之間的時間間隔。 預設值為 1000 (一秒)。 此項設定只適用於 contentPath 提供者。

追蹤層級

從下拉式清單中選取值，指定錯誤訊息記錄檔中的詳細程度。 可用的值包括「關閉」、「資訊」、「警告」、「錯誤」或「詳細資訊」。 預設值為「資訊」。 「關閉」表示不記錄任何錯誤訊息， 「詳細資訊」表示記錄所有錯誤訊息。

同步處理選項

元素名稱 描述

規則

開啟 [啟用或停用規則] 對話方塊，可讓您指定作業的規則。 如需詳細資訊，請參閱啟用或停用規則對話方塊。

WhatIf

按一下下拉式清單，可選取 True 或 False。True 指定作業將在沒有實際進行變更的情形下執行。 此設定可用來查看作業結果，了解整個作業是否能夠成功。 預設值為 False。

備註
使用 WhatIf 設定可以成功執行的命令，在不使用 WhatIf 設定執行的情況下可能會失敗。 如果作業期間發生意外的錯誤，就有可能造成這種狀況。 例如，因為進行 WhatIf 作業期間沒有寫入資料，所以偵測不到寫入權限錯誤。 WhatIf 設定只會顯示如果命令中所有作業都成功，會產生什麼結果。

另請參閱

概念

選取封裝的內容頁面
匯出應用程式封裝和匯出伺服器封裝精靈頁面


啟用或停用規則對話方塊

使用 [啟用或停用規則] 對話方塊，可以啟用或停用會影響同步處理作業結果的規則。 在 [群組依據] 下拉式清單中選取 [狀態] 可將規則分組為停用和啟用類別，選取 [沒有分組] 則可依照字母順序檢視規則。

UI 元素

欄位標題

元素名稱 | 描述
名稱 | 列出可供啟用或停用之同步處理規則的名稱。 以粗體顯示的規則預設為啟用，以灰色文字顯示的規則預設為停用。 您可以選取規則，接著使用 [啟用規則] 或 [停用規則] 按鈕，即可啟用或停用規則。 如需規則的詳細資訊，請參閱 Web Deploy 規則 (英文)。

按鈕

元素名稱 | 描述
啟用規則 | 啟用選取的規則。
停用規則 | 停用選取的規則。

另請參閱

概念

匯出應用程式封裝和匯出伺服器封裝精靈頁面
匯入應用程式封裝和匯入伺服器或站台封裝精靈頁面


選取參數頁面

使用 [匯出應用程式封裝精靈] 的 [選取參數] 頁面，新增或移除封裝的參數。 建立封裝時，可以指派參數給屬性。 稍後安裝封裝之後，使用者就可以指定該參數的自訂值，接著就可以指派新值給該屬性。 每個提供者的參數都會自動產生。

UI 元素

欄位標題

元素名稱 | 描述
名稱 | 列出您已透過 [新增參數] 對話方塊新增的參數名稱。 您可以按兩下參數或選取參數，然後按一下 [編輯]，即可編輯參數。
類型 | 顯示要參數化之屬性的參數類型。
範圍 | 顯示要參數化之屬性的範圍。
比對 | 顯示用於識別要參數化之屬性的比對運算式。

按鈕

元素名稱 | 描述
新增參數 | 開啟 [新增參數] 對話方塊。 這個對話方塊可讓您新增參數並設定其內容。 如需詳細資訊，請參閱新增或編輯參數對話方塊。
新增參數項目 | 開啟 [新增參數項目] 對話方塊。 這個對話方塊可讓您設定已選取之參數的 [類型]、[範圍] 及 [比對] 值。 如需詳細資訊，請參閱新增參數項目對話方塊。 當選取參數或參數項目時，便會啟用此選項。##########
編輯 | 如果選取參數，則這個按鈕會開啟 [編輯參數] 對話方塊。 這個對話方塊可讓您編輯參數的內容。 如需詳細資訊，請參閱新增或編輯參數對話方塊。 如果選取參數項目，則這個按鈕會開啟 [編輯參數項目] 對話方塊。 如需詳細資訊，請參閱編輯參數項目對話方塊。
移除 | 移除選取的參數。
上移 | 將選取的參數往參數清單的上方移動。 參數是按照它們出現在清單中的順序進行處理。
下移 | 將選取的參數往參數清單的下方移動。 參數是按照它們出現在清單中的順序進行處理。

另請參閱

概念

匯出應用程式封裝和匯出伺服器封裝精靈頁面


新增或編輯參數對話方塊

使用 [新增參數] 對話方塊或 [編輯參數] 對話方塊，新增參數至應用程式封裝，或編輯現有參數。

UI 元素

元素名稱 描述

名稱

輸入參數的名稱。例如 Connection String。

預設值

輸入參數的預設值。稍後部署封裝後，參數便具有此值，除非使用者指定其他值。例如，如果您輸入 Connection String 做為參數名稱，則可使用 Data Source=.\SQLExpress;Database=Test;Integrated Security 做為預設值。此項目並非必要項目。

重要
如果想要要求使用者提供參數值，請勿指定預設值。

標記

輸入自訂屬性的逗號分隔清單。標記是選用的參數屬性，可供稍後參考。例如，如果將參數標記為密碼，使用者介面就不會顯示密碼值。此項目並非必要項目。以 [預設值] 元素描述中的範例為例，您可以將標記 SQL, SQLConnectionString 用於 Connection String 參數。

描述

輸入參數的描述。例如：「這是應用程式所使用之資料庫的連接字串，如果您的環境使用不同的 SQL Server 或資料庫，請加以變更。」此段描述會放入封裝內的 Parameters.xml 檔案中，若在命令提示字元輸入 msdeploy -verb:getParameters -source:package=<封裝檔案名稱>，便會顯示這段描述。

類型

您可以選擇參數驗證類型。可用的值為 [無]、[規則運算式]、[列舉] 或 [布林值]。預設值為 [無]。如果選取 [無] 以外的參數驗證類型，則會檢查使用者輸入的參數值是否符合您指定的條件。如果選取 [規則運算式] 或 [列舉]，您必須在 [驗證字串] 方塊中提供驗證字串。

驗證字串

請輸入規則運算式或列舉值的逗號分隔清單。如需規則運算式的詳細資訊，請參閱規則運算式 (英文)。

另請參閱

概念

選取參數頁面
匯出應用程式封裝和匯出伺服器封裝精靈頁面


新增參數項目對話方塊

使用 [新增參數項目] 對話方塊可以指定參數的 [類型]、[範圍] 及 [比對] 值。

UI 元素

元素名稱 | 描述
類型 | 使用下拉式清單，可針對要參數化的屬性選取要使用的參數類型。 可用的參數類型包括 [XMLFile]、[文字檔]、[文字檔位置]、[提供者路徑]、[部署屬性]、[目的繫結] 及 [目的虛擬目錄]。 例如，如果您建立了 Connection String 參數，則可從下拉式清單選取 [XMLFile]，因為連接字串位於 Web.config 檔案中，此為 XML 格式的檔案。
範圍 | 輸入要參數化之屬性的範圍。 此值是必要的規則運算式。 例如，如果參數類型是 Xml File，則可使用規則運算式 \\web.config$ 做為範圍。 第一個反斜線用於逸出第二個反斜線，貨幣符號 ($) 表示在行尾停止比對字串。 因此，"\web.config" 就是所產生的範圍。 如需規則運算式的詳細資訊，請參閱規則運算式 (英文)。
比對 | 輸入用於識別要參數化之屬性的運算式。########## 此值與類型有關， 有時候會是規則運算式或 XPath 運算式。 Xml File 類型的相符值需為 XPath 運算式。 以上述範例為例，您可使用 XPath 運算式 //connectionStrings/add/@connectionString 來比對 Web.config 檔案中的連接字串項目。

另請參閱

概念

選取參數頁面
匯出應用程式封裝和匯出伺服器封裝精靈頁面


編輯參數項目對話方塊

使用 [編輯參數項目] 對話方塊，可以編輯參數的 [類型]、[範圍] 及 [比對] 值。 如果尚未建立參數，請參閱新增或編輯參數對話方塊。

UI 元素

元素名稱 | 描述
類型 | 使用下拉式清單可以變更參數類型。 可用的參數類型包括 [XMLFile]、[文字檔]、[文字檔位置]、[提供者路徑]、[部署屬性]、[目的繫結] 及 [目的虛擬目錄]。 例如，如果您建立了 Connection String 參數，則可從下拉式清單選取 [XMLFile]，因為連接字串位於 Web.config 檔案中，此為 XML 格式的檔案。
範圍 | 編輯要參數化之屬性的範圍。 此值是必要的規則運算式。 例如，如果參數類型是 [XMLFile]，則可使用規則運算式 \\web.config$ 做為範圍。 第一個反斜線用於逸出第二個反斜線，貨幣符號 ($) 表示在行尾停止比對字串。 因此，"\web.config" 就是所產生的範圍。 如需規則運算式的詳細資訊，請參閱規則運算式 (英文)。
比對 | 編輯用於識別要參數化之屬性的運算式。 此值與類型有關， 有時候會是規則運算式或 XPath 運算式。 Xml File 類型的相符值需為 XPath 運算式。 以上述範例為例，您可使用 XPath 運算式 //connectionStrings/add/@connectionString 來比對 Web.config 檔案中的連接字串項目。

另請參閱

概念

選取參數頁面
匯出應用程式封裝和匯出伺服器封裝精靈頁面


儲存封裝頁面

使用 [匯出應用程式封裝精靈] 的 [儲存封裝] 頁面，可指定要用來儲存封裝的檔案名稱和位置。

UI 元素

元素名稱 | 描述
封裝路徑 | 輸入封裝的檔案名稱。檔案名稱需有 .zip 副檔名。
瀏覽... | 按一下瀏覽按鈕，可以指定要用來儲存封裝的位置。

另請參閱

概念

匯出應用程式封裝和匯出伺服器封裝精靈頁面


加密密碼對話方塊

使用 [匯出應用程式封裝精靈] 的 [加密密碼] 對話方塊，可為有安全標示之設定的封裝內容提供密碼。

UI 元素

元素名稱 | 描述
密碼 | 輸入稍後匯入封裝時所需的密碼。 如果沒有為標示為安全的設定提供密碼，將無法匯出封裝。
確認密碼 | 再次輸入密碼以進行確認。

另請參閱

概念

匯出應用程式封裝和匯出伺服器封裝精靈頁面


匯出進度與摘要頁面

使用 [匯出應用程式精靈] 的 [匯出進度與摘要] 頁面，可以監視匯出程序的狀態，以及檢視精靈完成後作業的摘要和詳細資訊。

UI 元素

元素名稱 描述

狀態

[狀態] 區域會顯示目前正在執行的作業 (例如，檔案複製或資料庫指令碼作業)。 在匯出過程中，如果應用程式包含了密碼或憑證之類需要加密的項目，可能會出現提示，要求您輸入密碼。 請注意，如果資料量很大，或是將資料匯出至遠端伺服器，則匯出作業可能需要較久的時間才能完成。

摘要

提供在建立程序期間所執行之動作 (包括發生之所有錯誤) 的概觀。

重要
[摘要] 索引標籤並不包含已採取動作或已發生之錯誤的詳盡列表， 如需更詳細的相關資訊，請按一下 [詳細資料] 索引標籤。

詳細資料

提供已執行之動作的詳細列表。 若有發生錯誤，按一下此索引標籤也會顯示詳細的錯誤資訊，您可用以進行疑難排解。

另請參閱

概念

匯出應用程式封裝和匯出伺服器封裝精靈頁面


匯入應用程式封裝和匯入伺服器或站台封裝精靈頁面

選取封裝頁面

解密密碼對話方塊

選取封裝的內容頁面

進階設定對話方塊 (匯入)

選取資料庫頁面

輸入應用程式封裝資訊頁面

覆寫現有檔案頁面

安裝進度與摘要頁面


選取封裝頁面

使用 [選取封裝] 頁面，可以選取您要安裝在站台或伺服器上的現有封裝。

UI 元素

元素名稱 | 描述
封裝路徑 | 指定您要安裝在站台或伺服器上之封裝的位置。
瀏覽...… | 按一下瀏覽按鈕，可以指定要匯入之封裝的位置。

另請參閱

概念

匯入應用程式封裝和匯入伺服器或站台封裝精靈頁面


解密密碼對話方塊

使用 [匯入應用程式封裝精靈] 的 [解密密碼] 對話方塊，可為有安全標示之設定的封裝內容提供密碼。

UI 元素

元素名稱 | 描述
密碼 | 輸入解密封裝內容所需的密碼。因為在建立封裝時有些設定被標示為安全，所以需要密碼。如果沒有提供封裝建立時所指定的密碼，將無法匯入封裝。

另請參閱

概念

匯入應用程式封裝和匯入伺服器或站台封裝精靈頁面


選取封裝的內容頁面

使用 [匯入應用程式封裝精靈] 的 [選取封裝的內容] 頁面，可檢視 [選取封裝] 頁面中選取之封裝所包含的元件。

封裝可以包含元件，例如登錄設定、COM、GAC 組件或憑證。 若要在伺服器上安裝這些元件，您必須是 Administrators 群組的成員，或必須已獲委派適當的授權。 若只是安裝內容，則不需要系統管理員的使用者權限。

UI 元素

元素名稱 描述

封裝包含

列出封裝包含的元件。########## 您可選取或清除適當的元件核取方塊，指定要從封裝部署哪些項目。 例如，若要包含或排除 SQL 資料庫或 GAC 組件，請選取或清除對應的核取方塊。

注意
某些元件是應用程式的必要項目。 如果清除這些元件的核取方塊，應用程式在安裝後可能無法正確運作。

另請參閱

概念

匯入應用程式封裝和匯入伺服器或站台封裝精靈頁面


進階設定對話方塊 (匯入)

使用 [匯入應用程式封裝精靈] 的 [進階設定] 對話方塊，指定封裝的設定值。

UI 元素

進階選項

元素名稱 | 描述
解密密碼 | 開啟 [解密密碼] 對話方塊，可讓您輸入解密封裝內容所需的密碼。 在匯入作業期間，Web Deploy 會自動偵測封裝的伺服器層級設定檔案 (例如 ApplicationHost.config 或 Machine.config) 中是否有加密物件，例如具有自訂識別的應用程式集區。 如果有加密物件，您必須提供物件的密碼。 如果您未指定正確的密碼，匯入作業會失敗。
包含 ACL | 如果您指定之路徑的 ACL 要從來源複製至目的地，請選取 [True]，否則請選取 [False]。 此項設定適用於檔案系統、登錄與 Metabase，而且僅適用於下列提供者：appHostConfig、contentPath、iisApp、metaKey、webServer 及 webServer60。 預設值為 False。
連結擴充功能 | 按一下右側欄位，再按一下箭號，即可顯示連結擴充功能的下拉式清單。 選取或清除清單中的擴充功能，可啟用或停用您要套用至作業的連結擴充功能。 連結擴充功能會在一項作業中包含或排除特定的資料種類。 可用的 Web Deploy 擴充功能包括 AppPoolExtension、CertificateExtension、ContentExtension、FrameworkConfigExtension 及 HttpCertConfigExtension。 根據預設，會選取這些擴充功能。 如需連結擴充功能的詳細資訊，請參閱 Web Deploy 連結擴充功能 (英文)。
重試嘗試 | 輸入提供者在失敗後可以重試的次數。 預設的重試次數是 5。根據預設，每次重試之間都會有一秒鐘的延遲。 重試嘗試設定只適用於 contentPath 提供者。
重試間隔 | 輸入以毫秒為單位的值。 此值代表提供者每次重試嘗試之間的時間間隔。 預設值為 1000 (一秒)。 此項設定只適用於 contentPath 提供者。
追蹤層級 | 從下拉式清單中選取值，指定錯誤訊息記錄檔中的詳細程度。 可用的值包括「關閉」、「資訊」、「警告」、「錯誤」或「詳細資訊」。 預設值為「資訊」。 「關閉」表示不記錄任何錯誤訊息， 「詳細資訊」表示記錄所有錯誤訊息。

同步處理選項

元素名稱 描述

規則

開啟 [啟用或停用規則] 對話方塊，可讓您指定作業的規則。 如需詳細資訊，請參閱啟用或停用規則對話方塊。

WhatIf

按一下下拉式清單，可選取 True 或 False。True 指定作業將在沒有實際進行變更的情形下執行。 此設定可用來查看作業結果，了解整個作業是否能夠成功。 預設值為 False。

備註
使用 WhatIf 設定可以成功執行的命令，在不使用 WhatIf 設定執行的情況下可能會失敗。 如果作業期間發生意外的錯誤，就有可能造成這種狀況。 例如，因為進行 WhatIf 作業期間沒有寫入資料，所以偵測不到寫入權限錯誤。 WhatIf 設定只會顯示如果命令中所有作業都成功，會產生什麼結果。

另請參閱

概念

選取封裝的內容頁面
匯入應用程式封裝和匯入伺服器或站台封裝精靈頁面


選取資料庫頁面

使用 [選取資料庫] 頁面，可選取要用於進行安裝之封裝的資料庫選項。 只有當封裝中有超過一個資料庫類型時，才會顯示此頁面。

備註
如果封裝中有超過一個資料庫類型，但您只在 [選取封裝的內容] 頁面中勾選了一個資料庫類型而清除了其他所有資料庫類型的核取方塊，也不會顯示此頁面。

UI 元素

元素名稱 | 描述
請選擇要使用的資料庫 | 選取用於安裝的資料庫類型。 可用的資料庫類型為 [SQL]、[MySQL]、[VistaDB]、[SQLite]、[一般檔案] 或 [無資料庫]。 您所安裝的封裝內容會決定顯示的資料庫選項。 只有 SQL 和 MySQL 選項有相關的提供者。 如需詳細資訊，請參閱 Web Deploy dbFullSql 提供者 (英文) 和 Web Deploy MySQL 提供者 (英文)。
建立新資料庫或使用現有資料庫 | 選取 [建立新資料庫] 可以建立新的資料庫；選取 [使用現有資料庫] 則可使用現有資料庫。 只有在選擇 SQL 或 MySQL 做為資料庫類型時，才會啟用此選項。

另請參閱

概念

匯入應用程式封裝和匯入伺服器或站台封裝精靈頁面
輸入應用程式封裝資訊頁面


輸入應用程式封裝資訊頁面

使用 [匯入應用程式封裝精靈] 的 [輸入應用程式封裝資訊] 頁面，可以指定封裝中已宣告之參數的值。每個參數在頁面上都有一個欄位。頁面上所出現的欄位，視封裝中已宣告的參數而定。

UI 元素

元素名稱 | 描述
<參數名稱> | 針對安裝封裝所必要的參數，指定其值。此項資訊可以包括應用程式安裝位置的完整站台路徑、使用者認證，或應用程式的資料庫名稱。例如，可以變更應用程式路徑值以指定應用程式的安裝位置，例如 Default Web Site/NewApp。

另請參閱

概念

編輯連接字串對話方塊


編輯連接字串對話方塊

使用 [編輯連接字串] 對話方塊，可以指定您要使用的連接字串和認證。

UI 元素

元素名稱 | 描述
SQL Server | 選取這個選項可以使用您指定的 SQL Server。
伺服器 | 輸入您要使用之伺服器的路徑或連接字串 (例如 .\SQLExpress)。
資料庫 | 輸入您要使用之資料庫的名稱 (例如 Test)。
使用 Windows 整合式安全性 | 選取這個選項可以使用 Windows 整合式安全性。[Windows 整合式安全性] 會將使用者認證傳遞至 ASP.NET，如果使用者已登入 Windows，則不需要重新驗證。用戶端和伺服器位於相同網域時，最適合採用這種驗證方法。
指定認證 | 選取這個選項可以使用使用者指定的認證。按一下 [設定] 可以開啟 [設定認證] 對話方塊，並指定使用者名稱和密碼。
自訂 | 選取這個選項可以指定您要使用之伺服器的自訂路徑或連接字串 (例如 Server=.\SQLExpress;Database=Test;Integrated Security=true)。

另請參閱

概念

匯入應用程式封裝和匯入伺服器或站台封裝精靈頁面
輸入應用程式封裝資訊頁面


覆寫現有檔案頁面

使用 [覆寫現有檔案] 頁面，可以決定您要將新檔案附加至目的地，或是覆寫現有檔案並刪除在應用程式封裝中沒有對應項目的檔案。

UI 元素

元素名稱 | 描述
不，只將應用程式封裝中的檔案附加到目的地。 | 選取這個選項可以保留目的地上的現有檔案，並新增應用程式封裝中的新檔案。
是，刪除目的地上不在應用程式封裝中的所有額外檔案和資料夾。 | 選取這個選項會刪除目的地上任何不包含在應用程式封裝中的檔案。

另請參閱

概念

匯入應用程式封裝和匯入伺服器或站台封裝精靈頁面


安裝進度與摘要頁面

使用 [安裝進度與摘要] 頁面，可以監視匯入程序的狀態，以及檢視精靈完成後作業的摘要和詳細資訊。

UI 元素

元素名稱 描述

狀態

[狀態] 區域會顯示目前正在執行的作業 (例如，檔案複製或資料庫指令碼作業)。在匯入過程中，如果應用程式包含了密碼或憑證之類需要解密的項目，可能會出現提示，要求您輸入密碼。請注意，如果資料量很大，或是匯入資料自/至遠端伺服器，則匯入作業可能需要較久的時間才能完成。

摘要

提供在安裝程序期間所執行之動作 (包括發生之所有錯誤) 的概觀。

重要
[摘要] 索引標籤並不包含已採取動作或已發生之錯誤的詳盡列表，如需更詳細的相關資訊，請按一下 [詳細資料] 索引標籤。

詳細資料

提供已執行之動作的詳細列表。若有發生錯誤，按一下此索引標籤也會顯示詳細的錯誤資訊，您可用以進行疑難排解。

另請參閱

概念

匯入應用程式封裝和匯入伺服器或站台封裝精靈頁面