IIS マネージャー用の Web 配置ツールの概要

Web 配置ツール (Web Deploy) は、ユーザーが指定したサイトやサーバーと、ユーザーが指定した場所の間で、IIS 構成、コンテンツ、SSL 証明書、およびその他の種類のデータの同期化を実行します。また、既定では含まれていないレジストリ キーなどのオブジェクトを展開できます。

管理サービスの委任

IIS Managerの Web Deploy では、管理サービスの委任と呼ばれる管理者専用の機能がサーバー レベルで追加され、リモート ユーザーが実行できる展開操作を高精度で制御できます。詳細については、「[管理サービスの委任] ページ」を参照してください。

アプリケーションのエクスポートおよびインポート

IIS Managerの [操作] ウィンドウで、ツールのアプリケーション パッケージのエクスポート ウィザードを使用して、サイト、アプリケーション、およびコンテンツを格納する圧縮ファイル (パッケージ) を作成できます。詳細については、「アプリケーション パッケージのエクスポート ウィザード ページおよびサーバー パッケージのエクスポート ウィザード ページ」を参照してください。

パッケージをエクスポートすると、アプリケーション パッケージのインポート ウィザードを使用して、別の場所でパッケージのコンテンツをインストールできます。詳細については、「アプリケーション パッケージのインポート ウィザード ページおよびサーバーまたはサイト パッケージのインポート ウィザード ページ」を参照してください。

コマンド ライン機能

Web 配置ツールの Msdeploy.exe 実行可能プログラムでは、強力なコマンド ライン機能を多数使用できます。Msdeploy.exe 機能の概要ヘルプを参照するには、コマンド プロンプト ウィンドウで「msdeploy -help」と入力します。オンライン ヘルプの詳細については、Web 配置ツールに関するページ (英語の可能性あり) を参照してください。

その他のオンライン リソース

IIS.NET: Web 配置ツールに関するページ (英語の可能性あり)

IIS.NET: Web 配置ツール フォーラム (英語の可能性あり)

IIS.NET: Microsoft Web Deployment チーム ブログの投稿に関するページ (英語の可能性あり)


Web 配置ツールのユーザー インターフェイス (UI) のヘルプ

IIS Manager では、IIS Manager 内の各機能ページ、ダイアログ ボックス、およびウィザード ページにあるすべてのユーザー インターフェイス (UI) 要素の説明が提供されています。このヘルプを表示するには、アクティブな機能ページ上、ダイアログ ボックス上、またはウィザード ページ上で F1 キーを押します。

このセクションの内容

[管理サービスの委任] ページ

アプリケーション パッケージのエクスポート ウィザード ページおよびサーバー パッケージのエクスポート ウィザード ページ

アプリケーション パッケージのインポート ウィザード ページおよびサーバーまたはサイト パッケージのインポート ウィザード ページ


[管理サービスの委任] ページ

[管理サービスの委任] ページは、リモート ユーザーの展開の権限を制御する規則を指定するときに使用します。[管理サービスの委任] ページは、管理者のみが使用でき、サーバー レベルでのみ表示されます。

UI 要素

要素名 | 説明
[プロバイダー] | 規則が適用されるプロバイダーの一覧が表示されます。
[パス] | 規則が適用されるパスが表示されます。
[パスの種類] | パスの種類が表示されます。可能な値は、[PathPrefix]、[StringPrefix]、[StringSuffix]、[ConnectionString]、および [RegularExpression] です。
[操作] | 規則によって実行される操作が表示されます。Web Deploy プロバイダーの場合、典型的な値は [読み取り]、[書き込み]、および [*] です。
[ID の種類] | 規則が実行される ID の種類が表示されます。可能な値は、[CurrentUser]、[ProcessIdentity]、および [SpecificUser] です。
[ユーザー名] | ID の種類に [SpecificUser] が選択されている場合に、ユーザー名が表示されます。ID の種類が [CurrentUser] または [ProcessIdentity] の場合、ユーザー名は表示されません。
[状況] | 規則が有効か無効かを表示します。規則を有効化または無効化するには、[操作] ウィンドウで [規則の有効化] ボタンまたは [規則の無効化] ボタンをクリックします。

[操作] ウィンドウの要素

要素名 | 説明
[規則の追加] | [規則の追加] ダイアログ ボックスを開きます。規則を追加するには、このオプションを選択します。詳細については、「[規則の追加] ダイアログ ボックス (管理サービスの委任)」を参照してください。
[ユーザーを規則に追加]… | [ユーザーを規則に追加] ダイアログ ボックスを開きます。詳細については、「[ユーザーを規則に追加] ダイアログ ボックス」を参照してください。
[編集]… | [規則の編集] ダイアログ ボックスを開きます。詳細については、「[規則の追加] ダイアログ ボックスまたは [規則の編集] ダイアログ ボックス [Delegation]」を参照してください。
[削除] | 選択した委任規則または委任規則ユーザーを削除します。
[規則の無効化] | 選択した委任規則を無効化します。
[規則の有効化] | 選択した委任規則を有効化します。
[機能設定の編集]… | [機能設定の編集] ダイアログ ボックスを開きます。詳細については、「[機能設定の編集] ダイアログ ボックス (管理サービスの委任)」を参照してください。


[規則の追加] ダイアログ ボックス (管理サービスの委任)
関連項目

[規則テンプレートの選択] ダイアログ ボックスは、カスタムの委任規則の作成に使用できるテンプレートを選択するときに使用します。空白のテンプレート、または特定のシナリオ用に設計されたインストール済みのテンプレートを選択できます。

UI 要素

インストール済みのテンプレート

要素名 説明

[空の規則]

カスタマイズできる空の規則を作成します。

[コンテンツのみの展開]

コンテンツ展開を有効にする規則を作成します。この規則を使用すると、Web 管理サービス (WMSvc) の承認されたユーザーは、既に WMSvc によって承認されているパスにコンテンツを発行できます。規則を編集して、特定のパスまたはユーザーへのアクセスを制限できます。この規則では、Web サイト コンテンツの同期を実行する contentPath プロバイダーが使用されます。詳細については、Web Deploy contentPath プロバイダーに関するページ (英語の可能性あり) を参照してください。

[コンテンツのあるアプリケーションの展開]

アプリケーション展開を有効にする規則を作成します。このテンプレートには、フォルダーをアプリケーションとしてマークする規則は含まれませんが、このテンプレートはそのような規則と組み合わせてよく使用されます。この規則を使用すると、WMSvc の承認されたユーザーは、既に WMSvc によって承認されているパスにアプリケーションを発行できます。規則を編集して、特定のパスまたはユーザーへのアクセスを制限できます。この規則では、contentPath プロバイダーおよび iisApp プロバイダーが使用されます。詳細については、Web Deploy contentPath プロバイダーに関するページ (英語の可能性あり) および Web Deploy iisApp プロバイダーに関するページ (英語の可能性あり) を参照してください。

[データベースの展開]

データベース展開を有効にする規則を作成します。この規則を使用すると、WMSvc の承認されたユーザーはアクセスを許可されているデータベースに発行できます。このテンプレートでは、[CurrentUser] をアカウントに使用するように指定します。これは、データベース サーバー上でユーザー認証に接続文字列が使用されることを意味しています。規則を編集して、特定のデータベース サーバーまたはデータベース名へのアクセスを制限できます。この規則では、dbFullSql プロバイダーが使用され、ローカル SQL Server 展開データベースからリモートでホストされている SQL Server データベースへの初回データベース発行が有効にされます。詳細については、Web Deploy dbFullSql プロバイダーに関するページ (英語の可能性あり) を参照してください。

[フォルダーをアプリケーションとしてマーク]

フォルダーをアプリケーションとしてマークする規則を作成します。この規則を使用すると、WMSvc の承認されたユーザーはフォルダーをアプリケーションとしてマークすることができます。ユーザーが管理者でない場合は、ID の種類を ApplicationHost.config ファイルへの書き込みアクセス許可を持つアカウントに変更する必要があります。この規則の既定の ID の種類は [SpecificUser] です。この規則では、createApp プロバイダーが使用されます。このプロバイダーでは、フォルダーをアプリケーションとしてマークする必要があります。このプロバイダーの機能は iisApp プロバイダーに含まれています。詳細については、Web Deploy プロバイダーに関するページ (英語の可能性あり) を参照してください。

[アプリケーションのアクセス許可の設定]

アプリケーション パスの ACL を設定する規則を作成します。この規則を使用すると、WMSvc の承認されたユーザーは既に WMSvc によって承認されているアプリケーション パスのファイル システム ACL を設定できます。このテンプレートでは、[CurrentUser] をアカウントに使用するように指定されています。これは、ユーザーは ACL を変更するためにアクセス許可が必要であることを意味しています。規則を編集して、特定のパスまたはユーザーへのアクセスを制限できます。この規則では、宛先フォルダーのアクセス許可を設定する setAcl プロバイダーが使用されます。詳細については、Web Deploy setAcl プロバイダーに関するページ (英語の可能性あり) を参照してください。 .

[データベースのバックアップと復元 (SQL 認証を使用)]

SQL 認証を使用して、データベースのバックアップと復元を実行する規則を作成します。この規則を使用すると、WMSvc の承認されたユーザーは既にアクセスが許可されているデータベースのバックアップを作成または復元できます。バックアップと復元操作は、SQL 認証を使用する特定のユーザー ID として実行されます。規則を編集して、特定のデータベースおよび特定のユーザー セットへのアクセスを制限できます。

メモ
このテンプレートは IIS Database Manager の拡張機能と共に使用します。IIS Database Manager の詳細については、Database Manager に関するページ (英語の可能性あり) を参照してください。

[データベースのバックアップと復元 (Windows 統合セキュリティを使用)]

Windows 統合セキュリティを使用して、データベースのバックアップと復元を実行する規則を作成します。この規則を使用すると、WMSvc の承認されたユーザーは既にアクセスが許可されているデータベースのバックアップを作成または復元できます。規則を編集して、特定のデータベースおよび特定のユーザー セットへのアクセスを制限できます。

メモ
このテンプレートは IIS Database Manager の拡張機能と共に使用します。IIS Database Manager の詳細については、Database Manager に関するページ (英語の可能性あり) を参照してください。

関連項目

概念

アプリケーション パッケージのインポート ウィザード ページおよびサーバーまたはサイト パッケージのインポート ウィザード ページ

他のリソース

Web Deploy プロバイダーに関するページ (英語の可能性あり)


[規則の追加] ダイアログ ボックスまたは [規則の編集] ダイアログ ボックス [Delegation]

[規則の追加] ダイアログ ボックスおよび [規則の編集] ダイアログ ボックスは、委任規則を追加および編集するときに使用します。

UI 要素

要素名 | 説明
[プロバイダー] | ドロップダウン リストをクリックして、規則に追加するプロバイダーをオンにするか、規則から削除するプロバイダーをオフにし、ドロップダウン矢印をクリックして変更を確定します。プロバイダーは、コンマ区切りの一覧に表示されます。Web Deploy プロバイダーの詳細については、Web Deploy プロバイダーに関するページ (英語の可能性あり) を参照してください。
[操作] | ドロップダウン リストをクリックして、規則に追加する操作をオンにするか、規則から削除する操作をオフにし、ドロップダウン矢印をクリックして変更を確定します。操作は、コンマ区切りの一覧に表示されます。Web Deploy の場合、典型的な値は [読み取り]、[書き込み]、および [*] です。
[パスの種類] | ドロップダウン リストからパスの種類を選択します。可能な値は、[PathPrefix]、[StringPrefix]、[StringSuffix]、[ConnectionString]、および [RegularExpression] です。正規表現の詳細については、正規表現に関するページ (英語の可能性あり) を参照してください。
[パス] | 規則が適用されるパスを入力します。
[ID の種類] | ドロップダウン リストから規則の ID の種類を選択します。選択した ID により規則が実行されます。可能な値は、[CurrentUser]、[ProcessIdentity]、および [SpecificUser] です。[CurrentUser] は、現在のユーザーの ID を使用する場合に指定します。[ProcessIdentity] は、WMSvc ローカル サービスの ID を使用する場合に指定します。[SpecificUser] は、指定した特定の ID を使用する場合に指定します。[SpecificUser] を選択する場合、[資格情報の指定]、[設定] ボタンの順に使用して、資格情報を入力する必要があります。
[資格情報の指定] | ID の種類に [SpecificUser] が選択されている場合、[設定] ボタンを有効にします。
[設定] | [SpecificUser] のユーザー名とパスワードを指定できる [資格情報の設定] ダイアログ ボックスを開きます。詳細については、「[資格情報の設定] ダイアログ ボックス」を参照してください。


[資格情報の設定] ダイアログ ボックス

[資格情報の設定] ダイアログ ボックスは、規則を実行する Windows ユーザーのユーザー名およびパスワードを入力するときに使用します。

UI 要素

要素名 | 説明
[ユーザー名] | Windows ユーザーのユーザー名を入力します。
[パスワード] | パスワードを入力します。
[パスワードの確認] | 確認のために、もう一度パスワードを入力します。

関連項目

概念

[規則の追加] ダイアログ ボックスまたは [規則の編集] ダイアログ ボックス [Delegation]


[ユーザーを規則に追加] ダイアログ ボックス

[ユーザーを規則に追加] ダイアログ ボックスは、規則へのユーザー アクセスを許可または拒否するために使用します。

UI 要素

要素名 | 説明
[名前] | ユーザー名を入力します。
[アクセスの種類] | 指定したユーザーに対して許可するアクセスの種類を選択します。可能な値は [許可] および [拒否] です。
[役割である] | 指定したユーザー名がアクセスを許可または拒否されるユーザー グループのエイリアスである場合は、このチェック ボックスをオンにします。


[機能設定の編集] ダイアログ ボックス (管理サービスの委任)

[機能設定の編集] ダイアログ ボックスは、委任規則のバイパスを管理者に許可したり、失敗した要求のログを有効にしたりするときに使用します。

UI 要素

要素名 説明

[管理者による規則のバイパスを許可する]

このオプションは、指定した委任規則のバイパスを管理者に許可するときに選択します。

[委任サービスについて、失敗した要求のトレース ログを有効にする]

このオプションは、失敗した要求の情報のログを有効にするときに選択します。

警告
この機能を使用するには、失敗した要求トレース モジュールがインストールされている必要があります。


アプリケーション パッケージのエクスポート ウィザード ページおよびサーバー パッケージのエクスポート ウィザード ページ

[パッケージの内容の選択] ページ

[パラメーターの選択] ページ

[パッケージの保存] ページ

[パスワードの暗号化] ダイアログ ボックス

[エクスポートの進行状況および概要] ページ


[パッケージの内容の選択] ページ

アプリケーション パッケージのエクスポート ウィザードの [パッケージの内容の選択] ページは、作成するパッケージに含まれているコンポーネントを表示するときに使用します。

パッケージには、レジストリ設定、COM、GAC アセンブリ、証明書などのコンポーネントを含めることができます。これらのコンポーネントをサーバーにインストールするには、Administrators グループのメンバーであるか、適切な権限を委任されている必要があります。コンテンツのみをインストールする場合、管理者ユーザー権限は必要ありません。

UI 要素

要素名 説明

[パッケージの内容]

パッケージに含まれているコンポーネントを一覧表示します。該当するコンポーネントのチェック ボックスをオンまたはオフにして、パッケージに含めるコンポーネントを指定できます。たとえば、SQL データベースや GAC アセンブリなどを、該当するチェック ボックスをオンにして追加したり、オフにして除外したりすることができます。

注意
コンポーネントには、アプリケーションで必要なものもあります。これらのコンポーネントのチェック ボックスをオフにすると、インストール後にアプリケーションが正常に機能しない場合があります。

[属性]

選択したファイル、ディレクトリ、またはコンポーネントの属性を右側のウィンドウに表示します。これらの値は読み取り専用です。

[コンポーネントの管理]

[コンポーネントの管理] ダイアログ ボックスを開きます。このダイアログ ボックスで、パッケージに含めるコンポーネントを選択できます。詳細については、「[コンポーネントの管理] ダイアログ ボックス」を参照してください。

[詳細設定]…

[詳細設定] ダイアログ ボックスを開きます。ここで操作の設定および規則を指定できます。詳細については、「[詳細設定] ダイアログ ボックス (エクスポート)」を参照してください。

関連項目

概念

アプリケーション パッケージのエクスポート ウィザード ページおよびサーバー パッケージのエクスポート ウィザード ページ

他のリソース

IIS マネージャーを使用したパッケージのエクスポートに関するページ (オンライン リソース)(英語の可能性あり)


[コンポーネントの管理] ダイアログ ボックス

アプリケーション パッケージのエクスポート ウィザードの [コンポーネントの管理] ダイアログ ボックスは、COM オブジェクトや GAC アセンブリなどのコンポーネントをパッケージに追加するときに使用します。

UI 要素

列見出し

要素名 説明

[プロバイダー名]

パッケージ化するコンポーネントを指定します。コンポーネントごとにプロバイダーがあります。フィールドをクリックし、ドロップダウン リストを使用すると、プロバイダー名を選択できます。マウス ポインターをプロバイダー名に合わせると、そのプロバイダーの説明が表示されます。たとえば、[dbFullSql] を選択すると、スクリプトまたは接続文字列のパスをパッケージ化します。プロバイダーの詳細については、Web Deploy プロバイダーに関するページ (英語の可能性あり) を参照してください。

重要
Web サイトをパッケージ化する場合、iisApp プロバイダー (既定で選択) は Web サイトを宛先のアプリケーションとしてマークします。Web サイトおよびそれに関連するすべての構成 (アプリケーション プール名、コンテンツ ディレクトリの場所、証明書など) をパッケージ化する場合、appHostConfig プロバイダーを使用します。iisApp プロバイダーを使用する場合、Web サイトは宛先のアプリケーションになり、サイトからインストール先にすべての設定 (アプリケーション プール名やコンテンツ ディレクトリなど) を継承します。

[パス]

パッケージのデータを提供するコンポーネントのパスを指定します。たとえば、[dbFullSql] を選択すると、パスによって C:\SQLfiles\installSQL.sql などのスクリプトや Data Source=.\sqlexpress;Integrated Security=SSPI;Initial Catalog=db1 などの接続文字列を指定できます。

[プロバイダーの設定]

選択したプロバイダーで使用するプロバイダーの設定を指定します。フィールドをクリックし、参照 ([…]) ボタンを使用して、[プロバイダーの設定] ダイアログ ボックスを開きます。詳細については、「[プロバイダーの設定] ダイアログ ボックス」を参照してください。

ボタン

要素名 | 説明
[削除] | 選択したエントリを削除します。
[上へ移動] | 選択した行を一覧内の上方向に移動します。エントリは、一覧に表示されている順にインストールされます。エントリの順番は、一部のプロバイダーでは重要になります。たとえば、テーブルを設定するスクリプトの前にテーブルを作成するスクリプトを実行する必要があります。
[下へ移動] | 選択した行を一覧内の下方向に移動します。エントリは、一覧に表示されている順にインストールされます。

関連項目

概念

[パッケージの内容の選択] ページ
アプリケーション パッケージのエクスポート ウィザード ページおよびサーバー パッケージのエクスポート ウィザード ページ


[プロバイダーの設定] ダイアログ ボックス

[プロバイダーの設定] ダイアログ ボックスは、選択したプロバイダーの設定を指定するときに使用します。すべてのプロバイダーに設定があるとは限りません。

UI 要素

要素名 | 説明
[設定名] | 選択したプロバイダーの設定の名前が表示されます。選択したプロバイダーに関連する設定のみが一覧表示されます。
[設定値] | 設定の値を入力または選択します。ドロップダウン リストが利用できる場合は、設定で選択可能な値がリストに表示されます。入力しなければならない値の場合は、説明ボックスに許容値に関する情報が表示されます。
[設定の説明] | 選択したプロバイダーの設定の説明が表示されます。この設定の許容値に関する情報を入力します。

関連項目

概念

[コンポーネントの管理] ダイアログ ボックス
[パッケージの内容の選択] ページ
アプリケーション パッケージのエクスポート ウィザード ページおよびサーバー パッケージのエクスポート ウィザード ページ

他のリソース

Web Deploy プロバイダーの設定に関するページ (英語の可能性あり)


[詳細設定] ダイアログ ボックス (エクスポート)

アプリケーション パッケージのエクスポート ウィザードの [詳細設定] ダイアログ ボックスは、パッケージの設定を指定するときに使用します。

UI 要素

詳細オプション

要素名 説明

[パスワードの暗号化]

[…] をクリックして [パスワードの暗号化] ダイアログボックスを開き、IIS 構成のセキュリティ保護されたプロパティへのアクセスを制御する英数字のパスワードを指定します。

カスタム ID を持つアプリケーション プールなどの暗号化されたオブジェクトがサーバー レベルの構成ファイル (ApplicationHost.config または Machine.config など) 内に存在するかどうかを、Web Deploy が自動的に検出します。暗号化されたオブジェクトが存在する場合、そのオブジェクトのパスワードを入力する必要があります。正しいパスワードを指定しないと、エクスポート操作は失敗します。

重要
Web Deploy は、Web.config ファイルに暗号化されたオブジェクトがあるかどうかは確認しません。

[ACL を含める]

指定したパスの ACL をコピー元からコピー先にコピーする場合は [True] を、コピーしない場合は [False] を選択します。この設定は、ファイル システム、レジストリ、およびメタデータに適用され、適用先のプロバイダーは appHostConfig、contentPath、iisApp、metaKey、webServer、および webServer60 に限られます。既定値は [False] です。

[リンク拡張機能]

右側のフィールドをクリックし、矢印をクリックすると、リンク拡張機能のドロップダウン リストが表示されます。操作に適用するリンク拡張機能を有効または無効にするには、一覧内の拡張機能をオンまたはオフにします。リンク拡張機能は、特定の種類のデータを操作に追加したり、操作から除外したりします。利用可能な Web Deploy の拡張機能は、AppPoolExtension、CertificateExtension、ContentExtension、FrameworkConfigExtension、および HttpCertConfigExtension です。これらの拡張機能は既定で選択されています。リンク拡張機能の詳細については、Web Deploy リンク拡張機能に関するページ (英語の可能性あり) を参照してください。

[再試行回数]

プロバイダーが失敗した後に再試行する回数を入力します。既定の再試行回数は 5 回です。既定では、各再試行の間に 1 秒の遅延があります。再試行の設定は、contentPath プロバイダーでのみ使用できます。

[再試行間隔]

値をミリ秒で入力します。この値は、プロバイダーが再試行する時間間隔を指定します。既定値は 1,000 (1 秒) です。この設定は、contentPath プロバイダーでのみ使用できます。

[トレース レベル]

エラー メッセージ ログの詳細のレベルを指定する値をドロップダウン リストから選択します。可能な値は、[オフ]、[エラー]、[警告]、[情報]、および [詳細] です。既定値は [情報] です。[オフ] を選択すると、エラー メッセージは記録されません。[詳細] を選択すると、すべてのメッセージが記録されます。

同期オプション

要素名 説明

[規則]

操作の規則を指定できる [規則の有効化または無効化] ダイアログ ボックスを開きます。詳細については、「[規則の有効化または無効化] ダイアログ ボックス」を参照してください。

[WhatIf]

ドロップダウン リストをクリックして、True または False を選択します。True は、実際に変更を行わずに操作を実行することを指定します。この設定を使用すると、操作のすべてが成功した場合の結果を表示できます。既定値は False です。

メモ
[WhatIf] 設定を使用してコマンドが正常に実行された場合でも、[WhatIf] 設定を使用せずに実行すると失敗することがあります。これは、操作中に予期しないエラーが発生した場合に起こります。たとえば、[WhatIf] 操作中はデータが書き込まれないため、書き込みアクセス許可エラーは検出されません。[WhatIf] 設定では、コマンド内のすべての操作が成功した場合の結果のみが表示されます。

関連項目

概念

[パッケージの内容の選択] ページ
アプリケーション パッケージのエクスポート ウィザード ページおよびサーバー パッケージのエクスポート ウィザード ページ


[規則の有効化または無効化] ダイアログ ボックス

[規則の有効化または無効化] ダイアログ ボックスは、同期操作の結果に影響する規則を有効または無効にするときに使用します。[グループ化] ボックスの一覧から [状況] を選択すると、規則が無効および有効のカテゴリにグループ化されます。また、[グループ化なし] を選択すると、規則がアルファベット順に表示されます。

UI 要素

列見出し

要素名 | 説明
[名前] | 有効化または無効化できる同期規則の名前を一覧表示します。太字の規則は、既定で有効になっています。影付きテキストの規則は、既定で無効になっています。規則を有効化または無効化するには、規則を選択し、[規則の有効化] または [規則の無効化] を使用します。これらの規則の詳細については、Web Deploy の規則に関するページ (英語の可能性あり) を参照してください。

ボタン

要素名 | 説明
[規則の有効化] | 選択した規則を有効にします。
[規則の無効化] | 選択した規則を無効にします。

関連項目

概念

アプリケーション パッケージのエクスポート ウィザード ページおよびサーバー パッケージのエクスポート ウィザード ページ
アプリケーション パッケージのインポート ウィザード ページおよびサーバーまたはサイト パッケージのインポート ウィザード ページ


[パラメーターの選択] ページ

アプリケーション パッケージのエクスポート ウィザードの [パラメーターの選択] ページは、パラメーターをパッケージに追加またはパッケージから削除するときに使用します。パッケージを作成するときに、パラメーターを属性に割り当てることができます。その後、パッケージがインストールされると、ユーザーはパラメーターにカスタム値を指定することができ、新しい値が属性に割り当てられます。パラメーターはプロバイダーごとに自動的に生成されます。

UI 要素

列見出し

要素名 | 説明
[名前] | [パラメーターの追加] ダイアログ ボックスを使用して追加したパラメーターの名前を一覧表示します。パラメーターをダブルクリックするか、パラメーターを選択して [編集] をクリックすると、パラメーターを編集できます。
[種類] | パラメーター化される属性のパラメーターの種類を表示します。
[スコープ] | パラメーター化される属性のスコープを表示します。
[一致] | パラメーター化する属性を識別する一致表現を表示します。

ボタン

要素名 説明

[パラメーターの追加]

[パラメーターの追加] ダイアログ ボックスを開きます。ここでパラメーターを追加して、プロパティを設定できます。詳細については、「[プロバイダーの追加] ダイアログ ボックスまたは [プロバイダーの編集] ダイアログ ボックス」を参照してください。

[パラメーター エントリの追加]

[パラメーター エントリの追加] ダイアログ ボックスを開きます。ここで、選択したパラメーターの [種類]、[スコープ]、および [一致] の値を構成できます。詳細については、「[パラメーター エントリの追加] ダイアログ ボックス」を参照してください。このオプションは、パラメーターまたはパラメーター エントリを選択すると有効になります。

[編集]

パラメーターが選択されている場合、このボタンは [パラメーターの編集] ダイアログ ボックスを開きます。ここで既存のパラメーターのプロパティを編集できます。詳細については、「[プロバイダーの追加] ダイアログ ボックスまたは [プロバイダーの編集] ダイアログ ボックス」を参照してください。

パラメーター エントリが選択されている場合、このボタンは [パラメーター エントリの編集] ダイアログ ボックスを開きます。詳細については、「[パラメーター エントリの編集] ダイアログ ボックス」を参照してください。

[削除]

選択したパラメーターを削除します。

[上へ移動]

選択したパラメーターをパラメーターのリスト内の上方向に移動します。パラメーターは、リストに表示されている順に処理されます。

[下へ移動]

選択したパラメーターをパラメーターのリスト内の下方向に移動します。パラメーターは、リストに表示されている順に処理されます。

関連項目

概念

アプリケーション パッケージのエクスポート ウィザード ページおよびサーバー パッケージのエクスポート ウィザード ページ


[プロバイダーの追加] ダイアログ ボックスまたは [プロバイダーの編集] ダイアログ ボックス

[パラメーターの追加] ダイアログ ボックスは、アプリケーション パッケージの新しいパラメーターを追加するときに使用し、[パラメーターの編集] ダイアログ ボックスは、既存のパラメーターを編集するときに使用します。

UI 要素

要素名 説明

[名前]

パラメーターの名前を入力します (たとえば、「Connection String」)。

[既定値]

パラメーターの既定値を入力します。後にパッケージが展開されると、ユーザーが別の値を指定しない限り、パラメーターにはこの値が設定されます。たとえば、パラメーター名に「Connection String」と入力した場合、既定値に「Data Source=.\SQLExpress;Database=Test;Integrated Security」を使用できます。このエントリは必須ではありません。

重要
ユーザーにパラメーターの値を入力させる必要がある場合は、既定値を指定しないでください。

[タグ]

カスタム属性のコンマ区切りの一覧を入力します。タグは、後で参照できるパラメーターのオプション属性です。たとえば、ユーザー インターフェイスにパスワード値が表示されないように、パラメーターをパスワードとしてタグ付けできます。このエントリは必須ではありません。[既定値] 要素の説明にある例を使用すると、接続文字列のパラメーターにタグ「SQL、SQLConnectionString」を使用できます。

[説明]

パラメーターの説明を入力します (たとえば、「これは、アプリケーションが使用するデータベースの接続文字列です。使用環境に別の SQL サーバーやデータベースがある場合は、接続文字列を変更してください」)。この説明は、パッケージ内の Parameters.xml ファイルに記述され、「msdeploy -verb:getParameters -source:package=<PackageFileName>」と入力するとコマンド プロンプトで表示できます。

[種類]

必要に応じてパラメーター検証の種類を選択します。可能な値は [なし]、[正規表現]、[列挙値]、および [ブール値] です。既定値は [なし] です。パラメーター検証の種類で [なし] 以外を選択した場合は、ユーザーがパラメーターに対して入力した値がチェックされ、指定した条件に合致しているかどうかが確認されます。[正規表現] または [列挙値] を選択した場合は、[検証する文字列] ボックスに検証する文字列を入力する必要があります。

[検証する文字列]

正規表現またはコンマ区切りの列挙値の一覧を入力します。正規表現の詳細については、正規表現に関するページ (英語の可能性あり) を参照してください。

関連項目

概念

[パラメーターの選択] ページ
アプリケーション パッケージのエクスポート ウィザード ページおよびサーバー パッケージのエクスポート ウィザード ページ


[パラメーター エントリの追加] ダイアログ ボックス

[パラメーター エントリの追加] ダイアログ ボックスは、パラメーターの [種類]、[スコープ]、および [一致] の値を指定するときに使用します。

UI 要素

要素名 | 説明
[種類] | ドロップダウン リストから、パラメーター化される属性に使用するパラメーターの種類を選択します。使用できるパラメーターの種類は、[Xml ファイル]、[テキスト ファイル]、[テキスト ファイルの位置]、[プロバイダーのパス]、[展開属性]、[デスティネーションのバインド]、および [デスティネーションの仮想ディレクトリ] です。たとえば、接続文字列パラメーターを作成する場合、接続文字列は XML 形式の Web.config ファイル内にあるため、ドロップダウン リストで [Xml ファイル] を選択します。
[スコープ] | パラメーター化される属性のスコープを入力します。この値は、必須の正規表現です。たとえば、パラメーターの種類が [Xml File] の場合、スコープに「\\web.config$」という正規表現を使用します。最初のバックスラッシュ (\) は 2 番目のバックスラッシュをエスケープし、ドル記号 ($) は行の最後で一致文字列を終了させます。したがって、「\web.config」が結果のスコープになります。正規表現の詳細については、正規表現に関するページ (英語の可能性あり) を参照してください。
[一致] | パラメーター化する属性を識別する表現を入力します。この値は、パラメーターの種類によって決まり、場合によって、正規表現または XPath 表現になります。パラメーターの種類が [Xml File] の場合、検索条件の値は XPath 表現である必要があります。上記の例に従って、「//connectionStrings/add/@connectionString」という XPath 表現を使用すると、Web.config ファイル内で接続文字列エントリを検索できます。

関連項目

概念

[パラメーターの選択] ページ
アプリケーション パッケージのエクスポート ウィザード ページおよびサーバー パッケージのエクスポート ウィザード ページ


[パラメーター エントリの編集] ダイアログ ボックス

[パラメーター エントリの編集] ダイアログ ボックスは、パラメーターの [種類]、[スコープ]、および [一致] の値を編集するときに使用します。パラメーターをまだ作成していない場合、「[プロバイダーの追加] ダイアログ ボックスまたは [プロバイダーの編集] ダイアログ ボックス」を参照してください。

UI 要素

要素名 | 説明
[種類] | ドロップダウン リストを使用してパラメーターの種類を変更します。使用できるパラメーターの種類は、[Xml ファイル]、[テキスト ファイル]、[テキスト ファイルの位置]、[プロバイダーのパス]、[展開属性]、[デスティネーションのバインド]、および [デスティネーションの仮想ディレクトリ] です。たとえば、接続文字列パラメーターを作成する場合、接続文字列は XML 形式の Web.config ファイル内にあるため、ドロップダウン リストで [Xml ファイル] を選択します。
[スコープ] | パラメーター化される属性のスコープを編集します。この値は、必須の正規表現です。たとえば、パラメーターの種類が [Xml ファイル] の場合、スコープに「\\web.config$」という正規表現を使用します。最初のバックスラッシュ (\) は 2 番目のバックスラッシュをエスケープし、ドル記号 ($) は行の最後で一致文字列を終了させます。したがって、「\web.config」が結果のスコープになります。正規表現の詳細については、正規表現に関するページ (英語の可能性あり) を参照してください。
[一致] | パラメーター化する属性を識別する表現を編集します。この値は、パラメーターの種類によって決まり、場合によって、正規表現または XPath 表現になります。パラメーターの種類が [Xml File] の場合、検索条件の値は XPath 表現である必要があります。上記の例に従って、「//connectionStrings/add/@connectionString」という XPath 表現を使用すると、Web.config ファイル内で接続文字列エントリを検索できます。

関連項目

概念

[パラメーターの選択] ページ
アプリケーション パッケージのエクスポート ウィザード ページおよびサーバー パッケージのエクスポート ウィザード ページ


[パッケージの保存] ページ

アプリケーション パッケージのエクスポート ウィザードの [パッケージの保存] ページは、パッケージを保存するときのファイル名および場所を指定するために使用します。

UI 要素

要素名 | 説明
[パッケージのパス] | パッケージのファイル名を入力します。ファイル名には、.zip ファイル名拡張子が必要です。
[参照]… | パッケージを保存する場所を指定するには、[参照] をクリックします。

関連項目

概念

アプリケーション パッケージのエクスポート ウィザード ページおよびサーバー パッケージのエクスポート ウィザード ページ


[パスワードの暗号化] ダイアログ ボックス

アプリケーション パッケージのエクスポート ウィザードの [パスワードの暗号化] ダイアログは、セキュリティで保護された設定のパッケージ コンテンツのパスワードを入力するときに使用します。

UI 要素

要素名 | 説明
[パスワード] | 後でパッケージをインポートするときに必要なパスワードを入力します。セキュリティで保護された設定のパスワードを入力しないと、パッケージをエクスポートできなくなります。
[パスワードの確認] | 確認のために、もう一度パスワードを入力します。

関連項目

概念

アプリケーション パッケージのエクスポート ウィザード ページおよびサーバー パッケージのエクスポート ウィザード ページ


[エクスポートの進行状況および概要] ページ

アプリケーションのエクスポート ウィザードの [エクスポートの進行状況および概要] ページは、エクスポート プロセスの状態を監視するとき、およびウィザードの終了後に操作の概要や詳細情報を確認するときに使用します。

UI 要素

要素名 説明

[状態]

[状態] 領域には、実行中の現在の操作 (ファイルのコピーやデータベース スクリプトなどの操作) が表示されます。暗号化を必要とするパスワードや証明書などの項目がアプリケーションに含まれている場合、エクスポート プロセス中にパスワードの入力を求められることがあります。データ量が多い場合や、リモート サーバーにデータをエクスポートしている場合は、エクスポート操作に時間がかかることがあります。

[概要]

作成プロセス中に発生したエラーなど、実行された操作の概要を表示します。

重要
[概要] タブには、実行された操作や発生したエラーの完全な一覧は表示されません。[詳細] タブをクリックして、詳細情報を確認できます。

[詳細]

実行された操作の詳細な一覧を表示します。エラーが発生した場合、このタブをクリックすると、トラブルシューティングで使用できる詳細なエラー情報が表示されます。

関連項目

概念

アプリケーション パッケージのエクスポート ウィザード ページおよびサーバー パッケージのエクスポート ウィザード ページ


アプリケーション パッケージのインポート ウィザード ページおよびサーバーまたはサイト パッケージのインポート ウィザード ページ

[パッケージの選択] ページ

[パスワードの復号化] ダイアログ ボックス

[パッケージの内容の選択] ページ

[詳細設定] ダイアログ ボックス (インポート)

[データベースの選択] ページ

[アプリケーション パッケージ情報の入力] ページ

[既存のファイルの上書き] ページ

[インストールの進行状況および概要] ページ


[パッケージの選択] ページ

[パッケージの選択] ページは、サイトまたはサーバー上にインストールする既存のパッケージを選択するときに使用します。

UI 要素

要素名 | 説明
[パッケージのパス] | サイトまたはサーバーにインストールするパッケージの場所を指定します。
[参照] | インポートするパッケージの場所を指定するには、[参照] をクリックします。

関連項目

概念

アプリケーション パッケージのインポート ウィザード ページおよびサーバーまたはサイト パッケージのインポート ウィザード ページ


[パスワードの復号化] ダイアログ ボックス

アプリケーション パッケージのインポート ウィザードの [パスワードの復号化] ダイアログ ボックスは、設定がセキュリティで保護されたパッケージ コンテンツのパスワードを入力するときに使用します。

UI 要素

要素名 | 説明
[パスワード] | パッケージ コンテンツの暗号化を解除するために必要なパスワードを入力します。パッケージが作成されたときに一部の設定がセキュリティで保護されているので、パスワードが必要です。パッケージが作成されたときに指定されたパスワードを入力しないと、パッケージをインポートできません。

関連項目

概念

アプリケーション パッケージのインポート ウィザード ページおよびサーバーまたはサイト パッケージのインポート ウィザード ページ


[パッケージの内容の選択] ページ

アプリケーション パッケージのインポート ウィザードの [パッケージの内容の選択] ページは、[パッケージの選択] ページで選択したパッケージに含まれているコンポーネントを表示するときに使用します。

パッケージには、レジストリ設定、COM、GAC アセンブリ、証明書などのコンポーネントを含めることができます。これらのコンポーネントをサーバーにインストールするには、Administrators グループのメンバーであるか、適切な権限を委任されている必要があります。コンテンツのみをインストールする場合、管理者ユーザー権限は必要ありません。

UI 要素

要素名 説明

[パッケージの内容]

パッケージに含まれているコンポーネントを一覧表示します。該当するコンポーネントのチェック ボックスをオンまたはオフにして、パッケージから展開するコンポーネントを指定できます。たとえば、SQL データベースや GAC アセンブリなどを、該当するチェック ボックスをオンにして追加したり、オフにして除外したりすることができます。

注意
コンポーネントには、アプリケーションで必要なものもあります。これらのコンポーネントのチェック ボックスをオフにすると、インストール後にアプリケーションが正常に機能しない場合があります。

関連項目

概念

アプリケーション パッケージのインポート ウィザード ページおよびサーバーまたはサイト パッケージのインポート ウィザード ページ


[詳細設定] ダイアログ ボックス (インポート)

アプリケーション パッケージのインポート ウィザードの [詳細設定] ダイアログ ボックスは、パッケージの設定を指定するときに使用します。

UI 要素

詳細オプション

要素名 | 説明
[パスワードの復号化] | パッケージ コンテンツの暗号化を解除するために必要なパスワードを入力できる [パスワードの復号化] ダイアログ ボックスを開きます。 Web Deploy は、インポート操作中に、カスタム ID を持つアプリケーション プールなどの暗号化されたオブジェクトがパッケージのサーバーレベルの構成ファイル (ApplicationHost.config または Machine.config など) 内に存在するかどうかを自動的に検出します。暗号化されたオブジェクトが存在する場合、そのオブジェクトのパスワードを入力する必要があります。正しいパスワードを指定しないと、インポート操作は失敗します。
[ACL を含める] | 指定したパスの ACL をコピー元からコピー先にコピーする場合は [True] を、コピーしない場合は [False] を選択します。この設定は、ファイル システム、レジストリ、およびメタデータに適用され、適用先のプロバイダーは appHostConfig、contentPath、iisApp、metaKey、webServer、および webServer60 に限られます。既定値は False です。
[リンク拡張機能] | 右側のフィールドをクリックし、矢印をクリックすると、リンク拡張機能のドロップダウン リストが表示されます。操作に適用するリンク拡張機能を有効または無効にするには、一覧内の拡張機能をオンまたはオフにします。リンク拡張機能は、特定の種類のデータを操作に追加したり、操作から除外したりします。利用可能な Web Deploy の拡張機能は、AppPoolExtension、CertificateExtension、ContentExtension、FrameworkConfigExtension、および HttpCertConfigExtension です。これらの拡張機能は既定で選択されています。リンク拡張機能の詳細については、Web Deploy リンク拡張機能に関するページ (英語の可能性あり) を参照してください。
[再試行回数] | プロバイダーが失敗した後に再試行する回数を入力します。既定の再試行回数は 5 回です。既定では、各再試行の間に 1 秒の遅延があります。再試行の設定は、contentPath プロバイダーでのみ使用できます。
[再試行間隔] | 値をミリ秒で入力します。この値は、プロバイダーが再試行する時間間隔を指定します。既定値は 1,000 (1 秒) です。この設定は、contentPath プロバイダーでのみ使用できます。
[トレース レベル] | エラー メッセージ ログの詳細のレベルを指定する値をドロップダウン リストから選択します。可能な値は、[オフ]、[エラー]、[警告]、[情報]、および [詳細] です。既定値は [情報] です。[オフ] を選択すると、エラー メッセージは記録されません。[詳細] を選択すると、すべてのメッセージが記録されます。

同期オプション

要素名 説明

[規則]

操作の規則を指定できる [規則の有効化または無効化] ダイアログ ボックスを開きます。詳細については、「[規則の有効化または無効化] ダイアログ ボックス」を参照してください。

[WhatIf]

ドロップダウン リストをクリックして、True または False を選択します。True は、実際に変更を行わずに操作を実行することを指定します。この設定を使用すると、操作のすべてが成功した場合の結果を表示できます。既定値は False です。

メモ
[WhatIf] 設定を使用してコマンドが正常に実行された場合でも、[WhatIf] 設定を使用せずに実行すると失敗することがあります。これは、操作中に予期しないエラーが発生した場合に起こります。たとえば、[WhatIf] 操作中はデータが書き込まれないため、書き込みアクセス許可エラーは検出されません。[WhatIf] 設定では、コマンド内のすべての操作が成功した場合の結果のみが表示されます。

関連項目

概念

[パッケージの内容の選択] ページ
アプリケーション パッケージのインポート ウィザード ページおよびサーバーまたはサイト パッケージのインポート ウィザード ページ


[データベースの選択] ページ

[データベースの選択] ページは、インストール対象のパッケージで使用するデータベース オプションを選択するときに使用します。このページは、パッケージで使用できるデータベースの種類が複数存在する場合にのみ表示されます。

メモ
また、パッケージで使用できるデータベースの種類が複数存在する場合でも、[パッケージの内容の選択] ページで、データベースの種類のチェック ボックスを 1 つを除いてすべてオフにしてあると、このページは表示されません。

UI 要素

要素名 | 説明
[使用するデータベースを選択してください] | インストールで使用するデータベースの種類を選択します。使用できるデータベースの種類は、[SQL]、[MySQL]、[VistaDB]、[SQLite]、[フラットファイル]、または [データベースなし] です。表示されるデータベースのオプションは、インストールするパッケージの内容によって異なります。[SQL] および [MySQL] オプションにのみ、プロバイダーが関連付けられています。詳細については、Web Deploy dbFullSql プロバイダーに関するページ (英語の可能性あり) および Web Deploy MySQL プロバイダーに関するページ (英語の可能性あり) を参照してください。
[既存のデータベースの使用または新規作成] | 新しいデータベースを作成するときは [新しいデータベースの作成]、既存のデータベースを使用するときは [既存のデータベースを使用] を選択します。このオプションは、データベースの種類として [SQL] または [MySQL] を選択した場合にのみ有効になります。

関連項目

概念

アプリケーション パッケージのインポート ウィザード ページおよびサーバーまたはサイト パッケージのインポート ウィザード ページ
[アプリケーション パッケージ情報の入力] ページ


[アプリケーション パッケージ情報の入力] ページ

アプリケーション パッケージのインポート ウィザードの [アプリケーション パッケージ情報の入力] ページは、パッケージで宣言されたパラメーターの値を指定するために使用します。このページには、パラメーターごとにフィールドがあります。ページに表示されるフィールドは、パッケージで宣言されたパラメーターによって異なります。

UI 要素

要素名 | 説明
<パラメーター名> | パッケージのインストールに必要なパラメーターの値を指定します。この情報には、アプリケーションのインストール先への完全なサイト パスやユーザー資格情報、アプリケーションのデータベースの名前を含めることができます。たとえば、アプリケーション パスの値を変更して、Default Web Site/NewApp などアプリケーションのインストール場所を指定できます。

関連項目

概念

[接続文字列の編集] ダイアログ ボックス


[接続文字列の編集] ダイアログ ボックス

[接続文字列の編集] ダイアログ ボックスは、使用する接続文字列および資格情報を指定するときに使用します。

UI 要素

要素名 | 説明
[SQL サーバー] | このオプションは、指定した SQL サーバーを使用する場合に選択します。
[サーバー] | 使用するサーバーのパスまたは接続文字列 (たとえば、「.\SQLExpress」) を入力します。
[データベース] | 使用するデータベースの名前 (たとえば、「Test」) を入力します。
[Windows 統合セキュリティを使用] | このオプションは、Windows 統合セキュリティを使用する場合に選択します。ユーザーが既に Windows にログオンしている場合は、再認証を要求せずに Windows 統合セキュリティからユーザー資格情報が ASP.NET に渡されます。この認証方法は、クライアントとサーバーが両方とも同じドメインにある場合に最適です。
[資格情報の指定] | このオプションは、ユーザーが指定する資格情報を使用する場合に選択します。[設定] をクリックして、[資格情報の設定] ダイアログ ボックスを開き、ユーザー名およびパスワードを指定します。
[カスタム] | このオプションは、使用するサーバーのカスタム パスまたは接続文字列 (たとえば、「Server=.\SQLExpress;Database=Test;Integrated Security=true」) を指定する場合に選択します。

関連項目

概念

アプリケーション パッケージのインポート ウィザード ページおよびサーバーまたはサイト パッケージのインポート ウィザード ページ
[アプリケーション パッケージ情報の入力] ページ


[既存のファイルの上書き] ページ

[既存のファイルの上書き] ページは、インポートするファイルの処理方法を指定するときに使用します。新しいファイルをインポート先に追加する、または、既存のファイルを上書きして、アプリケーション パッケージ内に同じファイルがない場合はそのファイルを削除することができます。

UI 要素

要素名 | 説明
[いいえ、アプリケーション パッケージのファイルを単にデスティネーションに追加します。] | このオプションは、インポート先で既存のファイルを保持し、アプリケーション パッケージから新しいファイルを追加するときに選択します。
[はい、デスティネーションに存在し、アプリケーション パッケージには存在しない余分なファイルとフォルダーはすべて削除します。] | このオプションは、アプリケーション パッケージに含まれていないインポート先のファイルをすべて削除するときに選択します。

関連項目

概念

アプリケーション パッケージのインポート ウィザード ページおよびサーバーまたはサイト パッケージのインポート ウィザード ページ


[インストールの進行状況および概要] ページ

[インストールの進行状況および概要] ページは、インポート プロセスの状態を監視するとき、およびウィザードの終了後に操作の概要および詳細情報を確認するときに使用します。

UI 要素

要素名 説明

[状態]

[状態] 領域には、実行中の現在の操作 (ファイルのコピーやデータベース スクリプトなどの操作) が表示されます。復号化を必要とするパスワードや証明書などの項目がアプリケーションに含まれている場合、インポート プロセス中にパスワードの入力を求められることがあります。データ量が多かったり、リモート サーバーからデータをインポートしている場合、インポート操作に時間がかかることがあります。

[概要]

インストール プロセス中に発生したエラーなど、実行された操作の概要を表示します。

重要
[概要] タブには、実行された操作や発生したエラーの完全な一覧は表示されません。[詳細] タブをクリックして、詳細情報を確認できます。

[詳細]

実行された操作の詳細な一覧を表示します。エラーが発生した場合、このタブをクリックすると、トラブルシューティングで使用できる詳細なエラー情報が表示されます。

関連項目

概念

アプリケーション パッケージのインポート ウィザード ページおよびサーバーまたはサイト パッケージのインポート ウィザード ページ