ScrewTurn Wiki

ScrewTurn Wiki API Documentation
ScrewTurn Wiki
ScrewTurn Wiki
API documentation for ScrewTurn Wiki version 3.0.
Namespaces
Namespace | Description
ScrewTurn.Wiki | Root ScrewTurn Wiki namespace.
ScrewTurn.Wiki.AclEngine | Namespace containing ACL Engine types.
ScrewTurn.Wiki.PluginFramework | Namespace containing Plugin Framework types.
ScrewTurn.Wiki.Plugins.ActiveDirectory | Namespace containing Active Directory Provider types.
ScrewTurn.Wiki.Plugins.PluginPack | Namespace containing Plugin Pack types.
ScrewTurn.Wiki.Plugins.SqlCommon | Namespace containing SQL Common types.
ScrewTurn.Wiki.Plugins.SqlServer | Namespace containing SQL Server types.
ScrewTurn.Wiki.SearchEngine | Namespace containing Search Engine types.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.


ScrewTurn.Wiki Namespace

ScrewTurn.Wiki Namespace
ScrewTurn Wiki ► ScrewTurn.Wiki
Root ScrewTurn Wiki namespace.
Declaration Syntax
C# Visual Basic Visual C++
namespace ScrewTurn.Wiki
Namespace ScrewTurn.Wiki
namespace ScrewTurn.Wiki
Types
All Types Classes Structures Interfaces Enumerations
Icon | Type | Description
 | AccountActivationMode | Lists legal account activation mode values.
 | AclStorer | Implements a file-based ACL Storer.
 | Actions | Contains actions for resources.
 | AuthChecker | Utility class for checking permissions and authorizations.
 | AuthReader | Utility class for reading permissions and authorizations.
 | AuthStatus | Lists legal values for authorizations.
 | AuthTools | Implements tools supporting athorization management.
 | AuthWriter | Utility class for writing permissions and authorizations.
 | BreadcrumbsManager | Manages navigation Breadcrumbs.
 | Cache | Manages data cache.
 | CacheProvider | Implements a local cache provider. All instance members are thread-safe.
 | ChangeModerationMode | Lists legal page change moderation mode values.
 | Collectors | Contains instances of the Providers Collectors.
 | Collisions | Manages Page Editing collisions.
 | Content | Contains the Contents.
 | CustomToolbarItem | Represents a custom toolbar item.
 | DataMigrator | Provides methods for migrating data from a Provider to another.
 | Defaults | Contains default values.
 | Difference | O(ND) Difference Algorithm for C# Created by Matthias Hertel, see http://www.mathertel.de This work is licensed under a Creative Commons Attribution 2.0 Germany License. see http://creativecommons.org/licenses/by/2.0/de/
 | DiffTools | Provides methods for diffing text and items.
 | EditingSession | Represents an Editing Session.
 | EmailTools | Implements email-related tools.
 | Exchanger | Class used for exchaning data between the Core library and the Wiki engine.
 | FileDocument | Represents a file document.
 | FileDownloadCountFilterMode | Lists legal file download filter modes.
 | FilesAndAttachments | Manages files, directories and attachments.
 | FilesStorageProvider | Implements a Local Files Storage Provider.
 | Actions..::.ForDirectories | Contains actions for file directories.
 | Actions..::.ForGlobals | Contains actions for global resources.
 | Formatter | Performs all the text formatting and parsing operations.
 | FormattingPipeline | Contains methods for formatting content using a pipeline paradigm.
 | Actions..::.ForNamespaces | Contains actions for namespaces.
 | Actions..::.ForPages | Contains actions for pages.
 | Hash | Helps computing Hash codes.
 | Host | Implements the IHost interface.
 | HPosition | Represents a Header.
 | HPositionComparer | Compares HPosition objects.
 | HtmlList | Represents a HTML list.
 | HtmlListElement | Represents a HTML list element.
 | HtmlListType | Lists HTML list types.
 | IndexStorer | Stores index data to disk.
 | IResourceExchanger | Exposes methods for exchanging Resources.
 | Difference..::.Item | details of one difference.
 | LocalPageInfo | Represents a Local Page.
 | LocalProvidersTools | Implements tools for local providers.
 | LocalUserInfo | Stores a Local UserInfo object.
 | Log | Records and retrieves Log Entries.
 | MimeTypes | Contains a list of MIME Types.
 | MovedUser | Contains username, email and registration date/time of a moved User account.
 | NavigationPaths | Manages navigation paths.
 | PageAttachmentDocument | Represents a page attachment document.
 | PageContentDateComparer | Compares PageContent objects.
 | Pages | Allows access to the Pages.
 | PagesStorageProvider | Implements a Pages Storage Provider.
 | Preferences | Allows access to current user's preferences.
 | ProviderCollector<(Of <(T>)>) | Implements a generic Provider Collector.
 | ProviderConstraintException | Defines an exception thrown when a constraint is not fulfilled by a provider.
 | ProviderLoader | Loads providers from assemblies.
 | ProviderUpdater | Handles the updating of providers.
 | RecentChanges | Manages the Wiki's Recent Changes.
 | Redirections | Manages information about Page Redirections.
 | ReverseFormatter | Implements reverse formatting methods (HTML->WikiMarkup).
 | RssFeedsMode | Lists legal RSS feeds function modes.
 | SearchTools | Implements tools for searching through the wiki.
 | SessionCache | Implements a session data cache whose lifetime is only limited to one request.
 | SessionFacade | Exposes in a strongly-typed fashion the Session variables.
 | Settings | Allows access to all the ScrewTurn Wiki settings and configuration options.
 | SettingsStorageProvider | Implements a Settings Storage Provider against local text pluginAssemblies.
 | Snippets | Manages snippets.
 | StartupTools | Provides tools for starting and shutting down the wiki engine.
 | SubjectInfo | Describes the subject of an ACL entry.
 | SubjectType | Lists legal values for the type of a subject.
 | Tag | Represents an open or close tag.
 | TagType | Lists tag types.
 | Templates | Manages content templates.
 | Tools | Contains useful Tools.
 | UpdateStatus | Lists legal update statuses.
 | UrlTools | Implements useful URL-handling tools.
 | Users | Manages all the User Accounts data.
 | UsersStorageProvider | Implements a Users Storage Provider.


AccountActivationMode Enumeration

AccountActivationMode Enumeration
ScrewTurn Wiki ► ScrewTurn.Wiki ► AccountActivationMode
Lists legal account activation mode values.
Declaration Syntax
C# Visual Basic Visual C++
public enum AccountActivationMode
Public Enumeration AccountActivationMode
public enum class AccountActivationMode
Members
Member | Description
Email | Users must activate their account via email.
Administrator | Accounts must be activated by administrators.
Auto | Accounts are active by default.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


AclStorer Class

AclStorer Class
ScrewTurn Wiki ► ScrewTurn.Wiki ► AclStorer
Implements a file-based ACL Storer.
Declaration Syntax
C# Visual Basic Visual C++
public class AclStorer : AclStorerBase
Public Class AclStorer _
    Inherits AclStorerBase
public ref class AclStorer : public AclStorerBase
Members
All Members | Constructors | Methods | Properties | Fields
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | AclStorer(IAclManager, String) | Initializes a new instance of the AclStorer class.
 | aclChangedHandler | The event handler for the AclChanged event. (Inherited from AclStorerBase.)
 | aclManager | The instance of the ACL Manager to handle. (Inherited from AclStorerBase.)
 | AclManager | Gets the instance of the ACL Manager. (Inherited from AclStorerBase.)
 | DeleteEntries(array<AclEntry>[]()[]) | Deletes some entries. (Overrides AclStorerBase.DeleteEntries(array<AclEntry>[]()[]).)
 | Dispose()()() | Disposes the current object. (Inherited from AclStorerBase.)
 | disposed | Indicates whether the object was disposed. (Inherited from AclStorerBase.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | LoadData()()() | Loads the data and injects it in the instance of IAclManager. (Inherited from AclStorerBase.)
 | LoadDataInternal()()() | Loads data from storage. (Overrides AclStorerBase.LoadDataInternal()()().)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | StoreEntries(array<AclEntry>[]()[]) | Stores some entries. (Overrides AclStorerBase.StoreEntries(array<AclEntry>[]()[]).)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | AclStorerBase
 |  | AclStorer

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


AclStorer Constructor (aclManager, file)

AclStorer Constructor (aclManager, file)
ScrewTurn Wiki ► ScrewTurn.Wiki ► AclStorer ► AclStorer(IAclManager, String)
Initializes a new instance of the AclStorer class.
Declaration Syntax
C# Visual Basic Visual C++
public AclStorer(
    IAclManager aclManager,
    string file
)
Public Sub New ( _
    aclManager As IAclManager, _
    file As String _
)
public:
AclStorer(
    IAclManager^ aclManager,
    String^ file
)
Parameters
aclManager (IAclManager)
The instance of the ACL Manager to handle.
file (String)
The storage file.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


DeleteEntries Method (entries)

DeleteEntries Method (entries)
ScrewTurn Wiki ► ScrewTurn.Wiki ► AclStorer ► DeleteEntries(array<AclEntry>[]()[])
Deletes some entries.
Declaration Syntax
C# Visual Basic Visual C++
protected override void DeleteEntries(
    AclEntry[] entries
)
Protected Overrides Sub DeleteEntries ( _
    entries As AclEntry() _
)
protected:
virtual void DeleteEntries(
    array<AclEntry^>^ entries
) override
Parameters
entries (array< AclEntry >[]()[][])
The entries to delete.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


LoadDataInternal Method

LoadDataInternal Method
ScrewTurn Wiki ► ScrewTurn.Wiki ► AclStorer ► LoadDataInternal()()()
Loads data from storage.
Declaration Syntax
C# Visual Basic Visual C++
protected override AclEntry[] LoadDataInternal()
Protected Overrides Function LoadDataInternal As AclEntry()
protected:
virtual array<AclEntry^>^ LoadDataInternal() override
Return Value
The loaded ACL entries.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


StoreEntries Method (entries)

StoreEntries Method (entries)
ScrewTurn Wiki ► ScrewTurn.Wiki ► AclStorer ► StoreEntries(array<AclEntry>[]()[])
Stores some entries.
Declaration Syntax
C# Visual Basic Visual C++
protected override void StoreEntries(
    AclEntry[] entries
)
Protected Overrides Sub StoreEntries ( _
    entries As AclEntry() _
)
protected:
virtual void StoreEntries(
    array<AclEntry^>^ entries
) override
Parameters
entries (array< AclEntry >[]()[][])
The entries to store.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


Actions Class

Actions Class
ScrewTurn Wiki ► ScrewTurn.Wiki ► Actions
Contains actions for resources.
Declaration Syntax
C# Visual Basic Visual C++
public static class Actions
Public NotInheritable Class Actions
public ref class Actions abstract sealed
Members
All Members | Fields
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | FullControl | The full control action.
Inheritance Hierarchy
Object
Actions

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.PluginFramework (Module: ScrewTurn.Wiki.PluginFramework) Version: 3.0.2.500 (3.0.2.500)


FullControl Field

FullControl Field
ScrewTurn Wiki ► ScrewTurn.Wiki ► Actions ► FullControl
The full control action.
Declaration Syntax
C# Visual Basic Visual C++
public const string FullControl
Public Const FullControl As String
public:
literal String^ FullControl

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.PluginFramework (Module: ScrewTurn.Wiki.PluginFramework) Version: 3.0.2.500 (3.0.2.500)


Actions.ForDirectories Class

Actions..::..ForDirectories Class
ScrewTurn Wiki ► ScrewTurn.Wiki ► Actions ► Actions..::.ForDirectories
Contains actions for file directories.
Declaration Syntax
C# Visual Basic Visual C++
public static class ForDirectories
Public NotInheritable Class ForDirectories
public ref class ForDirectories abstract sealed
Members
All Members | Methods | Fields
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | All | Gets an array containing all actions.
 | CreateDirectories | Create directories.
 | DeleteDirectories | Delete directories.
 | DeleteFiles | Delete files.
 | DownloadFiles | Download files.
 | GetFullName(String) | Gets the full name of an action.
 | GlobalEscalators | The global escalation policies.
 | List | List files and directories.
 | LocalEscalators | The local escalation policies.
 | ResourceMasterPrefix | The master prefix for directories ('D.').
 | UploadFiles | Upload files.
Inheritance Hierarchy
Object
Actions..::.ForDirectories

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.PluginFramework (Module: ScrewTurn.Wiki.PluginFramework) Version: 3.0.2.500 (3.0.2.500)


All Field

All Field
ScrewTurn Wiki ► ScrewTurn.Wiki ► Actions..::.ForDirectories ► All
Gets an array containing all actions.
Declaration Syntax
C# Visual Basic Visual C++
public static readonly string[] All
Public Shared ReadOnly All As String()
public:
static initonly array<String^>^ All

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.PluginFramework (Module: ScrewTurn.Wiki.PluginFramework) Version: 3.0.2.500 (3.0.2.500)


CreateDirectories Field

CreateDirectories Field
ScrewTurn Wiki ► ScrewTurn.Wiki ► Actions..::.ForDirectories ► CreateDirectories
Create directories.
Declaration Syntax
C# Visual Basic Visual C++
public const string CreateDirectories
Public Const CreateDirectories As String
public:
literal String^ CreateDirectories

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.PluginFramework (Module: ScrewTurn.Wiki.PluginFramework) Version: 3.0.2.500 (3.0.2.500)


DeleteDirectories Field

DeleteDirectories Field
ScrewTurn Wiki ► ScrewTurn.Wiki ► Actions..::.ForDirectories ► DeleteDirectories
Delete directories.
Declaration Syntax
C# Visual Basic Visual C++
public const string DeleteDirectories
Public Const DeleteDirectories As String
public:
literal String^ DeleteDirectories

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.PluginFramework (Module: ScrewTurn.Wiki.PluginFramework) Version: 3.0.2.500 (3.0.2.500)


DeleteFiles Field

DeleteFiles Field
ScrewTurn Wiki ► ScrewTurn.Wiki ► Actions..::.ForDirectories ► DeleteFiles
Delete files.
Declaration Syntax
C# Visual Basic Visual C++
public const string DeleteFiles
Public Const DeleteFiles As String
public:
literal String^ DeleteFiles

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.PluginFramework (Module: ScrewTurn.Wiki.PluginFramework) Version: 3.0.2.500 (3.0.2.500)


DownloadFiles Field

DownloadFiles Field
ScrewTurn Wiki ► ScrewTurn.Wiki ► Actions..::.ForDirectories ► DownloadFiles
Download files.
Declaration Syntax
C# Visual Basic Visual C++
public const string DownloadFiles
Public Const DownloadFiles As String
public:
literal String^ DownloadFiles

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.PluginFramework (Module: ScrewTurn.Wiki.PluginFramework) Version: 3.0.2.500 (3.0.2.500)


GetFullName Method (name)

GetFullName Method (name)
ScrewTurn Wiki ► ScrewTurn.Wiki ► Actions..::.ForDirectories ► GetFullName(String)
Gets the full name of an action.
Declaration Syntax
C# Visual Basic Visual C++
public static string GetFullName(
    string name
)
Public Shared Function GetFullName ( _
    name As String _
) As String
public:
static String^ GetFullName(
    String^ name
)
Parameters
name (String)
The internal name.
Return Value
The full name.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.PluginFramework (Module: ScrewTurn.Wiki.PluginFramework) Version: 3.0.2.500 (3.0.2.500)


GlobalEscalators Field

GlobalEscalators Field
ScrewTurn Wiki ► ScrewTurn.Wiki ► Actions..::.ForDirectories ► GlobalEscalators
The global escalation policies.
Declaration Syntax
C# Visual Basic Visual C++
public static readonly Dictionary<string, string[]> GlobalEscalators
Public Shared ReadOnly GlobalEscalators As Dictionary(Of String, String())
public:
static initonly Dictionary<String^, array<String^>^>^ GlobalEscalators

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.PluginFramework (Module: ScrewTurn.Wiki.PluginFramework) Version: 3.0.2.500 (3.0.2.500)


List Field

List Field
ScrewTurn Wiki ► ScrewTurn.Wiki ► Actions..::.ForDirectories ► List
List files and directories.
Declaration Syntax
C# Visual Basic Visual C++
public const string List
Public Const List As String
public:
literal String^ List

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.PluginFramework (Module: ScrewTurn.Wiki.PluginFramework) Version: 3.0.2.500 (3.0.2.500)


LocalEscalators Field

LocalEscalators Field
ScrewTurn Wiki ► ScrewTurn.Wiki ► Actions..::.ForDirectories ► LocalEscalators
The local escalation policies.
Declaration Syntax
C# Visual Basic Visual C++
public static readonly Dictionary<string, string[]> LocalEscalators
Public Shared ReadOnly LocalEscalators As Dictionary(Of String, String())
public:
static initonly Dictionary<String^, array<String^>^>^ LocalEscalators

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.PluginFramework (Module: ScrewTurn.Wiki.PluginFramework) Version: 3.0.2.500 (3.0.2.500)


ResourceMasterPrefix Field

ResourceMasterPrefix Field
ScrewTurn Wiki ► ScrewTurn.Wiki ► Actions..::.ForDirectories ► ResourceMasterPrefix
The master prefix for directories ('D.').
Declaration Syntax
C# Visual Basic Visual C++
public const string ResourceMasterPrefix
Public Const ResourceMasterPrefix As String
public:
literal String^ ResourceMasterPrefix

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.PluginFramework (Module: ScrewTurn.Wiki.PluginFramework) Version: 3.0.2.500 (3.0.2.500)


UploadFiles Field

UploadFiles Field
ScrewTurn Wiki ► ScrewTurn.Wiki ► Actions..::.ForDirectories ► UploadFiles
Upload files.
Declaration Syntax
C# Visual Basic Visual C++
public const string UploadFiles
Public Const UploadFiles As String
public:
literal String^ UploadFiles

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.PluginFramework (Module: ScrewTurn.Wiki.PluginFramework) Version: 3.0.2.500 (3.0.2.500)


Actions.ForGlobals Class

Actions..::..ForGlobals Class
ScrewTurn Wiki ► ScrewTurn.Wiki ► Actions ► Actions..::.ForGlobals
Contains actions for global resources.
Declaration Syntax
C# Visual Basic Visual C++
public static class ForGlobals
Public NotInheritable Class ForGlobals
public ref class ForGlobals abstract sealed
Members
All Members | Methods | Fields
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | All | Gets an array containing all actions.
 | GetFullName(String) | Gets the full name of an action.
 | ManageAccounts | Manage user accounts.
 | ManageConfiguration | Manage configuration.
 | ManageDiscussions | Manage page discussions.
 | ManageFiles | Manage files.
 | ManageGroups | Manage user groups.
 | ManageMetaFiles | Manage meta-files.
 | ManageNamespaces | Manage namespaces.
 | ManageNavigationPaths | Manage navigation paths.
 | ManagePagesAndCategories | Manage pages and categories.
 | ManagePermissions | Manage permissions.
 | ManageProviders | Manage providers.
 | ManageSnippetsAndTemplates | Manage snippets and templates.
 | ResourceMasterPrefix | The master prefix for global resources ('G').
Inheritance Hierarchy
Object
Actions..::.ForGlobals

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.PluginFramework (Module: ScrewTurn.Wiki.PluginFramework) Version: 3.0.2.500 (3.0.2.500)


All Field

All Field
ScrewTurn Wiki ► ScrewTurn.Wiki ► Actions..::.ForGlobals ► All
Gets an array containing all actions.
Declaration Syntax
C# Visual Basic Visual C++
public static readonly string[] All
Public Shared ReadOnly All As String()
public:
static initonly array<String^>^ All

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.PluginFramework (Module: ScrewTurn.Wiki.PluginFramework) Version: 3.0.2.500 (3.0.2.500)


GetFullName Method (name)

GetFullName Method (name)
ScrewTurn Wiki ► ScrewTurn.Wiki ► Actions..::.ForGlobals ► GetFullName(String)
Gets the full name of an action.
Declaration Syntax
C# Visual Basic Visual C++
public static string GetFullName(
    string name
)
Public Shared Function GetFullName ( _
    name As String _
) As String
public:
static String^ GetFullName(
    String^ name
)
Parameters
name (String)
The internal name.
Return Value
The full name.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.PluginFramework (Module: ScrewTurn.Wiki.PluginFramework) Version: 3.0.2.500 (3.0.2.500)


ManageAccounts Field

ManageAccounts Field
ScrewTurn Wiki ► ScrewTurn.Wiki ► Actions..::.ForGlobals ► ManageAccounts
Manage user accounts.
Declaration Syntax
C# Visual Basic Visual C++
public const string ManageAccounts
Public Const ManageAccounts As String
public:
literal String^ ManageAccounts

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.PluginFramework (Module: ScrewTurn.Wiki.PluginFramework) Version: 3.0.2.500 (3.0.2.500)


ManageConfiguration Field

ManageConfiguration Field
ScrewTurn Wiki ► ScrewTurn.Wiki ► Actions..::.ForGlobals ► ManageConfiguration
Manage configuration.
Declaration Syntax
C# Visual Basic Visual C++
public const string ManageConfiguration
Public Const ManageConfiguration As String
public:
literal String^ ManageConfiguration

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.PluginFramework (Module: ScrewTurn.Wiki.PluginFramework) Version: 3.0.2.500 (3.0.2.500)


ManageDiscussions Field

ManageDiscussions Field
ScrewTurn Wiki ► ScrewTurn.Wiki ► Actions..::.ForGlobals ► ManageDiscussions
Manage page discussions.
Declaration Syntax
C# Visual Basic Visual C++
public const string ManageDiscussions
Public Const ManageDiscussions As String
public:
literal String^ ManageDiscussions

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.PluginFramework (Module: ScrewTurn.Wiki.PluginFramework) Version: 3.0.2.500 (3.0.2.500)


ManageFiles Field

ManageFiles Field
ScrewTurn Wiki ► ScrewTurn.Wiki ► Actions..::.ForGlobals ► ManageFiles
Manage files.
Declaration Syntax
C# Visual Basic Visual C++
public const string ManageFiles
Public Const ManageFiles As String
public:
literal String^ ManageFiles

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.PluginFramework (Module: ScrewTurn.Wiki.PluginFramework) Version: 3.0.2.500 (3.0.2.500)


ManageGroups Field

ManageGroups Field
ScrewTurn Wiki ► ScrewTurn.Wiki ► Actions..::.ForGlobals ► ManageGroups
Manage user groups.
Declaration Syntax
C# Visual Basic Visual C++
public const string ManageGroups
Public Const ManageGroups As String
public:
literal String^ ManageGroups

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.PluginFramework (Module: ScrewTurn.Wiki.PluginFramework) Version: 3.0.2.500 (3.0.2.500)


ManageMetaFiles Field

ManageMetaFiles Field
ScrewTurn Wiki ► ScrewTurn.Wiki ► Actions..::.ForGlobals ► ManageMetaFiles
Manage meta-files.
Declaration Syntax
C# Visual Basic Visual C++
public const string ManageMetaFiles
Public Const ManageMetaFiles As String
public:
literal String^ ManageMetaFiles

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.PluginFramework (Module: ScrewTurn.Wiki.PluginFramework) Version: 3.0.2.500 (3.0.2.500)


ManageNamespaces Field

ManageNamespaces Field
ScrewTurn Wiki ► ScrewTurn.Wiki ► Actions..::.ForGlobals ► ManageNamespaces
Manage namespaces.
Declaration Syntax
C# Visual Basic Visual C++
public const string ManageNamespaces
Public Const ManageNamespaces As String
public:
literal String^ ManageNamespaces

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.PluginFramework (Module: ScrewTurn.Wiki.PluginFramework) Version: 3.0.2.500 (3.0.2.500)


ManageNavigationPaths Field

ManageNavigationPaths Field
ScrewTurn Wiki ► ScrewTurn.Wiki ► Actions..::.ForGlobals ► ManageNavigationPaths
Manage navigation paths.
Declaration Syntax
C# Visual Basic Visual C++
public const string ManageNavigationPaths
Public Const ManageNavigationPaths As String
public:
literal String^ ManageNavigationPaths

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.PluginFramework (Module: ScrewTurn.Wiki.PluginFramework) Version: 3.0.2.500 (3.0.2.500)


ManagePagesAndCategories Field

ManagePagesAndCategories Field
ScrewTurn Wiki ► ScrewTurn.Wiki ► Actions..::.ForGlobals ► ManagePagesAndCategories
Manage pages and categories.
Declaration Syntax
C# Visual Basic Visual C++
public const string ManagePagesAndCategories
Public Const ManagePagesAndCategories As String
public:
literal String^ ManagePagesAndCategories

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.PluginFramework (Module: ScrewTurn.Wiki.PluginFramework) Version: 3.0.2.500 (3.0.2.500)


ManagePermissions Field

ManagePermissions Field
ScrewTurn Wiki ► ScrewTurn.Wiki ► Actions..::.ForGlobals ► ManagePermissions
Manage permissions.
Declaration Syntax
C# Visual Basic Visual C++
public const string ManagePermissions
Public Const ManagePermissions As String
public:
literal String^ ManagePermissions

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.PluginFramework (Module: ScrewTurn.Wiki.PluginFramework) Version: 3.0.2.500 (3.0.2.500)


ManageProviders Field

ManageProviders Field
ScrewTurn Wiki ► ScrewTurn.Wiki ► Actions..::.ForGlobals ► ManageProviders
Manage providers.
Declaration Syntax
C# Visual Basic Visual C++
public const string ManageProviders
Public Const ManageProviders As String
public:
literal String^ ManageProviders

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.PluginFramework (Module: ScrewTurn.Wiki.PluginFramework) Version: 3.0.2.500 (3.0.2.500)


ManageSnippetsAndTemplates Field

ManageSnippetsAndTemplates Field
ScrewTurn Wiki ► ScrewTurn.Wiki ► Actions..::.ForGlobals ► ManageSnippetsAndTemplates
Manage snippets and templates.
Declaration Syntax
C# Visual Basic Visual C++
public const string ManageSnippetsAndTemplates
Public Const ManageSnippetsAndTemplates As String
public:
literal String^ ManageSnippetsAndTemplates

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.PluginFramework (Module: ScrewTurn.Wiki.PluginFramework) Version: 3.0.2.500 (3.0.2.500)


ResourceMasterPrefix Field

ResourceMasterPrefix Field
ScrewTurn Wiki ► ScrewTurn.Wiki ► Actions..::.ForGlobals ► ResourceMasterPrefix
The master prefix for global resources ('G').
Declaration Syntax
C# Visual Basic Visual C++
public const string ResourceMasterPrefix
Public Const ResourceMasterPrefix As String
public:
literal String^ ResourceMasterPrefix

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.PluginFramework (Module: ScrewTurn.Wiki.PluginFramework) Version: 3.0.2.500 (3.0.2.500)


Actions.ForNamespaces Class

Actions..::..ForNamespaces Class
ScrewTurn Wiki ► ScrewTurn.Wiki ► Actions ► Actions..::.ForNamespaces
Contains actions for namespaces.
Declaration Syntax
C# Visual Basic Visual C++
public static class ForNamespaces
Public NotInheritable Class ForNamespaces
public ref class ForNamespaces abstract sealed
Members
All Members | Methods | Fields
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | All | Gets an array containing all actions.
 | CreatePages | Create pages.
 | DeleteAttachments | Delete attachments.
 | DeletePages | Delete pages.
 | DownloadAttachments | Download attachments.
 | GetFullName(String) | Gets the full name of an action.
 | GlobalEscalators | The global escalation policies.
 | LocalEscalators | The local escalation policies.
 | ManageCategories | Manage categories.
 | ManageDiscussion | Manage messages in page discussions.
 | ManagePages | Manage pages.
 | ModifyPages | Modify pages.
 | PostDiscussion | Post messages in page discussions.
 | ReadDiscussion | Read page discussions.
 | ReadPages | Read pages.
 | ResourceMasterPrefix | The master prefix for namespaces ('N.').
 | UploadAttachments | Upload attachments.
Inheritance Hierarchy
Object
Actions..::.ForNamespaces

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.PluginFramework (Module: ScrewTurn.Wiki.PluginFramework) Version: 3.0.2.500 (3.0.2.500)


All Field

All Field
ScrewTurn Wiki ► ScrewTurn.Wiki ► Actions..::.ForNamespaces ► All
Gets an array containing all actions.
Declaration Syntax
C# Visual Basic Visual C++
public static readonly string[] All
Public Shared ReadOnly All As String()
public:
static initonly array<String^>^ All

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.PluginFramework (Module: ScrewTurn.Wiki.PluginFramework) Version: 3.0.2.500 (3.0.2.500)


CreatePages Field

CreatePages Field
ScrewTurn Wiki ► ScrewTurn.Wiki ► Actions..::.ForNamespaces ► CreatePages
Create pages.
Declaration Syntax
C# Visual Basic Visual C++
public const string CreatePages
Public Const CreatePages As String
public:
literal String^ CreatePages

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.PluginFramework (Module: ScrewTurn.Wiki.PluginFramework) Version: 3.0.2.500 (3.0.2.500)


DeleteAttachments Field

DeleteAttachments Field
ScrewTurn Wiki ► ScrewTurn.Wiki ► Actions..::.ForNamespaces ► DeleteAttachments
Delete attachments.
Declaration Syntax
C# Visual Basic Visual C++
public const string DeleteAttachments
Public Const DeleteAttachments As String
public:
literal String^ DeleteAttachments

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.PluginFramework (Module: ScrewTurn.Wiki.PluginFramework) Version: 3.0.2.500 (3.0.2.500)


DeletePages Field

DeletePages Field
ScrewTurn Wiki ► ScrewTurn.Wiki ► Actions..::.ForNamespaces ► DeletePages
Delete pages.
Declaration Syntax
C# Visual Basic Visual C++
public const string DeletePages
Public Const DeletePages As String
public:
literal String^ DeletePages

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.PluginFramework (Module: ScrewTurn.Wiki.PluginFramework) Version: 3.0.2.500 (3.0.2.500)


DownloadAttachments Field

DownloadAttachments Field
ScrewTurn Wiki ► ScrewTurn.Wiki ► Actions..::.ForNamespaces ► DownloadAttachments
Download attachments.
Declaration Syntax
C# Visual Basic Visual C++
public const string DownloadAttachments
Public Const DownloadAttachments As String
public:
literal String^ DownloadAttachments

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.PluginFramework (Module: ScrewTurn.Wiki.PluginFramework) Version: 3.0.2.500 (3.0.2.500)


GetFullName Method (name)

GetFullName Method (name)
ScrewTurn Wiki ► ScrewTurn.Wiki ► Actions..::.ForNamespaces ► GetFullName(String)
Gets the full name of an action.
Declaration Syntax
C# Visual Basic Visual C++
public static string GetFullName(
    string name
)
Public Shared Function GetFullName ( _
    name As String _
) As String
public:
static String^ GetFullName(
    String^ name
)
Parameters
name (String)
The internal name.
Return Value
The full name.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.PluginFramework (Module: ScrewTurn.Wiki.PluginFramework) Version: 3.0.2.500 (3.0.2.500)


GlobalEscalators Field

GlobalEscalators Field
ScrewTurn Wiki ► ScrewTurn.Wiki ► Actions..::.ForNamespaces ► GlobalEscalators
The global escalation policies.
Declaration Syntax
C# Visual Basic Visual C++
public static readonly Dictionary<string, string[]> GlobalEscalators
Public Shared ReadOnly GlobalEscalators As Dictionary(Of String, String())
public:
static initonly Dictionary<String^, array<String^>^>^ GlobalEscalators

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.PluginFramework (Module: ScrewTurn.Wiki.PluginFramework) Version: 3.0.2.500 (3.0.2.500)


LocalEscalators Field

LocalEscalators Field
ScrewTurn Wiki ► ScrewTurn.Wiki ► Actions..::.ForNamespaces ► LocalEscalators
The local escalation policies.
Declaration Syntax
C# Visual Basic Visual C++
public static readonly Dictionary<string, string[]> LocalEscalators
Public Shared ReadOnly LocalEscalators As Dictionary(Of String, String())
public:
static initonly Dictionary<String^, array<String^>^>^ LocalEscalators

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.PluginFramework (Module: ScrewTurn.Wiki.PluginFramework) Version: 3.0.2.500 (3.0.2.500)


ManageCategories Field

ManageCategories Field
ScrewTurn Wiki ► ScrewTurn.Wiki ► Actions..::.ForNamespaces ► ManageCategories
Manage categories.
Declaration Syntax
C# Visual Basic Visual C++
public const string ManageCategories
Public Const ManageCategories As String
public:
literal String^ ManageCategories

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.PluginFramework (Module: ScrewTurn.Wiki.PluginFramework) Version: 3.0.2.500 (3.0.2.500)


ManageDiscussion Field

ManageDiscussion Field
ScrewTurn Wiki ► ScrewTurn.Wiki ► Actions..::.ForNamespaces ► ManageDiscussion
Manage messages in page discussions.
Declaration Syntax
C# Visual Basic Visual C++
public const string ManageDiscussion
Public Const ManageDiscussion As String
public:
literal String^ ManageDiscussion

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.PluginFramework (Module: ScrewTurn.Wiki.PluginFramework) Version: 3.0.2.500 (3.0.2.500)


ManagePages Field

ManagePages Field
ScrewTurn Wiki ► ScrewTurn.Wiki ► Actions..::.ForNamespaces ► ManagePages
Manage pages.
Declaration Syntax
C# Visual Basic Visual C++
public const string ManagePages
Public Const ManagePages As String
public:
literal String^ ManagePages

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.PluginFramework (Module: ScrewTurn.Wiki.PluginFramework) Version: 3.0.2.500 (3.0.2.500)


ModifyPages Field

ModifyPages Field
ScrewTurn Wiki ► ScrewTurn.Wiki ► Actions..::.ForNamespaces ► ModifyPages
Modify pages.
Declaration Syntax
C# Visual Basic Visual C++
public const string ModifyPages
Public Const ModifyPages As String
public:
literal String^ ModifyPages

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.PluginFramework (Module: ScrewTurn.Wiki.PluginFramework) Version: 3.0.2.500 (3.0.2.500)


PostDiscussion Field

PostDiscussion Field
ScrewTurn Wiki ► ScrewTurn.Wiki ► Actions..::.ForNamespaces ► PostDiscussion
Post messages in page discussions.
Declaration Syntax
C# Visual Basic Visual C++
public const string PostDiscussion
Public Const PostDiscussion As String
public:
literal String^ PostDiscussion

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.PluginFramework (Module: ScrewTurn.Wiki.PluginFramework) Version: 3.0.2.500 (3.0.2.500)


ReadDiscussion Field

ReadDiscussion Field
ScrewTurn Wiki ► ScrewTurn.Wiki ► Actions..::.ForNamespaces ► ReadDiscussion
Read page discussions.
Declaration Syntax
C# Visual Basic Visual C++
public const string ReadDiscussion
Public Const ReadDiscussion As String
public:
literal String^ ReadDiscussion

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.PluginFramework (Module: ScrewTurn.Wiki.PluginFramework) Version: 3.0.2.500 (3.0.2.500)


ReadPages Field

ReadPages Field
ScrewTurn Wiki ► ScrewTurn.Wiki ► Actions..::.ForNamespaces ► ReadPages
Read pages.
Declaration Syntax
C# Visual Basic Visual C++
public const string ReadPages
Public Const ReadPages As String
public:
literal String^ ReadPages

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.PluginFramework (Module: ScrewTurn.Wiki.PluginFramework) Version: 3.0.2.500 (3.0.2.500)


ResourceMasterPrefix Field

ResourceMasterPrefix Field
ScrewTurn Wiki ► ScrewTurn.Wiki ► Actions..::.ForNamespaces ► ResourceMasterPrefix
The master prefix for namespaces ('N.').
Declaration Syntax
C# Visual Basic Visual C++
public const string ResourceMasterPrefix
Public Const ResourceMasterPrefix As String
public:
literal String^ ResourceMasterPrefix

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.PluginFramework (Module: ScrewTurn.Wiki.PluginFramework) Version: 3.0.2.500 (3.0.2.500)


UploadAttachments Field

UploadAttachments Field
ScrewTurn Wiki ► ScrewTurn.Wiki ► Actions..::.ForNamespaces ► UploadAttachments
Upload attachments.
Declaration Syntax
C# Visual Basic Visual C++
public const string UploadAttachments
Public Const UploadAttachments As String
public:
literal String^ UploadAttachments

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.PluginFramework (Module: ScrewTurn.Wiki.PluginFramework) Version: 3.0.2.500 (3.0.2.500)


Actions.ForPages Class

Actions..::..ForPages Class
ScrewTurn Wiki ► ScrewTurn.Wiki ► Actions ► Actions..::.ForPages
Contains actions for pages.
Declaration Syntax
C# Visual Basic Visual C++
public static class ForPages
Public NotInheritable Class ForPages
public ref class ForPages abstract sealed
Members
All Members | Methods | Fields
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | All | Gets an array containing all actions.
 | DeleteAttachments | Delete attachments.
 | DownloadAttachments | Download attachments.
 | GetFullName(String) | Gets the full name of an action.
 | GlobalEscalators | The global escalation policies.
 | LocalEscalators | The local escalation policies.
 | ManageCategories | Manage the categories of the page.
 | ManageDiscussion | Manage page discussion.
 | ManagePage | Manage the page.
 | ModifyPage | Modify the page.
 | NamespaceEscalators | The namespace escalation policies.
 | PostDiscussion | Post messages in page discussion.
 | ReadDiscussion | Read page discussion.
 | ReadPage | Read the page.
 | ResourceMasterPrefix | The master prefix for pages ('P.').
 | UploadAttachments | Upload attachments.
Inheritance Hierarchy
Object
Actions..::.ForPages

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.PluginFramework (Module: ScrewTurn.Wiki.PluginFramework) Version: 3.0.2.500 (3.0.2.500)


All Field

All Field
ScrewTurn Wiki ► ScrewTurn.Wiki ► Actions..::.ForPages ► All
Gets an array containing all actions.
Declaration Syntax
C# Visual Basic Visual C++
public static readonly string[] All
Public Shared ReadOnly All As String()
public:
static initonly array<String^>^ All

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.PluginFramework (Module: ScrewTurn.Wiki.PluginFramework) Version: 3.0.2.500 (3.0.2.500)


DeleteAttachments Field

DeleteAttachments Field
ScrewTurn Wiki ► ScrewTurn.Wiki ► Actions..::.ForPages ► DeleteAttachments
Delete attachments.
Declaration Syntax
C# Visual Basic Visual C++
public const string DeleteAttachments
Public Const DeleteAttachments As String
public:
literal String^ DeleteAttachments

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.PluginFramework (Module: ScrewTurn.Wiki.PluginFramework) Version: 3.0.2.500 (3.0.2.500)


DownloadAttachments Field

DownloadAttachments Field
ScrewTurn Wiki ► ScrewTurn.Wiki ► Actions..::.ForPages ► DownloadAttachments
Download attachments.
Declaration Syntax
C# Visual Basic Visual C++
public const string DownloadAttachments
Public Const DownloadAttachments As String
public:
literal String^ DownloadAttachments

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.PluginFramework (Module: ScrewTurn.Wiki.PluginFramework) Version: 3.0.2.500 (3.0.2.500)


GetFullName Method (name)

GetFullName Method (name)
ScrewTurn Wiki ► ScrewTurn.Wiki ► Actions..::.ForPages ► GetFullName(String)
Gets the full name of an action.
Declaration Syntax
C# Visual Basic Visual C++
public static string GetFullName(
    string name
)
Public Shared Function GetFullName ( _
    name As String _
) As String
public:
static String^ GetFullName(
    String^ name
)
Parameters
name (String)
The internal name.
Return Value
The full name.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.PluginFramework (Module: ScrewTurn.Wiki.PluginFramework) Version: 3.0.2.500 (3.0.2.500)


GlobalEscalators Field

GlobalEscalators Field
ScrewTurn Wiki ► ScrewTurn.Wiki ► Actions..::.ForPages ► GlobalEscalators
The global escalation policies.
Declaration Syntax
C# Visual Basic Visual C++
public static readonly Dictionary<string, string[]> GlobalEscalators
Public Shared ReadOnly GlobalEscalators As Dictionary(Of String, String())
public:
static initonly Dictionary<String^, array<String^>^>^ GlobalEscalators

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.PluginFramework (Module: ScrewTurn.Wiki.PluginFramework) Version: 3.0.2.500 (3.0.2.500)


LocalEscalators Field

LocalEscalators Field
ScrewTurn Wiki ► ScrewTurn.Wiki ► Actions..::.ForPages ► LocalEscalators
The local escalation policies.
Declaration Syntax
C# Visual Basic Visual C++
public static readonly Dictionary<string, string[]> LocalEscalators
Public Shared ReadOnly LocalEscalators As Dictionary(Of String, String())
public:
static initonly Dictionary<String^, array<String^>^>^ LocalEscalators

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.PluginFramework (Module: ScrewTurn.Wiki.PluginFramework) Version: 3.0.2.500 (3.0.2.500)


ManageCategories Field

ManageCategories Field
ScrewTurn Wiki ► ScrewTurn.Wiki ► Actions..::.ForPages ► ManageCategories
Manage the categories of the page.
Declaration Syntax
C# Visual Basic Visual C++
public const string ManageCategories
Public Const ManageCategories As String
public:
literal String^ ManageCategories

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.PluginFramework (Module: ScrewTurn.Wiki.PluginFramework) Version: 3.0.2.500 (3.0.2.500)


ManageDiscussion Field

ManageDiscussion Field
ScrewTurn Wiki ► ScrewTurn.Wiki ► Actions..::.ForPages ► ManageDiscussion
Manage page discussion.
Declaration Syntax
C# Visual Basic Visual C++
public const string ManageDiscussion
Public Const ManageDiscussion As String
public:
literal String^ ManageDiscussion

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.PluginFramework (Module: ScrewTurn.Wiki.PluginFramework) Version: 3.0.2.500 (3.0.2.500)


ManagePage Field

ManagePage Field
ScrewTurn Wiki ► ScrewTurn.Wiki ► Actions..::.ForPages ► ManagePage
Manage the page.
Declaration Syntax
C# Visual Basic Visual C++
public const string ManagePage
Public Const ManagePage As String
public:
literal String^ ManagePage

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.PluginFramework (Module: ScrewTurn.Wiki.PluginFramework) Version: 3.0.2.500 (3.0.2.500)


ModifyPage Field

ModifyPage Field
ScrewTurn Wiki ► ScrewTurn.Wiki ► Actions..::.ForPages ► ModifyPage
Modify the page.
Declaration Syntax
C# Visual Basic Visual C++
public const string ModifyPage
Public Const ModifyPage As String
public:
literal String^ ModifyPage

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.PluginFramework (Module: ScrewTurn.Wiki.PluginFramework) Version: 3.0.2.500 (3.0.2.500)


NamespaceEscalators Field

NamespaceEscalators Field
ScrewTurn Wiki ► ScrewTurn.Wiki ► Actions..::.ForPages ► NamespaceEscalators
The namespace escalation policies.
Declaration Syntax
C# Visual Basic Visual C++
public static readonly Dictionary<string, string[]> NamespaceEscalators
Public Shared ReadOnly NamespaceEscalators As Dictionary(Of String, String())
public:
static initonly Dictionary<String^, array<String^>^>^ NamespaceEscalators

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.PluginFramework (Module: ScrewTurn.Wiki.PluginFramework) Version: 3.0.2.500 (3.0.2.500)


PostDiscussion Field

PostDiscussion Field
ScrewTurn Wiki ► ScrewTurn.Wiki ► Actions..::.ForPages ► PostDiscussion
Post messages in page discussion.
Declaration Syntax
C# Visual Basic Visual C++
public const string PostDiscussion
Public Const PostDiscussion As String
public:
literal String^ PostDiscussion

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.PluginFramework (Module: ScrewTurn.Wiki.PluginFramework) Version: 3.0.2.500 (3.0.2.500)


ReadDiscussion Field

ReadDiscussion Field
ScrewTurn Wiki ► ScrewTurn.Wiki ► Actions..::.ForPages ► ReadDiscussion
Read page discussion.
Declaration Syntax
C# Visual Basic Visual C++
public const string ReadDiscussion
Public Const ReadDiscussion As String
public:
literal String^ ReadDiscussion

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.PluginFramework (Module: ScrewTurn.Wiki.PluginFramework) Version: 3.0.2.500 (3.0.2.500)


ReadPage Field

ReadPage Field
ScrewTurn Wiki ► ScrewTurn.Wiki ► Actions..::.ForPages ► ReadPage
Read the page.
Declaration Syntax
C# Visual Basic Visual C++
public const string ReadPage
Public Const ReadPage As String
public:
literal String^ ReadPage

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.PluginFramework (Module: ScrewTurn.Wiki.PluginFramework) Version: 3.0.2.500 (3.0.2.500)


ResourceMasterPrefix Field

ResourceMasterPrefix Field
ScrewTurn Wiki ► ScrewTurn.Wiki ► Actions..::.ForPages ► ResourceMasterPrefix
The master prefix for pages ('P.').
Declaration Syntax
C# Visual Basic Visual C++
public const string ResourceMasterPrefix
Public Const ResourceMasterPrefix As String
public:
literal String^ ResourceMasterPrefix

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.PluginFramework (Module: ScrewTurn.Wiki.PluginFramework) Version: 3.0.2.500 (3.0.2.500)


UploadAttachments Field

UploadAttachments Field
ScrewTurn Wiki ► ScrewTurn.Wiki ► Actions..::.ForPages ► UploadAttachments
Upload attachments.
Declaration Syntax
C# Visual Basic Visual C++
public const string UploadAttachments
Public Const UploadAttachments As String
public:
literal String^ UploadAttachments

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.PluginFramework (Module: ScrewTurn.Wiki.PluginFramework) Version: 3.0.2.500 (3.0.2.500)


AuthChecker Class

AuthChecker Class
ScrewTurn Wiki ► ScrewTurn.Wiki ► AuthChecker
Utility class for checking permissions and authorizations.
Declaration Syntax
C# Visual Basic Visual C++
public static class AuthChecker
Public NotInheritable Class AuthChecker
public ref class AuthChecker abstract sealed
Members
All Members | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | CheckActionForDirectory(IFilesStorageProviderV30, String, String, String, array<String>[]()[]) | Checks whether an action is allowed for a directory.
 | CheckActionForGlobals(String, String, array<String>[]()[]) | Checks whether an action is allowed for the global resources.
 | CheckActionForNamespace(NamespaceInfo, String, String, array<String>[]()[]) | Checks whether an action is allowed for a namespace.
 | CheckActionForPage(PageInfo, String, String, array<String>[]()[]) | Checks whether an action is allowed for a page.
Remarks
All the methods in this class implement a security bypass for the admin user.
Inheritance Hierarchy
Object
AuthChecker

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


CheckActionForDirectory Method (provider, directory, action, currentUser, groups)

CheckActionForDirectory Method (provider, directory, action, currentUser, groups)
ScrewTurn Wiki ► ScrewTurn.Wiki ► AuthChecker ► CheckActionForDirectory(IFilesStorageProviderV30, String, String, String, array<String>[]()[])
Checks whether an action is allowed for a directory.
Declaration Syntax
C# Visual Basic Visual C++
public static bool CheckActionForDirectory(
    IFilesStorageProviderV30 provider,
    string directory,
    string action,
    string currentUser,
    string[] groups
)
Public Shared Function CheckActionForDirectory ( _
    provider As IFilesStorageProviderV30, _
    directory As String, _
    action As String, _
    currentUser As String, _
    groups As String() _
) As Boolean
public:
static bool CheckActionForDirectory(
    IFilesStorageProviderV30^ provider,
    String^ directory,
    String^ action,
    String^ currentUser,
    array<String^>^ groups
)
Parameters
provider (IFilesStorageProviderV30)
The provider that manages the directory.
directory (String)
The full path of the directory.
action (String)
The action the user is attempting to perform.
currentUser (String)
The current user.
groups (array< String >[]()[][])
The groups the user is member of.
Return Value
true if the action is allowed, false otherwise.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


CheckActionForGlobals Method (action, currentUser, groups)

CheckActionForGlobals Method (action, currentUser, groups)
ScrewTurn Wiki ► ScrewTurn.Wiki ► AuthChecker ► CheckActionForGlobals(String, String, array<String>[]()[])
Checks whether an action is allowed for the global resources.
Declaration Syntax
C# Visual Basic Visual C++
public static bool CheckActionForGlobals(
    string action,
    string currentUser,
    string[] groups
)
Public Shared Function CheckActionForGlobals ( _
    action As String, _
    currentUser As String, _
    groups As String() _
) As Boolean
public:
static bool CheckActionForGlobals(
    String^ action,
    String^ currentUser,
    array<String^>^ groups
)
Parameters
action (String)
The action the user is attempting to perform.
currentUser (String)
The current user.
groups (array< String >[]()[][])
The groups the user is member of.
Return Value
true if the action is allowed.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


CheckActionForNamespace Method (nspace, action, currentUser, groups)

CheckActionForNamespace Method (nspace, action, currentUser, groups)
ScrewTurn Wiki ► ScrewTurn.Wiki ► AuthChecker ► CheckActionForNamespace(NamespaceInfo, String, String, array<String>[]()[])
Checks whether an action is allowed for a namespace.
Declaration Syntax
C# Visual Basic Visual C++
public static bool CheckActionForNamespace(
    NamespaceInfo nspace,
    string action,
    string currentUser,
    string[] groups
)
Public Shared Function CheckActionForNamespace ( _
    nspace As NamespaceInfo, _
    action As String, _
    currentUser As String, _
    groups As String() _
) As Boolean
public:
static bool CheckActionForNamespace(
    NamespaceInfo^ nspace,
    String^ action,
    String^ currentUser,
    array<String^>^ groups
)
Parameters
nspace (NamespaceInfo)
The current namespace (null for the root).
action (String)
The action the user is attempting to perform.
currentUser (String)
The current user.
groups (array< String >[]()[][])
The groups the user is member of.
Return Value
true if the action is allowed, false otherwise.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


CheckActionForPage Method (page, action, currentUser, groups)

CheckActionForPage Method (page, action, currentUser, groups)
ScrewTurn Wiki ► ScrewTurn.Wiki ► AuthChecker ► CheckActionForPage(PageInfo, String, String, array<String>[]()[])
Checks whether an action is allowed for a page.
Declaration Syntax
C# Visual Basic Visual C++
public static bool CheckActionForPage(
    PageInfo page,
    string action,
    string currentUser,
    string[] groups
)
Public Shared Function CheckActionForPage ( _
    page As PageInfo, _
    action As String, _
    currentUser As String, _
    groups As String() _
) As Boolean
public:
static bool CheckActionForPage(
    PageInfo^ page,
    String^ action,
    String^ currentUser,
    array<String^>^ groups
)
Parameters
page (PageInfo)
The current page.
action (String)
The action the user is attempting to perform.
currentUser (String)
The current user.
groups (array< String >[]()[][])
The groups the user is member of.
Return Value
true if the action is allowed, false otherwise.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


AuthReader Class

AuthReader Class
ScrewTurn Wiki ► ScrewTurn.Wiki ► AuthReader
Utility class for reading permissions and authorizations.
Declaration Syntax
C# Visual Basic Visual C++
public static class AuthReader
Public NotInheritable Class AuthReader
public ref class AuthReader abstract sealed
Members
All Members | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | RetrieveDenialsForDirectory(UserGroup, IFilesStorageProviderV30, String) | Gets all the actions for a directory that are denied to a group.
 | RetrieveDenialsForDirectory(UserInfo, IFilesStorageProviderV30, String) | Gets all the actions for a directory that are denied to a user.
 | RetrieveDenialsForGlobals(UserGroup) | Gets all the actions for global resources that are denied to a group.
 | RetrieveDenialsForGlobals(UserInfo) | Gets all the actions for global resources that are denied to a user.
 | RetrieveDenialsForNamespace(UserGroup, NamespaceInfo) | Gets all the actions for a namespace that are denied to a group.
 | RetrieveDenialsForNamespace(UserInfo, NamespaceInfo) | Gets all the actions for a namespace that are denied to a user.
 | RetrieveDenialsForPage(UserGroup, PageInfo) | Gets all the actions for a page that are denied to a group.
 | RetrieveDenialsForPage(UserInfo, PageInfo) | Gets all the actions for a page that are denied to a user.
 | RetrieveGrantsForDirectory(UserGroup, IFilesStorageProviderV30, String) | Gets all the actions for a directory that are granted to a group.
 | RetrieveGrantsForDirectory(UserInfo, IFilesStorageProviderV30, String) | Gets all the actions for a directory that are granted to a user.
 | RetrieveGrantsForGlobals(UserGroup) | Gets all the actions for global resources that are granted to a group.
 | RetrieveGrantsForGlobals(UserInfo) | Gets all the actions for global resources that are granted to a user.
 | RetrieveGrantsForNamespace(UserGroup, NamespaceInfo) | Gets all the actions for a namespace that are granted to a group.
 | RetrieveGrantsForNamespace(UserInfo, NamespaceInfo) | Gets all the actions for a namespace that are granted to a user.
 | RetrieveGrantsForPage(UserGroup, PageInfo) | Gets all the actions for a page that are granted to a group.
 | RetrieveGrantsForPage(UserInfo, PageInfo) | Gets all the actions for a page that are granted to a user.
 | RetrieveSubjectsForDirectory(IFilesStorageProviderV30, String) | Retrieves the subjects that have ACL entries set for a directory.
 | RetrieveSubjectsForNamespace(NamespaceInfo) | Retrieves the subjects that have ACL entries set for a namespace.
 | RetrieveSubjectsForPage(PageInfo) | Retrieves the subjects that have ACL entries set for a page.
Inheritance Hierarchy
Object
AuthReader

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


RetrieveDenialsForDirectory Method

RetrieveDenialsForDirectory Method
ScrewTurn Wiki ► ScrewTurn.Wiki ► AuthReader ► RetrieveDenialsForDirectory()()()
Members
Icon | Member | Description
 | RetrieveDenialsForDirectory(UserGroup, IFilesStorageProviderV30, String) | Gets all the actions for a directory that are denied to a group.
 | RetrieveDenialsForDirectory(UserInfo, IFilesStorageProviderV30, String) | Gets all the actions for a directory that are denied to a user.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


RetrieveDenialsForDirectory Method (group, provider, directory)

RetrieveDenialsForDirectory Method (group, provider, directory)
ScrewTurn Wiki ► ScrewTurn.Wiki ► AuthReader ► RetrieveDenialsForDirectory(UserGroup, IFilesStorageProviderV30, String)
Gets all the actions for a directory that are denied to a group.
Declaration Syntax
C# Visual Basic Visual C++
public static string[] RetrieveDenialsForDirectory(
    UserGroup group,
    IFilesStorageProviderV30 provider,
    string directory
)
Public Shared Function RetrieveDenialsForDirectory ( _
    group As UserGroup, _
    provider As IFilesStorageProviderV30, _
    directory As String _
) As String()
public:
static array<String^>^ RetrieveDenialsForDirectory(
    UserGroup^ group,
    IFilesStorageProviderV30^ provider,
    String^ directory
)
Parameters
group (UserGroup)
The user group.
provider (IFilesStorageProviderV30)
The provider.
directory (String)
The directory.
Return Value
The denied actions.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


RetrieveDenialsForDirectory Method (user, provider, directory)

RetrieveDenialsForDirectory Method (user, provider, directory)
ScrewTurn Wiki ► ScrewTurn.Wiki ► AuthReader ► RetrieveDenialsForDirectory(UserInfo, IFilesStorageProviderV30, String)
Gets all the actions for a directory that are denied to a user.
Declaration Syntax
C# Visual Basic Visual C++
public static string[] RetrieveDenialsForDirectory(
    UserInfo user,
    IFilesStorageProviderV30 provider,
    string directory
)
Public Shared Function RetrieveDenialsForDirectory ( _
    user As UserInfo, _
    provider As IFilesStorageProviderV30, _
    directory As String _
) As String()
public:
static array<String^>^ RetrieveDenialsForDirectory(
    UserInfo^ user,
    IFilesStorageProviderV30^ provider,
    String^ directory
)
Parameters
user (UserInfo)
The user.
provider (IFilesStorageProviderV30)
The provider.
directory (String)
The directory.
Return Value
The denied actions.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


RetrieveDenialsForGlobals Method

RetrieveDenialsForGlobals Method
ScrewTurn Wiki ► ScrewTurn.Wiki ► AuthReader ► RetrieveDenialsForGlobals()()()
Members
Icon | Member | Description
 | RetrieveDenialsForGlobals(UserGroup) | Gets all the actions for global resources that are denied to a group.
 | RetrieveDenialsForGlobals(UserInfo) | Gets all the actions for global resources that are denied to a user.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


RetrieveDenialsForGlobals Method (group)

RetrieveDenialsForGlobals Method (group)
ScrewTurn Wiki ► ScrewTurn.Wiki ► AuthReader ► RetrieveDenialsForGlobals(UserGroup)
Gets all the actions for global resources that are denied to a group.
Declaration Syntax
C# Visual Basic Visual C++
public static string[] RetrieveDenialsForGlobals(
    UserGroup group
)
Public Shared Function RetrieveDenialsForGlobals ( _
    group As UserGroup _
) As String()
public:
static array<String^>^ RetrieveDenialsForGlobals(
    UserGroup^ group
)
Parameters
group (UserGroup)
The user group.
Return Value
The denied actions.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


RetrieveDenialsForGlobals Method (user)

RetrieveDenialsForGlobals Method (user)
ScrewTurn Wiki ► ScrewTurn.Wiki ► AuthReader ► RetrieveDenialsForGlobals(UserInfo)
Gets all the actions for global resources that are denied to a user.
Declaration Syntax
C# Visual Basic Visual C++
public static string[] RetrieveDenialsForGlobals(
    UserInfo user
)
Public Shared Function RetrieveDenialsForGlobals ( _
    user As UserInfo _
) As String()
public:
static array<String^>^ RetrieveDenialsForGlobals(
    UserInfo^ user
)
Parameters
user (UserInfo)
The user.
Return Value
The denied actions.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


RetrieveDenialsForNamespace Method

RetrieveDenialsForNamespace Method
ScrewTurn Wiki ► ScrewTurn.Wiki ► AuthReader ► RetrieveDenialsForNamespace()()()
Members
Icon | Member | Description
 | RetrieveDenialsForNamespace(UserGroup, NamespaceInfo) | Gets all the actions for a namespace that are denied to a group.
 | RetrieveDenialsForNamespace(UserInfo, NamespaceInfo) | Gets all the actions for a namespace that are denied to a user.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


RetrieveDenialsForNamespace Method (group, nspace)

RetrieveDenialsForNamespace Method (group, nspace)
ScrewTurn Wiki ► ScrewTurn.Wiki ► AuthReader ► RetrieveDenialsForNamespace(UserGroup, NamespaceInfo)
Gets all the actions for a namespace that are denied to a group.
Declaration Syntax
C# Visual Basic Visual C++
public static string[] RetrieveDenialsForNamespace(
    UserGroup group,
    NamespaceInfo nspace
)
Public Shared Function RetrieveDenialsForNamespace ( _
    group As UserGroup, _
    nspace As NamespaceInfo _
) As String()
public:
static array<String^>^ RetrieveDenialsForNamespace(
    UserGroup^ group,
    NamespaceInfo^ nspace
)
Parameters
group (UserGroup)
The user group.
nspace (NamespaceInfo)
The namespace (null for the root).
Return Value
The denied actions.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


RetrieveDenialsForNamespace Method (user, nspace)

RetrieveDenialsForNamespace Method (user, nspace)
ScrewTurn Wiki ► ScrewTurn.Wiki ► AuthReader ► RetrieveDenialsForNamespace(UserInfo, NamespaceInfo)
Gets all the actions for a namespace that are denied to a user.
Declaration Syntax
C# Visual Basic Visual C++
public static string[] RetrieveDenialsForNamespace(
    UserInfo user,
    NamespaceInfo nspace
)
Public Shared Function RetrieveDenialsForNamespace ( _
    user As UserInfo, _
    nspace As NamespaceInfo _
) As String()
public:
static array<String^>^ RetrieveDenialsForNamespace(
    UserInfo^ user,
    NamespaceInfo^ nspace
)
Parameters
user (UserInfo)
The user.
nspace (NamespaceInfo)
The namespace (null for the root).
Return Value
The denied actions.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


RetrieveDenialsForPage Method

RetrieveDenialsForPage Method
ScrewTurn Wiki ► ScrewTurn.Wiki ► AuthReader ► RetrieveDenialsForPage()()()
Members
Icon | Member | Description
 | RetrieveDenialsForPage(UserGroup, PageInfo) | Gets all the actions for a page that are denied to a group.
 | RetrieveDenialsForPage(UserInfo, PageInfo) | Gets all the actions for a page that are denied to a user.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


RetrieveDenialsForPage Method (group, page)

RetrieveDenialsForPage Method (group, page)
ScrewTurn Wiki ► ScrewTurn.Wiki ► AuthReader ► RetrieveDenialsForPage(UserGroup, PageInfo)
Gets all the actions for a page that are denied to a group.
Declaration Syntax
C# Visual Basic Visual C++
public static string[] RetrieveDenialsForPage(
    UserGroup group,
    PageInfo page
)
Public Shared Function RetrieveDenialsForPage ( _
    group As UserGroup, _
    page As PageInfo _
) As String()
public:
static array<String^>^ RetrieveDenialsForPage(
    UserGroup^ group,
    PageInfo^ page
)
Parameters
group (UserGroup)
The user group.
page (PageInfo)
The page.
Return Value
The granted actions.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


RetrieveDenialsForPage Method (user, page)

RetrieveDenialsForPage Method (user, page)
ScrewTurn Wiki ► ScrewTurn.Wiki ► AuthReader ► RetrieveDenialsForPage(UserInfo, PageInfo)
Gets all the actions for a page that are denied to a user.
Declaration Syntax
C# Visual Basic Visual C++
public static string[] RetrieveDenialsForPage(
    UserInfo user,
    PageInfo page
)
Public Shared Function RetrieveDenialsForPage ( _
    user As UserInfo, _
    page As PageInfo _
) As String()
public:
static array<String^>^ RetrieveDenialsForPage(
    UserInfo^ user,
    PageInfo^ page
)
Parameters
user (UserInfo)
The user.
page (PageInfo)
The page.
Return Value
The granted actions.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


RetrieveGrantsForDirectory Method

RetrieveGrantsForDirectory Method
ScrewTurn Wiki ► ScrewTurn.Wiki ► AuthReader ► RetrieveGrantsForDirectory()()()
Members
Icon | Member | Description
 | RetrieveGrantsForDirectory(UserGroup, IFilesStorageProviderV30, String) | Gets all the actions for a directory that are granted to a group.
 | RetrieveGrantsForDirectory(UserInfo, IFilesStorageProviderV30, String) | Gets all the actions for a directory that are granted to a user.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


RetrieveGrantsForDirectory Method (group, provider, directory)

RetrieveGrantsForDirectory Method (group, provider, directory)
ScrewTurn Wiki ► ScrewTurn.Wiki ► AuthReader ► RetrieveGrantsForDirectory(UserGroup, IFilesStorageProviderV30, String)
Gets all the actions for a directory that are granted to a group.
Declaration Syntax
C# Visual Basic Visual C++
public static string[] RetrieveGrantsForDirectory(
    UserGroup group,
    IFilesStorageProviderV30 provider,
    string directory
)
Public Shared Function RetrieveGrantsForDirectory ( _
    group As UserGroup, _
    provider As IFilesStorageProviderV30, _
    directory As String _
) As String()
public:
static array<String^>^ RetrieveGrantsForDirectory(
    UserGroup^ group,
    IFilesStorageProviderV30^ provider,
    String^ directory
)
Parameters
group (UserGroup)
The user group.
provider (IFilesStorageProviderV30)
The provider.
directory (String)
The directory.
Return Value
The granted actions.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


RetrieveGrantsForDirectory Method (user, provider, directory)

RetrieveGrantsForDirectory Method (user, provider, directory)
ScrewTurn Wiki ► ScrewTurn.Wiki ► AuthReader ► RetrieveGrantsForDirectory(UserInfo, IFilesStorageProviderV30, String)
Gets all the actions for a directory that are granted to a user.
Declaration Syntax
C# Visual Basic Visual C++
public static string[] RetrieveGrantsForDirectory(
    UserInfo user,
    IFilesStorageProviderV30 provider,
    string directory
)
Public Shared Function RetrieveGrantsForDirectory ( _
    user As UserInfo, _
    provider As IFilesStorageProviderV30, _
    directory As String _
) As String()
public:
static array<String^>^ RetrieveGrantsForDirectory(
    UserInfo^ user,
    IFilesStorageProviderV30^ provider,
    String^ directory
)
Parameters
user (UserInfo)
The user.
provider (IFilesStorageProviderV30)
The provider.
directory (String)
The directory.
Return Value
The granted actions.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


RetrieveGrantsForGlobals Method

RetrieveGrantsForGlobals Method
ScrewTurn Wiki ► ScrewTurn.Wiki ► AuthReader ► RetrieveGrantsForGlobals()()()
Members
Icon | Member | Description
 | RetrieveGrantsForGlobals(UserGroup) | Gets all the actions for global resources that are granted to a group.
 | RetrieveGrantsForGlobals(UserInfo) | Gets all the actions for global resources that are granted to a user.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


RetrieveGrantsForGlobals Method (group)

RetrieveGrantsForGlobals Method (group)
ScrewTurn Wiki ► ScrewTurn.Wiki ► AuthReader ► RetrieveGrantsForGlobals(UserGroup)
Gets all the actions for global resources that are granted to a group.
Declaration Syntax
C# Visual Basic Visual C++
public static string[] RetrieveGrantsForGlobals(
    UserGroup group
)
Public Shared Function RetrieveGrantsForGlobals ( _
    group As UserGroup _
) As String()
public:
static array<String^>^ RetrieveGrantsForGlobals(
    UserGroup^ group
)
Parameters
group (UserGroup)
The user group.
Return Value
The granted actions.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


RetrieveGrantsForGlobals Method (user)

RetrieveGrantsForGlobals Method (user)
ScrewTurn Wiki ► ScrewTurn.Wiki ► AuthReader ► RetrieveGrantsForGlobals(UserInfo)
Gets all the actions for global resources that are granted to a user.
Declaration Syntax
C# Visual Basic Visual C++
public static string[] RetrieveGrantsForGlobals(
    UserInfo user
)
Public Shared Function RetrieveGrantsForGlobals ( _
    user As UserInfo _
) As String()
public:
static array<String^>^ RetrieveGrantsForGlobals(
    UserInfo^ user
)
Parameters
user (UserInfo)
The user.
Return Value
The granted actions.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


RetrieveGrantsForNamespace Method

RetrieveGrantsForNamespace Method
ScrewTurn Wiki ► ScrewTurn.Wiki ► AuthReader ► RetrieveGrantsForNamespace()()()
Members
Icon | Member | Description
 | RetrieveGrantsForNamespace(UserGroup, NamespaceInfo) | Gets all the actions for a namespace that are granted to a group.
 | RetrieveGrantsForNamespace(UserInfo, NamespaceInfo) | Gets all the actions for a namespace that are granted to a user.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


RetrieveGrantsForNamespace Method (group, nspace)

RetrieveGrantsForNamespace Method (group, nspace)
ScrewTurn Wiki ► ScrewTurn.Wiki ► AuthReader ► RetrieveGrantsForNamespace(UserGroup, NamespaceInfo)
Gets all the actions for a namespace that are granted to a group.
Declaration Syntax
C# Visual Basic Visual C++
public static string[] RetrieveGrantsForNamespace(
    UserGroup group,
    NamespaceInfo nspace
)
Public Shared Function RetrieveGrantsForNamespace ( _
    group As UserGroup, _
    nspace As NamespaceInfo _
) As String()
public:
static array<String^>^ RetrieveGrantsForNamespace(
    UserGroup^ group,
    NamespaceInfo^ nspace
)
Parameters
group (UserGroup)
The user group.
nspace (NamespaceInfo)
The namespace (null for the root).
Return Value
The granted actions.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


RetrieveGrantsForNamespace Method (user, nspace)

RetrieveGrantsForNamespace Method (user, nspace)
ScrewTurn Wiki ► ScrewTurn.Wiki ► AuthReader ► RetrieveGrantsForNamespace(UserInfo, NamespaceInfo)
Gets all the actions for a namespace that are granted to a user.
Declaration Syntax
C# Visual Basic Visual C++
public static string[] RetrieveGrantsForNamespace(
    UserInfo user,
    NamespaceInfo nspace
)
Public Shared Function RetrieveGrantsForNamespace ( _
    user As UserInfo, _
    nspace As NamespaceInfo _
) As String()
public:
static array<String^>^ RetrieveGrantsForNamespace(
    UserInfo^ user,
    NamespaceInfo^ nspace
)
Parameters
user (UserInfo)
The user.
nspace (NamespaceInfo)
The namespace (null for the root).
Return Value
The granted actions.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


RetrieveGrantsForPage Method

RetrieveGrantsForPage Method
ScrewTurn Wiki ► ScrewTurn.Wiki ► AuthReader ► RetrieveGrantsForPage()()()
Members
Icon | Member | Description
 | RetrieveGrantsForPage(UserGroup, PageInfo) | Gets all the actions for a page that are granted to a group.
 | RetrieveGrantsForPage(UserInfo, PageInfo) | Gets all the actions for a page that are granted to a user.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


RetrieveGrantsForPage Method (group, page)

RetrieveGrantsForPage Method (group, page)
ScrewTurn Wiki ► ScrewTurn.Wiki ► AuthReader ► RetrieveGrantsForPage(UserGroup, PageInfo)
Gets all the actions for a page that are granted to a group.
Declaration Syntax
C# Visual Basic Visual C++
public static string[] RetrieveGrantsForPage(
    UserGroup group,
    PageInfo page
)
Public Shared Function RetrieveGrantsForPage ( _
    group As UserGroup, _
    page As PageInfo _
) As String()
public:
static array<String^>^ RetrieveGrantsForPage(
    UserGroup^ group,
    PageInfo^ page
)
Parameters
group (UserGroup)
The user group.
page (PageInfo)
The page.
Return Value
The granted actions.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


RetrieveGrantsForPage Method (user, page)

RetrieveGrantsForPage Method (user, page)
ScrewTurn Wiki ► ScrewTurn.Wiki ► AuthReader ► RetrieveGrantsForPage(UserInfo, PageInfo)
Gets all the actions for a page that are granted to a user.
Declaration Syntax
C# Visual Basic Visual C++
public static string[] RetrieveGrantsForPage(
    UserInfo user,
    PageInfo page
)
Public Shared Function RetrieveGrantsForPage ( _
    user As UserInfo, _
    page As PageInfo _
) As String()
public:
static array<String^>^ RetrieveGrantsForPage(
    UserInfo^ user,
    PageInfo^ page
)
Parameters
user (UserInfo)
The user.
page (PageInfo)
The page.
Return Value
The granted actions.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


RetrieveSubjectsForDirectory Method (provider, directory)

RetrieveSubjectsForDirectory Method (provider, directory)
ScrewTurn Wiki ► ScrewTurn.Wiki ► AuthReader ► RetrieveSubjectsForDirectory(IFilesStorageProviderV30, String)
Retrieves the subjects that have ACL entries set for a directory.
Declaration Syntax
C# Visual Basic Visual C++
public static SubjectInfo[] RetrieveSubjectsForDirectory(
    IFilesStorageProviderV30 provider,
    string directory
)
Public Shared Function RetrieveSubjectsForDirectory ( _
    provider As IFilesStorageProviderV30, _
    directory As String _
) As SubjectInfo()
public:
static array<SubjectInfo^>^ RetrieveSubjectsForDirectory(
    IFilesStorageProviderV30^ provider,
    String^ directory
)
Parameters
provider (IFilesStorageProviderV30)
The provider.
directory (String)
The directory.
Return Value
The subjects.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


RetrieveSubjectsForNamespace Method (nspace)

RetrieveSubjectsForNamespace Method (nspace)
ScrewTurn Wiki ► ScrewTurn.Wiki ► AuthReader ► RetrieveSubjectsForNamespace(NamespaceInfo)
Retrieves the subjects that have ACL entries set for a namespace.
Declaration Syntax
C# Visual Basic Visual C++
public static SubjectInfo[] RetrieveSubjectsForNamespace(
    NamespaceInfo nspace
)
Public Shared Function RetrieveSubjectsForNamespace ( _
    nspace As NamespaceInfo _
) As SubjectInfo()
public:
static array<SubjectInfo^>^ RetrieveSubjectsForNamespace(
    NamespaceInfo^ nspace
)
Parameters
nspace (NamespaceInfo)
The namespace (null for the root).
Return Value
The subjects.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


RetrieveSubjectsForPage Method (page)

RetrieveSubjectsForPage Method (page)
ScrewTurn Wiki ► ScrewTurn.Wiki ► AuthReader ► RetrieveSubjectsForPage(PageInfo)
Retrieves the subjects that have ACL entries set for a page.
Declaration Syntax
C# Visual Basic Visual C++
public static SubjectInfo[] RetrieveSubjectsForPage(
    PageInfo page
)
Public Shared Function RetrieveSubjectsForPage ( _
    page As PageInfo _
) As SubjectInfo()
public:
static array<SubjectInfo^>^ RetrieveSubjectsForPage(
    PageInfo^ page
)
Parameters
page (PageInfo)
The page.
Return Value
The subjects.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


AuthStatus Enumeration

AuthStatus Enumeration
ScrewTurn Wiki ► ScrewTurn.Wiki ► AuthStatus
Lists legal values for authorizations.
Declaration Syntax
C# Visual Basic Visual C++
public enum AuthStatus
Public Enumeration AuthStatus
public enum class AuthStatus
Members
Member | Description
Grant | Grant the action.
Deny | Deny the action.
Delete | Delete the permission entry.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


AuthTools Class

AuthTools Class
ScrewTurn Wiki ► ScrewTurn.Wiki ► AuthTools
Implements tools supporting athorization management.
Declaration Syntax
C# Visual Basic Visual C++
public static class AuthTools
Public NotInheritable Class AuthTools
public ref class AuthTools abstract sealed
Members
All Members | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | GetDirectoryName(IFilesStorageProviderV30, String) | Gets the proper full name for a directory.
 | IsGroup(String) | Determines whether a subject is a group.
 | IsValidAction(String, array<String>[]()[]) | Determines whether an action is valid.
 | PrepareGroup(String) | Prepends the proper string to the group name.
 | PrepareGroups(array<String>[]()[]) | Prepends the proper string to each group name in an array.
 | PrepareUsername(String) | Prepends the proper string to a username.
Inheritance Hierarchy
Object
AuthTools

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


GetDirectoryName Method (prov, name)

GetDirectoryName Method (prov, name)
ScrewTurn Wiki ► ScrewTurn.Wiki ► AuthTools ► GetDirectoryName(IFilesStorageProviderV30, String)
Gets the proper full name for a directory.
Declaration Syntax
C# Visual Basic Visual C++
public static string GetDirectoryName(
    IFilesStorageProviderV30 prov,
    string name
)
Public Shared Function GetDirectoryName ( _
    prov As IFilesStorageProviderV30, _
    name As String _
) As String
public:
static String^ GetDirectoryName(
    IFilesStorageProviderV30^ prov,
    String^ name
)
Parameters
prov (IFilesStorageProviderV30)
The provider.
name (String)
The directory name.
Return Value
The full name (not prepended with ResourceMasterPrefix.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


IsGroup Method (subject)

IsGroup Method (subject)
ScrewTurn Wiki ► ScrewTurn.Wiki ► AuthTools ► IsGroup(String)
Determines whether a subject is a group.
Declaration Syntax
C# Visual Basic Visual C++
public static bool IsGroup(
    string subject
)
Public Shared Function IsGroup ( _
    subject As String _
) As Boolean
public:
static bool IsGroup(
    String^ subject
)
Parameters
subject (String)
The subject to test.
Return Value
true if the subject is a group, false if it is a user.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


IsValidAction Method (action, validActions)

IsValidAction Method (action, validActions)
ScrewTurn Wiki ► ScrewTurn.Wiki ► AuthTools ► IsValidAction(String, array<String>[]()[])
Determines whether an action is valid.
Declaration Syntax
C# Visual Basic Visual C++
public static bool IsValidAction(
    string action,
    string[] validActions
)
Public Shared Function IsValidAction ( _
    action As String, _
    validActions As String() _
) As Boolean
public:
static bool IsValidAction(
    String^ action,
    array<String^>^ validActions
)
Parameters
action (String)
The action to validate.
validActions (array< String >[]()[][])
The list of valid actions.
Return Value
true if the action is valid, false otherwise.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


PrepareGroup Method (group)

PrepareGroup Method (group)
ScrewTurn Wiki ► ScrewTurn.Wiki ► AuthTools ► PrepareGroup(String)
Prepends the proper string to the group name.
Declaration Syntax
C# Visual Basic Visual C++
public static string PrepareGroup(
    string group
)
Public Shared Function PrepareGroup ( _
    group As String _
) As String
public:
static String^ PrepareGroup(
    String^ group
)
Parameters
group (String)
The group name.
Return Value
The result string.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


PrepareGroups Method (groups)

PrepareGroups Method (groups)
ScrewTurn Wiki ► ScrewTurn.Wiki ► AuthTools ► PrepareGroups(array<String>[]()[])
Prepends the proper string to each group name in an array.
Declaration Syntax
C# Visual Basic Visual C++
public static string[] PrepareGroups(
    string[] groups
)
Public Shared Function PrepareGroups ( _
    groups As String() _
) As String()
public:
static array<String^>^ PrepareGroups(
    array<String^>^ groups
)
Parameters
groups (array< String >[]()[][])
The group array.
Return Value
The resulting group array.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


PrepareUsername Method (username)

PrepareUsername Method (username)
ScrewTurn Wiki ► ScrewTurn.Wiki ► AuthTools ► PrepareUsername(String)
Prepends the proper string to a username.
Declaration Syntax
C# Visual Basic Visual C++
public static string PrepareUsername(
    string username
)
Public Shared Function PrepareUsername ( _
    username As String _
) As String
public:
static String^ PrepareUsername(
    String^ username
)
Parameters
username (String)
The username.
Return Value
The resulting username.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


AuthWriter Class

AuthWriter Class
ScrewTurn Wiki ► ScrewTurn.Wiki ► AuthWriter
Utility class for writing permissions and authorizations.
Declaration Syntax
C# Visual Basic Visual C++
public static class AuthWriter
Public NotInheritable Class AuthWriter
public ref class AuthWriter abstract sealed
Members
All Members | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | ClearEntriesForDirectory(IFilesStorageProviderV30, String) | Clears all the ACL entries for a directory.
 | ClearEntriesForNamespace(String, List<(Of <(String>)>)) | Clears all the ACL entries for a namespace.
 | ClearEntriesForPage(String) | Clears all the ACL entries for a page.
 | ProcessDirectoryRenaming(IFilesStorageProviderV30, String, String) | Processes the renaming of a directory.
 | ProcessNamespaceRenaming(String, List<(Of <(String>)>), String) | Processes the renaming of a namespace.
 | ProcessPageRenaming(String, String) | Processes the renaming of a page.
 | RemoveEntriesForDirectory(UserGroup, IFilesStorageProviderV30, String) | Removes all the ACL Entries for a directory that are bound to a user group.
 | RemoveEntriesForDirectory(UserInfo, IFilesStorageProviderV30, String) | Removes all the ACL Entries for a directory that are bound to a user.
 | RemoveEntriesForGlobals(UserGroup) | Removes all the ACL Entries for global resources that are bound to a user group.
 | RemoveEntriesForGlobals(UserInfo) | Removes all the ACL Entries for global resources that are bound to a user.
 | RemoveEntriesForNamespace(UserGroup, NamespaceInfo) | Removes all the ACL Entries for a namespace that are bound to a user group.
 | RemoveEntriesForNamespace(UserInfo, NamespaceInfo) | Removes all the ACL Entries for a namespace that are bound to a user.
 | RemoveEntriesForPage(UserGroup, PageInfo) | Removes all the ACL Entries for a page that are bound to a user group.
 | RemoveEntriesForPage(UserInfo, PageInfo) | Removes all the ACL Entries for a page that are bound to a user.
 | SetPermissionForDirectory(AuthStatus, IFilesStorageProviderV30, String, String, UserGroup) | Sets a permission for a directory.
 | SetPermissionForDirectory(AuthStatus, IFilesStorageProviderV30, String, String, UserInfo) | Sets a permission for a directory.
 | SetPermissionForGlobals(AuthStatus, String, UserGroup) | Sets a permission for a global resource.
 | SetPermissionForGlobals(AuthStatus, String, UserInfo) | Sets a permission for a global resource.
 | SetPermissionForNamespace(AuthStatus, NamespaceInfo, String, UserGroup) | Sets a permission for a namespace.
 | SetPermissionForNamespace(AuthStatus, NamespaceInfo, String, UserInfo) | Sets a permission for a namespace.
 | SetPermissionForPage(AuthStatus, PageInfo, String, UserGroup) | Sets a permission for a page.
 | SetPermissionForPage(AuthStatus, PageInfo, String, UserInfo) | Sets a permission for a page.
Inheritance Hierarchy
Object
AuthWriter

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


ClearEntriesForDirectory Method (provider, directory)

ClearEntriesForDirectory Method (provider, directory)
ScrewTurn Wiki ► ScrewTurn.Wiki ► AuthWriter ► ClearEntriesForDirectory(IFilesStorageProviderV30, String)
Clears all the ACL entries for a directory.
Declaration Syntax
C# Visual Basic Visual C++
public static void ClearEntriesForDirectory(
    IFilesStorageProviderV30 provider,
    string directory
)
Public Shared Sub ClearEntriesForDirectory ( _
    provider As IFilesStorageProviderV30, _
    directory As String _
)
public:
static void ClearEntriesForDirectory(
    IFilesStorageProviderV30^ provider,
    String^ directory
)
Parameters
provider (IFilesStorageProviderV30)
The provider.
directory (String)
The directory.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


ClearEntriesForNamespace Method (nspace, pages)

ClearEntriesForNamespace Method (nspace, pages)
ScrewTurn Wiki ► ScrewTurn.Wiki ► AuthWriter ► ClearEntriesForNamespace(String, List<(Of <(String>)>))
Clears all the ACL entries for a namespace.
Declaration Syntax
C# Visual Basic Visual C++
public static void ClearEntriesForNamespace(
    string nspace,
    List<string> pages
)
Public Shared Sub ClearEntriesForNamespace ( _
    nspace As String, _
    pages As List(Of String) _
)
public:
static void ClearEntriesForNamespace(
    String^ nspace,
    List<String^>^ pages
)
Parameters
nspace (String)
The namespace.
pages (List <(Of <(<' String >)>)>)
The local names of the pages in the namespace.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


ClearEntriesForPage Method (page)

ClearEntriesForPage Method (page)
ScrewTurn Wiki ► ScrewTurn.Wiki ► AuthWriter ► ClearEntriesForPage(String)
Clears all the ACL entries for a page.
Declaration Syntax
C# Visual Basic Visual C++
public static void ClearEntriesForPage(
    string page
)
Public Shared Sub ClearEntriesForPage ( _
    page As String _
)
public:
static void ClearEntriesForPage(
    String^ page
)
Parameters
page (String)
The page full name.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


ProcessDirectoryRenaming Method (provider, oldName, newName)

ProcessDirectoryRenaming Method (provider, oldName, newName)
ScrewTurn Wiki ► ScrewTurn.Wiki ► AuthWriter ► ProcessDirectoryRenaming(IFilesStorageProviderV30, String, String)
Processes the renaming of a directory.
Declaration Syntax
C# Visual Basic Visual C++
public static bool ProcessDirectoryRenaming(
    IFilesStorageProviderV30 provider,
    string oldName,
    string newName
)
Public Shared Function ProcessDirectoryRenaming ( _
    provider As IFilesStorageProviderV30, _
    oldName As String, _
    newName As String _
) As Boolean
public:
static bool ProcessDirectoryRenaming(
    IFilesStorageProviderV30^ provider,
    String^ oldName,
    String^ newName
)
Parameters
provider (IFilesStorageProviderV30)
The provider.
oldName (String)
The old directory name (full path).
newName (String)
The new directory name (full path).
Return Value
true if the operation completed successfully, false otherwise.
Remarks
The method does not recurse in sub-directories.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


ProcessNamespaceRenaming Method (oldName, oldPages, newName)

ProcessNamespaceRenaming Method (oldName, oldPages, newName)
ScrewTurn Wiki ► ScrewTurn.Wiki ► AuthWriter ► ProcessNamespaceRenaming(String, List<(Of <(String>)>), String)
Processes the renaming of a namespace.
Declaration Syntax
C# Visual Basic Visual C++
public static bool ProcessNamespaceRenaming(
    string oldName,
    List<string> oldPages,
    string newName
)
Public Shared Function ProcessNamespaceRenaming ( _
    oldName As String, _
    oldPages As List(Of String), _
    newName As String _
) As Boolean
public:
static bool ProcessNamespaceRenaming(
    String^ oldName,
    List<String^>^ oldPages,
    String^ newName
)
Parameters
oldName (String)
The old name of the namespace.
oldPages (List <(Of <(<' String >)>)>)
The list of local names of the pages in the renamed namespace.
newName (String)
The new name of the namespace.
Return Value
true if the operation completed successfully, false otherwise.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


ProcessPageRenaming Method (oldName, newName)

ProcessPageRenaming Method (oldName, newName)
ScrewTurn Wiki ► ScrewTurn.Wiki ► AuthWriter ► ProcessPageRenaming(String, String)
Processes the renaming of a page.
Declaration Syntax
C# Visual Basic Visual C++
public static bool ProcessPageRenaming(
    string oldName,
    string newName
)
Public Shared Function ProcessPageRenaming ( _
    oldName As String, _
    newName As String _
) As Boolean
public:
static bool ProcessPageRenaming(
    String^ oldName,
    String^ newName
)
Parameters
oldName (String)
The old full page name.
newName (String)
The new full page name.
Return Value
true if the operation completed successfully, false otherwise.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


RemoveEntriesForDirectory Method

RemoveEntriesForDirectory Method
ScrewTurn Wiki ► ScrewTurn.Wiki ► AuthWriter ► RemoveEntriesForDirectory()()()
Members
Icon | Member | Description
 | RemoveEntriesForDirectory(UserGroup, IFilesStorageProviderV30, String) | Removes all the ACL Entries for a directory that are bound to a user group.
 | RemoveEntriesForDirectory(UserInfo, IFilesStorageProviderV30, String) | Removes all the ACL Entries for a directory that are bound to a user.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


RemoveEntriesForDirectory Method (group, provider, directory)

RemoveEntriesForDirectory Method (group, provider, directory)
ScrewTurn Wiki ► ScrewTurn.Wiki ► AuthWriter ► RemoveEntriesForDirectory(UserGroup, IFilesStorageProviderV30, String)
Removes all the ACL Entries for a directory that are bound to a user group.
Declaration Syntax
C# Visual Basic Visual C++
public static bool RemoveEntriesForDirectory(
    UserGroup group,
    IFilesStorageProviderV30 provider,
    string directory
)
Public Shared Function RemoveEntriesForDirectory ( _
    group As UserGroup, _
    provider As IFilesStorageProviderV30, _
    directory As String _
) As Boolean
public:
static bool RemoveEntriesForDirectory(
    UserGroup^ group,
    IFilesStorageProviderV30^ provider,
    String^ directory
)
Parameters
group (UserGroup)
The group.
provider (IFilesStorageProviderV30)
The provider.
directory (String)
The directory.
Return Value
true if the operation succeeded, false otherwise.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


RemoveEntriesForDirectory Method (user, provider, directory)

RemoveEntriesForDirectory Method (user, provider, directory)
ScrewTurn Wiki ► ScrewTurn.Wiki ► AuthWriter ► RemoveEntriesForDirectory(UserInfo, IFilesStorageProviderV30, String)
Removes all the ACL Entries for a directory that are bound to a user.
Declaration Syntax
C# Visual Basic Visual C++
public static bool RemoveEntriesForDirectory(
    UserInfo user,
    IFilesStorageProviderV30 provider,
    string directory
)
Public Shared Function RemoveEntriesForDirectory ( _
    user As UserInfo, _
    provider As IFilesStorageProviderV30, _
    directory As String _
) As Boolean
public:
static bool RemoveEntriesForDirectory(
    UserInfo^ user,
    IFilesStorageProviderV30^ provider,
    String^ directory
)
Parameters
user (UserInfo)
The user.
provider (IFilesStorageProviderV30)
The provider.
directory (String)
The directory.
Return Value
true if the operation succeeded, false otherwise.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


RemoveEntriesForGlobals Method

RemoveEntriesForGlobals Method
ScrewTurn Wiki ► ScrewTurn.Wiki ► AuthWriter ► RemoveEntriesForGlobals()()()
Members
Icon | Member | Description
 | RemoveEntriesForGlobals(UserGroup) | Removes all the ACL Entries for global resources that are bound to a user group.
 | RemoveEntriesForGlobals(UserInfo) | Removes all the ACL Entries for global resources that are bound to a user.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


RemoveEntriesForGlobals Method (group)

RemoveEntriesForGlobals Method (group)
ScrewTurn Wiki ► ScrewTurn.Wiki ► AuthWriter ► RemoveEntriesForGlobals(UserGroup)
Removes all the ACL Entries for global resources that are bound to a user group.
Declaration Syntax
C# Visual Basic Visual C++
public static bool RemoveEntriesForGlobals(
    UserGroup group
)
Public Shared Function RemoveEntriesForGlobals ( _
    group As UserGroup _
) As Boolean
public:
static bool RemoveEntriesForGlobals(
    UserGroup^ group
)
Parameters
group (UserGroup)
The user group.
Return Value
true if the operation succeeded, false otherwise.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


RemoveEntriesForGlobals Method (user)

RemoveEntriesForGlobals Method (user)
ScrewTurn Wiki ► ScrewTurn.Wiki ► AuthWriter ► RemoveEntriesForGlobals(UserInfo)
Removes all the ACL Entries for global resources that are bound to a user.
Declaration Syntax
C# Visual Basic Visual C++
public static bool RemoveEntriesForGlobals(
    UserInfo user
)
Public Shared Function RemoveEntriesForGlobals ( _
    user As UserInfo _
) As Boolean
public:
static bool RemoveEntriesForGlobals(
    UserInfo^ user
)
Parameters
user (UserInfo)
The user.
Return Value
true if the operation succeeded, false otherwise.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


RemoveEntriesForNamespace Method

RemoveEntriesForNamespace Method
ScrewTurn Wiki ► ScrewTurn.Wiki ► AuthWriter ► RemoveEntriesForNamespace()()()
Members
Icon | Member | Description
 | RemoveEntriesForNamespace(UserGroup, NamespaceInfo) | Removes all the ACL Entries for a namespace that are bound to a user group.
 | RemoveEntriesForNamespace(UserInfo, NamespaceInfo) | Removes all the ACL Entries for a namespace that are bound to a user.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


RemoveEntriesForNamespace Method (group, nspace)

RemoveEntriesForNamespace Method (group, nspace)
ScrewTurn Wiki ► ScrewTurn.Wiki ► AuthWriter ► RemoveEntriesForNamespace(UserGroup, NamespaceInfo)
Removes all the ACL Entries for a namespace that are bound to a user group.
Declaration Syntax
C# Visual Basic Visual C++
public static bool RemoveEntriesForNamespace(
    UserGroup group,
    NamespaceInfo nspace
)
Public Shared Function RemoveEntriesForNamespace ( _
    group As UserGroup, _
    nspace As NamespaceInfo _
) As Boolean
public:
static bool RemoveEntriesForNamespace(
    UserGroup^ group,
    NamespaceInfo^ nspace
)
Parameters
group (UserGroup)
The user group.
nspace (NamespaceInfo)
The namespace (null for the root).
Return Value
true if the operation succeeded, false otherwise.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


RemoveEntriesForNamespace Method (user, nspace)

RemoveEntriesForNamespace Method (user, nspace)
ScrewTurn Wiki ► ScrewTurn.Wiki ► AuthWriter ► RemoveEntriesForNamespace(UserInfo, NamespaceInfo)
Removes all the ACL Entries for a namespace that are bound to a user.
Declaration Syntax
C# Visual Basic Visual C++
public static bool RemoveEntriesForNamespace(
    UserInfo user,
    NamespaceInfo nspace
)
Public Shared Function RemoveEntriesForNamespace ( _
    user As UserInfo, _
    nspace As NamespaceInfo _
) As Boolean
public:
static bool RemoveEntriesForNamespace(
    UserInfo^ user,
    NamespaceInfo^ nspace
)
Parameters
user (UserInfo)
The user.
nspace (NamespaceInfo)
The namespace (null for the root).
Return Value
true if the operation succeeded, false otherwise.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


RemoveEntriesForPage Method

RemoveEntriesForPage Method
ScrewTurn Wiki ► ScrewTurn.Wiki ► AuthWriter ► RemoveEntriesForPage()()()
Members
Icon | Member | Description
 | RemoveEntriesForPage(UserGroup, PageInfo) | Removes all the ACL Entries for a page that are bound to a user group.
 | RemoveEntriesForPage(UserInfo, PageInfo) | Removes all the ACL Entries for a page that are bound to a user.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


RemoveEntriesForPage Method (group, page)

RemoveEntriesForPage Method (group, page)
ScrewTurn Wiki ► ScrewTurn.Wiki ► AuthWriter ► RemoveEntriesForPage(UserGroup, PageInfo)
Removes all the ACL Entries for a page that are bound to a user group.
Declaration Syntax
C# Visual Basic Visual C++
public static bool RemoveEntriesForPage(
    UserGroup group,
    PageInfo page
)
Public Shared Function RemoveEntriesForPage ( _
    group As UserGroup, _
    page As PageInfo _
) As Boolean
public:
static bool RemoveEntriesForPage(
    UserGroup^ group,
    PageInfo^ page
)
Parameters
group (UserGroup)
The user group.
page (PageInfo)
The page.
Return Value
true if the operation succeeded, false otherwise.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


RemoveEntriesForPage Method (user, page)

RemoveEntriesForPage Method (user, page)
ScrewTurn Wiki ► ScrewTurn.Wiki ► AuthWriter ► RemoveEntriesForPage(UserInfo, PageInfo)
Removes all the ACL Entries for a page that are bound to a user.
Declaration Syntax
C# Visual Basic Visual C++
public static bool RemoveEntriesForPage(
    UserInfo user,
    PageInfo page
)
Public Shared Function RemoveEntriesForPage ( _
    user As UserInfo, _
    page As PageInfo _
) As Boolean
public:
static bool RemoveEntriesForPage(
    UserInfo^ user,
    PageInfo^ page
)
Parameters
user (UserInfo)
The user.
page (PageInfo)
The page.
Return Value
true if the operation succeeded, false otherwise.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


SetPermissionForDirectory Method

SetPermissionForDirectory Method
ScrewTurn Wiki ► ScrewTurn.Wiki ► AuthWriter ► SetPermissionForDirectory()()()
Members
Icon | Member | Description
 | SetPermissionForDirectory(AuthStatus, IFilesStorageProviderV30, String, String, UserGroup) | Sets a permission for a directory.
 | SetPermissionForDirectory(AuthStatus, IFilesStorageProviderV30, String, String, UserInfo) | Sets a permission for a directory.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


SetPermissionForDirectory Method (status, provider, directory, action, group)

SetPermissionForDirectory Method (status, provider, directory, action, group)
ScrewTurn Wiki ► ScrewTurn.Wiki ► AuthWriter ► SetPermissionForDirectory(AuthStatus, IFilesStorageProviderV30, String, String, UserGroup)
Sets a permission for a directory.
Declaration Syntax
C# Visual Basic Visual C++
public static bool SetPermissionForDirectory(
    AuthStatus status,
    IFilesStorageProviderV30 provider,
    string directory,
    string action,
    UserGroup group
)
Public Shared Function SetPermissionForDirectory ( _
    status As AuthStatus, _
    provider As IFilesStorageProviderV30, _
    directory As String, _
    action As String, _
    group As UserGroup _
) As Boolean
public:
static bool SetPermissionForDirectory(
    AuthStatus status,
    IFilesStorageProviderV30^ provider,
    String^ directory,
    String^ action,
    UserGroup^ group
)
Parameters
status (AuthStatus)
The authorization status.
provider (IFilesStorageProviderV30)
The provider that handles the directory.
directory (String)
The directory.
action (String)
The action of which to modify the authorization status.
group (UserGroup)
The group subject of the authorization change.
Return Value
true if the authorization status is changed, false otherwise.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


SetPermissionForDirectory Method (status, provider, directory, action, user)

SetPermissionForDirectory Method (status, provider, directory, action, user)
ScrewTurn Wiki ► ScrewTurn.Wiki ► AuthWriter ► SetPermissionForDirectory(AuthStatus, IFilesStorageProviderV30, String, String, UserInfo)
Sets a permission for a directory.
Declaration Syntax
C# Visual Basic Visual C++
public static bool SetPermissionForDirectory(
    AuthStatus status,
    IFilesStorageProviderV30 provider,
    string directory,
    string action,
    UserInfo user
)
Public Shared Function SetPermissionForDirectory ( _
    status As AuthStatus, _
    provider As IFilesStorageProviderV30, _
    directory As String, _
    action As String, _
    user As UserInfo _
) As Boolean
public:
static bool SetPermissionForDirectory(
    AuthStatus status,
    IFilesStorageProviderV30^ provider,
    String^ directory,
    String^ action,
    UserInfo^ user
)
Parameters
status (AuthStatus)
The authorization status.
provider (IFilesStorageProviderV30)
The provider that handles the directory.
directory (String)
The directory.
action (String)
The action of which to modify the authorization status.
user (UserInfo)
The user subject of the authorization change.
Return Value
true if the authorization status is changed, false otherwise.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


SetPermissionForGlobals Method

SetPermissionForGlobals Method
ScrewTurn Wiki ► ScrewTurn.Wiki ► AuthWriter ► SetPermissionForGlobals()()()
Members
Icon | Member | Description
 | SetPermissionForGlobals(AuthStatus, String, UserGroup) | Sets a permission for a global resource.
 | SetPermissionForGlobals(AuthStatus, String, UserInfo) | Sets a permission for a global resource.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


SetPermissionForGlobals Method (status, action, group)

SetPermissionForGlobals Method (status, action, group)
ScrewTurn Wiki ► ScrewTurn.Wiki ► AuthWriter ► SetPermissionForGlobals(AuthStatus, String, UserGroup)
Sets a permission for a global resource.
Declaration Syntax
C# Visual Basic Visual C++
public static bool SetPermissionForGlobals(
    AuthStatus status,
    string action,
    UserGroup group
)
Public Shared Function SetPermissionForGlobals ( _
    status As AuthStatus, _
    action As String, _
    group As UserGroup _
) As Boolean
public:
static bool SetPermissionForGlobals(
    AuthStatus status,
    String^ action,
    UserGroup^ group
)
Parameters
status (AuthStatus)
The authorization status.
action (String)
The action of which to modify the authorization status.
group (UserGroup)
The group subject of the authorization change.
Return Value
true if the authorization status is changed, false otherwise.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


SetPermissionForGlobals Method (status, action, user)

SetPermissionForGlobals Method (status, action, user)
ScrewTurn Wiki ► ScrewTurn.Wiki ► AuthWriter ► SetPermissionForGlobals(AuthStatus, String, UserInfo)
Sets a permission for a global resource.
Declaration Syntax
C# Visual Basic Visual C++
public static bool SetPermissionForGlobals(
    AuthStatus status,
    string action,
    UserInfo user
)
Public Shared Function SetPermissionForGlobals ( _
    status As AuthStatus, _
    action As String, _
    user As UserInfo _
) As Boolean
public:
static bool SetPermissionForGlobals(
    AuthStatus status,
    String^ action,
    UserInfo^ user
)
Parameters
status (AuthStatus)
The authorization status.
action (String)
The action of which to modify the authorization status.
user (UserInfo)
The user subject of the authorization change.
Return Value
true if the authorization status is changed, false otherwise.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


SetPermissionForNamespace Method

SetPermissionForNamespace Method
ScrewTurn Wiki ► ScrewTurn.Wiki ► AuthWriter ► SetPermissionForNamespace()()()
Members
Icon | Member | Description
 | SetPermissionForNamespace(AuthStatus, NamespaceInfo, String, UserGroup) | Sets a permission for a namespace.
 | SetPermissionForNamespace(AuthStatus, NamespaceInfo, String, UserInfo) | Sets a permission for a namespace.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


SetPermissionForNamespace Method (status, nspace, action, group)

SetPermissionForNamespace Method (status, nspace, action, group)
ScrewTurn Wiki ► ScrewTurn.Wiki ► AuthWriter ► SetPermissionForNamespace(AuthStatus, NamespaceInfo, String, UserGroup)
Sets a permission for a namespace.
Declaration Syntax
C# Visual Basic Visual C++
public static bool SetPermissionForNamespace(
    AuthStatus status,
    NamespaceInfo nspace,
    string action,
    UserGroup group
)
Public Shared Function SetPermissionForNamespace ( _
    status As AuthStatus, _
    nspace As NamespaceInfo, _
    action As String, _
    group As UserGroup _
) As Boolean
public:
static bool SetPermissionForNamespace(
    AuthStatus status,
    NamespaceInfo^ nspace,
    String^ action,
    UserGroup^ group
)
Parameters
status (AuthStatus)
The authorization status.
nspace (NamespaceInfo)
The namespace (null for the root).
action (String)
The action of which to modify the authorization status.
group (UserGroup)
The group subject of the authorization change.
Return Value
true if the authorization status is changed, false otherwise.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


SetPermissionForNamespace Method (status, nspace, action, user)

SetPermissionForNamespace Method (status, nspace, action, user)
ScrewTurn Wiki ► ScrewTurn.Wiki ► AuthWriter ► SetPermissionForNamespace(AuthStatus, NamespaceInfo, String, UserInfo)
Sets a permission for a namespace.
Declaration Syntax
C# Visual Basic Visual C++
public static bool SetPermissionForNamespace(
    AuthStatus status,
    NamespaceInfo nspace,
    string action,
    UserInfo user
)
Public Shared Function SetPermissionForNamespace ( _
    status As AuthStatus, _
    nspace As NamespaceInfo, _
    action As String, _
    user As UserInfo _
) As Boolean
public:
static bool SetPermissionForNamespace(
    AuthStatus status,
    NamespaceInfo^ nspace,
    String^ action,
    UserInfo^ user
)
Parameters
status (AuthStatus)
The authorization status.
nspace (NamespaceInfo)
The namespace (null for the root).
action (String)
The action of which to modify the authorization status.
user (UserInfo)
The user subject of the authorization change.
Return Value
true if the authorization status is changed, false otherwise.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


SetPermissionForPage Method

SetPermissionForPage Method
ScrewTurn Wiki ► ScrewTurn.Wiki ► AuthWriter ► SetPermissionForPage()()()
Members
Icon | Member | Description
 | SetPermissionForPage(AuthStatus, PageInfo, String, UserGroup) | Sets a permission for a page.
 | SetPermissionForPage(AuthStatus, PageInfo, String, UserInfo) | Sets a permission for a page.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


SetPermissionForPage Method (status, page, action, group)

SetPermissionForPage Method (status, page, action, group)
ScrewTurn Wiki ► ScrewTurn.Wiki ► AuthWriter ► SetPermissionForPage(AuthStatus, PageInfo, String, UserGroup)
Sets a permission for a page.
Declaration Syntax
C# Visual Basic Visual C++
public static bool SetPermissionForPage(
    AuthStatus status,
    PageInfo page,
    string action,
    UserGroup group
)
Public Shared Function SetPermissionForPage ( _
    status As AuthStatus, _
    page As PageInfo, _
    action As String, _
    group As UserGroup _
) As Boolean
public:
static bool SetPermissionForPage(
    AuthStatus status,
    PageInfo^ page,
    String^ action,
    UserGroup^ group
)
Parameters
status (AuthStatus)
The authorization status.
page (PageInfo)
The page.
action (String)
The action of which to modify the authorization status.
group (UserGroup)
The group subject of the authorization change.
Return Value
true if the authorization status is changed, false otherwise.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


SetPermissionForPage Method (status, page, action, user)

SetPermissionForPage Method (status, page, action, user)
ScrewTurn Wiki ► ScrewTurn.Wiki ► AuthWriter ► SetPermissionForPage(AuthStatus, PageInfo, String, UserInfo)
Sets a permission for a page.
Declaration Syntax
C# Visual Basic Visual C++
public static bool SetPermissionForPage(
    AuthStatus status,
    PageInfo page,
    string action,
    UserInfo user
)
Public Shared Function SetPermissionForPage ( _
    status As AuthStatus, _
    page As PageInfo, _
    action As String, _
    user As UserInfo _
) As Boolean
public:
static bool SetPermissionForPage(
    AuthStatus status,
    PageInfo^ page,
    String^ action,
    UserInfo^ user
)
Parameters
status (AuthStatus)
The authorization status.
page (PageInfo)
The page.
action (String)
The action of which to modify the authorization status.
user (UserInfo)
The user subject of the authorization change.
Return Value
true if the authorization status is changed, false otherwise.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


BreadcrumbsManager Class

BreadcrumbsManager Class
ScrewTurn Wiki ► ScrewTurn.Wiki ► BreadcrumbsManager
Manages navigation Breadcrumbs.
Declaration Syntax
C# Visual Basic Visual C++
public class BreadcrumbsManager
Public Class BreadcrumbsManager
public ref class BreadcrumbsManager
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | BreadcrumbsManager()()() | Initializes a new instance of the BreadcrumbsManager class.
 | AddPage(PageInfo) | Adds a Page to the Breadcrumbs trail.
 | AllPages | Gets all the Pages in the trail that still exist.
 | Clear()()() | Clears the Breadcrumbs trail.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | RemovePage(PageInfo) | Removes a Page from the Breadcrumbs trail.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
BreadcrumbsManager

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


BreadcrumbsManager Constructor

BreadcrumbsManager Constructor
ScrewTurn Wiki ► ScrewTurn.Wiki ► BreadcrumbsManager ► BreadcrumbsManager()()()
Initializes a new instance of the BreadcrumbsManager class.
Declaration Syntax
C# Visual Basic Visual C++
public BreadcrumbsManager()
Public Sub New
public:
BreadcrumbsManager()

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


AddPage Method (page)

AddPage Method (page)
ScrewTurn Wiki ► ScrewTurn.Wiki ► BreadcrumbsManager ► AddPage(PageInfo)
Adds a Page to the Breadcrumbs trail.
Declaration Syntax
C# Visual Basic Visual C++
public void AddPage(
    PageInfo page
)
Public Sub AddPage ( _
    page As PageInfo _
)
public:
void AddPage(
    PageInfo^ page
)
Parameters
page (PageInfo)
The Page to add.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


AllPages Property

AllPages Property
ScrewTurn Wiki ► ScrewTurn.Wiki ► BreadcrumbsManager ► AllPages
Gets all the Pages in the trail that still exist.
Declaration Syntax
C# Visual Basic Visual C++
public PageInfo[] AllPages { get; }
Public ReadOnly Property AllPages As PageInfo()
public:
property array<PageInfo^>^ AllPages {
    array<PageInfo^>^ get ();
}

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


Clear Method

Clear Method
ScrewTurn Wiki ► ScrewTurn.Wiki ► BreadcrumbsManager ► Clear()()()
Clears the Breadcrumbs trail.
Declaration Syntax
C# Visual Basic Visual C++
public void Clear()
Public Sub Clear
public:
void Clear()

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


RemovePage Method (page)

RemovePage Method (page)
ScrewTurn Wiki ► ScrewTurn.Wiki ► BreadcrumbsManager ► RemovePage(PageInfo)
Removes a Page from the Breadcrumbs trail.
Declaration Syntax
C# Visual Basic Visual C++
public void RemovePage(
    PageInfo page
)
Public Sub RemovePage ( _
    page As PageInfo _
)
public:
void RemovePage(
    PageInfo^ page
)
Parameters
page (PageInfo)
The Page to remove.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


Cache Class

Cache Class
ScrewTurn Wiki ► ScrewTurn.Wiki ► Cache
Manages data cache.
Declaration Syntax
C# Visual Basic Visual C++
public static class Cache
Public NotInheritable Class Cache
public ref class Cache abstract sealed
Members
All Members | Methods | Properties
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | ClearPageCache()()() | Clears the pages cache.
 | ClearPseudoCache()()() | Clears the pseudo cache.
 | FormattedPageCacheUsage | Gets the number of formatted pages currently in the page cache.
 | GetFormattedPageContent(PageInfo) | Gets a cached formatted page content.
 | GetPageContent(PageInfo) | Gets a cached PageContent.
 | GetPseudoCacheValue(String) | Gets a pseudo cache item value.
 | OnlineUsers | Gets or sets the number of users online.
 | PageCacheUsage | Gets the number of pages currently in the page cache.
 | Provider | Gets the cache provider.
 | RemovePage(PageInfo) | Removes a page from the cache.
 | SetFormattedPageContent(PageInfo, String) | Sets the formatted page content in cache.
 | SetPageContent(PageInfo, PageContent) | Sets the page content in cache.
 | SetPseudoCacheValue(String, String) | Sets a pseudo cache item value.
Inheritance Hierarchy
Object
Cache

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


ClearPageCache Method

ClearPageCache Method
ScrewTurn Wiki ► ScrewTurn.Wiki ► Cache ► ClearPageCache()()()
Clears the pages cache.
Declaration Syntax
C# Visual Basic Visual C++
public static void ClearPageCache()
Public Shared Sub ClearPageCache
public:
static void ClearPageCache()

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


ClearPseudoCache Method

ClearPseudoCache Method
ScrewTurn Wiki ► ScrewTurn.Wiki ► Cache ► ClearPseudoCache()()()
Clears the pseudo cache.
Declaration Syntax
C# Visual Basic Visual C++
public static void ClearPseudoCache()
Public Shared Sub ClearPseudoCache
public:
static void ClearPseudoCache()

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


FormattedPageCacheUsage Property

FormattedPageCacheUsage Property
ScrewTurn Wiki ► ScrewTurn.Wiki ► Cache ► FormattedPageCacheUsage
Gets the number of formatted pages currently in the page cache.
Declaration Syntax
C# Visual Basic Visual C++
public static int FormattedPageCacheUsage { get; }
Public Shared ReadOnly Property FormattedPageCacheUsage As Integer
public:
static property int FormattedPageCacheUsage {
    int get ();
}

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


GetFormattedPageContent Method (page)

GetFormattedPageContent Method (page)
ScrewTurn Wiki ► ScrewTurn.Wiki ► Cache ► GetFormattedPageContent(PageInfo)
Gets a cached formatted page content.
Declaration Syntax
C# Visual Basic Visual C++
public static string GetFormattedPageContent(
    PageInfo page
)
Public Shared Function GetFormattedPageContent ( _
    page As PageInfo _
) As String
public:
static String^ GetFormattedPageContent(
    PageInfo^ page
)
Parameters
page (PageInfo)
The page to get the formatted content of.
Return Value
The formatted page content, or null.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


GetPageContent Method (page)

GetPageContent Method (page)
ScrewTurn Wiki ► ScrewTurn.Wiki ► Cache ► GetPageContent(PageInfo)
Gets a cached PageContent.
Declaration Syntax
C# Visual Basic Visual C++
public static PageContent GetPageContent(
    PageInfo page
)
Public Shared Function GetPageContent ( _
    page As PageInfo _
) As PageContent
public:
static PageContent^ GetPageContent(
    PageInfo^ page
)
Parameters
page (PageInfo)
The page to get the content of.
Return Value
The page content, or null.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


GetPseudoCacheValue Method (name)

GetPseudoCacheValue Method (name)
ScrewTurn Wiki ► ScrewTurn.Wiki ► Cache ► GetPseudoCacheValue(String)
Gets a pseudo cache item value.
Declaration Syntax
C# Visual Basic Visual C++
public static string GetPseudoCacheValue(
    string name
)
Public Shared Function GetPseudoCacheValue ( _
    name As String _
) As String
public:
static String^ GetPseudoCacheValue(
    String^ name
)
Parameters
name (String)
The name of the item to get the value of.
Return Value
The value of the item, or null.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


OnlineUsers Property

OnlineUsers Property
ScrewTurn Wiki ► ScrewTurn.Wiki ► Cache ► OnlineUsers
Gets or sets the number of users online.
Declaration Syntax
C# Visual Basic Visual C++
public static int OnlineUsers { get; set; }
Public Shared Property OnlineUsers As Integer
public:
static property int OnlineUsers {
    int get ();
    void set (int value);
}

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


PageCacheUsage Property

PageCacheUsage Property
ScrewTurn Wiki ► ScrewTurn.Wiki ► Cache ► PageCacheUsage
Gets the number of pages currently in the page cache.
Declaration Syntax
C# Visual Basic Visual C++
public static int PageCacheUsage { get; }
Public Shared ReadOnly Property PageCacheUsage As Integer
public:
static property int PageCacheUsage {
    int get ();
}

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


Provider Property

Provider Property
ScrewTurn Wiki ► ScrewTurn.Wiki ► Cache ► Provider
Gets the cache provider.
Declaration Syntax
C# Visual Basic Visual C++
public static ICacheProviderV30 Provider { get; }
Public Shared ReadOnly Property Provider As ICacheProviderV30
public:
static property ICacheProviderV30^ Provider {
    ICacheProviderV30^ get ();
}

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


RemovePage Method (page)

RemovePage Method (page)
ScrewTurn Wiki ► ScrewTurn.Wiki ► Cache ► RemovePage(PageInfo)
Removes a page from the cache.
Declaration Syntax
C# Visual Basic Visual C++
public static void RemovePage(
    PageInfo page
)
Public Shared Sub RemovePage ( _
    page As PageInfo _
)
public:
static void RemovePage(
    PageInfo^ page
)
Parameters
page (PageInfo)
The page to remove.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


SetFormattedPageContent Method (page, content)

SetFormattedPageContent Method (page, content)
ScrewTurn Wiki ► ScrewTurn.Wiki ► Cache ► SetFormattedPageContent(PageInfo, String)
Sets the formatted page content in cache.
Declaration Syntax
C# Visual Basic Visual C++
public static void SetFormattedPageContent(
    PageInfo page,
    string content
)
Public Shared Sub SetFormattedPageContent ( _
    page As PageInfo, _
    content As String _
)
public:
static void SetFormattedPageContent(
    PageInfo^ page,
    String^ content
)
Parameters
page (PageInfo)
The page to set the content of.
content (String)
The content.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


SetPageContent Method (page, content)

SetPageContent Method (page, content)
ScrewTurn Wiki ► ScrewTurn.Wiki ► Cache ► SetPageContent(PageInfo, PageContent)
Sets the page content in cache.
Declaration Syntax
C# Visual Basic Visual C++
public static void SetPageContent(
    PageInfo page,
    PageContent content
)
Public Shared Sub SetPageContent ( _
    page As PageInfo, _
    content As PageContent _
)
public:
static void SetPageContent(
    PageInfo^ page,
    PageContent^ content
)
Parameters
page (PageInfo)
The page to set the content of.
content (PageContent)
The content.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


SetPseudoCacheValue Method (name, value)

SetPseudoCacheValue Method (name, value)
ScrewTurn Wiki ► ScrewTurn.Wiki ► Cache ► SetPseudoCacheValue(String, String)
Sets a pseudo cache item value.
Declaration Syntax
C# Visual Basic Visual C++
public static void SetPseudoCacheValue(
    string name,
    string value
)
Public Shared Sub SetPseudoCacheValue ( _
    name As String, _
    value As String _
)
public:
static void SetPseudoCacheValue(
    String^ name,
    String^ value
)
Parameters
name (String)
The name of the item to set the value of.
value (String)
The value of the item.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


CacheProvider Class

CacheProvider Class
ScrewTurn Wiki ► ScrewTurn.Wiki ► CacheProvider
Implements a local cache provider. All instance members are thread-safe.
Declaration Syntax
C# Visual Basic Visual C++
public class CacheProvider : ICacheProviderV30,
    IProviderV30
Public Class CacheProvider _
    Implements ICacheProviderV30, IProviderV30
public ref class CacheProvider : ICacheProviderV30,
    IProviderV30
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | CacheProvider()()() | Initializes a new instance of the CacheProvider class
 | AddRedirection(String, String) | Adds the redirection information for a page (overwrites the previous value, if any).
 | CancelEditingSession(String, String) | Cancels an editing session.
 | ClearPageContentCache()()() | Clears the Page Content cache.
 | ClearPseudoCache()()() | Clears the Pseudo-Cache.
 | ClearRedirections()()() | Clears all the redirections information.
 | ConfigHelpHtml | Gets a brief summary of the configuration string format, in HTML. Returns null if no configuration is needed.
 | CutCache(Int32) | Reduces the size of the Page Content cache, removing the least-recently used items.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | FormatterPageCacheUsage | Gets the numer of Pages whose formatted content is currently stored in the cache.
 | GetFormattedPageContent(PageInfo) | Gets the partially-formatted content (text) of a Page, previously stored in the cache.
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetPageContent(PageInfo) | Gets the Content of a Page, previously stored in cache.
 | GetPseudoCacheValue(String) | Gets the value of a Pseudo-cache item, previously stored in the cache.
 | GetRedirectionDestination(String) | Gets the destination of a redirection.
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | Information | Gets the Information about the Provider.
 | Init(IHostV30, String) | Initializes the Storage Provider.
 | IsPageBeingEdited(String, String) | Finds whether a Page is being edited by a different user.
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | OnlineUsers | Gets or sets the number of users online.
 | PageCacheUsage | Gets the number of Pages whose content is currently stored in the cache.
 | RemovePage(PageInfo) | Removes a Page from the cache.
 | RemovePageFromRedirections(String) | Removes a pge from both sources and destinations.
 | RenewEditingSession(String, String) | Adds or updates an editing session.
 | SetFormattedPageContent(PageInfo, String) | Sets the partially-preformatted content (text) of a Page.
 | SetPageContent(PageInfo, PageContent) | Sets the Content of a Page.
 | SetPseudoCacheValue(String, String) | Sets the value of a Pseudo-cache item.
 | Shutdown()()() | Method invoked on shutdown.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | WhosEditing(String) | Gets the username of the user who's editing a page.
Inheritance Hierarchy
Object
CacheProvider

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


CacheProvider Constructor

CacheProvider Constructor
ScrewTurn Wiki ► ScrewTurn.Wiki ► CacheProvider ► CacheProvider()()()
Initializes a new instance of the CacheProvider class
Declaration Syntax
C# Visual Basic Visual C++
public CacheProvider()
Public Sub New
public:
CacheProvider()

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


AddRedirection Method (source, destination)

AddRedirection Method (source, destination)
ScrewTurn Wiki ► ScrewTurn.Wiki ► CacheProvider ► AddRedirection(String, String)
Adds the redirection information for a page (overwrites the previous value, if any).
Declaration Syntax
C# Visual Basic Visual C++
public void AddRedirection(
    string source,
    string destination
)
Public Sub AddRedirection ( _
    source As String, _
    destination As String _
)
public:
virtual void AddRedirection(
    String^ source,
    String^ destination
) sealed
Parameters
source (String)
The source page.
destination (String)
The destination page.
Exceptions
Exception | Condition
ArgumentNullException | If source or destination are null.
ArgumentException | If source or destination are empty.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


CancelEditingSession Method (page, user)

CancelEditingSession Method (page, user)
ScrewTurn Wiki ► ScrewTurn.Wiki ► CacheProvider ► CancelEditingSession(String, String)
Cancels an editing session.
Declaration Syntax
C# Visual Basic Visual C++
public void CancelEditingSession(
    string page,
    string user
)
Public Sub CancelEditingSession ( _
    page As String, _
    user As String _
)
public:
virtual void CancelEditingSession(
    String^ page,
    String^ user
) sealed
Parameters
page (String)
The Page.
user (String)
The User.
Exceptions
Exception | Condition
ArgumentNullException | If page or user are null.
ArgumentException | If page or user are empty.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


ClearPageContentCache Method

ClearPageContentCache Method
ScrewTurn Wiki ► ScrewTurn.Wiki ► CacheProvider ► ClearPageContentCache()()()
Clears the Page Content cache.
Declaration Syntax
C# Visual Basic Visual C++
public void ClearPageContentCache()
Public Sub ClearPageContentCache
public:
virtual void ClearPageContentCache() sealed

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


ClearPseudoCache Method

ClearPseudoCache Method
ScrewTurn Wiki ► ScrewTurn.Wiki ► CacheProvider ► ClearPseudoCache()()()
Clears the Pseudo-Cache.
Declaration Syntax
C# Visual Basic Visual C++
public void ClearPseudoCache()
Public Sub ClearPseudoCache
public:
virtual void ClearPseudoCache() sealed

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


ClearRedirections Method

ClearRedirections Method
ScrewTurn Wiki ► ScrewTurn.Wiki ► CacheProvider ► ClearRedirections()()()
Clears all the redirections information.
Declaration Syntax
C# Visual Basic Visual C++
public void ClearRedirections()
Public Sub ClearRedirections
public:
virtual void ClearRedirections() sealed

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


ConfigHelpHtml Property

ConfigHelpHtml Property
ScrewTurn Wiki ► ScrewTurn.Wiki ► CacheProvider ► ConfigHelpHtml
Gets a brief summary of the configuration string format, in HTML. Returns null if no configuration is needed.
Declaration Syntax
C# Visual Basic Visual C++
public string ConfigHelpHtml { get; }
Public ReadOnly Property ConfigHelpHtml As String
public:
virtual property String^ ConfigHelpHtml {
    String^ get () sealed;
}

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


CutCache Method (cutSize)

CutCache Method (cutSize)
ScrewTurn Wiki ► ScrewTurn.Wiki ► CacheProvider ► CutCache(Int32)
Reduces the size of the Page Content cache, removing the least-recently used items.
Declaration Syntax
C# Visual Basic Visual C++
public void CutCache(
    int cutSize
)
Public Sub CutCache ( _
    cutSize As Integer _
)
public:
virtual void CutCache(
    int cutSize
) sealed
Parameters
cutSize (Int32)
The number of Pages to remove.
Exceptions
Exception | Condition
ArgumentOutOfRangeException | If cutSize is less than or equal to zero.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


FormatterPageCacheUsage Property

FormatterPageCacheUsage Property
ScrewTurn Wiki ► ScrewTurn.Wiki ► CacheProvider ► FormatterPageCacheUsage
Gets the numer of Pages whose formatted content is currently stored in the cache.
Declaration Syntax
C# Visual Basic Visual C++
public int FormatterPageCacheUsage { get; }
Public ReadOnly Property FormatterPageCacheUsage As Integer
public:
virtual property int FormatterPageCacheUsage {
    int get () sealed;
}

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


GetFormattedPageContent Method (pageInfo)

GetFormattedPageContent Method (pageInfo)
ScrewTurn Wiki ► ScrewTurn.Wiki ► CacheProvider ► GetFormattedPageContent(PageInfo)
Gets the partially-formatted content (text) of a Page, previously stored in the cache.
Declaration Syntax
C# Visual Basic Visual C++
public string GetFormattedPageContent(
    PageInfo pageInfo
)
Public Function GetFormattedPageContent ( _
    pageInfo As PageInfo _
) As String
public:
virtual String^ GetFormattedPageContent(
    PageInfo^ pageInfo
) sealed
Parameters
pageInfo (PageInfo)
The Page Info object related to the content being requested.
Return Value
The partially-formatted content, or null if the item is not found.
Exceptions
Exception | Condition
ArgumentNullException | If pageInfo is null.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


GetPageContent Method (pageInfo)

GetPageContent Method (pageInfo)
ScrewTurn Wiki ► ScrewTurn.Wiki ► CacheProvider ► GetPageContent(PageInfo)
Gets the Content of a Page, previously stored in cache.
Declaration Syntax
C# Visual Basic Visual C++
public PageContent GetPageContent(
    PageInfo pageInfo
)
Public Function GetPageContent ( _
    pageInfo As PageInfo _
) As PageContent
public:
virtual PageContent^ GetPageContent(
    PageInfo^ pageInfo
) sealed
Parameters
pageInfo (PageInfo)
The Page Info object related to the Content being requested.
Return Value
The Page Content object, or null if the item is not found.
Exceptions
Exception | Condition
ArgumentNullException | If pageInfo is null.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


GetPseudoCacheValue Method (name)

GetPseudoCacheValue Method (name)
ScrewTurn Wiki ► ScrewTurn.Wiki ► CacheProvider ► GetPseudoCacheValue(String)
Gets the value of a Pseudo-cache item, previously stored in the cache.
Declaration Syntax
C# Visual Basic Visual C++
public string GetPseudoCacheValue(
    string name
)
Public Function GetPseudoCacheValue ( _
    name As String _
) As String
public:
virtual String^ GetPseudoCacheValue(
    String^ name
) sealed
Parameters
name (String)
The name of the item being requested.
Return Value
The value of the item, or null if the item is not found.
Exceptions
Exception | Condition
ArgumentNullException | If name is null.
ArgumentException | If name is empty.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


GetRedirectionDestination Method (source)

GetRedirectionDestination Method (source)
ScrewTurn Wiki ► ScrewTurn.Wiki ► CacheProvider ► GetRedirectionDestination(String)
Gets the destination of a redirection.
Declaration Syntax
C# Visual Basic Visual C++
public string GetRedirectionDestination(
    string source
)
Public Function GetRedirectionDestination ( _
    source As String _
) As String
public:
virtual String^ GetRedirectionDestination(
    String^ source
) sealed
Parameters
source (String)
The source page.
Return Value
The destination page, if any, null otherwise.
Exceptions
Exception | Condition
ArgumentNullException | If source is null.
ArgumentException | If source is empty.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


Information Property

Information Property
ScrewTurn Wiki ► ScrewTurn.Wiki ► CacheProvider ► Information
Gets the Information about the Provider.
Declaration Syntax
C# Visual Basic Visual C++
public ComponentInformation Information { get; }
Public ReadOnly Property Information As ComponentInformation
public:
virtual property ComponentInformation^ Information {
    ComponentInformation^ get () sealed;
}

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


Init Method (host, config)

Init Method (host, config)
ScrewTurn Wiki ► ScrewTurn.Wiki ► CacheProvider ► Init(IHostV30, String)
Initializes the Storage Provider.
Declaration Syntax
C# Visual Basic Visual C++
public void Init(
    IHostV30 host,
    string config
)
Public Sub Init ( _
    host As IHostV30, _
    config As String _
)
public:
virtual void Init(
    IHostV30^ host,
    String^ config
) sealed
Parameters
host (IHostV30)
The Host of the Component.
config (String)
The Configuration data, if any.
Exceptions
Exception | Condition
ArgumentNullException | If host or config are null.
InvalidConfigurationException | If config is not valid or is incorrect.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


IsPageBeingEdited Method (page, currentUser)

IsPageBeingEdited Method (page, currentUser)
ScrewTurn Wiki ► ScrewTurn.Wiki ► CacheProvider ► IsPageBeingEdited(String, String)
Finds whether a Page is being edited by a different user.
Declaration Syntax
C# Visual Basic Visual C++
public bool IsPageBeingEdited(
    string page,
    string currentUser
)
Public Function IsPageBeingEdited ( _
    page As String, _
    currentUser As String _
) As Boolean
public:
virtual bool IsPageBeingEdited(
    String^ page,
    String^ currentUser
) sealed
Parameters
page (String)
The Page.
currentUser (String)
The User who is requesting the status of the Page.
Return Value
True if the Page is being edited by another User.
Exceptions
Exception | Condition
ArgumentNullException | If page or currentUser are null.
ArgumentException | If page or currentUser are empty.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


OnlineUsers Property

OnlineUsers Property
ScrewTurn Wiki ► ScrewTurn.Wiki ► CacheProvider ► OnlineUsers
Gets or sets the number of users online.
Declaration Syntax
C# Visual Basic Visual C++
public int OnlineUsers { get; set; }
Public Property OnlineUsers As Integer
public:
virtual property int OnlineUsers {
    int get () sealed;
    void set (int value) sealed;
}

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


PageCacheUsage Property

PageCacheUsage Property
ScrewTurn Wiki ► ScrewTurn.Wiki ► CacheProvider ► PageCacheUsage
Gets the number of Pages whose content is currently stored in the cache.
Declaration Syntax
C# Visual Basic Visual C++
public int PageCacheUsage { get; }
Public ReadOnly Property PageCacheUsage As Integer
public:
virtual property int PageCacheUsage {
    int get () sealed;
}

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


RemovePage Method (pageInfo)

RemovePage Method (pageInfo)
ScrewTurn Wiki ► ScrewTurn.Wiki ► CacheProvider ► RemovePage(PageInfo)
Removes a Page from the cache.
Declaration Syntax
C# Visual Basic Visual C++
public void RemovePage(
    PageInfo pageInfo
)
Public Sub RemovePage ( _
    pageInfo As PageInfo _
)
public:
virtual void RemovePage(
    PageInfo^ pageInfo
) sealed
Parameters
pageInfo (PageInfo)
The Page Info object related to the Page that has to be removed.
Exceptions
Exception | Condition
ArgumentNullException | If pageInfo is null.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


RemovePageFromRedirections Method (name)

RemovePageFromRedirections Method (name)
ScrewTurn Wiki ► ScrewTurn.Wiki ► CacheProvider ► RemovePageFromRedirections(String)
Removes a pge from both sources and destinations.
Declaration Syntax
C# Visual Basic Visual C++
public void RemovePageFromRedirections(
    string name
)
Public Sub RemovePageFromRedirections ( _
    name As String _
)
public:
virtual void RemovePageFromRedirections(
    String^ name
) sealed
Parameters
name (String)
The name of the page.
Exceptions
Exception | Condition
ArgumentNullException | If name is null.
ArgumentException | If name is empty.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


RenewEditingSession Method (page, user)

RenewEditingSession Method (page, user)
ScrewTurn Wiki ► ScrewTurn.Wiki ► CacheProvider ► RenewEditingSession(String, String)
Adds or updates an editing session.
Declaration Syntax
C# Visual Basic Visual C++
public void RenewEditingSession(
    string page,
    string user
)
Public Sub RenewEditingSession ( _
    page As String, _
    user As String _
)
public:
virtual void RenewEditingSession(
    String^ page,
    String^ user
) sealed
Parameters
page (String)
The edited Page.
user (String)
The User who is editing the Page.
Exceptions
Exception | Condition
ArgumentNullException | If page or user are null.
ArgumentException | If page or user are empty.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


SetFormattedPageContent Method (pageInfo, content)

SetFormattedPageContent Method (pageInfo, content)
ScrewTurn Wiki ► ScrewTurn.Wiki ► CacheProvider ► SetFormattedPageContent(PageInfo, String)
Sets the partially-preformatted content (text) of a Page.
Declaration Syntax
C# Visual Basic Visual C++
public void SetFormattedPageContent(
    PageInfo pageInfo,
    string content
)
Public Sub SetFormattedPageContent ( _
    pageInfo As PageInfo, _
    content As String _
)
public:
virtual void SetFormattedPageContent(
    PageInfo^ pageInfo,
    String^ content
) sealed
Parameters
pageInfo (PageInfo)
The Page Info object related to the content being stored.
content (String)
The partially-preformatted content.
Exceptions
Exception | Condition
ArgumentNullException | If pageInfo or content are null.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


SetPageContent Method (pageInfo, content)

SetPageContent Method (pageInfo, content)
ScrewTurn Wiki ► ScrewTurn.Wiki ► CacheProvider ► SetPageContent(PageInfo, PageContent)
Sets the Content of a Page.
Declaration Syntax
C# Visual Basic Visual C++
public void SetPageContent(
    PageInfo pageInfo,
    PageContent content
)
Public Sub SetPageContent ( _
    pageInfo As PageInfo, _
    content As PageContent _
)
public:
virtual void SetPageContent(
    PageInfo^ pageInfo,
    PageContent^ content
) sealed
Parameters
pageInfo (PageInfo)
The Page Info object related to the Content being stored.
content (PageContent)
The Content of the Page.
Exceptions
Exception | Condition
ArgumentNullException | If pageInfo or content are null.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


SetPseudoCacheValue Method (name, value)

SetPseudoCacheValue Method (name, value)
ScrewTurn Wiki ► ScrewTurn.Wiki ► CacheProvider ► SetPseudoCacheValue(String, String)
Sets the value of a Pseudo-cache item.
Declaration Syntax
C# Visual Basic Visual C++
public void SetPseudoCacheValue(
    string name,
    string value
)
Public Sub SetPseudoCacheValue ( _
    name As String, _
    value As String _
)
public:
virtual void SetPseudoCacheValue(
    String^ name,
    String^ value
) sealed
Parameters
name (String)
The name of the item being stored.
value (String)
The value of the item. If the value is null, then the item should be removed from the cache.
Exceptions
Exception | Condition
ArgumentNullException | If name is null.
ArgumentException | If name is empty.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


Shutdown Method

Shutdown Method
ScrewTurn Wiki ► ScrewTurn.Wiki ► CacheProvider ► Shutdown()()()
Method invoked on shutdown.
Declaration Syntax
C# Visual Basic Visual C++
public void Shutdown()
Public Sub Shutdown
public:
virtual void Shutdown() sealed
Remarks
This method might not be invoked in some cases.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


WhosEditing Method (page)

WhosEditing Method (page)
ScrewTurn Wiki ► ScrewTurn.Wiki ► CacheProvider ► WhosEditing(String)
Gets the username of the user who's editing a page.
Declaration Syntax
C# Visual Basic Visual C++
public string WhosEditing(
    string page
)
Public Function WhosEditing ( _
    page As String _
) As String
public:
virtual String^ WhosEditing(
    String^ page
) sealed
Parameters
page (String)
The page.
Return Value
The username.
Exceptions
Exception | Condition
ArgumentNullException | If page is null.
ArgumentException | If page is empty.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


ChangeModerationMode Enumeration

ChangeModerationMode Enumeration
ScrewTurn Wiki ► ScrewTurn.Wiki ► ChangeModerationMode
Lists legal page change moderation mode values.
Declaration Syntax
C# Visual Basic Visual C++
public enum ChangeModerationMode
Public Enumeration ChangeModerationMode
public enum class ChangeModerationMode
Members
Member | Description
None | Page change moderation is disabled.
RequirePageEditingPermissions | Anyone who has page editing permissoins but not page management permissions can edit pages, but the changes are held in moderation.
RequirePageViewingPermissions | Anyone who has page viewing permissions can edit pages, but the changes are held in moderation.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


Collectors Class

Collectors Class
ScrewTurn Wiki ► ScrewTurn.Wiki ► Collectors
Contains instances of the Providers Collectors.
Declaration Syntax
C# Visual Basic Visual C++
public static class Collectors
Public NotInheritable Class Collectors
public ref class Collectors abstract sealed
Members
All Members | Methods | Fields
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | CacheProviderCollector | The Cache Provider Collector instance.
 | DisabledCacheProviderCollector | The Disabled Cache Provider Collector instance.
 | DisabledFilesProviderCollector | The Disabled Files Provider Collector instance.
 | DisabledFormatterProviderCollector | The Disabled Formatter Provider Collector instance.
 | DisabledPagesProviderCollector | The Disabled Pages Provider Collector instance.
 | DisabledUsersProviderCollector | The Disabled Users Provider Collector instance.
 | FileNames | Contains the file names of the DLLs containing each provider (provider->file).
 | FilesProviderCollector | The Files Provider Collector instance.
 | FindProvider(String, Boolean%, Boolean%) | Finds a provider.
 | FormatterProviderCollector | The Formatter Provider Collector instance.
 | GetAllProviders()()() | Gets the names of all known providers, both enabled and disabled.
 | PagesProviderCollector | The Pages Provider Collector instance.
 | SettingsProvider | The settings storage provider.
 | TryDisable(String) | Tries to disable a provider.
 | TryEnable(String) | Tries to enable a provider.
 | TryUnload(String) | Tries to unload a provider.
 | UsersProviderCollector | The Users Provider Collector instance.
Inheritance Hierarchy
Object
Collectors

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


CacheProviderCollector Field

CacheProviderCollector Field
ScrewTurn Wiki ► ScrewTurn.Wiki ► Collectors ► CacheProviderCollector
The Cache Provider Collector instance.
Declaration Syntax
C# Visual Basic Visual C++
public static ProviderCollector<ICacheProviderV30> CacheProviderCollector
Public Shared CacheProviderCollector As ProviderCollector(Of ICacheProviderV30)
public:
static ProviderCollector<ICacheProviderV30^>^ CacheProviderCollector

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


DisabledCacheProviderCollector Field

DisabledCacheProviderCollector Field
ScrewTurn Wiki ► ScrewTurn.Wiki ► Collectors ► DisabledCacheProviderCollector
The Disabled Cache Provider Collector instance.
Declaration Syntax
C# Visual Basic Visual C++
public static ProviderCollector<ICacheProviderV30> DisabledCacheProviderCollector
Public Shared DisabledCacheProviderCollector As ProviderCollector(Of ICacheProviderV30)
public:
static ProviderCollector<ICacheProviderV30^>^ DisabledCacheProviderCollector

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


DisabledFilesProviderCollector Field

DisabledFilesProviderCollector Field
ScrewTurn Wiki ► ScrewTurn.Wiki ► Collectors ► DisabledFilesProviderCollector
The Disabled Files Provider Collector instance.
Declaration Syntax
C# Visual Basic Visual C++
public static ProviderCollector<IFilesStorageProviderV30> DisabledFilesProviderCollector
Public Shared DisabledFilesProviderCollector As ProviderCollector(Of IFilesStorageProviderV30)
public:
static ProviderCollector<IFilesStorageProviderV30^>^ DisabledFilesProviderCollector

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


DisabledFormatterProviderCollector Field

DisabledFormatterProviderCollector Field
ScrewTurn Wiki ► ScrewTurn.Wiki ► Collectors ► DisabledFormatterProviderCollector
The Disabled Formatter Provider Collector instance.
Declaration Syntax
C# Visual Basic Visual C++
public static ProviderCollector<IFormatterProviderV30> DisabledFormatterProviderCollector
Public Shared DisabledFormatterProviderCollector As ProviderCollector(Of IFormatterProviderV30)
public:
static ProviderCollector<IFormatterProviderV30^>^ DisabledFormatterProviderCollector

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


DisabledPagesProviderCollector Field

DisabledPagesProviderCollector Field
ScrewTurn Wiki ► ScrewTurn.Wiki ► Collectors ► DisabledPagesProviderCollector
The Disabled Pages Provider Collector instance.
Declaration Syntax
C# Visual Basic Visual C++
public static ProviderCollector<IPagesStorageProviderV30> DisabledPagesProviderCollector
Public Shared DisabledPagesProviderCollector As ProviderCollector(Of IPagesStorageProviderV30)
public:
static ProviderCollector<IPagesStorageProviderV30^>^ DisabledPagesProviderCollector

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


DisabledUsersProviderCollector Field

DisabledUsersProviderCollector Field
ScrewTurn Wiki ► ScrewTurn.Wiki ► Collectors ► DisabledUsersProviderCollector
The Disabled Users Provider Collector instance.
Declaration Syntax
C# Visual Basic Visual C++
public static ProviderCollector<IUsersStorageProviderV30> DisabledUsersProviderCollector
Public Shared DisabledUsersProviderCollector As ProviderCollector(Of IUsersStorageProviderV30)
public:
static ProviderCollector<IUsersStorageProviderV30^>^ DisabledUsersProviderCollector

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


FileNames Field

FileNames Field
ScrewTurn Wiki ► ScrewTurn.Wiki ► Collectors ► FileNames
Contains the file names of the DLLs containing each provider (provider->file).
Declaration Syntax
C# Visual Basic Visual C++
public static Dictionary<string, string> FileNames
Public Shared FileNames As Dictionary(Of String, String)
public:
static Dictionary<String^, String^>^ FileNames

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


FilesProviderCollector Field

FilesProviderCollector Field
ScrewTurn Wiki ► ScrewTurn.Wiki ► Collectors ► FilesProviderCollector
The Files Provider Collector instance.
Declaration Syntax
C# Visual Basic Visual C++
public static ProviderCollector<IFilesStorageProviderV30> FilesProviderCollector
Public Shared FilesProviderCollector As ProviderCollector(Of IFilesStorageProviderV30)
public:
static ProviderCollector<IFilesStorageProviderV30^>^ FilesProviderCollector

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


FindProvider Method (typeName, enabled, canDisable)

FindProvider Method (typeName, enabled, canDisable)
ScrewTurn Wiki ► ScrewTurn.Wiki ► Collectors ► FindProvider(String, Boolean%, Boolean%)
Finds a provider.
Declaration Syntax
C# Visual Basic Visual C++
public static IProviderV30 FindProvider(
    string typeName,
    out bool enabled,
    out bool canDisable
)
Public Shared Function FindProvider ( _
    typeName As String, _
    <OutAttribute> ByRef enabled As Boolean, _
    <OutAttribute> ByRef canDisable As Boolean _
) As IProviderV30
public:
static IProviderV30^ FindProvider(
    String^ typeName,
    [OutAttribute] bool% enabled,
    [OutAttribute] bool% canDisable
)
Parameters
typeName (String)
The provider type name.
enabled ( Boolean %)
A value indicating whether the provider is enabled.
canDisable ( Boolean %)
A value indicating whether the provider can be disabled.
Return Value
The provider, or null.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


FormatterProviderCollector Field

FormatterProviderCollector Field
ScrewTurn Wiki ► ScrewTurn.Wiki ► Collectors ► FormatterProviderCollector
The Formatter Provider Collector instance.
Declaration Syntax
C# Visual Basic Visual C++
public static ProviderCollector<IFormatterProviderV30> FormatterProviderCollector
Public Shared FormatterProviderCollector As ProviderCollector(Of IFormatterProviderV30)
public:
static ProviderCollector<IFormatterProviderV30^>^ FormatterProviderCollector

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


GetAllProviders Method

GetAllProviders Method
ScrewTurn Wiki ► ScrewTurn.Wiki ► Collectors ► GetAllProviders()()()
Gets the names of all known providers, both enabled and disabled.
Declaration Syntax
C# Visual Basic Visual C++
public static string[] GetAllProviders()
Public Shared Function GetAllProviders As String()
public:
static array<String^>^ GetAllProviders()
Return Value
The names of the known providers.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


PagesProviderCollector Field

PagesProviderCollector Field
ScrewTurn Wiki ► ScrewTurn.Wiki ► Collectors ► PagesProviderCollector
The Pages Provider Collector instance.
Declaration Syntax
C# Visual Basic Visual C++
public static ProviderCollector<IPagesStorageProviderV30> PagesProviderCollector
Public Shared PagesProviderCollector As ProviderCollector(Of IPagesStorageProviderV30)
public:
static ProviderCollector<IPagesStorageProviderV30^>^ PagesProviderCollector

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


SettingsProvider Field

SettingsProvider Field
ScrewTurn Wiki ► ScrewTurn.Wiki ► Collectors ► SettingsProvider
The settings storage provider.
Declaration Syntax
C# Visual Basic Visual C++
public static ISettingsStorageProviderV30 SettingsProvider
Public Shared SettingsProvider As ISettingsStorageProviderV30
public:
static ISettingsStorageProviderV30^ SettingsProvider

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


TryDisable Method (typeName)

TryDisable Method (typeName)
ScrewTurn Wiki ► ScrewTurn.Wiki ► Collectors ► TryDisable(String)
Tries to disable a provider.
Declaration Syntax
C# Visual Basic Visual C++
public static void TryDisable(
    string typeName
)
Public Shared Sub TryDisable ( _
    typeName As String _
)
public:
static void TryDisable(
    String^ typeName
)
Parameters
typeName (String)
The provider.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


TryEnable Method (typeName)

TryEnable Method (typeName)
ScrewTurn Wiki ► ScrewTurn.Wiki ► Collectors ► TryEnable(String)
Tries to enable a provider.
Declaration Syntax
C# Visual Basic Visual C++
public static void TryEnable(
    string typeName
)
Public Shared Sub TryEnable ( _
    typeName As String _
)
public:
static void TryEnable(
    String^ typeName
)
Parameters
typeName (String)
The provider.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


TryUnload Method (typeName)

TryUnload Method (typeName)
ScrewTurn Wiki ► ScrewTurn.Wiki ► Collectors ► TryUnload(String)
Tries to unload a provider.
Declaration Syntax
C# Visual Basic Visual C++
public static void TryUnload(
    string typeName
)
Public Shared Sub TryUnload ( _
    typeName As String _
)
public:
static void TryUnload(
    String^ typeName
)
Parameters
typeName (String)
The provider.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


UsersProviderCollector Field

UsersProviderCollector Field
ScrewTurn Wiki ► ScrewTurn.Wiki ► Collectors ► UsersProviderCollector
The Users Provider Collector instance.
Declaration Syntax
C# Visual Basic Visual C++
public static ProviderCollector<IUsersStorageProviderV30> UsersProviderCollector
Public Shared UsersProviderCollector As ProviderCollector(Of IUsersStorageProviderV30)
public:
static ProviderCollector<IUsersStorageProviderV30^>^ UsersProviderCollector

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


Collisions Class

Collisions Class
ScrewTurn Wiki ► ScrewTurn.Wiki ► Collisions
Manages Page Editing collisions.
Declaration Syntax
C# Visual Basic Visual C++
public static class Collisions
Public NotInheritable Class Collisions
public ref class Collisions abstract sealed
Members
All Members | Methods | Fields
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | CancelEditingSession(PageInfo, String) | Cancels an editing session.
 | EditingSessionTimeout | The refresh interval used for renewing the sessions.
 | IsPageBeingEdited(PageInfo, String) | Finds whether a Page is being edited by a different user.
 | RenewEditingSession(PageInfo, String) | Adds or updates an editing session.
 | WhosEditing(PageInfo) | Gets the username of the user who's editing a page.
Inheritance Hierarchy
Object
Collisions

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


CancelEditingSession Method (page, user)

CancelEditingSession Method (page, user)
ScrewTurn Wiki ► ScrewTurn.Wiki ► Collisions ► CancelEditingSession(PageInfo, String)
Cancels an editing session.
Declaration Syntax
C# Visual Basic Visual C++
public static void CancelEditingSession(
    PageInfo page,
    string user
)
Public Shared Sub CancelEditingSession ( _
    page As PageInfo, _
    user As String _
)
public:
static void CancelEditingSession(
    PageInfo^ page,
    String^ user
)
Parameters
page (PageInfo)
The Page.
user (String)
The User.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


EditingSessionTimeout Field

EditingSessionTimeout Field
ScrewTurn Wiki ► ScrewTurn.Wiki ► Collisions ► EditingSessionTimeout
The refresh interval used for renewing the sessions.
Declaration Syntax
C# Visual Basic Visual C++
public const int EditingSessionTimeout
Public Const EditingSessionTimeout As Integer
public:
literal int EditingSessionTimeout

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


IsPageBeingEdited Method (page, currentUser)

IsPageBeingEdited Method (page, currentUser)
ScrewTurn Wiki ► ScrewTurn.Wiki ► Collisions ► IsPageBeingEdited(PageInfo, String)
Finds whether a Page is being edited by a different user.
Declaration Syntax
C# Visual Basic Visual C++
public static bool IsPageBeingEdited(
    PageInfo page,
    string currentUser
)
Public Shared Function IsPageBeingEdited ( _
    page As PageInfo, _
    currentUser As String _
) As Boolean
public:
static bool IsPageBeingEdited(
    PageInfo^ page,
    String^ currentUser
)
Parameters
page (PageInfo)
The Page.
currentUser (String)
The User who is requesting the status of the Page.
Return Value
True if the Page is being edited by another User.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


RenewEditingSession Method (page, user)

RenewEditingSession Method (page, user)
ScrewTurn Wiki ► ScrewTurn.Wiki ► Collisions ► RenewEditingSession(PageInfo, String)
Adds or updates an editing session.
Declaration Syntax
C# Visual Basic Visual C++
public static void RenewEditingSession(
    PageInfo page,
    string user
)
Public Shared Sub RenewEditingSession ( _
    page As PageInfo, _
    user As String _
)
public:
static void RenewEditingSession(
    PageInfo^ page,
    String^ user
)
Parameters
page (PageInfo)
The edited Page.
user (String)
The User who is editing the Page.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


WhosEditing Method (page)

WhosEditing Method (page)
ScrewTurn Wiki ► ScrewTurn.Wiki ► Collisions ► WhosEditing(PageInfo)
Gets the username of the user who's editing a page.
Declaration Syntax
C# Visual Basic Visual C++
public static string WhosEditing(
    PageInfo page
)
Public Shared Function WhosEditing ( _
    page As PageInfo _
) As String
public:
static String^ WhosEditing(
    PageInfo^ page
)
Parameters
page (PageInfo)
The page.
Return Value
The username.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


Content Class

Content Class
ScrewTurn Wiki ► ScrewTurn.Wiki ► Content
Contains the Contents.
Declaration Syntax
C# Visual Basic Visual C++
public static class Content
Public NotInheritable Class Content
public ref class Content abstract sealed
Members
All Members | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | ClearPseudoCache()()() | Clears the pseudo cache.
 | GetFormattedPageContent(PageInfo, Boolean) | Gets the formatted Page Content, properly handling content caching and the Formatting Pipeline.
 | GetPageContent(PageInfo, Boolean) | Reads the Content of a Page.
 | GetPseudoCacheValue(String) | Gets a pseudo cache item value.
 | InvalidateAllPages()()() | Invalidates all the cache Contents.
 | InvalidatePage(PageInfo) | Invalidates the cached Content of a Page.
 | SetPseudoCacheValue(String, String) | Sets a pseudo cache item value, only if the content cache is enabled.
Inheritance Hierarchy
Object
Content

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


ClearPseudoCache Method

ClearPseudoCache Method
ScrewTurn Wiki ► ScrewTurn.Wiki ► Content ► ClearPseudoCache()()()
Clears the pseudo cache.
Declaration Syntax
C# Visual Basic Visual C++
public static void ClearPseudoCache()
Public Shared Sub ClearPseudoCache
public:
static void ClearPseudoCache()

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


GetFormattedPageContent Method (page, cached)

GetFormattedPageContent Method (page, cached)
ScrewTurn Wiki ► ScrewTurn.Wiki ► Content ► GetFormattedPageContent(PageInfo, Boolean)
Gets the formatted Page Content, properly handling content caching and the Formatting Pipeline.
Declaration Syntax
C# Visual Basic Visual C++
public static string GetFormattedPageContent(
    PageInfo page,
    bool cached
)
Public Shared Function GetFormattedPageContent ( _
    page As PageInfo, _
    cached As Boolean _
) As String
public:
static String^ GetFormattedPageContent(
    PageInfo^ page,
    bool cached
)
Parameters
page (PageInfo)
The Page to get the formatted Content of.
cached (Boolean)
Specifies whether the formatted content has to be cached or not.
Return Value
The formatted content.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


GetPageContent Method (pageInfo, cached)

GetPageContent Method (pageInfo, cached)
ScrewTurn Wiki ► ScrewTurn.Wiki ► Content ► GetPageContent(PageInfo, Boolean)
Reads the Content of a Page.
Declaration Syntax
C# Visual Basic Visual C++
public static PageContent GetPageContent(
    PageInfo pageInfo,
    bool cached
)
Public Shared Function GetPageContent ( _
    pageInfo As PageInfo, _
    cached As Boolean _
) As PageContent
public:
static PageContent^ GetPageContent(
    PageInfo^ pageInfo,
    bool cached
)
Parameters
pageInfo (PageInfo)
The Page.
cached (Boolean)
Specifies whether the page has to be cached or not.
Return Value
The Page Content.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


GetPseudoCacheValue Method (name)

GetPseudoCacheValue Method (name)
ScrewTurn Wiki ► ScrewTurn.Wiki ► Content ► GetPseudoCacheValue(String)
Gets a pseudo cache item value.
Declaration Syntax
C# Visual Basic Visual C++
public static string GetPseudoCacheValue(
    string name
)
Public Shared Function GetPseudoCacheValue ( _
    name As String _
) As String
public:
static String^ GetPseudoCacheValue(
    String^ name
)
Parameters
name (String)
The name of the item to retrieve the value of.
Return Value
The value of the item, or null.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


InvalidateAllPages Method

InvalidateAllPages Method
ScrewTurn Wiki ► ScrewTurn.Wiki ► Content ► InvalidateAllPages()()()
Invalidates all the cache Contents.
Declaration Syntax
C# Visual Basic Visual C++
public static void InvalidateAllPages()
Public Shared Sub InvalidateAllPages
public:
static void InvalidateAllPages()

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


InvalidatePage Method (pageInfo)

InvalidatePage Method (pageInfo)
ScrewTurn Wiki ► ScrewTurn.Wiki ► Content ► InvalidatePage(PageInfo)
Invalidates the cached Content of a Page.
Declaration Syntax
C# Visual Basic Visual C++
public static void InvalidatePage(
    PageInfo pageInfo
)
Public Shared Sub InvalidatePage ( _
    pageInfo As PageInfo _
)
public:
static void InvalidatePage(
    PageInfo^ pageInfo
)
Parameters
pageInfo (PageInfo)
The Page to invalidate the cached content of.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


SetPseudoCacheValue Method (name, value)

SetPseudoCacheValue Method (name, value)
ScrewTurn Wiki ► ScrewTurn.Wiki ► Content ► SetPseudoCacheValue(String, String)
Sets a pseudo cache item value, only if the content cache is enabled.
Declaration Syntax
C# Visual Basic Visual C++
public static void SetPseudoCacheValue(
    string name,
    string value
)
Public Shared Sub SetPseudoCacheValue ( _
    name As String, _
    value As String _
)
public:
static void SetPseudoCacheValue(
    String^ name,
    String^ value
)
Parameters
name (String)
The name of the item to store the value of.
value (String)
The value of the item.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


CustomToolbarItem Class

CustomToolbarItem Class
ScrewTurn Wiki ► ScrewTurn.Wiki ► CustomToolbarItem
Represents a custom toolbar item.
Declaration Syntax
C# Visual Basic Visual C++
public class CustomToolbarItem
Public Class CustomToolbarItem
public ref class CustomToolbarItem
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | CustomToolbarItem(ToolbarItem, String, String) | Initializes a new instance of the ToolbarItem class.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | Item | Gets or sets the item.
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Text | Gets the text.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | Value | Gets or sets the value.
Inheritance Hierarchy
Object
CustomToolbarItem

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


CustomToolbarItem Constructor (item, text, value)

CustomToolbarItem Constructor (item, text, value)
ScrewTurn Wiki ► ScrewTurn.Wiki ► CustomToolbarItem ► CustomToolbarItem(ToolbarItem, String, String)
Initializes a new instance of the ToolbarItem class.
Declaration Syntax
C# Visual Basic Visual C++
public CustomToolbarItem(
    ToolbarItem item,
    string text,
    string value
)
Public Sub New ( _
    item As ToolbarItem, _
    text As String, _
    value As String _
)
public:
CustomToolbarItem(
    ToolbarItem item,
    String^ text,
    String^ value
)
Parameters
item (ToolbarItem)
The item.
text (String)
The text.
value (String)
The value.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


Item Property

Item Property
ScrewTurn Wiki ► ScrewTurn.Wiki ► CustomToolbarItem ► Item
Gets or sets the item.
Declaration Syntax
C# Visual Basic Visual C++
public ToolbarItem Item { get; set; }
Public Property Item As ToolbarItem
public:
property ToolbarItem Item {
    ToolbarItem get ();
    void set (ToolbarItem value);
}

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


Text Property

Text Property
ScrewTurn Wiki ► ScrewTurn.Wiki ► CustomToolbarItem ► Text
Gets the text.
Declaration Syntax
C# Visual Basic Visual C++
public string Text { get; }
Public ReadOnly Property Text As String
public:
property String^ Text {
    String^ get ();
}

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


Value Property

Value Property
ScrewTurn Wiki ► ScrewTurn.Wiki ► CustomToolbarItem ► Value
Gets or sets the value.
Declaration Syntax
C# Visual Basic Visual C++
public string Value { get; set; }
Public Property Value As String
public:
property String^ Value {
    String^ get ();
    void set (String^ value);
}

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


DataMigrator Class

DataMigrator Class
ScrewTurn Wiki ► ScrewTurn.Wiki ► DataMigrator
Provides methods for migrating data from a Provider to another.
Declaration Syntax
C# Visual Basic Visual C++
public static class DataMigrator
Public NotInheritable Class DataMigrator
public ref class DataMigrator abstract sealed
Members
All Members | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | CopySettingsStorageProviderData(ISettingsStorageProviderV30, ISettingsStorageProviderV30, array<String>[]()[], array<String>[]()[]) | Copies the settings from a Provider to another.
 | MigrateFilesStorageProviderData(IFilesStorageProviderV30, IFilesStorageProviderV30, ISettingsStorageProviderV30) | Migrates all the stored files and page attachments from a Provider to another.
 | MigratePagesStorageProviderData(IPagesStorageProviderV30, IPagesStorageProviderV30) | Migrates all the data from a Pages Provider to another one.
 | MigrateUsersStorageProviderData(IUsersStorageProviderV30, IUsersStorageProviderV30, Boolean) | Migrates all the User Accounts from a Provider to another.
Inheritance Hierarchy
Object
DataMigrator

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


CopySettingsStorageProviderData Method (source, destination, knownNamespaces, knownPlugins)

CopySettingsStorageProviderData Method (source, destination, knownNamespaces, knownPlugins)
ScrewTurn Wiki ► ScrewTurn.Wiki ► DataMigrator ► CopySettingsStorageProviderData(ISettingsStorageProviderV30, ISettingsStorageProviderV30, array<String>[]()[], array<String>[]()[])
Copies the settings from a Provider to another.
Declaration Syntax
C# Visual Basic Visual C++
public static void CopySettingsStorageProviderData(
    ISettingsStorageProviderV30 source,
    ISettingsStorageProviderV30 destination,
    string[] knownNamespaces,
    string[] knownPlugins
)
Public Shared Sub CopySettingsStorageProviderData ( _
    source As ISettingsStorageProviderV30, _
    destination As ISettingsStorageProviderV30, _
    knownNamespaces As String(), _
    knownPlugins As String() _
)
public:
static void CopySettingsStorageProviderData(
    ISettingsStorageProviderV30^ source,
    ISettingsStorageProviderV30^ destination,
    array<String^>^ knownNamespaces,
    array<String^>^ knownPlugins
)
Parameters
source (ISettingsStorageProviderV30)
The source Provider.
destination (ISettingsStorageProviderV30)
The destination Provider.
knownNamespaces (array< String >[]()[][])
The currently known page namespaces.
knownPlugins (array< String >[]()[][])
The currently known plugins.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


MigrateFilesStorageProviderData Method (source, destination, settingsProvider)

MigrateFilesStorageProviderData Method (source, destination, settingsProvider)
ScrewTurn Wiki ► ScrewTurn.Wiki ► DataMigrator ► MigrateFilesStorageProviderData(IFilesStorageProviderV30, IFilesStorageProviderV30, ISettingsStorageProviderV30)
Migrates all the stored files and page attachments from a Provider to another.
Declaration Syntax
C# Visual Basic Visual C++
public static void MigrateFilesStorageProviderData(
    IFilesStorageProviderV30 source,
    IFilesStorageProviderV30 destination,
    ISettingsStorageProviderV30 settingsProvider
)
Public Shared Sub MigrateFilesStorageProviderData ( _
    source As IFilesStorageProviderV30, _
    destination As IFilesStorageProviderV30, _
    settingsProvider As ISettingsStorageProviderV30 _
)
public:
static void MigrateFilesStorageProviderData(
    IFilesStorageProviderV30^ source,
    IFilesStorageProviderV30^ destination,
    ISettingsStorageProviderV30^ settingsProvider
)
Parameters
source (IFilesStorageProviderV30)
The source Provider.
destination (IFilesStorageProviderV30)
The destination Provider.
settingsProvider (ISettingsStorageProviderV30)
The settings storage provider that handles permissions.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


MigratePagesStorageProviderData Method (source, destination)

MigratePagesStorageProviderData Method (source, destination)
ScrewTurn Wiki ► ScrewTurn.Wiki ► DataMigrator ► MigratePagesStorageProviderData(IPagesStorageProviderV30, IPagesStorageProviderV30)
Migrates all the data from a Pages Provider to another one.
Declaration Syntax
C# Visual Basic Visual C++
public static void MigratePagesStorageProviderData(
    IPagesStorageProviderV30 source,
    IPagesStorageProviderV30 destination
)
Public Shared Sub MigratePagesStorageProviderData ( _
    source As IPagesStorageProviderV30, _
    destination As IPagesStorageProviderV30 _
)
public:
static void MigratePagesStorageProviderData(
    IPagesStorageProviderV30^ source,
    IPagesStorageProviderV30^ destination
)
Parameters
source (IPagesStorageProviderV30)
The source Provider.
destination (IPagesStorageProviderV30)
The destination Provider.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


MigrateUsersStorageProviderData Method (source, destination, sendEmailNotification)

MigrateUsersStorageProviderData Method (source, destination, sendEmailNotification)
ScrewTurn Wiki ► ScrewTurn.Wiki ► DataMigrator ► MigrateUsersStorageProviderData(IUsersStorageProviderV30, IUsersStorageProviderV30, Boolean)
Migrates all the User Accounts from a Provider to another.
Declaration Syntax
C# Visual Basic Visual C++
public static void MigrateUsersStorageProviderData(
    IUsersStorageProviderV30 source,
    IUsersStorageProviderV30 destination,
    bool sendEmailNotification
)
Public Shared Sub MigrateUsersStorageProviderData ( _
    source As IUsersStorageProviderV30, _
    destination As IUsersStorageProviderV30, _
    sendEmailNotification As Boolean _
)
public:
static void MigrateUsersStorageProviderData(
    IUsersStorageProviderV30^ source,
    IUsersStorageProviderV30^ destination,
    bool sendEmailNotification
)
Parameters
source (IUsersStorageProviderV30)
The source Provider.
destination (IUsersStorageProviderV30)
The destination Provider.
sendEmailNotification (Boolean)
A value indicating whether or not to send a notification email message to the moved users.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


Defaults Class

Defaults Class
ScrewTurn Wiki ► ScrewTurn.Wiki ► Defaults
Contains default values.
Declaration Syntax
C# Visual Basic Visual C++
public static class Defaults
Public NotInheritable Class Defaults
public ref class Defaults abstract sealed
Members
All Members | Fields
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | AccountActivationMessageContent | The default content of the account activation message.
 | ApproveDraftMessage | The default content of the approve draft email message.
 | DiscussionChangeMessage | The default content of the discussion change email message.
 | EditNoticeContent | The default content of the edit notice.
 | FooterContent | The default content of the footer.
 | HeaderContent | The default content of the header.
 | MainPageContent | The default content of the main page.
 | MainPageContentForSubNamespace | The default content of the main page of a sub-namespace.
 | PageChangeMessage | The default content of the page change email message.
 | PasswordResetProcedureMessageContent | The default content of the password reset message.
 | SidebarContent | The default content of the sidebar.
 | SidebarContentForSubNamespace | The default content of the sidebar of a sub-namespace.
Inheritance Hierarchy
Object
Defaults

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


AccountActivationMessageContent Field

AccountActivationMessageContent Field
ScrewTurn Wiki ► ScrewTurn.Wiki ► Defaults ► AccountActivationMessageContent
The default content of the account activation message.
Declaration Syntax
C# Visual Basic Visual C++
public const string AccountActivationMessageContent
Public Const AccountActivationMessageContent As String
public:
literal String^ AccountActivationMessageContent

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


ApproveDraftMessage Field

ApproveDraftMessage Field
ScrewTurn Wiki ► ScrewTurn.Wiki ► Defaults ► ApproveDraftMessage
The default content of the approve draft email message.
Declaration Syntax
C# Visual Basic Visual C++
public const string ApproveDraftMessage
Public Const ApproveDraftMessage As String
public:
literal String^ ApproveDraftMessage

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


DiscussionChangeMessage Field

DiscussionChangeMessage Field
ScrewTurn Wiki ► ScrewTurn.Wiki ► Defaults ► DiscussionChangeMessage
The default content of the discussion change email message.
Declaration Syntax
C# Visual Basic Visual C++
public const string DiscussionChangeMessage
Public Const DiscussionChangeMessage As String
public:
literal String^ DiscussionChangeMessage

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


EditNoticeContent Field

EditNoticeContent Field
ScrewTurn Wiki ► ScrewTurn.Wiki ► Defaults ► EditNoticeContent
The default content of the edit notice.
Declaration Syntax
C# Visual Basic Visual C++
public const string EditNoticeContent
Public Const EditNoticeContent As String
public:
literal String^ EditNoticeContent

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


FooterContent Field

FooterContent Field
ScrewTurn Wiki ► ScrewTurn.Wiki ► Defaults ► FooterContent
The default content of the footer.
Declaration Syntax
C# Visual Basic Visual C++
public const string FooterContent
Public Const FooterContent As String
public:
literal String^ FooterContent

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


HeaderContent Field

HeaderContent Field
ScrewTurn Wiki ► ScrewTurn.Wiki ► Defaults ► HeaderContent
The default content of the header.
Declaration Syntax
C# Visual Basic Visual C++
public const string HeaderContent
Public Const HeaderContent As String
public:
literal String^ HeaderContent

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


MainPageContent Field

MainPageContent Field
ScrewTurn Wiki ► ScrewTurn.Wiki ► Defaults ► MainPageContent
The default content of the main page.
Declaration Syntax
C# Visual Basic Visual C++
public const string MainPageContent
Public Const MainPageContent As String
public:
literal String^ MainPageContent

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


MainPageContentForSubNamespace Field

MainPageContentForSubNamespace Field
ScrewTurn Wiki ► ScrewTurn.Wiki ► Defaults ► MainPageContentForSubNamespace
The default content of the main page of a sub-namespace.
Declaration Syntax
C# Visual Basic Visual C++
public const string MainPageContentForSubNamespace
Public Const MainPageContentForSubNamespace As String
public:
literal String^ MainPageContentForSubNamespace

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


PageChangeMessage Field

PageChangeMessage Field
ScrewTurn Wiki ► ScrewTurn.Wiki ► Defaults ► PageChangeMessage
The default content of the page change email message.
Declaration Syntax
C# Visual Basic Visual C++
public const string PageChangeMessage
Public Const PageChangeMessage As String
public:
literal String^ PageChangeMessage

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


PasswordResetProcedureMessageContent Field

PasswordResetProcedureMessageContent Field
ScrewTurn Wiki ► ScrewTurn.Wiki ► Defaults ► PasswordResetProcedureMessageContent
The default content of the password reset message.
Declaration Syntax
C# Visual Basic Visual C++
public const string PasswordResetProcedureMessageContent
Public Const PasswordResetProcedureMessageContent As String
public:
literal String^ PasswordResetProcedureMessageContent

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


SidebarContent Field

SidebarContent Field
ScrewTurn Wiki ► ScrewTurn.Wiki ► Defaults ► SidebarContent
The default content of the sidebar.
Declaration Syntax
C# Visual Basic Visual C++
public const string SidebarContent
Public Const SidebarContent As String
public:
literal String^ SidebarContent

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


SidebarContentForSubNamespace Field

SidebarContentForSubNamespace Field
ScrewTurn Wiki ► ScrewTurn.Wiki ► Defaults ► SidebarContentForSubNamespace
The default content of the sidebar of a sub-namespace.
Declaration Syntax
C# Visual Basic Visual C++
public const string SidebarContentForSubNamespace
Public Const SidebarContentForSubNamespace As String
public:
literal String^ SidebarContentForSubNamespace

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


Difference Class

Difference Class
ScrewTurn Wiki ► ScrewTurn.Wiki ► Difference
O(ND) Difference Algorithm for C# Created by Matthias Hertel, see http://www.mathertel.de This work is licensed under a Creative Commons Attribution 2.0 Germany License. see http://creativecommons.org/licenses/by/2.0/de/
Declaration Syntax
C# Visual Basic Visual C++
public class Difference
Public Class Difference
public ref class Difference
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | Difference()()() | Initializes a new instance of the Difference class
 | DiffInt(array<Int32>[]()[], array<Int32>[]()[]) | Find the difference in 2 arrays of integers.
 | DiffText(String, String) | Find the difference in 2 texts, comparing by textlines.
 | DiffText(String, String, Boolean, Boolean, Boolean) | Find the difference in 2 text documents, comparing by textlines. The algorithm itself is comparing 2 arrays of numbers so when comparing 2 text documents each line is converted into a (hash) number. This hash-value is computed by storing all textlines into a common hashtable so i can find dublicates in there, and generating a new number each time a new textline is inserted.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
Difference

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


Difference Constructor

Difference Constructor
ScrewTurn Wiki ► ScrewTurn.Wiki ► Difference ► Difference()()()
Initializes a new instance of the Difference class
Declaration Syntax
C# Visual Basic Visual C++
public Difference()
Public Sub New
public:
Difference()

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


DiffInt Method (ArrayA, ArrayB)

DiffInt Method (ArrayA, ArrayB)
ScrewTurn Wiki ► ScrewTurn.Wiki ► Difference ► DiffInt(array<Int32>[]()[], array<Int32>[]()[])
Find the difference in 2 arrays of integers.
Declaration Syntax
C# Visual Basic Visual C++
public static Difference..::.Item[] DiffInt(
    int[] ArrayA,
    int[] ArrayB
)
Public Shared Function DiffInt ( _
    ArrayA As Integer(), _
    ArrayB As Integer() _
) As Difference..::.Item()
public:
static array<Difference..::.Item>^ DiffInt(
    array<int>^ ArrayA,
    array<int>^ ArrayB
)
Parameters
ArrayA (array< Int32 >[]()[][])
A-version of the numbers (usualy the old one)
ArrayB (array< Int32 >[]()[][])
B-version of the numbers (usualy the new one)
Return Value
Returns a array of Items that describe the differences.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


DiffText Method

DiffText Method
ScrewTurn Wiki ► ScrewTurn.Wiki ► Difference ► DiffText()()()
Members
Icon | Member | Description
 | DiffText(String, String) | Find the difference in 2 texts, comparing by textlines.
 | DiffText(String, String, Boolean, Boolean, Boolean) | Find the difference in 2 text documents, comparing by textlines. The algorithm itself is comparing 2 arrays of numbers so when comparing 2 text documents each line is converted into a (hash) number. This hash-value is computed by storing all textlines into a common hashtable so i can find dublicates in there, and generating a new number each time a new textline is inserted.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


DiffText Method (TextA, TextB)

DiffText Method (TextA, TextB)
ScrewTurn Wiki ► ScrewTurn.Wiki ► Difference ► DiffText(String, String)
Find the difference in 2 texts, comparing by textlines.
Declaration Syntax
C# Visual Basic Visual C++
public Difference..::.Item[] DiffText(
    string TextA,
    string TextB
)
Public Function DiffText ( _
    TextA As String, _
    TextB As String _
) As Difference..::.Item()
public:
array<Difference..::.Item>^ DiffText(
    String^ TextA,
    String^ TextB
)
Parameters
TextA (String)
A-version of the text (usualy the old one)
TextB (String)
B-version of the text (usualy the new one)
Return Value
Returns a array of Items that describe the differences.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


DiffText Method (TextA, TextB, trimSpace, ignoreSpace, ignoreCase)

DiffText Method (TextA, TextB, trimSpace, ignoreSpace, ignoreCase)
ScrewTurn Wiki ► ScrewTurn.Wiki ► Difference ► DiffText(String, String, Boolean, Boolean, Boolean)
Find the difference in 2 text documents, comparing by textlines. The algorithm itself is comparing 2 arrays of numbers so when comparing 2 text documents each line is converted into a (hash) number. This hash-value is computed by storing all textlines into a common hashtable so i can find dublicates in there, and generating a new number each time a new textline is inserted.
Declaration Syntax
C# Visual Basic Visual C++
public static Difference..::.Item[] DiffText(
    string TextA,
    string TextB,
    bool trimSpace,
    bool ignoreSpace,
    bool ignoreCase
)
Public Shared Function DiffText ( _
    TextA As String, _
    TextB As String, _
    trimSpace As Boolean, _
    ignoreSpace As Boolean, _
    ignoreCase As Boolean _
) As Difference..::.Item()
public:
static array<Difference..::.Item>^ DiffText(
    String^ TextA,
    String^ TextB,
    bool trimSpace,
    bool ignoreSpace,
    bool ignoreCase
)
Parameters
TextA (String)
A-version of the text (usualy the old one)
TextB (String)
B-version of the text (usualy the new one)
trimSpace (Boolean)
When set to true, all leading and trailing whitespace characters are stripped out before the comparation is done.
ignoreSpace (Boolean)
When set to true, all whitespace characters are converted to a single space character before the comparation is done.
ignoreCase (Boolean)
When set to true, all characters are converted to their lowercase equivivalence before the comparation is done.
Return Value
Returns a array of Items that describe the differences.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


Difference.Item Structure

Difference..::..Item Structure
ScrewTurn Wiki ► ScrewTurn.Wiki ► Difference ► Difference..::.Item
details of one difference.
Declaration Syntax
C# Visual Basic Visual C++
public struct Item
Public Structure Item
public value class Item
Members
All Members | Methods | Fields
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | deletedA | Number of changes in Data A.
 | Equals(Object) | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Returns the hash code for this instance. (Inherited from ValueType.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | insertedB | Number of changes in Data A.
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | StartA | Start Line number in Data A.
 | StartB | Start Line number in Data B.
 | ToString()()() | Returns the fully qualified type name of this instance. (Inherited from ValueType.)

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


deletedA Field

deletedA Field
ScrewTurn Wiki ► ScrewTurn.Wiki ► Difference..::.Item ► deletedA
Number of changes in Data A.
Declaration Syntax
C# Visual Basic Visual C++
public int deletedA
Public deletedA As Integer
public:
int deletedA

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


insertedB Field

insertedB Field
ScrewTurn Wiki ► ScrewTurn.Wiki ► Difference..::.Item ► insertedB
Number of changes in Data A.
Declaration Syntax
C# Visual Basic Visual C++
public int insertedB
Public insertedB As Integer
public:
int insertedB

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


StartA Field

StartA Field
ScrewTurn Wiki ► ScrewTurn.Wiki ► Difference..::.Item ► StartA
Start Line number in Data A.
Declaration Syntax
C# Visual Basic Visual C++
public int StartA
Public StartA As Integer
public:
int StartA

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


StartB Field

StartB Field
ScrewTurn Wiki ► ScrewTurn.Wiki ► Difference..::.Item ► StartB
Start Line number in Data B.
Declaration Syntax
C# Visual Basic Visual C++
public int StartB
Public StartB As Integer
public:
int StartB

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


DiffTools Class

DiffTools Class
ScrewTurn Wiki ► ScrewTurn.Wiki ► DiffTools
Provides methods for diffing text and items.
Declaration Syntax
C# Visual Basic Visual C++
public static class DiffTools
Public NotInheritable Class DiffTools
public ref class DiffTools abstract sealed
Members
All Members | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | DiffRevisions(String, String) | Computes the difference between two revisions.
Inheritance Hierarchy
Object
DiffTools

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


DiffRevisions Method (rev1, rev2)

DiffRevisions Method (rev1, rev2)
ScrewTurn Wiki ► ScrewTurn.Wiki ► DiffTools ► DiffRevisions(String, String)
Computes the difference between two revisions.
Declaration Syntax
C# Visual Basic Visual C++
public static string DiffRevisions(
    string rev1,
    string rev2
)
Public Shared Function DiffRevisions ( _
    rev1 As String, _
    rev2 As String _
) As String
public:
static String^ DiffRevisions(
    String^ rev1,
    String^ rev2
)
Parameters
rev1 (String)
The first revision.
rev2 (String)
The second revision.
Return Value
The XHTML-formatted result.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


EditingSession Class

EditingSession Class
ScrewTurn Wiki ► ScrewTurn.Wiki ► EditingSession
Represents an Editing Session.
Declaration Syntax
C# Visual Basic Visual C++
public class EditingSession
Public Class EditingSession
public ref class EditingSession
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | EditingSession(String, String) | Initializes a new instance of the EditingSession class.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | LastContact | Gets the Last Contact Date/Time.
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Page | Gets the edited Page.
 | Renew()()() | Sets the Last Contact to now.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | User | Gets the User.
Inheritance Hierarchy
Object
EditingSession

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


EditingSession Constructor (page, user)

EditingSession Constructor (page, user)
ScrewTurn Wiki ► ScrewTurn.Wiki ► EditingSession ► EditingSession(String, String)
Initializes a new instance of the EditingSession class.
Declaration Syntax
C# Visual Basic Visual C++
public EditingSession(
    string page,
    string user
)
Public Sub New ( _
    page As String, _
    user As String _
)
public:
EditingSession(
    String^ page,
    String^ user
)
Parameters
page (String)
The edited Page.
user (String)
The User who is editing the Page.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


LastContact Property

LastContact Property
ScrewTurn Wiki ► ScrewTurn.Wiki ► EditingSession ► LastContact
Gets the Last Contact Date/Time.
Declaration Syntax
C# Visual Basic Visual C++
public DateTime LastContact { get; }
Public ReadOnly Property LastContact As DateTime
public:
property DateTime LastContact {
    DateTime get ();
}

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


Page Property

Page Property
ScrewTurn Wiki ► ScrewTurn.Wiki ► EditingSession ► Page
Gets the edited Page.
Declaration Syntax
C# Visual Basic Visual C++
public string Page { get; }
Public ReadOnly Property Page As String
public:
property String^ Page {
    String^ get ();
}

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


Renew Method

Renew Method
ScrewTurn Wiki ► ScrewTurn.Wiki ► EditingSession ► Renew()()()
Sets the Last Contact to now.
Declaration Syntax
C# Visual Basic Visual C++
public void Renew()
Public Sub Renew
public:
void Renew()

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


User Property

User Property
ScrewTurn Wiki ► ScrewTurn.Wiki ► EditingSession ► User
Gets the User.
Declaration Syntax
C# Visual Basic Visual C++
public string User { get; }
Public ReadOnly Property User As String
public:
property String^ User {
    String^ get ();
}

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


EmailTools Class

EmailTools Class
ScrewTurn Wiki ► ScrewTurn.Wiki ► EmailTools
Implements email-related tools.
Declaration Syntax
C# Visual Basic Visual C++
public static class EmailTools
Public NotInheritable Class EmailTools
public ref class EmailTools abstract sealed
Members
All Members | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | AsyncSendEmail(String, String, String, String, Boolean) | Sends an email.
 | AsyncSendMassEmail(array<String>[]()[], String, String, String, Boolean) | Asynchronously sends a mass email, using BCC.
 | GetRecipients(array<UserInfo>[]()[]) | Gets the email addresses of a set of users.
 | NotifyError(Exception, String) | Notifies an error to the email addresses set in the configuration, swallowing all exceptions.
Inheritance Hierarchy
Object
EmailTools

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


AsyncSendEmail Method (recipient, sender, subject, body, html)

AsyncSendEmail Method (recipient, sender, subject, body, html)
ScrewTurn Wiki ► ScrewTurn.Wiki ► EmailTools ► AsyncSendEmail(String, String, String, String, Boolean)
Sends an email.
Declaration Syntax
C# Visual Basic Visual C++
public static void AsyncSendEmail(
    string recipient,
    string sender,
    string subject,
    string body,
    bool html
)
Public Shared Sub AsyncSendEmail ( _
    recipient As String, _
    sender As String, _
    subject As String, _
    body As String, _
    html As Boolean _
)
public:
static void AsyncSendEmail(
    String^ recipient,
    String^ sender,
    String^ subject,
    String^ body,
    bool html
)
Parameters
recipient (String)
The recipient.
sender (String)
The sender.
subject (String)
The subject.
body (String)
The message body.
html (Boolean)
true if the body is HTML.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


AsyncSendMassEmail Method (recipients, sender, subject, body, html)

AsyncSendMassEmail Method (recipients, sender, subject, body, html)
ScrewTurn Wiki ► ScrewTurn.Wiki ► EmailTools ► AsyncSendMassEmail(array<String>[]()[], String, String, String, Boolean)
Asynchronously sends a mass email, using BCC.
Declaration Syntax
C# Visual Basic Visual C++
public static void AsyncSendMassEmail(
    string[] recipients,
    string sender,
    string subject,
    string body,
    bool html
)
Public Shared Sub AsyncSendMassEmail ( _
    recipients As String(), _
    sender As String, _
    subject As String, _
    body As String, _
    html As Boolean _
)
public:
static void AsyncSendMassEmail(
    array<String^>^ recipients,
    String^ sender,
    String^ subject,
    String^ body,
    bool html
)
Parameters
recipients (array< String >[]()[][])
The recipents.
sender (String)
The sender.
subject (String)
The subject.
body (String)
The body.
html (Boolean)
true if the body is HTML.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


GetRecipients Method (users)

GetRecipients Method (users)
ScrewTurn Wiki ► ScrewTurn.Wiki ► EmailTools ► GetRecipients(array<UserInfo>[]()[])
Gets the email addresses of a set of users.
Declaration Syntax
C# Visual Basic Visual C++
public static string[] GetRecipients(
    UserInfo[] users
)
Public Shared Function GetRecipients ( _
    users As UserInfo() _
) As String()
public:
static array<String^>^ GetRecipients(
    array<UserInfo^>^ users
)
Parameters
users (array< UserInfo >[]()[][])
The users.
Return Value
The email addresses.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


NotifyError Method (ex, url)

NotifyError Method (ex, url)
ScrewTurn Wiki ► ScrewTurn.Wiki ► EmailTools ► NotifyError(Exception, String)
Notifies an error to the email addresses set in the configuration, swallowing all exceptions.
Declaration Syntax
C# Visual Basic Visual C++
public static void NotifyError(
    Exception ex,
    string url
)
Public Shared Sub NotifyError ( _
    ex As Exception, _
    url As String _
)
public:
static void NotifyError(
    Exception^ ex,
    String^ url
)
Parameters
ex (Exception)
The exception to notify.
url (String)
The URL that caused the error, if any.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


Exchanger Class

Exchanger Class
ScrewTurn Wiki ► ScrewTurn.Wiki ► Exchanger
Class used for exchaning data between the Core library and the Wiki engine.
Declaration Syntax
C# Visual Basic Visual C++
public static class Exchanger
Public NotInheritable Class Exchanger
public ref class Exchanger abstract sealed
Members
All Members | Properties
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | ResourceExchanger | Gets or sets the singleton instance of the Resource Exchanger object.
Inheritance Hierarchy
Object
Exchanger

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.PluginFramework (Module: ScrewTurn.Wiki.PluginFramework) Version: 3.0.2.500 (3.0.2.500)


ResourceExchanger Property

ResourceExchanger Property
ScrewTurn Wiki ► ScrewTurn.Wiki ► Exchanger ► ResourceExchanger
Gets or sets the singleton instance of the Resource Exchanger object.
Declaration Syntax
C# Visual Basic Visual C++
public static IResourceExchanger ResourceExchanger { get; set; }
Public Shared Property ResourceExchanger As IResourceExchanger
public:
static property IResourceExchanger^ ResourceExchanger {
    IResourceExchanger^ get ();
    void set (IResourceExchanger^ value);
}

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.PluginFramework (Module: ScrewTurn.Wiki.PluginFramework) Version: 3.0.2.500 (3.0.2.500)


FileDocument Class

FileDocument Class
ScrewTurn Wiki ► ScrewTurn.Wiki ► FileDocument
Represents a file document.
Declaration Syntax
C# Visual Basic Visual C++
public class FileDocument : IDocument
Public Class FileDocument _
    Implements IDocument
public ref class FileDocument : IDocument
Members
All Members | Constructors | Methods | Properties | Fields
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | FileDocument(String, String, DateTime) | Initializes a new instance of the FileDocument class.
 | FileDocument(DumpedDocument) | Initializes a new instance of the FileDocument class.
 | DateTime | Gets the document date/time.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | ID | Gets or sets the globally unique ID of the document.
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets the globally-unique name of the document.
 | Provider | Gets the provider.
 | StandardTypeTag | The type tag for a FileDocument.
 | Title | Gets the title of the document, if any.
 | Tokenize(String) | Performs the tokenization of the document content.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | TypeTag | Gets the tag for the document type.
Inheritance Hierarchy
Object
FileDocument

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


FileDocument Constructor

FileDocument Constructor
ScrewTurn Wiki ► ScrewTurn.Wiki ► FileDocument ► FileDocument()()()
Members
Icon | Member | Description
 | FileDocument(String, String, DateTime) | Initializes a new instance of the FileDocument class.
 | FileDocument(DumpedDocument) | Initializes a new instance of the FileDocument class.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


FileDocument Constructor (doc)

FileDocument Constructor (doc)
ScrewTurn Wiki ► ScrewTurn.Wiki ► FileDocument ► FileDocument(DumpedDocument)
Initializes a new instance of the FileDocument class.
Declaration Syntax
C# Visual Basic Visual C++
public FileDocument(
    DumpedDocument doc
)
Public Sub New ( _
    doc As DumpedDocument _
)
public:
FileDocument(
    DumpedDocument^ doc
)
Parameters
doc (DumpedDocument)
The dumped document.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


FileDocument Constructor (fullName, provider, dateTime)

FileDocument Constructor (fullName, provider, dateTime)
ScrewTurn Wiki ► ScrewTurn.Wiki ► FileDocument ► FileDocument(String, String, DateTime)
Initializes a new instance of the FileDocument class.
Declaration Syntax
C# Visual Basic Visual C++
public FileDocument(
    string fullName,
    string provider,
    DateTime dateTime
)
Public Sub New ( _
    fullName As String, _
    provider As String, _
    dateTime As DateTime _
)
public:
FileDocument(
    String^ fullName,
    String^ provider,
    DateTime dateTime
)
Parameters
fullName (String)
The file full name.
provider (String)
The file provider.
dateTime (DateTime)
The modification date/time.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


DateTime Property

DateTime Property
ScrewTurn Wiki ► ScrewTurn.Wiki ► FileDocument ► DateTime
Gets the document date/time.
Declaration Syntax
C# Visual Basic Visual C++
public DateTime DateTime { get; }
Public ReadOnly Property DateTime As DateTime
public:
virtual property DateTime DateTime {
    DateTime get () sealed;
}

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


ID Property

ID Property
ScrewTurn Wiki ► ScrewTurn.Wiki ► FileDocument ► ID
Gets or sets the globally unique ID of the document.
Declaration Syntax
C# Visual Basic Visual C++
public uint ID { get; set; }
Public Property ID As UInteger
public:
virtual property unsigned int ID {
    unsigned int get () sealed;
    void set (unsigned int value) sealed;
}

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


Name Property

Name Property
ScrewTurn Wiki ► ScrewTurn.Wiki ► FileDocument ► Name
Gets the globally-unique name of the document.
Declaration Syntax
C# Visual Basic Visual C++
public string Name { get; }
Public ReadOnly Property Name As String
public:
virtual property String^ Name {
    String^ get () sealed;
}

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


Provider Property

Provider Property
ScrewTurn Wiki ► ScrewTurn.Wiki ► FileDocument ► Provider
Gets the provider.
Declaration Syntax
C# Visual Basic Visual C++
public string Provider { get; }
Public ReadOnly Property Provider As String
public:
property String^ Provider {
    String^ get ();
}

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


StandardTypeTag Field

StandardTypeTag Field
ScrewTurn Wiki ► ScrewTurn.Wiki ► FileDocument ► StandardTypeTag
The type tag for a FileDocument.
Declaration Syntax
C# Visual Basic Visual C++
public const string StandardTypeTag
Public Const StandardTypeTag As String
public:
literal String^ StandardTypeTag

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


Title Property

Title Property
ScrewTurn Wiki ► ScrewTurn.Wiki ► FileDocument ► Title
Gets the title of the document, if any.
Declaration Syntax
C# Visual Basic Visual C++
public string Title { get; }
Public ReadOnly Property Title As String
public:
virtual property String^ Title {
    String^ get () sealed;
}

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


Tokenize Method (content)

Tokenize Method (content)
ScrewTurn Wiki ► ScrewTurn.Wiki ► FileDocument ► Tokenize(String)
Performs the tokenization of the document content.
Declaration Syntax
C# Visual Basic Visual C++
public WordInfo[] Tokenize(
    string content
)
Public Function Tokenize ( _
    content As String _
) As WordInfo()
public:
virtual array<WordInfo^>^ Tokenize(
    String^ content
) sealed
Parameters
content (String)
The content to tokenize.
Return Value
The extracted words and their positions (always an empty array).

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


TypeTag Property

TypeTag Property
ScrewTurn Wiki ► ScrewTurn.Wiki ► FileDocument ► TypeTag
Gets the tag for the document type.
Declaration Syntax
C# Visual Basic Visual C++
public string TypeTag { get; }
Public ReadOnly Property TypeTag As String
public:
virtual property String^ TypeTag {
    String^ get () sealed;
}

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


FileDownloadCountFilterMode Enumeration

FileDownloadCountFilterMode Enumeration
ScrewTurn Wiki ► ScrewTurn.Wiki ► FileDownloadCountFilterMode
Lists legal file download filter modes.
Declaration Syntax
C# Visual Basic Visual C++
public enum FileDownloadCountFilterMode
Public Enumeration FileDownloadCountFilterMode
public enum class FileDownloadCountFilterMode
Members
Member | Description
CountAll | Counts all downloads.
CountSpecifiedExtensions | Counts only the specified extensions.
ExcludeSpecifiedExtensions | Excludes the specified extensions.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


FilesAndAttachments Class

FilesAndAttachments Class
ScrewTurn Wiki ► ScrewTurn.Wiki ► FilesAndAttachments
Manages files, directories and attachments.
Declaration Syntax
C# Visual Basic Visual C++
public static class FilesAndAttachments
Public NotInheritable Class FilesAndAttachments
public ref class FilesAndAttachments abstract sealed
Members
All Members | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | FindDirectoryProvider(String) | Finds the provider that has a directory.
 | FindFileProvider(String) | Finds the provider that has a file.
 | FindPageAttachmentProvider(PageInfo, String) | Finds the provider that has a page attachment.
 | GetFileDetails(String) | Gets the details of a file.
 | GetPageAttachmentDetails(PageInfo, String) | Gets the details of a page attachment.
 | ListDirectories(String) | Lists the directories in a directory.
 | ListFiles(String) | Lists the files in a directory.
 | RetrieveFile(String, Stream, Boolean) | Retrieves a File.
 | RetrievePageAttachment(PageInfo, String, Stream, Boolean) | Retrieves a Page Attachment.
Inheritance Hierarchy
Object
FilesAndAttachments

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


FindDirectoryProvider Method (fullPath)

FindDirectoryProvider Method (fullPath)
ScrewTurn Wiki ► ScrewTurn.Wiki ► FilesAndAttachments ► FindDirectoryProvider(String)
Finds the provider that has a directory.
Declaration Syntax
C# Visual Basic Visual C++
public static IFilesStorageProviderV30 FindDirectoryProvider(
    string fullPath
)
Public Shared Function FindDirectoryProvider ( _
    fullPath As String _
) As IFilesStorageProviderV30
public:
static IFilesStorageProviderV30^ FindDirectoryProvider(
    String^ fullPath
)
Parameters
fullPath (String)
The full path of the directory.
Return Value
The provider that has the directory, or null if no directory is found.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


FindFileProvider Method (fullName)

FindFileProvider Method (fullName)
ScrewTurn Wiki ► ScrewTurn.Wiki ► FilesAndAttachments ► FindFileProvider(String)
Finds the provider that has a file.
Declaration Syntax
C# Visual Basic Visual C++
public static IFilesStorageProviderV30 FindFileProvider(
    string fullName
)
Public Shared Function FindFileProvider ( _
    fullName As String _
) As IFilesStorageProviderV30
public:
static IFilesStorageProviderV30^ FindFileProvider(
    String^ fullName
)
Parameters
fullName (String)
The full name of the file.
Return Value
The provider that has the file, or null if the file could not be found.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


FindPageAttachmentProvider Method (page, attachmentName)

FindPageAttachmentProvider Method (page, attachmentName)
ScrewTurn Wiki ► ScrewTurn.Wiki ► FilesAndAttachments ► FindPageAttachmentProvider(PageInfo, String)
Finds the provider that has a page attachment.
Declaration Syntax
C# Visual Basic Visual C++
public static IFilesStorageProviderV30 FindPageAttachmentProvider(
    PageInfo page,
    string attachmentName
)
Public Shared Function FindPageAttachmentProvider ( _
    page As PageInfo, _
    attachmentName As String _
) As IFilesStorageProviderV30
public:
static IFilesStorageProviderV30^ FindPageAttachmentProvider(
    PageInfo^ page,
    String^ attachmentName
)
Parameters
page (PageInfo)
The page.
attachmentName (String)
The name of the attachment.
Return Value
The provider that has the attachment, or null if the attachment could not be found.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


GetFileDetails Method (fullName)

GetFileDetails Method (fullName)
ScrewTurn Wiki ► ScrewTurn.Wiki ► FilesAndAttachments ► GetFileDetails(String)
Gets the details of a file.
Declaration Syntax
C# Visual Basic Visual C++
public static FileDetails GetFileDetails(
    string fullName
)
Public Shared Function GetFileDetails ( _
    fullName As String _
) As FileDetails
public:
static FileDetails^ GetFileDetails(
    String^ fullName
)
Parameters
fullName (String)
The full name of the file.
Return Value
The details of the file, or null if no file is found.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


GetPageAttachmentDetails Method (page, attachmentName)

GetPageAttachmentDetails Method (page, attachmentName)
ScrewTurn Wiki ► ScrewTurn.Wiki ► FilesAndAttachments ► GetPageAttachmentDetails(PageInfo, String)
Gets the details of a page attachment.
Declaration Syntax
C# Visual Basic Visual C++
public static FileDetails GetPageAttachmentDetails(
    PageInfo page,
    string attachmentName
)
Public Shared Function GetPageAttachmentDetails ( _
    page As PageInfo, _
    attachmentName As String _
) As FileDetails
public:
static FileDetails^ GetPageAttachmentDetails(
    PageInfo^ page,
    String^ attachmentName
)
Parameters
page (PageInfo)
The page.
attachmentName (String)
The name of the attachment.
Return Value
The details of the attachment, or null if the attachment could not be found.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


ListDirectories Method (fullPath)

ListDirectories Method (fullPath)
ScrewTurn Wiki ► ScrewTurn.Wiki ► FilesAndAttachments ► ListDirectories(String)
Lists the directories in a directory.
Declaration Syntax
C# Visual Basic Visual C++
public static string[] ListDirectories(
    string fullPath
)
Public Shared Function ListDirectories ( _
    fullPath As String _
) As String()
public:
static array<String^>^ ListDirectories(
    String^ fullPath
)
Parameters
fullPath (String)
The full path.
Return Value
The directories.
Remarks
If the specified directory is the root, then the list is performed on all providers.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


ListFiles Method (fullPath)

ListFiles Method (fullPath)
ScrewTurn Wiki ► ScrewTurn.Wiki ► FilesAndAttachments ► ListFiles(String)
Lists the files in a directory.
Declaration Syntax
C# Visual Basic Visual C++
public static string[] ListFiles(
    string fullPath
)
Public Shared Function ListFiles ( _
    fullPath As String _
) As String()
public:
static array<String^>^ ListFiles(
    String^ fullPath
)
Parameters
fullPath (String)
The full path.
Return Value
The files.
Remarks
If the specified directory is the root, then the list is performed on all providers.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


RetrieveFile Method (fullName, output, countHit)

RetrieveFile Method (fullName, output, countHit)
ScrewTurn Wiki ► ScrewTurn.Wiki ► FilesAndAttachments ► RetrieveFile(String, Stream, Boolean)
Retrieves a File.
Declaration Syntax
C# Visual Basic Visual C++
public static bool RetrieveFile(
    string fullName,
    Stream output,
    bool countHit
)
Public Shared Function RetrieveFile ( _
    fullName As String, _
    output As Stream, _
    countHit As Boolean _
) As Boolean
public:
static bool RetrieveFile(
    String^ fullName,
    Stream^ output,
    bool countHit
)
Parameters
fullName (String)
The full name of the File.
output (Stream)
The output stream.
countHit (Boolean)
A value indicating whether or not to count this retrieval in the statistics.
Return Value
true if the file is retrieved, false otherwise.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


RetrievePageAttachment Method (page, attachmentName, output, countHit)

RetrievePageAttachment Method (page, attachmentName, output, countHit)
ScrewTurn Wiki ► ScrewTurn.Wiki ► FilesAndAttachments ► RetrievePageAttachment(PageInfo, String, Stream, Boolean)
Retrieves a Page Attachment.
Declaration Syntax
C# Visual Basic Visual C++
public static bool RetrievePageAttachment(
    PageInfo page,
    string attachmentName,
    Stream output,
    bool countHit
)
Public Shared Function RetrievePageAttachment ( _
    page As PageInfo, _
    attachmentName As String, _
    output As Stream, _
    countHit As Boolean _
) As Boolean
public:
static bool RetrievePageAttachment(
    PageInfo^ page,
    String^ attachmentName,
    Stream^ output,
    bool countHit
)
Parameters
page (PageInfo)
The Page Info that owns the Attachment.
attachmentName (String)
The name of the Attachment, for example "myfile.jpg".
output (Stream)
The output stream.
countHit (Boolean)
A value indicating whether or not to count this retrieval in the statistics.
Return Value
true if the Attachment is retrieved, false otherwise.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


FilesStorageProvider Class

FilesStorageProvider Class
ScrewTurn Wiki ► ScrewTurn.Wiki ► FilesStorageProvider
Implements a Local Files Storage Provider.
Declaration Syntax
C# Visual Basic Visual C++
public class FilesStorageProvider : IFilesStorageProviderV30,
    IStorageProviderV30, IProviderV30
Public Class FilesStorageProvider _
    Implements IFilesStorageProviderV30, IStorageProviderV30, IProviderV30
public ref class FilesStorageProvider : IFilesStorageProviderV30,
    IStorageProviderV30, IProviderV30
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | FilesStorageProvider()()() | Initializes a new instance of the FilesStorageProvider class
 | ConfigHelpHtml | Gets a brief summary of the configuration string format, in HTML. Returns null if no configuration is needed.
 | CreateDirectory(String, String) | Creates a new Directory.
 | DeleteDirectory(String) | Deletes a Directory and all of its content.
 | DeleteFile(String) | Deletes a File.
 | DeletePageAttachment(PageInfo, String) | Deletes a Page Attachment.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetFileDetails(String) | Gets the details of a file.
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetPageAttachmentDetails(PageInfo, String) | Gets the details of a page attachment.
 | GetPagesWithAttachments()()() | The the names of the pages with attachments.
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | Information | Gets the Information about the Provider.
 | Init(IHostV30, String) | Initializes the Storage Provider.
 | ListDirectories(String) | Lists the Directories in the specified directory.
 | ListFiles(String) | Lists the Files in the specified Directory.
 | ListPageAttachments(PageInfo) | Returns the names of the Attachments of a Page.
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | NotifyPageRenaming(PageInfo, PageInfo) | Notifies to the Provider that a Page has been renamed.
 | ReadOnly | Gets a value specifying whether the provider is read-only, i.e. it can only provide data and not store it.
 | RenameDirectory(String, String) | Renames or moves a Directory.
 | RenameFile(String, String) | Renames or moves a File.
 | RenamePageAttachment(PageInfo, String, String) | Renames a Page Attachment.
 | RetrieveFile(String, Stream, Boolean) | Retrieves a File.
 | RetrievePageAttachment(PageInfo, String, Stream, Boolean) | Retrieves a Page Attachment.
 | SetFileRetrievalCount(String, Int32) | Clears the number of times a file was retrieved.
 | SetPageAttachmentRetrievalCount(PageInfo, String, Int32) | Set the number of times a page attachment was retrieved.
 | Shutdown()()() | Method invoked on shutdown.
 | StoreFile(String, Stream, Boolean) | Stores a file.
 | StorePageAttachment(PageInfo, String, Stream, Boolean) | Stores a Page Attachment.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
FilesStorageProvider

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


FilesStorageProvider Constructor

FilesStorageProvider Constructor
ScrewTurn Wiki ► ScrewTurn.Wiki ► FilesStorageProvider ► FilesStorageProvider()()()
Initializes a new instance of the FilesStorageProvider class
Declaration Syntax
C# Visual Basic Visual C++
public FilesStorageProvider()
Public Sub New
public:
FilesStorageProvider()

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


ConfigHelpHtml Property

ConfigHelpHtml Property
ScrewTurn Wiki ► ScrewTurn.Wiki ► FilesStorageProvider ► ConfigHelpHtml
Gets a brief summary of the configuration string format, in HTML. Returns null if no configuration is needed.
Declaration Syntax
C# Visual Basic Visual C++
public string ConfigHelpHtml { get; }
Public ReadOnly Property ConfigHelpHtml As String
public:
virtual property String^ ConfigHelpHtml {
    String^ get () sealed;
}

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


CreateDirectory Method (path, name)

CreateDirectory Method (path, name)
ScrewTurn Wiki ► ScrewTurn.Wiki ► FilesStorageProvider ► CreateDirectory(String, String)
Creates a new Directory.
Declaration Syntax
C# Visual Basic Visual C++
public bool CreateDirectory(
    string path,
    string name
)
Public Function CreateDirectory ( _
    path As String, _
    name As String _
) As Boolean
public:
virtual bool CreateDirectory(
    String^ path,
    String^ name
) sealed
Parameters
path (String)
The path to create the new Directory in.
name (String)
The name of the new Directory.
Return Value
true if the Directory is created, false otherwise.
Remarks
If path is "/my/directory" and name is "newdir", a new directory named "/my/directory/newdir" is created.
Exceptions
Exception | Condition
ArgumentNullException | If path or name are null.
ArgumentException | If name is empty or if the directory does not exist, or if the new directory already exists.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


DeleteDirectory Method (fullPath)

DeleteDirectory Method (fullPath)
ScrewTurn Wiki ► ScrewTurn.Wiki ► FilesStorageProvider ► DeleteDirectory(String)
Deletes a Directory and all of its content.
Declaration Syntax
C# Visual Basic Visual C++
public bool DeleteDirectory(
    string fullPath
)
Public Function DeleteDirectory ( _
    fullPath As String _
) As Boolean
public:
virtual bool DeleteDirectory(
    String^ fullPath
) sealed
Parameters
fullPath (String)
The full path of the Directory.
Return Value
true if the Directory is delete, false otherwise.
Exceptions
Exception | Condition
ArgumentNullException | If fullPath is null.
ArgumentException | If fullPath is empty or if it equals '/' or it does not exist.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


DeleteFile Method (fullName)

DeleteFile Method (fullName)
ScrewTurn Wiki ► ScrewTurn.Wiki ► FilesStorageProvider ► DeleteFile(String)
Deletes a File.
Declaration Syntax
C# Visual Basic Visual C++
public bool DeleteFile(
    string fullName
)
Public Function DeleteFile ( _
    fullName As String _
) As Boolean
public:
virtual bool DeleteFile(
    String^ fullName
) sealed
Parameters
fullName (String)
The full name of the File.
Return Value
true if the File is deleted, false otherwise.
Exceptions
Exception | Condition
ArgumentNullException | If fullName is null.
ArgumentException | If fullName is empty or it does not exist.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


DeletePageAttachment Method (pageInfo, name)

DeletePageAttachment Method (pageInfo, name)
ScrewTurn Wiki ► ScrewTurn.Wiki ► FilesStorageProvider ► DeletePageAttachment(PageInfo, String)
Deletes a Page Attachment.
Declaration Syntax
C# Visual Basic Visual C++
public bool DeletePageAttachment(
    PageInfo pageInfo,
    string name
)
Public Function DeletePageAttachment ( _
    pageInfo As PageInfo, _
    name As String _
) As Boolean
public:
virtual bool DeletePageAttachment(
    PageInfo^ pageInfo,
    String^ name
) sealed
Parameters
pageInfo (PageInfo)
The Page Info that owns the Attachment.
name (String)
The name of the Attachment, for example "myfile.jpg".
Return Value
true if the Attachment is deleted, false otherwise.
Exceptions
Exception | Condition
ArgumentNullException | If pageInfo or name are null.
ArgumentException | If name is empty or if the page or attachment do not exist.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


GetFileDetails Method (fullName)

GetFileDetails Method (fullName)
ScrewTurn Wiki ► ScrewTurn.Wiki ► FilesStorageProvider ► GetFileDetails(String)
Gets the details of a file.
Declaration Syntax
C# Visual Basic Visual C++
public FileDetails GetFileDetails(
    string fullName
)
Public Function GetFileDetails ( _
    fullName As String _
) As FileDetails
public:
virtual FileDetails^ GetFileDetails(
    String^ fullName
) sealed
Parameters
fullName (String)
The full name of the file.
Return Value
The details, or null if the file does not exist.
Exceptions
Exception | Condition
ArgumentNullException | If fullName is null.
ArgumentException | If fullName is empty.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


GetPageAttachmentDetails Method (pageInfo, name)

GetPageAttachmentDetails Method (pageInfo, name)
ScrewTurn Wiki ► ScrewTurn.Wiki ► FilesStorageProvider ► GetPageAttachmentDetails(PageInfo, String)
Gets the details of a page attachment.
Declaration Syntax
C# Visual Basic Visual C++
public FileDetails GetPageAttachmentDetails(
    PageInfo pageInfo,
    string name
)
Public Function GetPageAttachmentDetails ( _
    pageInfo As PageInfo, _
    name As String _
) As FileDetails
public:
virtual FileDetails^ GetPageAttachmentDetails(
    PageInfo^ pageInfo,
    String^ name
) sealed
Parameters
pageInfo (PageInfo)
The page that owns the attachment.
name (String)
The name of the attachment, for example "myfile.jpg".
Return Value
The details of the attachment, or null if the attachment does not exist.
Exceptions
Exception | Condition
ArgumentNullException | If pageInfo or name are null.
ArgumentException | If name is empty.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


GetPagesWithAttachments Method

GetPagesWithAttachments Method
ScrewTurn Wiki ► ScrewTurn.Wiki ► FilesStorageProvider ► GetPagesWithAttachments()()()
The the names of the pages with attachments.
Declaration Syntax
C# Visual Basic Visual C++
public string[] GetPagesWithAttachments()
Public Function GetPagesWithAttachments As String()
public:
virtual array<String^>^ GetPagesWithAttachments() sealed
Return Value
The names of the pages with attachments.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


Information Property

Information Property
ScrewTurn Wiki ► ScrewTurn.Wiki ► FilesStorageProvider ► Information
Gets the Information about the Provider.
Declaration Syntax
C# Visual Basic Visual C++
public ComponentInformation Information { get; }
Public ReadOnly Property Information As ComponentInformation
public:
virtual property ComponentInformation^ Information {
    ComponentInformation^ get () sealed;
}

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


Init Method (host, config)

Init Method (host, config)
ScrewTurn Wiki ► ScrewTurn.Wiki ► FilesStorageProvider ► Init(IHostV30, String)
Initializes the Storage Provider.
Declaration Syntax
C# Visual Basic Visual C++
public void Init(
    IHostV30 host,
    string config
)
Public Sub Init ( _
    host As IHostV30, _
    config As String _
)
public:
virtual void Init(
    IHostV30^ host,
    String^ config
) sealed
Parameters
host (IHostV30)
The Host of the Component.
config (String)
The Configuration data, if any.
Exceptions
Exception | Condition
ArgumentNullException | If host or config are null.
InvalidConfigurationException | If config is not valid or is incorrect.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


ListDirectories Method (directory)

ListDirectories Method (directory)
ScrewTurn Wiki ► ScrewTurn.Wiki ► FilesStorageProvider ► ListDirectories(String)
Lists the Directories in the specified directory.
Declaration Syntax
C# Visual Basic Visual C++
public string[] ListDirectories(
    string directory
)
Public Function ListDirectories ( _
    directory As String _
) As String()
public:
virtual array<String^>^ ListDirectories(
    String^ directory
) sealed
Parameters
directory (String)
The full directory name, for example "/my/directory". Null, empty or "/" for the root directory.
Return Value
The list of Directories in the Directory.
Exceptions
Exception | Condition
ArgumentException | If directory does not exist.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


ListFiles Method (directory)

ListFiles Method (directory)
ScrewTurn Wiki ► ScrewTurn.Wiki ► FilesStorageProvider ► ListFiles(String)
Lists the Files in the specified Directory.
Declaration Syntax
C# Visual Basic Visual C++
public string[] ListFiles(
    string directory
)
Public Function ListFiles ( _
    directory As String _
) As String()
public:
virtual array<String^>^ ListFiles(
    String^ directory
) sealed
Parameters
directory (String)
The full directory name, for example "/my/directory". Null, empty or "/" for the root directory.
Return Value
The list of Files in the directory.
Exceptions
Exception | Condition
ArgumentException | If directory does not exist.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


ListPageAttachments Method (pageInfo)

ListPageAttachments Method (pageInfo)
ScrewTurn Wiki ► ScrewTurn.Wiki ► FilesStorageProvider ► ListPageAttachments(PageInfo)
Returns the names of the Attachments of a Page.
Declaration Syntax
C# Visual Basic Visual C++
public string[] ListPageAttachments(
    PageInfo pageInfo
)
Public Function ListPageAttachments ( _
    pageInfo As PageInfo _
) As String()
public:
virtual array<String^>^ ListPageAttachments(
    PageInfo^ pageInfo
) sealed
Parameters
pageInfo (PageInfo)
The Page Info object that owns the Attachments.
Return Value
The names, or an empty list.
Exceptions
Exception | Condition
ArgumentNullException | If pageInfo is null.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


NotifyPageRenaming Method (oldPage, newPage)

NotifyPageRenaming Method (oldPage, newPage)
ScrewTurn Wiki ► ScrewTurn.Wiki ► FilesStorageProvider ► NotifyPageRenaming(PageInfo, PageInfo)
Notifies to the Provider that a Page has been renamed.
Declaration Syntax
C# Visual Basic Visual C++
public void NotifyPageRenaming(
    PageInfo oldPage,
    PageInfo newPage
)
Public Sub NotifyPageRenaming ( _
    oldPage As PageInfo, _
    newPage As PageInfo _
)
public:
virtual void NotifyPageRenaming(
    PageInfo^ oldPage,
    PageInfo^ newPage
) sealed
Parameters
oldPage (PageInfo)
The old Page Info object.
newPage (PageInfo)
The new Page Info object.
Exceptions
Exception | Condition
ArgumentNullException | If oldPage or newPage are null
ArgumentException | If the new page is already in use.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


ReadOnly Property

ReadOnly Property
ScrewTurn Wiki ► ScrewTurn.Wiki ► FilesStorageProvider ► ReadOnly
Gets a value specifying whether the provider is read-only, i.e. it can only provide data and not store it.
Declaration Syntax
C# Visual Basic Visual C++
public bool ReadOnly { get; }
Public ReadOnly Property ReadOnly As Boolean
public:
virtual property bool ReadOnly {
    bool get () sealed;
}

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


RenameDirectory Method (oldFullPath, newFullPath)

RenameDirectory Method (oldFullPath, newFullPath)
ScrewTurn Wiki ► ScrewTurn.Wiki ► FilesStorageProvider ► RenameDirectory(String, String)
Renames or moves a Directory.
Declaration Syntax
C# Visual Basic Visual C++
public bool RenameDirectory(
    string oldFullPath,
    string newFullPath
)
Public Function RenameDirectory ( _
    oldFullPath As String, _
    newFullPath As String _
) As Boolean
public:
virtual bool RenameDirectory(
    String^ oldFullPath,
    String^ newFullPath
) sealed
Parameters
oldFullPath (String)
The old full path of the Directory.
newFullPath (String)
The new full path of the Directory.
Return Value
true if the Directory is renamed, false otherwise.
Exceptions
Exception | Condition
ArgumentNullException | If oldFullPath or newFullPath are null.
ArgumentException | If oldFullPath or newFullPath are empty or equal to '/', or if the old directory does not exist or the new directory already exists.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


RenameFile Method (oldFullName, newFullName)

RenameFile Method (oldFullName, newFullName)
ScrewTurn Wiki ► ScrewTurn.Wiki ► FilesStorageProvider ► RenameFile(String, String)
Renames or moves a File.
Declaration Syntax
C# Visual Basic Visual C++
public bool RenameFile(
    string oldFullName,
    string newFullName
)
Public Function RenameFile ( _
    oldFullName As String, _
    newFullName As String _
) As Boolean
public:
virtual bool RenameFile(
    String^ oldFullName,
    String^ newFullName
) sealed
Parameters
oldFullName (String)
The old full name of the File.
newFullName (String)
The new full name of the File.
Return Value
true if the File is renamed, false otherwise.
Exceptions
Exception | Condition
ArgumentNullException | If oldFullName or newFullName are null.
ArgumentException | If oldFullName or newFullName are empty, or if the old file does not exist, or if the new file already exist.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


RenamePageAttachment Method (pageInfo, oldName, newName)

RenamePageAttachment Method (pageInfo, oldName, newName)
ScrewTurn Wiki ► ScrewTurn.Wiki ► FilesStorageProvider ► RenamePageAttachment(PageInfo, String, String)
Renames a Page Attachment.
Declaration Syntax
C# Visual Basic Visual C++
public bool RenamePageAttachment(
    PageInfo pageInfo,
    string oldName,
    string newName
)
Public Function RenamePageAttachment ( _
    pageInfo As PageInfo, _
    oldName As String, _
    newName As String _
) As Boolean
public:
virtual bool RenamePageAttachment(
    PageInfo^ pageInfo,
    String^ oldName,
    String^ newName
) sealed
Parameters
pageInfo (PageInfo)
The Page Info that owns the Attachment.
oldName (String)
The old name of the Attachment.
newName (String)
The new name of the Attachment.
Return Value
true if the Attachment is renamed, false otherwise.
Exceptions
Exception | Condition
ArgumentNullException | If pageInfo, oldName or newName are null.
ArgumentException | If pageInfo, oldName or newName are empty, or if the page or old attachment do not exist, or the new attachment name already exists.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


RetrieveFile Method (fullName, destinationStream, countHit)

RetrieveFile Method (fullName, destinationStream, countHit)
ScrewTurn Wiki ► ScrewTurn.Wiki ► FilesStorageProvider ► RetrieveFile(String, Stream, Boolean)
Retrieves a File.
Declaration Syntax
C# Visual Basic Visual C++
public bool RetrieveFile(
    string fullName,
    Stream destinationStream,
    bool countHit
)
Public Function RetrieveFile ( _
    fullName As String, _
    destinationStream As Stream, _
    countHit As Boolean _
) As Boolean
public:
virtual bool RetrieveFile(
    String^ fullName,
    Stream^ destinationStream,
    bool countHit
) sealed
Parameters
fullName (String)
The full name of the File.
destinationStream (Stream)
A Stream object used as destination of a byte stream, i.e. the method writes to the Stream the file content.
countHit (Boolean)
A value indicating whether or not to count this retrieval in the statistics.
Return Value
true if the file is retrieved, false otherwise.
Exceptions
Exception | Condition
ArgumentNullException | If fullName os destinationStream are null.
ArgumentException | If fullName is empty or destinationStream does not support writing, or if fullName does not exist.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


RetrievePageAttachment Method (pageInfo, name, destinationStream, countHit)

RetrievePageAttachment Method (pageInfo, name, destinationStream, countHit)
ScrewTurn Wiki ► ScrewTurn.Wiki ► FilesStorageProvider ► RetrievePageAttachment(PageInfo, String, Stream, Boolean)
Retrieves a Page Attachment.
Declaration Syntax
C# Visual Basic Visual C++
public bool RetrievePageAttachment(
    PageInfo pageInfo,
    string name,
    Stream destinationStream,
    bool countHit
)
Public Function RetrievePageAttachment ( _
    pageInfo As PageInfo, _
    name As String, _
    destinationStream As Stream, _
    countHit As Boolean _
) As Boolean
public:
virtual bool RetrievePageAttachment(
    PageInfo^ pageInfo,
    String^ name,
    Stream^ destinationStream,
    bool countHit
) sealed
Parameters
pageInfo (PageInfo)
The Page Info that owns the Attachment.
name (String)
The name of the Attachment, for example "myfile.jpg".
destinationStream (Stream)
A Stream object used as destination of a byte stream, i.e. the method writes to the Stream the file content.
countHit (Boolean)
A value indicating whether or not to count this retrieval in the statistics.
Return Value
true if the Attachment is retrieved, false otherwise.
Exceptions
Exception | Condition
ArgumentNullException | If pageInfo, name or destinationStream are null.
ArgumentException | If name is empty or if destinationStream does not support writing, or if the page does not have attachments or if the attachment does not exist.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


SetFileRetrievalCount Method (fullName, count)

SetFileRetrievalCount Method (fullName, count)
ScrewTurn Wiki ► ScrewTurn.Wiki ► FilesStorageProvider ► SetFileRetrievalCount(String, Int32)
Clears the number of times a file was retrieved.
Declaration Syntax
C# Visual Basic Visual C++
public void SetFileRetrievalCount(
    string fullName,
    int count
)
Public Sub SetFileRetrievalCount ( _
    fullName As String, _
    count As Integer _
)
public:
virtual void SetFileRetrievalCount(
    String^ fullName,
    int count
) sealed
Parameters
fullName (String)
The full name of the file.
count (Int32)
The count to set.
Exceptions
Exception | Condition
ArgumentNullException | If fullName is null.
ArgumentException | If fullName is empty.
ArgumentOutOfRangeException | If count is less than zero.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


SetPageAttachmentRetrievalCount Method (pageInfo, name, count)

SetPageAttachmentRetrievalCount Method (pageInfo, name, count)
ScrewTurn Wiki ► ScrewTurn.Wiki ► FilesStorageProvider ► SetPageAttachmentRetrievalCount(PageInfo, String, Int32)
Set the number of times a page attachment was retrieved.
Declaration Syntax
C# Visual Basic Visual C++
public void SetPageAttachmentRetrievalCount(
    PageInfo pageInfo,
    string name,
    int count
)
Public Sub SetPageAttachmentRetrievalCount ( _
    pageInfo As PageInfo, _
    name As String, _
    count As Integer _
)
public:
virtual void SetPageAttachmentRetrievalCount(
    PageInfo^ pageInfo,
    String^ name,
    int count
) sealed
Parameters
pageInfo (PageInfo)
The page.
name (String)
The name of the attachment.
count (Int32)
The count to set.
Exceptions
Exception | Condition
ArgumentNullException | If pageInfo or name are null.
ArgumentException | If name is empty.
ArgumentOutOfRangeException | If count is less than zero.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


Shutdown Method

Shutdown Method
ScrewTurn Wiki ► ScrewTurn.Wiki ► FilesStorageProvider ► Shutdown()()()
Method invoked on shutdown.
Declaration Syntax
C# Visual Basic Visual C++
public void Shutdown()
Public Sub Shutdown
public:
virtual void Shutdown() sealed
Remarks
This method might not be invoked in some cases.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


StoreFile Method (fullName, sourceStream, overwrite)

StoreFile Method (fullName, sourceStream, overwrite)
ScrewTurn Wiki ► ScrewTurn.Wiki ► FilesStorageProvider ► StoreFile(String, Stream, Boolean)
Stores a file.
Declaration Syntax
C# Visual Basic Visual C++
public bool StoreFile(
    string fullName,
    Stream sourceStream,
    bool overwrite
)
Public Function StoreFile ( _
    fullName As String, _
    sourceStream As Stream, _
    overwrite As Boolean _
) As Boolean
public:
virtual bool StoreFile(
    String^ fullName,
    Stream^ sourceStream,
    bool overwrite
) sealed
Parameters
fullName (String)
The full name of the file.
sourceStream (Stream)
A Stream object used as source of a byte stream, i.e. the method reads from the Stream and stores the content properly.
overwrite (Boolean)
true to overwrite an existing file.
Return Value
true if the File is stored, false otherwise.
Remarks
If overwrite is false and File already exists, the method returns false.
Exceptions
Exception | Condition
ArgumentNullException | If fullName os sourceStream are null.
ArgumentException | If fullName is empty or sourceStream does not support reading.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


StorePageAttachment Method (pageInfo, name, sourceStream, overwrite)

StorePageAttachment Method (pageInfo, name, sourceStream, overwrite)
ScrewTurn Wiki ► ScrewTurn.Wiki ► FilesStorageProvider ► StorePageAttachment(PageInfo, String, Stream, Boolean)
Stores a Page Attachment.
Declaration Syntax
C# Visual Basic Visual C++
public bool StorePageAttachment(
    PageInfo pageInfo,
    string name,
    Stream sourceStream,
    bool overwrite
)
Public Function StorePageAttachment ( _
    pageInfo As PageInfo, _
    name As String, _
    sourceStream As Stream, _
    overwrite As Boolean _
) As Boolean
public:
virtual bool StorePageAttachment(
    PageInfo^ pageInfo,
    String^ name,
    Stream^ sourceStream,
    bool overwrite
) sealed
Parameters
pageInfo (PageInfo)
The Page Info that owns the Attachment.
name (String)
The name of the Attachment, for example "myfile.jpg".
sourceStream (Stream)
A Stream object used as source of a byte stream, i.e. the method reads from the Stream and stores the content properly.
overwrite (Boolean)
true to overwrite an existing Attachment.
Return Value
true if the Attachment is stored, false otherwise.
Remarks
If overwrite is false and Attachment already exists, the method returns false.
Exceptions
Exception | Condition
ArgumentNullException | If pageInfo, name or sourceStream are null.
ArgumentException | If name is empty or if sourceStream does not support reading.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


Formatter Class

Formatter Class
ScrewTurn Wiki ► ScrewTurn.Wiki ► Formatter
Performs all the text formatting and parsing operations.
Declaration Syntax
C# Visual Basic Visual C++
public static class Formatter
Public NotInheritable Class Formatter
public ref class Formatter abstract sealed
Members
All Members | Methods | Fields
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | BuildHAnchor(String) | Builds a valid anchor name from a string.
 | BuildHAnchor(String, String) | Builds a valid and unique anchor name from a string.
 | BuildRecentChangesTable(IList<(Of <(RecentChange>)>), FormattingContext, PageInfo) | Builds a table containing recent changes.
 | DetectHeaders(String) | Detects all the Headers in a block of text (H1, H2, H3, H4).
 | EditSectionPlaceHolder | The section editing button placeholder.
 | Format(String, Boolean, FormattingContext, PageInfo) | Formats WikiMarkup, converting it into XHTML.
 | Format(String, Boolean, FormattingContext, PageInfo, array<String>[]()[]%) | Formats WikiMarkup, converting it into XHTML.
 | Format(String, Boolean, FormattingContext, PageInfo, array<String>[]()[]%, Boolean) | Formats WikiMarkup, converting it into XHTML.
 | FormatPhase3(String, FormattingContext, PageInfo) | Performs the internal Phase 3 of the Formatting pipeline.
 | StripHtml(String) | Removes all HTML markup from a string.
Inheritance Hierarchy
Object
Formatter

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


BuildHAnchor Method

BuildHAnchor Method
ScrewTurn Wiki ► ScrewTurn.Wiki ► Formatter ► BuildHAnchor()()()
Members
Icon | Member | Description
 | BuildHAnchor(String) | Builds a valid anchor name from a string.
 | BuildHAnchor(String, String) | Builds a valid and unique anchor name from a string.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


BuildHAnchor Method (h)

BuildHAnchor Method (h)
ScrewTurn Wiki ► ScrewTurn.Wiki ► Formatter ► BuildHAnchor(String)
Builds a valid anchor name from a string.
Declaration Syntax
C# Visual Basic Visual C++
public static string BuildHAnchor(
    string h
)
Public Shared Function BuildHAnchor ( _
    h As String _
) As String
public:
static String^ BuildHAnchor(
    String^ h
)
Parameters
h (String)
The string, usually a header (Hx).
Return Value
The anchor ID.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


BuildHAnchor Method (h, uid)

BuildHAnchor Method (h, uid)
ScrewTurn Wiki ► ScrewTurn.Wiki ► Formatter ► BuildHAnchor(String, String)
Builds a valid and unique anchor name from a string.
Declaration Syntax
C# Visual Basic Visual C++
public static string BuildHAnchor(
    string h,
    string uid
)
Public Shared Function BuildHAnchor ( _
    h As String, _
    uid As String _
) As String
public:
static String^ BuildHAnchor(
    String^ h,
    String^ uid
)
Parameters
h (String)
The string, usually a header (Hx).
uid (String)
The unique ID.
Return Value
The anchor ID.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


BuildRecentChangesTable Method (allChanges, context, currentPage)

BuildRecentChangesTable Method (allChanges, context, currentPage)
ScrewTurn Wiki ► ScrewTurn.Wiki ► Formatter ► BuildRecentChangesTable(IList<(Of <(RecentChange>)>), FormattingContext, PageInfo)
Builds a table containing recent changes.
Declaration Syntax
C# Visual Basic Visual C++
public static string BuildRecentChangesTable(
    IList<RecentChange> allChanges,
    FormattingContext context,
    PageInfo currentPage
)
Public Shared Function BuildRecentChangesTable ( _
    allChanges As IList(Of RecentChange), _
    context As FormattingContext, _
    currentPage As PageInfo _
) As String
public:
static String^ BuildRecentChangesTable(
    IList<RecentChange^>^ allChanges,
    FormattingContext context,
    PageInfo^ currentPage
)
Parameters
allChanges (IList <(Of <(<' RecentChange >)>)>)
The changes.
context (FormattingContext)
The formatting context.
currentPage (PageInfo)
The current page, or null.
Return Value
The table HTML.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


DetectHeaders Method (text)

DetectHeaders Method (text)
ScrewTurn Wiki ► ScrewTurn.Wiki ► Formatter ► DetectHeaders(String)
Detects all the Headers in a block of text (H1, H2, H3, H4).
Declaration Syntax
C# Visual Basic Visual C++
public static List<HPosition> DetectHeaders(
    string text
)
Public Shared Function DetectHeaders ( _
    text As String _
) As List(Of HPosition)
public:
static List<HPosition^>^ DetectHeaders(
    String^ text
)
Parameters
text (String)
The text.
Return Value
The List of Header objects, in the same order as they are in the text.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


EditSectionPlaceHolder Field

EditSectionPlaceHolder Field
ScrewTurn Wiki ► ScrewTurn.Wiki ► Formatter ► EditSectionPlaceHolder
The section editing button placeholder.
Declaration Syntax
C# Visual Basic Visual C++
public const string EditSectionPlaceHolder
Public Const EditSectionPlaceHolder As String
public:
literal String^ EditSectionPlaceHolder

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


Format Method

Format Method
ScrewTurn Wiki ► ScrewTurn.Wiki ► Formatter ► Format()()()
Members
Icon | Member | Description
 | Format(String, Boolean, FormattingContext, PageInfo) | Formats WikiMarkup, converting it into XHTML.
 | Format(String, Boolean, FormattingContext, PageInfo, array<String>[]()[]%) | Formats WikiMarkup, converting it into XHTML.
 | Format(String, Boolean, FormattingContext, PageInfo, array<String>[]()[]%, Boolean) | Formats WikiMarkup, converting it into XHTML.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


Format Method (raw, forIndexing, context, current)

Format Method (raw, forIndexing, context, current)
ScrewTurn Wiki ► ScrewTurn.Wiki ► Formatter ► Format(String, Boolean, FormattingContext, PageInfo)
Formats WikiMarkup, converting it into XHTML.
Declaration Syntax
C# Visual Basic Visual C++
public static string Format(
    string raw,
    bool forIndexing,
    FormattingContext context,
    PageInfo current
)
Public Shared Function Format ( _
    raw As String, _
    forIndexing As Boolean, _
    context As FormattingContext, _
    current As PageInfo _
) As String
public:
static String^ Format(
    String^ raw,
    bool forIndexing,
    FormattingContext context,
    PageInfo^ current
)
Parameters
raw (String)
The raw WikiMarkup text.
forIndexing (Boolean)
A value indicating whether the formatting is being done for content indexing.
context (FormattingContext)
The formatting context.
current (PageInfo)
The current Page (can be null).
Return Value
The formatted text.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


Format Method (raw, forIndexing, context, current, linkedPages)

Format Method (raw, forIndexing, context, current, linkedPages)
ScrewTurn Wiki ► ScrewTurn.Wiki ► Formatter ► Format(String, Boolean, FormattingContext, PageInfo, array<String>[]()[]%)
Formats WikiMarkup, converting it into XHTML.
Declaration Syntax
C# Visual Basic Visual C++
public static string Format(
    string raw,
    bool forIndexing,
    FormattingContext context,
    PageInfo current,
    out string[] linkedPages
)
Public Shared Function Format ( _
    raw As String, _
    forIndexing As Boolean, _
    context As FormattingContext, _
    current As PageInfo, _
    <OutAttribute> ByRef linkedPages As String() _
) As String
public:
static String^ Format(
    String^ raw,
    bool forIndexing,
    FormattingContext context,
    PageInfo^ current,
    [OutAttribute] array<String^>^% linkedPages
)
Parameters
raw (String)
The raw WikiMarkup text.
forIndexing (Boolean)
A value indicating whether the formatting is being done for content indexing.
context (FormattingContext)
The formatting context.
current (PageInfo)
The current Page (can be null).
linkedPages ( array< String >[]()[][] %)
The linked pages, both existent and inexistent.
Return Value
The formatted text.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


Format Method (raw, forIndexing, context, current, linkedPages, bareBones)

Format Method (raw, forIndexing, context, current, linkedPages, bareBones)
ScrewTurn Wiki ► ScrewTurn.Wiki ► Formatter ► Format(String, Boolean, FormattingContext, PageInfo, array<String>[]()[]%, Boolean)
Formats WikiMarkup, converting it into XHTML.
Declaration Syntax
C# Visual Basic Visual C++
public static string Format(
    string raw,
    bool forIndexing,
    FormattingContext context,
    PageInfo current,
    out string[] linkedPages,
    bool bareBones
)
Public Shared Function Format ( _
    raw As String, _
    forIndexing As Boolean, _
    context As FormattingContext, _
    current As PageInfo, _
    <OutAttribute> ByRef linkedPages As String(), _
    bareBones As Boolean _
) As String
public:
static String^ Format(
    String^ raw,
    bool forIndexing,
    FormattingContext context,
    PageInfo^ current,
    [OutAttribute] array<String^>^% linkedPages,
    bool bareBones
)
Parameters
raw (String)
The raw WikiMarkup text.
forIndexing (Boolean)
A value indicating whether the formatting is being done for content indexing.
context (FormattingContext)
The formatting context.
current (PageInfo)
The current Page (can be null).
linkedPages ( array< String >[]()[][] %)
The linked pages, both existent and inexistent.
bareBones (Boolean)
A value indicating whether to format in bare-bones mode (for WYSIWYG editor).
Return Value
The formatted text.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


FormatPhase3 Method (raw, context, current)

FormatPhase3 Method (raw, context, current)
ScrewTurn Wiki ► ScrewTurn.Wiki ► Formatter ► FormatPhase3(String, FormattingContext, PageInfo)
Performs the internal Phase 3 of the Formatting pipeline.
Declaration Syntax
C# Visual Basic Visual C++
public static string FormatPhase3(
    string raw,
    FormattingContext context,
    PageInfo current
)
Public Shared Function FormatPhase3 ( _
    raw As String, _
    context As FormattingContext, _
    current As PageInfo _
) As String
public:
static String^ FormatPhase3(
    String^ raw,
    FormattingContext context,
    PageInfo^ current
)
Parameters
raw (String)
The raw data.
context (FormattingContext)
The formatting context.
current (PageInfo)
The current PageInfo, if any.
Return Value
The formatted content.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


StripHtml Method (content)

StripHtml Method (content)
ScrewTurn Wiki ► ScrewTurn.Wiki ► Formatter ► StripHtml(String)
Removes all HTML markup from a string.
Declaration Syntax
C# Visual Basic Visual C++
public static string StripHtml(
    string content
)
Public Shared Function StripHtml ( _
    content As String _
) As String
public:
static String^ StripHtml(
    String^ content
)
Parameters
content (String)
The string.
Return Value
The result.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


FormattingPipeline Class

FormattingPipeline Class
ScrewTurn Wiki ► ScrewTurn.Wiki ► FormattingPipeline
Contains methods for formatting content using a pipeline paradigm.
Declaration Syntax
C# Visual Basic Visual C++
public static class FormattingPipeline
Public NotInheritable Class FormattingPipeline
public ref class FormattingPipeline abstract sealed
Members
All Members | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | FormatWithPhase1And2(String, Boolean, FormattingContext, PageInfo) | Performs the Phases 1 and 2 of the formatting process.
 | FormatWithPhase1And2(String, Boolean, FormattingContext, PageInfo, array<String>[]()[]%) | Performs the Phases 1 and 2 of the formatting process.
 | FormatWithPhase3(String, FormattingContext, PageInfo) | Performs the Phase 3 of the formatting process.
 | PrepareTitle(String, Boolean, FormattingContext, PageInfo) | Prepares the title of an item for display.
Inheritance Hierarchy
Object
FormattingPipeline

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


FormatWithPhase1And2 Method

FormatWithPhase1And2 Method
ScrewTurn Wiki ► ScrewTurn.Wiki ► FormattingPipeline ► FormatWithPhase1And2()()()
Members
Icon | Member | Description
 | FormatWithPhase1And2(String, Boolean, FormattingContext, PageInfo) | Performs the Phases 1 and 2 of the formatting process.
 | FormatWithPhase1And2(String, Boolean, FormattingContext, PageInfo, array<String>[]()[]%) | Performs the Phases 1 and 2 of the formatting process.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


FormatWithPhase1And2 Method (raw, forIndexing, context, current)

FormatWithPhase1And2 Method (raw, forIndexing, context, current)
ScrewTurn Wiki ► ScrewTurn.Wiki ► FormattingPipeline ► FormatWithPhase1And2(String, Boolean, FormattingContext, PageInfo)
Performs the Phases 1 and 2 of the formatting process.
Declaration Syntax
C# Visual Basic Visual C++
public static string FormatWithPhase1And2(
    string raw,
    bool forIndexing,
    FormattingContext context,
    PageInfo current
)
Public Shared Function FormatWithPhase1And2 ( _
    raw As String, _
    forIndexing As Boolean, _
    context As FormattingContext, _
    current As PageInfo _
) As String
public:
static String^ FormatWithPhase1And2(
    String^ raw,
    bool forIndexing,
    FormattingContext context,
    PageInfo^ current
)
Parameters
raw (String)
The raw WikiMarkup to format.
forIndexing (Boolean)
A value indicating whether the formatting is being done for content indexing.
context (FormattingContext)
The formatting context.
current (PageInfo)
The current Page, if any.
Return Value
The formatted content.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


FormatWithPhase1And2 Method (raw, forIndexing, context, current, linkedPages)

FormatWithPhase1And2 Method (raw, forIndexing, context, current, linkedPages)
ScrewTurn Wiki ► ScrewTurn.Wiki ► FormattingPipeline ► FormatWithPhase1And2(String, Boolean, FormattingContext, PageInfo, array<String>[]()[]%)
Performs the Phases 1 and 2 of the formatting process.
Declaration Syntax
C# Visual Basic Visual C++
public static string FormatWithPhase1And2(
    string raw,
    bool forIndexing,
    FormattingContext context,
    PageInfo current,
    out string[] linkedPages
)
Public Shared Function FormatWithPhase1And2 ( _
    raw As String, _
    forIndexing As Boolean, _
    context As FormattingContext, _
    current As PageInfo, _
    <OutAttribute> ByRef linkedPages As String() _
) As String
public:
static String^ FormatWithPhase1And2(
    String^ raw,
    bool forIndexing,
    FormattingContext context,
    PageInfo^ current,
    [OutAttribute] array<String^>^% linkedPages
)
Parameters
raw (String)
The raw WikiMarkup to format.
forIndexing (Boolean)
A value indicating whether the formatting is being done for content indexing.
context (FormattingContext)
The formatting context.
current (PageInfo)
The current Page, if any.
linkedPages ( array< String >[]()[][] %)
The Pages linked by the current Page.
Return Value
The formatted content.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


FormatWithPhase3 Method (raw, context, current)

FormatWithPhase3 Method (raw, context, current)
ScrewTurn Wiki ► ScrewTurn.Wiki ► FormattingPipeline ► FormatWithPhase3(String, FormattingContext, PageInfo)
Performs the Phase 3 of the formatting process.
Declaration Syntax
C# Visual Basic Visual C++
public static string FormatWithPhase3(
    string raw,
    FormattingContext context,
    PageInfo current
)
Public Shared Function FormatWithPhase3 ( _
    raw As String, _
    context As FormattingContext, _
    current As PageInfo _
) As String
public:
static String^ FormatWithPhase3(
    String^ raw,
    FormattingContext context,
    PageInfo^ current
)
Parameters
raw (String)
The raw WikiMarkup to format.
context (FormattingContext)
The formatting context.
current (PageInfo)
The current Page, if any.
Return Value
The formatted content.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


PrepareTitle Method (title, forIndexing, context, current)

PrepareTitle Method (title, forIndexing, context, current)
ScrewTurn Wiki ► ScrewTurn.Wiki ► FormattingPipeline ► PrepareTitle(String, Boolean, FormattingContext, PageInfo)
Prepares the title of an item for display.
Declaration Syntax
C# Visual Basic Visual C++
public static string PrepareTitle(
    string title,
    bool forIndexing,
    FormattingContext context,
    PageInfo current
)
Public Shared Function PrepareTitle ( _
    title As String, _
    forIndexing As Boolean, _
    context As FormattingContext, _
    current As PageInfo _
) As String
public:
static String^ PrepareTitle(
    String^ title,
    bool forIndexing,
    FormattingContext context,
    PageInfo^ current
)
Parameters
title (String)
The input title.
forIndexing (Boolean)
A value indicating whether the formatting is being done for content indexing.
context (FormattingContext)
The context information.
current (PageInfo)
The current page, if any.
Return Value
The prepared title, properly sanitized.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


Hash Class

Hash Class
ScrewTurn Wiki ► ScrewTurn.Wiki ► Hash
Helps computing Hash codes.
Declaration Syntax
C# Visual Basic Visual C++
public static class Hash
Public NotInheritable Class Hash
public ref class Hash abstract sealed
Members
All Members | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | Compute(String) | Computes the Hash code of a string and converts it into a Hex string.
 | ComputeBytes(String) | Computes the Hash code of a string.
 | ComputeSecurityHash(String, String, DateTime, String) | Computes the Hash of a Username, mixing it with other data, in order to avoid illegal Account activations.
Inheritance Hierarchy
Object
Hash

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


Compute Method (input)

Compute Method (input)
ScrewTurn Wiki ► ScrewTurn.Wiki ► Hash ► Compute(String)
Computes the Hash code of a string and converts it into a Hex string.
Declaration Syntax
C# Visual Basic Visual C++
public static string Compute(
    string input
)
Public Shared Function Compute ( _
    input As String _
) As String
public:
static String^ Compute(
    String^ input
)
Parameters
input (String)
The string.
Return Value
The Hash code, converted into a Hex string.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


ComputeBytes Method (input)

ComputeBytes Method (input)
ScrewTurn Wiki ► ScrewTurn.Wiki ► Hash ► ComputeBytes(String)
Computes the Hash code of a string.
Declaration Syntax
C# Visual Basic Visual C++
public static byte[] ComputeBytes(
    string input
)
Public Shared Function ComputeBytes ( _
    input As String _
) As Byte()
public:
static array<unsigned char>^ ComputeBytes(
    String^ input
)
Parameters
input (String)
The string.
Return Value
The Hash code.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


ComputeSecurityHash Method (username, email, dateTime, otherData)

ComputeSecurityHash Method (username, email, dateTime, otherData)
ScrewTurn Wiki ► ScrewTurn.Wiki ► Hash ► ComputeSecurityHash(String, String, DateTime, String)
Computes the Hash of a Username, mixing it with other data, in order to avoid illegal Account activations.
Declaration Syntax
C# Visual Basic Visual C++
public static string ComputeSecurityHash(
    string username,
    string email,
    DateTime dateTime,
    string otherData
)
Public Shared Function ComputeSecurityHash ( _
    username As String, _
    email As String, _
    dateTime As DateTime, _
    otherData As String _
) As String
public:
static String^ ComputeSecurityHash(
    String^ username,
    String^ email,
    DateTime dateTime,
    String^ otherData
)
Parameters
username (String)
The Username.
email (String)
The email.
dateTime (DateTime)
The date/time.
otherData (String)
The other data to mix into the input string.
Return Value
The secured Hash of the Username.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


Host Class

Host Class
ScrewTurn Wiki ► ScrewTurn.Wiki ► Host
Implements the IHost interface.
Declaration Syntax
C# Visual Basic Visual C++
public class Host : IHostV30
Public Class Host _
    Implements IHostV30
public ref class Host : IHostV30
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | Host()()() | Initializes a new instance of the PluginHost class.
 | AddToolbarItem(ToolbarItem, String, String) | Adds an item in the Editing Toolbar.
 | AlignDateTimeWithPreferences(DateTime) | Aligns a Date and Time object to the User's Time Zone preferences.
 | ChangeCurrentUserLanguage(String) | Changes the language of the current user.
 | CheckActionForDirectory(StDirectoryInfo, String, UserInfo) | Checks whether an action is allowed for a directory.
 | CheckActionForGlobals(String, UserInfo) | Checks whether an action is allowed for a global resource.
 | CheckActionForNamespace(NamespaceInfo, String, UserInfo) | Checks whether an action is allowed for a namespace.
 | CheckActionForPage(PageInfo, String, UserInfo) | Checks whether an action is allowed for a page.
 | ClearCache(CacheData) | Clears the cache.
 | CustomSpecialTags | Gets the Special Tags added by providers.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | FileActivity | Event fired whenever an activity is performed on a file, directory or attachment.
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | FindNamespace(String) | Finds a namespace by name.
 | FindPage(String) | Gets a Wiki Page.
 | FindUser(String) | Finds a user by username, properly handling Users Storage Providers.
 | FindUserGroup(String) | Finds a user group by name.
 | Format(String) | Formats a block of WikiMarkup, using the built-in formatter only.
 | GetBackupContent(PageInfo, Int32) | Gets the Content of a Page Backup.
 | GetBackups(PageInfo) | Gets the Backup/Revision numbers of a Page.
 | GetCacheProviders(Boolean) | Gets the cache providers, either enabled or disabled.
 | GetCategories(NamespaceInfo) | Gets the List of Categories in a namespace.
 | GetCategoriesPerPage(PageInfo) | Gets the Categories of a Page.
 | GetCurrentUser()()() | Gets the authenticated user in the current session, if any.
 | GetDefaultProvider(Type) | Gets the default provider of the specified type.
 | GetFilesStorageProviders(Boolean) | Gets the files storage providers, either enabled or disabled.
 | GetFormattedContent(PageInfo) | Gets the formatted content of a Wiki Page.
 | GetFormatterProviders(Boolean) | Gets the formatter providers, either enabled or disabled.
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetNamespaces()()() | Gets the list of the namespaces.
 | GetNavigationPaths(NamespaceInfo) | Gets the list of Navigation Paths in a namespace.
 | GetPageContent(PageInfo) | Gets the Content of a Page.
 | GetPages(NamespaceInfo) | Gets the list of the Wiki Pages in a namespace.
 | GetPagesStorageProviders(Boolean) | Gets the pages storage providers, either enabled or disabled.
 | GetProviderConfiguration(String) | Gets the configuration of a provider.
 | GetSettingsStorageProvider()()() | Gets the current settings storage provider.
 | GetSettingValue(SettingName) | Gets the values of the Wiki Settings.
 | GetSnippets()()() | Gets the list of Snippets.
 | GetTheme(NamespaceInfo) | Gets the theme in use for a namespace.
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetUserGroups()()() | Gets the list of the user groups.
 | GetUsers()()() | Gets the list of the Users.
 | GetUsersStorageProviders(Boolean) | Gets the users storage providers, either enabled or disabled.
 | Instance | Gets or sets the singleton instance of the Host object.
 | ListDirectories(StDirectoryInfo) | Lists directories in a directory.
 | ListFiles(StDirectoryInfo) | Lists files in a directory.
 | ListPageAttachments(PageInfo) | Lists page attachments.
 | LogEntry(String, LogEntryType, String, Object) | Logs a new message.
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | NamespaceActivity | Event fired whenever an activity is performed on a namespace.
 | OnAttachmentActivity(String, String, String, String, FileActivity) | Fires the FileActivity event.
 | OnDirectoryActivity(String, String, String, FileActivity) | Fires the FileActivity event.
 | OnFileActivity(String, String, String, FileActivity) | Fires the FileActivity event.
 | OnNamespaceActivity(NamespaceInfo, String, NamespaceActivity) | Fires the NamespaceActivity event.
 | OnPageActivity(PageInfo, String, String, PageActivity) | Fires the PageActivity event.
 | OnUserAccountActivity(UserInfo, UserAccountActivity) | Fires the UserAccountActivity event.
 | OnUserGroupActivity(UserGroup, UserGroupActivity) | Fires the UserGroupActivity event.
 | PageActivity | Even fired whenever an activity is performed on a Page.
 | PerformSearch(String, Boolean, Boolean, SearchOptions) | Performs a search.
 | PrepareContentForIndexing(PageInfo, String) | Prepares content for indexing in the search engine, performing bare-bones formatting and removing all WikiMarkup and XML-like characters.
 | PrepareTitleForIndexing(PageInfo, String) | Prepares a title for indexing in the search engine, removing all WikiMarkup and XML-like characters.
 | SendEmail(String, String, String, String, Boolean) | Sends an Email.
 | SetProviderConfiguration(IProviderV30, String) | Sets the configuration of a provider.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | UpgradePageStatusToAcl(PageInfo, Char) | Upgrades the old Page Status to use the new ACL facilities.
 | UpgradeSecurityFlagsToGroupsAcl(UserGroup, UserGroup) | Upgrades the old security flags to use the new ACL facilities and user groups support.
 | UserAccountActivity | Event fired whenever an activity is performed on a User Account.
 | UserGroupActivity | Event fired whenever an activity is performed on a user group.
Inheritance Hierarchy
Object
Host

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


Host Constructor

Host Constructor
ScrewTurn Wiki ► ScrewTurn.Wiki ► Host ► Host()()()
Initializes a new instance of the PluginHost class.
Declaration Syntax
C# Visual Basic Visual C++
public Host()
Public Sub New
public:
Host()

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


AddToolbarItem Method (item, text, value)

AddToolbarItem Method (item, text, value)
ScrewTurn Wiki ► ScrewTurn.Wiki ► Host ► AddToolbarItem(ToolbarItem, String, String)
Adds an item in the Editing Toolbar.
Declaration Syntax
C# Visual Basic Visual C++
public void AddToolbarItem(
    ToolbarItem item,
    string text,
    string value
)
Public Sub AddToolbarItem ( _
    item As ToolbarItem, _
    text As String, _
    value As String _
)
public:
virtual void AddToolbarItem(
    ToolbarItem item,
    String^ text,
    String^ value
) sealed
Parameters
item (ToolbarItem)
The item to add.
text (String)
The text of the item.
value (String)
The value of the item.
Exceptions
Exception | Condition
ArgumentNullException | If text or value are null.
ArgumentException | If text or value are empty, or if they contain single or double quotes, or if value does not contain a pipe when item is SpecialTagWrap.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


AlignDateTimeWithPreferences Method (dt)

AlignDateTimeWithPreferences Method (dt)
ScrewTurn Wiki ► ScrewTurn.Wiki ► Host ► AlignDateTimeWithPreferences(DateTime)
Aligns a Date and Time object to the User's Time Zone preferences.
Declaration Syntax
C# Visual Basic Visual C++
public DateTime AlignDateTimeWithPreferences(
    DateTime dt
)
Public Function AlignDateTimeWithPreferences ( _
    dt As DateTime _
) As DateTime
public:
virtual DateTime AlignDateTimeWithPreferences(
    DateTime dt
) sealed
Parameters
dt (DateTime)
The Date/Time to align.
Return Value
The aligned Date/Time.
Remarks
The method takes care of daylight saving settings.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


ChangeCurrentUserLanguage Method (language)

ChangeCurrentUserLanguage Method (language)
ScrewTurn Wiki ► ScrewTurn.Wiki ► Host ► ChangeCurrentUserLanguage(String)
Changes the language of the current user.
Declaration Syntax
C# Visual Basic Visual C++
public void ChangeCurrentUserLanguage(
    string language
)
Public Sub ChangeCurrentUserLanguage ( _
    language As String _
)
public:
virtual void ChangeCurrentUserLanguage(
    String^ language
) sealed
Parameters
language (String)
The language code.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


CheckActionForDirectory Method (directory, action, user)

CheckActionForDirectory Method (directory, action, user)
ScrewTurn Wiki ► ScrewTurn.Wiki ► Host ► CheckActionForDirectory(StDirectoryInfo, String, UserInfo)
Checks whether an action is allowed for a directory.
Declaration Syntax
C# Visual Basic Visual C++
public bool CheckActionForDirectory(
    StDirectoryInfo directory,
    string action,
    UserInfo user
)
Public Function CheckActionForDirectory ( _
    directory As StDirectoryInfo, _
    action As String, _
    user As UserInfo _
) As Boolean
public:
virtual bool CheckActionForDirectory(
    StDirectoryInfo^ directory,
    String^ action,
    UserInfo^ user
) sealed
Parameters
directory (StDirectoryInfo)
The directory.
action (String)
The action (see Actions..::.ForDirectories).
user (UserInfo)
The user.
Return Value
true if the action is allowed, false otherwise.
Exceptions
Exception | Condition
ArgumentNullException | If directory, action or user are null.
ArgumentException | If action is empty.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


CheckActionForGlobals Method (action, user)

CheckActionForGlobals Method (action, user)
ScrewTurn Wiki ► ScrewTurn.Wiki ► Host ► CheckActionForGlobals(String, UserInfo)
Checks whether an action is allowed for a global resource.
Declaration Syntax
C# Visual Basic Visual C++
public bool CheckActionForGlobals(
    string action,
    UserInfo user
)
Public Function CheckActionForGlobals ( _
    action As String, _
    user As UserInfo _
) As Boolean
public:
virtual bool CheckActionForGlobals(
    String^ action,
    UserInfo^ user
) sealed
Parameters
action (String)
The action (see Actions..::.ForGlobals class)
user (UserInfo)
The user.
Return Value
true if the action is allowed, false otherwise.
Exceptions
Exception | Condition
ArgumentNullException | If action or user are null.
ArgumentException | If action is empty.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


CheckActionForNamespace Method (nspace, action, user)

CheckActionForNamespace Method (nspace, action, user)
ScrewTurn Wiki ► ScrewTurn.Wiki ► Host ► CheckActionForNamespace(NamespaceInfo, String, UserInfo)
Checks whether an action is allowed for a namespace.
Declaration Syntax
C# Visual Basic Visual C++
public bool CheckActionForNamespace(
    NamespaceInfo nspace,
    string action,
    UserInfo user
)
Public Function CheckActionForNamespace ( _
    nspace As NamespaceInfo, _
    action As String, _
    user As UserInfo _
) As Boolean
public:
virtual bool CheckActionForNamespace(
    NamespaceInfo^ nspace,
    String^ action,
    UserInfo^ user
) sealed
Parameters
nspace (NamespaceInfo)
The namespace (null for the root).
action (String)
The action (see Actions..::.ForNamespaces class)
user (UserInfo)
The user.
Return Value
true if the action is allowed, false otherwise.
Exceptions
Exception | Condition
ArgumentNullException | If action or user are null.
ArgumentException | If action is empty.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


CheckActionForPage Method (page, action, user)

CheckActionForPage Method (page, action, user)
ScrewTurn Wiki ► ScrewTurn.Wiki ► Host ► CheckActionForPage(PageInfo, String, UserInfo)
Checks whether an action is allowed for a page.
Declaration Syntax
C# Visual Basic Visual C++
public bool CheckActionForPage(
    PageInfo page,
    string action,
    UserInfo user
)
Public Function CheckActionForPage ( _
    page As PageInfo, _
    action As String, _
    user As UserInfo _
) As Boolean
public:
virtual bool CheckActionForPage(
    PageInfo^ page,
    String^ action,
    UserInfo^ user
) sealed
Parameters
page (PageInfo)
The page.
action (String)
The action (see Actions..::.ForPages class)
user (UserInfo)
The user.
Return Value
true if the action is allowed, false otherwise.
Exceptions
Exception | Condition
ArgumentNullException | If page, action or user are null.
ArgumentException | If action is empty.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


ClearCache Method (data)

ClearCache Method (data)
ScrewTurn Wiki ► ScrewTurn.Wiki ► Host ► ClearCache(CacheData)
Clears the cache.
Declaration Syntax
C# Visual Basic Visual C++
public void ClearCache(
    CacheData data
)
Public Sub ClearCache ( _
    data As CacheData _
)
public:
virtual void ClearCache(
    CacheData data
) sealed
Parameters
data (CacheData)
The part of the cache to clear.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


CustomSpecialTags Property

CustomSpecialTags Property
ScrewTurn Wiki ► ScrewTurn.Wiki ► Host ► CustomSpecialTags
Gets the Special Tags added by providers.
Declaration Syntax
C# Visual Basic Visual C++
public Dictionary<string, CustomToolbarItem> CustomSpecialTags { get; }
Public ReadOnly Property CustomSpecialTags As Dictionary(Of String, CustomToolbarItem)
public:
property Dictionary<String^, CustomToolbarItem^>^ CustomSpecialTags {
    Dictionary<String^, CustomToolbarItem^>^ get ();
}

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


FileActivity Event

FileActivity Event
ScrewTurn Wiki ► ScrewTurn.Wiki ► Host ► FileActivity
Event fired whenever an activity is performed on a file, directory or attachment.
Declaration Syntax
C# Visual Basic Visual C++
public event EventHandler<FileActivityEventArgs> FileActivity
Public Event FileActivity As EventHandler(Of FileActivityEventArgs)
public:
virtual  event EventHandler<FileActivityEventArgs^>^ FileActivity {
    void add (EventHandler<FileActivityEventArgs^>^ value);
    void remove (EventHandler<FileActivityEventArgs^>^ value);
}

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


FindNamespace Method (name)

FindNamespace Method (name)
ScrewTurn Wiki ► ScrewTurn.Wiki ► Host ► FindNamespace(String)
Finds a namespace by name.
Declaration Syntax
C# Visual Basic Visual C++
public NamespaceInfo FindNamespace(
    string name
)
Public Function FindNamespace ( _
    name As String _
) As NamespaceInfo
public:
virtual NamespaceInfo^ FindNamespace(
    String^ name
) sealed
Parameters
name (String)
The name.
Return Value
The NamespaceInfo, or null if no namespaces are found.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


FindPage Method (fullName)

FindPage Method (fullName)
ScrewTurn Wiki ► ScrewTurn.Wiki ► Host ► FindPage(String)
Gets a Wiki Page.
Declaration Syntax
C# Visual Basic Visual C++
public PageInfo FindPage(
    string fullName
)
Public Function FindPage ( _
    fullName As String _
) As PageInfo
public:
virtual PageInfo^ FindPage(
    String^ fullName
) sealed
Parameters
fullName (String)
The full Name of the Page.
Return Value
The Wiki Page or null.
Exceptions
Exception | Condition
ArgumentNullException | If fullName is null.
ArgumentException | If fullName is empty.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


FindUser Method (username)

FindUser Method (username)
ScrewTurn Wiki ► ScrewTurn.Wiki ► Host ► FindUser(String)
Finds a user by username, properly handling Users Storage Providers.
Declaration Syntax
C# Visual Basic Visual C++
public UserInfo FindUser(
    string username
)
Public Function FindUser ( _
    username As String _
) As UserInfo
public:
virtual UserInfo^ FindUser(
    String^ username
) sealed
Parameters
username (String)
The username.
Return Value
The UserInfo, or null if no users are found.
Exceptions
Exception | Condition
ArgumentNullException | If username is null.
ArgumentException | If username is empty.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


FindUserGroup Method (name)

FindUserGroup Method (name)
ScrewTurn Wiki ► ScrewTurn.Wiki ► Host ► FindUserGroup(String)
Finds a user group by name.
Declaration Syntax
C# Visual Basic Visual C++
public UserGroup FindUserGroup(
    string name
)
Public Function FindUserGroup ( _
    name As String _
) As UserGroup
public:
virtual UserGroup^ FindUserGroup(
    String^ name
) sealed
Parameters
name (String)
The name.
Return Value
The [T:UserGroup ], or null if no groups are found.
Exceptions
Exception | Condition
ArgumentNullException | If name is null.
ArgumentException | If name is empty.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


Format Method (raw)

Format Method (raw)
ScrewTurn Wiki ► ScrewTurn.Wiki ► Host ► Format(String)
Formats a block of WikiMarkup, using the built-in formatter only.
Declaration Syntax
C# Visual Basic Visual C++
public string Format(
    string raw
)
Public Function Format ( _
    raw As String _
) As String
public:
virtual String^ Format(
    String^ raw
) sealed
Parameters
raw (String)
The block of WikiMarkup.
Return Value
The formatted content.
Exceptions
Exception | Condition
ArgumentNullException | If raw is null.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


GetBackupContent Method (page, revision)

GetBackupContent Method (page, revision)
ScrewTurn Wiki ► ScrewTurn.Wiki ► Host ► GetBackupContent(PageInfo, Int32)
Gets the Content of a Page Backup.
Declaration Syntax
C# Visual Basic Visual C++
public PageContent GetBackupContent(
    PageInfo page,
    int revision
)
Public Function GetBackupContent ( _
    page As PageInfo, _
    revision As Integer _
) As PageContent
public:
virtual PageContent^ GetBackupContent(
    PageInfo^ page,
    int revision
) sealed
Parameters
page (PageInfo)
The Page.
revision (Int32)
The revision.
Return Value
The Backup Content.
Exceptions
Exception | Condition
ArgumentNullException | If page is null.
ArgumentOutOfRangeException | If revision is less than zero.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


GetBackups Method (page)

GetBackups Method (page)
ScrewTurn Wiki ► ScrewTurn.Wiki ► Host ► GetBackups(PageInfo)
Gets the Backup/Revision numbers of a Page.
Declaration Syntax
C# Visual Basic Visual C++
public int[] GetBackups(
    PageInfo page
)
Public Function GetBackups ( _
    page As PageInfo _
) As Integer()
public:
virtual array<int>^ GetBackups(
    PageInfo^ page
) sealed
Parameters
page (PageInfo)
The Page.
Return Value
The Backup/Revision numbers.
Exceptions
Exception | Condition
ArgumentNullException | If page is null.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


GetCacheProviders Method (enabled)

GetCacheProviders Method (enabled)
ScrewTurn Wiki ► ScrewTurn.Wiki ► Host ► GetCacheProviders(Boolean)
Gets the cache providers, either enabled or disabled.
Declaration Syntax
C# Visual Basic Visual C++
public ICacheProviderV30[] GetCacheProviders(
    bool enabled
)
Public Function GetCacheProviders ( _
    enabled As Boolean _
) As ICacheProviderV30()
public:
virtual array<ICacheProviderV30^>^ GetCacheProviders(
    bool enabled
) sealed
Parameters
enabled (Boolean)
true to get enabled providers, false to get disabled providers.
Return Value
The providers.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


GetCategories Method (nspace)

GetCategories Method (nspace)
ScrewTurn Wiki ► ScrewTurn.Wiki ► Host ► GetCategories(NamespaceInfo)
Gets the List of Categories in a namespace.
Declaration Syntax
C# Visual Basic Visual C++
public CategoryInfo[] GetCategories(
    NamespaceInfo nspace
)
Public Function GetCategories ( _
    nspace As NamespaceInfo _
) As CategoryInfo()
public:
virtual array<CategoryInfo^>^ GetCategories(
    NamespaceInfo^ nspace
) sealed
Parameters
nspace (NamespaceInfo)
The namespace (null for the root).
Return Value
The categories.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


GetCategoriesPerPage Method (page)

GetCategoriesPerPage Method (page)
ScrewTurn Wiki ► ScrewTurn.Wiki ► Host ► GetCategoriesPerPage(PageInfo)
Gets the Categories of a Page.
Declaration Syntax
C# Visual Basic Visual C++
public CategoryInfo[] GetCategoriesPerPage(
    PageInfo page
)
Public Function GetCategoriesPerPage ( _
    page As PageInfo _
) As CategoryInfo()
public:
virtual array<CategoryInfo^>^ GetCategoriesPerPage(
    PageInfo^ page
) sealed
Parameters
page (PageInfo)
The Page.
Return Value
The Categories.
Exceptions
Exception | Condition
ArgumentNullException | If page is null.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


GetCurrentUser Method

GetCurrentUser Method
ScrewTurn Wiki ► ScrewTurn.Wiki ► Host ► GetCurrentUser()()()
Gets the authenticated user in the current session, if any.
Declaration Syntax
C# Visual Basic Visual C++
public UserInfo GetCurrentUser()
Public Function GetCurrentUser As UserInfo
public:
virtual UserInfo^ GetCurrentUser() sealed
Return Value
The authenticated user, or null if no user is authenticated.
Remarks
If the built-it admin user is authenticated, the returned user has admin as Username.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


GetDefaultProvider Method (providerType)

GetDefaultProvider Method (providerType)
ScrewTurn Wiki ► ScrewTurn.Wiki ► Host ► GetDefaultProvider(Type)
Gets the default provider of the specified type.
Declaration Syntax
C# Visual Basic Visual C++
public string GetDefaultProvider(
    Type providerType
)
Public Function GetDefaultProvider ( _
    providerType As Type _
) As String
public:
virtual String^ GetDefaultProvider(
    Type^ providerType
) sealed
Parameters
providerType (Type)
The type of the provider ( IPagesStorageProviderV30, IUsersStorageProviderV30, IFilesStorageProviderV30, ICacheStorageProviderV30).
Return Value
The Full type name of the default provider of the specified type or null.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


GetFilesStorageProviders Method (enabled)

GetFilesStorageProviders Method (enabled)
ScrewTurn Wiki ► ScrewTurn.Wiki ► Host ► GetFilesStorageProviders(Boolean)
Gets the files storage providers, either enabled or disabled.
Declaration Syntax
C# Visual Basic Visual C++
public IFilesStorageProviderV30[] GetFilesStorageProviders(
    bool enabled
)
Public Function GetFilesStorageProviders ( _
    enabled As Boolean _
) As IFilesStorageProviderV30()
public:
virtual array<IFilesStorageProviderV30^>^ GetFilesStorageProviders(
    bool enabled
) sealed
Parameters
enabled (Boolean)
true to get enabled providers, false to get disabled providers.
Return Value
The providers.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


GetFormattedContent Method (page)

GetFormattedContent Method (page)
ScrewTurn Wiki ► ScrewTurn.Wiki ► Host ► GetFormattedContent(PageInfo)
Gets the formatted content of a Wiki Page.
Declaration Syntax
C# Visual Basic Visual C++
public string GetFormattedContent(
    PageInfo page
)
Public Function GetFormattedContent ( _
    page As PageInfo _
) As String
public:
virtual String^ GetFormattedContent(
    PageInfo^ page
) sealed
Parameters
page (PageInfo)
The Page.
Return Value
The formatted content.
Exceptions
Exception | Condition
ArgumentNullException | If page is null.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


GetFormatterProviders Method (enabled)

GetFormatterProviders Method (enabled)
ScrewTurn Wiki ► ScrewTurn.Wiki ► Host ► GetFormatterProviders(Boolean)
Gets the formatter providers, either enabled or disabled.
Declaration Syntax
C# Visual Basic Visual C++
public IFormatterProviderV30[] GetFormatterProviders(
    bool enabled
)
Public Function GetFormatterProviders ( _
    enabled As Boolean _
) As IFormatterProviderV30()
public:
virtual array<IFormatterProviderV30^>^ GetFormatterProviders(
    bool enabled
) sealed
Parameters
enabled (Boolean)
true to get enabled providers, false to get disabled providers.
Return Value
The providers.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


GetNamespaces Method

GetNamespaces Method
ScrewTurn Wiki ► ScrewTurn.Wiki ► Host ► GetNamespaces()()()
Gets the list of the namespaces.
Declaration Syntax
C# Visual Basic Visual C++
public NamespaceInfo[] GetNamespaces()
Public Function GetNamespaces As NamespaceInfo()
public:
virtual array<NamespaceInfo^>^ GetNamespaces() sealed
Return Value
The namespaces.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


GetNavigationPaths Method (nspace)

GetNavigationPaths Method (nspace)
ScrewTurn Wiki ► ScrewTurn.Wiki ► Host ► GetNavigationPaths(NamespaceInfo)
Gets the list of Navigation Paths in a namespace.
Declaration Syntax
C# Visual Basic Visual C++
public NavigationPath[] GetNavigationPaths(
    NamespaceInfo nspace
)
Public Function GetNavigationPaths ( _
    nspace As NamespaceInfo _
) As NavigationPath()
public:
virtual array<NavigationPath^>^ GetNavigationPaths(
    NamespaceInfo^ nspace
) sealed
Parameters
nspace (NamespaceInfo)
The namespace (null for the root).
Return Value
The navigation paths.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


GetPageContent Method (page)

GetPageContent Method (page)
ScrewTurn Wiki ► ScrewTurn.Wiki ► Host ► GetPageContent(PageInfo)
Gets the Content of a Page.
Declaration Syntax
C# Visual Basic Visual C++
public PageContent GetPageContent(
    PageInfo page
)
Public Function GetPageContent ( _
    page As PageInfo _
) As PageContent
public:
virtual PageContent^ GetPageContent(
    PageInfo^ page
) sealed
Parameters
page (PageInfo)
The Page.
Return Value
The Page Content.
Exceptions
Exception | Condition
ArgumentNullException | If page is null.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


GetPages Method (nspace)

GetPages Method (nspace)
ScrewTurn Wiki ► ScrewTurn.Wiki ► Host ► GetPages(NamespaceInfo)
Gets the list of the Wiki Pages in a namespace.
Declaration Syntax
C# Visual Basic Visual C++
public PageInfo[] GetPages(
    NamespaceInfo nspace
)
Public Function GetPages ( _
    nspace As NamespaceInfo _
) As PageInfo()
public:
virtual array<PageInfo^>^ GetPages(
    NamespaceInfo^ nspace
) sealed
Parameters
nspace (NamespaceInfo)
The namespace (null for the root).
Return Value
The pages.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


GetPagesStorageProviders Method (enabled)

GetPagesStorageProviders Method (enabled)
ScrewTurn Wiki ► ScrewTurn.Wiki ► Host ► GetPagesStorageProviders(Boolean)
Gets the pages storage providers, either enabled or disabled.
Declaration Syntax
C# Visual Basic Visual C++
public IPagesStorageProviderV30[] GetPagesStorageProviders(
    bool enabled
)
Public Function GetPagesStorageProviders ( _
    enabled As Boolean _
) As IPagesStorageProviderV30()
public:
virtual array<IPagesStorageProviderV30^>^ GetPagesStorageProviders(
    bool enabled
) sealed
Parameters
enabled (Boolean)
true to get enabled providers, false to get disabled providers.
Return Value
The providers.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


GetProviderConfiguration Method (providerTypeName)

GetProviderConfiguration Method (providerTypeName)
ScrewTurn Wiki ► ScrewTurn.Wiki ► Host ► GetProviderConfiguration(String)
Gets the configuration of a provider.
Declaration Syntax
C# Visual Basic Visual C++
public string GetProviderConfiguration(
    string providerTypeName
)
Public Function GetProviderConfiguration ( _
    providerTypeName As String _
) As String
public:
virtual String^ GetProviderConfiguration(
    String^ providerTypeName
) sealed
Parameters
providerTypeName (String)
The type name of the provider, such as 'Vendor.Namespace.Provider'.
Return Value
The configuration (can be empty or null).
Exceptions
Exception | Condition
ArgumentNullException | If providerTypeName is null.
ArgumentException | If providerTypeName is empty.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


GetSettingsStorageProvider Method

GetSettingsStorageProvider Method
ScrewTurn Wiki ► ScrewTurn.Wiki ► Host ► GetSettingsStorageProvider()()()
Gets the current settings storage provider.
Declaration Syntax
C# Visual Basic Visual C++
public ISettingsStorageProviderV30 GetSettingsStorageProvider()
Public Function GetSettingsStorageProvider As ISettingsStorageProviderV30
public:
virtual ISettingsStorageProviderV30^ GetSettingsStorageProvider() sealed
Return Value
The settings storage provider.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


GetSettingValue Method (name)

GetSettingValue Method (name)
ScrewTurn Wiki ► ScrewTurn.Wiki ► Host ► GetSettingValue(SettingName)
Gets the values of the Wiki Settings.
Declaration Syntax
C# Visual Basic Visual C++
public string GetSettingValue(
    SettingName name
)
Public Function GetSettingValue ( _
    name As SettingName _
) As String
public:
virtual String^ GetSettingValue(
    SettingName name
) sealed
Parameters
name (SettingName)
The Setting's Name.
Return Value
The Setting's value.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


GetSnippets Method

GetSnippets Method
ScrewTurn Wiki ► ScrewTurn.Wiki ► Host ► GetSnippets()()()
Gets the list of Snippets.
Declaration Syntax
C# Visual Basic Visual C++
public Snippet[] GetSnippets()
Public Function GetSnippets As Snippet()
public:
virtual array<Snippet^>^ GetSnippets() sealed
Return Value
The snippets.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


GetTheme Method (nspace)

GetTheme Method (nspace)
ScrewTurn Wiki ► ScrewTurn.Wiki ► Host ► GetTheme(NamespaceInfo)
Gets the theme in use for a namespace.
Declaration Syntax
C# Visual Basic Visual C++
public string GetTheme(
    NamespaceInfo nspace
)
Public Function GetTheme ( _
    nspace As NamespaceInfo _
) As String
public:
virtual String^ GetTheme(
    NamespaceInfo^ nspace
) sealed
Parameters
nspace (NamespaceInfo)
The namespace (null for the root).
Return Value
The theme.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


GetUserGroups Method

GetUserGroups Method
ScrewTurn Wiki ► ScrewTurn.Wiki ► Host ► GetUserGroups()()()
Gets the list of the user groups.
Declaration Syntax
C# Visual Basic Visual C++
public UserGroup[] GetUserGroups()
Public Function GetUserGroups As UserGroup()
public:
virtual array<UserGroup^>^ GetUserGroups() sealed
Return Value
The groups.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


GetUsers Method

GetUsers Method
ScrewTurn Wiki ► ScrewTurn.Wiki ► Host ► GetUsers()()()
Gets the list of the Users.
Declaration Syntax
C# Visual Basic Visual C++
public UserInfo[] GetUsers()
Public Function GetUsers As UserInfo()
public:
virtual array<UserInfo^>^ GetUsers() sealed
Return Value
The users.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


GetUsersStorageProviders Method (enabled)

GetUsersStorageProviders Method (enabled)
ScrewTurn Wiki ► ScrewTurn.Wiki ► Host ► GetUsersStorageProviders(Boolean)
Gets the users storage providers, either enabled or disabled.
Declaration Syntax
C# Visual Basic Visual C++
public IUsersStorageProviderV30[] GetUsersStorageProviders(
    bool enabled
)
Public Function GetUsersStorageProviders ( _
    enabled As Boolean _
) As IUsersStorageProviderV30()
public:
virtual array<IUsersStorageProviderV30^>^ GetUsersStorageProviders(
    bool enabled
) sealed
Parameters
enabled (Boolean)
true to get enabled providers, false to get disabled providers.
Return Value
The providers.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


Instance Property

Instance Property
ScrewTurn Wiki ► ScrewTurn.Wiki ► Host ► Instance
Gets or sets the singleton instance of the Host object.
Declaration Syntax
C# Visual Basic Visual C++
public static Host Instance { get; set; }
Public Shared Property Instance As Host
public:
static property Host^ Instance {
    Host^ get ();
    void set (Host^ value);
}

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


ListDirectories Method (directory)

ListDirectories Method (directory)
ScrewTurn Wiki ► ScrewTurn.Wiki ► Host ► ListDirectories(StDirectoryInfo)
Lists directories in a directory.
Declaration Syntax
C# Visual Basic Visual C++
public StDirectoryInfo[] ListDirectories(
    StDirectoryInfo directory
)
Public Function ListDirectories ( _
    directory As StDirectoryInfo _
) As StDirectoryInfo()
public:
virtual array<StDirectoryInfo^>^ ListDirectories(
    StDirectoryInfo^ directory
) sealed
Parameters
directory (StDirectoryInfo)
The directory (null for the root, first invocation).
Return Value
The directories.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


ListFiles Method (directory)

ListFiles Method (directory)
ScrewTurn Wiki ► ScrewTurn.Wiki ► Host ► ListFiles(StDirectoryInfo)
Lists files in a directory.
Declaration Syntax
C# Visual Basic Visual C++
public StFileInfo[] ListFiles(
    StDirectoryInfo directory
)
Public Function ListFiles ( _
    directory As StDirectoryInfo _
) As StFileInfo()
public:
virtual array<StFileInfo^>^ ListFiles(
    StDirectoryInfo^ directory
) sealed
Parameters
directory (StDirectoryInfo)
The directory (null for the root, first invocation).
Return Value
The files.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


ListPageAttachments Method (page)

ListPageAttachments Method (page)
ScrewTurn Wiki ► ScrewTurn.Wiki ► Host ► ListPageAttachments(PageInfo)
Lists page attachments.
Declaration Syntax
C# Visual Basic Visual C++
public StFileInfo[] ListPageAttachments(
    PageInfo page
)
Public Function ListPageAttachments ( _
    page As PageInfo _
) As StFileInfo()
public:
virtual array<StFileInfo^>^ ListPageAttachments(
    PageInfo^ page
) sealed
Parameters
page (PageInfo)
The page.
Return Value
The attachments.
Exceptions
Exception | Condition
ArgumentNullException | If page is null.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


LogEntry Method (message, entryType, user, caller)

LogEntry Method (message, entryType, user, caller)
ScrewTurn Wiki ► ScrewTurn.Wiki ► Host ► LogEntry(String, LogEntryType, String, Object)
Logs a new message.
Declaration Syntax
C# Visual Basic Visual C++
public void LogEntry(
    string message,
    LogEntryType entryType,
    string user,
    Object caller
)
Public Sub LogEntry ( _
    message As String, _
    entryType As LogEntryType, _
    user As String, _
    caller As Object _
)
public:
virtual void LogEntry(
    String^ message,
    LogEntryType entryType,
    String^ user,
    Object^ caller
) sealed
Parameters
message (String)
The Message.
entryType (LogEntryType)
The Entry Type.
user (String)
The user, or null. If null, the system will log "PluginName+System".
caller (Object)
The Component that calls the method. The caller cannot be null.
Exceptions
Exception | Condition
ArgumentNullException | If message or caller are null.
ArgumentException | If message is empty.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


NamespaceActivity Event

NamespaceActivity Event
ScrewTurn Wiki ► ScrewTurn.Wiki ► Host ► NamespaceActivity
Event fired whenever an activity is performed on a namespace.
Declaration Syntax
C# Visual Basic Visual C++
public event EventHandler<NamespaceActivityEventArgs> NamespaceActivity
Public Event NamespaceActivity As EventHandler(Of NamespaceActivityEventArgs)
public:
virtual  event EventHandler<NamespaceActivityEventArgs^>^ NamespaceActivity {
    void add (EventHandler<NamespaceActivityEventArgs^>^ value);
    void remove (EventHandler<NamespaceActivityEventArgs^>^ value);
}

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


OnAttachmentActivity Method (provider, attachment, page, oldAttachmentName, activity)

OnAttachmentActivity Method (provider, attachment, page, oldAttachmentName, activity)
ScrewTurn Wiki ► ScrewTurn.Wiki ► Host ► OnAttachmentActivity(String, String, String, String, FileActivity)
Fires the FileActivity event.
Declaration Syntax
C# Visual Basic Visual C++
public void OnAttachmentActivity(
    string provider,
    string attachment,
    string page,
    string oldAttachmentName,
    FileActivity activity
)
Public Sub OnAttachmentActivity ( _
    provider As String, _
    attachment As String, _
    page As String, _
    oldAttachmentName As String, _
    activity As FileActivity _
)
public:
void OnAttachmentActivity(
    String^ provider,
    String^ attachment,
    String^ page,
    String^ oldAttachmentName,
    FileActivity activity
)
Parameters
provider (String)
The provider that handles the attachment.
attachment (String)
The old name of the renamed attachment, if any.
page (String)
The page that owns the attachment.
oldAttachmentName (String)
The old name of the renamed attachment, if any.
activity (FileActivity)
The activity.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


OnDirectoryActivity Method (provider, directory, oldDirectoryName, activity)

OnDirectoryActivity Method (provider, directory, oldDirectoryName, activity)
ScrewTurn Wiki ► ScrewTurn.Wiki ► Host ► OnDirectoryActivity(String, String, String, FileActivity)
Fires the FileActivity event.
Declaration Syntax
C# Visual Basic Visual C++
public void OnDirectoryActivity(
    string provider,
    string directory,
    string oldDirectoryName,
    FileActivity activity
)
Public Sub OnDirectoryActivity ( _
    provider As String, _
    directory As String, _
    oldDirectoryName As String, _
    activity As FileActivity _
)
public:
void OnDirectoryActivity(
    String^ provider,
    String^ directory,
    String^ oldDirectoryName,
    FileActivity activity
)
Parameters
provider (String)
The provider that handles the directory.
directory (String)
The directory that changed.
oldDirectoryName (String)
The old name of the renamed directory, if any.
activity (FileActivity)
The activity.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


OnFileActivity Method (provider, file, oldFileName, activity)

OnFileActivity Method (provider, file, oldFileName, activity)
ScrewTurn Wiki ► ScrewTurn.Wiki ► Host ► OnFileActivity(String, String, String, FileActivity)
Fires the FileActivity event.
Declaration Syntax
C# Visual Basic Visual C++
public void OnFileActivity(
    string provider,
    string file,
    string oldFileName,
    FileActivity activity
)
Public Sub OnFileActivity ( _
    provider As String, _
    file As String, _
    oldFileName As String, _
    activity As FileActivity _
)
public:
void OnFileActivity(
    String^ provider,
    String^ file,
    String^ oldFileName,
    FileActivity activity
)
Parameters
provider (String)
The provider that handles the file.
file (String)
The name of the file that changed.
oldFileName (String)
The old name of the renamed file, if any.
activity (FileActivity)
The activity.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


OnNamespaceActivity Method (nspace, nspaceOldName, activity)

OnNamespaceActivity Method (nspace, nspaceOldName, activity)
ScrewTurn Wiki ► ScrewTurn.Wiki ► Host ► OnNamespaceActivity(NamespaceInfo, String, NamespaceActivity)
Fires the NamespaceActivity event.
Declaration Syntax
C# Visual Basic Visual C++
public void OnNamespaceActivity(
    NamespaceInfo nspace,
    string nspaceOldName,
    NamespaceActivity activity
)
Public Sub OnNamespaceActivity ( _
    nspace As NamespaceInfo, _
    nspaceOldName As String, _
    activity As NamespaceActivity _
)
public:
void OnNamespaceActivity(
    NamespaceInfo^ nspace,
    String^ nspaceOldName,
    NamespaceActivity activity
)
Parameters
nspace (NamespaceInfo)
The namespace the activity refers to.
nspaceOldName (String)
The old name of the renamed namespace, or null.
activity (NamespaceActivity)
The activity.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


OnPageActivity Method (page, pageOldName, author, activity)

OnPageActivity Method (page, pageOldName, author, activity)
ScrewTurn Wiki ► ScrewTurn.Wiki ► Host ► OnPageActivity(PageInfo, String, String, PageActivity)
Fires the PageActivity event.
Declaration Syntax
C# Visual Basic Visual C++
public void OnPageActivity(
    PageInfo page,
    string pageOldName,
    string author,
    PageActivity activity
)
Public Sub OnPageActivity ( _
    page As PageInfo, _
    pageOldName As String, _
    author As String, _
    activity As PageActivity _
)
public:
void OnPageActivity(
    PageInfo^ page,
    String^ pageOldName,
    String^ author,
    PageActivity activity
)
Parameters
page (PageInfo)
The page the activity refers to.
pageOldName (String)
The old name of the renamed page, or null.
author (String)
The author of the activity.
activity (PageActivity)
The activity.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


OnUserAccountActivity Method (user, activity)

OnUserAccountActivity Method (user, activity)
ScrewTurn Wiki ► ScrewTurn.Wiki ► Host ► OnUserAccountActivity(UserInfo, UserAccountActivity)
Fires the UserAccountActivity event.
Declaration Syntax
C# Visual Basic Visual C++
public void OnUserAccountActivity(
    UserInfo user,
    UserAccountActivity activity
)
Public Sub OnUserAccountActivity ( _
    user As UserInfo, _
    activity As UserAccountActivity _
)
public:
void OnUserAccountActivity(
    UserInfo^ user,
    UserAccountActivity activity
)
Parameters
user (UserInfo)
The user the activity refers to.
activity (UserAccountActivity)
The activity.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


OnUserGroupActivity Method (group, activity)

OnUserGroupActivity Method (group, activity)
ScrewTurn Wiki ► ScrewTurn.Wiki ► Host ► OnUserGroupActivity(UserGroup, UserGroupActivity)
Fires the UserGroupActivity event.
Declaration Syntax
C# Visual Basic Visual C++
public void OnUserGroupActivity(
    UserGroup group,
    UserGroupActivity activity
)
Public Sub OnUserGroupActivity ( _
    group As UserGroup, _
    activity As UserGroupActivity _
)
public:
void OnUserGroupActivity(
    UserGroup^ group,
    UserGroupActivity activity
)
Parameters
group (UserGroup)
The group the activity refers to.
activity (UserGroupActivity)
The activity.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


PageActivity Event

PageActivity Event
ScrewTurn Wiki ► ScrewTurn.Wiki ► Host ► PageActivity
Even fired whenever an activity is performed on a Page.
Declaration Syntax
C# Visual Basic Visual C++
public event EventHandler<PageActivityEventArgs> PageActivity
Public Event PageActivity As EventHandler(Of PageActivityEventArgs)
public:
virtual  event EventHandler<PageActivityEventArgs^>^ PageActivity {
    void add (EventHandler<PageActivityEventArgs^>^ value);
    void remove (EventHandler<PageActivityEventArgs^>^ value);
}

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


PerformSearch Method (query, fullText, filesAndAttachments, options)

PerformSearch Method (query, fullText, filesAndAttachments, options)
ScrewTurn Wiki ► ScrewTurn.Wiki ► Host ► PerformSearch(String, Boolean, Boolean, SearchOptions)
Performs a search.
Declaration Syntax
C# Visual Basic Visual C++
public SearchResultCollection PerformSearch(
    string query,
    bool fullText,
    bool filesAndAttachments,
    SearchOptions options
)
Public Function PerformSearch ( _
    query As String, _
    fullText As Boolean, _
    filesAndAttachments As Boolean, _
    options As SearchOptions _
) As SearchResultCollection
public:
virtual SearchResultCollection^ PerformSearch(
    String^ query,
    bool fullText,
    bool filesAndAttachments,
    SearchOptions options
) sealed
Parameters
query (String)
The search query.
fullText (Boolean)
A value indicating whether to perform a full-text search.
filesAndAttachments (Boolean)
A value indicating whether to search the names of files and attachments.
options (SearchOptions)
The search options.
Return Value
The search results.
Exceptions
Exception | Condition
ArgumentNullException | If query is null.
ArgumentException | If query is empty.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


PrepareContentForIndexing Method (page, content)

PrepareContentForIndexing Method (page, content)
ScrewTurn Wiki ► ScrewTurn.Wiki ► Host ► PrepareContentForIndexing(PageInfo, String)
Prepares content for indexing in the search engine, performing bare-bones formatting and removing all WikiMarkup and XML-like characters.
Declaration Syntax
C# Visual Basic Visual C++
public string PrepareContentForIndexing(
    PageInfo page,
    string content
)
Public Function PrepareContentForIndexing ( _
    page As PageInfo, _
    content As String _
) As String
public:
virtual String^ PrepareContentForIndexing(
    PageInfo^ page,
    String^ content
) sealed
Parameters
page (PageInfo)
The page being indexed, if any, null otherwise.
content (String)
The string to prepare.
Return Value
The sanitized string.
Exceptions
Exception | Condition
ArgumentNullException | If content is null.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


PrepareTitleForIndexing Method (page, title)

PrepareTitleForIndexing Method (page, title)
ScrewTurn Wiki ► ScrewTurn.Wiki ► Host ► PrepareTitleForIndexing(PageInfo, String)
Prepares a title for indexing in the search engine, removing all WikiMarkup and XML-like characters.
Declaration Syntax
C# Visual Basic Visual C++
public string PrepareTitleForIndexing(
    PageInfo page,
    string title
)
Public Function PrepareTitleForIndexing ( _
    page As PageInfo, _
    title As String _
) As String
public:
virtual String^ PrepareTitleForIndexing(
    PageInfo^ page,
    String^ title
) sealed
Parameters
page (PageInfo)
The page being indexed, if any, null otherwise.
title (String)
The title to prepare.
Return Value
The sanitized string.
Exceptions
Exception | Condition
ArgumentNullException | If title is null.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


SendEmail Method (recipient, sender, subject, body, html)

SendEmail Method (recipient, sender, subject, body, html)
ScrewTurn Wiki ► ScrewTurn.Wiki ► Host ► SendEmail(String, String, String, String, Boolean)
Sends an Email.
Declaration Syntax
C# Visual Basic Visual C++
public bool SendEmail(
    string recipient,
    string sender,
    string subject,
    string body,
    bool html
)
Public Function SendEmail ( _
    recipient As String, _
    sender As String, _
    subject As String, _
    body As String, _
    html As Boolean _
) As Boolean
public:
virtual bool SendEmail(
    String^ recipient,
    String^ sender,
    String^ subject,
    String^ body,
    bool html
) sealed
Parameters
recipient (String)
The Recipient Email address.
sender (String)
The Sender's Email address.
subject (String)
The Subject.
body (String)
The Body.
html (Boolean)
True if the message is HTML.
Return Value
True if the message has been sent successfully.
Exceptions
Exception | Condition
ArgumentNullException | If recipient, sender, subject or body are null.
ArgumentException | If recipient, sender, subject or body are empty.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


SetProviderConfiguration Method (provider, configuration)

SetProviderConfiguration Method (provider, configuration)
ScrewTurn Wiki ► ScrewTurn.Wiki ► Host ► SetProviderConfiguration(IProviderV30, String)
Sets the configuration of a provider.
Declaration Syntax
C# Visual Basic Visual C++
public bool SetProviderConfiguration(
    IProviderV30 provider,
    string configuration
)
Public Function SetProviderConfiguration ( _
    provider As IProviderV30, _
    configuration As String _
) As Boolean
public:
virtual bool SetProviderConfiguration(
    IProviderV30^ provider,
    String^ configuration
) sealed
Parameters
provider (IProviderV30)
The provider of which to set the configuration.
configuration (String)
The configuration to set.
Return Value
true if the configuration is set, false otherwise.
Exceptions
Exception | Condition
ArgumentNullException | If provider is null.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


UpgradePageStatusToAcl Method (page, oldStatus)

UpgradePageStatusToAcl Method (page, oldStatus)
ScrewTurn Wiki ► ScrewTurn.Wiki ► Host ► UpgradePageStatusToAcl(PageInfo, Char)
Upgrades the old Page Status to use the new ACL facilities.
Declaration Syntax
C# Visual Basic Visual C++
public bool UpgradePageStatusToAcl(
    PageInfo page,
    char oldStatus
)
Public Function UpgradePageStatusToAcl ( _
    page As PageInfo, _
    oldStatus As Char _
) As Boolean
public:
virtual bool UpgradePageStatusToAcl(
    PageInfo^ page,
    wchar_t oldStatus
) sealed
Parameters
page (PageInfo)
The page of which to upgrade the status.
oldStatus (Char)
The old status ('L' = Locked, 'P' = Public).
Return Value
true if the operation succeeded, false otherwise.
Exceptions
Exception | Condition
ArgumentNullException | If page is null.
ArgumentOutOfRangeException | If oldStatus is invalid.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


UpgradeSecurityFlagsToGroupsAcl Method (administrators, users)

UpgradeSecurityFlagsToGroupsAcl Method (administrators, users)
ScrewTurn Wiki ► ScrewTurn.Wiki ► Host ► UpgradeSecurityFlagsToGroupsAcl(UserGroup, UserGroup)
Upgrades the old security flags to use the new ACL facilities and user groups support.
Declaration Syntax
C# Visual Basic Visual C++
public bool UpgradeSecurityFlagsToGroupsAcl(
    UserGroup administrators,
    UserGroup users
)
Public Function UpgradeSecurityFlagsToGroupsAcl ( _
    administrators As UserGroup, _
    users As UserGroup _
) As Boolean
public:
virtual bool UpgradeSecurityFlagsToGroupsAcl(
    UserGroup^ administrators,
    UserGroup^ users
) sealed
Parameters
administrators (UserGroup)
The administrators group.
users (UserGroup)
The users group.
Return Value
true if the operation succeeded, false otherwise.
Exceptions
Exception | Condition
ArgumentNullException | If administrators or users are null.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


UserAccountActivity Event

UserAccountActivity Event
ScrewTurn Wiki ► ScrewTurn.Wiki ► Host ► UserAccountActivity
Event fired whenever an activity is performed on a User Account.
Declaration Syntax
C# Visual Basic Visual C++
public event EventHandler<UserAccountActivityEventArgs> UserAccountActivity
Public Event UserAccountActivity As EventHandler(Of UserAccountActivityEventArgs)
public:
virtual  event EventHandler<UserAccountActivityEventArgs^>^ UserAccountActivity {
    void add (EventHandler<UserAccountActivityEventArgs^>^ value);
    void remove (EventHandler<UserAccountActivityEventArgs^>^ value);
}

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


UserGroupActivity Event

UserGroupActivity Event
ScrewTurn Wiki ► ScrewTurn.Wiki ► Host ► UserGroupActivity
Event fired whenever an activity is performed on a user group.
Declaration Syntax
C# Visual Basic Visual C++
public event EventHandler<UserGroupActivityEventArgs> UserGroupActivity
Public Event UserGroupActivity As EventHandler(Of UserGroupActivityEventArgs)
public:
virtual  event EventHandler<UserGroupActivityEventArgs^>^ UserGroupActivity {
    void add (EventHandler<UserGroupActivityEventArgs^>^ value);
    void remove (EventHandler<UserGroupActivityEventArgs^>^ value);
}

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


HPosition Class

HPosition Class
ScrewTurn Wiki ► ScrewTurn.Wiki ► HPosition
Represents a Header.
Declaration Syntax
C# Visual Basic Visual C++
public class HPosition
Public Class HPosition
public ref class HPosition
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | HPosition(Int32, String, Int32, Int32) | Initializes a new instance of the HPosition class.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | ID | Gets or sets the ID (0-based counter).
 | Index | Gets or sets the Index.
 | Level | Gets or sets the Level.
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Text | Gets or sets the Text.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
HPosition

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


HPosition Constructor (index, text, level, id)

HPosition Constructor (index, text, level, id)
ScrewTurn Wiki ► ScrewTurn.Wiki ► HPosition ► HPosition(Int32, String, Int32, Int32)
Initializes a new instance of the HPosition class.
Declaration Syntax
C# Visual Basic Visual C++
public HPosition(
    int index,
    string text,
    int level,
    int id
)
Public Sub New ( _
    index As Integer, _
    text As String, _
    level As Integer, _
    id As Integer _
)
public:
HPosition(
    int index,
    String^ text,
    int level,
    int id
)
Parameters
index (Int32)
The Index.
text (String)
The Text.
level (Int32)
The Header level.
id (Int32)
The Unique ID of the Header (0-based counter).

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


ID Property

ID Property
ScrewTurn Wiki ► ScrewTurn.Wiki ► HPosition ► ID
Gets or sets the ID (0-based counter).
Declaration Syntax
C# Visual Basic Visual C++
public int ID { get; set; }
Public Property ID As Integer
public:
property int ID {
    int get ();
    void set (int value);
}

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


Index Property

Index Property
ScrewTurn Wiki ► ScrewTurn.Wiki ► HPosition ► Index
Gets or sets the Index.
Declaration Syntax
C# Visual Basic Visual C++
public int Index { get; set; }
Public Property Index As Integer
public:
property int Index {
    int get ();
    void set (int value);
}

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


Level Property

Level Property
ScrewTurn Wiki ► ScrewTurn.Wiki ► HPosition ► Level
Gets or sets the Level.
Declaration Syntax
C# Visual Basic Visual C++
public int Level { get; set; }
Public Property Level As Integer
public:
property int Level {
    int get ();
    void set (int value);
}

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


Text Property

Text Property
ScrewTurn Wiki ► ScrewTurn.Wiki ► HPosition ► Text
Gets or sets the Text.
Declaration Syntax
C# Visual Basic Visual C++
public string Text { get; set; }
Public Property Text As String
public:
property String^ Text {
    String^ get ();
    void set (String^ value);
}

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


HPositionComparer Class

HPositionComparer Class
ScrewTurn Wiki ► ScrewTurn.Wiki ► HPositionComparer
Compares HPosition objects.
Declaration Syntax
C# Visual Basic Visual C++
public class HPositionComparer : IComparer<HPosition>
Public Class HPositionComparer _
    Implements IComparer(Of HPosition)
public ref class HPositionComparer : IComparer<HPosition^>
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | HPositionComparer()()() | Initializes a new instance of the HPositionComparer class
 | Compare(HPosition, HPosition) | Performs the comparison.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
HPositionComparer

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


HPositionComparer Constructor

HPositionComparer Constructor
ScrewTurn Wiki ► ScrewTurn.Wiki ► HPositionComparer ► HPositionComparer()()()
Initializes a new instance of the HPositionComparer class
Declaration Syntax
C# Visual Basic Visual C++
public HPositionComparer()
Public Sub New
public:
HPositionComparer()

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


Compare Method (x, y)

Compare Method (x, y)
ScrewTurn Wiki ► ScrewTurn.Wiki ► HPositionComparer ► Compare(HPosition, HPosition)
Performs the comparison.
Declaration Syntax
C# Visual Basic Visual C++
public int Compare(
    HPosition x,
    HPosition y
)
Public Function Compare ( _
    x As HPosition, _
    y As HPosition _
) As Integer
public:
virtual int Compare(
    HPosition^ x,
    HPosition^ y
) sealed
Parameters
x (HPosition)
The first object.
y (HPosition)
The second object.
Return Value
The comparison result.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


HtmlList Class

HtmlList Class
ScrewTurn Wiki ► ScrewTurn.Wiki ► HtmlList
Represents a HTML list.
Declaration Syntax
C# Visual Basic Visual C++
public class HtmlList
Public Class HtmlList
public ref class HtmlList
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | HtmlList(HtmlListType) | Initializes a new instance of the HtmlList class.
 | Elements | Gets or sets the list elements.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | Type | Gets or sets the list type.
Inheritance Hierarchy
Object
HtmlList

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


HtmlList Constructor (type)

HtmlList Constructor (type)
ScrewTurn Wiki ► ScrewTurn.Wiki ► HtmlList ► HtmlList(HtmlListType)
Initializes a new instance of the HtmlList class.
Declaration Syntax
C# Visual Basic Visual C++
public HtmlList(
    HtmlListType type
)
Public Sub New ( _
    type As HtmlListType _
)
public:
HtmlList(
    HtmlListType type
)
Parameters
type (HtmlListType)
The list type.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


Elements Property

Elements Property
ScrewTurn Wiki ► ScrewTurn.Wiki ► HtmlList ► Elements
Gets or sets the list elements.
Declaration Syntax
C# Visual Basic Visual C++
public List<HtmlListElement> Elements { get; set; }
Public Property Elements As List(Of HtmlListElement)
public:
property List<HtmlListElement^>^ Elements {
    List<HtmlListElement^>^ get ();
    void set (List<HtmlListElement^>^ value);
}

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


Type Property

Type Property
ScrewTurn Wiki ► ScrewTurn.Wiki ► HtmlList ► Type
Gets or sets the list type.
Declaration Syntax
C# Visual Basic Visual C++
public HtmlListType Type { get; set; }
Public Property Type As HtmlListType
public:
property HtmlListType Type {
    HtmlListType get ();
    void set (HtmlListType value);
}

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


HtmlListElement Class

HtmlListElement Class
ScrewTurn Wiki ► ScrewTurn.Wiki ► HtmlListElement
Represents a HTML list element.
Declaration Syntax
C# Visual Basic Visual C++
public class HtmlListElement
Public Class HtmlListElement
public ref class HtmlListElement
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | HtmlListElement()()() | Initializes a new instance of the HtmlListElement class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | SubList | Gets or sets the sub-list.
 | Text | Gets or sets the text.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
HtmlListElement

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


HtmlListElement Constructor

HtmlListElement Constructor
ScrewTurn Wiki ► ScrewTurn.Wiki ► HtmlListElement ► HtmlListElement()()()
Initializes a new instance of the HtmlListElement class
Declaration Syntax
C# Visual Basic Visual C++
public HtmlListElement()
Public Sub New
public:
HtmlListElement()

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


SubList Property

SubList Property
ScrewTurn Wiki ► ScrewTurn.Wiki ► HtmlListElement ► SubList
Gets or sets the sub-list.
Declaration Syntax
C# Visual Basic Visual C++
public HtmlList SubList { get; set; }
Public Property SubList As HtmlList
public:
property HtmlList^ SubList {
    HtmlList^ get ();
    void set (HtmlList^ value);
}

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


Text Property

Text Property
ScrewTurn Wiki ► ScrewTurn.Wiki ► HtmlListElement ► Text
Gets or sets the text.
Declaration Syntax
C# Visual Basic Visual C++
public string Text { get; set; }
Public Property Text As String
public:
property String^ Text {
    String^ get ();
    void set (String^ value);
}

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


HtmlListType Enumeration

HtmlListType Enumeration
ScrewTurn Wiki ► ScrewTurn.Wiki ► HtmlListType
Lists HTML list types.
Declaration Syntax
C# Visual Basic Visual C++
public enum HtmlListType
Public Enumeration HtmlListType
public enum class HtmlListType
Members
Member | Description
Ordered | An ordered list.
Unordered | An unordered list.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


IndexStorer Class

IndexStorer Class
ScrewTurn Wiki ► ScrewTurn.Wiki ► IndexStorer
Stores index data to disk.
Declaration Syntax
C# Visual Basic Visual C++
public class IndexStorer : IndexStorerBase
Public Class IndexStorer _
    Inherits IndexStorerBase
public ref class IndexStorer : public IndexStorerBase
Members
All Members | Constructors | Methods | Properties | Fields
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | IndexStorer(String, String, String, IInMemoryIndex) | Initializes a new instance of the IndexStorer class.
 | dataCorrupted | true if the index data seems corrupted. (Inherited from IndexStorerBase.)
 | DataCorrupted | Gets a value indicating whether the index data seems corrupted and cannot be used. (Inherited from IndexStorerBase.)
 | DeleteData(DumpedChange, Object) | Deletes data from the data storage. (Overrides IndexStorerBase.DeleteData(DumpedChange, Object).)
 | Dispose()()() | Disposes the current object. (Inherited from IndexStorerBase.)
 | disposed | Indicates whether the object was disposed. (Inherited from IndexStorerBase.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | index | The index bound to this storer. (Inherited from IndexStorerBase.)
 | Index | Gets the index. (Inherited from IndexStorerBase.)
 | indexChangedHandler | The event handler for the IndexChanged of the bound index. (Inherited from IndexStorerBase.)
 | IndexChangedHandler(Object, IndexChangedEventArgs) | Handles the IndexChanged events. (Inherited from IndexStorerBase.)
 | InitDataStore(Object) | Initializes the data storage. (Overrides IndexStorerBase.InitDataStore(Object).)
 | LoadIndex()()() | Loads the index from the data store the first time. (Inherited from IndexStorerBase.)
 | LoadIndexInternal(array<DumpedDocument>[]()[]%, array<DumpedWord>[]()[]%, array<DumpedWordMapping>[]()[]%) | Loads the index from the data store the first time. (Overrides IndexStorerBase.LoadIndexInternal(array<DumpedDocument>[]()[]%, array<DumpedWord>[]()[]%, array<DumpedWordMapping>[]()[]%).)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | reasonForDataCorruption | Contains the exception occurred during index setup. (Inherited from IndexStorerBase.)
 | ReasonForDataCorruption | Gets the exception that caused data corruption. (Inherited from IndexStorerBase.)
 | SaveData(DumpedChange, Object) | Stores new data into the data storage. (Overrides IndexStorerBase.SaveData(DumpedChange, Object).)
 | Size | Gets the approximate size, in bytes, of the search engine index. (Overrides IndexStorerBase.Size.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Remarks
Instance and static members are thread-safe.
Inheritance Hierarchy
Object
 | IndexStorerBase
 |  | IndexStorer

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


IndexStorer Constructor (documentsFile, wordsFile, mappingsFile, index)

IndexStorer Constructor (documentsFile, wordsFile, mappingsFile, index)
ScrewTurn Wiki ► ScrewTurn.Wiki ► IndexStorer ► IndexStorer(String, String, String, IInMemoryIndex)
Initializes a new instance of the IndexStorer class.
Declaration Syntax
C# Visual Basic Visual C++
public IndexStorer(
    string documentsFile,
    string wordsFile,
    string mappingsFile,
    IInMemoryIndex index
)
Public Sub New ( _
    documentsFile As String, _
    wordsFile As String, _
    mappingsFile As String, _
    index As IInMemoryIndex _
)
public:
IndexStorer(
    String^ documentsFile,
    String^ wordsFile,
    String^ mappingsFile,
    IInMemoryIndex^ index
)
Parameters
documentsFile (String)
The file that contains the documents list.
wordsFile (String)
The file that contains the words list.
mappingsFile (String)
The file that contains the index mappings data.
index (IInMemoryIndex)
The index to manage.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


DeleteData Method (data, state)

DeleteData Method (data, state)
ScrewTurn Wiki ► ScrewTurn.Wiki ► IndexStorer ► DeleteData(DumpedChange, Object)
Deletes data from the data storage.
Declaration Syntax
C# Visual Basic Visual C++
protected override void DeleteData(
    DumpedChange data,
    Object state
)
Protected Overrides Sub DeleteData ( _
    data As DumpedChange, _
    state As Object _
)
protected:
virtual void DeleteData(
    DumpedChange^ data,
    Object^ state
) override
Parameters
data (DumpedChange)
The data to delete.
state (Object)
A state object passed from the index.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


InitDataStore Method (state)

InitDataStore Method (state)
ScrewTurn Wiki ► ScrewTurn.Wiki ► IndexStorer ► InitDataStore(Object)
Initializes the data storage.
Declaration Syntax
C# Visual Basic Visual C++
protected override void InitDataStore(
    Object state
)
Protected Overrides Sub InitDataStore ( _
    state As Object _
)
protected:
virtual void InitDataStore(
    Object^ state
) override
Parameters
state (Object)
A state object passed from the index.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


LoadIndexInternal Method (documents, words, mappings)

LoadIndexInternal Method (documents, words, mappings)
ScrewTurn Wiki ► ScrewTurn.Wiki ► IndexStorer ► LoadIndexInternal(array<DumpedDocument>[]()[]%, array<DumpedWord>[]()[]%, array<DumpedWordMapping>[]()[]%)
Loads the index from the data store the first time.
Declaration Syntax
C# Visual Basic Visual C++
protected override void LoadIndexInternal(
    out DumpedDocument[] documents,
    out DumpedWord[] words,
    out DumpedWordMapping[] mappings
)
Protected Overrides Sub LoadIndexInternal ( _
    <OutAttribute> ByRef documents As DumpedDocument(), _
    <OutAttribute> ByRef words As DumpedWord(), _
    <OutAttribute> ByRef mappings As DumpedWordMapping() _
)
protected:
virtual void LoadIndexInternal(
    [OutAttribute] array<DumpedDocument^>^% documents,
    [OutAttribute] array<DumpedWord^>^% words,
    [OutAttribute] array<DumpedWordMapping^>^% mappings
) override
Parameters
documents ( array< DumpedDocument >[]()[][] %)
The dumped documents.
words ( array< DumpedWord >[]()[][] %)
The dumped words.
mappings ( array< DumpedWordMapping >[]()[][] %)
The dumped word mappings.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


SaveData Method (data, state)

SaveData Method (data, state)
ScrewTurn Wiki ► ScrewTurn.Wiki ► IndexStorer ► SaveData(DumpedChange, Object)
Stores new data into the data storage.
Declaration Syntax
C# Visual Basic Visual C++
protected override IndexStorerResult SaveData(
    DumpedChange data,
    Object state
)
Protected Overrides Function SaveData ( _
    data As DumpedChange, _
    state As Object _
) As IndexStorerResult
protected:
virtual IndexStorerResult^ SaveData(
    DumpedChange^ data,
    Object^ state
) override
Parameters
data (DumpedChange)
The data to store.
state (Object)
A state object passed from the index.
Return Value
The storer result, if any.
Remarks
When saving a new document, the document ID in data.Mappings must be replaced with the currect document ID, generated by the concrete implementation of this method. data.Words should have IDs numbered from uint.MaxValue downwards. The method re-numbers the words appropriately.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


Size Property

Size Property
ScrewTurn Wiki ► ScrewTurn.Wiki ► IndexStorer ► Size
Gets the approximate size, in bytes, of the search engine index.
Declaration Syntax
C# Visual Basic Visual C++
public override long Size { get; }
Public Overrides ReadOnly Property Size As Long
public:
virtual property long long Size {
    long long get () override;
}

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


IResourceExchanger Interface

IResourceExchanger Interface
ScrewTurn Wiki ► ScrewTurn.Wiki ► IResourceExchanger
Exposes methods for exchanging Resources.
Declaration Syntax
C# Visual Basic Visual C++
public interface IResourceExchanger
Public Interface IResourceExchanger
public interface class IResourceExchanger
Members
All Members | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | GetResource(String) | Gets a Resource String.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.PluginFramework (Module: ScrewTurn.Wiki.PluginFramework) Version: 3.0.2.500 (3.0.2.500)


GetResource Method (name)

GetResource Method (name)
ScrewTurn Wiki ► ScrewTurn.Wiki ► IResourceExchanger ► GetResource(String)
Gets a Resource String.
Declaration Syntax
C# Visual Basic Visual C++
string GetResource(
    string name
)
Function GetResource ( _
    name As String _
) As String
String^ GetResource(
    String^ name
)
Parameters
name (String)
The Name of the Resource.
Return Value
The Resource String.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.PluginFramework (Module: ScrewTurn.Wiki.PluginFramework) Version: 3.0.2.500 (3.0.2.500)


LocalPageInfo Class

LocalPageInfo Class
ScrewTurn Wiki ► ScrewTurn.Wiki ► LocalPageInfo
Represents a Local Page.
Declaration Syntax
C# Visual Basic Visual C++
public class LocalPageInfo : PageInfo
Public Class LocalPageInfo _
    Inherits PageInfo
public ref class LocalPageInfo : public PageInfo
Members
All Members | Constructors | Methods | Properties | Fields
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | LocalPageInfo(String, IPagesStorageProviderV30, DateTime, String) | Initializes a new instance of the PageInfo class.
 | creationDateTime | The Page creation Date/Time. (Inherited from PageInfo.)
 | CreationDateTime | Gets or sets the creation Date/Time. (Inherited from PageInfo.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | File | Gets or sets the relative path of the File used for data storage.
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | FullName | Gets or sets the full name of the Page, such as 'Namespace.Page' or 'Page'. (Inherited from PageInfo.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | name | The Name of the Page. (Inherited from PageInfo.)
 | nonCached | A value specifying whether the Page should NOT be cached by the engine. (Inherited from PageInfo.)
 | NonCached | Gets or sets a value specifying whether the Page should NOT be cached by the engine. (Inherited from PageInfo.)
 | nspace | The namespace of the Page. (Inherited from PageInfo.)
 | provider | The Provider that handles the Page. (Inherited from PageInfo.)
 | Provider | Gets or sets the Pages Storage Provider. (Inherited from PageInfo.)
 | ToString()()() | Converts the current PageInfo to a string. (Inherited from PageInfo.)
Inheritance Hierarchy
Object
 | PageInfo
 |  | LocalPageInfo

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


LocalPageInfo Constructor (fullName, provider, creationDateTime, file)

LocalPageInfo Constructor (fullName, provider, creationDateTime, file)
ScrewTurn Wiki ► ScrewTurn.Wiki ► LocalPageInfo ► LocalPageInfo(String, IPagesStorageProviderV30, DateTime, String)
Initializes a new instance of the PageInfo class.
Declaration Syntax
C# Visual Basic Visual C++
public LocalPageInfo(
    string fullName,
    IPagesStorageProviderV30 provider,
    DateTime creationDateTime,
    string file
)
Public Sub New ( _
    fullName As String, _
    provider As IPagesStorageProviderV30, _
    creationDateTime As DateTime, _
    file As String _
)
public:
LocalPageInfo(
    String^ fullName,
    IPagesStorageProviderV30^ provider,
    DateTime creationDateTime,
    String^ file
)
Parameters
fullName (String)
The Full Name of the Page.
provider (IPagesStorageProviderV30)
The Pages Storage Provider that manages this Page.
creationDateTime (DateTime)
The creation Date/Time.
file (String)
The relative path of the file used for data storage.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


File Property

File Property
ScrewTurn Wiki ► ScrewTurn.Wiki ► LocalPageInfo ► File
Gets or sets the relative path of the File used for data storage.
Declaration Syntax
C# Visual Basic Visual C++
public string File { get; set; }
Public Property File As String
public:
property String^ File {
    String^ get ();
    void set (String^ value);
}

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


LocalProvidersTools Class

LocalProvidersTools Class
ScrewTurn Wiki ► ScrewTurn.Wiki ► LocalProvidersTools
Implements tools for local providers.
Declaration Syntax
C# Visual Basic Visual C++
public static class LocalProvidersTools
Public NotInheritable Class LocalProvidersTools
public ref class LocalProvidersTools abstract sealed
Members
All Members | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | CheckWritePermissions(String) | Checks a directory for write permissions.
Inheritance Hierarchy
Object
LocalProvidersTools

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


CheckWritePermissions Method (dir)

CheckWritePermissions Method (dir)
ScrewTurn Wiki ► ScrewTurn.Wiki ► LocalProvidersTools ► CheckWritePermissions(String)
Checks a directory for write permissions.
Declaration Syntax
C# Visual Basic Visual C++
public static bool CheckWritePermissions(
    string dir
)
Public Shared Function CheckWritePermissions ( _
    dir As String _
) As Boolean
public:
static bool CheckWritePermissions(
    String^ dir
)
Parameters
dir (String)
The directory.
Return Value
true if the directory has write permissions, false otherwise.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


LocalUserInfo Class

LocalUserInfo Class
ScrewTurn Wiki ► ScrewTurn.Wiki ► LocalUserInfo
Stores a Local UserInfo object.
Declaration Syntax
C# Visual Basic Visual C++
public class LocalUserInfo : UserInfo
Public Class LocalUserInfo _
    Inherits UserInfo
public ref class LocalUserInfo : public UserInfo
Members
All Members | Constructors | Methods | Properties | Fields
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | LocalUserInfo(String, String, String, Boolean, DateTime, IUsersStorageProviderV30, String) | Initializes a new instance of the LocalUserInfo class.
 | active | A value indicating whether the user account is active. (Inherited from UserInfo.)
 | Active | Gets or sets a value specifying whether the Account is active or not. (Inherited from UserInfo.)
 | dateTime | The account creation date/time. (Inherited from UserInfo.)
 | DateTime | Gets the creation DateTime. (Inherited from UserInfo.)
 | displayName | The display name of the User. (Inherited from UserInfo.)
 | DisplayName | Gets or sets the display name. (Inherited from UserInfo.)
 | email | The Email address of the User. (Inherited from UserInfo.)
 | Email | Gets or sets the Email. (Inherited from UserInfo.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | groups | The names of the groups the user is member of. (Inherited from UserInfo.)
 | Groups | Gets or sets the names of the groups the user is member of. (Inherited from UserInfo.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | PasswordHash | Gets or sets the Password Hash.
 | provider | The Provider that handles the User. (Inherited from UserInfo.)
 | Provider | Gets or sets the Users Storage Provider. (Inherited from UserInfo.)
 | ToString()()() | Converts the current instance to a string. (Inherited from UserInfo.)
 | username | The Username of the User. (Inherited from UserInfo.)
 | Username | Gets the Username. (Inherited from UserInfo.)
Inheritance Hierarchy
Object
 | UserInfo
 |  | LocalUserInfo

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


LocalUserInfo Constructor (username, displayName, email, active, dateTime, provider, passwordHash)

LocalUserInfo Constructor (username, displayName, email, active, dateTime, provider, passwordHash)
ScrewTurn Wiki ► ScrewTurn.Wiki ► LocalUserInfo ► LocalUserInfo(String, String, String, Boolean, DateTime, IUsersStorageProviderV30, String)
Initializes a new instance of the LocalUserInfo class.
Declaration Syntax
C# Visual Basic Visual C++
public LocalUserInfo(
    string username,
    string displayName,
    string email,
    bool active,
    DateTime dateTime,
    IUsersStorageProviderV30 provider,
    string passwordHash
)
Public Sub New ( _
    username As String, _
    displayName As String, _
    email As String, _
    active As Boolean, _
    dateTime As DateTime, _
    provider As IUsersStorageProviderV30, _
    passwordHash As String _
)
public:
LocalUserInfo(
    String^ username,
    String^ displayName,
    String^ email,
    bool active,
    DateTime dateTime,
    IUsersStorageProviderV30^ provider,
    String^ passwordHash
)
Parameters
username (String)
The Username.
displayName (String)
The display name.
email (String)
The Email.
active (Boolean)
Specifies whether the Account is active or not.
dateTime (DateTime)
The creation DateTime.
provider (IUsersStorageProviderV30)
The Users Storage Provider that manages the User.
passwordHash (String)
The Password Hash.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


PasswordHash Property

PasswordHash Property
ScrewTurn Wiki ► ScrewTurn.Wiki ► LocalUserInfo ► PasswordHash
Gets or sets the Password Hash.
Declaration Syntax
C# Visual Basic Visual C++
public string PasswordHash { get; set; }
Public Property PasswordHash As String
public:
property String^ PasswordHash {
    String^ get ();
    void set (String^ value);
}

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


Log Class

Log Class
ScrewTurn Wiki ► ScrewTurn.Wiki ► Log
Records and retrieves Log Entries.
Declaration Syntax
C# Visual Basic Visual C++
public static class Log
Public NotInheritable Class Log
public ref class Log abstract sealed
Members
All Members | Methods | Fields
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | ClearLog()()() | Clears the Log.
 | LogEntry(String, EntryType, String) | Writes an Entry in the Log.
 | ReadEntries()()() | Reads all the Log Entries (newest to oldest).
 | SystemUsername | The system username ('SYSTEM').
Inheritance Hierarchy
Object
Log

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


ClearLog Method

ClearLog Method
ScrewTurn Wiki ► ScrewTurn.Wiki ► Log ► ClearLog()()()
Clears the Log.
Declaration Syntax
C# Visual Basic Visual C++
public static void ClearLog()
Public Shared Sub ClearLog
public:
static void ClearLog()

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


LogEntry Method (message, type, user)

LogEntry Method (message, type, user)
ScrewTurn Wiki ► ScrewTurn.Wiki ► Log ► LogEntry(String, EntryType, String)
Writes an Entry in the Log.
Declaration Syntax
C# Visual Basic Visual C++
public static void LogEntry(
    string message,
    EntryType type,
    string user
)
Public Shared Sub LogEntry ( _
    message As String, _
    type As EntryType, _
    user As String _
)
public:
static void LogEntry(
    String^ message,
    EntryType type,
    String^ user
)
Parameters
message (String)
The Message.
type (EntryType)
The Type of the Entry.
user (String)
The User that generated the Entry.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


ReadEntries Method

ReadEntries Method
ScrewTurn Wiki ► ScrewTurn.Wiki ► Log ► ReadEntries()()()
Reads all the Log Entries (newest to oldest).
Declaration Syntax
C# Visual Basic Visual C++
public static List<LogEntry> ReadEntries()
Public Shared Function ReadEntries As List(Of LogEntry)
public:
static List<LogEntry^>^ ReadEntries()
Return Value
The Entries.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


SystemUsername Field

SystemUsername Field
ScrewTurn Wiki ► ScrewTurn.Wiki ► Log ► SystemUsername
The system username ('SYSTEM').
Declaration Syntax
C# Visual Basic Visual C++
public const string SystemUsername
Public Const SystemUsername As String
public:
literal String^ SystemUsername

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


MimeTypes Class

MimeTypes Class
ScrewTurn Wiki ► ScrewTurn.Wiki ► MimeTypes
Contains a list of MIME Types.
Declaration Syntax
C# Visual Basic Visual C++
public static class MimeTypes
Public NotInheritable Class MimeTypes
public ref class MimeTypes abstract sealed
Members
All Members | Methods | Properties
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | Init()()() | Initializes the list of the MIME Types, with the most common media types.
 | Types | Gets the list of the MIME Types.
Inheritance Hierarchy
Object
MimeTypes

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


Init Method

Init Method
ScrewTurn Wiki ► ScrewTurn.Wiki ► MimeTypes ► Init()()()
Initializes the list of the MIME Types, with the most common media types.
Declaration Syntax
C# Visual Basic Visual C++
public static void Init()
Public Shared Sub Init
public:
static void Init()

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


Types Property

Types Property
ScrewTurn Wiki ► ScrewTurn.Wiki ► MimeTypes ► Types
Gets the list of the MIME Types.
Declaration Syntax
C# Visual Basic Visual C++
public static Dictionary<string, string> Types { get; }
Public Shared ReadOnly Property Types As Dictionary(Of String, String)
public:
static property Dictionary<String^, String^>^ Types {
    Dictionary<String^, String^>^ get ();
}

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


MovedUser Class

MovedUser Class
ScrewTurn Wiki ► ScrewTurn.Wiki ► MovedUser
Contains username, email and registration date/time of a moved User account.
Declaration Syntax
C# Visual Basic Visual C++
public class MovedUser
Public Class MovedUser
public ref class MovedUser
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | MovedUser(String, String, DateTime) | Initializes a new instance of the MovedUser class.
 | DateTime | Gets the registration date/time.
 | Email | Gets the Email.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | Username | Gets the Username.
Inheritance Hierarchy
Object
MovedUser

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


MovedUser Constructor (username, email, dateTime)

MovedUser Constructor (username, email, dateTime)
ScrewTurn Wiki ► ScrewTurn.Wiki ► MovedUser ► MovedUser(String, String, DateTime)
Initializes a new instance of the MovedUser class.
Declaration Syntax
C# Visual Basic Visual C++
public MovedUser(
    string username,
    string email,
    DateTime dateTime
)
Public Sub New ( _
    username As String, _
    email As String, _
    dateTime As DateTime _
)
public:
MovedUser(
    String^ username,
    String^ email,
    DateTime dateTime
)
Parameters
username (String)
The esername.
email (String)
The email address.
dateTime (DateTime)
The registration date/time.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


DateTime Property

DateTime Property
ScrewTurn Wiki ► ScrewTurn.Wiki ► MovedUser ► DateTime
Gets the registration date/time.
Declaration Syntax
C# Visual Basic Visual C++
public DateTime DateTime { get; }
Public ReadOnly Property DateTime As DateTime
public:
property DateTime DateTime {
    DateTime get ();
}

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


Email Property

Email Property
ScrewTurn Wiki ► ScrewTurn.Wiki ► MovedUser ► Email
Gets the Email.
Declaration Syntax
C# Visual Basic Visual C++
public string Email { get; }
Public ReadOnly Property Email As String
public:
property String^ Email {
    String^ get ();
}

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


Username Property

Username Property
ScrewTurn Wiki ► ScrewTurn.Wiki ► MovedUser ► Username
Gets the Username.
Declaration Syntax
C# Visual Basic Visual C++
public string Username { get; }
Public ReadOnly Property Username As String
public:
property String^ Username {
    String^ get ();
}

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


NavigationPaths Class

NavigationPaths Class
ScrewTurn Wiki ► ScrewTurn.Wiki ► NavigationPaths
Manages navigation paths.
Declaration Syntax
C# Visual Basic Visual C++
public static class NavigationPaths
Public NotInheritable Class NavigationPaths
public ref class NavigationPaths abstract sealed
Members
All Members | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | AddNavigationPath(NamespaceInfo, String, List<(Of <(PageInfo>)>), IPagesStorageProviderV30) | Adds a new Navigation Path.
 | Exists(String) | Finds a Navigation Path's Name.
 | Find(String) | Finds and returns a Path.
 | GetAllNavigationPaths()()() | Gets the list of the Navigation Paths.
 | GetNavigationPaths(NamespaceInfo) | Gets the list of the Navigation Paths in a namespace.
 | ModifyNavigationPath(String, List<(Of <(PageInfo>)>)) | Modifies a Navigation Path.
 | PathsPerPage(PageInfo) | Finds all the Navigation Paths that include a Page.
 | RemoveNavigationPath(String) | Removes a Navigation Path.
Inheritance Hierarchy
Object
NavigationPaths

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


AddNavigationPath Method (nspace, name, pages, provider)

AddNavigationPath Method (nspace, name, pages, provider)
ScrewTurn Wiki ► ScrewTurn.Wiki ► NavigationPaths ► AddNavigationPath(NamespaceInfo, String, List<(Of <(PageInfo>)>), IPagesStorageProviderV30)
Adds a new Navigation Path.
Declaration Syntax
C# Visual Basic Visual C++
public static bool AddNavigationPath(
    NamespaceInfo nspace,
    string name,
    List<PageInfo> pages,
    IPagesStorageProviderV30 provider
)
Public Shared Function AddNavigationPath ( _
    nspace As NamespaceInfo, _
    name As String, _
    pages As List(Of PageInfo), _
    provider As IPagesStorageProviderV30 _
) As Boolean
public:
static bool AddNavigationPath(
    NamespaceInfo^ nspace,
    String^ name,
    List<PageInfo^>^ pages,
    IPagesStorageProviderV30^ provider
)
Parameters
nspace (NamespaceInfo)
The target namespace (null for the root).
name (String)
The Name.
pages (List <(Of <(<' PageInfo >)>)>)
The Pages.
provider (IPagesStorageProviderV30)
The Provider to use for the new Navigation Path, or null for the default provider.
Return Value
True if the Path is added successfully.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


Exists Method (name)

Exists Method (name)
ScrewTurn Wiki ► ScrewTurn.Wiki ► NavigationPaths ► Exists(String)
Finds a Navigation Path's Name.
Declaration Syntax
C# Visual Basic Visual C++
public static bool Exists(
    string name
)
Public Shared Function Exists ( _
    name As String _
) As Boolean
public:
static bool Exists(
    String^ name
)
Parameters
name (String)
The Name.
Return Value
True if the Navigation Path exists.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


Find Method (fullName)

Find Method (fullName)
ScrewTurn Wiki ► ScrewTurn.Wiki ► NavigationPaths ► Find(String)
Finds and returns a Path.
Declaration Syntax
C# Visual Basic Visual C++
public static NavigationPath Find(
    string fullName
)
Public Shared Function Find ( _
    fullName As String _
) As NavigationPath
public:
static NavigationPath^ Find(
    String^ fullName
)
Parameters
fullName (String)
The full name.
Return Value
The correct NavigationPath object or null if no path is found.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


GetAllNavigationPaths Method

GetAllNavigationPaths Method
ScrewTurn Wiki ► ScrewTurn.Wiki ► NavigationPaths ► GetAllNavigationPaths()()()
Gets the list of the Navigation Paths.
Declaration Syntax
C# Visual Basic Visual C++
public static List<NavigationPath> GetAllNavigationPaths()
Public Shared Function GetAllNavigationPaths As List(Of NavigationPath)
public:
static List<NavigationPath^>^ GetAllNavigationPaths()
Return Value
The navigation paths, sorted by name.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


GetNavigationPaths Method (nspace)

GetNavigationPaths Method (nspace)
ScrewTurn Wiki ► ScrewTurn.Wiki ► NavigationPaths ► GetNavigationPaths(NamespaceInfo)
Gets the list of the Navigation Paths in a namespace.
Declaration Syntax
C# Visual Basic Visual C++
public static List<NavigationPath> GetNavigationPaths(
    NamespaceInfo nspace
)
Public Shared Function GetNavigationPaths ( _
    nspace As NamespaceInfo _
) As List(Of NavigationPath)
public:
static List<NavigationPath^>^ GetNavigationPaths(
    NamespaceInfo^ nspace
)
Parameters
nspace (NamespaceInfo)
The namespace.
Return Value
The navigation paths, sorted by name.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


ModifyNavigationPath Method (fullName, pages)

ModifyNavigationPath Method (fullName, pages)
ScrewTurn Wiki ► ScrewTurn.Wiki ► NavigationPaths ► ModifyNavigationPath(String, List<(Of <(PageInfo>)>))
Modifies a Navigation Path.
Declaration Syntax
C# Visual Basic Visual C++
public static bool ModifyNavigationPath(
    string fullName,
    List<PageInfo> pages
)
Public Shared Function ModifyNavigationPath ( _
    fullName As String, _
    pages As List(Of PageInfo) _
) As Boolean
public:
static bool ModifyNavigationPath(
    String^ fullName,
    List<PageInfo^>^ pages
)
Parameters
fullName (String)
The full name of the path to modify.
pages (List <(Of <(<' PageInfo >)>)>)
The list of Pages.
Return Value
true if the path is modified, false otherwise.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


PathsPerPage Method (page)

PathsPerPage Method (page)
ScrewTurn Wiki ► ScrewTurn.Wiki ► NavigationPaths ► PathsPerPage(PageInfo)
Finds all the Navigation Paths that include a Page.
Declaration Syntax
C# Visual Basic Visual C++
public static string[] PathsPerPage(
    PageInfo page
)
Public Shared Function PathsPerPage ( _
    page As PageInfo _
) As String()
public:
static array<String^>^ PathsPerPage(
    PageInfo^ page
)
Parameters
page (PageInfo)
The Page.
Return Value
The list of Navigation Paths.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


RemoveNavigationPath Method (fullName)

RemoveNavigationPath Method (fullName)
ScrewTurn Wiki ► ScrewTurn.Wiki ► NavigationPaths ► RemoveNavigationPath(String)
Removes a Navigation Path.
Declaration Syntax
C# Visual Basic Visual C++
public static bool RemoveNavigationPath(
    string fullName
)
Public Shared Function RemoveNavigationPath ( _
    fullName As String _
) As Boolean
public:
static bool RemoveNavigationPath(
    String^ fullName
)
Parameters
fullName (String)
The full name of the path to remove.
Return Value
true if the path is removed, false otherwise.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


PageAttachmentDocument Class

PageAttachmentDocument Class
ScrewTurn Wiki ► ScrewTurn.Wiki ► PageAttachmentDocument
Represents a page attachment document.
Declaration Syntax
C# Visual Basic Visual C++
public class PageAttachmentDocument : IDocument
Public Class PageAttachmentDocument _
    Implements IDocument
public ref class PageAttachmentDocument : IDocument
Members
All Members | Constructors | Methods | Properties | Fields
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | PageAttachmentDocument(PageInfo, String, String, DateTime) | Initializes a new instance of the PageAttachmentDocument class.
 | PageAttachmentDocument(DumpedDocument) | Initializes a new instance of the PageAttachmentDocument class.
 | DateTime | Gets the document date/time.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | ID | Gets or sets the globally unique ID of the document.
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets the globally-unique name of the document.
 | Page | Gets the page.
 | Provider | Gets the provider.
 | StandardTypeTag | The type tag for a PageAttachmentDocument.
 | Title | Gets the title of the document, if any.
 | Tokenize(String) | Performs the tokenization of the document content.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | TypeTag | Gets the tag for the document type.
Inheritance Hierarchy
Object
PageAttachmentDocument

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


PageAttachmentDocument Constructor

PageAttachmentDocument Constructor
ScrewTurn Wiki ► ScrewTurn.Wiki ► PageAttachmentDocument ► PageAttachmentDocument()()()
Members
Icon | Member | Description
 | PageAttachmentDocument(PageInfo, String, String, DateTime) | Initializes a new instance of the PageAttachmentDocument class.
 | PageAttachmentDocument(DumpedDocument) | Initializes a new instance of the PageAttachmentDocument class.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


PageAttachmentDocument Constructor (page, name, provider, dateTime)

PageAttachmentDocument Constructor (page, name, provider, dateTime)
ScrewTurn Wiki ► ScrewTurn.Wiki ► PageAttachmentDocument ► PageAttachmentDocument(PageInfo, String, String, DateTime)
Initializes a new instance of the PageAttachmentDocument class.
Declaration Syntax
C# Visual Basic Visual C++
public PageAttachmentDocument(
    PageInfo page,
    string name,
    string provider,
    DateTime dateTime
)
Public Sub New ( _
    page As PageInfo, _
    name As String, _
    provider As String, _
    dateTime As DateTime _
)
public:
PageAttachmentDocument(
    PageInfo^ page,
    String^ name,
    String^ provider,
    DateTime dateTime
)
Parameters
page (PageInfo)
The page.
name (String)
The attachment name.
provider (String)
The file provider.
dateTime (DateTime)
The modification date/time.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


PageAttachmentDocument Constructor (doc)

PageAttachmentDocument Constructor (doc)
ScrewTurn Wiki ► ScrewTurn.Wiki ► PageAttachmentDocument ► PageAttachmentDocument(DumpedDocument)
Initializes a new instance of the PageAttachmentDocument class.
Declaration Syntax
C# Visual Basic Visual C++
public PageAttachmentDocument(
    DumpedDocument doc
)
Public Sub New ( _
    doc As DumpedDocument _
)
public:
PageAttachmentDocument(
    DumpedDocument^ doc
)
Parameters
doc (DumpedDocument)
The dumped document.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


DateTime Property

DateTime Property
ScrewTurn Wiki ► ScrewTurn.Wiki ► PageAttachmentDocument ► DateTime
Gets the document date/time.
Declaration Syntax
C# Visual Basic Visual C++
public DateTime DateTime { get; }
Public ReadOnly Property DateTime As DateTime
public:
virtual property DateTime DateTime {
    DateTime get () sealed;
}

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


ID Property

ID Property
ScrewTurn Wiki ► ScrewTurn.Wiki ► PageAttachmentDocument ► ID
Gets or sets the globally unique ID of the document.
Declaration Syntax
C# Visual Basic Visual C++
public uint ID { get; set; }
Public Property ID As UInteger
public:
virtual property unsigned int ID {
    unsigned int get () sealed;
    void set (unsigned int value) sealed;
}

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


Name Property

Name Property
ScrewTurn Wiki ► ScrewTurn.Wiki ► PageAttachmentDocument ► Name
Gets the globally-unique name of the document.
Declaration Syntax
C# Visual Basic Visual C++
public string Name { get; }
Public ReadOnly Property Name As String
public:
virtual property String^ Name {
    String^ get () sealed;
}

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


Page Property

Page Property
ScrewTurn Wiki ► ScrewTurn.Wiki ► PageAttachmentDocument ► Page
Gets the page.
Declaration Syntax
C# Visual Basic Visual C++
public PageInfo Page { get; }
Public ReadOnly Property Page As PageInfo
public:
property PageInfo^ Page {
    PageInfo^ get ();
}

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


Provider Property

Provider Property
ScrewTurn Wiki ► ScrewTurn.Wiki ► PageAttachmentDocument ► Provider
Gets the provider.
Declaration Syntax
C# Visual Basic Visual C++
public string Provider { get; }
Public ReadOnly Property Provider As String
public:
property String^ Provider {
    String^ get ();
}

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


StandardTypeTag Field

StandardTypeTag Field
ScrewTurn Wiki ► ScrewTurn.Wiki ► PageAttachmentDocument ► StandardTypeTag
The type tag for a PageAttachmentDocument.
Declaration Syntax
C# Visual Basic Visual C++
public const string StandardTypeTag
Public Const StandardTypeTag As String
public:
literal String^ StandardTypeTag

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


Title Property

Title Property
ScrewTurn Wiki ► ScrewTurn.Wiki ► PageAttachmentDocument ► Title
Gets the title of the document, if any.
Declaration Syntax
C# Visual Basic Visual C++
public string Title { get; }
Public ReadOnly Property Title As String
public:
virtual property String^ Title {
    String^ get () sealed;
}

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


Tokenize Method (content)

Tokenize Method (content)
ScrewTurn Wiki ► ScrewTurn.Wiki ► PageAttachmentDocument ► Tokenize(String)
Performs the tokenization of the document content.
Declaration Syntax
C# Visual Basic Visual C++
public WordInfo[] Tokenize(
    string content
)
Public Function Tokenize ( _
    content As String _
) As WordInfo()
public:
virtual array<WordInfo^>^ Tokenize(
    String^ content
) sealed
Parameters
content (String)
The content to tokenize.
Return Value
The extracted words and their positions (always an empty array).

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


TypeTag Property

TypeTag Property
ScrewTurn Wiki ► ScrewTurn.Wiki ► PageAttachmentDocument ► TypeTag
Gets the tag for the document type.
Declaration Syntax
C# Visual Basic Visual C++
public string TypeTag { get; }
Public ReadOnly Property TypeTag As String
public:
virtual property String^ TypeTag {
    String^ get () sealed;
}

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


PageContentDateComparer Class

PageContentDateComparer Class
ScrewTurn Wiki ► ScrewTurn.Wiki ► PageContentDateComparer
Compares PageContent objects.
Declaration Syntax
C# Visual Basic Visual C++
public class PageContentDateComparer : IComparer<PageContent>
Public Class PageContentDateComparer _
    Implements IComparer(Of PageContent)
public ref class PageContentDateComparer : IComparer<PageContent^>
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | PageContentDateComparer()()() | Initializes a new instance of the PageContentDateComparer class
 | Compare(PageContent, PageContent) | Compares two PageContent objects, using the DateTime as parameter.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
PageContentDateComparer

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


PageContentDateComparer Constructor

PageContentDateComparer Constructor
ScrewTurn Wiki ► ScrewTurn.Wiki ► PageContentDateComparer ► PageContentDateComparer()()()
Initializes a new instance of the PageContentDateComparer class
Declaration Syntax
C# Visual Basic Visual C++
public PageContentDateComparer()
Public Sub New
public:
PageContentDateComparer()

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


Compare Method (x, y)

Compare Method (x, y)
ScrewTurn Wiki ► ScrewTurn.Wiki ► PageContentDateComparer ► Compare(PageContent, PageContent)
Compares two PageContent objects, using the DateTime as parameter.
Declaration Syntax
C# Visual Basic Visual C++
public int Compare(
    PageContent x,
    PageContent y
)
Public Function Compare ( _
    x As PageContent, _
    y As PageContent _
) As Integer
public:
virtual int Compare(
    PageContent^ x,
    PageContent^ y
) sealed
Parameters
x (PageContent)
The first object.
y (PageContent)
The second object.
Return Value
The result of the comparison (1, 0 or -1).

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


Pages Class

Pages Class
ScrewTurn Wiki ► ScrewTurn.Wiki ► Pages
Allows access to the Pages.
Declaration Syntax
C# Visual Basic Visual C++
public static class Pages
Public NotInheritable Class Pages
public ref class Pages abstract sealed
Members
All Members | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | AddMessage(PageInfo, String, String, DateTime, String, Int32) | Adds a new Message to a Page.
 | CanApproveDraft(PageInfo, String, array<String>[]()[]) | Determines whether a user can approve/reject a draft of a page.
 | CanEditPage(PageInfo, String, array<String>[]()[], Boolean%, Boolean%) | Determines whether a user can edit a page.
 | CreateCategory(NamespaceInfo, String) | Creates a new Category.
 | CreateCategory(String, String) | Creates a new Category.
 | CreateCategory(NamespaceInfo, String, IPagesStorageProviderV30) | Creates a new Category in the specifued Provider.
 | CreateCategory(String, String, IPagesStorageProviderV30) | Creates a new Category in the specifued Provider.
 | CreateNamespace(String) | Creates a new namespace in the default pages storage provider.
 | CreateNamespace(String, IPagesStorageProviderV30) | Creates a new namespace.
 | CreatePage(NamespaceInfo, String) | Creates a new Page.
 | CreatePage(String, String) | Creates a new Page.
 | CreatePage(NamespaceInfo, String, IPagesStorageProviderV30) | Creates a new Page.
 | CreatePage(String, String, IPagesStorageProviderV30) | Creates a new Page.
 | DeleteBackups(PageInfo) | Deletes all the backups of a page.
 | DeleteBackups(PageInfo, Int32) | Deletes a subset of the backups of a page.
 | DeleteDraft(PageInfo) | Deletes the draft of a page (if any).
 | DeletePage(PageInfo) | Deletes a Page.
 | FindCategory(String) | Finds a Category.
 | FindMessage(array<Message>[]()[], Int32) | Finds a Message.
 | FindNamespace(String) | Finds a namespace.
 | FindNamespace(String, IPagesStorageProviderV30) | Finds a namespace.
 | FindPage(String) | Finds a Page.
 | FindPage(String, IPagesStorageProviderV30) | Finds a Page in a specific Provider.
 | GetAvailableCategories(PageInfo) | Gets the valid Categories for a Page, i.e. the Categories managed by the Page's Provider and in the same namespace as the page.
 | GetBackupContent(PageInfo, Int32) | Gets the Content of a Page Backup.
 | GetBackups(PageInfo) | Gets the Backups/Revisions of a Page.
 | GetCategories(NamespaceInfo) | Gets the list of all the Categories of a namespace. The list shouldn't be modified.
 | GetCategoriesForPage(PageInfo) | Gets the Categories of a Page.
 | GetDraft(PageInfo) | Gets a page draft, if any.
 | GetGlobalPageCount()()() | Gets the global number of pages.
 | GetMatchingCategories(CategoryInfo) | Gets the other Categories of the Provider and Namespace of the specified Category.
 | GetMessageCount(PageInfo) | Gets the total number of Messages in a Page Discussion.
 | GetNamespaces()()() | Gets all the namespaces, sorted.
 | GetOrphanedPages(NamespaceInfo) | Gets all the pages in a namespace without incoming links.
 | GetPageIncomingLinks(PageInfo) | Gets the incoming links for a page.
 | GetPageMessages(PageInfo) | Gets the Page Messages.
 | GetPageOutgoingLinks(PageInfo) | Gets the outgoing links of a page.
 | GetPages(NamespaceInfo) | Gets the list of all the Pages of a namespace.
 | GetUncategorizedPages(NamespaceInfo) | Gets all the Uncategorized Pages.
 | GetWantedPages(String) | Gets the wanted/inexistent pages in all namespaces.
 | IsValidName(String) | Checks the validity of a Page name.
 | MergeCategories(CategoryInfo, CategoryInfo) | Merges two Categories.
 | MigratePage(PageInfo, NamespaceInfo, Boolean) | Migrates a page.
 | ModifyMessage(PageInfo, Int32, String, String, DateTime, String) | Modifies a Message.
 | ModifyPage(PageInfo, String, String, DateTime, String, String, array<String>[]()[], String, SaveMode) | Modifies a Page.
 | Rebind(PageInfo, array<CategoryInfo>[]()[]) | Binds a Page with some Categories.
 | RemoveAllMessages(PageInfo) | Removes all messages of a Page.
 | RemoveCategory(CategoryInfo) | Removes a Category.
 | RemoveMessage(PageInfo, Int32, Boolean) | Removes a Message.
 | RemoveNamespace(NamespaceInfo) | Removes a namespace.
 | RenameCategory(CategoryInfo, String) | Renames a Category.
 | RenameNamespace(NamespaceInfo, String) | Renames a namespace.
 | RenamePage(PageInfo, String) | Renames a Page.
 | Rollback(PageInfo, Int32) | Performs the rollpack of a Page.
 | SendEmailNotificationForDraft(PageInfo, String, String, String) | Sends a draft notification to "administrators".
 | SetNamespaceDefaultPage(NamespaceInfo, PageInfo) | Sets the default page of a namespace.
 | StorePageOutgoingLinks(PageInfo, String) | Stores outgoing links for a page.
Inheritance Hierarchy
Object
Pages

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


AddMessage Method (page, username, subject, dateTime, body, parent)

AddMessage Method (page, username, subject, dateTime, body, parent)
ScrewTurn Wiki ► ScrewTurn.Wiki ► Pages ► AddMessage(PageInfo, String, String, DateTime, String, Int32)
Adds a new Message to a Page.
Declaration Syntax
C# Visual Basic Visual C++
public static bool AddMessage(
    PageInfo page,
    string username,
    string subject,
    DateTime dateTime,
    string body,
    int parent
)
Public Shared Function AddMessage ( _
    page As PageInfo, _
    username As String, _
    subject As String, _
    dateTime As DateTime, _
    body As String, _
    parent As Integer _
) As Boolean
public:
static bool AddMessage(
    PageInfo^ page,
    String^ username,
    String^ subject,
    DateTime dateTime,
    String^ body,
    int parent
)
Parameters
page (PageInfo)
The Page.
username (String)
The Username.
subject (String)
The Subject.
dateTime (DateTime)
The Date/Time.
body (String)
The Body.
parent (Int32)
The Parent Message ID, or -1.
Return Value
True if the Message has been added successfully.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


CanApproveDraft Method (page, username, groups)

CanApproveDraft Method (page, username, groups)
ScrewTurn Wiki ► ScrewTurn.Wiki ► Pages ► CanApproveDraft(PageInfo, String, array<String>[]()[])
Determines whether a user can approve/reject a draft of a page.
Declaration Syntax
C# Visual Basic Visual C++
public static bool CanApproveDraft(
    PageInfo page,
    string username,
    string[] groups
)
Public Shared Function CanApproveDraft ( _
    page As PageInfo, _
    username As String, _
    groups As String() _
) As Boolean
public:
static bool CanApproveDraft(
    PageInfo^ page,
    String^ username,
    array<String^>^ groups
)
Parameters
page (PageInfo)
The page.
username (String)
The username.
groups (array< String >[]()[][])
The groups.
Return Value
true if the user can approve/reject a draft of the page, false otherwise.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


CanEditPage Method (page, username, groups, canEdit, canEditWithApproval)

CanEditPage Method (page, username, groups, canEdit, canEditWithApproval)
ScrewTurn Wiki ► ScrewTurn.Wiki ► Pages ► CanEditPage(PageInfo, String, array<String>[]()[], Boolean%, Boolean%)
Determines whether a user can edit a page.
Declaration Syntax
C# Visual Basic Visual C++
public static void CanEditPage(
    PageInfo page,
    string username,
    string[] groups,
    out bool canEdit,
    out bool canEditWithApproval
)
Public Shared Sub CanEditPage ( _
    page As PageInfo, _
    username As String, _
    groups As String(), _
    <OutAttribute> ByRef canEdit As Boolean, _
    <OutAttribute> ByRef canEditWithApproval As Boolean _
)
public:
static void CanEditPage(
    PageInfo^ page,
    String^ username,
    array<String^>^ groups,
    [OutAttribute] bool% canEdit,
    [OutAttribute] bool% canEditWithApproval
)
Parameters
page (PageInfo)
The page.
username (String)
The username.
groups (array< String >[]()[][])
The groups.
canEdit ( Boolean %)
A value indicating whether the user can edit the page.
canEditWithApproval ( Boolean %)
A value indicating whether the user can edit the page with subsequent approval.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


CreateCategory Method

CreateCategory Method
ScrewTurn Wiki ► ScrewTurn.Wiki ► Pages ► CreateCategory()()()
Members
Icon | Member | Description
 | CreateCategory(NamespaceInfo, String) | Creates a new Category.
 | CreateCategory(String, String) | Creates a new Category.
 | CreateCategory(NamespaceInfo, String, IPagesStorageProviderV30) | Creates a new Category in the specifued Provider.
 | CreateCategory(String, String, IPagesStorageProviderV30) | Creates a new Category in the specifued Provider.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


CreateCategory Method (nspace, name)

CreateCategory Method (nspace, name)
ScrewTurn Wiki ► ScrewTurn.Wiki ► Pages ► CreateCategory(NamespaceInfo, String)
Creates a new Category.
Declaration Syntax
C# Visual Basic Visual C++
public static bool CreateCategory(
    NamespaceInfo nspace,
    string name
)
Public Shared Function CreateCategory ( _
    nspace As NamespaceInfo, _
    name As String _
) As Boolean
public:
static bool CreateCategory(
    NamespaceInfo^ nspace,
    String^ name
)
Parameters
nspace (NamespaceInfo)
The target namespace (null for the root).
name (String)
The Name of the Category.
Return Value
true if the category is created, false otherwise.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


CreateCategory Method (nspace, name, provider)

CreateCategory Method (nspace, name, provider)
ScrewTurn Wiki ► ScrewTurn.Wiki ► Pages ► CreateCategory(NamespaceInfo, String, IPagesStorageProviderV30)
Creates a new Category in the specifued Provider.
Declaration Syntax
C# Visual Basic Visual C++
public static bool CreateCategory(
    NamespaceInfo nspace,
    string name,
    IPagesStorageProviderV30 provider
)
Public Shared Function CreateCategory ( _
    nspace As NamespaceInfo, _
    name As String, _
    provider As IPagesStorageProviderV30 _
) As Boolean
public:
static bool CreateCategory(
    NamespaceInfo^ nspace,
    String^ name,
    IPagesStorageProviderV30^ provider
)
Parameters
nspace (NamespaceInfo)
The target namespace (null for the root).
name (String)
The Name of the Category.
provider (IPagesStorageProviderV30)
The Provider.
Return Value
true if the category is created, false otherwise.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


CreateCategory Method (nspace, name)

CreateCategory Method (nspace, name)
ScrewTurn Wiki ► ScrewTurn.Wiki ► Pages ► CreateCategory(String, String)
Creates a new Category.
Declaration Syntax
C# Visual Basic Visual C++
public static bool CreateCategory(
    string nspace,
    string name
)
Public Shared Function CreateCategory ( _
    nspace As String, _
    name As String _
) As Boolean
public:
static bool CreateCategory(
    String^ nspace,
    String^ name
)
Parameters
nspace (String)
The target namespace (null for the root).
name (String)
The Name of the Category.
Return Value
true if the category is created, false otherwise.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


CreateCategory Method (nspace, name, provider)

CreateCategory Method (nspace, name, provider)
ScrewTurn Wiki ► ScrewTurn.Wiki ► Pages ► CreateCategory(String, String, IPagesStorageProviderV30)
Creates a new Category in the specifued Provider.
Declaration Syntax
C# Visual Basic Visual C++
public static bool CreateCategory(
    string nspace,
    string name,
    IPagesStorageProviderV30 provider
)
Public Shared Function CreateCategory ( _
    nspace As String, _
    name As String, _
    provider As IPagesStorageProviderV30 _
) As Boolean
public:
static bool CreateCategory(
    String^ nspace,
    String^ name,
    IPagesStorageProviderV30^ provider
)
Parameters
nspace (String)
The target namespace (null for the root).
name (String)
The Name of the Category.
provider (IPagesStorageProviderV30)
The Provider.
Return Value
true if the category is created, false otherwise.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


CreateNamespace Method

CreateNamespace Method
ScrewTurn Wiki ► ScrewTurn.Wiki ► Pages ► CreateNamespace()()()
Members
Icon | Member | Description
 | CreateNamespace(String) | Creates a new namespace in the default pages storage provider.
 | CreateNamespace(String, IPagesStorageProviderV30) | Creates a new namespace.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


CreateNamespace Method (name)

CreateNamespace Method (name)
ScrewTurn Wiki ► ScrewTurn.Wiki ► Pages ► CreateNamespace(String)
Creates a new namespace in the default pages storage provider.
Declaration Syntax
C# Visual Basic Visual C++
public static bool CreateNamespace(
    string name
)
Public Shared Function CreateNamespace ( _
    name As String _
) As Boolean
public:
static bool CreateNamespace(
    String^ name
)
Parameters
name (String)
The name of the namespace to add.
Return Value
true if the namespace is created, false otherwise.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


CreateNamespace Method (name, provider)

CreateNamespace Method (name, provider)
ScrewTurn Wiki ► ScrewTurn.Wiki ► Pages ► CreateNamespace(String, IPagesStorageProviderV30)
Creates a new namespace.
Declaration Syntax
C# Visual Basic Visual C++
public static bool CreateNamespace(
    string name,
    IPagesStorageProviderV30 provider
)
Public Shared Function CreateNamespace ( _
    name As String, _
    provider As IPagesStorageProviderV30 _
) As Boolean
public:
static bool CreateNamespace(
    String^ name,
    IPagesStorageProviderV30^ provider
)
Parameters
name (String)
The name of the namespace to add.
provider (IPagesStorageProviderV30)
The provider to create the namespace into.
Return Value
true if the namespace is created, false otherwise.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


CreatePage Method

CreatePage Method
ScrewTurn Wiki ► ScrewTurn.Wiki ► Pages ► CreatePage()()()
Members
Icon | Member | Description
 | CreatePage(NamespaceInfo, String) | Creates a new Page.
 | CreatePage(String, String) | Creates a new Page.
 | CreatePage(NamespaceInfo, String, IPagesStorageProviderV30) | Creates a new Page.
 | CreatePage(String, String, IPagesStorageProviderV30) | Creates a new Page.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


CreatePage Method (nspace, name)

CreatePage Method (nspace, name)
ScrewTurn Wiki ► ScrewTurn.Wiki ► Pages ► CreatePage(NamespaceInfo, String)
Creates a new Page.
Declaration Syntax
C# Visual Basic Visual C++
public static bool CreatePage(
    NamespaceInfo nspace,
    string name
)
Public Shared Function CreatePage ( _
    nspace As NamespaceInfo, _
    name As String _
) As Boolean
public:
static bool CreatePage(
    NamespaceInfo^ nspace,
    String^ name
)
Parameters
nspace (NamespaceInfo)
The target namespace (null for the root).
name (String)
The Page name.
Return Value
true if the Page is created, false otherwise.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


CreatePage Method (nspace, name, provider)

CreatePage Method (nspace, name, provider)
ScrewTurn Wiki ► ScrewTurn.Wiki ► Pages ► CreatePage(NamespaceInfo, String, IPagesStorageProviderV30)
Creates a new Page.
Declaration Syntax
C# Visual Basic Visual C++
public static bool CreatePage(
    NamespaceInfo nspace,
    string name,
    IPagesStorageProviderV30 provider
)
Public Shared Function CreatePage ( _
    nspace As NamespaceInfo, _
    name As String, _
    provider As IPagesStorageProviderV30 _
) As Boolean
public:
static bool CreatePage(
    NamespaceInfo^ nspace,
    String^ name,
    IPagesStorageProviderV30^ provider
)
Parameters
nspace (NamespaceInfo)
The target namespace (null for the root).
name (String)
The Page name.
provider (IPagesStorageProviderV30)
The destination provider.
Return Value
true if the Page is created, false otherwise.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


CreatePage Method (nspace, name)

CreatePage Method (nspace, name)
ScrewTurn Wiki ► ScrewTurn.Wiki ► Pages ► CreatePage(String, String)
Creates a new Page.
Declaration Syntax
C# Visual Basic Visual C++
public static bool CreatePage(
    string nspace,
    string name
)
Public Shared Function CreatePage ( _
    nspace As String, _
    name As String _
) As Boolean
public:
static bool CreatePage(
    String^ nspace,
    String^ name
)
Parameters
nspace (String)
The target namespace (null for the root).
name (String)
The Page name.
Return Value
true if the Page is created, false otherwise.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


CreatePage Method (nspace, name, provider)

CreatePage Method (nspace, name, provider)
ScrewTurn Wiki ► ScrewTurn.Wiki ► Pages ► CreatePage(String, String, IPagesStorageProviderV30)
Creates a new Page.
Declaration Syntax
C# Visual Basic Visual C++
public static bool CreatePage(
    string nspace,
    string name,
    IPagesStorageProviderV30 provider
)
Public Shared Function CreatePage ( _
    nspace As String, _
    name As String, _
    provider As IPagesStorageProviderV30 _
) As Boolean
public:
static bool CreatePage(
    String^ nspace,
    String^ name,
    IPagesStorageProviderV30^ provider
)
Parameters
nspace (String)
The target namespace (null for the root).
name (String)
The Page name.
provider (IPagesStorageProviderV30)
The destination provider.
Return Value
true if the Page is created, false otherwise.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


DeleteBackups Method

DeleteBackups Method
ScrewTurn Wiki ► ScrewTurn.Wiki ► Pages ► DeleteBackups()()()
Members
Icon | Member | Description
 | DeleteBackups(PageInfo) | Deletes all the backups of a page.
 | DeleteBackups(PageInfo, Int32) | Deletes a subset of the backups of a page.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


DeleteBackups Method (page)

DeleteBackups Method (page)
ScrewTurn Wiki ► ScrewTurn.Wiki ► Pages ► DeleteBackups(PageInfo)
Deletes all the backups of a page.
Declaration Syntax
C# Visual Basic Visual C++
public static bool DeleteBackups(
    PageInfo page
)
Public Shared Function DeleteBackups ( _
    page As PageInfo _
) As Boolean
public:
static bool DeleteBackups(
    PageInfo^ page
)
Parameters
page (PageInfo)
The Page.
Return Value

[Missing <returns> documentation for "M:ScrewTurn.Wiki.Pages.DeleteBackups(ScrewTurn.Wiki.PluginFramework.PageInfo)"]

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


DeleteBackups Method (page, firstToDelete)

DeleteBackups Method (page, firstToDelete)
ScrewTurn Wiki ► ScrewTurn.Wiki ► Pages ► DeleteBackups(PageInfo, Int32)
Deletes a subset of the backups of a page.
Declaration Syntax
C# Visual Basic Visual C++
public static bool DeleteBackups(
    PageInfo page,
    int firstToDelete
)
Public Shared Function DeleteBackups ( _
    page As PageInfo, _
    firstToDelete As Integer _
) As Boolean
public:
static bool DeleteBackups(
    PageInfo^ page,
    int firstToDelete
)
Parameters
page (PageInfo)
The Page.
firstToDelete (Int32)
The first backup to be deleted (this backup and older backups are deleted).
Return Value

[Missing <returns> documentation for "M:ScrewTurn.Wiki.Pages.DeleteBackups(ScrewTurn.Wiki.PluginFramework.PageInfo,System.Int32)"]

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


DeleteDraft Method (page)

DeleteDraft Method (page)
ScrewTurn Wiki ► ScrewTurn.Wiki ► Pages ► DeleteDraft(PageInfo)
Deletes the draft of a page (if any).
Declaration Syntax
C# Visual Basic Visual C++
public static void DeleteDraft(
    PageInfo page
)
Public Shared Sub DeleteDraft ( _
    page As PageInfo _
)
public:
static void DeleteDraft(
    PageInfo^ page
)
Parameters
page (PageInfo)
The page of which to delete the draft.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


DeletePage Method (page)

DeletePage Method (page)
ScrewTurn Wiki ► ScrewTurn.Wiki ► Pages ► DeletePage(PageInfo)
Deletes a Page.
Declaration Syntax
C# Visual Basic Visual C++
public static bool DeletePage(
    PageInfo page
)
Public Shared Function DeletePage ( _
    page As PageInfo _
) As Boolean
public:
static bool DeletePage(
    PageInfo^ page
)
Parameters
page (PageInfo)
The Page to delete.
Return Value

[Missing <returns> documentation for "M:ScrewTurn.Wiki.Pages.DeletePage(ScrewTurn.Wiki.PluginFramework.PageInfo)"]

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


FindCategory Method (fullName)

FindCategory Method (fullName)
ScrewTurn Wiki ► ScrewTurn.Wiki ► Pages ► FindCategory(String)
Finds a Category.
Declaration Syntax
C# Visual Basic Visual C++
public static CategoryInfo FindCategory(
    string fullName
)
Public Shared Function FindCategory ( _
    fullName As String _
) As CategoryInfo
public:
static CategoryInfo^ FindCategory(
    String^ fullName
)
Parameters
fullName (String)
The full name of the Category to Find (case unsensitive).
Return Value
The correct CategoryInfo object or null if no category is found.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


FindMessage Method (messages, id)

FindMessage Method (messages, id)
ScrewTurn Wiki ► ScrewTurn.Wiki ► Pages ► FindMessage(array<Message>[]()[], Int32)
Finds a Message.
Declaration Syntax
C# Visual Basic Visual C++
public static Message FindMessage(
    Message[] messages,
    int id
)
Public Shared Function FindMessage ( _
    messages As Message(), _
    id As Integer _
) As Message
public:
static Message^ FindMessage(
    array<Message^>^ messages,
    int id
)
Parameters
messages (array< Message >[]()[][])
The Messages.
id (Int32)
The Message ID.
Return Value
The Message or null.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


FindNamespace Method

FindNamespace Method
ScrewTurn Wiki ► ScrewTurn.Wiki ► Pages ► FindNamespace()()()
Members
Icon | Member | Description
 | FindNamespace(String) | Finds a namespace.
 | FindNamespace(String, IPagesStorageProviderV30) | Finds a namespace.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


FindNamespace Method (name)

FindNamespace Method (name)
ScrewTurn Wiki ► ScrewTurn.Wiki ► Pages ► FindNamespace(String)
Finds a namespace.
Declaration Syntax
C# Visual Basic Visual C++
public static NamespaceInfo FindNamespace(
    string name
)
Public Shared Function FindNamespace ( _
    name As String _
) As NamespaceInfo
public:
static NamespaceInfo^ FindNamespace(
    String^ name
)
Parameters
name (String)
The name of the namespace to find.
Return Value
The namespace, or null if no namespace is found.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


FindNamespace Method (name, provider)

FindNamespace Method (name, provider)
ScrewTurn Wiki ► ScrewTurn.Wiki ► Pages ► FindNamespace(String, IPagesStorageProviderV30)
Finds a namespace.
Declaration Syntax
C# Visual Basic Visual C++
public static NamespaceInfo FindNamespace(
    string name,
    IPagesStorageProviderV30 provider
)
Public Shared Function FindNamespace ( _
    name As String, _
    provider As IPagesStorageProviderV30 _
) As NamespaceInfo
public:
static NamespaceInfo^ FindNamespace(
    String^ name,
    IPagesStorageProviderV30^ provider
)
Parameters
name (String)
The name of the namespace to find.
provider (IPagesStorageProviderV30)
The provider to look into.
Return Value
The namespace, or null if the namespace is not found.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


FindPage Method

FindPage Method
ScrewTurn Wiki ► ScrewTurn.Wiki ► Pages ► FindPage()()()
Members
Icon | Member | Description
 | FindPage(String) | Finds a Page.
 | FindPage(String, IPagesStorageProviderV30) | Finds a Page in a specific Provider.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


FindPage Method (fullName)

FindPage Method (fullName)
ScrewTurn Wiki ► ScrewTurn.Wiki ► Pages ► FindPage(String)
Finds a Page.
Declaration Syntax
C# Visual Basic Visual C++
public static PageInfo FindPage(
    string fullName
)
Public Shared Function FindPage ( _
    fullName As String _
) As PageInfo
public:
static PageInfo^ FindPage(
    String^ fullName
)
Parameters
fullName (String)
The full name of the page to find (case unsensitive).
Return Value
The correct PageInfo object, if any, null otherwise.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


FindPage Method (fullName, provider)

FindPage Method (fullName, provider)
ScrewTurn Wiki ► ScrewTurn.Wiki ► Pages ► FindPage(String, IPagesStorageProviderV30)
Finds a Page in a specific Provider.
Declaration Syntax
C# Visual Basic Visual C++
public static PageInfo FindPage(
    string fullName,
    IPagesStorageProviderV30 provider
)
Public Shared Function FindPage ( _
    fullName As String, _
    provider As IPagesStorageProviderV30 _
) As PageInfo
public:
static PageInfo^ FindPage(
    String^ fullName,
    IPagesStorageProviderV30^ provider
)
Parameters
fullName (String)
The full name of the page to find (case unsensitive).
provider (IPagesStorageProviderV30)
The Provider.
Return Value
The correct PageInfo object, if any, null otherwise.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


GetAvailableCategories Method (page)

GetAvailableCategories Method (page)
ScrewTurn Wiki ► ScrewTurn.Wiki ► Pages ► GetAvailableCategories(PageInfo)
Gets the valid Categories for a Page, i.e. the Categories managed by the Page's Provider and in the same namespace as the page.
Declaration Syntax
C# Visual Basic Visual C++
public static CategoryInfo[] GetAvailableCategories(
    PageInfo page
)
Public Shared Function GetAvailableCategories ( _
    page As PageInfo _
) As CategoryInfo()
public:
static array<CategoryInfo^>^ GetAvailableCategories(
    PageInfo^ page
)
Parameters
page (PageInfo)
The Page, or null to use the default provider.
Return Value
The valid Categories.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


GetBackupContent Method (page, revision)

GetBackupContent Method (page, revision)
ScrewTurn Wiki ► ScrewTurn.Wiki ► Pages ► GetBackupContent(PageInfo, Int32)
Gets the Content of a Page Backup.
Declaration Syntax
C# Visual Basic Visual C++
public static PageContent GetBackupContent(
    PageInfo page,
    int revision
)
Public Shared Function GetBackupContent ( _
    page As PageInfo, _
    revision As Integer _
) As PageContent
public:
static PageContent^ GetBackupContent(
    PageInfo^ page,
    int revision
)
Parameters
page (PageInfo)
The Page.
revision (Int32)
The Backup/Revision number.
Return Value
The Content of the Backup.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


GetBackups Method (page)

GetBackups Method (page)
ScrewTurn Wiki ► ScrewTurn.Wiki ► Pages ► GetBackups(PageInfo)
Gets the Backups/Revisions of a Page.
Declaration Syntax
C# Visual Basic Visual C++
public static List<int> GetBackups(
    PageInfo page
)
Public Shared Function GetBackups ( _
    page As PageInfo _
) As List(Of Integer)
public:
static List<int>^ GetBackups(
    PageInfo^ page
)
Parameters
page (PageInfo)
The Page.
Return Value
The list of available Backups/Revision numbers.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


GetCategories Method (nspace)

GetCategories Method (nspace)
ScrewTurn Wiki ► ScrewTurn.Wiki ► Pages ► GetCategories(NamespaceInfo)
Gets the list of all the Categories of a namespace. The list shouldn't be modified.
Declaration Syntax
C# Visual Basic Visual C++
public static List<CategoryInfo> GetCategories(
    NamespaceInfo nspace
)
Public Shared Function GetCategories ( _
    nspace As NamespaceInfo _
) As List(Of CategoryInfo)
public:
static List<CategoryInfo^>^ GetCategories(
    NamespaceInfo^ nspace
)
Parameters
nspace (NamespaceInfo)
The namespace (null for the root).
Return Value
The categories, sorted by name.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


GetCategoriesForPage Method (page)

GetCategoriesForPage Method (page)
ScrewTurn Wiki ► ScrewTurn.Wiki ► Pages ► GetCategoriesForPage(PageInfo)
Gets the Categories of a Page.
Declaration Syntax
C# Visual Basic Visual C++
public static CategoryInfo[] GetCategoriesForPage(
    PageInfo page
)
Public Shared Function GetCategoriesForPage ( _
    page As PageInfo _
) As CategoryInfo()
public:
static array<CategoryInfo^>^ GetCategoriesForPage(
    PageInfo^ page
)
Parameters
page (PageInfo)
The Page.
Return Value
The Categories of the Page.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


GetDraft Method (page)

GetDraft Method (page)
ScrewTurn Wiki ► ScrewTurn.Wiki ► Pages ► GetDraft(PageInfo)
Gets a page draft, if any.
Declaration Syntax
C# Visual Basic Visual C++
public static PageContent GetDraft(
    PageInfo page
)
Public Shared Function GetDraft ( _
    page As PageInfo _
) As PageContent
public:
static PageContent^ GetDraft(
    PageInfo^ page
)
Parameters
page (PageInfo)
The draft content, or null if no draft exists.
Return Value

[Missing <returns> documentation for "M:ScrewTurn.Wiki.Pages.GetDraft(ScrewTurn.Wiki.PluginFramework.PageInfo)"]

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


GetGlobalPageCount Method

GetGlobalPageCount Method
ScrewTurn Wiki ► ScrewTurn.Wiki ► Pages ► GetGlobalPageCount()()()
Gets the global number of pages.
Declaration Syntax
C# Visual Basic Visual C++
public static int GetGlobalPageCount()
Public Shared Function GetGlobalPageCount As Integer
public:
static int GetGlobalPageCount()
Return Value
The number of pages.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


GetMatchingCategories Method (category)

GetMatchingCategories Method (category)
ScrewTurn Wiki ► ScrewTurn.Wiki ► Pages ► GetMatchingCategories(CategoryInfo)
Gets the other Categories of the Provider and Namespace of the specified Category.
Declaration Syntax
C# Visual Basic Visual C++
public static CategoryInfo[] GetMatchingCategories(
    CategoryInfo category
)
Public Shared Function GetMatchingCategories ( _
    category As CategoryInfo _
) As CategoryInfo()
public:
static array<CategoryInfo^>^ GetMatchingCategories(
    CategoryInfo^ category
)
Parameters
category (CategoryInfo)
The Category.
Return Value
The matching Categories.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


GetMessageCount Method (page)

GetMessageCount Method (page)
ScrewTurn Wiki ► ScrewTurn.Wiki ► Pages ► GetMessageCount(PageInfo)
Gets the total number of Messages in a Page Discussion.
Declaration Syntax
C# Visual Basic Visual C++
public static int GetMessageCount(
    PageInfo page
)
Public Shared Function GetMessageCount ( _
    page As PageInfo _
) As Integer
public:
static int GetMessageCount(
    PageInfo^ page
)
Parameters
page (PageInfo)
The Page.
Return Value
The number of messages.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


GetNamespaces Method

GetNamespaces Method
ScrewTurn Wiki ► ScrewTurn.Wiki ► Pages ► GetNamespaces()()()
Gets all the namespaces, sorted.
Declaration Syntax
C# Visual Basic Visual C++
public static List<NamespaceInfo> GetNamespaces()
Public Shared Function GetNamespaces As List(Of NamespaceInfo)
public:
static List<NamespaceInfo^>^ GetNamespaces()
Return Value
The namespaces, sorted.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


GetOrphanedPages Method (nspace)

GetOrphanedPages Method (nspace)
ScrewTurn Wiki ► ScrewTurn.Wiki ► Pages ► GetOrphanedPages(NamespaceInfo)
Gets all the pages in a namespace without incoming links.
Declaration Syntax
C# Visual Basic Visual C++
public static PageInfo[] GetOrphanedPages(
    NamespaceInfo nspace
)
Public Shared Function GetOrphanedPages ( _
    nspace As NamespaceInfo _
) As PageInfo()
public:
static array<PageInfo^>^ GetOrphanedPages(
    NamespaceInfo^ nspace
)
Parameters
nspace (NamespaceInfo)
The namespace (null for the root).
Return Value
The orphaned pages.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


GetPageIncomingLinks Method (page)

GetPageIncomingLinks Method (page)
ScrewTurn Wiki ► ScrewTurn.Wiki ► Pages ► GetPageIncomingLinks(PageInfo)
Gets the incoming links for a page.
Declaration Syntax
C# Visual Basic Visual C++
public static string[] GetPageIncomingLinks(
    PageInfo page
)
Public Shared Function GetPageIncomingLinks ( _
    page As PageInfo _
) As String()
public:
static array<String^>^ GetPageIncomingLinks(
    PageInfo^ page
)
Parameters
page (PageInfo)
The page.
Return Value
The incoming links.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


GetPageMessages Method (page)

GetPageMessages Method (page)
ScrewTurn Wiki ► ScrewTurn.Wiki ► Pages ► GetPageMessages(PageInfo)
Gets the Page Messages.
Declaration Syntax
C# Visual Basic Visual C++
public static Message[] GetPageMessages(
    PageInfo page
)
Public Shared Function GetPageMessages ( _
    page As PageInfo _
) As Message()
public:
static array<Message^>^ GetPageMessages(
    PageInfo^ page
)
Parameters
page (PageInfo)
The Page.
Return Value
The list of the first-level Messages, containing the replies properly nested.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


GetPageOutgoingLinks Method (page)

GetPageOutgoingLinks Method (page)
ScrewTurn Wiki ► ScrewTurn.Wiki ► Pages ► GetPageOutgoingLinks(PageInfo)
Gets the outgoing links of a page.
Declaration Syntax
C# Visual Basic Visual C++
public static string[] GetPageOutgoingLinks(
    PageInfo page
)
Public Shared Function GetPageOutgoingLinks ( _
    page As PageInfo _
) As String()
public:
static array<String^>^ GetPageOutgoingLinks(
    PageInfo^ page
)
Parameters
page (PageInfo)
The page.
Return Value
The outgoing links.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


GetPages Method (nspace)

GetPages Method (nspace)
ScrewTurn Wiki ► ScrewTurn.Wiki ► Pages ► GetPages(NamespaceInfo)
Gets the list of all the Pages of a namespace.
Declaration Syntax
C# Visual Basic Visual C++
public static List<PageInfo> GetPages(
    NamespaceInfo nspace
)
Public Shared Function GetPages ( _
    nspace As NamespaceInfo _
) As List(Of PageInfo)
public:
static List<PageInfo^>^ GetPages(
    NamespaceInfo^ nspace
)
Parameters
nspace (NamespaceInfo)
The namespace (null for the root).
Return Value
The pages.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


GetUncategorizedPages Method (nspace)

GetUncategorizedPages Method (nspace)
ScrewTurn Wiki ► ScrewTurn.Wiki ► Pages ► GetUncategorizedPages(NamespaceInfo)
Gets all the Uncategorized Pages.
Declaration Syntax
C# Visual Basic Visual C++
public static PageInfo[] GetUncategorizedPages(
    NamespaceInfo nspace
)
Public Shared Function GetUncategorizedPages ( _
    nspace As NamespaceInfo _
) As PageInfo()
public:
static array<PageInfo^>^ GetUncategorizedPages(
    NamespaceInfo^ nspace
)
Parameters
nspace (NamespaceInfo)
The namespace.
Return Value
The Uncategorized Pages.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


GetWantedPages Method (nspace)

GetWantedPages Method (nspace)
ScrewTurn Wiki ► ScrewTurn.Wiki ► Pages ► GetWantedPages(String)
Gets the wanted/inexistent pages in all namespaces.
Declaration Syntax
C# Visual Basic Visual C++
public static Dictionary<string, List<string>> GetWantedPages(
    string nspace
)
Public Shared Function GetWantedPages ( _
    nspace As String _
) As Dictionary(Of String, List(Of String))
public:
static Dictionary<String^, List<String^>^>^ GetWantedPages(
    String^ nspace
)
Parameters
nspace (String)
The namespace (null for the root).
Return Value
The wanted/inexistent pages (dictionary wanted_page->linking_pages).

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


IsValidName Method (name)

IsValidName Method (name)
ScrewTurn Wiki ► ScrewTurn.Wiki ► Pages ► IsValidName(String)
Checks the validity of a Page name.
Declaration Syntax
C# Visual Basic Visual C++
public static bool IsValidName(
    string name
)
Public Shared Function IsValidName ( _
    name As String _
) As Boolean
public:
static bool IsValidName(
    String^ name
)
Parameters
name (String)
The Page name.
Return Value
True if the name is valid.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


MergeCategories Method (source, destination)

MergeCategories Method (source, destination)
ScrewTurn Wiki ► ScrewTurn.Wiki ► Pages ► MergeCategories(CategoryInfo, CategoryInfo)
Merges two Categories.
Declaration Syntax
C# Visual Basic Visual C++
public static bool MergeCategories(
    CategoryInfo source,
    CategoryInfo destination
)
Public Shared Function MergeCategories ( _
    source As CategoryInfo, _
    destination As CategoryInfo _
) As Boolean
public:
static bool MergeCategories(
    CategoryInfo^ source,
    CategoryInfo^ destination
)
Parameters
source (CategoryInfo)
The source Category.
destination (CategoryInfo)
The destination Category.
Return Value
True if the Categories have been merged successfully.
Remarks
The destination Category remains, while the source Category is deleted, and all its Pages re-binded in the destination Category. The two Categories must have the same provider.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


MigratePage Method (page, targetNamespace, copyCategories)

MigratePage Method (page, targetNamespace, copyCategories)
ScrewTurn Wiki ► ScrewTurn.Wiki ► Pages ► MigratePage(PageInfo, NamespaceInfo, Boolean)
Migrates a page.
Declaration Syntax
C# Visual Basic Visual C++
public static bool MigratePage(
    PageInfo page,
    NamespaceInfo targetNamespace,
    bool copyCategories
)
Public Shared Function MigratePage ( _
    page As PageInfo, _
    targetNamespace As NamespaceInfo, _
    copyCategories As Boolean _
) As Boolean
public:
static bool MigratePage(
    PageInfo^ page,
    NamespaceInfo^ targetNamespace,
    bool copyCategories
)
Parameters
page (PageInfo)
The page to migrate.
targetNamespace (NamespaceInfo)
The target namespace.
copyCategories (Boolean)
A value indicating whether to copy the page categories to the target namespace.
Return Value
true if the page is migrated, false otherwise.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


ModifyMessage Method (page, id, username, subject, dateTime, body)

ModifyMessage Method (page, id, username, subject, dateTime, body)
ScrewTurn Wiki ► ScrewTurn.Wiki ► Pages ► ModifyMessage(PageInfo, Int32, String, String, DateTime, String)
Modifies a Message.
Declaration Syntax
C# Visual Basic Visual C++
public static bool ModifyMessage(
    PageInfo page,
    int id,
    string username,
    string subject,
    DateTime dateTime,
    string body
)
Public Shared Function ModifyMessage ( _
    page As PageInfo, _
    id As Integer, _
    username As String, _
    subject As String, _
    dateTime As DateTime, _
    body As String _
) As Boolean
public:
static bool ModifyMessage(
    PageInfo^ page,
    int id,
    String^ username,
    String^ subject,
    DateTime dateTime,
    String^ body
)
Parameters
page (PageInfo)
The Page.
id (Int32)
The ID of the Message to modify.
username (String)
The Username.
subject (String)
The Subject.
dateTime (DateTime)
The Date/Time.
body (String)
The Body.
Return Value
True if the Message has been modified successfully.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


ModifyPage Method (page, title, username, dateTime, comment, content, keywords, description, saveMode)

ModifyPage Method (page, title, username, dateTime, comment, content, keywords, description, saveMode)
ScrewTurn Wiki ► ScrewTurn.Wiki ► Pages ► ModifyPage(PageInfo, String, String, DateTime, String, String, array<String>[]()[], String, SaveMode)
Modifies a Page.
Declaration Syntax
C# Visual Basic Visual C++
public static bool ModifyPage(
    PageInfo page,
    string title,
    string username,
    DateTime dateTime,
    string comment,
    string content,
    string[] keywords,
    string description,
    SaveMode saveMode
)
Public Shared Function ModifyPage ( _
    page As PageInfo, _
    title As String, _
    username As String, _
    dateTime As DateTime, _
    comment As String, _
    content As String, _
    keywords As String(), _
    description As String, _
    saveMode As SaveMode _
) As Boolean
public:
static bool ModifyPage(
    PageInfo^ page,
    String^ title,
    String^ username,
    DateTime dateTime,
    String^ comment,
    String^ content,
    array<String^>^ keywords,
    String^ description,
    SaveMode saveMode
)
Parameters
page (PageInfo)
The Page to modify.
title (String)
The Title of the Page.
username (String)
The Username of the user who modified the Page.
dateTime (DateTime)
The Date/Time of the modification.
comment (String)
The comment of the editor, about this revision.
content (String)
The Content.
keywords (array< String >[]()[][])
The keywords, usually used for SEO.
description (String)
The description, usually used for SEO.
saveMode (SaveMode)
The save mode.
Return Value
True if the Page has been modified successfully.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


Rebind Method (page, cats)

Rebind Method (page, cats)
ScrewTurn Wiki ► ScrewTurn.Wiki ► Pages ► Rebind(PageInfo, array<CategoryInfo>[]()[])
Binds a Page with some Categories.
Declaration Syntax
C# Visual Basic Visual C++
public static bool Rebind(
    PageInfo page,
    CategoryInfo[] cats
)
Public Shared Function Rebind ( _
    page As PageInfo, _
    cats As CategoryInfo() _
) As Boolean
public:
static bool Rebind(
    PageInfo^ page,
    array<CategoryInfo^>^ cats
)
Parameters
page (PageInfo)
The Page to rebind.
cats (array< CategoryInfo >[]()[][])
The Categories to bind the Page with.
Return Value
True if the binding succeeded.
Remarks
The specified Categories must be managed by the same Provider that manages the Page. The operation removes all the previous bindings.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


RemoveAllMessages Method (page)

RemoveAllMessages Method (page)
ScrewTurn Wiki ► ScrewTurn.Wiki ► Pages ► RemoveAllMessages(PageInfo)
Removes all messages of a Page.
Declaration Syntax
C# Visual Basic Visual C++
public static bool RemoveAllMessages(
    PageInfo page
)
Public Shared Function RemoveAllMessages ( _
    page As PageInfo _
) As Boolean
public:
static bool RemoveAllMessages(
    PageInfo^ page
)
Parameters
page (PageInfo)
The Page.
Return Value
true if the messages are removed, false otherwise.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


RemoveCategory Method (category)

RemoveCategory Method (category)
ScrewTurn Wiki ► ScrewTurn.Wiki ► Pages ► RemoveCategory(CategoryInfo)
Removes a Category.
Declaration Syntax
C# Visual Basic Visual C++
public static bool RemoveCategory(
    CategoryInfo category
)
Public Shared Function RemoveCategory ( _
    category As CategoryInfo _
) As Boolean
public:
static bool RemoveCategory(
    CategoryInfo^ category
)
Parameters
category (CategoryInfo)
The Category to remove.
Return Value
True if the Category has been removed successfully.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


RemoveMessage Method (page, id, removeReplies)

RemoveMessage Method (page, id, removeReplies)
ScrewTurn Wiki ► ScrewTurn.Wiki ► Pages ► RemoveMessage(PageInfo, Int32, Boolean)
Removes a Message.
Declaration Syntax
C# Visual Basic Visual C++
public static bool RemoveMessage(
    PageInfo page,
    int id,
    bool removeReplies
)
Public Shared Function RemoveMessage ( _
    page As PageInfo, _
    id As Integer, _
    removeReplies As Boolean _
) As Boolean
public:
static bool RemoveMessage(
    PageInfo^ page,
    int id,
    bool removeReplies
)
Parameters
page (PageInfo)
The Page.
id (Int32)
The ID of the Message to remove.
removeReplies (Boolean)
A value specifying whether or not to remove the replies.
Return Value
True if the Message has been removed successfully.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


RemoveNamespace Method (nspace)

RemoveNamespace Method (nspace)
ScrewTurn Wiki ► ScrewTurn.Wiki ► Pages ► RemoveNamespace(NamespaceInfo)
Removes a namespace.
Declaration Syntax
C# Visual Basic Visual C++
public static bool RemoveNamespace(
    NamespaceInfo nspace
)
Public Shared Function RemoveNamespace ( _
    nspace As NamespaceInfo _
) As Boolean
public:
static bool RemoveNamespace(
    NamespaceInfo^ nspace
)
Parameters
nspace (NamespaceInfo)
The namespace to remove.
Return Value
true if the namespace is removed, false otherwise.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


RenameCategory Method (category, newName)

RenameCategory Method (category, newName)
ScrewTurn Wiki ► ScrewTurn.Wiki ► Pages ► RenameCategory(CategoryInfo, String)
Renames a Category.
Declaration Syntax
C# Visual Basic Visual C++
public static bool RenameCategory(
    CategoryInfo category,
    string newName
)
Public Shared Function RenameCategory ( _
    category As CategoryInfo, _
    newName As String _
) As Boolean
public:
static bool RenameCategory(
    CategoryInfo^ category,
    String^ newName
)
Parameters
category (CategoryInfo)
The Category to rename.
newName (String)
The new Name of the Category.
Return Value
True if the Category has been renamed successfully.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


RenameNamespace Method (nspace, newName)

RenameNamespace Method (nspace, newName)
ScrewTurn Wiki ► ScrewTurn.Wiki ► Pages ► RenameNamespace(NamespaceInfo, String)
Renames a namespace.
Declaration Syntax
C# Visual Basic Visual C++
public static bool RenameNamespace(
    NamespaceInfo nspace,
    string newName
)
Public Shared Function RenameNamespace ( _
    nspace As NamespaceInfo, _
    newName As String _
) As Boolean
public:
static bool RenameNamespace(
    NamespaceInfo^ nspace,
    String^ newName
)
Parameters
nspace (NamespaceInfo)
The namespace to rename.
newName (String)
The new name.
Return Value
true if the namespace is removed, false otherwise.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


RenamePage Method (page, name)

RenamePage Method (page, name)
ScrewTurn Wiki ► ScrewTurn.Wiki ► Pages ► RenamePage(PageInfo, String)
Renames a Page.
Declaration Syntax
C# Visual Basic Visual C++
public static bool RenamePage(
    PageInfo page,
    string name
)
Public Shared Function RenamePage ( _
    page As PageInfo, _
    name As String _
) As Boolean
public:
static bool RenamePage(
    PageInfo^ page,
    String^ name
)
Parameters
page (PageInfo)
The Page to rename.
name (String)
The new name.
Return Value

[Missing <returns> documentation for "M:ScrewTurn.Wiki.Pages.RenamePage(ScrewTurn.Wiki.PluginFramework.PageInfo,System.String)"]

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


Rollback Method (page, version)

Rollback Method (page, version)
ScrewTurn Wiki ► ScrewTurn.Wiki ► Pages ► Rollback(PageInfo, Int32)
Performs the rollpack of a Page.
Declaration Syntax
C# Visual Basic Visual C++
public static bool Rollback(
    PageInfo page,
    int version
)
Public Shared Function Rollback ( _
    page As PageInfo, _
    version As Integer _
) As Boolean
public:
static bool Rollback(
    PageInfo^ page,
    int version
)
Parameters
page (PageInfo)
The Page.
version (Int32)
The revision to rollback the Page to.
Return Value

[Missing <returns> documentation for "M:ScrewTurn.Wiki.Pages.Rollback(ScrewTurn.Wiki.PluginFramework.PageInfo,System.Int32)"]

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


SendEmailNotificationForDraft Method (currentPage, title, comment, author)

SendEmailNotificationForDraft Method (currentPage, title, comment, author)
ScrewTurn Wiki ► ScrewTurn.Wiki ► Pages ► SendEmailNotificationForDraft(PageInfo, String, String, String)
Sends a draft notification to "administrators".
Declaration Syntax
C# Visual Basic Visual C++
public static void SendEmailNotificationForDraft(
    PageInfo currentPage,
    string title,
    string comment,
    string author
)
Public Shared Sub SendEmailNotificationForDraft ( _
    currentPage As PageInfo, _
    title As String, _
    comment As String, _
    author As String _
)
public:
static void SendEmailNotificationForDraft(
    PageInfo^ currentPage,
    String^ title,
    String^ comment,
    String^ author
)
Parameters
currentPage (PageInfo)
The edited page.
title (String)
The title.
comment (String)
The comment.
author (String)
The author.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


SetNamespaceDefaultPage Method (nspace, page)

SetNamespaceDefaultPage Method (nspace, page)
ScrewTurn Wiki ► ScrewTurn.Wiki ► Pages ► SetNamespaceDefaultPage(NamespaceInfo, PageInfo)
Sets the default page of a namespace.
Declaration Syntax
C# Visual Basic Visual C++
public static bool SetNamespaceDefaultPage(
    NamespaceInfo nspace,
    PageInfo page
)
Public Shared Function SetNamespaceDefaultPage ( _
    nspace As NamespaceInfo, _
    page As PageInfo _
) As Boolean
public:
static bool SetNamespaceDefaultPage(
    NamespaceInfo^ nspace,
    PageInfo^ page
)
Parameters
nspace (NamespaceInfo)
The namespace (null for the root).
page (PageInfo)
The page.
Return Value
true if the default page is set, false otherwise.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


StorePageOutgoingLinks Method (page, content)

StorePageOutgoingLinks Method (page, content)
ScrewTurn Wiki ► ScrewTurn.Wiki ► Pages ► StorePageOutgoingLinks(PageInfo, String)
Stores outgoing links for a page.
Declaration Syntax
C# Visual Basic Visual C++
public static void StorePageOutgoingLinks(
    PageInfo page,
    string content
)
Public Shared Sub StorePageOutgoingLinks ( _
    page As PageInfo, _
    content As String _
)
public:
static void StorePageOutgoingLinks(
    PageInfo^ page,
    String^ content
)
Parameters
page (PageInfo)
The page.
content (String)
The raw content.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


PagesStorageProvider Class

PagesStorageProvider Class
ScrewTurn Wiki ► ScrewTurn.Wiki ► PagesStorageProvider
Implements a Pages Storage Provider.
Declaration Syntax
C# Visual Basic Visual C++
public class PagesStorageProvider : IPagesStorageProviderV30,
    IStorageProviderV30, IProviderV30
Public Class PagesStorageProvider _
    Implements IPagesStorageProviderV30, IStorageProviderV30, IProviderV30
public ref class PagesStorageProvider : IPagesStorageProviderV30,
    IStorageProviderV30, IProviderV30
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | PagesStorageProvider()()() | Initializes a new instance of the PagesStorageProvider class
 | AddCategory(String, String) | Adds a new Category.
 | AddContentTemplate(String, String) | Adds a new content template.
 | AddMessage(PageInfo, String, String, DateTime, String, Int32) | Adds a new Message to a Page.
 | AddNamespace(String) | Adds a new namespace.
 | AddNavigationPath(String, String, array<PageInfo>[]()[]) | Adds a new Navigation Path.
 | AddPage(String, String, DateTime) | Adds a Page.
 | AddSnippet(String, String) | Adds a new Snippet.
 | BulkStoreMessages(PageInfo, array<Message>[]()[]) | Removes all messages for a page and stores the new messages.
 | ConfigHelpHtml | Gets a brief summary of the configuration string format, in HTML. Returns null if no configuration is needed.
 | DeleteBackups(PageInfo, Int32) | Deletes the Backups of a Page, up to a specified revision.
 | DeleteDraft(PageInfo) | Deletes a draft of a Page.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetBackupContent(PageInfo, Int32) | Gets the Content of a Backup.
 | GetBackups(PageInfo) | Gets the Backup/Revision numbers of a Page.
 | GetCategories(NamespaceInfo) | Gets all the Categories in a namespace.
 | GetCategoriesForPage(PageInfo) | Gets all the categories of a page.
 | GetCategory(String) | Gets a category.
 | GetContent(PageInfo) | Gets the Content of a Page.
 | GetContentTemplates()()() | Gets all the content templates.
 | GetDraft(PageInfo) | Gets the content of a draft of a Page.
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetIndexStats(Int32%, Int32%, Int32%, Int64%) | Gets some statistics about the search engine index.
 | GetMessageCount(PageInfo) | Gets the total number of Messages in a Page Discussion.
 | GetMessages(PageInfo) | Gets the Page Messages.
 | GetNamespace(String) | Gets a namespace.
 | GetNamespaces()()() | Gets all the sub-namespaces.
 | GetNavigationPaths(NamespaceInfo) | Gets all the Navigation Paths in a Namespace.
 | GetPage(String) | Gets a page.
 | GetPages(NamespaceInfo) | Gets all the Pages in a namespace.
 | GetSnippets()()() | Gets all the Snippets.
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetUncategorizedPages(NamespaceInfo) | Gets all the pages in a namespace that are bound to zero categories.
 | Information | Gets the Information about the Provider.
 | Init(IHostV30, String) | Initializes the Provider.
 | IsIndexCorrupted | Gets a value indicating whether the search engine index is corrupted and needs to be rebuilt.
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | MergeCategories(CategoryInfo, CategoryInfo) | Merges two Categories.
 | ModifyContentTemplate(String, String) | Modifies an existing content template.
 | ModifyMessage(PageInfo, Int32, String, String, DateTime, String) | Modifies a Message.
 | ModifyNavigationPath(NavigationPath, array<PageInfo>[]()[]) | Modifies an existing Navigation Path.
 | ModifyPage(PageInfo, String, String, DateTime, String, String, array<String>[]()[], String, SaveMode) | Modifies the Content of a Page.
 | ModifySnippet(String, String) | Modifies a new Snippet.
 | MovePage(PageInfo, NamespaceInfo, Boolean) | Moves a page from its namespace into another.
 | PerformSearch(SearchParameters) | Performs a search in the index.
 | ReadOnly | Gets a value specifying whether the provider is read-only, i.e. it can only provide data and not store it.
 | RebindPage(PageInfo, array<String>[]()[]) | Binds a Page with one or more Categories.
 | RebuildIndex()()() | Rebuilds the search index.
 | RemoveCategory(CategoryInfo) | Removes a Category.
 | RemoveContentTemplate(String) | Removes a content template.
 | RemoveMessage(PageInfo, Int32, Boolean) | Removes a Message.
 | RemoveNamespace(NamespaceInfo) | Removes a namespace.
 | RemoveNavigationPath(NavigationPath) | Removes a Navigation Path.
 | RemovePage(PageInfo) | Removes a Page.
 | RemoveSnippet(String) | Removes a new Snippet.
 | RenameCategory(CategoryInfo, String) | Renames a Category.
 | RenameNamespace(NamespaceInfo, String) | Renames a namespace.
 | RenamePage(PageInfo, String) | Renames a Page.
 | RollbackPage(PageInfo, Int32) | Performs the rollback of a Page to a specified revision.
 | SetBackupContent(PageContent, Int32) | Forces to overwrite or create a Backup.
 | SetNamespaceDefaultPage(NamespaceInfo, PageInfo) | Sets the default page of a namespace.
 | Shutdown()()() | Method invoked on shutdown.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
PagesStorageProvider

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


PagesStorageProvider Constructor

PagesStorageProvider Constructor
ScrewTurn Wiki ► ScrewTurn.Wiki ► PagesStorageProvider ► PagesStorageProvider()()()
Initializes a new instance of the PagesStorageProvider class
Declaration Syntax
C# Visual Basic Visual C++
public PagesStorageProvider()
Public Sub New
public:
PagesStorageProvider()

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


AddCategory Method (nspace, name)

AddCategory Method (nspace, name)
ScrewTurn Wiki ► ScrewTurn.Wiki ► PagesStorageProvider ► AddCategory(String, String)
Adds a new Category.
Declaration Syntax
C# Visual Basic Visual C++
public CategoryInfo AddCategory(
    string nspace,
    string name
)
Public Function AddCategory ( _
    nspace As String, _
    name As String _
) As CategoryInfo
public:
virtual CategoryInfo^ AddCategory(
    String^ nspace,
    String^ name
) sealed
Parameters
nspace (String)
The target namespace (null for the root).
name (String)
The Category name.
Return Value
The correct CategoryInfo object.
Exceptions
Exception | Condition
ArgumentNullException | If name is null.
ArgumentException | If name is empty.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


AddContentTemplate Method (name, content)

AddContentTemplate Method (name, content)
ScrewTurn Wiki ► ScrewTurn.Wiki ► PagesStorageProvider ► AddContentTemplate(String, String)
Adds a new content template.
Declaration Syntax
C# Visual Basic Visual C++
public ContentTemplate AddContentTemplate(
    string name,
    string content
)
Public Function AddContentTemplate ( _
    name As String, _
    content As String _
) As ContentTemplate
public:
virtual ContentTemplate^ AddContentTemplate(
    String^ name,
    String^ content
) sealed
Parameters
name (String)
The name of template.
content (String)
The content of the template.
Return Value
The correct ContentTemplate object.
Exceptions
Exception | Condition
ArgumentNullException | If name or content are null.
ArgumentNullException | If name is empty.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


AddMessage Method (page, username, subject, dateTime, body, parent)

AddMessage Method (page, username, subject, dateTime, body, parent)
ScrewTurn Wiki ► ScrewTurn.Wiki ► PagesStorageProvider ► AddMessage(PageInfo, String, String, DateTime, String, Int32)
Adds a new Message to a Page.
Declaration Syntax
C# Visual Basic Visual C++
public bool AddMessage(
    PageInfo page,
    string username,
    string subject,
    DateTime dateTime,
    string body,
    int parent
)
Public Function AddMessage ( _
    page As PageInfo, _
    username As String, _
    subject As String, _
    dateTime As DateTime, _
    body As String, _
    parent As Integer _
) As Boolean
public:
virtual bool AddMessage(
    PageInfo^ page,
    String^ username,
    String^ subject,
    DateTime dateTime,
    String^ body,
    int parent
) sealed
Parameters
page (PageInfo)
The Page.
username (String)
The Username.
subject (String)
The Subject.
dateTime (DateTime)
The Date/Time.
body (String)
The Body.
parent (Int32)
The Parent Message ID, or -1.
Return Value
True if the Message has been added successfully.
Exceptions
Exception | Condition
ArgumentNullException | If page, username, subject or body are null.
ArgumentException | If username or subject are empty.
ArgumentOutOfRangeException | If parent is less than -1.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


AddNamespace Method (name)

AddNamespace Method (name)
ScrewTurn Wiki ► ScrewTurn.Wiki ► PagesStorageProvider ► AddNamespace(String)
Adds a new namespace.
Declaration Syntax
C# Visual Basic Visual C++
public NamespaceInfo AddNamespace(
    string name
)
Public Function AddNamespace ( _
    name As String _
) As NamespaceInfo
public:
virtual NamespaceInfo^ AddNamespace(
    String^ name
) sealed
Parameters
name (String)
The name of the namespace.
Return Value
The correct NamespaceInfo object.
Exceptions
Exception | Condition
ArgumentNullException | If name is null.
ArgumentException | If name is empty.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


AddNavigationPath Method (nspace, name, pages)

AddNavigationPath Method (nspace, name, pages)
ScrewTurn Wiki ► ScrewTurn.Wiki ► PagesStorageProvider ► AddNavigationPath(String, String, array<PageInfo>[]()[])
Adds a new Navigation Path.
Declaration Syntax
C# Visual Basic Visual C++
public NavigationPath AddNavigationPath(
    string nspace,
    string name,
    PageInfo[] pages
)
Public Function AddNavigationPath ( _
    nspace As String, _
    name As String, _
    pages As PageInfo() _
) As NavigationPath
public:
virtual NavigationPath^ AddNavigationPath(
    String^ nspace,
    String^ name,
    array<PageInfo^>^ pages
) sealed
Parameters
nspace (String)
The target namespace (null for the root).
name (String)
The Name of the Path.
pages (array< PageInfo >[]()[][])
The Pages array.
Return Value
The correct NavigationPath object.
Exceptions
Exception | Condition
ArgumentNullException | If name or pages are null.
ArgumentException | If name or pages are empty.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


AddPage Method (nspace, name, creationDateTime)

AddPage Method (nspace, name, creationDateTime)
ScrewTurn Wiki ► ScrewTurn.Wiki ► PagesStorageProvider ► AddPage(String, String, DateTime)
Adds a Page.
Declaration Syntax
C# Visual Basic Visual C++
public PageInfo AddPage(
    string nspace,
    string name,
    DateTime creationDateTime
)
Public Function AddPage ( _
    nspace As String, _
    name As String, _
    creationDateTime As DateTime _
) As PageInfo
public:
virtual PageInfo^ AddPage(
    String^ nspace,
    String^ name,
    DateTime creationDateTime
) sealed
Parameters
nspace (String)
The target namespace (null for the root).
name (String)
The Page Name.
creationDateTime (DateTime)
The creation Date/Time.
Return Value
The correct PageInfo object or null.
Remarks
This method should not create the content of the Page.
Exceptions
Exception | Condition
ArgumentNullException | If name is null.
ArgumentException | If name is empty.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


AddSnippet Method (name, content)

AddSnippet Method (name, content)
ScrewTurn Wiki ► ScrewTurn.Wiki ► PagesStorageProvider ► AddSnippet(String, String)
Adds a new Snippet.
Declaration Syntax
C# Visual Basic Visual C++
public Snippet AddSnippet(
    string name,
    string content
)
Public Function AddSnippet ( _
    name As String, _
    content As String _
) As Snippet
public:
virtual Snippet^ AddSnippet(
    String^ name,
    String^ content
) sealed
Parameters
name (String)
The Name of the Snippet.
content (String)
The Content of the Snippet.
Return Value
The correct Snippet object.
Exceptions
Exception | Condition
ArgumentNullException | If name or content are null.
ArgumentNullException | If name is empty.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


BulkStoreMessages Method (page, messages)

BulkStoreMessages Method (page, messages)
ScrewTurn Wiki ► ScrewTurn.Wiki ► PagesStorageProvider ► BulkStoreMessages(PageInfo, array<Message>[]()[])
Removes all messages for a page and stores the new messages.
Declaration Syntax
C# Visual Basic Visual C++
public bool BulkStoreMessages(
    PageInfo page,
    Message[] messages
)
Public Function BulkStoreMessages ( _
    page As PageInfo, _
    messages As Message() _
) As Boolean
public:
virtual bool BulkStoreMessages(
    PageInfo^ page,
    array<Message^>^ messages
) sealed
Parameters
page (PageInfo)
The page.
messages (array< Message >[]()[][])
The new messages to store.
Return Value
true if the messages are stored, false otherwise.
Exceptions
Exception | Condition
ArgumentNullException | If page or messages are null.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


ConfigHelpHtml Property

ConfigHelpHtml Property
ScrewTurn Wiki ► ScrewTurn.Wiki ► PagesStorageProvider ► ConfigHelpHtml
Gets a brief summary of the configuration string format, in HTML. Returns null if no configuration is needed.
Declaration Syntax
C# Visual Basic Visual C++
public string ConfigHelpHtml { get; }
Public ReadOnly Property ConfigHelpHtml As String
public:
virtual property String^ ConfigHelpHtml {
    String^ get () sealed;
}

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


DeleteBackups Method (page, revision)

DeleteBackups Method (page, revision)
ScrewTurn Wiki ► ScrewTurn.Wiki ► PagesStorageProvider ► DeleteBackups(PageInfo, Int32)
Deletes the Backups of a Page, up to a specified revision.
Declaration Syntax
C# Visual Basic Visual C++
public bool DeleteBackups(
    PageInfo page,
    int revision
)
Public Function DeleteBackups ( _
    page As PageInfo, _
    revision As Integer _
) As Boolean
public:
virtual bool DeleteBackups(
    PageInfo^ page,
    int revision
) sealed
Parameters
page (PageInfo)
The Page to delete the backups of.
revision (Int32)
The newest revision to delete (newer revision are kept) or -1 to delete all the Backups.
Return Value
true if the deletion succeeded, false otherwise.
Exceptions
Exception | Condition
ArgumentNullException | If page is null.
ArgumentOutOfRangeException | If revision is less than -1.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


DeleteDraft Method (page)

DeleteDraft Method (page)
ScrewTurn Wiki ► ScrewTurn.Wiki ► PagesStorageProvider ► DeleteDraft(PageInfo)
Deletes a draft of a Page.
Declaration Syntax
C# Visual Basic Visual C++
public bool DeleteDraft(
    PageInfo page
)
Public Function DeleteDraft ( _
    page As PageInfo _
) As Boolean
public:
virtual bool DeleteDraft(
    PageInfo^ page
) sealed
Parameters
page (PageInfo)
The page.
Return Value
true if the draft is deleted, false otherwise.
Exceptions
Exception | Condition
ArgumentNullException | If page is null.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


GetBackupContent Method (page, revision)

GetBackupContent Method (page, revision)
ScrewTurn Wiki ► ScrewTurn.Wiki ► PagesStorageProvider ► GetBackupContent(PageInfo, Int32)
Gets the Content of a Backup.
Declaration Syntax
C# Visual Basic Visual C++
public PageContent GetBackupContent(
    PageInfo page,
    int revision
)
Public Function GetBackupContent ( _
    page As PageInfo, _
    revision As Integer _
) As PageContent
public:
virtual PageContent^ GetBackupContent(
    PageInfo^ page,
    int revision
) sealed
Parameters
page (PageInfo)
The Page.
revision (Int32)
The revision.
Return Value
The content.
Exceptions
Exception | Condition
ArgumentNullException | If page is null.
ArgumentOutOfRangeException | If revision is less than zero.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


GetBackups Method (page)

GetBackups Method (page)
ScrewTurn Wiki ► ScrewTurn.Wiki ► PagesStorageProvider ► GetBackups(PageInfo)
Gets the Backup/Revision numbers of a Page.
Declaration Syntax
C# Visual Basic Visual C++
public int[] GetBackups(
    PageInfo page
)
Public Function GetBackups ( _
    page As PageInfo _
) As Integer()
public:
virtual array<int>^ GetBackups(
    PageInfo^ page
) sealed
Parameters
page (PageInfo)
The Page to get the Backups of.
Return Value
The list of Backup/Revision numbers.
Exceptions
Exception | Condition
ArgumentNullException | If page is null.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


GetCategories Method (nspace)

GetCategories Method (nspace)
ScrewTurn Wiki ► ScrewTurn.Wiki ► PagesStorageProvider ► GetCategories(NamespaceInfo)
Gets all the Categories in a namespace.
Declaration Syntax
C# Visual Basic Visual C++
public CategoryInfo[] GetCategories(
    NamespaceInfo nspace
)
Public Function GetCategories ( _
    nspace As NamespaceInfo _
) As CategoryInfo()
public:
virtual array<CategoryInfo^>^ GetCategories(
    NamespaceInfo^ nspace
) sealed
Parameters
nspace (NamespaceInfo)
The namespace.
Return Value
All the Categories in the namespace, sorted by name.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


GetCategoriesForPage Method (page)

GetCategoriesForPage Method (page)
ScrewTurn Wiki ► ScrewTurn.Wiki ► PagesStorageProvider ► GetCategoriesForPage(PageInfo)
Gets all the categories of a page.
Declaration Syntax
C# Visual Basic Visual C++
public CategoryInfo[] GetCategoriesForPage(
    PageInfo page
)
Public Function GetCategoriesForPage ( _
    page As PageInfo _
) As CategoryInfo()
public:
virtual array<CategoryInfo^>^ GetCategoriesForPage(
    PageInfo^ page
) sealed
Parameters
page (PageInfo)
The page.
Return Value
The categories, sorted by name.
Exceptions
Exception | Condition
ArgumentNullException | If page is null.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


GetCategory Method (fullName)

GetCategory Method (fullName)
ScrewTurn Wiki ► ScrewTurn.Wiki ► PagesStorageProvider ► GetCategory(String)
Gets a category.
Declaration Syntax
C# Visual Basic Visual C++
public CategoryInfo GetCategory(
    string fullName
)
Public Function GetCategory ( _
    fullName As String _
) As CategoryInfo
public:
virtual CategoryInfo^ GetCategory(
    String^ fullName
) sealed
Parameters
fullName (String)
The full name of the category.
Return Value
The CategoryInfo, or null if no category is found.
Exceptions
Exception | Condition
ArgumentNullException | If fullName is null.
ArgumentException | If fullName is empty.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


GetContent Method (page)

GetContent Method (page)
ScrewTurn Wiki ► ScrewTurn.Wiki ► PagesStorageProvider ► GetContent(PageInfo)
Gets the Content of a Page.
Declaration Syntax
C# Visual Basic Visual C++
public PageContent GetContent(
    PageInfo page
)
Public Function GetContent ( _
    page As PageInfo _
) As PageContent
public:
virtual PageContent^ GetContent(
    PageInfo^ page
) sealed
Parameters
page (PageInfo)
The Page.
Return Value
The Page Content object, null if the page does not exist or page is null, or an empty instance if the content could not be retrieved ().
See Also
GetEmpty(PageInfo)

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


GetContentTemplates Method

GetContentTemplates Method
ScrewTurn Wiki ► ScrewTurn.Wiki ► PagesStorageProvider ► GetContentTemplates()()()
Gets all the content templates.
Declaration Syntax
C# Visual Basic Visual C++
public ContentTemplate[] GetContentTemplates()
Public Function GetContentTemplates As ContentTemplate()
public:
virtual array<ContentTemplate^>^ GetContentTemplates() sealed
Return Value
All the content templates, sorted by name.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


GetDraft Method (page)

GetDraft Method (page)
ScrewTurn Wiki ► ScrewTurn.Wiki ► PagesStorageProvider ► GetDraft(PageInfo)
Gets the content of a draft of a Page.
Declaration Syntax
C# Visual Basic Visual C++
public PageContent GetDraft(
    PageInfo page
)
Public Function GetDraft ( _
    page As PageInfo _
) As PageContent
public:
virtual PageContent^ GetDraft(
    PageInfo^ page
) sealed
Parameters
page (PageInfo)
The Page.
Return Value
The draft, or null if no draft exists.
Exceptions
Exception | Condition
ArgumentNullException | If page is null.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


GetIndexStats Method (documentCount, wordCount, occurrenceCount, size)

GetIndexStats Method (documentCount, wordCount, occurrenceCount, size)
ScrewTurn Wiki ► ScrewTurn.Wiki ► PagesStorageProvider ► GetIndexStats(Int32%, Int32%, Int32%, Int64%)
Gets some statistics about the search engine index.
Declaration Syntax
C# Visual Basic Visual C++
public void GetIndexStats(
    out int documentCount,
    out int wordCount,
    out int occurrenceCount,
    out long size
)
Public Sub GetIndexStats ( _
    <OutAttribute> ByRef documentCount As Integer, _
    <OutAttribute> ByRef wordCount As Integer, _
    <OutAttribute> ByRef occurrenceCount As Integer, _
    <OutAttribute> ByRef size As Long _
)
public:
virtual void GetIndexStats(
    [OutAttribute] int% documentCount,
    [OutAttribute] int% wordCount,
    [OutAttribute] int% occurrenceCount,
    [OutAttribute] long long% size
) sealed
Parameters
documentCount ( Int32 %)
The total number of documents.
wordCount ( Int32 %)
The total number of unique words.
occurrenceCount ( Int32 %)
The total number of word-document occurrences.
size ( Int64 %)
The approximated size, in bytes, of the search engine index.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


GetMessageCount Method (page)

GetMessageCount Method (page)
ScrewTurn Wiki ► ScrewTurn.Wiki ► PagesStorageProvider ► GetMessageCount(PageInfo)
Gets the total number of Messages in a Page Discussion.
Declaration Syntax
C# Visual Basic Visual C++
public int GetMessageCount(
    PageInfo page
)
Public Function GetMessageCount ( _
    page As PageInfo _
) As Integer
public:
virtual int GetMessageCount(
    PageInfo^ page
) sealed
Parameters
page (PageInfo)
The Page.
Return Value
The number of messages.
Exceptions
Exception | Condition
ArgumentNullException | If page is null.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


GetMessages Method (page)

GetMessages Method (page)
ScrewTurn Wiki ► ScrewTurn.Wiki ► PagesStorageProvider ► GetMessages(PageInfo)
Gets the Page Messages.
Declaration Syntax
C# Visual Basic Visual C++
public Message[] GetMessages(
    PageInfo page
)
Public Function GetMessages ( _
    page As PageInfo _
) As Message()
public:
virtual array<Message^>^ GetMessages(
    PageInfo^ page
) sealed
Parameters
page (PageInfo)
The Page.
Return Value
The list of the first-level Messages, containing the replies properly nested, sorted by date/time.
Exceptions
Exception | Condition
ArgumentNullException | If page is null.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


GetNamespace Method (name)

GetNamespace Method (name)
ScrewTurn Wiki ► ScrewTurn.Wiki ► PagesStorageProvider ► GetNamespace(String)
Gets a namespace.
Declaration Syntax
C# Visual Basic Visual C++
public NamespaceInfo GetNamespace(
    string name
)
Public Function GetNamespace ( _
    name As String _
) As NamespaceInfo
public:
virtual NamespaceInfo^ GetNamespace(
    String^ name
) sealed
Parameters
name (String)
The name of the namespace.
Return Value
The NamespaceInfo, or null if no namespace is found.
Exceptions
Exception | Condition
ArgumentNullException | If name is null.
ArgumentException | If name is empty.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


GetNamespaces Method

GetNamespaces Method
ScrewTurn Wiki ► ScrewTurn.Wiki ► PagesStorageProvider ► GetNamespaces()()()
Gets all the sub-namespaces.
Declaration Syntax
C# Visual Basic Visual C++
public NamespaceInfo[] GetNamespaces()
Public Function GetNamespaces As NamespaceInfo()
public:
virtual array<NamespaceInfo^>^ GetNamespaces() sealed
Return Value
The sub-namespaces, sorted by name.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


GetNavigationPaths Method (nspace)

GetNavigationPaths Method (nspace)
ScrewTurn Wiki ► ScrewTurn.Wiki ► PagesStorageProvider ► GetNavigationPaths(NamespaceInfo)
Gets all the Navigation Paths in a Namespace.
Declaration Syntax
C# Visual Basic Visual C++
public NavigationPath[] GetNavigationPaths(
    NamespaceInfo nspace
)
Public Function GetNavigationPaths ( _
    nspace As NamespaceInfo _
) As NavigationPath()
public:
virtual array<NavigationPath^>^ GetNavigationPaths(
    NamespaceInfo^ nspace
) sealed
Parameters
nspace (NamespaceInfo)
The Namespace.
Return Value
All the Navigation Paths, sorted by name.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


GetPage Method (fullName)

GetPage Method (fullName)
ScrewTurn Wiki ► ScrewTurn.Wiki ► PagesStorageProvider ► GetPage(String)
Gets a page.
Declaration Syntax
C# Visual Basic Visual C++
public PageInfo GetPage(
    string fullName
)
Public Function GetPage ( _
    fullName As String _
) As PageInfo
public:
virtual PageInfo^ GetPage(
    String^ fullName
) sealed
Parameters
fullName (String)
The full name of the page.
Return Value
The PageInfo, or null if no page is found.
Exceptions
Exception | Condition
ArgumentNullException | If fullName is null.
ArgumentException | If fullName is empty.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


GetPages Method (nspace)

GetPages Method (nspace)
ScrewTurn Wiki ► ScrewTurn.Wiki ► PagesStorageProvider ► GetPages(NamespaceInfo)
Gets all the Pages in a namespace.
Declaration Syntax
C# Visual Basic Visual C++
public PageInfo[] GetPages(
    NamespaceInfo nspace
)
Public Function GetPages ( _
    nspace As NamespaceInfo _
) As PageInfo()
public:
virtual array<PageInfo^>^ GetPages(
    NamespaceInfo^ nspace
) sealed
Parameters
nspace (NamespaceInfo)
The namespace (null for the root).
Return Value
All the Pages in the namespace. The array is not sorted.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


GetSnippets Method

GetSnippets Method
ScrewTurn Wiki ► ScrewTurn.Wiki ► PagesStorageProvider ► GetSnippets()()()
Gets all the Snippets.
Declaration Syntax
C# Visual Basic Visual C++
public Snippet[] GetSnippets()
Public Function GetSnippets As Snippet()
public:
virtual array<Snippet^>^ GetSnippets() sealed
Return Value
All the Snippets, sorted by name.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


GetUncategorizedPages Method (nspace)

GetUncategorizedPages Method (nspace)
ScrewTurn Wiki ► ScrewTurn.Wiki ► PagesStorageProvider ► GetUncategorizedPages(NamespaceInfo)
Gets all the pages in a namespace that are bound to zero categories.
Declaration Syntax
C# Visual Basic Visual C++
public PageInfo[] GetUncategorizedPages(
    NamespaceInfo nspace
)
Public Function GetUncategorizedPages ( _
    nspace As NamespaceInfo _
) As PageInfo()
public:
virtual array<PageInfo^>^ GetUncategorizedPages(
    NamespaceInfo^ nspace
) sealed
Parameters
nspace (NamespaceInfo)
The namespace (null for the root).
Return Value
The pages, sorted by name.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


Information Property

Information Property
ScrewTurn Wiki ► ScrewTurn.Wiki ► PagesStorageProvider ► Information
Gets the Information about the Provider.
Declaration Syntax
C# Visual Basic Visual C++
public ComponentInformation Information { get; }
Public ReadOnly Property Information As ComponentInformation
public:
virtual property ComponentInformation^ Information {
    ComponentInformation^ get () sealed;
}

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


Init Method (host, config)

Init Method (host, config)
ScrewTurn Wiki ► ScrewTurn.Wiki ► PagesStorageProvider ► Init(IHostV30, String)
Initializes the Provider.
Declaration Syntax
C# Visual Basic Visual C++
public void Init(
    IHostV30 host,
    string config
)
Public Sub Init ( _
    host As IHostV30, _
    config As String _
)
public:
virtual void Init(
    IHostV30^ host,
    String^ config
) sealed
Parameters
host (IHostV30)
The Host of the Provider.
config (String)
The Configuration data, if any.
Exceptions
Exception | Condition
ArgumentNullException | If host or config are null.
InvalidConfigurationException | If config is not valid or is incorrect.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


IsIndexCorrupted Property

IsIndexCorrupted Property
ScrewTurn Wiki ► ScrewTurn.Wiki ► PagesStorageProvider ► IsIndexCorrupted
Gets a value indicating whether the search engine index is corrupted and needs to be rebuilt.
Declaration Syntax
C# Visual Basic Visual C++
public bool IsIndexCorrupted { get; }
Public ReadOnly Property IsIndexCorrupted As Boolean
public:
virtual property bool IsIndexCorrupted {
    bool get () sealed;
}

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


MergeCategories Method (source, destination)

MergeCategories Method (source, destination)
ScrewTurn Wiki ► ScrewTurn.Wiki ► PagesStorageProvider ► MergeCategories(CategoryInfo, CategoryInfo)
Merges two Categories.
Declaration Syntax
C# Visual Basic Visual C++
public CategoryInfo MergeCategories(
    CategoryInfo source,
    CategoryInfo destination
)
Public Function MergeCategories ( _
    source As CategoryInfo, _
    destination As CategoryInfo _
) As CategoryInfo
public:
virtual CategoryInfo^ MergeCategories(
    CategoryInfo^ source,
    CategoryInfo^ destination
) sealed
Parameters
source (CategoryInfo)
The source Category.
destination (CategoryInfo)
The destination Category.
Return Value
True if the Categories have been merged successfully.
Remarks
The destination Category remains, while the source Category is deleted, and all its Pages re-bound in the destination Category.
Exceptions
Exception | Condition
ArgumentNullException | If source or destination are null.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


ModifyContentTemplate Method (name, content)

ModifyContentTemplate Method (name, content)
ScrewTurn Wiki ► ScrewTurn.Wiki ► PagesStorageProvider ► ModifyContentTemplate(String, String)
Modifies an existing content template.
Declaration Syntax
C# Visual Basic Visual C++
public ContentTemplate ModifyContentTemplate(
    string name,
    string content
)
Public Function ModifyContentTemplate ( _
    name As String, _
    content As String _
) As ContentTemplate
public:
virtual ContentTemplate^ ModifyContentTemplate(
    String^ name,
    String^ content
) sealed
Parameters
name (String)
The name of the template to modify.
content (String)
The content of the template.
Return Value
The correct ContentTemplate object.
Exceptions
Exception | Condition
ArgumentNullException | If name or content are null.
ArgumentNullException | If name is empty.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


ModifyMessage Method (page, id, username, subject, dateTime, body)

ModifyMessage Method (page, id, username, subject, dateTime, body)
ScrewTurn Wiki ► ScrewTurn.Wiki ► PagesStorageProvider ► ModifyMessage(PageInfo, Int32, String, String, DateTime, String)
Modifies a Message.
Declaration Syntax
C# Visual Basic Visual C++
public bool ModifyMessage(
    PageInfo page,
    int id,
    string username,
    string subject,
    DateTime dateTime,
    string body
)
Public Function ModifyMessage ( _
    page As PageInfo, _
    id As Integer, _
    username As String, _
    subject As String, _
    dateTime As DateTime, _
    body As String _
) As Boolean
public:
virtual bool ModifyMessage(
    PageInfo^ page,
    int id,
    String^ username,
    String^ subject,
    DateTime dateTime,
    String^ body
) sealed
Parameters
page (PageInfo)
The Page.
id (Int32)
The ID of the Message to modify.
username (String)
The Username.
subject (String)
The Subject.
dateTime (DateTime)
The Date/Time.
body (String)
The Body.
Return Value
True if the Message has been modified successfully.
Exceptions
Exception | Condition
ArgumentNullException | If page, username, subject or body are null.
ArgumentOutOfRangeException | If id is less than zero.
ArgumentException | If username or subject are empty.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


ModifyNavigationPath Method (path, pages)

ModifyNavigationPath Method (path, pages)
ScrewTurn Wiki ► ScrewTurn.Wiki ► PagesStorageProvider ► ModifyNavigationPath(NavigationPath, array<PageInfo>[]()[])
Modifies an existing Navigation Path.
Declaration Syntax
C# Visual Basic Visual C++
public NavigationPath ModifyNavigationPath(
    NavigationPath path,
    PageInfo[] pages
)
Public Function ModifyNavigationPath ( _
    path As NavigationPath, _
    pages As PageInfo() _
) As NavigationPath
public:
virtual NavigationPath^ ModifyNavigationPath(
    NavigationPath^ path,
    array<PageInfo^>^ pages
) sealed
Parameters
path (NavigationPath)
The Navigation Path to modify.
pages (array< PageInfo >[]()[][])
The new Pages array.
Return Value
The correct NavigationPath object.
Exceptions
Exception | Condition
ArgumentNullException | If path or pages are null.
ArgumentException | If pages is empty.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


ModifyPage Method (page, title, username, dateTime, comment, content, keywords, description, saveMode)

ModifyPage Method (page, title, username, dateTime, comment, content, keywords, description, saveMode)
ScrewTurn Wiki ► ScrewTurn.Wiki ► PagesStorageProvider ► ModifyPage(PageInfo, String, String, DateTime, String, String, array<String>[]()[], String, SaveMode)
Modifies the Content of a Page.
Declaration Syntax
C# Visual Basic Visual C++
public bool ModifyPage(
    PageInfo page,
    string title,
    string username,
    DateTime dateTime,
    string comment,
    string content,
    string[] keywords,
    string description,
    SaveMode saveMode
)
Public Function ModifyPage ( _
    page As PageInfo, _
    title As String, _
    username As String, _
    dateTime As DateTime, _
    comment As String, _
    content As String, _
    keywords As String(), _
    description As String, _
    saveMode As SaveMode _
) As Boolean
public:
virtual bool ModifyPage(
    PageInfo^ page,
    String^ title,
    String^ username,
    DateTime dateTime,
    String^ comment,
    String^ content,
    array<String^>^ keywords,
    String^ description,
    SaveMode saveMode
) sealed
Parameters
page (PageInfo)
The Page.
title (String)
The Title of the Page.
username (String)
The Username.
dateTime (DateTime)
The Date/Time.
comment (String)
The Comment of the editor, about this revision.
content (String)
The Page Content.
keywords (array< String >[]()[][])
The keywords, usually used for SEO.
description (String)
The description, usually used for SEO.
saveMode (SaveMode)
The save mode for this modification.
Return Value
true if the Page has been modified successfully, false otherwise.
Remarks
If saveMode equals Draft and a draft already exists, it is overwritten.
Exceptions
Exception | Condition
ArgumentNullException | If page, title username or content are null.
ArgumentException | If title or username are empty.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


ModifySnippet Method (name, content)

ModifySnippet Method (name, content)
ScrewTurn Wiki ► ScrewTurn.Wiki ► PagesStorageProvider ► ModifySnippet(String, String)
Modifies a new Snippet.
Declaration Syntax
C# Visual Basic Visual C++
public Snippet ModifySnippet(
    string name,
    string content
)
Public Function ModifySnippet ( _
    name As String, _
    content As String _
) As Snippet
public:
virtual Snippet^ ModifySnippet(
    String^ name,
    String^ content
) sealed
Parameters
name (String)
The Name of the Snippet to modify.
content (String)
The Content of the Snippet.
Return Value
The correct Snippet object.
Exceptions
Exception | Condition
ArgumentNullException | If name or content are null.
ArgumentNullException | If name is empty.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


MovePage Method (page, destination, copyCategories)

MovePage Method (page, destination, copyCategories)
ScrewTurn Wiki ► ScrewTurn.Wiki ► PagesStorageProvider ► MovePage(PageInfo, NamespaceInfo, Boolean)
Moves a page from its namespace into another.
Declaration Syntax
C# Visual Basic Visual C++
public PageInfo MovePage(
    PageInfo page,
    NamespaceInfo destination,
    bool copyCategories
)
Public Function MovePage ( _
    page As PageInfo, _
    destination As NamespaceInfo, _
    copyCategories As Boolean _
) As PageInfo
public:
virtual PageInfo^ MovePage(
    PageInfo^ page,
    NamespaceInfo^ destination,
    bool copyCategories
) sealed
Parameters
page (PageInfo)
The page to move.
destination (NamespaceInfo)
The destination namespace (null for the root).
copyCategories (Boolean)
A value indicating whether to copy the page categories in the destination namespace, if not already available.
Return Value
The correct instance of PageInfo.
Exceptions
Exception | Condition
ArgumentNullException | If page is null.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


PerformSearch Method (parameters)

PerformSearch Method (parameters)
ScrewTurn Wiki ► ScrewTurn.Wiki ► PagesStorageProvider ► PerformSearch(SearchParameters)
Performs a search in the index.
Declaration Syntax
C# Visual Basic Visual C++
public SearchResultCollection PerformSearch(
    SearchParameters parameters
)
Public Function PerformSearch ( _
    parameters As SearchParameters _
) As SearchResultCollection
public:
virtual SearchResultCollection^ PerformSearch(
    SearchParameters^ parameters
) sealed
Parameters
parameters (SearchParameters)
The search parameters.
Return Value
The results.
Exceptions
Exception | Condition
ArgumentNullException | If parameters is null.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


ReadOnly Property

ReadOnly Property
ScrewTurn Wiki ► ScrewTurn.Wiki ► PagesStorageProvider ► ReadOnly
Gets a value specifying whether the provider is read-only, i.e. it can only provide data and not store it.
Declaration Syntax
C# Visual Basic Visual C++
public bool ReadOnly { get; }
Public ReadOnly Property ReadOnly As Boolean
public:
virtual property bool ReadOnly {
    bool get () sealed;
}

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


RebindPage Method (page, categories)

RebindPage Method (page, categories)
ScrewTurn Wiki ► ScrewTurn.Wiki ► PagesStorageProvider ► RebindPage(PageInfo, array<String>[]()[])
Binds a Page with one or more Categories.
Declaration Syntax
C# Visual Basic Visual C++
public bool RebindPage(
    PageInfo page,
    string[] categories
)
Public Function RebindPage ( _
    page As PageInfo, _
    categories As String() _
) As Boolean
public:
virtual bool RebindPage(
    PageInfo^ page,
    array<String^>^ categories
) sealed
Parameters
page (PageInfo)
The Page to bind.
categories (array< String >[]()[][])
The Categories to bind the Page with (full name).
Return Value
True if the binding succeeded.
Remarks
After a successful operation, the Page is bound with all and only the categories passed as argument.
Exceptions
Exception | Condition
ArgumentNullException | If page or categories are null.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


RebuildIndex Method

RebuildIndex Method
ScrewTurn Wiki ► ScrewTurn.Wiki ► PagesStorageProvider ► RebuildIndex()()()
Rebuilds the search index.
Declaration Syntax
C# Visual Basic Visual C++
public void RebuildIndex()
Public Sub RebuildIndex
public:
virtual void RebuildIndex() sealed

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


RemoveCategory Method (category)

RemoveCategory Method (category)
ScrewTurn Wiki ► ScrewTurn.Wiki ► PagesStorageProvider ► RemoveCategory(CategoryInfo)
Removes a Category.
Declaration Syntax
C# Visual Basic Visual C++
public bool RemoveCategory(
    CategoryInfo category
)
Public Function RemoveCategory ( _
    category As CategoryInfo _
) As Boolean
public:
virtual bool RemoveCategory(
    CategoryInfo^ category
) sealed
Parameters
category (CategoryInfo)
The Category to remove.
Return Value
True if the Category has been removed successfully.
Exceptions
Exception | Condition
ArgumentNullException | If category is null.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


RemoveContentTemplate Method (name)

RemoveContentTemplate Method (name)
ScrewTurn Wiki ► ScrewTurn.Wiki ► PagesStorageProvider ► RemoveContentTemplate(String)
Removes a content template.
Declaration Syntax
C# Visual Basic Visual C++
public bool RemoveContentTemplate(
    string name
)
Public Function RemoveContentTemplate ( _
    name As String _
) As Boolean
public:
virtual bool RemoveContentTemplate(
    String^ name
) sealed
Parameters
name (String)
The name of the template to remove.
Return Value
true if the template is removed, false otherwise.
Exceptions
Exception | Condition
ArgumentNullException | If name is null.
ArgumentNullException | If name is empty.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


RemoveMessage Method (page, id, removeReplies)

RemoveMessage Method (page, id, removeReplies)
ScrewTurn Wiki ► ScrewTurn.Wiki ► PagesStorageProvider ► RemoveMessage(PageInfo, Int32, Boolean)
Removes a Message.
Declaration Syntax
C# Visual Basic Visual C++
public bool RemoveMessage(
    PageInfo page,
    int id,
    bool removeReplies
)
Public Function RemoveMessage ( _
    page As PageInfo, _
    id As Integer, _
    removeReplies As Boolean _
) As Boolean
public:
virtual bool RemoveMessage(
    PageInfo^ page,
    int id,
    bool removeReplies
) sealed
Parameters
page (PageInfo)
The Page.
id (Int32)
The ID of the Message to remove.
removeReplies (Boolean)
A value specifying whether or not to remove the replies.
Return Value
True if the Message has been removed successfully.
Exceptions
Exception | Condition
ArgumentNullException | If page is null.
ArgumentOutOfRangeException | If id is less than zero.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


RemoveNamespace Method (nspace)

RemoveNamespace Method (nspace)
ScrewTurn Wiki ► ScrewTurn.Wiki ► PagesStorageProvider ► RemoveNamespace(NamespaceInfo)
Removes a namespace.
Declaration Syntax
C# Visual Basic Visual C++
public bool RemoveNamespace(
    NamespaceInfo nspace
)
Public Function RemoveNamespace ( _
    nspace As NamespaceInfo _
) As Boolean
public:
virtual bool RemoveNamespace(
    NamespaceInfo^ nspace
) sealed
Parameters
nspace (NamespaceInfo)
The namespace to remove.
Return Value
true if the namespace is removed, false otherwise.
Exceptions
Exception | Condition
ArgumentNullException | If nspace is null.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


RemoveNavigationPath Method (path)

RemoveNavigationPath Method (path)
ScrewTurn Wiki ► ScrewTurn.Wiki ► PagesStorageProvider ► RemoveNavigationPath(NavigationPath)
Removes a Navigation Path.
Declaration Syntax
C# Visual Basic Visual C++
public bool RemoveNavigationPath(
    NavigationPath path
)
Public Function RemoveNavigationPath ( _
    path As NavigationPath _
) As Boolean
public:
virtual bool RemoveNavigationPath(
    NavigationPath^ path
) sealed
Parameters
path (NavigationPath)
The Navigation Path to remove.
Return Value
True if the Path is removed successfully.
Exceptions
Exception | Condition
ArgumentNullException | If path is null.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


RemovePage Method (page)

RemovePage Method (page)
ScrewTurn Wiki ► ScrewTurn.Wiki ► PagesStorageProvider ► RemovePage(PageInfo)
Removes a Page.
Declaration Syntax
C# Visual Basic Visual C++
public bool RemovePage(
    PageInfo page
)
Public Function RemovePage ( _
    page As PageInfo _
) As Boolean
public:
virtual bool RemovePage(
    PageInfo^ page
) sealed
Parameters
page (PageInfo)
The Page to remove.
Return Value
true if the Page has been removed successfully, false otherwise.
Exceptions
Exception | Condition
ArgumentNullException | If page is null.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


RemoveSnippet Method (name)

RemoveSnippet Method (name)
ScrewTurn Wiki ► ScrewTurn.Wiki ► PagesStorageProvider ► RemoveSnippet(String)
Removes a new Snippet.
Declaration Syntax
C# Visual Basic Visual C++
public bool RemoveSnippet(
    string name
)
Public Function RemoveSnippet ( _
    name As String _
) As Boolean
public:
virtual bool RemoveSnippet(
    String^ name
) sealed
Parameters
name (String)
The Name of the Snippet to remove.
Return Value
True if the Snippet is removed successfully.
Exceptions
Exception | Condition
ArgumentNullException | If name is null.
ArgumentNullException | If name is empty.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


RenameCategory Method (category, newName)

RenameCategory Method (category, newName)
ScrewTurn Wiki ► ScrewTurn.Wiki ► PagesStorageProvider ► RenameCategory(CategoryInfo, String)
Renames a Category.
Declaration Syntax
C# Visual Basic Visual C++
public CategoryInfo RenameCategory(
    CategoryInfo category,
    string newName
)
Public Function RenameCategory ( _
    category As CategoryInfo, _
    newName As String _
) As CategoryInfo
public:
virtual CategoryInfo^ RenameCategory(
    CategoryInfo^ category,
    String^ newName
) sealed
Parameters
category (CategoryInfo)
The Category to rename.
newName (String)
The new Name.
Return Value
The correct CategoryInfo object.
Exceptions
Exception | Condition
ArgumentNullException | If category or newName are null.
ArgumentException | If newName is empty.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


RenameNamespace Method (nspace, newName)

RenameNamespace Method (nspace, newName)
ScrewTurn Wiki ► ScrewTurn.Wiki ► PagesStorageProvider ► RenameNamespace(NamespaceInfo, String)
Renames a namespace.
Declaration Syntax
C# Visual Basic Visual C++
public NamespaceInfo RenameNamespace(
    NamespaceInfo nspace,
    string newName
)
Public Function RenameNamespace ( _
    nspace As NamespaceInfo, _
    newName As String _
) As NamespaceInfo
public:
virtual NamespaceInfo^ RenameNamespace(
    NamespaceInfo^ nspace,
    String^ newName
) sealed
Parameters
nspace (NamespaceInfo)
The namespace to rename.
newName (String)
The new name of the namespace.
Return Value
The correct NamespaceInfo object.
Exceptions
Exception | Condition
ArgumentNullException | If nspace or newName are null.
ArgumentException | If newName is empty.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


RenamePage Method (page, newName)

RenamePage Method (page, newName)
ScrewTurn Wiki ► ScrewTurn.Wiki ► PagesStorageProvider ► RenamePage(PageInfo, String)
Renames a Page.
Declaration Syntax
C# Visual Basic Visual C++
public PageInfo RenamePage(
    PageInfo page,
    string newName
)
Public Function RenamePage ( _
    page As PageInfo, _
    newName As String _
) As PageInfo
public:
virtual PageInfo^ RenamePage(
    PageInfo^ page,
    String^ newName
) sealed
Parameters
page (PageInfo)
The Page to rename.
newName (String)
The new Name.
Return Value
True if the Page has been renamed successfully.
Exceptions
Exception | Condition
ArgumentNullException | If page or newName are null.
ArgumentException | If newName is empty.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


RollbackPage Method (page, revision)

RollbackPage Method (page, revision)
ScrewTurn Wiki ► ScrewTurn.Wiki ► PagesStorageProvider ► RollbackPage(PageInfo, Int32)
Performs the rollback of a Page to a specified revision.
Declaration Syntax
C# Visual Basic Visual C++
public bool RollbackPage(
    PageInfo page,
    int revision
)
Public Function RollbackPage ( _
    page As PageInfo, _
    revision As Integer _
) As Boolean
public:
virtual bool RollbackPage(
    PageInfo^ page,
    int revision
) sealed
Parameters
page (PageInfo)
The Page to rollback.
revision (Int32)
The Revision to rollback the Page to.
Return Value
true if the rollback succeeded, false otherwise.
Exceptions
Exception | Condition
ArgumentNullException | If page is null.
ArgumentOutOfRangeException | If revision is less than zero.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


SetBackupContent Method (content, revision)

SetBackupContent Method (content, revision)
ScrewTurn Wiki ► ScrewTurn.Wiki ► PagesStorageProvider ► SetBackupContent(PageContent, Int32)
Forces to overwrite or create a Backup.
Declaration Syntax
C# Visual Basic Visual C++
public bool SetBackupContent(
    PageContent content,
    int revision
)
Public Function SetBackupContent ( _
    content As PageContent, _
    revision As Integer _
) As Boolean
public:
virtual bool SetBackupContent(
    PageContent^ content,
    int revision
) sealed
Parameters
content (PageContent)
The Backup content.
revision (Int32)
The revision.
Return Value
True if the Backup has been created successfully.
Exceptions
Exception | Condition
ArgumentNullException | If content is null.
ArgumentOutOfRangeException | If revision is less than zero.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


SetNamespaceDefaultPage Method (nspace, page)

SetNamespaceDefaultPage Method (nspace, page)
ScrewTurn Wiki ► ScrewTurn.Wiki ► PagesStorageProvider ► SetNamespaceDefaultPage(NamespaceInfo, PageInfo)
Sets the default page of a namespace.
Declaration Syntax
C# Visual Basic Visual C++
public NamespaceInfo SetNamespaceDefaultPage(
    NamespaceInfo nspace,
    PageInfo page
)
Public Function SetNamespaceDefaultPage ( _
    nspace As NamespaceInfo, _
    page As PageInfo _
) As NamespaceInfo
public:
virtual NamespaceInfo^ SetNamespaceDefaultPage(
    NamespaceInfo^ nspace,
    PageInfo^ page
) sealed
Parameters
nspace (NamespaceInfo)
The namespace of which to set the default page.
page (PageInfo)
The page to use as default page, or null.
Return Value
The correct NamespaceInfo object.
Exceptions
Exception | Condition
ArgumentNullException | If nspace is null.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


Shutdown Method

Shutdown Method
ScrewTurn Wiki ► ScrewTurn.Wiki ► PagesStorageProvider ► Shutdown()()()
Method invoked on shutdown.
Declaration Syntax
C# Visual Basic Visual C++
public void Shutdown()
Public Sub Shutdown
public:
virtual void Shutdown() sealed
Remarks
This method might not be invoked in some cases.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


Preferences Class

Preferences Class
ScrewTurn Wiki ► ScrewTurn.Wiki ► Preferences
Allows access to current user's preferences.
Declaration Syntax
C# Visual Basic Visual C++
public static class Preferences
Public NotInheritable Class Preferences
public ref class Preferences abstract sealed
Members
All Members | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | AlignWithServerTimezone(DateTime) | Aligns a date/time with the default timezone.
 | AlignWithTimezone(DateTime) | Aligns a date/time with the User's preferences (if any).
 | DeletePreferencesCookie()()() | Deletes the language and timezone preferences cookie.
 | LoadLanguageFromCookie()()() | Loads the language from a cookie.
 | LoadLanguageFromUserData()()() | Loads the language from the current user's data.
 | LoadTimezoneFromCookie()()() | Loads the timezone from a cookie.
 | LoadTimezoneFromUserData()()() | Loads the timezone from the current user's data.
 | SavePreferencesInCookie(String, Int32) | Saves language and timezone preferences into a cookie.
 | SavePreferencesInUserData(String, Int32) | Saves language and timezone preferences into the current user's data.
Inheritance Hierarchy
Object
Preferences

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


AlignWithServerTimezone Method (dateTime)

AlignWithServerTimezone Method (dateTime)
ScrewTurn Wiki ► ScrewTurn.Wiki ► Preferences ► AlignWithServerTimezone(DateTime)
Aligns a date/time with the default timezone.
Declaration Syntax
C# Visual Basic Visual C++
public static DateTime AlignWithServerTimezone(
    DateTime dateTime
)
Public Shared Function AlignWithServerTimezone ( _
    dateTime As DateTime _
) As DateTime
public:
static DateTime AlignWithServerTimezone(
    DateTime dateTime
)
Parameters
dateTime (DateTime)
The date/time to align.
Return Value
The aligned date/time.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


AlignWithTimezone Method (dateTime)

AlignWithTimezone Method (dateTime)
ScrewTurn Wiki ► ScrewTurn.Wiki ► Preferences ► AlignWithTimezone(DateTime)
Aligns a date/time with the User's preferences (if any).
Declaration Syntax
C# Visual Basic Visual C++
public static DateTime AlignWithTimezone(
    DateTime dateTime
)
Public Shared Function AlignWithTimezone ( _
    dateTime As DateTime _
) As DateTime
public:
static DateTime AlignWithTimezone(
    DateTime dateTime
)
Parameters
dateTime (DateTime)
The date/time to align.
Return Value
The aligned date/time.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


DeletePreferencesCookie Method

DeletePreferencesCookie Method
ScrewTurn Wiki ► ScrewTurn.Wiki ► Preferences ► DeletePreferencesCookie()()()
Deletes the language and timezone preferences cookie.
Declaration Syntax
C# Visual Basic Visual C++
public static void DeletePreferencesCookie()
Public Shared Sub DeletePreferencesCookie
public:
static void DeletePreferencesCookie()

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


LoadLanguageFromCookie Method

LoadLanguageFromCookie Method
ScrewTurn Wiki ► ScrewTurn.Wiki ► Preferences ► LoadLanguageFromCookie()()()
Loads the language from a cookie.
Declaration Syntax
C# Visual Basic Visual C++
public static string LoadLanguageFromCookie()
Public Shared Function LoadLanguageFromCookie As String
public:
static String^ LoadLanguageFromCookie()
Return Value
The language, or null.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


LoadLanguageFromUserData Method

LoadLanguageFromUserData Method
ScrewTurn Wiki ► ScrewTurn.Wiki ► Preferences ► LoadLanguageFromUserData()()()
Loads the language from the current user's data.
Declaration Syntax
C# Visual Basic Visual C++
public static string LoadLanguageFromUserData()
Public Shared Function LoadLanguageFromUserData As String
public:
static String^ LoadLanguageFromUserData()
Return Value
The language, or null.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


LoadTimezoneFromCookie Method

LoadTimezoneFromCookie Method
ScrewTurn Wiki ► ScrewTurn.Wiki ► Preferences ► LoadTimezoneFromCookie()()()
Loads the timezone from a cookie.
Declaration Syntax
C# Visual Basic Visual C++
public static Nullable<int> LoadTimezoneFromCookie()
Public Shared Function LoadTimezoneFromCookie As Nullable(Of Integer)
public:
static Nullable<int> LoadTimezoneFromCookie()
Return Value
The timezone, or null.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


LoadTimezoneFromUserData Method

LoadTimezoneFromUserData Method
ScrewTurn Wiki ► ScrewTurn.Wiki ► Preferences ► LoadTimezoneFromUserData()()()
Loads the timezone from the current user's data.
Declaration Syntax
C# Visual Basic Visual C++
public static Nullable<int> LoadTimezoneFromUserData()
Public Shared Function LoadTimezoneFromUserData As Nullable(Of Integer)
public:
static Nullable<int> LoadTimezoneFromUserData()
Return Value
The timezone, or null.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


SavePreferencesInCookie Method (culture, timezone)

SavePreferencesInCookie Method (culture, timezone)
ScrewTurn Wiki ► ScrewTurn.Wiki ► Preferences ► SavePreferencesInCookie(String, Int32)
Saves language and timezone preferences into a cookie.
Declaration Syntax
C# Visual Basic Visual C++
public static void SavePreferencesInCookie(
    string culture,
    int timezone
)
Public Shared Sub SavePreferencesInCookie ( _
    culture As String, _
    timezone As Integer _
)
public:
static void SavePreferencesInCookie(
    String^ culture,
    int timezone
)
Parameters
culture (String)
The culture.
timezone (Int32)
The timezone.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


SavePreferencesInUserData Method (culture, timezone)

SavePreferencesInUserData Method (culture, timezone)
ScrewTurn Wiki ► ScrewTurn.Wiki ► Preferences ► SavePreferencesInUserData(String, Int32)
Saves language and timezone preferences into the current user's data.
Declaration Syntax
C# Visual Basic Visual C++
public static bool SavePreferencesInUserData(
    string culture,
    int timezone
)
Public Shared Function SavePreferencesInUserData ( _
    culture As String, _
    timezone As Integer _
) As Boolean
public:
static bool SavePreferencesInUserData(
    String^ culture,
    int timezone
)
Parameters
culture (String)
The culture.
timezone (Int32)
The timezone.
Return Value
true if the data is stored, false otherwise.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


ProviderCollector(T) Class

ProviderCollector<(Of <(<'T>)>)> Class
ScrewTurn Wiki ► ScrewTurn.Wiki ► ProviderCollector<(Of <(T>)>)
Implements a generic Provider Collector.
Declaration Syntax
C# Visual Basic Visual C++
public class ProviderCollector<T>

Public Class ProviderCollector(Of T)
generic<typename T>
public ref class ProviderCollector
Generic Template Parameters
T
The type of the Collector.
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ProviderCollector<(Of <(T>)>)()()() | Initializes a new instance of the class.
 | AddProvider(T) | Adds a Provider to the Collector.
 | AllProviders | Gets all the Providers (copied array).
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetProvider(String) | Gets a Provider, searching for its Type Name.
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | RemoveProvider(T) | Removes a Provider from the Collector.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
ProviderCollector<(Of <(T>)>)

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


ProviderCollector(T) Constructor

ProviderCollector<(Of <(<'T>)>)> Constructor
ScrewTurn Wiki ► ScrewTurn.Wiki ► ProviderCollector<(Of <(T>)>) ► ProviderCollector<(Of <(T>)>)()()()
Initializes a new instance of the class.
Declaration Syntax
C# Visual Basic Visual C++
public ProviderCollector()
Public Sub New
public:
ProviderCollector()

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


AddProvider Method (provider)

AddProvider Method (provider)
ScrewTurn Wiki ► ScrewTurn.Wiki ► ProviderCollector<(Of <(T>)>) ► AddProvider(T)
Adds a Provider to the Collector.
Declaration Syntax
C# Visual Basic Visual C++
public void AddProvider(
    T provider
)
Public Sub AddProvider ( _
    provider As T _
)
public:
void AddProvider(
    T provider
)
Parameters
provider (T)
The Provider to add.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


AllProviders Property

AllProviders Property
ScrewTurn Wiki ► ScrewTurn.Wiki ► ProviderCollector<(Of <(T>)>) ► AllProviders
Gets all the Providers (copied array).
Declaration Syntax
C# Visual Basic Visual C++
public T[] AllProviders { get; }
Public ReadOnly Property AllProviders As T()
public:
property array<T>^ AllProviders {
    array<T>^ get ();
}

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


GetProvider Method (typeName)

GetProvider Method (typeName)
ScrewTurn Wiki ► ScrewTurn.Wiki ► ProviderCollector<(Of <(T>)>) ► GetProvider(String)
Gets a Provider, searching for its Type Name.
Declaration Syntax
C# Visual Basic Visual C++
public T GetProvider(
    string typeName
)
Public Function GetProvider ( _
    typeName As String _
) As T
public:
T GetProvider(
    String^ typeName
)
Parameters
typeName (String)
The Type Name.
Return Value
The Provider, or null if the Provider was not found.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


RemoveProvider Method (provider)

RemoveProvider Method (provider)
ScrewTurn Wiki ► ScrewTurn.Wiki ► ProviderCollector<(Of <(T>)>) ► RemoveProvider(T)
Removes a Provider from the Collector.
Declaration Syntax
C# Visual Basic Visual C++
public void RemoveProvider(
    T provider
)
Public Sub RemoveProvider ( _
    provider As T _
)
public:
void RemoveProvider(
    T provider
)
Parameters
provider (T)
The Provider to remove.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


ProviderConstraintException Class

ProviderConstraintException Class
ScrewTurn Wiki ► ScrewTurn.Wiki ► ProviderConstraintException
Defines an exception thrown when a constraint is not fulfilled by a provider.
Declaration Syntax
C# Visual Basic Visual C++
public class ProviderConstraintException : Exception
Public Class ProviderConstraintException _
    Inherits Exception
public ref class ProviderConstraintException : public Exception
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ProviderConstraintException(String) | Initializes a new instance of the ProviderConstraintException class.
 | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetBaseException()()() | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetObjectData(SerializationInfo, StreamingContext) | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
 | GetType()()() | Gets the runtime type of the current instance. (Inherited from Exception.)
 | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
 | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
 | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Message | Gets a message that describes the current exception. (Inherited from Exception.)
 | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
 | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
 | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
 | ToString()()() | Creates and returns a string representation of the current exception. (Inherited from Exception.)
Inheritance Hierarchy
Object
 | Exception
 |  | ProviderConstraintException

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


ProviderConstraintException Constructor (message)

ProviderConstraintException Constructor (message)
ScrewTurn Wiki ► ScrewTurn.Wiki ► ProviderConstraintException ► ProviderConstraintException(String)
Initializes a new instance of the ProviderConstraintException class.
Declaration Syntax
C# Visual Basic Visual C++
public ProviderConstraintException(
    string message
)
Public Sub New ( _
    message As String _
)
public:
ProviderConstraintException(
    String^ message
)
Parameters
message (String)
The message.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


ProviderLoader Class

ProviderLoader Class
ScrewTurn Wiki ► ScrewTurn.Wiki ► ProviderLoader
Loads providers from assemblies.
Declaration Syntax
C# Visual Basic Visual C++
public static class ProviderLoader
Public NotInheritable Class ProviderLoader
public ref class ProviderLoader abstract sealed
Members
All Members | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | DisableProvider(String) | Disables a provider.
 | EnableProvider(String) | Enables a provider.
 | FullLoad(Boolean, Boolean, Boolean, Boolean, Boolean) | Loads all the Providers and initialises them.
 | IsDisabled(String) | Returns a value specifying whether or not a Provider is disabled.
 | LoadAllSettingsStorageProviders(ISettingsStorageProviderV30) | Loads all settings storage providers available in all DLLs stored in a provider.
 | LoadConfiguration(String) | Loads the Configuration data of a Provider.
 | LoadFrom(String, array<IUsersStorageProviderV30>[]()[]%, array<IPagesStorageProviderV30>[]()[]%, array<IFilesStorageProviderV30>[]()[]%, array<IFormatterProviderV30>[]()[]%, array<ICacheProviderV30>[]()[]%) | Loads Providers from an assembly.
 | LoadFromAuto(String) | Loads Providers from an assembly.
 | LoadSettingsStorageProvider(String) | Loads the proper Setting Storage Provider, given its name.
 | SaveConfiguration(String, String) | Saves the Configuration data of a Provider.
 | SaveStatus(String, Boolean) | Saves the Status of a Provider.
 | TryChangeConfiguration(String, String, String%) | Tries to change a provider's configuration.
 | UnloadProvider(String) | Unloads a provider from memory.
Inheritance Hierarchy
Object
ProviderLoader

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


DisableProvider Method (typeName)

DisableProvider Method (typeName)
ScrewTurn Wiki ► ScrewTurn.Wiki ► ProviderLoader ► DisableProvider(String)
Disables a provider.
Declaration Syntax
C# Visual Basic Visual C++
public static void DisableProvider(
    string typeName
)
Public Shared Sub DisableProvider ( _
    typeName As String _
)
public:
static void DisableProvider(
    String^ typeName
)
Parameters
typeName (String)
The provider to disable.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


EnableProvider Method (typeName)

EnableProvider Method (typeName)
ScrewTurn Wiki ► ScrewTurn.Wiki ► ProviderLoader ► EnableProvider(String)
Enables a provider.
Declaration Syntax
C# Visual Basic Visual C++
public static void EnableProvider(
    string typeName
)
Public Shared Sub EnableProvider ( _
    typeName As String _
)
public:
static void EnableProvider(
    String^ typeName
)
Parameters
typeName (String)
The provider to enable.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


FullLoad Method (loadUsers, loadPages, loadFiles, loadFormatters, loadCache)

FullLoad Method (loadUsers, loadPages, loadFiles, loadFormatters, loadCache)
ScrewTurn Wiki ► ScrewTurn.Wiki ► ProviderLoader ► FullLoad(Boolean, Boolean, Boolean, Boolean, Boolean)
Loads all the Providers and initialises them.
Declaration Syntax
C# Visual Basic Visual C++
public static void FullLoad(
    bool loadUsers,
    bool loadPages,
    bool loadFiles,
    bool loadFormatters,
    bool loadCache
)
Public Shared Sub FullLoad ( _
    loadUsers As Boolean, _
    loadPages As Boolean, _
    loadFiles As Boolean, _
    loadFormatters As Boolean, _
    loadCache As Boolean _
)
public:
static void FullLoad(
    bool loadUsers,
    bool loadPages,
    bool loadFiles,
    bool loadFormatters,
    bool loadCache
)
Parameters
loadUsers (Boolean)
A value indicating whether to load users storage providers.
loadPages (Boolean)
A value indicating whether to load pages storage providers.
loadFiles (Boolean)
A value indicating whether to load files storage providers.
loadFormatters (Boolean)
A value indicating whether to load formatter providers.
loadCache (Boolean)
A value indicating whether to load cache providers.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


IsDisabled Method (typeName)

IsDisabled Method (typeName)
ScrewTurn Wiki ► ScrewTurn.Wiki ► ProviderLoader ► IsDisabled(String)
Returns a value specifying whether or not a Provider is disabled.
Declaration Syntax
C# Visual Basic Visual C++
public static bool IsDisabled(
    string typeName
)
Public Shared Function IsDisabled ( _
    typeName As String _
) As Boolean
public:
static bool IsDisabled(
    String^ typeName
)
Parameters
typeName (String)
The Type Name of the Provider.
Return Value
True if the Provider is disabled.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


LoadAllSettingsStorageProviders Method (repository)

LoadAllSettingsStorageProviders Method (repository)
ScrewTurn Wiki ► ScrewTurn.Wiki ► ProviderLoader ► LoadAllSettingsStorageProviders(ISettingsStorageProviderV30)
Loads all settings storage providers available in all DLLs stored in a provider.
Declaration Syntax
C# Visual Basic Visual C++
public static ISettingsStorageProviderV30[] LoadAllSettingsStorageProviders(
    ISettingsStorageProviderV30 repository
)
Public Shared Function LoadAllSettingsStorageProviders ( _
    repository As ISettingsStorageProviderV30 _
) As ISettingsStorageProviderV30()
public:
static array<ISettingsStorageProviderV30^>^ LoadAllSettingsStorageProviders(
    ISettingsStorageProviderV30^ repository
)
Parameters
repository (ISettingsStorageProviderV30)
The input provider.
Return Value
The providers found (not initialized).

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


LoadConfiguration Method (typeName)

LoadConfiguration Method (typeName)
ScrewTurn Wiki ► ScrewTurn.Wiki ► ProviderLoader ► LoadConfiguration(String)
Loads the Configuration data of a Provider.
Declaration Syntax
C# Visual Basic Visual C++
public static string LoadConfiguration(
    string typeName
)
Public Shared Function LoadConfiguration ( _
    typeName As String _
) As String
public:
static String^ LoadConfiguration(
    String^ typeName
)
Parameters
typeName (String)
The Type Name of the Provider.
Return Value
The Configuration, if available, otherwise an empty string.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


LoadFrom Method (assembly, users, pages, files, formatters, cache)

LoadFrom Method (assembly, users, pages, files, formatters, cache)
ScrewTurn Wiki ► ScrewTurn.Wiki ► ProviderLoader ► LoadFrom(String, array<IUsersStorageProviderV30>[]()[]%, array<IPagesStorageProviderV30>[]()[]%, array<IFilesStorageProviderV30>[]()[]%, array<IFormatterProviderV30>[]()[]%, array<ICacheProviderV30>[]()[]%)
Loads Providers from an assembly.
Declaration Syntax
C# Visual Basic Visual C++
public static void LoadFrom(
    string assembly,
    out IUsersStorageProviderV30[] users,
    out IPagesStorageProviderV30[] pages,
    out IFilesStorageProviderV30[] files,
    out IFormatterProviderV30[] formatters,
    out ICacheProviderV30[] cache
)
Public Shared Sub LoadFrom ( _
    assembly As String, _
    <OutAttribute> ByRef users As IUsersStorageProviderV30(), _
    <OutAttribute> ByRef pages As IPagesStorageProviderV30(), _
    <OutAttribute> ByRef files As IFilesStorageProviderV30(), _
    <OutAttribute> ByRef formatters As IFormatterProviderV30(), _
    <OutAttribute> ByRef cache As ICacheProviderV30() _
)
public:
static void LoadFrom(
    String^ assembly,
    [OutAttribute] array<IUsersStorageProviderV30^>^% users,
    [OutAttribute] array<IPagesStorageProviderV30^>^% pages,
    [OutAttribute] array<IFilesStorageProviderV30^>^% files,
    [OutAttribute] array<IFormatterProviderV30^>^% formatters,
    [OutAttribute] array<ICacheProviderV30^>^% cache
)
Parameters
assembly (String)
The path of the Assembly to load the Providers from.
users ( array< IUsersStorageProviderV30 >[]()[][] %)
The Users Providers.
pages ( array< IPagesStorageProviderV30 >[]()[][] %)
The Pages Providers.
files ( array< IFilesStorageProviderV30 >[]()[][] %)
The Files Providers.
formatters ( array< IFormatterProviderV30 >[]()[][] %)
The Formatter Providers.
cache ( array< ICacheProviderV30 >[]()[][] %)
The Cache Providers.
Remarks
The Components returned are not initialized.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


LoadFromAuto Method (assembly)

LoadFromAuto Method (assembly)
ScrewTurn Wiki ► ScrewTurn.Wiki ► ProviderLoader ► LoadFromAuto(String)
Loads Providers from an assembly.
Declaration Syntax
C# Visual Basic Visual C++
public static int LoadFromAuto(
    string assembly
)
Public Shared Function LoadFromAuto ( _
    assembly As String _
) As Integer
public:
static int LoadFromAuto(
    String^ assembly
)
Parameters
assembly (String)
The path of the Assembly to load the Providers from.
Return Value

[Missing <returns> documentation for "M:ScrewTurn.Wiki.ProviderLoader.LoadFromAuto(System.String)"]

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


LoadSettingsStorageProvider Method (name)

LoadSettingsStorageProvider Method (name)
ScrewTurn Wiki ► ScrewTurn.Wiki ► ProviderLoader ► LoadSettingsStorageProvider(String)
Loads the proper Setting Storage Provider, given its name.
Declaration Syntax
C# Visual Basic Visual C++
public static ISettingsStorageProviderV30 LoadSettingsStorageProvider(
    string name
)
Public Shared Function LoadSettingsStorageProvider ( _
    name As String _
) As ISettingsStorageProviderV30
public:
static ISettingsStorageProviderV30^ LoadSettingsStorageProvider(
    String^ name
)
Parameters
name (String)
The fully qualified name (such as "Namespace.ProviderClass, MyAssembly"), or null/String.Empty/"default" for the default provider.
Return Value
The settings storage provider.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


SaveConfiguration Method (typeName, config)

SaveConfiguration Method (typeName, config)
ScrewTurn Wiki ► ScrewTurn.Wiki ► ProviderLoader ► SaveConfiguration(String, String)
Saves the Configuration data of a Provider.
Declaration Syntax
C# Visual Basic Visual C++
public static void SaveConfiguration(
    string typeName,
    string config
)
Public Shared Sub SaveConfiguration ( _
    typeName As String, _
    config As String _
)
public:
static void SaveConfiguration(
    String^ typeName,
    String^ config
)
Parameters
typeName (String)
The Type Name of the Provider.
config (String)
The Configuration data to save.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


SaveStatus Method (typeName, enabled)

SaveStatus Method (typeName, enabled)
ScrewTurn Wiki ► ScrewTurn.Wiki ► ProviderLoader ► SaveStatus(String, Boolean)
Saves the Status of a Provider.
Declaration Syntax
C# Visual Basic Visual C++
public static void SaveStatus(
    string typeName,
    bool enabled
)
Public Shared Sub SaveStatus ( _
    typeName As String, _
    enabled As Boolean _
)
public:
static void SaveStatus(
    String^ typeName,
    bool enabled
)
Parameters
typeName (String)
The Type Name of the Provider.
enabled (Boolean)
A value specifying whether or not the Provider is enabled.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


TryChangeConfiguration Method (typeName, configuration, error)

TryChangeConfiguration Method (typeName, configuration, error)
ScrewTurn Wiki ► ScrewTurn.Wiki ► ProviderLoader ► TryChangeConfiguration(String, String, String%)
Tries to change a provider's configuration.
Declaration Syntax
C# Visual Basic Visual C++
public static bool TryChangeConfiguration(
    string typeName,
    string configuration,
    out string error
)
Public Shared Function TryChangeConfiguration ( _
    typeName As String, _
    configuration As String, _
    <OutAttribute> ByRef error As String _
) As Boolean
public:
static bool TryChangeConfiguration(
    String^ typeName,
    String^ configuration,
    [OutAttribute] String^% error
)
Parameters
typeName (String)
The provider.
configuration (String)
The new configuration.
error ( String %)
The error message, if any.
Return Value
true if the configuration is saved, false if the provider rejected it.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


UnloadProvider Method (typeName)

UnloadProvider Method (typeName)
ScrewTurn Wiki ► ScrewTurn.Wiki ► ProviderLoader ► UnloadProvider(String)
Unloads a provider from memory.
Declaration Syntax
C# Visual Basic Visual C++
public static void UnloadProvider(
    string typeName
)
Public Shared Sub UnloadProvider ( _
    typeName As String _
)
public:
static void UnloadProvider(
    String^ typeName
)
Parameters
typeName (String)
The provider to unload.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


ProviderUpdater Class

ProviderUpdater Class
ScrewTurn Wiki ► ScrewTurn.Wiki ► ProviderUpdater
Handles the updating of providers.
Declaration Syntax
C# Visual Basic Visual C++
public class ProviderUpdater
Public Class ProviderUpdater
public ref class ProviderUpdater
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | ProviderUpdater(ISettingsStorageProviderV30, Dictionary<(Of <(String, String>)>), array<array<IProviderV30>[]()[]>[]()[]) | Initializes a new instance of the ProviderUpdater class.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | UpdateAll()()() | Updates all the providers.
Inheritance Hierarchy
Object
ProviderUpdater

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


ProviderUpdater Constructor (settingsProvider, fileNamesForProviders, providers)

ProviderUpdater Constructor (settingsProvider, fileNamesForProviders, providers)
ScrewTurn Wiki ► ScrewTurn.Wiki ► ProviderUpdater ► ProviderUpdater(ISettingsStorageProviderV30, Dictionary<(Of <(String, String>)>), array<array<IProviderV30>[]()[]>[]()[])
Initializes a new instance of the ProviderUpdater class.
Declaration Syntax
C# Visual Basic Visual C++
public ProviderUpdater(
    ISettingsStorageProviderV30 settingsProvider,
    Dictionary<string, string> fileNamesForProviders,
    params IProviderV30[][] providers
)
Public Sub New ( _
    settingsProvider As ISettingsStorageProviderV30, _
    fileNamesForProviders As Dictionary(Of String, String), _
    ParamArray providers As IProviderV30()() _
)
public:
ProviderUpdater(
    ISettingsStorageProviderV30^ settingsProvider,
    Dictionary<String^, String^>^ fileNamesForProviders,
    ... array<array<IProviderV30^>^>^ providers
)
Parameters
settingsProvider (ISettingsStorageProviderV30)
The settings storage provider.
fileNamesForProviders (Dictionary <(Of <(<' String, String >)>)>)
A provider->file dictionary.
providers (array< array< IProviderV30 >[]()[][] >[]()[][])
The providers to update.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


UpdateAll Method

UpdateAll Method
ScrewTurn Wiki ► ScrewTurn.Wiki ► ProviderUpdater ► UpdateAll()()()
Updates all the providers.
Declaration Syntax
C# Visual Basic Visual C++
public int UpdateAll()
Public Function UpdateAll As Integer
public:
int UpdateAll()
Return Value
The number of updated DLLs.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


RecentChanges Class

RecentChanges Class
ScrewTurn Wiki ► ScrewTurn.Wiki ► RecentChanges
Manages the Wiki's Recent Changes.
Declaration Syntax
C# Visual Basic Visual C++
public static class RecentChanges
Public NotInheritable Class RecentChanges
public ref class RecentChanges abstract sealed
Members
All Members | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | AddChange(String, String, String, DateTime, String, Change, String) | Adds a new change.
 | GetAllChanges()()() | Gets all the changes, sorted by date/time ascending.
Inheritance Hierarchy
Object
RecentChanges

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


AddChange Method (page, title, messageSubject, dateTime, user, change, descr)

AddChange Method (page, title, messageSubject, dateTime, user, change, descr)
ScrewTurn Wiki ► ScrewTurn.Wiki ► RecentChanges ► AddChange(String, String, String, DateTime, String, Change, String)
Adds a new change.
Declaration Syntax
C# Visual Basic Visual C++
public static void AddChange(
    string page,
    string title,
    string messageSubject,
    DateTime dateTime,
    string user,
    Change change,
    string descr
)
Public Shared Sub AddChange ( _
    page As String, _
    title As String, _
    messageSubject As String, _
    dateTime As DateTime, _
    user As String, _
    change As Change, _
    descr As String _
)
public:
static void AddChange(
    String^ page,
    String^ title,
    String^ messageSubject,
    DateTime dateTime,
    String^ user,
    Change change,
    String^ descr
)
Parameters
page (String)
The page name.
title (String)
The page title.
messageSubject (String)
The message subject.
dateTime (DateTime)
The date/time.
user (String)
The user.
change (Change)
The change.
descr (String)
The description (optional).

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


GetAllChanges Method

GetAllChanges Method
ScrewTurn Wiki ► ScrewTurn.Wiki ► RecentChanges ► GetAllChanges()()()
Gets all the changes, sorted by date/time ascending.
Declaration Syntax
C# Visual Basic Visual C++
public static RecentChange[] GetAllChanges()
Public Shared Function GetAllChanges As RecentChange()
public:
static array<RecentChange^>^ GetAllChanges()
Return Value

[Missing <returns> documentation for "M:ScrewTurn.Wiki.RecentChanges.GetAllChanges"]

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


Redirections Class

Redirections Class
ScrewTurn Wiki ► ScrewTurn.Wiki ► Redirections
Manages information about Page Redirections.
Declaration Syntax
C# Visual Basic Visual C++
public static class Redirections
Public NotInheritable Class Redirections
public ref class Redirections abstract sealed
Members
All Members | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | AddRedirection(PageInfo, PageInfo) | Adds a new Redirection.
 | Clear()()() | Clears the Redirection table.
 | GetDestination(PageInfo) | Gets the destination Page.
 | WipePageOut(PageInfo) | Removes any occurrence of a Page from the redirection table, both on sources and destinations.
Inheritance Hierarchy
Object
Redirections

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


AddRedirection Method (source, destination)

AddRedirection Method (source, destination)
ScrewTurn Wiki ► ScrewTurn.Wiki ► Redirections ► AddRedirection(PageInfo, PageInfo)
Adds a new Redirection.
Declaration Syntax
C# Visual Basic Visual C++
public static void AddRedirection(
    PageInfo source,
    PageInfo destination
)
Public Shared Sub AddRedirection ( _
    source As PageInfo, _
    destination As PageInfo _
)
public:
static void AddRedirection(
    PageInfo^ source,
    PageInfo^ destination
)
Parameters
source (PageInfo)
The source Page.
destination (PageInfo)
The destination Page.
Return Value
True if the Redirection is added, false otherwise.
Remarks
The method prevents circular and multi-level redirection.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


Clear Method

Clear Method
ScrewTurn Wiki ► ScrewTurn.Wiki ► Redirections ► Clear()()()
Clears the Redirection table.
Declaration Syntax
C# Visual Basic Visual C++
public static void Clear()
Public Shared Sub Clear
public:
static void Clear()

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


GetDestination Method (page)

GetDestination Method (page)
ScrewTurn Wiki ► ScrewTurn.Wiki ► Redirections ► GetDestination(PageInfo)
Gets the destination Page.
Declaration Syntax
C# Visual Basic Visual C++
public static PageInfo GetDestination(
    PageInfo page
)
Public Shared Function GetDestination ( _
    page As PageInfo _
) As PageInfo
public:
static PageInfo^ GetDestination(
    PageInfo^ page
)
Parameters
page (PageInfo)
The source Page.
Return Value
The destination Page, or null.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


WipePageOut Method (page)

WipePageOut Method (page)
ScrewTurn Wiki ► ScrewTurn.Wiki ► Redirections ► WipePageOut(PageInfo)
Removes any occurrence of a Page from the redirection table, both on sources and destinations.
Declaration Syntax
C# Visual Basic Visual C++
public static void WipePageOut(
    PageInfo page
)
Public Shared Sub WipePageOut ( _
    page As PageInfo _
)
public:
static void WipePageOut(
    PageInfo^ page
)
Parameters
page (PageInfo)
The Page to wipe-out.
Remarks
This method is useful when removing a Page.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


ReverseFormatter Class

ReverseFormatter Class
ScrewTurn Wiki ► ScrewTurn.Wiki ► ReverseFormatter
Implements reverse formatting methods (HTML->WikiMarkup).
Declaration Syntax
C# Visual Basic Visual C++
public static class ReverseFormatter
Public NotInheritable Class ReverseFormatter
public ref class ReverseFormatter abstract sealed
Members
All Members | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | ReverseFormat(String) | Reverse formats HTML content into WikiMarkup.
Inheritance Hierarchy
Object
ReverseFormatter

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


ReverseFormat Method (html)

ReverseFormat Method (html)
ScrewTurn Wiki ► ScrewTurn.Wiki ► ReverseFormatter ► ReverseFormat(String)
Reverse formats HTML content into WikiMarkup.
Declaration Syntax
C# Visual Basic Visual C++
public static string ReverseFormat(
    string html
)
Public Shared Function ReverseFormat ( _
    html As String _
) As String
public:
static String^ ReverseFormat(
    String^ html
)
Parameters
html (String)
The input HTML.
Return Value
The corresponding WikiMarkup.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


RssFeedsMode Enumeration

RssFeedsMode Enumeration
ScrewTurn Wiki ► ScrewTurn.Wiki ► RssFeedsMode
Lists legal RSS feeds function modes.
Declaration Syntax
C# Visual Basic Visual C++
public enum RssFeedsMode
Public Enumeration RssFeedsMode
public enum class RssFeedsMode
Members
Member | Description
FullText | RSS feeds serve full-text content.
Summary | RSS feeds serve summary content.
Disabled | RSS feeds are disabled.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


SearchTools Class

SearchTools Class
ScrewTurn Wiki ► ScrewTurn.Wiki ► SearchTools
Implements tools for searching through the wiki.
Declaration Syntax
C# Visual Basic Visual C++
public static class SearchTools
Public NotInheritable Class SearchTools
public ref class SearchTools abstract sealed
Members
All Members | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | Search(String, Boolean, Boolean, SearchOptions) | Performs a search in the wiki.
 | SearchSimilarPages(String, String) | Searches for pages with name or title similar to a specified value.
Inheritance Hierarchy
Object
SearchTools

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


Search Method (query, fullText, searchFilesAndAttachments, options)

Search Method (query, fullText, searchFilesAndAttachments, options)
ScrewTurn Wiki ► ScrewTurn.Wiki ► SearchTools ► Search(String, Boolean, Boolean, SearchOptions)
Performs a search in the wiki.
Declaration Syntax
C# Visual Basic Visual C++
public static SearchResultCollection Search(
    string query,
    bool fullText,
    bool searchFilesAndAttachments,
    SearchOptions options
)
Public Shared Function Search ( _
    query As String, _
    fullText As Boolean, _
    searchFilesAndAttachments As Boolean, _
    options As SearchOptions _
) As SearchResultCollection
public:
static SearchResultCollection^ Search(
    String^ query,
    bool fullText,
    bool searchFilesAndAttachments,
    SearchOptions options
)
Parameters
query (String)
The search query.
fullText (Boolean)
A value indicating whether to perform a full-text search.
searchFilesAndAttachments (Boolean)
A value indicating whether to search through files and attachments.
options (SearchOptions)
The search options.
Return Value
The results collection.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


SearchSimilarPages Method (name, nspace)

SearchSimilarPages Method (name, nspace)
ScrewTurn Wiki ► ScrewTurn.Wiki ► SearchTools ► SearchSimilarPages(String, String)
Searches for pages with name or title similar to a specified value.
Declaration Syntax
C# Visual Basic Visual C++
public static PageInfo[] SearchSimilarPages(
    string name,
    string nspace
)
Public Shared Function SearchSimilarPages ( _
    name As String, _
    nspace As String _
) As PageInfo()
public:
static array<PageInfo^>^ SearchSimilarPages(
    String^ name,
    String^ nspace
)
Parameters
name (String)
The name to look for (null for the root).
nspace (String)
The namespace to search into.
Return Value
The similar pages, if any.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


SessionCache Class

SessionCache Class
ScrewTurn Wiki ► ScrewTurn.Wiki ► SessionCache
Implements a session data cache whose lifetime is only limited to one request.
Declaration Syntax
C# Visual Basic Visual C++
public static class SessionCache
Public NotInheritable Class SessionCache
public ref class SessionCache abstract sealed
Members
All Members | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | ClearData(String) | Clears all cached data of a session.
 | GetCurrentGroups(String) | Gets the current groups, if any, of a session.
 | GetCurrentUser(String) | Gets the current user, if any, of a session.
 | SetCurrentGroups(String, array<UserGroup>[]()[]) | Sets the current groups of a session.
 | SetCurrentUser(String, UserInfo) | Sets the current user of a session.
Inheritance Hierarchy
Object
SessionCache

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


ClearData Method (sessionId)

ClearData Method (sessionId)
ScrewTurn Wiki ► ScrewTurn.Wiki ► SessionCache ► ClearData(String)
Clears all cached data of a session.
Declaration Syntax
C# Visual Basic Visual C++
public static void ClearData(
    string sessionId
)
Public Shared Sub ClearData ( _
    sessionId As String _
)
public:
static void ClearData(
    String^ sessionId
)
Parameters
sessionId (String)
The session ID.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


GetCurrentGroups Method (sessionId)

GetCurrentGroups Method (sessionId)
ScrewTurn Wiki ► ScrewTurn.Wiki ► SessionCache ► GetCurrentGroups(String)
Gets the current groups, if any, of a session.
Declaration Syntax
C# Visual Basic Visual C++
public static UserGroup[] GetCurrentGroups(
    string sessionId
)
Public Shared Function GetCurrentGroups ( _
    sessionId As String _
) As UserGroup()
public:
static array<UserGroup^>^ GetCurrentGroups(
    String^ sessionId
)
Parameters
sessionId (String)
The session ID.
Return Value
The groups, or null.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


GetCurrentUser Method (sessionId)

GetCurrentUser Method (sessionId)
ScrewTurn Wiki ► ScrewTurn.Wiki ► SessionCache ► GetCurrentUser(String)
Gets the current user, if any, of a session.
Declaration Syntax
C# Visual Basic Visual C++
public static UserInfo GetCurrentUser(
    string sessionId
)
Public Shared Function GetCurrentUser ( _
    sessionId As String _
) As UserInfo
public:
static UserInfo^ GetCurrentUser(
    String^ sessionId
)
Parameters
sessionId (String)
The session ID.
Return Value
The current user, or null.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


SetCurrentGroups Method (sessionId, groups)

SetCurrentGroups Method (sessionId, groups)
ScrewTurn Wiki ► ScrewTurn.Wiki ► SessionCache ► SetCurrentGroups(String, array<UserGroup>[]()[])
Sets the current groups of a session.
Declaration Syntax
C# Visual Basic Visual C++
public static void SetCurrentGroups(
    string sessionId,
    UserGroup[] groups
)
Public Shared Sub SetCurrentGroups ( _
    sessionId As String, _
    groups As UserGroup() _
)
public:
static void SetCurrentGroups(
    String^ sessionId,
    array<UserGroup^>^ groups
)
Parameters
sessionId (String)
The session ID.
groups (array< UserGroup >[]()[][])
The groups.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


SetCurrentUser Method (sessionId, user)

SetCurrentUser Method (sessionId, user)
ScrewTurn Wiki ► ScrewTurn.Wiki ► SessionCache ► SetCurrentUser(String, UserInfo)
Sets the current user of a session.
Declaration Syntax
C# Visual Basic Visual C++
public static void SetCurrentUser(
    string sessionId,
    UserInfo user
)
Public Shared Sub SetCurrentUser ( _
    sessionId As String, _
    user As UserInfo _
)
public:
static void SetCurrentUser(
    String^ sessionId,
    UserInfo^ user
)
Parameters
sessionId (String)
The session ID.
user (UserInfo)
The user.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


SessionFacade Class

SessionFacade Class
ScrewTurn Wiki ► ScrewTurn.Wiki ► SessionFacade
Exposes in a strongly-typed fashion the Session variables.
Declaration Syntax
C# Visual Basic Visual C++
public static class SessionFacade
Public NotInheritable Class SessionFacade
public ref class SessionFacade abstract sealed
Members
All Members | Methods | Properties | Fields
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | AnonymousUsername | The username for anonymous users.
 | Breadcrumbs | Gets the Breadcrumbs Manager.
 | CurrentUsername | Gets or sets the current username, or null.
 | GetCurrentGroupNames()()() | Gets the current group names.
 | GetCurrentGroups()()() | Gets the current user groups.
 | GetCurrentUser()()() | Gets the current user, if any.
 | GetCurrentUsername()()() | Gets the current username for security checks purposes only.
 | LoginKey | Gets or sets the Login Key.
Inheritance Hierarchy
Object
SessionFacade

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


AnonymousUsername Field

AnonymousUsername Field
ScrewTurn Wiki ► ScrewTurn.Wiki ► SessionFacade ► AnonymousUsername
The username for anonymous users.
Declaration Syntax
C# Visual Basic Visual C++
public const string AnonymousUsername
Public Const AnonymousUsername As String
public:
literal String^ AnonymousUsername

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


Breadcrumbs Property

Breadcrumbs Property
ScrewTurn Wiki ► ScrewTurn.Wiki ► SessionFacade ► Breadcrumbs
Gets the Breadcrumbs Manager.
Declaration Syntax
C# Visual Basic Visual C++
public static BreadcrumbsManager Breadcrumbs { get; }
Public Shared ReadOnly Property Breadcrumbs As BreadcrumbsManager
public:
static property BreadcrumbsManager^ Breadcrumbs {
    BreadcrumbsManager^ get ();
}

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


CurrentUsername Property

CurrentUsername Property
ScrewTurn Wiki ► ScrewTurn.Wiki ► SessionFacade ► CurrentUsername
Gets or sets the current username, or null.
Declaration Syntax
C# Visual Basic Visual C++
public static string CurrentUsername { get; set; }
Public Shared Property CurrentUsername As String
public:
static property String^ CurrentUsername {
    String^ get ();
    void set (String^ value);
}

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


GetCurrentGroupNames Method

GetCurrentGroupNames Method
ScrewTurn Wiki ► ScrewTurn.Wiki ► SessionFacade ► GetCurrentGroupNames()()()
Gets the current group names.
Declaration Syntax
C# Visual Basic Visual C++
public static string[] GetCurrentGroupNames()
Public Shared Function GetCurrentGroupNames As String()
public:
static array<String^>^ GetCurrentGroupNames()
Return Value
The group names.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


GetCurrentGroups Method

GetCurrentGroups Method
ScrewTurn Wiki ► ScrewTurn.Wiki ► SessionFacade ► GetCurrentGroups()()()
Gets the current user groups.
Declaration Syntax
C# Visual Basic Visual C++
public static UserGroup[] GetCurrentGroups()
Public Shared Function GetCurrentGroups As UserGroup()
public:
static array<UserGroup^>^ GetCurrentGroups()
Return Value

[Missing <returns> documentation for "M:ScrewTurn.Wiki.SessionFacade.GetCurrentGroups"]

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


GetCurrentUser Method

GetCurrentUser Method
ScrewTurn Wiki ► ScrewTurn.Wiki ► SessionFacade ► GetCurrentUser()()()
Gets the current user, if any.
Declaration Syntax
C# Visual Basic Visual C++
public static UserInfo GetCurrentUser()
Public Shared Function GetCurrentUser As UserInfo
public:
static UserInfo^ GetCurrentUser()
Return Value
The current user, or null.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


GetCurrentUsername Method

GetCurrentUsername Method
ScrewTurn Wiki ► ScrewTurn.Wiki ► SessionFacade ► GetCurrentUsername()()()
Gets the current username for security checks purposes only.
Declaration Syntax
C# Visual Basic Visual C++
public static string GetCurrentUsername()
Public Shared Function GetCurrentUsername As String
public:
static String^ GetCurrentUsername()
Return Value
The current username, or AnonymousUsername if anonymous.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


LoginKey Property

LoginKey Property
ScrewTurn Wiki ► ScrewTurn.Wiki ► SessionFacade ► LoginKey
Gets or sets the Login Key.
Declaration Syntax
C# Visual Basic Visual C++
public static string LoginKey { get; set; }
Public Shared Property LoginKey As String
public:
static property String^ LoginKey {
    String^ get ();
    void set (String^ value);
}

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


Settings Class

Settings Class
ScrewTurn Wiki ► ScrewTurn.Wiki ► Settings
Allows access to all the ScrewTurn Wiki settings and configuration options.
Declaration Syntax
C# Visual Basic Visual C++
public static class Settings
Public NotInheritable Class Settings
public ref class Settings abstract sealed
Members
All Members | Methods | Properties
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | AccountActivationMode | Gets or sets the Account Activation Mode.
 | AdministratorsGroup | Gets or sets the name of the default Administrators group.
 | AllowedFileTypes | Gets or sets the list of allowed file types.
 | AnonymousGroup | Gets or sets the name of the default Anonymous users group.
 | AutoGeneratePageNames | Gets or sets a value indicating whether the editor should auto-generate page names from the title.
 | BeginBulkUpdate()()() | Begins a bulk update session.
 | CacheCutSize | Gets or sets the Cache Cut Size.
 | CacheSize | Gets or sets the Cache Size.
 | ChangeModerationMode | Gets or sets the page change moderation mode.
 | ConfigVisibleToAdmins | Obsolete. Gets or sets a valus specifying whether or not Administrators cannot access the Configuration section in the Administration page.
 | ContactEmail | Gets or sets the Contact Email.
 | CookiePath | Gets the correct path to use with Cookies.
 | CultureCookieName | Gets the name of the Culture Cookie.
 | DateTimeFormat | Gets or sets the DateTime format.
 | DefaultCacheProvider | Gets or sets the Default Cache Provider.
 | DefaultFilesProvider | Gets or sets the Type name of the Default Files Provider.
 | DefaultLanguage | Gets or sets the Default Language.
 | DefaultPage | Gets or sets the Defaul Page of the Wiki.
 | DefaultPagesProvider | Gets or sets the Type name of the Default Pages Provider.
 | DefaultTimezone | Gets or sets the Default Timezone (time delta in minutes).
 | DefaultUsersProvider | Gets or sets the Type name of the Default Users Provider.
 | DisableAutomaticVersionCheck | Gets or sets a value indicating whether to disable the Automatic Version Check.
 | DisableBreadcrumbsTrail | Gets or sets a value indicating whether to disable the Breadcrumbs Trail.
 | DisableCache | Gets or sets a value specifying whether to disable the cache.
 | DisableCaptchaControl | Gets or sets a value specifying whether to disable the Captcha control in the Registration Page.
 | DisableConcurrentEditing | Gets or sets a value specifying whether or not to disable concurrent editing of Pages.
 | DiscussionPermissions | Gets or sets the Discussion Permissions.
 | DisplayGravatars | Gets or sets a value indicating whether to display gravatars.
 | DisplayNameRegex | Gets the display name validation regex.
 | EmailRegex | Gets the Email validation Regex.
 | EnableDoubleClickEditing | Gets or sets a value specifying whether to enable double-click Page editing.
 | EnableHttpCompression | Gets or sets a value specifying whether HTTP compression is enabled or not.
 | EnablePageInfoDiv | Gets or sets a value indicating whether to enable the Page Information DIV.
 | EnablePageToolbar | Gets or sets a value indicating whether to enable the Page Toolbar.
 | EnableSectionAnchors | Gets or sets a value indicating whether to display section anchors.
 | EnableSectionEditing | Gets or sets a value indicating whether to enable section editing.
 | EnableViewPageCodeFeature | Gets or sets a value indicating whether to enable the "View Page Code" feature.
 | EnableViewStateCompression | Gets or sets a value specifying whether ViewState compression is enabled or not.
 | EndBulkUpdate()()() | Ends a bulk update session.
 | ErrorsEmails | Gets or sets the email addresses to send a message to when an error occurs.
 | FileDownloadCountFilter | Gets or sets the file download count extension filter.
 | FileDownloadCountFilterMode | Gets or sets the file download count filter mode.
 | FileManagementInPublicAccessAllowed | Gets or sets a value specifying whether, in Public Access mode, anonymous file management is allowed.
 | GetTheme(String) | Gets the theme name for a namespace.
 | GetThemePath(String) | Gets the Theme Path for a namespace.
 | IpHostFilter | Gets or sets the IP/Host filter for page editing.
 | IsMetaDataItemGlobal(MetaDataItem) | Determines whether a meta-data item is global or namespace-specific.
 | JsDirectory | Gets the JavaScript Directory.
 | JsDirectoryName | Gets the Name of the JavaScript Directory.
 | KeptBackupNumber | Gets or sets the # of Backups that are kept. Older backups are deleted after Page editing.
 | LoggingLevel | Gets or sets the Logging Level.
 | LoginCookieName | Gets the name of the Login Cookie.
 | MainUrl | Gets or sets the main URL of the Wiki.
 | MainUrlRegex | Gets the MainUrl validation Regex.
 | MasterPassword | Gets the Master Password, used to encrypt the Users data.
 | MasterPasswordBytes | Gets the bytes of the MasterPassword.
 | MaxFileSize | Gets or sets the Max file size for upload (in KB).
 | MaxLogSize | Gets or sets the Max size of the Log file (KB).
 | MaxRecentChanges | Gets or sets the max number of recent changes to log.
 | MaxRecentChangesToDisplay | Gets or sets the maximum number of recent changes to display with {RecentChanges} special tag.
 | PageExtension | Gets the extension used for Pages, including the dot.
 | PasswordRegex | Gets or sets the Password validation Regex.
 | PrivateAccess | Gets or sets a value specifying whether the access to the Wiki is private or not (in this case users won't be able to view pagesCache unless they are logged in).
 | ProcessSingleLineBreaks | Gets or sets a value indicating whether or not to process single line breaks in WikiMarkup.
 | Provider | Gets the settings storage provider.
 | PublicAccess | Gets or sets a value specifying whether the access to the Wiki is public or not (in this case users won't need to login in order to edit pagesCache).
 | PublicDirectory | Gets the Public Directory of the Wiki.
 | PublicDirectoryName | Gets the Public Directory Name (without the full Path) of the Wiki.
 | RootDirectory | Gets the Root Directory of the Wiki.
 | RssFeedsMode | Gets or sets the functioning mode of RSS feeds.
 | ScriptTagsAllowed | Gets or sets a value specifying whether script tags are allowed.
 | SenderEmail | Gets or sets the Sender Email.
 | SetTheme(String, String) | Sets the theme for a namespace.
 | SmtpPassword | Gets or sets the SMTP Server Password.
 | SmtpPort | Gets or sets the SMTP Server Port.
 | SmtpServer | Gets or sets the SMTP Server.
 | SmtpServerRegex | Gets the SMTP Server validation Regex.
 | SmtpSsl | Gets or sets a value specifying whether to enable SSL in SMTP.
 | SmtpUsername | Gets or sets the SMTP Server Username.
 | ThemesDirectory | Gets the Themes directory.
 | ThemesDirectoryName | Gets the Name of the Themes directory.
 | UsernameRegex | Gets or sets the Username validation Regex.
 | UsersCanCreateNewCategories | Gets or sets a value specifying whether or not users can create new Categories.
 | UsersCanCreateNewPages | Gets or sets a value specifying whether or not Users can create new Page.
 | UsersCanDeleteFiles | Gets or sets a value specifying whether or not users can delete Files.
 | UsersCanManagePageCategories | Gets or sets a value specifying whether or not users can manage Page Categories.
 | UsersCanRegister | Gets or sets a value specifying whether Users can create new accounts or not (in this case Register.aspx won't be available).
 | UsersCanUploadFiles | Gets or sets a value specifying whether or not users can upload Files.
 | UsersCanViewFiles | Gets or sets a value specifying whether or not users can view uploaded Files.
 | UsersGroup | Gets or sets the name of the default Users group.
 | UseVisualEditorAsDefault | Gets or sets a value indicating whether to use the Visual editor as default.
 | WikiTitle | Gets or sets the Title of the Wiki.
 | WikiTitleRegex | Gets the WikiTitle validation Regex.
 | WikiVersion | Gets the version of the Wiki.
Inheritance Hierarchy
Object
Settings

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


AccountActivationMode Property

AccountActivationMode Property
ScrewTurn Wiki ► ScrewTurn.Wiki ► Settings ► AccountActivationMode
Gets or sets the Account Activation Mode.
Declaration Syntax
C# Visual Basic Visual C++
public static AccountActivationMode AccountActivationMode { get; set; }
Public Shared Property AccountActivationMode As AccountActivationMode
public:
static property AccountActivationMode AccountActivationMode {
    AccountActivationMode get ();
    void set (AccountActivationMode value);
}

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


AdministratorsGroup Property

AdministratorsGroup Property
ScrewTurn Wiki ► ScrewTurn.Wiki ► Settings ► AdministratorsGroup
Gets or sets the name of the default Administrators group.
Declaration Syntax
C# Visual Basic Visual C++
public static string AdministratorsGroup { get; set; }
Public Shared Property AdministratorsGroup As String
public:
static property String^ AdministratorsGroup {
    String^ get ();
    void set (String^ value);
}

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


AllowedFileTypes Property

AllowedFileTypes Property
ScrewTurn Wiki ► ScrewTurn.Wiki ► Settings ► AllowedFileTypes
Gets or sets the list of allowed file types.
Declaration Syntax
C# Visual Basic Visual C++
public static string[] AllowedFileTypes { get; set; }
Public Shared Property AllowedFileTypes As String()
public:
static property array<String^>^ AllowedFileTypes {
    array<String^>^ get ();
    void set (array<String^>^ value);
}

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


AnonymousGroup Property

AnonymousGroup Property
ScrewTurn Wiki ► ScrewTurn.Wiki ► Settings ► AnonymousGroup
Gets or sets the name of the default Anonymous users group.
Declaration Syntax
C# Visual Basic Visual C++
public static string AnonymousGroup { get; set; }
Public Shared Property AnonymousGroup As String
public:
static property String^ AnonymousGroup {
    String^ get ();
    void set (String^ value);
}

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


AutoGeneratePageNames Property

AutoGeneratePageNames Property
ScrewTurn Wiki ► ScrewTurn.Wiki ► Settings ► AutoGeneratePageNames
Gets or sets a value indicating whether the editor should auto-generate page names from the title.
Declaration Syntax
C# Visual Basic Visual C++
public static bool AutoGeneratePageNames { get; set; }
Public Shared Property AutoGeneratePageNames As Boolean
public:
static property bool AutoGeneratePageNames {
    bool get ();
    void set (bool value);
}

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


BeginBulkUpdate Method

BeginBulkUpdate Method
ScrewTurn Wiki ► ScrewTurn.Wiki ► Settings ► BeginBulkUpdate()()()
Begins a bulk update session.
Declaration Syntax
C# Visual Basic Visual C++
public static void BeginBulkUpdate()
Public Shared Sub BeginBulkUpdate
public:
static void BeginBulkUpdate()

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


CacheCutSize Property

CacheCutSize Property
ScrewTurn Wiki ► ScrewTurn.Wiki ► Settings ► CacheCutSize
Gets or sets the Cache Cut Size.
Declaration Syntax
C# Visual Basic Visual C++
public static int CacheCutSize { get; set; }
Public Shared Property CacheCutSize As Integer
public:
static property int CacheCutSize {
    int get ();
    void set (int value);
}

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


CacheSize Property

CacheSize Property
ScrewTurn Wiki ► ScrewTurn.Wiki ► Settings ► CacheSize
Gets or sets the Cache Size.
Declaration Syntax
C# Visual Basic Visual C++
public static int CacheSize { get; set; }
Public Shared Property CacheSize As Integer
public:
static property int CacheSize {
    int get ();
    void set (int value);
}

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


ChangeModerationMode Property

ChangeModerationMode Property
ScrewTurn Wiki ► ScrewTurn.Wiki ► Settings ► ChangeModerationMode
Gets or sets the page change moderation mode.
Declaration Syntax
C# Visual Basic Visual C++
public static ChangeModerationMode ChangeModerationMode { get; set; }
Public Shared Property ChangeModerationMode As ChangeModerationMode
public:
static property ChangeModerationMode ChangeModerationMode {
    ChangeModerationMode get ();
    void set (ChangeModerationMode value);
}

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


ConfigVisibleToAdmins Property

ConfigVisibleToAdmins Property
ScrewTurn Wiki ► ScrewTurn.Wiki ► Settings ► ConfigVisibleToAdmins
Gets or sets a valus specifying whether or not Administrators cannot access the Configuration section in the Administration page.
Declaration Syntax
C# Visual Basic Visual C++
[ObsoleteAttribute]
public static bool ConfigVisibleToAdmins { get; set; }
<ObsoleteAttribute> _
Public Shared Property ConfigVisibleToAdmins As Boolean
[ObsoleteAttribute]
public:
static property bool ConfigVisibleToAdmins {
    bool get ();
    void set (bool value);
}
Remarks
Deprecated in version 3.0.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


ContactEmail Property

ContactEmail Property
ScrewTurn Wiki ► ScrewTurn.Wiki ► Settings ► ContactEmail
Gets or sets the Contact Email.
Declaration Syntax
C# Visual Basic Visual C++
public static string ContactEmail { get; set; }
Public Shared Property ContactEmail As String
public:
static property String^ ContactEmail {
    String^ get ();
    void set (String^ value);
}

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


CookiePath Property

CookiePath Property
ScrewTurn Wiki ► ScrewTurn.Wiki ► Settings ► CookiePath
Gets the correct path to use with Cookies.
Declaration Syntax
C# Visual Basic Visual C++
public static string CookiePath { get; }
Public Shared ReadOnly Property CookiePath As String
public:
static property String^ CookiePath {
    String^ get ();
}

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


CultureCookieName Property

CultureCookieName Property
ScrewTurn Wiki ► ScrewTurn.Wiki ► Settings ► CultureCookieName
Gets the name of the Culture Cookie.
Declaration Syntax
C# Visual Basic Visual C++
public static string CultureCookieName { get; }
Public Shared ReadOnly Property CultureCookieName As String
public:
static property String^ CultureCookieName {
    String^ get ();
}

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


DateTimeFormat Property

DateTimeFormat Property
ScrewTurn Wiki ► ScrewTurn.Wiki ► Settings ► DateTimeFormat
Gets or sets the DateTime format.
Declaration Syntax
C# Visual Basic Visual C++
public static string DateTimeFormat { get; set; }
Public Shared Property DateTimeFormat As String
public:
static property String^ DateTimeFormat {
    String^ get ();
    void set (String^ value);
}

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


DefaultCacheProvider Property

DefaultCacheProvider Property
ScrewTurn Wiki ► ScrewTurn.Wiki ► Settings ► DefaultCacheProvider
Gets or sets the Default Cache Provider.
Declaration Syntax
C# Visual Basic Visual C++
public static string DefaultCacheProvider { get; set; }
Public Shared Property DefaultCacheProvider As String
public:
static property String^ DefaultCacheProvider {
    String^ get ();
    void set (String^ value);
}

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


DefaultFilesProvider Property

DefaultFilesProvider Property
ScrewTurn Wiki ► ScrewTurn.Wiki ► Settings ► DefaultFilesProvider
Gets or sets the Type name of the Default Files Provider.
Declaration Syntax
C# Visual Basic Visual C++
public static string DefaultFilesProvider { get; set; }
Public Shared Property DefaultFilesProvider As String
public:
static property String^ DefaultFilesProvider {
    String^ get ();
    void set (String^ value);
}

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


DefaultLanguage Property

DefaultLanguage Property
ScrewTurn Wiki ► ScrewTurn.Wiki ► Settings ► DefaultLanguage
Gets or sets the Default Language.
Declaration Syntax
C# Visual Basic Visual C++
public static string DefaultLanguage { get; set; }
Public Shared Property DefaultLanguage As String
public:
static property String^ DefaultLanguage {
    String^ get ();
    void set (String^ value);
}

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


DefaultPage Property

DefaultPage Property
ScrewTurn Wiki ► ScrewTurn.Wiki ► Settings ► DefaultPage
Gets or sets the Defaul Page of the Wiki.
Declaration Syntax
C# Visual Basic Visual C++
public static string DefaultPage { get; set; }
Public Shared Property DefaultPage As String
public:
static property String^ DefaultPage {
    String^ get ();
    void set (String^ value);
}

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


DefaultPagesProvider Property

DefaultPagesProvider Property
ScrewTurn Wiki ► ScrewTurn.Wiki ► Settings ► DefaultPagesProvider
Gets or sets the Type name of the Default Pages Provider.
Declaration Syntax
C# Visual Basic Visual C++
public static string DefaultPagesProvider { get; set; }
Public Shared Property DefaultPagesProvider As String
public:
static property String^ DefaultPagesProvider {
    String^ get ();
    void set (String^ value);
}

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


DefaultTimezone Property

DefaultTimezone Property
ScrewTurn Wiki ► ScrewTurn.Wiki ► Settings ► DefaultTimezone
Gets or sets the Default Timezone (time delta in minutes).
Declaration Syntax
C# Visual Basic Visual C++
public static int DefaultTimezone { get; set; }
Public Shared Property DefaultTimezone As Integer
public:
static property int DefaultTimezone {
    int get ();
    void set (int value);
}

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


DefaultUsersProvider Property

DefaultUsersProvider Property
ScrewTurn Wiki ► ScrewTurn.Wiki ► Settings ► DefaultUsersProvider
Gets or sets the Type name of the Default Users Provider.
Declaration Syntax
C# Visual Basic Visual C++
public static string DefaultUsersProvider { get; set; }
Public Shared Property DefaultUsersProvider As String
public:
static property String^ DefaultUsersProvider {
    String^ get ();
    void set (String^ value);
}

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


DisableAutomaticVersionCheck Property

DisableAutomaticVersionCheck Property
ScrewTurn Wiki ► ScrewTurn.Wiki ► Settings ► DisableAutomaticVersionCheck
Gets or sets a value indicating whether to disable the Automatic Version Check.
Declaration Syntax
C# Visual Basic Visual C++
public static bool DisableAutomaticVersionCheck { get; set; }
Public Shared Property DisableAutomaticVersionCheck As Boolean
public:
static property bool DisableAutomaticVersionCheck {
    bool get ();
    void set (bool value);
}

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


DisableBreadcrumbsTrail Property

DisableBreadcrumbsTrail Property
ScrewTurn Wiki ► ScrewTurn.Wiki ► Settings ► DisableBreadcrumbsTrail
Gets or sets a value indicating whether to disable the Breadcrumbs Trail.
Declaration Syntax
C# Visual Basic Visual C++
public static bool DisableBreadcrumbsTrail { get; set; }
Public Shared Property DisableBreadcrumbsTrail As Boolean
public:
static property bool DisableBreadcrumbsTrail {
    bool get ();
    void set (bool value);
}

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


DisableCache Property

DisableCache Property
ScrewTurn Wiki ► ScrewTurn.Wiki ► Settings ► DisableCache
Gets or sets a value specifying whether to disable the cache.
Declaration Syntax
C# Visual Basic Visual C++
public static bool DisableCache { get; set; }
Public Shared Property DisableCache As Boolean
public:
static property bool DisableCache {
    bool get ();
    void set (bool value);
}

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


DisableCaptchaControl Property

DisableCaptchaControl Property
ScrewTurn Wiki ► ScrewTurn.Wiki ► Settings ► DisableCaptchaControl
Gets or sets a value specifying whether to disable the Captcha control in the Registration Page.
Declaration Syntax
C# Visual Basic Visual C++
public static bool DisableCaptchaControl { get; set; }
Public Shared Property DisableCaptchaControl As Boolean
public:
static property bool DisableCaptchaControl {
    bool get ();
    void set (bool value);
}

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


DisableConcurrentEditing Property

DisableConcurrentEditing Property
ScrewTurn Wiki ► ScrewTurn.Wiki ► Settings ► DisableConcurrentEditing
Gets or sets a value specifying whether or not to disable concurrent editing of Pages.
Declaration Syntax
C# Visual Basic Visual C++
public static bool DisableConcurrentEditing { get; set; }
Public Shared Property DisableConcurrentEditing As Boolean
public:
static property bool DisableConcurrentEditing {
    bool get ();
    void set (bool value);
}

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


DiscussionPermissions Property

DiscussionPermissions Property
ScrewTurn Wiki ► ScrewTurn.Wiki ► Settings ► DiscussionPermissions
Gets or sets the Discussion Permissions.
Declaration Syntax
C# Visual Basic Visual C++
public static string DiscussionPermissions { get; set; }
Public Shared Property DiscussionPermissions As String
public:
static property String^ DiscussionPermissions {
    String^ get ();
    void set (String^ value);
}

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


DisplayGravatars Property

DisplayGravatars Property
ScrewTurn Wiki ► ScrewTurn.Wiki ► Settings ► DisplayGravatars
Gets or sets a value indicating whether to display gravatars.
Declaration Syntax
C# Visual Basic Visual C++
public static bool DisplayGravatars { get; set; }
Public Shared Property DisplayGravatars As Boolean
public:
static property bool DisplayGravatars {
    bool get ();
    void set (bool value);
}

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


DisplayNameRegex Property

DisplayNameRegex Property
ScrewTurn Wiki ► ScrewTurn.Wiki ► Settings ► DisplayNameRegex
Gets the display name validation regex.
Declaration Syntax
C# Visual Basic Visual C++
public static string DisplayNameRegex { get; }
Public Shared ReadOnly Property DisplayNameRegex As String
public:
static property String^ DisplayNameRegex {
    String^ get ();
}

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


EmailRegex Property

EmailRegex Property
ScrewTurn Wiki ► ScrewTurn.Wiki ► Settings ► EmailRegex
Gets the Email validation Regex.
Declaration Syntax
C# Visual Basic Visual C++
public static string EmailRegex { get; }
Public Shared ReadOnly Property EmailRegex As String
public:
static property String^ EmailRegex {
    String^ get ();
}

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


EnableDoubleClickEditing Property

EnableDoubleClickEditing Property
ScrewTurn Wiki ► ScrewTurn.Wiki ► Settings ► EnableDoubleClickEditing
Gets or sets a value specifying whether to enable double-click Page editing.
Declaration Syntax
C# Visual Basic Visual C++
public static bool EnableDoubleClickEditing { get; set; }
Public Shared Property EnableDoubleClickEditing As Boolean
public:
static property bool EnableDoubleClickEditing {
    bool get ();
    void set (bool value);
}

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


EnableHttpCompression Property

EnableHttpCompression Property
ScrewTurn Wiki ► ScrewTurn.Wiki ► Settings ► EnableHttpCompression
Gets or sets a value specifying whether HTTP compression is enabled or not.
Declaration Syntax
C# Visual Basic Visual C++
public static bool EnableHttpCompression { get; set; }
Public Shared Property EnableHttpCompression As Boolean
public:
static property bool EnableHttpCompression {
    bool get ();
    void set (bool value);
}

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


EnablePageInfoDiv Property

EnablePageInfoDiv Property
ScrewTurn Wiki ► ScrewTurn.Wiki ► Settings ► EnablePageInfoDiv
Gets or sets a value indicating whether to enable the Page Information DIV.
Declaration Syntax
C# Visual Basic Visual C++
public static bool EnablePageInfoDiv { get; set; }
Public Shared Property EnablePageInfoDiv As Boolean
public:
static property bool EnablePageInfoDiv {
    bool get ();
    void set (bool value);
}

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


EnablePageToolbar Property

EnablePageToolbar Property
ScrewTurn Wiki ► ScrewTurn.Wiki ► Settings ► EnablePageToolbar
Gets or sets a value indicating whether to enable the Page Toolbar.
Declaration Syntax
C# Visual Basic Visual C++
public static bool EnablePageToolbar { get; set; }
Public Shared Property EnablePageToolbar As Boolean
public:
static property bool EnablePageToolbar {
    bool get ();
    void set (bool value);
}

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


EnableSectionAnchors Property

EnableSectionAnchors Property
ScrewTurn Wiki ► ScrewTurn.Wiki ► Settings ► EnableSectionAnchors
Gets or sets a value indicating whether to display section anchors.
Declaration Syntax
C# Visual Basic Visual C++
public static bool EnableSectionAnchors { get; set; }
Public Shared Property EnableSectionAnchors As Boolean
public:
static property bool EnableSectionAnchors {
    bool get ();
    void set (bool value);
}

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


EnableSectionEditing Property

EnableSectionEditing Property
ScrewTurn Wiki ► ScrewTurn.Wiki ► Settings ► EnableSectionEditing
Gets or sets a value indicating whether to enable section editing.
Declaration Syntax
C# Visual Basic Visual C++
public static bool EnableSectionEditing { get; set; }
Public Shared Property EnableSectionEditing As Boolean
public:
static property bool EnableSectionEditing {
    bool get ();
    void set (bool value);
}

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


EnableViewPageCodeFeature Property

EnableViewPageCodeFeature Property
ScrewTurn Wiki ► ScrewTurn.Wiki ► Settings ► EnableViewPageCodeFeature
Gets or sets a value indicating whether to enable the "View Page Code" feature.
Declaration Syntax
C# Visual Basic Visual C++
public static bool EnableViewPageCodeFeature { get; set; }
Public Shared Property EnableViewPageCodeFeature As Boolean
public:
static property bool EnableViewPageCodeFeature {
    bool get ();
    void set (bool value);
}

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


EnableViewStateCompression Property

EnableViewStateCompression Property
ScrewTurn Wiki ► ScrewTurn.Wiki ► Settings ► EnableViewStateCompression
Gets or sets a value specifying whether ViewState compression is enabled or not.
Declaration Syntax
C# Visual Basic Visual C++
public static bool EnableViewStateCompression { get; set; }
Public Shared Property EnableViewStateCompression As Boolean
public:
static property bool EnableViewStateCompression {
    bool get ();
    void set (bool value);
}

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


EndBulkUpdate Method

EndBulkUpdate Method
ScrewTurn Wiki ► ScrewTurn.Wiki ► Settings ► EndBulkUpdate()()()
Ends a bulk update session.
Declaration Syntax
C# Visual Basic Visual C++
public static void EndBulkUpdate()
Public Shared Sub EndBulkUpdate
public:
static void EndBulkUpdate()

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


ErrorsEmails Property

ErrorsEmails Property
ScrewTurn Wiki ► ScrewTurn.Wiki ► Settings ► ErrorsEmails
Gets or sets the email addresses to send a message to when an error occurs.
Declaration Syntax
C# Visual Basic Visual C++
public static string[] ErrorsEmails { get; set; }
Public Shared Property ErrorsEmails As String()
public:
static property array<String^>^ ErrorsEmails {
    array<String^>^ get ();
    void set (array<String^>^ value);
}

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


FileDownloadCountFilter Property

FileDownloadCountFilter Property
ScrewTurn Wiki ► ScrewTurn.Wiki ► Settings ► FileDownloadCountFilter
Gets or sets the file download count extension filter.
Declaration Syntax
C# Visual Basic Visual C++
public static string[] FileDownloadCountFilter { get; set; }
Public Shared Property FileDownloadCountFilter As String()
public:
static property array<String^>^ FileDownloadCountFilter {
    array<String^>^ get ();
    void set (array<String^>^ value);
}

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


FileDownloadCountFilterMode Property

FileDownloadCountFilterMode Property
ScrewTurn Wiki ► ScrewTurn.Wiki ► Settings ► FileDownloadCountFilterMode
Gets or sets the file download count filter mode.
Declaration Syntax
C# Visual Basic Visual C++
public static FileDownloadCountFilterMode FileDownloadCountFilterMode { get; set; }
Public Shared Property FileDownloadCountFilterMode As FileDownloadCountFilterMode
public:
static property FileDownloadCountFilterMode FileDownloadCountFilterMode {
    FileDownloadCountFilterMode get ();
    void set (FileDownloadCountFilterMode value);
}

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


FileManagementInPublicAccessAllowed Property

FileManagementInPublicAccessAllowed Property
ScrewTurn Wiki ► ScrewTurn.Wiki ► Settings ► FileManagementInPublicAccessAllowed
Gets or sets a value specifying whether, in Public Access mode, anonymous file management is allowed.
Declaration Syntax
C# Visual Basic Visual C++
public static bool FileManagementInPublicAccessAllowed { get; set; }
Public Shared Property FileManagementInPublicAccessAllowed As Boolean
public:
static property bool FileManagementInPublicAccessAllowed {
    bool get ();
    void set (bool value);
}
Remarks
Deprecated in version 3.0.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


GetTheme Method (nspace)

GetTheme Method (nspace)
ScrewTurn Wiki ► ScrewTurn.Wiki ► Settings ► GetTheme(String)
Gets the theme name for a namespace.
Declaration Syntax
C# Visual Basic Visual C++
public static string GetTheme(
    string nspace
)
Public Shared Function GetTheme ( _
    nspace As String _
) As String
public:
static String^ GetTheme(
    String^ nspace
)
Parameters
nspace (String)
The namespace (null for the root).
Return Value
The theme name.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


GetThemePath Method (nspace)

GetThemePath Method (nspace)
ScrewTurn Wiki ► ScrewTurn.Wiki ► Settings ► GetThemePath(String)
Gets the Theme Path for a namespace.
Declaration Syntax
C# Visual Basic Visual C++
public static string GetThemePath(
    string nspace
)
Public Shared Function GetThemePath ( _
    nspace As String _
) As String
public:
static String^ GetThemePath(
    String^ nspace
)
Parameters
nspace (String)
The namespace (null for the root).
Return Value
The path of the theme.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


IpHostFilter Property

IpHostFilter Property
ScrewTurn Wiki ► ScrewTurn.Wiki ► Settings ► IpHostFilter
Gets or sets the IP/Host filter for page editing.
Declaration Syntax
C# Visual Basic Visual C++
public static string IpHostFilter { get; set; }
Public Shared Property IpHostFilter As String
public:
static property String^ IpHostFilter {
    String^ get ();
    void set (String^ value);
}

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


IsMetaDataItemGlobal Method (item)

IsMetaDataItemGlobal Method (item)
ScrewTurn Wiki ► ScrewTurn.Wiki ► Settings ► IsMetaDataItemGlobal(MetaDataItem)
Determines whether a meta-data item is global or namespace-specific.
Declaration Syntax
C# Visual Basic Visual C++
public static bool IsMetaDataItemGlobal(
    MetaDataItem item
)
Public Shared Function IsMetaDataItemGlobal ( _
    item As MetaDataItem _
) As Boolean
public:
static bool IsMetaDataItemGlobal(
    MetaDataItem item
)
Parameters
item (MetaDataItem)
The item to test.
Return Value
true if the meta-data item is global, false otherwise.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


JsDirectory Property

JsDirectory Property
ScrewTurn Wiki ► ScrewTurn.Wiki ► Settings ► JsDirectory
Gets the JavaScript Directory.
Declaration Syntax
C# Visual Basic Visual C++
public static string JsDirectory { get; }
Public Shared ReadOnly Property JsDirectory As String
public:
static property String^ JsDirectory {
    String^ get ();
}

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


JsDirectoryName Property

JsDirectoryName Property
ScrewTurn Wiki ► ScrewTurn.Wiki ► Settings ► JsDirectoryName
Gets the Name of the JavaScript Directory.
Declaration Syntax
C# Visual Basic Visual C++
public static string JsDirectoryName { get; }
Public Shared ReadOnly Property JsDirectoryName As String
public:
static property String^ JsDirectoryName {
    String^ get ();
}

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


KeptBackupNumber Property

KeptBackupNumber Property
ScrewTurn Wiki ► ScrewTurn.Wiki ► Settings ► KeptBackupNumber
Gets or sets the # of Backups that are kept. Older backups are deleted after Page editing.
Declaration Syntax
C# Visual Basic Visual C++
public static int KeptBackupNumber { get; set; }
Public Shared Property KeptBackupNumber As Integer
public:
static property int KeptBackupNumber {
    int get ();
    void set (int value);
}
Remarks
-1 indicates that no backups are deleted.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


LoggingLevel Property

LoggingLevel Property
ScrewTurn Wiki ► ScrewTurn.Wiki ► Settings ► LoggingLevel
Gets or sets the Logging Level.
Declaration Syntax
C# Visual Basic Visual C++
public static LoggingLevel LoggingLevel { get; set; }
Public Shared Property LoggingLevel As LoggingLevel
public:
static property LoggingLevel LoggingLevel {
    LoggingLevel get ();
    void set (LoggingLevel value);
}

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


LoginCookieName Property

LoginCookieName Property
ScrewTurn Wiki ► ScrewTurn.Wiki ► Settings ► LoginCookieName
Gets the name of the Login Cookie.
Declaration Syntax
C# Visual Basic Visual C++
public static string LoginCookieName { get; }
Public Shared ReadOnly Property LoginCookieName As String
public:
static property String^ LoginCookieName {
    String^ get ();
}

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


MainUrl Property

MainUrl Property
ScrewTurn Wiki ► ScrewTurn.Wiki ► Settings ► MainUrl
Gets or sets the main URL of the Wiki.
Declaration Syntax
C# Visual Basic Visual C++
public static string MainUrl { get; set; }
Public Shared Property MainUrl As String
public:
static property String^ MainUrl {
    String^ get ();
    void set (String^ value);
}

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


MainUrlRegex Property

MainUrlRegex Property
ScrewTurn Wiki ► ScrewTurn.Wiki ► Settings ► MainUrlRegex
Gets the MainUrl validation Regex.
Declaration Syntax
C# Visual Basic Visual C++
public static string MainUrlRegex { get; }
Public Shared ReadOnly Property MainUrlRegex As String
public:
static property String^ MainUrlRegex {
    String^ get ();
}

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


MasterPassword Property

MasterPassword Property
ScrewTurn Wiki ► ScrewTurn.Wiki ► Settings ► MasterPassword
Gets the Master Password, used to encrypt the Users data.
Declaration Syntax
C# Visual Basic Visual C++
public static string MasterPassword { get; }
Public Shared ReadOnly Property MasterPassword As String
public:
static property String^ MasterPassword {
    String^ get ();
}

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


MasterPasswordBytes Property

MasterPasswordBytes Property
ScrewTurn Wiki ► ScrewTurn.Wiki ► Settings ► MasterPasswordBytes
Gets the bytes of the MasterPassword.
Declaration Syntax
C# Visual Basic Visual C++
public static byte[] MasterPasswordBytes { get; }
Public Shared ReadOnly Property MasterPasswordBytes As Byte()
public:
static property array<unsigned char>^ MasterPasswordBytes {
    array<unsigned char>^ get ();
}

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


MaxFileSize Property

MaxFileSize Property
ScrewTurn Wiki ► ScrewTurn.Wiki ► Settings ► MaxFileSize
Gets or sets the Max file size for upload (in KB).
Declaration Syntax
C# Visual Basic Visual C++
public static int MaxFileSize { get; set; }
Public Shared Property MaxFileSize As Integer
public:
static property int MaxFileSize {
    int get ();
    void set (int value);
}

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


MaxLogSize Property

MaxLogSize Property
ScrewTurn Wiki ► ScrewTurn.Wiki ► Settings ► MaxLogSize
Gets or sets the Max size of the Log file (KB).
Declaration Syntax
C# Visual Basic Visual C++
public static int MaxLogSize { get; set; }
Public Shared Property MaxLogSize As Integer
public:
static property int MaxLogSize {
    int get ();
    void set (int value);
}

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


MaxRecentChanges Property

MaxRecentChanges Property
ScrewTurn Wiki ► ScrewTurn.Wiki ► Settings ► MaxRecentChanges
Gets or sets the max number of recent changes to log.
Declaration Syntax
C# Visual Basic Visual C++
public static int MaxRecentChanges { get; set; }
Public Shared Property MaxRecentChanges As Integer
public:
static property int MaxRecentChanges {
    int get ();
    void set (int value);
}

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


MaxRecentChangesToDisplay Property

MaxRecentChangesToDisplay Property
ScrewTurn Wiki ► ScrewTurn.Wiki ► Settings ► MaxRecentChangesToDisplay
Gets or sets the maximum number of recent changes to display with {RecentChanges} special tag.
Declaration Syntax
C# Visual Basic Visual C++
public static int MaxRecentChangesToDisplay { get; set; }
Public Shared Property MaxRecentChangesToDisplay As Integer
public:
static property int MaxRecentChangesToDisplay {
    int get ();
    void set (int value);
}

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


PageExtension Property

PageExtension Property
ScrewTurn Wiki ► ScrewTurn.Wiki ► Settings ► PageExtension
Gets the extension used for Pages, including the dot.
Declaration Syntax
C# Visual Basic Visual C++
public static string PageExtension { get; }
Public Shared ReadOnly Property PageExtension As String
public:
static property String^ PageExtension {
    String^ get ();
}

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


PasswordRegex Property

PasswordRegex Property
ScrewTurn Wiki ► ScrewTurn.Wiki ► Settings ► PasswordRegex
Gets or sets the Password validation Regex.
Declaration Syntax
C# Visual Basic Visual C++
public static string PasswordRegex { get; set; }
Public Shared Property PasswordRegex As String
public:
static property String^ PasswordRegex {
    String^ get ();
    void set (String^ value);
}

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


PrivateAccess Property

PrivateAccess Property
ScrewTurn Wiki ► ScrewTurn.Wiki ► Settings ► PrivateAccess
Gets or sets a value specifying whether the access to the Wiki is private or not (in this case users won't be able to view pagesCache unless they are logged in).
Declaration Syntax
C# Visual Basic Visual C++
public static bool PrivateAccess { get; set; }
Public Shared Property PrivateAccess As Boolean
public:
static property bool PrivateAccess {
    bool get ();
    void set (bool value);
}
Remarks
Deprecated in version 3.0.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


ProcessSingleLineBreaks Property

ProcessSingleLineBreaks Property
ScrewTurn Wiki ► ScrewTurn.Wiki ► Settings ► ProcessSingleLineBreaks
Gets or sets a value indicating whether or not to process single line breaks in WikiMarkup.
Declaration Syntax
C# Visual Basic Visual C++
public static bool ProcessSingleLineBreaks { get; set; }
Public Shared Property ProcessSingleLineBreaks As Boolean
public:
static property bool ProcessSingleLineBreaks {
    bool get ();
    void set (bool value);
}

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


Provider Property

Provider Property
ScrewTurn Wiki ► ScrewTurn.Wiki ► Settings ► Provider
Gets the settings storage provider.
Declaration Syntax
C# Visual Basic Visual C++
public static ISettingsStorageProviderV30 Provider { get; }
Public Shared ReadOnly Property Provider As ISettingsStorageProviderV30
public:
static property ISettingsStorageProviderV30^ Provider {
    ISettingsStorageProviderV30^ get ();
}

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


PublicAccess Property

PublicAccess Property
ScrewTurn Wiki ► ScrewTurn.Wiki ► Settings ► PublicAccess
Gets or sets a value specifying whether the access to the Wiki is public or not (in this case users won't need to login in order to edit pagesCache).
Declaration Syntax
C# Visual Basic Visual C++
public static bool PublicAccess { get; set; }
Public Shared Property PublicAccess As Boolean
public:
static property bool PublicAccess {
    bool get ();
    void set (bool value);
}
Remarks
Deprecated in version 3.0.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


PublicDirectory Property

PublicDirectory Property
ScrewTurn Wiki ► ScrewTurn.Wiki ► Settings ► PublicDirectory
Gets the Public Directory of the Wiki.
Declaration Syntax
C# Visual Basic Visual C++
public static string PublicDirectory { get; }
Public Shared ReadOnly Property PublicDirectory As String
public:
static property String^ PublicDirectory {
    String^ get ();
}

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


PublicDirectoryName Property

PublicDirectoryName Property
ScrewTurn Wiki ► ScrewTurn.Wiki ► Settings ► PublicDirectoryName
Gets the Public Directory Name (without the full Path) of the Wiki.
Declaration Syntax
C# Visual Basic Visual C++
public static string PublicDirectoryName { get; }
Public Shared ReadOnly Property PublicDirectoryName As String
public:
static property String^ PublicDirectoryName {
    String^ get ();
}

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


RootDirectory Property

RootDirectory Property
ScrewTurn Wiki ► ScrewTurn.Wiki ► Settings ► RootDirectory
Gets the Root Directory of the Wiki.
Declaration Syntax
C# Visual Basic Visual C++
public static string RootDirectory { get; }
Public Shared ReadOnly Property RootDirectory As String
public:
static property String^ RootDirectory {
    String^ get ();
}

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


RssFeedsMode Property

RssFeedsMode Property
ScrewTurn Wiki ► ScrewTurn.Wiki ► Settings ► RssFeedsMode
Gets or sets the functioning mode of RSS feeds.
Declaration Syntax
C# Visual Basic Visual C++
public static RssFeedsMode RssFeedsMode { get; set; }
Public Shared Property RssFeedsMode As RssFeedsMode
public:
static property RssFeedsMode RssFeedsMode {
    RssFeedsMode get ();
    void set (RssFeedsMode value);
}

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


ScriptTagsAllowed Property

ScriptTagsAllowed Property
ScrewTurn Wiki ► ScrewTurn.Wiki ► Settings ► ScriptTagsAllowed
Gets or sets a value specifying whether script tags are allowed.
Declaration Syntax
C# Visual Basic Visual C++
public static bool ScriptTagsAllowed { get; set; }
Public Shared Property ScriptTagsAllowed As Boolean
public:
static property bool ScriptTagsAllowed {
    bool get ();
    void set (bool value);
}

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


SenderEmail Property

SenderEmail Property
ScrewTurn Wiki ► ScrewTurn.Wiki ► Settings ► SenderEmail
Gets or sets the Sender Email.
Declaration Syntax
C# Visual Basic Visual C++
public static string SenderEmail { get; set; }
Public Shared Property SenderEmail As String
public:
static property String^ SenderEmail {
    String^ get ();
    void set (String^ value);
}

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


SetTheme Method (nspace, theme)

SetTheme Method (nspace, theme)
ScrewTurn Wiki ► ScrewTurn.Wiki ► Settings ► SetTheme(String, String)
Sets the theme for a namespace.
Declaration Syntax
C# Visual Basic Visual C++
public static void SetTheme(
    string nspace,
    string theme
)
Public Shared Sub SetTheme ( _
    nspace As String, _
    theme As String _
)
public:
static void SetTheme(
    String^ nspace,
    String^ theme
)
Parameters
nspace (String)
The namespace (null for the root).
theme (String)
The theme name.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


SmtpPassword Property

SmtpPassword Property
ScrewTurn Wiki ► ScrewTurn.Wiki ► Settings ► SmtpPassword
Gets or sets the SMTP Server Password.
Declaration Syntax
C# Visual Basic Visual C++
public static string SmtpPassword { get; set; }
Public Shared Property SmtpPassword As String
public:
static property String^ SmtpPassword {
    String^ get ();
    void set (String^ value);
}

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


SmtpPort Property

SmtpPort Property
ScrewTurn Wiki ► ScrewTurn.Wiki ► Settings ► SmtpPort
Gets or sets the SMTP Server Port.
Declaration Syntax
C# Visual Basic Visual C++
public static int SmtpPort { get; set; }
Public Shared Property SmtpPort As Integer
public:
static property int SmtpPort {
    int get ();
    void set (int value);
}

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


SmtpServer Property

SmtpServer Property
ScrewTurn Wiki ► ScrewTurn.Wiki ► Settings ► SmtpServer
Gets or sets the SMTP Server.
Declaration Syntax
C# Visual Basic Visual C++
public static string SmtpServer { get; set; }
Public Shared Property SmtpServer As String
public:
static property String^ SmtpServer {
    String^ get ();
    void set (String^ value);
}

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


SmtpServerRegex Property

SmtpServerRegex Property
ScrewTurn Wiki ► ScrewTurn.Wiki ► Settings ► SmtpServerRegex
Gets the SMTP Server validation Regex.
Declaration Syntax
C# Visual Basic Visual C++
public static string SmtpServerRegex { get; }
Public Shared ReadOnly Property SmtpServerRegex As String
public:
static property String^ SmtpServerRegex {
    String^ get ();
}

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


SmtpSsl Property

SmtpSsl Property
ScrewTurn Wiki ► ScrewTurn.Wiki ► Settings ► SmtpSsl
Gets or sets a value specifying whether to enable SSL in SMTP.
Declaration Syntax
C# Visual Basic Visual C++
public static bool SmtpSsl { get; set; }
Public Shared Property SmtpSsl As Boolean
public:
static property bool SmtpSsl {
    bool get ();
    void set (bool value);
}

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


SmtpUsername Property

SmtpUsername Property
ScrewTurn Wiki ► ScrewTurn.Wiki ► Settings ► SmtpUsername
Gets or sets the SMTP Server Username.
Declaration Syntax
C# Visual Basic Visual C++
public static string SmtpUsername { get; set; }
Public Shared Property SmtpUsername As String
public:
static property String^ SmtpUsername {
    String^ get ();
    void set (String^ value);
}

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


ThemesDirectory Property

ThemesDirectory Property
ScrewTurn Wiki ► ScrewTurn.Wiki ► Settings ► ThemesDirectory
Gets the Themes directory.
Declaration Syntax
C# Visual Basic Visual C++
public static string ThemesDirectory { get; }
Public Shared ReadOnly Property ThemesDirectory As String
public:
static property String^ ThemesDirectory {
    String^ get ();
}

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


ThemesDirectoryName Property

ThemesDirectoryName Property
ScrewTurn Wiki ► ScrewTurn.Wiki ► Settings ► ThemesDirectoryName
Gets the Name of the Themes directory.
Declaration Syntax
C# Visual Basic Visual C++
public static string ThemesDirectoryName { get; }
Public Shared ReadOnly Property ThemesDirectoryName As String
public:
static property String^ ThemesDirectoryName {
    String^ get ();
}

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


UsernameRegex Property

UsernameRegex Property
ScrewTurn Wiki ► ScrewTurn.Wiki ► Settings ► UsernameRegex
Gets or sets the Username validation Regex.
Declaration Syntax
C# Visual Basic Visual C++
public static string UsernameRegex { get; set; }
Public Shared Property UsernameRegex As String
public:
static property String^ UsernameRegex {
    String^ get ();
    void set (String^ value);
}

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


UsersCanCreateNewCategories Property

UsersCanCreateNewCategories Property
ScrewTurn Wiki ► ScrewTurn.Wiki ► Settings ► UsersCanCreateNewCategories
Gets or sets a value specifying whether or not users can create new Categories.
Declaration Syntax
C# Visual Basic Visual C++
public static bool UsersCanCreateNewCategories { get; set; }
Public Shared Property UsersCanCreateNewCategories As Boolean
public:
static property bool UsersCanCreateNewCategories {
    bool get ();
    void set (bool value);
}
Remarks
Deprecated in version 3.0.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


UsersCanCreateNewPages Property

UsersCanCreateNewPages Property
ScrewTurn Wiki ► ScrewTurn.Wiki ► Settings ► UsersCanCreateNewPages
Gets or sets a value specifying whether or not Users can create new Page.
Declaration Syntax
C# Visual Basic Visual C++
public static bool UsersCanCreateNewPages { get; set; }
Public Shared Property UsersCanCreateNewPages As Boolean
public:
static property bool UsersCanCreateNewPages {
    bool get ();
    void set (bool value);
}
Remarks
Deprecated in version 3.0.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


UsersCanDeleteFiles Property

UsersCanDeleteFiles Property
ScrewTurn Wiki ► ScrewTurn.Wiki ► Settings ► UsersCanDeleteFiles
Gets or sets a value specifying whether or not users can delete Files.
Declaration Syntax
C# Visual Basic Visual C++
public static bool UsersCanDeleteFiles { get; set; }
Public Shared Property UsersCanDeleteFiles As Boolean
public:
static property bool UsersCanDeleteFiles {
    bool get ();
    void set (bool value);
}
Remarks
Deprecated in version 3.0.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


UsersCanManagePageCategories Property

UsersCanManagePageCategories Property
ScrewTurn Wiki ► ScrewTurn.Wiki ► Settings ► UsersCanManagePageCategories
Gets or sets a value specifying whether or not users can manage Page Categories.
Declaration Syntax
C# Visual Basic Visual C++
public static bool UsersCanManagePageCategories { get; set; }
Public Shared Property UsersCanManagePageCategories As Boolean
public:
static property bool UsersCanManagePageCategories {
    bool get ();
    void set (bool value);
}
Remarks
Deprecated in version 3.0.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


UsersCanRegister Property

UsersCanRegister Property
ScrewTurn Wiki ► ScrewTurn.Wiki ► Settings ► UsersCanRegister
Gets or sets a value specifying whether Users can create new accounts or not (in this case Register.aspx won't be available).
Declaration Syntax
C# Visual Basic Visual C++
public static bool UsersCanRegister { get; set; }
Public Shared Property UsersCanRegister As Boolean
public:
static property bool UsersCanRegister {
    bool get ();
    void set (bool value);
}

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


UsersCanUploadFiles Property

UsersCanUploadFiles Property
ScrewTurn Wiki ► ScrewTurn.Wiki ► Settings ► UsersCanUploadFiles
Gets or sets a value specifying whether or not users can upload Files.
Declaration Syntax
C# Visual Basic Visual C++
public static bool UsersCanUploadFiles { get; set; }
Public Shared Property UsersCanUploadFiles As Boolean
public:
static property bool UsersCanUploadFiles {
    bool get ();
    void set (bool value);
}
Remarks
Deprecated in version 3.0.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


UsersCanViewFiles Property

UsersCanViewFiles Property
ScrewTurn Wiki ► ScrewTurn.Wiki ► Settings ► UsersCanViewFiles
Gets or sets a value specifying whether or not users can view uploaded Files.
Declaration Syntax
C# Visual Basic Visual C++
public static bool UsersCanViewFiles { get; set; }
Public Shared Property UsersCanViewFiles As Boolean
public:
static property bool UsersCanViewFiles {
    bool get ();
    void set (bool value);
}
Remarks
Deprecated in version 3.0.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


UsersGroup Property

UsersGroup Property
ScrewTurn Wiki ► ScrewTurn.Wiki ► Settings ► UsersGroup
Gets or sets the name of the default Users group.
Declaration Syntax
C# Visual Basic Visual C++
public static string UsersGroup { get; set; }
Public Shared Property UsersGroup As String
public:
static property String^ UsersGroup {
    String^ get ();
    void set (String^ value);
}

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


UseVisualEditorAsDefault Property

UseVisualEditorAsDefault Property
ScrewTurn Wiki ► ScrewTurn.Wiki ► Settings ► UseVisualEditorAsDefault
Gets or sets a value indicating whether to use the Visual editor as default.
Declaration Syntax
C# Visual Basic Visual C++
public static bool UseVisualEditorAsDefault { get; set; }
Public Shared Property UseVisualEditorAsDefault As Boolean
public:
static property bool UseVisualEditorAsDefault {
    bool get ();
    void set (bool value);
}

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


WikiTitle Property

WikiTitle Property
ScrewTurn Wiki ► ScrewTurn.Wiki ► Settings ► WikiTitle
Gets or sets the Title of the Wiki.
Declaration Syntax
C# Visual Basic Visual C++
public static string WikiTitle { get; set; }
Public Shared Property WikiTitle As String
public:
static property String^ WikiTitle {
    String^ get ();
    void set (String^ value);
}

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


WikiTitleRegex Property

WikiTitleRegex Property
ScrewTurn Wiki ► ScrewTurn.Wiki ► Settings ► WikiTitleRegex
Gets the WikiTitle validation Regex.
Declaration Syntax
C# Visual Basic Visual C++
public static string WikiTitleRegex { get; }
Public Shared ReadOnly Property WikiTitleRegex As String
public:
static property String^ WikiTitleRegex {
    String^ get ();
}

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


WikiVersion Property

WikiVersion Property
ScrewTurn Wiki ► ScrewTurn.Wiki ► Settings ► WikiVersion
Gets the version of the Wiki.
Declaration Syntax
C# Visual Basic Visual C++
public static string WikiVersion { get; }
Public Shared ReadOnly Property WikiVersion As String
public:
static property String^ WikiVersion {
    String^ get ();
}

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


SettingsStorageProvider Class

SettingsStorageProvider Class
ScrewTurn Wiki ► ScrewTurn.Wiki ► SettingsStorageProvider
Implements a Settings Storage Provider against local text pluginAssemblies.
Declaration Syntax
C# Visual Basic Visual C++
public class SettingsStorageProvider : ISettingsStorageProviderV30,
    IProviderV30
Public Class SettingsStorageProvider _
    Implements ISettingsStorageProviderV30, IProviderV30
public ref class SettingsStorageProvider : ISettingsStorageProviderV30,
    IProviderV30
Members
All Members | Constructors | Methods | Properties | Fields
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | SettingsStorageProvider()()() | Initializes a new instance of the SettingsStorageProvider class
 | AclManager | Gets the ACL Manager instance.
 | AddRecentChange(String, String, String, DateTime, String, Change, String) | Adds a new change.
 | BeginBulkUpdate()()() | Starts a Bulk update of the Settings so that a bulk of settings can be set before storing them.
 | ClearLog()()() | Clear the Log.
 | ConfigHelpHtml | Gets a brief summary of the configuration string format, in HTML. Returns null if no configuration is needed.
 | DeleteOutgoingLinks(String) | Deletes the outgoing links of a page and all the target links that include the page.
 | DeletePluginAssembly(String) | Removes a plugin's assembly.
 | EndBulkUpdate()()() | Ends a Bulk update of the Settings and stores the settings.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetAllOutgoingLinks()()() | Gets all the outgoing links stored.
 | GetAllSettings()()() | Gets the all the setting values.
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetLogEntries()()() | Gets all the Log Entries, sorted by date/time (oldest to newest).
 | GetMetaDataItem(MetaDataItem, String) | Gets a meta-data item's content.
 | GetOutgoingLinks(String) | Gets the outgoing links of a page.
 | GetPluginConfiguration(String) | Gets the configuration of a plugin.
 | GetPluginStatus(String) | Gets the status of a plugin.
 | GetRecentChanges()()() | Gets the recent changes of the Wiki.
 | GetSetting(String) | Retrieves the value of a Setting.
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | Information | Gets the Information about the Provider.
 | Init(IHostV30, String) | Initializes the Storage Provider.
 | IsFirstApplicationStart()()() | Determines whether the application was started for the first time.
 | ListPluginAssemblies()()() | Lists the stored plugin assemblies.
 | LogEntry(String, EntryType, String) | Records a message to the System Log.
 | LogSize | Gets the current size of the Log, in KB.
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ProviderName | The name of the provider.
 | RetrievePluginAssembly(String) | Retrieves a plugin's assembly.
 | SetMetaDataItem(MetaDataItem, String, String) | Sets a meta-data items' content.
 | SetPluginConfiguration(String, String) | Sets the configuration of a plugin.
 | SetPluginStatus(String, Boolean) | Sets the status of a plugin.
 | SetSetting(String, String) | Stores the value of a Setting.
 | Shutdown()()() | Method invoked on shutdown.
 | StoreOutgoingLinks(String, array<String>[]()[]) | Stores the outgoing links of a page, overwriting existing data.
 | StorePluginAssembly(String, array<Byte>[]()[]) | Stores a plugin's assembly, overwriting existing ones if present.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | UpdateOutgoingLinksForRename(String, String) | Updates all outgoing links data for a page rename.
Inheritance Hierarchy
Object
SettingsStorageProvider

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


SettingsStorageProvider Constructor

SettingsStorageProvider Constructor
ScrewTurn Wiki ► ScrewTurn.Wiki ► SettingsStorageProvider ► SettingsStorageProvider()()()
Initializes a new instance of the SettingsStorageProvider class
Declaration Syntax
C# Visual Basic Visual C++
public SettingsStorageProvider()
Public Sub New
public:
SettingsStorageProvider()

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


AclManager Property

AclManager Property
ScrewTurn Wiki ► ScrewTurn.Wiki ► SettingsStorageProvider ► AclManager
Gets the ACL Manager instance.
Declaration Syntax
C# Visual Basic Visual C++
public IAclManager AclManager { get; }
Public ReadOnly Property AclManager As IAclManager
public:
virtual property IAclManager^ AclManager {
    IAclManager^ get () sealed;
}

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


AddRecentChange Method (page, title, messageSubject, dateTime, user, change, descr)

AddRecentChange Method (page, title, messageSubject, dateTime, user, change, descr)
ScrewTurn Wiki ► ScrewTurn.Wiki ► SettingsStorageProvider ► AddRecentChange(String, String, String, DateTime, String, Change, String)
Adds a new change.
Declaration Syntax
C# Visual Basic Visual C++
public bool AddRecentChange(
    string page,
    string title,
    string messageSubject,
    DateTime dateTime,
    string user,
    Change change,
    string descr
)
Public Function AddRecentChange ( _
    page As String, _
    title As String, _
    messageSubject As String, _
    dateTime As DateTime, _
    user As String, _
    change As Change, _
    descr As String _
) As Boolean
public:
virtual bool AddRecentChange(
    String^ page,
    String^ title,
    String^ messageSubject,
    DateTime dateTime,
    String^ user,
    Change change,
    String^ descr
) sealed
Parameters
page (String)
The page name.
title (String)
The page title.
messageSubject (String)
The message subject (or null).
dateTime (DateTime)
The date/time.
user (String)
The user.
change (Change)
The change.
descr (String)
The description (optional).
Return Value
true if the change is saved, false otherwise.
Exceptions
Exception | Condition
ArgumentNullException | If page, title or user are null.
ArgumentException | If page, title or user are empty.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


BeginBulkUpdate Method

BeginBulkUpdate Method
ScrewTurn Wiki ► ScrewTurn.Wiki ► SettingsStorageProvider ► BeginBulkUpdate()()()
Starts a Bulk update of the Settings so that a bulk of settings can be set before storing them.
Declaration Syntax
C# Visual Basic Visual C++
public void BeginBulkUpdate()
Public Sub BeginBulkUpdate
public:
virtual void BeginBulkUpdate() sealed

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


ClearLog Method

ClearLog Method
ScrewTurn Wiki ► ScrewTurn.Wiki ► SettingsStorageProvider ► ClearLog()()()
Clear the Log.
Declaration Syntax
C# Visual Basic Visual C++
public void ClearLog()
Public Sub ClearLog
public:
virtual void ClearLog() sealed

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


ConfigHelpHtml Property

ConfigHelpHtml Property
ScrewTurn Wiki ► ScrewTurn.Wiki ► SettingsStorageProvider ► ConfigHelpHtml
Gets a brief summary of the configuration string format, in HTML. Returns null if no configuration is needed.
Declaration Syntax
C# Visual Basic Visual C++
public string ConfigHelpHtml { get; }
Public ReadOnly Property ConfigHelpHtml As String
public:
virtual property String^ ConfigHelpHtml {
    String^ get () sealed;
}

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


DeleteOutgoingLinks Method (page)

DeleteOutgoingLinks Method (page)
ScrewTurn Wiki ► ScrewTurn.Wiki ► SettingsStorageProvider ► DeleteOutgoingLinks(String)
Deletes the outgoing links of a page and all the target links that include the page.
Declaration Syntax
C# Visual Basic Visual C++
public bool DeleteOutgoingLinks(
    string page
)
Public Function DeleteOutgoingLinks ( _
    page As String _
) As Boolean
public:
virtual bool DeleteOutgoingLinks(
    String^ page
) sealed
Parameters
page (String)
The full name of the page.
Return Value
true if the links are deleted, false otherwise.
Exceptions
Exception | Condition
ArgumentNullException | If page is null.
ArgumentException | If page is empty.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


DeletePluginAssembly Method (filename)

DeletePluginAssembly Method (filename)
ScrewTurn Wiki ► ScrewTurn.Wiki ► SettingsStorageProvider ► DeletePluginAssembly(String)
Removes a plugin's assembly.
Declaration Syntax
C# Visual Basic Visual C++
public bool DeletePluginAssembly(
    string filename
)
Public Function DeletePluginAssembly ( _
    filename As String _
) As Boolean
public:
virtual bool DeletePluginAssembly(
    String^ filename
) sealed
Parameters
filename (String)
The file name of the assembly to remove, such as "Assembly.dll".
Return Value
true if the assembly is removed, false otherwise.
Exceptions
Exception | Condition
ArgumentNullException | If filename is null.
ArgumentException | If filename is empty.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


EndBulkUpdate Method

EndBulkUpdate Method
ScrewTurn Wiki ► ScrewTurn.Wiki ► SettingsStorageProvider ► EndBulkUpdate()()()
Ends a Bulk update of the Settings and stores the settings.
Declaration Syntax
C# Visual Basic Visual C++
public void EndBulkUpdate()
Public Sub EndBulkUpdate
public:
virtual void EndBulkUpdate() sealed

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


GetAllOutgoingLinks Method

GetAllOutgoingLinks Method
ScrewTurn Wiki ► ScrewTurn.Wiki ► SettingsStorageProvider ► GetAllOutgoingLinks()()()
Gets all the outgoing links stored.
Declaration Syntax
C# Visual Basic Visual C++
public IDictionary<string, string[]> GetAllOutgoingLinks()
Public Function GetAllOutgoingLinks As IDictionary(Of String, String())
public:
virtual IDictionary<String^, array<String^>^>^ GetAllOutgoingLinks() sealed
Return Value
The outgoing links, in a dictionary in the form page->outgoing_links.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


GetAllSettings Method

GetAllSettings Method
ScrewTurn Wiki ► ScrewTurn.Wiki ► SettingsStorageProvider ► GetAllSettings()()()
Gets the all the setting values.
Declaration Syntax
C# Visual Basic Visual C++
public IDictionary<string, string> GetAllSettings()
Public Function GetAllSettings As IDictionary(Of String, String)
public:
virtual IDictionary<String^, String^>^ GetAllSettings() sealed
Return Value
All the settings.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


GetLogEntries Method

GetLogEntries Method
ScrewTurn Wiki ► ScrewTurn.Wiki ► SettingsStorageProvider ► GetLogEntries()()()
Gets all the Log Entries, sorted by date/time (oldest to newest).
Declaration Syntax
C# Visual Basic Visual C++
public LogEntry[] GetLogEntries()
Public Function GetLogEntries As LogEntry()
public:
virtual array<LogEntry^>^ GetLogEntries() sealed
Return Value

[Missing <returns> documentation for "M:ScrewTurn.Wiki.SettingsStorageProvider.GetLogEntries"]

Remarks
The Log Entries.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


GetMetaDataItem Method (item, tag)

GetMetaDataItem Method (item, tag)
ScrewTurn Wiki ► ScrewTurn.Wiki ► SettingsStorageProvider ► GetMetaDataItem(MetaDataItem, String)
Gets a meta-data item's content.
Declaration Syntax
C# Visual Basic Visual C++
public string GetMetaDataItem(
    MetaDataItem item,
    string tag
)
Public Function GetMetaDataItem ( _
    item As MetaDataItem, _
    tag As String _
) As String
public:
virtual String^ GetMetaDataItem(
    MetaDataItem item,
    String^ tag
) sealed
Parameters
item (MetaDataItem)
The item.
tag (String)
The tag that specifies the context (usually the namespace).
Return Value
The content.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


GetOutgoingLinks Method (page)

GetOutgoingLinks Method (page)
ScrewTurn Wiki ► ScrewTurn.Wiki ► SettingsStorageProvider ► GetOutgoingLinks(String)
Gets the outgoing links of a page.
Declaration Syntax
C# Visual Basic Visual C++
public string[] GetOutgoingLinks(
    string page
)
Public Function GetOutgoingLinks ( _
    page As String _
) As String()
public:
virtual array<String^>^ GetOutgoingLinks(
    String^ page
) sealed
Parameters
page (String)
The full name of the page.
Return Value
The outgoing links.
Exceptions
Exception | Condition
ArgumentNullException | If page is null.
ArgumentException | If page is empty.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


GetPluginConfiguration Method (typeName)

GetPluginConfiguration Method (typeName)
ScrewTurn Wiki ► ScrewTurn.Wiki ► SettingsStorageProvider ► GetPluginConfiguration(String)
Gets the configuration of a plugin.
Declaration Syntax
C# Visual Basic Visual C++
public string GetPluginConfiguration(
    string typeName
)
Public Function GetPluginConfiguration ( _
    typeName As String _
) As String
public:
virtual String^ GetPluginConfiguration(
    String^ typeName
) sealed
Parameters
typeName (String)
The Type name of the plugin.
Return Value
The plugin configuration, or String.Empty.
Exceptions
Exception | Condition
ArgumentNullException | If typeName is null.
ArgumentException | If typeName is empty.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


GetPluginStatus Method (typeName)

GetPluginStatus Method (typeName)
ScrewTurn Wiki ► ScrewTurn.Wiki ► SettingsStorageProvider ► GetPluginStatus(String)
Gets the status of a plugin.
Declaration Syntax
C# Visual Basic Visual C++
public bool GetPluginStatus(
    string typeName
)
Public Function GetPluginStatus ( _
    typeName As String _
) As Boolean
public:
virtual bool GetPluginStatus(
    String^ typeName
) sealed
Parameters
typeName (String)
The Type name of the plugin.
Return Value
The status (true for enabled, false for disabled), or true if no status is found.
Exceptions
Exception | Condition
ArgumentNullException | If typeName is null.
ArgumentException | If typeName is empty.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


GetRecentChanges Method

GetRecentChanges Method
ScrewTurn Wiki ► ScrewTurn.Wiki ► SettingsStorageProvider ► GetRecentChanges()()()
Gets the recent changes of the Wiki.
Declaration Syntax
C# Visual Basic Visual C++
public RecentChange[] GetRecentChanges()
Public Function GetRecentChanges As RecentChange()
public:
virtual array<RecentChange^>^ GetRecentChanges() sealed
Return Value
The recent Changes (oldest to newest).

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


GetSetting Method (name)

GetSetting Method (name)
ScrewTurn Wiki ► ScrewTurn.Wiki ► SettingsStorageProvider ► GetSetting(String)
Retrieves the value of a Setting.
Declaration Syntax
C# Visual Basic Visual C++
public string GetSetting(
    string name
)
Public Function GetSetting ( _
    name As String _
) As String
public:
virtual String^ GetSetting(
    String^ name
) sealed
Parameters
name (String)
The name of the Setting.
Return Value
The value of the Setting, or null.
Exceptions
Exception | Condition
ArgumentNullException | If name is null.
ArgumentException | If name is empty.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


Information Property

Information Property
ScrewTurn Wiki ► ScrewTurn.Wiki ► SettingsStorageProvider ► Information
Gets the Information about the Provider.
Declaration Syntax
C# Visual Basic Visual C++
public ComponentInformation Information { get; }
Public ReadOnly Property Information As ComponentInformation
public:
virtual property ComponentInformation^ Information {
    ComponentInformation^ get () sealed;
}

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


Init Method (host, config)

Init Method (host, config)
ScrewTurn Wiki ► ScrewTurn.Wiki ► SettingsStorageProvider ► Init(IHostV30, String)
Initializes the Storage Provider.
Declaration Syntax
C# Visual Basic Visual C++
public void Init(
    IHostV30 host,
    string config
)
Public Sub Init ( _
    host As IHostV30, _
    config As String _
)
public:
virtual void Init(
    IHostV30^ host,
    String^ config
) sealed
Parameters
host (IHostV30)
The Host of the Component.
config (String)
The Configuration data, if any.
Exceptions
Exception | Condition
ArgumentNullException | If host or config are null.
InvalidConfigurationException | If config is not valid or is incorrect.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


IsFirstApplicationStart Method

IsFirstApplicationStart Method
ScrewTurn Wiki ► ScrewTurn.Wiki ► SettingsStorageProvider ► IsFirstApplicationStart()()()
Determines whether the application was started for the first time.
Declaration Syntax
C# Visual Basic Visual C++
public bool IsFirstApplicationStart()
Public Function IsFirstApplicationStart As Boolean
public:
virtual bool IsFirstApplicationStart() sealed
Return Value
true if the application was started for the first time, false otherwise.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


ListPluginAssemblies Method

ListPluginAssemblies Method
ScrewTurn Wiki ► ScrewTurn.Wiki ► SettingsStorageProvider ► ListPluginAssemblies()()()
Lists the stored plugin assemblies.
Declaration Syntax
C# Visual Basic Visual C++
public string[] ListPluginAssemblies()
Public Function ListPluginAssemblies As String()
public:
virtual array<String^>^ ListPluginAssemblies() sealed
Return Value

[Missing <returns> documentation for "M:ScrewTurn.Wiki.SettingsStorageProvider.ListPluginAssemblies"]

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


LogEntry Method (message, entryType, user)

LogEntry Method (message, entryType, user)
ScrewTurn Wiki ► ScrewTurn.Wiki ► SettingsStorageProvider ► LogEntry(String, EntryType, String)
Records a message to the System Log.
Declaration Syntax
C# Visual Basic Visual C++
public void LogEntry(
    string message,
    EntryType entryType,
    string user
)
Public Sub LogEntry ( _
    message As String, _
    entryType As EntryType, _
    user As String _
)
public:
virtual void LogEntry(
    String^ message,
    EntryType entryType,
    String^ user
) sealed
Parameters
message (String)
The Log Message.
entryType (EntryType)
The Type of the Entry.
user (String)
The User.
Remarks
This method should not write messages to the Log using the method IHost.LogEntry. This method should also never throw exceptions (except for parameter validation).
Exceptions
Exception | Condition
ArgumentNullException | If message or user are null.
ArgumentException | If message or user are empty.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


LogSize Property

LogSize Property
ScrewTurn Wiki ► ScrewTurn.Wiki ► SettingsStorageProvider ► LogSize
Gets the current size of the Log, in KB.
Declaration Syntax
C# Visual Basic Visual C++
public int LogSize { get; }
Public ReadOnly Property LogSize As Integer
public:
virtual property int LogSize {
    int get () sealed;
}

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


ProviderName Field

ProviderName Field
ScrewTurn Wiki ► ScrewTurn.Wiki ► SettingsStorageProvider ► ProviderName
The name of the provider.
Declaration Syntax
C# Visual Basic Visual C++
public static readonly string ProviderName
Public Shared ReadOnly ProviderName As String
public:
static initonly String^ ProviderName

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


RetrievePluginAssembly Method (filename)

RetrievePluginAssembly Method (filename)
ScrewTurn Wiki ► ScrewTurn.Wiki ► SettingsStorageProvider ► RetrievePluginAssembly(String)
Retrieves a plugin's assembly.
Declaration Syntax
C# Visual Basic Visual C++
public byte[] RetrievePluginAssembly(
    string filename
)
Public Function RetrievePluginAssembly ( _
    filename As String _
) As Byte()
public:
virtual array<unsigned char>^ RetrievePluginAssembly(
    String^ filename
) sealed
Parameters
filename (String)
The file name of the assembly.
Return Value
The assembly content, or null.
Exceptions
Exception | Condition
ArgumentNullException | If filename is null.
ArgumentException | If filename is empty.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


SetMetaDataItem Method (item, tag, content)

SetMetaDataItem Method (item, tag, content)
ScrewTurn Wiki ► ScrewTurn.Wiki ► SettingsStorageProvider ► SetMetaDataItem(MetaDataItem, String, String)
Sets a meta-data items' content.
Declaration Syntax
C# Visual Basic Visual C++
public bool SetMetaDataItem(
    MetaDataItem item,
    string tag,
    string content
)
Public Function SetMetaDataItem ( _
    item As MetaDataItem, _
    tag As String, _
    content As String _
) As Boolean
public:
virtual bool SetMetaDataItem(
    MetaDataItem item,
    String^ tag,
    String^ content
) sealed
Parameters
item (MetaDataItem)
The item.
tag (String)
The tag that specifies the context (usually the namespace).
content (String)
The content.
Return Value
true if the content is set, false otherwise.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


SetPluginConfiguration Method (typeName, config)

SetPluginConfiguration Method (typeName, config)
ScrewTurn Wiki ► ScrewTurn.Wiki ► SettingsStorageProvider ► SetPluginConfiguration(String, String)
Sets the configuration of a plugin.
Declaration Syntax
C# Visual Basic Visual C++
public bool SetPluginConfiguration(
    string typeName,
    string config
)
Public Function SetPluginConfiguration ( _
    typeName As String, _
    config As String _
) As Boolean
public:
virtual bool SetPluginConfiguration(
    String^ typeName,
    String^ config
) sealed
Parameters
typeName (String)
The Type name of the plugin.
config (String)
The configuration.
Return Value
true if the configuration is stored, false otherwise.
Exceptions
Exception | Condition
ArgumentNullException | If typeName is null.
ArgumentException | If typeName is empty.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


SetPluginStatus Method (typeName, enabled)

SetPluginStatus Method (typeName, enabled)
ScrewTurn Wiki ► ScrewTurn.Wiki ► SettingsStorageProvider ► SetPluginStatus(String, Boolean)
Sets the status of a plugin.
Declaration Syntax
C# Visual Basic Visual C++
public bool SetPluginStatus(
    string typeName,
    bool enabled
)
Public Function SetPluginStatus ( _
    typeName As String, _
    enabled As Boolean _
) As Boolean
public:
virtual bool SetPluginStatus(
    String^ typeName,
    bool enabled
) sealed
Parameters
typeName (String)
The Type name of the plugin.
enabled (Boolean)
The plugin status.
Return Value
true if the status is stored, false otherwise.
Exceptions
Exception | Condition
ArgumentNullException | If typeName is null.
ArgumentException | If typeName is empty.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


SetSetting Method (name, value)

SetSetting Method (name, value)
ScrewTurn Wiki ► ScrewTurn.Wiki ► SettingsStorageProvider ► SetSetting(String, String)
Stores the value of a Setting.
Declaration Syntax
C# Visual Basic Visual C++
public bool SetSetting(
    string name,
    string value
)
Public Function SetSetting ( _
    name As String, _
    value As String _
) As Boolean
public:
virtual bool SetSetting(
    String^ name,
    String^ value
) sealed
Parameters
name (String)
The name of the Setting.
value (String)
The value of the Setting. Value cannot contain CR and LF characters, which will be removed.
Return Value
True if the Setting is stored, false otherwise.
Remarks
This method stores the Value immediately.
Exceptions
Exception | Condition
ArgumentNullException | If name is null.
ArgumentException | If name is empty.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


Shutdown Method

Shutdown Method
ScrewTurn Wiki ► ScrewTurn.Wiki ► SettingsStorageProvider ► Shutdown()()()
Method invoked on shutdown.
Declaration Syntax
C# Visual Basic Visual C++
public void Shutdown()
Public Sub Shutdown
public:
virtual void Shutdown() sealed
Remarks
This method might not be invoked in some cases.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


StoreOutgoingLinks Method (page, outgoingLinks)

StoreOutgoingLinks Method (page, outgoingLinks)
ScrewTurn Wiki ► ScrewTurn.Wiki ► SettingsStorageProvider ► StoreOutgoingLinks(String, array<String>[]()[])
Stores the outgoing links of a page, overwriting existing data.
Declaration Syntax
C# Visual Basic Visual C++
public bool StoreOutgoingLinks(
    string page,
    string[] outgoingLinks
)
Public Function StoreOutgoingLinks ( _
    page As String, _
    outgoingLinks As String() _
) As Boolean
public:
virtual bool StoreOutgoingLinks(
    String^ page,
    array<String^>^ outgoingLinks
) sealed
Parameters
page (String)
The full name of the page.
outgoingLinks (array< String >[]()[][])
The full names of the pages that page links to.
Return Value
true if the outgoing links are stored, false otherwise.
Exceptions
Exception | Condition
ArgumentNullException | If page or outgoingLinks are null.
ArgumentException | If page or outgoingLinks are empty.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


StorePluginAssembly Method (filename, assembly)

StorePluginAssembly Method (filename, assembly)
ScrewTurn Wiki ► ScrewTurn.Wiki ► SettingsStorageProvider ► StorePluginAssembly(String, array<Byte>[]()[])
Stores a plugin's assembly, overwriting existing ones if present.
Declaration Syntax
C# Visual Basic Visual C++
public bool StorePluginAssembly(
    string filename,
    byte[] assembly
)
Public Function StorePluginAssembly ( _
    filename As String, _
    assembly As Byte() _
) As Boolean
public:
virtual bool StorePluginAssembly(
    String^ filename,
    array<unsigned char>^ assembly
) sealed
Parameters
filename (String)
The file name of the assembly, such as "Assembly.dll".
assembly (array< Byte >[]()[][])
The assembly content.
Return Value
true if the assembly is stored, false otherwise.
Exceptions
Exception | Condition
ArgumentNullException | If filename or assembly are null.
ArgumentException | If filename or assembly are empty.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


UpdateOutgoingLinksForRename Method (oldName, newName)

UpdateOutgoingLinksForRename Method (oldName, newName)
ScrewTurn Wiki ► ScrewTurn.Wiki ► SettingsStorageProvider ► UpdateOutgoingLinksForRename(String, String)
Updates all outgoing links data for a page rename.
Declaration Syntax
C# Visual Basic Visual C++
public bool UpdateOutgoingLinksForRename(
    string oldName,
    string newName
)
Public Function UpdateOutgoingLinksForRename ( _
    oldName As String, _
    newName As String _
) As Boolean
public:
virtual bool UpdateOutgoingLinksForRename(
    String^ oldName,
    String^ newName
) sealed
Parameters
oldName (String)
The old page name.
newName (String)
The new page name.
Return Value
true if the data is updated, false otherwise.
Exceptions
Exception | Condition
ArgumentNullException | If oldName or newName are null.
ArgumentException | If oldName or newName are empty.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


Snippets Class

Snippets Class
ScrewTurn Wiki ► ScrewTurn.Wiki ► Snippets
Manages snippets.
Declaration Syntax
C# Visual Basic Visual C++
public static class Snippets
Public NotInheritable Class Snippets
public ref class Snippets abstract sealed
Members
All Members | Methods | Fields
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | AddSnippet(String, String, IPagesStorageProviderV30) | Creates a new Snippet.
 | CountParameters(Snippet) | Counts the parameters in a snippet.
 | ExtractParameterNames(Snippet) | Finds the parameters in a snippet.
 | Find(String) | Finds a Snippet.
 | GetSnippets()()() | Gets the complete list of the Snippets.
 | ModifySnippet(Snippet, String) | Modifies the Content of a Snippet.
 | ParametersRegex | The regular expression to use for extracting parameters.
 | RemoveSnippet(Snippet) | Removes a Snippet.
Inheritance Hierarchy
Object
Snippets

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


AddSnippet Method (name, content, provider)

AddSnippet Method (name, content, provider)
ScrewTurn Wiki ► ScrewTurn.Wiki ► Snippets ► AddSnippet(String, String, IPagesStorageProviderV30)
Creates a new Snippet.
Declaration Syntax
C# Visual Basic Visual C++
public static bool AddSnippet(
    string name,
    string content,
    IPagesStorageProviderV30 provider
)
Public Shared Function AddSnippet ( _
    name As String, _
    content As String, _
    provider As IPagesStorageProviderV30 _
) As Boolean
public:
static bool AddSnippet(
    String^ name,
    String^ content,
    IPagesStorageProviderV30^ provider
)
Parameters
name (String)
The name of the Snippet.
content (String)
The content of the Snippet.
provider (IPagesStorageProviderV30)
The Provider to use to store the Snippet (null for the default provider).
Return Value
True if the Snippets has been addedd successfully.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


CountParameters Method (snippet)

CountParameters Method (snippet)
ScrewTurn Wiki ► ScrewTurn.Wiki ► Snippets ► CountParameters(Snippet)
Counts the parameters in a snippet.
Declaration Syntax
C# Visual Basic Visual C++
public static int CountParameters(
    Snippet snippet
)
Public Shared Function CountParameters ( _
    snippet As Snippet _
) As Integer
public:
static int CountParameters(
    Snippet^ snippet
)
Parameters
snippet (Snippet)
The snippet.
Return Value
The number of parameters.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


ExtractParameterNames Method (snippet)

ExtractParameterNames Method (snippet)
ScrewTurn Wiki ► ScrewTurn.Wiki ► Snippets ► ExtractParameterNames(Snippet)
Finds the parameters in a snippet.
Declaration Syntax
C# Visual Basic Visual C++
public static string[] ExtractParameterNames(
    Snippet snippet
)
Public Shared Function ExtractParameterNames ( _
    snippet As Snippet _
) As String()
public:
static array<String^>^ ExtractParameterNames(
    Snippet^ snippet
)
Parameters
snippet (Snippet)
The snippet.
Return Value
The parameter names.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


Find Method (name)

Find Method (name)
ScrewTurn Wiki ► ScrewTurn.Wiki ► Snippets ► Find(String)
Finds a Snippet.
Declaration Syntax
C# Visual Basic Visual C++
public static Snippet Find(
    string name
)
Public Shared Function Find ( _
    name As String _
) As Snippet
public:
static Snippet^ Find(
    String^ name
)
Parameters
name (String)
The Name of the Snippet to find.
Return Value
The Snippet or null if it is not found.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


GetSnippets Method

GetSnippets Method
ScrewTurn Wiki ► ScrewTurn.Wiki ► Snippets ► GetSnippets()()()
Gets the complete list of the Snippets.
Declaration Syntax
C# Visual Basic Visual C++
public static List<Snippet> GetSnippets()
Public Shared Function GetSnippets As List(Of Snippet)
public:
static List<Snippet^>^ GetSnippets()
Return Value
The snippets, sorted by name.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


ModifySnippet Method (snippet, content)

ModifySnippet Method (snippet, content)
ScrewTurn Wiki ► ScrewTurn.Wiki ► Snippets ► ModifySnippet(Snippet, String)
Modifies the Content of a Snippet.
Declaration Syntax
C# Visual Basic Visual C++
public static bool ModifySnippet(
    Snippet snippet,
    string content
)
Public Shared Function ModifySnippet ( _
    snippet As Snippet, _
    content As String _
) As Boolean
public:
static bool ModifySnippet(
    Snippet^ snippet,
    String^ content
)
Parameters
snippet (Snippet)
The Snippet to update.
content (String)
The new Content.
Return Value
True if the Snippet has been updated successfully.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


ParametersRegex Field

ParametersRegex Field
ScrewTurn Wiki ► ScrewTurn.Wiki ► Snippets ► ParametersRegex
The regular expression to use for extracting parameters.
Declaration Syntax
C# Visual Basic Visual C++
public static readonly Regex ParametersRegex
Public Shared ReadOnly ParametersRegex As Regex
public:
static initonly Regex^ ParametersRegex

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


RemoveSnippet Method (snippet)

RemoveSnippet Method (snippet)
ScrewTurn Wiki ► ScrewTurn.Wiki ► Snippets ► RemoveSnippet(Snippet)
Removes a Snippet.
Declaration Syntax
C# Visual Basic Visual C++
public static bool RemoveSnippet(
    Snippet snippet
)
Public Shared Function RemoveSnippet ( _
    snippet As Snippet _
) As Boolean
public:
static bool RemoveSnippet(
    Snippet^ snippet
)
Parameters
snippet (Snippet)
The Snippet to remove.
Return Value
True if the Snippet has been removed successfully.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


StartupTools Class

StartupTools Class
ScrewTurn Wiki ► ScrewTurn.Wiki ► StartupTools
Provides tools for starting and shutting down the wiki engine.
Declaration Syntax
C# Visual Basic Visual C++
public static class StartupTools
Public NotInheritable Class StartupTools
public ref class StartupTools abstract sealed
Members
All Members | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | GetSettingsStorageProviderConfiguration()()() | Gets the Settings Storage Provider configuration string from web.config.
 | SetAdministratorsGroupDefaultPermissions(UserGroup) | Sets the default permissions for the administrators group, properly importing version 2.0 values.
 | SetAnonymousGroupDefaultPermissions(UserGroup) | Sets the default permissions for the anonymous users group, properly importing version 2.0 values.
 | SetUsersGroupDefaultPermissions(UserGroup) | Sets the default permissions for the users group, properly importing version 2.0 values.
 | Shutdown()()() | Performs shutdown operations, such as shutting-down Providers.
 | Startup()()() | Performs all needed startup operations.
Inheritance Hierarchy
Object
StartupTools

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


GetSettingsStorageProviderConfiguration Method

GetSettingsStorageProviderConfiguration Method
ScrewTurn Wiki ► ScrewTurn.Wiki ► StartupTools ► GetSettingsStorageProviderConfiguration()()()
Gets the Settings Storage Provider configuration string from web.config.
Declaration Syntax
C# Visual Basic Visual C++
public static string GetSettingsStorageProviderConfiguration()
Public Shared Function GetSettingsStorageProviderConfiguration As String
public:
static String^ GetSettingsStorageProviderConfiguration()
Return Value
The configuration string.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


SetAdministratorsGroupDefaultPermissions Method (administrators)

SetAdministratorsGroupDefaultPermissions Method (administrators)
ScrewTurn Wiki ► ScrewTurn.Wiki ► StartupTools ► SetAdministratorsGroupDefaultPermissions(UserGroup)
Sets the default permissions for the administrators group, properly importing version 2.0 values.
Declaration Syntax
C# Visual Basic Visual C++
public static bool SetAdministratorsGroupDefaultPermissions(
    UserGroup administrators
)
Public Shared Function SetAdministratorsGroupDefaultPermissions ( _
    administrators As UserGroup _
) As Boolean
public:
static bool SetAdministratorsGroupDefaultPermissions(
    UserGroup^ administrators
)
Parameters
administrators (UserGroup)
The administrators group.
Return Value
true if the operation succeeded, false otherwise.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


SetAnonymousGroupDefaultPermissions Method (anonymous)

SetAnonymousGroupDefaultPermissions Method (anonymous)
ScrewTurn Wiki ► ScrewTurn.Wiki ► StartupTools ► SetAnonymousGroupDefaultPermissions(UserGroup)
Sets the default permissions for the anonymous users group, properly importing version 2.0 values.
Declaration Syntax
C# Visual Basic Visual C++
public static bool SetAnonymousGroupDefaultPermissions(
    UserGroup anonymous
)
Public Shared Function SetAnonymousGroupDefaultPermissions ( _
    anonymous As UserGroup _
) As Boolean
public:
static bool SetAnonymousGroupDefaultPermissions(
    UserGroup^ anonymous
)
Parameters
anonymous (UserGroup)
The anonymous users group.
Return Value
true if the operation succeeded, false otherwise.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


SetUsersGroupDefaultPermissions Method (users)

SetUsersGroupDefaultPermissions Method (users)
ScrewTurn Wiki ► ScrewTurn.Wiki ► StartupTools ► SetUsersGroupDefaultPermissions(UserGroup)
Sets the default permissions for the users group, properly importing version 2.0 values.
Declaration Syntax
C# Visual Basic Visual C++
public static bool SetUsersGroupDefaultPermissions(
    UserGroup users
)
Public Shared Function SetUsersGroupDefaultPermissions ( _
    users As UserGroup _
) As Boolean
public:
static bool SetUsersGroupDefaultPermissions(
    UserGroup^ users
)
Parameters
users (UserGroup)
The users group.
Return Value
true if the operation succeeded, false otherwise.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


Shutdown Method

Shutdown Method
ScrewTurn Wiki ► ScrewTurn.Wiki ► StartupTools ► Shutdown()()()
Performs shutdown operations, such as shutting-down Providers.
Declaration Syntax
C# Visual Basic Visual C++
public static void Shutdown()
Public Shared Sub Shutdown
public:
static void Shutdown()

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


Startup Method

Startup Method
ScrewTurn Wiki ► ScrewTurn.Wiki ► StartupTools ► Startup()()()
Performs all needed startup operations.
Declaration Syntax
C# Visual Basic Visual C++
public static void Startup()
Public Shared Sub Startup
public:
static void Startup()

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


SubjectInfo Class

SubjectInfo Class
ScrewTurn Wiki ► ScrewTurn.Wiki ► SubjectInfo
Describes the subject of an ACL entry.
Declaration Syntax
C# Visual Basic Visual C++
public class SubjectInfo
Public Class SubjectInfo
public ref class SubjectInfo
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | SubjectInfo(String, SubjectType) | Initializes a new instance of the SubjectInfo class.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets the name.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | Type | Gets the type.
Inheritance Hierarchy
Object
SubjectInfo

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


SubjectInfo Constructor (name, type)

SubjectInfo Constructor (name, type)
ScrewTurn Wiki ► ScrewTurn.Wiki ► SubjectInfo ► SubjectInfo(String, SubjectType)
Initializes a new instance of the SubjectInfo class.
Declaration Syntax
C# Visual Basic Visual C++
public SubjectInfo(
    string name,
    SubjectType type
)
Public Sub New ( _
    name As String, _
    type As SubjectType _
)
public:
SubjectInfo(
    String^ name,
    SubjectType type
)
Parameters
name (String)
The name.
type (SubjectType)
The type.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


Name Property

Name Property
ScrewTurn Wiki ► ScrewTurn.Wiki ► SubjectInfo ► Name
Gets the name.
Declaration Syntax
C# Visual Basic Visual C++
public string Name { get; }
Public ReadOnly Property Name As String
public:
property String^ Name {
    String^ get ();
}

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


Type Property

Type Property
ScrewTurn Wiki ► ScrewTurn.Wiki ► SubjectInfo ► Type
Gets the type.
Declaration Syntax
C# Visual Basic Visual C++
public SubjectType Type { get; }
Public ReadOnly Property Type As SubjectType
public:
property SubjectType Type {
    SubjectType get ();
}

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


SubjectType Enumeration

SubjectType Enumeration
ScrewTurn Wiki ► ScrewTurn.Wiki ► SubjectType
Lists legal values for the type of a subject.
Declaration Syntax
C# Visual Basic Visual C++
public enum SubjectType
Public Enumeration SubjectType
public enum class SubjectType
Members
Member | Description
User | A user.
Group | A group.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


Tag Class

Tag Class
ScrewTurn Wiki ► ScrewTurn.Wiki ► Tag
Represents an open or close tag.
Declaration Syntax
C# Visual Basic Visual C++
public class Tag
Public Class Tag
public ref class Tag
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | Tag()()() | Initializes a new instance of the Tag class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | Index | Gets or sets the tag index.
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | Type | Gets or sets the tag type.
Inheritance Hierarchy
Object
Tag

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


Tag Constructor

Tag Constructor
ScrewTurn Wiki ► ScrewTurn.Wiki ► Tag ► Tag()()()
Initializes a new instance of the Tag class
Declaration Syntax
C# Visual Basic Visual C++
public Tag()
Public Sub New
public:
Tag()

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


Index Property

Index Property
ScrewTurn Wiki ► ScrewTurn.Wiki ► Tag ► Index
Gets or sets the tag index.
Declaration Syntax
C# Visual Basic Visual C++
public int Index { get; set; }
Public Property Index As Integer
public:
property int Index {
    int get ();
    void set (int value);
}

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


Type Property

Type Property
ScrewTurn Wiki ► ScrewTurn.Wiki ► Tag ► Type
Gets or sets the tag type.
Declaration Syntax
C# Visual Basic Visual C++
public TagType Type { get; set; }
Public Property Type As TagType
public:
property TagType Type {
    TagType get ();
    void set (TagType value);
}

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


TagType Enumeration

TagType Enumeration
ScrewTurn Wiki ► ScrewTurn.Wiki ► TagType
Lists tag types.
Declaration Syntax
C# Visual Basic Visual C++
public enum TagType
Public Enumeration TagType
public enum class TagType
Members
Member | Description
Open | An open tag.
Close | A close tag.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


Templates Class

Templates Class
ScrewTurn Wiki ► ScrewTurn.Wiki ► Templates
Manages content templates.
Declaration Syntax
C# Visual Basic Visual C++
public static class Templates
Public NotInheritable Class Templates
public ref class Templates abstract sealed
Members
All Members | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | AddTemplate(String, String, IPagesStorageProviderV30) | Adds a new content template.
 | Find(String) | Finds a content template.
 | GetTemplates()()() | Gets all the content templates.
 | ModifyTemplate(ContentTemplate, String) | Modifies a content template.
 | RemoveTemplate(ContentTemplate) | Removes a content template.
Inheritance Hierarchy
Object
Templates

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


AddTemplate Method (name, content, provider)

AddTemplate Method (name, content, provider)
ScrewTurn Wiki ► ScrewTurn.Wiki ► Templates ► AddTemplate(String, String, IPagesStorageProviderV30)
Adds a new content template.
Declaration Syntax
C# Visual Basic Visual C++
public static bool AddTemplate(
    string name,
    string content,
    IPagesStorageProviderV30 provider
)
Public Shared Function AddTemplate ( _
    name As String, _
    content As String, _
    provider As IPagesStorageProviderV30 _
) As Boolean
public:
static bool AddTemplate(
    String^ name,
    String^ content,
    IPagesStorageProviderV30^ provider
)
Parameters
name (String)
The name of the template.
content (String)
The content of the template.
provider (IPagesStorageProviderV30)
The target provider (null for the default provider).
Return Value
true if the template is added, false otherwise.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


Find Method (name)

Find Method (name)
ScrewTurn Wiki ► ScrewTurn.Wiki ► Templates ► Find(String)
Finds a content template.
Declaration Syntax
C# Visual Basic Visual C++
public static ContentTemplate Find(
    string name
)
Public Shared Function Find ( _
    name As String _
) As ContentTemplate
public:
static ContentTemplate^ Find(
    String^ name
)
Parameters
name (String)
The name of the template to find.
Return Value
The content template, or null.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


GetTemplates Method

GetTemplates Method
ScrewTurn Wiki ► ScrewTurn.Wiki ► Templates ► GetTemplates()()()
Gets all the content templates.
Declaration Syntax
C# Visual Basic Visual C++
public static List<ContentTemplate> GetTemplates()
Public Shared Function GetTemplates As List(Of ContentTemplate)
public:
static List<ContentTemplate^>^ GetTemplates()
Return Value
The content templates, sorted by name.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


ModifyTemplate Method (template, content)

ModifyTemplate Method (template, content)
ScrewTurn Wiki ► ScrewTurn.Wiki ► Templates ► ModifyTemplate(ContentTemplate, String)
Modifies a content template.
Declaration Syntax
C# Visual Basic Visual C++
public static bool ModifyTemplate(
    ContentTemplate template,
    string content
)
Public Shared Function ModifyTemplate ( _
    template As ContentTemplate, _
    content As String _
) As Boolean
public:
static bool ModifyTemplate(
    ContentTemplate^ template,
    String^ content
)
Parameters
template (ContentTemplate)
The template to modify.
content (String)
The new content of the template.
Return Value
true if the template is modified, false otherwise.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


RemoveTemplate Method (template)

RemoveTemplate Method (template)
ScrewTurn Wiki ► ScrewTurn.Wiki ► Templates ► RemoveTemplate(ContentTemplate)
Removes a content template.
Declaration Syntax
C# Visual Basic Visual C++
public static bool RemoveTemplate(
    ContentTemplate template
)
Public Shared Function RemoveTemplate ( _
    template As ContentTemplate _
) As Boolean
public:
static bool RemoveTemplate(
    ContentTemplate^ template
)
Parameters
template (ContentTemplate)
The template to remove.
Return Value
true if the template is removed, false otherwise.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


Tools Class

Tools Class
ScrewTurn Wiki ► ScrewTurn.Wiki ► Tools
Contains useful Tools.
Declaration Syntax
C# Visual Basic Visual C++
public static class Tools
Public NotInheritable Class Tools
public ref class Tools abstract sealed
Members
All Members | Methods | Properties
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | AvailableCultures | Gets the available Cultures.
 | AvailableThemes | Gets the available Themes.
 | BytesToString(Int64) | Converts a byte number into a string, formatted using KB, MB or GB.
 | ComputeSecurityHash(String, String, DateTime) | Computes the Hash of a Username, mixing it with other data, in order to avoid illegal Account activations.
 | DetectCurrentFullName()()() | Detects the full name of the current page using the Page and NS parameters in the query string.
 | DetectCurrentNamespace()()() | Detects the name of the current namespace using the NS parameter in the query string.
 | DetectCurrentNamespaceInfo()()() | Detects the correct NamespaceInfo object associated to the current namespace using the NS parameter in the query string.
 | DetectCurrentPageInfo(Boolean) | Detects the correct PageInfo object associated to the current page using the Page and NS parameters in the query string.
 | DiskUsage(String) | Computes the Disk Space Usage of a directory.
 | EscapeString(String) | Escapes bad characters in a string (pipes and \n).
 | ExtractDirectoryName(String) | Extracts the directory name from a path used in the Files Storage Providers.
 | GenerateRandomPassword()()() | Generates a random 10-char Password.
 | GetDirectoryName(String) | Gets the name of a file's directory.
 | GetIncludes(String) | Gets all the included files for the HTML Head, such as CSS, JavaScript and Icon pluginAssemblies, for a namespace.
 | GetJavaScriptIncludes()()() | Gets all the JavaScript files to include.
 | GetMessageIdForAnchor(DateTime) | Gets the message ID for HTML anchors.
 | GetUpdateStatus(String, String, String%, String%) | Gets the update status of a component.
 | GetVersionString(Int32) | Generates the standard 5-digit Page Version string.
 | HashDocumentNameForTemporaryIndex(String) | Computes the hash value of a string that is value across application instances and versions.
 | ObfuscateText(String) | Obfuscates text, replacing each character with its HTML escaped sequence, for example a becomes &#97;.
 | RemoveHtmlMarkup(String) | Removes all HTML tags from a text.
 | SystemUptime | Gets the approximate System Uptime.
 | TimeSpanToString(TimeSpan) | Converts a Time Span to string.
 | UnescapeString(String) | Unescapes bad characters in a string (pipes and \n).
 | UrlDecode(String) | Executes URL-decoding, replacing spaces as processed by UrlEncode.
 | UrlEncode(String) | Executes URL-encoding, avoiding to use '+' for spaces.
Inheritance Hierarchy
Object
Tools

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


AvailableCultures Property

AvailableCultures Property
ScrewTurn Wiki ► ScrewTurn.Wiki ► Tools ► AvailableCultures
Gets the available Cultures.
Declaration Syntax
C# Visual Basic Visual C++
public static string[] AvailableCultures { get; }
Public Shared ReadOnly Property AvailableCultures As String()
public:
static property array<String^>^ AvailableCultures {
    array<String^>^ get ();
}

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


AvailableThemes Property

AvailableThemes Property
ScrewTurn Wiki ► ScrewTurn.Wiki ► Tools ► AvailableThemes
Gets the available Themes.
Declaration Syntax
C# Visual Basic Visual C++
public static string[] AvailableThemes { get; }
Public Shared ReadOnly Property AvailableThemes As String()
public:
static property array<String^>^ AvailableThemes {
    array<String^>^ get ();
}

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


BytesToString Method (bytes)

BytesToString Method (bytes)
ScrewTurn Wiki ► ScrewTurn.Wiki ► Tools ► BytesToString(Int64)
Converts a byte number into a string, formatted using KB, MB or GB.
Declaration Syntax
C# Visual Basic Visual C++
public static string BytesToString(
    long bytes
)
Public Shared Function BytesToString ( _
    bytes As Long _
) As String
public:
static String^ BytesToString(
    long long bytes
)
Parameters
bytes (Int64)
The # of bytes.
Return Value
The formatted string.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


ComputeSecurityHash Method (username, email, dateTime)

ComputeSecurityHash Method (username, email, dateTime)
ScrewTurn Wiki ► ScrewTurn.Wiki ► Tools ► ComputeSecurityHash(String, String, DateTime)
Computes the Hash of a Username, mixing it with other data, in order to avoid illegal Account activations.
Declaration Syntax
C# Visual Basic Visual C++
public static string ComputeSecurityHash(
    string username,
    string email,
    DateTime dateTime
)
Public Shared Function ComputeSecurityHash ( _
    username As String, _
    email As String, _
    dateTime As DateTime _
) As String
public:
static String^ ComputeSecurityHash(
    String^ username,
    String^ email,
    DateTime dateTime
)
Parameters
username (String)
The Username.
email (String)
The email.
dateTime (DateTime)
The date/time.
Return Value
The secured Hash of the Username.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


DetectCurrentFullName Method

DetectCurrentFullName Method
ScrewTurn Wiki ► ScrewTurn.Wiki ► Tools ► DetectCurrentFullName()()()
Detects the full name of the current page using the Page and NS parameters in the query string.
Declaration Syntax
C# Visual Basic Visual C++
public static string DetectCurrentFullName()
Public Shared Function DetectCurrentFullName As String
public:
static String^ DetectCurrentFullName()
Return Value
The full name of the page, regardless of the existence of the page.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


DetectCurrentNamespace Method

DetectCurrentNamespace Method
ScrewTurn Wiki ► ScrewTurn.Wiki ► Tools ► DetectCurrentNamespace()()()
Detects the name of the current namespace using the NS parameter in the query string.
Declaration Syntax
C# Visual Basic Visual C++
public static string DetectCurrentNamespace()
Public Shared Function DetectCurrentNamespace As String
public:
static String^ DetectCurrentNamespace()
Return Value
The name of the namespace, or an empty string.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


DetectCurrentNamespaceInfo Method

DetectCurrentNamespaceInfo Method
ScrewTurn Wiki ► ScrewTurn.Wiki ► Tools ► DetectCurrentNamespaceInfo()()()
Detects the correct NamespaceInfo object associated to the current namespace using the NS parameter in the query string.
Declaration Syntax
C# Visual Basic Visual C++
public static NamespaceInfo DetectCurrentNamespaceInfo()
Public Shared Function DetectCurrentNamespaceInfo As NamespaceInfo
public:
static NamespaceInfo^ DetectCurrentNamespaceInfo()
Return Value
The correct NamespaceInfo object, or null.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


DetectCurrentPageInfo Method (loadDefault)

DetectCurrentPageInfo Method (loadDefault)
ScrewTurn Wiki ► ScrewTurn.Wiki ► Tools ► DetectCurrentPageInfo(Boolean)
Detects the correct PageInfo object associated to the current page using the Page and NS parameters in the query string.
Declaration Syntax
C# Visual Basic Visual C++
public static PageInfo DetectCurrentPageInfo(
    bool loadDefault
)
Public Shared Function DetectCurrentPageInfo ( _
    loadDefault As Boolean _
) As PageInfo
public:
static PageInfo^ DetectCurrentPageInfo(
    bool loadDefault
)
Parameters
loadDefault (Boolean)
true to load the default page of the specified namespace when Page is not specified, false otherwise.
Return Value
If Page is specified and exists, the correct PageInfo, otherwise null if loadDefault is false, or the PageInfo object representing the default page of the specified namespace if loadDefault is true.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


DiskUsage Method (dir)

DiskUsage Method (dir)
ScrewTurn Wiki ► ScrewTurn.Wiki ► Tools ► DiskUsage(String)
Computes the Disk Space Usage of a directory.
Declaration Syntax
C# Visual Basic Visual C++
public static long DiskUsage(
    string dir
)
Public Shared Function DiskUsage ( _
    dir As String _
) As Long
public:
static long long DiskUsage(
    String^ dir
)
Parameters
dir (String)
The directory.
Return Value
The used Disk Space, in bytes.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


EscapeString Method (input)

EscapeString Method (input)
ScrewTurn Wiki ► ScrewTurn.Wiki ► Tools ► EscapeString(String)
Escapes bad characters in a string (pipes and \n).
Declaration Syntax
C# Visual Basic Visual C++
public static string EscapeString(
    string input
)
Public Shared Function EscapeString ( _
    input As String _
) As String
public:
static String^ EscapeString(
    String^ input
)
Parameters
input (String)
The input string.
Return Value
The escaped string.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


ExtractDirectoryName Method (path)

ExtractDirectoryName Method (path)
ScrewTurn Wiki ► ScrewTurn.Wiki ► Tools ► ExtractDirectoryName(String)
Extracts the directory name from a path used in the Files Storage Providers.
Declaration Syntax
C# Visual Basic Visual C++
public static string ExtractDirectoryName(
    string path
)
Public Shared Function ExtractDirectoryName ( _
    path As String _
) As String
public:
static String^ ExtractDirectoryName(
    String^ path
)
Parameters
path (String)
The path, for example '/folder/blah/'.
Return Value
The directory name, for example 'blah'.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


GenerateRandomPassword Method

GenerateRandomPassword Method
ScrewTurn Wiki ► ScrewTurn.Wiki ► Tools ► GenerateRandomPassword()()()
Generates a random 10-char Password.
Declaration Syntax
C# Visual Basic Visual C++
public static string GenerateRandomPassword()
Public Shared Function GenerateRandomPassword As String
public:
static String^ GenerateRandomPassword()
Return Value
The Password.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


GetDirectoryName Method (filename)

GetDirectoryName Method (filename)
ScrewTurn Wiki ► ScrewTurn.Wiki ► Tools ► GetDirectoryName(String)
Gets the name of a file's directory.
Declaration Syntax
C# Visual Basic Visual C++
public static string GetDirectoryName(
    string filename
)
Public Shared Function GetDirectoryName ( _
    filename As String _
) As String
public:
static String^ GetDirectoryName(
    String^ filename
)
Parameters
filename (String)
The filename.
Return Value
The name of the item.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


GetIncludes Method (nspace)

GetIncludes Method (nspace)
ScrewTurn Wiki ► ScrewTurn.Wiki ► Tools ► GetIncludes(String)
Gets all the included files for the HTML Head, such as CSS, JavaScript and Icon pluginAssemblies, for a namespace.
Declaration Syntax
C# Visual Basic Visual C++
public static string GetIncludes(
    string nspace
)
Public Shared Function GetIncludes ( _
    nspace As String _
) As String
public:
static String^ GetIncludes(
    String^ nspace
)
Parameters
nspace (String)
The namespace (null for the root).
Return Value
The includes.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


GetJavaScriptIncludes Method

GetJavaScriptIncludes Method
ScrewTurn Wiki ► ScrewTurn.Wiki ► Tools ► GetJavaScriptIncludes()()()
Gets all the JavaScript files to include.
Declaration Syntax
C# Visual Basic Visual C++
public static string GetJavaScriptIncludes()
Public Shared Function GetJavaScriptIncludes As String
public:
static String^ GetJavaScriptIncludes()
Return Value
The JS files.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


GetMessageIdForAnchor Method (messageDateTime)

GetMessageIdForAnchor Method (messageDateTime)
ScrewTurn Wiki ► ScrewTurn.Wiki ► Tools ► GetMessageIdForAnchor(DateTime)
Gets the message ID for HTML anchors.
Declaration Syntax
C# Visual Basic Visual C++
public static string GetMessageIdForAnchor(
    DateTime messageDateTime
)
Public Shared Function GetMessageIdForAnchor ( _
    messageDateTime As DateTime _
) As String
public:
static String^ GetMessageIdForAnchor(
    DateTime messageDateTime
)
Parameters
messageDateTime (DateTime)
The message date/time.
Return Value
The ID.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


GetUpdateStatus Method (url, currentVersion, newVersion, newAssemblyUrl)

GetUpdateStatus Method (url, currentVersion, newVersion, newAssemblyUrl)
ScrewTurn Wiki ► ScrewTurn.Wiki ► Tools ► GetUpdateStatus(String, String, String%, String%)
Gets the update status of a component.
Declaration Syntax
C# Visual Basic Visual C++
public static UpdateStatus GetUpdateStatus(
    string url,
    string currentVersion,
    out string newVersion,
    out string newAssemblyUrl
)
Public Shared Function GetUpdateStatus ( _
    url As String, _
    currentVersion As String, _
    <OutAttribute> ByRef newVersion As String, _
    <OutAttribute> ByRef newAssemblyUrl As String _
) As UpdateStatus
public:
static UpdateStatus GetUpdateStatus(
    String^ url,
    String^ currentVersion,
    [OutAttribute] String^% newVersion,
    [OutAttribute] String^% newAssemblyUrl
)
Parameters
url (String)
The version file URL.
currentVersion (String)
The current version.
newVersion ( String %)
The new version, if any.
newAssemblyUrl ( String %)
The URL of the new assembly, if applicable and available.
Return Value
The update status.
Remarks
This method only works in Full Trust.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


GetVersionString Method (version)

GetVersionString Method (version)
ScrewTurn Wiki ► ScrewTurn.Wiki ► Tools ► GetVersionString(Int32)
Generates the standard 5-digit Page Version string.
Declaration Syntax
C# Visual Basic Visual C++
public static string GetVersionString(
    int version
)
Public Shared Function GetVersionString ( _
    version As Integer _
) As String
public:
static String^ GetVersionString(
    int version
)
Parameters
version (Int32)
The Page version.
Return Value
The 5-digit Version string.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


HashDocumentNameForTemporaryIndex Method (value)

HashDocumentNameForTemporaryIndex Method (value)
ScrewTurn Wiki ► ScrewTurn.Wiki ► Tools ► HashDocumentNameForTemporaryIndex(String)
Computes the hash value of a string that is value across application instances and versions.
Declaration Syntax
C# Visual Basic Visual C++
public static uint HashDocumentNameForTemporaryIndex(
    string value
)
Public Shared Function HashDocumentNameForTemporaryIndex ( _
    value As String _
) As UInteger
public:
static unsigned int HashDocumentNameForTemporaryIndex(
    String^ value
)
Parameters
value (String)
The string to compute the hash of.
Return Value
The hash value.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


ObfuscateText Method (input)

ObfuscateText Method (input)
ScrewTurn Wiki ► ScrewTurn.Wiki ► Tools ► ObfuscateText(String)
Obfuscates text, replacing each character with its HTML escaped sequence, for example a becomes &#97;.
Declaration Syntax
C# Visual Basic Visual C++
public static string ObfuscateText(
    string input
)
Public Shared Function ObfuscateText ( _
    input As String _
) As String
public:
static String^ ObfuscateText(
    String^ input
)
Parameters
input (String)
The input text.
Return Value
The output obfuscated text.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


RemoveHtmlMarkup Method (html)

RemoveHtmlMarkup Method (html)
ScrewTurn Wiki ► ScrewTurn.Wiki ► Tools ► RemoveHtmlMarkup(String)
Removes all HTML tags from a text.
Declaration Syntax
C# Visual Basic Visual C++
public static string RemoveHtmlMarkup(
    string html
)
Public Shared Function RemoveHtmlMarkup ( _
    html As String _
) As String
public:
static String^ RemoveHtmlMarkup(
    String^ html
)
Parameters
html (String)
The input HTML.
Return Value
The extracted plain text.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


SystemUptime Property

SystemUptime Property
ScrewTurn Wiki ► ScrewTurn.Wiki ► Tools ► SystemUptime
Gets the approximate System Uptime.
Declaration Syntax
C# Visual Basic Visual C++
public static TimeSpan SystemUptime { get; }
Public Shared ReadOnly Property SystemUptime As TimeSpan
public:
static property TimeSpan SystemUptime {
    TimeSpan get ();
}

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


TimeSpanToString Method (span)

TimeSpanToString Method (span)
ScrewTurn Wiki ► ScrewTurn.Wiki ► Tools ► TimeSpanToString(TimeSpan)
Converts a Time Span to string.
Declaration Syntax
C# Visual Basic Visual C++
public static string TimeSpanToString(
    TimeSpan span
)
Public Shared Function TimeSpanToString ( _
    span As TimeSpan _
) As String
public:
static String^ TimeSpanToString(
    TimeSpan span
)
Parameters
span (TimeSpan)
The Time Span.
Return Value
The string.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


UnescapeString Method (input)

UnescapeString Method (input)
ScrewTurn Wiki ► ScrewTurn.Wiki ► Tools ► UnescapeString(String)
Unescapes bad characters in a string (pipes and \n).
Declaration Syntax
C# Visual Basic Visual C++
public static string UnescapeString(
    string input
)
Public Shared Function UnescapeString ( _
    input As String _
) As String
public:
static String^ UnescapeString(
    String^ input
)
Parameters
input (String)
The input string.
Return Value
The unescaped string.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


UrlDecode Method (input)

UrlDecode Method (input)
ScrewTurn Wiki ► ScrewTurn.Wiki ► Tools ► UrlDecode(String)
Executes URL-decoding, replacing spaces as processed by UrlEncode.
Declaration Syntax
C# Visual Basic Visual C++
public static string UrlDecode(
    string input
)
Public Shared Function UrlDecode ( _
    input As String _
) As String
public:
static String^ UrlDecode(
    String^ input
)
Parameters
input (String)
The input string.
Return Value
The decoded string.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


UrlEncode Method (input)

UrlEncode Method (input)
ScrewTurn Wiki ► ScrewTurn.Wiki ► Tools ► UrlEncode(String)
Executes URL-encoding, avoiding to use '+' for spaces.
Declaration Syntax
C# Visual Basic Visual C++
public static string UrlEncode(
    string input
)
Public Shared Function UrlEncode ( _
    input As String _
) As String
public:
static String^ UrlEncode(
    String^ input
)
Parameters
input (String)
The input string.
Return Value
The encoded string.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


UpdateStatus Enumeration

UpdateStatus Enumeration
ScrewTurn Wiki ► ScrewTurn.Wiki ► UpdateStatus
Lists legal update statuses.
Declaration Syntax
C# Visual Basic Visual C++
public enum UpdateStatus
Public Enumeration UpdateStatus
public enum class UpdateStatus
Members
Member | Description
Error | Error while retrieving version information.
UpToDate | The component is up-to-date.
NewVersionFound | A new version was found.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


UrlTools Class

UrlTools Class
ScrewTurn Wiki ► ScrewTurn.Wiki ► UrlTools
Implements useful URL-handling tools.
Declaration Syntax
C# Visual Basic Visual C++
public static class UrlTools
Public NotInheritable Class UrlTools
public ref class UrlTools abstract sealed
Members
All Members | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | BuildUrl(array<String>[]()[]) | Builds a URL properly prepending the namespace to the URL.
 | BuildUrl(StringBuilder, array<String>[]()[]) | Builds a URL properly appendind the NS parameter if appropriate.
 | GetCurrentNamespace()()() | Extracts the current namespace from the URL, such as /App/Namespace.Edit.aspx.
 | Redirect(String) | Redirects the current response to the specified URL, properly appending the current namespace if any.
 | Redirect(String, Boolean) | Redirects the current response to the specified URL, appending the current namespace if requested.
 | RedirectHome()()() | Redirects to the default page of the current namespace.
 | RouteCurrentRequest()()() | Properly routes the current virtual request to a physical ASP.NET page.
Inheritance Hierarchy
Object
UrlTools

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


BuildUrl Method

BuildUrl Method
ScrewTurn Wiki ► ScrewTurn.Wiki ► UrlTools ► BuildUrl()()()
Members
Icon | Member | Description
 | BuildUrl(array<String>[]()[]) | Builds a URL properly prepending the namespace to the URL.
 | BuildUrl(StringBuilder, array<String>[]()[]) | Builds a URL properly appendind the NS parameter if appropriate.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


BuildUrl Method (chunks)

BuildUrl Method (chunks)
ScrewTurn Wiki ► ScrewTurn.Wiki ► UrlTools ► BuildUrl(array<String>[]()[])
Builds a URL properly prepending the namespace to the URL.
Declaration Syntax
C# Visual Basic Visual C++
public static string BuildUrl(
    params string[] chunks
)
Public Shared Function BuildUrl ( _
    ParamArray chunks As String() _
) As String
public:
static String^ BuildUrl(
    ... array<String^>^ chunks
)
Parameters
chunks (array< String >[]()[][])
The chunks used to build the URL.
Return Value
The complete URL.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


BuildUrl Method (destination, chunks)

BuildUrl Method (destination, chunks)
ScrewTurn Wiki ► ScrewTurn.Wiki ► UrlTools ► BuildUrl(StringBuilder, array<String>[]()[])
Builds a URL properly appendind the NS parameter if appropriate.
Declaration Syntax
C# Visual Basic Visual C++
public static void BuildUrl(
    StringBuilder destination,
    params string[] chunks
)
Public Shared Sub BuildUrl ( _
    destination As StringBuilder, _
    ParamArray chunks As String() _
)
public:
static void BuildUrl(
    StringBuilder^ destination,
    ... array<String^>^ chunks
)
Parameters
destination (StringBuilder)
The destination StringBuilder.
chunks (array< String >[]()[][])
The chunks to append.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


GetCurrentNamespace Method

GetCurrentNamespace Method
ScrewTurn Wiki ► ScrewTurn.Wiki ► UrlTools ► GetCurrentNamespace()()()
Extracts the current namespace from the URL, such as /App/Namespace.Edit.aspx.
Declaration Syntax
C# Visual Basic Visual C++
public static string GetCurrentNamespace()
Public Shared Function GetCurrentNamespace As String
public:
static String^ GetCurrentNamespace()
Return Value
The current namespace, or an empty string. null if the URL format is not specified.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


Redirect Method

Redirect Method
ScrewTurn Wiki ► ScrewTurn.Wiki ► UrlTools ► Redirect()()()
Members
Icon | Member | Description
 | Redirect(String) | Redirects the current response to the specified URL, properly appending the current namespace if any.
 | Redirect(String, Boolean) | Redirects the current response to the specified URL, appending the current namespace if requested.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


Redirect Method (target)

Redirect Method (target)
ScrewTurn Wiki ► ScrewTurn.Wiki ► UrlTools ► Redirect(String)
Redirects the current response to the specified URL, properly appending the current namespace if any.
Declaration Syntax
C# Visual Basic Visual C++
public static void Redirect(
    string target
)
Public Shared Sub Redirect ( _
    target As String _
)
public:
static void Redirect(
    String^ target
)
Parameters
target (String)
The target URL.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


Redirect Method (target, addNamespace)

Redirect Method (target, addNamespace)
ScrewTurn Wiki ► ScrewTurn.Wiki ► UrlTools ► Redirect(String, Boolean)
Redirects the current response to the specified URL, appending the current namespace if requested.
Declaration Syntax
C# Visual Basic Visual C++
public static void Redirect(
    string target,
    bool addNamespace
)
Public Shared Sub Redirect ( _
    target As String, _
    addNamespace As Boolean _
)
public:
static void Redirect(
    String^ target,
    bool addNamespace
)
Parameters
target (String)
The target URL.
addNamespace (Boolean)
A value indicating whether to add the namespace.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


RedirectHome Method

RedirectHome Method
ScrewTurn Wiki ► ScrewTurn.Wiki ► UrlTools ► RedirectHome()()()
Redirects to the default page of the current namespace.
Declaration Syntax
C# Visual Basic Visual C++
public static void RedirectHome()
Public Shared Sub RedirectHome
public:
static void RedirectHome()

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


RouteCurrentRequest Method

RouteCurrentRequest Method
ScrewTurn Wiki ► ScrewTurn.Wiki ► UrlTools ► RouteCurrentRequest()()()
Properly routes the current virtual request to a physical ASP.NET page.
Declaration Syntax
C# Visual Basic Visual C++
public static void RouteCurrentRequest()
Public Shared Sub RouteCurrentRequest
public:
static void RouteCurrentRequest()

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


Users Class

Users Class
ScrewTurn Wiki ► ScrewTurn.Wiki ► Users
Manages all the User Accounts data.
Declaration Syntax
C# Visual Basic Visual C++
public static class Users
Public NotInheritable Class Users
public ref class Users abstract sealed
Members
All Members | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | AddUser(String, String, String, String, Boolean, IUsersStorageProviderV30) | Adds a new User.
 | AddUserGroup(String, String, IUsersStorageProviderV30) | Adds a new user group to a specific provider.
 | AddUserGroup(String, String) | Adds a new user group to the default provider.
 | ChangeEmail(UserInfo, String) | Changes the Email address of a User.
 | ChangePassword(UserInfo, String) | Changes the Password of a User.
 | ComputeLoginKey(String, String, DateTime) | Copmputes the login key.
 | FindUser(String) | Finds a user.
 | FindUserByEmail(String) | Finds a user by email.
 | FindUserGroup(String) | Finds a user group.
 | GetAdministratorAccount()()() | Gets the built-in administrator account.
 | GetAnonymousAccount()()() | Gets the fake anonymous account.
 | GetDisplayName(UserInfo) | Gets the display name of a user.
 | GetEmailNotification(UserInfo, PageInfo, Boolean%, Boolean%) | Gets the email notification status for a page.
 | GetEmailNotification(UserInfo, NamespaceInfo, Boolean%, Boolean%) | Gets the email notification status for a namespace.
 | GetUserData(UserInfo, String) | Gets user data.
 | GetUserGroups()()() | Gets all the user groups.
 | GetUserGroups(IUsersStorageProviderV30) | Gets all the user groups in a provider.
 | GetUserGroupsForUser(UserInfo) | Gets all the user groups a user is member of.
 | GetUsers()()() | Gets all the Users that the providers declare to manage.
 | GetUsersToNotifyForDiscussionMessages(PageInfo) | Gets all the users that must be notified of a discussion message.
 | GetUsersToNotifyForPageChange(PageInfo) | Gets all the users that must be notified of a page change.
 | ModifyUser(UserInfo, String, String, String, Boolean) | Updates a new User.
 | ModifyUserGroup(UserGroup, String) | Modifies a user group.
 | NotifyLogout(String) | Notifies to the proper provider that a user has logged out.
 | RemoveUser(UserInfo) | Removes a User.
 | RemoveUserGroup(UserGroup) | Removes a user group.
 | SendPasswordResetMessage(String, String, DateTime) | Sends the password reset message to a user.
 | SetActivationStatus(UserInfo, Boolean) | Sets the Active/Inactive status of a User.
 | SetEmailNotification(UserInfo, PageInfo, Boolean, Boolean) | Sets the email notification status for a page.
 | SetEmailNotification(UserInfo, NamespaceInfo, Boolean, Boolean) | Sets the email notification status for a namespace.
 | SetUserData(UserInfo, String, String) | Sets user data.
 | SetUserMembership(UserInfo, array<String>[]()[]) | Sets the group memberships of a user account.
 | TryAutoLogin(HttpContext) | Tries to automatically login a user using the current HttpContext, through any provider that supports the operation.
 | TryCookieLogin(String, String) | Tries to login a user through the cookie-stored authentication data.
 | TryLogin(String, String) | Tries to manually login a user using all the available methods.
 | UserLink(String) | Creates the correct link of a User.
 | UserLink(String, Boolean) | Creates the correct link of a User.
Inheritance Hierarchy
Object
Users

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


AddUser Method (username, displayName, password, email, active, provider)

AddUser Method (username, displayName, password, email, active, provider)
ScrewTurn Wiki ► ScrewTurn.Wiki ► Users ► AddUser(String, String, String, String, Boolean, IUsersStorageProviderV30)
Adds a new User.
Declaration Syntax
C# Visual Basic Visual C++
public static bool AddUser(
    string username,
    string displayName,
    string password,
    string email,
    bool active,
    IUsersStorageProviderV30 provider
)
Public Shared Function AddUser ( _
    username As String, _
    displayName As String, _
    password As String, _
    email As String, _
    active As Boolean, _
    provider As IUsersStorageProviderV30 _
) As Boolean
public:
static bool AddUser(
    String^ username,
    String^ displayName,
    String^ password,
    String^ email,
    bool active,
    IUsersStorageProviderV30^ provider
)
Parameters
username (String)
The Username.
displayName (String)
The display name.
password (String)
The Password (plain text).
email (String)
The Email address.
active (Boolean)
A value specifying whether or not the account is active.
provider (IUsersStorageProviderV30)
The Provider. If null, the default provider is used.
Return Value
True if the User has been created successfully.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


AddUserGroup Method

AddUserGroup Method
ScrewTurn Wiki ► ScrewTurn.Wiki ► Users ► AddUserGroup()()()
Members
Icon | Member | Description
 | AddUserGroup(String, String, IUsersStorageProviderV30) | Adds a new user group to a specific provider.
 | AddUserGroup(String, String) | Adds a new user group to the default provider.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


AddUserGroup Method (name, description)

AddUserGroup Method (name, description)
ScrewTurn Wiki ► ScrewTurn.Wiki ► Users ► AddUserGroup(String, String)
Adds a new user group to the default provider.
Declaration Syntax
C# Visual Basic Visual C++
public static bool AddUserGroup(
    string name,
    string description
)
Public Shared Function AddUserGroup ( _
    name As String, _
    description As String _
) As Boolean
public:
static bool AddUserGroup(
    String^ name,
    String^ description
)
Parameters
name (String)
The name of the group.
description (String)
The description of the group.
Return Value
true if the groups is added, false otherwise.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


AddUserGroup Method (name, description, provider)

AddUserGroup Method (name, description, provider)
ScrewTurn Wiki ► ScrewTurn.Wiki ► Users ► AddUserGroup(String, String, IUsersStorageProviderV30)
Adds a new user group to a specific provider.
Declaration Syntax
C# Visual Basic Visual C++
public static bool AddUserGroup(
    string name,
    string description,
    IUsersStorageProviderV30 provider
)
Public Shared Function AddUserGroup ( _
    name As String, _
    description As String, _
    provider As IUsersStorageProviderV30 _
) As Boolean
public:
static bool AddUserGroup(
    String^ name,
    String^ description,
    IUsersStorageProviderV30^ provider
)
Parameters
name (String)
The name of the group.
description (String)
The description of the group.
provider (IUsersStorageProviderV30)
The target provider.
Return Value
true if the groups is added, false otherwise.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


ChangeEmail Method (user, newEmail)

ChangeEmail Method (user, newEmail)
ScrewTurn Wiki ► ScrewTurn.Wiki ► Users ► ChangeEmail(UserInfo, String)
Changes the Email address of a User.
Declaration Syntax
C# Visual Basic Visual C++
public static bool ChangeEmail(
    UserInfo user,
    string newEmail
)
Public Shared Function ChangeEmail ( _
    user As UserInfo, _
    newEmail As String _
) As Boolean
public:
static bool ChangeEmail(
    UserInfo^ user,
    String^ newEmail
)
Parameters
user (UserInfo)
The User to change the Email address of.
newEmail (String)
The new Email address.
Return Value
true if the Email address has been changed successfully, false otherwise.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


ChangePassword Method (user, newPassword)

ChangePassword Method (user, newPassword)
ScrewTurn Wiki ► ScrewTurn.Wiki ► Users ► ChangePassword(UserInfo, String)
Changes the Password of a User.
Declaration Syntax
C# Visual Basic Visual C++
public static bool ChangePassword(
    UserInfo user,
    string newPassword
)
Public Shared Function ChangePassword ( _
    user As UserInfo, _
    newPassword As String _
) As Boolean
public:
static bool ChangePassword(
    UserInfo^ user,
    String^ newPassword
)
Parameters
user (UserInfo)
The User to change the password of.
newPassword (String)
The new Password (plain text).
Return Value
true if the Password has been changed successfully, false otherwise.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


ComputeLoginKey Method (username, email, dateTime)

ComputeLoginKey Method (username, email, dateTime)
ScrewTurn Wiki ► ScrewTurn.Wiki ► Users ► ComputeLoginKey(String, String, DateTime)
Copmputes the login key.
Declaration Syntax
C# Visual Basic Visual C++
public static string ComputeLoginKey(
    string username,
    string email,
    DateTime dateTime
)
Public Shared Function ComputeLoginKey ( _
    username As String, _
    email As String, _
    dateTime As DateTime _
) As String
public:
static String^ ComputeLoginKey(
    String^ username,
    String^ email,
    DateTime dateTime
)
Parameters
username (String)
The username.
email (String)
The email.
dateTime (DateTime)
The registration date/time.
Return Value
The login key.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


FindUser Method (username)

FindUser Method (username)
ScrewTurn Wiki ► ScrewTurn.Wiki ► Users ► FindUser(String)
Finds a user.
Declaration Syntax
C# Visual Basic Visual C++
public static UserInfo FindUser(
    string username
)
Public Shared Function FindUser ( _
    username As String _
) As UserInfo
public:
static UserInfo^ FindUser(
    String^ username
)
Parameters
username (String)
The username.
Return Value
The user, or null.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


FindUserByEmail Method (email)

FindUserByEmail Method (email)
ScrewTurn Wiki ► ScrewTurn.Wiki ► Users ► FindUserByEmail(String)
Finds a user by email.
Declaration Syntax
C# Visual Basic Visual C++
public static UserInfo FindUserByEmail(
    string email
)
Public Shared Function FindUserByEmail ( _
    email As String _
) As UserInfo
public:
static UserInfo^ FindUserByEmail(
    String^ email
)
Parameters
email (String)
The email address.
Return Value
The user, or null.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


FindUserGroup Method (name)

FindUserGroup Method (name)
ScrewTurn Wiki ► ScrewTurn.Wiki ► Users ► FindUserGroup(String)
Finds a user group.
Declaration Syntax
C# Visual Basic Visual C++
public static UserGroup FindUserGroup(
    string name
)
Public Shared Function FindUserGroup ( _
    name As String _
) As UserGroup
public:
static UserGroup^ FindUserGroup(
    String^ name
)
Parameters
name (String)
The name of the user group to find.
Return Value
The UserGroup object or null if no data is found.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


GetAdministratorAccount Method

GetAdministratorAccount Method
ScrewTurn Wiki ► ScrewTurn.Wiki ► Users ► GetAdministratorAccount()()()
Gets the built-in administrator account.
Declaration Syntax
C# Visual Basic Visual C++
public static UserInfo GetAdministratorAccount()
Public Shared Function GetAdministratorAccount As UserInfo
public:
static UserInfo^ GetAdministratorAccount()
Return Value
The account.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


GetAnonymousAccount Method

GetAnonymousAccount Method
ScrewTurn Wiki ► ScrewTurn.Wiki ► Users ► GetAnonymousAccount()()()
Gets the fake anonymous account.
Declaration Syntax
C# Visual Basic Visual C++
public static UserInfo GetAnonymousAccount()
Public Shared Function GetAnonymousAccount As UserInfo
public:
static UserInfo^ GetAnonymousAccount()
Return Value
The account.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


GetDisplayName Method (user)

GetDisplayName Method (user)
ScrewTurn Wiki ► ScrewTurn.Wiki ► Users ► GetDisplayName(UserInfo)
Gets the display name of a user.
Declaration Syntax
C# Visual Basic Visual C++
public static string GetDisplayName(
    UserInfo user
)
Public Shared Function GetDisplayName ( _
    user As UserInfo _
) As String
public:
static String^ GetDisplayName(
    UserInfo^ user
)
Parameters
user (UserInfo)
The user.
Return Value
The display name.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


GetEmailNotification Method

GetEmailNotification Method
ScrewTurn Wiki ► ScrewTurn.Wiki ► Users ► GetEmailNotification()()()
Members
Icon | Member | Description
 | GetEmailNotification(UserInfo, PageInfo, Boolean%, Boolean%) | Gets the email notification status for a page.
 | GetEmailNotification(UserInfo, NamespaceInfo, Boolean%, Boolean%) | Gets the email notification status for a namespace.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


GetEmailNotification Method (user, nspace, pageChanges, discussionMessages)

GetEmailNotification Method (user, nspace, pageChanges, discussionMessages)
ScrewTurn Wiki ► ScrewTurn.Wiki ► Users ► GetEmailNotification(UserInfo, NamespaceInfo, Boolean%, Boolean%)
Gets the email notification status for a namespace.
Declaration Syntax
C# Visual Basic Visual C++
public static void GetEmailNotification(
    UserInfo user,
    NamespaceInfo nspace,
    out bool pageChanges,
    out bool discussionMessages
)
Public Shared Sub GetEmailNotification ( _
    user As UserInfo, _
    nspace As NamespaceInfo, _
    <OutAttribute> ByRef pageChanges As Boolean, _
    <OutAttribute> ByRef discussionMessages As Boolean _
)
public:
static void GetEmailNotification(
    UserInfo^ user,
    NamespaceInfo^ nspace,
    [OutAttribute] bool% pageChanges,
    [OutAttribute] bool% discussionMessages
)
Parameters
user (UserInfo)
The user for which to get the notification status.
nspace (NamespaceInfo)
The namespace subject of the notification (null for the root).
pageChanges ( Boolean %)
A value indicating whether page changes should be notified.
discussionMessages ( Boolean %)
A value indicating whether discussion messages should be notified.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


GetEmailNotification Method (user, page, pageChanges, discussionMessages)

GetEmailNotification Method (user, page, pageChanges, discussionMessages)
ScrewTurn Wiki ► ScrewTurn.Wiki ► Users ► GetEmailNotification(UserInfo, PageInfo, Boolean%, Boolean%)
Gets the email notification status for a page.
Declaration Syntax
C# Visual Basic Visual C++
public static void GetEmailNotification(
    UserInfo user,
    PageInfo page,
    out bool pageChanges,
    out bool discussionMessages
)
Public Shared Sub GetEmailNotification ( _
    user As UserInfo, _
    page As PageInfo, _
    <OutAttribute> ByRef pageChanges As Boolean, _
    <OutAttribute> ByRef discussionMessages As Boolean _
)
public:
static void GetEmailNotification(
    UserInfo^ user,
    PageInfo^ page,
    [OutAttribute] bool% pageChanges,
    [OutAttribute] bool% discussionMessages
)
Parameters
user (UserInfo)
The user for which to get the notification status.
page (PageInfo)
The page subject of the notification.
pageChanges ( Boolean %)
A value indicating whether page changes should be notified.
discussionMessages ( Boolean %)
A value indicating whether discussion messages should be notified.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


GetUserData Method (user, key)

GetUserData Method (user, key)
ScrewTurn Wiki ► ScrewTurn.Wiki ► Users ► GetUserData(UserInfo, String)
Gets user data.
Declaration Syntax
C# Visual Basic Visual C++
public static string GetUserData(
    UserInfo user,
    string key
)
Public Shared Function GetUserData ( _
    user As UserInfo, _
    key As String _
) As String
public:
static String^ GetUserData(
    UserInfo^ user,
    String^ key
)
Parameters
user (UserInfo)
The user.
key (String)
The data key.
Return Value
The data, or null if either the user or the key is not found.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


GetUserGroups Method

GetUserGroups Method
ScrewTurn Wiki ► ScrewTurn.Wiki ► Users ► GetUserGroups()()()
Members
Icon | Member | Description
 | GetUserGroups()()() | Gets all the user groups.
 | GetUserGroups(IUsersStorageProviderV30) | Gets all the user groups in a provider.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


GetUserGroups Method

GetUserGroups Method
ScrewTurn Wiki ► ScrewTurn.Wiki ► Users ► GetUserGroups()()()
Gets all the user groups.
Declaration Syntax
C# Visual Basic Visual C++
public static List<UserGroup> GetUserGroups()
Public Shared Function GetUserGroups As List(Of UserGroup)
public:
static List<UserGroup^>^ GetUserGroups()
Return Value
All the user groups, sorted by name.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


GetUserGroups Method (provider)

GetUserGroups Method (provider)
ScrewTurn Wiki ► ScrewTurn.Wiki ► Users ► GetUserGroups(IUsersStorageProviderV30)
Gets all the user groups in a provider.
Declaration Syntax
C# Visual Basic Visual C++
public static List<UserGroup> GetUserGroups(
    IUsersStorageProviderV30 provider
)
Public Shared Function GetUserGroups ( _
    provider As IUsersStorageProviderV30 _
) As List(Of UserGroup)
public:
static List<UserGroup^>^ GetUserGroups(
    IUsersStorageProviderV30^ provider
)
Parameters
provider (IUsersStorageProviderV30)
The provider.
Return Value
The user groups, sorted by name.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


GetUserGroupsForUser Method (user)

GetUserGroupsForUser Method (user)
ScrewTurn Wiki ► ScrewTurn.Wiki ► Users ► GetUserGroupsForUser(UserInfo)
Gets all the user groups a user is member of.
Declaration Syntax
C# Visual Basic Visual C++
public static List<UserGroup> GetUserGroupsForUser(
    UserInfo user
)
Public Shared Function GetUserGroupsForUser ( _
    user As UserInfo _
) As List(Of UserGroup)
public:
static List<UserGroup^>^ GetUserGroupsForUser(
    UserInfo^ user
)
Parameters
user (UserInfo)
The user.
Return Value
All the user groups the user is member of, sorted by name.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


GetUsers Method

GetUsers Method
ScrewTurn Wiki ► ScrewTurn.Wiki ► Users ► GetUsers()()()
Gets all the Users that the providers declare to manage.
Declaration Syntax
C# Visual Basic Visual C++
public static List<UserInfo> GetUsers()
Public Shared Function GetUsers As List(Of UserInfo)
public:
static List<UserInfo^>^ GetUsers()
Return Value
The users, sorted by username.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


GetUsersToNotifyForDiscussionMessages Method (page)

GetUsersToNotifyForDiscussionMessages Method (page)
ScrewTurn Wiki ► ScrewTurn.Wiki ► Users ► GetUsersToNotifyForDiscussionMessages(PageInfo)
Gets all the users that must be notified of a discussion message.
Declaration Syntax
C# Visual Basic Visual C++
public static UserInfo[] GetUsersToNotifyForDiscussionMessages(
    PageInfo page
)
Public Shared Function GetUsersToNotifyForDiscussionMessages ( _
    page As PageInfo _
) As UserInfo()
public:
static array<UserInfo^>^ GetUsersToNotifyForDiscussionMessages(
    PageInfo^ page
)
Parameters
page (PageInfo)
The page.
Return Value
The users to be notified.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


GetUsersToNotifyForPageChange Method (page)

GetUsersToNotifyForPageChange Method (page)
ScrewTurn Wiki ► ScrewTurn.Wiki ► Users ► GetUsersToNotifyForPageChange(PageInfo)
Gets all the users that must be notified of a page change.
Declaration Syntax
C# Visual Basic Visual C++
public static UserInfo[] GetUsersToNotifyForPageChange(
    PageInfo page
)
Public Shared Function GetUsersToNotifyForPageChange ( _
    page As PageInfo _
) As UserInfo()
public:
static array<UserInfo^>^ GetUsersToNotifyForPageChange(
    PageInfo^ page
)
Parameters
page (PageInfo)
The page.
Return Value
The users to be notified.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


ModifyUser Method (user, displayName, password, email, active)

ModifyUser Method (user, displayName, password, email, active)
ScrewTurn Wiki ► ScrewTurn.Wiki ► Users ► ModifyUser(UserInfo, String, String, String, Boolean)
Updates a new User.
Declaration Syntax
C# Visual Basic Visual C++
public static bool ModifyUser(
    UserInfo user,
    string displayName,
    string password,
    string email,
    bool active
)
Public Shared Function ModifyUser ( _
    user As UserInfo, _
    displayName As String, _
    password As String, _
    email As String, _
    active As Boolean _
) As Boolean
public:
static bool ModifyUser(
    UserInfo^ user,
    String^ displayName,
    String^ password,
    String^ email,
    bool active
)
Parameters
user (UserInfo)
The user to modify.
displayName (String)
The display name.
password (String)
The Password (plain text, null or empty for no change).
email (String)
The Email address.
active (Boolean)
A value specifying whether or not the account is active.
Return Value
True if the User has been created successfully.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


ModifyUserGroup Method (group, description)

ModifyUserGroup Method (group, description)
ScrewTurn Wiki ► ScrewTurn.Wiki ► Users ► ModifyUserGroup(UserGroup, String)
Modifies a user group.
Declaration Syntax
C# Visual Basic Visual C++
public static bool ModifyUserGroup(
    UserGroup group,
    string description
)
Public Shared Function ModifyUserGroup ( _
    group As UserGroup, _
    description As String _
) As Boolean
public:
static bool ModifyUserGroup(
    UserGroup^ group,
    String^ description
)
Parameters
group (UserGroup)
The user group to modify.
description (String)
The new description.
Return Value
true if the user group is modified, false otherwise.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


NotifyLogout Method (username)

NotifyLogout Method (username)
ScrewTurn Wiki ► ScrewTurn.Wiki ► Users ► NotifyLogout(String)
Notifies to the proper provider that a user has logged out.
Declaration Syntax
C# Visual Basic Visual C++
public static void NotifyLogout(
    string username
)
Public Shared Sub NotifyLogout ( _
    username As String _
)
public:
static void NotifyLogout(
    String^ username
)
Parameters
username (String)
The username.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


RemoveUser Method (user)

RemoveUser Method (user)
ScrewTurn Wiki ► ScrewTurn.Wiki ► Users ► RemoveUser(UserInfo)
Removes a User.
Declaration Syntax
C# Visual Basic Visual C++
public static bool RemoveUser(
    UserInfo user
)
Public Shared Function RemoveUser ( _
    user As UserInfo _
) As Boolean
public:
static bool RemoveUser(
    UserInfo^ user
)
Parameters
user (UserInfo)
The User to remove.
Return Value
True if the User has been removed successfully.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


RemoveUserGroup Method (group)

RemoveUserGroup Method (group)
ScrewTurn Wiki ► ScrewTurn.Wiki ► Users ► RemoveUserGroup(UserGroup)
Removes a user group.
Declaration Syntax
C# Visual Basic Visual C++
public static bool RemoveUserGroup(
    UserGroup group
)
Public Shared Function RemoveUserGroup ( _
    group As UserGroup _
) As Boolean
public:
static bool RemoveUserGroup(
    UserGroup^ group
)
Parameters
group (UserGroup)
The user group to remove.
Return Value
true if the user group is removed, false otherwise.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


SendPasswordResetMessage Method (username, email, dateTime)

SendPasswordResetMessage Method (username, email, dateTime)
ScrewTurn Wiki ► ScrewTurn.Wiki ► Users ► SendPasswordResetMessage(String, String, DateTime)
Sends the password reset message to a user.
Declaration Syntax
C# Visual Basic Visual C++
public static void SendPasswordResetMessage(
    string username,
    string email,
    DateTime dateTime
)
Public Shared Sub SendPasswordResetMessage ( _
    username As String, _
    email As String, _
    dateTime As DateTime _
)
public:
static void SendPasswordResetMessage(
    String^ username,
    String^ email,
    DateTime dateTime
)
Parameters
username (String)
The username.
email (String)
The email.
dateTime (DateTime)
The user registration date/time.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


SetActivationStatus Method (user, active)

SetActivationStatus Method (user, active)
ScrewTurn Wiki ► ScrewTurn.Wiki ► Users ► SetActivationStatus(UserInfo, Boolean)
Sets the Active/Inactive status of a User.
Declaration Syntax
C# Visual Basic Visual C++
public static bool SetActivationStatus(
    UserInfo user,
    bool active
)
Public Shared Function SetActivationStatus ( _
    user As UserInfo, _
    active As Boolean _
) As Boolean
public:
static bool SetActivationStatus(
    UserInfo^ user,
    bool active
)
Parameters
user (UserInfo)
The User.
active (Boolean)
The status.
Return Value
True if the User's status has been changed successfully.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


SetEmailNotification Method

SetEmailNotification Method
ScrewTurn Wiki ► ScrewTurn.Wiki ► Users ► SetEmailNotification()()()
Members
Icon | Member | Description
 | SetEmailNotification(UserInfo, PageInfo, Boolean, Boolean) | Sets the email notification status for a page.
 | SetEmailNotification(UserInfo, NamespaceInfo, Boolean, Boolean) | Sets the email notification status for a namespace.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


SetEmailNotification Method (user, nspace, pageChanges, discussionMessages)

SetEmailNotification Method (user, nspace, pageChanges, discussionMessages)
ScrewTurn Wiki ► ScrewTurn.Wiki ► Users ► SetEmailNotification(UserInfo, NamespaceInfo, Boolean, Boolean)
Sets the email notification status for a namespace.
Declaration Syntax
C# Visual Basic Visual C++
public static bool SetEmailNotification(
    UserInfo user,
    NamespaceInfo nspace,
    bool pageChanges,
    bool discussionMessages
)
Public Shared Function SetEmailNotification ( _
    user As UserInfo, _
    nspace As NamespaceInfo, _
    pageChanges As Boolean, _
    discussionMessages As Boolean _
) As Boolean
public:
static bool SetEmailNotification(
    UserInfo^ user,
    NamespaceInfo^ nspace,
    bool pageChanges,
    bool discussionMessages
)
Parameters
user (UserInfo)
The user for which to set the notification status.
nspace (NamespaceInfo)
The namespace subject of the notification.
pageChanges (Boolean)
A value indicating whether page changes should be notified.
discussionMessages (Boolean)
A value indicating whether discussion messages should be notified.
Return Value
true if the notification is set, false otherwise.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


SetEmailNotification Method (user, page, pageChanges, discussionMessages)

SetEmailNotification Method (user, page, pageChanges, discussionMessages)
ScrewTurn Wiki ► ScrewTurn.Wiki ► Users ► SetEmailNotification(UserInfo, PageInfo, Boolean, Boolean)
Sets the email notification status for a page.
Declaration Syntax
C# Visual Basic Visual C++
public static bool SetEmailNotification(
    UserInfo user,
    PageInfo page,
    bool pageChanges,
    bool discussionMessages
)
Public Shared Function SetEmailNotification ( _
    user As UserInfo, _
    page As PageInfo, _
    pageChanges As Boolean, _
    discussionMessages As Boolean _
) As Boolean
public:
static bool SetEmailNotification(
    UserInfo^ user,
    PageInfo^ page,
    bool pageChanges,
    bool discussionMessages
)
Parameters
user (UserInfo)
The user for which to set the notification status.
page (PageInfo)
The page subject of the notification.
pageChanges (Boolean)
A value indicating whether page changes should be notified.
discussionMessages (Boolean)
A value indicating whether discussion messages should be notified.
Return Value
true if the notification is set, false otherwise.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


SetUserData Method (user, key, data)

SetUserData Method (user, key, data)
ScrewTurn Wiki ► ScrewTurn.Wiki ► Users ► SetUserData(UserInfo, String, String)
Sets user data.
Declaration Syntax
C# Visual Basic Visual C++
public static bool SetUserData(
    UserInfo user,
    string key,
    string data
)
Public Shared Function SetUserData ( _
    user As UserInfo, _
    key As String, _
    data As String _
) As Boolean
public:
static bool SetUserData(
    UserInfo^ user,
    String^ key,
    String^ data
)
Parameters
user (UserInfo)
The user.
key (String)
The data key.
data (String)
The data value.
Return Value
true if the data is stored, false otherwise.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


SetUserMembership Method (user, groups)

SetUserMembership Method (user, groups)
ScrewTurn Wiki ► ScrewTurn.Wiki ► Users ► SetUserMembership(UserInfo, array<String>[]()[])
Sets the group memberships of a user account.
Declaration Syntax
C# Visual Basic Visual C++
public static bool SetUserMembership(
    UserInfo user,
    string[] groups
)
Public Shared Function SetUserMembership ( _
    user As UserInfo, _
    groups As String() _
) As Boolean
public:
static bool SetUserMembership(
    UserInfo^ user,
    array<String^>^ groups
)
Parameters
user (UserInfo)
The user account.
groups (array< String >[]()[][])
The groups the user account is member of.
Return Value
true if the membership is set, false otherwise.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


TryAutoLogin Method (context)

TryAutoLogin Method (context)
ScrewTurn Wiki ► ScrewTurn.Wiki ► Users ► TryAutoLogin(HttpContext)
Tries to automatically login a user using the current HttpContext, through any provider that supports the operation.
Declaration Syntax
C# Visual Basic Visual C++
public static UserInfo TryAutoLogin(
    HttpContext context
)
Public Shared Function TryAutoLogin ( _
    context As HttpContext _
) As UserInfo
public:
static UserInfo^ TryAutoLogin(
    HttpContext^ context
)
Parameters
context (HttpContext)
The current HttpContext.
Return Value
The correct UserInfo, or null.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


TryCookieLogin Method (username, loginKey)

TryCookieLogin Method (username, loginKey)
ScrewTurn Wiki ► ScrewTurn.Wiki ► Users ► TryCookieLogin(String, String)
Tries to login a user through the cookie-stored authentication data.
Declaration Syntax
C# Visual Basic Visual C++
public static UserInfo TryCookieLogin(
    string username,
    string loginKey
)
Public Shared Function TryCookieLogin ( _
    username As String, _
    loginKey As String _
) As UserInfo
public:
static UserInfo^ TryCookieLogin(
    String^ username,
    String^ loginKey
)
Parameters
username (String)
The username.
loginKey (String)
The login key.
Return Value
The correct UserInfo object, or null.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


TryLogin Method (username, password)

TryLogin Method (username, password)
ScrewTurn Wiki ► ScrewTurn.Wiki ► Users ► TryLogin(String, String)
Tries to manually login a user using all the available methods.
Declaration Syntax
C# Visual Basic Visual C++
public static UserInfo TryLogin(
    string username,
    string password
)
Public Shared Function TryLogin ( _
    username As String, _
    password As String _
) As UserInfo
public:
static UserInfo^ TryLogin(
    String^ username,
    String^ password
)
Parameters
username (String)
The username.
password (String)
The password.
Return Value
The correct UserInfo, or null.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


UserLink Method

UserLink Method
ScrewTurn Wiki ► ScrewTurn.Wiki ► Users ► UserLink()()()
Members
Icon | Member | Description
 | UserLink(String) | Creates the correct link of a User.
 | UserLink(String, Boolean) | Creates the correct link of a User.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


UserLink Method (username)

UserLink Method (username)
ScrewTurn Wiki ► ScrewTurn.Wiki ► Users ► UserLink(String)
Creates the correct link of a User.
Declaration Syntax
C# Visual Basic Visual C++
public static string UserLink(
    string username
)
Public Shared Function UserLink ( _
    username As String _
) As String
public:
static String^ UserLink(
    String^ username
)
Parameters
username (String)
The Username.
Return Value
The User link.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


UserLink Method (username, newWindow)

UserLink Method (username, newWindow)
ScrewTurn Wiki ► ScrewTurn.Wiki ► Users ► UserLink(String, Boolean)
Creates the correct link of a User.
Declaration Syntax
C# Visual Basic Visual C++
public static string UserLink(
    string username,
    bool newWindow
)
Public Shared Function UserLink ( _
    username As String, _
    newWindow As Boolean _
) As String
public:
static String^ UserLink(
    String^ username,
    bool newWindow
)
Parameters
username (String)
The Username.
newWindow (Boolean)
A value indicating whether to open the link in a new window.
Return Value
The User link.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


UsersStorageProvider Class

UsersStorageProvider Class
ScrewTurn Wiki ► ScrewTurn.Wiki ► UsersStorageProvider
Implements a Users Storage Provider.
Declaration Syntax
C# Visual Basic Visual C++
public class UsersStorageProvider : IUsersStorageProviderV30,
    IProviderV30
Public Class UsersStorageProvider _
    Implements IUsersStorageProviderV30, IProviderV30
public ref class UsersStorageProvider : IUsersStorageProviderV30,
    IProviderV30
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | UsersStorageProvider()()() | Initializes a new instance of the UsersStorageProvider class
 | AddUser(String, String, String, String, Boolean, DateTime) | Adds a new User.
 | AddUserGroup(String, String) | Adds a new user group.
 | ConfigHelpHtml | Gets a brief summary of the configuration string format, in HTML. Returns null if no configuration is needed.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetUser(String) | Tries to retrieve the information about a user account.
 | GetUserByEmail(String) | Tries to retrieve the information about a user account.
 | GetUserGroups()()() | Gets all the user groups.
 | GetUsers()()() | Gets the complete list of Users.
 | GetUsersWithData(String) | Gets all the users that have the specified element in their data.
 | GroupMembershipReadOnly | Gets a value indicating whether group membership is read-only (if UserAccountsReadOnly is false, then this property must be false). If this property is true, the provider should return membership data compatible with default user groups.
 | Information | Gets the Information about the Provider.
 | Init(IHostV30, String) | Initializes the Provider.
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ModifyUser(UserInfo, String, String, String, Boolean) | Modifies a User.
 | ModifyUserGroup(UserGroup, String) | Modifies a user group.
 | NotifyCookieLogin(UserInfo) | Notifies the provider that a user has logged in through the authentication cookie.
 | NotifyLogout(UserInfo) | Notifies the provider that a user has logged out.
 | RemoveUser(UserInfo) | Removes a User.
 | RemoveUserGroup(UserGroup) | Removes a user group.
 | RetrieveAllUserData(UserInfo) | Retrieves all the user data elements for a user.
 | RetrieveUserData(UserInfo, String) | Gets a user data element, if any.
 | SetUserMembership(UserInfo, array<String>[]()[]) | Sets the group memberships of a user account.
 | Shutdown()()() | Method invoked on shutdown.
 | StoreUserData(UserInfo, String, String) | Stores a user data element, overwriting the previous one if present.
 | TestAccount(UserInfo, String) | Tests a Password for a User account.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | TryAutoLogin(HttpContext) | Tries to login a user directly through the provider using the current HttpContext and without username/password.
 | TryManualLogin(String, String) | Tries to login a user directly through the provider.
 | UserAccountsReadOnly | Gets a value indicating whether user accounts are read-only.
 | UserGroupsReadOnly | Gets a value indicating whether user groups are read-only. If so, the provider should support default user groups as defined in the wiki configuration.
 | UsersDataReadOnly | Gets a value indicating whether users' data is read-only.
Inheritance Hierarchy
Object
UsersStorageProvider

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


UsersStorageProvider Constructor

UsersStorageProvider Constructor
ScrewTurn Wiki ► ScrewTurn.Wiki ► UsersStorageProvider ► UsersStorageProvider()()()
Initializes a new instance of the UsersStorageProvider class
Declaration Syntax
C# Visual Basic Visual C++
public UsersStorageProvider()
Public Sub New
public:
UsersStorageProvider()

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


AddUser Method (username, displayName, password, email, active, dateTime)

AddUser Method (username, displayName, password, email, active, dateTime)
ScrewTurn Wiki ► ScrewTurn.Wiki ► UsersStorageProvider ► AddUser(String, String, String, String, Boolean, DateTime)
Adds a new User.
Declaration Syntax
C# Visual Basic Visual C++
public UserInfo AddUser(
    string username,
    string displayName,
    string password,
    string email,
    bool active,
    DateTime dateTime
)
Public Function AddUser ( _
    username As String, _
    displayName As String, _
    password As String, _
    email As String, _
    active As Boolean, _
    dateTime As DateTime _
) As UserInfo
public:
virtual UserInfo^ AddUser(
    String^ username,
    String^ displayName,
    String^ password,
    String^ email,
    bool active,
    DateTime dateTime
) sealed
Parameters
username (String)
The Username.
displayName (String)
The display name (can be null).
password (String)
The Password.
email (String)
The Email address.
active (Boolean)
A value specifying whether or not the account is active.
dateTime (DateTime)
The Account creation Date/Time.
Return Value
The correct UserInfo object or null.
Exceptions
Exception | Condition
ArgumentNullException | If username, password or email are null.
ArgumentException | If username, password or email are empty.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


AddUserGroup Method (name, description)

AddUserGroup Method (name, description)
ScrewTurn Wiki ► ScrewTurn.Wiki ► UsersStorageProvider ► AddUserGroup(String, String)
Adds a new user group.
Declaration Syntax
C# Visual Basic Visual C++
public UserGroup AddUserGroup(
    string name,
    string description
)
Public Function AddUserGroup ( _
    name As String, _
    description As String _
) As UserGroup
public:
virtual UserGroup^ AddUserGroup(
    String^ name,
    String^ description
) sealed
Parameters
name (String)
The name of the group.
description (String)
The description of the group.
Return Value
The correct UserGroup object or null.
Exceptions
Exception | Condition
ArgumentNullException | If name or description are null.
ArgumentException | If name is empty.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


ConfigHelpHtml Property

ConfigHelpHtml Property
ScrewTurn Wiki ► ScrewTurn.Wiki ► UsersStorageProvider ► ConfigHelpHtml
Gets a brief summary of the configuration string format, in HTML. Returns null if no configuration is needed.
Declaration Syntax
C# Visual Basic Visual C++
public string ConfigHelpHtml { get; }
Public ReadOnly Property ConfigHelpHtml As String
public:
virtual property String^ ConfigHelpHtml {
    String^ get () sealed;
}

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


GetUser Method (username)

GetUser Method (username)
ScrewTurn Wiki ► ScrewTurn.Wiki ► UsersStorageProvider ► GetUser(String)
Tries to retrieve the information about a user account.
Declaration Syntax
C# Visual Basic Visual C++
public UserInfo GetUser(
    string username
)
Public Function GetUser ( _
    username As String _
) As UserInfo
public:
virtual UserInfo^ GetUser(
    String^ username
) sealed
Parameters
username (String)
The username.
Return Value
The correct UserInfo object, or null.
Exceptions
Exception | Condition
ArgumentNullException | If username is null.
ArgumentException | If username is empty.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


GetUserByEmail Method (email)

GetUserByEmail Method (email)
ScrewTurn Wiki ► ScrewTurn.Wiki ► UsersStorageProvider ► GetUserByEmail(String)
Tries to retrieve the information about a user account.
Declaration Syntax
C# Visual Basic Visual C++
public UserInfo GetUserByEmail(
    string email
)
Public Function GetUserByEmail ( _
    email As String _
) As UserInfo
public:
virtual UserInfo^ GetUserByEmail(
    String^ email
) sealed
Parameters
email (String)
The email address.
Return Value
The first user found with the specified email address, or null.
Exceptions
Exception | Condition
ArgumentNullException | If email is null.
ArgumentException | If email is empty.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


GetUserGroups Method

GetUserGroups Method
ScrewTurn Wiki ► ScrewTurn.Wiki ► UsersStorageProvider ► GetUserGroups()()()
Gets all the user groups.
Declaration Syntax
C# Visual Basic Visual C++
public UserGroup[] GetUserGroups()
Public Function GetUserGroups As UserGroup()
public:
virtual array<UserGroup^>^ GetUserGroups() sealed
Return Value
All the groups, sorted by name.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


GetUsers Method

GetUsers Method
ScrewTurn Wiki ► ScrewTurn.Wiki ► UsersStorageProvider ► GetUsers()()()
Gets the complete list of Users.
Declaration Syntax
C# Visual Basic Visual C++
public UserInfo[] GetUsers()
Public Function GetUsers As UserInfo()
public:
virtual array<UserInfo^>^ GetUsers() sealed
Return Value
All the Users, sorted by username.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


GetUsersWithData Method (key)

GetUsersWithData Method (key)
ScrewTurn Wiki ► ScrewTurn.Wiki ► UsersStorageProvider ► GetUsersWithData(String)
Gets all the users that have the specified element in their data.
Declaration Syntax
C# Visual Basic Visual C++
public IDictionary<UserInfo, string> GetUsersWithData(
    string key
)
Public Function GetUsersWithData ( _
    key As String _
) As IDictionary(Of UserInfo, String)
public:
virtual IDictionary<UserInfo^, String^>^ GetUsersWithData(
    String^ key
) sealed
Parameters
key (String)
The key of the data.
Return Value
The users and the data.
Exceptions
Exception | Condition
ArgumentNullException | If key is null.
ArgumentException | If key is empty.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


GroupMembershipReadOnly Property

GroupMembershipReadOnly Property
ScrewTurn Wiki ► ScrewTurn.Wiki ► UsersStorageProvider ► GroupMembershipReadOnly
Gets a value indicating whether group membership is read-only (if UserAccountsReadOnly is false, then this property must be false). If this property is true, the provider should return membership data compatible with default user groups.
Declaration Syntax
C# Visual Basic Visual C++
public bool GroupMembershipReadOnly { get; }
Public ReadOnly Property GroupMembershipReadOnly As Boolean
public:
virtual property bool GroupMembershipReadOnly {
    bool get () sealed;
}

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


Information Property

Information Property
ScrewTurn Wiki ► ScrewTurn.Wiki ► UsersStorageProvider ► Information
Gets the Information about the Provider.
Declaration Syntax
C# Visual Basic Visual C++
public ComponentInformation Information { get; }
Public ReadOnly Property Information As ComponentInformation
public:
virtual property ComponentInformation^ Information {
    ComponentInformation^ get () sealed;
}

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


Init Method (host, config)

Init Method (host, config)
ScrewTurn Wiki ► ScrewTurn.Wiki ► UsersStorageProvider ► Init(IHostV30, String)
Initializes the Provider.
Declaration Syntax
C# Visual Basic Visual C++
public void Init(
    IHostV30 host,
    string config
)
Public Sub Init ( _
    host As IHostV30, _
    config As String _
)
public:
virtual void Init(
    IHostV30^ host,
    String^ config
) sealed
Parameters
host (IHostV30)
The Host of the Provider.
config (String)
The Configuration data, if any.
Exceptions
Exception | Condition
ArgumentNullException | If host or config are null.
InvalidConfigurationException | If config is not valid or is incorrect.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


ModifyUser Method (user, newDisplayName, newPassword, newEmail, newActive)

ModifyUser Method (user, newDisplayName, newPassword, newEmail, newActive)
ScrewTurn Wiki ► ScrewTurn.Wiki ► UsersStorageProvider ► ModifyUser(UserInfo, String, String, String, Boolean)
Modifies a User.
Declaration Syntax
C# Visual Basic Visual C++
public UserInfo ModifyUser(
    UserInfo user,
    string newDisplayName,
    string newPassword,
    string newEmail,
    bool newActive
)
Public Function ModifyUser ( _
    user As UserInfo, _
    newDisplayName As String, _
    newPassword As String, _
    newEmail As String, _
    newActive As Boolean _
) As UserInfo
public:
virtual UserInfo^ ModifyUser(
    UserInfo^ user,
    String^ newDisplayName,
    String^ newPassword,
    String^ newEmail,
    bool newActive
) sealed
Parameters
user (UserInfo)
The Username of the user to modify.
newDisplayName (String)
The new display name (can be null).
newPassword (String)
The new Password (null or blank to keep the current password).
newEmail (String)
The new Email address.
newActive (Boolean)
A value indicating whether the account is active.
Return Value
The correct UserInfo object or null.
Exceptions
Exception | Condition
ArgumentNullException | If user or newEmail are null.
ArgumentException | If newEmail is empty.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


ModifyUserGroup Method (group, description)

ModifyUserGroup Method (group, description)
ScrewTurn Wiki ► ScrewTurn.Wiki ► UsersStorageProvider ► ModifyUserGroup(UserGroup, String)
Modifies a user group.
Declaration Syntax
C# Visual Basic Visual C++
public UserGroup ModifyUserGroup(
    UserGroup group,
    string description
)
Public Function ModifyUserGroup ( _
    group As UserGroup, _
    description As String _
) As UserGroup
public:
virtual UserGroup^ ModifyUserGroup(
    UserGroup^ group,
    String^ description
) sealed
Parameters
group (UserGroup)
The group to modify.
description (String)
The new description of the group.
Return Value
The correct UserGroup object or null.
Exceptions
Exception | Condition
ArgumentNullException | If group or description are null.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


NotifyCookieLogin Method (user)

NotifyCookieLogin Method (user)
ScrewTurn Wiki ► ScrewTurn.Wiki ► UsersStorageProvider ► NotifyCookieLogin(UserInfo)
Notifies the provider that a user has logged in through the authentication cookie.
Declaration Syntax
C# Visual Basic Visual C++
public void NotifyCookieLogin(
    UserInfo user
)
Public Sub NotifyCookieLogin ( _
    user As UserInfo _
)
public:
virtual void NotifyCookieLogin(
    UserInfo^ user
) sealed
Parameters
user (UserInfo)
The user who has logged in.
Exceptions
Exception | Condition
ArgumentNullException | If user is null.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


NotifyLogout Method (user)

NotifyLogout Method (user)
ScrewTurn Wiki ► ScrewTurn.Wiki ► UsersStorageProvider ► NotifyLogout(UserInfo)
Notifies the provider that a user has logged out.
Declaration Syntax
C# Visual Basic Visual C++
public void NotifyLogout(
    UserInfo user
)
Public Sub NotifyLogout ( _
    user As UserInfo _
)
public:
virtual void NotifyLogout(
    UserInfo^ user
) sealed
Parameters
user (UserInfo)
The user who has logged out.
Exceptions
Exception | Condition
ArgumentNullException | If user is null.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


RemoveUser Method (user)

RemoveUser Method (user)
ScrewTurn Wiki ► ScrewTurn.Wiki ► UsersStorageProvider ► RemoveUser(UserInfo)
Removes a User.
Declaration Syntax
C# Visual Basic Visual C++
public bool RemoveUser(
    UserInfo user
)
Public Function RemoveUser ( _
    user As UserInfo _
) As Boolean
public:
virtual bool RemoveUser(
    UserInfo^ user
) sealed
Parameters
user (UserInfo)
The User to remove.
Return Value
True if the User has been removed successfully.
Exceptions
Exception | Condition
ArgumentNullException | If user is null.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


RemoveUserGroup Method (group)

RemoveUserGroup Method (group)
ScrewTurn Wiki ► ScrewTurn.Wiki ► UsersStorageProvider ► RemoveUserGroup(UserGroup)
Removes a user group.
Declaration Syntax
C# Visual Basic Visual C++
public bool RemoveUserGroup(
    UserGroup group
)
Public Function RemoveUserGroup ( _
    group As UserGroup _
) As Boolean
public:
virtual bool RemoveUserGroup(
    UserGroup^ group
) sealed
Parameters
group (UserGroup)
The group to remove.
Return Value
true if the group is removed, false otherwise.
Exceptions
Exception | Condition
ArgumentNullException | If group is null.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


RetrieveAllUserData Method (user)

RetrieveAllUserData Method (user)
ScrewTurn Wiki ► ScrewTurn.Wiki ► UsersStorageProvider ► RetrieveAllUserData(UserInfo)
Retrieves all the user data elements for a user.
Declaration Syntax
C# Visual Basic Visual C++
public IDictionary<string, string> RetrieveAllUserData(
    UserInfo user
)
Public Function RetrieveAllUserData ( _
    user As UserInfo _
) As IDictionary(Of String, String)
public:
virtual IDictionary<String^, String^>^ RetrieveAllUserData(
    UserInfo^ user
) sealed
Parameters
user (UserInfo)
The user.
Return Value
The user data elements (key->value).
Exceptions
Exception | Condition
ArgumentNullException | If user is null.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


RetrieveUserData Method (user, key)

RetrieveUserData Method (user, key)
ScrewTurn Wiki ► ScrewTurn.Wiki ► UsersStorageProvider ► RetrieveUserData(UserInfo, String)
Gets a user data element, if any.
Declaration Syntax
C# Visual Basic Visual C++
public string RetrieveUserData(
    UserInfo user,
    string key
)
Public Function RetrieveUserData ( _
    user As UserInfo, _
    key As String _
) As String
public:
virtual String^ RetrieveUserData(
    UserInfo^ user,
    String^ key
) sealed
Parameters
user (UserInfo)
The user the data belongs to.
key (String)
The key of the data element.
Return Value
The value of the data element, or null if the element is not found.
Exceptions
Exception | Condition
ArgumentNullException | If user or key are null.
ArgumentException | If key is empty.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


SetUserMembership Method (user, groups)

SetUserMembership Method (user, groups)
ScrewTurn Wiki ► ScrewTurn.Wiki ► UsersStorageProvider ► SetUserMembership(UserInfo, array<String>[]()[])
Sets the group memberships of a user account.
Declaration Syntax
C# Visual Basic Visual C++
public UserInfo SetUserMembership(
    UserInfo user,
    string[] groups
)
Public Function SetUserMembership ( _
    user As UserInfo, _
    groups As String() _
) As UserInfo
public:
virtual UserInfo^ SetUserMembership(
    UserInfo^ user,
    array<String^>^ groups
) sealed
Parameters
user (UserInfo)
The user account.
groups (array< String >[]()[][])
The groups the user account is member of.
Return Value
The correct UserGroup object or null.
Exceptions
Exception | Condition
ArgumentNullException | If user or groups are null.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


Shutdown Method

Shutdown Method
ScrewTurn Wiki ► ScrewTurn.Wiki ► UsersStorageProvider ► Shutdown()()()
Method invoked on shutdown.
Declaration Syntax
C# Visual Basic Visual C++
public void Shutdown()
Public Sub Shutdown
public:
virtual void Shutdown() sealed
Remarks
This method might not be invoked in some cases.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


StoreUserData Method (user, key, value)

StoreUserData Method (user, key, value)
ScrewTurn Wiki ► ScrewTurn.Wiki ► UsersStorageProvider ► StoreUserData(UserInfo, String, String)
Stores a user data element, overwriting the previous one if present.
Declaration Syntax
C# Visual Basic Visual C++
public bool StoreUserData(
    UserInfo user,
    string key,
    string value
)
Public Function StoreUserData ( _
    user As UserInfo, _
    key As String, _
    value As String _
) As Boolean
public:
virtual bool StoreUserData(
    UserInfo^ user,
    String^ key,
    String^ value
) sealed
Parameters
user (UserInfo)
The user the data belongs to.
key (String)
The key of the data element (case insensitive).
value (String)
The value of the data element, null for deleting the data.
Return Value
true if the data element is stored, false otherwise.
Exceptions
Exception | Condition
ArgumentNullException | If user or key are null.
ArgumentException | If key is empty.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


TestAccount Method (user, password)

TestAccount Method (user, password)
ScrewTurn Wiki ► ScrewTurn.Wiki ► UsersStorageProvider ► TestAccount(UserInfo, String)
Tests a Password for a User account.
Declaration Syntax
C# Visual Basic Visual C++
public bool TestAccount(
    UserInfo user,
    string password
)
Public Function TestAccount ( _
    user As UserInfo, _
    password As String _
) As Boolean
public:
virtual bool TestAccount(
    UserInfo^ user,
    String^ password
) sealed
Parameters
user (UserInfo)
The User account.
password (String)
The Password to test.
Return Value
True if the Password is correct.
Exceptions
Exception | Condition
ArgumentNullException | If user or password are null.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


TryAutoLogin Method (context)

TryAutoLogin Method (context)
ScrewTurn Wiki ► ScrewTurn.Wiki ► UsersStorageProvider ► TryAutoLogin(HttpContext)
Tries to login a user directly through the provider using the current HttpContext and without username/password.
Declaration Syntax
C# Visual Basic Visual C++
public UserInfo TryAutoLogin(
    HttpContext context
)
Public Function TryAutoLogin ( _
    context As HttpContext _
) As UserInfo
public:
virtual UserInfo^ TryAutoLogin(
    HttpContext^ context
) sealed
Parameters
context (HttpContext)
The current HttpContext.
Return Value
The correct UserInfo object, or null.
Exceptions
Exception | Condition
ArgumentNullException | If context is null.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


TryManualLogin Method (username, password)

TryManualLogin Method (username, password)
ScrewTurn Wiki ► ScrewTurn.Wiki ► UsersStorageProvider ► TryManualLogin(String, String)
Tries to login a user directly through the provider.
Declaration Syntax
C# Visual Basic Visual C++
public UserInfo TryManualLogin(
    string username,
    string password
)
Public Function TryManualLogin ( _
    username As String, _
    password As String _
) As UserInfo
public:
virtual UserInfo^ TryManualLogin(
    String^ username,
    String^ password
) sealed
Parameters
username (String)
The username.
password (String)
The password.
Return Value
The correct UserInfo object, or null.
Exceptions
Exception | Condition
ArgumentNullException | If username or password are null.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


UserAccountsReadOnly Property

UserAccountsReadOnly Property
ScrewTurn Wiki ► ScrewTurn.Wiki ► UsersStorageProvider ► UserAccountsReadOnly
Gets a value indicating whether user accounts are read-only.
Declaration Syntax
C# Visual Basic Visual C++
public bool UserAccountsReadOnly { get; }
Public ReadOnly Property UserAccountsReadOnly As Boolean
public:
virtual property bool UserAccountsReadOnly {
    bool get () sealed;
}

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


UserGroupsReadOnly Property

UserGroupsReadOnly Property
ScrewTurn Wiki ► ScrewTurn.Wiki ► UsersStorageProvider ► UserGroupsReadOnly
Gets a value indicating whether user groups are read-only. If so, the provider should support default user groups as defined in the wiki configuration.
Declaration Syntax
C# Visual Basic Visual C++
public bool UserGroupsReadOnly { get; }
Public ReadOnly Property UserGroupsReadOnly As Boolean
public:
virtual property bool UserGroupsReadOnly {
    bool get () sealed;
}

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


UsersDataReadOnly Property

UsersDataReadOnly Property
ScrewTurn Wiki ► ScrewTurn.Wiki ► UsersStorageProvider ► UsersDataReadOnly
Gets a value indicating whether users' data is read-only.
Declaration Syntax
C# Visual Basic Visual C++
public bool UsersDataReadOnly { get; }
Public ReadOnly Property UsersDataReadOnly As Boolean
public:
virtual property bool UsersDataReadOnly {
    bool get () sealed;
}

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Core (Module: ScrewTurn.Wiki.Core) Version: 3.0.2.500 (3.0.2.500)


ScrewTurn.Wiki.AclEngine Namespace

ScrewTurn.Wiki.AclEngine Namespace
ScrewTurn Wiki ► ScrewTurn.Wiki.AclEngine
Namespace containing ACL Engine types.
Declaration Syntax
C# Visual Basic Visual C++
namespace ScrewTurn.Wiki.AclEngine
Namespace ScrewTurn.Wiki.AclEngine
namespace ScrewTurn.Wiki.AclEngine
Types
All Types Classes Interfaces Enumerations
Icon | Type | Description
 | AclChangedEventArgs | Contains arguments for the AclChanged event.
 | AclEntry | Represents an ACL Entry.
 | AclEvaluator | Implements tools for evaluating permissions.
 | AclManagerBase | Implements a base class for an ACL Manager.
 | AclStorerBase | Implements a base class for an ACL Storer.
 | Authorization | Lists legal authorization values.
 | Change | Lists legal changes for ACL entries.
 | IAclManager | Defines an interface for an ACL manager.
 | Value | Lists legal ACL Entry values.


AclChangedEventArgs Class

AclChangedEventArgs Class
ScrewTurn Wiki ► ScrewTurn.Wiki.AclEngine ► AclChangedEventArgs
Contains arguments for the AclChanged event.
Declaration Syntax
C# Visual Basic Visual C++
public class AclChangedEventArgs : EventArgs
Public Class AclChangedEventArgs _
    Inherits EventArgs
public ref class AclChangedEventArgs : public EventArgs
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | AclChangedEventArgs(array<AclEntry>[]()[], Change) | Initializes a new instance of the AclChangedEventArgs class.
 | Change | Gets the change.
 | Entries | Gets the entries that changed.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | EventArgs
 |  | AclChangedEventArgs

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.AclEngine (Module: ScrewTurn.Wiki.AclEngine) Version: 3.0.2.500 (3.0.2.500)


AclChangedEventArgs Constructor (entries, change)

AclChangedEventArgs Constructor (entries, change)
ScrewTurn Wiki ► ScrewTurn.Wiki.AclEngine ► AclChangedEventArgs ► AclChangedEventArgs(array<AclEntry>[]()[], Change)
Initializes a new instance of the AclChangedEventArgs class.
Declaration Syntax
C# Visual Basic Visual C++
public AclChangedEventArgs(
    AclEntry[] entries,
    Change change
)
Public Sub New ( _
    entries As AclEntry(), _
    change As Change _
)
public:
AclChangedEventArgs(
    array<AclEntry^>^ entries,
    Change change
)
Parameters
entries (array< AclEntry >[]()[][])
The entries that changed.
change (Change)
The change.
Exceptions
Exception | Condition
ArgumentNullException | If entries is null.
ArgumentException | If entries is empty.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.AclEngine (Module: ScrewTurn.Wiki.AclEngine) Version: 3.0.2.500 (3.0.2.500)


Change Property

Change Property
ScrewTurn Wiki ► ScrewTurn.Wiki.AclEngine ► AclChangedEventArgs ► Change
Gets the change.
Declaration Syntax
C# Visual Basic Visual C++
public Change Change { get; }
Public ReadOnly Property Change As Change
public:
property Change Change {
    Change get ();
}

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.AclEngine (Module: ScrewTurn.Wiki.AclEngine) Version: 3.0.2.500 (3.0.2.500)


Entries Property

Entries Property
ScrewTurn Wiki ► ScrewTurn.Wiki.AclEngine ► AclChangedEventArgs ► Entries
Gets the entries that changed.
Declaration Syntax
C# Visual Basic Visual C++
public AclEntry[] Entries { get; }
Public ReadOnly Property Entries As AclEntry()
public:
property array<AclEntry^>^ Entries {
    array<AclEntry^>^ get ();
}

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.AclEngine (Module: ScrewTurn.Wiki.AclEngine) Version: 3.0.2.500 (3.0.2.500)


AclEntry Class

AclEntry Class
ScrewTurn Wiki ► ScrewTurn.Wiki.AclEngine ► AclEntry
Represents an ACL Entry.
Declaration Syntax
C# Visual Basic Visual C++
public class AclEntry
Public Class AclEntry
public ref class AclEntry
Members
All Members | Constructors | Methods | Properties | Fields
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | AclEntry(String, String, String, Value) | Initializes a new instance of the AclEntry class.
 | Action | Gets the controlled action on the resource.
 | Equals(Object) | Determines whether this object equals another (by value). (Overrides Object.Equals(Object).)
 | Equals(AclEntry) | Determines whether this instance equals another (by value).
 | Equals(AclEntry, AclEntry) | Determines whether two instances of AclEntry are equal (by value).
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | FullControlAction | The full control action.
 | GetHashCode()()() | Gets a hash code for the current object. (Overrides Object.GetHashCode()()().)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Resource | Gets the controlled resource.
 | Subject | Gets the subject of the entry.
 | ToString()()() | Gets a string representation of the current object. (Overrides Object.ToString()()().)
 | Value | Gets the value of the entry.
Inheritance Hierarchy
Object
AclEntry

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.AclEngine (Module: ScrewTurn.Wiki.AclEngine) Version: 3.0.2.500 (3.0.2.500)


AclEntry Constructor (resource, action, subject, value)

AclEntry Constructor (resource, action, subject, value)
ScrewTurn Wiki ► ScrewTurn.Wiki.AclEngine ► AclEntry ► AclEntry(String, String, String, Value)
Initializes a new instance of the AclEntry class.
Declaration Syntax
C# Visual Basic Visual C++
public AclEntry(
    string resource,
    string action,
    string subject,
    Value value
)
Public Sub New ( _
    resource As String, _
    action As String, _
    subject As String, _
    value As Value _
)
public:
AclEntry(
    String^ resource,
    String^ action,
    String^ subject,
    Value value
)
Parameters
resource (String)
The controlled resource.
action (String)
The controlled action on the resource.
subject (String)
The subject whose access to the resource/action is controlled.
value (Value)
The entry value.
Exceptions
Exception | Condition
ArgumentNullException | If resource, action or subject are null.
ArgumentException | If resource, action or subject are empty.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.AclEngine (Module: ScrewTurn.Wiki.AclEngine) Version: 3.0.2.500 (3.0.2.500)


Action Property

Action Property
ScrewTurn Wiki ► ScrewTurn.Wiki.AclEngine ► AclEntry ► Action
Gets the controlled action on the resource.
Declaration Syntax
C# Visual Basic Visual C++
public string Action { get; }
Public ReadOnly Property Action As String
public:
property String^ Action {
    String^ get ();
}

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.AclEngine (Module: ScrewTurn.Wiki.AclEngine) Version: 3.0.2.500 (3.0.2.500)


Equals Method

Equals Method
ScrewTurn Wiki ► ScrewTurn.Wiki.AclEngine ► AclEntry ► Equals()()()
Members
Icon | Member | Description
 | Equals(Object) | Determines whether this object equals another (by value). (Overrides Object.Equals(Object).)
 | Equals(AclEntry) | Determines whether this instance equals another (by value).
 | Equals(AclEntry, AclEntry) | Determines whether two instances of AclEntry are equal (by value).

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.AclEngine (Module: ScrewTurn.Wiki.AclEngine) Version: 3.0.2.500 (3.0.2.500)


Equals Method (other)

Equals Method (other)
ScrewTurn Wiki ► ScrewTurn.Wiki.AclEngine ► AclEntry ► Equals(AclEntry)
Determines whether this instance equals another (by value).
Declaration Syntax
C# Visual Basic Visual C++
public bool Equals(
    AclEntry other
)
Public Function Equals ( _
    other As AclEntry _
) As Boolean
public:
bool Equals(
    AclEntry^ other
)
Parameters
other (AclEntry)
The other instance.
Return Value
true if this instance equals other, false otherwise.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.AclEngine (Module: ScrewTurn.Wiki.AclEngine) Version: 3.0.2.500 (3.0.2.500)


Equals Method (x, y)

Equals Method (x, y)
ScrewTurn Wiki ► ScrewTurn.Wiki.AclEngine ► AclEntry ► Equals(AclEntry, AclEntry)
Determines whether two instances of AclEntry are equal (by value).
Declaration Syntax
C# Visual Basic Visual C++
public static bool Equals(
    AclEntry x,
    AclEntry y
)
Public Shared Function Equals ( _
    x As AclEntry, _
    y As AclEntry _
) As Boolean
public:
static bool Equals(
    AclEntry^ x,
    AclEntry^ y
)
Parameters
x (AclEntry)
The first instance.
y (AclEntry)
The second instance.
Return Value
true if x equals y, false otherwise.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.AclEngine (Module: ScrewTurn.Wiki.AclEngine) Version: 3.0.2.500 (3.0.2.500)


Equals Method (obj)

Equals Method (obj)
ScrewTurn Wiki ► ScrewTurn.Wiki.AclEngine ► AclEntry ► Equals(Object)
Determines whether this object equals another (by value).
Declaration Syntax
C# Visual Basic Visual C++
public override bool Equals(
    Object obj
)
Public Overrides Function Equals ( _
    obj As Object _
) As Boolean
public:
virtual bool Equals(
    Object^ obj
) override
Parameters
obj (Object)
The other object.
Return Value
true if this object equals obj, false otherwise.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.AclEngine (Module: ScrewTurn.Wiki.AclEngine) Version: 3.0.2.500 (3.0.2.500)


FullControlAction Field

FullControlAction Field
ScrewTurn Wiki ► ScrewTurn.Wiki.AclEngine ► AclEntry ► FullControlAction
The full control action.
Declaration Syntax
C# Visual Basic Visual C++
public const string FullControlAction
Public Const FullControlAction As String
public:
literal String^ FullControlAction

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.AclEngine (Module: ScrewTurn.Wiki.AclEngine) Version: 3.0.2.500 (3.0.2.500)


GetHashCode Method

GetHashCode Method
ScrewTurn Wiki ► ScrewTurn.Wiki.AclEngine ► AclEntry ► GetHashCode()()()
Gets a hash code for the current object.
Declaration Syntax
C# Visual Basic Visual C++
public override int GetHashCode()
Public Overrides Function GetHashCode As Integer
public:
virtual int GetHashCode() override
Return Value
The hash code.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.AclEngine (Module: ScrewTurn.Wiki.AclEngine) Version: 3.0.2.500 (3.0.2.500)


Resource Property

Resource Property
ScrewTurn Wiki ► ScrewTurn.Wiki.AclEngine ► AclEntry ► Resource
Gets the controlled resource.
Declaration Syntax
C# Visual Basic Visual C++
public string Resource { get; }
Public ReadOnly Property Resource As String
public:
property String^ Resource {
    String^ get ();
}

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.AclEngine (Module: ScrewTurn.Wiki.AclEngine) Version: 3.0.2.500 (3.0.2.500)


Subject Property

Subject Property
ScrewTurn Wiki ► ScrewTurn.Wiki.AclEngine ► AclEntry ► Subject
Gets the subject of the entry.
Declaration Syntax
C# Visual Basic Visual C++
public string Subject { get; }
Public ReadOnly Property Subject As String
public:
property String^ Subject {
    String^ get ();
}

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.AclEngine (Module: ScrewTurn.Wiki.AclEngine) Version: 3.0.2.500 (3.0.2.500)


ToString Method

ToString Method
ScrewTurn Wiki ► ScrewTurn.Wiki.AclEngine ► AclEntry ► ToString()()()
Gets a string representation of the current object.
Declaration Syntax
C# Visual Basic Visual C++
public override string ToString()
Public Overrides Function ToString As String
public:
virtual String^ ToString() override
Return Value
The string representation.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.AclEngine (Module: ScrewTurn.Wiki.AclEngine) Version: 3.0.2.500 (3.0.2.500)


Value Property

Value Property
ScrewTurn Wiki ► ScrewTurn.Wiki.AclEngine ► AclEntry ► Value
Gets the value of the entry.
Declaration Syntax
C# Visual Basic Visual C++
public Value Value { get; }
Public ReadOnly Property Value As Value
public:
property Value Value {
    Value get ();
}

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.AclEngine (Module: ScrewTurn.Wiki.AclEngine) Version: 3.0.2.500 (3.0.2.500)


AclEvaluator Class

AclEvaluator Class
ScrewTurn Wiki ► ScrewTurn.Wiki.AclEngine ► AclEvaluator
Implements tools for evaluating permissions.
Declaration Syntax
C# Visual Basic Visual C++
public static class AclEvaluator
Public NotInheritable Class AclEvaluator
public ref class AclEvaluator abstract sealed
Members
All Members | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | AuthorizeAction(String, String, String, array<String>[]()[], array<AclEntry>[]()[]) | Decides whether a user, member of some groups, is authorized to perform an action on a resource.
Inheritance Hierarchy
Object
AclEvaluator

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.AclEngine (Module: ScrewTurn.Wiki.AclEngine) Version: 3.0.2.500 (3.0.2.500)


AuthorizeAction Method (resource, action, user, groups, entries)

AuthorizeAction Method (resource, action, user, groups, entries)
ScrewTurn Wiki ► ScrewTurn.Wiki.AclEngine ► AclEvaluator ► AuthorizeAction(String, String, String, array<String>[]()[], array<AclEntry>[]()[])
Decides whether a user, member of some groups, is authorized to perform an action on a resource.
Declaration Syntax
C# Visual Basic Visual C++
public static Authorization AuthorizeAction(
    string resource,
    string action,
    string user,
    string[] groups,
    AclEntry[] entries
)
Public Shared Function AuthorizeAction ( _
    resource As String, _
    action As String, _
    user As String, _
    groups As String(), _
    entries As AclEntry() _
) As Authorization
public:
static Authorization AuthorizeAction(
    String^ resource,
    String^ action,
    String^ user,
    array<String^>^ groups,
    array<AclEntry^>^ entries
)
Parameters
resource (String)
The resource.
action (String)
The action on the resource.
user (String)
The user, in the form 'U.Name'.
groups (array< String >[]()[][])
The groups the user is member of, in the form 'G.Name'.
entries (array< AclEntry >[]()[][])
The available ACL entries for the resource.
Return Value
The positive, negative, or indeterminate result.
Exceptions
Exception | Condition
ArgumentNullException | If resource, action, user, groups or entries are null.
ArgumentException | If resource, action, user are empty, or if action equals FullControlAction.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.AclEngine (Module: ScrewTurn.Wiki.AclEngine) Version: 3.0.2.500 (3.0.2.500)


AclManagerBase Class

AclManagerBase Class
ScrewTurn Wiki ► ScrewTurn.Wiki.AclEngine ► AclManagerBase
Implements a base class for an ACL Manager.
Declaration Syntax
C# Visual Basic Visual C++
public abstract class AclManagerBase : IAclManager
Public MustInherit Class AclManagerBase _
    Implements IAclManager
public ref class AclManagerBase abstract : IAclManager
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | AclManagerBase()()() | Initializes a new instance of the AclManagerBase abstract class.
 | AclChanged | Event fired when an ACL entry is stored or deleted.
 | DeleteEntriesForResource(String) | Deletes all the ACL entries for a resource.
 | DeleteEntriesForSubject(String) | Deletes all the ACL entries for a subject.
 | DeleteEntry(String, String, String) | Deletes an ACL entry.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | InitializeData(array<AclEntry>[]()[]) | Initializes the manager data.
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | OnAclChanged(array<AclEntry>[]()[], Change) | Handles the invokation of AclChanged event.
 | RenameResource(String, String) | Renames a resource.
 | RetrieveAllEntries()()() | Retrieves all the ACL entries for a resource.
 | RetrieveEntriesForResource(String) | Retrieves all the ACL entries for a resource.
 | RetrieveEntriesForSubject(String) | Retrieves all the ACL entries for a subject.
 | StoreEntry(String, String, String, Value) | Stores a new ACL entry.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | TotalEntries | Gets the total number of ACL entries.
Remarks
All instance and static members are thread-safe.
Inheritance Hierarchy
Object
 | AclManagerBase
 |  | StandardAclManager

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.AclEngine (Module: ScrewTurn.Wiki.AclEngine) Version: 3.0.2.500 (3.0.2.500)


AclManagerBase Constructor

AclManagerBase Constructor
ScrewTurn Wiki ► ScrewTurn.Wiki.AclEngine ► AclManagerBase ► AclManagerBase()()()
Initializes a new instance of the AclManagerBase abstract class.
Declaration Syntax
C# Visual Basic Visual C++
public AclManagerBase()
Public Sub New
public:
AclManagerBase()

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.AclEngine (Module: ScrewTurn.Wiki.AclEngine) Version: 3.0.2.500 (3.0.2.500)


AclChanged Event

AclChanged Event
ScrewTurn Wiki ► ScrewTurn.Wiki.AclEngine ► AclManagerBase ► AclChanged
Event fired when an ACL entry is stored or deleted.
Declaration Syntax
C# Visual Basic Visual C++
public event EventHandler<AclChangedEventArgs> AclChanged
Public Event AclChanged As EventHandler(Of AclChangedEventArgs)
public:
virtual  event EventHandler<AclChangedEventArgs^>^ AclChanged {
    void add (EventHandler<AclChangedEventArgs^>^ value);
    void remove (EventHandler<AclChangedEventArgs^>^ value);
}

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.AclEngine (Module: ScrewTurn.Wiki.AclEngine) Version: 3.0.2.500 (3.0.2.500)


DeleteEntriesForResource Method (resource)

DeleteEntriesForResource Method (resource)
ScrewTurn Wiki ► ScrewTurn.Wiki.AclEngine ► AclManagerBase ► DeleteEntriesForResource(String)
Deletes all the ACL entries for a resource.
Declaration Syntax
C# Visual Basic Visual C++
public bool DeleteEntriesForResource(
    string resource
)
Public Function DeleteEntriesForResource ( _
    resource As String _
) As Boolean
public:
virtual bool DeleteEntriesForResource(
    String^ resource
) sealed
Parameters
resource (String)
The controlled resource.
Return Value
true if the entries are deleted, false otherwise.
Exceptions
Exception | Condition
ArgumentNullException | If resource is null.
ArgumentException | If resource is empty.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.AclEngine (Module: ScrewTurn.Wiki.AclEngine) Version: 3.0.2.500 (3.0.2.500)


DeleteEntriesForSubject Method (subject)

DeleteEntriesForSubject Method (subject)
ScrewTurn Wiki ► ScrewTurn.Wiki.AclEngine ► AclManagerBase ► DeleteEntriesForSubject(String)
Deletes all the ACL entries for a subject.
Declaration Syntax
C# Visual Basic Visual C++
public bool DeleteEntriesForSubject(
    string subject
)
Public Function DeleteEntriesForSubject ( _
    subject As String _
) As Boolean
public:
virtual bool DeleteEntriesForSubject(
    String^ subject
) sealed
Parameters
subject (String)
The subject.
Return Value
true if the entries are deleted, false otherwise.
Exceptions
Exception | Condition
ArgumentNullException | If subject is null.
ArgumentException | If subject is empty.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.AclEngine (Module: ScrewTurn.Wiki.AclEngine) Version: 3.0.2.500 (3.0.2.500)


DeleteEntry Method (resource, action, subject)

DeleteEntry Method (resource, action, subject)
ScrewTurn Wiki ► ScrewTurn.Wiki.AclEngine ► AclManagerBase ► DeleteEntry(String, String, String)
Deletes an ACL entry.
Declaration Syntax
C# Visual Basic Visual C++
public bool DeleteEntry(
    string resource,
    string action,
    string subject
)
Public Function DeleteEntry ( _
    resource As String, _
    action As String, _
    subject As String _
) As Boolean
public:
virtual bool DeleteEntry(
    String^ resource,
    String^ action,
    String^ subject
) sealed
Parameters
resource (String)
The controlled resource.
action (String)
The action on the controlled resource.
subject (String)
The subject whose access to the resource/action is controlled.
Return Value
true if the entry is deleted, false otherwise.
Exceptions
Exception | Condition
ArgumentNullException | If resource, action or subject are null.
ArgumentException | If resource, action or subject are empty.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.AclEngine (Module: ScrewTurn.Wiki.AclEngine) Version: 3.0.2.500 (3.0.2.500)


InitializeData Method (entries)

InitializeData Method (entries)
ScrewTurn Wiki ► ScrewTurn.Wiki.AclEngine ► AclManagerBase ► InitializeData(array<AclEntry>[]()[])
Initializes the manager data.
Declaration Syntax
C# Visual Basic Visual C++
public void InitializeData(
    AclEntry[] entries
)
Public Sub InitializeData ( _
    entries As AclEntry() _
)
public:
virtual void InitializeData(
    array<AclEntry^>^ entries
) sealed
Parameters
entries (array< AclEntry >[]()[][])
The ACL entries.
Exceptions
Exception | Condition
ArgumentNullException | If entries is null.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.AclEngine (Module: ScrewTurn.Wiki.AclEngine) Version: 3.0.2.500 (3.0.2.500)


OnAclChanged Method (entries, change)

OnAclChanged Method (entries, change)
ScrewTurn Wiki ► ScrewTurn.Wiki.AclEngine ► AclManagerBase ► OnAclChanged(array<AclEntry>[]()[], Change)
Handles the invokation of AclChanged event.
Declaration Syntax
C# Visual Basic Visual C++
protected void OnAclChanged(
    AclEntry[] entries,
    Change change
)
Protected Sub OnAclChanged ( _
    entries As AclEntry(), _
    change As Change _
)
protected:
void OnAclChanged(
    array<AclEntry^>^ entries,
    Change change
)
Parameters
entries (array< AclEntry >[]()[][])
The changed entries.
change (Change)
The change.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.AclEngine (Module: ScrewTurn.Wiki.AclEngine) Version: 3.0.2.500 (3.0.2.500)


RenameResource Method (resource, newName)

RenameResource Method (resource, newName)
ScrewTurn Wiki ► ScrewTurn.Wiki.AclEngine ► AclManagerBase ► RenameResource(String, String)
Renames a resource.
Declaration Syntax
C# Visual Basic Visual C++
public bool RenameResource(
    string resource,
    string newName
)
Public Function RenameResource ( _
    resource As String, _
    newName As String _
) As Boolean
public:
virtual bool RenameResource(
    String^ resource,
    String^ newName
) sealed
Parameters
resource (String)
The resource.
newName (String)
The new name of the resource.
Return Value
true if the resource is renamed, false otherwise.
Exceptions
Exception | Condition
ArgumentNullException | If resource or newName are null.
ArgumentException | If resource or newName are empty.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.AclEngine (Module: ScrewTurn.Wiki.AclEngine) Version: 3.0.2.500 (3.0.2.500)


RetrieveAllEntries Method

RetrieveAllEntries Method
ScrewTurn Wiki ► ScrewTurn.Wiki.AclEngine ► AclManagerBase ► RetrieveAllEntries()()()
Retrieves all the ACL entries for a resource.
Declaration Syntax
C# Visual Basic Visual C++
public AclEntry[] RetrieveAllEntries()
Public Function RetrieveAllEntries As AclEntry()
public:
virtual array<AclEntry^>^ RetrieveAllEntries() sealed
Return Value
The entries.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.AclEngine (Module: ScrewTurn.Wiki.AclEngine) Version: 3.0.2.500 (3.0.2.500)


RetrieveEntriesForResource Method (resource)

RetrieveEntriesForResource Method (resource)
ScrewTurn Wiki ► ScrewTurn.Wiki.AclEngine ► AclManagerBase ► RetrieveEntriesForResource(String)
Retrieves all the ACL entries for a resource.
Declaration Syntax
C# Visual Basic Visual C++
public AclEntry[] RetrieveEntriesForResource(
    string resource
)
Public Function RetrieveEntriesForResource ( _
    resource As String _
) As AclEntry()
public:
virtual array<AclEntry^>^ RetrieveEntriesForResource(
    String^ resource
) sealed
Parameters
resource (String)
The resource.
Return Value
The entries.
Exceptions
Exception | Condition
ArgumentNullException | If resource is null.
ArgumentException | If resource is empty.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.AclEngine (Module: ScrewTurn.Wiki.AclEngine) Version: 3.0.2.500 (3.0.2.500)


RetrieveEntriesForSubject Method (subject)

RetrieveEntriesForSubject Method (subject)
ScrewTurn Wiki ► ScrewTurn.Wiki.AclEngine ► AclManagerBase ► RetrieveEntriesForSubject(String)
Retrieves all the ACL entries for a subject.
Declaration Syntax
C# Visual Basic Visual C++
public AclEntry[] RetrieveEntriesForSubject(
    string subject
)
Public Function RetrieveEntriesForSubject ( _
    subject As String _
) As AclEntry()
public:
virtual array<AclEntry^>^ RetrieveEntriesForSubject(
    String^ subject
) sealed
Parameters
subject (String)
The subject.
Return Value
The entries.
Exceptions
Exception | Condition
ArgumentNullException | If subject is null.
ArgumentException | If subject is empty.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.AclEngine (Module: ScrewTurn.Wiki.AclEngine) Version: 3.0.2.500 (3.0.2.500)


StoreEntry Method (resource, action, subject, value)

StoreEntry Method (resource, action, subject, value)
ScrewTurn Wiki ► ScrewTurn.Wiki.AclEngine ► AclManagerBase ► StoreEntry(String, String, String, Value)
Stores a new ACL entry.
Declaration Syntax
C# Visual Basic Visual C++
public bool StoreEntry(
    string resource,
    string action,
    string subject,
    Value value
)
Public Function StoreEntry ( _
    resource As String, _
    action As String, _
    subject As String, _
    value As Value _
) As Boolean
public:
virtual bool StoreEntry(
    String^ resource,
    String^ action,
    String^ subject,
    Value value
) sealed
Parameters
resource (String)
The controlled resource.
action (String)
The action on the controlled resource.
subject (String)
The subject whose access to the resource/action is controlled.
value (Value)
The value of the entry.
Return Value
true if the entry is stored, false otherwise.
Exceptions
Exception | Condition
ArgumentNullException | If resource, action or subject are null.
ArgumentException | If resource, action or subject are empty.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.AclEngine (Module: ScrewTurn.Wiki.AclEngine) Version: 3.0.2.500 (3.0.2.500)


TotalEntries Property

TotalEntries Property
ScrewTurn Wiki ► ScrewTurn.Wiki.AclEngine ► AclManagerBase ► TotalEntries
Gets the total number of ACL entries.
Declaration Syntax
C# Visual Basic Visual C++
public int TotalEntries { get; }
Public ReadOnly Property TotalEntries As Integer
public:
virtual property int TotalEntries {
    int get () sealed;
}

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.AclEngine (Module: ScrewTurn.Wiki.AclEngine) Version: 3.0.2.500 (3.0.2.500)


AclStorerBase Class

AclStorerBase Class
ScrewTurn Wiki ► ScrewTurn.Wiki.AclEngine ► AclStorerBase
Implements a base class for an ACL Storer.
Declaration Syntax
C# Visual Basic Visual C++
public abstract class AclStorerBase : IDisposable
Public MustInherit Class AclStorerBase _
    Implements IDisposable
public ref class AclStorerBase abstract : IDisposable
Members
All Members | Constructors | Methods | Properties | Fields
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | AclStorerBase(IAclManager) | Initializes a new instance of the AclStorerBase abstract class.
 | aclChangedHandler | The event handler for the AclChanged event.
 | aclManager | The instance of the ACL Manager to handle.
 | AclManager | Gets the instance of the ACL Manager.
 | DeleteEntries(array<AclEntry>[]()[]) | Deletes some entries.
 | Dispose()()() | Disposes the current object.
 | disposed | Indicates whether the object was disposed.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | LoadData()()() | Loads the data and injects it in the instance of IAclManager.
 | LoadDataInternal()()() | Loads data from storage.
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | StoreEntries(array<AclEntry>[]()[]) | Stores some entries.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | AclStorerBase
 |  | AclStorer

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.AclEngine (Module: ScrewTurn.Wiki.AclEngine) Version: 3.0.2.500 (3.0.2.500)


AclStorerBase Constructor (aclManager)

AclStorerBase Constructor (aclManager)
ScrewTurn Wiki ► ScrewTurn.Wiki.AclEngine ► AclStorerBase ► AclStorerBase(IAclManager)
Initializes a new instance of the AclStorerBase abstract class.
Declaration Syntax
C# Visual Basic Visual C++
public AclStorerBase(
    IAclManager aclManager
)
Public Sub New ( _
    aclManager As IAclManager _
)
public:
AclStorerBase(
    IAclManager^ aclManager
)
Parameters
aclManager (IAclManager)
The instance of the ACL Manager to handle.
Exceptions
Exception | Condition
ArgumentNullException | If aclManager is null.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.AclEngine (Module: ScrewTurn.Wiki.AclEngine) Version: 3.0.2.500 (3.0.2.500)


aclChangedHandler Field

aclChangedHandler Field
ScrewTurn Wiki ► ScrewTurn.Wiki.AclEngine ► AclStorerBase ► aclChangedHandler
The event handler for the AclChanged event.
Declaration Syntax
C# Visual Basic Visual C++
protected EventHandler<AclChangedEventArgs> aclChangedHandler
Protected aclChangedHandler As EventHandler(Of AclChangedEventArgs)
protected:
EventHandler<AclChangedEventArgs^>^ aclChangedHandler

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.AclEngine (Module: ScrewTurn.Wiki.AclEngine) Version: 3.0.2.500 (3.0.2.500)


aclManager Field

aclManager Field
ScrewTurn Wiki ► ScrewTurn.Wiki.AclEngine ► AclStorerBase ► aclManager
The instance of the ACL Manager to handle.
Declaration Syntax
C# Visual Basic Visual C++
protected IAclManager aclManager
Protected aclManager As IAclManager
protected:
IAclManager^ aclManager

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.AclEngine (Module: ScrewTurn.Wiki.AclEngine) Version: 3.0.2.500 (3.0.2.500)


AclManager Property

AclManager Property
ScrewTurn Wiki ► ScrewTurn.Wiki.AclEngine ► AclStorerBase ► AclManager
Gets the instance of the ACL Manager.
Declaration Syntax
C# Visual Basic Visual C++
public IAclManager AclManager { get; }
Public ReadOnly Property AclManager As IAclManager
public:
property IAclManager^ AclManager {
    IAclManager^ get ();
}

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.AclEngine (Module: ScrewTurn.Wiki.AclEngine) Version: 3.0.2.500 (3.0.2.500)


DeleteEntries Method (entries)

DeleteEntries Method (entries)
ScrewTurn Wiki ► ScrewTurn.Wiki.AclEngine ► AclStorerBase ► DeleteEntries(array<AclEntry>[]()[])
Deletes some entries.
Declaration Syntax
C# Visual Basic Visual C++
protected abstract void DeleteEntries(
    AclEntry[] entries
)
Protected MustOverride Sub DeleteEntries ( _
    entries As AclEntry() _
)
protected:
virtual void DeleteEntries(
    array<AclEntry^>^ entries
) abstract
Parameters
entries (array< AclEntry >[]()[][])
The entries to delete.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.AclEngine (Module: ScrewTurn.Wiki.AclEngine) Version: 3.0.2.500 (3.0.2.500)


Dispose Method

Dispose Method
ScrewTurn Wiki ► ScrewTurn.Wiki.AclEngine ► AclStorerBase ► Dispose()()()
Disposes the current object.
Declaration Syntax
C# Visual Basic Visual C++
public void Dispose()
Public Sub Dispose
public:
virtual void Dispose() sealed

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.AclEngine (Module: ScrewTurn.Wiki.AclEngine) Version: 3.0.2.500 (3.0.2.500)


disposed Field

disposed Field
ScrewTurn Wiki ► ScrewTurn.Wiki.AclEngine ► AclStorerBase ► disposed
Indicates whether the object was disposed.
Declaration Syntax
C# Visual Basic Visual C++
protected bool disposed
Protected disposed As Boolean
protected:
bool disposed

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.AclEngine (Module: ScrewTurn.Wiki.AclEngine) Version: 3.0.2.500 (3.0.2.500)


LoadData Method

LoadData Method
ScrewTurn Wiki ► ScrewTurn.Wiki.AclEngine ► AclStorerBase ► LoadData()()()
Loads the data and injects it in the instance of IAclManager.
Declaration Syntax
C# Visual Basic Visual C++
public void LoadData()
Public Sub LoadData
public:
void LoadData()

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.AclEngine (Module: ScrewTurn.Wiki.AclEngine) Version: 3.0.2.500 (3.0.2.500)


LoadDataInternal Method

LoadDataInternal Method
ScrewTurn Wiki ► ScrewTurn.Wiki.AclEngine ► AclStorerBase ► LoadDataInternal()()()
Loads data from storage.
Declaration Syntax
C# Visual Basic Visual C++
protected abstract AclEntry[] LoadDataInternal()
Protected MustOverride Function LoadDataInternal As AclEntry()
protected:
virtual array<AclEntry^>^ LoadDataInternal() abstract
Return Value
The loaded ACL entries.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.AclEngine (Module: ScrewTurn.Wiki.AclEngine) Version: 3.0.2.500 (3.0.2.500)


StoreEntries Method (entries)

StoreEntries Method (entries)
ScrewTurn Wiki ► ScrewTurn.Wiki.AclEngine ► AclStorerBase ► StoreEntries(array<AclEntry>[]()[])
Stores some entries.
Declaration Syntax
C# Visual Basic Visual C++
protected abstract void StoreEntries(
    AclEntry[] entries
)
Protected MustOverride Sub StoreEntries ( _
    entries As AclEntry() _
)
protected:
virtual void StoreEntries(
    array<AclEntry^>^ entries
) abstract
Parameters
entries (array< AclEntry >[]()[][])
The entries to store.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.AclEngine (Module: ScrewTurn.Wiki.AclEngine) Version: 3.0.2.500 (3.0.2.500)


Authorization Enumeration

Authorization Enumeration
ScrewTurn Wiki ► ScrewTurn.Wiki.AclEngine ► Authorization
Lists legal authorization values.
Declaration Syntax
C# Visual Basic Visual C++
public enum Authorization
Public Enumeration Authorization
public enum class Authorization
Members
Member | Description
Granted | Authorization granted.
Denied | Authorization denied.
Unknown | No information available.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.AclEngine (Module: ScrewTurn.Wiki.AclEngine) Version: 3.0.2.500 (3.0.2.500)


Change Enumeration

Change Enumeration
ScrewTurn Wiki ► ScrewTurn.Wiki.AclEngine ► Change
Lists legal changes for ACL entries.
Declaration Syntax
C# Visual Basic Visual C++
public enum Change
Public Enumeration Change
public enum class Change
Members
Member | Description
EntryStored | An entry is stored.
EntryDeleted | An entry is deleted.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.AclEngine (Module: ScrewTurn.Wiki.AclEngine) Version: 3.0.2.500 (3.0.2.500)


IAclManager Interface

IAclManager Interface
ScrewTurn Wiki ► ScrewTurn.Wiki.AclEngine ► IAclManager
Defines an interface for an ACL manager.
Declaration Syntax
C# Visual Basic Visual C++
public interface IAclManager
Public Interface IAclManager
public interface class IAclManager
Members
All Members | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | AclChanged | Event fired when an ACL entry is stored or deleted.
 | DeleteEntriesForResource(String) | Deletes all the ACL entries for a resource.
 | DeleteEntriesForSubject(String) | Deletes all the ACL entries for a subject.
 | DeleteEntry(String, String, String) | Deletes an ACL entry.
 | InitializeData(array<AclEntry>[]()[]) | Initializes the manager data.
 | RenameResource(String, String) | Renames a resource.
 | RetrieveAllEntries()()() | Retrieves all the ACL entries for a resource.
 | RetrieveEntriesForResource(String) | Retrieves all the ACL entries for a resource.
 | RetrieveEntriesForSubject(String) | Retrieves all the ACL entries for a subject.
 | StoreEntry(String, String, String, Value) | Stores a new ACL entry.
 | TotalEntries | Gets the total number of ACL entries.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.AclEngine (Module: ScrewTurn.Wiki.AclEngine) Version: 3.0.2.500 (3.0.2.500)


AclChanged Event

AclChanged Event
ScrewTurn Wiki ► ScrewTurn.Wiki.AclEngine ► IAclManager ► AclChanged
Event fired when an ACL entry is stored or deleted.
Declaration Syntax
C# Visual Basic Visual C++
event EventHandler<AclChangedEventArgs> AclChanged
Event AclChanged As EventHandler(Of AclChangedEventArgs)
 event EventHandler<AclChangedEventArgs^>^ AclChanged {
    void add (EventHandler<AclChangedEventArgs^>^ value);
    void remove (EventHandler<AclChangedEventArgs^>^ value);
}

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.AclEngine (Module: ScrewTurn.Wiki.AclEngine) Version: 3.0.2.500 (3.0.2.500)


DeleteEntriesForResource Method (resource)

DeleteEntriesForResource Method (resource)
ScrewTurn Wiki ► ScrewTurn.Wiki.AclEngine ► IAclManager ► DeleteEntriesForResource(String)
Deletes all the ACL entries for a resource.
Declaration Syntax
C# Visual Basic Visual C++
bool DeleteEntriesForResource(
    string resource
)
Function DeleteEntriesForResource ( _
    resource As String _
) As Boolean
bool DeleteEntriesForResource(
    String^ resource
)
Parameters
resource (String)
The controlled resource.
Return Value
true if the entries are deleted, false otherwise.
Exceptions
Exception | Condition
ArgumentNullException | If resource is null.
ArgumentException | If resource is empty.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.AclEngine (Module: ScrewTurn.Wiki.AclEngine) Version: 3.0.2.500 (3.0.2.500)


DeleteEntriesForSubject Method (subject)

DeleteEntriesForSubject Method (subject)
ScrewTurn Wiki ► ScrewTurn.Wiki.AclEngine ► IAclManager ► DeleteEntriesForSubject(String)
Deletes all the ACL entries for a subject.
Declaration Syntax
C# Visual Basic Visual C++
bool DeleteEntriesForSubject(
    string subject
)
Function DeleteEntriesForSubject ( _
    subject As String _
) As Boolean
bool DeleteEntriesForSubject(
    String^ subject
)
Parameters
subject (String)
The subject.
Return Value
true if the entries are deleted, false otherwise.
Exceptions
Exception | Condition
ArgumentNullException | If subject is null.
ArgumentException | If subject is empty.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.AclEngine (Module: ScrewTurn.Wiki.AclEngine) Version: 3.0.2.500 (3.0.2.500)


DeleteEntry Method (resource, action, subject)

DeleteEntry Method (resource, action, subject)
ScrewTurn Wiki ► ScrewTurn.Wiki.AclEngine ► IAclManager ► DeleteEntry(String, String, String)
Deletes an ACL entry.
Declaration Syntax
C# Visual Basic Visual C++
bool DeleteEntry(
    string resource,
    string action,
    string subject
)
Function DeleteEntry ( _
    resource As String, _
    action As String, _
    subject As String _
) As Boolean
bool DeleteEntry(
    String^ resource,
    String^ action,
    String^ subject
)
Parameters
resource (String)
The controlled resource.
action (String)
The action on the controlled resource.
subject (String)
The subject whose access to the resource/action is controlled.
Return Value
true if the entry is deleted, false otherwise.
Exceptions
Exception | Condition
ArgumentNullException | If resource, action or subject are null.
ArgumentException | If resource, action or subject are empty.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.AclEngine (Module: ScrewTurn.Wiki.AclEngine) Version: 3.0.2.500 (3.0.2.500)


InitializeData Method (entries)

InitializeData Method (entries)
ScrewTurn Wiki ► ScrewTurn.Wiki.AclEngine ► IAclManager ► InitializeData(array<AclEntry>[]()[])
Initializes the manager data.
Declaration Syntax
C# Visual Basic Visual C++
void InitializeData(
    AclEntry[] entries
)
Sub InitializeData ( _
    entries As AclEntry() _
)
void InitializeData(
    array<AclEntry^>^ entries
)
Parameters
entries (array< AclEntry >[]()[][])
The ACL entries.
Exceptions
Exception | Condition
ArgumentNullException | If entries is null.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.AclEngine (Module: ScrewTurn.Wiki.AclEngine) Version: 3.0.2.500 (3.0.2.500)


RenameResource Method (resource, newName)

RenameResource Method (resource, newName)
ScrewTurn Wiki ► ScrewTurn.Wiki.AclEngine ► IAclManager ► RenameResource(String, String)
Renames a resource.
Declaration Syntax
C# Visual Basic Visual C++
bool RenameResource(
    string resource,
    string newName
)
Function RenameResource ( _
    resource As String, _
    newName As String _
) As Boolean
bool RenameResource(
    String^ resource,
    String^ newName
)
Parameters
resource (String)
The resource.
newName (String)
The new name of the resource.
Return Value
true if the resource is renamed, false otherwise.
Exceptions
Exception | Condition
ArgumentNullException | If resource or newName are null.
ArgumentException | If resource or newName are empty.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.AclEngine (Module: ScrewTurn.Wiki.AclEngine) Version: 3.0.2.500 (3.0.2.500)


RetrieveAllEntries Method

RetrieveAllEntries Method
ScrewTurn Wiki ► ScrewTurn.Wiki.AclEngine ► IAclManager ► RetrieveAllEntries()()()
Retrieves all the ACL entries for a resource.
Declaration Syntax
C# Visual Basic Visual C++
AclEntry[] RetrieveAllEntries()
Function RetrieveAllEntries As AclEntry()
array<AclEntry^>^ RetrieveAllEntries()
Return Value
The entries.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.AclEngine (Module: ScrewTurn.Wiki.AclEngine) Version: 3.0.2.500 (3.0.2.500)


RetrieveEntriesForResource Method (resource)

RetrieveEntriesForResource Method (resource)
ScrewTurn Wiki ► ScrewTurn.Wiki.AclEngine ► IAclManager ► RetrieveEntriesForResource(String)
Retrieves all the ACL entries for a resource.
Declaration Syntax
C# Visual Basic Visual C++
AclEntry[] RetrieveEntriesForResource(
    string resource
)
Function RetrieveEntriesForResource ( _
    resource As String _
) As AclEntry()
array<AclEntry^>^ RetrieveEntriesForResource(
    String^ resource
)
Parameters
resource (String)
The resource.
Return Value
The entries.
Exceptions
Exception | Condition
ArgumentNullException | If resource is null.
ArgumentException | If resource is empty.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.AclEngine (Module: ScrewTurn.Wiki.AclEngine) Version: 3.0.2.500 (3.0.2.500)


RetrieveEntriesForSubject Method (subject)

RetrieveEntriesForSubject Method (subject)
ScrewTurn Wiki ► ScrewTurn.Wiki.AclEngine ► IAclManager ► RetrieveEntriesForSubject(String)
Retrieves all the ACL entries for a subject.
Declaration Syntax
C# Visual Basic Visual C++
AclEntry[] RetrieveEntriesForSubject(
    string subject
)
Function RetrieveEntriesForSubject ( _
    subject As String _
) As AclEntry()
array<AclEntry^>^ RetrieveEntriesForSubject(
    String^ subject
)
Parameters
subject (String)
The subject.
Return Value
The entries.
Exceptions
Exception | Condition
ArgumentNullException | If subject is null.
ArgumentException | If subject is empty.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.AclEngine (Module: ScrewTurn.Wiki.AclEngine) Version: 3.0.2.500 (3.0.2.500)


StoreEntry Method (resource, action, subject, value)

StoreEntry Method (resource, action, subject, value)
ScrewTurn Wiki ► ScrewTurn.Wiki.AclEngine ► IAclManager ► StoreEntry(String, String, String, Value)
Stores a new ACL entry.
Declaration Syntax
C# Visual Basic Visual C++
bool StoreEntry(
    string resource,
    string action,
    string subject,
    Value value
)
Function StoreEntry ( _
    resource As String, _
    action As String, _
    subject As String, _
    value As Value _
) As Boolean
bool StoreEntry(
    String^ resource,
    String^ action,
    String^ subject,
    Value value
)
Parameters
resource (String)
The controlled resource.
action (String)
The action on the controlled resource.
subject (String)
The subject whose access to the resource/action is controlled.
value (Value)
The value of the entry.
Return Value
true if the entry is stored, false otherwise.
Exceptions
Exception | Condition
ArgumentNullException | If resource, action or subject are null.
ArgumentException | If resource, action or subject are empty.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.AclEngine (Module: ScrewTurn.Wiki.AclEngine) Version: 3.0.2.500 (3.0.2.500)


TotalEntries Property

TotalEntries Property
ScrewTurn Wiki ► ScrewTurn.Wiki.AclEngine ► IAclManager ► TotalEntries
Gets the total number of ACL entries.
Declaration Syntax
C# Visual Basic Visual C++
int TotalEntries { get; }
ReadOnly Property TotalEntries As Integer
property int TotalEntries {
    int get ();
}

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.AclEngine (Module: ScrewTurn.Wiki.AclEngine) Version: 3.0.2.500 (3.0.2.500)


Value Enumeration

Value Enumeration
ScrewTurn Wiki ► ScrewTurn.Wiki.AclEngine ► Value
Lists legal ACL Entry values.
Declaration Syntax
C# Visual Basic Visual C++
public enum Value
Public Enumeration Value
public enum class Value
Members
Member | Description
Deny | Deny the action.
Grant | Grant the action.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.AclEngine (Module: ScrewTurn.Wiki.AclEngine) Version: 3.0.2.500 (3.0.2.500)


ScrewTurn.Wiki.PluginFramework Namespace

ScrewTurn.Wiki.PluginFramework Namespace
ScrewTurn Wiki ► ScrewTurn.Wiki.PluginFramework
Namespace containing Plugin Framework types.
Declaration Syntax
C# Visual Basic Visual C++
namespace ScrewTurn.Wiki.PluginFramework
Namespace ScrewTurn.Wiki.PluginFramework
namespace ScrewTurn.Wiki.PluginFramework
Types
All Types Classes Interfaces Enumerations Delegates
Icon | Type | Description
 | CacheData | Enumerates the parts of the cache that can be cleared.
 | CategoryInfo | Represents a Page Category. A page can be binded with one or more categories (within the same Provider); this class manages this binding.
 | CategoryNameComparer | Compares two CategoryInfo objects, using the FullName as parameter.
 | Change | Lists possible changes.
 | ComponentInformation | Contains information about a Provider.
 | ContentTemplate | Contains a template for page content.
 | ContentTemplateNameComparer | Compares two ContentTemplate objects.
 | ContextInformation | Contains information about the Context of the page formatting.
 | EntryType | Enumerates the Types of Log Entries.
 | FileActivity | Lists legal file activities.
 | FileActivityEventArgs | Contains arguments for the File Activity event.
 | FileDetails | Contains information about a file.
 | FormattingContext | Lists formatting contexts.
 | FormattingPhase | Enumerates formatting Phases.
 | ICacheProviderV30 | Provides an interface for implementing a Cache Provider for ScrewTurn Wiki.
 | IFilesStorageProviderV30 | It is the interface that must be implemented in order to create a custom Files Storage Provider for ScrewTurn Wiki.
 | IFormatterProviderV30 | It is the interface that must be implemented in order to create a custom Formatter Provider for ScrewTurn Wiki.
 | IHostV30 | It is the interface that the ScrewTurn Wiki's Host object implements.
 | InvalidConfigurationException | Represents errors that occur while decoding the Provider's Configuration String.
 | IPagesStorageProviderV30 | It is the interface that must be implemented in order to create a custom Pages Storage Provider for ScrewTurn Wiki.
 | IProviderV30 | The base interface that all the Providers must implement. All the Provider Type-specific interfaces inherit from this one or from a one, either directly or from a derived interface.
 | ISettingsStorageProviderV30 | The interface that must be implemented in order to create a custom Settings and Log Storage Provider for ScrewTurn Wiki.
 | IStorageProviderV30 | The base interface that all the Storage Providers must implement. All the Provider Type-specific interfaces inherit from this one or from a one, either directly or from a derived interface
 | IUsersStorageProviderV30 | It is the interface that must be implemented in order to create a custom Users Storage Provider for ScrewTurn Wiki.
 | LogEntry | Represents a Log Entry.
 | LogEntryType | Enumerates the Types of Log Entries.
 | LoggingLevel | Lists legal logging level values.
 | Message | Represents a Page Discussion Message.
 | MessageDateTimeComparer | Compares two Message object using their Date/Time as parameter.
 | MessageDocument | Represents a message for use with the search engine.
 | MetaDataItem | Lists legal meta-data items (global items have a integer value greater than or equal to 100.
 | NamespaceActivity | Lists legal namespace activity types.
 | NamespaceActivityEventArgs | Contains arguments for Namespace activity events.
 | NamespaceComparer | Compares two NamespaceInfo objects, using the Name as parameter.
 | NamespaceInfo | Represents a namespace.
 | NameTools | Implements useful tools for handling full object names.
 | NavigationPath | Represents a Navigation Path.
 | NavigationPathComparer | Compares two NavigationPaths objects, using FullName as the comparison parameter.
 | PageActivity | Lists legal Page Activity types.
 | PageActivityEventArgs | Contains arguments for Page Activity events.
 | PageContent | Contains the Content of a Page.
 | PageDocument | Represents a page for use with the search engine.
 | PageInfo | Contains basic information about a Page.
 | PageNameComparer | Compares two PageInfo objects, using the FullName as parameter.
 | RecentChange | Represents a Change.
 | SaveMode | Lists legal saving modes.
 | SettingName | Enumerates the Setting values' names.
 | Snippet | Contains a Snippet.
 | SnippetNameComparer | Compares two Snippet objects.
 | StandardAclManager | Implements a standard ACL Manager.
 | StandardIndex | Implements a standard index class.
 | StDirectoryInfo | Contains information about a directory.
 | StFileInfo | Contains information about a file.
 | Tokenizer | Defines a delegate that tokenizes strings.
 | ToolbarItem | Enumerates the toolbar items that can be added.
 | UserAccountActivity | Lists legal User Account Activity types.
 | UserAccountActivityEventArgs | Contains arguments for User Account Activity events.
 | UserGroup | Represents a group of users.
 | UserGroupActivity | Lists legal user group activity types.
 | UserGroupActivityEventArgs | Contains arguments for the User Group Activity events.
 | UserGroupComparer | Implements a comparer for UserGroup objects, using Name as parameter.
 | UserInfo | Describes a User.
 | UsernameComparer | Provides a method for comparing two UserInfo objects, comparing their Username.


CacheData Enumeration

CacheData Enumeration
ScrewTurn Wiki ► ScrewTurn.Wiki.PluginFramework ► CacheData
Enumerates the parts of the cache that can be cleared.
Declaration Syntax
C# Visual Basic Visual C++
public enum CacheData
Public Enumeration CacheData
public enum class CacheData
Members
Member | Description
Pages | All the pages data.
MetaFiles | All the meta-files (Header, Footer, Sidebar, etc.).

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.PluginFramework (Module: ScrewTurn.Wiki.PluginFramework) Version: 3.0.2.500 (3.0.2.500)


CategoryInfo Class

CategoryInfo Class
ScrewTurn Wiki ► ScrewTurn.Wiki.PluginFramework ► CategoryInfo
Represents a Page Category. A page can be binded with one or more categories (within the same Provider); this class manages this binding.
Declaration Syntax
C# Visual Basic Visual C++
public class CategoryInfo
Public Class CategoryInfo
public ref class CategoryInfo
Members
All Members | Constructors | Methods | Properties | Fields
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | CategoryInfo(String, IPagesStorageProviderV30) | Initializes a new instance of the CategoryInfo class.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | FullName | Gets or sets the full name of the Category, such as 'Namespace.Category' or 'Category'.
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | name | The Name of the Category.
 | nspace | The namespace of the Category.
 | pages | The Pages of the Category.
 | Pages | Gets or sets the Page array, containing their names.
 | provider | The Provider that handles the Category.
 | Provider | Gets or sets the Provider that manages the Category.
 | ToString()()() | Gets a string representation of the current object. (Overrides Object.ToString()()().)
Inheritance Hierarchy
Object
CategoryInfo

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.PluginFramework (Module: ScrewTurn.Wiki.PluginFramework) Version: 3.0.2.500 (3.0.2.500)


CategoryInfo Constructor (fullName, provider)

CategoryInfo Constructor (fullName, provider)
ScrewTurn Wiki ► ScrewTurn.Wiki.PluginFramework ► CategoryInfo ► CategoryInfo(String, IPagesStorageProviderV30)
Initializes a new instance of the CategoryInfo class.
Declaration Syntax
C# Visual Basic Visual C++
public CategoryInfo(
    string fullName,
    IPagesStorageProviderV30 provider
)
Public Sub New ( _
    fullName As String, _
    provider As IPagesStorageProviderV30 _
)
public:
CategoryInfo(
    String^ fullName,
    IPagesStorageProviderV30^ provider
)
Parameters
fullName (String)
The Full Name of the Category.
provider (IPagesStorageProviderV30)
The Storage that manages the category.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.PluginFramework (Module: ScrewTurn.Wiki.PluginFramework) Version: 3.0.2.500 (3.0.2.500)


FullName Property

FullName Property
ScrewTurn Wiki ► ScrewTurn.Wiki.PluginFramework ► CategoryInfo ► FullName
Gets or sets the full name of the Category, such as 'Namespace.Category' or 'Category'.
Declaration Syntax
C# Visual Basic Visual C++
public string FullName { get; set; }
Public Property FullName As String
public:
property String^ FullName {
    String^ get ();
    void set (String^ value);
}

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.PluginFramework (Module: ScrewTurn.Wiki.PluginFramework) Version: 3.0.2.500 (3.0.2.500)


name Field

name Field
ScrewTurn Wiki ► ScrewTurn.Wiki.PluginFramework ► CategoryInfo ► name
The Name of the Category.
Declaration Syntax
C# Visual Basic Visual C++
protected string name
Protected name As String
protected:
String^ name

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.PluginFramework (Module: ScrewTurn.Wiki.PluginFramework) Version: 3.0.2.500 (3.0.2.500)


nspace Field

nspace Field
ScrewTurn Wiki ► ScrewTurn.Wiki.PluginFramework ► CategoryInfo ► nspace
The namespace of the Category.
Declaration Syntax
C# Visual Basic Visual C++
protected string nspace
Protected nspace As String
protected:
String^ nspace

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.PluginFramework (Module: ScrewTurn.Wiki.PluginFramework) Version: 3.0.2.500 (3.0.2.500)


pages Field

pages Field
ScrewTurn Wiki ► ScrewTurn.Wiki.PluginFramework ► CategoryInfo ► pages
The Pages of the Category.
Declaration Syntax
C# Visual Basic Visual C++
protected string[] pages
Protected pages As String()
protected:
array<String^>^ pages

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.PluginFramework (Module: ScrewTurn.Wiki.PluginFramework) Version: 3.0.2.500 (3.0.2.500)


Pages Property

Pages Property
ScrewTurn Wiki ► ScrewTurn.Wiki.PluginFramework ► CategoryInfo ► Pages
Gets or sets the Page array, containing their names.
Declaration Syntax
C# Visual Basic Visual C++
public string[] Pages { get; set; }
Public Property Pages As String()
public:
property array<String^>^ Pages {
    array<String^>^ get ();
    void set (array<String^>^ value);
}

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.PluginFramework (Module: ScrewTurn.Wiki.PluginFramework) Version: 3.0.2.500 (3.0.2.500)


provider Field

provider Field
ScrewTurn Wiki ► ScrewTurn.Wiki.PluginFramework ► CategoryInfo ► provider
The Provider that handles the Category.
Declaration Syntax
C# Visual Basic Visual C++
protected IPagesStorageProviderV30 provider
Protected provider As IPagesStorageProviderV30
protected:
IPagesStorageProviderV30^ provider

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.PluginFramework (Module: ScrewTurn.Wiki.PluginFramework) Version: 3.0.2.500 (3.0.2.500)


Provider Property

Provider Property
ScrewTurn Wiki ► ScrewTurn.Wiki.PluginFramework ► CategoryInfo ► Provider
Gets or sets the Provider that manages the Category.
Declaration Syntax
C# Visual Basic Visual C++
public IPagesStorageProviderV30 Provider { get; set; }
Public Property Provider As IPagesStorageProviderV30
public:
property IPagesStorageProviderV30^ Provider {
    IPagesStorageProviderV30^ get ();
    void set (IPagesStorageProviderV30^ value);
}

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.PluginFramework (Module: ScrewTurn.Wiki.PluginFramework) Version: 3.0.2.500 (3.0.2.500)


ToString Method

ToString Method
ScrewTurn Wiki ► ScrewTurn.Wiki.PluginFramework ► CategoryInfo ► ToString()()()
Gets a string representation of the current object.
Declaration Syntax
C# Visual Basic Visual C++
public override string ToString()
Public Overrides Function ToString As String
public:
virtual String^ ToString() override
Return Value
The string representation.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.PluginFramework (Module: ScrewTurn.Wiki.PluginFramework) Version: 3.0.2.500 (3.0.2.500)


CategoryNameComparer Class

CategoryNameComparer Class
ScrewTurn Wiki ► ScrewTurn.Wiki.PluginFramework ► CategoryNameComparer
Compares two CategoryInfo objects, using the FullName as parameter.
Declaration Syntax
C# Visual Basic Visual C++
public class CategoryNameComparer : IComparer<CategoryInfo>
Public Class CategoryNameComparer _
    Implements IComparer(Of CategoryInfo)
public ref class CategoryNameComparer : IComparer<CategoryInfo^>
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | CategoryNameComparer()()() | Initializes a new instance of the CategoryNameComparer class
 | Compare(CategoryInfo, CategoryInfo) | Compares two CategoryInfo objects, using the FullName as parameter.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Remarks
The comparison is case insensitive.
Inheritance Hierarchy
Object
CategoryNameComparer

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.PluginFramework (Module: ScrewTurn.Wiki.PluginFramework) Version: 3.0.2.500 (3.0.2.500)


CategoryNameComparer Constructor

CategoryNameComparer Constructor
ScrewTurn Wiki ► ScrewTurn.Wiki.PluginFramework ► CategoryNameComparer ► CategoryNameComparer()()()
Initializes a new instance of the CategoryNameComparer class
Declaration Syntax
C# Visual Basic Visual C++
public CategoryNameComparer()
Public Sub New
public:
CategoryNameComparer()

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.PluginFramework (Module: ScrewTurn.Wiki.PluginFramework) Version: 3.0.2.500 (3.0.2.500)


Compare Method (x, y)

Compare Method (x, y)
ScrewTurn Wiki ► ScrewTurn.Wiki.PluginFramework ► CategoryNameComparer ► Compare(CategoryInfo, CategoryInfo)
Compares two CategoryInfo objects, using the FullName as parameter.
Declaration Syntax
C# Visual Basic Visual C++
public int Compare(
    CategoryInfo x,
    CategoryInfo y
)
Public Function Compare ( _
    x As CategoryInfo, _
    y As CategoryInfo _
) As Integer
public:
virtual int Compare(
    CategoryInfo^ x,
    CategoryInfo^ y
) sealed
Parameters
x (CategoryInfo)
The first object.
y (CategoryInfo)
The second object.
Return Value
The comparison result (-1, 0 or 1).

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.PluginFramework (Module: ScrewTurn.Wiki.PluginFramework) Version: 3.0.2.500 (3.0.2.500)


Change Enumeration

Change Enumeration
ScrewTurn Wiki ► ScrewTurn.Wiki.PluginFramework ► Change
Lists possible changes.
Declaration Syntax
C# Visual Basic Visual C++
public enum Change
Public Enumeration Change
public enum class Change
Members
Member | Description
PageUpdated | A page was updated.
PageDeleted | A page was deleted.
PageRolledBack | A page was rolled back.
PageRenamed | A page was renamed.
MessagePosted | A message was posted to a page discussion.
MessageDeleted | A message was deleted from a page discussion.
MessageEdited | A message was edited in a page discussion.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.PluginFramework (Module: ScrewTurn.Wiki.PluginFramework) Version: 3.0.2.500 (3.0.2.500)


ComponentInformation Class

ComponentInformation Class
ScrewTurn Wiki ► ScrewTurn.Wiki.PluginFramework ► ComponentInformation
Contains information about a Provider.
Declaration Syntax
C# Visual Basic Visual C++
public class ComponentInformation
Public Class ComponentInformation
public ref class ComponentInformation
Members
All Members | Constructors | Methods | Properties | Fields
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ComponentInformation(String, String, String, String, String) | Initializes a new instance of the ComponentInformation class.
 | author | The Author of the Component.
 | Author | Gets the Author of the Component.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | name | The Name of the Component.
 | Name | Gets the Name of the Component.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | updateUrl | The component update URL which should point to a text file containing one or two rows (separated by \r\n or \n): 1. A list of increasing versions separated by pipes, such as "1.0.0|1.0.1|1.0.2" (without quotes) 2. (optional) The absolute HTTP URL of the latest DLL, for example "http://www.server.com/update/MyAssembly.dll" (without quotes) The second row should only be present if the provider can be updated automatically without any type of user intervention, i.e. by simply replacing the DLL and restarting the wiki. If the DLL contains multiple providers, they are all updated (obviously). The new DLL must have the same name of the being-replaced DLL (in other words, a provider must reside in the same DLL forever in order to be updated automatically).
 | UpdateUrl | Gets the update URL of the component.
 | url | The info URL of the Component/Author.
 | Url | Gets the info URL of the Component/Author.
 | version | The component version.
 | Version | Gets the component version.
Inheritance Hierarchy
Object
ComponentInformation

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.PluginFramework (Module: ScrewTurn.Wiki.PluginFramework) Version: 3.0.2.500 (3.0.2.500)


ComponentInformation Constructor (name, author, version, url, updateUrl)

ComponentInformation Constructor (name, author, version, url, updateUrl)
ScrewTurn Wiki ► ScrewTurn.Wiki.PluginFramework ► ComponentInformation ► ComponentInformation(String, String, String, String, String)
Initializes a new instance of the ComponentInformation class.
Declaration Syntax
C# Visual Basic Visual C++
public ComponentInformation(
    string name,
    string author,
    string version,
    string url,
    string updateUrl
)
Public Sub New ( _
    name As String, _
    author As String, _
    version As String, _
    url As String, _
    updateUrl As String _
)
public:
ComponentInformation(
    String^ name,
    String^ author,
    String^ version,
    String^ url,
    String^ updateUrl
)
Parameters
name (String)
The Name of the Component.
author (String)
The Author of the Component.
version (String)
The component version.
url (String)
The info URL of the Component/Author.
updateUrl (String)
The update URL of the component, or null.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.PluginFramework (Module: ScrewTurn.Wiki.PluginFramework) Version: 3.0.2.500 (3.0.2.500)


author Field

author Field
ScrewTurn Wiki ► ScrewTurn.Wiki.PluginFramework ► ComponentInformation ► author
The Author of the Component.
Declaration Syntax
C# Visual Basic Visual C++
protected string author
Protected author As String
protected:
String^ author

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.PluginFramework (Module: ScrewTurn.Wiki.PluginFramework) Version: 3.0.2.500 (3.0.2.500)


Author Property

Author Property
ScrewTurn Wiki ► ScrewTurn.Wiki.PluginFramework ► ComponentInformation ► Author
Gets the Author of the Component.
Declaration Syntax
C# Visual Basic Visual C++
public string Author { get; }
Public ReadOnly Property Author As String
public:
property String^ Author {
    String^ get ();
}

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.PluginFramework (Module: ScrewTurn.Wiki.PluginFramework) Version: 3.0.2.500 (3.0.2.500)


name Field

name Field
ScrewTurn Wiki ► ScrewTurn.Wiki.PluginFramework ► ComponentInformation ► name
The Name of the Component.
Declaration Syntax
C# Visual Basic Visual C++
protected string name
Protected name As String
protected:
String^ name

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.PluginFramework (Module: ScrewTurn.Wiki.PluginFramework) Version: 3.0.2.500 (3.0.2.500)


Name Property

Name Property
ScrewTurn Wiki ► ScrewTurn.Wiki.PluginFramework ► ComponentInformation ► Name
Gets the Name of the Component.
Declaration Syntax
C# Visual Basic Visual C++
public string Name { get; }
Public ReadOnly Property Name As String
public:
property String^ Name {
    String^ get ();
}

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.PluginFramework (Module: ScrewTurn.Wiki.PluginFramework) Version: 3.0.2.500 (3.0.2.500)


updateUrl Field

updateUrl Field
ScrewTurn Wiki ► ScrewTurn.Wiki.PluginFramework ► ComponentInformation ► updateUrl
The component update URL which should point to a text file containing one or two rows (separated by \r\n or \n): 1. A list of increasing versions separated by pipes, such as "1.0.0|1.0.1|1.0.2" (without quotes) 2. (optional) The absolute HTTP URL of the latest DLL, for example "http://www.server.com/update/MyAssembly.dll" (without quotes) The second row should only be present if the provider can be updated automatically without any type of user intervention, i.e. by simply replacing the DLL and restarting the wiki. If the DLL contains multiple providers, they are all updated (obviously). The new DLL must have the same name of the being-replaced DLL (in other words, a provider must reside in the same DLL forever in order to be updated automatically).
Declaration Syntax
C# Visual Basic Visual C++
protected string updateUrl
Protected updateUrl As String
protected:
String^ updateUrl

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.PluginFramework (Module: ScrewTurn.Wiki.PluginFramework) Version: 3.0.2.500 (3.0.2.500)


UpdateUrl Property

UpdateUrl Property
ScrewTurn Wiki ► ScrewTurn.Wiki.PluginFramework ► ComponentInformation ► UpdateUrl
Gets the update URL of the component.
Declaration Syntax
C# Visual Basic Visual C++
public string UpdateUrl { get; }
Public ReadOnly Property UpdateUrl As String
public:
property String^ UpdateUrl {
    String^ get ();
}

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.PluginFramework (Module: ScrewTurn.Wiki.PluginFramework) Version: 3.0.2.500 (3.0.2.500)


url Field

url Field
ScrewTurn Wiki ► ScrewTurn.Wiki.PluginFramework ► ComponentInformation ► url
The info URL of the Component/Author.
Declaration Syntax
C# Visual Basic Visual C++
protected string url
Protected url As String
protected:
String^ url

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.PluginFramework (Module: ScrewTurn.Wiki.PluginFramework) Version: 3.0.2.500 (3.0.2.500)


Url Property

Url Property
ScrewTurn Wiki ► ScrewTurn.Wiki.PluginFramework ► ComponentInformation ► Url
Gets the info URL of the Component/Author.
Declaration Syntax
C# Visual Basic Visual C++
public string Url { get; }
Public ReadOnly Property Url As String
public:
property String^ Url {
    String^ get ();
}

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.PluginFramework (Module: ScrewTurn.Wiki.PluginFramework) Version: 3.0.2.500 (3.0.2.500)


version Field

version Field
ScrewTurn Wiki ► ScrewTurn.Wiki.PluginFramework ► ComponentInformation ► version
The component version.
Declaration Syntax
C# Visual Basic Visual C++
protected string version
Protected version As String
protected:
String^ version

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.PluginFramework (Module: ScrewTurn.Wiki.PluginFramework) Version: 3.0.2.500 (3.0.2.500)


Version Property

Version Property
ScrewTurn Wiki ► ScrewTurn.Wiki.PluginFramework ► ComponentInformation ► Version
Gets the component version.
Declaration Syntax
C# Visual Basic Visual C++
public string Version { get; }
Public ReadOnly Property Version As String
public:
property String^ Version {
    String^ get ();
}

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.PluginFramework (Module: ScrewTurn.Wiki.PluginFramework) Version: 3.0.2.500 (3.0.2.500)


ContentTemplate Class

ContentTemplate Class
ScrewTurn Wiki ► ScrewTurn.Wiki.PluginFramework ► ContentTemplate
Contains a template for page content.
Declaration Syntax
C# Visual Basic Visual C++
public class ContentTemplate
Public Class ContentTemplate
public ref class ContentTemplate
Members
All Members | Constructors | Methods | Properties | Fields
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ContentTemplate(String, String, IPagesStorageProviderV30) | Initializes a new instance of the ContentTemplate class.
 | content | The content of the template.
 | Content | Gets the content of the template.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | name | The name of the template.
 | Name | Gets the name of the template.
 | provider | The provider handling the template.
 | Provider | Gets the provider handling the template.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
ContentTemplate

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.PluginFramework (Module: ScrewTurn.Wiki.PluginFramework) Version: 3.0.2.500 (3.0.2.500)


ContentTemplate Constructor (name, content, provider)

ContentTemplate Constructor (name, content, provider)
ScrewTurn Wiki ► ScrewTurn.Wiki.PluginFramework ► ContentTemplate ► ContentTemplate(String, String, IPagesStorageProviderV30)
Initializes a new instance of the ContentTemplate class.
Declaration Syntax
C# Visual Basic Visual C++
public ContentTemplate(
    string name,
    string content,
    IPagesStorageProviderV30 provider
)
Public Sub New ( _
    name As String, _
    content As String, _
    provider As IPagesStorageProviderV30 _
)
public:
ContentTemplate(
    String^ name,
    String^ content,
    IPagesStorageProviderV30^ provider
)
Parameters
name (String)
The name of the template.
content (String)
The content of the template.
provider (IPagesStorageProviderV30)
The provider handling the template.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.PluginFramework (Module: ScrewTurn.Wiki.PluginFramework) Version: 3.0.2.500 (3.0.2.500)


content Field

content Field
ScrewTurn Wiki ► ScrewTurn.Wiki.PluginFramework ► ContentTemplate ► content
The content of the template.
Declaration Syntax
C# Visual Basic Visual C++
protected string content
Protected content As String
protected:
String^ content

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.PluginFramework (Module: ScrewTurn.Wiki.PluginFramework) Version: 3.0.2.500 (3.0.2.500)


Content Property

Content Property
ScrewTurn Wiki ► ScrewTurn.Wiki.PluginFramework ► ContentTemplate ► Content
Gets the content of the template.
Declaration Syntax
C# Visual Basic Visual C++
public string Content { get; }
Public ReadOnly Property Content As String
public:
property String^ Content {
    String^ get ();
}

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.PluginFramework (Module: ScrewTurn.Wiki.PluginFramework) Version: 3.0.2.500 (3.0.2.500)


name Field

name Field
ScrewTurn Wiki ► ScrewTurn.Wiki.PluginFramework ► ContentTemplate ► name
The name of the template.
Declaration Syntax
C# Visual Basic Visual C++
protected string name
Protected name As String
protected:
String^ name

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.PluginFramework (Module: ScrewTurn.Wiki.PluginFramework) Version: 3.0.2.500 (3.0.2.500)


Name Property

Name Property
ScrewTurn Wiki ► ScrewTurn.Wiki.PluginFramework ► ContentTemplate ► Name
Gets the name of the template.
Declaration Syntax
C# Visual Basic Visual C++
public string Name { get; }
Public ReadOnly Property Name As String
public:
property String^ Name {
    String^ get ();
}

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.PluginFramework (Module: ScrewTurn.Wiki.PluginFramework) Version: 3.0.2.500 (3.0.2.500)


provider Field

provider Field
ScrewTurn Wiki ► ScrewTurn.Wiki.PluginFramework ► ContentTemplate ► provider
The provider handling the template.
Declaration Syntax
C# Visual Basic Visual C++
protected IPagesStorageProviderV30 provider
Protected provider As IPagesStorageProviderV30
protected:
IPagesStorageProviderV30^ provider

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.PluginFramework (Module: ScrewTurn.Wiki.PluginFramework) Version: 3.0.2.500 (3.0.2.500)


Provider Property

Provider Property
ScrewTurn Wiki ► ScrewTurn.Wiki.PluginFramework ► ContentTemplate ► Provider
Gets the provider handling the template.
Declaration Syntax
C# Visual Basic Visual C++
public IPagesStorageProviderV30 Provider { get; }
Public ReadOnly Property Provider As IPagesStorageProviderV30
public:
property IPagesStorageProviderV30^ Provider {
    IPagesStorageProviderV30^ get ();
}

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.PluginFramework (Module: ScrewTurn.Wiki.PluginFramework) Version: 3.0.2.500 (3.0.2.500)


ContentTemplateNameComparer Class

ContentTemplateNameComparer Class
ScrewTurn Wiki ► ScrewTurn.Wiki.PluginFramework ► ContentTemplateNameComparer
Compares two ContentTemplate objects.
Declaration Syntax
C# Visual Basic Visual C++
public class ContentTemplateNameComparer : IComparer<ContentTemplate>
Public Class ContentTemplateNameComparer _
    Implements IComparer(Of ContentTemplate)
public ref class ContentTemplateNameComparer : IComparer<ContentTemplate^>
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | ContentTemplateNameComparer()()() | Initializes a new instance of the ContentTemplateNameComparer class
 | Compare(ContentTemplate, ContentTemplate) | Compares the name of two ContentTemplate objects.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
ContentTemplateNameComparer

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.PluginFramework (Module: ScrewTurn.Wiki.PluginFramework) Version: 3.0.2.500 (3.0.2.500)


ContentTemplateNameComparer Constructor

ContentTemplateNameComparer Constructor
ScrewTurn Wiki ► ScrewTurn.Wiki.PluginFramework ► ContentTemplateNameComparer ► ContentTemplateNameComparer()()()
Initializes a new instance of the ContentTemplateNameComparer class
Declaration Syntax
C# Visual Basic Visual C++
public ContentTemplateNameComparer()
Public Sub New
public:
ContentTemplateNameComparer()

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.PluginFramework (Module: ScrewTurn.Wiki.PluginFramework) Version: 3.0.2.500 (3.0.2.500)


Compare Method (x, y)

Compare Method (x, y)
ScrewTurn Wiki ► ScrewTurn.Wiki.PluginFramework ► ContentTemplateNameComparer ► Compare(ContentTemplate, ContentTemplate)
Compares the name of two ContentTemplate objects.
Declaration Syntax
C# Visual Basic Visual C++
public int Compare(
    ContentTemplate x,
    ContentTemplate y
)
Public Function Compare ( _
    x As ContentTemplate, _
    y As ContentTemplate _
) As Integer
public:
virtual int Compare(
    ContentTemplate^ x,
    ContentTemplate^ y
) sealed
Parameters
x (ContentTemplate)
The first ContentTemplate.
y (ContentTemplate)
The second ContentTemplate.
Return Value
The result of the comparison (1, 0 or -1).

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.PluginFramework (Module: ScrewTurn.Wiki.PluginFramework) Version: 3.0.2.500 (3.0.2.500)


ContextInformation Class

ContextInformation Class
ScrewTurn Wiki ► ScrewTurn.Wiki.PluginFramework ► ContextInformation
Contains information about the Context of the page formatting.
Declaration Syntax
C# Visual Basic Visual C++
public class ContextInformation
Public Class ContextInformation
public ref class ContextInformation
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ContextInformation(Boolean, Boolean, FormattingContext, PageInfo, String, HttpContext, String, array<String>[]()[]) | Initializes a new instance of the FormatContext class.
 | Context | Gets the formatting context.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | ForIndexing | Gets a value indicating whether the formatting is being done for content indexing.
 | ForWysiwyg | Gets a value indicating whether the formatting is being done for display in the WYSIWYG editor.
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | Groups | Gets the groups the user is member of (or null).
 | HttpContext | Gets the current HTTP Context object.
 | Language | Gets the current Thread's Language (for example en-US).
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Page | Gets the Page Information.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | Username | Gets the Username of the current User (or null).
Inheritance Hierarchy
Object
ContextInformation

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.PluginFramework (Module: ScrewTurn.Wiki.PluginFramework) Version: 3.0.2.500 (3.0.2.500)


ContextInformation Constructor (forIndexing, forWysiwyg, context, page, language, httpContext, username, groups)

ContextInformation Constructor (forIndexing, forWysiwyg, context, page, language, httpContext, username, groups)
ScrewTurn Wiki ► ScrewTurn.Wiki.PluginFramework ► ContextInformation ► ContextInformation(Boolean, Boolean, FormattingContext, PageInfo, String, HttpContext, String, array<String>[]()[])
Initializes a new instance of the FormatContext class.
Declaration Syntax
C# Visual Basic Visual C++
public ContextInformation(
    bool forIndexing,
    bool forWysiwyg,
    FormattingContext context,
    PageInfo page,
    string language,
    HttpContext httpContext,
    string username,
    string[] groups
)
Public Sub New ( _
    forIndexing As Boolean, _
    forWysiwyg As Boolean, _
    context As FormattingContext, _
    page As PageInfo, _
    language As String, _
    httpContext As HttpContext, _
    username As String, _
    groups As String() _
)
public:
ContextInformation(
    bool forIndexing,
    bool forWysiwyg,
    FormattingContext context,
    PageInfo^ page,
    String^ language,
    HttpContext^ httpContext,
    String^ username,
    array<String^>^ groups
)
Parameters
forIndexing (Boolean)
A value indicating whether the formatting is being done for content indexing.
forWysiwyg (Boolean)
A value indicating whether the formatting is being done for display in the WYSIWYG editor.
context (FormattingContext)
The formatting context.
page (PageInfo)
The Page Information, if any, null otherwise.
language (String)
The current Thread's language (for example "en-US").
httpContext (HttpContext)
The current HTTP Context object.
username (String)
The current User's Username (or null).
groups (array< String >[]()[][])
The groups the user is member of (or null).

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.PluginFramework (Module: ScrewTurn.Wiki.PluginFramework) Version: 3.0.2.500 (3.0.2.500)


Context Property

Context Property
ScrewTurn Wiki ► ScrewTurn.Wiki.PluginFramework ► ContextInformation ► Context
Gets the formatting context.
Declaration Syntax
C# Visual Basic Visual C++
public FormattingContext Context { get; }
Public ReadOnly Property Context As FormattingContext
public:
property FormattingContext Context {
    FormattingContext get ();
}

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.PluginFramework (Module: ScrewTurn.Wiki.PluginFramework) Version: 3.0.2.500 (3.0.2.500)


ForIndexing Property

ForIndexing Property
ScrewTurn Wiki ► ScrewTurn.Wiki.PluginFramework ► ContextInformation ► ForIndexing
Gets a value indicating whether the formatting is being done for content indexing.
Declaration Syntax
C# Visual Basic Visual C++
public bool ForIndexing { get; }
Public ReadOnly Property ForIndexing As Boolean
public:
property bool ForIndexing {
    bool get ();
}

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.PluginFramework (Module: ScrewTurn.Wiki.PluginFramework) Version: 3.0.2.500 (3.0.2.500)


ForWysiwyg Property

ForWysiwyg Property
ScrewTurn Wiki ► ScrewTurn.Wiki.PluginFramework ► ContextInformation ► ForWysiwyg
Gets a value indicating whether the formatting is being done for display in the WYSIWYG editor.
Declaration Syntax
C# Visual Basic Visual C++
public bool ForWysiwyg { get; }
Public ReadOnly Property ForWysiwyg As Boolean
public:
property bool ForWysiwyg {
    bool get ();
}

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.PluginFramework (Module: ScrewTurn.Wiki.PluginFramework) Version: 3.0.2.500 (3.0.2.500)


Groups Property

Groups Property
ScrewTurn Wiki ► ScrewTurn.Wiki.PluginFramework ► ContextInformation ► Groups
Gets the groups the user is member of (or null).
Declaration Syntax
C# Visual Basic Visual C++
public string[] Groups { get; }
Public ReadOnly Property Groups As String()
public:
property array<String^>^ Groups {
    array<String^>^ get ();
}

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.PluginFramework (Module: ScrewTurn.Wiki.PluginFramework) Version: 3.0.2.500 (3.0.2.500)


HttpContext Property

HttpContext Property
ScrewTurn Wiki ► ScrewTurn.Wiki.PluginFramework ► ContextInformation ► HttpContext
Gets the current HTTP Context object.
Declaration Syntax
C# Visual Basic Visual C++
public HttpContext HttpContext { get; }
Public ReadOnly Property HttpContext As HttpContext
public:
property HttpContext^ HttpContext {
    HttpContext^ get ();
}

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.PluginFramework (Module: ScrewTurn.Wiki.PluginFramework) Version: 3.0.2.500 (3.0.2.500)


Language Property

Language Property
ScrewTurn Wiki ► ScrewTurn.Wiki.PluginFramework ► ContextInformation ► Language
Gets the current Thread's Language (for example en-US).
Declaration Syntax
C# Visual Basic Visual C++
public string Language { get; }
Public ReadOnly Property Language As String
public:
property String^ Language {
    String^ get ();
}

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.PluginFramework (Module: ScrewTurn.Wiki.PluginFramework) Version: 3.0.2.500 (3.0.2.500)


Page Property

Page Property
ScrewTurn Wiki ► ScrewTurn.Wiki.PluginFramework ► ContextInformation ► Page
Gets the Page Information.
Declaration Syntax
C# Visual Basic Visual C++
public PageInfo Page { get; }
Public ReadOnly Property Page As PageInfo
public:
property PageInfo^ Page {
    PageInfo^ get ();
}

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.PluginFramework (Module: ScrewTurn.Wiki.PluginFramework) Version: 3.0.2.500 (3.0.2.500)


Username Property

Username Property
ScrewTurn Wiki ► ScrewTurn.Wiki.PluginFramework ► ContextInformation ► Username
Gets the Username of the current User (or null).
Declaration Syntax
C# Visual Basic Visual C++
public string Username { get; }
Public ReadOnly Property Username As String
public:
property String^ Username {
    String^ get ();
}
Remarks
If the Username is not available, the return value is null.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.PluginFramework (Module: ScrewTurn.Wiki.PluginFramework) Version: 3.0.2.500 (3.0.2.500)


EntryType Enumeration

EntryType Enumeration
ScrewTurn Wiki ► ScrewTurn.Wiki.PluginFramework ► EntryType
Enumerates the Types of Log Entries.
Declaration Syntax
C# Visual Basic Visual C++
public enum EntryType
Public Enumeration EntryType
public enum class EntryType
Members
Member | Description
General | Represents a simple Message.
Warning | Represents a Warning.
Error | Represents an Error.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.PluginFramework (Module: ScrewTurn.Wiki.PluginFramework) Version: 3.0.2.500 (3.0.2.500)


FileActivity Enumeration

FileActivity Enumeration
ScrewTurn Wiki ► ScrewTurn.Wiki.PluginFramework ► FileActivity
Lists legal file activities.
Declaration Syntax
C# Visual Basic Visual C++
public enum FileActivity
Public Enumeration FileActivity
public enum class FileActivity
Members
Member | Description
FileUploaded | A file has been uploaded.
FileRenamed | A file has been renamed.
FileDeleted | A file has been deleted.
DirectoryCreated | A directory has been created.
DirectoryRenamed | A directory has been renamed.
DirectoryDeleted | A directory (and all its contents) has been deleted.
AttachmentUploaded | An attachment has been uploaded.
AttachmentRenamed | An attachment has been renamed.
AttachmentDeleted | An attachment has been deleted.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.PluginFramework (Module: ScrewTurn.Wiki.PluginFramework) Version: 3.0.2.500 (3.0.2.500)


FileActivityEventArgs Class

FileActivityEventArgs Class
ScrewTurn Wiki ► ScrewTurn.Wiki.PluginFramework ► FileActivityEventArgs
Contains arguments for the File Activity event.
Declaration Syntax
C# Visual Basic Visual C++
public class FileActivityEventArgs : EventArgs
Public Class FileActivityEventArgs _
    Inherits EventArgs
public ref class FileActivityEventArgs : public EventArgs
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | FileActivityEventArgs(StFileInfo, String, StDirectoryInfo, String, PageInfo, FileActivity) | Initializes a new instance of the FileActivityEventArgs class.
 | Activity | Gets the activity.
 | Directory | Gets the directory that changed, if any.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | File | Gets the file that changed, if any.
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | OldDirectoryName | Gets the old name of the directory, if any.
 | OldFileName | Gets the old name of the file, if any.
 | Page | Gets the page owning the attachment, if any.
 | Provider | Gets the provider.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | EventArgs
 |  | FileActivityEventArgs

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.PluginFramework (Module: ScrewTurn.Wiki.PluginFramework) Version: 3.0.2.500 (3.0.2.500)


FileActivityEventArgs Constructor (file, oldFileName, directory, oldDirectoryName, page, activity)

FileActivityEventArgs Constructor (file, oldFileName, directory, oldDirectoryName, page, activity)
ScrewTurn Wiki ► ScrewTurn.Wiki.PluginFramework ► FileActivityEventArgs ► FileActivityEventArgs(StFileInfo, String, StDirectoryInfo, String, PageInfo, FileActivity)
Initializes a new instance of the FileActivityEventArgs class.
Declaration Syntax
C# Visual Basic Visual C++
public FileActivityEventArgs(
    StFileInfo file,
    string oldFileName,
    StDirectoryInfo directory,
    string oldDirectoryName,
    PageInfo page,
    FileActivity activity
)
Public Sub New ( _
    file As StFileInfo, _
    oldFileName As String, _
    directory As StDirectoryInfo, _
    oldDirectoryName As String, _
    page As PageInfo, _
    activity As FileActivity _
)
public:
FileActivityEventArgs(
    StFileInfo^ file,
    String^ oldFileName,
    StDirectoryInfo^ directory,
    String^ oldDirectoryName,
    PageInfo^ page,
    FileActivity activity
)
Parameters
file (StFileInfo)
The file that changed, if any (full path).
oldFileName (String)
The old name of the file, if any (full path).
directory (StDirectoryInfo)
The directory that changed, if any (full path).
oldDirectoryName (String)
The old name of the directory, if any (full path).
page (PageInfo)
The page owning the attachment, if any.
activity (FileActivity)
The activity.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.PluginFramework (Module: ScrewTurn.Wiki.PluginFramework) Version: 3.0.2.500 (3.0.2.500)


Activity Property

Activity Property
ScrewTurn Wiki ► ScrewTurn.Wiki.PluginFramework ► FileActivityEventArgs ► Activity
Gets the activity.
Declaration Syntax
C# Visual Basic Visual C++
public FileActivity Activity { get; }
Public ReadOnly Property Activity As FileActivity
public:
property FileActivity Activity {
    FileActivity get ();
}

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.PluginFramework (Module: ScrewTurn.Wiki.PluginFramework) Version: 3.0.2.500 (3.0.2.500)


Directory Property

Directory Property
ScrewTurn Wiki ► ScrewTurn.Wiki.PluginFramework ► FileActivityEventArgs ► Directory
Gets the directory that changed, if any.
Declaration Syntax
C# Visual Basic Visual C++
public StDirectoryInfo Directory { get; }
Public ReadOnly Property Directory As StDirectoryInfo
public:
property StDirectoryInfo^ Directory {
    StDirectoryInfo^ get ();
}

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.PluginFramework (Module: ScrewTurn.Wiki.PluginFramework) Version: 3.0.2.500 (3.0.2.500)


File Property

File Property
ScrewTurn Wiki ► ScrewTurn.Wiki.PluginFramework ► FileActivityEventArgs ► File
Gets the file that changed, if any.
Declaration Syntax
C# Visual Basic Visual C++
public StFileInfo File { get; }
Public ReadOnly Property File As StFileInfo
public:
property StFileInfo^ File {
    StFileInfo^ get ();
}

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.PluginFramework (Module: ScrewTurn.Wiki.PluginFramework) Version: 3.0.2.500 (3.0.2.500)


OldDirectoryName Property

OldDirectoryName Property
ScrewTurn Wiki ► ScrewTurn.Wiki.PluginFramework ► FileActivityEventArgs ► OldDirectoryName
Gets the old name of the directory, if any.
Declaration Syntax
C# Visual Basic Visual C++
public string OldDirectoryName { get; }
Public ReadOnly Property OldDirectoryName As String
public:
property String^ OldDirectoryName {
    String^ get ();
}

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.PluginFramework (Module: ScrewTurn.Wiki.PluginFramework) Version: 3.0.2.500 (3.0.2.500)


OldFileName Property

OldFileName Property
ScrewTurn Wiki ► ScrewTurn.Wiki.PluginFramework ► FileActivityEventArgs ► OldFileName
Gets the old name of the file, if any.
Declaration Syntax
C# Visual Basic Visual C++
public string OldFileName { get; }
Public ReadOnly Property OldFileName As String
public:
property String^ OldFileName {
    String^ get ();
}

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.PluginFramework (Module: ScrewTurn.Wiki.PluginFramework) Version: 3.0.2.500 (3.0.2.500)


Page Property

Page Property
ScrewTurn Wiki ► ScrewTurn.Wiki.PluginFramework ► FileActivityEventArgs ► Page
Gets the page owning the attachment, if any.
Declaration Syntax
C# Visual Basic Visual C++
public PageInfo Page { get; }
Public ReadOnly Property Page As PageInfo
public:
property PageInfo^ Page {
    PageInfo^ get ();
}

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.PluginFramework (Module: ScrewTurn.Wiki.PluginFramework) Version: 3.0.2.500 (3.0.2.500)


Provider Property

Provider Property
ScrewTurn Wiki ► ScrewTurn.Wiki.PluginFramework ► FileActivityEventArgs ► Provider
Gets the provider.
Declaration Syntax
C# Visual Basic Visual C++
public IFilesStorageProviderV30 Provider { get; }
Public ReadOnly Property Provider As IFilesStorageProviderV30
public:
property IFilesStorageProviderV30^ Provider {
    IFilesStorageProviderV30^ get ();
}

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.PluginFramework (Module: ScrewTurn.Wiki.PluginFramework) Version: 3.0.2.500 (3.0.2.500)


FileDetails Class

FileDetails Class
ScrewTurn Wiki ► ScrewTurn.Wiki.PluginFramework ► FileDetails
Contains information about a file.
Declaration Syntax
C# Visual Basic Visual C++
public class FileDetails
Public Class FileDetails
public ref class FileDetails
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | FileDetails(Int64, DateTime, Int32) | Initializes a new instance of the FileDetails class.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | LastModified | Gets the modification date/time.
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | RetrievalCount | Gets the number of times the file was retrieved.
 | Size | Gets the size of the file in bytes.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | FileDetails
 |  | StFileInfo

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.PluginFramework (Module: ScrewTurn.Wiki.PluginFramework) Version: 3.0.2.500 (3.0.2.500)


FileDetails Constructor (size, lastModified, retrievalCount)

FileDetails Constructor (size, lastModified, retrievalCount)
ScrewTurn Wiki ► ScrewTurn.Wiki.PluginFramework ► FileDetails ► FileDetails(Int64, DateTime, Int32)
Initializes a new instance of the FileDetails class.
Declaration Syntax
C# Visual Basic Visual C++
public FileDetails(
    long size,
    DateTime lastModified,
    int retrievalCount
)
Public Sub New ( _
    size As Long, _
    lastModified As DateTime, _
    retrievalCount As Integer _
)
public:
FileDetails(
    long long size,
    DateTime lastModified,
    int retrievalCount
)
Parameters
size (Int64)
The size of the file in bytes.
lastModified (DateTime)
The modification date/time.
retrievalCount (Int32)
The number of times the file was retrieved.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.PluginFramework (Module: ScrewTurn.Wiki.PluginFramework) Version: 3.0.2.500 (3.0.2.500)


LastModified Property

LastModified Property
ScrewTurn Wiki ► ScrewTurn.Wiki.PluginFramework ► FileDetails ► LastModified
Gets the modification date/time.
Declaration Syntax
C# Visual Basic Visual C++
public DateTime LastModified { get; }
Public ReadOnly Property LastModified As DateTime
public:
property DateTime LastModified {
    DateTime get ();
}

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.PluginFramework (Module: ScrewTurn.Wiki.PluginFramework) Version: 3.0.2.500 (3.0.2.500)


RetrievalCount Property

RetrievalCount Property
ScrewTurn Wiki ► ScrewTurn.Wiki.PluginFramework ► FileDetails ► RetrievalCount
Gets the number of times the file was retrieved.
Declaration Syntax
C# Visual Basic Visual C++
public int RetrievalCount { get; }
Public ReadOnly Property RetrievalCount As Integer
public:
property int RetrievalCount {
    int get ();
}

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.PluginFramework (Module: ScrewTurn.Wiki.PluginFramework) Version: 3.0.2.500 (3.0.2.500)


Size Property

Size Property
ScrewTurn Wiki ► ScrewTurn.Wiki.PluginFramework ► FileDetails ► Size
Gets the size of the file in bytes.
Declaration Syntax
C# Visual Basic Visual C++
public long Size { get; }
Public ReadOnly Property Size As Long
public:
property long long Size {
    long long get ();
}

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.PluginFramework (Module: ScrewTurn.Wiki.PluginFramework) Version: 3.0.2.500 (3.0.2.500)


FormattingContext Enumeration

FormattingContext Enumeration
ScrewTurn Wiki ► ScrewTurn.Wiki.PluginFramework ► FormattingContext
Lists formatting contexts.
Declaration Syntax
C# Visual Basic Visual C++
public enum FormattingContext
Public Enumeration FormattingContext
public enum class FormattingContext
Members
Member | Description
Header | The overall header.
Footer | The overall footer.
Sidebar | The sidebar.
PageHeader | The page header.
PageFooter | The page footer.
PageContent | The page content.
TranscludedPageContent | Transcluded page content.
MessageBody | The body of a message.
Other | Any other context.
Unknown | No know context.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.PluginFramework (Module: ScrewTurn.Wiki.PluginFramework) Version: 3.0.2.500 (3.0.2.500)


FormattingPhase Enumeration

FormattingPhase Enumeration
ScrewTurn Wiki ► ScrewTurn.Wiki.PluginFramework ► FormattingPhase
Enumerates formatting Phases.
Declaration Syntax
C# Visual Basic Visual C++
public enum FormattingPhase
Public Enumeration FormattingPhase
public enum class FormattingPhase
Members
Member | Description
Phase1 | Phase 1, performed before the internal formatting step.
Phase2 | Phase 2, performed after the internal formatting step.
Phase3 | Phase 3, performed before sending the page content to the client.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.PluginFramework (Module: ScrewTurn.Wiki.PluginFramework) Version: 3.0.2.500 (3.0.2.500)


ICacheProviderV30 Interface

ICacheProviderV30 Interface
ScrewTurn Wiki ► ScrewTurn.Wiki.PluginFramework ► ICacheProviderV30
Provides an interface for implementing a Cache Provider for ScrewTurn Wiki.
Declaration Syntax
C# Visual Basic Visual C++
public interface ICacheProviderV30 : IProviderV30
Public Interface ICacheProviderV30 _
    Implements IProviderV30
public interface class ICacheProviderV30 : IProviderV30
Members
All Members | Methods | Properties
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | AddRedirection(String, String) | Adds the redirection information for a page (overwrites the previous value, if any).
 | CancelEditingSession(String, String) | Cancels an editing session.
 | ClearPageContentCache()()() | Clears the Page Content cache.
 | ClearPseudoCache()()() | Clears the Pseudo-Cache.
 | ClearRedirections()()() | Clears all the redirections information.
 | ConfigHelpHtml | Gets a brief summary of the configuration string format, in HTML. Returns null if no configuration is needed. (Inherited from IProviderV30.)
 | CutCache(Int32) | Reduces the size of the Page Content cache, removing the least-recently used items.
 | FormatterPageCacheUsage | Gets the numer of Pages whose formatted content is currently stored in the cache.
 | GetFormattedPageContent(PageInfo) | Gets the partially-formatted content (text) of a Page, previously stored in the cache.
 | GetPageContent(PageInfo) | Gets the Content of a Page, previously stored in cache.
 | GetPseudoCacheValue(String) | Gets the value of a Pseudo-cache item, previously stored in the cache.
 | GetRedirectionDestination(String) | Gets the destination of a redirection.
 | Information | Gets the Information about the Provider. (Inherited from IProviderV30.)
 | Init(IHostV30, String) | Initializes the Storage Provider. (Inherited from IProviderV30.)
 | IsPageBeingEdited(String, String) | Finds whether a Page is being edited by a different user.
 | OnlineUsers | Gets or sets the number of users online.
 | PageCacheUsage | Gets the number of Pages whose content is currently stored in the cache.
 | RemovePage(PageInfo) | Removes a Page from the cache.
 | RemovePageFromRedirections(String) | Removes a pge from both sources and destinations.
 | RenewEditingSession(String, String) | Adds or updates an editing session.
 | SetFormattedPageContent(PageInfo, String) | Sets the partially-preformatted content (text) of a Page.
 | SetPageContent(PageInfo, PageContent) | Sets the Content of a Page.
 | SetPseudoCacheValue(String, String) | Sets the value of a Pseudo-cache item.
 | Shutdown()()() | Method invoked on shutdown. (Inherited from IProviderV30.)
 | WhosEditing(String) | Gets the username of the user who's editing a page.
Remarks
The Cache should preferably reside in RAM for performance purposes.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.PluginFramework (Module: ScrewTurn.Wiki.PluginFramework) Version: 3.0.2.500 (3.0.2.500)


AddRedirection Method (source, destination)

AddRedirection Method (source, destination)
ScrewTurn Wiki ► ScrewTurn.Wiki.PluginFramework ► ICacheProviderV30 ► AddRedirection(String, String)
Adds the redirection information for a page (overwrites the previous value, if any).
Declaration Syntax
C# Visual Basic Visual C++
void AddRedirection(
    string source,
    string destination
)
Sub AddRedirection ( _
    source As String, _
    destination As String _
)
void AddRedirection(
    String^ source,
    String^ destination
)
Parameters
source (String)
The source page.
destination (String)
The destination page.
Exceptions
Exception | Condition
ArgumentNullException | If source or destination are null.
ArgumentException | If source or destination are empty.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.PluginFramework (Module: ScrewTurn.Wiki.PluginFramework) Version: 3.0.2.500 (3.0.2.500)


CancelEditingSession Method (page, user)

CancelEditingSession Method (page, user)
ScrewTurn Wiki ► ScrewTurn.Wiki.PluginFramework ► ICacheProviderV30 ► CancelEditingSession(String, String)
Cancels an editing session.
Declaration Syntax
C# Visual Basic Visual C++
void CancelEditingSession(
    string page,
    string user
)
Sub CancelEditingSession ( _
    page As String, _
    user As String _
)
void CancelEditingSession(
    String^ page,
    String^ user
)
Parameters
page (String)
The Page.
user (String)
The User.
Exceptions
Exception | Condition
ArgumentNullException | If page or user are null.
ArgumentException | If page or user are empty.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.PluginFramework (Module: ScrewTurn.Wiki.PluginFramework) Version: 3.0.2.500 (3.0.2.500)


ClearPageContentCache Method

ClearPageContentCache Method
ScrewTurn Wiki ► ScrewTurn.Wiki.PluginFramework ► ICacheProviderV30 ► ClearPageContentCache()()()
Clears the Page Content cache.
Declaration Syntax
C# Visual Basic Visual C++
void ClearPageContentCache()
Sub ClearPageContentCache
void ClearPageContentCache()

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.PluginFramework (Module: ScrewTurn.Wiki.PluginFramework) Version: 3.0.2.500 (3.0.2.500)


ClearPseudoCache Method

ClearPseudoCache Method
ScrewTurn Wiki ► ScrewTurn.Wiki.PluginFramework ► ICacheProviderV30 ► ClearPseudoCache()()()
Clears the Pseudo-Cache.
Declaration Syntax
C# Visual Basic Visual C++
void ClearPseudoCache()
Sub ClearPseudoCache
void ClearPseudoCache()

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.PluginFramework (Module: ScrewTurn.Wiki.PluginFramework) Version: 3.0.2.500 (3.0.2.500)


ClearRedirections Method

ClearRedirections Method
ScrewTurn Wiki ► ScrewTurn.Wiki.PluginFramework ► ICacheProviderV30 ► ClearRedirections()()()
Clears all the redirections information.
Declaration Syntax
C# Visual Basic Visual C++
void ClearRedirections()
Sub ClearRedirections
void ClearRedirections()

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.PluginFramework (Module: ScrewTurn.Wiki.PluginFramework) Version: 3.0.2.500 (3.0.2.500)


CutCache Method (cutSize)

CutCache Method (cutSize)
ScrewTurn Wiki ► ScrewTurn.Wiki.PluginFramework ► ICacheProviderV30 ► CutCache(Int32)
Reduces the size of the Page Content cache, removing the least-recently used items.
Declaration Syntax
C# Visual Basic Visual C++
void CutCache(
    int cutSize
)
Sub CutCache ( _
    cutSize As Integer _
)
void CutCache(
    int cutSize
)
Parameters
cutSize (Int32)
The number of Pages to remove.
Exceptions
Exception | Condition
ArgumentOutOfRangeException | If cutSize is less than or equal to zero.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.PluginFramework (Module: ScrewTurn.Wiki.PluginFramework) Version: 3.0.2.500 (3.0.2.500)


FormatterPageCacheUsage Property

FormatterPageCacheUsage Property
ScrewTurn Wiki ► ScrewTurn.Wiki.PluginFramework ► ICacheProviderV30 ► FormatterPageCacheUsage
Gets the numer of Pages whose formatted content is currently stored in the cache.
Declaration Syntax
C# Visual Basic Visual C++
int FormatterPageCacheUsage { get; }
ReadOnly Property FormatterPageCacheUsage As Integer
property int FormatterPageCacheUsage {
    int get ();
}

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.PluginFramework (Module: ScrewTurn.Wiki.PluginFramework) Version: 3.0.2.500 (3.0.2.500)


GetFormattedPageContent Method (pageInfo)

GetFormattedPageContent Method (pageInfo)
ScrewTurn Wiki ► ScrewTurn.Wiki.PluginFramework ► ICacheProviderV30 ► GetFormattedPageContent(PageInfo)
Gets the partially-formatted content (text) of a Page, previously stored in the cache.
Declaration Syntax
C# Visual Basic Visual C++
string GetFormattedPageContent(
    PageInfo pageInfo
)
Function GetFormattedPageContent ( _
    pageInfo As PageInfo _
) As String
String^ GetFormattedPageContent(
    PageInfo^ pageInfo
)
Parameters
pageInfo (PageInfo)
The Page Info object related to the content being requested.
Return Value
The partially-formatted content, or null if the item is not found.
Exceptions
Exception | Condition
ArgumentNullException | If pageInfo is null.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.PluginFramework (Module: ScrewTurn.Wiki.PluginFramework) Version: 3.0.2.500 (3.0.2.500)


GetPageContent Method (pageInfo)

GetPageContent Method (pageInfo)
ScrewTurn Wiki ► ScrewTurn.Wiki.PluginFramework ► ICacheProviderV30 ► GetPageContent(PageInfo)
Gets the Content of a Page, previously stored in cache.
Declaration Syntax
C# Visual Basic Visual C++
PageContent GetPageContent(
    PageInfo pageInfo
)
Function GetPageContent ( _
    pageInfo As PageInfo _
) As PageContent
PageContent^ GetPageContent(
    PageInfo^ pageInfo
)
Parameters
pageInfo (PageInfo)
The Page Info object related to the Content being requested.
Return Value
The Page Content object, or null if the item is not found.
Exceptions
Exception | Condition
ArgumentNullException | If pageInfo is null.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.PluginFramework (Module: ScrewTurn.Wiki.PluginFramework) Version: 3.0.2.500 (3.0.2.500)


GetPseudoCacheValue Method (name)

GetPseudoCacheValue Method (name)
ScrewTurn Wiki ► ScrewTurn.Wiki.PluginFramework ► ICacheProviderV30 ► GetPseudoCacheValue(String)
Gets the value of a Pseudo-cache item, previously stored in the cache.
Declaration Syntax
C# Visual Basic Visual C++
string GetPseudoCacheValue(
    string name
)
Function GetPseudoCacheValue ( _
    name As String _
) As String
String^ GetPseudoCacheValue(
    String^ name
)
Parameters
name (String)
The name of the item being requested.
Return Value
The value of the item, or null if the item is not found.
Exceptions
Exception | Condition
ArgumentNullException | If name is null.
ArgumentException | If name is empty.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.PluginFramework (Module: ScrewTurn.Wiki.PluginFramework) Version: 3.0.2.500 (3.0.2.500)


GetRedirectionDestination Method (source)

GetRedirectionDestination Method (source)
ScrewTurn Wiki ► ScrewTurn.Wiki.PluginFramework ► ICacheProviderV30 ► GetRedirectionDestination(String)
Gets the destination of a redirection.
Declaration Syntax
C# Visual Basic Visual C++
string GetRedirectionDestination(
    string source
)
Function GetRedirectionDestination ( _
    source As String _
) As String
String^ GetRedirectionDestination(
    String^ source
)
Parameters
source (String)
The source page.
Return Value
The destination page, if any, null otherwise.
Exceptions
Exception | Condition
ArgumentNullException | If source is null.
ArgumentException | If source is empty.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.PluginFramework (Module: ScrewTurn.Wiki.PluginFramework) Version: 3.0.2.500 (3.0.2.500)


IsPageBeingEdited Method (page, currentUser)

IsPageBeingEdited Method (page, currentUser)
ScrewTurn Wiki ► ScrewTurn.Wiki.PluginFramework ► ICacheProviderV30 ► IsPageBeingEdited(String, String)
Finds whether a Page is being edited by a different user.
Declaration Syntax
C# Visual Basic Visual C++
bool IsPageBeingEdited(
    string page,
    string currentUser
)
Function IsPageBeingEdited ( _
    page As String, _
    currentUser As String _
) As Boolean
bool IsPageBeingEdited(
    String^ page,
    String^ currentUser
)
Parameters
page (String)
The Page.
currentUser (String)
The User who is requesting the status of the Page.
Return Value
True if the Page is being edited by another User.
Exceptions
Exception | Condition
ArgumentNullException | If page or currentUser are null.
ArgumentException | If page or currentUser are empty.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.PluginFramework (Module: ScrewTurn.Wiki.PluginFramework) Version: 3.0.2.500 (3.0.2.500)


OnlineUsers Property

OnlineUsers Property
ScrewTurn Wiki ► ScrewTurn.Wiki.PluginFramework ► ICacheProviderV30 ► OnlineUsers
Gets or sets the number of users online.
Declaration Syntax
C# Visual Basic Visual C++
int OnlineUsers { get; set; }
Property OnlineUsers As Integer
property int OnlineUsers {
    int get ();
    void set (int value);
}

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.PluginFramework (Module: ScrewTurn.Wiki.PluginFramework) Version: 3.0.2.500 (3.0.2.500)


PageCacheUsage Property

PageCacheUsage Property
ScrewTurn Wiki ► ScrewTurn.Wiki.PluginFramework ► ICacheProviderV30 ► PageCacheUsage
Gets the number of Pages whose content is currently stored in the cache.
Declaration Syntax
C# Visual Basic Visual C++
int PageCacheUsage { get; }
ReadOnly Property PageCacheUsage As Integer
property int PageCacheUsage {
    int get ();
}

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.PluginFramework (Module: ScrewTurn.Wiki.PluginFramework) Version: 3.0.2.500 (3.0.2.500)


RemovePage Method (pageInfo)

RemovePage Method (pageInfo)
ScrewTurn Wiki ► ScrewTurn.Wiki.PluginFramework ► ICacheProviderV30 ► RemovePage(PageInfo)
Removes a Page from the cache.
Declaration Syntax
C# Visual Basic Visual C++
void RemovePage(
    PageInfo pageInfo
)
Sub RemovePage ( _
    pageInfo As PageInfo _
)
void RemovePage(
    PageInfo^ pageInfo
)
Parameters
pageInfo (PageInfo)
The Page Info object related to the Page that has to be removed.
Exceptions
Exception | Condition
ArgumentNullException | If pageInfo is null.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.PluginFramework (Module: ScrewTurn.Wiki.PluginFramework) Version: 3.0.2.500 (3.0.2.500)


RemovePageFromRedirections Method (name)

RemovePageFromRedirections Method (name)
ScrewTurn Wiki ► ScrewTurn.Wiki.PluginFramework ► ICacheProviderV30 ► RemovePageFromRedirections(String)
Removes a pge from both sources and destinations.
Declaration Syntax
C# Visual Basic Visual C++
void RemovePageFromRedirections(
    string name
)
Sub RemovePageFromRedirections ( _
    name As String _
)
void RemovePageFromRedirections(
    String^ name
)
Parameters
name (String)
The name of the page.
Exceptions
Exception | Condition
ArgumentNullException | If name is null.
ArgumentException | If name is empty.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.PluginFramework (Module: ScrewTurn.Wiki.PluginFramework) Version: 3.0.2.500 (3.0.2.500)


RenewEditingSession Method (page, user)

RenewEditingSession Method (page, user)
ScrewTurn Wiki ► ScrewTurn.Wiki.PluginFramework ► ICacheProviderV30 ► RenewEditingSession(String, String)
Adds or updates an editing session.
Declaration Syntax
C# Visual Basic Visual C++
void RenewEditingSession(
    string page,
    string user
)
Sub RenewEditingSession ( _
    page As String, _
    user As String _
)
void RenewEditingSession(
    String^ page,
    String^ user
)
Parameters
page (String)
The edited Page.
user (String)
The User who is editing the Page.
Exceptions
Exception | Condition
ArgumentNullException | If page or user are null.
ArgumentException | If page or user are empty.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.PluginFramework (Module: ScrewTurn.Wiki.PluginFramework) Version: 3.0.2.500 (3.0.2.500)


SetFormattedPageContent Method (pageInfo, content)

SetFormattedPageContent Method (pageInfo, content)
ScrewTurn Wiki ► ScrewTurn.Wiki.PluginFramework ► ICacheProviderV30 ► SetFormattedPageContent(PageInfo, String)
Sets the partially-preformatted content (text) of a Page.
Declaration Syntax
C# Visual Basic Visual C++
void SetFormattedPageContent(
    PageInfo pageInfo,
    string content
)
Sub SetFormattedPageContent ( _
    pageInfo As PageInfo, _
    content As String _
)
void SetFormattedPageContent(
    PageInfo^ pageInfo,
    String^ content
)
Parameters
pageInfo (PageInfo)
The Page Info object related to the content being stored.
content (String)
The partially-preformatted content.
Exceptions
Exception | Condition
ArgumentNullException | If pageInfo or content are null.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.PluginFramework (Module: ScrewTurn.Wiki.PluginFramework) Version: 3.0.2.500 (3.0.2.500)


SetPageContent Method (pageInfo, content)

SetPageContent Method (pageInfo, content)
ScrewTurn Wiki ► ScrewTurn.Wiki.PluginFramework ► ICacheProviderV30 ► SetPageContent(PageInfo, PageContent)
Sets the Content of a Page.
Declaration Syntax
C# Visual Basic Visual C++
void SetPageContent(
    PageInfo pageInfo,
    PageContent content
)
Sub SetPageContent ( _
    pageInfo As PageInfo, _
    content As PageContent _
)
void SetPageContent(
    PageInfo^ pageInfo,
    PageContent^ content
)
Parameters
pageInfo (PageInfo)
The Page Info object related to the Content being stored.
content (PageContent)
The Content of the Page.
Exceptions
Exception | Condition
ArgumentNullException | If pageInfo or content are null.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.PluginFramework (Module: ScrewTurn.Wiki.PluginFramework) Version: 3.0.2.500 (3.0.2.500)


SetPseudoCacheValue Method (name, value)

SetPseudoCacheValue Method (name, value)
ScrewTurn Wiki ► ScrewTurn.Wiki.PluginFramework ► ICacheProviderV30 ► SetPseudoCacheValue(String, String)
Sets the value of a Pseudo-cache item.
Declaration Syntax
C# Visual Basic Visual C++
void SetPseudoCacheValue(
    string name,
    string value
)
Sub SetPseudoCacheValue ( _
    name As String, _
    value As String _
)
void SetPseudoCacheValue(
    String^ name,
    String^ value
)
Parameters
name (String)
The name of the item being stored.
value (String)
The value of the item. If the value is null, then the item should be removed from the cache.
Exceptions
Exception | Condition
ArgumentNullException | If name is null.
ArgumentException | If name is empty.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.PluginFramework (Module: ScrewTurn.Wiki.PluginFramework) Version: 3.0.2.500 (3.0.2.500)


WhosEditing Method (page)

WhosEditing Method (page)
ScrewTurn Wiki ► ScrewTurn.Wiki.PluginFramework ► ICacheProviderV30 ► WhosEditing(String)
Gets the username of the user who's editing a page.
Declaration Syntax
C# Visual Basic Visual C++
string WhosEditing(
    string page
)
Function WhosEditing ( _
    page As String _
) As String
String^ WhosEditing(
    String^ page
)
Parameters
page (String)
The page.
Return Value
The username.
Exceptions
Exception | Condition
ArgumentNullException | If page is null.
ArgumentException | If page is empty.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.PluginFramework (Module: ScrewTurn.Wiki.PluginFramework) Version: 3.0.2.500 (3.0.2.500)


IFilesStorageProviderV30 Interface

IFilesStorageProviderV30 Interface
ScrewTurn Wiki ► ScrewTurn.Wiki.PluginFramework ► IFilesStorageProviderV30
It is the interface that must be implemented in order to create a custom Files Storage Provider for ScrewTurn Wiki.
Declaration Syntax
C# Visual Basic Visual C++
public interface IFilesStorageProviderV30 : IStorageProviderV30,
    IProviderV30
Public Interface IFilesStorageProviderV30 _
    Implements IStorageProviderV30, IProviderV30
public interface class IFilesStorageProviderV30 : IStorageProviderV30,
    IProviderV30
Members
All Members | Methods | Properties
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | ConfigHelpHtml | Gets a brief summary of the configuration string format, in HTML. Returns null if no configuration is needed. (Inherited from IProviderV30.)
 | CreateDirectory(String, String) | Creates a new Directory.
 | DeleteDirectory(String) | Deletes a Directory and all of its content.
 | DeleteFile(String) | Deletes a File.
 | DeletePageAttachment(PageInfo, String) | Deletes a Page Attachment.
 | GetFileDetails(String) | Gets the details of a file.
 | GetPageAttachmentDetails(PageInfo, String) | Gets the details of a page attachment.
 | GetPagesWithAttachments()()() | The the names of the pages with attachments.
 | Information | Gets the Information about the Provider. (Inherited from IProviderV30.)
 | Init(IHostV30, String) | Initializes the Storage Provider. (Inherited from IProviderV30.)
 | ListDirectories(String) | Lists the Directories in the specified directory.
 | ListFiles(String) | Lists the Files in the specified Directory.
 | ListPageAttachments(PageInfo) | Returns the names of the Attachments of a Page.
 | NotifyPageRenaming(PageInfo, PageInfo) | Notifies the Provider that a Page has been renamed.
 | ReadOnly | Gets a value specifying whether the provider is read-only, i.e. it can only provide data and not store it. (Inherited from IStorageProviderV30.)
 | RenameDirectory(String, String) | Renames or moves a Directory.
 | RenameFile(String, String) | Renames or moves a File.
 | RenamePageAttachment(PageInfo, String, String) | Renames a Page Attachment.
 | RetrieveFile(String, Stream, Boolean) | Retrieves a File.
 | RetrievePageAttachment(PageInfo, String, Stream, Boolean) | Retrieves a Page Attachment.
 | SetFileRetrievalCount(String, Int32) | Sets the number of times a file was retrieved.
 | SetPageAttachmentRetrievalCount(PageInfo, String, Int32) | Sets the number of times a page attachment was retrieved.
 | Shutdown()()() | Method invoked on shutdown. (Inherited from IProviderV30.)
 | StoreFile(String, Stream, Boolean) | Stores a file.
 | StorePageAttachment(PageInfo, String, Stream, Boolean) | Stores a Page Attachment.
Remarks
A class that implements this interface should not have any kind of data caching. All directory paths are specified in a UNIX-like fashion, for example "/my/directory/myfile.jpg". All paths must start with '/'. All Directory paths must end with '/'. All paths are case-insensitive.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.PluginFramework (Module: ScrewTurn.Wiki.PluginFramework) Version: 3.0.2.500 (3.0.2.500)


CreateDirectory Method (path, name)

CreateDirectory Method (path, name)
ScrewTurn Wiki ► ScrewTurn.Wiki.PluginFramework ► IFilesStorageProviderV30 ► CreateDirectory(String, String)
Creates a new Directory.
Declaration Syntax
C# Visual Basic Visual C++
bool CreateDirectory(
    string path,
    string name
)
Function CreateDirectory ( _
    path As String, _
    name As String _
) As Boolean
bool CreateDirectory(
    String^ path,
    String^ name
)
Parameters
path (String)
The path to create the new Directory in.
name (String)
The name of the new Directory.
Return Value
true if the Directory is created, false otherwise.
Remarks
If path is "/my/directory" and name is "newdir", a new directory named "/my/directory/newdir" is created.
Exceptions
Exception | Condition
ArgumentNullException | If path or name are null.
ArgumentException | If name is empty or if the directory does not exist, or if the new directory already exists.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.PluginFramework (Module: ScrewTurn.Wiki.PluginFramework) Version: 3.0.2.500 (3.0.2.500)


DeleteDirectory Method (fullPath)

DeleteDirectory Method (fullPath)
ScrewTurn Wiki ► ScrewTurn.Wiki.PluginFramework ► IFilesStorageProviderV30 ► DeleteDirectory(String)
Deletes a Directory and all of its content.
Declaration Syntax
C# Visual Basic Visual C++
bool DeleteDirectory(
    string fullPath
)
Function DeleteDirectory ( _
    fullPath As String _
) As Boolean
bool DeleteDirectory(
    String^ fullPath
)
Parameters
fullPath (String)
The full path of the Directory.
Return Value
true if the Directory is delete, false otherwise.
Exceptions
Exception | Condition
ArgumentNullException | If fullPath is null.
ArgumentException | If fullPath is empty or if it equals '/' or it does not exist.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.PluginFramework (Module: ScrewTurn.Wiki.PluginFramework) Version: 3.0.2.500 (3.0.2.500)


DeleteFile Method (fullName)

DeleteFile Method (fullName)
ScrewTurn Wiki ► ScrewTurn.Wiki.PluginFramework ► IFilesStorageProviderV30 ► DeleteFile(String)
Deletes a File.
Declaration Syntax
C# Visual Basic Visual C++
bool DeleteFile(
    string fullName
)
Function DeleteFile ( _
    fullName As String _
) As Boolean
bool DeleteFile(
    String^ fullName
)
Parameters
fullName (String)
The full name of the File.
Return Value
true if the File is deleted, false otherwise.
Exceptions
Exception | Condition
ArgumentNullException | If fullName is null.
ArgumentException | If fullName is empty or it does not exist.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.PluginFramework (Module: ScrewTurn.Wiki.PluginFramework) Version: 3.0.2.500 (3.0.2.500)


DeletePageAttachment Method (pageInfo, name)

DeletePageAttachment Method (pageInfo, name)
ScrewTurn Wiki ► ScrewTurn.Wiki.PluginFramework ► IFilesStorageProviderV30 ► DeletePageAttachment(PageInfo, String)
Deletes a Page Attachment.
Declaration Syntax
C# Visual Basic Visual C++
bool DeletePageAttachment(
    PageInfo pageInfo,
    string name
)
Function DeletePageAttachment ( _
    pageInfo As PageInfo, _
    name As String _
) As Boolean
bool DeletePageAttachment(
    PageInfo^ pageInfo,
    String^ name
)
Parameters
pageInfo (PageInfo)
The Page Info that owns the Attachment.
name (String)
The name of the Attachment, for example "myfile.jpg".
Return Value
true if the Attachment is deleted, false otherwise.
Exceptions
Exception | Condition
ArgumentNullException | If pageInfo or name are null.
ArgumentException | If name is empty or if the page or attachment do not exist.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.PluginFramework (Module: ScrewTurn.Wiki.PluginFramework) Version: 3.0.2.500 (3.0.2.500)


GetFileDetails Method (fullName)

GetFileDetails Method (fullName)
ScrewTurn Wiki ► ScrewTurn.Wiki.PluginFramework ► IFilesStorageProviderV30 ► GetFileDetails(String)
Gets the details of a file.
Declaration Syntax
C# Visual Basic Visual C++
FileDetails GetFileDetails(
    string fullName
)
Function GetFileDetails ( _
    fullName As String _
) As FileDetails
FileDetails^ GetFileDetails(
    String^ fullName
)
Parameters
fullName (String)
The full name of the file.
Return Value
The details, or null if the file does not exist.
Exceptions
Exception | Condition
ArgumentNullException | If fullName is null.
ArgumentException | If fullName is empty.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.PluginFramework (Module: ScrewTurn.Wiki.PluginFramework) Version: 3.0.2.500 (3.0.2.500)


GetPageAttachmentDetails Method (pageInfo, name)

GetPageAttachmentDetails Method (pageInfo, name)
ScrewTurn Wiki ► ScrewTurn.Wiki.PluginFramework ► IFilesStorageProviderV30 ► GetPageAttachmentDetails(PageInfo, String)
Gets the details of a page attachment.
Declaration Syntax
C# Visual Basic Visual C++
FileDetails GetPageAttachmentDetails(
    PageInfo pageInfo,
    string name
)
Function GetPageAttachmentDetails ( _
    pageInfo As PageInfo, _
    name As String _
) As FileDetails
FileDetails^ GetPageAttachmentDetails(
    PageInfo^ pageInfo,
    String^ name
)
Parameters
pageInfo (PageInfo)
The page that owns the attachment.
name (String)
The name of the attachment, for example "myfile.jpg".
Return Value
The details of the attachment, or null if the attachment does not exist.
Exceptions
Exception | Condition
ArgumentNullException | If pageInfo or name are null.
ArgumentException | If name is empty.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.PluginFramework (Module: ScrewTurn.Wiki.PluginFramework) Version: 3.0.2.500 (3.0.2.500)


GetPagesWithAttachments Method

GetPagesWithAttachments Method
ScrewTurn Wiki ► ScrewTurn.Wiki.PluginFramework ► IFilesStorageProviderV30 ► GetPagesWithAttachments()()()
The the names of the pages with attachments.
Declaration Syntax
C# Visual Basic Visual C++
string[] GetPagesWithAttachments()
Function GetPagesWithAttachments As String()
array<String^>^ GetPagesWithAttachments()
Return Value
The names of the pages with attachments.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.PluginFramework (Module: ScrewTurn.Wiki.PluginFramework) Version: 3.0.2.500 (3.0.2.500)


ListDirectories Method (directory)

ListDirectories Method (directory)
ScrewTurn Wiki ► ScrewTurn.Wiki.PluginFramework ► IFilesStorageProviderV30 ► ListDirectories(String)
Lists the Directories in the specified directory.
Declaration Syntax
C# Visual Basic Visual C++
string[] ListDirectories(
    string directory
)
Function ListDirectories ( _
    directory As String _
) As String()
array<String^>^ ListDirectories(
    String^ directory
)
Parameters
directory (String)
The full directory name, for example "/my/directory". Null, empty or "/" for the root directory.
Return Value
The list of Directories in the Directory.
Exceptions
Exception | Condition
ArgumentException | If directory does not exist.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.PluginFramework (Module: ScrewTurn.Wiki.PluginFramework) Version: 3.0.2.500 (3.0.2.500)


ListFiles Method (directory)

ListFiles Method (directory)
ScrewTurn Wiki ► ScrewTurn.Wiki.PluginFramework ► IFilesStorageProviderV30 ► ListFiles(String)
Lists the Files in the specified Directory.
Declaration Syntax
C# Visual Basic Visual C++
string[] ListFiles(
    string directory
)
Function ListFiles ( _
    directory As String _
) As String()
array<String^>^ ListFiles(
    String^ directory
)
Parameters
directory (String)
The full directory name, for example "/my/directory". Null, empty or "/" for the root directory.
Return Value
The list of Files in the directory.
Exceptions
Exception | Condition
ArgumentException | If directory does not exist.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.PluginFramework (Module: ScrewTurn.Wiki.PluginFramework) Version: 3.0.2.500 (3.0.2.500)


ListPageAttachments Method (pageInfo)

ListPageAttachments Method (pageInfo)
ScrewTurn Wiki ► ScrewTurn.Wiki.PluginFramework ► IFilesStorageProviderV30 ► ListPageAttachments(PageInfo)
Returns the names of the Attachments of a Page.
Declaration Syntax
C# Visual Basic Visual C++
string[] ListPageAttachments(
    PageInfo pageInfo
)
Function ListPageAttachments ( _
    pageInfo As PageInfo _
) As String()
array<String^>^ ListPageAttachments(
    PageInfo^ pageInfo
)
Parameters
pageInfo (PageInfo)
The Page Info object that owns the Attachments.
Return Value
The names, or an empty list.
Exceptions
Exception | Condition
ArgumentNullException | If pageInfo is null.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.PluginFramework (Module: ScrewTurn.Wiki.PluginFramework) Version: 3.0.2.500 (3.0.2.500)


NotifyPageRenaming Method (oldPage, newPage)

NotifyPageRenaming Method (oldPage, newPage)
ScrewTurn Wiki ► ScrewTurn.Wiki.PluginFramework ► IFilesStorageProviderV30 ► NotifyPageRenaming(PageInfo, PageInfo)
Notifies the Provider that a Page has been renamed.
Declaration Syntax
C# Visual Basic Visual C++
void NotifyPageRenaming(
    PageInfo oldPage,
    PageInfo newPage
)
Sub NotifyPageRenaming ( _
    oldPage As PageInfo, _
    newPage As PageInfo _
)
void NotifyPageRenaming(
    PageInfo^ oldPage,
    PageInfo^ newPage
)
Parameters
oldPage (PageInfo)
The old Page Info object.
newPage (PageInfo)
The new Page Info object.
Exceptions
Exception | Condition
ArgumentNullException | If oldPage or newPage are null.
ArgumentException | If the new page is already in use.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.PluginFramework (Module: ScrewTurn.Wiki.PluginFramework) Version: 3.0.2.500 (3.0.2.500)


RenameDirectory Method (oldFullPath, newFullPath)

RenameDirectory Method (oldFullPath, newFullPath)
ScrewTurn Wiki ► ScrewTurn.Wiki.PluginFramework ► IFilesStorageProviderV30 ► RenameDirectory(String, String)
Renames or moves a Directory.
Declaration Syntax
C# Visual Basic Visual C++
bool RenameDirectory(
    string oldFullPath,
    string newFullPath
)
Function RenameDirectory ( _
    oldFullPath As String, _
    newFullPath As String _
) As Boolean
bool RenameDirectory(
    String^ oldFullPath,
    String^ newFullPath
)
Parameters
oldFullPath (String)
The old full path of the Directory.
newFullPath (String)
The new full path of the Directory.
Return Value
true if the Directory is renamed, false otherwise.
Exceptions
Exception | Condition
ArgumentNullException | If oldFullPath or newFullPath are null.
ArgumentException | If oldFullPath or newFullPath are empty or equal to '/', or if the old directory does not exist or the new directory already exists.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.PluginFramework (Module: ScrewTurn.Wiki.PluginFramework) Version: 3.0.2.500 (3.0.2.500)


RenameFile Method (oldFullName, newFullName)

RenameFile Method (oldFullName, newFullName)
ScrewTurn Wiki ► ScrewTurn.Wiki.PluginFramework ► IFilesStorageProviderV30 ► RenameFile(String, String)
Renames or moves a File.
Declaration Syntax
C# Visual Basic Visual C++
bool RenameFile(
    string oldFullName,
    string newFullName
)
Function RenameFile ( _
    oldFullName As String, _
    newFullName As String _
) As Boolean
bool RenameFile(
    String^ oldFullName,
    String^ newFullName
)
Parameters
oldFullName (String)
The old full name of the File.
newFullName (String)
The new full name of the File.
Return Value
true if the File is renamed, false otherwise.
Exceptions
Exception | Condition
ArgumentNullException | If oldFullName or newFullName are null.
ArgumentException | If oldFullName or newFullName are empty, or if the old file does not exist, or if the new file already exist.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.PluginFramework (Module: ScrewTurn.Wiki.PluginFramework) Version: 3.0.2.500 (3.0.2.500)


RenamePageAttachment Method (pageInfo, oldName, newName)

RenamePageAttachment Method (pageInfo, oldName, newName)
ScrewTurn Wiki ► ScrewTurn.Wiki.PluginFramework ► IFilesStorageProviderV30 ► RenamePageAttachment(PageInfo, String, String)
Renames a Page Attachment.
Declaration Syntax
C# Visual Basic Visual C++
bool RenamePageAttachment(
    PageInfo pageInfo,
    string oldName,
    string newName
)
Function RenamePageAttachment ( _
    pageInfo As PageInfo, _
    oldName As String, _
    newName As String _
) As Boolean
bool RenamePageAttachment(
    PageInfo^ pageInfo,
    String^ oldName,
    String^ newName
)
Parameters
pageInfo (PageInfo)
The Page Info that owns the Attachment.
oldName (String)
The old name of the Attachment.
newName (String)
The new name of the Attachment.
Return Value
true if the Attachment is renamed, false otherwise.
Exceptions
Exception | Condition
ArgumentNullException | If pageInfo, oldName or newName are null.
ArgumentException | If pageInfo, oldName or newName are empty, or if the page or old attachment do not exist, or the new attachment name already exists.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.PluginFramework (Module: ScrewTurn.Wiki.PluginFramework) Version: 3.0.2.500 (3.0.2.500)


RetrieveFile Method (fullName, destinationStream, countHit)

RetrieveFile Method (fullName, destinationStream, countHit)
ScrewTurn Wiki ► ScrewTurn.Wiki.PluginFramework ► IFilesStorageProviderV30 ► RetrieveFile(String, Stream, Boolean)
Retrieves a File.
Declaration Syntax
C# Visual Basic Visual C++
bool RetrieveFile(
    string fullName,
    Stream destinationStream,
    bool countHit
)
Function RetrieveFile ( _
    fullName As String, _
    destinationStream As Stream, _
    countHit As Boolean _
) As Boolean
bool RetrieveFile(
    String^ fullName,
    Stream^ destinationStream,
    bool countHit
)
Parameters
fullName (String)
The full name of the File.
destinationStream (Stream)
A Stream object used as destination of a byte stream, i.e. the method writes to the Stream the file content.
countHit (Boolean)
A value indicating whether or not to count this retrieval in the statistics.
Return Value
true if the file is retrieved, false otherwise.
Exceptions
Exception | Condition
ArgumentNullException | If fullName os destinationStream are null.
ArgumentException | If fullName is empty or destinationStream does not support writing, or if fullName does not exist.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.PluginFramework (Module: ScrewTurn.Wiki.PluginFramework) Version: 3.0.2.500 (3.0.2.500)


RetrievePageAttachment Method (pageInfo, name, destinationStream, countHit)

RetrievePageAttachment Method (pageInfo, name, destinationStream, countHit)
ScrewTurn Wiki ► ScrewTurn.Wiki.PluginFramework ► IFilesStorageProviderV30 ► RetrievePageAttachment(PageInfo, String, Stream, Boolean)
Retrieves a Page Attachment.
Declaration Syntax
C# Visual Basic Visual C++
bool RetrievePageAttachment(
    PageInfo pageInfo,
    string name,
    Stream destinationStream,
    bool countHit
)
Function RetrievePageAttachment ( _
    pageInfo As PageInfo, _
    name As String, _
    destinationStream As Stream, _
    countHit As Boolean _
) As Boolean
bool RetrievePageAttachment(
    PageInfo^ pageInfo,
    String^ name,
    Stream^ destinationStream,
    bool countHit
)
Parameters
pageInfo (PageInfo)
The Page Info that owns the Attachment.
name (String)
The name of the Attachment, for example "myfile.jpg".
destinationStream (Stream)
A Stream object used as destination of a byte stream, i.e. the method writes to the Stream the file content.
countHit (Boolean)
A value indicating whether or not to count this retrieval in the statistics.
Return Value
true if the Attachment is retrieved, false otherwise.
Exceptions
Exception | Condition
ArgumentNullException | If pageInfo, name or destinationStream are null.
ArgumentException | If name is empty or if destinationStream does not support writing, or if the page does not have attachments or if the attachment does not exist.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.PluginFramework (Module: ScrewTurn.Wiki.PluginFramework) Version: 3.0.2.500 (3.0.2.500)


SetFileRetrievalCount Method (fullName, count)

SetFileRetrievalCount Method (fullName, count)
ScrewTurn Wiki ► ScrewTurn.Wiki.PluginFramework ► IFilesStorageProviderV30 ► SetFileRetrievalCount(String, Int32)
Sets the number of times a file was retrieved.
Declaration Syntax
C# Visual Basic Visual C++
void SetFileRetrievalCount(
    string fullName,
    int count
)
Sub SetFileRetrievalCount ( _
    fullName As String, _
    count As Integer _
)
void SetFileRetrievalCount(
    String^ fullName,
    int count
)
Parameters
fullName (String)
The full name of the file.
count (Int32)
The count to set.
Exceptions
Exception | Condition
ArgumentNullException | If fullName is null.
ArgumentException | If fullName is empty.
ArgumentOutOfRangeException | If count is less than zero.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.PluginFramework (Module: ScrewTurn.Wiki.PluginFramework) Version: 3.0.2.500 (3.0.2.500)


SetPageAttachmentRetrievalCount Method (pageInfo, name, count)

SetPageAttachmentRetrievalCount Method (pageInfo, name, count)
ScrewTurn Wiki ► ScrewTurn.Wiki.PluginFramework ► IFilesStorageProviderV30 ► SetPageAttachmentRetrievalCount(PageInfo, String, Int32)
Sets the number of times a page attachment was retrieved.
Declaration Syntax
C# Visual Basic Visual C++
void SetPageAttachmentRetrievalCount(
    PageInfo pageInfo,
    string name,
    int count
)
Sub SetPageAttachmentRetrievalCount ( _
    pageInfo As PageInfo, _
    name As String, _
    count As Integer _
)
void SetPageAttachmentRetrievalCount(
    PageInfo^ pageInfo,
    String^ name,
    int count
)
Parameters
pageInfo (PageInfo)
The page.
name (String)
The name of the attachment.
count (Int32)
The count to set.
Exceptions
Exception | Condition
ArgumentNullException | If pageInfo or name are null.
ArgumentException | If name is empty.
ArgumentOutOfRangeException | If count is less than zero.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.PluginFramework (Module: ScrewTurn.Wiki.PluginFramework) Version: 3.0.2.500 (3.0.2.500)


StoreFile Method (fullName, sourceStream, overwrite)

StoreFile Method (fullName, sourceStream, overwrite)
ScrewTurn Wiki ► ScrewTurn.Wiki.PluginFramework ► IFilesStorageProviderV30 ► StoreFile(String, Stream, Boolean)
Stores a file.
Declaration Syntax
C# Visual Basic Visual C++
bool StoreFile(
    string fullName,
    Stream sourceStream,
    bool overwrite
)
Function StoreFile ( _
    fullName As String, _
    sourceStream As Stream, _
    overwrite As Boolean _
) As Boolean
bool StoreFile(
    String^ fullName,
    Stream^ sourceStream,
    bool overwrite
)
Parameters
fullName (String)
The full name of the file.
sourceStream (Stream)
A Stream object used as source of a byte stream, i.e. the method reads from the Stream and stores the content properly.
overwrite (Boolean)
true to overwrite an existing file.
Return Value
true if the File is stored, false otherwise.
Remarks
If overwrite is false and File already exists, the method returns false.
Exceptions
Exception | Condition
ArgumentNullException | If fullName os sourceStream are null.
ArgumentException | If fullName is empty or sourceStream does not support reading.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.PluginFramework (Module: ScrewTurn.Wiki.PluginFramework) Version: 3.0.2.500 (3.0.2.500)


StorePageAttachment Method (pageInfo, name, sourceStream, overwrite)

StorePageAttachment Method (pageInfo, name, sourceStream, overwrite)
ScrewTurn Wiki ► ScrewTurn.Wiki.PluginFramework ► IFilesStorageProviderV30 ► StorePageAttachment(PageInfo, String, Stream, Boolean)
Stores a Page Attachment.
Declaration Syntax
C# Visual Basic Visual C++
bool StorePageAttachment(
    PageInfo pageInfo,
    string name,
    Stream sourceStream,
    bool overwrite
)
Function StorePageAttachment ( _
    pageInfo As PageInfo, _
    name As String, _
    sourceStream As Stream, _
    overwrite As Boolean _
) As Boolean
bool StorePageAttachment(
    PageInfo^ pageInfo,
    String^ name,
    Stream^ sourceStream,
    bool overwrite
)
Parameters
pageInfo (PageInfo)
The Page Info that owns the Attachment.
name (String)
The name of the Attachment, for example "myfile.jpg".
sourceStream (Stream)
A Stream object used as source of a byte stream, i.e. the method reads from the Stream and stores the content properly.
overwrite (Boolean)
true to overwrite an existing Attachment.
Return Value
true if the Attachment is stored, false otherwise.
Remarks
If overwrite is false and Attachment already exists, the method returns false.
Exceptions
Exception | Condition
ArgumentNullException | If pageInfo, name or sourceStream are null.
ArgumentException | If name is empty or if sourceStream does not support reading.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.PluginFramework (Module: ScrewTurn.Wiki.PluginFramework) Version: 3.0.2.500 (3.0.2.500)


IFormatterProviderV30 Interface

IFormatterProviderV30 Interface
ScrewTurn Wiki ► ScrewTurn.Wiki.PluginFramework ► IFormatterProviderV30
It is the interface that must be implemented in order to create a custom Formatter Provider for ScrewTurn Wiki.
Declaration Syntax
C# Visual Basic Visual C++
public interface IFormatterProviderV30 : IProviderV30
Public Interface IFormatterProviderV30 _
    Implements IProviderV30
public interface class IFormatterProviderV30 : IProviderV30
Members
All Members | Methods | Properties
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | ConfigHelpHtml | Gets a brief summary of the configuration string format, in HTML. Returns null if no configuration is needed. (Inherited from IProviderV30.)
 | ExecutionPriority | Gets the execution priority of the provider (0 lowest, 100 highest).
 | Format(String, ContextInformation, FormattingPhase) | Performs a Formatting phase.
 | Information | Gets the Information about the Provider. (Inherited from IProviderV30.)
 | Init(IHostV30, String) | Initializes the Storage Provider. (Inherited from IProviderV30.)
 | PerformPhase1 | Specifies whether or not to execute Phase 1.
 | PerformPhase2 | Specifies whether or not to execute Phase 2.
 | PerformPhase3 | Specifies whether or not to execute Phase 3.
 | PrepareTitle(String, ContextInformation) | Prepares the title of an item for display (always during phase 3).
 | Shutdown()()() | Method invoked on shutdown. (Inherited from IProviderV30.)

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.PluginFramework (Module: ScrewTurn.Wiki.PluginFramework) Version: 3.0.2.500 (3.0.2.500)


ExecutionPriority Property

ExecutionPriority Property
ScrewTurn Wiki ► ScrewTurn.Wiki.PluginFramework ► IFormatterProviderV30 ► ExecutionPriority
Gets the execution priority of the provider (0 lowest, 100 highest).
Declaration Syntax
C# Visual Basic Visual C++
int ExecutionPriority { get; }
ReadOnly Property ExecutionPriority As Integer
property int ExecutionPriority {
    int get ();
}

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.PluginFramework (Module: ScrewTurn.Wiki.PluginFramework) Version: 3.0.2.500 (3.0.2.500)


Format Method (raw, context, phase)

Format Method (raw, context, phase)
ScrewTurn Wiki ► ScrewTurn.Wiki.PluginFramework ► IFormatterProviderV30 ► Format(String, ContextInformation, FormattingPhase)
Performs a Formatting phase.
Declaration Syntax
C# Visual Basic Visual C++
string Format(
    string raw,
    ContextInformation context,
    FormattingPhase phase
)
Function Format ( _
    raw As String, _
    context As ContextInformation, _
    phase As FormattingPhase _
) As String
String^ Format(
    String^ raw,
    ContextInformation^ context,
    FormattingPhase phase
)
Parameters
raw (String)
The raw content to Format.
context (ContextInformation)
The Context information.
phase (FormattingPhase)
The Phase.
Return Value
The Formatted content.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.PluginFramework (Module: ScrewTurn.Wiki.PluginFramework) Version: 3.0.2.500 (3.0.2.500)


PerformPhase1 Property

PerformPhase1 Property
ScrewTurn Wiki ► ScrewTurn.Wiki.PluginFramework ► IFormatterProviderV30 ► PerformPhase1
Specifies whether or not to execute Phase 1.
Declaration Syntax
C# Visual Basic Visual C++
bool PerformPhase1 { get; }
ReadOnly Property PerformPhase1 As Boolean
property bool PerformPhase1 {
    bool get ();
}

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.PluginFramework (Module: ScrewTurn.Wiki.PluginFramework) Version: 3.0.2.500 (3.0.2.500)


PerformPhase2 Property

PerformPhase2 Property
ScrewTurn Wiki ► ScrewTurn.Wiki.PluginFramework ► IFormatterProviderV30 ► PerformPhase2
Specifies whether or not to execute Phase 2.
Declaration Syntax
C# Visual Basic Visual C++
bool PerformPhase2 { get; }
ReadOnly Property PerformPhase2 As Boolean
property bool PerformPhase2 {
    bool get ();
}

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.PluginFramework (Module: ScrewTurn.Wiki.PluginFramework) Version: 3.0.2.500 (3.0.2.500)


PerformPhase3 Property

PerformPhase3 Property
ScrewTurn Wiki ► ScrewTurn.Wiki.PluginFramework ► IFormatterProviderV30 ► PerformPhase3
Specifies whether or not to execute Phase 3.
Declaration Syntax
C# Visual Basic Visual C++
bool PerformPhase3 { get; }
ReadOnly Property PerformPhase3 As Boolean
property bool PerformPhase3 {
    bool get ();
}

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.PluginFramework (Module: ScrewTurn.Wiki.PluginFramework) Version: 3.0.2.500 (3.0.2.500)


PrepareTitle Method (title, context)

PrepareTitle Method (title, context)
ScrewTurn Wiki ► ScrewTurn.Wiki.PluginFramework ► IFormatterProviderV30 ► PrepareTitle(String, ContextInformation)
Prepares the title of an item for display (always during phase 3).
Declaration Syntax
C# Visual Basic Visual C++
string PrepareTitle(
    string title,
    ContextInformation context
)
Function PrepareTitle ( _
    title As String, _
    context As ContextInformation _
) As String
String^ PrepareTitle(
    String^ title,
    ContextInformation^ context
)
Parameters
title (String)
The input title.
context (ContextInformation)
The context information.
Return Value
The prepared title (no markup allowed).

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.PluginFramework (Module: ScrewTurn.Wiki.PluginFramework) Version: 3.0.2.500 (3.0.2.500)


IHostV30 Interface

IHostV30 Interface
ScrewTurn Wiki ► ScrewTurn.Wiki.PluginFramework ► IHostV30
It is the interface that the ScrewTurn Wiki's Host object implements.
Declaration Syntax
C# Visual Basic Visual C++
public interface IHostV30
Public Interface IHostV30
public interface class IHostV30
Members
All Members | Methods | Events
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | AddToolbarItem(ToolbarItem, String, String) | Adds an item in the Editing Toolbar.
 | AlignDateTimeWithPreferences(DateTime) | Aligns a Date and Time object to the User's Time Zone preferences.
 | ChangeCurrentUserLanguage(String) | Changes the language of the current user.
 | CheckActionForDirectory(StDirectoryInfo, String, UserInfo) | Checks whether an action is allowed for a directory.
 | CheckActionForGlobals(String, UserInfo) | Checks whether an action is allowed for a global resource.
 | CheckActionForNamespace(NamespaceInfo, String, UserInfo) | Checks whether an action is allowed for a namespace.
 | CheckActionForPage(PageInfo, String, UserInfo) | Checks whether an action is allowed for a page.
 | ClearCache(CacheData) | Clears the cache.
 | FileActivity | Event fired whenever an activity is performed on a file, directory or attachment.
 | FindNamespace(String) | Finds a namespace by name.
 | FindPage(String) | Gets the WikiPage with the specified full Name.
 | FindUser(String) | Finds a user by username.
 | FindUserGroup(String) | Finds a user group by name.
 | Format(String) | Formats a block of WikiMarkup, using the built-in formatter only.
 | GetBackupContent(PageInfo, Int32) | Gets the Content of a Page Backup.
 | GetBackups(PageInfo) | Gets the Backup/Revision numbers of a Page.
 | GetCacheProviders(Boolean) | Gets the cache providers, either enabled or disabled.
 | GetCategories(NamespaceInfo) | Gets the list of the Categories in a namespace.
 | GetCategoriesPerPage(PageInfo) | Gets the Categories of a Page.
 | GetCurrentUser()()() | Gets the authenticated user in the current session, if any.
 | GetDefaultProvider(Type) | Gets the default provider of the specified type.
 | GetFilesStorageProviders(Boolean) | Gets the files storage providers, either enabled or disabled.
 | GetFormattedContent(PageInfo) | Gets the formatted content of a Page, retrieving it from the cache (if available).
 | GetFormatterProviders(Boolean) | Gets the formatter providers, either enabled or disabled.
 | GetNamespaces()()() | Gets the list of the namespaces.
 | GetNavigationPaths(NamespaceInfo) | Gets the list of Navigation Paths in a namespace.
 | GetPageContent(PageInfo) | Gets the Content of a Page.
 | GetPages(NamespaceInfo) | Gets the list of the Pages in a namespace.
 | GetPagesStorageProviders(Boolean) | Gets the pages storage providers, either enabled or disabled.
 | GetProviderConfiguration(String) | Gets the configuration of a provider.
 | GetSettingsStorageProvider()()() | Gets the current settings storage provider.
 | GetSettingValue(SettingName) | Gets the values of the Wiki Settings.
 | GetSnippets()()() | Gets the list of Snippets.
 | GetTheme(NamespaceInfo) | Gets the theme in use for a namespace.
 | GetUserGroups()()() | Gets the list of the user groups.
 | GetUsers()()() | Gets the list of the Users.
 | GetUsersStorageProviders(Boolean) | Gets the users storage providers, either enabled or disabled.
 | ListDirectories(StDirectoryInfo) | Lists directories in a directory.
 | ListFiles(StDirectoryInfo) | Lists files in a directory.
 | ListPageAttachments(PageInfo) | Lists page attachments.
 | LogEntry(String, LogEntryType, String, Object) | Logs a new message.
 | NamespaceActivity | Event fired whenever an activity is performed on a namespace.
 | PageActivity | Even fired whenever an activity is performed on a Page.
 | PerformSearch(String, Boolean, Boolean, SearchOptions) | Performs a search.
 | PrepareContentForIndexing(PageInfo, String) | Prepares content for indexing in the search engine, performing bare-bones formatting and removing all WikiMarkup and XML-like characters.
 | PrepareTitleForIndexing(PageInfo, String) | Prepares a title for indexing in the search engine, removing all WikiMarkup and XML-like characters.
 | SendEmail(String, String, String, String, Boolean) | Sends an Email.
 | SetProviderConfiguration(IProviderV30, String) | Sets the configuration of a provider.
 | UpgradePageStatusToAcl(PageInfo, Char) | Upgrades the old Page Status to use the new ACL facilities.
 | UpgradeSecurityFlagsToGroupsAcl(UserGroup, UserGroup) | Upgrades the old security flags to use the new ACL facilities and user groups support.
 | UserAccountActivity | Event fired whenever an activity is performed on a User Account.
 | UserGroupActivity | Event fired whenever an activity is performed on a user group.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.PluginFramework (Module: ScrewTurn.Wiki.PluginFramework) Version: 3.0.2.500 (3.0.2.500)


AddToolbarItem Method (item, text, value)

AddToolbarItem Method (item, text, value)
ScrewTurn Wiki ► ScrewTurn.Wiki.PluginFramework ► IHostV30 ► AddToolbarItem(ToolbarItem, String, String)
Adds an item in the Editing Toolbar.
Declaration Syntax
C# Visual Basic Visual C++
void AddToolbarItem(
    ToolbarItem item,
    string text,
    string value
)
Sub AddToolbarItem ( _
    item As ToolbarItem, _
    text As String, _
    value As String _
)
void AddToolbarItem(
    ToolbarItem item,
    String^ text,
    String^ value
)
Parameters
item (ToolbarItem)
The item to add.
text (String)
The text of the item showed in the toolbar.
value (String)
The value of the item, placed in the content: if item is ToolbarItem.SpecialTagWrap, separate start and end tag with a pipe.
Exceptions
Exception | Condition
ArgumentNullException | If text or value are null.
ArgumentException | If text or value are empty, or if they contain single or double quotes, or if value does not contain a pipe when item is SpecialTagWrap.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.PluginFramework (Module: ScrewTurn.Wiki.PluginFramework) Version: 3.0.2.500 (3.0.2.500)


AlignDateTimeWithPreferences Method (dt)

AlignDateTimeWithPreferences Method (dt)
ScrewTurn Wiki ► ScrewTurn.Wiki.PluginFramework ► IHostV30 ► AlignDateTimeWithPreferences(DateTime)
Aligns a Date and Time object to the User's Time Zone preferences.
Declaration Syntax
C# Visual Basic Visual C++
DateTime AlignDateTimeWithPreferences(
    DateTime dt
)
Function AlignDateTimeWithPreferences ( _
    dt As DateTime _
) As DateTime
DateTime AlignDateTimeWithPreferences(
    DateTime dt
)
Parameters
dt (DateTime)
The Date/Time to align.
Return Value
The aligned Date/Time.
Remarks
The method takes care of daylight saving settings.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.PluginFramework (Module: ScrewTurn.Wiki.PluginFramework) Version: 3.0.2.500 (3.0.2.500)


ChangeCurrentUserLanguage Method (language)

ChangeCurrentUserLanguage Method (language)
ScrewTurn Wiki ► ScrewTurn.Wiki.PluginFramework ► IHostV30 ► ChangeCurrentUserLanguage(String)
Changes the language of the current user.
Declaration Syntax
C# Visual Basic Visual C++
void ChangeCurrentUserLanguage(
    string language
)
Sub ChangeCurrentUserLanguage ( _
    language As String _
)
void ChangeCurrentUserLanguage(
    String^ language
)
Parameters
language (String)
The language code.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.PluginFramework (Module: ScrewTurn.Wiki.PluginFramework) Version: 3.0.2.500 (3.0.2.500)


CheckActionForDirectory Method (directory, action, user)

CheckActionForDirectory Method (directory, action, user)
ScrewTurn Wiki ► ScrewTurn.Wiki.PluginFramework ► IHostV30 ► CheckActionForDirectory(StDirectoryInfo, String, UserInfo)
Checks whether an action is allowed for a directory.
Declaration Syntax
C# Visual Basic Visual C++
bool CheckActionForDirectory(
    StDirectoryInfo directory,
    string action,
    UserInfo user
)
Function CheckActionForDirectory ( _
    directory As StDirectoryInfo, _
    action As String, _
    user As UserInfo _
) As Boolean
bool CheckActionForDirectory(
    StDirectoryInfo^ directory,
    String^ action,
    UserInfo^ user
)
Parameters
directory (StDirectoryInfo)
The directory.
action (String)
The action (see Actions..::.ForDirectories).
user (UserInfo)
The user.
Return Value
true if the action is allowed, false otherwise.
Exceptions
Exception | Condition
ArgumentNullException | If directory, action or user are null.
ArgumentException | If action is empty.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.PluginFramework (Module: ScrewTurn.Wiki.PluginFramework) Version: 3.0.2.500 (3.0.2.500)


CheckActionForGlobals Method (action, user)

CheckActionForGlobals Method (action, user)
ScrewTurn Wiki ► ScrewTurn.Wiki.PluginFramework ► IHostV30 ► CheckActionForGlobals(String, UserInfo)
Checks whether an action is allowed for a global resource.
Declaration Syntax
C# Visual Basic Visual C++
bool CheckActionForGlobals(
    string action,
    UserInfo user
)
Function CheckActionForGlobals ( _
    action As String, _
    user As UserInfo _
) As Boolean
bool CheckActionForGlobals(
    String^ action,
    UserInfo^ user
)
Parameters
action (String)
The action (see Actions..::.ForGlobals class)
user (UserInfo)
The user.
Return Value
true if the action is allowed, false otherwise.
Exceptions
Exception | Condition
ArgumentNullException | If action or user are null.
ArgumentException | If action is empty.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.PluginFramework (Module: ScrewTurn.Wiki.PluginFramework) Version: 3.0.2.500 (3.0.2.500)


CheckActionForNamespace Method (nspace, action, user)

CheckActionForNamespace Method (nspace, action, user)
ScrewTurn Wiki ► ScrewTurn.Wiki.PluginFramework ► IHostV30 ► CheckActionForNamespace(NamespaceInfo, String, UserInfo)
Checks whether an action is allowed for a namespace.
Declaration Syntax
C# Visual Basic Visual C++
bool CheckActionForNamespace(
    NamespaceInfo nspace,
    string action,
    UserInfo user
)
Function CheckActionForNamespace ( _
    nspace As NamespaceInfo, _
    action As String, _
    user As UserInfo _
) As Boolean
bool CheckActionForNamespace(
    NamespaceInfo^ nspace,
    String^ action,
    UserInfo^ user
)
Parameters
nspace (NamespaceInfo)
The namespace (null for the root).
action (String)
The action (see Actions..::.ForNamespaces class)
user (UserInfo)
The user.
Return Value
true if the action is allowed, false otherwise.
Exceptions
Exception | Condition
ArgumentNullException | If action or user are null.
ArgumentException | If action is empty.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.PluginFramework (Module: ScrewTurn.Wiki.PluginFramework) Version: 3.0.2.500 (3.0.2.500)


CheckActionForPage Method (page, action, user)

CheckActionForPage Method (page, action, user)
ScrewTurn Wiki ► ScrewTurn.Wiki.PluginFramework ► IHostV30 ► CheckActionForPage(PageInfo, String, UserInfo)
Checks whether an action is allowed for a page.
Declaration Syntax
C# Visual Basic Visual C++
bool CheckActionForPage(
    PageInfo page,
    string action,
    UserInfo user
)
Function CheckActionForPage ( _
    page As PageInfo, _
    action As String, _
    user As UserInfo _
) As Boolean
bool CheckActionForPage(
    PageInfo^ page,
    String^ action,
    UserInfo^ user
)
Parameters
page (PageInfo)
The page.
action (String)
The action (see Actions..::.ForPages class)
user (UserInfo)
The user.
Return Value
true if the action is allowed, false otherwise.
Exceptions
Exception | Condition
ArgumentNullException | If page, action or user are null.
ArgumentException | If action is empty.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.PluginFramework (Module: ScrewTurn.Wiki.PluginFramework) Version: 3.0.2.500 (3.0.2.500)


ClearCache Method (data)

ClearCache Method (data)
ScrewTurn Wiki ► ScrewTurn.Wiki.PluginFramework ► IHostV30 ► ClearCache(CacheData)
Clears the cache.
Declaration Syntax
C# Visual Basic Visual C++
void ClearCache(
    CacheData data
)
Sub ClearCache ( _
    data As CacheData _
)
void ClearCache(
    CacheData data
)
Parameters
data (CacheData)
The part of the cache to clear.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.PluginFramework (Module: ScrewTurn.Wiki.PluginFramework) Version: 3.0.2.500 (3.0.2.500)


FileActivity Event

FileActivity Event
ScrewTurn Wiki ► ScrewTurn.Wiki.PluginFramework ► IHostV30 ► FileActivity
Event fired whenever an activity is performed on a file, directory or attachment.
Declaration Syntax
C# Visual Basic Visual C++
event EventHandler<FileActivityEventArgs> FileActivity
Event FileActivity As EventHandler(Of FileActivityEventArgs)
 event EventHandler<FileActivityEventArgs^>^ FileActivity {
    void add (EventHandler<FileActivityEventArgs^>^ value);
    void remove (EventHandler<FileActivityEventArgs^>^ value);
}

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.PluginFramework (Module: ScrewTurn.Wiki.PluginFramework) Version: 3.0.2.500 (3.0.2.500)


FindNamespace Method (name)

FindNamespace Method (name)
ScrewTurn Wiki ► ScrewTurn.Wiki.PluginFramework ► IHostV30 ► FindNamespace(String)
Finds a namespace by name.
Declaration Syntax
C# Visual Basic Visual C++
NamespaceInfo FindNamespace(
    string name
)
Function FindNamespace ( _
    name As String _
) As NamespaceInfo
NamespaceInfo^ FindNamespace(
    String^ name
)
Parameters
name (String)
The name.
Return Value
The NamespaceInfo, or null if no namespaces are found.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.PluginFramework (Module: ScrewTurn.Wiki.PluginFramework) Version: 3.0.2.500 (3.0.2.500)


FindPage Method (fullName)

FindPage Method (fullName)
ScrewTurn Wiki ► ScrewTurn.Wiki.PluginFramework ► IHostV30 ► FindPage(String)
Gets the WikiPage with the specified full Name.
Declaration Syntax
C# Visual Basic Visual C++
PageInfo FindPage(
    string fullName
)
Function FindPage ( _
    fullName As String _
) As PageInfo
PageInfo^ FindPage(
    String^ fullName
)
Parameters
fullName (String)
The full Name of the Page.
Return Value
The Wiki Page, or null if no pages are found.
Exceptions
Exception | Condition
ArgumentNullException | If fullName is null.
ArgumentException | If fullName is empty.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.PluginFramework (Module: ScrewTurn.Wiki.PluginFramework) Version: 3.0.2.500 (3.0.2.500)


FindUser Method (username)

FindUser Method (username)
ScrewTurn Wiki ► ScrewTurn.Wiki.PluginFramework ► IHostV30 ► FindUser(String)
Finds a user by username.
Declaration Syntax
C# Visual Basic Visual C++
UserInfo FindUser(
    string username
)
Function FindUser ( _
    username As String _
) As UserInfo
UserInfo^ FindUser(
    String^ username
)
Parameters
username (String)
The username.
Return Value
The UserInfo, or null if no users are found.
Exceptions
Exception | Condition
ArgumentNullException | If username is null.
ArgumentException | If username is empty.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.PluginFramework (Module: ScrewTurn.Wiki.PluginFramework) Version: 3.0.2.500 (3.0.2.500)


FindUserGroup Method (name)

FindUserGroup Method (name)
ScrewTurn Wiki ► ScrewTurn.Wiki.PluginFramework ► IHostV30 ► FindUserGroup(String)
Finds a user group by name.
Declaration Syntax
C# Visual Basic Visual C++
UserGroup FindUserGroup(
    string name
)
Function FindUserGroup ( _
    name As String _
) As UserGroup
UserGroup^ FindUserGroup(
    String^ name
)
Parameters
name (String)
The name.
Return Value
The [T:UserGroup ], or null if no groups are found.
Exceptions
Exception | Condition
ArgumentNullException | If name is null.
ArgumentException | If name is empty.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.PluginFramework (Module: ScrewTurn.Wiki.PluginFramework) Version: 3.0.2.500 (3.0.2.500)


Format Method (raw)

Format Method (raw)
ScrewTurn Wiki ► ScrewTurn.Wiki.PluginFramework ► IHostV30 ► Format(String)
Formats a block of WikiMarkup, using the built-in formatter only.
Declaration Syntax
C# Visual Basic Visual C++
string Format(
    string raw
)
Function Format ( _
    raw As String _
) As String
String^ Format(
    String^ raw
)
Parameters
raw (String)
The block of WikiMarkup.
Return Value
The formatted content.
Exceptions
Exception | Condition
ArgumentNullException | If raw is null.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.PluginFramework (Module: ScrewTurn.Wiki.PluginFramework) Version: 3.0.2.500 (3.0.2.500)


GetBackupContent Method (page, revision)

GetBackupContent Method (page, revision)
ScrewTurn Wiki ► ScrewTurn.Wiki.PluginFramework ► IHostV30 ► GetBackupContent(PageInfo, Int32)
Gets the Content of a Page Backup.
Declaration Syntax
C# Visual Basic Visual C++
PageContent GetBackupContent(
    PageInfo page,
    int revision
)
Function GetBackupContent ( _
    page As PageInfo, _
    revision As Integer _
) As PageContent
PageContent^ GetBackupContent(
    PageInfo^ page,
    int revision
)
Parameters
page (PageInfo)
The Page.
revision (Int32)
The revision.
Return Value
The Backup Content.
Exceptions
Exception | Condition
ArgumentNullException | If page is null.
ArgumentOutOfRangeException | If revision is less than zero.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.PluginFramework (Module: ScrewTurn.Wiki.PluginFramework) Version: 3.0.2.500 (3.0.2.500)


GetBackups Method (page)

GetBackups Method (page)
ScrewTurn Wiki ► ScrewTurn.Wiki.PluginFramework ► IHostV30 ► GetBackups(PageInfo)
Gets the Backup/Revision numbers of a Page.
Declaration Syntax
C# Visual Basic Visual C++
int[] GetBackups(
    PageInfo page
)
Function GetBackups ( _
    page As PageInfo _
) As Integer()
array<int>^ GetBackups(
    PageInfo^ page
)
Parameters
page (PageInfo)
The Page.
Return Value
The Backup/Revision numbers.
Exceptions
Exception | Condition
ArgumentNullException | If page is null.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.PluginFramework (Module: ScrewTurn.Wiki.PluginFramework) Version: 3.0.2.500 (3.0.2.500)


GetCacheProviders Method (enabled)

GetCacheProviders Method (enabled)
ScrewTurn Wiki ► ScrewTurn.Wiki.PluginFramework ► IHostV30 ► GetCacheProviders(Boolean)
Gets the cache providers, either enabled or disabled.
Declaration Syntax
C# Visual Basic Visual C++
ICacheProviderV30[] GetCacheProviders(
    bool enabled
)
Function GetCacheProviders ( _
    enabled As Boolean _
) As ICacheProviderV30()
array<ICacheProviderV30^>^ GetCacheProviders(
    bool enabled
)
Parameters
enabled (Boolean)
true to get enabled providers, false to get disabled providers.
Return Value
The providers.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.PluginFramework (Module: ScrewTurn.Wiki.PluginFramework) Version: 3.0.2.500 (3.0.2.500)


GetCategories Method (nspace)

GetCategories Method (nspace)
ScrewTurn Wiki ► ScrewTurn.Wiki.PluginFramework ► IHostV30 ► GetCategories(NamespaceInfo)
Gets the list of the Categories in a namespace.
Declaration Syntax
C# Visual Basic Visual C++
CategoryInfo[] GetCategories(
    NamespaceInfo nspace
)
Function GetCategories ( _
    nspace As NamespaceInfo _
) As CategoryInfo()
array<CategoryInfo^>^ GetCategories(
    NamespaceInfo^ nspace
)
Parameters
nspace (NamespaceInfo)
The namespace (null for the root).
Return Value
The categories.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.PluginFramework (Module: ScrewTurn.Wiki.PluginFramework) Version: 3.0.2.500 (3.0.2.500)


GetCategoriesPerPage Method (page)

GetCategoriesPerPage Method (page)
ScrewTurn Wiki ► ScrewTurn.Wiki.PluginFramework ► IHostV30 ► GetCategoriesPerPage(PageInfo)
Gets the Categories of a Page.
Declaration Syntax
C# Visual Basic Visual C++
CategoryInfo[] GetCategoriesPerPage(
    PageInfo page
)
Function GetCategoriesPerPage ( _
    page As PageInfo _
) As CategoryInfo()
array<CategoryInfo^>^ GetCategoriesPerPage(
    PageInfo^ page
)
Parameters
page (PageInfo)
The Page.
Return Value
The Categories.
Exceptions
Exception | Condition
ArgumentNullException | If page is null.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.PluginFramework (Module: ScrewTurn.Wiki.PluginFramework) Version: 3.0.2.500 (3.0.2.500)


GetCurrentUser Method

GetCurrentUser Method
ScrewTurn Wiki ► ScrewTurn.Wiki.PluginFramework ► IHostV30 ► GetCurrentUser()()()
Gets the authenticated user in the current session, if any.
Declaration Syntax
C# Visual Basic Visual C++
UserInfo GetCurrentUser()
Function GetCurrentUser As UserInfo
UserInfo^ GetCurrentUser()
Return Value
The authenticated user, or null if no user is authenticated.
Remarks
If the built-it admin user is authenticated, the returned user has admin as Username.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.PluginFramework (Module: ScrewTurn.Wiki.PluginFramework) Version: 3.0.2.500 (3.0.2.500)


GetDefaultProvider Method (providerType)

GetDefaultProvider Method (providerType)
ScrewTurn Wiki ► ScrewTurn.Wiki.PluginFramework ► IHostV30 ► GetDefaultProvider(Type)
Gets the default provider of the specified type.
Declaration Syntax
C# Visual Basic Visual C++
string GetDefaultProvider(
    Type providerType
)
Function GetDefaultProvider ( _
    providerType As Type _
) As String
String^ GetDefaultProvider(
    Type^ providerType
)
Parameters
providerType (Type)
The type of the provider ( IPagesStorageProviderV30, IUsersStorageProviderV30, IFilesStorageProviderV30, ICacheStorageProviderV30, IFormatterProviderV30).
Return Value
The Full type name of the default provider of the specified type or null.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.PluginFramework (Module: ScrewTurn.Wiki.PluginFramework) Version: 3.0.2.500 (3.0.2.500)


GetFilesStorageProviders Method (enabled)

GetFilesStorageProviders Method (enabled)
ScrewTurn Wiki ► ScrewTurn.Wiki.PluginFramework ► IHostV30 ► GetFilesStorageProviders(Boolean)
Gets the files storage providers, either enabled or disabled.
Declaration Syntax
C# Visual Basic Visual C++
IFilesStorageProviderV30[] GetFilesStorageProviders(
    bool enabled
)
Function GetFilesStorageProviders ( _
    enabled As Boolean _
) As IFilesStorageProviderV30()
array<IFilesStorageProviderV30^>^ GetFilesStorageProviders(
    bool enabled
)
Parameters
enabled (Boolean)
true to get enabled providers, false to get disabled providers.
Return Value
The providers.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.PluginFramework (Module: ScrewTurn.Wiki.PluginFramework) Version: 3.0.2.500 (3.0.2.500)


GetFormattedContent Method (page)

GetFormattedContent Method (page)
ScrewTurn Wiki ► ScrewTurn.Wiki.PluginFramework ► IHostV30 ► GetFormattedContent(PageInfo)
Gets the formatted content of a Page, retrieving it from the cache (if available).
Declaration Syntax
C# Visual Basic Visual C++
string GetFormattedContent(
    PageInfo page
)
Function GetFormattedContent ( _
    page As PageInfo _
) As String
String^ GetFormattedContent(
    PageInfo^ page
)
Parameters
page (PageInfo)
The Page.
Return Value
The formatted content of the Page.
Exceptions
Exception | Condition
ArgumentNullException | If page is null.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.PluginFramework (Module: ScrewTurn.Wiki.PluginFramework) Version: 3.0.2.500 (3.0.2.500)


GetFormatterProviders Method (enabled)

GetFormatterProviders Method (enabled)
ScrewTurn Wiki ► ScrewTurn.Wiki.PluginFramework ► IHostV30 ► GetFormatterProviders(Boolean)
Gets the formatter providers, either enabled or disabled.
Declaration Syntax
C# Visual Basic Visual C++
IFormatterProviderV30[] GetFormatterProviders(
    bool enabled
)
Function GetFormatterProviders ( _
    enabled As Boolean _
) As IFormatterProviderV30()
array<IFormatterProviderV30^>^ GetFormatterProviders(
    bool enabled
)
Parameters
enabled (Boolean)
true to get enabled providers, false to get disabled providers.
Return Value
The providers.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.PluginFramework (Module: ScrewTurn.Wiki.PluginFramework) Version: 3.0.2.500 (3.0.2.500)


GetNamespaces Method

GetNamespaces Method
ScrewTurn Wiki ► ScrewTurn.Wiki.PluginFramework ► IHostV30 ► GetNamespaces()()()
Gets the list of the namespaces.
Declaration Syntax
C# Visual Basic Visual C++
NamespaceInfo[] GetNamespaces()
Function GetNamespaces As NamespaceInfo()
array<NamespaceInfo^>^ GetNamespaces()
Return Value
The namespaces.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.PluginFramework (Module: ScrewTurn.Wiki.PluginFramework) Version: 3.0.2.500 (3.0.2.500)


GetNavigationPaths Method (nspace)

GetNavigationPaths Method (nspace)
ScrewTurn Wiki ► ScrewTurn.Wiki.PluginFramework ► IHostV30 ► GetNavigationPaths(NamespaceInfo)
Gets the list of Navigation Paths in a namespace.
Declaration Syntax
C# Visual Basic Visual C++
NavigationPath[] GetNavigationPaths(
    NamespaceInfo nspace
)
Function GetNavigationPaths ( _
    nspace As NamespaceInfo _
) As NavigationPath()
array<NavigationPath^>^ GetNavigationPaths(
    NamespaceInfo^ nspace
)
Parameters
nspace (NamespaceInfo)
The namespace (null for the root).
Return Value
The navigation paths.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.PluginFramework (Module: ScrewTurn.Wiki.PluginFramework) Version: 3.0.2.500 (3.0.2.500)


GetPageContent Method (page)

GetPageContent Method (page)
ScrewTurn Wiki ► ScrewTurn.Wiki.PluginFramework ► IHostV30 ► GetPageContent(PageInfo)
Gets the Content of a Page.
Declaration Syntax
C# Visual Basic Visual C++
PageContent GetPageContent(
    PageInfo page
)
Function GetPageContent ( _
    page As PageInfo _
) As PageContent
PageContent^ GetPageContent(
    PageInfo^ page
)
Parameters
page (PageInfo)
The Page.
Return Value
The Page Content.
Exceptions
Exception | Condition
ArgumentNullException | If page is null.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.PluginFramework (Module: ScrewTurn.Wiki.PluginFramework) Version: 3.0.2.500 (3.0.2.500)


GetPages Method (nspace)

GetPages Method (nspace)
ScrewTurn Wiki ► ScrewTurn.Wiki.PluginFramework ► IHostV30 ► GetPages(NamespaceInfo)
Gets the list of the Pages in a namespace.
Declaration Syntax
C# Visual Basic Visual C++
PageInfo[] GetPages(
    NamespaceInfo nspace
)
Function GetPages ( _
    nspace As NamespaceInfo _
) As PageInfo()
array<PageInfo^>^ GetPages(
    NamespaceInfo^ nspace
)
Parameters
nspace (NamespaceInfo)
The namespace (null for the root).
Return Value
The pages.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.PluginFramework (Module: ScrewTurn.Wiki.PluginFramework) Version: 3.0.2.500 (3.0.2.500)


GetPagesStorageProviders Method (enabled)

GetPagesStorageProviders Method (enabled)
ScrewTurn Wiki ► ScrewTurn.Wiki.PluginFramework ► IHostV30 ► GetPagesStorageProviders(Boolean)
Gets the pages storage providers, either enabled or disabled.
Declaration Syntax
C# Visual Basic Visual C++
IPagesStorageProviderV30[] GetPagesStorageProviders(
    bool enabled
)
Function GetPagesStorageProviders ( _
    enabled As Boolean _
) As IPagesStorageProviderV30()
array<IPagesStorageProviderV30^>^ GetPagesStorageProviders(
    bool enabled
)
Parameters
enabled (Boolean)
true to get enabled providers, false to get disabled providers.
Return Value
The providers.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.PluginFramework (Module: ScrewTurn.Wiki.PluginFramework) Version: 3.0.2.500 (3.0.2.500)


GetProviderConfiguration Method (providerTypeName)

GetProviderConfiguration Method (providerTypeName)
ScrewTurn Wiki ► ScrewTurn.Wiki.PluginFramework ► IHostV30 ► GetProviderConfiguration(String)
Gets the configuration of a provider.
Declaration Syntax
C# Visual Basic Visual C++
string GetProviderConfiguration(
    string providerTypeName
)
Function GetProviderConfiguration ( _
    providerTypeName As String _
) As String
String^ GetProviderConfiguration(
    String^ providerTypeName
)
Parameters
providerTypeName (String)
The type name of the provider, such as 'Vendor.Namespace.Provider'.
Return Value
The configuration (can be empty or null).
Exceptions
Exception | Condition
ArgumentNullException | If providerTypeName is null.
ArgumentException | If providerTypeName is empty.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.PluginFramework (Module: ScrewTurn.Wiki.PluginFramework) Version: 3.0.2.500 (3.0.2.500)


GetSettingsStorageProvider Method

GetSettingsStorageProvider Method
ScrewTurn Wiki ► ScrewTurn.Wiki.PluginFramework ► IHostV30 ► GetSettingsStorageProvider()()()
Gets the current settings storage provider.
Declaration Syntax
C# Visual Basic Visual C++
ISettingsStorageProviderV30 GetSettingsStorageProvider()
Function GetSettingsStorageProvider As ISettingsStorageProviderV30
ISettingsStorageProviderV30^ GetSettingsStorageProvider()
Return Value
The settings storage provider.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.PluginFramework (Module: ScrewTurn.Wiki.PluginFramework) Version: 3.0.2.500 (3.0.2.500)


GetSettingValue Method (name)

GetSettingValue Method (name)
ScrewTurn Wiki ► ScrewTurn.Wiki.PluginFramework ► IHostV30 ► GetSettingValue(SettingName)
Gets the values of the Wiki Settings.
Declaration Syntax
C# Visual Basic Visual C++
string GetSettingValue(
    SettingName name
)
Function GetSettingValue ( _
    name As SettingName _
) As String
String^ GetSettingValue(
    SettingName name
)
Parameters
name (SettingName)
The Setting's Name.
Return Value
The Setting's value.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.PluginFramework (Module: ScrewTurn.Wiki.PluginFramework) Version: 3.0.2.500 (3.0.2.500)


GetSnippets Method

GetSnippets Method
ScrewTurn Wiki ► ScrewTurn.Wiki.PluginFramework ► IHostV30 ► GetSnippets()()()
Gets the list of Snippets.
Declaration Syntax
C# Visual Basic Visual C++
Snippet[] GetSnippets()
Function GetSnippets As Snippet()
array<Snippet^>^ GetSnippets()
Return Value
The snippets.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.PluginFramework (Module: ScrewTurn.Wiki.PluginFramework) Version: 3.0.2.500 (3.0.2.500)


GetTheme Method (nspace)

GetTheme Method (nspace)
ScrewTurn Wiki ► ScrewTurn.Wiki.PluginFramework ► IHostV30 ► GetTheme(NamespaceInfo)
Gets the theme in use for a namespace.
Declaration Syntax
C# Visual Basic Visual C++
string GetTheme(
    NamespaceInfo nspace
)
Function GetTheme ( _
    nspace As NamespaceInfo _
) As String
String^ GetTheme(
    NamespaceInfo^ nspace
)
Parameters
nspace (NamespaceInfo)
The namespace (null for the root).
Return Value
The theme.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.PluginFramework (Module: ScrewTurn.Wiki.PluginFramework) Version: 3.0.2.500 (3.0.2.500)


GetUserGroups Method

GetUserGroups Method
ScrewTurn Wiki ► ScrewTurn.Wiki.PluginFramework ► IHostV30 ► GetUserGroups()()()
Gets the list of the user groups.
Declaration Syntax
C# Visual Basic Visual C++
UserGroup[] GetUserGroups()
Function GetUserGroups As UserGroup()
array<UserGroup^>^ GetUserGroups()
Return Value
The groups.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.PluginFramework (Module: ScrewTurn.Wiki.PluginFramework) Version: 3.0.2.500 (3.0.2.500)


GetUsers Method

GetUsers Method
ScrewTurn Wiki ► ScrewTurn.Wiki.PluginFramework ► IHostV30 ► GetUsers()()()
Gets the list of the Users.
Declaration Syntax
C# Visual Basic Visual C++
UserInfo[] GetUsers()
Function GetUsers As UserInfo()
array<UserInfo^>^ GetUsers()
Return Value
The users.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.PluginFramework (Module: ScrewTurn.Wiki.PluginFramework) Version: 3.0.2.500 (3.0.2.500)


GetUsersStorageProviders Method (enabled)

GetUsersStorageProviders Method (enabled)
ScrewTurn Wiki ► ScrewTurn.Wiki.PluginFramework ► IHostV30 ► GetUsersStorageProviders(Boolean)
Gets the users storage providers, either enabled or disabled.
Declaration Syntax
C# Visual Basic Visual C++
IUsersStorageProviderV30[] GetUsersStorageProviders(
    bool enabled
)
Function GetUsersStorageProviders ( _
    enabled As Boolean _
) As IUsersStorageProviderV30()
array<IUsersStorageProviderV30^>^ GetUsersStorageProviders(
    bool enabled
)
Parameters
enabled (Boolean)
true to get enabled providers, false to get disabled providers.
Return Value
The providers.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.PluginFramework (Module: ScrewTurn.Wiki.PluginFramework) Version: 3.0.2.500 (3.0.2.500)


ListDirectories Method (directory)

ListDirectories Method (directory)
ScrewTurn Wiki ► ScrewTurn.Wiki.PluginFramework ► IHostV30 ► ListDirectories(StDirectoryInfo)
Lists directories in a directory.
Declaration Syntax
C# Visual Basic Visual C++
StDirectoryInfo[] ListDirectories(
    StDirectoryInfo directory
)
Function ListDirectories ( _
    directory As StDirectoryInfo _
) As StDirectoryInfo()
array<StDirectoryInfo^>^ ListDirectories(
    StDirectoryInfo^ directory
)
Parameters
directory (StDirectoryInfo)
The directory (null for the root, first invocation).
Return Value
The directories.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.PluginFramework (Module: ScrewTurn.Wiki.PluginFramework) Version: 3.0.2.500 (3.0.2.500)


ListFiles Method (directory)

ListFiles Method (directory)
ScrewTurn Wiki ► ScrewTurn.Wiki.PluginFramework ► IHostV30 ► ListFiles(StDirectoryInfo)
Lists files in a directory.
Declaration Syntax
C# Visual Basic Visual C++
StFileInfo[] ListFiles(
    StDirectoryInfo directory
)
Function ListFiles ( _
    directory As StDirectoryInfo _
) As StFileInfo()
array<StFileInfo^>^ ListFiles(
    StDirectoryInfo^ directory
)
Parameters
directory (StDirectoryInfo)
The directory (null for the root, first invocation).
Return Value
The files.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.PluginFramework (Module: ScrewTurn.Wiki.PluginFramework) Version: 3.0.2.500 (3.0.2.500)


ListPageAttachments Method (page)

ListPageAttachments Method (page)
ScrewTurn Wiki ► ScrewTurn.Wiki.PluginFramework ► IHostV30 ► ListPageAttachments(PageInfo)
Lists page attachments.
Declaration Syntax
C# Visual Basic Visual C++
StFileInfo[] ListPageAttachments(
    PageInfo page
)
Function ListPageAttachments ( _
    page As PageInfo _
) As StFileInfo()
array<StFileInfo^>^ ListPageAttachments(
    PageInfo^ page
)
Parameters
page (PageInfo)
The page.
Return Value
The attachments.
Exceptions
Exception | Condition
ArgumentNullException | If page is null.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.PluginFramework (Module: ScrewTurn.Wiki.PluginFramework) Version: 3.0.2.500 (3.0.2.500)


LogEntry Method (message, entryType, user, caller)

LogEntry Method (message, entryType, user, caller)
ScrewTurn Wiki ► ScrewTurn.Wiki.PluginFramework ► IHostV30 ► LogEntry(String, LogEntryType, String, Object)
Logs a new message.
Declaration Syntax
C# Visual Basic Visual C++
void LogEntry(
    string message,
    LogEntryType entryType,
    string user,
    Object caller
)
Sub LogEntry ( _
    message As String, _
    entryType As LogEntryType, _
    user As String, _
    caller As Object _
)
void LogEntry(
    String^ message,
    LogEntryType entryType,
    String^ user,
    Object^ caller
)
Parameters
message (String)
The Message.
entryType (LogEntryType)
The Entry Type.
user (String)
The user, or null. If null, the system will log "PluginName+System".
caller (Object)
The Component that calls the method. The caller cannot be null.
Exceptions
Exception | Condition
ArgumentNullException | If message or caller are null.
ArgumentException | If message is empty.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.PluginFramework (Module: ScrewTurn.Wiki.PluginFramework) Version: 3.0.2.500 (3.0.2.500)


NamespaceActivity Event

NamespaceActivity Event
ScrewTurn Wiki ► ScrewTurn.Wiki.PluginFramework ► IHostV30 ► NamespaceActivity
Event fired whenever an activity is performed on a namespace.
Declaration Syntax
C# Visual Basic Visual C++
event EventHandler<NamespaceActivityEventArgs> NamespaceActivity
Event NamespaceActivity As EventHandler(Of NamespaceActivityEventArgs)
 event EventHandler<NamespaceActivityEventArgs^>^ NamespaceActivity {
    void add (EventHandler<NamespaceActivityEventArgs^>^ value);
    void remove (EventHandler<NamespaceActivityEventArgs^>^ value);
}

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.PluginFramework (Module: ScrewTurn.Wiki.PluginFramework) Version: 3.0.2.500 (3.0.2.500)


PageActivity Event

PageActivity Event
ScrewTurn Wiki ► ScrewTurn.Wiki.PluginFramework ► IHostV30 ► PageActivity
Even fired whenever an activity is performed on a Page.
Declaration Syntax
C# Visual Basic Visual C++
event EventHandler<PageActivityEventArgs> PageActivity
Event PageActivity As EventHandler(Of PageActivityEventArgs)
 event EventHandler<PageActivityEventArgs^>^ PageActivity {
    void add (EventHandler<PageActivityEventArgs^>^ value);
    void remove (EventHandler<PageActivityEventArgs^>^ value);
}

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.PluginFramework (Module: ScrewTurn.Wiki.PluginFramework) Version: 3.0.2.500 (3.0.2.500)


PerformSearch Method (query, fullText, filesAndAttachments, options)

PerformSearch Method (query, fullText, filesAndAttachments, options)
ScrewTurn Wiki ► ScrewTurn.Wiki.PluginFramework ► IHostV30 ► PerformSearch(String, Boolean, Boolean, SearchOptions)
Performs a search.
Declaration Syntax
C# Visual Basic Visual C++
SearchResultCollection PerformSearch(
    string query,
    bool fullText,
    bool filesAndAttachments,
    SearchOptions options
)
Function PerformSearch ( _
    query As String, _
    fullText As Boolean, _
    filesAndAttachments As Boolean, _
    options As SearchOptions _
) As SearchResultCollection
SearchResultCollection^ PerformSearch(
    String^ query,
    bool fullText,
    bool filesAndAttachments,
    SearchOptions options
)
Parameters
query (String)
The search query.
fullText (Boolean)
A value indicating whether to perform a full-text search.
filesAndAttachments (Boolean)
A value indicating whether to search the names of files and attachments.
options (SearchOptions)
The search options.
Return Value
The search results.
Exceptions
Exception | Condition
ArgumentNullException | If query is null.
ArgumentException | If query is empty.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.PluginFramework (Module: ScrewTurn.Wiki.PluginFramework) Version: 3.0.2.500 (3.0.2.500)


PrepareContentForIndexing Method (page, content)

PrepareContentForIndexing Method (page, content)
ScrewTurn Wiki ► ScrewTurn.Wiki.PluginFramework ► IHostV30 ► PrepareContentForIndexing(PageInfo, String)
Prepares content for indexing in the search engine, performing bare-bones formatting and removing all WikiMarkup and XML-like characters.
Declaration Syntax
C# Visual Basic Visual C++
string PrepareContentForIndexing(
    PageInfo page,
    string content
)
Function PrepareContentForIndexing ( _
    page As PageInfo, _
    content As String _
) As String
String^ PrepareContentForIndexing(
    PageInfo^ page,
    String^ content
)
Parameters
page (PageInfo)
The page being indexed, if any, null otherwise.
content (String)
The string to prepare.
Return Value
The sanitized string.
Exceptions
Exception | Condition
ArgumentNullException | If content is null.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.PluginFramework (Module: ScrewTurn.Wiki.PluginFramework) Version: 3.0.2.500 (3.0.2.500)


PrepareTitleForIndexing Method (page, title)

PrepareTitleForIndexing Method (page, title)
ScrewTurn Wiki ► ScrewTurn.Wiki.PluginFramework ► IHostV30 ► PrepareTitleForIndexing(PageInfo, String)
Prepares a title for indexing in the search engine, removing all WikiMarkup and XML-like characters.
Declaration Syntax
C# Visual Basic Visual C++
string PrepareTitleForIndexing(
    PageInfo page,
    string title
)
Function PrepareTitleForIndexing ( _
    page As PageInfo, _
    title As String _
) As String
String^ PrepareTitleForIndexing(
    PageInfo^ page,
    String^ title
)
Parameters
page (PageInfo)
The page being indexed, if any, null otherwise.
title (String)
The title to prepare.
Return Value
The sanitized string.
Exceptions
Exception | Condition
ArgumentNullException | If title is null.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.PluginFramework (Module: ScrewTurn.Wiki.PluginFramework) Version: 3.0.2.500 (3.0.2.500)


SendEmail Method (recipient, sender, subject, body, html)

SendEmail Method (recipient, sender, subject, body, html)
ScrewTurn Wiki ► ScrewTurn.Wiki.PluginFramework ► IHostV30 ► SendEmail(String, String, String, String, Boolean)
Sends an Email.
Declaration Syntax
C# Visual Basic Visual C++
bool SendEmail(
    string recipient,
    string sender,
    string subject,
    string body,
    bool html
)
Function SendEmail ( _
    recipient As String, _
    sender As String, _
    subject As String, _
    body As String, _
    html As Boolean _
) As Boolean
bool SendEmail(
    String^ recipient,
    String^ sender,
    String^ subject,
    String^ body,
    bool html
)
Parameters
recipient (String)
The Recipient Email address.
sender (String)
The Sender's Email address.
subject (String)
The Subject.
body (String)
The Body.
html (Boolean)
True if the message is HTML.
Return Value
True if the message has been sent successfully.
Exceptions
Exception | Condition
ArgumentNullException | If recipient, sender, subject or body are null.
ArgumentException | If recipient, sender, subject or body are empty.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.PluginFramework (Module: ScrewTurn.Wiki.PluginFramework) Version: 3.0.2.500 (3.0.2.500)


SetProviderConfiguration Method (provider, configuration)

SetProviderConfiguration Method (provider, configuration)
ScrewTurn Wiki ► ScrewTurn.Wiki.PluginFramework ► IHostV30 ► SetProviderConfiguration(IProviderV30, String)
Sets the configuration of a provider.
Declaration Syntax
C# Visual Basic Visual C++
bool SetProviderConfiguration(
    IProviderV30 provider,
    string configuration
)
Function SetProviderConfiguration ( _
    provider As IProviderV30, _
    configuration As String _
) As Boolean
bool SetProviderConfiguration(
    IProviderV30^ provider,
    String^ configuration
)
Parameters
provider (IProviderV30)
The provider of which to set the configuration.
configuration (String)
The configuration to set.
Return Value
true if the configuration is set, false otherwise.
Exceptions
Exception | Condition
ArgumentNullException | If provider is null.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.PluginFramework (Module: ScrewTurn.Wiki.PluginFramework) Version: 3.0.2.500 (3.0.2.500)


UpgradePageStatusToAcl Method (page, oldStatus)

UpgradePageStatusToAcl Method (page, oldStatus)
ScrewTurn Wiki ► ScrewTurn.Wiki.PluginFramework ► IHostV30 ► UpgradePageStatusToAcl(PageInfo, Char)
Upgrades the old Page Status to use the new ACL facilities.
Declaration Syntax
C# Visual Basic Visual C++
bool UpgradePageStatusToAcl(
    PageInfo page,
    char oldStatus
)
Function UpgradePageStatusToAcl ( _
    page As PageInfo, _
    oldStatus As Char _
) As Boolean
bool UpgradePageStatusToAcl(
    PageInfo^ page,
    wchar_t oldStatus
)
Parameters
page (PageInfo)
The page of which to upgrade the status.
oldStatus (Char)
The old status ('L' = Locked, 'P' = Public).
Return Value
true if the operation succeeded, false otherwise.
Exceptions
Exception | Condition
ArgumentNullException | If page is null.
ArgumentOutOfRangeException | If oldStatus is invalid.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.PluginFramework (Module: ScrewTurn.Wiki.PluginFramework) Version: 3.0.2.500 (3.0.2.500)


UpgradeSecurityFlagsToGroupsAcl Method (administrators, users)

UpgradeSecurityFlagsToGroupsAcl Method (administrators, users)
ScrewTurn Wiki ► ScrewTurn.Wiki.PluginFramework ► IHostV30 ► UpgradeSecurityFlagsToGroupsAcl(UserGroup, UserGroup)
Upgrades the old security flags to use the new ACL facilities and user groups support.
Declaration Syntax
C# Visual Basic Visual C++
bool UpgradeSecurityFlagsToGroupsAcl(
    UserGroup administrators,
    UserGroup users
)
Function UpgradeSecurityFlagsToGroupsAcl ( _
    administrators As UserGroup, _
    users As UserGroup _
) As Boolean
bool UpgradeSecurityFlagsToGroupsAcl(
    UserGroup^ administrators,
    UserGroup^ users
)
Parameters
administrators (UserGroup)
The administrators group.
users (UserGroup)
The users group.
Return Value
true if the operation succeeded, false otherwise.
Exceptions
Exception | Condition
ArgumentNullException | If administrator or users are null.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.PluginFramework (Module: ScrewTurn.Wiki.PluginFramework) Version: 3.0.2.500 (3.0.2.500)


UserAccountActivity Event

UserAccountActivity Event
ScrewTurn Wiki ► ScrewTurn.Wiki.PluginFramework ► IHostV30 ► UserAccountActivity
Event fired whenever an activity is performed on a User Account.
Declaration Syntax
C# Visual Basic Visual C++
event EventHandler<UserAccountActivityEventArgs> UserAccountActivity
Event UserAccountActivity As EventHandler(Of UserAccountActivityEventArgs)
 event EventHandler<UserAccountActivityEventArgs^>^ UserAccountActivity {
    void add (EventHandler<UserAccountActivityEventArgs^>^ value);
    void remove (EventHandler<UserAccountActivityEventArgs^>^ value);
}

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.PluginFramework (Module: ScrewTurn.Wiki.PluginFramework) Version: 3.0.2.500 (3.0.2.500)


UserGroupActivity Event

UserGroupActivity Event
ScrewTurn Wiki ► ScrewTurn.Wiki.PluginFramework ► IHostV30 ► UserGroupActivity
Event fired whenever an activity is performed on a user group.
Declaration Syntax
C# Visual Basic Visual C++
event EventHandler<UserGroupActivityEventArgs> UserGroupActivity
Event UserGroupActivity As EventHandler(Of UserGroupActivityEventArgs)
 event EventHandler<UserGroupActivityEventArgs^>^ UserGroupActivity {
    void add (EventHandler<UserGroupActivityEventArgs^>^ value);
    void remove (EventHandler<UserGroupActivityEventArgs^>^ value);
}

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.PluginFramework (Module: ScrewTurn.Wiki.PluginFramework) Version: 3.0.2.500 (3.0.2.500)


InvalidConfigurationException Class

InvalidConfigurationException Class
ScrewTurn Wiki ► ScrewTurn.Wiki.PluginFramework ► InvalidConfigurationException
Represents errors that occur while decoding the Provider's Configuration String.
Declaration Syntax
C# Visual Basic Visual C++
public class InvalidConfigurationException : Exception
Public Class InvalidConfigurationException _
    Inherits Exception
public ref class InvalidConfigurationException : public Exception
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | InvalidConfigurationException()()() | Initializes a new instance of the InvalidConfigurationException class.
 | InvalidConfigurationException(String) | Initializes a new instance of the InvalidConfigurationException class.
 | InvalidConfigurationException(String, Exception) | Initializes a new instance of the InvalidConfigurationException class.
 | InvalidConfigurationException(SerializationInfo, StreamingContext) | Initializes a new instance of the InvalidConfigurationException class.
 | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetBaseException()()() | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetObjectData(SerializationInfo, StreamingContext) | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
 | GetType()()() | Gets the runtime type of the current instance. (Inherited from Exception.)
 | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
 | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
 | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Message | Gets a message that describes the current exception. (Inherited from Exception.)
 | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
 | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
 | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
 | ToString()()() | Creates and returns a string representation of the current exception. (Inherited from Exception.)
Inheritance Hierarchy
Object
 | Exception
 |  | InvalidConfigurationException

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.PluginFramework (Module: ScrewTurn.Wiki.PluginFramework) Version: 3.0.2.500 (3.0.2.500)


InvalidConfigurationException Constructor

InvalidConfigurationException Constructor
ScrewTurn Wiki ► ScrewTurn.Wiki.PluginFramework ► InvalidConfigurationException ► InvalidConfigurationException()()()
Members
Icon | Member | Description
 | InvalidConfigurationException()()() | Initializes a new instance of the InvalidConfigurationException class.
 | InvalidConfigurationException(String) | Initializes a new instance of the InvalidConfigurationException class.
 | InvalidConfigurationException(String, Exception) | Initializes a new instance of the InvalidConfigurationException class.
 | InvalidConfigurationException(SerializationInfo, StreamingContext) | Initializes a new instance of the InvalidConfigurationException class.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.PluginFramework (Module: ScrewTurn.Wiki.PluginFramework) Version: 3.0.2.500 (3.0.2.500)


InvalidConfigurationException Constructor

InvalidConfigurationException Constructor
ScrewTurn Wiki ► ScrewTurn.Wiki.PluginFramework ► InvalidConfigurationException ► InvalidConfigurationException()()()
Initializes a new instance of the InvalidConfigurationException class.
Declaration Syntax
C# Visual Basic Visual C++
public InvalidConfigurationException()
Public Sub New
public:
InvalidConfigurationException()

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.PluginFramework (Module: ScrewTurn.Wiki.PluginFramework) Version: 3.0.2.500 (3.0.2.500)


InvalidConfigurationException Constructor (info, context)

InvalidConfigurationException Constructor (info, context)
ScrewTurn Wiki ► ScrewTurn.Wiki.PluginFramework ► InvalidConfigurationException ► InvalidConfigurationException(SerializationInfo, StreamingContext)
Initializes a new instance of the InvalidConfigurationException class.
Declaration Syntax
C# Visual Basic Visual C++
public InvalidConfigurationException(
    SerializationInfo info,
    StreamingContext context
)
Public Sub New ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
public:
InvalidConfigurationException(
    SerializationInfo^ info,
    StreamingContext context
)
Parameters
info (SerializationInfo)
The serialization info.
context (StreamingContext)
The streaming context.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.PluginFramework (Module: ScrewTurn.Wiki.PluginFramework) Version: 3.0.2.500 (3.0.2.500)


InvalidConfigurationException Constructor (message)

InvalidConfigurationException Constructor (message)
ScrewTurn Wiki ► ScrewTurn.Wiki.PluginFramework ► InvalidConfigurationException ► InvalidConfigurationException(String)
Initializes a new instance of the InvalidConfigurationException class.
Declaration Syntax
C# Visual Basic Visual C++
public InvalidConfigurationException(
    string message
)
Public Sub New ( _
    message As String _
)
public:
InvalidConfigurationException(
    String^ message
)
Parameters
message (String)
The error message.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.PluginFramework (Module: ScrewTurn.Wiki.PluginFramework) Version: 3.0.2.500 (3.0.2.500)


InvalidConfigurationException Constructor (message, innerException)

InvalidConfigurationException Constructor (message, innerException)
ScrewTurn Wiki ► ScrewTurn.Wiki.PluginFramework ► InvalidConfigurationException ► InvalidConfigurationException(String, Exception)
Initializes a new instance of the InvalidConfigurationException class.
Declaration Syntax
C# Visual Basic Visual C++
public InvalidConfigurationException(
    string message,
    Exception innerException
)
Public Sub New ( _
    message As String, _
    innerException As Exception _
)
public:
InvalidConfigurationException(
    String^ message,
    Exception^ innerException
)
Parameters
message (String)
The error message.
innerException (Exception)
The inner Exception.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.PluginFramework (Module: ScrewTurn.Wiki.PluginFramework) Version: 3.0.2.500 (3.0.2.500)


IPagesStorageProviderV30 Interface

IPagesStorageProviderV30 Interface
ScrewTurn Wiki ► ScrewTurn.Wiki.PluginFramework ► IPagesStorageProviderV30
It is the interface that must be implemented in order to create a custom Pages Storage Provider for ScrewTurn Wiki.
Declaration Syntax
C# Visual Basic Visual C++
public interface IPagesStorageProviderV30 : IStorageProviderV30,
    IProviderV30
Public Interface IPagesStorageProviderV30 _
    Implements IStorageProviderV30, IProviderV30
public interface class IPagesStorageProviderV30 : IStorageProviderV30,
    IProviderV30
Members
All Members | Methods | Properties
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | AddCategory(String, String) | Adds a Category.
 | AddContentTemplate(String, String) | Adds a new content template.
 | AddMessage(PageInfo, String, String, DateTime, String, Int32) | Adds a new Message to a Page.
 | AddNamespace(String) | Adds a new namespace.
 | AddNavigationPath(String, String, array<PageInfo>[]()[]) | Adds a new Navigation Path.
 | AddPage(String, String, DateTime) | Adds a Page.
 | AddSnippet(String, String) | Adds a new snippet.
 | BulkStoreMessages(PageInfo, array<Message>[]()[]) | Removes all messages for a page and stores the new messages.
 | ConfigHelpHtml | Gets a brief summary of the configuration string format, in HTML. Returns null if no configuration is needed. (Inherited from IProviderV30.)
 | DeleteBackups(PageInfo, Int32) | Deletes the Backups of a Page, up to a specified revision.
 | DeleteDraft(PageInfo) | Deletes a draft of a Page.
 | GetBackupContent(PageInfo, Int32) | Gets the Content of a Backup of a Page.
 | GetBackups(PageInfo) | Gets the Backup/Revision numbers of a Page.
 | GetCategories(NamespaceInfo) | Gets all the Categories in a namespace.
 | GetCategoriesForPage(PageInfo) | Gets all the categories of a page.
 | GetCategory(String) | Gets a category.
 | GetContent(PageInfo) | Gets the Content of a Page.
 | GetContentTemplates()()() | Gets all the content templates.
 | GetDraft(PageInfo) | Gets the content of a draft of a Page.
 | GetIndexStats(Int32%, Int32%, Int32%, Int64%) | Gets some statistics about the search engine index.
 | GetMessageCount(PageInfo) | Gets the total number of Messages in a Page Discussion.
 | GetMessages(PageInfo) | Gets the Page Messages.
 | GetNamespace(String) | Gets a namespace.
 | GetNamespaces()()() | Gets all the sub-namespaces.
 | GetNavigationPaths(NamespaceInfo) | Gets all the Navigation Paths in a Namespace.
 | GetPage(String) | Gets a page.
 | GetPages(NamespaceInfo) | Gets all the Pages in a namespace.
 | GetSnippets()()() | Gets all the snippets.
 | GetUncategorizedPages(NamespaceInfo) | Gets all the pages in a namespace that are bound to zero categories.
 | Information | Gets the Information about the Provider. (Inherited from IProviderV30.)
 | Init(IHostV30, String) | Initializes the Storage Provider. (Inherited from IProviderV30.)
 | IsIndexCorrupted | Gets a value indicating whether the search engine index is corrupted and needs to be rebuilt.
 | MergeCategories(CategoryInfo, CategoryInfo) | Merges two Categories.
 | ModifyContentTemplate(String, String) | Modifies an existing content template.
 | ModifyMessage(PageInfo, Int32, String, String, DateTime, String) | Modifies a Message.
 | ModifyNavigationPath(NavigationPath, array<PageInfo>[]()[]) | Modifies an existing navigation path.
 | ModifyPage(PageInfo, String, String, DateTime, String, String, array<String>[]()[], String, SaveMode) | Modifies the Content of a Page.
 | ModifySnippet(String, String) | Modifies an existing snippet.
 | MovePage(PageInfo, NamespaceInfo, Boolean) | Moves a page from its namespace into another.
 | PerformSearch(SearchParameters) | Performs a search in the index.
 | ReadOnly | Gets a value specifying whether the provider is read-only, i.e. it can only provide data and not store it. (Inherited from IStorageProviderV30.)
 | RebindPage(PageInfo, array<String>[]()[]) | Binds a Page with one or more Categories.
 | RebuildIndex()()() | Rebuilds the search index.
 | RemoveCategory(CategoryInfo) | Removes a Category.
 | RemoveContentTemplate(String) | Removes a content template.
 | RemoveMessage(PageInfo, Int32, Boolean) | Removes a Message.
 | RemoveNamespace(NamespaceInfo) | Removes a namespace.
 | RemoveNavigationPath(NavigationPath) | Removes a Navigation Path.
 | RemovePage(PageInfo) | Removes a Page.
 | RemoveSnippet(String) | Removes a new Snippet.
 | RenameCategory(CategoryInfo, String) | Renames a Category.
 | RenameNamespace(NamespaceInfo, String) | Renames a namespace.
 | RenamePage(PageInfo, String) | Renames a Page.
 | RollbackPage(PageInfo, Int32) | Performs the rollback of a Page to a specified revision.
 | SetBackupContent(PageContent, Int32) | Forces to overwrite or create a Backup.
 | SetNamespaceDefaultPage(NamespaceInfo, PageInfo) | Sets the default page of a namespace.
 | Shutdown()()() | Method invoked on shutdown. (Inherited from IProviderV30.)
Remarks
A class that implements this interface should not have any kind of data caching.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.PluginFramework (Module: ScrewTurn.Wiki.PluginFramework) Version: 3.0.2.500 (3.0.2.500)


AddCategory Method (nspace, name)

AddCategory Method (nspace, name)
ScrewTurn Wiki ► ScrewTurn.Wiki.PluginFramework ► IPagesStorageProviderV30 ► AddCategory(String, String)
Adds a Category.
Declaration Syntax
C# Visual Basic Visual C++
CategoryInfo AddCategory(
    string nspace,
    string name
)
Function AddCategory ( _
    nspace As String, _
    name As String _
) As CategoryInfo
CategoryInfo^ AddCategory(
    String^ nspace,
    String^ name
)
Parameters
nspace (String)
The target namespace (null for the root).
name (String)
The Category name.
Return Value
The correct CategoryInfo object.
Remarks
The method should set category's Pages to an empty array.
Exceptions
Exception | Condition
ArgumentNullException | If name is null.
ArgumentException | If name is empty.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.PluginFramework (Module: ScrewTurn.Wiki.PluginFramework) Version: 3.0.2.500 (3.0.2.500)


AddContentTemplate Method (name, content)

AddContentTemplate Method (name, content)
ScrewTurn Wiki ► ScrewTurn.Wiki.PluginFramework ► IPagesStorageProviderV30 ► AddContentTemplate(String, String)
Adds a new content template.
Declaration Syntax
C# Visual Basic Visual C++
ContentTemplate AddContentTemplate(
    string name,
    string content
)
Function AddContentTemplate ( _
    name As String, _
    content As String _
) As ContentTemplate
ContentTemplate^ AddContentTemplate(
    String^ name,
    String^ content
)
Parameters
name (String)
The name of template.
content (String)
The content of the template.
Return Value
The correct ContentTemplate object.
Exceptions
Exception | Condition
ArgumentNullException | If name or content are null.
ArgumentNullException | If name is empty.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.PluginFramework (Module: ScrewTurn.Wiki.PluginFramework) Version: 3.0.2.500 (3.0.2.500)


AddMessage Method (page, username, subject, dateTime, body, parent)

AddMessage Method (page, username, subject, dateTime, body, parent)
ScrewTurn Wiki ► ScrewTurn.Wiki.PluginFramework ► IPagesStorageProviderV30 ► AddMessage(PageInfo, String, String, DateTime, String, Int32)
Adds a new Message to a Page.
Declaration Syntax
C# Visual Basic Visual C++
bool AddMessage(
    PageInfo page,
    string username,
    string subject,
    DateTime dateTime,
    string body,
    int parent
)
Function AddMessage ( _
    page As PageInfo, _
    username As String, _
    subject As String, _
    dateTime As DateTime, _
    body As String, _
    parent As Integer _
) As Boolean
bool AddMessage(
    PageInfo^ page,
    String^ username,
    String^ subject,
    DateTime dateTime,
    String^ body,
    int parent
)
Parameters
page (PageInfo)
The Page.
username (String)
The Username.
subject (String)
The Subject.
dateTime (DateTime)
The Date/Time.
body (String)
The Body.
parent (Int32)
The Parent Message ID, or -1.
Return Value
True if the Message is added successfully.
Exceptions
Exception | Condition
ArgumentNullException | If page, username, subject or body are null.
ArgumentException | If username or subject are empty.
ArgumentOutOfRangeException | If parent is less than -1.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.PluginFramework (Module: ScrewTurn.Wiki.PluginFramework) Version: 3.0.2.500 (3.0.2.500)


AddNamespace Method (name)

AddNamespace Method (name)
ScrewTurn Wiki ► ScrewTurn.Wiki.PluginFramework ► IPagesStorageProviderV30 ► AddNamespace(String)
Adds a new namespace.
Declaration Syntax
C# Visual Basic Visual C++
NamespaceInfo AddNamespace(
    string name
)
Function AddNamespace ( _
    name As String _
) As NamespaceInfo
NamespaceInfo^ AddNamespace(
    String^ name
)
Parameters
name (String)
The name of the namespace.
Return Value
The correct NamespaceInfo object.
Exceptions
Exception | Condition
ArgumentNullException | If name is null.
ArgumentException | If name is empty.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.PluginFramework (Module: ScrewTurn.Wiki.PluginFramework) Version: 3.0.2.500 (3.0.2.500)


AddNavigationPath Method (nspace, name, pages)

AddNavigationPath Method (nspace, name, pages)
ScrewTurn Wiki ► ScrewTurn.Wiki.PluginFramework ► IPagesStorageProviderV30 ► AddNavigationPath(String, String, array<PageInfo>[]()[])
Adds a new Navigation Path.
Declaration Syntax
C# Visual Basic Visual C++
NavigationPath AddNavigationPath(
    string nspace,
    string name,
    PageInfo[] pages
)
Function AddNavigationPath ( _
    nspace As String, _
    name As String, _
    pages As PageInfo() _
) As NavigationPath
NavigationPath^ AddNavigationPath(
    String^ nspace,
    String^ name,
    array<PageInfo^>^ pages
)
Parameters
nspace (String)
The target namespace (null for the root).
name (String)
The Name of the Path.
pages (array< PageInfo >[]()[][])
The Pages array.
Return Value
The correct NavigationPath object.
Exceptions
Exception | Condition
ArgumentNullException | If name or pages are null.
ArgumentException | If name or pages are empty.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.PluginFramework (Module: ScrewTurn.Wiki.PluginFramework) Version: 3.0.2.500 (3.0.2.500)


AddPage Method (nspace, name, creationDateTime)

AddPage Method (nspace, name, creationDateTime)
ScrewTurn Wiki ► ScrewTurn.Wiki.PluginFramework ► IPagesStorageProviderV30 ► AddPage(String, String, DateTime)
Adds a Page.
Declaration Syntax
C# Visual Basic Visual C++
PageInfo AddPage(
    string nspace,
    string name,
    DateTime creationDateTime
)
Function AddPage ( _
    nspace As String, _
    name As String, _
    creationDateTime As DateTime _
) As PageInfo
PageInfo^ AddPage(
    String^ nspace,
    String^ name,
    DateTime creationDateTime
)
Parameters
nspace (String)
The target namespace (null for the root).
name (String)
The Page Name.
creationDateTime (DateTime)
The creation Date/Time.
Return Value
The correct PageInfo object or null.
Remarks
This method should not create the content of the Page.
Exceptions
Exception | Condition
ArgumentNullException | If name is null.
ArgumentException | If name is empty.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.PluginFramework (Module: ScrewTurn.Wiki.PluginFramework) Version: 3.0.2.500 (3.0.2.500)


AddSnippet Method (name, content)

AddSnippet Method (name, content)
ScrewTurn Wiki ► ScrewTurn.Wiki.PluginFramework ► IPagesStorageProviderV30 ► AddSnippet(String, String)
Adds a new snippet.
Declaration Syntax
C# Visual Basic Visual C++
Snippet AddSnippet(
    string name,
    string content
)
Function AddSnippet ( _
    name As String, _
    content As String _
) As Snippet
Snippet^ AddSnippet(
    String^ name,
    String^ content
)
Parameters
name (String)
The name of the snippet.
content (String)
The content of the snippet.
Return Value
The correct Snippet object.
Exceptions
Exception | Condition
ArgumentNullException | If name or content are null.
ArgumentNullException | If name is empty.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.PluginFramework (Module: ScrewTurn.Wiki.PluginFramework) Version: 3.0.2.500 (3.0.2.500)


BulkStoreMessages Method (page, messages)

BulkStoreMessages Method (page, messages)
ScrewTurn Wiki ► ScrewTurn.Wiki.PluginFramework ► IPagesStorageProviderV30 ► BulkStoreMessages(PageInfo, array<Message>[]()[])
Removes all messages for a page and stores the new messages.
Declaration Syntax
C# Visual Basic Visual C++
bool BulkStoreMessages(
    PageInfo page,
    Message[] messages
)
Function BulkStoreMessages ( _
    page As PageInfo, _
    messages As Message() _
) As Boolean
bool BulkStoreMessages(
    PageInfo^ page,
    array<Message^>^ messages
)
Parameters
page (PageInfo)
The page.
messages (array< Message >[]()[][])
The new messages to store.
Return Value
true if the messages are stored, false otherwise.
Exceptions
Exception | Condition
ArgumentNullException | If page or messages are null.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.PluginFramework (Module: ScrewTurn.Wiki.PluginFramework) Version: 3.0.2.500 (3.0.2.500)


DeleteBackups Method (page, revision)

DeleteBackups Method (page, revision)
ScrewTurn Wiki ► ScrewTurn.Wiki.PluginFramework ► IPagesStorageProviderV30 ► DeleteBackups(PageInfo, Int32)
Deletes the Backups of a Page, up to a specified revision.
Declaration Syntax
C# Visual Basic Visual C++
bool DeleteBackups(
    PageInfo page,
    int revision
)
Function DeleteBackups ( _
    page As PageInfo, _
    revision As Integer _
) As Boolean
bool DeleteBackups(
    PageInfo^ page,
    int revision
)
Parameters
page (PageInfo)
The Page to delete the backups of.
revision (Int32)
The newest revision to delete (newer revision are kept) or -1 to delete all the Backups.
Return Value
true if the deletion succeeded, false otherwise.
Exceptions
Exception | Condition
ArgumentNullException | If page is null.
ArgumentOutOfRangeException | If revision is less than -1.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.PluginFramework (Module: ScrewTurn.Wiki.PluginFramework) Version: 3.0.2.500 (3.0.2.500)


DeleteDraft Method (page)

DeleteDraft Method (page)
ScrewTurn Wiki ► ScrewTurn.Wiki.PluginFramework ► IPagesStorageProviderV30 ► DeleteDraft(PageInfo)
Deletes a draft of a Page.
Declaration Syntax
C# Visual Basic Visual C++
bool DeleteDraft(
    PageInfo page
)
Function DeleteDraft ( _
    page As PageInfo _
) As Boolean
bool DeleteDraft(
    PageInfo^ page
)
Parameters
page (PageInfo)
The page.
Return Value
true if the draft is deleted, false otherwise.
Exceptions
Exception | Condition
ArgumentNullException | If page is null.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.PluginFramework (Module: ScrewTurn.Wiki.PluginFramework) Version: 3.0.2.500 (3.0.2.500)


GetBackupContent Method (page, revision)

GetBackupContent Method (page, revision)
ScrewTurn Wiki ► ScrewTurn.Wiki.PluginFramework ► IPagesStorageProviderV30 ► GetBackupContent(PageInfo, Int32)
Gets the Content of a Backup of a Page.
Declaration Syntax
C# Visual Basic Visual C++
PageContent GetBackupContent(
    PageInfo page,
    int revision
)
Function GetBackupContent ( _
    page As PageInfo, _
    revision As Integer _
) As PageContent
PageContent^ GetBackupContent(
    PageInfo^ page,
    int revision
)
Parameters
page (PageInfo)
The Page to get the backup of.
revision (Int32)
The Backup/Revision number.
Return Value
The Page Backup.
Exceptions
Exception | Condition
ArgumentNullException | If page is null.
ArgumentOutOfRangeException | If revision is less than zero.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.PluginFramework (Module: ScrewTurn.Wiki.PluginFramework) Version: 3.0.2.500 (3.0.2.500)


GetBackups Method (page)

GetBackups Method (page)
ScrewTurn Wiki ► ScrewTurn.Wiki.PluginFramework ► IPagesStorageProviderV30 ► GetBackups(PageInfo)
Gets the Backup/Revision numbers of a Page.
Declaration Syntax
C# Visual Basic Visual C++
int[] GetBackups(
    PageInfo page
)
Function GetBackups ( _
    page As PageInfo _
) As Integer()
array<int>^ GetBackups(
    PageInfo^ page
)
Parameters
page (PageInfo)
The Page to get the Backups of.
Return Value
The Backup/Revision numbers.
Exceptions
Exception | Condition
ArgumentNullException | If page is null.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.PluginFramework (Module: ScrewTurn.Wiki.PluginFramework) Version: 3.0.2.500 (3.0.2.500)


GetCategories Method (nspace)

GetCategories Method (nspace)
ScrewTurn Wiki ► ScrewTurn.Wiki.PluginFramework ► IPagesStorageProviderV30 ► GetCategories(NamespaceInfo)
Gets all the Categories in a namespace.
Declaration Syntax
C# Visual Basic Visual C++
CategoryInfo[] GetCategories(
    NamespaceInfo nspace
)
Function GetCategories ( _
    nspace As NamespaceInfo _
) As CategoryInfo()
array<CategoryInfo^>^ GetCategories(
    NamespaceInfo^ nspace
)
Parameters
nspace (NamespaceInfo)
The namespace.
Return Value
All the Categories in the namespace, sorted by name.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.PluginFramework (Module: ScrewTurn.Wiki.PluginFramework) Version: 3.0.2.500 (3.0.2.500)


GetCategoriesForPage Method (page)

GetCategoriesForPage Method (page)
ScrewTurn Wiki ► ScrewTurn.Wiki.PluginFramework ► IPagesStorageProviderV30 ► GetCategoriesForPage(PageInfo)
Gets all the categories of a page.
Declaration Syntax
C# Visual Basic Visual C++
CategoryInfo[] GetCategoriesForPage(
    PageInfo page
)
Function GetCategoriesForPage ( _
    page As PageInfo _
) As CategoryInfo()
array<CategoryInfo^>^ GetCategoriesForPage(
    PageInfo^ page
)
Parameters
page (PageInfo)
The page.
Return Value
The categories, sorted by name.
Exceptions
Exception | Condition
ArgumentNullException | If page is null.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.PluginFramework (Module: ScrewTurn.Wiki.PluginFramework) Version: 3.0.2.500 (3.0.2.500)


GetCategory Method (fullName)

GetCategory Method (fullName)
ScrewTurn Wiki ► ScrewTurn.Wiki.PluginFramework ► IPagesStorageProviderV30 ► GetCategory(String)
Gets a category.
Declaration Syntax
C# Visual Basic Visual C++
CategoryInfo GetCategory(
    string fullName
)
Function GetCategory ( _
    fullName As String _
) As CategoryInfo
CategoryInfo^ GetCategory(
    String^ fullName
)
Parameters
fullName (String)
The full name of the category.
Return Value
The CategoryInfo, or null if no category is found.
Exceptions
Exception | Condition
ArgumentNullException | If fullName is null.
ArgumentException | If fullName is empty.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.PluginFramework (Module: ScrewTurn.Wiki.PluginFramework) Version: 3.0.2.500 (3.0.2.500)


GetContent Method (page)

GetContent Method (page)
ScrewTurn Wiki ► ScrewTurn.Wiki.PluginFramework ► IPagesStorageProviderV30 ► GetContent(PageInfo)
Gets the Content of a Page.
Declaration Syntax
C# Visual Basic Visual C++
PageContent GetContent(
    PageInfo page
)
Function GetContent ( _
    page As PageInfo _
) As PageContent
PageContent^ GetContent(
    PageInfo^ page
)
Parameters
page (PageInfo)
The Page.
Return Value
The Page Content object, null if the page does not exist or page is null, or an empty instance if the content could not be retrieved ().
See Also
GetEmpty(PageInfo)

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.PluginFramework (Module: ScrewTurn.Wiki.PluginFramework) Version: 3.0.2.500 (3.0.2.500)


GetContentTemplates Method

GetContentTemplates Method
ScrewTurn Wiki ► ScrewTurn.Wiki.PluginFramework ► IPagesStorageProviderV30 ► GetContentTemplates()()()
Gets all the content templates.
Declaration Syntax
C# Visual Basic Visual C++
ContentTemplate[] GetContentTemplates()
Function GetContentTemplates As ContentTemplate()
array<ContentTemplate^>^ GetContentTemplates()
Return Value
All the content templates, sorted by name.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.PluginFramework (Module: ScrewTurn.Wiki.PluginFramework) Version: 3.0.2.500 (3.0.2.500)


GetDraft Method (page)

GetDraft Method (page)
ScrewTurn Wiki ► ScrewTurn.Wiki.PluginFramework ► IPagesStorageProviderV30 ► GetDraft(PageInfo)
Gets the content of a draft of a Page.
Declaration Syntax
C# Visual Basic Visual C++
PageContent GetDraft(
    PageInfo page
)
Function GetDraft ( _
    page As PageInfo _
) As PageContent
PageContent^ GetDraft(
    PageInfo^ page
)
Parameters
page (PageInfo)
The Page.
Return Value
The draft, or null if no draft exists.
Exceptions
Exception | Condition
ArgumentNullException | If page is null.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.PluginFramework (Module: ScrewTurn.Wiki.PluginFramework) Version: 3.0.2.500 (3.0.2.500)


GetIndexStats Method (documentCount, wordCount, occurrenceCount, size)

GetIndexStats Method (documentCount, wordCount, occurrenceCount, size)
ScrewTurn Wiki ► ScrewTurn.Wiki.PluginFramework ► IPagesStorageProviderV30 ► GetIndexStats(Int32%, Int32%, Int32%, Int64%)
Gets some statistics about the search engine index.
Declaration Syntax
C# Visual Basic Visual C++
void GetIndexStats(
    out int documentCount,
    out int wordCount,
    out int occurrenceCount,
    out long size
)
Sub GetIndexStats ( _
    <OutAttribute> ByRef documentCount As Integer, _
    <OutAttribute> ByRef wordCount As Integer, _
    <OutAttribute> ByRef occurrenceCount As Integer, _
    <OutAttribute> ByRef size As Long _
)
void GetIndexStats(
    [OutAttribute] int% documentCount,
    [OutAttribute] int% wordCount,
    [OutAttribute] int% occurrenceCount,
    [OutAttribute] long long% size
)
Parameters
documentCount ( Int32 %)
The total number of documents.
wordCount ( Int32 %)
The total number of unique words.
occurrenceCount ( Int32 %)
The total number of word-document occurrences.
size ( Int64 %)
The approximated size, in bytes, of the search engine index.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.PluginFramework (Module: ScrewTurn.Wiki.PluginFramework) Version: 3.0.2.500 (3.0.2.500)


GetMessageCount Method (page)

GetMessageCount Method (page)
ScrewTurn Wiki ► ScrewTurn.Wiki.PluginFramework ► IPagesStorageProviderV30 ► GetMessageCount(PageInfo)
Gets the total number of Messages in a Page Discussion.
Declaration Syntax
C# Visual Basic Visual C++
int GetMessageCount(
    PageInfo page
)
Function GetMessageCount ( _
    page As PageInfo _
) As Integer
int GetMessageCount(
    PageInfo^ page
)
Parameters
page (PageInfo)
The Page.
Return Value
The number of messages.
Exceptions
Exception | Condition
ArgumentNullException | If page is null.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.PluginFramework (Module: ScrewTurn.Wiki.PluginFramework) Version: 3.0.2.500 (3.0.2.500)


GetMessages Method (page)

GetMessages Method (page)
ScrewTurn Wiki ► ScrewTurn.Wiki.PluginFramework ► IPagesStorageProviderV30 ► GetMessages(PageInfo)
Gets the Page Messages.
Declaration Syntax
C# Visual Basic Visual C++
Message[] GetMessages(
    PageInfo page
)
Function GetMessages ( _
    page As PageInfo _
) As Message()
array<Message^>^ GetMessages(
    PageInfo^ page
)
Parameters
page (PageInfo)
The Page.
Return Value
The list of the first-level Messages, containing the replies properly nested, sorted by date/time.
Exceptions
Exception | Condition
ArgumentNullException | If page is null.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.PluginFramework (Module: ScrewTurn.Wiki.PluginFramework) Version: 3.0.2.500 (3.0.2.500)


GetNamespace Method (name)

GetNamespace Method (name)
ScrewTurn Wiki ► ScrewTurn.Wiki.PluginFramework ► IPagesStorageProviderV30 ► GetNamespace(String)
Gets a namespace.
Declaration Syntax
C# Visual Basic Visual C++
NamespaceInfo GetNamespace(
    string name
)
Function GetNamespace ( _
    name As String _
) As NamespaceInfo
NamespaceInfo^ GetNamespace(
    String^ name
)
Parameters
name (String)
The name of the namespace.
Return Value
The NamespaceInfo, or null if no namespace is found.
Exceptions
Exception | Condition
ArgumentNullException | If name is null.
ArgumentException | If name is empty.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.PluginFramework (Module: ScrewTurn.Wiki.PluginFramework) Version: 3.0.2.500 (3.0.2.500)


GetNamespaces Method

GetNamespaces Method
ScrewTurn Wiki ► ScrewTurn.Wiki.PluginFramework ► IPagesStorageProviderV30 ► GetNamespaces()()()
Gets all the sub-namespaces.
Declaration Syntax
C# Visual Basic Visual C++
NamespaceInfo[] GetNamespaces()
Function GetNamespaces As NamespaceInfo()
array<NamespaceInfo^>^ GetNamespaces()
Return Value
The sub-namespaces, sorted by name.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.PluginFramework (Module: ScrewTurn.Wiki.PluginFramework) Version: 3.0.2.500 (3.0.2.500)


GetNavigationPaths Method (nspace)

GetNavigationPaths Method (nspace)
ScrewTurn Wiki ► ScrewTurn.Wiki.PluginFramework ► IPagesStorageProviderV30 ► GetNavigationPaths(NamespaceInfo)
Gets all the Navigation Paths in a Namespace.
Declaration Syntax
C# Visual Basic Visual C++
NavigationPath[] GetNavigationPaths(
    NamespaceInfo nspace
)
Function GetNavigationPaths ( _
    nspace As NamespaceInfo _
) As NavigationPath()
array<NavigationPath^>^ GetNavigationPaths(
    NamespaceInfo^ nspace
)
Parameters
nspace (NamespaceInfo)
The Namespace.
Return Value
All the Navigation Paths, sorted by name.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.PluginFramework (Module: ScrewTurn.Wiki.PluginFramework) Version: 3.0.2.500 (3.0.2.500)


GetPage Method (fullName)

GetPage Method (fullName)
ScrewTurn Wiki ► ScrewTurn.Wiki.PluginFramework ► IPagesStorageProviderV30 ► GetPage(String)
Gets a page.
Declaration Syntax
C# Visual Basic Visual C++
PageInfo GetPage(
    string fullName
)
Function GetPage ( _
    fullName As String _
) As PageInfo
PageInfo^ GetPage(
    String^ fullName
)
Parameters
fullName (String)
The full name of the page.
Return Value
The PageInfo, or null if no page is found.
Exceptions
Exception | Condition
ArgumentNullException | If fullName is null.
ArgumentException | If fullName is empty.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.PluginFramework (Module: ScrewTurn.Wiki.PluginFramework) Version: 3.0.2.500 (3.0.2.500)


GetPages Method (nspace)

GetPages Method (nspace)
ScrewTurn Wiki ► ScrewTurn.Wiki.PluginFramework ► IPagesStorageProviderV30 ► GetPages(NamespaceInfo)
Gets all the Pages in a namespace.
Declaration Syntax
C# Visual Basic Visual C++
PageInfo[] GetPages(
    NamespaceInfo nspace
)
Function GetPages ( _
    nspace As NamespaceInfo _
) As PageInfo()
array<PageInfo^>^ GetPages(
    NamespaceInfo^ nspace
)
Parameters
nspace (NamespaceInfo)
The namespace (null for the root).
Return Value
All the Pages in the namespace, sorted by name.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.PluginFramework (Module: ScrewTurn.Wiki.PluginFramework) Version: 3.0.2.500 (3.0.2.500)


GetSnippets Method

GetSnippets Method
ScrewTurn Wiki ► ScrewTurn.Wiki.PluginFramework ► IPagesStorageProviderV30 ► GetSnippets()()()
Gets all the snippets.
Declaration Syntax
C# Visual Basic Visual C++
Snippet[] GetSnippets()
Function GetSnippets As Snippet()
array<Snippet^>^ GetSnippets()
Return Value
All the snippets, sorted by name.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.PluginFramework (Module: ScrewTurn.Wiki.PluginFramework) Version: 3.0.2.500 (3.0.2.500)


GetUncategorizedPages Method (nspace)

GetUncategorizedPages Method (nspace)
ScrewTurn Wiki ► ScrewTurn.Wiki.PluginFramework ► IPagesStorageProviderV30 ► GetUncategorizedPages(NamespaceInfo)
Gets all the pages in a namespace that are bound to zero categories.
Declaration Syntax
C# Visual Basic Visual C++
PageInfo[] GetUncategorizedPages(
    NamespaceInfo nspace
)
Function GetUncategorizedPages ( _
    nspace As NamespaceInfo _
) As PageInfo()
array<PageInfo^>^ GetUncategorizedPages(
    NamespaceInfo^ nspace
)
Parameters
nspace (NamespaceInfo)
The namespace (null for the root).
Return Value
The pages, sorted by name.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.PluginFramework (Module: ScrewTurn.Wiki.PluginFramework) Version: 3.0.2.500 (3.0.2.500)


IsIndexCorrupted Property

IsIndexCorrupted Property
ScrewTurn Wiki ► ScrewTurn.Wiki.PluginFramework ► IPagesStorageProviderV30 ► IsIndexCorrupted
Gets a value indicating whether the search engine index is corrupted and needs to be rebuilt.
Declaration Syntax
C# Visual Basic Visual C++
bool IsIndexCorrupted { get; }
ReadOnly Property IsIndexCorrupted As Boolean
property bool IsIndexCorrupted {
    bool get ();
}

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.PluginFramework (Module: ScrewTurn.Wiki.PluginFramework) Version: 3.0.2.500 (3.0.2.500)


MergeCategories Method (source, destination)

MergeCategories Method (source, destination)
ScrewTurn Wiki ► ScrewTurn.Wiki.PluginFramework ► IPagesStorageProviderV30 ► MergeCategories(CategoryInfo, CategoryInfo)
Merges two Categories.
Declaration Syntax
C# Visual Basic Visual C++
CategoryInfo MergeCategories(
    CategoryInfo source,
    CategoryInfo destination
)
Function MergeCategories ( _
    source As CategoryInfo, _
    destination As CategoryInfo _
) As CategoryInfo
CategoryInfo^ MergeCategories(
    CategoryInfo^ source,
    CategoryInfo^ destination
)
Parameters
source (CategoryInfo)
The source Category.
destination (CategoryInfo)
The destination Category.
Return Value
The correct CategoryInfo object.
Remarks
The destination Category remains, while the source Category is deleted, and all its Pages re-bound in the destination Category.
Exceptions
Exception | Condition
ArgumentNullException | If source or destination are null.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.PluginFramework (Module: ScrewTurn.Wiki.PluginFramework) Version: 3.0.2.500 (3.0.2.500)


ModifyContentTemplate Method (name, content)

ModifyContentTemplate Method (name, content)
ScrewTurn Wiki ► ScrewTurn.Wiki.PluginFramework ► IPagesStorageProviderV30 ► ModifyContentTemplate(String, String)
Modifies an existing content template.
Declaration Syntax
C# Visual Basic Visual C++
ContentTemplate ModifyContentTemplate(
    string name,
    string content
)
Function ModifyContentTemplate ( _
    name As String, _
    content As String _
) As ContentTemplate
ContentTemplate^ ModifyContentTemplate(
    String^ name,
    String^ content
)
Parameters
name (String)
The name of the template to modify.
content (String)
The content of the template.
Return Value
The correct ContentTemplate object.
Exceptions
Exception | Condition
ArgumentNullException | If name or content are null.
ArgumentNullException | If name is empty.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.PluginFramework (Module: ScrewTurn.Wiki.PluginFramework) Version: 3.0.2.500 (3.0.2.500)


ModifyMessage Method (page, id, username, subject, dateTime, body)

ModifyMessage Method (page, id, username, subject, dateTime, body)
ScrewTurn Wiki ► ScrewTurn.Wiki.PluginFramework ► IPagesStorageProviderV30 ► ModifyMessage(PageInfo, Int32, String, String, DateTime, String)
Modifies a Message.
Declaration Syntax
C# Visual Basic Visual C++
bool ModifyMessage(
    PageInfo page,
    int id,
    string username,
    string subject,
    DateTime dateTime,
    string body
)
Function ModifyMessage ( _
    page As PageInfo, _
    id As Integer, _
    username As String, _
    subject As String, _
    dateTime As DateTime, _
    body As String _
) As Boolean
bool ModifyMessage(
    PageInfo^ page,
    int id,
    String^ username,
    String^ subject,
    DateTime dateTime,
    String^ body
)
Parameters
page (PageInfo)
The Page.
id (Int32)
The ID of the Message to modify.
username (String)
The Username.
subject (String)
The Subject.
dateTime (DateTime)
The Date/Time.
body (String)
The Body.
Return Value
True if the Message is modified successfully.
Exceptions
Exception | Condition
ArgumentNullException | If page, username, subject or body are null.
ArgumentOutOfRangeException | If id is less than zero.
ArgumentException | If username or subject are empty.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.PluginFramework (Module: ScrewTurn.Wiki.PluginFramework) Version: 3.0.2.500 (3.0.2.500)


ModifyNavigationPath Method (path, pages)

ModifyNavigationPath Method (path, pages)
ScrewTurn Wiki ► ScrewTurn.Wiki.PluginFramework ► IPagesStorageProviderV30 ► ModifyNavigationPath(NavigationPath, array<PageInfo>[]()[])
Modifies an existing navigation path.
Declaration Syntax
C# Visual Basic Visual C++
NavigationPath ModifyNavigationPath(
    NavigationPath path,
    PageInfo[] pages
)
Function ModifyNavigationPath ( _
    path As NavigationPath, _
    pages As PageInfo() _
) As NavigationPath
NavigationPath^ ModifyNavigationPath(
    NavigationPath^ path,
    array<PageInfo^>^ pages
)
Parameters
path (NavigationPath)
The navigation path to modify.
pages (array< PageInfo >[]()[][])
The new pages array.
Return Value
The correct NavigationPath object.
Exceptions
Exception | Condition
ArgumentNullException | If path or pages are null.
ArgumentException | If pages is empty.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.PluginFramework (Module: ScrewTurn.Wiki.PluginFramework) Version: 3.0.2.500 (3.0.2.500)


ModifyPage Method (page, title, username, dateTime, comment, content, keywords, description, saveMode)

ModifyPage Method (page, title, username, dateTime, comment, content, keywords, description, saveMode)
ScrewTurn Wiki ► ScrewTurn.Wiki.PluginFramework ► IPagesStorageProviderV30 ► ModifyPage(PageInfo, String, String, DateTime, String, String, array<String>[]()[], String, SaveMode)
Modifies the Content of a Page.
Declaration Syntax
C# Visual Basic Visual C++
bool ModifyPage(
    PageInfo page,
    string title,
    string username,
    DateTime dateTime,
    string comment,
    string content,
    string[] keywords,
    string description,
    SaveMode saveMode
)
Function ModifyPage ( _
    page As PageInfo, _
    title As String, _
    username As String, _
    dateTime As DateTime, _
    comment As String, _
    content As String, _
    keywords As String(), _
    description As String, _
    saveMode As SaveMode _
) As Boolean
bool ModifyPage(
    PageInfo^ page,
    String^ title,
    String^ username,
    DateTime dateTime,
    String^ comment,
    String^ content,
    array<String^>^ keywords,
    String^ description,
    SaveMode saveMode
)
Parameters
page (PageInfo)
The Page.
title (String)
The Title of the Page.
username (String)
The Username.
dateTime (DateTime)
The Date/Time.
comment (String)
The Comment of the editor, about this revision.
content (String)
The Page Content.
keywords (array< String >[]()[][])
The keywords, usually used for SEO.
description (String)
The description, usually used for SEO.
saveMode (SaveMode)
The save mode for this modification.
Return Value
true if the Page has been modified successfully, false otherwise.
Remarks
If saveMode equals Draft and a draft already exists, it is overwritten.
Exceptions
Exception | Condition
ArgumentNullException | If page, title username or content are null.
ArgumentException | If title or username are empty.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.PluginFramework (Module: ScrewTurn.Wiki.PluginFramework) Version: 3.0.2.500 (3.0.2.500)


ModifySnippet Method (name, content)

ModifySnippet Method (name, content)
ScrewTurn Wiki ► ScrewTurn.Wiki.PluginFramework ► IPagesStorageProviderV30 ► ModifySnippet(String, String)
Modifies an existing snippet.
Declaration Syntax
C# Visual Basic Visual C++
Snippet ModifySnippet(
    string name,
    string content
)
Function ModifySnippet ( _
    name As String, _
    content As String _
) As Snippet
Snippet^ ModifySnippet(
    String^ name,
    String^ content
)
Parameters
name (String)
The name of the snippet to modify.
content (String)
The content of the snippet.
Return Value
The correct Snippet object.
Exceptions
Exception | Condition
ArgumentNullException | If name or content are null.
ArgumentNullException | If name is empty.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.PluginFramework (Module: ScrewTurn.Wiki.PluginFramework) Version: 3.0.2.500 (3.0.2.500)


MovePage Method (page, destination, copyCategories)

MovePage Method (page, destination, copyCategories)
ScrewTurn Wiki ► ScrewTurn.Wiki.PluginFramework ► IPagesStorageProviderV30 ► MovePage(PageInfo, NamespaceInfo, Boolean)
Moves a page from its namespace into another.
Declaration Syntax
C# Visual Basic Visual C++
PageInfo MovePage(
    PageInfo page,
    NamespaceInfo destination,
    bool copyCategories
)
Function MovePage ( _
    page As PageInfo, _
    destination As NamespaceInfo, _
    copyCategories As Boolean _
) As PageInfo
PageInfo^ MovePage(
    PageInfo^ page,
    NamespaceInfo^ destination,
    bool copyCategories
)
Parameters
page (PageInfo)
The page to move.
destination (NamespaceInfo)
The destination namespace (null for the root).
copyCategories (Boolean)
A value indicating whether to copy the page categories in the destination namespace, if not already available.
Return Value
The correct instance of PageInfo.
Exceptions
Exception | Condition
ArgumentNullException | If page is null.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.PluginFramework (Module: ScrewTurn.Wiki.PluginFramework) Version: 3.0.2.500 (3.0.2.500)


PerformSearch Method (parameters)

PerformSearch Method (parameters)
ScrewTurn Wiki ► ScrewTurn.Wiki.PluginFramework ► IPagesStorageProviderV30 ► PerformSearch(SearchParameters)
Performs a search in the index.
Declaration Syntax
C# Visual Basic Visual C++
SearchResultCollection PerformSearch(
    SearchParameters parameters
)
Function PerformSearch ( _
    parameters As SearchParameters _
) As SearchResultCollection
SearchResultCollection^ PerformSearch(
    SearchParameters^ parameters
)
Parameters
parameters (SearchParameters)
The search parameters.
Return Value
The results.
Exceptions
Exception | Condition
ArgumentNullException | If parameters is null.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.PluginFramework (Module: ScrewTurn.Wiki.PluginFramework) Version: 3.0.2.500 (3.0.2.500)


RebindPage Method (page, categories)

RebindPage Method (page, categories)
ScrewTurn Wiki ► ScrewTurn.Wiki.PluginFramework ► IPagesStorageProviderV30 ► RebindPage(PageInfo, array<String>[]()[])
Binds a Page with one or more Categories.
Declaration Syntax
C# Visual Basic Visual C++
bool RebindPage(
    PageInfo page,
    string[] categories
)
Function RebindPage ( _
    page As PageInfo, _
    categories As String() _
) As Boolean
bool RebindPage(
    PageInfo^ page,
    array<String^>^ categories
)
Parameters
page (PageInfo)
The Page to bind.
categories (array< String >[]()[][])
The Categories to bind the Page with.
Return Value
True if the binding succeeded.
Remarks
After a successful operation, the Page is bound with all and only the categories passed as argument.
Exceptions
Exception | Condition
ArgumentNullException | If page or categories are null.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.PluginFramework (Module: ScrewTurn.Wiki.PluginFramework) Version: 3.0.2.500 (3.0.2.500)


RebuildIndex Method

RebuildIndex Method
ScrewTurn Wiki ► ScrewTurn.Wiki.PluginFramework ► IPagesStorageProviderV30 ► RebuildIndex()()()
Rebuilds the search index.
Declaration Syntax
C# Visual Basic Visual C++
void RebuildIndex()
Sub RebuildIndex
void RebuildIndex()

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.PluginFramework (Module: ScrewTurn.Wiki.PluginFramework) Version: 3.0.2.500 (3.0.2.500)


RemoveCategory Method (category)

RemoveCategory Method (category)
ScrewTurn Wiki ► ScrewTurn.Wiki.PluginFramework ► IPagesStorageProviderV30 ► RemoveCategory(CategoryInfo)
Removes a Category.
Declaration Syntax
C# Visual Basic Visual C++
bool RemoveCategory(
    CategoryInfo category
)
Function RemoveCategory ( _
    category As CategoryInfo _
) As Boolean
bool RemoveCategory(
    CategoryInfo^ category
)
Parameters
category (CategoryInfo)
The Category to remove.
Return Value
True if the Category has been removed successfully.
Exceptions
Exception | Condition
ArgumentNullException | If category is null.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.PluginFramework (Module: ScrewTurn.Wiki.PluginFramework) Version: 3.0.2.500 (3.0.2.500)


RemoveContentTemplate Method (name)

RemoveContentTemplate Method (name)
ScrewTurn Wiki ► ScrewTurn.Wiki.PluginFramework ► IPagesStorageProviderV30 ► RemoveContentTemplate(String)
Removes a content template.
Declaration Syntax
C# Visual Basic Visual C++
bool RemoveContentTemplate(
    string name
)
Function RemoveContentTemplate ( _
    name As String _
) As Boolean
bool RemoveContentTemplate(
    String^ name
)
Parameters
name (String)
The name of the template to remove.
Return Value
true if the template is removed, false otherwise.
Exceptions
Exception | Condition
ArgumentNullException | If name is null.
ArgumentNullException | If name is empty.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.PluginFramework (Module: ScrewTurn.Wiki.PluginFramework) Version: 3.0.2.500 (3.0.2.500)


RemoveMessage Method (page, id, removeReplies)

RemoveMessage Method (page, id, removeReplies)
ScrewTurn Wiki ► ScrewTurn.Wiki.PluginFramework ► IPagesStorageProviderV30 ► RemoveMessage(PageInfo, Int32, Boolean)
Removes a Message.
Declaration Syntax
C# Visual Basic Visual C++
bool RemoveMessage(
    PageInfo page,
    int id,
    bool removeReplies
)
Function RemoveMessage ( _
    page As PageInfo, _
    id As Integer, _
    removeReplies As Boolean _
) As Boolean
bool RemoveMessage(
    PageInfo^ page,
    int id,
    bool removeReplies
)
Parameters
page (PageInfo)
The Page.
id (Int32)
The ID of the Message to remove.
removeReplies (Boolean)
A value specifying whether or not to remove the replies.
Return Value
True if the Message is removed successfully.
Exceptions
Exception | Condition
ArgumentNullException | If page is null.
ArgumentOutOfRangeException | If id is less than zero.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.PluginFramework (Module: ScrewTurn.Wiki.PluginFramework) Version: 3.0.2.500 (3.0.2.500)


RemoveNamespace Method (nspace)

RemoveNamespace Method (nspace)
ScrewTurn Wiki ► ScrewTurn.Wiki.PluginFramework ► IPagesStorageProviderV30 ► RemoveNamespace(NamespaceInfo)
Removes a namespace.
Declaration Syntax
C# Visual Basic Visual C++
bool RemoveNamespace(
    NamespaceInfo nspace
)
Function RemoveNamespace ( _
    nspace As NamespaceInfo _
) As Boolean
bool RemoveNamespace(
    NamespaceInfo^ nspace
)
Parameters
nspace (NamespaceInfo)
The namespace to remove.
Return Value
true if the namespace is removed, false otherwise.
Exceptions
Exception | Condition
ArgumentNullException | If nspace is null.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.PluginFramework (Module: ScrewTurn.Wiki.PluginFramework) Version: 3.0.2.500 (3.0.2.500)


RemoveNavigationPath Method (path)

RemoveNavigationPath Method (path)
ScrewTurn Wiki ► ScrewTurn.Wiki.PluginFramework ► IPagesStorageProviderV30 ► RemoveNavigationPath(NavigationPath)
Removes a Navigation Path.
Declaration Syntax
C# Visual Basic Visual C++
bool RemoveNavigationPath(
    NavigationPath path
)
Function RemoveNavigationPath ( _
    path As NavigationPath _
) As Boolean
bool RemoveNavigationPath(
    NavigationPath^ path
)
Parameters
path (NavigationPath)
The navigation path to remove.
Return Value
true if the path is removed, false otherwise.
Exceptions
Exception | Condition
ArgumentNullException | If path is null.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.PluginFramework (Module: ScrewTurn.Wiki.PluginFramework) Version: 3.0.2.500 (3.0.2.500)


RemovePage Method (page)

RemovePage Method (page)
ScrewTurn Wiki ► ScrewTurn.Wiki.PluginFramework ► IPagesStorageProviderV30 ► RemovePage(PageInfo)
Removes a Page.
Declaration Syntax
C# Visual Basic Visual C++
bool RemovePage(
    PageInfo page
)
Function RemovePage ( _
    page As PageInfo _
) As Boolean
bool RemovePage(
    PageInfo^ page
)
Parameters
page (PageInfo)
The Page to remove.
Return Value
True if the Page is removed successfully.
Exceptions
Exception | Condition
ArgumentNullException | If page is null.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.PluginFramework (Module: ScrewTurn.Wiki.PluginFramework) Version: 3.0.2.500 (3.0.2.500)


RemoveSnippet Method (name)

RemoveSnippet Method (name)
ScrewTurn Wiki ► ScrewTurn.Wiki.PluginFramework ► IPagesStorageProviderV30 ► RemoveSnippet(String)
Removes a new Snippet.
Declaration Syntax
C# Visual Basic Visual C++
bool RemoveSnippet(
    string name
)
Function RemoveSnippet ( _
    name As String _
) As Boolean
bool RemoveSnippet(
    String^ name
)
Parameters
name (String)
The Name of the Snippet to remove.
Return Value
true if the snippet is removed, false otherwise.
Exceptions
Exception | Condition
ArgumentNullException | If name is null.
ArgumentNullException | If name is empty.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.PluginFramework (Module: ScrewTurn.Wiki.PluginFramework) Version: 3.0.2.500 (3.0.2.500)


RenameCategory Method (category, newName)

RenameCategory Method (category, newName)
ScrewTurn Wiki ► ScrewTurn.Wiki.PluginFramework ► IPagesStorageProviderV30 ► RenameCategory(CategoryInfo, String)
Renames a Category.
Declaration Syntax
C# Visual Basic Visual C++
CategoryInfo RenameCategory(
    CategoryInfo category,
    string newName
)
Function RenameCategory ( _
    category As CategoryInfo, _
    newName As String _
) As CategoryInfo
CategoryInfo^ RenameCategory(
    CategoryInfo^ category,
    String^ newName
)
Parameters
category (CategoryInfo)
The Category to rename.
newName (String)
The new Name.
Return Value
The correct CategoryInfo object.
Exceptions
Exception | Condition
ArgumentNullException | If category or newName are null.
ArgumentException | If newName is empty.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.PluginFramework (Module: ScrewTurn.Wiki.PluginFramework) Version: 3.0.2.500 (3.0.2.500)


RenameNamespace Method (nspace, newName)

RenameNamespace Method (nspace, newName)
ScrewTurn Wiki ► ScrewTurn.Wiki.PluginFramework ► IPagesStorageProviderV30 ► RenameNamespace(NamespaceInfo, String)
Renames a namespace.
Declaration Syntax
C# Visual Basic Visual C++
NamespaceInfo RenameNamespace(
    NamespaceInfo nspace,
    string newName
)
Function RenameNamespace ( _
    nspace As NamespaceInfo, _
    newName As String _
) As NamespaceInfo
NamespaceInfo^ RenameNamespace(
    NamespaceInfo^ nspace,
    String^ newName
)
Parameters
nspace (NamespaceInfo)
The namespace to rename.
newName (String)
The new name of the namespace.
Return Value
The correct NamespaceInfo object.
Exceptions
Exception | Condition
ArgumentNullException | If nspace or newName are null.
ArgumentException | If newName is empty.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.PluginFramework (Module: ScrewTurn.Wiki.PluginFramework) Version: 3.0.2.500 (3.0.2.500)


RenamePage Method (page, newName)

RenamePage Method (page, newName)
ScrewTurn Wiki ► ScrewTurn.Wiki.PluginFramework ► IPagesStorageProviderV30 ► RenamePage(PageInfo, String)
Renames a Page.
Declaration Syntax
C# Visual Basic Visual C++
PageInfo RenamePage(
    PageInfo page,
    string newName
)
Function RenamePage ( _
    page As PageInfo, _
    newName As String _
) As PageInfo
PageInfo^ RenamePage(
    PageInfo^ page,
    String^ newName
)
Parameters
page (PageInfo)
The Page to rename.
newName (String)
The new Name.
Return Value
The correct PageInfo object.
Exceptions
Exception | Condition
ArgumentNullException | If page or newName are null.
ArgumentException | If newName is empty.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.PluginFramework (Module: ScrewTurn.Wiki.PluginFramework) Version: 3.0.2.500 (3.0.2.500)


RollbackPage Method (page, revision)

RollbackPage Method (page, revision)
ScrewTurn Wiki ► ScrewTurn.Wiki.PluginFramework ► IPagesStorageProviderV30 ► RollbackPage(PageInfo, Int32)
Performs the rollback of a Page to a specified revision.
Declaration Syntax
C# Visual Basic Visual C++
bool RollbackPage(
    PageInfo page,
    int revision
)
Function RollbackPage ( _
    page As PageInfo, _
    revision As Integer _
) As Boolean
bool RollbackPage(
    PageInfo^ page,
    int revision
)
Parameters
page (PageInfo)
The Page to rollback.
revision (Int32)
The Revision to rollback the Page to.
Return Value
true if the rollback succeeded, false otherwise.
Exceptions
Exception | Condition
ArgumentNullException | If page is null.
ArgumentOutOfRangeException | If revision is less than zero.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.PluginFramework (Module: ScrewTurn.Wiki.PluginFramework) Version: 3.0.2.500 (3.0.2.500)


SetBackupContent Method (content, revision)

SetBackupContent Method (content, revision)
ScrewTurn Wiki ► ScrewTurn.Wiki.PluginFramework ► IPagesStorageProviderV30 ► SetBackupContent(PageContent, Int32)
Forces to overwrite or create a Backup.
Declaration Syntax
C# Visual Basic Visual C++
bool SetBackupContent(
    PageContent content,
    int revision
)
Function SetBackupContent ( _
    content As PageContent, _
    revision As Integer _
) As Boolean
bool SetBackupContent(
    PageContent^ content,
    int revision
)
Parameters
content (PageContent)
The Backup content.
revision (Int32)
The revision.
Return Value
True if the Backup has been created successfully.
Exceptions
Exception | Condition
ArgumentNullException | If content is null.
ArgumentOutOfRangeException | If revision is less than zero.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.PluginFramework (Module: ScrewTurn.Wiki.PluginFramework) Version: 3.0.2.500 (3.0.2.500)


SetNamespaceDefaultPage Method (nspace, page)

SetNamespaceDefaultPage Method (nspace, page)
ScrewTurn Wiki ► ScrewTurn.Wiki.PluginFramework ► IPagesStorageProviderV30 ► SetNamespaceDefaultPage(NamespaceInfo, PageInfo)
Sets the default page of a namespace.
Declaration Syntax
C# Visual Basic Visual C++
NamespaceInfo SetNamespaceDefaultPage(
    NamespaceInfo nspace,
    PageInfo page
)
Function SetNamespaceDefaultPage ( _
    nspace As NamespaceInfo, _
    page As PageInfo _
) As NamespaceInfo
NamespaceInfo^ SetNamespaceDefaultPage(
    NamespaceInfo^ nspace,
    PageInfo^ page
)
Parameters
nspace (NamespaceInfo)
The namespace of which to set the default page.
page (PageInfo)
The page to use as default page, or null.
Return Value
The correct NamespaceInfo object.
Exceptions
Exception | Condition
ArgumentNullException | If nspace is null.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.PluginFramework (Module: ScrewTurn.Wiki.PluginFramework) Version: 3.0.2.500 (3.0.2.500)


IProviderV30 Interface

IProviderV30 Interface
ScrewTurn Wiki ► ScrewTurn.Wiki.PluginFramework ► IProviderV30
The base interface that all the Providers must implement. All the Provider Type-specific interfaces inherit from this one or from a one, either directly or from a derived interface.
Declaration Syntax
C# Visual Basic Visual C++
public interface IProviderV30
Public Interface IProviderV30
public interface class IProviderV30
Members
All Members | Methods | Properties
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | ConfigHelpHtml | Gets a brief summary of the configuration string format, in HTML. Returns null if no configuration is needed.
 | Information | Gets the Information about the Provider.
 | Init(IHostV30, String) | Initializes the Storage Provider.
 | Shutdown()()() | Method invoked on shutdown.
Remarks
This interface should not be implemented directly by a class.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.PluginFramework (Module: ScrewTurn.Wiki.PluginFramework) Version: 3.0.2.500 (3.0.2.500)


ConfigHelpHtml Property

ConfigHelpHtml Property
ScrewTurn Wiki ► ScrewTurn.Wiki.PluginFramework ► IProviderV30 ► ConfigHelpHtml
Gets a brief summary of the configuration string format, in HTML. Returns null if no configuration is needed.
Declaration Syntax
C# Visual Basic Visual C++
string ConfigHelpHtml { get; }
ReadOnly Property ConfigHelpHtml As String
property String^ ConfigHelpHtml {
    String^ get ();
}

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.PluginFramework (Module: ScrewTurn.Wiki.PluginFramework) Version: 3.0.2.500 (3.0.2.500)


Information Property

Information Property
ScrewTurn Wiki ► ScrewTurn.Wiki.PluginFramework ► IProviderV30 ► Information
Gets the Information about the Provider.
Declaration Syntax
C# Visual Basic Visual C++
ComponentInformation Information { get; }
ReadOnly Property Information As ComponentInformation
property ComponentInformation^ Information {
    ComponentInformation^ get ();
}

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.PluginFramework (Module: ScrewTurn.Wiki.PluginFramework) Version: 3.0.2.500 (3.0.2.500)


Init Method (host, config)

Init Method (host, config)
ScrewTurn Wiki ► ScrewTurn.Wiki.PluginFramework ► IProviderV30 ► Init(IHostV30, String)
Initializes the Storage Provider.
Declaration Syntax
C# Visual Basic Visual C++
void Init(
    IHostV30 host,
    string config
)
Sub Init ( _
    host As IHostV30, _
    config As String _
)
void Init(
    IHostV30^ host,
    String^ config
)
Parameters
host (IHostV30)
The Host of the Component.
config (String)
The Configuration data, if any.
Exceptions
Exception | Condition
ArgumentNullException | If host or config are null.
InvalidConfigurationException | If config is not valid or is incorrect.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.PluginFramework (Module: ScrewTurn.Wiki.PluginFramework) Version: 3.0.2.500 (3.0.2.500)


Shutdown Method

Shutdown Method
ScrewTurn Wiki ► ScrewTurn.Wiki.PluginFramework ► IProviderV30 ► Shutdown()()()
Method invoked on shutdown.
Declaration Syntax
C# Visual Basic Visual C++
void Shutdown()
Sub Shutdown
void Shutdown()
Remarks
This method might not be invoked in some cases.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.PluginFramework (Module: ScrewTurn.Wiki.PluginFramework) Version: 3.0.2.500 (3.0.2.500)


ISettingsStorageProviderV30 Interface

ISettingsStorageProviderV30 Interface
ScrewTurn Wiki ► ScrewTurn.Wiki.PluginFramework ► ISettingsStorageProviderV30
The interface that must be implemented in order to create a custom Settings and Log Storage Provider for ScrewTurn Wiki.
Declaration Syntax
C# Visual Basic Visual C++
public interface ISettingsStorageProviderV30 : IProviderV30
Public Interface ISettingsStorageProviderV30 _
    Implements IProviderV30
public interface class ISettingsStorageProviderV30 : IProviderV30
Members
All Members | Methods | Properties
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | AclManager | Gets the ACL Manager instance.
 | AddRecentChange(String, String, String, DateTime, String, Change, String) | Adds a new change.
 | BeginBulkUpdate()()() | Starts a Bulk update of the Settings so that a bulk of settings can be set before storing them.
 | ClearLog()()() | Clear the Log.
 | ConfigHelpHtml | Gets a brief summary of the configuration string format, in HTML. Returns null if no configuration is needed. (Inherited from IProviderV30.)
 | DeleteOutgoingLinks(String) | Deletes the outgoing links of a page and all the target links that include the page.
 | DeletePluginAssembly(String) | Removes a plugin's assembly.
 | EndBulkUpdate()()() | Ends a Bulk update of the Settings and stores the settings.
 | GetAllOutgoingLinks()()() | Gets all the outgoing links stored.
 | GetAllSettings()()() | Gets the all the setting values.
 | GetLogEntries()()() | Gets all the Log Entries, sorted by date/time (oldest to newest).
 | GetMetaDataItem(MetaDataItem, String) | Gets a meta-data item's content.
 | GetOutgoingLinks(String) | Gets the outgoing links of a page.
 | GetPluginConfiguration(String) | Gets the configuration of a plugin.
 | GetPluginStatus(String) | Gets the status of a plugin.
 | GetRecentChanges()()() | Gets the recent changes of the Wiki.
 | GetSetting(String) | Retrieves the value of a Setting.
 | Information | Gets the Information about the Provider. (Inherited from IProviderV30.)
 | Init(IHostV30, String) | Initializes the Storage Provider. (Inherited from IProviderV30.)
 | IsFirstApplicationStart()()() | Determines whether the application was started for the first time.
 | ListPluginAssemblies()()() | Lists the stored plugin assemblies.
 | LogEntry(String, EntryType, String) | Records a message to the System Log.
 | LogSize | Gets the current size of the Log, in KB.
 | RetrievePluginAssembly(String) | Retrieves a plugin's assembly.
 | SetMetaDataItem(MetaDataItem, String, String) | Sets a meta-data items' content.
 | SetPluginConfiguration(String, String) | Sets the configuration of a plugin.
 | SetPluginStatus(String, Boolean) | Sets the status of a plugin.
 | SetSetting(String, String) | Stores the value of a Setting.
 | Shutdown()()() | Method invoked on shutdown. (Inherited from IProviderV30.)
 | StoreOutgoingLinks(String, array<String>[]()[]) | Stores the outgoing links of a page, overwriting existing data.
 | StorePluginAssembly(String, array<Byte>[]()[]) | Stores a plugin's assembly, overwriting existing ones if present.
 | UpdateOutgoingLinksForRename(String, String) | Updates all outgoing links data for a page rename.
Remarks
A class that implements this interface should have some kind of data caching. The Provider should not use the method GetSettingValue()()() during the execution of the Init()()() method, nor access the wiki log.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.PluginFramework (Module: ScrewTurn.Wiki.PluginFramework) Version: 3.0.2.500 (3.0.2.500)


AclManager Property

AclManager Property
ScrewTurn Wiki ► ScrewTurn.Wiki.PluginFramework ► ISettingsStorageProviderV30 ► AclManager
Gets the ACL Manager instance.
Declaration Syntax
C# Visual Basic Visual C++
IAclManager AclManager { get; }
ReadOnly Property AclManager As IAclManager
property IAclManager^ AclManager {
    IAclManager^ get ();
}

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.PluginFramework (Module: ScrewTurn.Wiki.PluginFramework) Version: 3.0.2.500 (3.0.2.500)


AddRecentChange Method (page, title, messageSubject, dateTime, user, change, descr)

AddRecentChange Method (page, title, messageSubject, dateTime, user, change, descr)
ScrewTurn Wiki ► ScrewTurn.Wiki.PluginFramework ► ISettingsStorageProviderV30 ► AddRecentChange(String, String, String, DateTime, String, Change, String)
Adds a new change.
Declaration Syntax
C# Visual Basic Visual C++
bool AddRecentChange(
    string page,
    string title,
    string messageSubject,
    DateTime dateTime,
    string user,
    Change change,
    string descr
)
Function AddRecentChange ( _
    page As String, _
    title As String, _
    messageSubject As String, _
    dateTime As DateTime, _
    user As String, _
    change As Change, _
    descr As String _
) As Boolean
bool AddRecentChange(
    String^ page,
    String^ title,
    String^ messageSubject,
    DateTime dateTime,
    String^ user,
    Change change,
    String^ descr
)
Parameters
page (String)
The page name.
title (String)
The page title.
messageSubject (String)
The message subject (or null).
dateTime (DateTime)
The date/time.
user (String)
The user.
change (Change)
The change.
descr (String)
The description (optional).
Return Value
true if the change is saved, false otherwise.
Exceptions
Exception | Condition
ArgumentNullException | If page, title or user are null.
ArgumentException | If page, title or user are empty.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.PluginFramework (Module: ScrewTurn.Wiki.PluginFramework) Version: 3.0.2.500 (3.0.2.500)


BeginBulkUpdate Method

BeginBulkUpdate Method
ScrewTurn Wiki ► ScrewTurn.Wiki.PluginFramework ► ISettingsStorageProviderV30 ► BeginBulkUpdate()()()
Starts a Bulk update of the Settings so that a bulk of settings can be set before storing them.
Declaration Syntax
C# Visual Basic Visual C++
void BeginBulkUpdate()
Sub BeginBulkUpdate
void BeginBulkUpdate()

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.PluginFramework (Module: ScrewTurn.Wiki.PluginFramework) Version: 3.0.2.500 (3.0.2.500)


ClearLog Method

ClearLog Method
ScrewTurn Wiki ► ScrewTurn.Wiki.PluginFramework ► ISettingsStorageProviderV30 ► ClearLog()()()
Clear the Log.
Declaration Syntax
C# Visual Basic Visual C++
void ClearLog()
Sub ClearLog
void ClearLog()

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.PluginFramework (Module: ScrewTurn.Wiki.PluginFramework) Version: 3.0.2.500 (3.0.2.500)


DeleteOutgoingLinks Method (page)

DeleteOutgoingLinks Method (page)
ScrewTurn Wiki ► ScrewTurn.Wiki.PluginFramework ► ISettingsStorageProviderV30 ► DeleteOutgoingLinks(String)
Deletes the outgoing links of a page and all the target links that include the page.
Declaration Syntax
C# Visual Basic Visual C++
bool DeleteOutgoingLinks(
    string page
)
Function DeleteOutgoingLinks ( _
    page As String _
) As Boolean
bool DeleteOutgoingLinks(
    String^ page
)
Parameters
page (String)
The full name of the page.
Return Value
true if the links are deleted, false otherwise.
Exceptions
Exception | Condition
ArgumentNullException | If page is null.
ArgumentException | If page is empty.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.PluginFramework (Module: ScrewTurn.Wiki.PluginFramework) Version: 3.0.2.500 (3.0.2.500)


DeletePluginAssembly Method (filename)

DeletePluginAssembly Method (filename)
ScrewTurn Wiki ► ScrewTurn.Wiki.PluginFramework ► ISettingsStorageProviderV30 ► DeletePluginAssembly(String)
Removes a plugin's assembly.
Declaration Syntax
C# Visual Basic Visual C++
bool DeletePluginAssembly(
    string filename
)
Function DeletePluginAssembly ( _
    filename As String _
) As Boolean
bool DeletePluginAssembly(
    String^ filename
)
Parameters
filename (String)
The file name of the assembly to remove, such as "Assembly.dll".
Return Value
true if the assembly is removed, false otherwise.
Exceptions
Exception | Condition
ArgumentNullException | If filename is null.
ArgumentException | If filename is empty.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.PluginFramework (Module: ScrewTurn.Wiki.PluginFramework) Version: 3.0.2.500 (3.0.2.500)


EndBulkUpdate Method

EndBulkUpdate Method
ScrewTurn Wiki ► ScrewTurn.Wiki.PluginFramework ► ISettingsStorageProviderV30 ► EndBulkUpdate()()()
Ends a Bulk update of the Settings and stores the settings.
Declaration Syntax
C# Visual Basic Visual C++
void EndBulkUpdate()
Sub EndBulkUpdate
void EndBulkUpdate()

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.PluginFramework (Module: ScrewTurn.Wiki.PluginFramework) Version: 3.0.2.500 (3.0.2.500)


GetAllOutgoingLinks Method

GetAllOutgoingLinks Method
ScrewTurn Wiki ► ScrewTurn.Wiki.PluginFramework ► ISettingsStorageProviderV30 ► GetAllOutgoingLinks()()()
Gets all the outgoing links stored.
Declaration Syntax
C# Visual Basic Visual C++
IDictionary<string, string[]> GetAllOutgoingLinks()
Function GetAllOutgoingLinks As IDictionary(Of String, String())
IDictionary<String^, array<String^>^>^ GetAllOutgoingLinks()
Return Value
The outgoing links, in a dictionary in the form page->outgoing_links.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.PluginFramework (Module: ScrewTurn.Wiki.PluginFramework) Version: 3.0.2.500 (3.0.2.500)


GetAllSettings Method

GetAllSettings Method
ScrewTurn Wiki ► ScrewTurn.Wiki.PluginFramework ► ISettingsStorageProviderV30 ► GetAllSettings()()()
Gets the all the setting values.
Declaration Syntax
C# Visual Basic Visual C++
IDictionary<string, string> GetAllSettings()
Function GetAllSettings As IDictionary(Of String, String)
IDictionary<String^, String^>^ GetAllSettings()
Return Value
All the settings.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.PluginFramework (Module: ScrewTurn.Wiki.PluginFramework) Version: 3.0.2.500 (3.0.2.500)


GetLogEntries Method

GetLogEntries Method
ScrewTurn Wiki ► ScrewTurn.Wiki.PluginFramework ► ISettingsStorageProviderV30 ► GetLogEntries()()()
Gets all the Log Entries, sorted by date/time (oldest to newest).
Declaration Syntax
C# Visual Basic Visual C++
LogEntry[] GetLogEntries()
Function GetLogEntries As LogEntry()
array<LogEntry^>^ GetLogEntries()
Return Value
The Log Entries.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.PluginFramework (Module: ScrewTurn.Wiki.PluginFramework) Version: 3.0.2.500 (3.0.2.500)


GetMetaDataItem Method (item, tag)

GetMetaDataItem Method (item, tag)
ScrewTurn Wiki ► ScrewTurn.Wiki.PluginFramework ► ISettingsStorageProviderV30 ► GetMetaDataItem(MetaDataItem, String)
Gets a meta-data item's content.
Declaration Syntax
C# Visual Basic Visual C++
string GetMetaDataItem(
    MetaDataItem item,
    string tag
)
Function GetMetaDataItem ( _
    item As MetaDataItem, _
    tag As String _
) As String
String^ GetMetaDataItem(
    MetaDataItem item,
    String^ tag
)
Parameters
item (MetaDataItem)
The item.
tag (String)
The tag that specifies the context (usually the namespace).
Return Value
The content.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.PluginFramework (Module: ScrewTurn.Wiki.PluginFramework) Version: 3.0.2.500 (3.0.2.500)


GetOutgoingLinks Method (page)

GetOutgoingLinks Method (page)
ScrewTurn Wiki ► ScrewTurn.Wiki.PluginFramework ► ISettingsStorageProviderV30 ► GetOutgoingLinks(String)
Gets the outgoing links of a page.
Declaration Syntax
C# Visual Basic Visual C++
string[] GetOutgoingLinks(
    string page
)
Function GetOutgoingLinks ( _
    page As String _
) As String()
array<String^>^ GetOutgoingLinks(
    String^ page
)
Parameters
page (String)
The full name of the page.
Return Value
The outgoing links.
Exceptions
Exception | Condition
ArgumentNullException | If page is null.
ArgumentException | If page is empty.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.PluginFramework (Module: ScrewTurn.Wiki.PluginFramework) Version: 3.0.2.500 (3.0.2.500)


GetPluginConfiguration Method (typeName)

GetPluginConfiguration Method (typeName)
ScrewTurn Wiki ► ScrewTurn.Wiki.PluginFramework ► ISettingsStorageProviderV30 ► GetPluginConfiguration(String)
Gets the configuration of a plugin.
Declaration Syntax
C# Visual Basic Visual C++
string GetPluginConfiguration(
    string typeName
)
Function GetPluginConfiguration ( _
    typeName As String _
) As String
String^ GetPluginConfiguration(
    String^ typeName
)
Parameters
typeName (String)
The Type name of the plugin.
Return Value
The plugin configuration, or String.Empty.
Exceptions
Exception | Condition
ArgumentNullException | If typeName is null.
ArgumentException | If typeName is empty.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.PluginFramework (Module: ScrewTurn.Wiki.PluginFramework) Version: 3.0.2.500 (3.0.2.500)


GetPluginStatus Method (typeName)

GetPluginStatus Method (typeName)
ScrewTurn Wiki ► ScrewTurn.Wiki.PluginFramework ► ISettingsStorageProviderV30 ► GetPluginStatus(String)
Gets the status of a plugin.
Declaration Syntax
C# Visual Basic Visual C++
bool GetPluginStatus(
    string typeName
)
Function GetPluginStatus ( _
    typeName As String _
) As Boolean
bool GetPluginStatus(
    String^ typeName
)
Parameters
typeName (String)
The Type name of the plugin.
Return Value
The status (false for disabled, true for enabled), or true if no status is found.
Exceptions
Exception | Condition
ArgumentNullException | If typeName is null.
ArgumentException | If typeName is empty.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.PluginFramework (Module: ScrewTurn.Wiki.PluginFramework) Version: 3.0.2.500 (3.0.2.500)


GetRecentChanges Method

GetRecentChanges Method
ScrewTurn Wiki ► ScrewTurn.Wiki.PluginFramework ► ISettingsStorageProviderV30 ► GetRecentChanges()()()
Gets the recent changes of the Wiki.
Declaration Syntax
C# Visual Basic Visual C++
RecentChange[] GetRecentChanges()
Function GetRecentChanges As RecentChange()
array<RecentChange^>^ GetRecentChanges()
Return Value
The recent Changes, oldest to newest.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.PluginFramework (Module: ScrewTurn.Wiki.PluginFramework) Version: 3.0.2.500 (3.0.2.500)


GetSetting Method (name)

GetSetting Method (name)
ScrewTurn Wiki ► ScrewTurn.Wiki.PluginFramework ► ISettingsStorageProviderV30 ► GetSetting(String)
Retrieves the value of a Setting.
Declaration Syntax
C# Visual Basic Visual C++
string GetSetting(
    string name
)
Function GetSetting ( _
    name As String _
) As String
String^ GetSetting(
    String^ name
)
Parameters
name (String)
The name of the Setting.
Return Value
The value of the Setting, or null.
Exceptions
Exception | Condition
ArgumentNullException | If name is null.
ArgumentException | If name is empty.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.PluginFramework (Module: ScrewTurn.Wiki.PluginFramework) Version: 3.0.2.500 (3.0.2.500)


IsFirstApplicationStart Method

IsFirstApplicationStart Method
ScrewTurn Wiki ► ScrewTurn.Wiki.PluginFramework ► ISettingsStorageProviderV30 ► IsFirstApplicationStart()()()
Determines whether the application was started for the first time.
Declaration Syntax
C# Visual Basic Visual C++
bool IsFirstApplicationStart()
Function IsFirstApplicationStart As Boolean
bool IsFirstApplicationStart()
Return Value
true if the application was started for the first time, false otherwise.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.PluginFramework (Module: ScrewTurn.Wiki.PluginFramework) Version: 3.0.2.500 (3.0.2.500)


ListPluginAssemblies Method

ListPluginAssemblies Method
ScrewTurn Wiki ► ScrewTurn.Wiki.PluginFramework ► ISettingsStorageProviderV30 ► ListPluginAssemblies()()()
Lists the stored plugin assemblies.
Declaration Syntax
C# Visual Basic Visual C++
string[] ListPluginAssemblies()
Function ListPluginAssemblies As String()
array<String^>^ ListPluginAssemblies()
Return Value

[Missing <returns> documentation for "M:ScrewTurn.Wiki.PluginFramework.ISettingsStorageProviderV30.ListPluginAssemblies"]

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.PluginFramework (Module: ScrewTurn.Wiki.PluginFramework) Version: 3.0.2.500 (3.0.2.500)


LogEntry Method (message, entryType, user)

LogEntry Method (message, entryType, user)
ScrewTurn Wiki ► ScrewTurn.Wiki.PluginFramework ► ISettingsStorageProviderV30 ► LogEntry(String, EntryType, String)
Records a message to the System Log.
Declaration Syntax
C# Visual Basic Visual C++
void LogEntry(
    string message,
    EntryType entryType,
    string user
)
Sub LogEntry ( _
    message As String, _
    entryType As EntryType, _
    user As String _
)
void LogEntry(
    String^ message,
    EntryType entryType,
    String^ user
)
Parameters
message (String)
The Log Message.
entryType (EntryType)
The Type of the Entry.
user (String)
The User.
Remarks
This method should not write messages to the Log using the method IHost.LogEntry. This method should also never throw exceptions (except for parameter validation).
Exceptions
Exception | Condition
ArgumentNullException | If message or user are null.
ArgumentException | If message or user are empty.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.PluginFramework (Module: ScrewTurn.Wiki.PluginFramework) Version: 3.0.2.500 (3.0.2.500)


LogSize Property

LogSize Property
ScrewTurn Wiki ► ScrewTurn.Wiki.PluginFramework ► ISettingsStorageProviderV30 ► LogSize
Gets the current size of the Log, in KB.
Declaration Syntax
C# Visual Basic Visual C++
int LogSize { get; }
ReadOnly Property LogSize As Integer
property int LogSize {
    int get ();
}

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.PluginFramework (Module: ScrewTurn.Wiki.PluginFramework) Version: 3.0.2.500 (3.0.2.500)


RetrievePluginAssembly Method (filename)

RetrievePluginAssembly Method (filename)
ScrewTurn Wiki ► ScrewTurn.Wiki.PluginFramework ► ISettingsStorageProviderV30 ► RetrievePluginAssembly(String)
Retrieves a plugin's assembly.
Declaration Syntax
C# Visual Basic Visual C++
byte[] RetrievePluginAssembly(
    string filename
)
Function RetrievePluginAssembly ( _
    filename As String _
) As Byte()
array<unsigned char>^ RetrievePluginAssembly(
    String^ filename
)
Parameters
filename (String)
The file name of the assembly.
Return Value
The assembly content, or null.
Exceptions
Exception | Condition
ArgumentNullException | If filename is null.
ArgumentException | If filename is empty.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.PluginFramework (Module: ScrewTurn.Wiki.PluginFramework) Version: 3.0.2.500 (3.0.2.500)


SetMetaDataItem Method (item, tag, content)

SetMetaDataItem Method (item, tag, content)
ScrewTurn Wiki ► ScrewTurn.Wiki.PluginFramework ► ISettingsStorageProviderV30 ► SetMetaDataItem(MetaDataItem, String, String)
Sets a meta-data items' content.
Declaration Syntax
C# Visual Basic Visual C++
bool SetMetaDataItem(
    MetaDataItem item,
    string tag,
    string content
)
Function SetMetaDataItem ( _
    item As MetaDataItem, _
    tag As String, _
    content As String _
) As Boolean
bool SetMetaDataItem(
    MetaDataItem item,
    String^ tag,
    String^ content
)
Parameters
item (MetaDataItem)
The item.
tag (String)
The tag that specifies the context (usually the namespace).
content (String)
The content.
Return Value
true if the content is set, false otherwise.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.PluginFramework (Module: ScrewTurn.Wiki.PluginFramework) Version: 3.0.2.500 (3.0.2.500)


SetPluginConfiguration Method (typeName, config)

SetPluginConfiguration Method (typeName, config)
ScrewTurn Wiki ► ScrewTurn.Wiki.PluginFramework ► ISettingsStorageProviderV30 ► SetPluginConfiguration(String, String)
Sets the configuration of a plugin.
Declaration Syntax
C# Visual Basic Visual C++
bool SetPluginConfiguration(
    string typeName,
    string config
)
Function SetPluginConfiguration ( _
    typeName As String, _
    config As String _
) As Boolean
bool SetPluginConfiguration(
    String^ typeName,
    String^ config
)
Parameters
typeName (String)
The Type name of the plugin.
config (String)
The configuration.
Return Value
true if the configuration is stored, false otherwise.
Exceptions
Exception | Condition
ArgumentNullException | If typeName is null.
ArgumentException | If typeName is empty.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.PluginFramework (Module: ScrewTurn.Wiki.PluginFramework) Version: 3.0.2.500 (3.0.2.500)


SetPluginStatus Method (typeName, enabled)

SetPluginStatus Method (typeName, enabled)
ScrewTurn Wiki ► ScrewTurn.Wiki.PluginFramework ► ISettingsStorageProviderV30 ► SetPluginStatus(String, Boolean)
Sets the status of a plugin.
Declaration Syntax
C# Visual Basic Visual C++
bool SetPluginStatus(
    string typeName,
    bool enabled
)
Function SetPluginStatus ( _
    typeName As String, _
    enabled As Boolean _
) As Boolean
bool SetPluginStatus(
    String^ typeName,
    bool enabled
)
Parameters
typeName (String)
The Type name of the plugin.
enabled (Boolean)
The plugin status.
Return Value
true if the status is stored, false otherwise.
Exceptions
Exception | Condition
ArgumentNullException | If typeName is null.
ArgumentException | If typeName is empty.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.PluginFramework (Module: ScrewTurn.Wiki.PluginFramework) Version: 3.0.2.500 (3.0.2.500)


SetSetting Method (name, value)

SetSetting Method (name, value)
ScrewTurn Wiki ► ScrewTurn.Wiki.PluginFramework ► ISettingsStorageProviderV30 ► SetSetting(String, String)
Stores the value of a Setting.
Declaration Syntax
C# Visual Basic Visual C++
bool SetSetting(
    string name,
    string value
)
Function SetSetting ( _
    name As String, _
    value As String _
) As Boolean
bool SetSetting(
    String^ name,
    String^ value
)
Parameters
name (String)
The name of the Setting.
value (String)
The value of the Setting. Value cannot contain CR and LF characters, which will be removed.
Return Value
True if the Setting is stored, false otherwise.
Remarks
This method stores the Value immediately.
Exceptions
Exception | Condition
ArgumentNullException | If name is null.
ArgumentException | If name is empty.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.PluginFramework (Module: ScrewTurn.Wiki.PluginFramework) Version: 3.0.2.500 (3.0.2.500)


StoreOutgoingLinks Method (page, outgoingLinks)

StoreOutgoingLinks Method (page, outgoingLinks)
ScrewTurn Wiki ► ScrewTurn.Wiki.PluginFramework ► ISettingsStorageProviderV30 ► StoreOutgoingLinks(String, array<String>[]()[])
Stores the outgoing links of a page, overwriting existing data.
Declaration Syntax
C# Visual Basic Visual C++
bool StoreOutgoingLinks(
    string page,
    string[] outgoingLinks
)
Function StoreOutgoingLinks ( _
    page As String, _
    outgoingLinks As String() _
) As Boolean
bool StoreOutgoingLinks(
    String^ page,
    array<String^>^ outgoingLinks
)
Parameters
page (String)
The full name of the page.
outgoingLinks (array< String >[]()[][])
The full names of the pages that page links to.
Return Value
true if the outgoing links are stored, false otherwise.
Exceptions
Exception | Condition
ArgumentNullException | If page or outgoingLinks are null.
ArgumentException | If page or outgoingLinks are empty.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.PluginFramework (Module: ScrewTurn.Wiki.PluginFramework) Version: 3.0.2.500 (3.0.2.500)


StorePluginAssembly Method (filename, assembly)

StorePluginAssembly Method (filename, assembly)
ScrewTurn Wiki ► ScrewTurn.Wiki.PluginFramework ► ISettingsStorageProviderV30 ► StorePluginAssembly(String, array<Byte>[]()[])
Stores a plugin's assembly, overwriting existing ones if present.
Declaration Syntax
C# Visual Basic Visual C++
bool StorePluginAssembly(
    string filename,
    byte[] assembly
)
Function StorePluginAssembly ( _
    filename As String, _
    assembly As Byte() _
) As Boolean
bool StorePluginAssembly(
    String^ filename,
    array<unsigned char>^ assembly
)
Parameters
filename (String)
The file name of the assembly, such as "Assembly.dll".
assembly (array< Byte >[]()[][])
The assembly content.
Return Value
true if the assembly is stored, false otherwise.
Exceptions
Exception | Condition
ArgumentNullException | If filename or assembly are null.
ArgumentException | If filename or assembly are empty.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.PluginFramework (Module: ScrewTurn.Wiki.PluginFramework) Version: 3.0.2.500 (3.0.2.500)


UpdateOutgoingLinksForRename Method (oldName, newName)

UpdateOutgoingLinksForRename Method (oldName, newName)
ScrewTurn Wiki ► ScrewTurn.Wiki.PluginFramework ► ISettingsStorageProviderV30 ► UpdateOutgoingLinksForRename(String, String)
Updates all outgoing links data for a page rename.
Declaration Syntax
C# Visual Basic Visual C++
bool UpdateOutgoingLinksForRename(
    string oldName,
    string newName
)
Function UpdateOutgoingLinksForRename ( _
    oldName As String, _
    newName As String _
) As Boolean
bool UpdateOutgoingLinksForRename(
    String^ oldName,
    String^ newName
)
Parameters
oldName (String)
The old page name.
newName (String)
The new page name.
Return Value
true if the data is updated, false otherwise.
Exceptions
Exception | Condition
ArgumentNullException | If oldName or newName are null.
ArgumentException | If oldName or newName are empty.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.PluginFramework (Module: ScrewTurn.Wiki.PluginFramework) Version: 3.0.2.500 (3.0.2.500)


IStorageProviderV30 Interface

IStorageProviderV30 Interface
ScrewTurn Wiki ► ScrewTurn.Wiki.PluginFramework ► IStorageProviderV30
The base interface that all the Storage Providers must implement. All the Provider Type-specific interfaces inherit from this one or from a one, either directly or from a derived interface
Declaration Syntax
C# Visual Basic Visual C++
public interface IStorageProviderV30 : IProviderV30
Public Interface IStorageProviderV30 _
    Implements IProviderV30
public interface class IStorageProviderV30 : IProviderV30
Members
All Members | Methods | Properties
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | ConfigHelpHtml | Gets a brief summary of the configuration string format, in HTML. Returns null if no configuration is needed. (Inherited from IProviderV30.)
 | Information | Gets the Information about the Provider. (Inherited from IProviderV30.)
 | Init(IHostV30, String) | Initializes the Storage Provider. (Inherited from IProviderV30.)
 | ReadOnly | Gets a value specifying whether the provider is read-only, i.e. it can only provide data and not store it.
 | Shutdown()()() | Method invoked on shutdown. (Inherited from IProviderV30.)
Remarks
This interface should not be implemented directly by a class.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.PluginFramework (Module: ScrewTurn.Wiki.PluginFramework) Version: 3.0.2.500 (3.0.2.500)


ReadOnly Property

ReadOnly Property
ScrewTurn Wiki ► ScrewTurn.Wiki.PluginFramework ► IStorageProviderV30 ► ReadOnly
Gets a value specifying whether the provider is read-only, i.e. it can only provide data and not store it.
Declaration Syntax
C# Visual Basic Visual C++
bool ReadOnly { get; }
ReadOnly Property ReadOnly As Boolean
property bool ReadOnly {
    bool get ();
}

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.PluginFramework (Module: ScrewTurn.Wiki.PluginFramework) Version: 3.0.2.500 (3.0.2.500)


IUsersStorageProviderV30 Interface

IUsersStorageProviderV30 Interface
ScrewTurn Wiki ► ScrewTurn.Wiki.PluginFramework ► IUsersStorageProviderV30
It is the interface that must be implemented in order to create a custom Users Storage Provider for ScrewTurn Wiki.
Declaration Syntax
C# Visual Basic Visual C++
public interface IUsersStorageProviderV30 : IProviderV30
Public Interface IUsersStorageProviderV30 _
    Implements IProviderV30
public interface class IUsersStorageProviderV30 : IProviderV30
Members
All Members | Methods | Properties
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | AddUser(String, String, String, String, Boolean, DateTime) | Adds a new User.
 | AddUserGroup(String, String) | Adds a new user group.
 | ConfigHelpHtml | Gets a brief summary of the configuration string format, in HTML. Returns null if no configuration is needed. (Inherited from IProviderV30.)
 | GetUser(String) | Gets a user account.
 | GetUserByEmail(String) | Gets a user account.
 | GetUserGroups()()() | Gets all the user groups.
 | GetUsers()()() | Gets the complete list of Users.
 | GetUsersWithData(String) | Gets all the users that have the specified element in their data.
 | GroupMembershipReadOnly | Gets a value indicating whether group membership is read-only (if UserAccountsReadOnly is false, then this property must be false). If this property is true, the provider should return membership data compatible with default user groups.
 | Information | Gets the Information about the Provider. (Inherited from IProviderV30.)
 | Init(IHostV30, String) | Initializes the Storage Provider. (Inherited from IProviderV30.)
 | ModifyUser(UserInfo, String, String, String, Boolean) | Modifies a User.
 | ModifyUserGroup(UserGroup, String) | Modifies a user group.
 | NotifyCookieLogin(UserInfo) | Notifies the provider that a user has logged in through the authentication cookie.
 | NotifyLogout(UserInfo) | Notifies the provider that a user has logged out.
 | RemoveUser(UserInfo) | Removes a User.
 | RemoveUserGroup(UserGroup) | Removes a user group.
 | RetrieveAllUserData(UserInfo) | Retrieves all the user data elements for a user.
 | RetrieveUserData(UserInfo, String) | Gets a user data element, if any.
 | SetUserMembership(UserInfo, array<String>[]()[]) | Sets the group memberships of a user account.
 | Shutdown()()() | Method invoked on shutdown. (Inherited from IProviderV30.)
 | StoreUserData(UserInfo, String, String) | Stores a user data element, overwriting the previous one if present.
 | TestAccount(UserInfo, String) | Tests a Password for a User account.
 | TryAutoLogin(HttpContext) | Tries to login a user directly through the provider using the current HttpContext and without username/password.
 | TryManualLogin(String, String) | Tries to login a user directly through the provider.
 | UserAccountsReadOnly | Gets a value indicating whether user accounts are read-only.
 | UserGroupsReadOnly | Gets a value indicating whether user groups are read-only. If so, the provider should support default user groups as defined in the wiki configuration.
 | UsersDataReadOnly | Gets a value indicating whether users' data is read-only.
Remarks
A class that implements this class should not have any kind of data caching.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.PluginFramework (Module: ScrewTurn.Wiki.PluginFramework) Version: 3.0.2.500 (3.0.2.500)


AddUser Method (username, displayName, password, email, active, dateTime)

AddUser Method (username, displayName, password, email, active, dateTime)
ScrewTurn Wiki ► ScrewTurn.Wiki.PluginFramework ► IUsersStorageProviderV30 ► AddUser(String, String, String, String, Boolean, DateTime)
Adds a new User.
Declaration Syntax
C# Visual Basic Visual C++
UserInfo AddUser(
    string username,
    string displayName,
    string password,
    string email,
    bool active,
    DateTime dateTime
)
Function AddUser ( _
    username As String, _
    displayName As String, _
    password As String, _
    email As String, _
    active As Boolean, _
    dateTime As DateTime _
) As UserInfo
UserInfo^ AddUser(
    String^ username,
    String^ displayName,
    String^ password,
    String^ email,
    bool active,
    DateTime dateTime
)
Parameters
username (String)
The Username.
displayName (String)
The display name (can be null).
password (String)
The Password.
email (String)
The Email address.
active (Boolean)
A value indicating whether the account is active.
dateTime (DateTime)
The Account creation Date/Time.
Return Value
The correct UserInfo object or null.
Exceptions
Exception | Condition
ArgumentNullException | If username, password or email are null.
ArgumentException | If username, password or email are empty.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.PluginFramework (Module: ScrewTurn.Wiki.PluginFramework) Version: 3.0.2.500 (3.0.2.500)


AddUserGroup Method (name, description)

AddUserGroup Method (name, description)
ScrewTurn Wiki ► ScrewTurn.Wiki.PluginFramework ► IUsersStorageProviderV30 ► AddUserGroup(String, String)
Adds a new user group.
Declaration Syntax
C# Visual Basic Visual C++
UserGroup AddUserGroup(
    string name,
    string description
)
Function AddUserGroup ( _
    name As String, _
    description As String _
) As UserGroup
UserGroup^ AddUserGroup(
    String^ name,
    String^ description
)
Parameters
name (String)
The name of the group.
description (String)
The description of the group.
Return Value
The correct UserGroup object or null.
Exceptions
Exception | Condition
ArgumentNullException | If name or description are null.
ArgumentException | If name is empty.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.PluginFramework (Module: ScrewTurn.Wiki.PluginFramework) Version: 3.0.2.500 (3.0.2.500)


GetUser Method (username)

GetUser Method (username)
ScrewTurn Wiki ► ScrewTurn.Wiki.PluginFramework ► IUsersStorageProviderV30 ► GetUser(String)
Gets a user account.
Declaration Syntax
C# Visual Basic Visual C++
UserInfo GetUser(
    string username
)
Function GetUser ( _
    username As String _
) As UserInfo
UserInfo^ GetUser(
    String^ username
)
Parameters
username (String)
The username.
Return Value
The UserInfo, or null.
Exceptions
Exception | Condition
ArgumentNullException | If username is null.
ArgumentException | If username is empty.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.PluginFramework (Module: ScrewTurn.Wiki.PluginFramework) Version: 3.0.2.500 (3.0.2.500)


GetUserByEmail Method (email)

GetUserByEmail Method (email)
ScrewTurn Wiki ► ScrewTurn.Wiki.PluginFramework ► IUsersStorageProviderV30 ► GetUserByEmail(String)
Gets a user account.
Declaration Syntax
C# Visual Basic Visual C++
UserInfo GetUserByEmail(
    string email
)
Function GetUserByEmail ( _
    email As String _
) As UserInfo
UserInfo^ GetUserByEmail(
    String^ email
)
Parameters
email (String)
The email address.
Return Value
The first user found with the specified email address, or null.
Exceptions
Exception | Condition
ArgumentNullException | If email is null.
ArgumentException | If email is empty.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.PluginFramework (Module: ScrewTurn.Wiki.PluginFramework) Version: 3.0.2.500 (3.0.2.500)


GetUserGroups Method

GetUserGroups Method
ScrewTurn Wiki ► ScrewTurn.Wiki.PluginFramework ► IUsersStorageProviderV30 ► GetUserGroups()()()
Gets all the user groups.
Declaration Syntax
C# Visual Basic Visual C++
UserGroup[] GetUserGroups()
Function GetUserGroups As UserGroup()
array<UserGroup^>^ GetUserGroups()
Return Value
All the groups, sorted by name.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.PluginFramework (Module: ScrewTurn.Wiki.PluginFramework) Version: 3.0.2.500 (3.0.2.500)


GetUsers Method

GetUsers Method
ScrewTurn Wiki ► ScrewTurn.Wiki.PluginFramework ► IUsersStorageProviderV30 ► GetUsers()()()
Gets the complete list of Users.
Declaration Syntax
C# Visual Basic Visual C++
UserInfo[] GetUsers()
Function GetUsers As UserInfo()
array<UserInfo^>^ GetUsers()
Return Value
All the Users, sorted by username.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.PluginFramework (Module: ScrewTurn.Wiki.PluginFramework) Version: 3.0.2.500 (3.0.2.500)


GetUsersWithData Method (key)

GetUsersWithData Method (key)
ScrewTurn Wiki ► ScrewTurn.Wiki.PluginFramework ► IUsersStorageProviderV30 ► GetUsersWithData(String)
Gets all the users that have the specified element in their data.
Declaration Syntax
C# Visual Basic Visual C++
IDictionary<UserInfo, string> GetUsersWithData(
    string key
)
Function GetUsersWithData ( _
    key As String _
) As IDictionary(Of UserInfo, String)
IDictionary<UserInfo^, String^>^ GetUsersWithData(
    String^ key
)
Parameters
key (String)
The key of the data.
Return Value
The users and the data.
Exceptions
Exception | Condition
ArgumentNullException | If key is null.
ArgumentException | If key is empty.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.PluginFramework (Module: ScrewTurn.Wiki.PluginFramework) Version: 3.0.2.500 (3.0.2.500)


GroupMembershipReadOnly Property

GroupMembershipReadOnly Property
ScrewTurn Wiki ► ScrewTurn.Wiki.PluginFramework ► IUsersStorageProviderV30 ► GroupMembershipReadOnly
Gets a value indicating whether group membership is read-only (if UserAccountsReadOnly is false, then this property must be false). If this property is true, the provider should return membership data compatible with default user groups.
Declaration Syntax
C# Visual Basic Visual C++
bool GroupMembershipReadOnly { get; }
ReadOnly Property GroupMembershipReadOnly As Boolean
property bool GroupMembershipReadOnly {
    bool get ();
}

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.PluginFramework (Module: ScrewTurn.Wiki.PluginFramework) Version: 3.0.2.500 (3.0.2.500)


ModifyUser Method (user, newDisplayName, newPassword, newEmail, newActive)

ModifyUser Method (user, newDisplayName, newPassword, newEmail, newActive)
ScrewTurn Wiki ► ScrewTurn.Wiki.PluginFramework ► IUsersStorageProviderV30 ► ModifyUser(UserInfo, String, String, String, Boolean)
Modifies a User.
Declaration Syntax
C# Visual Basic Visual C++
UserInfo ModifyUser(
    UserInfo user,
    string newDisplayName,
    string newPassword,
    string newEmail,
    bool newActive
)
Function ModifyUser ( _
    user As UserInfo, _
    newDisplayName As String, _
    newPassword As String, _
    newEmail As String, _
    newActive As Boolean _
) As UserInfo
UserInfo^ ModifyUser(
    UserInfo^ user,
    String^ newDisplayName,
    String^ newPassword,
    String^ newEmail,
    bool newActive
)
Parameters
user (UserInfo)
The Username of the user to modify.
newDisplayName (String)
The new display name (can be null).
newPassword (String)
The new Password (null or blank to keep the current password).
newEmail (String)
The new Email address.
newActive (Boolean)
A value indicating whether the account is active.
Return Value
The correct UserInfo object or null.
Exceptions
Exception | Condition
ArgumentNullException | If user or newEmail are null.
ArgumentException | If newEmail is empty.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.PluginFramework (Module: ScrewTurn.Wiki.PluginFramework) Version: 3.0.2.500 (3.0.2.500)


ModifyUserGroup Method (group, description)

ModifyUserGroup Method (group, description)
ScrewTurn Wiki ► ScrewTurn.Wiki.PluginFramework ► IUsersStorageProviderV30 ► ModifyUserGroup(UserGroup, String)
Modifies a user group.
Declaration Syntax
C# Visual Basic Visual C++
UserGroup ModifyUserGroup(
    UserGroup group,
    string description
)
Function ModifyUserGroup ( _
    group As UserGroup, _
    description As String _
) As UserGroup
UserGroup^ ModifyUserGroup(
    UserGroup^ group,
    String^ description
)
Parameters
group (UserGroup)
The group to modify.
description (String)
The new description of the group.
Return Value
The correct UserGroup object or null.
Exceptions
Exception | Condition
ArgumentNullException | If group or description are null.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.PluginFramework (Module: ScrewTurn.Wiki.PluginFramework) Version: 3.0.2.500 (3.0.2.500)


NotifyCookieLogin Method (user)

NotifyCookieLogin Method (user)
ScrewTurn Wiki ► ScrewTurn.Wiki.PluginFramework ► IUsersStorageProviderV30 ► NotifyCookieLogin(UserInfo)
Notifies the provider that a user has logged in through the authentication cookie.
Declaration Syntax
C# Visual Basic Visual C++
void NotifyCookieLogin(
    UserInfo user
)
Sub NotifyCookieLogin ( _
    user As UserInfo _
)
void NotifyCookieLogin(
    UserInfo^ user
)
Parameters
user (UserInfo)
The user who has logged in.
Exceptions
Exception | Condition
ArgumentNullException | If user is null.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.PluginFramework (Module: ScrewTurn.Wiki.PluginFramework) Version: 3.0.2.500 (3.0.2.500)


NotifyLogout Method (user)

NotifyLogout Method (user)
ScrewTurn Wiki ► ScrewTurn.Wiki.PluginFramework ► IUsersStorageProviderV30 ► NotifyLogout(UserInfo)
Notifies the provider that a user has logged out.
Declaration Syntax
C# Visual Basic Visual C++
void NotifyLogout(
    UserInfo user
)
Sub NotifyLogout ( _
    user As UserInfo _
)
void NotifyLogout(
    UserInfo^ user
)
Parameters
user (UserInfo)
The user who has logged out.
Exceptions
Exception | Condition
ArgumentNullException | If user is null.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.PluginFramework (Module: ScrewTurn.Wiki.PluginFramework) Version: 3.0.2.500 (3.0.2.500)


RemoveUser Method (user)

RemoveUser Method (user)
ScrewTurn Wiki ► ScrewTurn.Wiki.PluginFramework ► IUsersStorageProviderV30 ► RemoveUser(UserInfo)
Removes a User.
Declaration Syntax
C# Visual Basic Visual C++
bool RemoveUser(
    UserInfo user
)
Function RemoveUser ( _
    user As UserInfo _
) As Boolean
bool RemoveUser(
    UserInfo^ user
)
Parameters
user (UserInfo)
The User to remove.
Return Value
True if the User has been removed successfully.
Exceptions
Exception | Condition
ArgumentNullException | If user is null.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.PluginFramework (Module: ScrewTurn.Wiki.PluginFramework) Version: 3.0.2.500 (3.0.2.500)


RemoveUserGroup Method (group)

RemoveUserGroup Method (group)
ScrewTurn Wiki ► ScrewTurn.Wiki.PluginFramework ► IUsersStorageProviderV30 ► RemoveUserGroup(UserGroup)
Removes a user group.
Declaration Syntax
C# Visual Basic Visual C++
bool RemoveUserGroup(
    UserGroup group
)
Function RemoveUserGroup ( _
    group As UserGroup _
) As Boolean
bool RemoveUserGroup(
    UserGroup^ group
)
Parameters
group (UserGroup)
The group to remove.
Return Value
true if the group is removed, false otherwise.
Exceptions
Exception | Condition
ArgumentNullException | If group is null.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.PluginFramework (Module: ScrewTurn.Wiki.PluginFramework) Version: 3.0.2.500 (3.0.2.500)


RetrieveAllUserData Method (user)

RetrieveAllUserData Method (user)
ScrewTurn Wiki ► ScrewTurn.Wiki.PluginFramework ► IUsersStorageProviderV30 ► RetrieveAllUserData(UserInfo)
Retrieves all the user data elements for a user.
Declaration Syntax
C# Visual Basic Visual C++
IDictionary<string, string> RetrieveAllUserData(
    UserInfo user
)
Function RetrieveAllUserData ( _
    user As UserInfo _
) As IDictionary(Of String, String)
IDictionary<String^, String^>^ RetrieveAllUserData(
    UserInfo^ user
)
Parameters
user (UserInfo)
The user.
Return Value
The user data elements (key->value).
Exceptions
Exception | Condition
ArgumentNullException | If user is null.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.PluginFramework (Module: ScrewTurn.Wiki.PluginFramework) Version: 3.0.2.500 (3.0.2.500)


RetrieveUserData Method (user, key)

RetrieveUserData Method (user, key)
ScrewTurn Wiki ► ScrewTurn.Wiki.PluginFramework ► IUsersStorageProviderV30 ► RetrieveUserData(UserInfo, String)
Gets a user data element, if any.
Declaration Syntax
C# Visual Basic Visual C++
string RetrieveUserData(
    UserInfo user,
    string key
)
Function RetrieveUserData ( _
    user As UserInfo, _
    key As String _
) As String
String^ RetrieveUserData(
    UserInfo^ user,
    String^ key
)
Parameters
user (UserInfo)
The user the data belongs to.
key (String)
The key of the data element.
Return Value
The value of the data element, or null if the element is not found.
Exceptions
Exception | Condition
ArgumentNullException | If user or key are null.
ArgumentException | If key is empty.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.PluginFramework (Module: ScrewTurn.Wiki.PluginFramework) Version: 3.0.2.500 (3.0.2.500)


SetUserMembership Method (user, groups)

SetUserMembership Method (user, groups)
ScrewTurn Wiki ► ScrewTurn.Wiki.PluginFramework ► IUsersStorageProviderV30 ► SetUserMembership(UserInfo, array<String>[]()[])
Sets the group memberships of a user account.
Declaration Syntax
C# Visual Basic Visual C++
UserInfo SetUserMembership(
    UserInfo user,
    string[] groups
)
Function SetUserMembership ( _
    user As UserInfo, _
    groups As String() _
) As UserInfo
UserInfo^ SetUserMembership(
    UserInfo^ user,
    array<String^>^ groups
)
Parameters
user (UserInfo)
The user account.
groups (array< String >[]()[][])
The groups the user account is member of.
Return Value
The correct UserGroup object or null.
Exceptions
Exception | Condition
ArgumentNullException | If user or groups are null.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.PluginFramework (Module: ScrewTurn.Wiki.PluginFramework) Version: 3.0.2.500 (3.0.2.500)


StoreUserData Method (user, key, value)

StoreUserData Method (user, key, value)
ScrewTurn Wiki ► ScrewTurn.Wiki.PluginFramework ► IUsersStorageProviderV30 ► StoreUserData(UserInfo, String, String)
Stores a user data element, overwriting the previous one if present.
Declaration Syntax
C# Visual Basic Visual C++
bool StoreUserData(
    UserInfo user,
    string key,
    string value
)
Function StoreUserData ( _
    user As UserInfo, _
    key As String, _
    value As String _
) As Boolean
bool StoreUserData(
    UserInfo^ user,
    String^ key,
    String^ value
)
Parameters
user (UserInfo)
The user the data belongs to.
key (String)
The key of the data element (case insensitive).
value (String)
The value of the data element, null for deleting the data.
Return Value
true if the data element is stored, false otherwise.
Exceptions
Exception | Condition
ArgumentNullException | If user or key are null.
ArgumentException | If key is empty.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.PluginFramework (Module: ScrewTurn.Wiki.PluginFramework) Version: 3.0.2.500 (3.0.2.500)


TestAccount Method (user, password)

TestAccount Method (user, password)
ScrewTurn Wiki ► ScrewTurn.Wiki.PluginFramework ► IUsersStorageProviderV30 ► TestAccount(UserInfo, String)
Tests a Password for a User account.
Declaration Syntax
C# Visual Basic Visual C++
bool TestAccount(
    UserInfo user,
    string password
)
Function TestAccount ( _
    user As UserInfo, _
    password As String _
) As Boolean
bool TestAccount(
    UserInfo^ user,
    String^ password
)
Parameters
user (UserInfo)
The User account.
password (String)
The Password to test.
Return Value
True if the Password is correct.
Exceptions
Exception | Condition
ArgumentNullException | If username or password are null.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.PluginFramework (Module: ScrewTurn.Wiki.PluginFramework) Version: 3.0.2.500 (3.0.2.500)


TryAutoLogin Method (context)

TryAutoLogin Method (context)
ScrewTurn Wiki ► ScrewTurn.Wiki.PluginFramework ► IUsersStorageProviderV30 ► TryAutoLogin(HttpContext)
Tries to login a user directly through the provider using the current HttpContext and without username/password.
Declaration Syntax
C# Visual Basic Visual C++
UserInfo TryAutoLogin(
    HttpContext context
)
Function TryAutoLogin ( _
    context As HttpContext _
) As UserInfo
UserInfo^ TryAutoLogin(
    HttpContext^ context
)
Parameters
context (HttpContext)
The current HttpContext.
Return Value
The correct UserInfo object, or null.
Exceptions
Exception | Condition
ArgumentNullException | If context is null.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.PluginFramework (Module: ScrewTurn.Wiki.PluginFramework) Version: 3.0.2.500 (3.0.2.500)


TryManualLogin Method (username, password)

TryManualLogin Method (username, password)
ScrewTurn Wiki ► ScrewTurn.Wiki.PluginFramework ► IUsersStorageProviderV30 ► TryManualLogin(String, String)
Tries to login a user directly through the provider.
Declaration Syntax
C# Visual Basic Visual C++
UserInfo TryManualLogin(
    string username,
    string password
)
Function TryManualLogin ( _
    username As String, _
    password As String _
) As UserInfo
UserInfo^ TryManualLogin(
    String^ username,
    String^ password
)
Parameters
username (String)
The username.
password (String)
The password.
Return Value
The correct UserInfo object, or null.
Exceptions
Exception | Condition
ArgumentNullException | If username or password are null.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.PluginFramework (Module: ScrewTurn.Wiki.PluginFramework) Version: 3.0.2.500 (3.0.2.500)


UserAccountsReadOnly Property

UserAccountsReadOnly Property
ScrewTurn Wiki ► ScrewTurn.Wiki.PluginFramework ► IUsersStorageProviderV30 ► UserAccountsReadOnly
Gets a value indicating whether user accounts are read-only.
Declaration Syntax
C# Visual Basic Visual C++
bool UserAccountsReadOnly { get; }
ReadOnly Property UserAccountsReadOnly As Boolean
property bool UserAccountsReadOnly {
    bool get ();
}

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.PluginFramework (Module: ScrewTurn.Wiki.PluginFramework) Version: 3.0.2.500 (3.0.2.500)


UserGroupsReadOnly Property

UserGroupsReadOnly Property
ScrewTurn Wiki ► ScrewTurn.Wiki.PluginFramework ► IUsersStorageProviderV30 ► UserGroupsReadOnly
Gets a value indicating whether user groups are read-only. If so, the provider should support default user groups as defined in the wiki configuration.
Declaration Syntax
C# Visual Basic Visual C++
bool UserGroupsReadOnly { get; }
ReadOnly Property UserGroupsReadOnly As Boolean
property bool UserGroupsReadOnly {
    bool get ();
}

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.PluginFramework (Module: ScrewTurn.Wiki.PluginFramework) Version: 3.0.2.500 (3.0.2.500)


UsersDataReadOnly Property

UsersDataReadOnly Property
ScrewTurn Wiki ► ScrewTurn.Wiki.PluginFramework ► IUsersStorageProviderV30 ► UsersDataReadOnly
Gets a value indicating whether users' data is read-only.
Declaration Syntax
C# Visual Basic Visual C++
bool UsersDataReadOnly { get; }
ReadOnly Property UsersDataReadOnly As Boolean
property bool UsersDataReadOnly {
    bool get ();
}

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.PluginFramework (Module: ScrewTurn.Wiki.PluginFramework) Version: 3.0.2.500 (3.0.2.500)


LogEntry Class

LogEntry Class
ScrewTurn Wiki ► ScrewTurn.Wiki.PluginFramework ► LogEntry
Represents a Log Entry.
Declaration Syntax
C# Visual Basic Visual C++
public class LogEntry
Public Class LogEntry
public ref class LogEntry
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | LogEntry(EntryType, DateTime, String, String) | Initializes a new instance of the LogEntry class.
 | DateTime | Gets the DateTime.
 | EntryType | Gets the EntryType.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Message | Gets the Message.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | User | Gets the User.
Inheritance Hierarchy
Object
LogEntry

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.PluginFramework (Module: ScrewTurn.Wiki.PluginFramework) Version: 3.0.2.500 (3.0.2.500)


LogEntry Constructor (type, dateTime, message, user)

LogEntry Constructor (type, dateTime, message, user)
ScrewTurn Wiki ► ScrewTurn.Wiki.PluginFramework ► LogEntry ► LogEntry(EntryType, DateTime, String, String)
Initializes a new instance of the LogEntry class.
Declaration Syntax
C# Visual Basic Visual C++
public LogEntry(
    EntryType type,
    DateTime dateTime,
    string message,
    string user
)
Public Sub New ( _
    type As EntryType, _
    dateTime As DateTime, _
    message As String, _
    user As String _
)
public:
LogEntry(
    EntryType type,
    DateTime dateTime,
    String^ message,
    String^ user
)
Parameters
type (EntryType)
The type of the Entry
dateTime (DateTime)
The DateTime.
message (String)
The Message.
user (String)
The User.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.PluginFramework (Module: ScrewTurn.Wiki.PluginFramework) Version: 3.0.2.500 (3.0.2.500)


DateTime Property

DateTime Property
ScrewTurn Wiki ► ScrewTurn.Wiki.PluginFramework ► LogEntry ► DateTime
Gets the DateTime.
Declaration Syntax
C# Visual Basic Visual C++
public DateTime DateTime { get; }
Public ReadOnly Property DateTime As DateTime
public:
property DateTime DateTime {
    DateTime get ();
}

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.PluginFramework (Module: ScrewTurn.Wiki.PluginFramework) Version: 3.0.2.500 (3.0.2.500)


EntryType Property

EntryType Property
ScrewTurn Wiki ► ScrewTurn.Wiki.PluginFramework ► LogEntry ► EntryType
Gets the EntryType.
Declaration Syntax
C# Visual Basic Visual C++
public EntryType EntryType { get; }
Public ReadOnly Property EntryType As EntryType
public:
property EntryType EntryType {
    EntryType get ();
}

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.PluginFramework (Module: ScrewTurn.Wiki.PluginFramework) Version: 3.0.2.500 (3.0.2.500)


Message Property

Message Property
ScrewTurn Wiki ► ScrewTurn.Wiki.PluginFramework ► LogEntry ► Message
Gets the Message.
Declaration Syntax
C# Visual Basic Visual C++
public string Message { get; }
Public ReadOnly Property Message As String
public:
property String^ Message {
    String^ get ();
}

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.PluginFramework (Module: ScrewTurn.Wiki.PluginFramework) Version: 3.0.2.500 (3.0.2.500)


User Property

User Property
ScrewTurn Wiki ► ScrewTurn.Wiki.PluginFramework ► LogEntry ► User
Gets the User.
Declaration Syntax
C# Visual Basic Visual C++
public string User { get; }
Public ReadOnly Property User As String
public:
property String^ User {
    String^ get ();
}

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.PluginFramework (Module: ScrewTurn.Wiki.PluginFramework) Version: 3.0.2.500 (3.0.2.500)


LogEntryType Enumeration

LogEntryType Enumeration
ScrewTurn Wiki ► ScrewTurn.Wiki.PluginFramework ► LogEntryType
Enumerates the Types of Log Entries.
Declaration Syntax
C# Visual Basic Visual C++
public enum LogEntryType
Public Enumeration LogEntryType
public enum class LogEntryType
Members
Member | Description
General | Represents a simple Message.
Warning | Represents a Warning.
Error | Represents an Error.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.PluginFramework (Module: ScrewTurn.Wiki.PluginFramework) Version: 3.0.2.500 (3.0.2.500)


LoggingLevel Enumeration

LoggingLevel Enumeration
ScrewTurn Wiki ► ScrewTurn.Wiki.PluginFramework ► LoggingLevel
Lists legal logging level values.
Declaration Syntax
C# Visual Basic Visual C++
public enum LoggingLevel
Public Enumeration LoggingLevel
public enum class LoggingLevel
Members
Member | Description
AllMessages | All messages are logged.
WarningsAndErrors | Warnings and errors are logged.
ErrorsOnly | Errors only are logged.
DisableLog | Logging is completely disabled.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.PluginFramework (Module: ScrewTurn.Wiki.PluginFramework) Version: 3.0.2.500 (3.0.2.500)


Message Class

Message Class
ScrewTurn Wiki ► ScrewTurn.Wiki.PluginFramework ► Message
Represents a Page Discussion Message.
Declaration Syntax
C# Visual Basic Visual C++
public class Message
Public Class Message
public ref class Message
Members
All Members | Constructors | Methods | Properties | Fields
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | Message(Int32, String, String, DateTime, String) | Initializes a new instance of the Message class.
 | body | The Body.
 | Body | Gets or sets the Body.
 | dateTime | The Date/Time.
 | DateTime | Gets or sets the Date/Time.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | id | The Message ID.
 | ID | Gets or sets the Message ID.
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | replies | The Replies.
 | Replies | Gets or sets the Replies.
 | subject | The Subject.
 | Subject | Gets or sets the Subject.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | username | The Username.
 | Username | Gets or sets the Username.
Inheritance Hierarchy
Object
Message

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.PluginFramework (Module: ScrewTurn.Wiki.PluginFramework) Version: 3.0.2.500 (3.0.2.500)


Message Constructor (id, username, subject, dateTime, body)

Message Constructor (id, username, subject, dateTime, body)
ScrewTurn Wiki ► ScrewTurn.Wiki.PluginFramework ► Message ► Message(Int32, String, String, DateTime, String)
Initializes a new instance of the Message class.
Declaration Syntax
C# Visual Basic Visual C++
public Message(
    int id,
    string username,
    string subject,
    DateTime dateTime,
    string body
)
Public Sub New ( _
    id As Integer, _
    username As String, _
    subject As String, _
    dateTime As DateTime, _
    body As String _
)
public:
Message(
    int id,
    String^ username,
    String^ subject,
    DateTime dateTime,
    String^ body
)
Parameters
id (Int32)
The ID of the Message.
username (String)
The Username of the User.
subject (String)
The Subject of the Message.
dateTime (DateTime)
The Date/Time of the Message.
body (String)
The body of the Message.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.PluginFramework (Module: ScrewTurn.Wiki.PluginFramework) Version: 3.0.2.500 (3.0.2.500)


body Field

body Field
ScrewTurn Wiki ► ScrewTurn.Wiki.PluginFramework ► Message ► body
The Body.
Declaration Syntax
C# Visual Basic Visual C++
protected string body
Protected body As String
protected:
String^ body

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.PluginFramework (Module: ScrewTurn.Wiki.PluginFramework) Version: 3.0.2.500 (3.0.2.500)


Body Property

Body Property
ScrewTurn Wiki ► ScrewTurn.Wiki.PluginFramework ► Message ► Body
Gets or sets the Body.
Declaration Syntax
C# Visual Basic Visual C++
public string Body { get; set; }
Public Property Body As String
public:
property String^ Body {
    String^ get ();
    void set (String^ value);
}

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.PluginFramework (Module: ScrewTurn.Wiki.PluginFramework) Version: 3.0.2.500 (3.0.2.500)


dateTime Field

dateTime Field
ScrewTurn Wiki ► ScrewTurn.Wiki.PluginFramework ► Message ► dateTime
The Date/Time.
Declaration Syntax
C# Visual Basic Visual C++
protected DateTime dateTime
Protected dateTime As DateTime
protected:
DateTime dateTime

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.PluginFramework (Module: ScrewTurn.Wiki.PluginFramework) Version: 3.0.2.500 (3.0.2.500)


DateTime Property

DateTime Property
ScrewTurn Wiki ► ScrewTurn.Wiki.PluginFramework ► Message ► DateTime
Gets or sets the Date/Time.
Declaration Syntax
C# Visual Basic Visual C++
public DateTime DateTime { get; set; }
Public Property DateTime As DateTime
public:
property DateTime DateTime {
    DateTime get ();
    void set (DateTime value);
}

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.PluginFramework (Module: ScrewTurn.Wiki.PluginFramework) Version: 3.0.2.500 (3.0.2.500)


id Field

id Field
ScrewTurn Wiki ► ScrewTurn.Wiki.PluginFramework ► Message ► id
The Message ID.
Declaration Syntax
C# Visual Basic Visual C++
protected int id
Protected id As Integer
protected:
int id

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.PluginFramework (Module: ScrewTurn.Wiki.PluginFramework) Version: 3.0.2.500 (3.0.2.500)


ID Property

ID Property
ScrewTurn Wiki ► ScrewTurn.Wiki.PluginFramework ► Message ► ID
Gets or sets the Message ID.
Declaration Syntax
C# Visual Basic Visual C++
public int ID { get; set; }
Public Property ID As Integer
public:
property int ID {
    int get ();
    void set (int value);
}

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.PluginFramework (Module: ScrewTurn.Wiki.PluginFramework) Version: 3.0.2.500 (3.0.2.500)


replies Field

replies Field
ScrewTurn Wiki ► ScrewTurn.Wiki.PluginFramework ► Message ► replies
The Replies.
Declaration Syntax
C# Visual Basic Visual C++
protected Message[] replies
Protected replies As Message()
protected:
array<Message^>^ replies

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.PluginFramework (Module: ScrewTurn.Wiki.PluginFramework) Version: 3.0.2.500 (3.0.2.500)


Replies Property

Replies Property
ScrewTurn Wiki ► ScrewTurn.Wiki.PluginFramework ► Message ► Replies
Gets or sets the Replies.
Declaration Syntax
C# Visual Basic Visual C++
public Message[] Replies { get; set; }
Public Property Replies As Message()
public:
property array<Message^>^ Replies {
    array<Message^>^ get ();
    void set (array<Message^>^ value);
}

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.PluginFramework (Module: ScrewTurn.Wiki.PluginFramework) Version: 3.0.2.500 (3.0.2.500)


subject Field

subject Field
ScrewTurn Wiki ► ScrewTurn.Wiki.PluginFramework ► Message ► subject
The Subject.
Declaration Syntax
C# Visual Basic Visual C++
protected string subject
Protected subject As String
protected:
String^ subject

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.PluginFramework (Module: ScrewTurn.Wiki.PluginFramework) Version: 3.0.2.500 (3.0.2.500)


Subject Property

Subject Property
ScrewTurn Wiki ► ScrewTurn.Wiki.PluginFramework ► Message ► Subject
Gets or sets the Subject.
Declaration Syntax
C# Visual Basic Visual C++
public string Subject { get; set; }
Public Property Subject As String
public:
property String^ Subject {
    String^ get ();
    void set (String^ value);
}

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.PluginFramework (Module: ScrewTurn.Wiki.PluginFramework) Version: 3.0.2.500 (3.0.2.500)


username Field

username Field
ScrewTurn Wiki ► ScrewTurn.Wiki.PluginFramework ► Message ► username
The Username.
Declaration Syntax
C# Visual Basic Visual C++
protected string username
Protected username As String
protected:
String^ username

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.PluginFramework (Module: ScrewTurn.Wiki.PluginFramework) Version: 3.0.2.500 (3.0.2.500)


Username Property

Username Property
ScrewTurn Wiki ► ScrewTurn.Wiki.PluginFramework ► Message ► Username
Gets or sets the Username.
Declaration Syntax
C# Visual Basic Visual C++
public string Username { get; set; }
Public Property Username As String
public:
property String^ Username {
    String^ get ();
    void set (String^ value);
}

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.PluginFramework (Module: ScrewTurn.Wiki.PluginFramework) Version: 3.0.2.500 (3.0.2.500)


MessageDateTimeComparer Class

MessageDateTimeComparer Class
ScrewTurn Wiki ► ScrewTurn.Wiki.PluginFramework ► MessageDateTimeComparer
Compares two Message object using their Date/Time as parameter.
Declaration Syntax
C# Visual Basic Visual C++
public class MessageDateTimeComparer : IComparer<Message>
Public Class MessageDateTimeComparer _
    Implements IComparer(Of Message)
public ref class MessageDateTimeComparer : IComparer<Message^>
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | MessageDateTimeComparer(Boolean) | Initializes a new instance of the MessageDateTimeComparer class.
 | Compare(Message, Message) | Compares two Message objects.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
MessageDateTimeComparer

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.PluginFramework (Module: ScrewTurn.Wiki.PluginFramework) Version: 3.0.2.500 (3.0.2.500)


MessageDateTimeComparer Constructor (reverse)

MessageDateTimeComparer Constructor (reverse)
ScrewTurn Wiki ► ScrewTurn.Wiki.PluginFramework ► MessageDateTimeComparer ► MessageDateTimeComparer(Boolean)
Initializes a new instance of the MessageDateTimeComparer class.
Declaration Syntax
C# Visual Basic Visual C++
public MessageDateTimeComparer(
    bool reverse
)
Public Sub New ( _
    reverse As Boolean _
)
public:
MessageDateTimeComparer(
    bool reverse
)
Parameters
reverse (Boolean)
True to compare in reverse order (bigger to smaller).

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.PluginFramework (Module: ScrewTurn.Wiki.PluginFramework) Version: 3.0.2.500 (3.0.2.500)


Compare Method (x, y)

Compare Method (x, y)
ScrewTurn Wiki ► ScrewTurn.Wiki.PluginFramework ► MessageDateTimeComparer ► Compare(Message, Message)
Compares two Message objects.
Declaration Syntax
C# Visual Basic Visual C++
public int Compare(
    Message x,
    Message y
)
Public Function Compare ( _
    x As Message, _
    y As Message _
) As Integer
public:
virtual int Compare(
    Message^ x,
    Message^ y
) sealed
Parameters
x (Message)
The first object.
y (Message)
The second object.
Return Value
The result of the comparison (1, 0 or -1).

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.PluginFramework (Module: ScrewTurn.Wiki.PluginFramework) Version: 3.0.2.500 (3.0.2.500)


MessageDocument Class

MessageDocument Class
ScrewTurn Wiki ► ScrewTurn.Wiki.PluginFramework ► MessageDocument
Represents a message for use with the search engine.
Declaration Syntax
C# Visual Basic Visual C++
public class MessageDocument : IDocument
Public Class MessageDocument _
    Implements IDocument
public ref class MessageDocument : IDocument
Members
All Members | Constructors | Methods | Properties | Fields
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | MessageDocument(PageInfo, Int32, DumpedDocument, Tokenizer) | Initializes a new instance of the MessageDocument class.
 | DateTime | Gets the document date/time.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetDocumentName(PageInfo, Int32) | Gets the document name for a message.
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetMessageDetails(String, String%, Int32%) | Gets the page name and message ID from a document name.
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | ID | Gets or sets the globally unique ID of the document.
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | MessageID | Gets the message ID.
 | Name | Gets the globally-unique name of the document.
 | PageInfo | Gets the page information.
 | StandardTypeTag | The type tag for a MessageDocument.
 | Title | Gets the title of the document, if any.
 | Tokenize(String) | Performs the tokenization of the document content.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | TypeTag | Gets the tag for the document type.
Inheritance Hierarchy
Object
MessageDocument

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.PluginFramework (Module: ScrewTurn.Wiki.PluginFramework) Version: 3.0.2.500 (3.0.2.500)


MessageDocument Constructor (pageInfo, messageID, dumpedDocument, tokenizer)

MessageDocument Constructor (pageInfo, messageID, dumpedDocument, tokenizer)
ScrewTurn Wiki ► ScrewTurn.Wiki.PluginFramework ► MessageDocument ► MessageDocument(PageInfo, Int32, DumpedDocument, Tokenizer)
Initializes a new instance of the MessageDocument class.
Declaration Syntax
C# Visual Basic Visual C++
public MessageDocument(
    PageInfo pageInfo,
    int messageID,
    DumpedDocument dumpedDocument,
    Tokenizer tokenizer
)
Public Sub New ( _
    pageInfo As PageInfo, _
    messageID As Integer, _
    dumpedDocument As DumpedDocument, _
    tokenizer As Tokenizer _
)
public:
MessageDocument(
    PageInfo^ pageInfo,
    int messageID,
    DumpedDocument^ dumpedDocument,
    Tokenizer^ tokenizer
)
Parameters
pageInfo (PageInfo)
The page.
messageID (Int32)
The message ID.
dumpedDocument (DumpedDocument)
The dumped document data.
tokenizer (Tokenizer)
The tokenizer.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.PluginFramework (Module: ScrewTurn.Wiki.PluginFramework) Version: 3.0.2.500 (3.0.2.500)


DateTime Property

DateTime Property
ScrewTurn Wiki ► ScrewTurn.Wiki.PluginFramework ► MessageDocument ► DateTime
Gets the document date/time.
Declaration Syntax
C# Visual Basic Visual C++
public DateTime DateTime { get; }
Public ReadOnly Property DateTime As DateTime
public:
virtual property DateTime DateTime {
    DateTime get () sealed;
}

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.PluginFramework (Module: ScrewTurn.Wiki.PluginFramework) Version: 3.0.2.500 (3.0.2.500)


GetDocumentName Method (page, messageID)

GetDocumentName Method (page, messageID)
ScrewTurn Wiki ► ScrewTurn.Wiki.PluginFramework ► MessageDocument ► GetDocumentName(PageInfo, Int32)
Gets the document name for a message.
Declaration Syntax
C# Visual Basic Visual C++
public static string GetDocumentName(
    PageInfo page,
    int messageID
)
Public Shared Function GetDocumentName ( _
    page As PageInfo, _
    messageID As Integer _
) As String
public:
static String^ GetDocumentName(
    PageInfo^ page,
    int messageID
)
Parameters
page (PageInfo)
The page.
messageID (Int32)
The message ID.
Return Value
The document name.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.PluginFramework (Module: ScrewTurn.Wiki.PluginFramework) Version: 3.0.2.500 (3.0.2.500)


GetMessageDetails Method (documentName, pageName, messageID)

GetMessageDetails Method (documentName, pageName, messageID)
ScrewTurn Wiki ► ScrewTurn.Wiki.PluginFramework ► MessageDocument ► GetMessageDetails(String, String%, Int32%)
Gets the page name and message ID from a document name.
Declaration Syntax
C# Visual Basic Visual C++
public static void GetMessageDetails(
    string documentName,
    out string pageName,
    out int messageID
)
Public Shared Sub GetMessageDetails ( _
    documentName As String, _
    <OutAttribute> ByRef pageName As String, _
    <OutAttribute> ByRef messageID As Integer _
)
public:
static void GetMessageDetails(
    String^ documentName,
    [OutAttribute] String^% pageName,
    [OutAttribute] int% messageID
)
Parameters
documentName (String)
The document name.
pageName ( String %)
The page name.
messageID ( Int32 %)
The message ID.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.PluginFramework (Module: ScrewTurn.Wiki.PluginFramework) Version: 3.0.2.500 (3.0.2.500)


ID Property

ID Property
ScrewTurn Wiki ► ScrewTurn.Wiki.PluginFramework ► MessageDocument ► ID
Gets or sets the globally unique ID of the document.
Declaration Syntax
C# Visual Basic Visual C++
public uint ID { get; set; }
Public Property ID As UInteger
public:
virtual property unsigned int ID {
    unsigned int get () sealed;
    void set (unsigned int value) sealed;
}

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.PluginFramework (Module: ScrewTurn.Wiki.PluginFramework) Version: 3.0.2.500 (3.0.2.500)


MessageID Property

MessageID Property
ScrewTurn Wiki ► ScrewTurn.Wiki.PluginFramework ► MessageDocument ► MessageID
Gets the message ID.
Declaration Syntax
C# Visual Basic Visual C++
public int MessageID { get; }
Public ReadOnly Property MessageID As Integer
public:
property int MessageID {
    int get ();
}

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.PluginFramework (Module: ScrewTurn.Wiki.PluginFramework) Version: 3.0.2.500 (3.0.2.500)


Name Property

Name Property
ScrewTurn Wiki ► ScrewTurn.Wiki.PluginFramework ► MessageDocument ► Name
Gets the globally-unique name of the document.
Declaration Syntax
C# Visual Basic Visual C++
public string Name { get; }
Public ReadOnly Property Name As String
public:
virtual property String^ Name {
    String^ get () sealed;
}

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.PluginFramework (Module: ScrewTurn.Wiki.PluginFramework) Version: 3.0.2.500 (3.0.2.500)


PageInfo Property

PageInfo Property
ScrewTurn Wiki ► ScrewTurn.Wiki.PluginFramework ► MessageDocument ► PageInfo
Gets the page information.
Declaration Syntax
C# Visual Basic Visual C++
public PageInfo PageInfo { get; }
Public ReadOnly Property PageInfo As PageInfo
public:
property PageInfo^ PageInfo {
    PageInfo^ get ();
}

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.PluginFramework (Module: ScrewTurn.Wiki.PluginFramework) Version: 3.0.2.500 (3.0.2.500)


StandardTypeTag Field

StandardTypeTag Field
ScrewTurn Wiki ► ScrewTurn.Wiki.PluginFramework ► MessageDocument ► StandardTypeTag
The type tag for a MessageDocument.
Declaration Syntax
C# Visual Basic Visual C++
public const string StandardTypeTag
Public Const StandardTypeTag As String
public:
literal String^ StandardTypeTag

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.PluginFramework (Module: ScrewTurn.Wiki.PluginFramework) Version: 3.0.2.500 (3.0.2.500)


Title Property

Title Property
ScrewTurn Wiki ► ScrewTurn.Wiki.PluginFramework ► MessageDocument ► Title
Gets the title of the document, if any.
Declaration Syntax
C# Visual Basic Visual C++
public string Title { get; }
Public ReadOnly Property Title As String
public:
virtual property String^ Title {
    String^ get () sealed;
}

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.PluginFramework (Module: ScrewTurn.Wiki.PluginFramework) Version: 3.0.2.500 (3.0.2.500)


Tokenize Method (content)

Tokenize Method (content)
ScrewTurn Wiki ► ScrewTurn.Wiki.PluginFramework ► MessageDocument ► Tokenize(String)
Performs the tokenization of the document content.
Declaration Syntax
C# Visual Basic Visual C++
public WordInfo[] Tokenize(
    string content
)
Public Function Tokenize ( _
    content As String _
) As WordInfo()
public:
virtual array<WordInfo^>^ Tokenize(
    String^ content
) sealed
Parameters
content (String)
The content to tokenize.
Return Value
The extracted words and their positions.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.PluginFramework (Module: ScrewTurn.Wiki.PluginFramework) Version: 3.0.2.500 (3.0.2.500)


TypeTag Property

TypeTag Property
ScrewTurn Wiki ► ScrewTurn.Wiki.PluginFramework ► MessageDocument ► TypeTag
Gets the tag for the document type.
Declaration Syntax
C# Visual Basic Visual C++
public string TypeTag { get; }
Public ReadOnly Property TypeTag As String
public:
virtual property String^ TypeTag {
    String^ get () sealed;
}

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.PluginFramework (Module: ScrewTurn.Wiki.PluginFramework) Version: 3.0.2.500 (3.0.2.500)


MetaDataItem Enumeration

MetaDataItem Enumeration
ScrewTurn Wiki ► ScrewTurn.Wiki.PluginFramework ► MetaDataItem
Lists legal meta-data items (global items have a integer value greater than or equal to 100.
Declaration Syntax
C# Visual Basic Visual C++
public enum MetaDataItem
Public Enumeration MetaDataItem
public enum class MetaDataItem
Members
Member | Description
AccountActivationMessage | The account activation message which is sent to the newly registered users.
PasswordResetProcedureMessage | The password reset message which is sent to the users who reset their password.
LoginNotice | The notice that appears and replaces the text in the Login page.
AccessDeniedNotice | The notice that appears and replaces the text in the Access Denied page.
PageChangeMessage | The message that is sent when a page is modified.
DiscussionChangeMessage | The message that is sent when a new message is posted on a discussion.
ApproveDraftMessage | The message sent when a page draft requires approval.
RegisterNotice | The notice that appears and replates the text in the Register page.
EditNotice | The notice that appears in the editing page.
Footer | The wiki footer.
Header | The wiki header.
HtmlHead | The custom content of the HTML Head tag.
PageFooter | The pages footer.
PageHeader | The pages header.
Sidebar | The content of the sidebar.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.PluginFramework (Module: ScrewTurn.Wiki.PluginFramework) Version: 3.0.2.500 (3.0.2.500)


NamespaceActivity Enumeration

NamespaceActivity Enumeration
ScrewTurn Wiki ► ScrewTurn.Wiki.PluginFramework ► NamespaceActivity
Lists legal namespace activity types.
Declaration Syntax
C# Visual Basic Visual C++
public enum NamespaceActivity
Public Enumeration NamespaceActivity
public enum class NamespaceActivity
Members
Member | Description
NamespaceAdded | A namespace has been added.
NamespaceRenamed | A namespace has been renamed.
NamespaceModified | A namespace has been modified.
NamespaceRemoved | A namespace has been removed.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.PluginFramework (Module: ScrewTurn.Wiki.PluginFramework) Version: 3.0.2.500 (3.0.2.500)


NamespaceActivityEventArgs Class

NamespaceActivityEventArgs Class
ScrewTurn Wiki ► ScrewTurn.Wiki.PluginFramework ► NamespaceActivityEventArgs
Contains arguments for Namespace activity events.
Declaration Syntax
C# Visual Basic Visual C++
public class NamespaceActivityEventArgs : EventArgs
Public Class NamespaceActivityEventArgs _
    Inherits EventArgs
public ref class NamespaceActivityEventArgs : public EventArgs
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | NamespaceActivityEventArgs(NamespaceInfo, String, NamespaceActivity) | Initializes a new instance of the NamespaceActivityEventArgs class.
 | Activity | Gets the activity.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | NamespaceInfo | Gets the namespace the activity refers to.
 | NamespaceOldName | Gets the old name of the renamed namespace, or null.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | EventArgs
 |  | NamespaceActivityEventArgs

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.PluginFramework (Module: ScrewTurn.Wiki.PluginFramework) Version: 3.0.2.500 (3.0.2.500)


NamespaceActivityEventArgs Constructor (nspace, nspaceOldName, activity)

NamespaceActivityEventArgs Constructor (nspace, nspaceOldName, activity)
ScrewTurn Wiki ► ScrewTurn.Wiki.PluginFramework ► NamespaceActivityEventArgs ► NamespaceActivityEventArgs(NamespaceInfo, String, NamespaceActivity)
Initializes a new instance of the NamespaceActivityEventArgs class.
Declaration Syntax
C# Visual Basic Visual C++
public NamespaceActivityEventArgs(
    NamespaceInfo nspace,
    string nspaceOldName,
    NamespaceActivity activity
)
Public Sub New ( _
    nspace As NamespaceInfo, _
    nspaceOldName As String, _
    activity As NamespaceActivity _
)
public:
NamespaceActivityEventArgs(
    NamespaceInfo^ nspace,
    String^ nspaceOldName,
    NamespaceActivity activity
)
Parameters
nspace (NamespaceInfo)
The namespace the activity refers to.
nspaceOldName (String)
The old name of the renamed namespace, or null.
activity (NamespaceActivity)
The activity.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.PluginFramework (Module: ScrewTurn.Wiki.PluginFramework) Version: 3.0.2.500 (3.0.2.500)


Activity Property

Activity Property
ScrewTurn Wiki ► ScrewTurn.Wiki.PluginFramework ► NamespaceActivityEventArgs ► Activity
Gets the activity.
Declaration Syntax
C# Visual Basic Visual C++
public NamespaceActivity Activity { get; }
Public ReadOnly Property Activity As NamespaceActivity
public:
property NamespaceActivity Activity {
    NamespaceActivity get ();
}

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.PluginFramework (Module: ScrewTurn.Wiki.PluginFramework) Version: 3.0.2.500 (3.0.2.500)


NamespaceInfo Property

NamespaceInfo Property
ScrewTurn Wiki ► ScrewTurn.Wiki.PluginFramework ► NamespaceActivityEventArgs ► NamespaceInfo
Gets the namespace the activity refers to.
Declaration Syntax
C# Visual Basic Visual C++
public NamespaceInfo NamespaceInfo { get; }
Public ReadOnly Property NamespaceInfo As NamespaceInfo
public:
property NamespaceInfo^ NamespaceInfo {
    NamespaceInfo^ get ();
}

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.PluginFramework (Module: ScrewTurn.Wiki.PluginFramework) Version: 3.0.2.500 (3.0.2.500)


NamespaceOldName Property

NamespaceOldName Property
ScrewTurn Wiki ► ScrewTurn.Wiki.PluginFramework ► NamespaceActivityEventArgs ► NamespaceOldName
Gets the old name of the renamed namespace, or null.
Declaration Syntax
C# Visual Basic Visual C++
public string NamespaceOldName { get; }
Public ReadOnly Property NamespaceOldName As String
public:
property String^ NamespaceOldName {
    String^ get ();
}

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.PluginFramework (Module: ScrewTurn.Wiki.PluginFramework) Version: 3.0.2.500 (3.0.2.500)


NamespaceComparer Class

NamespaceComparer Class
ScrewTurn Wiki ► ScrewTurn.Wiki.PluginFramework ► NamespaceComparer
Compares two NamespaceInfo objects, using the Name as parameter.
Declaration Syntax
C# Visual Basic Visual C++
public class NamespaceComparer : IComparer<NamespaceInfo>
Public Class NamespaceComparer _
    Implements IComparer(Of NamespaceInfo)
public ref class NamespaceComparer : IComparer<NamespaceInfo^>
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | NamespaceComparer()()() | Initializes a new instance of the NamespaceComparer class
 | Compare(NamespaceInfo, NamespaceInfo) | Compares two NamespaceInfo objects, using the Name as parameter.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
NamespaceComparer

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.PluginFramework (Module: ScrewTurn.Wiki.PluginFramework) Version: 3.0.2.500 (3.0.2.500)


NamespaceComparer Constructor

NamespaceComparer Constructor
ScrewTurn Wiki ► ScrewTurn.Wiki.PluginFramework ► NamespaceComparer ► NamespaceComparer()()()
Initializes a new instance of the NamespaceComparer class
Declaration Syntax
C# Visual Basic Visual C++
public NamespaceComparer()
Public Sub New
public:
NamespaceComparer()

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.PluginFramework (Module: ScrewTurn.Wiki.PluginFramework) Version: 3.0.2.500 (3.0.2.500)


Compare Method (x, y)

Compare Method (x, y)
ScrewTurn Wiki ► ScrewTurn.Wiki.PluginFramework ► NamespaceComparer ► Compare(NamespaceInfo, NamespaceInfo)
Compares two NamespaceInfo objects, using the Name as parameter.
Declaration Syntax
C# Visual Basic Visual C++
public int Compare(
    NamespaceInfo x,
    NamespaceInfo y
)
Public Function Compare ( _
    x As NamespaceInfo, _
    y As NamespaceInfo _
) As Integer
public:
virtual int Compare(
    NamespaceInfo^ x,
    NamespaceInfo^ y
) sealed
Parameters
x (NamespaceInfo)
The first object.
y (NamespaceInfo)
The second object.
Return Value
The comparison result (-1, 0 or 1).

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.PluginFramework (Module: ScrewTurn.Wiki.PluginFramework) Version: 3.0.2.500 (3.0.2.500)


NamespaceInfo Class

NamespaceInfo Class
ScrewTurn Wiki ► ScrewTurn.Wiki.PluginFramework ► NamespaceInfo
Represents a namespace.
Declaration Syntax
C# Visual Basic Visual C++
public class NamespaceInfo
Public Class NamespaceInfo
public ref class NamespaceInfo
Members
All Members | Constructors | Methods | Properties | Fields
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | NamespaceInfo(String, IPagesStorageProviderV30, PageInfo) | Initializes a new instance of the NamespaceInfo class.
 | defaultPage | The default page of the namespace (can be null).
 | DefaultPage | Gets or sets the default page, or null.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | name | The name of the namespace.
 | Name | Gets or sets the name of the namespace.
 | provider | The provider of the namespace.
 | Provider | Gets or sets the provider.
 | ToString()()() | Gets a string representation of the current object. (Overrides Object.ToString()()().)
Inheritance Hierarchy
Object
NamespaceInfo

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.PluginFramework (Module: ScrewTurn.Wiki.PluginFramework) Version: 3.0.2.500 (3.0.2.500)


NamespaceInfo Constructor (name, provider, defaultPage)

NamespaceInfo Constructor (name, provider, defaultPage)
ScrewTurn Wiki ► ScrewTurn.Wiki.PluginFramework ► NamespaceInfo ► NamespaceInfo(String, IPagesStorageProviderV30, PageInfo)
Initializes a new instance of the NamespaceInfo class.
Declaration Syntax
C# Visual Basic Visual C++
public NamespaceInfo(
    string name,
    IPagesStorageProviderV30 provider,
    PageInfo defaultPage
)
Public Sub New ( _
    name As String, _
    provider As IPagesStorageProviderV30, _
    defaultPage As PageInfo _
)
public:
NamespaceInfo(
    String^ name,
    IPagesStorageProviderV30^ provider,
    PageInfo^ defaultPage
)
Parameters
name (String)
The namespace name.
provider (IPagesStorageProviderV30)
The provider.
defaultPage (PageInfo)
The default page, or null.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.PluginFramework (Module: ScrewTurn.Wiki.PluginFramework) Version: 3.0.2.500 (3.0.2.500)


defaultPage Field

defaultPage Field
ScrewTurn Wiki ► ScrewTurn.Wiki.PluginFramework ► NamespaceInfo ► defaultPage
The default page of the namespace (can be null).
Declaration Syntax
C# Visual Basic Visual C++
protected PageInfo defaultPage
Protected defaultPage As PageInfo
protected:
PageInfo^ defaultPage

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.PluginFramework (Module: ScrewTurn.Wiki.PluginFramework) Version: 3.0.2.500 (3.0.2.500)


DefaultPage Property

DefaultPage Property
ScrewTurn Wiki ► ScrewTurn.Wiki.PluginFramework ► NamespaceInfo ► DefaultPage
Gets or sets the default page, or null.
Declaration Syntax
C# Visual Basic Visual C++
public PageInfo DefaultPage { get; set; }
Public Property DefaultPage As PageInfo
public:
property PageInfo^ DefaultPage {
    PageInfo^ get ();
    void set (PageInfo^ value);
}

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.PluginFramework (Module: ScrewTurn.Wiki.PluginFramework) Version: 3.0.2.500 (3.0.2.500)


name Field

name Field
ScrewTurn Wiki ► ScrewTurn.Wiki.PluginFramework ► NamespaceInfo ► name
The name of the namespace.
Declaration Syntax
C# Visual Basic Visual C++
protected string name
Protected name As String
protected:
String^ name

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.PluginFramework (Module: ScrewTurn.Wiki.PluginFramework) Version: 3.0.2.500 (3.0.2.500)


Name Property

Name Property
ScrewTurn Wiki ► ScrewTurn.Wiki.PluginFramework ► NamespaceInfo ► Name
Gets or sets the name of the namespace.
Declaration Syntax
C# Visual Basic Visual C++
public string Name { get; set; }
Public Property Name As String
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.PluginFramework (Module: ScrewTurn.Wiki.PluginFramework) Version: 3.0.2.500 (3.0.2.500)


provider Field

provider Field
ScrewTurn Wiki ► ScrewTurn.Wiki.PluginFramework ► NamespaceInfo ► provider
The provider of the namespace.
Declaration Syntax
C# Visual Basic Visual C++
protected IPagesStorageProviderV30 provider
Protected provider As IPagesStorageProviderV30
protected:
IPagesStorageProviderV30^ provider

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.PluginFramework (Module: ScrewTurn.Wiki.PluginFramework) Version: 3.0.2.500 (3.0.2.500)


Provider Property

Provider Property
ScrewTurn Wiki ► ScrewTurn.Wiki.PluginFramework ► NamespaceInfo ► Provider
Gets or sets the provider.
Declaration Syntax
C# Visual Basic Visual C++
public IPagesStorageProviderV30 Provider { get; set; }
Public Property Provider As IPagesStorageProviderV30
public:
property IPagesStorageProviderV30^ Provider {
    IPagesStorageProviderV30^ get ();
    void set (IPagesStorageProviderV30^ value);
}

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.PluginFramework (Module: ScrewTurn.Wiki.PluginFramework) Version: 3.0.2.500 (3.0.2.500)


ToString Method

ToString Method
ScrewTurn Wiki ► ScrewTurn.Wiki.PluginFramework ► NamespaceInfo ► ToString()()()
Gets a string representation of the current object.
Declaration Syntax
C# Visual Basic Visual C++
public override string ToString()
Public Overrides Function ToString As String
public:
virtual String^ ToString() override
Return Value
The string representation.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.PluginFramework (Module: ScrewTurn.Wiki.PluginFramework) Version: 3.0.2.500 (3.0.2.500)


NameTools Class

NameTools Class
ScrewTurn Wiki ► ScrewTurn.Wiki.PluginFramework ► NameTools
Implements useful tools for handling full object names.
Declaration Syntax
C# Visual Basic Visual C++
public static class NameTools
Public NotInheritable Class NameTools
public ref class NameTools abstract sealed
Members
All Members | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | ExpandFullName(String, String%, String%) | Expands a full name into the namespace and local name.
 | GetFullName(String, String) | Gets the full name of a page from the namespace and local name.
 | GetLocalName(String) | Extracts the local name from a full name.
 | GetNamespace(String) | Extracts the namespace from a full name.
Inheritance Hierarchy
Object
NameTools

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.PluginFramework (Module: ScrewTurn.Wiki.PluginFramework) Version: 3.0.2.500 (3.0.2.500)


ExpandFullName Method (fullName, nspace, name)

ExpandFullName Method (fullName, nspace, name)
ScrewTurn Wiki ► ScrewTurn.Wiki.PluginFramework ► NameTools ► ExpandFullName(String, String%, String%)
Expands a full name into the namespace and local name.
Declaration Syntax
C# Visual Basic Visual C++
public static void ExpandFullName(
    string fullName,
    out string nspace,
    out string name
)
Public Shared Sub ExpandFullName ( _
    fullName As String, _
    <OutAttribute> ByRef nspace As String, _
    <OutAttribute> ByRef name As String _
)
public:
static void ExpandFullName(
    String^ fullName,
    [OutAttribute] String^% nspace,
    [OutAttribute] String^% name
)
Parameters
fullName (String)
The full name to expand.
nspace ( String %)
The namespace.
name ( String %)
The local name.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.PluginFramework (Module: ScrewTurn.Wiki.PluginFramework) Version: 3.0.2.500 (3.0.2.500)


GetFullName Method (nspace, name)

GetFullName Method (nspace, name)
ScrewTurn Wiki ► ScrewTurn.Wiki.PluginFramework ► NameTools ► GetFullName(String, String)
Gets the full name of a page from the namespace and local name.
Declaration Syntax
C# Visual Basic Visual C++
public static string GetFullName(
    string nspace,
    string name
)
Public Shared Function GetFullName ( _
    nspace As String, _
    name As String _
) As String
public:
static String^ GetFullName(
    String^ nspace,
    String^ name
)
Parameters
nspace (String)
The namespace (null for the root).
name (String)
The local name.
Return Value
The full name.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.PluginFramework (Module: ScrewTurn.Wiki.PluginFramework) Version: 3.0.2.500 (3.0.2.500)


GetLocalName Method (fullName)

GetLocalName Method (fullName)
ScrewTurn Wiki ► ScrewTurn.Wiki.PluginFramework ► NameTools ► GetLocalName(String)
Extracts the local name from a full name.
Declaration Syntax
C# Visual Basic Visual C++
public static string GetLocalName(
    string fullName
)
Public Shared Function GetLocalName ( _
    fullName As String _
) As String
public:
static String^ GetLocalName(
    String^ fullName
)
Parameters
fullName (String)
The full name.
Return Value
The local name.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.PluginFramework (Module: ScrewTurn.Wiki.PluginFramework) Version: 3.0.2.500 (3.0.2.500)


GetNamespace Method (fullName)

GetNamespace Method (fullName)
ScrewTurn Wiki ► ScrewTurn.Wiki.PluginFramework ► NameTools ► GetNamespace(String)
Extracts the namespace from a full name.
Declaration Syntax
C# Visual Basic Visual C++
public static string GetNamespace(
    string fullName
)
Public Shared Function GetNamespace ( _
    fullName As String _
) As String
public:
static String^ GetNamespace(
    String^ fullName
)
Parameters
fullName (String)
The full name.
Return Value
The namespace, or null.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.PluginFramework (Module: ScrewTurn.Wiki.PluginFramework) Version: 3.0.2.500 (3.0.2.500)


NavigationPath Class

NavigationPath Class
ScrewTurn Wiki ► ScrewTurn.Wiki.PluginFramework ► NavigationPath
Represents a Navigation Path.
Declaration Syntax
C# Visual Basic Visual C++
public class NavigationPath
Public Class NavigationPath
public ref class NavigationPath
Members
All Members | Constructors | Methods | Properties | Fields
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | NavigationPath(String, IPagesStorageProviderV30) | Initializes a new instance of the NavigationPath class.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | FullName | Gets or sets the full name of the Navigation Path, such as 'Namespace.Path' or 'Path'.
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | name | The Name of the Navigation Path.
 | nspace | The namespace of the Navigation Path (null for the root).
 | pages | The names of the Pages in the Navigation Path.
 | Pages | Gets or sets the Pages of the Path.
 | provider | The Provider that handles the Navigation Path.
 | Provider | Gets the Provider.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
NavigationPath

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.PluginFramework (Module: ScrewTurn.Wiki.PluginFramework) Version: 3.0.2.500 (3.0.2.500)


NavigationPath Constructor (fullName, provider)

NavigationPath Constructor (fullName, provider)
ScrewTurn Wiki ► ScrewTurn.Wiki.PluginFramework ► NavigationPath ► NavigationPath(String, IPagesStorageProviderV30)
Initializes a new instance of the NavigationPath class.
Declaration Syntax
C# Visual Basic Visual C++
public NavigationPath(
    string fullName,
    IPagesStorageProviderV30 provider
)
Public Sub New ( _
    fullName As String, _
    provider As IPagesStorageProviderV30 _
)
public:
NavigationPath(
    String^ fullName,
    IPagesStorageProviderV30^ provider
)
Parameters
fullName (String)
The Full Name of the Navigation Path.
provider (IPagesStorageProviderV30)
The Provider

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.PluginFramework (Module: ScrewTurn.Wiki.PluginFramework) Version: 3.0.2.500 (3.0.2.500)


FullName Property

FullName Property
ScrewTurn Wiki ► ScrewTurn.Wiki.PluginFramework ► NavigationPath ► FullName
Gets or sets the full name of the Navigation Path, such as 'Namespace.Path' or 'Path'.
Declaration Syntax
C# Visual Basic Visual C++
public string FullName { get; set; }
Public Property FullName As String
public:
property String^ FullName {
    String^ get ();
    void set (String^ value);
}

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.PluginFramework (Module: ScrewTurn.Wiki.PluginFramework) Version: 3.0.2.500 (3.0.2.500)


name Field

name Field
ScrewTurn Wiki ► ScrewTurn.Wiki.PluginFramework ► NavigationPath ► name
The Name of the Navigation Path.
Declaration Syntax
C# Visual Basic Visual C++
protected string name
Protected name As String
protected:
String^ name

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.PluginFramework (Module: ScrewTurn.Wiki.PluginFramework) Version: 3.0.2.500 (3.0.2.500)


nspace Field

nspace Field
ScrewTurn Wiki ► ScrewTurn.Wiki.PluginFramework ► NavigationPath ► nspace
The namespace of the Navigation Path (null for the root).
Declaration Syntax
C# Visual Basic Visual C++
protected string nspace
Protected nspace As String
protected:
String^ nspace

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.PluginFramework (Module: ScrewTurn.Wiki.PluginFramework) Version: 3.0.2.500 (3.0.2.500)


pages Field

pages Field
ScrewTurn Wiki ► ScrewTurn.Wiki.PluginFramework ► NavigationPath ► pages
The names of the Pages in the Navigation Path.
Declaration Syntax
C# Visual Basic Visual C++
protected string[] pages
Protected pages As String()
protected:
array<String^>^ pages

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.PluginFramework (Module: ScrewTurn.Wiki.PluginFramework) Version: 3.0.2.500 (3.0.2.500)


Pages Property

Pages Property
ScrewTurn Wiki ► ScrewTurn.Wiki.PluginFramework ► NavigationPath ► Pages
Gets or sets the Pages of the Path.
Declaration Syntax
C# Visual Basic Visual C++
public string[] Pages { get; set; }
Public Property Pages As String()
public:
property array<String^>^ Pages {
    array<String^>^ get ();
    void set (array<String^>^ value);
}

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.PluginFramework (Module: ScrewTurn.Wiki.PluginFramework) Version: 3.0.2.500 (3.0.2.500)


provider Field

provider Field
ScrewTurn Wiki ► ScrewTurn.Wiki.PluginFramework ► NavigationPath ► provider
The Provider that handles the Navigation Path.
Declaration Syntax
C# Visual Basic Visual C++
protected IPagesStorageProviderV30 provider
Protected provider As IPagesStorageProviderV30
protected:
IPagesStorageProviderV30^ provider

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.PluginFramework (Module: ScrewTurn.Wiki.PluginFramework) Version: 3.0.2.500 (3.0.2.500)


Provider Property

Provider Property
ScrewTurn Wiki ► ScrewTurn.Wiki.PluginFramework ► NavigationPath ► Provider
Gets the Provider.
Declaration Syntax
C# Visual Basic Visual C++
public IPagesStorageProviderV30 Provider { get; }
Public ReadOnly Property Provider As IPagesStorageProviderV30
public:
property IPagesStorageProviderV30^ Provider {
    IPagesStorageProviderV30^ get ();
}

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.PluginFramework (Module: ScrewTurn.Wiki.PluginFramework) Version: 3.0.2.500 (3.0.2.500)


NavigationPathComparer Class

NavigationPathComparer Class
ScrewTurn Wiki ► ScrewTurn.Wiki.PluginFramework ► NavigationPathComparer
Compares two NavigationPaths objects, using FullName as the comparison parameter.
Declaration Syntax
C# Visual Basic Visual C++
public class NavigationPathComparer : IComparer<NavigationPath>
Public Class NavigationPathComparer _
    Implements IComparer(Of NavigationPath)
public ref class NavigationPathComparer : IComparer<NavigationPath^>
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | NavigationPathComparer()()() | Initializes a new instance of the NavigationPathComparer class
 | Compare(NavigationPath, NavigationPath) | Compares two Navigation Paths's FullName.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
NavigationPathComparer

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.PluginFramework (Module: ScrewTurn.Wiki.PluginFramework) Version: 3.0.2.500 (3.0.2.500)


NavigationPathComparer Constructor

NavigationPathComparer Constructor
ScrewTurn Wiki ► ScrewTurn.Wiki.PluginFramework ► NavigationPathComparer ► NavigationPathComparer()()()
Initializes a new instance of the NavigationPathComparer class
Declaration Syntax
C# Visual Basic Visual C++
public NavigationPathComparer()
Public Sub New
public:
NavigationPathComparer()

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.PluginFramework (Module: ScrewTurn.Wiki.PluginFramework) Version: 3.0.2.500 (3.0.2.500)


Compare Method (x, y)

Compare Method (x, y)
ScrewTurn Wiki ► ScrewTurn.Wiki.PluginFramework ► NavigationPathComparer ► Compare(NavigationPath, NavigationPath)
Compares two Navigation Paths's FullName.
Declaration Syntax
C# Visual Basic Visual C++
public int Compare(
    NavigationPath x,
    NavigationPath y
)
Public Function Compare ( _
    x As NavigationPath, _
    y As NavigationPath _
) As Integer
public:
virtual int Compare(
    NavigationPath^ x,
    NavigationPath^ y
) sealed
Parameters
x (NavigationPath)
The first object.
y (NavigationPath)
The second object.
Return Value
The result of the comparison (1, 0 or -1).

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.PluginFramework (Module: ScrewTurn.Wiki.PluginFramework) Version: 3.0.2.500 (3.0.2.500)


PageActivity Enumeration

PageActivity Enumeration
ScrewTurn Wiki ► ScrewTurn.Wiki.PluginFramework ► PageActivity
Lists legal Page Activity types.
Declaration Syntax
C# Visual Basic Visual C++
public enum PageActivity
Public Enumeration PageActivity
public enum class PageActivity
Members
Member | Description
PageCreated | A page has been created.
PageModified | A page has been modified.
PageDraftSaved | A draft for a page has been saved.
PageRenamed | A page has been renamed.
PageRolledBack | A page has been rolled back.
PageBackupsDeleted | A page's backups have been deleted.
PageDeleted | A page has been deleted.
MessagePosted | A message has been posted to a page discussion.
MessageModified | A message has been modified.
MessageDeleted | A message has been deleted from a page discussion.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.PluginFramework (Module: ScrewTurn.Wiki.PluginFramework) Version: 3.0.2.500 (3.0.2.500)


PageActivityEventArgs Class

PageActivityEventArgs Class
ScrewTurn Wiki ► ScrewTurn.Wiki.PluginFramework ► PageActivityEventArgs
Contains arguments for Page Activity events.
Declaration Syntax
C# Visual Basic Visual C++
public class PageActivityEventArgs : EventArgs
Public Class PageActivityEventArgs _
    Inherits EventArgs
public ref class PageActivityEventArgs : public EventArgs
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | PageActivityEventArgs(PageInfo, String, String, PageActivity) | Initializes a new instance of the PageActivityEventArgs class.
 | Activity | Gets the activity.
 | Author | Gets the author of the activity.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Page | Gets the page the activity refers to.
 | PageOldName | Gets the old name of the renamed page, or null.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | EventArgs
 |  | PageActivityEventArgs

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.PluginFramework (Module: ScrewTurn.Wiki.PluginFramework) Version: 3.0.2.500 (3.0.2.500)


PageActivityEventArgs Constructor (page, pageOldName, author, activity)

PageActivityEventArgs Constructor (page, pageOldName, author, activity)
ScrewTurn Wiki ► ScrewTurn.Wiki.PluginFramework ► PageActivityEventArgs ► PageActivityEventArgs(PageInfo, String, String, PageActivity)
Initializes a new instance of the PageActivityEventArgs class.
Declaration Syntax
C# Visual Basic Visual C++
public PageActivityEventArgs(
    PageInfo page,
    string pageOldName,
    string author,
    PageActivity activity
)
Public Sub New ( _
    page As PageInfo, _
    pageOldName As String, _
    author As String, _
    activity As PageActivity _
)
public:
PageActivityEventArgs(
    PageInfo^ page,
    String^ pageOldName,
    String^ author,
    PageActivity activity
)
Parameters
page (PageInfo)
The page the activity refers to.
pageOldName (String)
The old name of the renamed page, or null.
author (String)
The author of the activity, if available, null otherwise.
activity (PageActivity)
The activity.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.PluginFramework (Module: ScrewTurn.Wiki.PluginFramework) Version: 3.0.2.500 (3.0.2.500)


Activity Property

Activity Property
ScrewTurn Wiki ► ScrewTurn.Wiki.PluginFramework ► PageActivityEventArgs ► Activity
Gets the activity.
Declaration Syntax
C# Visual Basic Visual C++
public PageActivity Activity { get; }
Public ReadOnly Property Activity As PageActivity
public:
property PageActivity Activity {
    PageActivity get ();
}

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.PluginFramework (Module: ScrewTurn.Wiki.PluginFramework) Version: 3.0.2.500 (3.0.2.500)


Author Property

Author Property
ScrewTurn Wiki ► ScrewTurn.Wiki.PluginFramework ► PageActivityEventArgs ► Author
Gets the author of the activity.
Declaration Syntax
C# Visual Basic Visual C++
public string Author { get; }
Public ReadOnly Property Author As String
public:
property String^ Author {
    String^ get ();
}

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.PluginFramework (Module: ScrewTurn.Wiki.PluginFramework) Version: 3.0.2.500 (3.0.2.500)


Page Property

Page Property
ScrewTurn Wiki ► ScrewTurn.Wiki.PluginFramework ► PageActivityEventArgs ► Page
Gets the page the activity refers to.
Declaration Syntax
C# Visual Basic Visual C++
public PageInfo Page { get; }
Public ReadOnly Property Page As PageInfo
public:
property PageInfo^ Page {
    PageInfo^ get ();
}

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.PluginFramework (Module: ScrewTurn.Wiki.PluginFramework) Version: 3.0.2.500 (3.0.2.500)


PageOldName Property

PageOldName Property
ScrewTurn Wiki ► ScrewTurn.Wiki.PluginFramework ► PageActivityEventArgs ► PageOldName
Gets the old name of the renamed page, or null.
Declaration Syntax
C# Visual Basic Visual C++
public string PageOldName { get; }
Public ReadOnly Property PageOldName As String
public:
property String^ PageOldName {
    String^ get ();
}

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.PluginFramework (Module: ScrewTurn.Wiki.PluginFramework) Version: 3.0.2.500 (3.0.2.500)


PageContent Class

PageContent Class
ScrewTurn Wiki ► ScrewTurn.Wiki.PluginFramework ► PageContent
Contains the Content of a Page.
Declaration Syntax
C# Visual Basic Visual C++
public class PageContent
Public Class PageContent
public ref class PageContent
Members
All Members | Constructors | Methods | Properties | Fields
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | PageContent(PageInfo, String, String, DateTime, String, String, array<String>[]()[], String) | Initializes a new instance of the PageContent class.
 | comment | The comment of the editor, about this revision.
 | Comment | Gets the Comment of the editor, about this revision.
 | content | The Content of the Page (WikiMarkup).
 | Content | Gets the unformatted Content.
 | description | The page description, usually used for SEO.
 | Description | Gets the description, usually used for SEO.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetEmpty(PageInfo) | Gets an empty instance of PageContent.
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | IsEmpty()()() | Determines whether the current instance was built using [M:GetEmpty].
 | keywords | The keywords, usually used for SEO.
 | Keywords | Gets the keywords, usually used for SEO.
 | lastModified | The Date/Time of the last modification.
 | LastModified | Gets the last modification Date and Time.
 | linkedPages | The Pages linked in this Page (both existent and inexistent).
 | LinkedPages | Gets or sets the Linked Pages, both existent and inexistent.
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | pageInfo | The PageInfo object.
 | PageInfo | Gets the PageInfo.
 | title | The Title of the Page.
 | Title | Gets the Title.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | user | The Username of the user who modified the Page.
 | User | Gets the User.
Inheritance Hierarchy
Object
PageContent

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.PluginFramework (Module: ScrewTurn.Wiki.PluginFramework) Version: 3.0.2.500 (3.0.2.500)


PageContent Constructor (pageInfo, title, user, lastModified, comment, content, keywords, description)

PageContent Constructor (pageInfo, title, user, lastModified, comment, content, keywords, description)
ScrewTurn Wiki ► ScrewTurn.Wiki.PluginFramework ► PageContent ► PageContent(PageInfo, String, String, DateTime, String, String, array<String>[]()[], String)
Initializes a new instance of the PageContent class.
Declaration Syntax
C# Visual Basic Visual C++
public PageContent(
    PageInfo pageInfo,
    string title,
    string user,
    DateTime lastModified,
    string comment,
    string content,
    string[] keywords,
    string description
)
Public Sub New ( _
    pageInfo As PageInfo, _
    title As String, _
    user As String, _
    lastModified As DateTime, _
    comment As String, _
    content As String, _
    keywords As String(), _
    description As String _
)
public:
PageContent(
    PageInfo^ pageInfo,
    String^ title,
    String^ user,
    DateTime lastModified,
    String^ comment,
    String^ content,
    array<String^>^ keywords,
    String^ description
)
Parameters
pageInfo (PageInfo)
The PageInfo object.
title (String)
The Title.
user (String)
The User that last modified the Page.
lastModified (DateTime)
The last modification Date and Time.
comment (String)
The Comment of the editor, about this revision.
content (String)
The unparsed Content.
keywords (array< String >[]()[][])
The keywords, usually used for SEO, or null.
description (String)
The description, usually used for SEO, or null.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.PluginFramework (Module: ScrewTurn.Wiki.PluginFramework) Version: 3.0.2.500 (3.0.2.500)


comment Field

comment Field
ScrewTurn Wiki ► ScrewTurn.Wiki.PluginFramework ► PageContent ► comment
The comment of the editor, about this revision.
Declaration Syntax
C# Visual Basic Visual C++
protected string comment
Protected comment As String
protected:
String^ comment

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.PluginFramework (Module: ScrewTurn.Wiki.PluginFramework) Version: 3.0.2.500 (3.0.2.500)


Comment Property

Comment Property
ScrewTurn Wiki ► ScrewTurn.Wiki.PluginFramework ► PageContent ► Comment
Gets the Comment of the editor, about this revision.
Declaration Syntax
C# Visual Basic Visual C++
public string Comment { get; }
Public ReadOnly Property Comment As String
public:
property String^ Comment {
    String^ get ();
}

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.PluginFramework (Module: ScrewTurn.Wiki.PluginFramework) Version: 3.0.2.500 (3.0.2.500)


content Field

content Field
ScrewTurn Wiki ► ScrewTurn.Wiki.PluginFramework ► PageContent ► content
The Content of the Page (WikiMarkup).
Declaration Syntax
C# Visual Basic Visual C++
protected string content
Protected content As String
protected:
String^ content

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.PluginFramework (Module: ScrewTurn.Wiki.PluginFramework) Version: 3.0.2.500 (3.0.2.500)


Content Property

Content Property
ScrewTurn Wiki ► ScrewTurn.Wiki.PluginFramework ► PageContent ► Content
Gets the unformatted Content.
Declaration Syntax
C# Visual Basic Visual C++
public string Content { get; }
Public ReadOnly Property Content As String
public:
property String^ Content {
    String^ get ();
}

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.PluginFramework (Module: ScrewTurn.Wiki.PluginFramework) Version: 3.0.2.500 (3.0.2.500)


description Field

description Field
ScrewTurn Wiki ► ScrewTurn.Wiki.PluginFramework ► PageContent ► description
The page description, usually used for SEO.
Declaration Syntax
C# Visual Basic Visual C++
protected string description
Protected description As String
protected:
String^ description

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.PluginFramework (Module: ScrewTurn.Wiki.PluginFramework) Version: 3.0.2.500 (3.0.2.500)


Description Property

Description Property
ScrewTurn Wiki ► ScrewTurn.Wiki.PluginFramework ► PageContent ► Description
Gets the description, usually used for SEO.
Declaration Syntax
C# Visual Basic Visual C++
public string Description { get; }
Public ReadOnly Property Description As String
public:
property String^ Description {
    String^ get ();
}

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.PluginFramework (Module: ScrewTurn.Wiki.PluginFramework) Version: 3.0.2.500 (3.0.2.500)


GetEmpty Method (page)

GetEmpty Method (page)
ScrewTurn Wiki ► ScrewTurn.Wiki.PluginFramework ► PageContent ► GetEmpty(PageInfo)
Gets an empty instance of PageContent.
Declaration Syntax
C# Visual Basic Visual C++
public static PageContent GetEmpty(
    PageInfo page
)
Public Shared Function GetEmpty ( _
    page As PageInfo _
) As PageContent
public:
static PageContent^ GetEmpty(
    PageInfo^ page
)
Parameters
page (PageInfo)
The page.
Return Value
The instance.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.PluginFramework (Module: ScrewTurn.Wiki.PluginFramework) Version: 3.0.2.500 (3.0.2.500)


IsEmpty Method

IsEmpty Method
ScrewTurn Wiki ► ScrewTurn.Wiki.PluginFramework ► PageContent ► IsEmpty()()()
Determines whether the current instance was built using [M:GetEmpty].
Declaration Syntax
C# Visual Basic Visual C++
public bool IsEmpty()
Public Function IsEmpty As Boolean
public:
bool IsEmpty()
Return Value
True if the instance is empty, false otherwise.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.PluginFramework (Module: ScrewTurn.Wiki.PluginFramework) Version: 3.0.2.500 (3.0.2.500)


keywords Field

keywords Field
ScrewTurn Wiki ► ScrewTurn.Wiki.PluginFramework ► PageContent ► keywords
The keywords, usually used for SEO.
Declaration Syntax
C# Visual Basic Visual C++
protected string[] keywords
Protected keywords As String()
protected:
array<String^>^ keywords

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.PluginFramework (Module: ScrewTurn.Wiki.PluginFramework) Version: 3.0.2.500 (3.0.2.500)


Keywords Property

Keywords Property
ScrewTurn Wiki ► ScrewTurn.Wiki.PluginFramework ► PageContent ► Keywords
Gets the keywords, usually used for SEO.
Declaration Syntax
C# Visual Basic Visual C++
public string[] Keywords { get; }
Public ReadOnly Property Keywords As String()
public:
property array<String^>^ Keywords {
    array<String^>^ get ();
}

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.PluginFramework (Module: ScrewTurn.Wiki.PluginFramework) Version: 3.0.2.500 (3.0.2.500)


lastModified Field

lastModified Field
ScrewTurn Wiki ► ScrewTurn.Wiki.PluginFramework ► PageContent ► lastModified
The Date/Time of the last modification.
Declaration Syntax
C# Visual Basic Visual C++
protected DateTime lastModified
Protected lastModified As DateTime
protected:
DateTime lastModified

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.PluginFramework (Module: ScrewTurn.Wiki.PluginFramework) Version: 3.0.2.500 (3.0.2.500)


LastModified Property

LastModified Property
ScrewTurn Wiki ► ScrewTurn.Wiki.PluginFramework ► PageContent ► LastModified
Gets the last modification Date and Time.
Declaration Syntax
C# Visual Basic Visual C++
public DateTime LastModified { get; }
Public ReadOnly Property LastModified As DateTime
public:
property DateTime LastModified {
    DateTime get ();
}

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.PluginFramework (Module: ScrewTurn.Wiki.PluginFramework) Version: 3.0.2.500 (3.0.2.500)


linkedPages Field

linkedPages Field
ScrewTurn Wiki ► ScrewTurn.Wiki.PluginFramework ► PageContent ► linkedPages
The Pages linked in this Page (both existent and inexistent).
Declaration Syntax
C# Visual Basic Visual C++
protected string[] linkedPages
Protected linkedPages As String()
protected:
array<String^>^ linkedPages

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.PluginFramework (Module: ScrewTurn.Wiki.PluginFramework) Version: 3.0.2.500 (3.0.2.500)


LinkedPages Property

LinkedPages Property
ScrewTurn Wiki ► ScrewTurn.Wiki.PluginFramework ► PageContent ► LinkedPages
Gets or sets the Linked Pages, both existent and inexistent.
Declaration Syntax
C# Visual Basic Visual C++
public string[] LinkedPages { get; set; }
Public Property LinkedPages As String()
public:
property array<String^>^ LinkedPages {
    array<String^>^ get ();
    void set (array<String^>^ value);
}

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.PluginFramework (Module: ScrewTurn.Wiki.PluginFramework) Version: 3.0.2.500 (3.0.2.500)


pageInfo Field

pageInfo Field
ScrewTurn Wiki ► ScrewTurn.Wiki.PluginFramework ► PageContent ► pageInfo
The PageInfo object.
Declaration Syntax
C# Visual Basic Visual C++
protected PageInfo pageInfo
Protected pageInfo As PageInfo
protected:
PageInfo^ pageInfo

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.PluginFramework (Module: ScrewTurn.Wiki.PluginFramework) Version: 3.0.2.500 (3.0.2.500)


PageInfo Property

PageInfo Property
ScrewTurn Wiki ► ScrewTurn.Wiki.PluginFramework ► PageContent ► PageInfo
Gets the PageInfo.
Declaration Syntax
C# Visual Basic Visual C++
public PageInfo PageInfo { get; }
Public ReadOnly Property PageInfo As PageInfo
public:
property PageInfo^ PageInfo {
    PageInfo^ get ();
}

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.PluginFramework (Module: ScrewTurn.Wiki.PluginFramework) Version: 3.0.2.500 (3.0.2.500)


title Field

title Field
ScrewTurn Wiki ► ScrewTurn.Wiki.PluginFramework ► PageContent ► title
The Title of the Page.
Declaration Syntax
C# Visual Basic Visual C++
protected string title
Protected title As String
protected:
String^ title

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.PluginFramework (Module: ScrewTurn.Wiki.PluginFramework) Version: 3.0.2.500 (3.0.2.500)


Title Property

Title Property
ScrewTurn Wiki ► ScrewTurn.Wiki.PluginFramework ► PageContent ► Title
Gets the Title.
Declaration Syntax
C# Visual Basic Visual C++
public string Title { get; }
Public ReadOnly Property Title As String
public:
property String^ Title {
    String^ get ();
}

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.PluginFramework (Module: ScrewTurn.Wiki.PluginFramework) Version: 3.0.2.500 (3.0.2.500)


user Field

user Field
ScrewTurn Wiki ► ScrewTurn.Wiki.PluginFramework ► PageContent ► user
The Username of the user who modified the Page.
Declaration Syntax
C# Visual Basic Visual C++
protected string user
Protected user As String
protected:
String^ user

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.PluginFramework (Module: ScrewTurn.Wiki.PluginFramework) Version: 3.0.2.500 (3.0.2.500)


User Property

User Property
ScrewTurn Wiki ► ScrewTurn.Wiki.PluginFramework ► PageContent ► User
Gets the User.
Declaration Syntax
C# Visual Basic Visual C++
public string User { get; }
Public ReadOnly Property User As String
public:
property String^ User {
    String^ get ();
}

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.PluginFramework (Module: ScrewTurn.Wiki.PluginFramework) Version: 3.0.2.500 (3.0.2.500)


PageDocument Class

PageDocument Class
ScrewTurn Wiki ► ScrewTurn.Wiki.PluginFramework ► PageDocument
Represents a page for use with the search engine.
Declaration Syntax
C# Visual Basic Visual C++
public class PageDocument : IDocument
Public Class PageDocument _
    Implements IDocument
public ref class PageDocument : IDocument
Members
All Members | Constructors | Methods | Properties | Fields
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | PageDocument(PageInfo, DumpedDocument, Tokenizer) | Initializes a new instance of the PageDocument class.
 | DateTime | Gets the document date/time.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetDocumentName(PageInfo) | Gets the document name for a Page.
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetPageName(String) | Gets the page name from a document name.
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | ID | Gets or sets the globally unique ID of the document.
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets the globally-unique name of the document.
 | PageInfo | Gets the page information.
 | StandardTypeTag | The type tag for a PageDocument.
 | Title | Gets the title of the document, if any.
 | Tokenize(String) | Performs the tokenization of the document content.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | TypeTag | Gets the tag for the document type.
Inheritance Hierarchy
Object
PageDocument

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.PluginFramework (Module: ScrewTurn.Wiki.PluginFramework) Version: 3.0.2.500 (3.0.2.500)


PageDocument Constructor (pageInfo, dumpedDocument, tokenizer)

PageDocument Constructor (pageInfo, dumpedDocument, tokenizer)
ScrewTurn Wiki ► ScrewTurn.Wiki.PluginFramework ► PageDocument ► PageDocument(PageInfo, DumpedDocument, Tokenizer)
Initializes a new instance of the PageDocument class.
Declaration Syntax
C# Visual Basic Visual C++
public PageDocument(
    PageInfo pageInfo,
    DumpedDocument dumpedDocument,
    Tokenizer tokenizer
)
Public Sub New ( _
    pageInfo As PageInfo, _
    dumpedDocument As DumpedDocument, _
    tokenizer As Tokenizer _
)
public:
PageDocument(
    PageInfo^ pageInfo,
    DumpedDocument^ dumpedDocument,
    Tokenizer^ tokenizer
)
Parameters
pageInfo (PageInfo)
The page.
dumpedDocument (DumpedDocument)
The dumped document data.
tokenizer (Tokenizer)
The tokenizer.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.PluginFramework (Module: ScrewTurn.Wiki.PluginFramework) Version: 3.0.2.500 (3.0.2.500)


DateTime Property

DateTime Property
ScrewTurn Wiki ► ScrewTurn.Wiki.PluginFramework ► PageDocument ► DateTime
Gets the document date/time.
Declaration Syntax
C# Visual Basic Visual C++
public DateTime DateTime { get; }
Public ReadOnly Property DateTime As DateTime
public:
virtual property DateTime DateTime {
    DateTime get () sealed;
}

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.PluginFramework (Module: ScrewTurn.Wiki.PluginFramework) Version: 3.0.2.500 (3.0.2.500)


GetDocumentName Method (page)

GetDocumentName Method (page)
ScrewTurn Wiki ► ScrewTurn.Wiki.PluginFramework ► PageDocument ► GetDocumentName(PageInfo)
Gets the document name for a Page.
Declaration Syntax
C# Visual Basic Visual C++
public static string GetDocumentName(
    PageInfo page
)
Public Shared Function GetDocumentName ( _
    page As PageInfo _
) As String
public:
static String^ GetDocumentName(
    PageInfo^ page
)
Parameters
page (PageInfo)
The page.
Return Value
The document name.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.PluginFramework (Module: ScrewTurn.Wiki.PluginFramework) Version: 3.0.2.500 (3.0.2.500)


GetPageName Method (documentName)

GetPageName Method (documentName)
ScrewTurn Wiki ► ScrewTurn.Wiki.PluginFramework ► PageDocument ► GetPageName(String)
Gets the page name from a document name.
Declaration Syntax
C# Visual Basic Visual C++
public static string GetPageName(
    string documentName
)
Public Shared Function GetPageName ( _
    documentName As String _
) As String
public:
static String^ GetPageName(
    String^ documentName
)
Parameters
documentName (String)
The document name.
Return Value
The page name.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.PluginFramework (Module: ScrewTurn.Wiki.PluginFramework) Version: 3.0.2.500 (3.0.2.500)


ID Property

ID Property
ScrewTurn Wiki ► ScrewTurn.Wiki.PluginFramework ► PageDocument ► ID
Gets or sets the globally unique ID of the document.
Declaration Syntax
C# Visual Basic Visual C++
public uint ID { get; set; }
Public Property ID As UInteger
public:
virtual property unsigned int ID {
    unsigned int get () sealed;
    void set (unsigned int value) sealed;
}

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.PluginFramework (Module: ScrewTurn.Wiki.PluginFramework) Version: 3.0.2.500 (3.0.2.500)


Name Property

Name Property
ScrewTurn Wiki ► ScrewTurn.Wiki.PluginFramework ► PageDocument ► Name
Gets the globally-unique name of the document.
Declaration Syntax
C# Visual Basic Visual C++
public string Name { get; }
Public ReadOnly Property Name As String
public:
virtual property String^ Name {
    String^ get () sealed;
}

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.PluginFramework (Module: ScrewTurn.Wiki.PluginFramework) Version: 3.0.2.500 (3.0.2.500)


PageInfo Property

PageInfo Property
ScrewTurn Wiki ► ScrewTurn.Wiki.PluginFramework ► PageDocument ► PageInfo
Gets the page information.
Declaration Syntax
C# Visual Basic Visual C++
public PageInfo PageInfo { get; }
Public ReadOnly Property PageInfo As PageInfo
public:
property PageInfo^ PageInfo {
    PageInfo^ get ();
}

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.PluginFramework (Module: ScrewTurn.Wiki.PluginFramework) Version: 3.0.2.500 (3.0.2.500)


StandardTypeTag Field

StandardTypeTag Field
ScrewTurn Wiki ► ScrewTurn.Wiki.PluginFramework ► PageDocument ► StandardTypeTag
The type tag for a PageDocument.
Declaration Syntax
C# Visual Basic Visual C++
public const string StandardTypeTag
Public Const StandardTypeTag As String
public:
literal String^ StandardTypeTag

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.PluginFramework (Module: ScrewTurn.Wiki.PluginFramework) Version: 3.0.2.500 (3.0.2.500)


Title Property

Title Property
ScrewTurn Wiki ► ScrewTurn.Wiki.PluginFramework ► PageDocument ► Title
Gets the title of the document, if any.
Declaration Syntax
C# Visual Basic Visual C++
public string Title { get; }
Public ReadOnly Property Title As String
public:
virtual property String^ Title {
    String^ get () sealed;
}

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.PluginFramework (Module: ScrewTurn.Wiki.PluginFramework) Version: 3.0.2.500 (3.0.2.500)


Tokenize Method (content)

Tokenize Method (content)
ScrewTurn Wiki ► ScrewTurn.Wiki.PluginFramework ► PageDocument ► Tokenize(String)
Performs the tokenization of the document content.
Declaration Syntax
C# Visual Basic Visual C++
public WordInfo[] Tokenize(
    string content
)
Public Function Tokenize ( _
    content As String _
) As WordInfo()
public:
virtual array<WordInfo^>^ Tokenize(
    String^ content
) sealed
Parameters
content (String)
The content to tokenize.
Return Value
The extracted words and their positions.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.PluginFramework (Module: ScrewTurn.Wiki.PluginFramework) Version: 3.0.2.500 (3.0.2.500)


TypeTag Property

TypeTag Property
ScrewTurn Wiki ► ScrewTurn.Wiki.PluginFramework ► PageDocument ► TypeTag
Gets the tag for the document type.
Declaration Syntax
C# Visual Basic Visual C++
public string TypeTag { get; }
Public ReadOnly Property TypeTag As String
public:
virtual property String^ TypeTag {
    String^ get () sealed;
}

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.PluginFramework (Module: ScrewTurn.Wiki.PluginFramework) Version: 3.0.2.500 (3.0.2.500)


PageInfo Class

PageInfo Class
ScrewTurn Wiki ► ScrewTurn.Wiki.PluginFramework ► PageInfo
Contains basic information about a Page.
Declaration Syntax
C# Visual Basic Visual C++
public class PageInfo
Public Class PageInfo
public ref class PageInfo
Members
All Members | Constructors | Methods | Properties | Fields
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | PageInfo(String, IPagesStorageProviderV30, DateTime) | Initializes a new instance of the PageInfo class.
 | creationDateTime | The Page creation Date/Time.
 | CreationDateTime | Gets or sets the creation Date/Time.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | FullName | Gets or sets the full name of the Page, such as 'Namespace.Page' or 'Page'.
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | name | The Name of the Page.
 | nonCached | A value specifying whether the Page should NOT be cached by the engine.
 | NonCached | Gets or sets a value specifying whether the Page should NOT be cached by the engine.
 | nspace | The namespace of the Page.
 | provider | The Provider that handles the Page.
 | Provider | Gets or sets the Pages Storage Provider.
 | ToString()()() | Converts the current PageInfo to a string. (Overrides Object.ToString()()().)
Inheritance Hierarchy
Object
 | PageInfo
 |  | LocalPageInfo

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.PluginFramework (Module: ScrewTurn.Wiki.PluginFramework) Version: 3.0.2.500 (3.0.2.500)


PageInfo Constructor (fullName, provider, creationDateTime)

PageInfo Constructor (fullName, provider, creationDateTime)
ScrewTurn Wiki ► ScrewTurn.Wiki.PluginFramework ► PageInfo ► PageInfo(String, IPagesStorageProviderV30, DateTime)
Initializes a new instance of the PageInfo class.
Declaration Syntax
C# Visual Basic Visual C++
public PageInfo(
    string fullName,
    IPagesStorageProviderV30 provider,
    DateTime creationDateTime
)
Public Sub New ( _
    fullName As String, _
    provider As IPagesStorageProviderV30, _
    creationDateTime As DateTime _
)
public:
PageInfo(
    String^ fullName,
    IPagesStorageProviderV30^ provider,
    DateTime creationDateTime
)
Parameters
fullName (String)
The Full Name of the Page.
provider (IPagesStorageProviderV30)
The Pages Storage Provider that manages this Page.
creationDateTime (DateTime)
The Page creation Date/Time.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.PluginFramework (Module: ScrewTurn.Wiki.PluginFramework) Version: 3.0.2.500 (3.0.2.500)


creationDateTime Field

creationDateTime Field
ScrewTurn Wiki ► ScrewTurn.Wiki.PluginFramework ► PageInfo ► creationDateTime
The Page creation Date/Time.
Declaration Syntax
C# Visual Basic Visual C++
protected DateTime creationDateTime
Protected creationDateTime As DateTime
protected:
DateTime creationDateTime

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.PluginFramework (Module: ScrewTurn.Wiki.PluginFramework) Version: 3.0.2.500 (3.0.2.500)


CreationDateTime Property

CreationDateTime Property
ScrewTurn Wiki ► ScrewTurn.Wiki.PluginFramework ► PageInfo ► CreationDateTime
Gets or sets the creation Date/Time.
Declaration Syntax
C# Visual Basic Visual C++
public DateTime CreationDateTime { get; set; }
Public Property CreationDateTime As DateTime
public:
property DateTime CreationDateTime {
    DateTime get ();
    void set (DateTime value);
}

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.PluginFramework (Module: ScrewTurn.Wiki.PluginFramework) Version: 3.0.2.500 (3.0.2.500)


FullName Property

FullName Property
ScrewTurn Wiki ► ScrewTurn.Wiki.PluginFramework ► PageInfo ► FullName
Gets or sets the full name of the Page, such as 'Namespace.Page' or 'Page'.
Declaration Syntax
C# Visual Basic Visual C++
public string FullName { get; set; }
Public Property FullName As String
public:
property String^ FullName {
    String^ get ();
    void set (String^ value);
}

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.PluginFramework (Module: ScrewTurn.Wiki.PluginFramework) Version: 3.0.2.500 (3.0.2.500)


name Field

name Field
ScrewTurn Wiki ► ScrewTurn.Wiki.PluginFramework ► PageInfo ► name
The Name of the Page.
Declaration Syntax
C# Visual Basic Visual C++
protected string name
Protected name As String
protected:
String^ name

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.PluginFramework (Module: ScrewTurn.Wiki.PluginFramework) Version: 3.0.2.500 (3.0.2.500)


nonCached Field

nonCached Field
ScrewTurn Wiki ► ScrewTurn.Wiki.PluginFramework ► PageInfo ► nonCached
A value specifying whether the Page should NOT be cached by the engine.
Declaration Syntax
C# Visual Basic Visual C++
protected bool nonCached
Protected nonCached As Boolean
protected:
bool nonCached

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.PluginFramework (Module: ScrewTurn.Wiki.PluginFramework) Version: 3.0.2.500 (3.0.2.500)


NonCached Property

NonCached Property
ScrewTurn Wiki ► ScrewTurn.Wiki.PluginFramework ► PageInfo ► NonCached
Gets or sets a value specifying whether the Page should NOT be cached by the engine.
Declaration Syntax
C# Visual Basic Visual C++
public bool NonCached { get; set; }
Public Property NonCached As Boolean
public:
property bool NonCached {
    bool get ();
    void set (bool value);
}

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.PluginFramework (Module: ScrewTurn.Wiki.PluginFramework) Version: 3.0.2.500 (3.0.2.500)


nspace Field

nspace Field
ScrewTurn Wiki ► ScrewTurn.Wiki.PluginFramework ► PageInfo ► nspace
The namespace of the Page.
Declaration Syntax
C# Visual Basic Visual C++
protected string nspace
Protected nspace As String
protected:
String^ nspace

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.PluginFramework (Module: ScrewTurn.Wiki.PluginFramework) Version: 3.0.2.500 (3.0.2.500)


provider Field

provider Field
ScrewTurn Wiki ► ScrewTurn.Wiki.PluginFramework ► PageInfo ► provider
The Provider that handles the Page.
Declaration Syntax
C# Visual Basic Visual C++
protected IPagesStorageProviderV30 provider
Protected provider As IPagesStorageProviderV30
protected:
IPagesStorageProviderV30^ provider

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.PluginFramework (Module: ScrewTurn.Wiki.PluginFramework) Version: 3.0.2.500 (3.0.2.500)


Provider Property

Provider Property
ScrewTurn Wiki ► ScrewTurn.Wiki.PluginFramework ► PageInfo ► Provider
Gets or sets the Pages Storage Provider.
Declaration Syntax
C# Visual Basic Visual C++
public IPagesStorageProviderV30 Provider { get; set; }
Public Property Provider As IPagesStorageProviderV30
public:
property IPagesStorageProviderV30^ Provider {
    IPagesStorageProviderV30^ get ();
    void set (IPagesStorageProviderV30^ value);
}

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.PluginFramework (Module: ScrewTurn.Wiki.PluginFramework) Version: 3.0.2.500 (3.0.2.500)


ToString Method

ToString Method
ScrewTurn Wiki ► ScrewTurn.Wiki.PluginFramework ► PageInfo ► ToString()()()
Converts the current PageInfo to a string.
Declaration Syntax
C# Visual Basic Visual C++
public override string ToString()
Public Overrides Function ToString As String
public:
virtual String^ ToString() override
Return Value
The string.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.PluginFramework (Module: ScrewTurn.Wiki.PluginFramework) Version: 3.0.2.500 (3.0.2.500)


PageNameComparer Class

PageNameComparer Class
ScrewTurn Wiki ► ScrewTurn.Wiki.PluginFramework ► PageNameComparer
Compares two PageInfo objects, using the FullName as parameter.
Declaration Syntax
C# Visual Basic Visual C++
public class PageNameComparer : IComparer<PageInfo>
Public Class PageNameComparer _
    Implements IComparer(Of PageInfo)
public ref class PageNameComparer : IComparer<PageInfo^>
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | PageNameComparer()()() | Initializes a new instance of the PageNameComparer class
 | Compare(PageInfo, PageInfo) | Compares two PageInfo objects, using the FullName as parameter.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Remarks
The comparison is case insensitive.
Inheritance Hierarchy
Object
PageNameComparer

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.PluginFramework (Module: ScrewTurn.Wiki.PluginFramework) Version: 3.0.2.500 (3.0.2.500)


PageNameComparer Constructor

PageNameComparer Constructor
ScrewTurn Wiki ► ScrewTurn.Wiki.PluginFramework ► PageNameComparer ► PageNameComparer()()()
Initializes a new instance of the PageNameComparer class
Declaration Syntax
C# Visual Basic Visual C++
public PageNameComparer()
Public Sub New
public:
PageNameComparer()

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.PluginFramework (Module: ScrewTurn.Wiki.PluginFramework) Version: 3.0.2.500 (3.0.2.500)


Compare Method (x, y)

Compare Method (x, y)
ScrewTurn Wiki ► ScrewTurn.Wiki.PluginFramework ► PageNameComparer ► Compare(PageInfo, PageInfo)
Compares two PageInfo objects, using the FullName as parameter.
Declaration Syntax
C# Visual Basic Visual C++
public int Compare(
    PageInfo x,
    PageInfo y
)
Public Function Compare ( _
    x As PageInfo, _
    y As PageInfo _
) As Integer
public:
virtual int Compare(
    PageInfo^ x,
    PageInfo^ y
) sealed
Parameters
x (PageInfo)
The first object.
y (PageInfo)
The second object.
Return Value
The comparison result (-1, 0 or 1).

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.PluginFramework (Module: ScrewTurn.Wiki.PluginFramework) Version: 3.0.2.500 (3.0.2.500)


RecentChange Class

RecentChange Class
ScrewTurn Wiki ► ScrewTurn.Wiki.PluginFramework ► RecentChange
Represents a Change.
Declaration Syntax
C# Visual Basic Visual C++
public class RecentChange
Public Class RecentChange
public ref class RecentChange
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | RecentChange(String, String, String, DateTime, String, Change, String) | Initializes a new instance of the RecentChange class.
 | Change | Gets the change.
 | DateTime | Gets the date/time.
 | Description | Gets the description (optional).
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | MessageSubject | Gets the message subject (or null).
 | Page | Gets the page name.
 | Title | Gets the page title.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | User | Gets the user.
Inheritance Hierarchy
Object
RecentChange

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.PluginFramework (Module: ScrewTurn.Wiki.PluginFramework) Version: 3.0.2.500 (3.0.2.500)


RecentChange Constructor (page, title, messageSubject, dateTime, user, change, descr)

RecentChange Constructor (page, title, messageSubject, dateTime, user, change, descr)
ScrewTurn Wiki ► ScrewTurn.Wiki.PluginFramework ► RecentChange ► RecentChange(String, String, String, DateTime, String, Change, String)
Initializes a new instance of the RecentChange class.
Declaration Syntax
C# Visual Basic Visual C++
public RecentChange(
    string page,
    string title,
    string messageSubject,
    DateTime dateTime,
    string user,
    Change change,
    string descr
)
Public Sub New ( _
    page As String, _
    title As String, _
    messageSubject As String, _
    dateTime As DateTime, _
    user As String, _
    change As Change, _
    descr As String _
)
public:
RecentChange(
    String^ page,
    String^ title,
    String^ messageSubject,
    DateTime dateTime,
    String^ user,
    Change change,
    String^ descr
)
Parameters
page (String)
The page pame.
title (String)
The page title.
messageSubject (String)
The message subject (or null).
dateTime (DateTime)
The date/time.
user (String)
The user.
change (Change)
The change.
descr (String)
The description (optional).

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.PluginFramework (Module: ScrewTurn.Wiki.PluginFramework) Version: 3.0.2.500 (3.0.2.500)


Change Property

Change Property
ScrewTurn Wiki ► ScrewTurn.Wiki.PluginFramework ► RecentChange ► Change
Gets the change.
Declaration Syntax
C# Visual Basic Visual C++
public Change Change { get; }
Public ReadOnly Property Change As Change
public:
property Change Change {
    Change get ();
}

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.PluginFramework (Module: ScrewTurn.Wiki.PluginFramework) Version: 3.0.2.500 (3.0.2.500)


DateTime Property

DateTime Property
ScrewTurn Wiki ► ScrewTurn.Wiki.PluginFramework ► RecentChange ► DateTime
Gets the date/time.
Declaration Syntax
C# Visual Basic Visual C++
public DateTime DateTime { get; }
Public ReadOnly Property DateTime As DateTime
public:
property DateTime DateTime {
    DateTime get ();
}

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.PluginFramework (Module: ScrewTurn.Wiki.PluginFramework) Version: 3.0.2.500 (3.0.2.500)


Description Property

Description Property
ScrewTurn Wiki ► ScrewTurn.Wiki.PluginFramework ► RecentChange ► Description
Gets the description (optional).
Declaration Syntax
C# Visual Basic Visual C++
public string Description { get; }
Public ReadOnly Property Description As String
public:
property String^ Description {
    String^ get ();
}

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.PluginFramework (Module: ScrewTurn.Wiki.PluginFramework) Version: 3.0.2.500 (3.0.2.500)


MessageSubject Property

MessageSubject Property
ScrewTurn Wiki ► ScrewTurn.Wiki.PluginFramework ► RecentChange ► MessageSubject
Gets the message subject (or null).
Declaration Syntax
C# Visual Basic Visual C++
public string MessageSubject { get; }
Public ReadOnly Property MessageSubject As String
public:
property String^ MessageSubject {
    String^ get ();
}

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.PluginFramework (Module: ScrewTurn.Wiki.PluginFramework) Version: 3.0.2.500 (3.0.2.500)


Page Property

Page Property
ScrewTurn Wiki ► ScrewTurn.Wiki.PluginFramework ► RecentChange ► Page
Gets the page name.
Declaration Syntax
C# Visual Basic Visual C++
public string Page { get; }
Public ReadOnly Property Page As String
public:
property String^ Page {
    String^ get ();
}

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.PluginFramework (Module: ScrewTurn.Wiki.PluginFramework) Version: 3.0.2.500 (3.0.2.500)


Title Property

Title Property
ScrewTurn Wiki ► ScrewTurn.Wiki.PluginFramework ► RecentChange ► Title
Gets the page title.
Declaration Syntax
C# Visual Basic Visual C++
public string Title { get; }
Public ReadOnly Property Title As String
public:
property String^ Title {
    String^ get ();
}

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.PluginFramework (Module: ScrewTurn.Wiki.PluginFramework) Version: 3.0.2.500 (3.0.2.500)


User Property

User Property
ScrewTurn Wiki ► ScrewTurn.Wiki.PluginFramework ► RecentChange ► User
Gets the user.
Declaration Syntax
C# Visual Basic Visual C++
public string User { get; }
Public ReadOnly Property User As String
public:
property String^ User {
    String^ get ();
}

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.PluginFramework (Module: ScrewTurn.Wiki.PluginFramework) Version: 3.0.2.500 (3.0.2.500)


SaveMode Enumeration

SaveMode Enumeration
ScrewTurn Wiki ► ScrewTurn.Wiki.PluginFramework ► SaveMode
Lists legal saving modes.
Declaration Syntax
C# Visual Basic Visual C++
public enum SaveMode
Public Enumeration SaveMode
public enum class SaveMode
Members
Member | Description
Normal | Save the content.
Backup | Backup the previous content, then save the current content.
Draft | Save the content as draft.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.PluginFramework (Module: ScrewTurn.Wiki.PluginFramework) Version: 3.0.2.500 (3.0.2.500)


SettingName Enumeration

SettingName Enumeration
ScrewTurn Wiki ► ScrewTurn.Wiki.PluginFramework ► SettingName
Enumerates the Setting values' names.
Declaration Syntax
C# Visual Basic Visual C++
public enum SettingName
Public Enumeration SettingName
public enum class SettingName
Members
Member | Description
WikiTitle | The Title of the Wiki.
MainUrl | The Main URL of the Wiki.
RootNamespaceDefaultPage | The default page of the root namespace.
ContactEmail | The Contact Email.
SenderEmail | The Sender Email.
DateTimeFormat | The Date/Time format.
DefaultLanguage | The default Language (for example en-US).
DefaultTimeZone | The default Time Zone (a string representing the shift in minutes respect to the Greenwich time, for example -120).
ThemesDirectory | The Themes directory.
PublicDirectory | The Public directory.
UsersCanRegister | A value (true/false) indicating whether users can create new accounts.
UsernameRegex | The regex used to validate usernames.
PasswordRegex | The regex used to validate passwords.
EmailRegex | The regex used to validate email addresses.
MainUrlRegex | The regex used to validate the main Wiki URL.
EnableDoubleClickEditing | A value (true/false) indicating whether to activate page editing with a double click.
ProcessSingleLineBreaks | A value (true/false) indicating whether to process single line breaks in WikiMarkup.
AccountActivationMode | The account activation mode.
AllowedFileTypes | The file types allowed for upload.
DisableAutomaticVersionCheck | A value (true/false) indicating whether to disable the automatic version check.
DisableBreadcrumbsTrail | A value (true/false) indicating whether to disable the breadcrumbs trail.
DisableCache | A value (true/false) indicating whether to disable the page cache.
DisableCaptchaControl | A value (true/false) indicating whether to disable the captcha control in public functionalities.
DisableConcurrentEditing | A value (true/false) indicating whether to disable concurrent page editing.
EnableHttpCompression | A value (true/false) indicating whether to enable HTTP compression.
EnableViewStateCompression | A value (true/false) indicating whether to enable View State compression.
LoggingLevel | The logging level.
MaxFileSize | The max size for uploaded files (bytes).
PageExtension | The extension used for pages.
ScriptTagsAllowed | A value (true/false) indicating whether to SCRIPT tags are allowed in WikiMarkup.
WikiVersion | The version of the Wiki Engine.
MaxLogSize | The max size, in KB, of the log.
MaxRecentChanges | The max number of recent changes to log.
CacheSize | The size of the cache (# of pages).
CacheCutSize | The # of pages to remove fromm the cache when it is full.
EditingSessionTimeout | The timeout, in seconds, after which a page editing session is considered to be dead.
AdministratorsGroup | The default administrators group.
UsersGroup | The default users group.
AnonymousGroup | The default anonymous users group.
ChangeModerationMode | The page change moderation mode.
DefaultPagesStorageProvider | The default pages provider.
DefaultUsersStorageProvider | The default users provider.
DefaultFilesStorageProvider | The default files provider.
DefaultCacheProvider | The default cache provider.
RootNamespaceTheme | The name of the theme of the root namespace.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.PluginFramework (Module: ScrewTurn.Wiki.PluginFramework) Version: 3.0.2.500 (3.0.2.500)


Snippet Class

Snippet Class
ScrewTurn Wiki ► ScrewTurn.Wiki.PluginFramework ► Snippet
Contains a Snippet.
Declaration Syntax
C# Visual Basic Visual C++
public class Snippet
Public Class Snippet
public ref class Snippet
Members
All Members | Constructors | Methods | Properties | Fields
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | Snippet(String, String, IPagesStorageProviderV30) | Initializes a new instance of the Snippet class.
 | content | The content of the Snippet.
 | Content | Gets or sets the Content of the Snippet.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | name | The name of the Snippet.
 | Name | Gets the Name of the Snippet.
 | provider | The Provider that handles the Snippet.
 | Provider | Gets the Provider of the Snippet.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
Snippet

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.PluginFramework (Module: ScrewTurn.Wiki.PluginFramework) Version: 3.0.2.500 (3.0.2.500)


Snippet Constructor (name, content, provider)

Snippet Constructor (name, content, provider)
ScrewTurn Wiki ► ScrewTurn.Wiki.PluginFramework ► Snippet ► Snippet(String, String, IPagesStorageProviderV30)
Initializes a new instance of the Snippet class.
Declaration Syntax
C# Visual Basic Visual C++
public Snippet(
    string name,
    string content,
    IPagesStorageProviderV30 provider
)
Public Sub New ( _
    name As String, _
    content As String, _
    provider As IPagesStorageProviderV30 _
)
public:
Snippet(
    String^ name,
    String^ content,
    IPagesStorageProviderV30^ provider
)
Parameters
name (String)
The Name of the Snippet.
content (String)
The Content of the Snippet.
provider (IPagesStorageProviderV30)
The Provider of the Snippet.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.PluginFramework (Module: ScrewTurn.Wiki.PluginFramework) Version: 3.0.2.500 (3.0.2.500)


content Field

content Field
ScrewTurn Wiki ► ScrewTurn.Wiki.PluginFramework ► Snippet ► content
The content of the Snippet.
Declaration Syntax
C# Visual Basic Visual C++
protected string content
Protected content As String
protected:
String^ content

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.PluginFramework (Module: ScrewTurn.Wiki.PluginFramework) Version: 3.0.2.500 (3.0.2.500)


Content Property

Content Property
ScrewTurn Wiki ► ScrewTurn.Wiki.PluginFramework ► Snippet ► Content
Gets or sets the Content of the Snippet.
Declaration Syntax
C# Visual Basic Visual C++
public string Content { get; }
Public ReadOnly Property Content As String
public:
property String^ Content {
    String^ get ();
}

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.PluginFramework (Module: ScrewTurn.Wiki.PluginFramework) Version: 3.0.2.500 (3.0.2.500)


name Field

name Field
ScrewTurn Wiki ► ScrewTurn.Wiki.PluginFramework ► Snippet ► name
The name of the Snippet.
Declaration Syntax
C# Visual Basic Visual C++
protected string name
Protected name As String
protected:
String^ name

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.PluginFramework (Module: ScrewTurn.Wiki.PluginFramework) Version: 3.0.2.500 (3.0.2.500)


Name Property

Name Property
ScrewTurn Wiki ► ScrewTurn.Wiki.PluginFramework ► Snippet ► Name
Gets the Name of the Snippet.
Declaration Syntax
C# Visual Basic Visual C++
public string Name { get; }
Public ReadOnly Property Name As String
public:
property String^ Name {
    String^ get ();
}

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.PluginFramework (Module: ScrewTurn.Wiki.PluginFramework) Version: 3.0.2.500 (3.0.2.500)


provider Field

provider Field
ScrewTurn Wiki ► ScrewTurn.Wiki.PluginFramework ► Snippet ► provider
The Provider that handles the Snippet.
Declaration Syntax
C# Visual Basic Visual C++
protected IPagesStorageProviderV30 provider
Protected provider As IPagesStorageProviderV30
protected:
IPagesStorageProviderV30^ provider

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.PluginFramework (Module: ScrewTurn.Wiki.PluginFramework) Version: 3.0.2.500 (3.0.2.500)


Provider Property

Provider Property
ScrewTurn Wiki ► ScrewTurn.Wiki.PluginFramework ► Snippet ► Provider
Gets the Provider of the Snippet.
Declaration Syntax
C# Visual Basic Visual C++
public IPagesStorageProviderV30 Provider { get; }
Public ReadOnly Property Provider As IPagesStorageProviderV30
public:
property IPagesStorageProviderV30^ Provider {
    IPagesStorageProviderV30^ get ();
}

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.PluginFramework (Module: ScrewTurn.Wiki.PluginFramework) Version: 3.0.2.500 (3.0.2.500)


SnippetNameComparer Class

SnippetNameComparer Class
ScrewTurn Wiki ► ScrewTurn.Wiki.PluginFramework ► SnippetNameComparer
Compares two Snippet objects.
Declaration Syntax
C# Visual Basic Visual C++
public class SnippetNameComparer : IComparer<Snippet>
Public Class SnippetNameComparer _
    Implements IComparer(Of Snippet)
public ref class SnippetNameComparer : IComparer<Snippet^>
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | SnippetNameComparer()()() | Initializes a new instance of the SnippetNameComparer class
 | Compare(Snippet, Snippet) | Compares the name of two Snippet objects.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
SnippetNameComparer

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.PluginFramework (Module: ScrewTurn.Wiki.PluginFramework) Version: 3.0.2.500 (3.0.2.500)


SnippetNameComparer Constructor

SnippetNameComparer Constructor
ScrewTurn Wiki ► ScrewTurn.Wiki.PluginFramework ► SnippetNameComparer ► SnippetNameComparer()()()
Initializes a new instance of the SnippetNameComparer class
Declaration Syntax
C# Visual Basic Visual C++
public SnippetNameComparer()
Public Sub New
public:
SnippetNameComparer()

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.PluginFramework (Module: ScrewTurn.Wiki.PluginFramework) Version: 3.0.2.500 (3.0.2.500)


Compare Method (x, y)

Compare Method (x, y)
ScrewTurn Wiki ► ScrewTurn.Wiki.PluginFramework ► SnippetNameComparer ► Compare(Snippet, Snippet)
Compares the name of two Snippet objects.
Declaration Syntax
C# Visual Basic Visual C++
public int Compare(
    Snippet x,
    Snippet y
)
Public Function Compare ( _
    x As Snippet, _
    y As Snippet _
) As Integer
public:
virtual int Compare(
    Snippet^ x,
    Snippet^ y
) sealed
Parameters
x (Snippet)
The first Snippet.
y (Snippet)
The second Snippet.
Return Value
The result of the comparison (1, 0 or -1).

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.PluginFramework (Module: ScrewTurn.Wiki.PluginFramework) Version: 3.0.2.500 (3.0.2.500)


StandardAclManager Class

StandardAclManager Class
ScrewTurn Wiki ► ScrewTurn.Wiki.PluginFramework ► StandardAclManager
Implements a standard ACL Manager.
Declaration Syntax
C# Visual Basic Visual C++
public class StandardAclManager : AclManagerBase
Public Class StandardAclManager _
    Inherits AclManagerBase
public ref class StandardAclManager : public AclManagerBase
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | StandardAclManager()()() | Initializes a new instance of the StandardAclManager class
 | AclChanged | Event fired when an ACL entry is stored or deleted. (Inherited from AclManagerBase.)
 | DeleteEntriesForResource(String) | Deletes all the ACL entries for a resource. (Inherited from AclManagerBase.)
 | DeleteEntriesForSubject(String) | Deletes all the ACL entries for a subject. (Inherited from AclManagerBase.)
 | DeleteEntry(String, String, String) | Deletes an ACL entry. (Inherited from AclManagerBase.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | InitializeData(array<AclEntry>[]()[]) | Initializes the manager data. (Inherited from AclManagerBase.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | OnAclChanged(array<AclEntry>[]()[], Change) | Handles the invokation of AclChanged event. (Inherited from AclManagerBase.)
 | RenameResource(String, String) | Renames a resource. (Inherited from AclManagerBase.)
 | RetrieveAllEntries()()() | Retrieves all the ACL entries for a resource. (Inherited from AclManagerBase.)
 | RetrieveEntriesForResource(String) | Retrieves all the ACL entries for a resource. (Inherited from AclManagerBase.)
 | RetrieveEntriesForSubject(String) | Retrieves all the ACL entries for a subject. (Inherited from AclManagerBase.)
 | StoreEntry(String, String, String, Value) | Stores a new ACL entry. (Inherited from AclManagerBase.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | TotalEntries | Gets the total number of ACL entries. (Inherited from AclManagerBase.)
Inheritance Hierarchy
Object
 | AclManagerBase
 |  | StandardAclManager

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.PluginFramework (Module: ScrewTurn.Wiki.PluginFramework) Version: 3.0.2.500 (3.0.2.500)


StandardAclManager Constructor

StandardAclManager Constructor
ScrewTurn Wiki ► ScrewTurn.Wiki.PluginFramework ► StandardAclManager ► StandardAclManager()()()
Initializes a new instance of the StandardAclManager class
Declaration Syntax
C# Visual Basic Visual C++
public StandardAclManager()
Public Sub New
public:
StandardAclManager()

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.PluginFramework (Module: ScrewTurn.Wiki.PluginFramework) Version: 3.0.2.500 (3.0.2.500)


StandardIndex Class

StandardIndex Class
ScrewTurn Wiki ► ScrewTurn.Wiki.PluginFramework ► StandardIndex
Implements a standard index class.
Declaration Syntax
C# Visual Basic Visual C++
public class StandardIndex : InMemoryIndexBase
Public Class StandardIndex _
    Inherits InMemoryIndexBase
public ref class StandardIndex : public InMemoryIndexBase
Members
All Members | Constructors | Methods | Properties | Fields | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | StandardIndex()()() | Initializes a new instance of the StandardIndex class
 | buildDocument | The BuildDocument delegate. (Inherited from InMemoryIndexBase.)
 | catalog | Contains the index catalog. (Inherited from InMemoryIndexBase.)
 | Clear(Object) | Completely clears the index (stop words are not affected). (Inherited from InMemoryIndexBase.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | IndexChanged | An event fired when the index is changed. (Inherited from InMemoryIndexBase.)
 | InitializeData(array<DumpedDocument>[]()[], array<DumpedWord>[]()[], array<DumpedWordMapping>[]()[]) | Initializes index data by completely emptying the index catalog and storing the specified data. (Inherited from InMemoryIndexBase.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | OnIndexChange(IDocument, IndexChangeType, DumpedChange, Object) | Takes care of firing the IndexChanged event. (Inherited from InMemoryIndexBase.)
 | RemoveDocument(IDocument, Object) | Removes a document from the index. (Inherited from InMemoryIndexBase.)
 | RemoveDocumentInternal(IDocument) | Removes a document from the index and generates the dumped change data. (Inherited from InMemoryIndexBase.)
 | Search(SearchParameters) | Performs a search in the index. (Inherited from InMemoryIndexBase.)
 | SetBuildDocumentDelegate(BuildDocument) | Sets the delegate used for converting a DumpedDocument to an instance of a class implementing IDocument, while reading index data from a permanent storage. (Inherited from InMemoryIndexBase.)
 | stopWords | The stop words to be used while indexing new content. (Inherited from InMemoryIndexBase.)
 | StopWords | Gets or sets the stop words to be used while indexing new content. (Inherited from InMemoryIndexBase.)
 | StoreDocument(IDocument, array<String>[]()[], String, Object) | Stores a document in the index. (Inherited from InMemoryIndexBase.)
 | StoreWord(String, IDocument, UInt16, UInt16, WordLocation, Word%, DumpedWord%) | Stores a word in the catalog. (Inherited from InMemoryIndexBase.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | TotalDocuments | Gets the total count of documents. (Inherited from InMemoryIndexBase.)
 | TotalOccurrences | Gets the total number of occurrences (count of words in each document). (Inherited from InMemoryIndexBase.)
 | TotalWords | Gets the total count of unique words. (Inherited from InMemoryIndexBase.)
Inheritance Hierarchy
Object
 | InMemoryIndexBase
 |  | StandardIndex

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.PluginFramework (Module: ScrewTurn.Wiki.PluginFramework) Version: 3.0.2.500 (3.0.2.500)


StandardIndex Constructor

StandardIndex Constructor
ScrewTurn Wiki ► ScrewTurn.Wiki.PluginFramework ► StandardIndex ► StandardIndex()()()
Initializes a new instance of the StandardIndex class
Declaration Syntax
C# Visual Basic Visual C++
public StandardIndex()
Public Sub New
public:
StandardIndex()

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.PluginFramework (Module: ScrewTurn.Wiki.PluginFramework) Version: 3.0.2.500 (3.0.2.500)


StDirectoryInfo Class

StDirectoryInfo Class
ScrewTurn Wiki ► ScrewTurn.Wiki.PluginFramework ► StDirectoryInfo
Contains information about a directory.
Declaration Syntax
C# Visual Basic Visual C++
public class StDirectoryInfo
Public Class StDirectoryInfo
public ref class StDirectoryInfo
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | StDirectoryInfo(String, IFilesStorageProviderV30) | Initializes a new instance of the StDirectoryInfo class.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | FullPath | Gets the full path of the directory, for example /dir/sub/ or /.
 | GetDirectory(String) | Gets the directory of a file.
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Provider | Gets the provider that handles the directory.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Remarks
This class is only used for provider-host communication.
Inheritance Hierarchy
Object
StDirectoryInfo

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.PluginFramework (Module: ScrewTurn.Wiki.PluginFramework) Version: 3.0.2.500 (3.0.2.500)


StDirectoryInfo Constructor (fullPath, provider)

StDirectoryInfo Constructor (fullPath, provider)
ScrewTurn Wiki ► ScrewTurn.Wiki.PluginFramework ► StDirectoryInfo ► StDirectoryInfo(String, IFilesStorageProviderV30)
Initializes a new instance of the StDirectoryInfo class.
Declaration Syntax
C# Visual Basic Visual C++
public StDirectoryInfo(
    string fullPath,
    IFilesStorageProviderV30 provider
)
Public Sub New ( _
    fullPath As String, _
    provider As IFilesStorageProviderV30 _
)
public:
StDirectoryInfo(
    String^ fullPath,
    IFilesStorageProviderV30^ provider
)
Parameters
fullPath (String)
The full path of the directory, for example /dir/sub/ or /.
provider (IFilesStorageProviderV30)
The provider that handles the directory.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.PluginFramework (Module: ScrewTurn.Wiki.PluginFramework) Version: 3.0.2.500 (3.0.2.500)


FullPath Property

FullPath Property
ScrewTurn Wiki ► ScrewTurn.Wiki.PluginFramework ► StDirectoryInfo ► FullPath
Gets the full path of the directory, for example /dir/sub/ or /.
Declaration Syntax
C# Visual Basic Visual C++
public string FullPath { get; }
Public ReadOnly Property FullPath As String
public:
property String^ FullPath {
    String^ get ();
}

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.PluginFramework (Module: ScrewTurn.Wiki.PluginFramework) Version: 3.0.2.500 (3.0.2.500)


GetDirectory Method (filePath)

GetDirectory Method (filePath)
ScrewTurn Wiki ► ScrewTurn.Wiki.PluginFramework ► StDirectoryInfo ► GetDirectory(String)
Gets the directory of a file.
Declaration Syntax
C# Visual Basic Visual C++
public static string GetDirectory(
    string filePath
)
Public Shared Function GetDirectory ( _
    filePath As String _
) As String
public:
static String^ GetDirectory(
    String^ filePath
)
Parameters
filePath (String)
The full file path, such as '/file.txt' or '/directory/sub/file.txt'.
Return Value
The directory, such as '/' or '/directory/sub/'.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.PluginFramework (Module: ScrewTurn.Wiki.PluginFramework) Version: 3.0.2.500 (3.0.2.500)


Provider Property

Provider Property
ScrewTurn Wiki ► ScrewTurn.Wiki.PluginFramework ► StDirectoryInfo ► Provider
Gets the provider that handles the directory.
Declaration Syntax
C# Visual Basic Visual C++
public IFilesStorageProviderV30 Provider { get; }
Public ReadOnly Property Provider As IFilesStorageProviderV30
public:
property IFilesStorageProviderV30^ Provider {
    IFilesStorageProviderV30^ get ();
}

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.PluginFramework (Module: ScrewTurn.Wiki.PluginFramework) Version: 3.0.2.500 (3.0.2.500)


StFileInfo Class

StFileInfo Class
ScrewTurn Wiki ► ScrewTurn.Wiki.PluginFramework ► StFileInfo
Contains information about a file.
Declaration Syntax
C# Visual Basic Visual C++
public class StFileInfo : FileDetails
Public Class StFileInfo _
    Inherits FileDetails
public ref class StFileInfo : public FileDetails
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | StFileInfo(Int64, DateTime, Int32, String, IFilesStorageProviderV30) | Initializes a new instance of the StFileInfo class.
 | StFileInfo(FileDetails, String, IFilesStorageProviderV30) | Initializes a new instance of the StFileInfo class.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | FullName | Gets the full name of the file, for example /dir/sub/file.txt or /file.txt.
 | GetDirectory()()() | Gets the directory path of the file.
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | LastModified | Gets the modification date/time. (Inherited from FileDetails.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Provider | Gets the provider that handles the file.
 | RetrievalCount | Gets the number of times the file was retrieved. (Inherited from FileDetails.)
 | Size | Gets the size of the file in bytes. (Inherited from FileDetails.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Remarks
This class is only used for provider-host communication.
Inheritance Hierarchy
Object
 | FileDetails
 |  | StFileInfo

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.PluginFramework (Module: ScrewTurn.Wiki.PluginFramework) Version: 3.0.2.500 (3.0.2.500)


StFileInfo Constructor

StFileInfo Constructor
ScrewTurn Wiki ► ScrewTurn.Wiki.PluginFramework ► StFileInfo ► StFileInfo()()()
Members
Icon | Member | Description
 | StFileInfo(Int64, DateTime, Int32, String, IFilesStorageProviderV30) | Initializes a new instance of the StFileInfo class.
 | StFileInfo(FileDetails, String, IFilesStorageProviderV30) | Initializes a new instance of the StFileInfo class.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.PluginFramework (Module: ScrewTurn.Wiki.PluginFramework) Version: 3.0.2.500 (3.0.2.500)


StFileInfo Constructor (details, fullName, provider)

StFileInfo Constructor (details, fullName, provider)
ScrewTurn Wiki ► ScrewTurn.Wiki.PluginFramework ► StFileInfo ► StFileInfo(FileDetails, String, IFilesStorageProviderV30)
Initializes a new instance of the StFileInfo class.
Declaration Syntax
C# Visual Basic Visual C++
public StFileInfo(
    FileDetails details,
    string fullName,
    IFilesStorageProviderV30 provider
)
Public Sub New ( _
    details As FileDetails, _
    fullName As String, _
    provider As IFilesStorageProviderV30 _
)
public:
StFileInfo(
    FileDetails^ details,
    String^ fullName,
    IFilesStorageProviderV30^ provider
)
Parameters
details (FileDetails)
The file details.
fullName (String)
The full name.
provider (IFilesStorageProviderV30)
The provider.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.PluginFramework (Module: ScrewTurn.Wiki.PluginFramework) Version: 3.0.2.500 (3.0.2.500)


StFileInfo Constructor (size, lastModified, downloadCount, fullName, provider)

StFileInfo Constructor (size, lastModified, downloadCount, fullName, provider)
ScrewTurn Wiki ► ScrewTurn.Wiki.PluginFramework ► StFileInfo ► StFileInfo(Int64, DateTime, Int32, String, IFilesStorageProviderV30)
Initializes a new instance of the StFileInfo class.
Declaration Syntax
C# Visual Basic Visual C++
public StFileInfo(
    long size,
    DateTime lastModified,
    int downloadCount,
    string fullName,
    IFilesStorageProviderV30 provider
)
Public Sub New ( _
    size As Long, _
    lastModified As DateTime, _
    downloadCount As Integer, _
    fullName As String, _
    provider As IFilesStorageProviderV30 _
)
public:
StFileInfo(
    long long size,
    DateTime lastModified,
    int downloadCount,
    String^ fullName,
    IFilesStorageProviderV30^ provider
)
Parameters
size (Int64)
The size of the file in bytes.
lastModified (DateTime)
The last modification date/time.
downloadCount (Int32)
The download count.
fullName (String)
The full name of the file, for example /dir/sub/file.txt or /file.txt.
provider (IFilesStorageProviderV30)
The provider that handles the file.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.PluginFramework (Module: ScrewTurn.Wiki.PluginFramework) Version: 3.0.2.500 (3.0.2.500)


FullName Property

FullName Property
ScrewTurn Wiki ► ScrewTurn.Wiki.PluginFramework ► StFileInfo ► FullName
Gets the full name of the file, for example /dir/sub/file.txt or /file.txt.
Declaration Syntax
C# Visual Basic Visual C++
public string FullName { get; }
Public ReadOnly Property FullName As String
public:
property String^ FullName {
    String^ get ();
}

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.PluginFramework (Module: ScrewTurn.Wiki.PluginFramework) Version: 3.0.2.500 (3.0.2.500)


GetDirectory Method

GetDirectory Method
ScrewTurn Wiki ► ScrewTurn.Wiki.PluginFramework ► StFileInfo ► GetDirectory()()()
Gets the directory path of the file.
Declaration Syntax
C# Visual Basic Visual C++
public string GetDirectory()
Public Function GetDirectory As String
public:
String^ GetDirectory()
Return Value
The directory path.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.PluginFramework (Module: ScrewTurn.Wiki.PluginFramework) Version: 3.0.2.500 (3.0.2.500)


Provider Property

Provider Property
ScrewTurn Wiki ► ScrewTurn.Wiki.PluginFramework ► StFileInfo ► Provider
Gets the provider that handles the file.
Declaration Syntax
C# Visual Basic Visual C++
public IFilesStorageProviderV30 Provider { get; }
Public ReadOnly Property Provider As IFilesStorageProviderV30
public:
property IFilesStorageProviderV30^ Provider {
    IFilesStorageProviderV30^ get ();
}

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.PluginFramework (Module: ScrewTurn.Wiki.PluginFramework) Version: 3.0.2.500 (3.0.2.500)


Tokenizer Delegate

Tokenizer Delegate
ScrewTurn Wiki ► ScrewTurn.Wiki.PluginFramework ► Tokenizer
Defines a delegate that tokenizes strings.
Declaration Syntax
C# Visual Basic Visual C++
public delegate WordInfo[] Tokenizer(
    string content
)
Public Delegate Function Tokenizer ( _
    content As String _
) As WordInfo()
public delegate array<WordInfo^>^ Tokenizer(
    String^ content
)
Parameters
content (String)
The content to tokenize.
Return Value
The tokenized words.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.PluginFramework (Module: ScrewTurn.Wiki.PluginFramework) Version: 3.0.2.500 (3.0.2.500)


ToolbarItem Enumeration

ToolbarItem Enumeration
ScrewTurn Wiki ► ScrewTurn.Wiki.PluginFramework ► ToolbarItem
Enumerates the toolbar items that can be added.
Declaration Syntax
C# Visual Basic Visual C++
public enum ToolbarItem
Public Enumeration ToolbarItem
public enum class ToolbarItem
Members
Member | Description
SpecialTag | A Special Tag that is inserted in the text.
SpecialTagWrap | A special tag that wraps the selected text.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.PluginFramework (Module: ScrewTurn.Wiki.PluginFramework) Version: 3.0.2.500 (3.0.2.500)


UserAccountActivity Enumeration

UserAccountActivity Enumeration
ScrewTurn Wiki ► ScrewTurn.Wiki.PluginFramework ► UserAccountActivity
Lists legal User Account Activity types.
Declaration Syntax
C# Visual Basic Visual C++
public enum UserAccountActivity
Public Enumeration UserAccountActivity
public enum class UserAccountActivity
Members
Member | Description
AccountAdded | A user account has been added.
AccountActivated | A user account has been activated.
AccountDeactivated | A user account has been deactivated.
AccountModified | A user account has been modified (email, password).
AccountRemoved | A user account has been removed.
AccountMembershipChanged | A user account group membership has been changed.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.PluginFramework (Module: ScrewTurn.Wiki.PluginFramework) Version: 3.0.2.500 (3.0.2.500)


UserAccountActivityEventArgs Class

UserAccountActivityEventArgs Class
ScrewTurn Wiki ► ScrewTurn.Wiki.PluginFramework ► UserAccountActivityEventArgs
Contains arguments for User Account Activity events.
Declaration Syntax
C# Visual Basic Visual C++
public class UserAccountActivityEventArgs : EventArgs
Public Class UserAccountActivityEventArgs _
    Inherits EventArgs
public ref class UserAccountActivityEventArgs : public EventArgs
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | UserAccountActivityEventArgs(UserInfo, UserAccountActivity) | Initializes a new instance of the UserAccountActivityEventArgs class.
 | Activity | Gets the activity performed.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | User | Gets the user the activity refers to.
Inheritance Hierarchy
Object
 | EventArgs
 |  | UserAccountActivityEventArgs

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.PluginFramework (Module: ScrewTurn.Wiki.PluginFramework) Version: 3.0.2.500 (3.0.2.500)


UserAccountActivityEventArgs Constructor (user, activity)

UserAccountActivityEventArgs Constructor (user, activity)
ScrewTurn Wiki ► ScrewTurn.Wiki.PluginFramework ► UserAccountActivityEventArgs ► UserAccountActivityEventArgs(UserInfo, UserAccountActivity)
Initializes a new instance of the UserAccountActivityEventArgs class.
Declaration Syntax
C# Visual Basic Visual C++
public UserAccountActivityEventArgs(
    UserInfo user,
    UserAccountActivity activity
)
Public Sub New ( _
    user As UserInfo, _
    activity As UserAccountActivity _
)
public:
UserAccountActivityEventArgs(
    UserInfo^ user,
    UserAccountActivity activity
)
Parameters
user (UserInfo)
The User Info the activity refers to.
activity (UserAccountActivity)
The activity performed.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.PluginFramework (Module: ScrewTurn.Wiki.PluginFramework) Version: 3.0.2.500 (3.0.2.500)


Activity Property

Activity Property
ScrewTurn Wiki ► ScrewTurn.Wiki.PluginFramework ► UserAccountActivityEventArgs ► Activity
Gets the activity performed.
Declaration Syntax
C# Visual Basic Visual C++
public UserAccountActivity Activity { get; }
Public ReadOnly Property Activity As UserAccountActivity
public:
property UserAccountActivity Activity {
    UserAccountActivity get ();
}

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.PluginFramework (Module: ScrewTurn.Wiki.PluginFramework) Version: 3.0.2.500 (3.0.2.500)


User Property

User Property
ScrewTurn Wiki ► ScrewTurn.Wiki.PluginFramework ► UserAccountActivityEventArgs ► User
Gets the user the activity refers to.
Declaration Syntax
C# Visual Basic Visual C++
public UserInfo User { get; }
Public ReadOnly Property User As UserInfo
public:
property UserInfo^ User {
    UserInfo^ get ();
}

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.PluginFramework (Module: ScrewTurn.Wiki.PluginFramework) Version: 3.0.2.500 (3.0.2.500)


UserGroup Class

UserGroup Class
ScrewTurn Wiki ► ScrewTurn.Wiki.PluginFramework ► UserGroup
Represents a group of users.
Declaration Syntax
C# Visual Basic Visual C++
public class UserGroup
Public Class UserGroup
public ref class UserGroup
Members
All Members | Constructors | Methods | Properties | Fields
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | UserGroup(String, String, IUsersStorageProviderV30) | Initializes a new instance of the UserGroup class.
 | description | The group description.
 | Description | Gets or sets the description of the group.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | name | The group name.
 | Name | Gets or sets the name of the user group.
 | provider | The provider that handles the user group.
 | Provider | Gets or sets the provider that handles the user group.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | users | The users in the group.
 | Users | Gets or sets the users in the group.
Inheritance Hierarchy
Object
UserGroup

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.PluginFramework (Module: ScrewTurn.Wiki.PluginFramework) Version: 3.0.2.500 (3.0.2.500)


UserGroup Constructor (name, description, provider)

UserGroup Constructor (name, description, provider)
ScrewTurn Wiki ► ScrewTurn.Wiki.PluginFramework ► UserGroup ► UserGroup(String, String, IUsersStorageProviderV30)
Initializes a new instance of the UserGroup class.
Declaration Syntax
C# Visual Basic Visual C++
public UserGroup(
    string name,
    string description,
    IUsersStorageProviderV30 provider
)
Public Sub New ( _
    name As String, _
    description As String, _
    provider As IUsersStorageProviderV30 _
)
public:
UserGroup(
    String^ name,
    String^ description,
    IUsersStorageProviderV30^ provider
)
Parameters
name (String)
The name of the group.
description (String)
The description of the group.
provider (IUsersStorageProviderV30)
The Users Storage Provider that handles the user group.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.PluginFramework (Module: ScrewTurn.Wiki.PluginFramework) Version: 3.0.2.500 (3.0.2.500)


description Field

description Field
ScrewTurn Wiki ► ScrewTurn.Wiki.PluginFramework ► UserGroup ► description
The group description.
Declaration Syntax
C# Visual Basic Visual C++
protected string description
Protected description As String
protected:
String^ description

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.PluginFramework (Module: ScrewTurn.Wiki.PluginFramework) Version: 3.0.2.500 (3.0.2.500)


Description Property

Description Property
ScrewTurn Wiki ► ScrewTurn.Wiki.PluginFramework ► UserGroup ► Description
Gets or sets the description of the group.
Declaration Syntax
C# Visual Basic Visual C++
public string Description { get; set; }
Public Property Description As String
public:
property String^ Description {
    String^ get ();
    void set (String^ value);
}

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.PluginFramework (Module: ScrewTurn.Wiki.PluginFramework) Version: 3.0.2.500 (3.0.2.500)


name Field

name Field
ScrewTurn Wiki ► ScrewTurn.Wiki.PluginFramework ► UserGroup ► name
The group name.
Declaration Syntax
C# Visual Basic Visual C++
protected string name
Protected name As String
protected:
String^ name

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.PluginFramework (Module: ScrewTurn.Wiki.PluginFramework) Version: 3.0.2.500 (3.0.2.500)


Name Property

Name Property
ScrewTurn Wiki ► ScrewTurn.Wiki.PluginFramework ► UserGroup ► Name
Gets or sets the name of the user group.
Declaration Syntax
C# Visual Basic Visual C++
public string Name { get; set; }
Public Property Name As String
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.PluginFramework (Module: ScrewTurn.Wiki.PluginFramework) Version: 3.0.2.500 (3.0.2.500)


provider Field

provider Field
ScrewTurn Wiki ► ScrewTurn.Wiki.PluginFramework ► UserGroup ► provider
The provider that handles the user group.
Declaration Syntax
C# Visual Basic Visual C++
protected IUsersStorageProviderV30 provider
Protected provider As IUsersStorageProviderV30
protected:
IUsersStorageProviderV30^ provider

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.PluginFramework (Module: ScrewTurn.Wiki.PluginFramework) Version: 3.0.2.500 (3.0.2.500)


Provider Property

Provider Property
ScrewTurn Wiki ► ScrewTurn.Wiki.PluginFramework ► UserGroup ► Provider
Gets or sets the provider that handles the user group.
Declaration Syntax
C# Visual Basic Visual C++
public IUsersStorageProviderV30 Provider { get; set; }
Public Property Provider As IUsersStorageProviderV30
public:
property IUsersStorageProviderV30^ Provider {
    IUsersStorageProviderV30^ get ();
    void set (IUsersStorageProviderV30^ value);
}

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.PluginFramework (Module: ScrewTurn.Wiki.PluginFramework) Version: 3.0.2.500 (3.0.2.500)


users Field

users Field
ScrewTurn Wiki ► ScrewTurn.Wiki.PluginFramework ► UserGroup ► users
The users in the group.
Declaration Syntax
C# Visual Basic Visual C++
protected string[] users
Protected users As String()
protected:
array<String^>^ users

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.PluginFramework (Module: ScrewTurn.Wiki.PluginFramework) Version: 3.0.2.500 (3.0.2.500)


Users Property

Users Property
ScrewTurn Wiki ► ScrewTurn.Wiki.PluginFramework ► UserGroup ► Users
Gets or sets the users in the group.
Declaration Syntax
C# Visual Basic Visual C++
public string[] Users { get; set; }
Public Property Users As String()
public:
property array<String^>^ Users {
    array<String^>^ get ();
    void set (array<String^>^ value);
}

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.PluginFramework (Module: ScrewTurn.Wiki.PluginFramework) Version: 3.0.2.500 (3.0.2.500)


UserGroupActivity Enumeration

UserGroupActivity Enumeration
ScrewTurn Wiki ► ScrewTurn.Wiki.PluginFramework ► UserGroupActivity
Lists legal user group activity types.
Declaration Syntax
C# Visual Basic Visual C++
public enum UserGroupActivity
Public Enumeration UserGroupActivity
public enum class UserGroupActivity
Members
Member | Description
GroupAdded | A group has been added.
GroupRemoved | A group has been removed.
GroupModified | A group has been modified.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.PluginFramework (Module: ScrewTurn.Wiki.PluginFramework) Version: 3.0.2.500 (3.0.2.500)


UserGroupActivityEventArgs Class

UserGroupActivityEventArgs Class
ScrewTurn Wiki ► ScrewTurn.Wiki.PluginFramework ► UserGroupActivityEventArgs
Contains arguments for the User Group Activity events.
Declaration Syntax
C# Visual Basic Visual C++
public class UserGroupActivityEventArgs : EventArgs
Public Class UserGroupActivityEventArgs _
    Inherits EventArgs
public ref class UserGroupActivityEventArgs : public EventArgs
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | UserGroupActivityEventArgs(UserGroup, UserGroupActivity) | Initializes a new instance of the UserGroupActivityEventArgs class.
 | Activity | Gets the activity performed.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | Group | Gets the user group the activity refers to.
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | EventArgs
 |  | UserGroupActivityEventArgs

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.PluginFramework (Module: ScrewTurn.Wiki.PluginFramework) Version: 3.0.2.500 (3.0.2.500)


UserGroupActivityEventArgs Constructor (group, activity)

UserGroupActivityEventArgs Constructor (group, activity)
ScrewTurn Wiki ► ScrewTurn.Wiki.PluginFramework ► UserGroupActivityEventArgs ► UserGroupActivityEventArgs(UserGroup, UserGroupActivity)
Initializes a new instance of the UserGroupActivityEventArgs class.
Declaration Syntax
C# Visual Basic Visual C++
public UserGroupActivityEventArgs(
    UserGroup group,
    UserGroupActivity activity
)
Public Sub New ( _
    group As UserGroup, _
    activity As UserGroupActivity _
)
public:
UserGroupActivityEventArgs(
    UserGroup^ group,
    UserGroupActivity activity
)
Parameters
group (UserGroup)
The user group the activity refers to.
activity (UserGroupActivity)
The activity performed.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.PluginFramework (Module: ScrewTurn.Wiki.PluginFramework) Version: 3.0.2.500 (3.0.2.500)


Activity Property

Activity Property
ScrewTurn Wiki ► ScrewTurn.Wiki.PluginFramework ► UserGroupActivityEventArgs ► Activity
Gets the activity performed.
Declaration Syntax
C# Visual Basic Visual C++
public UserGroupActivity Activity { get; }
Public ReadOnly Property Activity As UserGroupActivity
public:
property UserGroupActivity Activity {
    UserGroupActivity get ();
}

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.PluginFramework (Module: ScrewTurn.Wiki.PluginFramework) Version: 3.0.2.500 (3.0.2.500)


Group Property

Group Property
ScrewTurn Wiki ► ScrewTurn.Wiki.PluginFramework ► UserGroupActivityEventArgs ► Group
Gets the user group the activity refers to.
Declaration Syntax
C# Visual Basic Visual C++
public UserGroup Group { get; }
Public ReadOnly Property Group As UserGroup
public:
property UserGroup^ Group {
    UserGroup^ get ();
}

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.PluginFramework (Module: ScrewTurn.Wiki.PluginFramework) Version: 3.0.2.500 (3.0.2.500)


UserGroupComparer Class

UserGroupComparer Class
ScrewTurn Wiki ► ScrewTurn.Wiki.PluginFramework ► UserGroupComparer
Implements a comparer for UserGroup objects, using Name as parameter.
Declaration Syntax
C# Visual Basic Visual C++
public class UserGroupComparer : IComparer<UserGroup>
Public Class UserGroupComparer _
    Implements IComparer(Of UserGroup)
public ref class UserGroupComparer : IComparer<UserGroup^>
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | UserGroupComparer()()() | Initializes a new instance of the UserGroupComparer class
 | Compare(UserGroup, UserGroup) | Compares two UserGroup objects, using Name as parameter.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
UserGroupComparer

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.PluginFramework (Module: ScrewTurn.Wiki.PluginFramework) Version: 3.0.2.500 (3.0.2.500)


UserGroupComparer Constructor

UserGroupComparer Constructor
ScrewTurn Wiki ► ScrewTurn.Wiki.PluginFramework ► UserGroupComparer ► UserGroupComparer()()()
Initializes a new instance of the UserGroupComparer class
Declaration Syntax
C# Visual Basic Visual C++
public UserGroupComparer()
Public Sub New
public:
UserGroupComparer()

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.PluginFramework (Module: ScrewTurn.Wiki.PluginFramework) Version: 3.0.2.500 (3.0.2.500)


Compare Method (x, y)

Compare Method (x, y)
ScrewTurn Wiki ► ScrewTurn.Wiki.PluginFramework ► UserGroupComparer ► Compare(UserGroup, UserGroup)
Compares two UserGroup objects, using Name as parameter.
Declaration Syntax
C# Visual Basic Visual C++
public int Compare(
    UserGroup x,
    UserGroup y
)
Public Function Compare ( _
    x As UserGroup, _
    y As UserGroup _
) As Integer
public:
virtual int Compare(
    UserGroup^ x,
    UserGroup^ y
) sealed
Parameters
x (UserGroup)
The first object.
y (UserGroup)
The second object.
Return Value
The comparison result.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.PluginFramework (Module: ScrewTurn.Wiki.PluginFramework) Version: 3.0.2.500 (3.0.2.500)


UserInfo Class

UserInfo Class
ScrewTurn Wiki ► ScrewTurn.Wiki.PluginFramework ► UserInfo
Describes a User.
Declaration Syntax
C# Visual Basic Visual C++
public class UserInfo
Public Class UserInfo
public ref class UserInfo
Members
All Members | Constructors | Methods | Properties | Fields
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | UserInfo(String, String, String, Boolean, DateTime, IUsersStorageProviderV30) | Initializes a new instance of the UserInfo class.
 | active | A value indicating whether the user account is active.
 | Active | Gets or sets a value specifying whether the Account is active or not.
 | dateTime | The account creation date/time.
 | DateTime | Gets the creation DateTime.
 | displayName | The display name of the User.
 | DisplayName | Gets or sets the display name.
 | email | The Email address of the User.
 | Email | Gets or sets the Email.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | groups | The names of the groups the user is member of.
 | Groups | Gets or sets the names of the groups the user is member of.
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | provider | The Provider that handles the User.
 | Provider | Gets or sets the Users Storage Provider.
 | ToString()()() | Converts the current instance to a string. (Overrides Object.ToString()()().)
 | username | The Username of the User.
 | Username | Gets the Username.
Inheritance Hierarchy
Object
 | UserInfo
 |  | LocalUserInfo

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.PluginFramework (Module: ScrewTurn.Wiki.PluginFramework) Version: 3.0.2.500 (3.0.2.500)


UserInfo Constructor (username, displayName, email, active, dateTime, provider)

UserInfo Constructor (username, displayName, email, active, dateTime, provider)
ScrewTurn Wiki ► ScrewTurn.Wiki.PluginFramework ► UserInfo ► UserInfo(String, String, String, Boolean, DateTime, IUsersStorageProviderV30)
Initializes a new instance of the UserInfo class.
Declaration Syntax
C# Visual Basic Visual C++
public UserInfo(
    string username,
    string displayName,
    string email,
    bool active,
    DateTime dateTime,
    IUsersStorageProviderV30 provider
)
Public Sub New ( _
    username As String, _
    displayName As String, _
    email As String, _
    active As Boolean, _
    dateTime As DateTime, _
    provider As IUsersStorageProviderV30 _
)
public:
UserInfo(
    String^ username,
    String^ displayName,
    String^ email,
    bool active,
    DateTime dateTime,
    IUsersStorageProviderV30^ provider
)
Parameters
username (String)
The Username.
displayName (String)
The display name.
email (String)
The Email.
active (Boolean)
Specifies whether the Account is active or not.
dateTime (DateTime)
The creation DateTime.
provider (IUsersStorageProviderV30)
The Users Storage Provider that manages the User.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.PluginFramework (Module: ScrewTurn.Wiki.PluginFramework) Version: 3.0.2.500 (3.0.2.500)


active Field

active Field
ScrewTurn Wiki ► ScrewTurn.Wiki.PluginFramework ► UserInfo ► active
A value indicating whether the user account is active.
Declaration Syntax
C# Visual Basic Visual C++
protected bool active
Protected active As Boolean
protected:
bool active

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.PluginFramework (Module: ScrewTurn.Wiki.PluginFramework) Version: 3.0.2.500 (3.0.2.500)


Active Property

Active Property
ScrewTurn Wiki ► ScrewTurn.Wiki.PluginFramework ► UserInfo ► Active
Gets or sets a value specifying whether the Account is active or not.
Declaration Syntax
C# Visual Basic Visual C++
public bool Active { get; set; }
Public Property Active As Boolean
public:
property bool Active {
    bool get ();
    void set (bool value);
}

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.PluginFramework (Module: ScrewTurn.Wiki.PluginFramework) Version: 3.0.2.500 (3.0.2.500)


dateTime Field

dateTime Field
ScrewTurn Wiki ► ScrewTurn.Wiki.PluginFramework ► UserInfo ► dateTime
The account creation date/time.
Declaration Syntax
C# Visual Basic Visual C++
protected DateTime dateTime
Protected dateTime As DateTime
protected:
DateTime dateTime

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.PluginFramework (Module: ScrewTurn.Wiki.PluginFramework) Version: 3.0.2.500 (3.0.2.500)


DateTime Property

DateTime Property
ScrewTurn Wiki ► ScrewTurn.Wiki.PluginFramework ► UserInfo ► DateTime
Gets the creation DateTime.
Declaration Syntax
C# Visual Basic Visual C++
public DateTime DateTime { get; set; }
Public Property DateTime As DateTime
public:
property DateTime DateTime {
    DateTime get ();
    void set (DateTime value);
}

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.PluginFramework (Module: ScrewTurn.Wiki.PluginFramework) Version: 3.0.2.500 (3.0.2.500)


displayName Field

displayName Field
ScrewTurn Wiki ► ScrewTurn.Wiki.PluginFramework ► UserInfo ► displayName
The display name of the User.
Declaration Syntax
C# Visual Basic Visual C++
protected string displayName
Protected displayName As String
protected:
String^ displayName

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.PluginFramework (Module: ScrewTurn.Wiki.PluginFramework) Version: 3.0.2.500 (3.0.2.500)


DisplayName Property

DisplayName Property
ScrewTurn Wiki ► ScrewTurn.Wiki.PluginFramework ► UserInfo ► DisplayName
Gets or sets the display name.
Declaration Syntax
C# Visual Basic Visual C++
public string DisplayName { get; set; }
Public Property DisplayName As String
public:
property String^ DisplayName {
    String^ get ();
    void set (String^ value);
}

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.PluginFramework (Module: ScrewTurn.Wiki.PluginFramework) Version: 3.0.2.500 (3.0.2.500)


email Field

email Field
ScrewTurn Wiki ► ScrewTurn.Wiki.PluginFramework ► UserInfo ► email
The Email address of the User.
Declaration Syntax
C# Visual Basic Visual C++
protected string email
Protected email As String
protected:
String^ email

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.PluginFramework (Module: ScrewTurn.Wiki.PluginFramework) Version: 3.0.2.500 (3.0.2.500)


Email Property

Email Property
ScrewTurn Wiki ► ScrewTurn.Wiki.PluginFramework ► UserInfo ► Email
Gets or sets the Email.
Declaration Syntax
C# Visual Basic Visual C++
public string Email { get; set; }
Public Property Email As String
public:
property String^ Email {
    String^ get ();
    void set (String^ value);
}

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.PluginFramework (Module: ScrewTurn.Wiki.PluginFramework) Version: 3.0.2.500 (3.0.2.500)


groups Field

groups Field
ScrewTurn Wiki ► ScrewTurn.Wiki.PluginFramework ► UserInfo ► groups
The names of the groups the user is member of.
Declaration Syntax
C# Visual Basic Visual C++
protected string[] groups
Protected groups As String()
protected:
array<String^>^ groups

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.PluginFramework (Module: ScrewTurn.Wiki.PluginFramework) Version: 3.0.2.500 (3.0.2.500)


Groups Property

Groups Property
ScrewTurn Wiki ► ScrewTurn.Wiki.PluginFramework ► UserInfo ► Groups
Gets or sets the names of the groups the user is member of.
Declaration Syntax
C# Visual Basic Visual C++
public string[] Groups { get; set; }
Public Property Groups As String()
public:
property array<String^>^ Groups {
    array<String^>^ get ();
    void set (array<String^>^ value);
}

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.PluginFramework (Module: ScrewTurn.Wiki.PluginFramework) Version: 3.0.2.500 (3.0.2.500)


provider Field

provider Field
ScrewTurn Wiki ► ScrewTurn.Wiki.PluginFramework ► UserInfo ► provider
The Provider that handles the User.
Declaration Syntax
C# Visual Basic Visual C++
protected IUsersStorageProviderV30 provider
Protected provider As IUsersStorageProviderV30
protected:
IUsersStorageProviderV30^ provider

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.PluginFramework (Module: ScrewTurn.Wiki.PluginFramework) Version: 3.0.2.500 (3.0.2.500)


Provider Property

Provider Property
ScrewTurn Wiki ► ScrewTurn.Wiki.PluginFramework ► UserInfo ► Provider
Gets or sets the Users Storage Provider.
Declaration Syntax
C# Visual Basic Visual C++
public IUsersStorageProviderV30 Provider { get; set; }
Public Property Provider As IUsersStorageProviderV30
public:
property IUsersStorageProviderV30^ Provider {
    IUsersStorageProviderV30^ get ();
    void set (IUsersStorageProviderV30^ value);
}

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.PluginFramework (Module: ScrewTurn.Wiki.PluginFramework) Version: 3.0.2.500 (3.0.2.500)


ToString Method

ToString Method
ScrewTurn Wiki ► ScrewTurn.Wiki.PluginFramework ► UserInfo ► ToString()()()
Converts the current instance to a string.
Declaration Syntax
C# Visual Basic Visual C++
public override string ToString()
Public Overrides Function ToString As String
public:
virtual String^ ToString() override
Return Value
The string.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.PluginFramework (Module: ScrewTurn.Wiki.PluginFramework) Version: 3.0.2.500 (3.0.2.500)


username Field

username Field
ScrewTurn Wiki ► ScrewTurn.Wiki.PluginFramework ► UserInfo ► username
The Username of the User.
Declaration Syntax
C# Visual Basic Visual C++
protected string username
Protected username As String
protected:
String^ username

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.PluginFramework (Module: ScrewTurn.Wiki.PluginFramework) Version: 3.0.2.500 (3.0.2.500)


Username Property

Username Property
ScrewTurn Wiki ► ScrewTurn.Wiki.PluginFramework ► UserInfo ► Username
Gets the Username.
Declaration Syntax
C# Visual Basic Visual C++
public string Username { get; }
Public ReadOnly Property Username As String
public:
property String^ Username {
    String^ get ();
}

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.PluginFramework (Module: ScrewTurn.Wiki.PluginFramework) Version: 3.0.2.500 (3.0.2.500)


UsernameComparer Class

UsernameComparer Class
ScrewTurn Wiki ► ScrewTurn.Wiki.PluginFramework ► UsernameComparer
Provides a method for comparing two UserInfo objects, comparing their Username.
Declaration Syntax
C# Visual Basic Visual C++
public class UsernameComparer : IComparer<UserInfo>
Public Class UsernameComparer _
    Implements IComparer(Of UserInfo)
public ref class UsernameComparer : IComparer<UserInfo^>
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | UsernameComparer()()() | Initializes a new instance of the UsernameComparer class
 | Compare(UserInfo, UserInfo) | Compares two UserInfo objects, comparing their Username.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Remarks
The comparison is case unsensitive.
Inheritance Hierarchy
Object
UsernameComparer

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.PluginFramework (Module: ScrewTurn.Wiki.PluginFramework) Version: 3.0.2.500 (3.0.2.500)


UsernameComparer Constructor

UsernameComparer Constructor
ScrewTurn Wiki ► ScrewTurn.Wiki.PluginFramework ► UsernameComparer ► UsernameComparer()()()
Initializes a new instance of the UsernameComparer class
Declaration Syntax
C# Visual Basic Visual C++
public UsernameComparer()
Public Sub New
public:
UsernameComparer()

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.PluginFramework (Module: ScrewTurn.Wiki.PluginFramework) Version: 3.0.2.500 (3.0.2.500)


Compare Method (x, y)

Compare Method (x, y)
ScrewTurn Wiki ► ScrewTurn.Wiki.PluginFramework ► UsernameComparer ► Compare(UserInfo, UserInfo)
Compares two UserInfo objects, comparing their Username.
Declaration Syntax
C# Visual Basic Visual C++
public int Compare(
    UserInfo x,
    UserInfo y
)
Public Function Compare ( _
    x As UserInfo, _
    y As UserInfo _
) As Integer
public:
virtual int Compare(
    UserInfo^ x,
    UserInfo^ y
) sealed
Parameters
x (UserInfo)
The first object.
y (UserInfo)
The second object.
Return Value
The comparison result (-1, 0 or 1).

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.PluginFramework (Module: ScrewTurn.Wiki.PluginFramework) Version: 3.0.2.500 (3.0.2.500)


ScrewTurn.Wiki.Plugins.ActiveDirectory Namespace

ScrewTurn.Wiki.Plugins.ActiveDirectory Namespace
ScrewTurn Wiki ► ScrewTurn.Wiki.Plugins.ActiveDirectory
Namespace containing Active Directory Provider types.
Declaration Syntax
C# Visual Basic Visual C++
namespace ScrewTurn.Wiki.Plugins.ActiveDirectory
Namespace ScrewTurn.Wiki.Plugins.ActiveDirectory
namespace ScrewTurn.Wiki.Plugins.ActiveDirectory
Types
All Types Classes
Icon | Type | Description
 | ActiveDirectoryProvider | Implements a Users Storage Provider for Active Directory.


ActiveDirectoryProvider Class

ActiveDirectoryProvider Class
ScrewTurn Wiki ► ScrewTurn.Wiki.Plugins.ActiveDirectory ► ActiveDirectoryProvider
Implements a Users Storage Provider for Active Directory.
Declaration Syntax
C# Visual Basic Visual C++
public class ActiveDirectoryProvider
Public Class ActiveDirectoryProvider
public ref class ActiveDirectoryProvider
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ActiveDirectoryProvider()()() | Initializes a new instance of the ActiveDirectoryProvider class
 | AddUser(String, String, String, String, Boolean, DateTime) | Not Implemented
 | AddUserGroup(String, String) | Not Implemented
 | ConfigHelpHtml | Plugin Help Text
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetUser(String) | Gets the user info object for the currently logged in user.
 | GetUserByEmail(String) | Not Implemented - Passed Directly to the IUsersStorageProviderV30
 | GetUserGroups()()() | Not Implemented
 | GetUsers()()() | Not Implemented
 | GetUsersWithData(String) | Not Implemented - Passed Directly to the IUsersStorageProviderV30
 | GroupMembershipReadOnly | True, always, we can't write back to AD
 | Information | Plugin Information TODO return and complete
 | Init(IHostV30, String) | Inits the settings
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ModifyUser(UserInfo, String, String, String, Boolean) | Not Implemented
 | ModifyUserGroup(UserGroup, String) | Not Implemented
 | NotifyCookieLogin(UserInfo) | Not Implemented - Passed Directly to the IUsersStorageProviderV30
 | NotifyLogout(UserInfo) | Not Implemented - Passed Directly to the IUsersStorageProviderV30
 | RemoveUser(UserInfo) | Not Implemented
 | RemoveUserGroup(UserGroup) | Not Implemented
 | RetrieveAllUserData(UserInfo) | Not Implemented - Passed Directly to the IUsersStorageProviderV30
 | RetrieveUserData(UserInfo, String) | Not Implemented - Passed Directly to the IUsersStorageProviderV30
 | SetUserMembership(UserInfo, array<String>[]()[]) | Not Implemented
 | Shutdown()()() | Ignored
 | StoreUserData(UserInfo, String, String) | Not Implemented - Passed Directly to the IUsersStorageProviderV30
 | TestAccount(UserInfo, String) | Not Implemented
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | TryAutoLogin(HttpContext) | Tries to log the user in automagically
 | TryManualLogin(String, String) | Tries to log the user in manually
 | UserAccountsReadOnly | True, always, we can't write back to AD
 | UserGroupsReadOnly | No
 | UsersDataReadOnly | True, always, we can't write back to AD
Inheritance Hierarchy
Object
ActiveDirectoryProvider

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ActiveDirectoryProvider (Module: ActiveDirectoryProvider) Version: 3.0.2.500 (3.0.2.500)


ActiveDirectoryProvider Constructor

ActiveDirectoryProvider Constructor
ScrewTurn Wiki ► ScrewTurn.Wiki.Plugins.ActiveDirectory ► ActiveDirectoryProvider ► ActiveDirectoryProvider()()()
Initializes a new instance of the ActiveDirectoryProvider class
Declaration Syntax
C# Visual Basic Visual C++
public ActiveDirectoryProvider()
Public Sub New
public:
ActiveDirectoryProvider()

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ActiveDirectoryProvider (Module: ActiveDirectoryProvider) Version: 3.0.2.500 (3.0.2.500)


AddUser Method (username, displayName, password, email, active, dateTime)

AddUser Method (username, displayName, password, email, active, dateTime)
ScrewTurn Wiki ► ScrewTurn.Wiki.Plugins.ActiveDirectory ► ActiveDirectoryProvider ► AddUser(String, String, String, String, Boolean, DateTime)
Not Implemented
Declaration Syntax
C# Visual Basic Visual C++
public UserInfo AddUser(
    string username,
    string displayName,
    string password,
    string email,
    bool active,
    DateTime dateTime
)
Public Function AddUser ( _
    username As String, _
    displayName As String, _
    password As String, _
    email As String, _
    active As Boolean, _
    dateTime As DateTime _
) As UserInfo
public:
UserInfo^ AddUser(
    String^ username,
    String^ displayName,
    String^ password,
    String^ email,
    bool active,
    DateTime dateTime
)
Parameters
username (String)

[Missing <param name="username"/> documentation for "M:ScrewTurn.Wiki.Plugins.ActiveDirectory.ActiveDirectoryProvider.AddUser(System.String,System.String,System.String,System.String,System.Boolean,System.DateTime)"]

displayName (String)

[Missing <param name="displayName"/> documentation for "M:ScrewTurn.Wiki.Plugins.ActiveDirectory.ActiveDirectoryProvider.AddUser(System.String,System.String,System.String,System.String,System.Boolean,System.DateTime)"]

password (String)

[Missing <param name="password"/> documentation for "M:ScrewTurn.Wiki.Plugins.ActiveDirectory.ActiveDirectoryProvider.AddUser(System.String,System.String,System.String,System.String,System.Boolean,System.DateTime)"]

email (String)

[Missing <param name="email"/> documentation for "M:ScrewTurn.Wiki.Plugins.ActiveDirectory.ActiveDirectoryProvider.AddUser(System.String,System.String,System.String,System.String,System.Boolean,System.DateTime)"]

active (Boolean)

[Missing <param name="active"/> documentation for "M:ScrewTurn.Wiki.Plugins.ActiveDirectory.ActiveDirectoryProvider.AddUser(System.String,System.String,System.String,System.String,System.Boolean,System.DateTime)"]

dateTime (DateTime)

[Missing <param name="dateTime"/> documentation for "M:ScrewTurn.Wiki.Plugins.ActiveDirectory.ActiveDirectoryProvider.AddUser(System.String,System.String,System.String,System.String,System.Boolean,System.DateTime)"]

Return Value

[Missing <returns> documentation for "M:ScrewTurn.Wiki.Plugins.ActiveDirectory.ActiveDirectoryProvider.AddUser(System.String,System.String,System.String,System.String,System.Boolean,System.DateTime)"]

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ActiveDirectoryProvider (Module: ActiveDirectoryProvider) Version: 3.0.2.500 (3.0.2.500)


AddUserGroup Method (name, description)

AddUserGroup Method (name, description)
ScrewTurn Wiki ► ScrewTurn.Wiki.Plugins.ActiveDirectory ► ActiveDirectoryProvider ► AddUserGroup(String, String)
Not Implemented
Declaration Syntax
C# Visual Basic Visual C++
public UserGroup AddUserGroup(
    string name,
    string description
)
Public Function AddUserGroup ( _
    name As String, _
    description As String _
) As UserGroup
public:
UserGroup^ AddUserGroup(
    String^ name,
    String^ description
)
Parameters
name (String)

[Missing <param name="name"/> documentation for "M:ScrewTurn.Wiki.Plugins.ActiveDirectory.ActiveDirectoryProvider.AddUserGroup(System.String,System.String)"]

description (String)

[Missing <param name="description"/> documentation for "M:ScrewTurn.Wiki.Plugins.ActiveDirectory.ActiveDirectoryProvider.AddUserGroup(System.String,System.String)"]

Return Value

[Missing <returns> documentation for "M:ScrewTurn.Wiki.Plugins.ActiveDirectory.ActiveDirectoryProvider.AddUserGroup(System.String,System.String)"]

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ActiveDirectoryProvider (Module: ActiveDirectoryProvider) Version: 3.0.2.500 (3.0.2.500)


ConfigHelpHtml Property

ConfigHelpHtml Property
ScrewTurn Wiki ► ScrewTurn.Wiki.Plugins.ActiveDirectory ► ActiveDirectoryProvider ► ConfigHelpHtml
Plugin Help Text
Declaration Syntax
C# Visual Basic Visual C++
public string ConfigHelpHtml { get; }
Public ReadOnly Property ConfigHelpHtml As String
public:
property String^ ConfigHelpHtml {
    String^ get ();
}

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ActiveDirectoryProvider (Module: ActiveDirectoryProvider) Version: 3.0.2.500 (3.0.2.500)


GetUser Method (username)

GetUser Method (username)
ScrewTurn Wiki ► ScrewTurn.Wiki.Plugins.ActiveDirectory ► ActiveDirectoryProvider ► GetUser(String)
Gets the user info object for the currently logged in user.
Declaration Syntax
C# Visual Basic Visual C++
public UserInfo GetUser(
    string username
)
Public Function GetUser ( _
    username As String _
) As UserInfo
public:
UserInfo^ GetUser(
    String^ username
)
Parameters
username (String)

[Missing <param name="username"/> documentation for "M:ScrewTurn.Wiki.Plugins.ActiveDirectory.ActiveDirectoryProvider.GetUser(System.String)"]

Return Value

[Missing <returns> documentation for "M:ScrewTurn.Wiki.Plugins.ActiveDirectory.ActiveDirectoryProvider.GetUser(System.String)"]

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ActiveDirectoryProvider (Module: ActiveDirectoryProvider) Version: 3.0.2.500 (3.0.2.500)


GetUserByEmail Method (email)

GetUserByEmail Method (email)
ScrewTurn Wiki ► ScrewTurn.Wiki.Plugins.ActiveDirectory ► ActiveDirectoryProvider ► GetUserByEmail(String)
Not Implemented - Passed Directly to the IUsersStorageProviderV30
Declaration Syntax
C# Visual Basic Visual C++
public UserInfo GetUserByEmail(
    string email
)
Public Function GetUserByEmail ( _
    email As String _
) As UserInfo
public:
UserInfo^ GetUserByEmail(
    String^ email
)
Parameters
email (String)

[Missing <param name="email"/> documentation for "M:ScrewTurn.Wiki.Plugins.ActiveDirectory.ActiveDirectoryProvider.GetUserByEmail(System.String)"]

Return Value

[Missing <returns> documentation for "M:ScrewTurn.Wiki.Plugins.ActiveDirectory.ActiveDirectoryProvider.GetUserByEmail(System.String)"]

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ActiveDirectoryProvider (Module: ActiveDirectoryProvider) Version: 3.0.2.500 (3.0.2.500)


GetUserGroups Method

GetUserGroups Method
ScrewTurn Wiki ► ScrewTurn.Wiki.Plugins.ActiveDirectory ► ActiveDirectoryProvider ► GetUserGroups()()()
Not Implemented
Declaration Syntax
C# Visual Basic Visual C++
public UserGroup[] GetUserGroups()
Public Function GetUserGroups As UserGroup()
public:
array<UserGroup^>^ GetUserGroups()
Return Value

[Missing <returns> documentation for "M:ScrewTurn.Wiki.Plugins.ActiveDirectory.ActiveDirectoryProvider.GetUserGroups"]

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ActiveDirectoryProvider (Module: ActiveDirectoryProvider) Version: 3.0.2.500 (3.0.2.500)


GetUsers Method

GetUsers Method
ScrewTurn Wiki ► ScrewTurn.Wiki.Plugins.ActiveDirectory ► ActiveDirectoryProvider ► GetUsers()()()
Not Implemented
Declaration Syntax
C# Visual Basic Visual C++
public UserInfo[] GetUsers()
Public Function GetUsers As UserInfo()
public:
array<UserInfo^>^ GetUsers()
Return Value

[Missing <returns> documentation for "M:ScrewTurn.Wiki.Plugins.ActiveDirectory.ActiveDirectoryProvider.GetUsers"]

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ActiveDirectoryProvider (Module: ActiveDirectoryProvider) Version: 3.0.2.500 (3.0.2.500)


GetUsersWithData Method (key)

GetUsersWithData Method (key)
ScrewTurn Wiki ► ScrewTurn.Wiki.Plugins.ActiveDirectory ► ActiveDirectoryProvider ► GetUsersWithData(String)
Not Implemented - Passed Directly to the IUsersStorageProviderV30
Declaration Syntax
C# Visual Basic Visual C++
public IDictionary<UserInfo, string> GetUsersWithData(
    string key
)
Public Function GetUsersWithData ( _
    key As String _
) As IDictionary(Of UserInfo, String)
public:
IDictionary<UserInfo^, String^>^ GetUsersWithData(
    String^ key
)
Parameters
key (String)

[Missing <param name="key"/> documentation for "M:ScrewTurn.Wiki.Plugins.ActiveDirectory.ActiveDirectoryProvider.GetUsersWithData(System.String)"]

Return Value

[Missing <returns> documentation for "M:ScrewTurn.Wiki.Plugins.ActiveDirectory.ActiveDirectoryProvider.GetUsersWithData(System.String)"]

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ActiveDirectoryProvider (Module: ActiveDirectoryProvider) Version: 3.0.2.500 (3.0.2.500)


GroupMembershipReadOnly Property

GroupMembershipReadOnly Property
ScrewTurn Wiki ► ScrewTurn.Wiki.Plugins.ActiveDirectory ► ActiveDirectoryProvider ► GroupMembershipReadOnly
True, always, we can't write back to AD
Declaration Syntax
C# Visual Basic Visual C++
public bool GroupMembershipReadOnly { get; }
Public ReadOnly Property GroupMembershipReadOnly As Boolean
public:
property bool GroupMembershipReadOnly {
    bool get ();
}

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ActiveDirectoryProvider (Module: ActiveDirectoryProvider) Version: 3.0.2.500 (3.0.2.500)


Information Property

Information Property
ScrewTurn Wiki ► ScrewTurn.Wiki.Plugins.ActiveDirectory ► ActiveDirectoryProvider ► Information
Plugin Information TODO return and complete
Declaration Syntax
C# Visual Basic Visual C++
public ComponentInformation Information { get; }
Public ReadOnly Property Information As ComponentInformation
public:
property ComponentInformation^ Information {
    ComponentInformation^ get ();
}

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ActiveDirectoryProvider (Module: ActiveDirectoryProvider) Version: 3.0.2.500 (3.0.2.500)


Init Method (host, config)

Init Method (host, config)
ScrewTurn Wiki ► ScrewTurn.Wiki.Plugins.ActiveDirectory ► ActiveDirectoryProvider ► Init(IHostV30, String)
Inits the settings
Declaration Syntax
C# Visual Basic Visual C++
public void Init(
    IHostV30 host,
    string config
)
Public Sub Init ( _
    host As IHostV30, _
    config As String _
)
public:
void Init(
    IHostV30^ host,
    String^ config
)
Parameters
host (IHostV30)

[Missing <param name="host"/> documentation for "M:ScrewTurn.Wiki.Plugins.ActiveDirectory.ActiveDirectoryProvider.Init(ScrewTurn.Wiki.PluginFramework.IHostV30,System.String)"]

config (String)

[Missing <param name="config"/> documentation for "M:ScrewTurn.Wiki.Plugins.ActiveDirectory.ActiveDirectoryProvider.Init(ScrewTurn.Wiki.PluginFramework.IHostV30,System.String)"]

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ActiveDirectoryProvider (Module: ActiveDirectoryProvider) Version: 3.0.2.500 (3.0.2.500)


ModifyUser Method (user, newDisplayName, newPassword, newEmail, newActive)

ModifyUser Method (user, newDisplayName, newPassword, newEmail, newActive)
ScrewTurn Wiki ► ScrewTurn.Wiki.Plugins.ActiveDirectory ► ActiveDirectoryProvider ► ModifyUser(UserInfo, String, String, String, Boolean)
Not Implemented
Declaration Syntax
C# Visual Basic Visual C++
public UserInfo ModifyUser(
    UserInfo user,
    string newDisplayName,
    string newPassword,
    string newEmail,
    bool newActive
)
Public Function ModifyUser ( _
    user As UserInfo, _
    newDisplayName As String, _
    newPassword As String, _
    newEmail As String, _
    newActive As Boolean _
) As UserInfo
public:
UserInfo^ ModifyUser(
    UserInfo^ user,
    String^ newDisplayName,
    String^ newPassword,
    String^ newEmail,
    bool newActive
)
Parameters
user (UserInfo)

[Missing <param name="user"/> documentation for "M:ScrewTurn.Wiki.Plugins.ActiveDirectory.ActiveDirectoryProvider.ModifyUser(ScrewTurn.Wiki.PluginFramework.UserInfo,System.String,System.String,System.String,System.Boolean)"]

newDisplayName (String)

[Missing <param name="newDisplayName"/> documentation for "M:ScrewTurn.Wiki.Plugins.ActiveDirectory.ActiveDirectoryProvider.ModifyUser(ScrewTurn.Wiki.PluginFramework.UserInfo,System.String,System.String,System.String,System.Boolean)"]

newPassword (String)

[Missing <param name="newPassword"/> documentation for "M:ScrewTurn.Wiki.Plugins.ActiveDirectory.ActiveDirectoryProvider.ModifyUser(ScrewTurn.Wiki.PluginFramework.UserInfo,System.String,System.String,System.String,System.Boolean)"]

newEmail (String)

[Missing <param name="newEmail"/> documentation for "M:ScrewTurn.Wiki.Plugins.ActiveDirectory.ActiveDirectoryProvider.ModifyUser(ScrewTurn.Wiki.PluginFramework.UserInfo,System.String,System.String,System.String,System.Boolean)"]

newActive (Boolean)

[Missing <param name="newActive"/> documentation for "M:ScrewTurn.Wiki.Plugins.ActiveDirectory.ActiveDirectoryProvider.ModifyUser(ScrewTurn.Wiki.PluginFramework.UserInfo,System.String,System.String,System.String,System.Boolean)"]

Return Value

[Missing <returns> documentation for "M:ScrewTurn.Wiki.Plugins.ActiveDirectory.ActiveDirectoryProvider.ModifyUser(ScrewTurn.Wiki.PluginFramework.UserInfo,System.String,System.String,System.String,System.Boolean)"]

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ActiveDirectoryProvider (Module: ActiveDirectoryProvider) Version: 3.0.2.500 (3.0.2.500)


ModifyUserGroup Method (group, description)

ModifyUserGroup Method (group, description)
ScrewTurn Wiki ► ScrewTurn.Wiki.Plugins.ActiveDirectory ► ActiveDirectoryProvider ► ModifyUserGroup(UserGroup, String)
Not Implemented
Declaration Syntax
C# Visual Basic Visual C++
public UserGroup ModifyUserGroup(
    UserGroup group,
    string description
)
Public Function ModifyUserGroup ( _
    group As UserGroup, _
    description As String _
) As UserGroup
public:
UserGroup^ ModifyUserGroup(
    UserGroup^ group,
    String^ description
)
Parameters
group (UserGroup)

[Missing <param name="group"/> documentation for "M:ScrewTurn.Wiki.Plugins.ActiveDirectory.ActiveDirectoryProvider.ModifyUserGroup(ScrewTurn.Wiki.PluginFramework.UserGroup,System.String)"]

description (String)

[Missing <param name="description"/> documentation for "M:ScrewTurn.Wiki.Plugins.ActiveDirectory.ActiveDirectoryProvider.ModifyUserGroup(ScrewTurn.Wiki.PluginFramework.UserGroup,System.String)"]

Return Value

[Missing <returns> documentation for "M:ScrewTurn.Wiki.Plugins.ActiveDirectory.ActiveDirectoryProvider.ModifyUserGroup(ScrewTurn.Wiki.PluginFramework.UserGroup,System.String)"]

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ActiveDirectoryProvider (Module: ActiveDirectoryProvider) Version: 3.0.2.500 (3.0.2.500)


NotifyCookieLogin Method (user)

NotifyCookieLogin Method (user)
ScrewTurn Wiki ► ScrewTurn.Wiki.Plugins.ActiveDirectory ► ActiveDirectoryProvider ► NotifyCookieLogin(UserInfo)
Not Implemented - Passed Directly to the IUsersStorageProviderV30
Declaration Syntax
C# Visual Basic Visual C++
public void NotifyCookieLogin(
    UserInfo user
)
Public Sub NotifyCookieLogin ( _
    user As UserInfo _
)
public:
void NotifyCookieLogin(
    UserInfo^ user
)
Parameters
user (UserInfo)

[Missing <param name="user"/> documentation for "M:ScrewTurn.Wiki.Plugins.ActiveDirectory.ActiveDirectoryProvider.NotifyCookieLogin(ScrewTurn.Wiki.PluginFramework.UserInfo)"]

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ActiveDirectoryProvider (Module: ActiveDirectoryProvider) Version: 3.0.2.500 (3.0.2.500)


NotifyLogout Method (user)

NotifyLogout Method (user)
ScrewTurn Wiki ► ScrewTurn.Wiki.Plugins.ActiveDirectory ► ActiveDirectoryProvider ► NotifyLogout(UserInfo)
Not Implemented - Passed Directly to the IUsersStorageProviderV30
Declaration Syntax
C# Visual Basic Visual C++
public void NotifyLogout(
    UserInfo user
)
Public Sub NotifyLogout ( _
    user As UserInfo _
)
public:
void NotifyLogout(
    UserInfo^ user
)
Parameters
user (UserInfo)

[Missing <param name="user"/> documentation for "M:ScrewTurn.Wiki.Plugins.ActiveDirectory.ActiveDirectoryProvider.NotifyLogout(ScrewTurn.Wiki.PluginFramework.UserInfo)"]

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ActiveDirectoryProvider (Module: ActiveDirectoryProvider) Version: 3.0.2.500 (3.0.2.500)


RemoveUser Method (user)

RemoveUser Method (user)
ScrewTurn Wiki ► ScrewTurn.Wiki.Plugins.ActiveDirectory ► ActiveDirectoryProvider ► RemoveUser(UserInfo)
Not Implemented
Declaration Syntax
C# Visual Basic Visual C++
public bool RemoveUser(
    UserInfo user
)
Public Function RemoveUser ( _
    user As UserInfo _
) As Boolean
public:
bool RemoveUser(
    UserInfo^ user
)
Parameters
user (UserInfo)

[Missing <param name="user"/> documentation for "M:ScrewTurn.Wiki.Plugins.ActiveDirectory.ActiveDirectoryProvider.RemoveUser(ScrewTurn.Wiki.PluginFramework.UserInfo)"]

Return Value

[Missing <returns> documentation for "M:ScrewTurn.Wiki.Plugins.ActiveDirectory.ActiveDirectoryProvider.RemoveUser(ScrewTurn.Wiki.PluginFramework.UserInfo)"]

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ActiveDirectoryProvider (Module: ActiveDirectoryProvider) Version: 3.0.2.500 (3.0.2.500)


RemoveUserGroup Method (group)

RemoveUserGroup Method (group)
ScrewTurn Wiki ► ScrewTurn.Wiki.Plugins.ActiveDirectory ► ActiveDirectoryProvider ► RemoveUserGroup(UserGroup)
Not Implemented
Declaration Syntax
C# Visual Basic Visual C++
public bool RemoveUserGroup(
    UserGroup group
)
Public Function RemoveUserGroup ( _
    group As UserGroup _
) As Boolean
public:
bool RemoveUserGroup(
    UserGroup^ group
)
Parameters
group (UserGroup)

[Missing <param name="group"/> documentation for "M:ScrewTurn.Wiki.Plugins.ActiveDirectory.ActiveDirectoryProvider.RemoveUserGroup(ScrewTurn.Wiki.PluginFramework.UserGroup)"]

Return Value

[Missing <returns> documentation for "M:ScrewTurn.Wiki.Plugins.ActiveDirectory.ActiveDirectoryProvider.RemoveUserGroup(ScrewTurn.Wiki.PluginFramework.UserGroup)"]

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ActiveDirectoryProvider (Module: ActiveDirectoryProvider) Version: 3.0.2.500 (3.0.2.500)


RetrieveAllUserData Method (user)

RetrieveAllUserData Method (user)
ScrewTurn Wiki ► ScrewTurn.Wiki.Plugins.ActiveDirectory ► ActiveDirectoryProvider ► RetrieveAllUserData(UserInfo)
Not Implemented - Passed Directly to the IUsersStorageProviderV30
Declaration Syntax
C# Visual Basic Visual C++
public IDictionary<string, string> RetrieveAllUserData(
    UserInfo user
)
Public Function RetrieveAllUserData ( _
    user As UserInfo _
) As IDictionary(Of String, String)
public:
IDictionary<String^, String^>^ RetrieveAllUserData(
    UserInfo^ user
)
Parameters
user (UserInfo)

[Missing <param name="user"/> documentation for "M:ScrewTurn.Wiki.Plugins.ActiveDirectory.ActiveDirectoryProvider.RetrieveAllUserData(ScrewTurn.Wiki.PluginFramework.UserInfo)"]

Return Value

[Missing <returns> documentation for "M:ScrewTurn.Wiki.Plugins.ActiveDirectory.ActiveDirectoryProvider.RetrieveAllUserData(ScrewTurn.Wiki.PluginFramework.UserInfo)"]

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ActiveDirectoryProvider (Module: ActiveDirectoryProvider) Version: 3.0.2.500 (3.0.2.500)


RetrieveUserData Method (user, key)

RetrieveUserData Method (user, key)
ScrewTurn Wiki ► ScrewTurn.Wiki.Plugins.ActiveDirectory ► ActiveDirectoryProvider ► RetrieveUserData(UserInfo, String)
Not Implemented - Passed Directly to the IUsersStorageProviderV30
Declaration Syntax
C# Visual Basic Visual C++
public string RetrieveUserData(
    UserInfo user,
    string key
)
Public Function RetrieveUserData ( _
    user As UserInfo, _
    key As String _
) As String
public:
String^ RetrieveUserData(
    UserInfo^ user,
    String^ key
)
Parameters
user (UserInfo)

[Missing <param name="user"/> documentation for "M:ScrewTurn.Wiki.Plugins.ActiveDirectory.ActiveDirectoryProvider.RetrieveUserData(ScrewTurn.Wiki.PluginFramework.UserInfo,System.String)"]

key (String)

[Missing <param name="key"/> documentation for "M:ScrewTurn.Wiki.Plugins.ActiveDirectory.ActiveDirectoryProvider.RetrieveUserData(ScrewTurn.Wiki.PluginFramework.UserInfo,System.String)"]

Return Value

[Missing <returns> documentation for "M:ScrewTurn.Wiki.Plugins.ActiveDirectory.ActiveDirectoryProvider.RetrieveUserData(ScrewTurn.Wiki.PluginFramework.UserInfo,System.String)"]

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ActiveDirectoryProvider (Module: ActiveDirectoryProvider) Version: 3.0.2.500 (3.0.2.500)


SetUserMembership Method (user, groups)

SetUserMembership Method (user, groups)
ScrewTurn Wiki ► ScrewTurn.Wiki.Plugins.ActiveDirectory ► ActiveDirectoryProvider ► SetUserMembership(UserInfo, array<String>[]()[])
Not Implemented
Declaration Syntax
C# Visual Basic Visual C++
public UserInfo SetUserMembership(
    UserInfo user,
    string[] groups
)
Public Function SetUserMembership ( _
    user As UserInfo, _
    groups As String() _
) As UserInfo
public:
UserInfo^ SetUserMembership(
    UserInfo^ user,
    array<String^>^ groups
)
Parameters
user (UserInfo)

[Missing <param name="user"/> documentation for "M:ScrewTurn.Wiki.Plugins.ActiveDirectory.ActiveDirectoryProvider.SetUserMembership(ScrewTurn.Wiki.PluginFramework.UserInfo,System.String[])"]

groups (array< String >[]()[][])

[Missing <param name="groups"/> documentation for "M:ScrewTurn.Wiki.Plugins.ActiveDirectory.ActiveDirectoryProvider.SetUserMembership(ScrewTurn.Wiki.PluginFramework.UserInfo,System.String[])"]

Return Value

[Missing <returns> documentation for "M:ScrewTurn.Wiki.Plugins.ActiveDirectory.ActiveDirectoryProvider.SetUserMembership(ScrewTurn.Wiki.PluginFramework.UserInfo,System.String[])"]

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ActiveDirectoryProvider (Module: ActiveDirectoryProvider) Version: 3.0.2.500 (3.0.2.500)


Shutdown Method

Shutdown Method
ScrewTurn Wiki ► ScrewTurn.Wiki.Plugins.ActiveDirectory ► ActiveDirectoryProvider ► Shutdown()()()
Ignored
Declaration Syntax
C# Visual Basic Visual C++
public void Shutdown()
Public Sub Shutdown
public:
void Shutdown()

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ActiveDirectoryProvider (Module: ActiveDirectoryProvider) Version: 3.0.2.500 (3.0.2.500)


StoreUserData Method (user, key, value)

StoreUserData Method (user, key, value)
ScrewTurn Wiki ► ScrewTurn.Wiki.Plugins.ActiveDirectory ► ActiveDirectoryProvider ► StoreUserData(UserInfo, String, String)
Not Implemented - Passed Directly to the IUsersStorageProviderV30
Declaration Syntax
C# Visual Basic Visual C++
public bool StoreUserData(
    UserInfo user,
    string key,
    string value
)
Public Function StoreUserData ( _
    user As UserInfo, _
    key As String, _
    value As String _
) As Boolean
public:
bool StoreUserData(
    UserInfo^ user,
    String^ key,
    String^ value
)
Parameters
user (UserInfo)

[Missing <param name="user"/> documentation for "M:ScrewTurn.Wiki.Plugins.ActiveDirectory.ActiveDirectoryProvider.StoreUserData(ScrewTurn.Wiki.PluginFramework.UserInfo,System.String,System.String)"]

key (String)

[Missing <param name="key"/> documentation for "M:ScrewTurn.Wiki.Plugins.ActiveDirectory.ActiveDirectoryProvider.StoreUserData(ScrewTurn.Wiki.PluginFramework.UserInfo,System.String,System.String)"]

value (String)

[Missing <param name="value"/> documentation for "M:ScrewTurn.Wiki.Plugins.ActiveDirectory.ActiveDirectoryProvider.StoreUserData(ScrewTurn.Wiki.PluginFramework.UserInfo,System.String,System.String)"]

Return Value

[Missing <returns> documentation for "M:ScrewTurn.Wiki.Plugins.ActiveDirectory.ActiveDirectoryProvider.StoreUserData(ScrewTurn.Wiki.PluginFramework.UserInfo,System.String,System.String)"]

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ActiveDirectoryProvider (Module: ActiveDirectoryProvider) Version: 3.0.2.500 (3.0.2.500)


TestAccount Method (user, password)

TestAccount Method (user, password)
ScrewTurn Wiki ► ScrewTurn.Wiki.Plugins.ActiveDirectory ► ActiveDirectoryProvider ► TestAccount(UserInfo, String)
Not Implemented
Declaration Syntax
C# Visual Basic Visual C++
public bool TestAccount(
    UserInfo user,
    string password
)
Public Function TestAccount ( _
    user As UserInfo, _
    password As String _
) As Boolean
public:
bool TestAccount(
    UserInfo^ user,
    String^ password
)
Parameters
user (UserInfo)

[Missing <param name="user"/> documentation for "M:ScrewTurn.Wiki.Plugins.ActiveDirectory.ActiveDirectoryProvider.TestAccount(ScrewTurn.Wiki.PluginFramework.UserInfo,System.String)"]

password (String)

[Missing <param name="password"/> documentation for "M:ScrewTurn.Wiki.Plugins.ActiveDirectory.ActiveDirectoryProvider.TestAccount(ScrewTurn.Wiki.PluginFramework.UserInfo,System.String)"]

Return Value

[Missing <returns> documentation for "M:ScrewTurn.Wiki.Plugins.ActiveDirectory.ActiveDirectoryProvider.TestAccount(ScrewTurn.Wiki.PluginFramework.UserInfo,System.String)"]

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ActiveDirectoryProvider (Module: ActiveDirectoryProvider) Version: 3.0.2.500 (3.0.2.500)


TryAutoLogin Method (context)

TryAutoLogin Method (context)
ScrewTurn Wiki ► ScrewTurn.Wiki.Plugins.ActiveDirectory ► ActiveDirectoryProvider ► TryAutoLogin(HttpContext)
Tries to log the user in automagically
Declaration Syntax
C# Visual Basic Visual C++
public UserInfo TryAutoLogin(
    HttpContext context
)
Public Function TryAutoLogin ( _
    context As HttpContext _
) As UserInfo
public:
UserInfo^ TryAutoLogin(
    HttpContext^ context
)
Parameters
context (HttpContext)

[Missing <param name="context"/> documentation for "M:ScrewTurn.Wiki.Plugins.ActiveDirectory.ActiveDirectoryProvider.TryAutoLogin(System.Web.HttpContext)"]

Return Value

[Missing <returns> documentation for "M:ScrewTurn.Wiki.Plugins.ActiveDirectory.ActiveDirectoryProvider.TryAutoLogin(System.Web.HttpContext)"]

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ActiveDirectoryProvider (Module: ActiveDirectoryProvider) Version: 3.0.2.500 (3.0.2.500)


TryManualLogin Method (username, password)

TryManualLogin Method (username, password)
ScrewTurn Wiki ► ScrewTurn.Wiki.Plugins.ActiveDirectory ► ActiveDirectoryProvider ► TryManualLogin(String, String)
Tries to log the user in manually
Declaration Syntax
C# Visual Basic Visual C++
public UserInfo TryManualLogin(
    string username,
    string password
)
Public Function TryManualLogin ( _
    username As String, _
    password As String _
) As UserInfo
public:
UserInfo^ TryManualLogin(
    String^ username,
    String^ password
)
Parameters
username (String)

[Missing <param name="username"/> documentation for "M:ScrewTurn.Wiki.Plugins.ActiveDirectory.ActiveDirectoryProvider.TryManualLogin(System.String,System.String)"]

password (String)

[Missing <param name="password"/> documentation for "M:ScrewTurn.Wiki.Plugins.ActiveDirectory.ActiveDirectoryProvider.TryManualLogin(System.String,System.String)"]

Return Value

[Missing <returns> documentation for "M:ScrewTurn.Wiki.Plugins.ActiveDirectory.ActiveDirectoryProvider.TryManualLogin(System.String,System.String)"]

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ActiveDirectoryProvider (Module: ActiveDirectoryProvider) Version: 3.0.2.500 (3.0.2.500)


UserAccountsReadOnly Property

UserAccountsReadOnly Property
ScrewTurn Wiki ► ScrewTurn.Wiki.Plugins.ActiveDirectory ► ActiveDirectoryProvider ► UserAccountsReadOnly
True, always, we can't write back to AD
Declaration Syntax
C# Visual Basic Visual C++
public bool UserAccountsReadOnly { get; }
Public ReadOnly Property UserAccountsReadOnly As Boolean
public:
property bool UserAccountsReadOnly {
    bool get ();
}

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ActiveDirectoryProvider (Module: ActiveDirectoryProvider) Version: 3.0.2.500 (3.0.2.500)


UserGroupsReadOnly Property

UserGroupsReadOnly Property
ScrewTurn Wiki ► ScrewTurn.Wiki.Plugins.ActiveDirectory ► ActiveDirectoryProvider ► UserGroupsReadOnly
No
Declaration Syntax
C# Visual Basic Visual C++
public bool UserGroupsReadOnly { get; }
Public ReadOnly Property UserGroupsReadOnly As Boolean
public:
property bool UserGroupsReadOnly {
    bool get ();
}

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ActiveDirectoryProvider (Module: ActiveDirectoryProvider) Version: 3.0.2.500 (3.0.2.500)


UsersDataReadOnly Property

UsersDataReadOnly Property
ScrewTurn Wiki ► ScrewTurn.Wiki.Plugins.ActiveDirectory ► ActiveDirectoryProvider ► UsersDataReadOnly
True, always, we can't write back to AD
Declaration Syntax
C# Visual Basic Visual C++
public bool UsersDataReadOnly { get; }
Public ReadOnly Property UsersDataReadOnly As Boolean
public:
property bool UsersDataReadOnly {
    bool get ();
}

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ActiveDirectoryProvider (Module: ActiveDirectoryProvider) Version: 3.0.2.500 (3.0.2.500)


ScrewTurn.Wiki.Plugins.PluginPack Namespace

ScrewTurn.Wiki.Plugins.PluginPack Namespace
ScrewTurn Wiki ► ScrewTurn.Wiki.Plugins.PluginPack
Namespace containing Plugin Pack types.
Declaration Syntax
C# Visual Basic Visual C++
namespace ScrewTurn.Wiki.Plugins.PluginPack
Namespace ScrewTurn.Wiki.Plugins.PluginPack
namespace ScrewTurn.Wiki.Plugins.PluginPack
Types
All Types Classes
Icon | Type | Description
 | DownloadCounter | Implements a formatter provider that counts download of files and attachments.
 | Footnotes | Implements a footnotes plugin.
 | MultilanguageContentPlugin | Implements a Formatter Provider that allows to write multi-language content in Wiki Pages.
 | PagesSandbox | Implements a sandbox plugin for pages.
 | RssFeedDisplay | Implements a formatter provider that counts download of files and attachments.
 | UnfuddleTickets | Implements a formatter that display tickets from Unfuddle.


DownloadCounter Class

DownloadCounter Class
ScrewTurn Wiki ► ScrewTurn.Wiki.Plugins.PluginPack ► DownloadCounter
Implements a formatter provider that counts download of files and attachments.
Declaration Syntax
C# Visual Basic Visual C++
public class DownloadCounter : IFormatterProviderV30,
    IProviderV30
Public Class DownloadCounter _
    Implements IFormatterProviderV30, IProviderV30
public ref class DownloadCounter : IFormatterProviderV30,
    IProviderV30
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | DownloadCounter()()() | Initializes a new instance of the DownloadCounter class
 | ConfigHelpHtml | Gets a brief summary of the configuration string format, in HTML. Returns null if no configuration is needed.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | ExecutionPriority | Gets the execution priority of the provider (0 lowest, 100 highest).
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | Format(String, ContextInformation, FormattingPhase) | Performs a Formatting phase.
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | Information | Gets the Information about the Provider.
 | Init(IHostV30, String) | Initializes the Storage Provider.
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | PerformPhase1 | Specifies whether or not to execute Phase 1.
 | PerformPhase2 | Specifies whether or not to execute Phase 2.
 | PerformPhase3 | Specifies whether or not to execute Phase 3.
 | PrepareTitle(String, ContextInformation) | Prepares the title of an item for display (always during phase 3).
 | Shutdown()()() | Method invoked on shutdown.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
DownloadCounter

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: PluginPack (Module: PluginPack) Version: 3.0.2.500 (3.0.2.500)


DownloadCounter Constructor

DownloadCounter Constructor
ScrewTurn Wiki ► ScrewTurn.Wiki.Plugins.PluginPack ► DownloadCounter ► DownloadCounter()()()
Initializes a new instance of the DownloadCounter class
Declaration Syntax
C# Visual Basic Visual C++
public DownloadCounter()
Public Sub New
public:
DownloadCounter()

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: PluginPack (Module: PluginPack) Version: 3.0.2.500 (3.0.2.500)


ConfigHelpHtml Property

ConfigHelpHtml Property
ScrewTurn Wiki ► ScrewTurn.Wiki.Plugins.PluginPack ► DownloadCounter ► ConfigHelpHtml
Gets a brief summary of the configuration string format, in HTML. Returns null if no configuration is needed.
Declaration Syntax
C# Visual Basic Visual C++
public string ConfigHelpHtml { get; }
Public ReadOnly Property ConfigHelpHtml As String
public:
virtual property String^ ConfigHelpHtml {
    String^ get () sealed;
}

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: PluginPack (Module: PluginPack) Version: 3.0.2.500 (3.0.2.500)


ExecutionPriority Property

ExecutionPriority Property
ScrewTurn Wiki ► ScrewTurn.Wiki.Plugins.PluginPack ► DownloadCounter ► ExecutionPriority
Gets the execution priority of the provider (0 lowest, 100 highest).
Declaration Syntax
C# Visual Basic Visual C++
public int ExecutionPriority { get; }
Public ReadOnly Property ExecutionPriority As Integer
public:
virtual property int ExecutionPriority {
    int get () sealed;
}

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: PluginPack (Module: PluginPack) Version: 3.0.2.500 (3.0.2.500)


Format Method (raw, context, phase)

Format Method (raw, context, phase)
ScrewTurn Wiki ► ScrewTurn.Wiki.Plugins.PluginPack ► DownloadCounter ► Format(String, ContextInformation, FormattingPhase)
Performs a Formatting phase.
Declaration Syntax
C# Visual Basic Visual C++
public string Format(
    string raw,
    ContextInformation context,
    FormattingPhase phase
)
Public Function Format ( _
    raw As String, _
    context As ContextInformation, _
    phase As FormattingPhase _
) As String
public:
virtual String^ Format(
    String^ raw,
    ContextInformation^ context,
    FormattingPhase phase
) sealed
Parameters
raw (String)
The raw content to Format.
context (ContextInformation)
The Context information.
phase (FormattingPhase)
The Phase.
Return Value
The Formatted content.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: PluginPack (Module: PluginPack) Version: 3.0.2.500 (3.0.2.500)


Information Property

Information Property
ScrewTurn Wiki ► ScrewTurn.Wiki.Plugins.PluginPack ► DownloadCounter ► Information
Gets the Information about the Provider.
Declaration Syntax
C# Visual Basic Visual C++
public ComponentInformation Information { get; }
Public ReadOnly Property Information As ComponentInformation
public:
virtual property ComponentInformation^ Information {
    ComponentInformation^ get () sealed;
}

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: PluginPack (Module: PluginPack) Version: 3.0.2.500 (3.0.2.500)


Init Method (host, config)

Init Method (host, config)
ScrewTurn Wiki ► ScrewTurn.Wiki.Plugins.PluginPack ► DownloadCounter ► Init(IHostV30, String)
Initializes the Storage Provider.
Declaration Syntax
C# Visual Basic Visual C++
public void Init(
    IHostV30 host,
    string config
)
Public Sub Init ( _
    host As IHostV30, _
    config As String _
)
public:
virtual void Init(
    IHostV30^ host,
    String^ config
) sealed
Parameters
host (IHostV30)
The Host of the Component.
config (String)
The Configuration data, if any.
Remarks
If the configuration string is not valid, the methoud should throw a InvalidConfigurationException.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: PluginPack (Module: PluginPack) Version: 3.0.2.500 (3.0.2.500)


PerformPhase1 Property

PerformPhase1 Property
ScrewTurn Wiki ► ScrewTurn.Wiki.Plugins.PluginPack ► DownloadCounter ► PerformPhase1
Specifies whether or not to execute Phase 1.
Declaration Syntax
C# Visual Basic Visual C++
public bool PerformPhase1 { get; }
Public ReadOnly Property PerformPhase1 As Boolean
public:
virtual property bool PerformPhase1 {
    bool get () sealed;
}

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: PluginPack (Module: PluginPack) Version: 3.0.2.500 (3.0.2.500)


PerformPhase2 Property

PerformPhase2 Property
ScrewTurn Wiki ► ScrewTurn.Wiki.Plugins.PluginPack ► DownloadCounter ► PerformPhase2
Specifies whether or not to execute Phase 2.
Declaration Syntax
C# Visual Basic Visual C++
public bool PerformPhase2 { get; }
Public ReadOnly Property PerformPhase2 As Boolean
public:
virtual property bool PerformPhase2 {
    bool get () sealed;
}

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: PluginPack (Module: PluginPack) Version: 3.0.2.500 (3.0.2.500)


PerformPhase3 Property

PerformPhase3 Property
ScrewTurn Wiki ► ScrewTurn.Wiki.Plugins.PluginPack ► DownloadCounter ► PerformPhase3
Specifies whether or not to execute Phase 3.
Declaration Syntax
C# Visual Basic Visual C++
public bool PerformPhase3 { get; }
Public ReadOnly Property PerformPhase3 As Boolean
public:
virtual property bool PerformPhase3 {
    bool get () sealed;
}

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: PluginPack (Module: PluginPack) Version: 3.0.2.500 (3.0.2.500)


PrepareTitle Method (title, context)

PrepareTitle Method (title, context)
ScrewTurn Wiki ► ScrewTurn.Wiki.Plugins.PluginPack ► DownloadCounter ► PrepareTitle(String, ContextInformation)
Prepares the title of an item for display (always during phase 3).
Declaration Syntax
C# Visual Basic Visual C++
public string PrepareTitle(
    string title,
    ContextInformation context
)
Public Function PrepareTitle ( _
    title As String, _
    context As ContextInformation _
) As String
public:
virtual String^ PrepareTitle(
    String^ title,
    ContextInformation^ context
) sealed
Parameters
title (String)
The input title.
context (ContextInformation)
The context information.
Return Value
The prepared title (no markup allowed).

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: PluginPack (Module: PluginPack) Version: 3.0.2.500 (3.0.2.500)


Shutdown Method

Shutdown Method
ScrewTurn Wiki ► ScrewTurn.Wiki.Plugins.PluginPack ► DownloadCounter ► Shutdown()()()
Method invoked on shutdown.
Declaration Syntax
C# Visual Basic Visual C++
public void Shutdown()
Public Sub Shutdown
public:
virtual void Shutdown() sealed
Remarks
This method might not be invoked in some cases.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: PluginPack (Module: PluginPack) Version: 3.0.2.500 (3.0.2.500)


Footnotes Class

Footnotes Class
ScrewTurn Wiki ► ScrewTurn.Wiki.Plugins.PluginPack ► Footnotes
Implements a footnotes plugin.
Declaration Syntax
C# Visual Basic Visual C++
public class Footnotes : IFormatterProviderV30, IProviderV30
Public Class Footnotes _
    Implements IFormatterProviderV30, IProviderV30
public ref class Footnotes : IFormatterProviderV30,
    IProviderV30
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | Footnotes()()() | Initializes a new instance of the Footnotes class
 | ConfigHelpHtml | Gets a brief summary of the configuration string format, in HTML. Returns null if no configuration is needed.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | ExecutionPriority | Gets the execution priority of the provider (0 lowest, 100 highest).
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | Format(String, ContextInformation, FormattingPhase) | Performs a Formatting phase.
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | Information | Gets the Information about the Provider.
 | Init(IHostV30, String) | Initializes the Storage Provider.
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | PerformPhase1 | Specifies whether or not to execute Phase 1.
 | PerformPhase2 | Specifies whether or not to execute Phase 2.
 | PerformPhase3 | Specifies whether or not to execute Phase 3.
 | PrepareTitle(String, ContextInformation) | Prepares the title of an item for display (always during phase 3).
 | Shutdown()()() | Method invoked on shutdown.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
Footnotes

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: PluginPack (Module: PluginPack) Version: 3.0.2.500 (3.0.2.500)


Footnotes Constructor

Footnotes Constructor
ScrewTurn Wiki ► ScrewTurn.Wiki.Plugins.PluginPack ► Footnotes ► Footnotes()()()
Initializes a new instance of the Footnotes class
Declaration Syntax
C# Visual Basic Visual C++
public Footnotes()
Public Sub New
public:
Footnotes()

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: PluginPack (Module: PluginPack) Version: 3.0.2.500 (3.0.2.500)


ConfigHelpHtml Property

ConfigHelpHtml Property
ScrewTurn Wiki ► ScrewTurn.Wiki.Plugins.PluginPack ► Footnotes ► ConfigHelpHtml
Gets a brief summary of the configuration string format, in HTML. Returns null if no configuration is needed.
Declaration Syntax
C# Visual Basic Visual C++
public string ConfigHelpHtml { get; }
Public ReadOnly Property ConfigHelpHtml As String
public:
virtual property String^ ConfigHelpHtml {
    String^ get () sealed;
}

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: PluginPack (Module: PluginPack) Version: 3.0.2.500 (3.0.2.500)


ExecutionPriority Property

ExecutionPriority Property
ScrewTurn Wiki ► ScrewTurn.Wiki.Plugins.PluginPack ► Footnotes ► ExecutionPriority
Gets the execution priority of the provider (0 lowest, 100 highest).
Declaration Syntax
C# Visual Basic Visual C++
public int ExecutionPriority { get; }
Public ReadOnly Property ExecutionPriority As Integer
public:
virtual property int ExecutionPriority {
    int get () sealed;
}

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: PluginPack (Module: PluginPack) Version: 3.0.2.500 (3.0.2.500)


Format Method (raw, context, phase)

Format Method (raw, context, phase)
ScrewTurn Wiki ► ScrewTurn.Wiki.Plugins.PluginPack ► Footnotes ► Format(String, ContextInformation, FormattingPhase)
Performs a Formatting phase.
Declaration Syntax
C# Visual Basic Visual C++
public string Format(
    string raw,
    ContextInformation context,
    FormattingPhase phase
)
Public Function Format ( _
    raw As String, _
    context As ContextInformation, _
    phase As FormattingPhase _
) As String
public:
virtual String^ Format(
    String^ raw,
    ContextInformation^ context,
    FormattingPhase phase
) sealed
Parameters
raw (String)
The raw content to Format.
context (ContextInformation)
The Context information.
phase (FormattingPhase)
The Phase.
Return Value
The Formatted content.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: PluginPack (Module: PluginPack) Version: 3.0.2.500 (3.0.2.500)


Information Property

Information Property
ScrewTurn Wiki ► ScrewTurn.Wiki.Plugins.PluginPack ► Footnotes ► Information
Gets the Information about the Provider.
Declaration Syntax
C# Visual Basic Visual C++
public ComponentInformation Information { get; }
Public ReadOnly Property Information As ComponentInformation
public:
virtual property ComponentInformation^ Information {
    ComponentInformation^ get () sealed;
}

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: PluginPack (Module: PluginPack) Version: 3.0.2.500 (3.0.2.500)


Init Method (host, config)

Init Method (host, config)
ScrewTurn Wiki ► ScrewTurn.Wiki.Plugins.PluginPack ► Footnotes ► Init(IHostV30, String)
Initializes the Storage Provider.
Declaration Syntax
C# Visual Basic Visual C++
public void Init(
    IHostV30 host,
    string config
)
Public Sub Init ( _
    host As IHostV30, _
    config As String _
)
public:
virtual void Init(
    IHostV30^ host,
    String^ config
) sealed
Parameters
host (IHostV30)
The Host of the Component.
config (String)
The Configuration data, if any.
Exceptions
Exception | Condition
ArgumentNullException | If host or config are null.
InvalidConfigurationException | If config is not valid or is incorrect.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: PluginPack (Module: PluginPack) Version: 3.0.2.500 (3.0.2.500)


PerformPhase1 Property

PerformPhase1 Property
ScrewTurn Wiki ► ScrewTurn.Wiki.Plugins.PluginPack ► Footnotes ► PerformPhase1
Specifies whether or not to execute Phase 1.
Declaration Syntax
C# Visual Basic Visual C++
public bool PerformPhase1 { get; }
Public ReadOnly Property PerformPhase1 As Boolean
public:
virtual property bool PerformPhase1 {
    bool get () sealed;
}

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: PluginPack (Module: PluginPack) Version: 3.0.2.500 (3.0.2.500)


PerformPhase2 Property

PerformPhase2 Property
ScrewTurn Wiki ► ScrewTurn.Wiki.Plugins.PluginPack ► Footnotes ► PerformPhase2
Specifies whether or not to execute Phase 2.
Declaration Syntax
C# Visual Basic Visual C++
public bool PerformPhase2 { get; }
Public ReadOnly Property PerformPhase2 As Boolean
public:
virtual property bool PerformPhase2 {
    bool get () sealed;
}

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: PluginPack (Module: PluginPack) Version: 3.0.2.500 (3.0.2.500)


PerformPhase3 Property

PerformPhase3 Property
ScrewTurn Wiki ► ScrewTurn.Wiki.Plugins.PluginPack ► Footnotes ► PerformPhase3
Specifies whether or not to execute Phase 3.
Declaration Syntax
C# Visual Basic Visual C++
public bool PerformPhase3 { get; }
Public ReadOnly Property PerformPhase3 As Boolean
public:
virtual property bool PerformPhase3 {
    bool get () sealed;
}

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: PluginPack (Module: PluginPack) Version: 3.0.2.500 (3.0.2.500)


PrepareTitle Method (title, context)

PrepareTitle Method (title, context)
ScrewTurn Wiki ► ScrewTurn.Wiki.Plugins.PluginPack ► Footnotes ► PrepareTitle(String, ContextInformation)
Prepares the title of an item for display (always during phase 3).
Declaration Syntax
C# Visual Basic Visual C++
public string PrepareTitle(
    string title,
    ContextInformation context
)
Public Function PrepareTitle ( _
    title As String, _
    context As ContextInformation _
) As String
public:
virtual String^ PrepareTitle(
    String^ title,
    ContextInformation^ context
) sealed
Parameters
title (String)
The input title.
context (ContextInformation)
The context information.
Return Value
The prepared title (no markup allowed).

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: PluginPack (Module: PluginPack) Version: 3.0.2.500 (3.0.2.500)


Shutdown Method

Shutdown Method
ScrewTurn Wiki ► ScrewTurn.Wiki.Plugins.PluginPack ► Footnotes ► Shutdown()()()
Method invoked on shutdown.
Declaration Syntax
C# Visual Basic Visual C++
public void Shutdown()
Public Sub Shutdown
public:
virtual void Shutdown() sealed
Remarks
This method might not be invoked in some cases.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: PluginPack (Module: PluginPack) Version: 3.0.2.500 (3.0.2.500)


MultilanguageContentPlugin Class

MultilanguageContentPlugin Class
ScrewTurn Wiki ► ScrewTurn.Wiki.Plugins.PluginPack ► MultilanguageContentPlugin
Implements a Formatter Provider that allows to write multi-language content in Wiki Pages.
Declaration Syntax
C# Visual Basic Visual C++
public class MultilanguageContentPlugin : IFormatterProviderV30,
    IProviderV30
Public Class MultilanguageContentPlugin _
    Implements IFormatterProviderV30, IProviderV30
public ref class MultilanguageContentPlugin : IFormatterProviderV30,
    IProviderV30
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | MultilanguageContentPlugin()()() | Initializes a new instance of the MultilanguageContentPlugin class
 | ConfigHelpHtml | Gets a brief summary of the configuration string format, in HTML. Returns null if no configuration is needed.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | ExecutionPriority | Gets the execution priority of the provider (0 lowest, 100 highest).
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | Format(String, ContextInformation, FormattingPhase) | Performs a Formatting phase.
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | Information | Gets the Information about the Provider.
 | Init(IHostV30, String) | Initializes the Storage Provider.
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | PerformPhase1 | Specifies whether or not to execute Phase 1.
 | PerformPhase2 | Specifies whether or not to execute Phase 2.
 | PerformPhase3 | Specifies whether or not to execute Phase 3.
 | PrepareTitle(String, ContextInformation) | Prepares the title of an item for display (always during phase 3).
 | Shutdown()()() | Method invoked on shutdown.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
MultilanguageContentPlugin

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: PluginPack (Module: PluginPack) Version: 3.0.2.500 (3.0.2.500)


MultilanguageContentPlugin Constructor

MultilanguageContentPlugin Constructor
ScrewTurn Wiki ► ScrewTurn.Wiki.Plugins.PluginPack ► MultilanguageContentPlugin ► MultilanguageContentPlugin()()()
Initializes a new instance of the MultilanguageContentPlugin class
Declaration Syntax
C# Visual Basic Visual C++
public MultilanguageContentPlugin()
Public Sub New
public:
MultilanguageContentPlugin()

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: PluginPack (Module: PluginPack) Version: 3.0.2.500 (3.0.2.500)


ConfigHelpHtml Property

ConfigHelpHtml Property
ScrewTurn Wiki ► ScrewTurn.Wiki.Plugins.PluginPack ► MultilanguageContentPlugin ► ConfigHelpHtml
Gets a brief summary of the configuration string format, in HTML. Returns null if no configuration is needed.
Declaration Syntax
C# Visual Basic Visual C++
public string ConfigHelpHtml { get; }
Public ReadOnly Property ConfigHelpHtml As String
public:
virtual property String^ ConfigHelpHtml {
    String^ get () sealed;
}

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: PluginPack (Module: PluginPack) Version: 3.0.2.500 (3.0.2.500)


ExecutionPriority Property

ExecutionPriority Property
ScrewTurn Wiki ► ScrewTurn.Wiki.Plugins.PluginPack ► MultilanguageContentPlugin ► ExecutionPriority
Gets the execution priority of the provider (0 lowest, 100 highest).
Declaration Syntax
C# Visual Basic Visual C++
public int ExecutionPriority { get; }
Public ReadOnly Property ExecutionPriority As Integer
public:
virtual property int ExecutionPriority {
    int get () sealed;
}

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: PluginPack (Module: PluginPack) Version: 3.0.2.500 (3.0.2.500)


Format Method (raw, context, phase)

Format Method (raw, context, phase)
ScrewTurn Wiki ► ScrewTurn.Wiki.Plugins.PluginPack ► MultilanguageContentPlugin ► Format(String, ContextInformation, FormattingPhase)
Performs a Formatting phase.
Declaration Syntax
C# Visual Basic Visual C++
public string Format(
    string raw,
    ContextInformation context,
    FormattingPhase phase
)
Public Function Format ( _
    raw As String, _
    context As ContextInformation, _
    phase As FormattingPhase _
) As String
public:
virtual String^ Format(
    String^ raw,
    ContextInformation^ context,
    FormattingPhase phase
) sealed
Parameters
raw (String)
The raw content to Format.
context (ContextInformation)
The Context information.
phase (FormattingPhase)
The Phase.
Return Value
The Formatted content.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: PluginPack (Module: PluginPack) Version: 3.0.2.500 (3.0.2.500)


Information Property

Information Property
ScrewTurn Wiki ► ScrewTurn.Wiki.Plugins.PluginPack ► MultilanguageContentPlugin ► Information
Gets the Information about the Provider.
Declaration Syntax
C# Visual Basic Visual C++
public ComponentInformation Information { get; }
Public ReadOnly Property Information As ComponentInformation
public:
virtual property ComponentInformation^ Information {
    ComponentInformation^ get () sealed;
}

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: PluginPack (Module: PluginPack) Version: 3.0.2.500 (3.0.2.500)


Init Method (host, config)

Init Method (host, config)
ScrewTurn Wiki ► ScrewTurn.Wiki.Plugins.PluginPack ► MultilanguageContentPlugin ► Init(IHostV30, String)
Initializes the Storage Provider.
Declaration Syntax
C# Visual Basic Visual C++
public void Init(
    IHostV30 host,
    string config
)
Public Sub Init ( _
    host As IHostV30, _
    config As String _
)
public:
virtual void Init(
    IHostV30^ host,
    String^ config
) sealed
Parameters
host (IHostV30)
The Host of the Component.
config (String)
The Configuration data, if any.
Remarks
If the configuration string is not valid, the methoud should throw a InvalidConfigurationException.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: PluginPack (Module: PluginPack) Version: 3.0.2.500 (3.0.2.500)


PerformPhase1 Property

PerformPhase1 Property
ScrewTurn Wiki ► ScrewTurn.Wiki.Plugins.PluginPack ► MultilanguageContentPlugin ► PerformPhase1
Specifies whether or not to execute Phase 1.
Declaration Syntax
C# Visual Basic Visual C++
public bool PerformPhase1 { get; }
Public ReadOnly Property PerformPhase1 As Boolean
public:
virtual property bool PerformPhase1 {
    bool get () sealed;
}

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: PluginPack (Module: PluginPack) Version: 3.0.2.500 (3.0.2.500)


PerformPhase2 Property

PerformPhase2 Property
ScrewTurn Wiki ► ScrewTurn.Wiki.Plugins.PluginPack ► MultilanguageContentPlugin ► PerformPhase2
Specifies whether or not to execute Phase 2.
Declaration Syntax
C# Visual Basic Visual C++
public bool PerformPhase2 { get; }
Public ReadOnly Property PerformPhase2 As Boolean
public:
virtual property bool PerformPhase2 {
    bool get () sealed;
}

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: PluginPack (Module: PluginPack) Version: 3.0.2.500 (3.0.2.500)


PerformPhase3 Property

PerformPhase3 Property
ScrewTurn Wiki ► ScrewTurn.Wiki.Plugins.PluginPack ► MultilanguageContentPlugin ► PerformPhase3
Specifies whether or not to execute Phase 3.
Declaration Syntax
C# Visual Basic Visual C++
public bool PerformPhase3 { get; }
Public ReadOnly Property PerformPhase3 As Boolean
public:
virtual property bool PerformPhase3 {
    bool get () sealed;
}

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: PluginPack (Module: PluginPack) Version: 3.0.2.500 (3.0.2.500)


PrepareTitle Method (title, context)

PrepareTitle Method (title, context)
ScrewTurn Wiki ► ScrewTurn.Wiki.Plugins.PluginPack ► MultilanguageContentPlugin ► PrepareTitle(String, ContextInformation)
Prepares the title of an item for display (always during phase 3).
Declaration Syntax
C# Visual Basic Visual C++
public string PrepareTitle(
    string title,
    ContextInformation context
)
Public Function PrepareTitle ( _
    title As String, _
    context As ContextInformation _
) As String
public:
virtual String^ PrepareTitle(
    String^ title,
    ContextInformation^ context
) sealed
Parameters
title (String)
The input title.
context (ContextInformation)
The context information.
Return Value
The prepared title (no markup allowed).

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: PluginPack (Module: PluginPack) Version: 3.0.2.500 (3.0.2.500)


Shutdown Method

Shutdown Method
ScrewTurn Wiki ► ScrewTurn.Wiki.Plugins.PluginPack ► MultilanguageContentPlugin ► Shutdown()()()
Method invoked on shutdown.
Declaration Syntax
C# Visual Basic Visual C++
public void Shutdown()
Public Sub Shutdown
public:
virtual void Shutdown() sealed
Remarks
This method might not be invoked in some cases.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: PluginPack (Module: PluginPack) Version: 3.0.2.500 (3.0.2.500)


PagesSandbox Class

PagesSandbox Class
ScrewTurn Wiki ► ScrewTurn.Wiki.Plugins.PluginPack ► PagesSandbox
Implements a sandbox plugin for pages.
Declaration Syntax
C# Visual Basic Visual C++
public class PagesSandbox
Public Class PagesSandbox
public ref class PagesSandbox
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | PagesSandbox()()() | Initializes a new instance of the PagesSandbox class
 | AddCategory(String, String) | Adds a Category.
 | AddContentTemplate(String, String) | Adds a new content template.
 | AddMessage(PageInfo, String, String, DateTime, String, Int32) | Adds a new Message to a Page.
 | AddNamespace(String) | Adds a new namespace.
 | AddNavigationPath(String, String, array<PageInfo>[]()[]) | Adds a new Navigation Path.
 | AddPage(String, String, DateTime) | Adds a Page.
 | AddSnippet(String, String) | Adds a new snippet.
 | BulkStoreMessages(PageInfo, array<Message>[]()[]) | Removes all messages for a page and stores the new messages.
 | ConfigHelpHtml | Gets a brief summary of the configuration string format, in HTML. Returns null if no configuration is needed.
 | DeleteBackups(PageInfo, Int32) | Deletes the Backups of a Page, up to a specified revision.
 | DeleteDraft(PageInfo) | Deletes a draft of a Page.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetBackupContent(PageInfo, Int32) | Gets the Content of a Backup of a Page.
 | GetBackups(PageInfo) | Gets the Backup/Revision numbers of a Page.
 | GetCategories(NamespaceInfo) | Gets all the Categories in a namespace.
 | GetCategoriesForPage(PageInfo) | Gets all the categories of a page.
 | GetCategory(String) | Gets a category.
 | GetContent(PageInfo) | Gets the Content of a Page.
 | GetContentTemplates()()() | Gets all the content templates.
 | GetDraft(PageInfo) | Gets the content of a draft of a Page.
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetIndexStats(Int32%, Int32%, Int32%, Int64%) | Gets some statistics about the search engine index.
 | GetMessageCount(PageInfo) | Gets the total number of Messages in a Page Discussion.
 | GetMessages(PageInfo) | Gets the Page Messages.
 | GetNamespace(String) | Gets a namespace.
 | GetNamespaces()()() | Gets all the sub-namespaces.
 | GetNavigationPaths(NamespaceInfo) | Gets all the Navigation Paths in a Namespace.
 | GetPage(String) | Gets a page.
 | GetPages(NamespaceInfo) | Gets all the Pages in a namespace.
 | GetSnippets()()() | Gets all the snippets.
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetUncategorizedPages(NamespaceInfo) | Gets all the pages in a namespace that are bound to zero categories.
 | Information | Gets the Information about the Provider.
 | Init(IHostV30, String) | Initializes the Storage Provider.
 | IsIndexCorrupted | Gets a value indicating whether the search engine index is corrupted and needs to be rebuilt.
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | MergeCategories(CategoryInfo, CategoryInfo) | Merges two Categories.
 | ModifyContentTemplate(String, String) | Modifies an existing content template.
 | ModifyMessage(PageInfo, Int32, String, String, DateTime, String) | Modifies a Message.
 | ModifyNavigationPath(NavigationPath, array<PageInfo>[]()[]) | Modifies an existing navigation path.
 | ModifyPage(PageInfo, String, String, DateTime, String, String, array<String>[]()[], String, SaveMode) | Modifies the Content of a Page.
 | ModifySnippet(String, String) | Modifies an existing snippet.
 | MovePage(PageInfo, NamespaceInfo, Boolean) | Moves a page from its namespace into another.
 | PerformSearch(SearchParameters) | Performs a search in the index.
 | ReadOnly | Gets a value specifying whether the provider is read-only, i.e. it can only provide data and not store it.
 | RebindPage(PageInfo, array<String>[]()[]) | Binds a Page with one or more Categories.
 | RebuildIndex()()() | Rebuilds the search index.
 | RemoveCategory(CategoryInfo) | Removes a Category.
 | RemoveContentTemplate(String) | Removes a content template.
 | RemoveMessage(PageInfo, Int32, Boolean) | Removes a Message.
 | RemoveNamespace(NamespaceInfo) | Removes a namespace.
 | RemoveNavigationPath(NavigationPath) | Removes a Navigation Path.
 | RemovePage(PageInfo) | Removes a Page.
 | RemoveSnippet(String) | Removes a new Snippet.
 | RenameCategory(CategoryInfo, String) | Renames a Category.
 | RenameNamespace(NamespaceInfo, String) | Renames a namespace.
 | RenamePage(PageInfo, String) | Renames a Page.
 | RollbackPage(PageInfo, Int32) | Performs the rollback of a Page to a specified revision.
 | SetBackupContent(PageContent, Int32) | Forces to overwrite or create a Backup.
 | SetNamespaceDefaultPage(NamespaceInfo, PageInfo) | Sets the default page of a namespace.
 | Shutdown()()() | Method invoked on shutdown.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
PagesSandbox

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: PluginPack (Module: PluginPack) Version: 3.0.2.500 (3.0.2.500)


PagesSandbox Constructor

PagesSandbox Constructor
ScrewTurn Wiki ► ScrewTurn.Wiki.Plugins.PluginPack ► PagesSandbox ► PagesSandbox()()()
Initializes a new instance of the PagesSandbox class
Declaration Syntax
C# Visual Basic Visual C++
public PagesSandbox()
Public Sub New
public:
PagesSandbox()

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: PluginPack (Module: PluginPack) Version: 3.0.2.500 (3.0.2.500)


AddCategory Method (nspace, name)

AddCategory Method (nspace, name)
ScrewTurn Wiki ► ScrewTurn.Wiki.Plugins.PluginPack ► PagesSandbox ► AddCategory(String, String)
Adds a Category.
Declaration Syntax
C# Visual Basic Visual C++
public CategoryInfo AddCategory(
    string nspace,
    string name
)
Public Function AddCategory ( _
    nspace As String, _
    name As String _
) As CategoryInfo
public:
CategoryInfo^ AddCategory(
    String^ nspace,
    String^ name
)
Parameters
nspace (String)
The target namespace (null for the root).
name (String)
The Category name.
Return Value
The correct CategoryInfo object.
Remarks
The moethod should set category's Pages to an empty array.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: PluginPack (Module: PluginPack) Version: 3.0.2.500 (3.0.2.500)


AddContentTemplate Method (name, content)

AddContentTemplate Method (name, content)
ScrewTurn Wiki ► ScrewTurn.Wiki.Plugins.PluginPack ► PagesSandbox ► AddContentTemplate(String, String)
Adds a new content template.
Declaration Syntax
C# Visual Basic Visual C++
public ContentTemplate AddContentTemplate(
    string name,
    string content
)
Public Function AddContentTemplate ( _
    name As String, _
    content As String _
) As ContentTemplate
public:
ContentTemplate^ AddContentTemplate(
    String^ name,
    String^ content
)
Parameters
name (String)
The name of template.
content (String)
The content of the template.
Return Value
The correct ContentTemplate object.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: PluginPack (Module: PluginPack) Version: 3.0.2.500 (3.0.2.500)


AddMessage Method (page, username, subject, dateTime, body, parent)

AddMessage Method (page, username, subject, dateTime, body, parent)
ScrewTurn Wiki ► ScrewTurn.Wiki.Plugins.PluginPack ► PagesSandbox ► AddMessage(PageInfo, String, String, DateTime, String, Int32)
Adds a new Message to a Page.
Declaration Syntax
C# Visual Basic Visual C++
public bool AddMessage(
    PageInfo page,
    string username,
    string subject,
    DateTime dateTime,
    string body,
    int parent
)
Public Function AddMessage ( _
    page As PageInfo, _
    username As String, _
    subject As String, _
    dateTime As DateTime, _
    body As String, _
    parent As Integer _
) As Boolean
public:
bool AddMessage(
    PageInfo^ page,
    String^ username,
    String^ subject,
    DateTime dateTime,
    String^ body,
    int parent
)
Parameters
page (PageInfo)
The Page.
username (String)
The Username.
subject (String)
The Subject.
dateTime (DateTime)
The Date/Time.
body (String)
The Body.
parent (Int32)
The Parent Message ID, or -1.
Return Value
True if the Message is added successfully.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: PluginPack (Module: PluginPack) Version: 3.0.2.500 (3.0.2.500)


AddNamespace Method (name)

AddNamespace Method (name)
ScrewTurn Wiki ► ScrewTurn.Wiki.Plugins.PluginPack ► PagesSandbox ► AddNamespace(String)
Adds a new namespace.
Declaration Syntax
C# Visual Basic Visual C++
public NamespaceInfo AddNamespace(
    string name
)
Public Function AddNamespace ( _
    name As String _
) As NamespaceInfo
public:
NamespaceInfo^ AddNamespace(
    String^ name
)
Parameters
name (String)
The name of the namespace.
Return Value
The correct NamespaceInfo object.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: PluginPack (Module: PluginPack) Version: 3.0.2.500 (3.0.2.500)


AddNavigationPath Method (nspace, name, pages)

AddNavigationPath Method (nspace, name, pages)
ScrewTurn Wiki ► ScrewTurn.Wiki.Plugins.PluginPack ► PagesSandbox ► AddNavigationPath(String, String, array<PageInfo>[]()[])
Adds a new Navigation Path.
Declaration Syntax
C# Visual Basic Visual C++
public NavigationPath AddNavigationPath(
    string nspace,
    string name,
    PageInfo[] pages
)
Public Function AddNavigationPath ( _
    nspace As String, _
    name As String, _
    pages As PageInfo() _
) As NavigationPath
public:
NavigationPath^ AddNavigationPath(
    String^ nspace,
    String^ name,
    array<PageInfo^>^ pages
)
Parameters
nspace (String)
The target namespace (null for the root).
name (String)
The Name of the Path.
pages (array< PageInfo >[]()[][])
The Pages array.
Return Value
The correct NavigationPath object.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: PluginPack (Module: PluginPack) Version: 3.0.2.500 (3.0.2.500)


AddPage Method (nspace, name, creationDateTime)

AddPage Method (nspace, name, creationDateTime)
ScrewTurn Wiki ► ScrewTurn.Wiki.Plugins.PluginPack ► PagesSandbox ► AddPage(String, String, DateTime)
Adds a Page.
Declaration Syntax
C# Visual Basic Visual C++
public PageInfo AddPage(
    string nspace,
    string name,
    DateTime creationDateTime
)
Public Function AddPage ( _
    nspace As String, _
    name As String, _
    creationDateTime As DateTime _
) As PageInfo
public:
PageInfo^ AddPage(
    String^ nspace,
    String^ name,
    DateTime creationDateTime
)
Parameters
nspace (String)
The target namespace (null for the root).
name (String)
The Page Name.
creationDateTime (DateTime)
The creation Date/Time.
Return Value
The correct PageInfo object or null.
Remarks
This method should not create the content of the Page.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: PluginPack (Module: PluginPack) Version: 3.0.2.500 (3.0.2.500)


AddSnippet Method (name, content)

AddSnippet Method (name, content)
ScrewTurn Wiki ► ScrewTurn.Wiki.Plugins.PluginPack ► PagesSandbox ► AddSnippet(String, String)
Adds a new snippet.
Declaration Syntax
C# Visual Basic Visual C++
public Snippet AddSnippet(
    string name,
    string content
)
Public Function AddSnippet ( _
    name As String, _
    content As String _
) As Snippet
public:
Snippet^ AddSnippet(
    String^ name,
    String^ content
)
Parameters
name (String)
The name of the snippet.
content (String)
The content of the snippet.
Return Value
The correct Snippet object.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: PluginPack (Module: PluginPack) Version: 3.0.2.500 (3.0.2.500)


BulkStoreMessages Method (page, messages)

BulkStoreMessages Method (page, messages)
ScrewTurn Wiki ► ScrewTurn.Wiki.Plugins.PluginPack ► PagesSandbox ► BulkStoreMessages(PageInfo, array<Message>[]()[])
Removes all messages for a page and stores the new messages.
Declaration Syntax
C# Visual Basic Visual C++
public bool BulkStoreMessages(
    PageInfo page,
    Message[] messages
)
Public Function BulkStoreMessages ( _
    page As PageInfo, _
    messages As Message() _
) As Boolean
public:
bool BulkStoreMessages(
    PageInfo^ page,
    array<Message^>^ messages
)
Parameters
page (PageInfo)
The page.
messages (array< Message >[]()[][])
The new messages to store.
Return Value
true if the messages are stored, false otherwise.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: PluginPack (Module: PluginPack) Version: 3.0.2.500 (3.0.2.500)


ConfigHelpHtml Property

ConfigHelpHtml Property
ScrewTurn Wiki ► ScrewTurn.Wiki.Plugins.PluginPack ► PagesSandbox ► ConfigHelpHtml
Gets a brief summary of the configuration string format, in HTML. Returns null if no configuration is needed.
Declaration Syntax
C# Visual Basic Visual C++
public string ConfigHelpHtml { get; }
Public ReadOnly Property ConfigHelpHtml As String
public:
property String^ ConfigHelpHtml {
    String^ get ();
}

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: PluginPack (Module: PluginPack) Version: 3.0.2.500 (3.0.2.500)


DeleteBackups Method (page, revision)

DeleteBackups Method (page, revision)
ScrewTurn Wiki ► ScrewTurn.Wiki.Plugins.PluginPack ► PagesSandbox ► DeleteBackups(PageInfo, Int32)
Deletes the Backups of a Page, up to a specified revision.
Declaration Syntax
C# Visual Basic Visual C++
public bool DeleteBackups(
    PageInfo page,
    int revision
)
Public Function DeleteBackups ( _
    page As PageInfo, _
    revision As Integer _
) As Boolean
public:
bool DeleteBackups(
    PageInfo^ page,
    int revision
)
Parameters
page (PageInfo)
The Page to delete the backups of.
revision (Int32)
The newest revision to delete (newer revision are kept) or -1 to delete all the Backups.
Return Value
true if the deletion succeeded, false otherwise.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: PluginPack (Module: PluginPack) Version: 3.0.2.500 (3.0.2.500)


DeleteDraft Method (page)

DeleteDraft Method (page)
ScrewTurn Wiki ► ScrewTurn.Wiki.Plugins.PluginPack ► PagesSandbox ► DeleteDraft(PageInfo)
Deletes a draft of a Page.
Declaration Syntax
C# Visual Basic Visual C++
public bool DeleteDraft(
    PageInfo page
)
Public Function DeleteDraft ( _
    page As PageInfo _
) As Boolean
public:
bool DeleteDraft(
    PageInfo^ page
)
Parameters
page (PageInfo)
The page.
Return Value
true if the draft is deleted, false otherwise.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: PluginPack (Module: PluginPack) Version: 3.0.2.500 (3.0.2.500)


GetBackupContent Method (page, revision)

GetBackupContent Method (page, revision)
ScrewTurn Wiki ► ScrewTurn.Wiki.Plugins.PluginPack ► PagesSandbox ► GetBackupContent(PageInfo, Int32)
Gets the Content of a Backup of a Page.
Declaration Syntax
C# Visual Basic Visual C++
public PageContent GetBackupContent(
    PageInfo page,
    int revision
)
Public Function GetBackupContent ( _
    page As PageInfo, _
    revision As Integer _
) As PageContent
public:
PageContent^ GetBackupContent(
    PageInfo^ page,
    int revision
)
Parameters
page (PageInfo)
The Page to get the backup of.
revision (Int32)
The Backup/Revision number.
Return Value
The Page Backup.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: PluginPack (Module: PluginPack) Version: 3.0.2.500 (3.0.2.500)


GetBackups Method (page)

GetBackups Method (page)
ScrewTurn Wiki ► ScrewTurn.Wiki.Plugins.PluginPack ► PagesSandbox ► GetBackups(PageInfo)
Gets the Backup/Revision numbers of a Page.
Declaration Syntax
C# Visual Basic Visual C++
public int[] GetBackups(
    PageInfo page
)
Public Function GetBackups ( _
    page As PageInfo _
) As Integer()
public:
array<int>^ GetBackups(
    PageInfo^ page
)
Parameters
page (PageInfo)
The Page to get the Backups of.
Return Value
The Backup/Revision numbers.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: PluginPack (Module: PluginPack) Version: 3.0.2.500 (3.0.2.500)


GetCategories Method (nspace)

GetCategories Method (nspace)
ScrewTurn Wiki ► ScrewTurn.Wiki.Plugins.PluginPack ► PagesSandbox ► GetCategories(NamespaceInfo)
Gets all the Categories in a namespace.
Declaration Syntax
C# Visual Basic Visual C++
public CategoryInfo[] GetCategories(
    NamespaceInfo nspace
)
Public Function GetCategories ( _
    nspace As NamespaceInfo _
) As CategoryInfo()
public:
array<CategoryInfo^>^ GetCategories(
    NamespaceInfo^ nspace
)
Parameters
nspace (NamespaceInfo)
The namespace.
Return Value
All the Categories in the namespace, sorted by name.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: PluginPack (Module: PluginPack) Version: 3.0.2.500 (3.0.2.500)


GetCategoriesForPage Method (page)

GetCategoriesForPage Method (page)
ScrewTurn Wiki ► ScrewTurn.Wiki.Plugins.PluginPack ► PagesSandbox ► GetCategoriesForPage(PageInfo)
Gets all the categories of a page.
Declaration Syntax
C# Visual Basic Visual C++
public CategoryInfo[] GetCategoriesForPage(
    PageInfo page
)
Public Function GetCategoriesForPage ( _
    page As PageInfo _
) As CategoryInfo()
public:
array<CategoryInfo^>^ GetCategoriesForPage(
    PageInfo^ page
)
Parameters
page (PageInfo)
The page.
Return Value
The categories, sorted by name.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: PluginPack (Module: PluginPack) Version: 3.0.2.500 (3.0.2.500)


GetCategory Method (fullName)

GetCategory Method (fullName)
ScrewTurn Wiki ► ScrewTurn.Wiki.Plugins.PluginPack ► PagesSandbox ► GetCategory(String)
Gets a category.
Declaration Syntax
C# Visual Basic Visual C++
public CategoryInfo GetCategory(
    string fullName
)
Public Function GetCategory ( _
    fullName As String _
) As CategoryInfo
public:
CategoryInfo^ GetCategory(
    String^ fullName
)
Parameters
fullName (String)
The full name of the category.
Return Value
The CategoryInfo, or null if no category is found.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: PluginPack (Module: PluginPack) Version: 3.0.2.500 (3.0.2.500)


GetContent Method (page)

GetContent Method (page)
ScrewTurn Wiki ► ScrewTurn.Wiki.Plugins.PluginPack ► PagesSandbox ► GetContent(PageInfo)
Gets the Content of a Page.
Declaration Syntax
C# Visual Basic Visual C++
public PageContent GetContent(
    PageInfo page
)
Public Function GetContent ( _
    page As PageInfo _
) As PageContent
public:
PageContent^ GetContent(
    PageInfo^ page
)
Parameters
page (PageInfo)
The Page.
Return Value
The Page Content object.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: PluginPack (Module: PluginPack) Version: 3.0.2.500 (3.0.2.500)


GetContentTemplates Method

GetContentTemplates Method
ScrewTurn Wiki ► ScrewTurn.Wiki.Plugins.PluginPack ► PagesSandbox ► GetContentTemplates()()()
Gets all the content templates.
Declaration Syntax
C# Visual Basic Visual C++
public ContentTemplate[] GetContentTemplates()
Public Function GetContentTemplates As ContentTemplate()
public:
array<ContentTemplate^>^ GetContentTemplates()
Return Value
All the content templates, sorted by name.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: PluginPack (Module: PluginPack) Version: 3.0.2.500 (3.0.2.500)


GetDraft Method (page)

GetDraft Method (page)
ScrewTurn Wiki ► ScrewTurn.Wiki.Plugins.PluginPack ► PagesSandbox ► GetDraft(PageInfo)
Gets the content of a draft of a Page.
Declaration Syntax
C# Visual Basic Visual C++
public PageContent GetDraft(
    PageInfo page
)
Public Function GetDraft ( _
    page As PageInfo _
) As PageContent
public:
PageContent^ GetDraft(
    PageInfo^ page
)
Parameters
page (PageInfo)
The Page.
Return Value
The draft, or null if no draft exists.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: PluginPack (Module: PluginPack) Version: 3.0.2.500 (3.0.2.500)


GetIndexStats Method (documentCount, wordCount, occurrenceCount, size)

GetIndexStats Method (documentCount, wordCount, occurrenceCount, size)
ScrewTurn Wiki ► ScrewTurn.Wiki.Plugins.PluginPack ► PagesSandbox ► GetIndexStats(Int32%, Int32%, Int32%, Int64%)
Gets some statistics about the search engine index.
Declaration Syntax
C# Visual Basic Visual C++
public void GetIndexStats(
    out int documentCount,
    out int wordCount,
    out int occurrenceCount,
    out long size
)
Public Sub GetIndexStats ( _
    <OutAttribute> ByRef documentCount As Integer, _
    <OutAttribute> ByRef wordCount As Integer, _
    <OutAttribute> ByRef occurrenceCount As Integer, _
    <OutAttribute> ByRef size As Long _
)
public:
void GetIndexStats(
    [OutAttribute] int% documentCount,
    [OutAttribute] int% wordCount,
    [OutAttribute] int% occurrenceCount,
    [OutAttribute] long long% size
)
Parameters
documentCount ( Int32 %)
The total number of documents.
wordCount ( Int32 %)
The total number of unique words.
occurrenceCount ( Int32 %)
The total number of word-document occurrences.
size ( Int64 %)
The approximated size, in bytes, of the search engine index.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: PluginPack (Module: PluginPack) Version: 3.0.2.500 (3.0.2.500)


GetMessageCount Method (page)

GetMessageCount Method (page)
ScrewTurn Wiki ► ScrewTurn.Wiki.Plugins.PluginPack ► PagesSandbox ► GetMessageCount(PageInfo)
Gets the total number of Messages in a Page Discussion.
Declaration Syntax
C# Visual Basic Visual C++
public int GetMessageCount(
    PageInfo page
)
Public Function GetMessageCount ( _
    page As PageInfo _
) As Integer
public:
int GetMessageCount(
    PageInfo^ page
)
Parameters
page (PageInfo)
The Page.
Return Value
The number of messages.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: PluginPack (Module: PluginPack) Version: 3.0.2.500 (3.0.2.500)


GetMessages Method (page)

GetMessages Method (page)
ScrewTurn Wiki ► ScrewTurn.Wiki.Plugins.PluginPack ► PagesSandbox ► GetMessages(PageInfo)
Gets the Page Messages.
Declaration Syntax
C# Visual Basic Visual C++
public Message[] GetMessages(
    PageInfo page
)
Public Function GetMessages ( _
    page As PageInfo _
) As Message()
public:
array<Message^>^ GetMessages(
    PageInfo^ page
)
Parameters
page (PageInfo)
The Page.
Return Value
The list of the first-level Messages, containing the replies properly nested, sorted by date/time.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: PluginPack (Module: PluginPack) Version: 3.0.2.500 (3.0.2.500)


GetNamespace Method (name)

GetNamespace Method (name)
ScrewTurn Wiki ► ScrewTurn.Wiki.Plugins.PluginPack ► PagesSandbox ► GetNamespace(String)
Gets a namespace.
Declaration Syntax
C# Visual Basic Visual C++
public NamespaceInfo GetNamespace(
    string name
)
Public Function GetNamespace ( _
    name As String _
) As NamespaceInfo
public:
NamespaceInfo^ GetNamespace(
    String^ name
)
Parameters
name (String)
The name of the namespace (cannot be null or empty).
Return Value
The NamespaceInfo, or null if no namespace is found.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: PluginPack (Module: PluginPack) Version: 3.0.2.500 (3.0.2.500)


GetNamespaces Method

GetNamespaces Method
ScrewTurn Wiki ► ScrewTurn.Wiki.Plugins.PluginPack ► PagesSandbox ► GetNamespaces()()()
Gets all the sub-namespaces.
Declaration Syntax
C# Visual Basic Visual C++
public NamespaceInfo[] GetNamespaces()
Public Function GetNamespaces As NamespaceInfo()
public:
array<NamespaceInfo^>^ GetNamespaces()
Return Value
The sub-namespaces, sorted by name.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: PluginPack (Module: PluginPack) Version: 3.0.2.500 (3.0.2.500)


GetNavigationPaths Method (nspace)

GetNavigationPaths Method (nspace)
ScrewTurn Wiki ► ScrewTurn.Wiki.Plugins.PluginPack ► PagesSandbox ► GetNavigationPaths(NamespaceInfo)
Gets all the Navigation Paths in a Namespace.
Declaration Syntax
C# Visual Basic Visual C++
public NavigationPath[] GetNavigationPaths(
    NamespaceInfo nspace
)
Public Function GetNavigationPaths ( _
    nspace As NamespaceInfo _
) As NavigationPath()
public:
array<NavigationPath^>^ GetNavigationPaths(
    NamespaceInfo^ nspace
)
Parameters
nspace (NamespaceInfo)
The Namespace.
Return Value
All the Navigation Paths, sorted by name.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: PluginPack (Module: PluginPack) Version: 3.0.2.500 (3.0.2.500)


GetPage Method (fullName)

GetPage Method (fullName)
ScrewTurn Wiki ► ScrewTurn.Wiki.Plugins.PluginPack ► PagesSandbox ► GetPage(String)
Gets a page.
Declaration Syntax
C# Visual Basic Visual C++
public PageInfo GetPage(
    string fullName
)
Public Function GetPage ( _
    fullName As String _
) As PageInfo
public:
PageInfo^ GetPage(
    String^ fullName
)
Parameters
fullName (String)
The full name of the page.
Return Value
The PageInfo, or null if no page is found.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: PluginPack (Module: PluginPack) Version: 3.0.2.500 (3.0.2.500)


GetPages Method (nspace)

GetPages Method (nspace)
ScrewTurn Wiki ► ScrewTurn.Wiki.Plugins.PluginPack ► PagesSandbox ► GetPages(NamespaceInfo)
Gets all the Pages in a namespace.
Declaration Syntax
C# Visual Basic Visual C++
public PageInfo[] GetPages(
    NamespaceInfo nspace
)
Public Function GetPages ( _
    nspace As NamespaceInfo _
) As PageInfo()
public:
array<PageInfo^>^ GetPages(
    NamespaceInfo^ nspace
)
Parameters
nspace (NamespaceInfo)
The namespace (null for the root).
Return Value
All the Pages in the namespace, sorted by name.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: PluginPack (Module: PluginPack) Version: 3.0.2.500 (3.0.2.500)


GetSnippets Method

GetSnippets Method
ScrewTurn Wiki ► ScrewTurn.Wiki.Plugins.PluginPack ► PagesSandbox ► GetSnippets()()()
Gets all the snippets.
Declaration Syntax
C# Visual Basic Visual C++
public Snippet[] GetSnippets()
Public Function GetSnippets As Snippet()
public:
array<Snippet^>^ GetSnippets()
Return Value
All the snippets, sorted by name.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: PluginPack (Module: PluginPack) Version: 3.0.2.500 (3.0.2.500)


GetUncategorizedPages Method (nspace)

GetUncategorizedPages Method (nspace)
ScrewTurn Wiki ► ScrewTurn.Wiki.Plugins.PluginPack ► PagesSandbox ► GetUncategorizedPages(NamespaceInfo)
Gets all the pages in a namespace that are bound to zero categories.
Declaration Syntax
C# Visual Basic Visual C++
public PageInfo[] GetUncategorizedPages(
    NamespaceInfo nspace
)
Public Function GetUncategorizedPages ( _
    nspace As NamespaceInfo _
) As PageInfo()
public:
array<PageInfo^>^ GetUncategorizedPages(
    NamespaceInfo^ nspace
)
Parameters
nspace (NamespaceInfo)
The namespace (null for the root).
Return Value
The pages, sorted by name.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: PluginPack (Module: PluginPack) Version: 3.0.2.500 (3.0.2.500)


Information Property

Information Property
ScrewTurn Wiki ► ScrewTurn.Wiki.Plugins.PluginPack ► PagesSandbox ► Information
Gets the Information about the Provider.
Declaration Syntax
C# Visual Basic Visual C++
public ComponentInformation Information { get; }
Public ReadOnly Property Information As ComponentInformation
public:
property ComponentInformation^ Information {
    ComponentInformation^ get ();
}

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: PluginPack (Module: PluginPack) Version: 3.0.2.500 (3.0.2.500)


Init Method (host, config)

Init Method (host, config)
ScrewTurn Wiki ► ScrewTurn.Wiki.Plugins.PluginPack ► PagesSandbox ► Init(IHostV30, String)
Initializes the Storage Provider.
Declaration Syntax
C# Visual Basic Visual C++
public void Init(
    IHostV30 host,
    string config
)
Public Sub Init ( _
    host As IHostV30, _
    config As String _
)
public:
void Init(
    IHostV30^ host,
    String^ config
)
Parameters
host (IHostV30)
The Host of the Component.
config (String)
The Configuration data, if any.
Remarks
If the configuration string is not valid, the methoud should throw a InvalidConfigurationException.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: PluginPack (Module: PluginPack) Version: 3.0.2.500 (3.0.2.500)


IsIndexCorrupted Property

IsIndexCorrupted Property
ScrewTurn Wiki ► ScrewTurn.Wiki.Plugins.PluginPack ► PagesSandbox ► IsIndexCorrupted
Gets a value indicating whether the search engine index is corrupted and needs to be rebuilt.
Declaration Syntax
C# Visual Basic Visual C++
public bool IsIndexCorrupted { get; }
Public ReadOnly Property IsIndexCorrupted As Boolean
public:
property bool IsIndexCorrupted {
    bool get ();
}

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: PluginPack (Module: PluginPack) Version: 3.0.2.500 (3.0.2.500)


MergeCategories Method (source, destination)

MergeCategories Method (source, destination)
ScrewTurn Wiki ► ScrewTurn.Wiki.Plugins.PluginPack ► PagesSandbox ► MergeCategories(CategoryInfo, CategoryInfo)
Merges two Categories.
Declaration Syntax
C# Visual Basic Visual C++
public CategoryInfo MergeCategories(
    CategoryInfo source,
    CategoryInfo destination
)
Public Function MergeCategories ( _
    source As CategoryInfo, _
    destination As CategoryInfo _
) As CategoryInfo
public:
CategoryInfo^ MergeCategories(
    CategoryInfo^ source,
    CategoryInfo^ destination
)
Parameters
source (CategoryInfo)
The source Category.
destination (CategoryInfo)
The destination Category.
Return Value
The correct CategoryInfo object.
Remarks
The destination Category remains, while the source Category is deleted, and all its Pages re-bound in the destination Category.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: PluginPack (Module: PluginPack) Version: 3.0.2.500 (3.0.2.500)


ModifyContentTemplate Method (name, content)

ModifyContentTemplate Method (name, content)
ScrewTurn Wiki ► ScrewTurn.Wiki.Plugins.PluginPack ► PagesSandbox ► ModifyContentTemplate(String, String)
Modifies an existing content template.
Declaration Syntax
C# Visual Basic Visual C++
public ContentTemplate ModifyContentTemplate(
    string name,
    string content
)
Public Function ModifyContentTemplate ( _
    name As String, _
    content As String _
) As ContentTemplate
public:
ContentTemplate^ ModifyContentTemplate(
    String^ name,
    String^ content
)
Parameters
name (String)
The name of the template to modify.
content (String)
The content of the template.
Return Value
The correct ContentTemplate object.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: PluginPack (Module: PluginPack) Version: 3.0.2.500 (3.0.2.500)


ModifyMessage Method (page, id, username, subject, dateTime, body)

ModifyMessage Method (page, id, username, subject, dateTime, body)
ScrewTurn Wiki ► ScrewTurn.Wiki.Plugins.PluginPack ► PagesSandbox ► ModifyMessage(PageInfo, Int32, String, String, DateTime, String)
Modifies a Message.
Declaration Syntax
C# Visual Basic Visual C++
public bool ModifyMessage(
    PageInfo page,
    int id,
    string username,
    string subject,
    DateTime dateTime,
    string body
)
Public Function ModifyMessage ( _
    page As PageInfo, _
    id As Integer, _
    username As String, _
    subject As String, _
    dateTime As DateTime, _
    body As String _
) As Boolean
public:
bool ModifyMessage(
    PageInfo^ page,
    int id,
    String^ username,
    String^ subject,
    DateTime dateTime,
    String^ body
)
Parameters
page (PageInfo)
The Page.
id (Int32)
The ID of the Message to modify.
username (String)
The Username.
subject (String)
The Subject.
dateTime (DateTime)
The Date/Time.
body (String)
The Body.
Return Value
True if the Message is modified successfully.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: PluginPack (Module: PluginPack) Version: 3.0.2.500 (3.0.2.500)


ModifyNavigationPath Method (path, pages)

ModifyNavigationPath Method (path, pages)
ScrewTurn Wiki ► ScrewTurn.Wiki.Plugins.PluginPack ► PagesSandbox ► ModifyNavigationPath(NavigationPath, array<PageInfo>[]()[])
Modifies an existing navigation path.
Declaration Syntax
C# Visual Basic Visual C++
public NavigationPath ModifyNavigationPath(
    NavigationPath path,
    PageInfo[] pages
)
Public Function ModifyNavigationPath ( _
    path As NavigationPath, _
    pages As PageInfo() _
) As NavigationPath
public:
NavigationPath^ ModifyNavigationPath(
    NavigationPath^ path,
    array<PageInfo^>^ pages
)
Parameters
path (NavigationPath)
The navigation path to modify.
pages (array< PageInfo >[]()[][])
The new pages array.
Return Value
The correct NavigationPath object.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: PluginPack (Module: PluginPack) Version: 3.0.2.500 (3.0.2.500)


ModifyPage Method (page, title, username, dateTime, comment, content, keywords, description, saveMode)

ModifyPage Method (page, title, username, dateTime, comment, content, keywords, description, saveMode)
ScrewTurn Wiki ► ScrewTurn.Wiki.Plugins.PluginPack ► PagesSandbox ► ModifyPage(PageInfo, String, String, DateTime, String, String, array<String>[]()[], String, SaveMode)
Modifies the Content of a Page.
Declaration Syntax
C# Visual Basic Visual C++
public bool ModifyPage(
    PageInfo page,
    string title,
    string username,
    DateTime dateTime,
    string comment,
    string content,
    string[] keywords,
    string description,
    SaveMode saveMode
)
Public Function ModifyPage ( _
    page As PageInfo, _
    title As String, _
    username As String, _
    dateTime As DateTime, _
    comment As String, _
    content As String, _
    keywords As String(), _
    description As String, _
    saveMode As SaveMode _
) As Boolean
public:
bool ModifyPage(
    PageInfo^ page,
    String^ title,
    String^ username,
    DateTime dateTime,
    String^ comment,
    String^ content,
    array<String^>^ keywords,
    String^ description,
    SaveMode saveMode
)
Parameters
page (PageInfo)
The Page.
title (String)
The Title of the Page.
username (String)
The Username.
dateTime (DateTime)
The Date/Time.
comment (String)
The Comment of the editor, about this revision.
content (String)
The Page Content.
keywords (array< String >[]()[][])
The keywords, usually used for SEO.
description (String)
The description, usually used for SEO.
saveMode (SaveMode)
The save mode for this modification.
Return Value
true if the Page has been modified successfully, false otherwise.
Remarks
If saveMode equals Draft and a draft already exists, it is overwritten.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: PluginPack (Module: PluginPack) Version: 3.0.2.500 (3.0.2.500)


ModifySnippet Method (name, content)

ModifySnippet Method (name, content)
ScrewTurn Wiki ► ScrewTurn.Wiki.Plugins.PluginPack ► PagesSandbox ► ModifySnippet(String, String)
Modifies an existing snippet.
Declaration Syntax
C# Visual Basic Visual C++
public Snippet ModifySnippet(
    string name,
    string content
)
Public Function ModifySnippet ( _
    name As String, _
    content As String _
) As Snippet
public:
Snippet^ ModifySnippet(
    String^ name,
    String^ content
)
Parameters
name (String)
The name of the snippet to modify.
content (String)
The content of the snippet.
Return Value
The correct Snippet object.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: PluginPack (Module: PluginPack) Version: 3.0.2.500 (3.0.2.500)


MovePage Method (page, destination, copyCategories)

MovePage Method (page, destination, copyCategories)
ScrewTurn Wiki ► ScrewTurn.Wiki.Plugins.PluginPack ► PagesSandbox ► MovePage(PageInfo, NamespaceInfo, Boolean)
Moves a page from its namespace into another.
Declaration Syntax
C# Visual Basic Visual C++
public PageInfo MovePage(
    PageInfo page,
    NamespaceInfo destination,
    bool copyCategories
)
Public Function MovePage ( _
    page As PageInfo, _
    destination As NamespaceInfo, _
    copyCategories As Boolean _
) As PageInfo
public:
PageInfo^ MovePage(
    PageInfo^ page,
    NamespaceInfo^ destination,
    bool copyCategories
)
Parameters
page (PageInfo)
The page to move.
destination (NamespaceInfo)
The destination namespace (null for the root).
copyCategories (Boolean)
A value indicating whether to copy the page categories in the destination namespace, if not already available.
Return Value
The correct instance of PageInfo.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: PluginPack (Module: PluginPack) Version: 3.0.2.500 (3.0.2.500)


PerformSearch Method (parameters)

PerformSearch Method (parameters)
ScrewTurn Wiki ► ScrewTurn.Wiki.Plugins.PluginPack ► PagesSandbox ► PerformSearch(SearchParameters)
Performs a search in the index.
Declaration Syntax
C# Visual Basic Visual C++
public SearchResultCollection PerformSearch(
    SearchParameters parameters
)
Public Function PerformSearch ( _
    parameters As SearchParameters _
) As SearchResultCollection
public:
SearchResultCollection^ PerformSearch(
    SearchParameters^ parameters
)
Parameters
parameters (SearchParameters)
The search parameters.
Return Value
The results.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: PluginPack (Module: PluginPack) Version: 3.0.2.500 (3.0.2.500)


ReadOnly Property

ReadOnly Property
ScrewTurn Wiki ► ScrewTurn.Wiki.Plugins.PluginPack ► PagesSandbox ► ReadOnly
Gets a value specifying whether the provider is read-only, i.e. it can only provide data and not store it.
Declaration Syntax
C# Visual Basic Visual C++
public bool ReadOnly { get; }
Public ReadOnly Property ReadOnly As Boolean
public:
property bool ReadOnly {
    bool get ();
}

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: PluginPack (Module: PluginPack) Version: 3.0.2.500 (3.0.2.500)


RebindPage Method (page, categories)

RebindPage Method (page, categories)
ScrewTurn Wiki ► ScrewTurn.Wiki.Plugins.PluginPack ► PagesSandbox ► RebindPage(PageInfo, array<String>[]()[])
Binds a Page with one or more Categories.
Declaration Syntax
C# Visual Basic Visual C++
public bool RebindPage(
    PageInfo page,
    string[] categories
)
Public Function RebindPage ( _
    page As PageInfo, _
    categories As String() _
) As Boolean
public:
bool RebindPage(
    PageInfo^ page,
    array<String^>^ categories
)
Parameters
page (PageInfo)
The Page to bind.
categories (array< String >[]()[][])
The Categories to bind the Page with.
Return Value
True if the binding succeeded.
Remarks
After a successful operation, the Page is bound with all and only the categories passed as argument.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: PluginPack (Module: PluginPack) Version: 3.0.2.500 (3.0.2.500)


RebuildIndex Method

RebuildIndex Method
ScrewTurn Wiki ► ScrewTurn.Wiki.Plugins.PluginPack ► PagesSandbox ► RebuildIndex()()()
Rebuilds the search index.
Declaration Syntax
C# Visual Basic Visual C++
public void RebuildIndex()
Public Sub RebuildIndex
public:
void RebuildIndex()

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: PluginPack (Module: PluginPack) Version: 3.0.2.500 (3.0.2.500)


RemoveCategory Method (category)

RemoveCategory Method (category)
ScrewTurn Wiki ► ScrewTurn.Wiki.Plugins.PluginPack ► PagesSandbox ► RemoveCategory(CategoryInfo)
Removes a Category.
Declaration Syntax
C# Visual Basic Visual C++
public bool RemoveCategory(
    CategoryInfo category
)
Public Function RemoveCategory ( _
    category As CategoryInfo _
) As Boolean
public:
bool RemoveCategory(
    CategoryInfo^ category
)
Parameters
category (CategoryInfo)
The Category to remove.
Return Value
True if the Category has been removed successfully.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: PluginPack (Module: PluginPack) Version: 3.0.2.500 (3.0.2.500)


RemoveContentTemplate Method (name)

RemoveContentTemplate Method (name)
ScrewTurn Wiki ► ScrewTurn.Wiki.Plugins.PluginPack ► PagesSandbox ► RemoveContentTemplate(String)
Removes a content template.
Declaration Syntax
C# Visual Basic Visual C++
public bool RemoveContentTemplate(
    string name
)
Public Function RemoveContentTemplate ( _
    name As String _
) As Boolean
public:
bool RemoveContentTemplate(
    String^ name
)
Parameters
name (String)
The name of the template to remove.
Return Value
true if the template is removed, false otherwise.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: PluginPack (Module: PluginPack) Version: 3.0.2.500 (3.0.2.500)


RemoveMessage Method (page, id, removeReplies)

RemoveMessage Method (page, id, removeReplies)
ScrewTurn Wiki ► ScrewTurn.Wiki.Plugins.PluginPack ► PagesSandbox ► RemoveMessage(PageInfo, Int32, Boolean)
Removes a Message.
Declaration Syntax
C# Visual Basic Visual C++
public bool RemoveMessage(
    PageInfo page,
    int id,
    bool removeReplies
)
Public Function RemoveMessage ( _
    page As PageInfo, _
    id As Integer, _
    removeReplies As Boolean _
) As Boolean
public:
bool RemoveMessage(
    PageInfo^ page,
    int id,
    bool removeReplies
)
Parameters
page (PageInfo)
The Page.
id (Int32)
The ID of the Message to remove.
removeReplies (Boolean)
A value specifying whether or not to remove the replies.
Return Value
True if the Message is removed successfully.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: PluginPack (Module: PluginPack) Version: 3.0.2.500 (3.0.2.500)


RemoveNamespace Method (nspace)

RemoveNamespace Method (nspace)
ScrewTurn Wiki ► ScrewTurn.Wiki.Plugins.PluginPack ► PagesSandbox ► RemoveNamespace(NamespaceInfo)
Removes a namespace.
Declaration Syntax
C# Visual Basic Visual C++
public bool RemoveNamespace(
    NamespaceInfo nspace
)
Public Function RemoveNamespace ( _
    nspace As NamespaceInfo _
) As Boolean
public:
bool RemoveNamespace(
    NamespaceInfo^ nspace
)
Parameters
nspace (NamespaceInfo)
The namespace to remove.
Return Value
true if the namespace is removed, false otherwise.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: PluginPack (Module: PluginPack) Version: 3.0.2.500 (3.0.2.500)


RemoveNavigationPath Method (path)

RemoveNavigationPath Method (path)
ScrewTurn Wiki ► ScrewTurn.Wiki.Plugins.PluginPack ► PagesSandbox ► RemoveNavigationPath(NavigationPath)
Removes a Navigation Path.
Declaration Syntax
C# Visual Basic Visual C++
public bool RemoveNavigationPath(
    NavigationPath path
)
Public Function RemoveNavigationPath ( _
    path As NavigationPath _
) As Boolean
public:
bool RemoveNavigationPath(
    NavigationPath^ path
)
Parameters
path (NavigationPath)
The navigation path to remove.
Return Value
true if the path is removed, false otherwise.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: PluginPack (Module: PluginPack) Version: 3.0.2.500 (3.0.2.500)


RemovePage Method (page)

RemovePage Method (page)
ScrewTurn Wiki ► ScrewTurn.Wiki.Plugins.PluginPack ► PagesSandbox ► RemovePage(PageInfo)
Removes a Page.
Declaration Syntax
C# Visual Basic Visual C++
public bool RemovePage(
    PageInfo page
)
Public Function RemovePage ( _
    page As PageInfo _
) As Boolean
public:
bool RemovePage(
    PageInfo^ page
)
Parameters
page (PageInfo)
The Page to remove.
Return Value
True if the Page is removed successfully.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: PluginPack (Module: PluginPack) Version: 3.0.2.500 (3.0.2.500)


RemoveSnippet Method (name)

RemoveSnippet Method (name)
ScrewTurn Wiki ► ScrewTurn.Wiki.Plugins.PluginPack ► PagesSandbox ► RemoveSnippet(String)
Removes a new Snippet.
Declaration Syntax
C# Visual Basic Visual C++
public bool RemoveSnippet(
    string name
)
Public Function RemoveSnippet ( _
    name As String _
) As Boolean
public:
bool RemoveSnippet(
    String^ name
)
Parameters
name (String)
The Name of the Snippet to remove.
Return Value
true if the snippet is removed, false otherwise.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: PluginPack (Module: PluginPack) Version: 3.0.2.500 (3.0.2.500)


RenameCategory Method (category, newName)

RenameCategory Method (category, newName)
ScrewTurn Wiki ► ScrewTurn.Wiki.Plugins.PluginPack ► PagesSandbox ► RenameCategory(CategoryInfo, String)
Renames a Category.
Declaration Syntax
C# Visual Basic Visual C++
public CategoryInfo RenameCategory(
    CategoryInfo category,
    string newName
)
Public Function RenameCategory ( _
    category As CategoryInfo, _
    newName As String _
) As CategoryInfo
public:
CategoryInfo^ RenameCategory(
    CategoryInfo^ category,
    String^ newName
)
Parameters
category (CategoryInfo)
The Category to rename.
newName (String)
The new Name.
Return Value
The correct CategoryInfo object.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: PluginPack (Module: PluginPack) Version: 3.0.2.500 (3.0.2.500)


RenameNamespace Method (nspace, newName)

RenameNamespace Method (nspace, newName)
ScrewTurn Wiki ► ScrewTurn.Wiki.Plugins.PluginPack ► PagesSandbox ► RenameNamespace(NamespaceInfo, String)
Renames a namespace.
Declaration Syntax
C# Visual Basic Visual C++
public NamespaceInfo RenameNamespace(
    NamespaceInfo nspace,
    string newName
)
Public Function RenameNamespace ( _
    nspace As NamespaceInfo, _
    newName As String _
) As NamespaceInfo
public:
NamespaceInfo^ RenameNamespace(
    NamespaceInfo^ nspace,
    String^ newName
)
Parameters
nspace (NamespaceInfo)
The namespace to rename.
newName (String)
The new name of the namespace.
Return Value
The correct NamespaceInfo object.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: PluginPack (Module: PluginPack) Version: 3.0.2.500 (3.0.2.500)


RenamePage Method (page, newName)

RenamePage Method (page, newName)
ScrewTurn Wiki ► ScrewTurn.Wiki.Plugins.PluginPack ► PagesSandbox ► RenamePage(PageInfo, String)
Renames a Page.
Declaration Syntax
C# Visual Basic Visual C++
public PageInfo RenamePage(
    PageInfo page,
    string newName
)
Public Function RenamePage ( _
    page As PageInfo, _
    newName As String _
) As PageInfo
public:
PageInfo^ RenamePage(
    PageInfo^ page,
    String^ newName
)
Parameters
page (PageInfo)
The Page to rename.
newName (String)
The new Name.
Return Value
The correct PageInfo object.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: PluginPack (Module: PluginPack) Version: 3.0.2.500 (3.0.2.500)


RollbackPage Method (page, revision)

RollbackPage Method (page, revision)
ScrewTurn Wiki ► ScrewTurn.Wiki.Plugins.PluginPack ► PagesSandbox ► RollbackPage(PageInfo, Int32)
Performs the rollback of a Page to a specified revision.
Declaration Syntax
C# Visual Basic Visual C++
public bool RollbackPage(
    PageInfo page,
    int revision
)
Public Function RollbackPage ( _
    page As PageInfo, _
    revision As Integer _
) As Boolean
public:
bool RollbackPage(
    PageInfo^ page,
    int revision
)
Parameters
page (PageInfo)
The Page to rollback.
revision (Int32)
The Revision to rollback the Page to.
Return Value
true if the rollback succeeded, false otherwise.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: PluginPack (Module: PluginPack) Version: 3.0.2.500 (3.0.2.500)


SetBackupContent Method (content, revision)

SetBackupContent Method (content, revision)
ScrewTurn Wiki ► ScrewTurn.Wiki.Plugins.PluginPack ► PagesSandbox ► SetBackupContent(PageContent, Int32)
Forces to overwrite or create a Backup.
Declaration Syntax
C# Visual Basic Visual C++
public bool SetBackupContent(
    PageContent content,
    int revision
)
Public Function SetBackupContent ( _
    content As PageContent, _
    revision As Integer _
) As Boolean
public:
bool SetBackupContent(
    PageContent^ content,
    int revision
)
Parameters
content (PageContent)
The Backup content.
revision (Int32)
The revision.
Return Value
True if the Backup has been created successfully.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: PluginPack (Module: PluginPack) Version: 3.0.2.500 (3.0.2.500)


SetNamespaceDefaultPage Method (nspace, page)

SetNamespaceDefaultPage Method (nspace, page)
ScrewTurn Wiki ► ScrewTurn.Wiki.Plugins.PluginPack ► PagesSandbox ► SetNamespaceDefaultPage(NamespaceInfo, PageInfo)
Sets the default page of a namespace.
Declaration Syntax
C# Visual Basic Visual C++
public NamespaceInfo SetNamespaceDefaultPage(
    NamespaceInfo nspace,
    PageInfo page
)
Public Function SetNamespaceDefaultPage ( _
    nspace As NamespaceInfo, _
    page As PageInfo _
) As NamespaceInfo
public:
NamespaceInfo^ SetNamespaceDefaultPage(
    NamespaceInfo^ nspace,
    PageInfo^ page
)
Parameters
nspace (NamespaceInfo)
The namespace of which to set the default page.
page (PageInfo)
The page to use as default page, or null.
Return Value
The correct NamespaceInfo object.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: PluginPack (Module: PluginPack) Version: 3.0.2.500 (3.0.2.500)


Shutdown Method

Shutdown Method
ScrewTurn Wiki ► ScrewTurn.Wiki.Plugins.PluginPack ► PagesSandbox ► Shutdown()()()
Method invoked on shutdown.
Declaration Syntax
C# Visual Basic Visual C++
public void Shutdown()
Public Sub Shutdown
public:
void Shutdown()
Remarks
This method might not be invoked in some cases.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: PluginPack (Module: PluginPack) Version: 3.0.2.500 (3.0.2.500)


RssFeedDisplay Class

RssFeedDisplay Class
ScrewTurn Wiki ► ScrewTurn.Wiki.Plugins.PluginPack ► RssFeedDisplay
Implements a formatter provider that counts download of files and attachments.
Declaration Syntax
C# Visual Basic Visual C++
public class RssFeedDisplay : IFormatterProviderV30,
    IProviderV30
Public Class RssFeedDisplay _
    Implements IFormatterProviderV30, IProviderV30
public ref class RssFeedDisplay : IFormatterProviderV30,
    IProviderV30
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | RssFeedDisplay()()() | Initializes a new instance of the RssFeedDisplay class
 | ConfigHelpHtml | Gets a brief summary of the configuration string format, in HTML. Returns null if no configuration is needed.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | ExecutionPriority | Gets the execution priority of the provider (0 lowest, 100 highest).
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | Format(String, ContextInformation, FormattingPhase) | Performs a Formatting phase.
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | Information | Gets the Information about the Provider.
 | Init(IHostV30, String) | Initializes the Storage Provider.
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | PerformPhase1 | Specifies whether or not to execute Phase 1.
 | PerformPhase2 | Specifies whether or not to execute Phase 2.
 | PerformPhase3 | Specifies whether or not to execute Phase 3.
 | PrepareTitle(String, ContextInformation) | Prepares the title of an item for display (always during phase 3).
 | Shutdown()()() | Method invoked on shutdown.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
RssFeedDisplay

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: PluginPack (Module: PluginPack) Version: 3.0.2.500 (3.0.2.500)


RssFeedDisplay Constructor

RssFeedDisplay Constructor
ScrewTurn Wiki ► ScrewTurn.Wiki.Plugins.PluginPack ► RssFeedDisplay ► RssFeedDisplay()()()
Initializes a new instance of the RssFeedDisplay class
Declaration Syntax
C# Visual Basic Visual C++
public RssFeedDisplay()
Public Sub New
public:
RssFeedDisplay()

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: PluginPack (Module: PluginPack) Version: 3.0.2.500 (3.0.2.500)


ConfigHelpHtml Property

ConfigHelpHtml Property
ScrewTurn Wiki ► ScrewTurn.Wiki.Plugins.PluginPack ► RssFeedDisplay ► ConfigHelpHtml
Gets a brief summary of the configuration string format, in HTML. Returns null if no configuration is needed.
Declaration Syntax
C# Visual Basic Visual C++
public string ConfigHelpHtml { get; }
Public ReadOnly Property ConfigHelpHtml As String
public:
virtual property String^ ConfigHelpHtml {
    String^ get () sealed;
}

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: PluginPack (Module: PluginPack) Version: 3.0.2.500 (3.0.2.500)


ExecutionPriority Property

ExecutionPriority Property
ScrewTurn Wiki ► ScrewTurn.Wiki.Plugins.PluginPack ► RssFeedDisplay ► ExecutionPriority
Gets the execution priority of the provider (0 lowest, 100 highest).
Declaration Syntax
C# Visual Basic Visual C++
public int ExecutionPriority { get; }
Public ReadOnly Property ExecutionPriority As Integer
public:
virtual property int ExecutionPriority {
    int get () sealed;
}

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: PluginPack (Module: PluginPack) Version: 3.0.2.500 (3.0.2.500)


Format Method (raw, context, phase)

Format Method (raw, context, phase)
ScrewTurn Wiki ► ScrewTurn.Wiki.Plugins.PluginPack ► RssFeedDisplay ► Format(String, ContextInformation, FormattingPhase)
Performs a Formatting phase.
Declaration Syntax
C# Visual Basic Visual C++
public string Format(
    string raw,
    ContextInformation context,
    FormattingPhase phase
)
Public Function Format ( _
    raw As String, _
    context As ContextInformation, _
    phase As FormattingPhase _
) As String
public:
virtual String^ Format(
    String^ raw,
    ContextInformation^ context,
    FormattingPhase phase
) sealed
Parameters
raw (String)
The raw content to Format.
context (ContextInformation)
The Context information.
phase (FormattingPhase)
The Phase.
Return Value
The Formatted content.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: PluginPack (Module: PluginPack) Version: 3.0.2.500 (3.0.2.500)


Information Property

Information Property
ScrewTurn Wiki ► ScrewTurn.Wiki.Plugins.PluginPack ► RssFeedDisplay ► Information
Gets the Information about the Provider.
Declaration Syntax
C# Visual Basic Visual C++
public ComponentInformation Information { get; }
Public ReadOnly Property Information As ComponentInformation
public:
virtual property ComponentInformation^ Information {
    ComponentInformation^ get () sealed;
}

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: PluginPack (Module: PluginPack) Version: 3.0.2.500 (3.0.2.500)


Init Method (host, config)

Init Method (host, config)
ScrewTurn Wiki ► ScrewTurn.Wiki.Plugins.PluginPack ► RssFeedDisplay ► Init(IHostV30, String)
Initializes the Storage Provider.
Declaration Syntax
C# Visual Basic Visual C++
public void Init(
    IHostV30 host,
    string config
)
Public Sub Init ( _
    host As IHostV30, _
    config As String _
)
public:
virtual void Init(
    IHostV30^ host,
    String^ config
) sealed
Parameters
host (IHostV30)
The Host of the Component.
config (String)
The Configuration data, if any.
Remarks
If the configuration string is not valid, the methoud should throw a InvalidConfigurationException.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: PluginPack (Module: PluginPack) Version: 3.0.2.500 (3.0.2.500)


PerformPhase1 Property

PerformPhase1 Property
ScrewTurn Wiki ► ScrewTurn.Wiki.Plugins.PluginPack ► RssFeedDisplay ► PerformPhase1
Specifies whether or not to execute Phase 1.
Declaration Syntax
C# Visual Basic Visual C++
public bool PerformPhase1 { get; }
Public ReadOnly Property PerformPhase1 As Boolean
public:
virtual property bool PerformPhase1 {
    bool get () sealed;
}

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: PluginPack (Module: PluginPack) Version: 3.0.2.500 (3.0.2.500)


PerformPhase2 Property

PerformPhase2 Property
ScrewTurn Wiki ► ScrewTurn.Wiki.Plugins.PluginPack ► RssFeedDisplay ► PerformPhase2
Specifies whether or not to execute Phase 2.
Declaration Syntax
C# Visual Basic Visual C++
public bool PerformPhase2 { get; }
Public ReadOnly Property PerformPhase2 As Boolean
public:
virtual property bool PerformPhase2 {
    bool get () sealed;
}

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: PluginPack (Module: PluginPack) Version: 3.0.2.500 (3.0.2.500)


PerformPhase3 Property

PerformPhase3 Property
ScrewTurn Wiki ► ScrewTurn.Wiki.Plugins.PluginPack ► RssFeedDisplay ► PerformPhase3
Specifies whether or not to execute Phase 3.
Declaration Syntax
C# Visual Basic Visual C++
public bool PerformPhase3 { get; }
Public ReadOnly Property PerformPhase3 As Boolean
public:
virtual property bool PerformPhase3 {
    bool get () sealed;
}

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: PluginPack (Module: PluginPack) Version: 3.0.2.500 (3.0.2.500)


PrepareTitle Method (title, context)

PrepareTitle Method (title, context)
ScrewTurn Wiki ► ScrewTurn.Wiki.Plugins.PluginPack ► RssFeedDisplay ► PrepareTitle(String, ContextInformation)
Prepares the title of an item for display (always during phase 3).
Declaration Syntax
C# Visual Basic Visual C++
public string PrepareTitle(
    string title,
    ContextInformation context
)
Public Function PrepareTitle ( _
    title As String, _
    context As ContextInformation _
) As String
public:
virtual String^ PrepareTitle(
    String^ title,
    ContextInformation^ context
) sealed
Parameters
title (String)
The input title.
context (ContextInformation)
The context information.
Return Value
The prepared title (no markup allowed).

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: PluginPack (Module: PluginPack) Version: 3.0.2.500 (3.0.2.500)


Shutdown Method

Shutdown Method
ScrewTurn Wiki ► ScrewTurn.Wiki.Plugins.PluginPack ► RssFeedDisplay ► Shutdown()()()
Method invoked on shutdown.
Declaration Syntax
C# Visual Basic Visual C++
public void Shutdown()
Public Sub Shutdown
public:
virtual void Shutdown() sealed
Remarks
This method might not be invoked in some cases.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: PluginPack (Module: PluginPack) Version: 3.0.2.500 (3.0.2.500)


UnfuddleTickets Class

UnfuddleTickets Class
ScrewTurn Wiki ► ScrewTurn.Wiki.Plugins.PluginPack ► UnfuddleTickets
Implements a formatter that display tickets from Unfuddle.
Declaration Syntax
C# Visual Basic Visual C++
public class UnfuddleTickets : IFormatterProviderV30,
    IProviderV30
Public Class UnfuddleTickets _
    Implements IFormatterProviderV30, IProviderV30
public ref class UnfuddleTickets : IFormatterProviderV30,
    IProviderV30
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | UnfuddleTickets()()() | Initializes a new instance of the UnfuddleTickets class
 | ConfigHelpHtml | Gets a brief summary of the configuration string format, in HTML. Returns null if no configuration is needed.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | ExecutionPriority | Gets the execution priority of the provider (0 lowest, 100 highest).
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | Format(String, ContextInformation, FormattingPhase) | Performs a Formatting phase.
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | Information | Gets the Information about the Provider.
 | Init(IHostV30, String) | Initializes the Storage Provider.
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | PerformPhase1 | Specifies whether or not to execute Phase 1.
 | PerformPhase2 | Specifies whether or not to execute Phase 2.
 | PerformPhase3 | Specifies whether or not to execute Phase 3.
 | PrepareTitle(String, ContextInformation) | Prepares the title of an item for display (always during phase 3).
 | Shutdown()()() | Method invoked on shutdown.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
UnfuddleTickets

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: PluginPack (Module: PluginPack) Version: 3.0.2.500 (3.0.2.500)


UnfuddleTickets Constructor

UnfuddleTickets Constructor
ScrewTurn Wiki ► ScrewTurn.Wiki.Plugins.PluginPack ► UnfuddleTickets ► UnfuddleTickets()()()
Initializes a new instance of the UnfuddleTickets class
Declaration Syntax
C# Visual Basic Visual C++
public UnfuddleTickets()
Public Sub New
public:
UnfuddleTickets()

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: PluginPack (Module: PluginPack) Version: 3.0.2.500 (3.0.2.500)


ConfigHelpHtml Property

ConfigHelpHtml Property
ScrewTurn Wiki ► ScrewTurn.Wiki.Plugins.PluginPack ► UnfuddleTickets ► ConfigHelpHtml
Gets a brief summary of the configuration string format, in HTML. Returns null if no configuration is needed.
Declaration Syntax
C# Visual Basic Visual C++
public string ConfigHelpHtml { get; }
Public ReadOnly Property ConfigHelpHtml As String
public:
virtual property String^ ConfigHelpHtml {
    String^ get () sealed;
}

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: PluginPack (Module: PluginPack) Version: 3.0.2.500 (3.0.2.500)


ExecutionPriority Property

ExecutionPriority Property
ScrewTurn Wiki ► ScrewTurn.Wiki.Plugins.PluginPack ► UnfuddleTickets ► ExecutionPriority
Gets the execution priority of the provider (0 lowest, 100 highest).
Declaration Syntax
C# Visual Basic Visual C++
public int ExecutionPriority { get; }
Public ReadOnly Property ExecutionPriority As Integer
public:
virtual property int ExecutionPriority {
    int get () sealed;
}

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: PluginPack (Module: PluginPack) Version: 3.0.2.500 (3.0.2.500)


Format Method (raw, context, phase)

Format Method (raw, context, phase)
ScrewTurn Wiki ► ScrewTurn.Wiki.Plugins.PluginPack ► UnfuddleTickets ► Format(String, ContextInformation, FormattingPhase)
Performs a Formatting phase.
Declaration Syntax
C# Visual Basic Visual C++
public string Format(
    string raw,
    ContextInformation context,
    FormattingPhase phase
)
Public Function Format ( _
    raw As String, _
    context As ContextInformation, _
    phase As FormattingPhase _
) As String
public:
virtual String^ Format(
    String^ raw,
    ContextInformation^ context,
    FormattingPhase phase
) sealed
Parameters
raw (String)
The raw content to Format.
context (ContextInformation)
The Context information.
phase (FormattingPhase)
The Phase.
Return Value
The Formatted content.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: PluginPack (Module: PluginPack) Version: 3.0.2.500 (3.0.2.500)


Information Property

Information Property
ScrewTurn Wiki ► ScrewTurn.Wiki.Plugins.PluginPack ► UnfuddleTickets ► Information
Gets the Information about the Provider.
Declaration Syntax
C# Visual Basic Visual C++
public ComponentInformation Information { get; }
Public ReadOnly Property Information As ComponentInformation
public:
virtual property ComponentInformation^ Information {
    ComponentInformation^ get () sealed;
}

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: PluginPack (Module: PluginPack) Version: 3.0.2.500 (3.0.2.500)


Init Method (host, config)

Init Method (host, config)
ScrewTurn Wiki ► ScrewTurn.Wiki.Plugins.PluginPack ► UnfuddleTickets ► Init(IHostV30, String)
Initializes the Storage Provider.
Declaration Syntax
C# Visual Basic Visual C++
public void Init(
    IHostV30 host,
    string config
)
Public Sub Init ( _
    host As IHostV30, _
    config As String _
)
public:
virtual void Init(
    IHostV30^ host,
    String^ config
) sealed
Parameters
host (IHostV30)
The Host of the Component.
config (String)
The Configuration data, if any.
Remarks
If the configuration string is not valid, the methoud should throw a InvalidConfigurationException.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: PluginPack (Module: PluginPack) Version: 3.0.2.500 (3.0.2.500)


PerformPhase1 Property

PerformPhase1 Property
ScrewTurn Wiki ► ScrewTurn.Wiki.Plugins.PluginPack ► UnfuddleTickets ► PerformPhase1
Specifies whether or not to execute Phase 1.
Declaration Syntax
C# Visual Basic Visual C++
public bool PerformPhase1 { get; }
Public ReadOnly Property PerformPhase1 As Boolean
public:
virtual property bool PerformPhase1 {
    bool get () sealed;
}

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: PluginPack (Module: PluginPack) Version: 3.0.2.500 (3.0.2.500)


PerformPhase2 Property

PerformPhase2 Property
ScrewTurn Wiki ► ScrewTurn.Wiki.Plugins.PluginPack ► UnfuddleTickets ► PerformPhase2
Specifies whether or not to execute Phase 2.
Declaration Syntax
C# Visual Basic Visual C++
public bool PerformPhase2 { get; }
Public ReadOnly Property PerformPhase2 As Boolean
public:
virtual property bool PerformPhase2 {
    bool get () sealed;
}

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: PluginPack (Module: PluginPack) Version: 3.0.2.500 (3.0.2.500)


PerformPhase3 Property

PerformPhase3 Property
ScrewTurn Wiki ► ScrewTurn.Wiki.Plugins.PluginPack ► UnfuddleTickets ► PerformPhase3
Specifies whether or not to execute Phase 3.
Declaration Syntax
C# Visual Basic Visual C++
public bool PerformPhase3 { get; }
Public ReadOnly Property PerformPhase3 As Boolean
public:
virtual property bool PerformPhase3 {
    bool get () sealed;
}

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: PluginPack (Module: PluginPack) Version: 3.0.2.500 (3.0.2.500)


PrepareTitle Method (title, context)

PrepareTitle Method (title, context)
ScrewTurn Wiki ► ScrewTurn.Wiki.Plugins.PluginPack ► UnfuddleTickets ► PrepareTitle(String, ContextInformation)
Prepares the title of an item for display (always during phase 3).
Declaration Syntax
C# Visual Basic Visual C++
public string PrepareTitle(
    string title,
    ContextInformation context
)
Public Function PrepareTitle ( _
    title As String, _
    context As ContextInformation _
) As String
public:
virtual String^ PrepareTitle(
    String^ title,
    ContextInformation^ context
) sealed
Parameters
title (String)
The input title.
context (ContextInformation)
The context information.
Return Value
The prepared title (no markup allowed).

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: PluginPack (Module: PluginPack) Version: 3.0.2.500 (3.0.2.500)


Shutdown Method

Shutdown Method
ScrewTurn Wiki ► ScrewTurn.Wiki.Plugins.PluginPack ► UnfuddleTickets ► Shutdown()()()
Method invoked on shutdown.
Declaration Syntax
C# Visual Basic Visual C++
public void Shutdown()
Public Sub Shutdown
public:
virtual void Shutdown() sealed
Remarks
This method might not be invoked in some cases.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: PluginPack (Module: PluginPack) Version: 3.0.2.500 (3.0.2.500)


ScrewTurn.Wiki.Plugins.SqlCommon Namespace

ScrewTurn.Wiki.Plugins.SqlCommon Namespace
ScrewTurn Wiki ► ScrewTurn.Wiki.Plugins.SqlCommon
Namespace containing SQL Common types.
Declaration Syntax
C# Visual Basic Visual C++
namespace ScrewTurn.Wiki.Plugins.SqlCommon
Namespace ScrewTurn.Wiki.Plugins.SqlCommon
namespace ScrewTurn.Wiki.Plugins.SqlCommon
Types
All Types Classes Interfaces Enumerations Delegates
Icon | Type | Description
 | ClearIndex | Defines a delegate for method that clears the index.
 | DeleteDataForDocument | Defines a delegate for a method for deleting a document's data.
 | DeleteEntries | Defines a delegate for a method that deletes ACL entries in the storage.
 | DeleteEntry | Defines a delegate for a method that deletes a ACL entry in the storage.
 | GetCount | Defines a delegate for a method that counts elements in the index.
 | GetSize | Defines a delegate for a method that gets the size of the approximate index in bytes.
 | GetWordFetcher | Defines a delegate for a method for getting a word fetcher.
 | Hash | Computes hashes.
 | ICommandBuilder | Defines an interface for a command builder component.
 | IIndexConnector | Defines the interface for a connector between an index to a pages storage provider.
 | IndexConnector | Defines a connector between an index and a pages storage provider.
 | IndexElementType | Defines legal index element types.
 | Join | List JOIN types.
 | Ordering | Lists ordering directions.
 | Parameter | Represents a generic database parameter.
 | ParameterType | Lists parameter types.
 | QueryBuilder | A tool for building queries.
 | RenameResource | Defines a delegate for a method that renames a resource.
 | RetrieveAllEntries | Defines a delegate for a method that retrieves all entries.
 | RetrieveEntriesForResource | Defines a delegate for a method that retrieves all entries for a resource.
 | RetrieveEntriesForSubject | Defines a delegate for a method that retrieves all entries for a subject.
 | SaveDataForDocument | Defines a delegate for a method for saving data. The passed data is the whole document data, as it was tokenized.
 | SqlAclManager | Implements a SQL ACL Manager.
 | SqlClassBase | Implements a base class for all SQL-based classes.
 | SqlFilesStorageProviderBase | Implements a base class for a SQL files storage provider.
 | SqlIndex | Implements a SQL-based search engine index.
 | SqlPagesStorageProviderBase | Implements a base class for a SQL pages storage provider.
 | SqlSettingsStorageProviderBase | Implements a base class for a SQL settings storage provider.
 | SqlStorageProviderBase | Implements a base class for a SQL storage provider.
 | SqlUsersStorageProviderBase | Implements a base class for a SQL users storage provider.
 | SqlWordFetcher | Implements a word fetcher for a SQL-based index.
 | StoreEntry | Defines a delegate for a method that stores a ACL entry in the storage.
 | Tools | Implements tools.
 | TryFindWord | Defines a delegate for a method for finding a word.
 | WhereOperator | Lists WHERE operators.


ClearIndex Delegate

ClearIndex Delegate
ScrewTurn Wiki ► ScrewTurn.Wiki.Plugins.SqlCommon ► ClearIndex
Defines a delegate for method that clears the index.
Declaration Syntax
C# Visual Basic Visual C++
public delegate void ClearIndex(
    Object state
)
Public Delegate Sub ClearIndex ( _
    state As Object _
)
public delegate void ClearIndex(
    Object^ state
)
Parameters
state (Object)
A state object passed from the index.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Plugins.SqlCommon (Module: ScrewTurn.Wiki.Plugins.SqlCommon) Version: 3.0.2.500 (3.0.2.500)

Assembly: SqlServerProviders (Module: SqlServerProviders) Version: 3.0.2.500 (3.0.2.500)


DeleteDataForDocument Delegate

DeleteDataForDocument Delegate
ScrewTurn Wiki ► ScrewTurn.Wiki.Plugins.SqlCommon ► DeleteDataForDocument
Defines a delegate for a method for deleting a document's data.
Declaration Syntax
C# Visual Basic Visual C++
public delegate void DeleteDataForDocument(
    IDocument document,
    Object state
)
Public Delegate Sub DeleteDataForDocument ( _
    document As IDocument, _
    state As Object _
)
public delegate void DeleteDataForDocument(
    IDocument^ document,
    Object^ state
)
Parameters
document (IDocument)
The document.
state (Object)
A state object passed from the index.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: SqlServerProviders (Module: SqlServerProviders) Version: 3.0.2.500 (3.0.2.500)

Assembly: ScrewTurn.Wiki.Plugins.SqlCommon (Module: ScrewTurn.Wiki.Plugins.SqlCommon) Version: 3.0.2.500 (3.0.2.500)


DeleteEntries Delegate

DeleteEntries Delegate
ScrewTurn Wiki ► ScrewTurn.Wiki.Plugins.SqlCommon ► DeleteEntries
Defines a delegate for a method that deletes ACL entries in the storage.
Declaration Syntax
C# Visual Basic Visual C++
public delegate bool DeleteEntries(
    AclEntry[] entries
)
Public Delegate Function DeleteEntries ( _
    entries As AclEntry() _
) As Boolean
public delegate bool DeleteEntries(
    array<AclEntry^>^ entries
)
Parameters
entries (array< AclEntry >[]()[][])
The entries to delete.
Remarks
true if one or more enties were deleted, false otherwise.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: SqlServerProviders (Module: SqlServerProviders) Version: 3.0.2.500 (3.0.2.500)

Assembly: ScrewTurn.Wiki.Plugins.SqlCommon (Module: ScrewTurn.Wiki.Plugins.SqlCommon) Version: 3.0.2.500 (3.0.2.500)


DeleteEntry Delegate

DeleteEntry Delegate
ScrewTurn Wiki ► ScrewTurn.Wiki.Plugins.SqlCommon ► DeleteEntry
Defines a delegate for a method that deletes a ACL entry in the storage.
Declaration Syntax
C# Visual Basic Visual C++
public delegate bool DeleteEntry(
    AclEntry entry
)
Public Delegate Function DeleteEntry ( _
    entry As AclEntry _
) As Boolean
public delegate bool DeleteEntry(
    AclEntry^ entry
)
Parameters
entry (AclEntry)
The entry to delete.
Remarks
true if the entry was deleted, false otherwise.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: SqlServerProviders (Module: SqlServerProviders) Version: 3.0.2.500 (3.0.2.500)

Assembly: ScrewTurn.Wiki.Plugins.SqlCommon (Module: ScrewTurn.Wiki.Plugins.SqlCommon) Version: 3.0.2.500 (3.0.2.500)


GetCount Delegate

GetCount Delegate
ScrewTurn Wiki ► ScrewTurn.Wiki.Plugins.SqlCommon ► GetCount
Defines a delegate for a method that counts elements in the index.
Declaration Syntax
C# Visual Basic Visual C++
public delegate int GetCount(
    IndexElementType element
)
Public Delegate Function GetCount ( _
    element As IndexElementType _
) As Integer
public delegate int GetCount(
    IndexElementType element
)
Parameters
element (IndexElementType)
The element type.
Return Value
The element count.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Plugins.SqlCommon (Module: ScrewTurn.Wiki.Plugins.SqlCommon) Version: 3.0.2.500 (3.0.2.500)

Assembly: SqlServerProviders (Module: SqlServerProviders) Version: 3.0.2.500 (3.0.2.500)


GetSize Delegate

GetSize Delegate
ScrewTurn Wiki ► ScrewTurn.Wiki.Plugins.SqlCommon ► GetSize
Defines a delegate for a method that gets the size of the approximate index in bytes.
Declaration Syntax
C# Visual Basic Visual C++
public delegate long GetSize()
Public Delegate Function GetSize As Long
public delegate long long GetSize()
Return Value
The size of the index, in bytes.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Plugins.SqlCommon (Module: ScrewTurn.Wiki.Plugins.SqlCommon) Version: 3.0.2.500 (3.0.2.500)

Assembly: SqlServerProviders (Module: SqlServerProviders) Version: 3.0.2.500 (3.0.2.500)


GetWordFetcher Delegate

GetWordFetcher Delegate
ScrewTurn Wiki ► ScrewTurn.Wiki.Plugins.SqlCommon ► GetWordFetcher
Defines a delegate for a method for getting a word fetcher.
Declaration Syntax
C# Visual Basic Visual C++
public delegate IWordFetcher GetWordFetcher()
Public Delegate Function GetWordFetcher As IWordFetcher
public delegate IWordFetcher^ GetWordFetcher()
Return Value
The word fetcher.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Plugins.SqlCommon (Module: ScrewTurn.Wiki.Plugins.SqlCommon) Version: 3.0.2.500 (3.0.2.500)

Assembly: SqlServerProviders (Module: SqlServerProviders) Version: 3.0.2.500 (3.0.2.500)


Hash Class

Hash Class
ScrewTurn Wiki ► ScrewTurn.Wiki.Plugins.SqlCommon ► Hash
Computes hashes.
Declaration Syntax
C# Visual Basic Visual C++
public static class Hash
Public NotInheritable Class Hash
public ref class Hash abstract sealed
Members
All Members | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | Compute(String) | Computes the Hash code of a string and converts it into a Hex string.
Inheritance Hierarchy
Object
Hash

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: SqlServerProviders (Module: SqlServerProviders) Version: 3.0.2.500 (3.0.2.500)

Assembly: ScrewTurn.Wiki.Plugins.SqlCommon (Module: ScrewTurn.Wiki.Plugins.SqlCommon) Version: 3.0.2.500 (3.0.2.500)


Compute Method (input)

Compute Method (input)
ScrewTurn Wiki ► ScrewTurn.Wiki.Plugins.SqlCommon ► Hash ► Compute(String)
Computes the Hash code of a string and converts it into a Hex string.
Declaration Syntax
C# Visual Basic Visual C++
public static string Compute(
    string input
)
Public Shared Function Compute ( _
    input As String _
) As String
public:
static String^ Compute(
    String^ input
)
Parameters
input (String)
The string.
Return Value
The Hash code, converted into a Hex string.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: SqlServerProviders (Module: SqlServerProviders) Version: 3.0.2.500 (3.0.2.500)

Assembly: ScrewTurn.Wiki.Plugins.SqlCommon (Module: ScrewTurn.Wiki.Plugins.SqlCommon) Version: 3.0.2.500 (3.0.2.500)


ICommandBuilder Interface

ICommandBuilder Interface
ScrewTurn Wiki ► ScrewTurn.Wiki.Plugins.SqlCommon ► ICommandBuilder
Defines an interface for a command builder component.
Declaration Syntax
C# Visual Basic Visual C++
public interface ICommandBuilder
Public Interface ICommandBuilder
public interface class ICommandBuilder
Members
All Members | Methods | Properties
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | BatchQuerySeparator | Gets the string to use in order to separate queries in a batch.
 | GetCommand(String, String, List<(Of <(Parameter>)>)) | Gets a properly built database command, with the underlying connection already open.
 | GetCommand(DbConnection, String, List<(Of <(Parameter>)>)) | Gets a properly built database command, re-using an open connection.
 | GetCommand(DbTransaction, String, List<(Of <(Parameter>)>)) | Gets a properly built database command, re-using an open connection and a begun transaction.
 | GetConnection(String) | Gets a new database connection, open.
 | ObjectNamePrefix | Gets the table and column name prefix.
 | ObjectNameSuffix | Gets the table and column name suffix.
 | ParameterNamePrefix | Gets the parameter name prefix.
 | ParameterNameSuffix | Gets the parameter name suffix.
 | ParameterPlaceholder | Gets the parameter name placeholder.
 | UseNamedParameters | Gets a value indicating whether to use named parameters. If false, parameter placeholders will be equal to ParameterPlaceholder.
Remarks
Classes implementing this interface should be thread-safe.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: SqlServerProviders (Module: SqlServerProviders) Version: 3.0.2.500 (3.0.2.500)

Assembly: ScrewTurn.Wiki.Plugins.SqlCommon (Module: ScrewTurn.Wiki.Plugins.SqlCommon) Version: 3.0.2.500 (3.0.2.500)


BatchQuerySeparator Property

BatchQuerySeparator Property
ScrewTurn Wiki ► ScrewTurn.Wiki.Plugins.SqlCommon ► ICommandBuilder ► BatchQuerySeparator
Gets the string to use in order to separate queries in a batch.
Declaration Syntax
C# Visual Basic Visual C++
string BatchQuerySeparator { get; }
ReadOnly Property BatchQuerySeparator As String
property String^ BatchQuerySeparator {
    String^ get ();
}

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: SqlServerProviders (Module: SqlServerProviders) Version: 3.0.2.500 (3.0.2.500)

Assembly: ScrewTurn.Wiki.Plugins.SqlCommon (Module: ScrewTurn.Wiki.Plugins.SqlCommon) Version: 3.0.2.500 (3.0.2.500)


GetCommand Method

GetCommand Method
ScrewTurn Wiki ► ScrewTurn.Wiki.Plugins.SqlCommon ► ICommandBuilder ► GetCommand()()()
Members
Icon | Member | Description
 | GetCommand(String, String, List<(Of <(Parameter>)>)) | Gets a properly built database command, with the underlying connection already open.
 | GetCommand(DbConnection, String, List<(Of <(Parameter>)>)) | Gets a properly built database command, re-using an open connection.
 | GetCommand(DbTransaction, String, List<(Of <(Parameter>)>)) | Gets a properly built database command, re-using an open connection and a begun transaction.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: SqlServerProviders (Module: SqlServerProviders) Version: 3.0.2.500 (3.0.2.500)

Assembly: ScrewTurn.Wiki.Plugins.SqlCommon (Module: ScrewTurn.Wiki.Plugins.SqlCommon) Version: 3.0.2.500 (3.0.2.500)


GetCommand Method (connection, preparedQuery, parameters)

GetCommand Method (connection, preparedQuery, parameters)
ScrewTurn Wiki ► ScrewTurn.Wiki.Plugins.SqlCommon ► ICommandBuilder ► GetCommand(DbConnection, String, List<(Of <(Parameter>)>))
Gets a properly built database command, re-using an open connection.
Declaration Syntax
C# Visual Basic Visual C++
DbCommand GetCommand(
    DbConnection connection,
    string preparedQuery,
    List<Parameter> parameters
)
Function GetCommand ( _
    connection As DbConnection, _
    preparedQuery As String, _
    parameters As List(Of Parameter) _
) As DbCommand
DbCommand^ GetCommand(
    DbConnection^ connection,
    String^ preparedQuery,
    List<Parameter^>^ parameters
)
Parameters
connection (DbConnection)
The open connection to use.
preparedQuery (String)
The prepared query.
parameters (List <(Of <(<' Parameter >)>)>)
The parameters, if any.
Return Value
The command.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: SqlServerProviders (Module: SqlServerProviders) Version: 3.0.2.500 (3.0.2.500)

Assembly: ScrewTurn.Wiki.Plugins.SqlCommon (Module: ScrewTurn.Wiki.Plugins.SqlCommon) Version: 3.0.2.500 (3.0.2.500)


GetCommand Method (transaction, preparedQuery, parameters)

GetCommand Method (transaction, preparedQuery, parameters)
ScrewTurn Wiki ► ScrewTurn.Wiki.Plugins.SqlCommon ► ICommandBuilder ► GetCommand(DbTransaction, String, List<(Of <(Parameter>)>))
Gets a properly built database command, re-using an open connection and a begun transaction.
Declaration Syntax
C# Visual Basic Visual C++
DbCommand GetCommand(
    DbTransaction transaction,
    string preparedQuery,
    List<Parameter> parameters
)
Function GetCommand ( _
    transaction As DbTransaction, _
    preparedQuery As String, _
    parameters As List(Of Parameter) _
) As DbCommand
DbCommand^ GetCommand(
    DbTransaction^ transaction,
    String^ preparedQuery,
    List<Parameter^>^ parameters
)
Parameters
transaction (DbTransaction)
The transaction.
preparedQuery (String)
The prepared query.
parameters (List <(Of <(<' Parameter >)>)>)
The parameters, if any.
Return Value
The command.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: SqlServerProviders (Module: SqlServerProviders) Version: 3.0.2.500 (3.0.2.500)

Assembly: ScrewTurn.Wiki.Plugins.SqlCommon (Module: ScrewTurn.Wiki.Plugins.SqlCommon) Version: 3.0.2.500 (3.0.2.500)


GetCommand Method (connString, preparedQuery, parameters)

GetCommand Method (connString, preparedQuery, parameters)
ScrewTurn Wiki ► ScrewTurn.Wiki.Plugins.SqlCommon ► ICommandBuilder ► GetCommand(String, String, List<(Of <(Parameter>)>))
Gets a properly built database command, with the underlying connection already open.
Declaration Syntax
C# Visual Basic Visual C++
DbCommand GetCommand(
    string connString,
    string preparedQuery,
    List<Parameter> parameters
)
Function GetCommand ( _
    connString As String, _
    preparedQuery As String, _
    parameters As List(Of Parameter) _
) As DbCommand
DbCommand^ GetCommand(
    String^ connString,
    String^ preparedQuery,
    List<Parameter^>^ parameters
)
Parameters
connString (String)
The connection string.
preparedQuery (String)
The prepared query.
parameters (List <(Of <(<' Parameter >)>)>)
The parameters, if any.
Return Value
The command.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: SqlServerProviders (Module: SqlServerProviders) Version: 3.0.2.500 (3.0.2.500)

Assembly: ScrewTurn.Wiki.Plugins.SqlCommon (Module: ScrewTurn.Wiki.Plugins.SqlCommon) Version: 3.0.2.500 (3.0.2.500)


GetConnection Method (connString)

GetConnection Method (connString)
ScrewTurn Wiki ► ScrewTurn.Wiki.Plugins.SqlCommon ► ICommandBuilder ► GetConnection(String)
Gets a new database connection, open.
Declaration Syntax
C# Visual Basic Visual C++
DbConnection GetConnection(
    string connString
)
Function GetConnection ( _
    connString As String _
) As DbConnection
DbConnection^ GetConnection(
    String^ connString
)
Parameters
connString (String)
The connection string.
Return Value
The connection.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: SqlServerProviders (Module: SqlServerProviders) Version: 3.0.2.500 (3.0.2.500)

Assembly: ScrewTurn.Wiki.Plugins.SqlCommon (Module: ScrewTurn.Wiki.Plugins.SqlCommon) Version: 3.0.2.500 (3.0.2.500)


ObjectNamePrefix Property

ObjectNamePrefix Property
ScrewTurn Wiki ► ScrewTurn.Wiki.Plugins.SqlCommon ► ICommandBuilder ► ObjectNamePrefix
Gets the table and column name prefix.
Declaration Syntax
C# Visual Basic Visual C++
string ObjectNamePrefix { get; }
ReadOnly Property ObjectNamePrefix As String
property String^ ObjectNamePrefix {
    String^ get ();
}

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: SqlServerProviders (Module: SqlServerProviders) Version: 3.0.2.500 (3.0.2.500)

Assembly: ScrewTurn.Wiki.Plugins.SqlCommon (Module: ScrewTurn.Wiki.Plugins.SqlCommon) Version: 3.0.2.500 (3.0.2.500)


ObjectNameSuffix Property

ObjectNameSuffix Property
ScrewTurn Wiki ► ScrewTurn.Wiki.Plugins.SqlCommon ► ICommandBuilder ► ObjectNameSuffix
Gets the table and column name suffix.
Declaration Syntax
C# Visual Basic Visual C++
string ObjectNameSuffix { get; }
ReadOnly Property ObjectNameSuffix As String
property String^ ObjectNameSuffix {
    String^ get ();
}

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: SqlServerProviders (Module: SqlServerProviders) Version: 3.0.2.500 (3.0.2.500)

Assembly: ScrewTurn.Wiki.Plugins.SqlCommon (Module: ScrewTurn.Wiki.Plugins.SqlCommon) Version: 3.0.2.500 (3.0.2.500)


ParameterNamePrefix Property

ParameterNamePrefix Property
ScrewTurn Wiki ► ScrewTurn.Wiki.Plugins.SqlCommon ► ICommandBuilder ► ParameterNamePrefix
Gets the parameter name prefix.
Declaration Syntax
C# Visual Basic Visual C++
string ParameterNamePrefix { get; }
ReadOnly Property ParameterNamePrefix As String
property String^ ParameterNamePrefix {
    String^ get ();
}

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: SqlServerProviders (Module: SqlServerProviders) Version: 3.0.2.500 (3.0.2.500)

Assembly: ScrewTurn.Wiki.Plugins.SqlCommon (Module: ScrewTurn.Wiki.Plugins.SqlCommon) Version: 3.0.2.500 (3.0.2.500)


ParameterNameSuffix Property

ParameterNameSuffix Property
ScrewTurn Wiki ► ScrewTurn.Wiki.Plugins.SqlCommon ► ICommandBuilder ► ParameterNameSuffix
Gets the parameter name suffix.
Declaration Syntax
C# Visual Basic Visual C++
string ParameterNameSuffix { get; }
ReadOnly Property ParameterNameSuffix As String
property String^ ParameterNameSuffix {
    String^ get ();
}

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: SqlServerProviders (Module: SqlServerProviders) Version: 3.0.2.500 (3.0.2.500)

Assembly: ScrewTurn.Wiki.Plugins.SqlCommon (Module: ScrewTurn.Wiki.Plugins.SqlCommon) Version: 3.0.2.500 (3.0.2.500)


ParameterPlaceholder Property

ParameterPlaceholder Property
ScrewTurn Wiki ► ScrewTurn.Wiki.Plugins.SqlCommon ► ICommandBuilder ► ParameterPlaceholder
Gets the parameter name placeholder.
Declaration Syntax
C# Visual Basic Visual C++
string ParameterPlaceholder { get; }
ReadOnly Property ParameterPlaceholder As String
property String^ ParameterPlaceholder {
    String^ get ();
}

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: SqlServerProviders (Module: SqlServerProviders) Version: 3.0.2.500 (3.0.2.500)

Assembly: ScrewTurn.Wiki.Plugins.SqlCommon (Module: ScrewTurn.Wiki.Plugins.SqlCommon) Version: 3.0.2.500 (3.0.2.500)


UseNamedParameters Property

UseNamedParameters Property
ScrewTurn Wiki ► ScrewTurn.Wiki.Plugins.SqlCommon ► ICommandBuilder ► UseNamedParameters
Gets a value indicating whether to use named parameters. If false, parameter placeholders will be equal to ParameterPlaceholder.
Declaration Syntax
C# Visual Basic Visual C++
bool UseNamedParameters { get; }
ReadOnly Property UseNamedParameters As Boolean
property bool UseNamedParameters {
    bool get ();
}

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: SqlServerProviders (Module: SqlServerProviders) Version: 3.0.2.500 (3.0.2.500)

Assembly: ScrewTurn.Wiki.Plugins.SqlCommon (Module: ScrewTurn.Wiki.Plugins.SqlCommon) Version: 3.0.2.500 (3.0.2.500)


IIndexConnector Interface

IIndexConnector Interface
ScrewTurn Wiki ► ScrewTurn.Wiki.Plugins.SqlCommon ► IIndexConnector
Defines the interface for a connector between an index to a pages storage provider.
Declaration Syntax
C# Visual Basic Visual C++
public interface IIndexConnector
Public Interface IIndexConnector
public interface class IIndexConnector
Members
All Members | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | ClearIndex(Object) | Invokes the ClearIndex delegate.
 | DeleteDataForDocument(IDocument, Object) | Invokes the DeleteDataForDocument delegate.
 | GetCount(IndexElementType) | Invokes the GetCount delegate.
 | GetSize()()() | Defines a delegate for a method that gets the size of the approximate index in bytes.
 | GetWordFetcher()()() | Invokes the GetWordFetcher delegate.
 | SaveDataForDocument(IDocument, array<WordInfo>[]()[], array<WordInfo>[]()[], array<WordInfo>[]()[], Object) | Invokes the SaveDataForDocument delegate.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Plugins.SqlCommon (Module: ScrewTurn.Wiki.Plugins.SqlCommon) Version: 3.0.2.500 (3.0.2.500)

Assembly: SqlServerProviders (Module: SqlServerProviders) Version: 3.0.2.500 (3.0.2.500)


ClearIndex Method (state)

ClearIndex Method (state)
ScrewTurn Wiki ► ScrewTurn.Wiki.Plugins.SqlCommon ► IIndexConnector ► ClearIndex(Object)
Invokes the ClearIndex delegate.
Declaration Syntax
C# Visual Basic Visual C++
void ClearIndex(
    Object state
)
Sub ClearIndex ( _
    state As Object _
)
void ClearIndex(
    Object^ state
)
Parameters
state (Object)
A state object passed from the index.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Plugins.SqlCommon (Module: ScrewTurn.Wiki.Plugins.SqlCommon) Version: 3.0.2.500 (3.0.2.500)

Assembly: SqlServerProviders (Module: SqlServerProviders) Version: 3.0.2.500 (3.0.2.500)


DeleteDataForDocument Method (document, state)

DeleteDataForDocument Method (document, state)
ScrewTurn Wiki ► ScrewTurn.Wiki.Plugins.SqlCommon ► IIndexConnector ► DeleteDataForDocument(IDocument, Object)
Invokes the DeleteDataForDocument delegate.
Declaration Syntax
C# Visual Basic Visual C++
void DeleteDataForDocument(
    IDocument document,
    Object state
)
Sub DeleteDataForDocument ( _
    document As IDocument, _
    state As Object _
)
void DeleteDataForDocument(
    IDocument^ document,
    Object^ state
)
Parameters
document (IDocument)
The document.
state (Object)
A state object passed from the index.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Plugins.SqlCommon (Module: ScrewTurn.Wiki.Plugins.SqlCommon) Version: 3.0.2.500 (3.0.2.500)

Assembly: SqlServerProviders (Module: SqlServerProviders) Version: 3.0.2.500 (3.0.2.500)


GetCount Method (element)

GetCount Method (element)
ScrewTurn Wiki ► ScrewTurn.Wiki.Plugins.SqlCommon ► IIndexConnector ► GetCount(IndexElementType)
Invokes the GetCount delegate.
Declaration Syntax
C# Visual Basic Visual C++
int GetCount(
    IndexElementType element
)
Function GetCount ( _
    element As IndexElementType _
) As Integer
int GetCount(
    IndexElementType element
)
Parameters
element (IndexElementType)
The element type.
Return Value
The element count.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Plugins.SqlCommon (Module: ScrewTurn.Wiki.Plugins.SqlCommon) Version: 3.0.2.500 (3.0.2.500)

Assembly: SqlServerProviders (Module: SqlServerProviders) Version: 3.0.2.500 (3.0.2.500)


GetSize Method

GetSize Method
ScrewTurn Wiki ► ScrewTurn.Wiki.Plugins.SqlCommon ► IIndexConnector ► GetSize()()()
Defines a delegate for a method that gets the size of the approximate index in bytes.
Declaration Syntax
C# Visual Basic Visual C++
long GetSize()
Function GetSize As Long
long long GetSize()
Return Value
The size of the index, in bytes.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Plugins.SqlCommon (Module: ScrewTurn.Wiki.Plugins.SqlCommon) Version: 3.0.2.500 (3.0.2.500)

Assembly: SqlServerProviders (Module: SqlServerProviders) Version: 3.0.2.500 (3.0.2.500)


GetWordFetcher Method

GetWordFetcher Method
ScrewTurn Wiki ► ScrewTurn.Wiki.Plugins.SqlCommon ► IIndexConnector ► GetWordFetcher()()()
Invokes the GetWordFetcher delegate.
Declaration Syntax
C# Visual Basic Visual C++
IWordFetcher GetWordFetcher()
Function GetWordFetcher As IWordFetcher
IWordFetcher^ GetWordFetcher()
Return Value
The word fetcher.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Plugins.SqlCommon (Module: ScrewTurn.Wiki.Plugins.SqlCommon) Version: 3.0.2.500 (3.0.2.500)

Assembly: SqlServerProviders (Module: SqlServerProviders) Version: 3.0.2.500 (3.0.2.500)


SaveDataForDocument Method (document, content, title, keywords, state)

SaveDataForDocument Method (document, content, title, keywords, state)
ScrewTurn Wiki ► ScrewTurn.Wiki.Plugins.SqlCommon ► IIndexConnector ► SaveDataForDocument(IDocument, array<WordInfo>[]()[], array<WordInfo>[]()[], array<WordInfo>[]()[], Object)
Invokes the SaveDataForDocument delegate.
Declaration Syntax
C# Visual Basic Visual C++
int SaveDataForDocument(
    IDocument document,
    WordInfo[] content,
    WordInfo[] title,
    WordInfo[] keywords,
    Object state
)
Function SaveDataForDocument ( _
    document As IDocument, _
    content As WordInfo(), _
    title As WordInfo(), _
    keywords As WordInfo(), _
    state As Object _
) As Integer
int SaveDataForDocument(
    IDocument^ document,
    array<WordInfo^>^ content,
    array<WordInfo^>^ title,
    array<WordInfo^>^ keywords,
    Object^ state
)
Parameters
document (IDocument)
The document.
content (array< WordInfo >[]()[][])
The content words.
title (array< WordInfo >[]()[][])
The title words.
keywords (array< WordInfo >[]()[][])
The keywords.
state (Object)
A state object passed from the index.
Return Value
The number of stored occurrences.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Plugins.SqlCommon (Module: ScrewTurn.Wiki.Plugins.SqlCommon) Version: 3.0.2.500 (3.0.2.500)

Assembly: SqlServerProviders (Module: SqlServerProviders) Version: 3.0.2.500 (3.0.2.500)


IndexConnector Class

IndexConnector Class
ScrewTurn Wiki ► ScrewTurn.Wiki.Plugins.SqlCommon ► IndexConnector
Defines a connector between an index and a pages storage provider.
Declaration Syntax
C# Visual Basic Visual C++
public class IndexConnector : IIndexConnector
Public Class IndexConnector _
    Implements IIndexConnector
public ref class IndexConnector : IIndexConnector
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | IndexConnector(GetWordFetcher, GetSize, GetCount, ClearIndex, DeleteDataForDocument, SaveDataForDocument, TryFindWord) | Initializes a new instance of the IndexConnector class.
 | ClearIndex(Object) | Invokes the ClearIndex delegate.
 | DeleteDataForDocument(IDocument, Object) | Invokes the DeleteDataForDocument delegate.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetCount(IndexElementType) | Invokes the GetCount delegate.
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetSize()()() | Defines a delegate for a method that gets the size of the approximate index in bytes.
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetWordFetcher()()() | Invokes the GetWordFetcher delegate.
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | SaveDataForDocument(IDocument, array<WordInfo>[]()[], array<WordInfo>[]()[], array<WordInfo>[]()[], Object) | Invokes the SaveDataForDocument delegate.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
IndexConnector

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Plugins.SqlCommon (Module: ScrewTurn.Wiki.Plugins.SqlCommon) Version: 3.0.2.500 (3.0.2.500)

Assembly: SqlServerProviders (Module: SqlServerProviders) Version: 3.0.2.500 (3.0.2.500)


IndexConnector Constructor (getWordFetcher, getSize, getCount, clearIndex, deleteData, saveData, tryFindWord)

IndexConnector Constructor (getWordFetcher, getSize, getCount, clearIndex, deleteData, saveData, tryFindWord)
ScrewTurn Wiki ► ScrewTurn.Wiki.Plugins.SqlCommon ► IndexConnector ► IndexConnector(GetWordFetcher, GetSize, GetCount, ClearIndex, DeleteDataForDocument, SaveDataForDocument, TryFindWord)
Initializes a new instance of the IndexConnector class.
Declaration Syntax
C# Visual Basic Visual C++
public IndexConnector(
    GetWordFetcher getWordFetcher,
    GetSize getSize,
    GetCount getCount,
    ClearIndex clearIndex,
    DeleteDataForDocument deleteData,
    SaveDataForDocument saveData,
    TryFindWord tryFindWord
)
Public Sub New ( _
    getWordFetcher As GetWordFetcher, _
    getSize As GetSize, _
    getCount As GetCount, _
    clearIndex As ClearIndex, _
    deleteData As DeleteDataForDocument, _
    saveData As SaveDataForDocument, _
    tryFindWord As TryFindWord _
)
public:
IndexConnector(
    GetWordFetcher^ getWordFetcher,
    GetSize^ getSize,
    GetCount^ getCount,
    ClearIndex^ clearIndex,
    DeleteDataForDocument^ deleteData,
    SaveDataForDocument^ saveData,
    TryFindWord^ tryFindWord
)
Parameters
getWordFetcher (GetWordFetcher)
The GetWordFetcher delegate.
getSize (GetSize)
The GetSize delegate.
getCount (GetCount)
The GetCount delegate.
clearIndex (ClearIndex)
The ClearIndex delegate.
deleteData (DeleteDataForDocument)
The DeleteDataForDocument delegate.
saveData (SaveDataForDocument)
The SaveData delegate.
tryFindWord (TryFindWord)
The TryFindWord delegate.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Plugins.SqlCommon (Module: ScrewTurn.Wiki.Plugins.SqlCommon) Version: 3.0.2.500 (3.0.2.500)

Assembly: SqlServerProviders (Module: SqlServerProviders) Version: 3.0.2.500 (3.0.2.500)


ClearIndex Method (state)

ClearIndex Method (state)
ScrewTurn Wiki ► ScrewTurn.Wiki.Plugins.SqlCommon ► IndexConnector ► ClearIndex(Object)
Invokes the ClearIndex delegate.
Declaration Syntax
C# Visual Basic Visual C++
public void ClearIndex(
    Object state
)
Public Sub ClearIndex ( _
    state As Object _
)
public:
virtual void ClearIndex(
    Object^ state
) sealed
Parameters
state (Object)
A state object passed from the index.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Plugins.SqlCommon (Module: ScrewTurn.Wiki.Plugins.SqlCommon) Version: 3.0.2.500 (3.0.2.500)

Assembly: SqlServerProviders (Module: SqlServerProviders) Version: 3.0.2.500 (3.0.2.500)


DeleteDataForDocument Method (document, state)

DeleteDataForDocument Method (document, state)
ScrewTurn Wiki ► ScrewTurn.Wiki.Plugins.SqlCommon ► IndexConnector ► DeleteDataForDocument(IDocument, Object)
Invokes the DeleteDataForDocument delegate.
Declaration Syntax
C# Visual Basic Visual C++
public void DeleteDataForDocument(
    IDocument document,
    Object state
)
Public Sub DeleteDataForDocument ( _
    document As IDocument, _
    state As Object _
)
public:
virtual void DeleteDataForDocument(
    IDocument^ document,
    Object^ state
) sealed
Parameters
document (IDocument)
The document.
state (Object)
A state object passed from the index.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Plugins.SqlCommon (Module: ScrewTurn.Wiki.Plugins.SqlCommon) Version: 3.0.2.500 (3.0.2.500)

Assembly: SqlServerProviders (Module: SqlServerProviders) Version: 3.0.2.500 (3.0.2.500)


GetCount Method (element)

GetCount Method (element)
ScrewTurn Wiki ► ScrewTurn.Wiki.Plugins.SqlCommon ► IndexConnector ► GetCount(IndexElementType)
Invokes the GetCount delegate.
Declaration Syntax
C# Visual Basic Visual C++
public int GetCount(
    IndexElementType element
)
Public Function GetCount ( _
    element As IndexElementType _
) As Integer
public:
virtual int GetCount(
    IndexElementType element
) sealed
Parameters
element (IndexElementType)
The element type.
Return Value
The element count.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Plugins.SqlCommon (Module: ScrewTurn.Wiki.Plugins.SqlCommon) Version: 3.0.2.500 (3.0.2.500)

Assembly: SqlServerProviders (Module: SqlServerProviders) Version: 3.0.2.500 (3.0.2.500)


GetSize Method

GetSize Method
ScrewTurn Wiki ► ScrewTurn.Wiki.Plugins.SqlCommon ► IndexConnector ► GetSize()()()
Defines a delegate for a method that gets the size of the approximate index in bytes.
Declaration Syntax
C# Visual Basic Visual C++
public long GetSize()
Public Function GetSize As Long
public:
virtual long long GetSize() sealed
Return Value
The size of the index, in bytes.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Plugins.SqlCommon (Module: ScrewTurn.Wiki.Plugins.SqlCommon) Version: 3.0.2.500 (3.0.2.500)

Assembly: SqlServerProviders (Module: SqlServerProviders) Version: 3.0.2.500 (3.0.2.500)


GetWordFetcher Method

GetWordFetcher Method
ScrewTurn Wiki ► ScrewTurn.Wiki.Plugins.SqlCommon ► IndexConnector ► GetWordFetcher()()()
Invokes the GetWordFetcher delegate.
Declaration Syntax
C# Visual Basic Visual C++
public IWordFetcher GetWordFetcher()
Public Function GetWordFetcher As IWordFetcher
public:
virtual IWordFetcher^ GetWordFetcher() sealed
Return Value
The word fetcher.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Plugins.SqlCommon (Module: ScrewTurn.Wiki.Plugins.SqlCommon) Version: 3.0.2.500 (3.0.2.500)

Assembly: SqlServerProviders (Module: SqlServerProviders) Version: 3.0.2.500 (3.0.2.500)


SaveDataForDocument Method (document, content, title, keywords, state)

SaveDataForDocument Method (document, content, title, keywords, state)
ScrewTurn Wiki ► ScrewTurn.Wiki.Plugins.SqlCommon ► IndexConnector ► SaveDataForDocument(IDocument, array<WordInfo>[]()[], array<WordInfo>[]()[], array<WordInfo>[]()[], Object)
Invokes the SaveDataForDocument delegate.
Declaration Syntax
C# Visual Basic Visual C++
public int SaveDataForDocument(
    IDocument document,
    WordInfo[] content,
    WordInfo[] title,
    WordInfo[] keywords,
    Object state
)
Public Function SaveDataForDocument ( _
    document As IDocument, _
    content As WordInfo(), _
    title As WordInfo(), _
    keywords As WordInfo(), _
    state As Object _
) As Integer
public:
virtual int SaveDataForDocument(
    IDocument^ document,
    array<WordInfo^>^ content,
    array<WordInfo^>^ title,
    array<WordInfo^>^ keywords,
    Object^ state
) sealed
Parameters
document (IDocument)
The document.
content (array< WordInfo >[]()[][])
The content words.
title (array< WordInfo >[]()[][])
The title words.
keywords (array< WordInfo >[]()[][])
The keywords.
state (Object)
A state object passed from the index.
Return Value
The number of stored occurrences.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Plugins.SqlCommon (Module: ScrewTurn.Wiki.Plugins.SqlCommon) Version: 3.0.2.500 (3.0.2.500)

Assembly: SqlServerProviders (Module: SqlServerProviders) Version: 3.0.2.500 (3.0.2.500)


IndexElementType Enumeration

IndexElementType Enumeration
ScrewTurn Wiki ► ScrewTurn.Wiki.Plugins.SqlCommon ► IndexElementType
Defines legal index element types.
Declaration Syntax
C# Visual Basic Visual C++
public enum IndexElementType
Public Enumeration IndexElementType
public enum class IndexElementType
Members
Member | Description
Documents | The documents.
Words | The words.
Occurrences | The occurrences.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Plugins.SqlCommon (Module: ScrewTurn.Wiki.Plugins.SqlCommon) Version: 3.0.2.500 (3.0.2.500)

Assembly: SqlServerProviders (Module: SqlServerProviders) Version: 3.0.2.500 (3.0.2.500)


Join Enumeration

Join Enumeration
ScrewTurn Wiki ► ScrewTurn.Wiki.Plugins.SqlCommon ► Join
List JOIN types.
Declaration Syntax
C# Visual Basic Visual C++
public enum Join
Public Enumeration Join
public enum class Join
Members
Member | Description
Join | JOIN.
InnerJoin | INNER JOIN.
LeftJoin | LEFT JOIN.
RightJoin | RIGHT JOIN.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: SqlServerProviders (Module: SqlServerProviders) Version: 3.0.2.500 (3.0.2.500)

Assembly: ScrewTurn.Wiki.Plugins.SqlCommon (Module: ScrewTurn.Wiki.Plugins.SqlCommon) Version: 3.0.2.500 (3.0.2.500)


Ordering Enumeration

Ordering Enumeration
ScrewTurn Wiki ► ScrewTurn.Wiki.Plugins.SqlCommon ► Ordering
Lists ordering directions.
Declaration Syntax
C# Visual Basic Visual C++
public enum Ordering
Public Enumeration Ordering
public enum class Ordering
Members
Member | Description
Asc | Ascending.
Desc | Descending.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: SqlServerProviders (Module: SqlServerProviders) Version: 3.0.2.500 (3.0.2.500)

Assembly: ScrewTurn.Wiki.Plugins.SqlCommon (Module: ScrewTurn.Wiki.Plugins.SqlCommon) Version: 3.0.2.500 (3.0.2.500)


Parameter Class

Parameter Class
ScrewTurn Wiki ► ScrewTurn.Wiki.Plugins.SqlCommon ► Parameter
Represents a generic database parameter.
Declaration Syntax
C# Visual Basic Visual C++
public class Parameter
Public Class Parameter
public ref class Parameter
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | Parameter(ParameterType, String, Object) | Initializes a new instance of the GenericDbParameter class.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets the name of the parameter.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | Type | Gets the type of the parameter.
 | Value | Gets or sets the value of the parameter.
Inheritance Hierarchy
Object
Parameter

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: SqlServerProviders (Module: SqlServerProviders) Version: 3.0.2.500 (3.0.2.500)

Assembly: ScrewTurn.Wiki.Plugins.SqlCommon (Module: ScrewTurn.Wiki.Plugins.SqlCommon) Version: 3.0.2.500 (3.0.2.500)


Parameter Constructor (type, name, value)

Parameter Constructor (type, name, value)
ScrewTurn Wiki ► ScrewTurn.Wiki.Plugins.SqlCommon ► Parameter ► Parameter(ParameterType, String, Object)
Initializes a new instance of the GenericDbParameter class.
Declaration Syntax
C# Visual Basic Visual C++
public Parameter(
    ParameterType type,
    string name,
    Object value
)
Public Sub New ( _
    type As ParameterType, _
    name As String, _
    value As Object _
)
public:
Parameter(
    ParameterType type,
    String^ name,
    Object^ value
)
Parameters
type (ParameterType)
The type of the parameter.
name (String)
The name of the parameter.
value (Object)
The value of the parameter.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: SqlServerProviders (Module: SqlServerProviders) Version: 3.0.2.500 (3.0.2.500)

Assembly: ScrewTurn.Wiki.Plugins.SqlCommon (Module: ScrewTurn.Wiki.Plugins.SqlCommon) Version: 3.0.2.500 (3.0.2.500)


Name Property

Name Property
ScrewTurn Wiki ► ScrewTurn.Wiki.Plugins.SqlCommon ► Parameter ► Name
Gets the name of the parameter.
Declaration Syntax
C# Visual Basic Visual C++
public string Name { get; }
Public ReadOnly Property Name As String
public:
property String^ Name {
    String^ get ();
}

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: SqlServerProviders (Module: SqlServerProviders) Version: 3.0.2.500 (3.0.2.500)

Assembly: ScrewTurn.Wiki.Plugins.SqlCommon (Module: ScrewTurn.Wiki.Plugins.SqlCommon) Version: 3.0.2.500 (3.0.2.500)


Type Property

Type Property
ScrewTurn Wiki ► ScrewTurn.Wiki.Plugins.SqlCommon ► Parameter ► Type
Gets the type of the parameter.
Declaration Syntax
C# Visual Basic Visual C++
public ParameterType Type { get; }
Public ReadOnly Property Type As ParameterType
public:
property ParameterType Type {
    ParameterType get ();
}

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: SqlServerProviders (Module: SqlServerProviders) Version: 3.0.2.500 (3.0.2.500)

Assembly: ScrewTurn.Wiki.Plugins.SqlCommon (Module: ScrewTurn.Wiki.Plugins.SqlCommon) Version: 3.0.2.500 (3.0.2.500)


Value Property

Value Property
ScrewTurn Wiki ► ScrewTurn.Wiki.Plugins.SqlCommon ► Parameter ► Value
Gets or sets the value of the parameter.
Declaration Syntax
C# Visual Basic Visual C++
public Object Value { get; set; }
Public Property Value As Object
public:
property Object^ Value {
    Object^ get ();
    void set (Object^ value);
}

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: SqlServerProviders (Module: SqlServerProviders) Version: 3.0.2.500 (3.0.2.500)

Assembly: ScrewTurn.Wiki.Plugins.SqlCommon (Module: ScrewTurn.Wiki.Plugins.SqlCommon) Version: 3.0.2.500 (3.0.2.500)


ParameterType Enumeration

ParameterType Enumeration
ScrewTurn Wiki ► ScrewTurn.Wiki.Plugins.SqlCommon ► ParameterType
Lists parameter types.
Declaration Syntax
C# Visual Basic Visual C++
public enum ParameterType
Public Enumeration ParameterType
public enum class ParameterType
Members
Member | Description
Int16 | An Int16.
Int32 | An Int32.
Int64 | An Int64.
String | A unicode string.
Char | A unicode character.
DateTime | A date/time.
Boolean | A boolean.
Byte | A byte.
ByteArray | An array of bytes.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: SqlServerProviders (Module: SqlServerProviders) Version: 3.0.2.500 (3.0.2.500)

Assembly: ScrewTurn.Wiki.Plugins.SqlCommon (Module: ScrewTurn.Wiki.Plugins.SqlCommon) Version: 3.0.2.500 (3.0.2.500)


QueryBuilder Class

QueryBuilder Class
ScrewTurn Wiki ► ScrewTurn.Wiki.Plugins.SqlCommon ► QueryBuilder
A tool for building queries.
Declaration Syntax
C# Visual Basic Visual C++
public class QueryBuilder
Public Class QueryBuilder
public ref class QueryBuilder
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | QueryBuilder(ICommandBuilder) | Initializes a new instance of the QueryBuilder class.
 | AndWhere(String, String, WhereOperator, String) | Adds another WHERE clause to a query.
 | AndWhere(String, String, WhereOperator, String, Boolean, Boolean) | Adds another WHERE clause to a query.
 | AndWhere(String, String, String, WhereOperator, String) | Adds another WHERE clause to a query.
 | AndWhere(String, String, String, WhereOperator, String, Boolean, Boolean) | Adds another WHERE clause to a query.
 | AppendForBatch(String, String) | Appends a query to an existing query for batch execution.
 | DeleteFrom(String) | Builds a DELETE FROM query.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GroupBy(String, array<String>[]()[]) | Applies a GROUP BY clause to a query.
 | InsertInto(String, array<String>[]()[], array<String>[]()[]) | Builds an INSERT INTO query.
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | NewQuery(ICommandBuilder) | Initializes a new instance of the QueryBuilder class.
 | OrderBy(String, array<String>[]()[], array<Ordering>[]()[]) | Applies an ORDER BY clause to a query.
 | OrWhere(String, String, WhereOperator, String) | Adds another WHERE clause to a query.
 | OrWhere(String, String, WhereOperator, String, Boolean, Boolean) | Adds another WHERE clause to a query.
 | OrWhere(String, String, String, WhereOperator, String) | Adds another WHERE clause to a query.
 | OrWhere(String, String, String, WhereOperator, String, Boolean, Boolean) | Adds another WHERE clause to a query.
 | SelectCountFrom(String) | Builds a SELECT COUNT(*) query.
 | SelectFrom(String, array<String>[]()[]) | Builds a SELECT query.
 | SelectFrom(String) | Builds a SELECT query.
 | SelectFrom(String, String, String, String, Join, array<String>[]()[], array<String>[]()[]) | Builds a SELECT query with a JOIN clause.
 | SelectFrom(String, String, array<String>[]()[], array<String>[]()[], Join, array<String>[]()[], array<String>[]()[]) | Builds a SELECT query with a JOIN clause.
 | SelectFrom(String, String, String, String, Join) | Builds a SELECT query with a JOIN clause.
 | SelectFrom(String, String, String, String, Join, array<String>[]()[], array<String>[]()[], String, String, Join, array<String>[]()[]) | Builds a SELECT query with two JOIN clauses (both on the main table).
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | Update(String, array<String>[]()[], array<String>[]()[]) | Builds an UPDATE query.
 | UpdateIncrement(String, String, Int32) | Builds an UPDATE query that increments the numerical value of a column by one.
 | Where(String, String, WhereOperator, String) | Applies a WHERE clause to a query.
 | Where(String, String, WhereOperator, String, Boolean, Boolean) | Applies a WHERE clause to a query.
 | Where(String, String, String, WhereOperator, String) | Applies a WHERE clause to a query.
 | Where(String, String, String, WhereOperator, String, Boolean, Boolean) | Applies a WHERE clause to a query.
 | WhereIn(String, String, array<String>[]()[]) | Applies a WHERE clause with IN operator to a query.
 | WhereIn(String, String, String, array<String>[]()[]) | Applies a WHERE clause with IN operator to a query.
 | WhereNotInSubquery(String, String, String, String) | Applies a WHERE NOT IN (subQuery) clause to a query.
Inheritance Hierarchy
Object
QueryBuilder

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Plugins.SqlCommon (Module: ScrewTurn.Wiki.Plugins.SqlCommon) Version: 3.0.2.500 (3.0.2.500)

Assembly: SqlServerProviders (Module: SqlServerProviders) Version: 3.0.2.500 (3.0.2.500)


QueryBuilder Constructor (builder)

QueryBuilder Constructor (builder)
ScrewTurn Wiki ► ScrewTurn.Wiki.Plugins.SqlCommon ► QueryBuilder ► QueryBuilder(ICommandBuilder)
Initializes a new instance of the QueryBuilder class.
Declaration Syntax
C# Visual Basic Visual C++
public QueryBuilder(
    ICommandBuilder builder
)
Public Sub New ( _
    builder As ICommandBuilder _
)
public:
QueryBuilder(
    ICommandBuilder^ builder
)
Parameters
builder (ICommandBuilder)
The command builder.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Plugins.SqlCommon (Module: ScrewTurn.Wiki.Plugins.SqlCommon) Version: 3.0.2.500 (3.0.2.500)

Assembly: SqlServerProviders (Module: SqlServerProviders) Version: 3.0.2.500 (3.0.2.500)


AndWhere Method

AndWhere Method
ScrewTurn Wiki ► ScrewTurn.Wiki.Plugins.SqlCommon ► QueryBuilder ► AndWhere()()()
Members
Icon | Member | Description
 | AndWhere(String, String, WhereOperator, String) | Adds another WHERE clause to a query.
 | AndWhere(String, String, WhereOperator, String, Boolean, Boolean) | Adds another WHERE clause to a query.
 | AndWhere(String, String, String, WhereOperator, String) | Adds another WHERE clause to a query.
 | AndWhere(String, String, String, WhereOperator, String, Boolean, Boolean) | Adds another WHERE clause to a query.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Plugins.SqlCommon (Module: ScrewTurn.Wiki.Plugins.SqlCommon) Version: 3.0.2.500 (3.0.2.500)

Assembly: SqlServerProviders (Module: SqlServerProviders) Version: 3.0.2.500 (3.0.2.500)


AndWhere Method (query, column, op, parameter)

AndWhere Method (query, column, op, parameter)
ScrewTurn Wiki ► ScrewTurn.Wiki.Plugins.SqlCommon ► QueryBuilder ► AndWhere(String, String, WhereOperator, String)
Adds another WHERE clause to a query.
Declaration Syntax
C# Visual Basic Visual C++
public string AndWhere(
    string query,
    string column,
    WhereOperator op,
    string parameter
)
Public Function AndWhere ( _
    query As String, _
    column As String, _
    op As WhereOperator, _
    parameter As String _
) As String
public:
String^ AndWhere(
    String^ query,
    String^ column,
    WhereOperator op,
    String^ parameter
)
Parameters
query (String)
The query.
column (String)
The column subject of the WHERE clause.
op (WhereOperator)
The operator.
parameter (String)
The name of the parameter for the WHERE clause.
Return Value
The resulting query.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Plugins.SqlCommon (Module: ScrewTurn.Wiki.Plugins.SqlCommon) Version: 3.0.2.500 (3.0.2.500)

Assembly: SqlServerProviders (Module: SqlServerProviders) Version: 3.0.2.500 (3.0.2.500)


AndWhere Method (query, column, op, parameter, openBracket, closeBracket)

AndWhere Method (query, column, op, parameter, openBracket, closeBracket)
ScrewTurn Wiki ► ScrewTurn.Wiki.Plugins.SqlCommon ► QueryBuilder ► AndWhere(String, String, WhereOperator, String, Boolean, Boolean)
Adds another WHERE clause to a query.
Declaration Syntax
C# Visual Basic Visual C++
public string AndWhere(
    string query,
    string column,
    WhereOperator op,
    string parameter,
    bool openBracket,
    bool closeBracket
)
Public Function AndWhere ( _
    query As String, _
    column As String, _
    op As WhereOperator, _
    parameter As String, _
    openBracket As Boolean, _
    closeBracket As Boolean _
) As String
public:
String^ AndWhere(
    String^ query,
    String^ column,
    WhereOperator op,
    String^ parameter,
    bool openBracket,
    bool closeBracket
)
Parameters
query (String)
The query.
column (String)
The column subject of the WHERE clause.
op (WhereOperator)
The operator.
parameter (String)
The name of the parameter for the WHERE clause.
openBracket (Boolean)
A value indicating whether to open a bracket after the AND.
closeBracket (Boolean)
A value indicating whether to close a bracket after the clause.
Return Value
The resulting query.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Plugins.SqlCommon (Module: ScrewTurn.Wiki.Plugins.SqlCommon) Version: 3.0.2.500 (3.0.2.500)

Assembly: SqlServerProviders (Module: SqlServerProviders) Version: 3.0.2.500 (3.0.2.500)


AndWhere Method (query, table, column, op, parameter)

AndWhere Method (query, table, column, op, parameter)
ScrewTurn Wiki ► ScrewTurn.Wiki.Plugins.SqlCommon ► QueryBuilder ► AndWhere(String, String, String, WhereOperator, String)
Adds another WHERE clause to a query.
Declaration Syntax
C# Visual Basic Visual C++
public string AndWhere(
    string query,
    string table,
    string column,
    WhereOperator op,
    string parameter
)
Public Function AndWhere ( _
    query As String, _
    table As String, _
    column As String, _
    op As WhereOperator, _
    parameter As String _
) As String
public:
String^ AndWhere(
    String^ query,
    String^ table,
    String^ column,
    WhereOperator op,
    String^ parameter
)
Parameters
query (String)
The query.
table (String)
The table the column belongs to.
column (String)
The column subject of the WHERE clause.
op (WhereOperator)
The operator.
parameter (String)
The name of the parameter for the WHERE clause.
Return Value
The resulting query.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Plugins.SqlCommon (Module: ScrewTurn.Wiki.Plugins.SqlCommon) Version: 3.0.2.500 (3.0.2.500)

Assembly: SqlServerProviders (Module: SqlServerProviders) Version: 3.0.2.500 (3.0.2.500)


AndWhere Method (query, table, column, op, parameter, openBracket, closeBracket)

AndWhere Method (query, table, column, op, parameter, openBracket, closeBracket)
ScrewTurn Wiki ► ScrewTurn.Wiki.Plugins.SqlCommon ► QueryBuilder ► AndWhere(String, String, String, WhereOperator, String, Boolean, Boolean)
Adds another WHERE clause to a query.
Declaration Syntax
C# Visual Basic Visual C++
public string AndWhere(
    string query,
    string table,
    string column,
    WhereOperator op,
    string parameter,
    bool openBracket,
    bool closeBracket
)
Public Function AndWhere ( _
    query As String, _
    table As String, _
    column As String, _
    op As WhereOperator, _
    parameter As String, _
    openBracket As Boolean, _
    closeBracket As Boolean _
) As String
public:
String^ AndWhere(
    String^ query,
    String^ table,
    String^ column,
    WhereOperator op,
    String^ parameter,
    bool openBracket,
    bool closeBracket
)
Parameters
query (String)
The query.
table (String)
The table the column belongs to.
column (String)
The column subject of the WHERE clause.
op (WhereOperator)
The operator.
parameter (String)
The name of the parameter for the WHERE clause.
openBracket (Boolean)
A value indicating whether to open a bracket after the AND.
closeBracket (Boolean)
A value indicating whether to close a bracket after the clause.
Return Value
The resulting query.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Plugins.SqlCommon (Module: ScrewTurn.Wiki.Plugins.SqlCommon) Version: 3.0.2.500 (3.0.2.500)

Assembly: SqlServerProviders (Module: SqlServerProviders) Version: 3.0.2.500 (3.0.2.500)


AppendForBatch Method (query, secondQuery)

AppendForBatch Method (query, secondQuery)
ScrewTurn Wiki ► ScrewTurn.Wiki.Plugins.SqlCommon ► QueryBuilder ► AppendForBatch(String, String)
Appends a query to an existing query for batch execution.
Declaration Syntax
C# Visual Basic Visual C++
public string AppendForBatch(
    string query,
    string secondQuery
)
Public Function AppendForBatch ( _
    query As String, _
    secondQuery As String _
) As String
public:
String^ AppendForBatch(
    String^ query,
    String^ secondQuery
)
Parameters
query (String)
The query.
secondQuery (String)
The second query.
Return Value
The resulting query.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Plugins.SqlCommon (Module: ScrewTurn.Wiki.Plugins.SqlCommon) Version: 3.0.2.500 (3.0.2.500)

Assembly: SqlServerProviders (Module: SqlServerProviders) Version: 3.0.2.500 (3.0.2.500)


DeleteFrom Method (table)

DeleteFrom Method (table)
ScrewTurn Wiki ► ScrewTurn.Wiki.Plugins.SqlCommon ► QueryBuilder ► DeleteFrom(String)
Builds a DELETE FROM query.
Declaration Syntax
C# Visual Basic Visual C++
public string DeleteFrom(
    string table
)
Public Function DeleteFrom ( _
    table As String _
) As String
public:
String^ DeleteFrom(
    String^ table
)
Parameters
table (String)
The table.
Return Value
The DELETE FROM query, without any WHERE clause.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Plugins.SqlCommon (Module: ScrewTurn.Wiki.Plugins.SqlCommon) Version: 3.0.2.500 (3.0.2.500)

Assembly: SqlServerProviders (Module: SqlServerProviders) Version: 3.0.2.500 (3.0.2.500)


GroupBy Method (query, columns)

GroupBy Method (query, columns)
ScrewTurn Wiki ► ScrewTurn.Wiki.Plugins.SqlCommon ► QueryBuilder ► GroupBy(String, array<String>[]()[])
Applies a GROUP BY clause to a query.
Declaration Syntax
C# Visual Basic Visual C++
public string GroupBy(
    string query,
    string[] columns
)
Public Function GroupBy ( _
    query As String, _
    columns As String() _
) As String
public:
String^ GroupBy(
    String^ query,
    array<String^>^ columns
)
Parameters
query (String)
The query.
columns (array< String >[]()[][])
The columns to group by.
Return Value
The resulting query.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Plugins.SqlCommon (Module: ScrewTurn.Wiki.Plugins.SqlCommon) Version: 3.0.2.500 (3.0.2.500)

Assembly: SqlServerProviders (Module: SqlServerProviders) Version: 3.0.2.500 (3.0.2.500)


InsertInto Method (table, columns, parameters)

InsertInto Method (table, columns, parameters)
ScrewTurn Wiki ► ScrewTurn.Wiki.Plugins.SqlCommon ► QueryBuilder ► InsertInto(String, array<String>[]()[], array<String>[]()[])
Builds an INSERT INTO query.
Declaration Syntax
C# Visual Basic Visual C++
public string InsertInto(
    string table,
    string[] columns,
    string[] parameters
)
Public Function InsertInto ( _
    table As String, _
    columns As String(), _
    parameters As String() _
) As String
public:
String^ InsertInto(
    String^ table,
    array<String^>^ columns,
    array<String^>^ parameters
)
Parameters
table (String)
The destination table.
columns (array< String >[]()[][])
The columns names.
parameters (array< String >[]()[][])
The parameters names.
Return Value
The INSERT INTO query.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Plugins.SqlCommon (Module: ScrewTurn.Wiki.Plugins.SqlCommon) Version: 3.0.2.500 (3.0.2.500)

Assembly: SqlServerProviders (Module: SqlServerProviders) Version: 3.0.2.500 (3.0.2.500)


NewQuery Method (builder)

NewQuery Method (builder)
ScrewTurn Wiki ► ScrewTurn.Wiki.Plugins.SqlCommon ► QueryBuilder ► NewQuery(ICommandBuilder)
Initializes a new instance of the QueryBuilder class.
Declaration Syntax
C# Visual Basic Visual C++
public static QueryBuilder NewQuery(
    ICommandBuilder builder
)
Public Shared Function NewQuery ( _
    builder As ICommandBuilder _
) As QueryBuilder
public:
static QueryBuilder^ NewQuery(
    ICommandBuilder^ builder
)
Parameters
builder (ICommandBuilder)
The command builder.
Return Value
The new instance.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Plugins.SqlCommon (Module: ScrewTurn.Wiki.Plugins.SqlCommon) Version: 3.0.2.500 (3.0.2.500)

Assembly: SqlServerProviders (Module: SqlServerProviders) Version: 3.0.2.500 (3.0.2.500)


OrderBy Method (query, columns, orderings)

OrderBy Method (query, columns, orderings)
ScrewTurn Wiki ► ScrewTurn.Wiki.Plugins.SqlCommon ► QueryBuilder ► OrderBy(String, array<String>[]()[], array<Ordering>[]()[])
Applies an ORDER BY clause to a query.
Declaration Syntax
C# Visual Basic Visual C++
public string OrderBy(
    string query,
    string[] columns,
    Ordering[] orderings
)
Public Function OrderBy ( _
    query As String, _
    columns As String(), _
    orderings As Ordering() _
) As String
public:
String^ OrderBy(
    String^ query,
    array<String^>^ columns,
    array<Ordering>^ orderings
)
Parameters
query (String)
The query.
columns (array< String >[]()[][])
The columns to order by.
orderings (array< Ordering >[]()[][])
The ordering directions for each column.
Return Value
The resulting query.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Plugins.SqlCommon (Module: ScrewTurn.Wiki.Plugins.SqlCommon) Version: 3.0.2.500 (3.0.2.500)

Assembly: SqlServerProviders (Module: SqlServerProviders) Version: 3.0.2.500 (3.0.2.500)


OrWhere Method

OrWhere Method
ScrewTurn Wiki ► ScrewTurn.Wiki.Plugins.SqlCommon ► QueryBuilder ► OrWhere()()()
Members
Icon | Member | Description
 | OrWhere(String, String, WhereOperator, String) | Adds another WHERE clause to a query.
 | OrWhere(String, String, WhereOperator, String, Boolean, Boolean) | Adds another WHERE clause to a query.
 | OrWhere(String, String, String, WhereOperator, String) | Adds another WHERE clause to a query.
 | OrWhere(String, String, String, WhereOperator, String, Boolean, Boolean) | Adds another WHERE clause to a query.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Plugins.SqlCommon (Module: ScrewTurn.Wiki.Plugins.SqlCommon) Version: 3.0.2.500 (3.0.2.500)

Assembly: SqlServerProviders (Module: SqlServerProviders) Version: 3.0.2.500 (3.0.2.500)


OrWhere Method (query, column, op, parameter)

OrWhere Method (query, column, op, parameter)
ScrewTurn Wiki ► ScrewTurn.Wiki.Plugins.SqlCommon ► QueryBuilder ► OrWhere(String, String, WhereOperator, String)
Adds another WHERE clause to a query.
Declaration Syntax
C# Visual Basic Visual C++
public string OrWhere(
    string query,
    string column,
    WhereOperator op,
    string parameter
)
Public Function OrWhere ( _
    query As String, _
    column As String, _
    op As WhereOperator, _
    parameter As String _
) As String
public:
String^ OrWhere(
    String^ query,
    String^ column,
    WhereOperator op,
    String^ parameter
)
Parameters
query (String)
The query.
column (String)
The column subject of the WHERE clause.
op (WhereOperator)
The operator.
parameter (String)
The name of the parameter for the WHERE clause.
Return Value
The resulting query.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Plugins.SqlCommon (Module: ScrewTurn.Wiki.Plugins.SqlCommon) Version: 3.0.2.500 (3.0.2.500)

Assembly: SqlServerProviders (Module: SqlServerProviders) Version: 3.0.2.500 (3.0.2.500)


OrWhere Method (query, column, op, parameter, openBracket, closeBracket)

OrWhere Method (query, column, op, parameter, openBracket, closeBracket)
ScrewTurn Wiki ► ScrewTurn.Wiki.Plugins.SqlCommon ► QueryBuilder ► OrWhere(String, String, WhereOperator, String, Boolean, Boolean)
Adds another WHERE clause to a query.
Declaration Syntax
C# Visual Basic Visual C++
public string OrWhere(
    string query,
    string column,
    WhereOperator op,
    string parameter,
    bool openBracket,
    bool closeBracket
)
Public Function OrWhere ( _
    query As String, _
    column As String, _
    op As WhereOperator, _
    parameter As String, _
    openBracket As Boolean, _
    closeBracket As Boolean _
) As String
public:
String^ OrWhere(
    String^ query,
    String^ column,
    WhereOperator op,
    String^ parameter,
    bool openBracket,
    bool closeBracket
)
Parameters
query (String)
The query.
column (String)
The column subject of the WHERE clause.
op (WhereOperator)
The operator.
parameter (String)
The name of the parameter for the WHERE clause.
openBracket (Boolean)
A value indicating whether to open a bracket after the OR.
closeBracket (Boolean)
A value indicating whether to close a bracket after the clause.
Return Value
The resulting query.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Plugins.SqlCommon (Module: ScrewTurn.Wiki.Plugins.SqlCommon) Version: 3.0.2.500 (3.0.2.500)

Assembly: SqlServerProviders (Module: SqlServerProviders) Version: 3.0.2.500 (3.0.2.500)


OrWhere Method (query, table, column, op, parameter)

OrWhere Method (query, table, column, op, parameter)
ScrewTurn Wiki ► ScrewTurn.Wiki.Plugins.SqlCommon ► QueryBuilder ► OrWhere(String, String, String, WhereOperator, String)
Adds another WHERE clause to a query.
Declaration Syntax
C# Visual Basic Visual C++
public string OrWhere(
    string query,
    string table,
    string column,
    WhereOperator op,
    string parameter
)
Public Function OrWhere ( _
    query As String, _
    table As String, _
    column As String, _
    op As WhereOperator, _
    parameter As String _
) As String
public:
String^ OrWhere(
    String^ query,
    String^ table,
    String^ column,
    WhereOperator op,
    String^ parameter
)
Parameters
query (String)
The query.
table (String)
The table the column belongs to.
column (String)
The column subject of the WHERE clause.
op (WhereOperator)
The operator.
parameter (String)
The name of the parameter for the WHERE clause.
Return Value
The resulting query.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Plugins.SqlCommon (Module: ScrewTurn.Wiki.Plugins.SqlCommon) Version: 3.0.2.500 (3.0.2.500)

Assembly: SqlServerProviders (Module: SqlServerProviders) Version: 3.0.2.500 (3.0.2.500)


OrWhere Method (query, table, column, op, parameter, openBracket, closeBracket)

OrWhere Method (query, table, column, op, parameter, openBracket, closeBracket)
ScrewTurn Wiki ► ScrewTurn.Wiki.Plugins.SqlCommon ► QueryBuilder ► OrWhere(String, String, String, WhereOperator, String, Boolean, Boolean)
Adds another WHERE clause to a query.
Declaration Syntax
C# Visual Basic Visual C++
public string OrWhere(
    string query,
    string table,
    string column,
    WhereOperator op,
    string parameter,
    bool openBracket,
    bool closeBracket
)
Public Function OrWhere ( _
    query As String, _
    table As String, _
    column As String, _
    op As WhereOperator, _
    parameter As String, _
    openBracket As Boolean, _
    closeBracket As Boolean _
) As String
public:
String^ OrWhere(
    String^ query,
    String^ table,
    String^ column,
    WhereOperator op,
    String^ parameter,
    bool openBracket,
    bool closeBracket
)
Parameters
query (String)
The query.
table (String)
The table the column belongs to.
column (String)
The column subject of the WHERE clause.
op (WhereOperator)
The operator.
parameter (String)
The name of the parameter for the WHERE clause.
openBracket (Boolean)
A value indicating whether to open a bracket after the AND.
closeBracket (Boolean)
A value indicating whether to close a bracket after the clause.
Return Value
The resulting query.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Plugins.SqlCommon (Module: ScrewTurn.Wiki.Plugins.SqlCommon) Version: 3.0.2.500 (3.0.2.500)

Assembly: SqlServerProviders (Module: SqlServerProviders) Version: 3.0.2.500 (3.0.2.500)


SelectCountFrom Method (table)

SelectCountFrom Method (table)
ScrewTurn Wiki ► ScrewTurn.Wiki.Plugins.SqlCommon ► QueryBuilder ► SelectCountFrom(String)
Builds a SELECT COUNT(*) query.
Declaration Syntax
C# Visual Basic Visual C++
public string SelectCountFrom(
    string table
)
Public Function SelectCountFrom ( _
    table As String _
) As String
public:
String^ SelectCountFrom(
    String^ table
)
Parameters
table (String)
The table.
Return Value
The SELECT query.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Plugins.SqlCommon (Module: ScrewTurn.Wiki.Plugins.SqlCommon) Version: 3.0.2.500 (3.0.2.500)

Assembly: SqlServerProviders (Module: SqlServerProviders) Version: 3.0.2.500 (3.0.2.500)


SelectFrom Method

SelectFrom Method
ScrewTurn Wiki ► ScrewTurn.Wiki.Plugins.SqlCommon ► QueryBuilder ► SelectFrom()()()
Members
Icon | Member | Description
 | SelectFrom(String, array<String>[]()[]) | Builds a SELECT query.
 | SelectFrom(String) | Builds a SELECT query.
 | SelectFrom(String, String, String, String, Join, array<String>[]()[], array<String>[]()[]) | Builds a SELECT query with a JOIN clause.
 | SelectFrom(String, String, array<String>[]()[], array<String>[]()[], Join, array<String>[]()[], array<String>[]()[]) | Builds a SELECT query with a JOIN clause.
 | SelectFrom(String, String, String, String, Join) | Builds a SELECT query with a JOIN clause.
 | SelectFrom(String, String, String, String, Join, array<String>[]()[], array<String>[]()[], String, String, Join, array<String>[]()[]) | Builds a SELECT query with two JOIN clauses (both on the main table).

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Plugins.SqlCommon (Module: ScrewTurn.Wiki.Plugins.SqlCommon) Version: 3.0.2.500 (3.0.2.500)

Assembly: SqlServerProviders (Module: SqlServerProviders) Version: 3.0.2.500 (3.0.2.500)


SelectFrom Method (table)

SelectFrom Method (table)
ScrewTurn Wiki ► ScrewTurn.Wiki.Plugins.SqlCommon ► QueryBuilder ► SelectFrom(String)
Builds a SELECT query.
Declaration Syntax
C# Visual Basic Visual C++
public string SelectFrom(
    string table
)
Public Function SelectFrom ( _
    table As String _
) As String
public:
String^ SelectFrom(
    String^ table
)
Parameters
table (String)
The table.
Return Value
The SELECT query.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Plugins.SqlCommon (Module: ScrewTurn.Wiki.Plugins.SqlCommon) Version: 3.0.2.500 (3.0.2.500)

Assembly: SqlServerProviders (Module: SqlServerProviders) Version: 3.0.2.500 (3.0.2.500)


SelectFrom Method (table, joinedTable, tableColumn, joinedTableColumn, join)

SelectFrom Method (table, joinedTable, tableColumn, joinedTableColumn, join)
ScrewTurn Wiki ► ScrewTurn.Wiki.Plugins.SqlCommon ► QueryBuilder ► SelectFrom(String, String, String, String, Join)
Builds a SELECT query with a JOIN clause.
Declaration Syntax
C# Visual Basic Visual C++
public string SelectFrom(
    string table,
    string joinedTable,
    string tableColumn,
    string joinedTableColumn,
    Join join
)
Public Function SelectFrom ( _
    table As String, _
    joinedTable As String, _
    tableColumn As String, _
    joinedTableColumn As String, _
    join As Join _
) As String
public:
String^ SelectFrom(
    String^ table,
    String^ joinedTable,
    String^ tableColumn,
    String^ joinedTableColumn,
    Join join
)
Parameters
table (String)
The main table.
joinedTable (String)
The joined table.
tableColumn (String)
The main table column to join.
joinedTableColumn (String)
The joined table column to join.
join (Join)
The JOIN type.
Return Value
The SELECT query.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Plugins.SqlCommon (Module: ScrewTurn.Wiki.Plugins.SqlCommon) Version: 3.0.2.500 (3.0.2.500)

Assembly: SqlServerProviders (Module: SqlServerProviders) Version: 3.0.2.500 (3.0.2.500)


SelectFrom Method (table, joinedTable, tableColumn, joinedTableColumn, join, tableColumns, joinedTableColumns)

SelectFrom Method (table, joinedTable, tableColumn, joinedTableColumn, join, tableColumns, joinedTableColumns)
ScrewTurn Wiki ► ScrewTurn.Wiki.Plugins.SqlCommon ► QueryBuilder ► SelectFrom(String, String, String, String, Join, array<String>[]()[], array<String>[]()[])
Builds a SELECT query with a JOIN clause.
Declaration Syntax
C# Visual Basic Visual C++
public string SelectFrom(
    string table,
    string joinedTable,
    string tableColumn,
    string joinedTableColumn,
    Join join,
    string[] tableColumns,
    string[] joinedTableColumns
)
Public Function SelectFrom ( _
    table As String, _
    joinedTable As String, _
    tableColumn As String, _
    joinedTableColumn As String, _
    join As Join, _
    tableColumns As String(), _
    joinedTableColumns As String() _
) As String
public:
String^ SelectFrom(
    String^ table,
    String^ joinedTable,
    String^ tableColumn,
    String^ joinedTableColumn,
    Join join,
    array<String^>^ tableColumns,
    array<String^>^ joinedTableColumns
)
Parameters
table (String)
The min table.
joinedTable (String)
The joined table.
tableColumn (String)
The main table column to join.
joinedTableColumn (String)
The joined table column to join.
join (Join)
The JOIN type.
tableColumns (array< String >[]()[][])
The main table columns to select.
joinedTableColumns (array< String >[]()[][])
The joined table columns to select.
Return Value
The SELECT query (returned columns are named like [Table_Column]).

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Plugins.SqlCommon (Module: ScrewTurn.Wiki.Plugins.SqlCommon) Version: 3.0.2.500 (3.0.2.500)

Assembly: SqlServerProviders (Module: SqlServerProviders) Version: 3.0.2.500 (3.0.2.500)


SelectFrom Method (table, joinedTable, tableColumn, joinedTableColumn, join, tableColumns, joinedTableColumns, otherJoinedTable, otherJoinedTableColumn, otherJoin, otherJoinedTableColumns)

SelectFrom Method (table, joinedTable, tableColumn, joinedTableColumn, join, tableColumns, joinedTableColumns, otherJoinedTable, otherJoinedTableColumn, otherJoin, otherJoinedTableColumns)
ScrewTurn Wiki ► ScrewTurn.Wiki.Plugins.SqlCommon ► QueryBuilder ► SelectFrom(String, String, String, String, Join, array<String>[]()[], array<String>[]()[], String, String, Join, array<String>[]()[])
Builds a SELECT query with two JOIN clauses (both on the main table).
Declaration Syntax
C# Visual Basic Visual C++
public string SelectFrom(
    string table,
    string joinedTable,
    string tableColumn,
    string joinedTableColumn,
    Join join,
    string[] tableColumns,
    string[] joinedTableColumns,
    string otherJoinedTable,
    string otherJoinedTableColumn,
    Join otherJoin,
    string[] otherJoinedTableColumns
)
Public Function SelectFrom ( _
    table As String, _
    joinedTable As String, _
    tableColumn As String, _
    joinedTableColumn As String, _
    join As Join, _
    tableColumns As String(), _
    joinedTableColumns As String(), _
    otherJoinedTable As String, _
    otherJoinedTableColumn As String, _
    otherJoin As Join, _
    otherJoinedTableColumns As String() _
) As String
public:
String^ SelectFrom(
    String^ table,
    String^ joinedTable,
    String^ tableColumn,
    String^ joinedTableColumn,
    Join join,
    array<String^>^ tableColumns,
    array<String^>^ joinedTableColumns,
    String^ otherJoinedTable,
    String^ otherJoinedTableColumn,
    Join otherJoin,
    array<String^>^ otherJoinedTableColumns
)
Parameters
table (String)
The main table.
joinedTable (String)
The joined table.
tableColumn (String)
The main table column to join.
joinedTableColumn (String)
The joined table column to join.
join (Join)
The join.
tableColumns (array< String >[]()[][])
The main table columns to select.
joinedTableColumns (array< String >[]()[][])
The joined table columns to select.
otherJoinedTable (String)
The other joined table.
otherJoinedTableColumn (String)
The other joined table column to join.
otherJoin (Join)
The join.
otherJoinedTableColumns (array< String >[]()[][])
The other joined table columns to select.
Return Value
The SELECT query (returned columns are named like [Table_Column]).

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Plugins.SqlCommon (Module: ScrewTurn.Wiki.Plugins.SqlCommon) Version: 3.0.2.500 (3.0.2.500)

Assembly: SqlServerProviders (Module: SqlServerProviders) Version: 3.0.2.500 (3.0.2.500)


SelectFrom Method (table, joinedTable, joinTableColumns, joinJoinedTableColumns, join, tableColumns, joinedTableColumns)

SelectFrom Method (table, joinedTable, joinTableColumns, joinJoinedTableColumns, join, tableColumns, joinedTableColumns)
ScrewTurn Wiki ► ScrewTurn.Wiki.Plugins.SqlCommon ► QueryBuilder ► SelectFrom(String, String, array<String>[]()[], array<String>[]()[], Join, array<String>[]()[], array<String>[]()[])
Builds a SELECT query with a JOIN clause.
Declaration Syntax
C# Visual Basic Visual C++
public string SelectFrom(
    string table,
    string joinedTable,
    string[] joinTableColumns,
    string[] joinJoinedTableColumns,
    Join join,
    string[] tableColumns,
    string[] joinedTableColumns
)
Public Function SelectFrom ( _
    table As String, _
    joinedTable As String, _
    joinTableColumns As String(), _
    joinJoinedTableColumns As String(), _
    join As Join, _
    tableColumns As String(), _
    joinedTableColumns As String() _
) As String
public:
String^ SelectFrom(
    String^ table,
    String^ joinedTable,
    array<String^>^ joinTableColumns,
    array<String^>^ joinJoinedTableColumns,
    Join join,
    array<String^>^ tableColumns,
    array<String^>^ joinedTableColumns
)
Parameters
table (String)
The min table.
joinedTable (String)
The joined table.
joinTableColumns (array< String >[]()[][])
The main table columns to join.
joinJoinedTableColumns (array< String >[]()[][])
The joined table columns to join.
join (Join)
The JOIN type.
tableColumns (array< String >[]()[][])
The main table columns to select.
joinedTableColumns (array< String >[]()[][])
The joined table columns to select.
Return Value
The SELECT query (returned columns are named like [Table_Column]).

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Plugins.SqlCommon (Module: ScrewTurn.Wiki.Plugins.SqlCommon) Version: 3.0.2.500 (3.0.2.500)

Assembly: SqlServerProviders (Module: SqlServerProviders) Version: 3.0.2.500 (3.0.2.500)


SelectFrom Method (table, columns)

SelectFrom Method (table, columns)
ScrewTurn Wiki ► ScrewTurn.Wiki.Plugins.SqlCommon ► QueryBuilder ► SelectFrom(String, array<String>[]()[])
Builds a SELECT query.
Declaration Syntax
C# Visual Basic Visual C++
public string SelectFrom(
    string table,
    string[] columns
)
Public Function SelectFrom ( _
    table As String, _
    columns As String() _
) As String
public:
String^ SelectFrom(
    String^ table,
    array<String^>^ columns
)
Parameters
table (String)
The table.
columns (array< String >[]()[][])
The columns to select.
Return Value
The SELECT query.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Plugins.SqlCommon (Module: ScrewTurn.Wiki.Plugins.SqlCommon) Version: 3.0.2.500 (3.0.2.500)

Assembly: SqlServerProviders (Module: SqlServerProviders) Version: 3.0.2.500 (3.0.2.500)


Update Method (table, columns, parameters)

Update Method (table, columns, parameters)
ScrewTurn Wiki ► ScrewTurn.Wiki.Plugins.SqlCommon ► QueryBuilder ► Update(String, array<String>[]()[], array<String>[]()[])
Builds an UPDATE query.
Declaration Syntax
C# Visual Basic Visual C++
public string Update(
    string table,
    string[] columns,
    string[] parameters
)
Public Function Update ( _
    table As String, _
    columns As String(), _
    parameters As String() _
) As String
public:
String^ Update(
    String^ table,
    array<String^>^ columns,
    array<String^>^ parameters
)
Parameters
table (String)
The table.
columns (array< String >[]()[][])
The columns to update.
parameters (array< String >[]()[][])
The parameters.
Return Value
The UPDATE query, without any WHERE clause.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Plugins.SqlCommon (Module: ScrewTurn.Wiki.Plugins.SqlCommon) Version: 3.0.2.500 (3.0.2.500)

Assembly: SqlServerProviders (Module: SqlServerProviders) Version: 3.0.2.500 (3.0.2.500)


UpdateIncrement Method (table, column, increment)

UpdateIncrement Method (table, column, increment)
ScrewTurn Wiki ► ScrewTurn.Wiki.Plugins.SqlCommon ► QueryBuilder ► UpdateIncrement(String, String, Int32)
Builds an UPDATE query that increments the numerical value of a column by one.
Declaration Syntax
C# Visual Basic Visual C++
public string UpdateIncrement(
    string table,
    string column,
    int increment
)
Public Function UpdateIncrement ( _
    table As String, _
    column As String, _
    increment As Integer _
) As String
public:
String^ UpdateIncrement(
    String^ table,
    String^ column,
    int increment
)
Parameters
table (String)
The table.
column (String)
The column to update.
increment (Int32)
The increment or decrement value.
Return Value
The UPDATE query, without any WHERE clause.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Plugins.SqlCommon (Module: ScrewTurn.Wiki.Plugins.SqlCommon) Version: 3.0.2.500 (3.0.2.500)

Assembly: SqlServerProviders (Module: SqlServerProviders) Version: 3.0.2.500 (3.0.2.500)


Where Method

Where Method
ScrewTurn Wiki ► ScrewTurn.Wiki.Plugins.SqlCommon ► QueryBuilder ► Where()()()
Members
Icon | Member | Description
 | Where(String, String, WhereOperator, String) | Applies a WHERE clause to a query.
 | Where(String, String, WhereOperator, String, Boolean, Boolean) | Applies a WHERE clause to a query.
 | Where(String, String, String, WhereOperator, String) | Applies a WHERE clause to a query.
 | Where(String, String, String, WhereOperator, String, Boolean, Boolean) | Applies a WHERE clause to a query.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Plugins.SqlCommon (Module: ScrewTurn.Wiki.Plugins.SqlCommon) Version: 3.0.2.500 (3.0.2.500)

Assembly: SqlServerProviders (Module: SqlServerProviders) Version: 3.0.2.500 (3.0.2.500)


Where Method (query, column, op, parameter)

Where Method (query, column, op, parameter)
ScrewTurn Wiki ► ScrewTurn.Wiki.Plugins.SqlCommon ► QueryBuilder ► Where(String, String, WhereOperator, String)
Applies a WHERE clause to a query.
Declaration Syntax
C# Visual Basic Visual C++
public string Where(
    string query,
    string column,
    WhereOperator op,
    string parameter
)
Public Function Where ( _
    query As String, _
    column As String, _
    op As WhereOperator, _
    parameter As String _
) As String
public:
String^ Where(
    String^ query,
    String^ column,
    WhereOperator op,
    String^ parameter
)
Parameters
query (String)
The query.
column (String)
The column subject of the WHERE clause.
op (WhereOperator)
The operator.
parameter (String)
The name of the parameter for the WHERE clause.
Return Value
The resulting query.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Plugins.SqlCommon (Module: ScrewTurn.Wiki.Plugins.SqlCommon) Version: 3.0.2.500 (3.0.2.500)

Assembly: SqlServerProviders (Module: SqlServerProviders) Version: 3.0.2.500 (3.0.2.500)


Where Method (query, column, op, parameter, openBracket, closeBracket)

Where Method (query, column, op, parameter, openBracket, closeBracket)
ScrewTurn Wiki ► ScrewTurn.Wiki.Plugins.SqlCommon ► QueryBuilder ► Where(String, String, WhereOperator, String, Boolean, Boolean)
Applies a WHERE clause to a query.
Declaration Syntax
C# Visual Basic Visual C++
public string Where(
    string query,
    string column,
    WhereOperator op,
    string parameter,
    bool openBracket,
    bool closeBracket
)
Public Function Where ( _
    query As String, _
    column As String, _
    op As WhereOperator, _
    parameter As String, _
    openBracket As Boolean, _
    closeBracket As Boolean _
) As String
public:
String^ Where(
    String^ query,
    String^ column,
    WhereOperator op,
    String^ parameter,
    bool openBracket,
    bool closeBracket
)
Parameters
query (String)
The query.
column (String)
The column subject of the WHERE clause.
op (WhereOperator)
The operator.
parameter (String)
The name of the parameter for the WHERE clause.
openBracket (Boolean)
A value indicating whether to open a bracket after the WHERE.
closeBracket (Boolean)
A value indicating whether to close a bracket after the clause.
Return Value
The resulting query.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Plugins.SqlCommon (Module: ScrewTurn.Wiki.Plugins.SqlCommon) Version: 3.0.2.500 (3.0.2.500)

Assembly: SqlServerProviders (Module: SqlServerProviders) Version: 3.0.2.500 (3.0.2.500)


Where Method (query, table, column, op, parameter)

Where Method (query, table, column, op, parameter)
ScrewTurn Wiki ► ScrewTurn.Wiki.Plugins.SqlCommon ► QueryBuilder ► Where(String, String, String, WhereOperator, String)
Applies a WHERE clause to a query.
Declaration Syntax
C# Visual Basic Visual C++
public string Where(
    string query,
    string table,
    string column,
    WhereOperator op,
    string parameter
)
Public Function Where ( _
    query As String, _
    table As String, _
    column As String, _
    op As WhereOperator, _
    parameter As String _
) As String
public:
String^ Where(
    String^ query,
    String^ table,
    String^ column,
    WhereOperator op,
    String^ parameter
)
Parameters
query (String)
The query.
table (String)
The table the column belongs to.
column (String)
The column subject of the WHERE clause.
op (WhereOperator)
The operator.
parameter (String)
The name of the parameter for the WHERE clause.
Return Value
The resulting query.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Plugins.SqlCommon (Module: ScrewTurn.Wiki.Plugins.SqlCommon) Version: 3.0.2.500 (3.0.2.500)

Assembly: SqlServerProviders (Module: SqlServerProviders) Version: 3.0.2.500 (3.0.2.500)


Where Method (query, table, column, op, parameter, openBracket, closeBracket)

Where Method (query, table, column, op, parameter, openBracket, closeBracket)
ScrewTurn Wiki ► ScrewTurn.Wiki.Plugins.SqlCommon ► QueryBuilder ► Where(String, String, String, WhereOperator, String, Boolean, Boolean)
Applies a WHERE clause to a query.
Declaration Syntax
C# Visual Basic Visual C++
public string Where(
    string query,
    string table,
    string column,
    WhereOperator op,
    string parameter,
    bool openBracket,
    bool closeBracket
)
Public Function Where ( _
    query As String, _
    table As String, _
    column As String, _
    op As WhereOperator, _
    parameter As String, _
    openBracket As Boolean, _
    closeBracket As Boolean _
) As String
public:
String^ Where(
    String^ query,
    String^ table,
    String^ column,
    WhereOperator op,
    String^ parameter,
    bool openBracket,
    bool closeBracket
)
Parameters
query (String)
The query.
table (String)
The table the column belongs to.
column (String)
The column subject of the WHERE clause.
op (WhereOperator)
The operator.
parameter (String)
The name of the parameter for the WHERE clause.
openBracket (Boolean)
A value indicating whether to open a bracket after the WHERE.
closeBracket (Boolean)
A value indicating whether to close a bracket after the clause.
Return Value
The resulting query.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Plugins.SqlCommon (Module: ScrewTurn.Wiki.Plugins.SqlCommon) Version: 3.0.2.500 (3.0.2.500)

Assembly: SqlServerProviders (Module: SqlServerProviders) Version: 3.0.2.500 (3.0.2.500)


WhereIn Method

WhereIn Method
ScrewTurn Wiki ► ScrewTurn.Wiki.Plugins.SqlCommon ► QueryBuilder ► WhereIn()()()
Members
Icon | Member | Description
 | WhereIn(String, String, array<String>[]()[]) | Applies a WHERE clause with IN operator to a query.
 | WhereIn(String, String, String, array<String>[]()[]) | Applies a WHERE clause with IN operator to a query.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Plugins.SqlCommon (Module: ScrewTurn.Wiki.Plugins.SqlCommon) Version: 3.0.2.500 (3.0.2.500)

Assembly: SqlServerProviders (Module: SqlServerProviders) Version: 3.0.2.500 (3.0.2.500)


WhereIn Method (query, table, column, parameters)

WhereIn Method (query, table, column, parameters)
ScrewTurn Wiki ► ScrewTurn.Wiki.Plugins.SqlCommon ► QueryBuilder ► WhereIn(String, String, String, array<String>[]()[])
Applies a WHERE clause with IN operator to a query.
Declaration Syntax
C# Visual Basic Visual C++
public string WhereIn(
    string query,
    string table,
    string column,
    string[] parameters
)
Public Function WhereIn ( _
    query As String, _
    table As String, _
    column As String, _
    parameters As String() _
) As String
public:
String^ WhereIn(
    String^ query,
    String^ table,
    String^ column,
    array<String^>^ parameters
)
Parameters
query (String)
The query.
table (String)
The table the column belongs to.
column (String)
The column subject of the WHERE clause.
parameters (array< String >[]()[][])
The names of the parameters in the IN set.
Return Value
The resulting query.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Plugins.SqlCommon (Module: ScrewTurn.Wiki.Plugins.SqlCommon) Version: 3.0.2.500 (3.0.2.500)

Assembly: SqlServerProviders (Module: SqlServerProviders) Version: 3.0.2.500 (3.0.2.500)


WhereIn Method (query, column, parameters)

WhereIn Method (query, column, parameters)
ScrewTurn Wiki ► ScrewTurn.Wiki.Plugins.SqlCommon ► QueryBuilder ► WhereIn(String, String, array<String>[]()[])
Applies a WHERE clause with IN operator to a query.
Declaration Syntax
C# Visual Basic Visual C++
public string WhereIn(
    string query,
    string column,
    string[] parameters
)
Public Function WhereIn ( _
    query As String, _
    column As String, _
    parameters As String() _
) As String
public:
String^ WhereIn(
    String^ query,
    String^ column,
    array<String^>^ parameters
)
Parameters
query (String)
The query.
column (String)
The column subject of the WHERE clause.
parameters (array< String >[]()[][])
The names of the parameters in the IN set.
Return Value
The resulting query.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Plugins.SqlCommon (Module: ScrewTurn.Wiki.Plugins.SqlCommon) Version: 3.0.2.500 (3.0.2.500)

Assembly: SqlServerProviders (Module: SqlServerProviders) Version: 3.0.2.500 (3.0.2.500)


WhereNotInSubquery Method (query, table, column, subQuery)

WhereNotInSubquery Method (query, table, column, subQuery)
ScrewTurn Wiki ► ScrewTurn.Wiki.Plugins.SqlCommon ► QueryBuilder ► WhereNotInSubquery(String, String, String, String)
Applies a WHERE NOT IN (subQuery) clause to a query.
Declaration Syntax
C# Visual Basic Visual C++
public string WhereNotInSubquery(
    string query,
    string table,
    string column,
    string subQuery
)
Public Function WhereNotInSubquery ( _
    query As String, _
    table As String, _
    column As String, _
    subQuery As String _
) As String
public:
String^ WhereNotInSubquery(
    String^ query,
    String^ table,
    String^ column,
    String^ subQuery
)
Parameters
query (String)
The query.
table (String)
The table the column belongs to.
column (String)
The column.
subQuery (String)
The subQuery.
Return Value
The resulting query.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Plugins.SqlCommon (Module: ScrewTurn.Wiki.Plugins.SqlCommon) Version: 3.0.2.500 (3.0.2.500)

Assembly: SqlServerProviders (Module: SqlServerProviders) Version: 3.0.2.500 (3.0.2.500)


RenameResource Delegate

RenameResource Delegate
ScrewTurn Wiki ► ScrewTurn.Wiki.Plugins.SqlCommon ► RenameResource
Defines a delegate for a method that renames a resource.
Declaration Syntax
C# Visual Basic Visual C++
public delegate bool RenameResource(
    string resource,
    string newName
)
Public Delegate Function RenameResource ( _
    resource As String, _
    newName As String _
) As Boolean
public delegate bool RenameResource(
    String^ resource,
    String^ newName
)
Parameters
resource (String)
The resource to rename.
newName (String)
The new name of the resource.
Return Value
true if the resource was renamed, false otherwise.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Plugins.SqlCommon (Module: ScrewTurn.Wiki.Plugins.SqlCommon) Version: 3.0.2.500 (3.0.2.500)

Assembly: SqlServerProviders (Module: SqlServerProviders) Version: 3.0.2.500 (3.0.2.500)


RetrieveAllEntries Delegate

RetrieveAllEntries Delegate
ScrewTurn Wiki ► ScrewTurn.Wiki.Plugins.SqlCommon ► RetrieveAllEntries
Defines a delegate for a method that retrieves all entries.
Declaration Syntax
C# Visual Basic Visual C++
public delegate AclEntry[] RetrieveAllEntries()
Public Delegate Function RetrieveAllEntries As AclEntry()
public delegate array<AclEntry^>^ RetrieveAllEntries()
Return Value
The entries.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Plugins.SqlCommon (Module: ScrewTurn.Wiki.Plugins.SqlCommon) Version: 3.0.2.500 (3.0.2.500)

Assembly: SqlServerProviders (Module: SqlServerProviders) Version: 3.0.2.500 (3.0.2.500)


RetrieveEntriesForResource Delegate

RetrieveEntriesForResource Delegate
ScrewTurn Wiki ► ScrewTurn.Wiki.Plugins.SqlCommon ► RetrieveEntriesForResource
Defines a delegate for a method that retrieves all entries for a resource.
Declaration Syntax
C# Visual Basic Visual C++
public delegate AclEntry[] RetrieveEntriesForResource(
    string resource
)
Public Delegate Function RetrieveEntriesForResource ( _
    resource As String _
) As AclEntry()
public delegate array<AclEntry^>^ RetrieveEntriesForResource(
    String^ resource
)
Parameters
resource (String)
The resource.
Return Value
The entries of the resource.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Plugins.SqlCommon (Module: ScrewTurn.Wiki.Plugins.SqlCommon) Version: 3.0.2.500 (3.0.2.500)

Assembly: SqlServerProviders (Module: SqlServerProviders) Version: 3.0.2.500 (3.0.2.500)


RetrieveEntriesForSubject Delegate

RetrieveEntriesForSubject Delegate
ScrewTurn Wiki ► ScrewTurn.Wiki.Plugins.SqlCommon ► RetrieveEntriesForSubject
Defines a delegate for a method that retrieves all entries for a subject.
Declaration Syntax
C# Visual Basic Visual C++
public delegate AclEntry[] RetrieveEntriesForSubject(
    string subject
)
Public Delegate Function RetrieveEntriesForSubject ( _
    subject As String _
) As AclEntry()
public delegate array<AclEntry^>^ RetrieveEntriesForSubject(
    String^ subject
)
Parameters
subject (String)
The subject.
Return Value
The entries of the subject.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Plugins.SqlCommon (Module: ScrewTurn.Wiki.Plugins.SqlCommon) Version: 3.0.2.500 (3.0.2.500)

Assembly: SqlServerProviders (Module: SqlServerProviders) Version: 3.0.2.500 (3.0.2.500)


SaveDataForDocument Delegate

SaveDataForDocument Delegate
ScrewTurn Wiki ► ScrewTurn.Wiki.Plugins.SqlCommon ► SaveDataForDocument
Defines a delegate for a method for saving data. The passed data is the whole document data, as it was tokenized.
Declaration Syntax
C# Visual Basic Visual C++
public delegate int SaveDataForDocument(
    IDocument document,
    WordInfo[] content,
    WordInfo[] title,
    WordInfo[] keywords,
    Object state
)
Public Delegate Function SaveDataForDocument ( _
    document As IDocument, _
    content As WordInfo(), _
    title As WordInfo(), _
    keywords As WordInfo(), _
    state As Object _
) As Integer
public delegate int SaveDataForDocument(
    IDocument^ document,
    array<WordInfo^>^ content,
    array<WordInfo^>^ title,
    array<WordInfo^>^ keywords,
    Object^ state
)
Parameters
document (IDocument)
The document.
content (array< WordInfo >[]()[][])
The content words.
title (array< WordInfo >[]()[][])
The title words.
keywords (array< WordInfo >[]()[][])
The keywords.
state (Object)
A state object passed from the index.
Return Value
The number of stored occurrences.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Plugins.SqlCommon (Module: ScrewTurn.Wiki.Plugins.SqlCommon) Version: 3.0.2.500 (3.0.2.500)

Assembly: SqlServerProviders (Module: SqlServerProviders) Version: 3.0.2.500 (3.0.2.500)


SqlAclManager Class

SqlAclManager Class
ScrewTurn Wiki ► ScrewTurn.Wiki.Plugins.SqlCommon ► SqlAclManager
Implements a SQL ACL Manager.
Declaration Syntax
C# Visual Basic Visual C++
public class SqlAclManager : IAclManager
Public Class SqlAclManager _
    Implements IAclManager
public ref class SqlAclManager : IAclManager
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | SqlAclManager(StoreEntry, DeleteEntries, RenameResource, RetrieveAllEntries, RetrieveEntriesForResource, RetrieveEntriesForSubject) | Initializes a new instance of the SqlAclManager class.
 | AclChanged | Event fired when an ACL entry is stored or deleted.
 | DeleteEntriesForResource(String) | Deletes all the ACL entries for a resource.
 | DeleteEntriesForSubject(String) | Deletes all the ACL entries for a subject.
 | DeleteEntry(String, String, String) | Deletes an ACL entry.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | InitializeData(array<AclEntry>[]()[]) | Initializes the manager data.
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | RenameResource(String, String) | Renames a resource.
 | RetrieveAllEntries()()() | Retrieves all the ACL entries for a resource.
 | RetrieveEntriesForResource(String) | Retrieves all the ACL entries for a resource.
 | RetrieveEntriesForSubject(String) | Retrieves all the ACL entries for a subject.
 | StoreEntry(String, String, String, Value) | Stores a new ACL entry.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | TotalEntries | Gets the total number of ACL entries.
Inheritance Hierarchy
Object
SqlAclManager

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Plugins.SqlCommon (Module: ScrewTurn.Wiki.Plugins.SqlCommon) Version: 3.0.2.500 (3.0.2.500)

Assembly: SqlServerProviders (Module: SqlServerProviders) Version: 3.0.2.500 (3.0.2.500)


SqlAclManager Constructor (storeEntry, deleteEntries, renameResource, retrieveAllEntries, retrieveEntriesForResource, retrieveEntriesForSubject)

SqlAclManager Constructor (storeEntry, deleteEntries, renameResource, retrieveAllEntries, retrieveEntriesForResource, retrieveEntriesForSubject)
ScrewTurn Wiki ► ScrewTurn.Wiki.Plugins.SqlCommon ► SqlAclManager ► SqlAclManager(StoreEntry, DeleteEntries, RenameResource, RetrieveAllEntries, RetrieveEntriesForResource, RetrieveEntriesForSubject)
Initializes a new instance of the SqlAclManager class.
Declaration Syntax
C# Visual Basic Visual C++
public SqlAclManager(
    StoreEntry storeEntry,
    DeleteEntries deleteEntries,
    RenameResource renameResource,
    RetrieveAllEntries retrieveAllEntries,
    RetrieveEntriesForResource retrieveEntriesForResource,
    RetrieveEntriesForSubject retrieveEntriesForSubject
)
Public Sub New ( _
    storeEntry As StoreEntry, _
    deleteEntries As DeleteEntries, _
    renameResource As RenameResource, _
    retrieveAllEntries As RetrieveAllEntries, _
    retrieveEntriesForResource As RetrieveEntriesForResource, _
    retrieveEntriesForSubject As RetrieveEntriesForSubject _
)
public:
SqlAclManager(
    StoreEntry^ storeEntry,
    DeleteEntries^ deleteEntries,
    RenameResource^ renameResource,
    RetrieveAllEntries^ retrieveAllEntries,
    RetrieveEntriesForResource^ retrieveEntriesForResource,
    RetrieveEntriesForSubject^ retrieveEntriesForSubject
)
Parameters
storeEntry (StoreEntry)
The StoreEntry(String, String, String, Value) delegate.
deleteEntries (DeleteEntries)
The DeleteEntries delegate.
renameResource (RenameResource)
The RenameResource(String, String) delegate.
retrieveAllEntries (RetrieveAllEntries)
The RetrieveAllEntries()()() delegate.
retrieveEntriesForResource (RetrieveEntriesForResource)
The RetrieveEntriesForResource(String) delegate.
retrieveEntriesForSubject (RetrieveEntriesForSubject)
The RetrieveEntriesForSubject(String) delegate.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Plugins.SqlCommon (Module: ScrewTurn.Wiki.Plugins.SqlCommon) Version: 3.0.2.500 (3.0.2.500)

Assembly: SqlServerProviders (Module: SqlServerProviders) Version: 3.0.2.500 (3.0.2.500)


AclChanged Event

AclChanged Event
ScrewTurn Wiki ► ScrewTurn.Wiki.Plugins.SqlCommon ► SqlAclManager ► AclChanged
Event fired when an ACL entry is stored or deleted.
Declaration Syntax
C# Visual Basic Visual C++
public event EventHandler<AclChangedEventArgs> AclChanged
Public Event AclChanged As EventHandler(Of AclChangedEventArgs)
public:
virtual  event EventHandler<AclChangedEventArgs^>^ AclChanged {
    void add (EventHandler<AclChangedEventArgs^>^ value);
    void remove (EventHandler<AclChangedEventArgs^>^ value);
}

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Plugins.SqlCommon (Module: ScrewTurn.Wiki.Plugins.SqlCommon) Version: 3.0.2.500 (3.0.2.500)

Assembly: SqlServerProviders (Module: SqlServerProviders) Version: 3.0.2.500 (3.0.2.500)


DeleteEntriesForResource Method (resource)

DeleteEntriesForResource Method (resource)
ScrewTurn Wiki ► ScrewTurn.Wiki.Plugins.SqlCommon ► SqlAclManager ► DeleteEntriesForResource(String)
Deletes all the ACL entries for a resource.
Declaration Syntax
C# Visual Basic Visual C++
public bool DeleteEntriesForResource(
    string resource
)
Public Function DeleteEntriesForResource ( _
    resource As String _
) As Boolean
public:
virtual bool DeleteEntriesForResource(
    String^ resource
) sealed
Parameters
resource (String)
The controlled resource.
Return Value
true if the entries are deleted, false otherwise.
Exceptions
Exception | Condition
ArgumentNullException | If resource is null.
ArgumentException | If resource is empty.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Plugins.SqlCommon (Module: ScrewTurn.Wiki.Plugins.SqlCommon) Version: 3.0.2.500 (3.0.2.500)

Assembly: SqlServerProviders (Module: SqlServerProviders) Version: 3.0.2.500 (3.0.2.500)


DeleteEntriesForSubject Method (subject)

DeleteEntriesForSubject Method (subject)
ScrewTurn Wiki ► ScrewTurn.Wiki.Plugins.SqlCommon ► SqlAclManager ► DeleteEntriesForSubject(String)
Deletes all the ACL entries for a subject.
Declaration Syntax
C# Visual Basic Visual C++
public bool DeleteEntriesForSubject(
    string subject
)
Public Function DeleteEntriesForSubject ( _
    subject As String _
) As Boolean
public:
virtual bool DeleteEntriesForSubject(
    String^ subject
) sealed
Parameters
subject (String)
The subject.
Return Value
true if the entries are deleted, false otherwise.
Exceptions
Exception | Condition
ArgumentNullException | If subject is null.
ArgumentException | If subject is empty.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Plugins.SqlCommon (Module: ScrewTurn.Wiki.Plugins.SqlCommon) Version: 3.0.2.500 (3.0.2.500)

Assembly: SqlServerProviders (Module: SqlServerProviders) Version: 3.0.2.500 (3.0.2.500)


DeleteEntry Method (resource, action, subject)

DeleteEntry Method (resource, action, subject)
ScrewTurn Wiki ► ScrewTurn.Wiki.Plugins.SqlCommon ► SqlAclManager ► DeleteEntry(String, String, String)
Deletes an ACL entry.
Declaration Syntax
C# Visual Basic Visual C++
public bool DeleteEntry(
    string resource,
    string action,
    string subject
)
Public Function DeleteEntry ( _
    resource As String, _
    action As String, _
    subject As String _
) As Boolean
public:
virtual bool DeleteEntry(
    String^ resource,
    String^ action,
    String^ subject
) sealed
Parameters
resource (String)
The controlled resource.
action (String)
The action on the controlled resource.
subject (String)
The subject whose access to the resource/action is controlled.
Return Value
true if the entry is deleted, false otherwise.
Exceptions
Exception | Condition
ArgumentNullException | If resource, action or subject are null.
ArgumentException | If resource, action or subject are empty.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Plugins.SqlCommon (Module: ScrewTurn.Wiki.Plugins.SqlCommon) Version: 3.0.2.500 (3.0.2.500)

Assembly: SqlServerProviders (Module: SqlServerProviders) Version: 3.0.2.500 (3.0.2.500)


InitializeData Method (entries)

InitializeData Method (entries)
ScrewTurn Wiki ► ScrewTurn.Wiki.Plugins.SqlCommon ► SqlAclManager ► InitializeData(array<AclEntry>[]()[])
Initializes the manager data.
Declaration Syntax
C# Visual Basic Visual C++
public void InitializeData(
    AclEntry[] entries
)
Public Sub InitializeData ( _
    entries As AclEntry() _
)
public:
virtual void InitializeData(
    array<AclEntry^>^ entries
) sealed
Parameters
entries (array< AclEntry >[]()[][])
The ACL entries.
Exceptions
Exception | Condition
ArgumentNullException | If entries is null.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Plugins.SqlCommon (Module: ScrewTurn.Wiki.Plugins.SqlCommon) Version: 3.0.2.500 (3.0.2.500)

Assembly: SqlServerProviders (Module: SqlServerProviders) Version: 3.0.2.500 (3.0.2.500)


RenameResource Method (resource, newName)

RenameResource Method (resource, newName)
ScrewTurn Wiki ► ScrewTurn.Wiki.Plugins.SqlCommon ► SqlAclManager ► RenameResource(String, String)
Renames a resource.
Declaration Syntax
C# Visual Basic Visual C++
public bool RenameResource(
    string resource,
    string newName
)
Public Function RenameResource ( _
    resource As String, _
    newName As String _
) As Boolean
public:
virtual bool RenameResource(
    String^ resource,
    String^ newName
) sealed
Parameters
resource (String)
The resource.
newName (String)
The new name of the resource.
Return Value
true if the resource is renamed, false otherwise.
Exceptions
Exception | Condition
ArgumentNullException | If resource or newName are null.
ArgumentException | If resource or newName are empty.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Plugins.SqlCommon (Module: ScrewTurn.Wiki.Plugins.SqlCommon) Version: 3.0.2.500 (3.0.2.500)

Assembly: SqlServerProviders (Module: SqlServerProviders) Version: 3.0.2.500 (3.0.2.500)


RetrieveAllEntries Method

RetrieveAllEntries Method
ScrewTurn Wiki ► ScrewTurn.Wiki.Plugins.SqlCommon ► SqlAclManager ► RetrieveAllEntries()()()
Retrieves all the ACL entries for a resource.
Declaration Syntax
C# Visual Basic Visual C++
public AclEntry[] RetrieveAllEntries()
Public Function RetrieveAllEntries As AclEntry()
public:
virtual array<AclEntry^>^ RetrieveAllEntries() sealed
Return Value
The entries.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Plugins.SqlCommon (Module: ScrewTurn.Wiki.Plugins.SqlCommon) Version: 3.0.2.500 (3.0.2.500)

Assembly: SqlServerProviders (Module: SqlServerProviders) Version: 3.0.2.500 (3.0.2.500)


RetrieveEntriesForResource Method (resource)

RetrieveEntriesForResource Method (resource)
ScrewTurn Wiki ► ScrewTurn.Wiki.Plugins.SqlCommon ► SqlAclManager ► RetrieveEntriesForResource(String)
Retrieves all the ACL entries for a resource.
Declaration Syntax
C# Visual Basic Visual C++
public AclEntry[] RetrieveEntriesForResource(
    string resource
)
Public Function RetrieveEntriesForResource ( _
    resource As String _
) As AclEntry()
public:
virtual array<AclEntry^>^ RetrieveEntriesForResource(
    String^ resource
) sealed
Parameters
resource (String)
The resource.
Return Value
The entries.
Exceptions
Exception | Condition
ArgumentNullException | If resource is null.
ArgumentException | If resource is empty.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Plugins.SqlCommon (Module: ScrewTurn.Wiki.Plugins.SqlCommon) Version: 3.0.2.500 (3.0.2.500)

Assembly: SqlServerProviders (Module: SqlServerProviders) Version: 3.0.2.500 (3.0.2.500)


RetrieveEntriesForSubject Method (subject)

RetrieveEntriesForSubject Method (subject)
ScrewTurn Wiki ► ScrewTurn.Wiki.Plugins.SqlCommon ► SqlAclManager ► RetrieveEntriesForSubject(String)
Retrieves all the ACL entries for a subject.
Declaration Syntax
C# Visual Basic Visual C++
public AclEntry[] RetrieveEntriesForSubject(
    string subject
)
Public Function RetrieveEntriesForSubject ( _
    subject As String _
) As AclEntry()
public:
virtual array<AclEntry^>^ RetrieveEntriesForSubject(
    String^ subject
) sealed
Parameters
subject (String)
The subject.
Return Value
The entries.
Exceptions
Exception | Condition
ArgumentNullException | If subject is null.
ArgumentException | If subject is empty.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Plugins.SqlCommon (Module: ScrewTurn.Wiki.Plugins.SqlCommon) Version: 3.0.2.500 (3.0.2.500)

Assembly: SqlServerProviders (Module: SqlServerProviders) Version: 3.0.2.500 (3.0.2.500)


StoreEntry Method (resource, action, subject, value)

StoreEntry Method (resource, action, subject, value)
ScrewTurn Wiki ► ScrewTurn.Wiki.Plugins.SqlCommon ► SqlAclManager ► StoreEntry(String, String, String, Value)
Stores a new ACL entry.
Declaration Syntax
C# Visual Basic Visual C++
public bool StoreEntry(
    string resource,
    string action,
    string subject,
    Value value
)
Public Function StoreEntry ( _
    resource As String, _
    action As String, _
    subject As String, _
    value As Value _
) As Boolean
public:
virtual bool StoreEntry(
    String^ resource,
    String^ action,
    String^ subject,
    Value value
) sealed
Parameters
resource (String)
The controlled resource.
action (String)
The action on the controlled resource.
subject (String)
The subject whose access to the resource/action is controlled.
value (Value)
The value of the entry.
Return Value
true if the entry is stored, false otherwise.
Exceptions
Exception | Condition
ArgumentNullException | If resource, action or subject are null.
ArgumentException | If resource, action or subject are empty.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Plugins.SqlCommon (Module: ScrewTurn.Wiki.Plugins.SqlCommon) Version: 3.0.2.500 (3.0.2.500)

Assembly: SqlServerProviders (Module: SqlServerProviders) Version: 3.0.2.500 (3.0.2.500)


TotalEntries Property

TotalEntries Property
ScrewTurn Wiki ► ScrewTurn.Wiki.Plugins.SqlCommon ► SqlAclManager ► TotalEntries
Gets the total number of ACL entries.
Declaration Syntax
C# Visual Basic Visual C++
public int TotalEntries { get; }
Public ReadOnly Property TotalEntries As Integer
public:
virtual property int TotalEntries {
    int get () sealed;
}

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Plugins.SqlCommon (Module: ScrewTurn.Wiki.Plugins.SqlCommon) Version: 3.0.2.500 (3.0.2.500)

Assembly: SqlServerProviders (Module: SqlServerProviders) Version: 3.0.2.500 (3.0.2.500)


SqlClassBase Class

SqlClassBase Class
ScrewTurn Wiki ► ScrewTurn.Wiki.Plugins.SqlCommon ► SqlClassBase
Implements a base class for all SQL-based classes.
Declaration Syntax
C# Visual Basic Visual C++
public abstract class SqlClassBase
Public MustInherit Class SqlClassBase
public ref class SqlClassBase abstract
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | SqlClassBase()()() | Initializes a new instance of the SqlClassBase class
 | BeginTransaction(DbConnection) | Begins a transaction.
 | CloseConnection(DbConnection) | Closes a connection, swallowing all exceptions.
 | CloseReader(DbCommand, DbDataReader) | Closes a reader, a command and the associated connection.
 | CloseReader(DbDataReader) | Closes a reader.
 | CommitTransaction(DbTransaction) | Commits a transaction.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | ExecuteNonQuery(DbCommand) | Executes a non-query command, then closes the connection.
 | ExecuteNonQuery(DbCommand, Boolean) | Executes a non-query command, then closes the connection if requested.
 | ExecuteNonQuery(DbCommand, Boolean, Boolean) | Executes a non-query command, then closes the connection if requested.
 | ExecuteReader(DbCommand, Boolean) | Executes a reader command, leaving the connection open.
 | ExecuteReader(DbCommand) | Executes a reader command, leaving the connection open.
 | ExecuteScalar<(Of <(T>)>)(DbCommand, T) | Executes a scalar command, then closes the connection.
 | ExecuteScalar<(Of <(T>)>)(DbCommand, T, Boolean) | Executes a scalar command, then closes the connection.
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetBinaryColumn(DbDataReader, String, Int32) | Reads all the contents of a binary column.
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetNullableColumn<(Of <(T>)>)(DbDataReader, String, T) | Gets the value of a nullable column.
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | IsDBNull(DbDataReader, String) | Gets a value indicating whether a column contains nonexistent or missing value.
 | LogException(Exception) | Logs an exception.
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ReadBinaryColumn(DbDataReader, String, Stream) | Copies all the contents of a binary column into a Stream.
 | RollbackTransaction(DbTransaction) | Rolls back a transaction.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | SqlClassBase
 |  | SqlStorageProviderBase

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Plugins.SqlCommon (Module: ScrewTurn.Wiki.Plugins.SqlCommon) Version: 3.0.2.500 (3.0.2.500)

Assembly: SqlServerProviders (Module: SqlServerProviders) Version: 3.0.2.500 (3.0.2.500)


SqlClassBase Constructor

SqlClassBase Constructor
ScrewTurn Wiki ► ScrewTurn.Wiki.Plugins.SqlCommon ► SqlClassBase ► SqlClassBase()()()
Initializes a new instance of the SqlClassBase class
Declaration Syntax
C# Visual Basic Visual C++
protected SqlClassBase()
Protected Sub New
protected:
SqlClassBase()

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Plugins.SqlCommon (Module: ScrewTurn.Wiki.Plugins.SqlCommon) Version: 3.0.2.500 (3.0.2.500)

Assembly: SqlServerProviders (Module: SqlServerProviders) Version: 3.0.2.500 (3.0.2.500)


BeginTransaction Method (connection)

BeginTransaction Method (connection)
ScrewTurn Wiki ► ScrewTurn.Wiki.Plugins.SqlCommon ► SqlClassBase ► BeginTransaction(DbConnection)
Begins a transaction.
Declaration Syntax
C# Visual Basic Visual C++
protected DbTransaction BeginTransaction(
    DbConnection connection
)
Protected Function BeginTransaction ( _
    connection As DbConnection _
) As DbTransaction
protected:
DbTransaction^ BeginTransaction(
    DbConnection^ connection
)
Parameters
connection (DbConnection)
The connection.
Return Value
The transaction.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Plugins.SqlCommon (Module: ScrewTurn.Wiki.Plugins.SqlCommon) Version: 3.0.2.500 (3.0.2.500)

Assembly: SqlServerProviders (Module: SqlServerProviders) Version: 3.0.2.500 (3.0.2.500)


CloseConnection Method (connection)

CloseConnection Method (connection)
ScrewTurn Wiki ► ScrewTurn.Wiki.Plugins.SqlCommon ► SqlClassBase ► CloseConnection(DbConnection)
Closes a connection, swallowing all exceptions.
Declaration Syntax
C# Visual Basic Visual C++
protected void CloseConnection(
    DbConnection connection
)
Protected Sub CloseConnection ( _
    connection As DbConnection _
)
protected:
void CloseConnection(
    DbConnection^ connection
)
Parameters
connection (DbConnection)
The connection to close.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Plugins.SqlCommon (Module: ScrewTurn.Wiki.Plugins.SqlCommon) Version: 3.0.2.500 (3.0.2.500)

Assembly: SqlServerProviders (Module: SqlServerProviders) Version: 3.0.2.500 (3.0.2.500)


CloseReader Method

CloseReader Method
ScrewTurn Wiki ► ScrewTurn.Wiki.Plugins.SqlCommon ► SqlClassBase ► CloseReader()()()
Members
Icon | Member | Description
 | CloseReader(DbCommand, DbDataReader) | Closes a reader, a command and the associated connection.
 | CloseReader(DbDataReader) | Closes a reader.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Plugins.SqlCommon (Module: ScrewTurn.Wiki.Plugins.SqlCommon) Version: 3.0.2.500 (3.0.2.500)

Assembly: SqlServerProviders (Module: SqlServerProviders) Version: 3.0.2.500 (3.0.2.500)


CloseReader Method (command, reader)

CloseReader Method (command, reader)
ScrewTurn Wiki ► ScrewTurn.Wiki.Plugins.SqlCommon ► SqlClassBase ► CloseReader(DbCommand, DbDataReader)
Closes a reader, a command and the associated connection.
Declaration Syntax
C# Visual Basic Visual C++
protected void CloseReader(
    DbCommand command,
    DbDataReader reader
)
Protected Sub CloseReader ( _
    command As DbCommand, _
    reader As DbDataReader _
)
protected:
void CloseReader(
    DbCommand^ command,
    DbDataReader^ reader
)
Parameters
command (DbCommand)
The command.
reader (DbDataReader)
The reader.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Plugins.SqlCommon (Module: ScrewTurn.Wiki.Plugins.SqlCommon) Version: 3.0.2.500 (3.0.2.500)

Assembly: SqlServerProviders (Module: SqlServerProviders) Version: 3.0.2.500 (3.0.2.500)


CloseReader Method (reader)

CloseReader Method (reader)
ScrewTurn Wiki ► ScrewTurn.Wiki.Plugins.SqlCommon ► SqlClassBase ► CloseReader(DbDataReader)
Closes a reader.
Declaration Syntax
C# Visual Basic Visual C++
protected void CloseReader(
    DbDataReader reader
)
Protected Sub CloseReader ( _
    reader As DbDataReader _
)
protected:
void CloseReader(
    DbDataReader^ reader
)
Parameters
reader (DbDataReader)
The reader.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Plugins.SqlCommon (Module: ScrewTurn.Wiki.Plugins.SqlCommon) Version: 3.0.2.500 (3.0.2.500)

Assembly: SqlServerProviders (Module: SqlServerProviders) Version: 3.0.2.500 (3.0.2.500)


CommitTransaction Method (transaction)

CommitTransaction Method (transaction)
ScrewTurn Wiki ► ScrewTurn.Wiki.Plugins.SqlCommon ► SqlClassBase ► CommitTransaction(DbTransaction)
Commits a transaction.
Declaration Syntax
C# Visual Basic Visual C++
protected void CommitTransaction(
    DbTransaction transaction
)
Protected Sub CommitTransaction ( _
    transaction As DbTransaction _
)
protected:
void CommitTransaction(
    DbTransaction^ transaction
)
Parameters
transaction (DbTransaction)
The transaction.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Plugins.SqlCommon (Module: ScrewTurn.Wiki.Plugins.SqlCommon) Version: 3.0.2.500 (3.0.2.500)

Assembly: SqlServerProviders (Module: SqlServerProviders) Version: 3.0.2.500 (3.0.2.500)


ExecuteNonQuery Method

ExecuteNonQuery Method
ScrewTurn Wiki ► ScrewTurn.Wiki.Plugins.SqlCommon ► SqlClassBase ► ExecuteNonQuery()()()
Members
Icon | Member | Description
 | ExecuteNonQuery(DbCommand) | Executes a non-query command, then closes the connection.
 | ExecuteNonQuery(DbCommand, Boolean) | Executes a non-query command, then closes the connection if requested.
 | ExecuteNonQuery(DbCommand, Boolean, Boolean) | Executes a non-query command, then closes the connection if requested.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Plugins.SqlCommon (Module: ScrewTurn.Wiki.Plugins.SqlCommon) Version: 3.0.2.500 (3.0.2.500)

Assembly: SqlServerProviders (Module: SqlServerProviders) Version: 3.0.2.500 (3.0.2.500)


ExecuteNonQuery Method (command)

ExecuteNonQuery Method (command)
ScrewTurn Wiki ► ScrewTurn.Wiki.Plugins.SqlCommon ► SqlClassBase ► ExecuteNonQuery(DbCommand)
Executes a non-query command, then closes the connection.
Declaration Syntax
C# Visual Basic Visual C++
protected int ExecuteNonQuery(
    DbCommand command
)
Protected Function ExecuteNonQuery ( _
    command As DbCommand _
) As Integer
protected:
int ExecuteNonQuery(
    DbCommand^ command
)
Parameters
command (DbCommand)
The command to execute.
Return Value
The rows affected (-1 if the command failed).
Remarks
The connection is closed after the execution.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Plugins.SqlCommon (Module: ScrewTurn.Wiki.Plugins.SqlCommon) Version: 3.0.2.500 (3.0.2.500)

Assembly: SqlServerProviders (Module: SqlServerProviders) Version: 3.0.2.500 (3.0.2.500)


ExecuteNonQuery Method (command, close)

ExecuteNonQuery Method (command, close)
ScrewTurn Wiki ► ScrewTurn.Wiki.Plugins.SqlCommon ► SqlClassBase ► ExecuteNonQuery(DbCommand, Boolean)
Executes a non-query command, then closes the connection if requested.
Declaration Syntax
C# Visual Basic Visual C++
protected int ExecuteNonQuery(
    DbCommand command,
    bool close
)
Protected Function ExecuteNonQuery ( _
    command As DbCommand, _
    close As Boolean _
) As Integer
protected:
int ExecuteNonQuery(
    DbCommand^ command,
    bool close
)
Parameters
command (DbCommand)
The command to execute.
close (Boolean)
A value indicating whether to close the connection after execution.
Return Value
The rows affected (-1 if the command failed).

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Plugins.SqlCommon (Module: ScrewTurn.Wiki.Plugins.SqlCommon) Version: 3.0.2.500 (3.0.2.500)

Assembly: SqlServerProviders (Module: SqlServerProviders) Version: 3.0.2.500 (3.0.2.500)


ExecuteNonQuery Method (command, close, logError)

ExecuteNonQuery Method (command, close, logError)
ScrewTurn Wiki ► ScrewTurn.Wiki.Plugins.SqlCommon ► SqlClassBase ► ExecuteNonQuery(DbCommand, Boolean, Boolean)
Executes a non-query command, then closes the connection if requested.
Declaration Syntax
C# Visual Basic Visual C++
protected int ExecuteNonQuery(
    DbCommand command,
    bool close,
    bool logError
)
Protected Function ExecuteNonQuery ( _
    command As DbCommand, _
    close As Boolean, _
    logError As Boolean _
) As Integer
protected:
int ExecuteNonQuery(
    DbCommand^ command,
    bool close,
    bool logError
)
Parameters
command (DbCommand)
The command to execute.
close (Boolean)
A value indicating whether to close the connection after execution.
logError (Boolean)
A value indicating whether to log any error.
Return Value
The rows affected (-1 if the command failed).

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Plugins.SqlCommon (Module: ScrewTurn.Wiki.Plugins.SqlCommon) Version: 3.0.2.500 (3.0.2.500)

Assembly: SqlServerProviders (Module: SqlServerProviders) Version: 3.0.2.500 (3.0.2.500)


ExecuteReader Method

ExecuteReader Method
ScrewTurn Wiki ► ScrewTurn.Wiki.Plugins.SqlCommon ► SqlClassBase ► ExecuteReader()()()
Members
Icon | Member | Description
 | ExecuteReader(DbCommand, Boolean) | Executes a reader command, leaving the connection open.
 | ExecuteReader(DbCommand) | Executes a reader command, leaving the connection open.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Plugins.SqlCommon (Module: ScrewTurn.Wiki.Plugins.SqlCommon) Version: 3.0.2.500 (3.0.2.500)

Assembly: SqlServerProviders (Module: SqlServerProviders) Version: 3.0.2.500 (3.0.2.500)


ExecuteReader Method (command)

ExecuteReader Method (command)
ScrewTurn Wiki ► ScrewTurn.Wiki.Plugins.SqlCommon ► SqlClassBase ► ExecuteReader(DbCommand)
Executes a reader command, leaving the connection open.
Declaration Syntax
C# Visual Basic Visual C++
protected DbDataReader ExecuteReader(
    DbCommand command
)
Protected Function ExecuteReader ( _
    command As DbCommand _
) As DbDataReader
protected:
DbDataReader^ ExecuteReader(
    DbCommand^ command
)
Parameters
command (DbCommand)
The command to execute.
Return Value
The data reader, or null if the command fails.
Remarks
If the command fails, the connection is closed.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Plugins.SqlCommon (Module: ScrewTurn.Wiki.Plugins.SqlCommon) Version: 3.0.2.500 (3.0.2.500)

Assembly: SqlServerProviders (Module: SqlServerProviders) Version: 3.0.2.500 (3.0.2.500)


ExecuteReader Method (command, closeOnError)

ExecuteReader Method (command, closeOnError)
ScrewTurn Wiki ► ScrewTurn.Wiki.Plugins.SqlCommon ► SqlClassBase ► ExecuteReader(DbCommand, Boolean)
Executes a reader command, leaving the connection open.
Declaration Syntax
C# Visual Basic Visual C++
protected DbDataReader ExecuteReader(
    DbCommand command,
    bool closeOnError
)
Protected Function ExecuteReader ( _
    command As DbCommand, _
    closeOnError As Boolean _
) As DbDataReader
protected:
DbDataReader^ ExecuteReader(
    DbCommand^ command,
    bool closeOnError
)
Parameters
command (DbCommand)
The command to execute.
closeOnError (Boolean)
A value indicating whether to close the connection on error.
Return Value
The data reader, or null if the command fails.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Plugins.SqlCommon (Module: ScrewTurn.Wiki.Plugins.SqlCommon) Version: 3.0.2.500 (3.0.2.500)

Assembly: SqlServerProviders (Module: SqlServerProviders) Version: 3.0.2.500 (3.0.2.500)


ExecuteScalar Method

ExecuteScalar Method
ScrewTurn Wiki ► ScrewTurn.Wiki.Plugins.SqlCommon ► SqlClassBase ► ExecuteScalar()()()
Members
Icon | Member | Description
 | ExecuteScalar<(Of <(T>)>)(DbCommand, T) | Executes a scalar command, then closes the connection.
 | ExecuteScalar<(Of <(T>)>)(DbCommand, T, Boolean) | Executes a scalar command, then closes the connection.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Plugins.SqlCommon (Module: ScrewTurn.Wiki.Plugins.SqlCommon) Version: 3.0.2.500 (3.0.2.500)

Assembly: SqlServerProviders (Module: SqlServerProviders) Version: 3.0.2.500 (3.0.2.500)


ExecuteScalar Method (command, defaultValue)

ExecuteScalar<(Of <(<'T>)>)> Method (command, defaultValue)
ScrewTurn Wiki ► ScrewTurn.Wiki.Plugins.SqlCommon ► SqlClassBase ► ExecuteScalar<(Of <(T>)>)(DbCommand, T)
Executes a scalar command, then closes the connection.
Declaration Syntax
C# Visual Basic Visual C++
protected T ExecuteScalar<T>(
    DbCommand command,
    T defaultValue
)

Protected Function ExecuteScalar(Of T) ( _
    command As DbCommand, _
    defaultValue As T _
) As T
protected:
generic<typename T>
T ExecuteScalar(
    DbCommand^ command,
    T defaultValue
)
Generic Template Parameters
T
The return type.
Parameters
command (DbCommand)
The command to execute.
defaultValue (T)
The default value of the return value, to use when the command fails.
Return Value
The result.
Remarks
The connection is closed after the execution.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Plugins.SqlCommon (Module: ScrewTurn.Wiki.Plugins.SqlCommon) Version: 3.0.2.500 (3.0.2.500)

Assembly: SqlServerProviders (Module: SqlServerProviders) Version: 3.0.2.500 (3.0.2.500)


ExecuteScalar Method (command, defaultValue, close)

ExecuteScalar<(Of <(<'T>)>)> Method (command, defaultValue, close)
ScrewTurn Wiki ► ScrewTurn.Wiki.Plugins.SqlCommon ► SqlClassBase ► ExecuteScalar<(Of <(T>)>)(DbCommand, T, Boolean)
Executes a scalar command, then closes the connection.
Declaration Syntax
C# Visual Basic Visual C++
protected T ExecuteScalar<T>(
    DbCommand command,
    T defaultValue,
    bool close
)

Protected Function ExecuteScalar(Of T) ( _
    command As DbCommand, _
    defaultValue As T, _
    close As Boolean _
) As T
protected:
generic<typename T>
T ExecuteScalar(
    DbCommand^ command,
    T defaultValue,
    bool close
)
Generic Template Parameters
T
The return type.
Parameters
command (DbCommand)
The command to execute.
defaultValue (T)
The default value of the return value, to use when the command fails.
close (Boolean)
A value indicating whether to close the connection after execution.
Return Value
The result.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Plugins.SqlCommon (Module: ScrewTurn.Wiki.Plugins.SqlCommon) Version: 3.0.2.500 (3.0.2.500)

Assembly: SqlServerProviders (Module: SqlServerProviders) Version: 3.0.2.500 (3.0.2.500)


GetBinaryColumn Method (reader, column, maxSize)

GetBinaryColumn Method (reader, column, maxSize)
ScrewTurn Wiki ► ScrewTurn.Wiki.Plugins.SqlCommon ► SqlClassBase ► GetBinaryColumn(DbDataReader, String, Int32)
Reads all the contents of a binary column.
Declaration Syntax
C# Visual Basic Visual C++
protected byte[] GetBinaryColumn(
    DbDataReader reader,
    string column,
    int maxSize
)
Protected Function GetBinaryColumn ( _
    reader As DbDataReader, _
    column As String, _
    maxSize As Integer _
) As Byte()
protected:
array<unsigned char>^ GetBinaryColumn(
    DbDataReader^ reader,
    String^ column,
    int maxSize
)
Parameters
reader (DbDataReader)
The DbDataReader.
column (String)
The name of the column.
maxSize (Int32)
The max size, in bytes, to read. If exceeded, null is returned.
Return Value
The read bytes, or null.
Remarks
This method buffers the data in memory; avoid reading data bigger than a few megabytes.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Plugins.SqlCommon (Module: ScrewTurn.Wiki.Plugins.SqlCommon) Version: 3.0.2.500 (3.0.2.500)

Assembly: SqlServerProviders (Module: SqlServerProviders) Version: 3.0.2.500 (3.0.2.500)


GetNullableColumn Method (reader, column, defaultValue)

GetNullableColumn<(Of <(<'T>)>)> Method (reader, column, defaultValue)
ScrewTurn Wiki ► ScrewTurn.Wiki.Plugins.SqlCommon ► SqlClassBase ► GetNullableColumn<(Of <(T>)>)(DbDataReader, String, T)
Gets the value of a nullable column.
Declaration Syntax
C# Visual Basic Visual C++
protected T GetNullableColumn<T>(
    DbDataReader reader,
    string column,
    T defaultValue
)

Protected Function GetNullableColumn(Of T) ( _
    reader As DbDataReader, _
    column As String, _
    defaultValue As T _
) As T
protected:
generic<typename T>
T GetNullableColumn(
    DbDataReader^ reader,
    String^ column,
    T defaultValue
)
Generic Template Parameters
T
The return type.
Parameters
reader (DbDataReader)
The DbDataReader.
column (String)
The name of the column.
defaultValue (T)
The default value to return when the column contains a null value.
Return Value
The value.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Plugins.SqlCommon (Module: ScrewTurn.Wiki.Plugins.SqlCommon) Version: 3.0.2.500 (3.0.2.500)

Assembly: SqlServerProviders (Module: SqlServerProviders) Version: 3.0.2.500 (3.0.2.500)


IsDBNull Method (reader, column)

IsDBNull Method (reader, column)
ScrewTurn Wiki ► ScrewTurn.Wiki.Plugins.SqlCommon ► SqlClassBase ► IsDBNull(DbDataReader, String)
Gets a value indicating whether a column contains nonexistent or missing value.
Declaration Syntax
C# Visual Basic Visual C++
protected bool IsDBNull(
    DbDataReader reader,
    string column
)
Protected Function IsDBNull ( _
    reader As DbDataReader, _
    column As String _
) As Boolean
protected:
bool IsDBNull(
    DbDataReader^ reader,
    String^ column
)
Parameters
reader (DbDataReader)
The DbDataReader.
column (String)
The name of the column.
Return Value
true if the column contains a nonexistent or missing value, false otherwise.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Plugins.SqlCommon (Module: ScrewTurn.Wiki.Plugins.SqlCommon) Version: 3.0.2.500 (3.0.2.500)

Assembly: SqlServerProviders (Module: SqlServerProviders) Version: 3.0.2.500 (3.0.2.500)


LogException Method (ex)

LogException Method (ex)
ScrewTurn Wiki ► ScrewTurn.Wiki.Plugins.SqlCommon ► SqlClassBase ► LogException(Exception)
Logs an exception.
Declaration Syntax
C# Visual Basic Visual C++
protected abstract void LogException(
    Exception ex
)
Protected MustOverride Sub LogException ( _
    ex As Exception _
)
protected:
virtual void LogException(
    Exception^ ex
) abstract
Parameters
ex (Exception)
The exception.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Plugins.SqlCommon (Module: ScrewTurn.Wiki.Plugins.SqlCommon) Version: 3.0.2.500 (3.0.2.500)

Assembly: SqlServerProviders (Module: SqlServerProviders) Version: 3.0.2.500 (3.0.2.500)


ReadBinaryColumn Method (reader, column, stream)

ReadBinaryColumn Method (reader, column, stream)
ScrewTurn Wiki ► ScrewTurn.Wiki.Plugins.SqlCommon ► SqlClassBase ► ReadBinaryColumn(DbDataReader, String, Stream)
Copies all the contents of a binary column into a Stream.
Declaration Syntax
C# Visual Basic Visual C++
protected int ReadBinaryColumn(
    DbDataReader reader,
    string column,
    Stream stream
)
Protected Function ReadBinaryColumn ( _
    reader As DbDataReader, _
    column As String, _
    stream As Stream _
) As Integer
protected:
int ReadBinaryColumn(
    DbDataReader^ reader,
    String^ column,
    Stream^ stream
)
Parameters
reader (DbDataReader)
The DbDataReader.
column (String)
The name of the column.
stream (Stream)
The destination Stream.
Return Value

[Missing <returns> documentation for "M:ScrewTurn.Wiki.Plugins.SqlCommon.SqlClassBase.ReadBinaryColumn(System.Data.Common.DbDataReader,System.String,System.IO.Stream)"]

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Plugins.SqlCommon (Module: ScrewTurn.Wiki.Plugins.SqlCommon) Version: 3.0.2.500 (3.0.2.500)

Assembly: SqlServerProviders (Module: SqlServerProviders) Version: 3.0.2.500 (3.0.2.500)


RollbackTransaction Method (transaction)

RollbackTransaction Method (transaction)
ScrewTurn Wiki ► ScrewTurn.Wiki.Plugins.SqlCommon ► SqlClassBase ► RollbackTransaction(DbTransaction)
Rolls back a transaction.
Declaration Syntax
C# Visual Basic Visual C++
protected void RollbackTransaction(
    DbTransaction transaction
)
Protected Sub RollbackTransaction ( _
    transaction As DbTransaction _
)
protected:
void RollbackTransaction(
    DbTransaction^ transaction
)
Parameters
transaction (DbTransaction)
The transaction.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Plugins.SqlCommon (Module: ScrewTurn.Wiki.Plugins.SqlCommon) Version: 3.0.2.500 (3.0.2.500)

Assembly: SqlServerProviders (Module: SqlServerProviders) Version: 3.0.2.500 (3.0.2.500)


SqlFilesStorageProviderBase Class

SqlFilesStorageProviderBase Class
ScrewTurn Wiki ► ScrewTurn.Wiki.Plugins.SqlCommon ► SqlFilesStorageProviderBase
Implements a base class for a SQL files storage provider.
Declaration Syntax
C# Visual Basic Visual C++
public abstract class SqlFilesStorageProviderBase : SqlStorageProviderBase,
    IFilesStorageProviderV30, IStorageProviderV30, IProviderV30
Public MustInherit Class SqlFilesStorageProviderBase _
    Inherits SqlStorageProviderBase _
    Implements IFilesStorageProviderV30, IStorageProviderV30, IProviderV30
public ref class SqlFilesStorageProviderBase abstract : public SqlStorageProviderBase,
    IFilesStorageProviderV30, IStorageProviderV30, IProviderV30
Members
All Members | Constructors | Methods | Properties | Fields
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | SqlFilesStorageProviderBase()()() | Initializes a new instance of the SqlFilesStorageProviderBase class
 | BeginTransaction(DbConnection) | Begins a transaction. (Inherited from SqlClassBase.)
 | CloseConnection(DbConnection) | Closes a connection, swallowing all exceptions. (Inherited from SqlClassBase.)
 | CloseReader(DbCommand, DbDataReader) | Closes a reader, a command and the associated connection. (Inherited from SqlClassBase.)
 | CloseReader(DbDataReader) | Closes a reader. (Inherited from SqlClassBase.)
 | CommitTransaction(DbTransaction) | Commits a transaction. (Inherited from SqlClassBase.)
 | ConfigHelpHtml | Gets a brief summary of the configuration string format, in HTML. Returns null if no configuration is needed. (Inherited from SqlStorageProviderBase.)
 | connString | The connection string. (Inherited from SqlStorageProviderBase.)
 | CreateDirectory(String, String) | Creates a new Directory.
 | CreateOrUpdateDatabaseIfNecessary()()() | Creates or updates the database schema if necessary. (Inherited from SqlStorageProviderBase.)
 | DeleteDirectory(String) | Deletes a Directory and all of its content.
 | DeleteFile(String) | Deletes a File.
 | DeletePageAttachment(PageInfo, String) | Deletes a Page Attachment.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | ExecuteNonQuery(DbCommand) | Executes a non-query command, then closes the connection. (Inherited from SqlClassBase.)
 | ExecuteNonQuery(DbCommand, Boolean) | Executes a non-query command, then closes the connection if requested. (Inherited from SqlClassBase.)
 | ExecuteNonQuery(DbCommand, Boolean, Boolean) | Executes a non-query command, then closes the connection if requested. (Inherited from SqlClassBase.)
 | ExecuteReader(DbCommand, Boolean) | Executes a reader command, leaving the connection open. (Inherited from SqlClassBase.)
 | ExecuteReader(DbCommand) | Executes a reader command, leaving the connection open. (Inherited from SqlClassBase.)
 | ExecuteScalar<(Of <(T>)>)(DbCommand, T) | Executes a scalar command, then closes the connection. (Inherited from SqlClassBase.)
 | ExecuteScalar<(Of <(T>)>)(DbCommand, T, Boolean) | Executes a scalar command, then closes the connection. (Inherited from SqlClassBase.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetBinaryColumn(DbDataReader, String, Int32) | Reads all the contents of a binary column. (Inherited from SqlClassBase.)
 | GetCommandBuilder()()() | Gets a new command builder object. (Inherited from SqlStorageProviderBase.)
 | GetFileDetails(String) | Gets the details of a file.
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetNullableColumn<(Of <(T>)>)(DbDataReader, String, T) | Gets the value of a nullable column. (Inherited from SqlClassBase.)
 | GetPageAttachmentDetails(PageInfo, String) | Gets the details of a page attachment.
 | GetPagesWithAttachments()()() | The the names of the pages with attachments.
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | host | The host. (Inherited from SqlStorageProviderBase.)
 | Information | Gets the Information about the Provider. (Inherited from SqlStorageProviderBase.)
 | Init(IHostV30, String) | Initializes the Storage Provider. (Inherited from SqlStorageProviderBase.)
 | IsDBNull(DbDataReader, String) | Gets a value indicating whether a column contains nonexistent or missing value. (Inherited from SqlClassBase.)
 | ListDirectories(String) | Lists the Directories in the specified directory.
 | ListFiles(String) | Lists the Files in the specified Directory.
 | ListPageAttachments(PageInfo) | Returns the names of the Attachments of a Page.
 | LogException(Exception) | Logs an exception. (Inherited from SqlStorageProviderBase.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | NotifyPageRenaming(PageInfo, PageInfo) | Notifies the Provider that a Page has been renamed.
 | ReadBinaryColumn(DbDataReader, String, Stream) | Copies all the contents of a binary column into a Stream. (Inherited from SqlClassBase.)
 | ReadOnly | Gets a value specifying whether the provider is read-only, i.e. it can only provide data and not store it.
 | RenameDirectory(String, String) | Renames or moves a Directory.
 | RenameFile(String, String) | Renames or moves a File.
 | RenamePageAttachment(PageInfo, String, String) | Renames a Page Attachment.
 | RetrieveFile(String, Stream, Boolean) | Retrieves a File.
 | RetrievePageAttachment(PageInfo, String, Stream, Boolean) | Retrieves a Page Attachment.
 | RollbackTransaction(DbTransaction) | Rolls back a transaction. (Inherited from SqlClassBase.)
 | SetFileRetrievalCount(String, Int32) | Sets the number of times a file was retrieved.
 | SetPageAttachmentRetrievalCount(PageInfo, String, Int32) | Sets the number of times a page attachment was retrieved.
 | Shutdown()()() | Method invoked on shutdown. (Inherited from SqlStorageProviderBase.)
 | StoreFile(String, Stream, Boolean) | Stores a file.
 | StorePageAttachment(PageInfo, String, Stream, Boolean) | Stores a Page Attachment.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | TryLoadSettingsStorageProviderConfiguration()()() | Tries to load the configuration of the corresponding settings storage provider. (Inherited from SqlStorageProviderBase.)
 | TryLoadV2Configuration()()() | Tries to load the configuration from a corresponding v2 provider. (Inherited from SqlStorageProviderBase.)
 | ValidateConnectionString(String) | Validates a connection string. (Inherited from SqlStorageProviderBase.)
Inheritance Hierarchy
Object
 | SqlClassBase
 |  | SqlStorageProviderBase
 |  |  | SqlFilesStorageProviderBase
 |  |  |  | SqlServerFilesStorageProvider

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: SqlServerProviders (Module: SqlServerProviders) Version: 3.0.2.500 (3.0.2.500)

Assembly: ScrewTurn.Wiki.Plugins.SqlCommon (Module: ScrewTurn.Wiki.Plugins.SqlCommon) Version: 3.0.2.500 (3.0.2.500)


SqlFilesStorageProviderBase Constructor

SqlFilesStorageProviderBase Constructor
ScrewTurn Wiki ► ScrewTurn.Wiki.Plugins.SqlCommon ► SqlFilesStorageProviderBase ► SqlFilesStorageProviderBase()()()
Initializes a new instance of the SqlFilesStorageProviderBase class
Declaration Syntax
C# Visual Basic Visual C++
protected SqlFilesStorageProviderBase()
Protected Sub New
protected:
SqlFilesStorageProviderBase()

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: SqlServerProviders (Module: SqlServerProviders) Version: 3.0.2.500 (3.0.2.500)

Assembly: ScrewTurn.Wiki.Plugins.SqlCommon (Module: ScrewTurn.Wiki.Plugins.SqlCommon) Version: 3.0.2.500 (3.0.2.500)


CreateDirectory Method (path, name)

CreateDirectory Method (path, name)
ScrewTurn Wiki ► ScrewTurn.Wiki.Plugins.SqlCommon ► SqlFilesStorageProviderBase ► CreateDirectory(String, String)
Creates a new Directory.
Declaration Syntax
C# Visual Basic Visual C++
public bool CreateDirectory(
    string path,
    string name
)
Public Function CreateDirectory ( _
    path As String, _
    name As String _
) As Boolean
public:
virtual bool CreateDirectory(
    String^ path,
    String^ name
) sealed
Parameters
path (String)
The path to create the new Directory in.
name (String)
The name of the new Directory.
Return Value
true if the Directory is created, false otherwise.
Remarks
If path is "/my/directory" and name is "newdir", a new directory named "/my/directory/newdir" is created.
Exceptions
Exception | Condition
ArgumentNullException | If path or name are null.
ArgumentException | If name is empty or if the directory does not exist, or if the new directory already exists.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: SqlServerProviders (Module: SqlServerProviders) Version: 3.0.2.500 (3.0.2.500)

Assembly: ScrewTurn.Wiki.Plugins.SqlCommon (Module: ScrewTurn.Wiki.Plugins.SqlCommon) Version: 3.0.2.500 (3.0.2.500)


DeleteDirectory Method (fullPath)

DeleteDirectory Method (fullPath)
ScrewTurn Wiki ► ScrewTurn.Wiki.Plugins.SqlCommon ► SqlFilesStorageProviderBase ► DeleteDirectory(String)
Deletes a Directory and all of its content.
Declaration Syntax
C# Visual Basic Visual C++
public bool DeleteDirectory(
    string fullPath
)
Public Function DeleteDirectory ( _
    fullPath As String _
) As Boolean
public:
virtual bool DeleteDirectory(
    String^ fullPath
) sealed
Parameters
fullPath (String)
The full path of the Directory.
Return Value
true if the Directory is deleted, false otherwise.
Exceptions
Exception | Condition
ArgumentNullException | If fullPath is null.
ArgumentException | If fullPath is empty or if it equals '/' or it does not exist.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: SqlServerProviders (Module: SqlServerProviders) Version: 3.0.2.500 (3.0.2.500)

Assembly: ScrewTurn.Wiki.Plugins.SqlCommon (Module: ScrewTurn.Wiki.Plugins.SqlCommon) Version: 3.0.2.500 (3.0.2.500)


DeleteFile Method (fullName)

DeleteFile Method (fullName)
ScrewTurn Wiki ► ScrewTurn.Wiki.Plugins.SqlCommon ► SqlFilesStorageProviderBase ► DeleteFile(String)
Deletes a File.
Declaration Syntax
C# Visual Basic Visual C++
public bool DeleteFile(
    string fullName
)
Public Function DeleteFile ( _
    fullName As String _
) As Boolean
public:
virtual bool DeleteFile(
    String^ fullName
) sealed
Parameters
fullName (String)
The full name of the File.
Return Value
true if the File is deleted, false otherwise.
Exceptions
Exception | Condition
ArgumentNullException | If fullName is null.
ArgumentException | If fullName is empty or it does not exist.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: SqlServerProviders (Module: SqlServerProviders) Version: 3.0.2.500 (3.0.2.500)

Assembly: ScrewTurn.Wiki.Plugins.SqlCommon (Module: ScrewTurn.Wiki.Plugins.SqlCommon) Version: 3.0.2.500 (3.0.2.500)


DeletePageAttachment Method (pageInfo, name)

DeletePageAttachment Method (pageInfo, name)
ScrewTurn Wiki ► ScrewTurn.Wiki.Plugins.SqlCommon ► SqlFilesStorageProviderBase ► DeletePageAttachment(PageInfo, String)
Deletes a Page Attachment.
Declaration Syntax
C# Visual Basic Visual C++
public bool DeletePageAttachment(
    PageInfo pageInfo,
    string name
)
Public Function DeletePageAttachment ( _
    pageInfo As PageInfo, _
    name As String _
) As Boolean
public:
virtual bool DeletePageAttachment(
    PageInfo^ pageInfo,
    String^ name
) sealed
Parameters
pageInfo (PageInfo)
The Page Info that owns the Attachment.
name (String)
The name of the Attachment, for example "myfile.jpg".
Return Value
true if the Attachment is deleted, false otherwise.
Exceptions
Exception | Condition
ArgumentNullException | If pageInfo or name are null.
ArgumentException | If name is empty or if the page or attachment do not exist.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: SqlServerProviders (Module: SqlServerProviders) Version: 3.0.2.500 (3.0.2.500)

Assembly: ScrewTurn.Wiki.Plugins.SqlCommon (Module: ScrewTurn.Wiki.Plugins.SqlCommon) Version: 3.0.2.500 (3.0.2.500)


GetFileDetails Method (fullName)

GetFileDetails Method (fullName)
ScrewTurn Wiki ► ScrewTurn.Wiki.Plugins.SqlCommon ► SqlFilesStorageProviderBase ► GetFileDetails(String)
Gets the details of a file.
Declaration Syntax
C# Visual Basic Visual C++
public FileDetails GetFileDetails(
    string fullName
)
Public Function GetFileDetails ( _
    fullName As String _
) As FileDetails
public:
virtual FileDetails^ GetFileDetails(
    String^ fullName
) sealed
Parameters
fullName (String)
The full name of the file.
Return Value
The details, or null if the file does not exist.
Exceptions
Exception | Condition
ArgumentNullException | If fullName is null.
ArgumentException | If fullName is empty.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: SqlServerProviders (Module: SqlServerProviders) Version: 3.0.2.500 (3.0.2.500)

Assembly: ScrewTurn.Wiki.Plugins.SqlCommon (Module: ScrewTurn.Wiki.Plugins.SqlCommon) Version: 3.0.2.500 (3.0.2.500)


GetPageAttachmentDetails Method (pageInfo, name)

GetPageAttachmentDetails Method (pageInfo, name)
ScrewTurn Wiki ► ScrewTurn.Wiki.Plugins.SqlCommon ► SqlFilesStorageProviderBase ► GetPageAttachmentDetails(PageInfo, String)
Gets the details of a page attachment.
Declaration Syntax
C# Visual Basic Visual C++
public FileDetails GetPageAttachmentDetails(
    PageInfo pageInfo,
    string name
)
Public Function GetPageAttachmentDetails ( _
    pageInfo As PageInfo, _
    name As String _
) As FileDetails
public:
virtual FileDetails^ GetPageAttachmentDetails(
    PageInfo^ pageInfo,
    String^ name
) sealed
Parameters
pageInfo (PageInfo)
The page that owns the attachment.
name (String)
The name of the attachment, for example "myfile.jpg".
Return Value
The details of the attachment, or null if the attachment does not exist.
Exceptions
Exception | Condition
ArgumentNullException | If pageInfo or name are null.
ArgumentException | If name is empty.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: SqlServerProviders (Module: SqlServerProviders) Version: 3.0.2.500 (3.0.2.500)

Assembly: ScrewTurn.Wiki.Plugins.SqlCommon (Module: ScrewTurn.Wiki.Plugins.SqlCommon) Version: 3.0.2.500 (3.0.2.500)


GetPagesWithAttachments Method

GetPagesWithAttachments Method
ScrewTurn Wiki ► ScrewTurn.Wiki.Plugins.SqlCommon ► SqlFilesStorageProviderBase ► GetPagesWithAttachments()()()
The the names of the pages with attachments.
Declaration Syntax
C# Visual Basic Visual C++
public string[] GetPagesWithAttachments()
Public Function GetPagesWithAttachments As String()
public:
virtual array<String^>^ GetPagesWithAttachments() sealed
Return Value
The names of the pages with attachments.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: SqlServerProviders (Module: SqlServerProviders) Version: 3.0.2.500 (3.0.2.500)

Assembly: ScrewTurn.Wiki.Plugins.SqlCommon (Module: ScrewTurn.Wiki.Plugins.SqlCommon) Version: 3.0.2.500 (3.0.2.500)


ListDirectories Method (directory)

ListDirectories Method (directory)
ScrewTurn Wiki ► ScrewTurn.Wiki.Plugins.SqlCommon ► SqlFilesStorageProviderBase ► ListDirectories(String)
Lists the Directories in the specified directory.
Declaration Syntax
C# Visual Basic Visual C++
public string[] ListDirectories(
    string directory
)
Public Function ListDirectories ( _
    directory As String _
) As String()
public:
virtual array<String^>^ ListDirectories(
    String^ directory
) sealed
Parameters
directory (String)
The full directory name, for example "/my/directory". Null, empty or "/" for the root directory.
Return Value
The list of Directories in the Directory.
Exceptions
Exception | Condition
ArgumentException | If directory does not exist.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: SqlServerProviders (Module: SqlServerProviders) Version: 3.0.2.500 (3.0.2.500)

Assembly: ScrewTurn.Wiki.Plugins.SqlCommon (Module: ScrewTurn.Wiki.Plugins.SqlCommon) Version: 3.0.2.500 (3.0.2.500)


ListFiles Method (directory)

ListFiles Method (directory)
ScrewTurn Wiki ► ScrewTurn.Wiki.Plugins.SqlCommon ► SqlFilesStorageProviderBase ► ListFiles(String)
Lists the Files in the specified Directory.
Declaration Syntax
C# Visual Basic Visual C++
public string[] ListFiles(
    string directory
)
Public Function ListFiles ( _
    directory As String _
) As String()
public:
virtual array<String^>^ ListFiles(
    String^ directory
) sealed
Parameters
directory (String)
The full directory name, for example "/my/directory". Null, empty or "/" for the root directory.
Return Value
The list of Files in the directory.
Exceptions
Exception | Condition
ArgumentException | If directory does not exist.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: SqlServerProviders (Module: SqlServerProviders) Version: 3.0.2.500 (3.0.2.500)

Assembly: ScrewTurn.Wiki.Plugins.SqlCommon (Module: ScrewTurn.Wiki.Plugins.SqlCommon) Version: 3.0.2.500 (3.0.2.500)


ListPageAttachments Method (pageInfo)

ListPageAttachments Method (pageInfo)
ScrewTurn Wiki ► ScrewTurn.Wiki.Plugins.SqlCommon ► SqlFilesStorageProviderBase ► ListPageAttachments(PageInfo)
Returns the names of the Attachments of a Page.
Declaration Syntax
C# Visual Basic Visual C++
public string[] ListPageAttachments(
    PageInfo pageInfo
)
Public Function ListPageAttachments ( _
    pageInfo As PageInfo _
) As String()
public:
virtual array<String^>^ ListPageAttachments(
    PageInfo^ pageInfo
) sealed
Parameters
pageInfo (PageInfo)
The Page Info object that owns the Attachments.
Return Value
The names, or an empty list.
Exceptions
Exception | Condition
ArgumentNullException | If pageInfo is null.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: SqlServerProviders (Module: SqlServerProviders) Version: 3.0.2.500 (3.0.2.500)

Assembly: ScrewTurn.Wiki.Plugins.SqlCommon (Module: ScrewTurn.Wiki.Plugins.SqlCommon) Version: 3.0.2.500 (3.0.2.500)


NotifyPageRenaming Method (oldPage, newPage)

NotifyPageRenaming Method (oldPage, newPage)
ScrewTurn Wiki ► ScrewTurn.Wiki.Plugins.SqlCommon ► SqlFilesStorageProviderBase ► NotifyPageRenaming(PageInfo, PageInfo)
Notifies the Provider that a Page has been renamed.
Declaration Syntax
C# Visual Basic Visual C++
public void NotifyPageRenaming(
    PageInfo oldPage,
    PageInfo newPage
)
Public Sub NotifyPageRenaming ( _
    oldPage As PageInfo, _
    newPage As PageInfo _
)
public:
virtual void NotifyPageRenaming(
    PageInfo^ oldPage,
    PageInfo^ newPage
) sealed
Parameters
oldPage (PageInfo)
The old Page Info object.
newPage (PageInfo)
The new Page Info object.
Exceptions
Exception | Condition
ArgumentNullException | If oldPage or newPage are null.
ArgumentException | If the new page is already in use.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: SqlServerProviders (Module: SqlServerProviders) Version: 3.0.2.500 (3.0.2.500)

Assembly: ScrewTurn.Wiki.Plugins.SqlCommon (Module: ScrewTurn.Wiki.Plugins.SqlCommon) Version: 3.0.2.500 (3.0.2.500)


ReadOnly Property

ReadOnly Property
ScrewTurn Wiki ► ScrewTurn.Wiki.Plugins.SqlCommon ► SqlFilesStorageProviderBase ► ReadOnly
Gets a value specifying whether the provider is read-only, i.e. it can only provide data and not store it.
Declaration Syntax
C# Visual Basic Visual C++
public bool ReadOnly { get; }
Public ReadOnly Property ReadOnly As Boolean
public:
virtual property bool ReadOnly {
    bool get () sealed;
}

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: SqlServerProviders (Module: SqlServerProviders) Version: 3.0.2.500 (3.0.2.500)

Assembly: ScrewTurn.Wiki.Plugins.SqlCommon (Module: ScrewTurn.Wiki.Plugins.SqlCommon) Version: 3.0.2.500 (3.0.2.500)


RenameDirectory Method (oldFullPath, newFullPath)

RenameDirectory Method (oldFullPath, newFullPath)
ScrewTurn Wiki ► ScrewTurn.Wiki.Plugins.SqlCommon ► SqlFilesStorageProviderBase ► RenameDirectory(String, String)
Renames or moves a Directory.
Declaration Syntax
C# Visual Basic Visual C++
public bool RenameDirectory(
    string oldFullPath,
    string newFullPath
)
Public Function RenameDirectory ( _
    oldFullPath As String, _
    newFullPath As String _
) As Boolean
public:
virtual bool RenameDirectory(
    String^ oldFullPath,
    String^ newFullPath
) sealed
Parameters
oldFullPath (String)
The old full path of the Directory.
newFullPath (String)
The new full path of the Directory.
Return Value
true if the Directory is renamed, false otherwise.
Exceptions
Exception | Condition
ArgumentNullException | If oldFullPath or newFullPath are null.
ArgumentException | If oldFullPath or newFullPath are empty or equal to '/', or if the old directory does not exist or the new directory already exists.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: SqlServerProviders (Module: SqlServerProviders) Version: 3.0.2.500 (3.0.2.500)

Assembly: ScrewTurn.Wiki.Plugins.SqlCommon (Module: ScrewTurn.Wiki.Plugins.SqlCommon) Version: 3.0.2.500 (3.0.2.500)


RenameFile Method (oldFullName, newFullName)

RenameFile Method (oldFullName, newFullName)
ScrewTurn Wiki ► ScrewTurn.Wiki.Plugins.SqlCommon ► SqlFilesStorageProviderBase ► RenameFile(String, String)
Renames or moves a File.
Declaration Syntax
C# Visual Basic Visual C++
public bool RenameFile(
    string oldFullName,
    string newFullName
)
Public Function RenameFile ( _
    oldFullName As String, _
    newFullName As String _
) As Boolean
public:
virtual bool RenameFile(
    String^ oldFullName,
    String^ newFullName
) sealed
Parameters
oldFullName (String)
The old full name of the File.
newFullName (String)
The new full name of the File.
Return Value
true if the File is renamed, false otherwise.
Exceptions
Exception | Condition
ArgumentNullException | If oldFullName or newFullName are null.
ArgumentException | If oldFullName or newFullName are empty, or if the old file does not exist, or if the new file already exist.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: SqlServerProviders (Module: SqlServerProviders) Version: 3.0.2.500 (3.0.2.500)

Assembly: ScrewTurn.Wiki.Plugins.SqlCommon (Module: ScrewTurn.Wiki.Plugins.SqlCommon) Version: 3.0.2.500 (3.0.2.500)


RenamePageAttachment Method (pageInfo, oldName, newName)

RenamePageAttachment Method (pageInfo, oldName, newName)
ScrewTurn Wiki ► ScrewTurn.Wiki.Plugins.SqlCommon ► SqlFilesStorageProviderBase ► RenamePageAttachment(PageInfo, String, String)
Renames a Page Attachment.
Declaration Syntax
C# Visual Basic Visual C++
public bool RenamePageAttachment(
    PageInfo pageInfo,
    string oldName,
    string newName
)
Public Function RenamePageAttachment ( _
    pageInfo As PageInfo, _
    oldName As String, _
    newName As String _
) As Boolean
public:
virtual bool RenamePageAttachment(
    PageInfo^ pageInfo,
    String^ oldName,
    String^ newName
) sealed
Parameters
pageInfo (PageInfo)
The Page Info that owns the Attachment.
oldName (String)
The old name of the Attachment.
newName (String)
The new name of the Attachment.
Return Value
true if the Attachment is renamed, false otherwise.
Exceptions
Exception | Condition
ArgumentNullException | If pageInfo, oldName or newName are null.
ArgumentException | If pageInfo, oldName or newName are empty, or if the page or old attachment do not exist, or the new attachment name already exists.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: SqlServerProviders (Module: SqlServerProviders) Version: 3.0.2.500 (3.0.2.500)

Assembly: ScrewTurn.Wiki.Plugins.SqlCommon (Module: ScrewTurn.Wiki.Plugins.SqlCommon) Version: 3.0.2.500 (3.0.2.500)


RetrieveFile Method (fullName, destinationStream, countHit)

RetrieveFile Method (fullName, destinationStream, countHit)
ScrewTurn Wiki ► ScrewTurn.Wiki.Plugins.SqlCommon ► SqlFilesStorageProviderBase ► RetrieveFile(String, Stream, Boolean)
Retrieves a File.
Declaration Syntax
C# Visual Basic Visual C++
public bool RetrieveFile(
    string fullName,
    Stream destinationStream,
    bool countHit
)
Public Function RetrieveFile ( _
    fullName As String, _
    destinationStream As Stream, _
    countHit As Boolean _
) As Boolean
public:
virtual bool RetrieveFile(
    String^ fullName,
    Stream^ destinationStream,
    bool countHit
) sealed
Parameters
fullName (String)
The full name of the File.
destinationStream (Stream)
A Stream object used as destination of a byte stream, i.e. the method writes to the Stream the file content.
countHit (Boolean)
A value indicating whether or not to count this retrieval in the statistics.
Return Value
true if the file is retrieved, false otherwise.
Exceptions
Exception | Condition
ArgumentNullException | If fullName os destinationStream are null.
ArgumentException | If fullName is empty or destinationStream does not support writing.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: SqlServerProviders (Module: SqlServerProviders) Version: 3.0.2.500 (3.0.2.500)

Assembly: ScrewTurn.Wiki.Plugins.SqlCommon (Module: ScrewTurn.Wiki.Plugins.SqlCommon) Version: 3.0.2.500 (3.0.2.500)


RetrievePageAttachment Method (pageInfo, name, destinationStream, countHit)

RetrievePageAttachment Method (pageInfo, name, destinationStream, countHit)
ScrewTurn Wiki ► ScrewTurn.Wiki.Plugins.SqlCommon ► SqlFilesStorageProviderBase ► RetrievePageAttachment(PageInfo, String, Stream, Boolean)
Retrieves a Page Attachment.
Declaration Syntax
C# Visual Basic Visual C++
public bool RetrievePageAttachment(
    PageInfo pageInfo,
    string name,
    Stream destinationStream,
    bool countHit
)
Public Function RetrievePageAttachment ( _
    pageInfo As PageInfo, _
    name As String, _
    destinationStream As Stream, _
    countHit As Boolean _
) As Boolean
public:
virtual bool RetrievePageAttachment(
    PageInfo^ pageInfo,
    String^ name,
    Stream^ destinationStream,
    bool countHit
) sealed
Parameters
pageInfo (PageInfo)
The Page Info that owns the Attachment.
name (String)
The name of the Attachment, for example "myfile.jpg".
destinationStream (Stream)
A Stream object used as destination of a byte stream, i.e. the method writes to the Stream the file content.
countHit (Boolean)
A value indicating whether or not to count this retrieval in the statistics.
Return Value
true if the Attachment is retrieved, false otherwise.
Exceptions
Exception | Condition
ArgumentNullException | If pageInfo, name or destinationStream are null.
ArgumentException | If name is empty or if destinationStream does not support writing, or if the page does not have attachments or if the attachment does not exist.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: SqlServerProviders (Module: SqlServerProviders) Version: 3.0.2.500 (3.0.2.500)

Assembly: ScrewTurn.Wiki.Plugins.SqlCommon (Module: ScrewTurn.Wiki.Plugins.SqlCommon) Version: 3.0.2.500 (3.0.2.500)


SetFileRetrievalCount Method (fullName, count)

SetFileRetrievalCount Method (fullName, count)
ScrewTurn Wiki ► ScrewTurn.Wiki.Plugins.SqlCommon ► SqlFilesStorageProviderBase ► SetFileRetrievalCount(String, Int32)
Sets the number of times a file was retrieved.
Declaration Syntax
C# Visual Basic Visual C++
public void SetFileRetrievalCount(
    string fullName,
    int count
)
Public Sub SetFileRetrievalCount ( _
    fullName As String, _
    count As Integer _
)
public:
virtual void SetFileRetrievalCount(
    String^ fullName,
    int count
) sealed
Parameters
fullName (String)
The full name of the file.
count (Int32)
The count to set.
Exceptions
Exception | Condition
ArgumentNullException | If fullName is null.
ArgumentException | If fullName is empty.
ArgumentOutOfRangeException | If count is less than zero.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: SqlServerProviders (Module: SqlServerProviders) Version: 3.0.2.500 (3.0.2.500)

Assembly: ScrewTurn.Wiki.Plugins.SqlCommon (Module: ScrewTurn.Wiki.Plugins.SqlCommon) Version: 3.0.2.500 (3.0.2.500)


SetPageAttachmentRetrievalCount Method (pageInfo, name, count)

SetPageAttachmentRetrievalCount Method (pageInfo, name, count)
ScrewTurn Wiki ► ScrewTurn.Wiki.Plugins.SqlCommon ► SqlFilesStorageProviderBase ► SetPageAttachmentRetrievalCount(PageInfo, String, Int32)
Sets the number of times a page attachment was retrieved.
Declaration Syntax
C# Visual Basic Visual C++
public void SetPageAttachmentRetrievalCount(
    PageInfo pageInfo,
    string name,
    int count
)
Public Sub SetPageAttachmentRetrievalCount ( _
    pageInfo As PageInfo, _
    name As String, _
    count As Integer _
)
public:
virtual void SetPageAttachmentRetrievalCount(
    PageInfo^ pageInfo,
    String^ name,
    int count
) sealed
Parameters
pageInfo (PageInfo)
The page.
name (String)
The name of the attachment.
count (Int32)
The count to set.
Exceptions
Exception | Condition
ArgumentNullException | If pageInfo or name are null.
ArgumentException | If name is empty.
ArgumentOutOfRangeException | If count is less than zero.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: SqlServerProviders (Module: SqlServerProviders) Version: 3.0.2.500 (3.0.2.500)

Assembly: ScrewTurn.Wiki.Plugins.SqlCommon (Module: ScrewTurn.Wiki.Plugins.SqlCommon) Version: 3.0.2.500 (3.0.2.500)


StoreFile Method (fullName, sourceStream, overwrite)

StoreFile Method (fullName, sourceStream, overwrite)
ScrewTurn Wiki ► ScrewTurn.Wiki.Plugins.SqlCommon ► SqlFilesStorageProviderBase ► StoreFile(String, Stream, Boolean)
Stores a file.
Declaration Syntax
C# Visual Basic Visual C++
public bool StoreFile(
    string fullName,
    Stream sourceStream,
    bool overwrite
)
Public Function StoreFile ( _
    fullName As String, _
    sourceStream As Stream, _
    overwrite As Boolean _
) As Boolean
public:
virtual bool StoreFile(
    String^ fullName,
    Stream^ sourceStream,
    bool overwrite
) sealed
Parameters
fullName (String)
The full name of the file.
sourceStream (Stream)
A Stream object used as source of a byte stream, i.e. the method reads from the Stream and stores the content properly.
overwrite (Boolean)
true to overwrite an existing file.
Return Value
true if the File is stored, false otherwise.
Remarks
If overwrite is false and File already exists, the method returns false.
Exceptions
Exception | Condition
ArgumentNullException | If fullName os sourceStream are null.
ArgumentException | If fullName is empty or sourceStream does not support reading.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: SqlServerProviders (Module: SqlServerProviders) Version: 3.0.2.500 (3.0.2.500)

Assembly: ScrewTurn.Wiki.Plugins.SqlCommon (Module: ScrewTurn.Wiki.Plugins.SqlCommon) Version: 3.0.2.500 (3.0.2.500)


StorePageAttachment Method (pageInfo, name, sourceStream, overwrite)

StorePageAttachment Method (pageInfo, name, sourceStream, overwrite)
ScrewTurn Wiki ► ScrewTurn.Wiki.Plugins.SqlCommon ► SqlFilesStorageProviderBase ► StorePageAttachment(PageInfo, String, Stream, Boolean)
Stores a Page Attachment.
Declaration Syntax
C# Visual Basic Visual C++
public bool StorePageAttachment(
    PageInfo pageInfo,
    string name,
    Stream sourceStream,
    bool overwrite
)
Public Function StorePageAttachment ( _
    pageInfo As PageInfo, _
    name As String, _
    sourceStream As Stream, _
    overwrite As Boolean _
) As Boolean
public:
virtual bool StorePageAttachment(
    PageInfo^ pageInfo,
    String^ name,
    Stream^ sourceStream,
    bool overwrite
) sealed
Parameters
pageInfo (PageInfo)
The Page Info that owns the Attachment.
name (String)
The name of the Attachment, for example "myfile.jpg".
sourceStream (Stream)
A Stream object used as source of a byte stream, i.e. the method reads from the Stream and stores the content properly.
overwrite (Boolean)
true to overwrite an existing Attachment.
Return Value
true if the Attachment is stored, false otherwise.
Remarks
If overwrite is false and Attachment already exists, the method returns false.
Exceptions
Exception | Condition
ArgumentNullException | If pageInfo, name or sourceStream are null.
ArgumentException | If name is empty or if sourceStream does not support reading.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: SqlServerProviders (Module: SqlServerProviders) Version: 3.0.2.500 (3.0.2.500)

Assembly: ScrewTurn.Wiki.Plugins.SqlCommon (Module: ScrewTurn.Wiki.Plugins.SqlCommon) Version: 3.0.2.500 (3.0.2.500)


SqlIndex Class

SqlIndex Class
ScrewTurn Wiki ► ScrewTurn.Wiki.Plugins.SqlCommon ► SqlIndex
Implements a SQL-based search engine index.
Declaration Syntax
C# Visual Basic Visual C++
public class SqlIndex : IIndex
Public Class SqlIndex _
    Implements IIndex
public ref class SqlIndex : IIndex
Members
All Members | Constructors | Methods | Properties | Fields
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | SqlIndex(IIndexConnector) | Initializes a new instance of the SqlIndex class.
 | Clear(Object) | Completely clears the index (stop words are not affected).
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | RemoveDocument(IDocument, Object) | Removes a document from the index.
 | Search(SearchParameters) | Performs a search in the index.
 | stopWords | The stop words to be used while indexing new content.
 | StopWords | Gets or sets the stop words to be used while indexing new content.
 | StoreDocument(IDocument, array<String>[]()[], String, Object) | Stores a document in the index.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | TotalDocuments | Gets the total count of documents.
 | TotalOccurrences | Gets the total number of occurrences (count of words in each document).
 | TotalWords | Gets the total count of unique words.
Inheritance Hierarchy
Object
SqlIndex

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: SqlServerProviders (Module: SqlServerProviders) Version: 3.0.2.500 (3.0.2.500)

Assembly: ScrewTurn.Wiki.Plugins.SqlCommon (Module: ScrewTurn.Wiki.Plugins.SqlCommon) Version: 3.0.2.500 (3.0.2.500)


SqlIndex Constructor (connector)

SqlIndex Constructor (connector)
ScrewTurn Wiki ► ScrewTurn.Wiki.Plugins.SqlCommon ► SqlIndex ► SqlIndex(IIndexConnector)
Initializes a new instance of the SqlIndex class.
Declaration Syntax
C# Visual Basic Visual C++
public SqlIndex(
    IIndexConnector connector
)
Public Sub New ( _
    connector As IIndexConnector _
)
public:
SqlIndex(
    IIndexConnector^ connector
)
Parameters
connector (IIndexConnector)
The connection object.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: SqlServerProviders (Module: SqlServerProviders) Version: 3.0.2.500 (3.0.2.500)

Assembly: ScrewTurn.Wiki.Plugins.SqlCommon (Module: ScrewTurn.Wiki.Plugins.SqlCommon) Version: 3.0.2.500 (3.0.2.500)


Clear Method (state)

Clear Method (state)
ScrewTurn Wiki ► ScrewTurn.Wiki.Plugins.SqlCommon ► SqlIndex ► Clear(Object)
Completely clears the index (stop words are not affected).
Declaration Syntax
C# Visual Basic Visual C++
public void Clear(
    Object state
)
Public Sub Clear ( _
    state As Object _
)
public:
virtual void Clear(
    Object^ state
) sealed
Parameters
state (Object)
A state object that is passed to the IndexStorer SaveDate/DeleteData function.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: SqlServerProviders (Module: SqlServerProviders) Version: 3.0.2.500 (3.0.2.500)

Assembly: ScrewTurn.Wiki.Plugins.SqlCommon (Module: ScrewTurn.Wiki.Plugins.SqlCommon) Version: 3.0.2.500 (3.0.2.500)


RemoveDocument Method (document, state)

RemoveDocument Method (document, state)
ScrewTurn Wiki ► ScrewTurn.Wiki.Plugins.SqlCommon ► SqlIndex ► RemoveDocument(IDocument, Object)
Removes a document from the index.
Declaration Syntax
C# Visual Basic Visual C++
public void RemoveDocument(
    IDocument document,
    Object state
)
Public Sub RemoveDocument ( _
    document As IDocument, _
    state As Object _
)
public:
virtual void RemoveDocument(
    IDocument^ document,
    Object^ state
) sealed
Parameters
document (IDocument)
The document to remove.
state (Object)
A state object that is passed to the IndexStorer SaveDate/DeleteData function.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: SqlServerProviders (Module: SqlServerProviders) Version: 3.0.2.500 (3.0.2.500)

Assembly: ScrewTurn.Wiki.Plugins.SqlCommon (Module: ScrewTurn.Wiki.Plugins.SqlCommon) Version: 3.0.2.500 (3.0.2.500)


Search Method (parameters)

Search Method (parameters)
ScrewTurn Wiki ► ScrewTurn.Wiki.Plugins.SqlCommon ► SqlIndex ► Search(SearchParameters)
Performs a search in the index.
Declaration Syntax
C# Visual Basic Visual C++
public SearchResultCollection Search(
    SearchParameters parameters
)
Public Function Search ( _
    parameters As SearchParameters _
) As SearchResultCollection
public:
virtual SearchResultCollection^ Search(
    SearchParameters^ parameters
) sealed
Parameters
parameters (SearchParameters)
The search parameters.
Return Value
The results.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: SqlServerProviders (Module: SqlServerProviders) Version: 3.0.2.500 (3.0.2.500)

Assembly: ScrewTurn.Wiki.Plugins.SqlCommon (Module: ScrewTurn.Wiki.Plugins.SqlCommon) Version: 3.0.2.500 (3.0.2.500)


stopWords Field

stopWords Field
ScrewTurn Wiki ► ScrewTurn.Wiki.Plugins.SqlCommon ► SqlIndex ► stopWords
The stop words to be used while indexing new content.
Declaration Syntax
C# Visual Basic Visual C++
protected string[] stopWords
Protected stopWords As String()
protected:
array<String^>^ stopWords

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: SqlServerProviders (Module: SqlServerProviders) Version: 3.0.2.500 (3.0.2.500)

Assembly: ScrewTurn.Wiki.Plugins.SqlCommon (Module: ScrewTurn.Wiki.Plugins.SqlCommon) Version: 3.0.2.500 (3.0.2.500)


StopWords Property

StopWords Property
ScrewTurn Wiki ► ScrewTurn.Wiki.Plugins.SqlCommon ► SqlIndex ► StopWords
Gets or sets the stop words to be used while indexing new content.
Declaration Syntax
C# Visual Basic Visual C++
public string[] StopWords { get; set; }
Public Property StopWords As String()
public:
virtual property array<String^>^ StopWords {
    array<String^>^ get () sealed;
    void set (array<String^>^ value) sealed;
}
Value

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: SqlServerProviders (Module: SqlServerProviders) Version: 3.0.2.500 (3.0.2.500)

Assembly: ScrewTurn.Wiki.Plugins.SqlCommon (Module: ScrewTurn.Wiki.Plugins.SqlCommon) Version: 3.0.2.500 (3.0.2.500)


StoreDocument Method (document, keywords, content, state)

StoreDocument Method (document, keywords, content, state)
ScrewTurn Wiki ► ScrewTurn.Wiki.Plugins.SqlCommon ► SqlIndex ► StoreDocument(IDocument, array<String>[]()[], String, Object)
Stores a document in the index.
Declaration Syntax
C# Visual Basic Visual C++
public int StoreDocument(
    IDocument document,
    string[] keywords,
    string content,
    Object state
)
Public Function StoreDocument ( _
    document As IDocument, _
    keywords As String(), _
    content As String, _
    state As Object _
) As Integer
public:
virtual int StoreDocument(
    IDocument^ document,
    array<String^>^ keywords,
    String^ content,
    Object^ state
) sealed
Parameters
document (IDocument)
The document.
keywords (array< String >[]()[][])
The document keywords, if any, an empty array or null otherwise.
content (String)
The content of the document.
state (Object)
A state object that is passed to the IndexStorer SaveDate/DeleteData function.
Return Value
The number of indexed words (including duplicates).
Remarks
Indexing the content of the document is O(n), where n is the total number of words in the document.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: SqlServerProviders (Module: SqlServerProviders) Version: 3.0.2.500 (3.0.2.500)

Assembly: ScrewTurn.Wiki.Plugins.SqlCommon (Module: ScrewTurn.Wiki.Plugins.SqlCommon) Version: 3.0.2.500 (3.0.2.500)


TotalDocuments Property

TotalDocuments Property
ScrewTurn Wiki ► ScrewTurn.Wiki.Plugins.SqlCommon ► SqlIndex ► TotalDocuments
Gets the total count of documents.
Declaration Syntax
C# Visual Basic Visual C++
public int TotalDocuments { get; }
Public ReadOnly Property TotalDocuments As Integer
public:
virtual property int TotalDocuments {
    int get () sealed;
}
Remarks
Computing the result is O(n*m), where n is the number of words in the index and m is the number of documents.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: SqlServerProviders (Module: SqlServerProviders) Version: 3.0.2.500 (3.0.2.500)

Assembly: ScrewTurn.Wiki.Plugins.SqlCommon (Module: ScrewTurn.Wiki.Plugins.SqlCommon) Version: 3.0.2.500 (3.0.2.500)


TotalOccurrences Property

TotalOccurrences Property
ScrewTurn Wiki ► ScrewTurn.Wiki.Plugins.SqlCommon ► SqlIndex ► TotalOccurrences
Gets the total number of occurrences (count of words in each document).
Declaration Syntax
C# Visual Basic Visual C++
public int TotalOccurrences { get; }
Public ReadOnly Property TotalOccurrences As Integer
public:
virtual property int TotalOccurrences {
    int get () sealed;
}
Remarks
Computing the result is O(n), where n is the number of words in the index.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: SqlServerProviders (Module: SqlServerProviders) Version: 3.0.2.500 (3.0.2.500)

Assembly: ScrewTurn.Wiki.Plugins.SqlCommon (Module: ScrewTurn.Wiki.Plugins.SqlCommon) Version: 3.0.2.500 (3.0.2.500)


TotalWords Property

TotalWords Property
ScrewTurn Wiki ► ScrewTurn.Wiki.Plugins.SqlCommon ► SqlIndex ► TotalWords
Gets the total count of unique words.
Declaration Syntax
C# Visual Basic Visual C++
public int TotalWords { get; }
Public ReadOnly Property TotalWords As Integer
public:
virtual property int TotalWords {
    int get () sealed;
}
Remarks
Computing the result is O(1).

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: SqlServerProviders (Module: SqlServerProviders) Version: 3.0.2.500 (3.0.2.500)

Assembly: ScrewTurn.Wiki.Plugins.SqlCommon (Module: ScrewTurn.Wiki.Plugins.SqlCommon) Version: 3.0.2.500 (3.0.2.500)


SqlPagesStorageProviderBase Class

SqlPagesStorageProviderBase Class
ScrewTurn Wiki ► ScrewTurn.Wiki.Plugins.SqlCommon ► SqlPagesStorageProviderBase
Implements a base class for a SQL pages storage provider.
Declaration Syntax
C# Visual Basic Visual C++
public abstract class SqlPagesStorageProviderBase : SqlStorageProviderBase,
    IPagesStorageProviderV30, IStorageProviderV30, IProviderV30
Public MustInherit Class SqlPagesStorageProviderBase _
    Inherits SqlStorageProviderBase _
    Implements IPagesStorageProviderV30, IStorageProviderV30, IProviderV30
public ref class SqlPagesStorageProviderBase abstract : public SqlStorageProviderBase,
    IPagesStorageProviderV30, IStorageProviderV30, IProviderV30
Members
All Members | Constructors | Methods | Properties | Fields
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | SqlPagesStorageProviderBase()()() | Initializes a new instance of the SqlPagesStorageProviderBase class
 | AddCategory(String, String) | Adds a Category.
 | AddContentTemplate(String, String) | Adds a new content template.
 | AddMessage(PageInfo, String, String, DateTime, String, Int32) | Adds a new Message to a Page.
 | AddNamespace(String) | Adds a new namespace.
 | AddNavigationPath(String, String, array<PageInfo>[]()[]) | Adds a new Navigation Path.
 | AddPage(String, String, DateTime) | Adds a Page.
 | AddSnippet(String, String) | Adds a new snippet.
 | BeginTransaction(DbConnection) | Begins a transaction. (Inherited from SqlClassBase.)
 | BulkStoreMessages(PageInfo, array<Message>[]()[]) | Removes all messages for a page and stores the new messages.
 | CloseConnection(DbConnection) | Closes a connection, swallowing all exceptions. (Inherited from SqlClassBase.)
 | CloseReader(DbCommand, DbDataReader) | Closes a reader, a command and the associated connection. (Inherited from SqlClassBase.)
 | CloseReader(DbDataReader) | Closes a reader. (Inherited from SqlClassBase.)
 | CommitTransaction(DbTransaction) | Commits a transaction. (Inherited from SqlClassBase.)
 | ConfigHelpHtml | Gets a brief summary of the configuration string format, in HTML. Returns null if no configuration is needed. (Inherited from SqlStorageProviderBase.)
 | connString | The connection string. (Inherited from SqlStorageProviderBase.)
 | CreateOrUpdateDatabaseIfNecessary()()() | Creates or updates the database schema if necessary. (Inherited from SqlStorageProviderBase.)
 | DeleteBackups(PageInfo, Int32) | Deletes the Backups of a Page, up to a specified revision.
 | DeleteDraft(PageInfo) | Deletes a draft of a Page.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | ExecuteNonQuery(DbCommand) | Executes a non-query command, then closes the connection. (Inherited from SqlClassBase.)
 | ExecuteNonQuery(DbCommand, Boolean) | Executes a non-query command, then closes the connection if requested. (Inherited from SqlClassBase.)
 | ExecuteNonQuery(DbCommand, Boolean, Boolean) | Executes a non-query command, then closes the connection if requested. (Inherited from SqlClassBase.)
 | ExecuteReader(DbCommand, Boolean) | Executes a reader command, leaving the connection open. (Inherited from SqlClassBase.)
 | ExecuteReader(DbCommand) | Executes a reader command, leaving the connection open. (Inherited from SqlClassBase.)
 | ExecuteScalar<(Of <(T>)>)(DbCommand, T) | Executes a scalar command, then closes the connection. (Inherited from SqlClassBase.)
 | ExecuteScalar<(Of <(T>)>)(DbCommand, T, Boolean) | Executes a scalar command, then closes the connection. (Inherited from SqlClassBase.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetBackupContent(PageInfo, Int32) | Gets the Content of a Backup of a Page.
 | GetBackups(PageInfo) | Gets the Backup/Revision numbers of a Page.
 | GetBinaryColumn(DbDataReader, String, Int32) | Reads all the contents of a binary column. (Inherited from SqlClassBase.)
 | GetCategories(NamespaceInfo) | Gets all the Categories in a namespace.
 | GetCategoriesForPage(PageInfo) | Gets all the categories of a page.
 | GetCategory(String) | Gets a category.
 | GetCommandBuilder()()() | Gets a new command builder object. (Inherited from SqlStorageProviderBase.)
 | GetContent(PageInfo) | Gets the Content of a Page.
 | GetContentTemplates()()() | Gets all the content templates.
 | GetDraft(PageInfo) | Gets the content of a draft of a Page.
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetIndexStats(Int32%, Int32%, Int32%, Int64%) | Gets some statistics about the search engine index.
 | GetMessageCount(PageInfo) | Gets the total number of Messages in a Page Discussion.
 | GetMessages(PageInfo) | Gets the Page Messages.
 | GetNamespace(String) | Gets a namespace.
 | GetNamespaces()()() | Gets all the sub-namespaces.
 | GetNavigationPaths(NamespaceInfo) | Gets all the Navigation Paths in a Namespace.
 | GetNullableColumn<(Of <(T>)>)(DbDataReader, String, T) | Gets the value of a nullable column. (Inherited from SqlClassBase.)
 | GetPage(String) | Gets a page.
 | GetPages(NamespaceInfo) | Gets all the Pages in a namespace.
 | GetSnippets()()() | Gets all the snippets.
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetUncategorizedPages(NamespaceInfo) | Gets all the pages in a namespace that are bound to zero categories.
 | host | The host. (Inherited from SqlStorageProviderBase.)
 | Index | Gets the search index (only used for testing purposes).
 | Information | Gets the Information about the Provider. (Inherited from SqlStorageProviderBase.)
 | Init(IHostV30, String) | Initializes the Storage Provider.
 | IsDBNull(DbDataReader, String) | Gets a value indicating whether a column contains nonexistent or missing value. (Inherited from SqlClassBase.)
 | IsIndexCorrupted | Gets a value indicating whether the search engine index is corrupted and needs to be rebuilt.
 | LogException(Exception) | Logs an exception. (Inherited from SqlStorageProviderBase.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | MergeCategories(CategoryInfo, CategoryInfo) | Merges two Categories.
 | ModifyContentTemplate(String, String) | Modifies an existing content template.
 | ModifyMessage(PageInfo, Int32, String, String, DateTime, String) | Modifies a Message.
 | ModifyNavigationPath(NavigationPath, array<PageInfo>[]()[]) | Modifies an existing navigation path.
 | ModifyPage(PageInfo, String, String, DateTime, String, String, array<String>[]()[], String, SaveMode) | Modifies the Content of a Page.
 | ModifySnippet(String, String) | Modifies an existing snippet.
 | MovePage(PageInfo, NamespaceInfo, Boolean) | Moves a page from its namespace into another.
 | PerformSearch(SearchParameters) | Performs a search in the index.
 | ReadBinaryColumn(DbDataReader, String, Stream) | Copies all the contents of a binary column into a Stream. (Inherited from SqlClassBase.)
 | ReadOnly | Gets a value specifying whether the provider is read-only, i.e. it can only provide data and not store it.
 | RebindPage(PageInfo, array<String>[]()[]) | Binds a Page with one or more Categories.
 | RebuildIndex()()() | Rebuilds the search index.
 | RemoveCategory(CategoryInfo) | Removes a Category.
 | RemoveContentTemplate(String) | Removes a content template.
 | RemoveMessage(PageInfo, Int32, Boolean) | Removes a Message.
 | RemoveNamespace(NamespaceInfo) | Removes a namespace.
 | RemoveNavigationPath(NavigationPath) | Removes a Navigation Path.
 | RemovePage(PageInfo) | Removes a Page.
 | RemoveSnippet(String) | Removes a new Snippet.
 | RenameCategory(CategoryInfo, String) | Renames a Category.
 | RenameNamespace(NamespaceInfo, String) | Renames a namespace.
 | RenamePage(PageInfo, String) | Renames a Page.
 | RollbackPage(PageInfo, Int32) | Performs the rollback of a Page to a specified revision.
 | RollbackTransaction(DbTransaction) | Rolls back a transaction. (Inherited from SqlClassBase.)
 | SetBackupContent(PageContent, Int32) | Forces to overwrite or create a Backup.
 | SetFlags(Boolean) | Sets test flags (to be used only for tests).
 | SetNamespaceDefaultPage(NamespaceInfo, PageInfo) | Sets the default page of a namespace.
 | Shutdown()()() | Method invoked on shutdown. (Inherited from SqlStorageProviderBase.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | TryLoadSettingsStorageProviderConfiguration()()() | Tries to load the configuration of the corresponding settings storage provider. (Inherited from SqlStorageProviderBase.)
 | TryLoadV2Configuration()()() | Tries to load the configuration from a corresponding v2 provider. (Inherited from SqlStorageProviderBase.)
 | ValidateConnectionString(String) | Validates a connection string. (Inherited from SqlStorageProviderBase.)
Inheritance Hierarchy
Object
 | SqlClassBase
 |  | SqlStorageProviderBase
 |  |  | SqlPagesStorageProviderBase
 |  |  |  | SqlServerPagesStorageProvider

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: SqlServerProviders (Module: SqlServerProviders) Version: 3.0.2.500 (3.0.2.500)

Assembly: ScrewTurn.Wiki.Plugins.SqlCommon (Module: ScrewTurn.Wiki.Plugins.SqlCommon) Version: 3.0.2.500 (3.0.2.500)


SqlPagesStorageProviderBase Constructor

SqlPagesStorageProviderBase Constructor
ScrewTurn Wiki ► ScrewTurn.Wiki.Plugins.SqlCommon ► SqlPagesStorageProviderBase ► SqlPagesStorageProviderBase()()()
Initializes a new instance of the SqlPagesStorageProviderBase class
Declaration Syntax
C# Visual Basic Visual C++
protected SqlPagesStorageProviderBase()
Protected Sub New
protected:
SqlPagesStorageProviderBase()

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: SqlServerProviders (Module: SqlServerProviders) Version: 3.0.2.500 (3.0.2.500)

Assembly: ScrewTurn.Wiki.Plugins.SqlCommon (Module: ScrewTurn.Wiki.Plugins.SqlCommon) Version: 3.0.2.500 (3.0.2.500)


AddCategory Method (nspace, name)

AddCategory Method (nspace, name)
ScrewTurn Wiki ► ScrewTurn.Wiki.Plugins.SqlCommon ► SqlPagesStorageProviderBase ► AddCategory(String, String)
Adds a Category.
Declaration Syntax
C# Visual Basic Visual C++
public CategoryInfo AddCategory(
    string nspace,
    string name
)
Public Function AddCategory ( _
    nspace As String, _
    name As String _
) As CategoryInfo
public:
virtual CategoryInfo^ AddCategory(
    String^ nspace,
    String^ name
) sealed
Parameters
nspace (String)
The target namespace (null for the root).
name (String)
The Category name.
Return Value
The correct CategoryInfo object.
Remarks
The method should set category's Pages to an empty array.
Exceptions
Exception | Condition
ArgumentNullException | If name is null.
ArgumentException | If name is empty.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: SqlServerProviders (Module: SqlServerProviders) Version: 3.0.2.500 (3.0.2.500)

Assembly: ScrewTurn.Wiki.Plugins.SqlCommon (Module: ScrewTurn.Wiki.Plugins.SqlCommon) Version: 3.0.2.500 (3.0.2.500)


AddContentTemplate Method (name, content)

AddContentTemplate Method (name, content)
ScrewTurn Wiki ► ScrewTurn.Wiki.Plugins.SqlCommon ► SqlPagesStorageProviderBase ► AddContentTemplate(String, String)
Adds a new content template.
Declaration Syntax
C# Visual Basic Visual C++
public ContentTemplate AddContentTemplate(
    string name,
    string content
)
Public Function AddContentTemplate ( _
    name As String, _
    content As String _
) As ContentTemplate
public:
virtual ContentTemplate^ AddContentTemplate(
    String^ name,
    String^ content
) sealed
Parameters
name (String)
The name of template.
content (String)
The content of the template.
Return Value
The correct ContentTemplate object.
Exceptions
Exception | Condition
ArgumentNullException | If name or content are null.
ArgumentNullException | If name is empty.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: SqlServerProviders (Module: SqlServerProviders) Version: 3.0.2.500 (3.0.2.500)

Assembly: ScrewTurn.Wiki.Plugins.SqlCommon (Module: ScrewTurn.Wiki.Plugins.SqlCommon) Version: 3.0.2.500 (3.0.2.500)


AddMessage Method (page, username, subject, dateTime, body, parent)

AddMessage Method (page, username, subject, dateTime, body, parent)
ScrewTurn Wiki ► ScrewTurn.Wiki.Plugins.SqlCommon ► SqlPagesStorageProviderBase ► AddMessage(PageInfo, String, String, DateTime, String, Int32)
Adds a new Message to a Page.
Declaration Syntax
C# Visual Basic Visual C++
public bool AddMessage(
    PageInfo page,
    string username,
    string subject,
    DateTime dateTime,
    string body,
    int parent
)
Public Function AddMessage ( _
    page As PageInfo, _
    username As String, _
    subject As String, _
    dateTime As DateTime, _
    body As String, _
    parent As Integer _
) As Boolean
public:
virtual bool AddMessage(
    PageInfo^ page,
    String^ username,
    String^ subject,
    DateTime dateTime,
    String^ body,
    int parent
) sealed
Parameters
page (PageInfo)
The Page.
username (String)
The Username.
subject (String)
The Subject.
dateTime (DateTime)
The Date/Time.
body (String)
The Body.
parent (Int32)
The Parent Message ID, or -1.
Return Value
True if the Message is added successfully.
Exceptions
Exception | Condition
ArgumentNullException | If page, username, subject or body are null.
ArgumentException | If username or subject are empty.
ArgumentOutOfRangeException | If parent is less than -1.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: SqlServerProviders (Module: SqlServerProviders) Version: 3.0.2.500 (3.0.2.500)

Assembly: ScrewTurn.Wiki.Plugins.SqlCommon (Module: ScrewTurn.Wiki.Plugins.SqlCommon) Version: 3.0.2.500 (3.0.2.500)


AddNamespace Method (name)

AddNamespace Method (name)
ScrewTurn Wiki ► ScrewTurn.Wiki.Plugins.SqlCommon ► SqlPagesStorageProviderBase ► AddNamespace(String)
Adds a new namespace.
Declaration Syntax
C# Visual Basic Visual C++
public NamespaceInfo AddNamespace(
    string name
)
Public Function AddNamespace ( _
    name As String _
) As NamespaceInfo
public:
virtual NamespaceInfo^ AddNamespace(
    String^ name
) sealed
Parameters
name (String)
The name of the namespace.
Return Value
The correct NamespaceInfo object.
Exceptions
Exception | Condition
ArgumentNullException | If name is null.
ArgumentException | If name is empty.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: SqlServerProviders (Module: SqlServerProviders) Version: 3.0.2.500 (3.0.2.500)

Assembly: ScrewTurn.Wiki.Plugins.SqlCommon (Module: ScrewTurn.Wiki.Plugins.SqlCommon) Version: 3.0.2.500 (3.0.2.500)


AddNavigationPath Method (nspace, name, pages)

AddNavigationPath Method (nspace, name, pages)
ScrewTurn Wiki ► ScrewTurn.Wiki.Plugins.SqlCommon ► SqlPagesStorageProviderBase ► AddNavigationPath(String, String, array<PageInfo>[]()[])
Adds a new Navigation Path.
Declaration Syntax
C# Visual Basic Visual C++
public NavigationPath AddNavigationPath(
    string nspace,
    string name,
    PageInfo[] pages
)
Public Function AddNavigationPath ( _
    nspace As String, _
    name As String, _
    pages As PageInfo() _
) As NavigationPath
public:
virtual NavigationPath^ AddNavigationPath(
    String^ nspace,
    String^ name,
    array<PageInfo^>^ pages
) sealed
Parameters
nspace (String)
The target namespace (null for the root).
name (String)
The Name of the Path.
pages (array< PageInfo >[]()[][])
The Pages array.
Return Value
The correct NavigationPath object.
Exceptions
Exception | Condition
ArgumentNullException | If name or pages are null.
ArgumentException | If name or pages are empty.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: SqlServerProviders (Module: SqlServerProviders) Version: 3.0.2.500 (3.0.2.500)

Assembly: ScrewTurn.Wiki.Plugins.SqlCommon (Module: ScrewTurn.Wiki.Plugins.SqlCommon) Version: 3.0.2.500 (3.0.2.500)


AddPage Method (nspace, name, creationDateTime)

AddPage Method (nspace, name, creationDateTime)
ScrewTurn Wiki ► ScrewTurn.Wiki.Plugins.SqlCommon ► SqlPagesStorageProviderBase ► AddPage(String, String, DateTime)
Adds a Page.
Declaration Syntax
C# Visual Basic Visual C++
public PageInfo AddPage(
    string nspace,
    string name,
    DateTime creationDateTime
)
Public Function AddPage ( _
    nspace As String, _
    name As String, _
    creationDateTime As DateTime _
) As PageInfo
public:
virtual PageInfo^ AddPage(
    String^ nspace,
    String^ name,
    DateTime creationDateTime
) sealed
Parameters
nspace (String)
The target namespace (null for the root).
name (String)
The Page Name.
creationDateTime (DateTime)
The creation Date/Time.
Return Value
The correct PageInfo object or null.
Remarks
This method should not create the content of the Page.
Exceptions
Exception | Condition
ArgumentNullException | If name is null.
ArgumentException | If name is empty.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: SqlServerProviders (Module: SqlServerProviders) Version: 3.0.2.500 (3.0.2.500)

Assembly: ScrewTurn.Wiki.Plugins.SqlCommon (Module: ScrewTurn.Wiki.Plugins.SqlCommon) Version: 3.0.2.500 (3.0.2.500)


AddSnippet Method (name, content)

AddSnippet Method (name, content)
ScrewTurn Wiki ► ScrewTurn.Wiki.Plugins.SqlCommon ► SqlPagesStorageProviderBase ► AddSnippet(String, String)
Adds a new snippet.
Declaration Syntax
C# Visual Basic Visual C++
public Snippet AddSnippet(
    string name,
    string content
)
Public Function AddSnippet ( _
    name As String, _
    content As String _
) As Snippet
public:
virtual Snippet^ AddSnippet(
    String^ name,
    String^ content
) sealed
Parameters
name (String)
The name of the snippet.
content (String)
The content of the snippet.
Return Value
The correct Snippet object.
Exceptions
Exception | Condition
ArgumentNullException | If name or content are null.
ArgumentNullException | If name is empty.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: SqlServerProviders (Module: SqlServerProviders) Version: 3.0.2.500 (3.0.2.500)

Assembly: ScrewTurn.Wiki.Plugins.SqlCommon (Module: ScrewTurn.Wiki.Plugins.SqlCommon) Version: 3.0.2.500 (3.0.2.500)


BulkStoreMessages Method (page, messages)

BulkStoreMessages Method (page, messages)
ScrewTurn Wiki ► ScrewTurn.Wiki.Plugins.SqlCommon ► SqlPagesStorageProviderBase ► BulkStoreMessages(PageInfo, array<Message>[]()[])
Removes all messages for a page and stores the new messages.
Declaration Syntax
C# Visual Basic Visual C++
public bool BulkStoreMessages(
    PageInfo page,
    Message[] messages
)
Public Function BulkStoreMessages ( _
    page As PageInfo, _
    messages As Message() _
) As Boolean
public:
virtual bool BulkStoreMessages(
    PageInfo^ page,
    array<Message^>^ messages
) sealed
Parameters
page (PageInfo)
The page.
messages (array< Message >[]()[][])
The new messages to store.
Return Value
true if the messages are stored, false otherwise.
Exceptions
Exception | Condition
ArgumentNullException | If page or messages are null.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: SqlServerProviders (Module: SqlServerProviders) Version: 3.0.2.500 (3.0.2.500)

Assembly: ScrewTurn.Wiki.Plugins.SqlCommon (Module: ScrewTurn.Wiki.Plugins.SqlCommon) Version: 3.0.2.500 (3.0.2.500)


DeleteBackups Method (page, revision)

DeleteBackups Method (page, revision)
ScrewTurn Wiki ► ScrewTurn.Wiki.Plugins.SqlCommon ► SqlPagesStorageProviderBase ► DeleteBackups(PageInfo, Int32)
Deletes the Backups of a Page, up to a specified revision.
Declaration Syntax
C# Visual Basic Visual C++
public bool DeleteBackups(
    PageInfo page,
    int revision
)
Public Function DeleteBackups ( _
    page As PageInfo, _
    revision As Integer _
) As Boolean
public:
virtual bool DeleteBackups(
    PageInfo^ page,
    int revision
) sealed
Parameters
page (PageInfo)
The Page to delete the backups of.
revision (Int32)
The newest revision to delete (newer revision are kept) o -1 to delete all the Backups.
Return Value
true if the deletion succeeded, false otherwise.
Exceptions
Exception | Condition
ArgumentNullException | If page is null.
ArgumentOutOfRangeException | If revision is less than -1.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: SqlServerProviders (Module: SqlServerProviders) Version: 3.0.2.500 (3.0.2.500)

Assembly: ScrewTurn.Wiki.Plugins.SqlCommon (Module: ScrewTurn.Wiki.Plugins.SqlCommon) Version: 3.0.2.500 (3.0.2.500)


DeleteDraft Method (page)

DeleteDraft Method (page)
ScrewTurn Wiki ► ScrewTurn.Wiki.Plugins.SqlCommon ► SqlPagesStorageProviderBase ► DeleteDraft(PageInfo)
Deletes a draft of a Page.
Declaration Syntax
C# Visual Basic Visual C++
public bool DeleteDraft(
    PageInfo page
)
Public Function DeleteDraft ( _
    page As PageInfo _
) As Boolean
public:
virtual bool DeleteDraft(
    PageInfo^ page
) sealed
Parameters
page (PageInfo)
The page.
Return Value
true if the draft is deleted, false otherwise.
Exceptions
Exception | Condition
ArgumentNullException | If page is null.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: SqlServerProviders (Module: SqlServerProviders) Version: 3.0.2.500 (3.0.2.500)

Assembly: ScrewTurn.Wiki.Plugins.SqlCommon (Module: ScrewTurn.Wiki.Plugins.SqlCommon) Version: 3.0.2.500 (3.0.2.500)


GetBackupContent Method (page, revision)

GetBackupContent Method (page, revision)
ScrewTurn Wiki ► ScrewTurn.Wiki.Plugins.SqlCommon ► SqlPagesStorageProviderBase ► GetBackupContent(PageInfo, Int32)
Gets the Content of a Backup of a Page.
Declaration Syntax
C# Visual Basic Visual C++
public PageContent GetBackupContent(
    PageInfo page,
    int revision
)
Public Function GetBackupContent ( _
    page As PageInfo, _
    revision As Integer _
) As PageContent
public:
virtual PageContent^ GetBackupContent(
    PageInfo^ page,
    int revision
) sealed
Parameters
page (PageInfo)
The Page to get the backup of.
revision (Int32)
The Backup/Revision number.
Return Value
The Page Backup.
Exceptions
Exception | Condition
ArgumentNullException | If page is null.
ArgumentOutOfRangeException | If revision is less than zero.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: SqlServerProviders (Module: SqlServerProviders) Version: 3.0.2.500 (3.0.2.500)

Assembly: ScrewTurn.Wiki.Plugins.SqlCommon (Module: ScrewTurn.Wiki.Plugins.SqlCommon) Version: 3.0.2.500 (3.0.2.500)


GetBackups Method (page)

GetBackups Method (page)
ScrewTurn Wiki ► ScrewTurn.Wiki.Plugins.SqlCommon ► SqlPagesStorageProviderBase ► GetBackups(PageInfo)
Gets the Backup/Revision numbers of a Page.
Declaration Syntax
C# Visual Basic Visual C++
public int[] GetBackups(
    PageInfo page
)
Public Function GetBackups ( _
    page As PageInfo _
) As Integer()
public:
virtual array<int>^ GetBackups(
    PageInfo^ page
) sealed
Parameters
page (PageInfo)
The Page to get the Backups of.
Return Value
The Backup/Revision numbers.
Exceptions
Exception | Condition
ArgumentNullException | If page is null.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: SqlServerProviders (Module: SqlServerProviders) Version: 3.0.2.500 (3.0.2.500)

Assembly: ScrewTurn.Wiki.Plugins.SqlCommon (Module: ScrewTurn.Wiki.Plugins.SqlCommon) Version: 3.0.2.500 (3.0.2.500)


GetCategories Method (nspace)

GetCategories Method (nspace)
ScrewTurn Wiki ► ScrewTurn.Wiki.Plugins.SqlCommon ► SqlPagesStorageProviderBase ► GetCategories(NamespaceInfo)
Gets all the Categories in a namespace.
Declaration Syntax
C# Visual Basic Visual C++
public CategoryInfo[] GetCategories(
    NamespaceInfo nspace
)
Public Function GetCategories ( _
    nspace As NamespaceInfo _
) As CategoryInfo()
public:
virtual array<CategoryInfo^>^ GetCategories(
    NamespaceInfo^ nspace
) sealed
Parameters
nspace (NamespaceInfo)
The namespace.
Return Value
All the Categories in the namespace, sorted by name.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: SqlServerProviders (Module: SqlServerProviders) Version: 3.0.2.500 (3.0.2.500)

Assembly: ScrewTurn.Wiki.Plugins.SqlCommon (Module: ScrewTurn.Wiki.Plugins.SqlCommon) Version: 3.0.2.500 (3.0.2.500)


GetCategoriesForPage Method (page)

GetCategoriesForPage Method (page)
ScrewTurn Wiki ► ScrewTurn.Wiki.Plugins.SqlCommon ► SqlPagesStorageProviderBase ► GetCategoriesForPage(PageInfo)
Gets all the categories of a page.
Declaration Syntax
C# Visual Basic Visual C++
public CategoryInfo[] GetCategoriesForPage(
    PageInfo page
)
Public Function GetCategoriesForPage ( _
    page As PageInfo _
) As CategoryInfo()
public:
virtual array<CategoryInfo^>^ GetCategoriesForPage(
    PageInfo^ page
) sealed
Parameters
page (PageInfo)
The page.
Return Value
The categories, sorted by name.
Exceptions
Exception | Condition
ArgumentNullException | If page is null.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: SqlServerProviders (Module: SqlServerProviders) Version: 3.0.2.500 (3.0.2.500)

Assembly: ScrewTurn.Wiki.Plugins.SqlCommon (Module: ScrewTurn.Wiki.Plugins.SqlCommon) Version: 3.0.2.500 (3.0.2.500)


GetCategory Method (fullName)

GetCategory Method (fullName)
ScrewTurn Wiki ► ScrewTurn.Wiki.Plugins.SqlCommon ► SqlPagesStorageProviderBase ► GetCategory(String)
Gets a category.
Declaration Syntax
C# Visual Basic Visual C++
public CategoryInfo GetCategory(
    string fullName
)
Public Function GetCategory ( _
    fullName As String _
) As CategoryInfo
public:
virtual CategoryInfo^ GetCategory(
    String^ fullName
) sealed
Parameters
fullName (String)
The full name of the category.
Return Value
The CategoryInfo, or null if no category is found.
Exceptions
Exception | Condition
ArgumentNullException | If fullName is null.
ArgumentException | If fullName is empty.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: SqlServerProviders (Module: SqlServerProviders) Version: 3.0.2.500 (3.0.2.500)

Assembly: ScrewTurn.Wiki.Plugins.SqlCommon (Module: ScrewTurn.Wiki.Plugins.SqlCommon) Version: 3.0.2.500 (3.0.2.500)


GetContent Method (page)

GetContent Method (page)
ScrewTurn Wiki ► ScrewTurn.Wiki.Plugins.SqlCommon ► SqlPagesStorageProviderBase ► GetContent(PageInfo)
Gets the Content of a Page.
Declaration Syntax
C# Visual Basic Visual C++
public PageContent GetContent(
    PageInfo page
)
Public Function GetContent ( _
    page As PageInfo _
) As PageContent
public:
virtual PageContent^ GetContent(
    PageInfo^ page
) sealed
Parameters
page (PageInfo)
The Page.
Return Value
The Page Content object, null if the page does not exist or page is null, or an empty instance if the content could not be retrieved ().
See Also
GetEmpty(PageInfo)

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: SqlServerProviders (Module: SqlServerProviders) Version: 3.0.2.500 (3.0.2.500)

Assembly: ScrewTurn.Wiki.Plugins.SqlCommon (Module: ScrewTurn.Wiki.Plugins.SqlCommon) Version: 3.0.2.500 (3.0.2.500)


GetContentTemplates Method

GetContentTemplates Method
ScrewTurn Wiki ► ScrewTurn.Wiki.Plugins.SqlCommon ► SqlPagesStorageProviderBase ► GetContentTemplates()()()
Gets all the content templates.
Declaration Syntax
C# Visual Basic Visual C++
public ContentTemplate[] GetContentTemplates()
Public Function GetContentTemplates As ContentTemplate()
public:
virtual array<ContentTemplate^>^ GetContentTemplates() sealed
Return Value
All the content templates, sorted by name.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: SqlServerProviders (Module: SqlServerProviders) Version: 3.0.2.500 (3.0.2.500)

Assembly: ScrewTurn.Wiki.Plugins.SqlCommon (Module: ScrewTurn.Wiki.Plugins.SqlCommon) Version: 3.0.2.500 (3.0.2.500)


GetDraft Method (page)

GetDraft Method (page)
ScrewTurn Wiki ► ScrewTurn.Wiki.Plugins.SqlCommon ► SqlPagesStorageProviderBase ► GetDraft(PageInfo)
Gets the content of a draft of a Page.
Declaration Syntax
C# Visual Basic Visual C++
public PageContent GetDraft(
    PageInfo page
)
Public Function GetDraft ( _
    page As PageInfo _
) As PageContent
public:
virtual PageContent^ GetDraft(
    PageInfo^ page
) sealed
Parameters
page (PageInfo)
The Page.
Return Value
The draft, or null if no draft exists.
Exceptions
Exception | Condition
ArgumentNullException | If page is null.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: SqlServerProviders (Module: SqlServerProviders) Version: 3.0.2.500 (3.0.2.500)

Assembly: ScrewTurn.Wiki.Plugins.SqlCommon (Module: ScrewTurn.Wiki.Plugins.SqlCommon) Version: 3.0.2.500 (3.0.2.500)


GetIndexStats Method (documentCount, wordCount, occurrenceCount, size)

GetIndexStats Method (documentCount, wordCount, occurrenceCount, size)
ScrewTurn Wiki ► ScrewTurn.Wiki.Plugins.SqlCommon ► SqlPagesStorageProviderBase ► GetIndexStats(Int32%, Int32%, Int32%, Int64%)
Gets some statistics about the search engine index.
Declaration Syntax
C# Visual Basic Visual C++
public void GetIndexStats(
    out int documentCount,
    out int wordCount,
    out int occurrenceCount,
    out long size
)
Public Sub GetIndexStats ( _
    <OutAttribute> ByRef documentCount As Integer, _
    <OutAttribute> ByRef wordCount As Integer, _
    <OutAttribute> ByRef occurrenceCount As Integer, _
    <OutAttribute> ByRef size As Long _
)
public:
virtual void GetIndexStats(
    [OutAttribute] int% documentCount,
    [OutAttribute] int% wordCount,
    [OutAttribute] int% occurrenceCount,
    [OutAttribute] long long% size
) sealed
Parameters
documentCount ( Int32 %)
The total number of documents.
wordCount ( Int32 %)
The total number of unique words.
occurrenceCount ( Int32 %)
The total number of word-document occurrences.
size ( Int64 %)
The approximated size, in bytes, of the search engine index.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: SqlServerProviders (Module: SqlServerProviders) Version: 3.0.2.500 (3.0.2.500)

Assembly: ScrewTurn.Wiki.Plugins.SqlCommon (Module: ScrewTurn.Wiki.Plugins.SqlCommon) Version: 3.0.2.500 (3.0.2.500)


GetMessageCount Method (page)

GetMessageCount Method (page)
ScrewTurn Wiki ► ScrewTurn.Wiki.Plugins.SqlCommon ► SqlPagesStorageProviderBase ► GetMessageCount(PageInfo)
Gets the total number of Messages in a Page Discussion.
Declaration Syntax
C# Visual Basic Visual C++
public int GetMessageCount(
    PageInfo page
)
Public Function GetMessageCount ( _
    page As PageInfo _
) As Integer
public:
virtual int GetMessageCount(
    PageInfo^ page
) sealed
Parameters
page (PageInfo)
The Page.
Return Value
The number of messages.
Exceptions
Exception | Condition
ArgumentNullException | If page is null.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: SqlServerProviders (Module: SqlServerProviders) Version: 3.0.2.500 (3.0.2.500)

Assembly: ScrewTurn.Wiki.Plugins.SqlCommon (Module: ScrewTurn.Wiki.Plugins.SqlCommon) Version: 3.0.2.500 (3.0.2.500)


GetMessages Method (page)

GetMessages Method (page)
ScrewTurn Wiki ► ScrewTurn.Wiki.Plugins.SqlCommon ► SqlPagesStorageProviderBase ► GetMessages(PageInfo)
Gets the Page Messages.
Declaration Syntax
C# Visual Basic Visual C++
public Message[] GetMessages(
    PageInfo page
)
Public Function GetMessages ( _
    page As PageInfo _
) As Message()
public:
virtual array<Message^>^ GetMessages(
    PageInfo^ page
) sealed
Parameters
page (PageInfo)
The Page.
Return Value
The list of the first-level Messages, containing the replies properly nested, sorted by date/time.
Exceptions
Exception | Condition
ArgumentNullException | If page is null.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: SqlServerProviders (Module: SqlServerProviders) Version: 3.0.2.500 (3.0.2.500)

Assembly: ScrewTurn.Wiki.Plugins.SqlCommon (Module: ScrewTurn.Wiki.Plugins.SqlCommon) Version: 3.0.2.500 (3.0.2.500)


GetNamespace Method (name)

GetNamespace Method (name)
ScrewTurn Wiki ► ScrewTurn.Wiki.Plugins.SqlCommon ► SqlPagesStorageProviderBase ► GetNamespace(String)
Gets a namespace.
Declaration Syntax
C# Visual Basic Visual C++
public NamespaceInfo GetNamespace(
    string name
)
Public Function GetNamespace ( _
    name As String _
) As NamespaceInfo
public:
virtual NamespaceInfo^ GetNamespace(
    String^ name
) sealed
Parameters
name (String)
The name of the namespace (cannot be null or empty).
Return Value
The NamespaceInfo, or null if no namespace is found.
Exceptions
Exception | Condition
ArgumentNullException | If name is null.
ArgumentException | If name is empty.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: SqlServerProviders (Module: SqlServerProviders) Version: 3.0.2.500 (3.0.2.500)

Assembly: ScrewTurn.Wiki.Plugins.SqlCommon (Module: ScrewTurn.Wiki.Plugins.SqlCommon) Version: 3.0.2.500 (3.0.2.500)


GetNamespaces Method

GetNamespaces Method
ScrewTurn Wiki ► ScrewTurn.Wiki.Plugins.SqlCommon ► SqlPagesStorageProviderBase ► GetNamespaces()()()
Gets all the sub-namespaces.
Declaration Syntax
C# Visual Basic Visual C++
public NamespaceInfo[] GetNamespaces()
Public Function GetNamespaces As NamespaceInfo()
public:
virtual array<NamespaceInfo^>^ GetNamespaces() sealed
Return Value
The sub-namespaces, sorted by name.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: SqlServerProviders (Module: SqlServerProviders) Version: 3.0.2.500 (3.0.2.500)

Assembly: ScrewTurn.Wiki.Plugins.SqlCommon (Module: ScrewTurn.Wiki.Plugins.SqlCommon) Version: 3.0.2.500 (3.0.2.500)


GetNavigationPaths Method (nspace)

GetNavigationPaths Method (nspace)
ScrewTurn Wiki ► ScrewTurn.Wiki.Plugins.SqlCommon ► SqlPagesStorageProviderBase ► GetNavigationPaths(NamespaceInfo)
Gets all the Navigation Paths in a Namespace.
Declaration Syntax
C# Visual Basic Visual C++
public NavigationPath[] GetNavigationPaths(
    NamespaceInfo nspace
)
Public Function GetNavigationPaths ( _
    nspace As NamespaceInfo _
) As NavigationPath()
public:
virtual array<NavigationPath^>^ GetNavigationPaths(
    NamespaceInfo^ nspace
) sealed
Parameters
nspace (NamespaceInfo)
The Namespace.
Return Value
All the Navigation Paths, sorted by name.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: SqlServerProviders (Module: SqlServerProviders) Version: 3.0.2.500 (3.0.2.500)

Assembly: ScrewTurn.Wiki.Plugins.SqlCommon (Module: ScrewTurn.Wiki.Plugins.SqlCommon) Version: 3.0.2.500 (3.0.2.500)


GetPage Method (fullName)

GetPage Method (fullName)
ScrewTurn Wiki ► ScrewTurn.Wiki.Plugins.SqlCommon ► SqlPagesStorageProviderBase ► GetPage(String)
Gets a page.
Declaration Syntax
C# Visual Basic Visual C++
public PageInfo GetPage(
    string fullName
)
Public Function GetPage ( _
    fullName As String _
) As PageInfo
public:
virtual PageInfo^ GetPage(
    String^ fullName
) sealed
Parameters
fullName (String)
The full name of the page.
Return Value
The PageInfo, or null if no page is found.
Exceptions
Exception | Condition
ArgumentNullException | If fullName is null.
ArgumentException | If fullName is empty.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: SqlServerProviders (Module: SqlServerProviders) Version: 3.0.2.500 (3.0.2.500)

Assembly: ScrewTurn.Wiki.Plugins.SqlCommon (Module: ScrewTurn.Wiki.Plugins.SqlCommon) Version: 3.0.2.500 (3.0.2.500)


GetPages Method (nspace)

GetPages Method (nspace)
ScrewTurn Wiki ► ScrewTurn.Wiki.Plugins.SqlCommon ► SqlPagesStorageProviderBase ► GetPages(NamespaceInfo)
Gets all the Pages in a namespace.
Declaration Syntax
C# Visual Basic Visual C++
public PageInfo[] GetPages(
    NamespaceInfo nspace
)
Public Function GetPages ( _
    nspace As NamespaceInfo _
) As PageInfo()
public:
virtual array<PageInfo^>^ GetPages(
    NamespaceInfo^ nspace
) sealed
Parameters
nspace (NamespaceInfo)
The namespace (null for the root).
Return Value
All the Pages in the namespace. The array is not sorted.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: SqlServerProviders (Module: SqlServerProviders) Version: 3.0.2.500 (3.0.2.500)

Assembly: ScrewTurn.Wiki.Plugins.SqlCommon (Module: ScrewTurn.Wiki.Plugins.SqlCommon) Version: 3.0.2.500 (3.0.2.500)


GetSnippets Method

GetSnippets Method
ScrewTurn Wiki ► ScrewTurn.Wiki.Plugins.SqlCommon ► SqlPagesStorageProviderBase ► GetSnippets()()()
Gets all the snippets.
Declaration Syntax
C# Visual Basic Visual C++
public Snippet[] GetSnippets()
Public Function GetSnippets As Snippet()
public:
virtual array<Snippet^>^ GetSnippets() sealed
Return Value
All the snippets, sorted by name.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: SqlServerProviders (Module: SqlServerProviders) Version: 3.0.2.500 (3.0.2.500)

Assembly: ScrewTurn.Wiki.Plugins.SqlCommon (Module: ScrewTurn.Wiki.Plugins.SqlCommon) Version: 3.0.2.500 (3.0.2.500)


GetUncategorizedPages Method (nspace)

GetUncategorizedPages Method (nspace)
ScrewTurn Wiki ► ScrewTurn.Wiki.Plugins.SqlCommon ► SqlPagesStorageProviderBase ► GetUncategorizedPages(NamespaceInfo)
Gets all the pages in a namespace that are bound to zero categories.
Declaration Syntax
C# Visual Basic Visual C++
public PageInfo[] GetUncategorizedPages(
    NamespaceInfo nspace
)
Public Function GetUncategorizedPages ( _
    nspace As NamespaceInfo _
) As PageInfo()
public:
virtual array<PageInfo^>^ GetUncategorizedPages(
    NamespaceInfo^ nspace
) sealed
Parameters
nspace (NamespaceInfo)
The namespace (null for the root).
Return Value
The pages, sorted by name.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: SqlServerProviders (Module: SqlServerProviders) Version: 3.0.2.500 (3.0.2.500)

Assembly: ScrewTurn.Wiki.Plugins.SqlCommon (Module: ScrewTurn.Wiki.Plugins.SqlCommon) Version: 3.0.2.500 (3.0.2.500)


Index Property

Index Property
ScrewTurn Wiki ► ScrewTurn.Wiki.Plugins.SqlCommon ► SqlPagesStorageProviderBase ► Index
Gets the search index (only used for testing purposes).
Declaration Syntax
C# Visual Basic Visual C++
public IIndex Index { get; }
Public ReadOnly Property Index As IIndex
public:
property IIndex^ Index {
    IIndex^ get ();
}

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: SqlServerProviders (Module: SqlServerProviders) Version: 3.0.2.500 (3.0.2.500)

Assembly: ScrewTurn.Wiki.Plugins.SqlCommon (Module: ScrewTurn.Wiki.Plugins.SqlCommon) Version: 3.0.2.500 (3.0.2.500)


Init Method (host, config)

Init Method (host, config)
ScrewTurn Wiki ► ScrewTurn.Wiki.Plugins.SqlCommon ► SqlPagesStorageProviderBase ► Init(IHostV30, String)
Initializes the Storage Provider.
Declaration Syntax
C# Visual Basic Visual C++
public void Init(
    IHostV30 host,
    string config
)
Public Sub Init ( _
    host As IHostV30, _
    config As String _
)
public:
virtual void Init(
    IHostV30^ host,
    String^ config
) sealed
Parameters
host (IHostV30)
The Host of the Component.
config (String)
The Configuration data, if any.
Remarks
If the configuration string is not valid, the methoud should throw a InvalidConfigurationException.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: SqlServerProviders (Module: SqlServerProviders) Version: 3.0.2.500 (3.0.2.500)

Assembly: ScrewTurn.Wiki.Plugins.SqlCommon (Module: ScrewTurn.Wiki.Plugins.SqlCommon) Version: 3.0.2.500 (3.0.2.500)


IsIndexCorrupted Property

IsIndexCorrupted Property
ScrewTurn Wiki ► ScrewTurn.Wiki.Plugins.SqlCommon ► SqlPagesStorageProviderBase ► IsIndexCorrupted
Gets a value indicating whether the search engine index is corrupted and needs to be rebuilt.
Declaration Syntax
C# Visual Basic Visual C++
public bool IsIndexCorrupted { get; }
Public ReadOnly Property IsIndexCorrupted As Boolean
public:
virtual property bool IsIndexCorrupted {
    bool get () sealed;
}

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: SqlServerProviders (Module: SqlServerProviders) Version: 3.0.2.500 (3.0.2.500)

Assembly: ScrewTurn.Wiki.Plugins.SqlCommon (Module: ScrewTurn.Wiki.Plugins.SqlCommon) Version: 3.0.2.500 (3.0.2.500)


MergeCategories Method (source, destination)

MergeCategories Method (source, destination)
ScrewTurn Wiki ► ScrewTurn.Wiki.Plugins.SqlCommon ► SqlPagesStorageProviderBase ► MergeCategories(CategoryInfo, CategoryInfo)
Merges two Categories.
Declaration Syntax
C# Visual Basic Visual C++
public CategoryInfo MergeCategories(
    CategoryInfo source,
    CategoryInfo destination
)
Public Function MergeCategories ( _
    source As CategoryInfo, _
    destination As CategoryInfo _
) As CategoryInfo
public:
virtual CategoryInfo^ MergeCategories(
    CategoryInfo^ source,
    CategoryInfo^ destination
) sealed
Parameters
source (CategoryInfo)
The source Category.
destination (CategoryInfo)
The destination Category.
Return Value
The correct CategoryInfo object.
Remarks
The destination Category remains, while the source Category is deleted, and all its Pages re-bound in the destination Category.
Exceptions
Exception | Condition
ArgumentNullException | If source or destination are null.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: SqlServerProviders (Module: SqlServerProviders) Version: 3.0.2.500 (3.0.2.500)

Assembly: ScrewTurn.Wiki.Plugins.SqlCommon (Module: ScrewTurn.Wiki.Plugins.SqlCommon) Version: 3.0.2.500 (3.0.2.500)


ModifyContentTemplate Method (name, content)

ModifyContentTemplate Method (name, content)
ScrewTurn Wiki ► ScrewTurn.Wiki.Plugins.SqlCommon ► SqlPagesStorageProviderBase ► ModifyContentTemplate(String, String)
Modifies an existing content template.
Declaration Syntax
C# Visual Basic Visual C++
public ContentTemplate ModifyContentTemplate(
    string name,
    string content
)
Public Function ModifyContentTemplate ( _
    name As String, _
    content As String _
) As ContentTemplate
public:
virtual ContentTemplate^ ModifyContentTemplate(
    String^ name,
    String^ content
) sealed
Parameters
name (String)
The name of the template to modify.
content (String)
The content of the template.
Return Value
The correct ContentTemplate object.
Exceptions
Exception | Condition
ArgumentNullException | If name or content are null.
ArgumentNullException | If name is empty.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: SqlServerProviders (Module: SqlServerProviders) Version: 3.0.2.500 (3.0.2.500)

Assembly: ScrewTurn.Wiki.Plugins.SqlCommon (Module: ScrewTurn.Wiki.Plugins.SqlCommon) Version: 3.0.2.500 (3.0.2.500)


ModifyMessage Method (page, id, username, subject, dateTime, body)

ModifyMessage Method (page, id, username, subject, dateTime, body)
ScrewTurn Wiki ► ScrewTurn.Wiki.Plugins.SqlCommon ► SqlPagesStorageProviderBase ► ModifyMessage(PageInfo, Int32, String, String, DateTime, String)
Modifies a Message.
Declaration Syntax
C# Visual Basic Visual C++
public bool ModifyMessage(
    PageInfo page,
    int id,
    string username,
    string subject,
    DateTime dateTime,
    string body
)
Public Function ModifyMessage ( _
    page As PageInfo, _
    id As Integer, _
    username As String, _
    subject As String, _
    dateTime As DateTime, _
    body As String _
) As Boolean
public:
virtual bool ModifyMessage(
    PageInfo^ page,
    int id,
    String^ username,
    String^ subject,
    DateTime dateTime,
    String^ body
) sealed
Parameters
page (PageInfo)
The Page.
id (Int32)
The ID of the Message to modify.
username (String)
The Username.
subject (String)
The Subject.
dateTime (DateTime)
The Date/Time.
body (String)
The Body.
Return Value
True if the Message is modified successfully.
Exceptions
Exception | Condition
ArgumentNullException | If page, username, subject or body are null.
ArgumentOutOfRangeException | If id is less than zero.
ArgumentException | If username or subject are empty.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: SqlServerProviders (Module: SqlServerProviders) Version: 3.0.2.500 (3.0.2.500)

Assembly: ScrewTurn.Wiki.Plugins.SqlCommon (Module: ScrewTurn.Wiki.Plugins.SqlCommon) Version: 3.0.2.500 (3.0.2.500)


ModifyNavigationPath Method (path, pages)

ModifyNavigationPath Method (path, pages)
ScrewTurn Wiki ► ScrewTurn.Wiki.Plugins.SqlCommon ► SqlPagesStorageProviderBase ► ModifyNavigationPath(NavigationPath, array<PageInfo>[]()[])
Modifies an existing navigation path.
Declaration Syntax
C# Visual Basic Visual C++
public NavigationPath ModifyNavigationPath(
    NavigationPath path,
    PageInfo[] pages
)
Public Function ModifyNavigationPath ( _
    path As NavigationPath, _
    pages As PageInfo() _
) As NavigationPath
public:
virtual NavigationPath^ ModifyNavigationPath(
    NavigationPath^ path,
    array<PageInfo^>^ pages
) sealed
Parameters
path (NavigationPath)
The navigation path to modify.
pages (array< PageInfo >[]()[][])
The new pages array.
Return Value
The correct NavigationPath object.
Exceptions
Exception | Condition
ArgumentNullException | If path or pages are null.
ArgumentException | If pages is empty.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: SqlServerProviders (Module: SqlServerProviders) Version: 3.0.2.500 (3.0.2.500)

Assembly: ScrewTurn.Wiki.Plugins.SqlCommon (Module: ScrewTurn.Wiki.Plugins.SqlCommon) Version: 3.0.2.500 (3.0.2.500)


ModifyPage Method (page, title, username, dateTime, comment, content, keywords, description, saveMode)

ModifyPage Method (page, title, username, dateTime, comment, content, keywords, description, saveMode)
ScrewTurn Wiki ► ScrewTurn.Wiki.Plugins.SqlCommon ► SqlPagesStorageProviderBase ► ModifyPage(PageInfo, String, String, DateTime, String, String, array<String>[]()[], String, SaveMode)
Modifies the Content of a Page.
Declaration Syntax
C# Visual Basic Visual C++
public bool ModifyPage(
    PageInfo page,
    string title,
    string username,
    DateTime dateTime,
    string comment,
    string content,
    string[] keywords,
    string description,
    SaveMode saveMode
)
Public Function ModifyPage ( _
    page As PageInfo, _
    title As String, _
    username As String, _
    dateTime As DateTime, _
    comment As String, _
    content As String, _
    keywords As String(), _
    description As String, _
    saveMode As SaveMode _
) As Boolean
public:
virtual bool ModifyPage(
    PageInfo^ page,
    String^ title,
    String^ username,
    DateTime dateTime,
    String^ comment,
    String^ content,
    array<String^>^ keywords,
    String^ description,
    SaveMode saveMode
) sealed
Parameters
page (PageInfo)
The Page.
title (String)
The Title of the Page.
username (String)
The Username.
dateTime (DateTime)
The Date/Time.
comment (String)
The Comment of the editor, about this revision.
content (String)
The Page Content.
keywords (array< String >[]()[][])
The keywords, usually used for SEO.
description (String)
The description, usually used for SEO.
saveMode (SaveMode)
The save mode for this modification.
Return Value
true if the Page has been modified successfully, false otherwise.
Remarks
If saveMode equals Draft and a draft already exists, it is overwritten.
Exceptions
Exception | Condition
ArgumentNullException | If page, title, username or content are null.
ArgumentException | If title or username are empty.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: SqlServerProviders (Module: SqlServerProviders) Version: 3.0.2.500 (3.0.2.500)

Assembly: ScrewTurn.Wiki.Plugins.SqlCommon (Module: ScrewTurn.Wiki.Plugins.SqlCommon) Version: 3.0.2.500 (3.0.2.500)


ModifySnippet Method (name, content)

ModifySnippet Method (name, content)
ScrewTurn Wiki ► ScrewTurn.Wiki.Plugins.SqlCommon ► SqlPagesStorageProviderBase ► ModifySnippet(String, String)
Modifies an existing snippet.
Declaration Syntax
C# Visual Basic Visual C++
public Snippet ModifySnippet(
    string name,
    string content
)
Public Function ModifySnippet ( _
    name As String, _
    content As String _
) As Snippet
public:
virtual Snippet^ ModifySnippet(
    String^ name,
    String^ content
) sealed
Parameters
name (String)
The name of the snippet to modify.
content (String)
The content of the snippet.
Return Value
The correct Snippet object.
Exceptions
Exception | Condition
ArgumentNullException | If name or content are null.
ArgumentNullException | If name is empty.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: SqlServerProviders (Module: SqlServerProviders) Version: 3.0.2.500 (3.0.2.500)

Assembly: ScrewTurn.Wiki.Plugins.SqlCommon (Module: ScrewTurn.Wiki.Plugins.SqlCommon) Version: 3.0.2.500 (3.0.2.500)


MovePage Method (page, destination, copyCategories)

MovePage Method (page, destination, copyCategories)
ScrewTurn Wiki ► ScrewTurn.Wiki.Plugins.SqlCommon ► SqlPagesStorageProviderBase ► MovePage(PageInfo, NamespaceInfo, Boolean)
Moves a page from its namespace into another.
Declaration Syntax
C# Visual Basic Visual C++
public PageInfo MovePage(
    PageInfo page,
    NamespaceInfo destination,
    bool copyCategories
)
Public Function MovePage ( _
    page As PageInfo, _
    destination As NamespaceInfo, _
    copyCategories As Boolean _
) As PageInfo
public:
virtual PageInfo^ MovePage(
    PageInfo^ page,
    NamespaceInfo^ destination,
    bool copyCategories
) sealed
Parameters
page (PageInfo)
The page to move.
destination (NamespaceInfo)
The destination namespace (null for the root).
copyCategories (Boolean)
A value indicating whether to copy the page categories in the destination namespace, if not already available.
Return Value
The correct instance of PageInfo.
Exceptions
Exception | Condition
ArgumentNullException | If page is null.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: SqlServerProviders (Module: SqlServerProviders) Version: 3.0.2.500 (3.0.2.500)

Assembly: ScrewTurn.Wiki.Plugins.SqlCommon (Module: ScrewTurn.Wiki.Plugins.SqlCommon) Version: 3.0.2.500 (3.0.2.500)


PerformSearch Method (parameters)

PerformSearch Method (parameters)
ScrewTurn Wiki ► ScrewTurn.Wiki.Plugins.SqlCommon ► SqlPagesStorageProviderBase ► PerformSearch(SearchParameters)
Performs a search in the index.
Declaration Syntax
C# Visual Basic Visual C++
public SearchResultCollection PerformSearch(
    SearchParameters parameters
)
Public Function PerformSearch ( _
    parameters As SearchParameters _
) As SearchResultCollection
public:
virtual SearchResultCollection^ PerformSearch(
    SearchParameters^ parameters
) sealed
Parameters
parameters (SearchParameters)
The search parameters.
Return Value
The results.
Exceptions
Exception | Condition
ArgumentNullException | If parameters is null.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: SqlServerProviders (Module: SqlServerProviders) Version: 3.0.2.500 (3.0.2.500)

Assembly: ScrewTurn.Wiki.Plugins.SqlCommon (Module: ScrewTurn.Wiki.Plugins.SqlCommon) Version: 3.0.2.500 (3.0.2.500)


ReadOnly Property

ReadOnly Property
ScrewTurn Wiki ► ScrewTurn.Wiki.Plugins.SqlCommon ► SqlPagesStorageProviderBase ► ReadOnly
Gets a value specifying whether the provider is read-only, i.e. it can only provide data and not store it.
Declaration Syntax
C# Visual Basic Visual C++
public bool ReadOnly { get; }
Public ReadOnly Property ReadOnly As Boolean
public:
virtual property bool ReadOnly {
    bool get () sealed;
}

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: SqlServerProviders (Module: SqlServerProviders) Version: 3.0.2.500 (3.0.2.500)

Assembly: ScrewTurn.Wiki.Plugins.SqlCommon (Module: ScrewTurn.Wiki.Plugins.SqlCommon) Version: 3.0.2.500 (3.0.2.500)


RebindPage Method (page, categories)

RebindPage Method (page, categories)
ScrewTurn Wiki ► ScrewTurn.Wiki.Plugins.SqlCommon ► SqlPagesStorageProviderBase ► RebindPage(PageInfo, array<String>[]()[])
Binds a Page with one or more Categories.
Declaration Syntax
C# Visual Basic Visual C++
public bool RebindPage(
    PageInfo page,
    string[] categories
)
Public Function RebindPage ( _
    page As PageInfo, _
    categories As String() _
) As Boolean
public:
virtual bool RebindPage(
    PageInfo^ page,
    array<String^>^ categories
) sealed
Parameters
page (PageInfo)
The Page to bind.
categories (array< String >[]()[][])
The Categories to bind the Page with.
Return Value
True if the binding succeeded.
Remarks
After a successful operation, the Page is bound with all and only the categories passed as argument.
Exceptions
Exception | Condition
ArgumentNullException | If page or categories are null.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: SqlServerProviders (Module: SqlServerProviders) Version: 3.0.2.500 (3.0.2.500)

Assembly: ScrewTurn.Wiki.Plugins.SqlCommon (Module: ScrewTurn.Wiki.Plugins.SqlCommon) Version: 3.0.2.500 (3.0.2.500)


RebuildIndex Method

RebuildIndex Method
ScrewTurn Wiki ► ScrewTurn.Wiki.Plugins.SqlCommon ► SqlPagesStorageProviderBase ► RebuildIndex()()()
Rebuilds the search index.
Declaration Syntax
C# Visual Basic Visual C++
public void RebuildIndex()
Public Sub RebuildIndex
public:
virtual void RebuildIndex() sealed

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: SqlServerProviders (Module: SqlServerProviders) Version: 3.0.2.500 (3.0.2.500)

Assembly: ScrewTurn.Wiki.Plugins.SqlCommon (Module: ScrewTurn.Wiki.Plugins.SqlCommon) Version: 3.0.2.500 (3.0.2.500)


RemoveCategory Method (category)

RemoveCategory Method (category)
ScrewTurn Wiki ► ScrewTurn.Wiki.Plugins.SqlCommon ► SqlPagesStorageProviderBase ► RemoveCategory(CategoryInfo)
Removes a Category.
Declaration Syntax
C# Visual Basic Visual C++
public bool RemoveCategory(
    CategoryInfo category
)
Public Function RemoveCategory ( _
    category As CategoryInfo _
) As Boolean
public:
virtual bool RemoveCategory(
    CategoryInfo^ category
) sealed
Parameters
category (CategoryInfo)
The Category to remove.
Return Value
True if the Category has been removed successfully.
Exceptions
Exception | Condition
ArgumentNullException | If category is null.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: SqlServerProviders (Module: SqlServerProviders) Version: 3.0.2.500 (3.0.2.500)

Assembly: ScrewTurn.Wiki.Plugins.SqlCommon (Module: ScrewTurn.Wiki.Plugins.SqlCommon) Version: 3.0.2.500 (3.0.2.500)


RemoveContentTemplate Method (name)

RemoveContentTemplate Method (name)
ScrewTurn Wiki ► ScrewTurn.Wiki.Plugins.SqlCommon ► SqlPagesStorageProviderBase ► RemoveContentTemplate(String)
Removes a content template.
Declaration Syntax
C# Visual Basic Visual C++
public bool RemoveContentTemplate(
    string name
)
Public Function RemoveContentTemplate ( _
    name As String _
) As Boolean
public:
virtual bool RemoveContentTemplate(
    String^ name
) sealed
Parameters
name (String)
The name of the template to remove.
Return Value
true if the template is removed, false otherwise.
Exceptions
Exception | Condition
ArgumentNullException | If name is null.
ArgumentNullException | If name is empty.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: SqlServerProviders (Module: SqlServerProviders) Version: 3.0.2.500 (3.0.2.500)

Assembly: ScrewTurn.Wiki.Plugins.SqlCommon (Module: ScrewTurn.Wiki.Plugins.SqlCommon) Version: 3.0.2.500 (3.0.2.500)


RemoveMessage Method (page, id, removeReplies)

RemoveMessage Method (page, id, removeReplies)
ScrewTurn Wiki ► ScrewTurn.Wiki.Plugins.SqlCommon ► SqlPagesStorageProviderBase ► RemoveMessage(PageInfo, Int32, Boolean)
Removes a Message.
Declaration Syntax
C# Visual Basic Visual C++
public bool RemoveMessage(
    PageInfo page,
    int id,
    bool removeReplies
)
Public Function RemoveMessage ( _
    page As PageInfo, _
    id As Integer, _
    removeReplies As Boolean _
) As Boolean
public:
virtual bool RemoveMessage(
    PageInfo^ page,
    int id,
    bool removeReplies
) sealed
Parameters
page (PageInfo)
The Page.
id (Int32)
The ID of the Message to remove.
removeReplies (Boolean)
A value specifying whether or not to remove the replies.
Return Value
True if the Message is removed successfully.
Exceptions
Exception | Condition
ArgumentNullException | If page is null.
ArgumentOutOfRangeException | If id is less than zero.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: SqlServerProviders (Module: SqlServerProviders) Version: 3.0.2.500 (3.0.2.500)

Assembly: ScrewTurn.Wiki.Plugins.SqlCommon (Module: ScrewTurn.Wiki.Plugins.SqlCommon) Version: 3.0.2.500 (3.0.2.500)


RemoveNamespace Method (nspace)

RemoveNamespace Method (nspace)
ScrewTurn Wiki ► ScrewTurn.Wiki.Plugins.SqlCommon ► SqlPagesStorageProviderBase ► RemoveNamespace(NamespaceInfo)
Removes a namespace.
Declaration Syntax
C# Visual Basic Visual C++
public bool RemoveNamespace(
    NamespaceInfo nspace
)
Public Function RemoveNamespace ( _
    nspace As NamespaceInfo _
) As Boolean
public:
virtual bool RemoveNamespace(
    NamespaceInfo^ nspace
) sealed
Parameters
nspace (NamespaceInfo)
The namespace to remove.
Return Value
true if the namespace is removed, false otherwise.
Exceptions
Exception | Condition
ArgumentNullException | If nspace is null.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: SqlServerProviders (Module: SqlServerProviders) Version: 3.0.2.500 (3.0.2.500)

Assembly: ScrewTurn.Wiki.Plugins.SqlCommon (Module: ScrewTurn.Wiki.Plugins.SqlCommon) Version: 3.0.2.500 (3.0.2.500)


RemoveNavigationPath Method (path)

RemoveNavigationPath Method (path)
ScrewTurn Wiki ► ScrewTurn.Wiki.Plugins.SqlCommon ► SqlPagesStorageProviderBase ► RemoveNavigationPath(NavigationPath)
Removes a Navigation Path.
Declaration Syntax
C# Visual Basic Visual C++
public bool RemoveNavigationPath(
    NavigationPath path
)
Public Function RemoveNavigationPath ( _
    path As NavigationPath _
) As Boolean
public:
virtual bool RemoveNavigationPath(
    NavigationPath^ path
) sealed
Parameters
path (NavigationPath)
The navigation path to remove.
Return Value
true if the path is removed, false otherwise.
Exceptions
Exception | Condition
ArgumentNullException | If path is null.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: SqlServerProviders (Module: SqlServerProviders) Version: 3.0.2.500 (3.0.2.500)

Assembly: ScrewTurn.Wiki.Plugins.SqlCommon (Module: ScrewTurn.Wiki.Plugins.SqlCommon) Version: 3.0.2.500 (3.0.2.500)


RemovePage Method (page)

RemovePage Method (page)
ScrewTurn Wiki ► ScrewTurn.Wiki.Plugins.SqlCommon ► SqlPagesStorageProviderBase ► RemovePage(PageInfo)
Removes a Page.
Declaration Syntax
C# Visual Basic Visual C++
public bool RemovePage(
    PageInfo page
)
Public Function RemovePage ( _
    page As PageInfo _
) As Boolean
public:
virtual bool RemovePage(
    PageInfo^ page
) sealed
Parameters
page (PageInfo)
The Page to remove.
Return Value
True if the Page is removed successfully.
Exceptions
Exception | Condition
ArgumentNullException | If page is null.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: SqlServerProviders (Module: SqlServerProviders) Version: 3.0.2.500 (3.0.2.500)

Assembly: ScrewTurn.Wiki.Plugins.SqlCommon (Module: ScrewTurn.Wiki.Plugins.SqlCommon) Version: 3.0.2.500 (3.0.2.500)


RemoveSnippet Method (name)

RemoveSnippet Method (name)
ScrewTurn Wiki ► ScrewTurn.Wiki.Plugins.SqlCommon ► SqlPagesStorageProviderBase ► RemoveSnippet(String)
Removes a new Snippet.
Declaration Syntax
C# Visual Basic Visual C++
public bool RemoveSnippet(
    string name
)
Public Function RemoveSnippet ( _
    name As String _
) As Boolean
public:
virtual bool RemoveSnippet(
    String^ name
) sealed
Parameters
name (String)
The Name of the Snippet to remove.
Return Value
true if the snippet is removed, false otherwise.
Exceptions
Exception | Condition
ArgumentNullException | If name is null.
ArgumentNullException | If name is empty.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: SqlServerProviders (Module: SqlServerProviders) Version: 3.0.2.500 (3.0.2.500)

Assembly: ScrewTurn.Wiki.Plugins.SqlCommon (Module: ScrewTurn.Wiki.Plugins.SqlCommon) Version: 3.0.2.500 (3.0.2.500)


RenameCategory Method (category, newName)

RenameCategory Method (category, newName)
ScrewTurn Wiki ► ScrewTurn.Wiki.Plugins.SqlCommon ► SqlPagesStorageProviderBase ► RenameCategory(CategoryInfo, String)
Renames a Category.
Declaration Syntax
C# Visual Basic Visual C++
public CategoryInfo RenameCategory(
    CategoryInfo category,
    string newName
)
Public Function RenameCategory ( _
    category As CategoryInfo, _
    newName As String _
) As CategoryInfo
public:
virtual CategoryInfo^ RenameCategory(
    CategoryInfo^ category,
    String^ newName
) sealed
Parameters
category (CategoryInfo)
The Category to rename.
newName (String)
The new Name.
Return Value
The correct CategoryInfo object.
Exceptions
Exception | Condition
ArgumentNullException | If category or newName are null.
ArgumentException | If newName is empty.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: SqlServerProviders (Module: SqlServerProviders) Version: 3.0.2.500 (3.0.2.500)

Assembly: ScrewTurn.Wiki.Plugins.SqlCommon (Module: ScrewTurn.Wiki.Plugins.SqlCommon) Version: 3.0.2.500 (3.0.2.500)


RenameNamespace Method (nspace, newName)

RenameNamespace Method (nspace, newName)
ScrewTurn Wiki ► ScrewTurn.Wiki.Plugins.SqlCommon ► SqlPagesStorageProviderBase ► RenameNamespace(NamespaceInfo, String)
Renames a namespace.
Declaration Syntax
C# Visual Basic Visual C++
public NamespaceInfo RenameNamespace(
    NamespaceInfo nspace,
    string newName
)
Public Function RenameNamespace ( _
    nspace As NamespaceInfo, _
    newName As String _
) As NamespaceInfo
public:
virtual NamespaceInfo^ RenameNamespace(
    NamespaceInfo^ nspace,
    String^ newName
) sealed
Parameters
nspace (NamespaceInfo)
The namespace to rename.
newName (String)
The new name of the namespace.
Return Value
The correct NamespaceInfo object.
Exceptions
Exception | Condition
ArgumentNullException | If nspace or newName are null.
ArgumentException | If newName is empty.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: SqlServerProviders (Module: SqlServerProviders) Version: 3.0.2.500 (3.0.2.500)

Assembly: ScrewTurn.Wiki.Plugins.SqlCommon (Module: ScrewTurn.Wiki.Plugins.SqlCommon) Version: 3.0.2.500 (3.0.2.500)


RenamePage Method (page, newName)

RenamePage Method (page, newName)
ScrewTurn Wiki ► ScrewTurn.Wiki.Plugins.SqlCommon ► SqlPagesStorageProviderBase ► RenamePage(PageInfo, String)
Renames a Page.
Declaration Syntax
C# Visual Basic Visual C++
public PageInfo RenamePage(
    PageInfo page,
    string newName
)
Public Function RenamePage ( _
    page As PageInfo, _
    newName As String _
) As PageInfo
public:
virtual PageInfo^ RenamePage(
    PageInfo^ page,
    String^ newName
) sealed
Parameters
page (PageInfo)
The Page to rename.
newName (String)
The new Name.
Return Value
The correct PageInfo object.
Exceptions
Exception | Condition
ArgumentNullException | If page or newName are null.
ArgumentException | If newName is empty.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: SqlServerProviders (Module: SqlServerProviders) Version: 3.0.2.500 (3.0.2.500)

Assembly: ScrewTurn.Wiki.Plugins.SqlCommon (Module: ScrewTurn.Wiki.Plugins.SqlCommon) Version: 3.0.2.500 (3.0.2.500)


RollbackPage Method (page, revision)

RollbackPage Method (page, revision)
ScrewTurn Wiki ► ScrewTurn.Wiki.Plugins.SqlCommon ► SqlPagesStorageProviderBase ► RollbackPage(PageInfo, Int32)
Performs the rollback of a Page to a specified revision.
Declaration Syntax
C# Visual Basic Visual C++
public bool RollbackPage(
    PageInfo page,
    int revision
)
Public Function RollbackPage ( _
    page As PageInfo, _
    revision As Integer _
) As Boolean
public:
virtual bool RollbackPage(
    PageInfo^ page,
    int revision
) sealed
Parameters
page (PageInfo)
The Page to rollback.
revision (Int32)
The Revision to rollback the Page to.
Return Value
true if the rollback succeeded, false otherwise.
Exceptions
Exception | Condition
ArgumentNullException | If page is null.
ArgumentOutOfRangeException | If revision is less than zero.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: SqlServerProviders (Module: SqlServerProviders) Version: 3.0.2.500 (3.0.2.500)

Assembly: ScrewTurn.Wiki.Plugins.SqlCommon (Module: ScrewTurn.Wiki.Plugins.SqlCommon) Version: 3.0.2.500 (3.0.2.500)


SetBackupContent Method (content, revision)

SetBackupContent Method (content, revision)
ScrewTurn Wiki ► ScrewTurn.Wiki.Plugins.SqlCommon ► SqlPagesStorageProviderBase ► SetBackupContent(PageContent, Int32)
Forces to overwrite or create a Backup.
Declaration Syntax
C# Visual Basic Visual C++
public bool SetBackupContent(
    PageContent content,
    int revision
)
Public Function SetBackupContent ( _
    content As PageContent, _
    revision As Integer _
) As Boolean
public:
virtual bool SetBackupContent(
    PageContent^ content,
    int revision
) sealed
Parameters
content (PageContent)
The Backup content.
revision (Int32)
The revision.
Return Value
True if the Backup has been created successfully.
Exceptions
Exception | Condition
ArgumentNullException | If content is null.
ArgumentOutOfRangeException | If revision is less than zero.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: SqlServerProviders (Module: SqlServerProviders) Version: 3.0.2.500 (3.0.2.500)

Assembly: ScrewTurn.Wiki.Plugins.SqlCommon (Module: ScrewTurn.Wiki.Plugins.SqlCommon) Version: 3.0.2.500 (3.0.2.500)


SetFlags Method (alwaysGenerateDocument)

SetFlags Method (alwaysGenerateDocument)
ScrewTurn Wiki ► ScrewTurn.Wiki.Plugins.SqlCommon ► SqlPagesStorageProviderBase ► SetFlags(Boolean)
Sets test flags (to be used only for tests).
Declaration Syntax
C# Visual Basic Visual C++
public void SetFlags(
    bool alwaysGenerateDocument
)
Public Sub SetFlags ( _
    alwaysGenerateDocument As Boolean _
)
public:
void SetFlags(
    bool alwaysGenerateDocument
)
Parameters
alwaysGenerateDocument (Boolean)
A value indicating whether to always generate a result when resolving a document, even when the page does not exist.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: SqlServerProviders (Module: SqlServerProviders) Version: 3.0.2.500 (3.0.2.500)

Assembly: ScrewTurn.Wiki.Plugins.SqlCommon (Module: ScrewTurn.Wiki.Plugins.SqlCommon) Version: 3.0.2.500 (3.0.2.500)


SetNamespaceDefaultPage Method (nspace, page)

SetNamespaceDefaultPage Method (nspace, page)
ScrewTurn Wiki ► ScrewTurn.Wiki.Plugins.SqlCommon ► SqlPagesStorageProviderBase ► SetNamespaceDefaultPage(NamespaceInfo, PageInfo)
Sets the default page of a namespace.
Declaration Syntax
C# Visual Basic Visual C++
public NamespaceInfo SetNamespaceDefaultPage(
    NamespaceInfo nspace,
    PageInfo page
)
Public Function SetNamespaceDefaultPage ( _
    nspace As NamespaceInfo, _
    page As PageInfo _
) As NamespaceInfo
public:
virtual NamespaceInfo^ SetNamespaceDefaultPage(
    NamespaceInfo^ nspace,
    PageInfo^ page
) sealed
Parameters
nspace (NamespaceInfo)
The namespace of which to set the default page.
page (PageInfo)
The page to use as default page, or null.
Return Value
The correct NamespaceInfo object.
Exceptions
Exception | Condition
ArgumentNullException | If nspace is null.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: SqlServerProviders (Module: SqlServerProviders) Version: 3.0.2.500 (3.0.2.500)

Assembly: ScrewTurn.Wiki.Plugins.SqlCommon (Module: ScrewTurn.Wiki.Plugins.SqlCommon) Version: 3.0.2.500 (3.0.2.500)


SqlSettingsStorageProviderBase Class

SqlSettingsStorageProviderBase Class
ScrewTurn Wiki ► ScrewTurn.Wiki.Plugins.SqlCommon ► SqlSettingsStorageProviderBase
Implements a base class for a SQL settings storage provider.
Declaration Syntax
C# Visual Basic Visual C++
public abstract class SqlSettingsStorageProviderBase : SqlStorageProviderBase,
    ISettingsStorageProviderV30, IProviderV30
Public MustInherit Class SqlSettingsStorageProviderBase _
    Inherits SqlStorageProviderBase _
    Implements ISettingsStorageProviderV30, IProviderV30
public ref class SqlSettingsStorageProviderBase abstract : public SqlStorageProviderBase,
    ISettingsStorageProviderV30, IProviderV30
Members
All Members | Constructors | Methods | Properties | Fields
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | SqlSettingsStorageProviderBase()()() | Initializes a new instance of the SqlSettingsStorageProviderBase class
 | AclManager | Gets the ACL Manager instance.
 | AddRecentChange(String, String, String, DateTime, String, Change, String) | Adds a new change.
 | BeginBulkUpdate()()() | Starts a Bulk update of the Settings so that a bulk of settings can be set before storing them.
 | BeginTransaction(DbConnection) | Begins a transaction. (Inherited from SqlClassBase.)
 | ClearLog()()() | Clear the Log.
 | CloseConnection(DbConnection) | Closes a connection, swallowing all exceptions. (Inherited from SqlClassBase.)
 | CloseReader(DbCommand, DbDataReader) | Closes a reader, a command and the associated connection. (Inherited from SqlClassBase.)
 | CloseReader(DbDataReader) | Closes a reader. (Inherited from SqlClassBase.)
 | CommitTransaction(DbTransaction) | Commits a transaction. (Inherited from SqlClassBase.)
 | ConfigHelpHtml | Gets a brief summary of the configuration string format, in HTML. Returns null if no configuration is needed. (Inherited from SqlStorageProviderBase.)
 | connString | The connection string. (Inherited from SqlStorageProviderBase.)
 | CreateOrUpdateDatabaseIfNecessary()()() | Creates or updates the database schema if necessary. (Inherited from SqlStorageProviderBase.)
 | DefaultFilesStorageProvider | Gets the default files storage provider, when no value is stored in the database.
 | DefaultPagesStorageProvider | Gets the default pages storage provider, when no value is stored in the database.
 | DefaultUsersStorageProvider | Gets the default users storage provider, when no value is stored in the database.
 | DeleteOutgoingLinks(String) | Deletes the outgoing links of a page and all the target links that include the page.
 | DeletePluginAssembly(String) | Removes a plugin's assembly.
 | EndBulkUpdate()()() | Ends a Bulk update of the Settings and stores the settings.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | ExecuteNonQuery(DbCommand) | Executes a non-query command, then closes the connection. (Inherited from SqlClassBase.)
 | ExecuteNonQuery(DbCommand, Boolean) | Executes a non-query command, then closes the connection if requested. (Inherited from SqlClassBase.)
 | ExecuteNonQuery(DbCommand, Boolean, Boolean) | Executes a non-query command, then closes the connection if requested. (Inherited from SqlClassBase.)
 | ExecuteReader(DbCommand, Boolean) | Executes a reader command, leaving the connection open. (Inherited from SqlClassBase.)
 | ExecuteReader(DbCommand) | Executes a reader command, leaving the connection open. (Inherited from SqlClassBase.)
 | ExecuteScalar<(Of <(T>)>)(DbCommand, T) | Executes a scalar command, then closes the connection. (Inherited from SqlClassBase.)
 | ExecuteScalar<(Of <(T>)>)(DbCommand, T, Boolean) | Executes a scalar command, then closes the connection. (Inherited from SqlClassBase.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetAllOutgoingLinks()()() | Gets all the outgoing links stored.
 | GetAllSettings()()() | Gets the all the setting values.
 | GetBinaryColumn(DbDataReader, String, Int32) | Reads all the contents of a binary column. (Inherited from SqlClassBase.)
 | GetCommandBuilder()()() | Gets a new command builder object. (Inherited from SqlStorageProviderBase.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetLogEntries()()() | Gets all the Log Entries, sorted by date/time (oldest to newest).
 | GetMetaDataItem(MetaDataItem, String) | Gets a meta-data item's content.
 | GetNullableColumn<(Of <(T>)>)(DbDataReader, String, T) | Gets the value of a nullable column. (Inherited from SqlClassBase.)
 | GetOutgoingLinks(String) | Gets the outgoing links of a page.
 | GetPluginConfiguration(String) | Gets the configuration of a plugin.
 | GetPluginStatus(String) | Gets the status of a plugin.
 | GetRecentChanges()()() | Gets the recent changes of the Wiki.
 | GetSetting(String) | Retrieves the value of a Setting.
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | host | The host. (Inherited from SqlStorageProviderBase.)
 | Information | Gets the Information about the Provider. (Inherited from SqlStorageProviderBase.)
 | Init(IHostV30, String) | Initializes the Storage Provider.
 | IsDBNull(DbDataReader, String) | Gets a value indicating whether a column contains nonexistent or missing value. (Inherited from SqlClassBase.)
 | IsFirstApplicationStart()()() | Determines whether the application was started for the first time.
 | isFirstStart | Holds a value indicating whether the application was started for the first time.
 | ListPluginAssemblies()()() | Lists the stored plugin assemblies.
 | LogEntry(String, EntryType, String) | Records a message to the System Log.
 | LogException(Exception) | Logs an exception. (Inherited from SqlStorageProviderBase.)
 | LogSize | Gets the current size of the Log, in KB.
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ReadBinaryColumn(DbDataReader, String, Stream) | Copies all the contents of a binary column into a Stream. (Inherited from SqlClassBase.)
 | RetrievePluginAssembly(String) | Retrieves a plugin's assembly.
 | RollbackTransaction(DbTransaction) | Rolls back a transaction. (Inherited from SqlClassBase.)
 | SetMetaDataItem(MetaDataItem, String, String) | Sets a meta-data items' content.
 | SetPluginConfiguration(String, String) | Sets the configuration of a plugin.
 | SetPluginStatus(String, Boolean) | Sets the status of a plugin.
 | SetSetting(String, String) | Stores the value of a Setting.
 | Shutdown()()() | Method invoked on shutdown. (Inherited from SqlStorageProviderBase.)
 | StoreOutgoingLinks(String, array<String>[]()[]) | Stores the outgoing links of a page, overwriting existing data.
 | StorePluginAssembly(String, array<Byte>[]()[]) | Stores a plugin's assembly, overwriting existing ones if present.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | TryLoadSettingsStorageProviderConfiguration()()() | Tries to load the configuration of the corresponding settings storage provider. (Inherited from SqlStorageProviderBase.)
 | TryLoadV2Configuration()()() | Tries to load the configuration from a corresponding v2 provider. (Inherited from SqlStorageProviderBase.)
 | UpdateOutgoingLinksForRename(String, String) | Updates all outgoing links data for a page rename.
 | ValidateConnectionString(String) | Validates a connection string. (Inherited from SqlStorageProviderBase.)
Inheritance Hierarchy
Object
 | SqlClassBase
 |  | SqlStorageProviderBase
 |  |  | SqlSettingsStorageProviderBase

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Plugins.SqlCommon (Module: ScrewTurn.Wiki.Plugins.SqlCommon) Version: 3.0.2.500 (3.0.2.500)

Assembly: SqlServerProviders (Module: SqlServerProviders) Version: 3.0.2.500 (3.0.2.500)


SqlSettingsStorageProviderBase Constructor

SqlSettingsStorageProviderBase Constructor
ScrewTurn Wiki ► ScrewTurn.Wiki.Plugins.SqlCommon ► SqlSettingsStorageProviderBase ► SqlSettingsStorageProviderBase()()()
Initializes a new instance of the SqlSettingsStorageProviderBase class
Declaration Syntax
C# Visual Basic Visual C++
protected SqlSettingsStorageProviderBase()
Protected Sub New
protected:
SqlSettingsStorageProviderBase()

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Plugins.SqlCommon (Module: ScrewTurn.Wiki.Plugins.SqlCommon) Version: 3.0.2.500 (3.0.2.500)

Assembly: SqlServerProviders (Module: SqlServerProviders) Version: 3.0.2.500 (3.0.2.500)


AclManager Property

AclManager Property
ScrewTurn Wiki ► ScrewTurn.Wiki.Plugins.SqlCommon ► SqlSettingsStorageProviderBase ► AclManager
Gets the ACL Manager instance.
Declaration Syntax
C# Visual Basic Visual C++
public IAclManager AclManager { get; }
Public ReadOnly Property AclManager As IAclManager
public:
virtual property IAclManager^ AclManager {
    IAclManager^ get () sealed;
}

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Plugins.SqlCommon (Module: ScrewTurn.Wiki.Plugins.SqlCommon) Version: 3.0.2.500 (3.0.2.500)

Assembly: SqlServerProviders (Module: SqlServerProviders) Version: 3.0.2.500 (3.0.2.500)


AddRecentChange Method (page, title, messageSubject, dateTime, user, change, descr)

AddRecentChange Method (page, title, messageSubject, dateTime, user, change, descr)
ScrewTurn Wiki ► ScrewTurn.Wiki.Plugins.SqlCommon ► SqlSettingsStorageProviderBase ► AddRecentChange(String, String, String, DateTime, String, Change, String)
Adds a new change.
Declaration Syntax
C# Visual Basic Visual C++
public bool AddRecentChange(
    string page,
    string title,
    string messageSubject,
    DateTime dateTime,
    string user,
    Change change,
    string descr
)
Public Function AddRecentChange ( _
    page As String, _
    title As String, _
    messageSubject As String, _
    dateTime As DateTime, _
    user As String, _
    change As Change, _
    descr As String _
) As Boolean
public:
virtual bool AddRecentChange(
    String^ page,
    String^ title,
    String^ messageSubject,
    DateTime dateTime,
    String^ user,
    Change change,
    String^ descr
) sealed
Parameters
page (String)
The page name.
title (String)
The page title.
messageSubject (String)
The message subject (or null).
dateTime (DateTime)
The date/time.
user (String)
The user.
change (Change)
The change.
descr (String)
The description (optional).
Return Value
true if the change is saved, false otherwise.
Exceptions
Exception | Condition
ArgumentNullException | If page, title or user are null.
ArgumentException | If page, title or user are empty.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Plugins.SqlCommon (Module: ScrewTurn.Wiki.Plugins.SqlCommon) Version: 3.0.2.500 (3.0.2.500)

Assembly: SqlServerProviders (Module: SqlServerProviders) Version: 3.0.2.500 (3.0.2.500)


BeginBulkUpdate Method

BeginBulkUpdate Method
ScrewTurn Wiki ► ScrewTurn.Wiki.Plugins.SqlCommon ► SqlSettingsStorageProviderBase ► BeginBulkUpdate()()()
Starts a Bulk update of the Settings so that a bulk of settings can be set before storing them.
Declaration Syntax
C# Visual Basic Visual C++
public void BeginBulkUpdate()
Public Sub BeginBulkUpdate
public:
virtual void BeginBulkUpdate() sealed

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Plugins.SqlCommon (Module: ScrewTurn.Wiki.Plugins.SqlCommon) Version: 3.0.2.500 (3.0.2.500)

Assembly: SqlServerProviders (Module: SqlServerProviders) Version: 3.0.2.500 (3.0.2.500)


ClearLog Method

ClearLog Method
ScrewTurn Wiki ► ScrewTurn.Wiki.Plugins.SqlCommon ► SqlSettingsStorageProviderBase ► ClearLog()()()
Clear the Log.
Declaration Syntax
C# Visual Basic Visual C++
public void ClearLog()
Public Sub ClearLog
public:
virtual void ClearLog() sealed

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Plugins.SqlCommon (Module: ScrewTurn.Wiki.Plugins.SqlCommon) Version: 3.0.2.500 (3.0.2.500)

Assembly: SqlServerProviders (Module: SqlServerProviders) Version: 3.0.2.500 (3.0.2.500)


DefaultFilesStorageProvider Property

DefaultFilesStorageProvider Property
ScrewTurn Wiki ► ScrewTurn.Wiki.Plugins.SqlCommon ► SqlSettingsStorageProviderBase ► DefaultFilesStorageProvider
Gets the default files storage provider, when no value is stored in the database.
Declaration Syntax
C# Visual Basic Visual C++
protected abstract string DefaultFilesStorageProvider { get; }
Protected MustOverride ReadOnly Property DefaultFilesStorageProvider As String
protected:
virtual property String^ DefaultFilesStorageProvider {
    String^ get () abstract;
}

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Plugins.SqlCommon (Module: ScrewTurn.Wiki.Plugins.SqlCommon) Version: 3.0.2.500 (3.0.2.500)

Assembly: SqlServerProviders (Module: SqlServerProviders) Version: 3.0.2.500 (3.0.2.500)


DefaultPagesStorageProvider Property

DefaultPagesStorageProvider Property
ScrewTurn Wiki ► ScrewTurn.Wiki.Plugins.SqlCommon ► SqlSettingsStorageProviderBase ► DefaultPagesStorageProvider
Gets the default pages storage provider, when no value is stored in the database.
Declaration Syntax
C# Visual Basic Visual C++
protected abstract string DefaultPagesStorageProvider { get; }
Protected MustOverride ReadOnly Property DefaultPagesStorageProvider As String
protected:
virtual property String^ DefaultPagesStorageProvider {
    String^ get () abstract;
}

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Plugins.SqlCommon (Module: ScrewTurn.Wiki.Plugins.SqlCommon) Version: 3.0.2.500 (3.0.2.500)

Assembly: SqlServerProviders (Module: SqlServerProviders) Version: 3.0.2.500 (3.0.2.500)


DefaultUsersStorageProvider Property

DefaultUsersStorageProvider Property
ScrewTurn Wiki ► ScrewTurn.Wiki.Plugins.SqlCommon ► SqlSettingsStorageProviderBase ► DefaultUsersStorageProvider
Gets the default users storage provider, when no value is stored in the database.
Declaration Syntax
C# Visual Basic Visual C++
protected abstract string DefaultUsersStorageProvider { get; }
Protected MustOverride ReadOnly Property DefaultUsersStorageProvider As String
protected:
virtual property String^ DefaultUsersStorageProvider {
    String^ get () abstract;
}

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Plugins.SqlCommon (Module: ScrewTurn.Wiki.Plugins.SqlCommon) Version: 3.0.2.500 (3.0.2.500)

Assembly: SqlServerProviders (Module: SqlServerProviders) Version: 3.0.2.500 (3.0.2.500)


DeleteOutgoingLinks Method (page)

DeleteOutgoingLinks Method (page)
ScrewTurn Wiki ► ScrewTurn.Wiki.Plugins.SqlCommon ► SqlSettingsStorageProviderBase ► DeleteOutgoingLinks(String)
Deletes the outgoing links of a page and all the target links that include the page.
Declaration Syntax
C# Visual Basic Visual C++
public bool DeleteOutgoingLinks(
    string page
)
Public Function DeleteOutgoingLinks ( _
    page As String _
) As Boolean
public:
virtual bool DeleteOutgoingLinks(
    String^ page
) sealed
Parameters
page (String)
The full name of the page.
Return Value
true if the links are deleted, false otherwise.
Exceptions
Exception | Condition
ArgumentNullException | If page is null.
ArgumentException | If page is empty.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Plugins.SqlCommon (Module: ScrewTurn.Wiki.Plugins.SqlCommon) Version: 3.0.2.500 (3.0.2.500)

Assembly: SqlServerProviders (Module: SqlServerProviders) Version: 3.0.2.500 (3.0.2.500)


DeletePluginAssembly Method (filename)

DeletePluginAssembly Method (filename)
ScrewTurn Wiki ► ScrewTurn.Wiki.Plugins.SqlCommon ► SqlSettingsStorageProviderBase ► DeletePluginAssembly(String)
Removes a plugin's assembly.
Declaration Syntax
C# Visual Basic Visual C++
public bool DeletePluginAssembly(
    string filename
)
Public Function DeletePluginAssembly ( _
    filename As String _
) As Boolean
public:
virtual bool DeletePluginAssembly(
    String^ filename
) sealed
Parameters
filename (String)
The file name of the assembly to remove, such as "Assembly.dll".
Return Value
true if the assembly is removed, false otherwise.
Exceptions
Exception | Condition
ArgumentNullException | If filename is null.
ArgumentException | If filename is empty.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Plugins.SqlCommon (Module: ScrewTurn.Wiki.Plugins.SqlCommon) Version: 3.0.2.500 (3.0.2.500)

Assembly: SqlServerProviders (Module: SqlServerProviders) Version: 3.0.2.500 (3.0.2.500)


EndBulkUpdate Method

EndBulkUpdate Method
ScrewTurn Wiki ► ScrewTurn.Wiki.Plugins.SqlCommon ► SqlSettingsStorageProviderBase ► EndBulkUpdate()()()
Ends a Bulk update of the Settings and stores the settings.
Declaration Syntax
C# Visual Basic Visual C++
public void EndBulkUpdate()
Public Sub EndBulkUpdate
public:
virtual void EndBulkUpdate() sealed

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Plugins.SqlCommon (Module: ScrewTurn.Wiki.Plugins.SqlCommon) Version: 3.0.2.500 (3.0.2.500)

Assembly: SqlServerProviders (Module: SqlServerProviders) Version: 3.0.2.500 (3.0.2.500)


GetAllOutgoingLinks Method

GetAllOutgoingLinks Method
ScrewTurn Wiki ► ScrewTurn.Wiki.Plugins.SqlCommon ► SqlSettingsStorageProviderBase ► GetAllOutgoingLinks()()()
Gets all the outgoing links stored.
Declaration Syntax
C# Visual Basic Visual C++
public IDictionary<string, string[]> GetAllOutgoingLinks()
Public Function GetAllOutgoingLinks As IDictionary(Of String, String())
public:
virtual IDictionary<String^, array<String^>^>^ GetAllOutgoingLinks() sealed
Return Value
The outgoing links, in a dictionary in the form page->outgoing_links.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Plugins.SqlCommon (Module: ScrewTurn.Wiki.Plugins.SqlCommon) Version: 3.0.2.500 (3.0.2.500)

Assembly: SqlServerProviders (Module: SqlServerProviders) Version: 3.0.2.500 (3.0.2.500)


GetAllSettings Method

GetAllSettings Method
ScrewTurn Wiki ► ScrewTurn.Wiki.Plugins.SqlCommon ► SqlSettingsStorageProviderBase ► GetAllSettings()()()
Gets the all the setting values.
Declaration Syntax
C# Visual Basic Visual C++
public IDictionary<string, string> GetAllSettings()
Public Function GetAllSettings As IDictionary(Of String, String)
public:
virtual IDictionary<String^, String^>^ GetAllSettings() sealed
Return Value
All the settings.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Plugins.SqlCommon (Module: ScrewTurn.Wiki.Plugins.SqlCommon) Version: 3.0.2.500 (3.0.2.500)

Assembly: SqlServerProviders (Module: SqlServerProviders) Version: 3.0.2.500 (3.0.2.500)


GetLogEntries Method

GetLogEntries Method
ScrewTurn Wiki ► ScrewTurn.Wiki.Plugins.SqlCommon ► SqlSettingsStorageProviderBase ► GetLogEntries()()()
Gets all the Log Entries, sorted by date/time (oldest to newest).
Declaration Syntax
C# Visual Basic Visual C++
public LogEntry[] GetLogEntries()
Public Function GetLogEntries As LogEntry()
public:
virtual array<LogEntry^>^ GetLogEntries() sealed
Return Value
The Log Entries.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Plugins.SqlCommon (Module: ScrewTurn.Wiki.Plugins.SqlCommon) Version: 3.0.2.500 (3.0.2.500)

Assembly: SqlServerProviders (Module: SqlServerProviders) Version: 3.0.2.500 (3.0.2.500)


GetMetaDataItem Method (item, tag)

GetMetaDataItem Method (item, tag)
ScrewTurn Wiki ► ScrewTurn.Wiki.Plugins.SqlCommon ► SqlSettingsStorageProviderBase ► GetMetaDataItem(MetaDataItem, String)
Gets a meta-data item's content.
Declaration Syntax
C# Visual Basic Visual C++
public string GetMetaDataItem(
    MetaDataItem item,
    string tag
)
Public Function GetMetaDataItem ( _
    item As MetaDataItem, _
    tag As String _
) As String
public:
virtual String^ GetMetaDataItem(
    MetaDataItem item,
    String^ tag
) sealed
Parameters
item (MetaDataItem)
The item.
tag (String)
The tag that specifies the context (usually the namespace).
Return Value
The content.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Plugins.SqlCommon (Module: ScrewTurn.Wiki.Plugins.SqlCommon) Version: 3.0.2.500 (3.0.2.500)

Assembly: SqlServerProviders (Module: SqlServerProviders) Version: 3.0.2.500 (3.0.2.500)


GetOutgoingLinks Method (page)

GetOutgoingLinks Method (page)
ScrewTurn Wiki ► ScrewTurn.Wiki.Plugins.SqlCommon ► SqlSettingsStorageProviderBase ► GetOutgoingLinks(String)
Gets the outgoing links of a page.
Declaration Syntax
C# Visual Basic Visual C++
public string[] GetOutgoingLinks(
    string page
)
Public Function GetOutgoingLinks ( _
    page As String _
) As String()
public:
virtual array<String^>^ GetOutgoingLinks(
    String^ page
) sealed
Parameters
page (String)
The full name of the page.
Return Value
The outgoing links.
Exceptions
Exception | Condition
ArgumentNullException | If page is null.
ArgumentException | If page is empty.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Plugins.SqlCommon (Module: ScrewTurn.Wiki.Plugins.SqlCommon) Version: 3.0.2.500 (3.0.2.500)

Assembly: SqlServerProviders (Module: SqlServerProviders) Version: 3.0.2.500 (3.0.2.500)


GetPluginConfiguration Method (typeName)

GetPluginConfiguration Method (typeName)
ScrewTurn Wiki ► ScrewTurn.Wiki.Plugins.SqlCommon ► SqlSettingsStorageProviderBase ► GetPluginConfiguration(String)
Gets the configuration of a plugin.
Declaration Syntax
C# Visual Basic Visual C++
public string GetPluginConfiguration(
    string typeName
)
Public Function GetPluginConfiguration ( _
    typeName As String _
) As String
public:
virtual String^ GetPluginConfiguration(
    String^ typeName
) sealed
Parameters
typeName (String)
The Type name of the plugin.
Return Value
The plugin configuration, or String.Empty.
Exceptions
Exception | Condition
ArgumentNullException | If typeName is null.
ArgumentException | If typeName is empty.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Plugins.SqlCommon (Module: ScrewTurn.Wiki.Plugins.SqlCommon) Version: 3.0.2.500 (3.0.2.500)

Assembly: SqlServerProviders (Module: SqlServerProviders) Version: 3.0.2.500 (3.0.2.500)


GetPluginStatus Method (typeName)

GetPluginStatus Method (typeName)
ScrewTurn Wiki ► ScrewTurn.Wiki.Plugins.SqlCommon ► SqlSettingsStorageProviderBase ► GetPluginStatus(String)
Gets the status of a plugin.
Declaration Syntax
C# Visual Basic Visual C++
public bool GetPluginStatus(
    string typeName
)
Public Function GetPluginStatus ( _
    typeName As String _
) As Boolean
public:
virtual bool GetPluginStatus(
    String^ typeName
) sealed
Parameters
typeName (String)
The Type name of the plugin.
Return Value
The status (false for disabled, true for enabled), or true if no status is found.
Exceptions
Exception | Condition
ArgumentNullException | If typeName is null.
ArgumentException | If typeName is empty.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Plugins.SqlCommon (Module: ScrewTurn.Wiki.Plugins.SqlCommon) Version: 3.0.2.500 (3.0.2.500)

Assembly: SqlServerProviders (Module: SqlServerProviders) Version: 3.0.2.500 (3.0.2.500)


GetRecentChanges Method

GetRecentChanges Method
ScrewTurn Wiki ► ScrewTurn.Wiki.Plugins.SqlCommon ► SqlSettingsStorageProviderBase ► GetRecentChanges()()()
Gets the recent changes of the Wiki.
Declaration Syntax
C# Visual Basic Visual C++
public RecentChange[] GetRecentChanges()
Public Function GetRecentChanges As RecentChange()
public:
virtual array<RecentChange^>^ GetRecentChanges() sealed
Return Value
The recent Changes, oldest to newest.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Plugins.SqlCommon (Module: ScrewTurn.Wiki.Plugins.SqlCommon) Version: 3.0.2.500 (3.0.2.500)

Assembly: SqlServerProviders (Module: SqlServerProviders) Version: 3.0.2.500 (3.0.2.500)


GetSetting Method (name)

GetSetting Method (name)
ScrewTurn Wiki ► ScrewTurn.Wiki.Plugins.SqlCommon ► SqlSettingsStorageProviderBase ► GetSetting(String)
Retrieves the value of a Setting.
Declaration Syntax
C# Visual Basic Visual C++
public string GetSetting(
    string name
)
Public Function GetSetting ( _
    name As String _
) As String
public:
virtual String^ GetSetting(
    String^ name
) sealed
Parameters
name (String)
The name of the Setting.
Return Value
The value of the Setting, or null.
Exceptions
Exception | Condition
ArgumentNullException | If name is null.
ArgumentException | If name is empty.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Plugins.SqlCommon (Module: ScrewTurn.Wiki.Plugins.SqlCommon) Version: 3.0.2.500 (3.0.2.500)

Assembly: SqlServerProviders (Module: SqlServerProviders) Version: 3.0.2.500 (3.0.2.500)


Init Method (host, config)

Init Method (host, config)
ScrewTurn Wiki ► ScrewTurn.Wiki.Plugins.SqlCommon ► SqlSettingsStorageProviderBase ► Init(IHostV30, String)
Initializes the Storage Provider.
Declaration Syntax
C# Visual Basic Visual C++
public void Init(
    IHostV30 host,
    string config
)
Public Sub Init ( _
    host As IHostV30, _
    config As String _
)
public:
virtual void Init(
    IHostV30^ host,
    String^ config
) sealed
Parameters
host (IHostV30)
The Host of the Component.
config (String)
The Configuration data, if any.
Remarks
If the configuration string is not valid, the methoud should throw a InvalidConfigurationException.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Plugins.SqlCommon (Module: ScrewTurn.Wiki.Plugins.SqlCommon) Version: 3.0.2.500 (3.0.2.500)

Assembly: SqlServerProviders (Module: SqlServerProviders) Version: 3.0.2.500 (3.0.2.500)


IsFirstApplicationStart Method

IsFirstApplicationStart Method
ScrewTurn Wiki ► ScrewTurn.Wiki.Plugins.SqlCommon ► SqlSettingsStorageProviderBase ► IsFirstApplicationStart()()()
Determines whether the application was started for the first time.
Declaration Syntax
C# Visual Basic Visual C++
public bool IsFirstApplicationStart()
Public Function IsFirstApplicationStart As Boolean
public:
virtual bool IsFirstApplicationStart() sealed
Return Value
true if the application was started for the first time, false otherwise.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Plugins.SqlCommon (Module: ScrewTurn.Wiki.Plugins.SqlCommon) Version: 3.0.2.500 (3.0.2.500)

Assembly: SqlServerProviders (Module: SqlServerProviders) Version: 3.0.2.500 (3.0.2.500)


isFirstStart Field

isFirstStart Field
ScrewTurn Wiki ► ScrewTurn.Wiki.Plugins.SqlCommon ► SqlSettingsStorageProviderBase ► isFirstStart
Holds a value indicating whether the application was started for the first time.
Declaration Syntax
C# Visual Basic Visual C++
protected bool isFirstStart
Protected isFirstStart As Boolean
protected:
bool isFirstStart

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Plugins.SqlCommon (Module: ScrewTurn.Wiki.Plugins.SqlCommon) Version: 3.0.2.500 (3.0.2.500)

Assembly: SqlServerProviders (Module: SqlServerProviders) Version: 3.0.2.500 (3.0.2.500)


ListPluginAssemblies Method

ListPluginAssemblies Method
ScrewTurn Wiki ► ScrewTurn.Wiki.Plugins.SqlCommon ► SqlSettingsStorageProviderBase ► ListPluginAssemblies()()()
Lists the stored plugin assemblies.
Declaration Syntax
C# Visual Basic Visual C++
public string[] ListPluginAssemblies()
Public Function ListPluginAssemblies As String()
public:
virtual array<String^>^ ListPluginAssemblies() sealed
Return Value

[Missing <returns> documentation for "M:ScrewTurn.Wiki.Plugins.SqlCommon.SqlSettingsStorageProviderBase.ListPluginAssemblies"]

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Plugins.SqlCommon (Module: ScrewTurn.Wiki.Plugins.SqlCommon) Version: 3.0.2.500 (3.0.2.500)

Assembly: SqlServerProviders (Module: SqlServerProviders) Version: 3.0.2.500 (3.0.2.500)


LogEntry Method (message, entryType, user)

LogEntry Method (message, entryType, user)
ScrewTurn Wiki ► ScrewTurn.Wiki.Plugins.SqlCommon ► SqlSettingsStorageProviderBase ► LogEntry(String, EntryType, String)
Records a message to the System Log.
Declaration Syntax
C# Visual Basic Visual C++
public void LogEntry(
    string message,
    EntryType entryType,
    string user
)
Public Sub LogEntry ( _
    message As String, _
    entryType As EntryType, _
    user As String _
)
public:
virtual void LogEntry(
    String^ message,
    EntryType entryType,
    String^ user
) sealed
Parameters
message (String)
The Log Message.
entryType (EntryType)
The Type of the Entry.
user (String)
The User.
Remarks
This method should not write messages to the Log using the method IHost.LogEntry. This method should also never throw exceptions (except for parameter validation).
Exceptions
Exception | Condition
ArgumentNullException | If message or user are null.
ArgumentException | If message or user are empty.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Plugins.SqlCommon (Module: ScrewTurn.Wiki.Plugins.SqlCommon) Version: 3.0.2.500 (3.0.2.500)

Assembly: SqlServerProviders (Module: SqlServerProviders) Version: 3.0.2.500 (3.0.2.500)


LogSize Property

LogSize Property
ScrewTurn Wiki ► ScrewTurn.Wiki.Plugins.SqlCommon ► SqlSettingsStorageProviderBase ► LogSize
Gets the current size of the Log, in KB.
Declaration Syntax
C# Visual Basic Visual C++
public int LogSize { get; }
Public ReadOnly Property LogSize As Integer
public:
virtual property int LogSize {
    int get () sealed;
}

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Plugins.SqlCommon (Module: ScrewTurn.Wiki.Plugins.SqlCommon) Version: 3.0.2.500 (3.0.2.500)

Assembly: SqlServerProviders (Module: SqlServerProviders) Version: 3.0.2.500 (3.0.2.500)


RetrievePluginAssembly Method (filename)

RetrievePluginAssembly Method (filename)
ScrewTurn Wiki ► ScrewTurn.Wiki.Plugins.SqlCommon ► SqlSettingsStorageProviderBase ► RetrievePluginAssembly(String)
Retrieves a plugin's assembly.
Declaration Syntax
C# Visual Basic Visual C++
public byte[] RetrievePluginAssembly(
    string filename
)
Public Function RetrievePluginAssembly ( _
    filename As String _
) As Byte()
public:
virtual array<unsigned char>^ RetrievePluginAssembly(
    String^ filename
) sealed
Parameters
filename (String)
The file name of the assembly.
Return Value
The assembly content, or null.
Exceptions
Exception | Condition
ArgumentNullException | If filename is null.
ArgumentException | If filename is empty.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Plugins.SqlCommon (Module: ScrewTurn.Wiki.Plugins.SqlCommon) Version: 3.0.2.500 (3.0.2.500)

Assembly: SqlServerProviders (Module: SqlServerProviders) Version: 3.0.2.500 (3.0.2.500)


SetMetaDataItem Method (item, tag, content)

SetMetaDataItem Method (item, tag, content)
ScrewTurn Wiki ► ScrewTurn.Wiki.Plugins.SqlCommon ► SqlSettingsStorageProviderBase ► SetMetaDataItem(MetaDataItem, String, String)
Sets a meta-data items' content.
Declaration Syntax
C# Visual Basic Visual C++
public bool SetMetaDataItem(
    MetaDataItem item,
    string tag,
    string content
)
Public Function SetMetaDataItem ( _
    item As MetaDataItem, _
    tag As String, _
    content As String _
) As Boolean
public:
virtual bool SetMetaDataItem(
    MetaDataItem item,
    String^ tag,
    String^ content
) sealed
Parameters
item (MetaDataItem)
The item.
tag (String)
The tag that specifies the context (usually the namespace).
content (String)
The content.
Return Value
true if the content is set, false otherwise.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Plugins.SqlCommon (Module: ScrewTurn.Wiki.Plugins.SqlCommon) Version: 3.0.2.500 (3.0.2.500)

Assembly: SqlServerProviders (Module: SqlServerProviders) Version: 3.0.2.500 (3.0.2.500)


SetPluginConfiguration Method (typeName, config)

SetPluginConfiguration Method (typeName, config)
ScrewTurn Wiki ► ScrewTurn.Wiki.Plugins.SqlCommon ► SqlSettingsStorageProviderBase ► SetPluginConfiguration(String, String)
Sets the configuration of a plugin.
Declaration Syntax
C# Visual Basic Visual C++
public bool SetPluginConfiguration(
    string typeName,
    string config
)
Public Function SetPluginConfiguration ( _
    typeName As String, _
    config As String _
) As Boolean
public:
virtual bool SetPluginConfiguration(
    String^ typeName,
    String^ config
) sealed
Parameters
typeName (String)
The Type name of the plugin.
config (String)
The configuration.
Return Value
true if the configuration is stored, false otherwise.
Exceptions
Exception | Condition
ArgumentNullException | If typeName is null.
ArgumentException | If typeName is empty.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Plugins.SqlCommon (Module: ScrewTurn.Wiki.Plugins.SqlCommon) Version: 3.0.2.500 (3.0.2.500)

Assembly: SqlServerProviders (Module: SqlServerProviders) Version: 3.0.2.500 (3.0.2.500)


SetPluginStatus Method (typeName, enabled)

SetPluginStatus Method (typeName, enabled)
ScrewTurn Wiki ► ScrewTurn.Wiki.Plugins.SqlCommon ► SqlSettingsStorageProviderBase ► SetPluginStatus(String, Boolean)
Sets the status of a plugin.
Declaration Syntax
C# Visual Basic Visual C++
public bool SetPluginStatus(
    string typeName,
    bool enabled
)
Public Function SetPluginStatus ( _
    typeName As String, _
    enabled As Boolean _
) As Boolean
public:
virtual bool SetPluginStatus(
    String^ typeName,
    bool enabled
) sealed
Parameters
typeName (String)
The Type name of the plugin.
enabled (Boolean)
The plugin status.
Return Value
true if the status is stored, false otherwise.
Exceptions
Exception | Condition
ArgumentNullException | If typeName is null.
ArgumentException | If typeName is empty.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Plugins.SqlCommon (Module: ScrewTurn.Wiki.Plugins.SqlCommon) Version: 3.0.2.500 (3.0.2.500)

Assembly: SqlServerProviders (Module: SqlServerProviders) Version: 3.0.2.500 (3.0.2.500)


SetSetting Method (name, value)

SetSetting Method (name, value)
ScrewTurn Wiki ► ScrewTurn.Wiki.Plugins.SqlCommon ► SqlSettingsStorageProviderBase ► SetSetting(String, String)
Stores the value of a Setting.
Declaration Syntax
C# Visual Basic Visual C++
public bool SetSetting(
    string name,
    string value
)
Public Function SetSetting ( _
    name As String, _
    value As String _
) As Boolean
public:
virtual bool SetSetting(
    String^ name,
    String^ value
) sealed
Parameters
name (String)
The name of the Setting.
value (String)
The value of the Setting. Value cannot contain CR and LF characters, which will be removed.
Return Value
True if the Setting is stored, false otherwise.
Remarks
This method stores the Value immediately.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Plugins.SqlCommon (Module: ScrewTurn.Wiki.Plugins.SqlCommon) Version: 3.0.2.500 (3.0.2.500)

Assembly: SqlServerProviders (Module: SqlServerProviders) Version: 3.0.2.500 (3.0.2.500)


StoreOutgoingLinks Method (page, outgoingLinks)

StoreOutgoingLinks Method (page, outgoingLinks)
ScrewTurn Wiki ► ScrewTurn.Wiki.Plugins.SqlCommon ► SqlSettingsStorageProviderBase ► StoreOutgoingLinks(String, array<String>[]()[])
Stores the outgoing links of a page, overwriting existing data.
Declaration Syntax
C# Visual Basic Visual C++
public bool StoreOutgoingLinks(
    string page,
    string[] outgoingLinks
)
Public Function StoreOutgoingLinks ( _
    page As String, _
    outgoingLinks As String() _
) As Boolean
public:
virtual bool StoreOutgoingLinks(
    String^ page,
    array<String^>^ outgoingLinks
) sealed
Parameters
page (String)
The full name of the page.
outgoingLinks (array< String >[]()[][])
The full names of the pages that page links to.
Return Value
true if the outgoing links are stored, false otherwise.
Exceptions
Exception | Condition
ArgumentNullException | If page or outgoingLinks are null.
ArgumentException | If page or outgoingLinks are empty.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Plugins.SqlCommon (Module: ScrewTurn.Wiki.Plugins.SqlCommon) Version: 3.0.2.500 (3.0.2.500)

Assembly: SqlServerProviders (Module: SqlServerProviders) Version: 3.0.2.500 (3.0.2.500)


StorePluginAssembly Method (filename, assembly)

StorePluginAssembly Method (filename, assembly)
ScrewTurn Wiki ► ScrewTurn.Wiki.Plugins.SqlCommon ► SqlSettingsStorageProviderBase ► StorePluginAssembly(String, array<Byte>[]()[])
Stores a plugin's assembly, overwriting existing ones if present.
Declaration Syntax
C# Visual Basic Visual C++
public bool StorePluginAssembly(
    string filename,
    byte[] assembly
)
Public Function StorePluginAssembly ( _
    filename As String, _
    assembly As Byte() _
) As Boolean
public:
virtual bool StorePluginAssembly(
    String^ filename,
    array<unsigned char>^ assembly
) sealed
Parameters
filename (String)
The file name of the assembly, such as "Assembly.dll".
assembly (array< Byte >[]()[][])
The assembly content.
Return Value
true if the assembly is stored, false otherwise.
Exceptions
Exception | Condition
ArgumentNullException | If filename or assembly are null.
ArgumentException | If filename or assembly are empty.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Plugins.SqlCommon (Module: ScrewTurn.Wiki.Plugins.SqlCommon) Version: 3.0.2.500 (3.0.2.500)

Assembly: SqlServerProviders (Module: SqlServerProviders) Version: 3.0.2.500 (3.0.2.500)


UpdateOutgoingLinksForRename Method (oldName, newName)

UpdateOutgoingLinksForRename Method (oldName, newName)
ScrewTurn Wiki ► ScrewTurn.Wiki.Plugins.SqlCommon ► SqlSettingsStorageProviderBase ► UpdateOutgoingLinksForRename(String, String)
Updates all outgoing links data for a page rename.
Declaration Syntax
C# Visual Basic Visual C++
public bool UpdateOutgoingLinksForRename(
    string oldName,
    string newName
)
Public Function UpdateOutgoingLinksForRename ( _
    oldName As String, _
    newName As String _
) As Boolean
public:
virtual bool UpdateOutgoingLinksForRename(
    String^ oldName,
    String^ newName
) sealed
Parameters
oldName (String)
The old page name.
newName (String)
The new page name.
Return Value
true if the data is updated, false otherwise.
Exceptions
Exception | Condition
ArgumentNullException | If oldName or newName are null.
ArgumentException | If oldName or newName are empty.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Plugins.SqlCommon (Module: ScrewTurn.Wiki.Plugins.SqlCommon) Version: 3.0.2.500 (3.0.2.500)

Assembly: SqlServerProviders (Module: SqlServerProviders) Version: 3.0.2.500 (3.0.2.500)


SqlStorageProviderBase Class

SqlStorageProviderBase Class
ScrewTurn Wiki ► ScrewTurn.Wiki.Plugins.SqlCommon ► SqlStorageProviderBase
Implements a base class for a SQL storage provider.
Declaration Syntax
C# Visual Basic Visual C++
public abstract class SqlStorageProviderBase : SqlClassBase
Public MustInherit Class SqlStorageProviderBase _
    Inherits SqlClassBase
public ref class SqlStorageProviderBase abstract : public SqlClassBase
Members
All Members | Constructors | Methods | Properties | Fields
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | SqlStorageProviderBase()()() | Initializes a new instance of the SqlStorageProviderBase class
 | BeginTransaction(DbConnection) | Begins a transaction. (Inherited from SqlClassBase.)
 | CloseConnection(DbConnection) | Closes a connection, swallowing all exceptions. (Inherited from SqlClassBase.)
 | CloseReader(DbCommand, DbDataReader) | Closes a reader, a command and the associated connection. (Inherited from SqlClassBase.)
 | CloseReader(DbDataReader) | Closes a reader. (Inherited from SqlClassBase.)
 | CommitTransaction(DbTransaction) | Commits a transaction. (Inherited from SqlClassBase.)
 | ConfigHelpHtml | Gets a brief summary of the configuration string format, in HTML. Returns null if no configuration is needed.
 | connString | The connection string.
 | CreateOrUpdateDatabaseIfNecessary()()() | Creates or updates the database schema if necessary.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | ExecuteNonQuery(DbCommand) | Executes a non-query command, then closes the connection. (Inherited from SqlClassBase.)
 | ExecuteNonQuery(DbCommand, Boolean) | Executes a non-query command, then closes the connection if requested. (Inherited from SqlClassBase.)
 | ExecuteNonQuery(DbCommand, Boolean, Boolean) | Executes a non-query command, then closes the connection if requested. (Inherited from SqlClassBase.)
 | ExecuteReader(DbCommand, Boolean) | Executes a reader command, leaving the connection open. (Inherited from SqlClassBase.)
 | ExecuteReader(DbCommand) | Executes a reader command, leaving the connection open. (Inherited from SqlClassBase.)
 | ExecuteScalar<(Of <(T>)>)(DbCommand, T) | Executes a scalar command, then closes the connection. (Inherited from SqlClassBase.)
 | ExecuteScalar<(Of <(T>)>)(DbCommand, T, Boolean) | Executes a scalar command, then closes the connection. (Inherited from SqlClassBase.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetBinaryColumn(DbDataReader, String, Int32) | Reads all the contents of a binary column. (Inherited from SqlClassBase.)
 | GetCommandBuilder()()() | Gets a new command builder object.
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetNullableColumn<(Of <(T>)>)(DbDataReader, String, T) | Gets the value of a nullable column. (Inherited from SqlClassBase.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | host | The host.
 | Information | Gets the Information about the Provider.
 | Init(IHostV30, String) | Initializes the Storage Provider.
 | IsDBNull(DbDataReader, String) | Gets a value indicating whether a column contains nonexistent or missing value. (Inherited from SqlClassBase.)
 | LogException(Exception) | Logs an exception. (Overrides SqlClassBase.LogException(Exception).)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ReadBinaryColumn(DbDataReader, String, Stream) | Copies all the contents of a binary column into a Stream. (Inherited from SqlClassBase.)
 | RollbackTransaction(DbTransaction) | Rolls back a transaction. (Inherited from SqlClassBase.)
 | Shutdown()()() | Method invoked on shutdown.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | TryLoadSettingsStorageProviderConfiguration()()() | Tries to load the configuration of the corresponding settings storage provider.
 | TryLoadV2Configuration()()() | Tries to load the configuration from a corresponding v2 provider.
 | ValidateConnectionString(String) | Validates a connection string.
Inheritance Hierarchy
Object
 | SqlClassBase
 |  | SqlStorageProviderBase
 |  |  | SqlFilesStorageProviderBase
 |  |  | SqlPagesStorageProviderBase
 |  |  | SqlSettingsStorageProviderBase
 |  |  | SqlUsersStorageProviderBase

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Plugins.SqlCommon (Module: ScrewTurn.Wiki.Plugins.SqlCommon) Version: 3.0.2.500 (3.0.2.500)

Assembly: SqlServerProviders (Module: SqlServerProviders) Version: 3.0.2.500 (3.0.2.500)


SqlStorageProviderBase Constructor

SqlStorageProviderBase Constructor
ScrewTurn Wiki ► ScrewTurn.Wiki.Plugins.SqlCommon ► SqlStorageProviderBase ► SqlStorageProviderBase()()()
Initializes a new instance of the SqlStorageProviderBase class
Declaration Syntax
C# Visual Basic Visual C++
protected SqlStorageProviderBase()
Protected Sub New
protected:
SqlStorageProviderBase()

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Plugins.SqlCommon (Module: ScrewTurn.Wiki.Plugins.SqlCommon) Version: 3.0.2.500 (3.0.2.500)

Assembly: SqlServerProviders (Module: SqlServerProviders) Version: 3.0.2.500 (3.0.2.500)


ConfigHelpHtml Property

ConfigHelpHtml Property
ScrewTurn Wiki ► ScrewTurn.Wiki.Plugins.SqlCommon ► SqlStorageProviderBase ► ConfigHelpHtml
Gets a brief summary of the configuration string format, in HTML. Returns null if no configuration is needed.
Declaration Syntax
C# Visual Basic Visual C++
public abstract string ConfigHelpHtml { get; }
Public MustOverride ReadOnly Property ConfigHelpHtml As String
public:
virtual property String^ ConfigHelpHtml {
    String^ get () abstract;
}

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Plugins.SqlCommon (Module: ScrewTurn.Wiki.Plugins.SqlCommon) Version: 3.0.2.500 (3.0.2.500)

Assembly: SqlServerProviders (Module: SqlServerProviders) Version: 3.0.2.500 (3.0.2.500)


connString Field

connString Field
ScrewTurn Wiki ► ScrewTurn.Wiki.Plugins.SqlCommon ► SqlStorageProviderBase ► connString
The connection string.
Declaration Syntax
C# Visual Basic Visual C++
protected string connString
Protected connString As String
protected:
String^ connString

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Plugins.SqlCommon (Module: ScrewTurn.Wiki.Plugins.SqlCommon) Version: 3.0.2.500 (3.0.2.500)

Assembly: SqlServerProviders (Module: SqlServerProviders) Version: 3.0.2.500 (3.0.2.500)


CreateOrUpdateDatabaseIfNecessary Method

CreateOrUpdateDatabaseIfNecessary Method
ScrewTurn Wiki ► ScrewTurn.Wiki.Plugins.SqlCommon ► SqlStorageProviderBase ► CreateOrUpdateDatabaseIfNecessary()()()
Creates or updates the database schema if necessary.
Declaration Syntax
C# Visual Basic Visual C++
protected abstract void CreateOrUpdateDatabaseIfNecessary()
Protected MustOverride Sub CreateOrUpdateDatabaseIfNecessary
protected:
virtual void CreateOrUpdateDatabaseIfNecessary() abstract

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Plugins.SqlCommon (Module: ScrewTurn.Wiki.Plugins.SqlCommon) Version: 3.0.2.500 (3.0.2.500)

Assembly: SqlServerProviders (Module: SqlServerProviders) Version: 3.0.2.500 (3.0.2.500)


GetCommandBuilder Method

GetCommandBuilder Method
ScrewTurn Wiki ► ScrewTurn.Wiki.Plugins.SqlCommon ► SqlStorageProviderBase ► GetCommandBuilder()()()
Gets a new command builder object.
Declaration Syntax
C# Visual Basic Visual C++
protected abstract ICommandBuilder GetCommandBuilder()
Protected MustOverride Function GetCommandBuilder As ICommandBuilder
protected:
virtual ICommandBuilder^ GetCommandBuilder() abstract
Return Value
The command builder.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Plugins.SqlCommon (Module: ScrewTurn.Wiki.Plugins.SqlCommon) Version: 3.0.2.500 (3.0.2.500)

Assembly: SqlServerProviders (Module: SqlServerProviders) Version: 3.0.2.500 (3.0.2.500)


host Field

host Field
ScrewTurn Wiki ► ScrewTurn.Wiki.Plugins.SqlCommon ► SqlStorageProviderBase ► host
The host.
Declaration Syntax
C# Visual Basic Visual C++
protected IHostV30 host
Protected host As IHostV30
protected:
IHostV30^ host

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Plugins.SqlCommon (Module: ScrewTurn.Wiki.Plugins.SqlCommon) Version: 3.0.2.500 (3.0.2.500)

Assembly: SqlServerProviders (Module: SqlServerProviders) Version: 3.0.2.500 (3.0.2.500)


Information Property

Information Property
ScrewTurn Wiki ► ScrewTurn.Wiki.Plugins.SqlCommon ► SqlStorageProviderBase ► Information
Gets the Information about the Provider.
Declaration Syntax
C# Visual Basic Visual C++
public abstract ComponentInformation Information { get; }
Public MustOverride ReadOnly Property Information As ComponentInformation
public:
virtual property ComponentInformation^ Information {
    ComponentInformation^ get () abstract;
}

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Plugins.SqlCommon (Module: ScrewTurn.Wiki.Plugins.SqlCommon) Version: 3.0.2.500 (3.0.2.500)

Assembly: SqlServerProviders (Module: SqlServerProviders) Version: 3.0.2.500 (3.0.2.500)


Init Method (host, config)

Init Method (host, config)
ScrewTurn Wiki ► ScrewTurn.Wiki.Plugins.SqlCommon ► SqlStorageProviderBase ► Init(IHostV30, String)
Initializes the Storage Provider.
Declaration Syntax
C# Visual Basic Visual C++
public void Init(
    IHostV30 host,
    string config
)
Public Sub Init ( _
    host As IHostV30, _
    config As String _
)
public:
virtual void Init(
    IHostV30^ host,
    String^ config
) sealed
Parameters
host (IHostV30)
The Host of the Component.
config (String)
The Configuration data, if any.
Exceptions
Exception | Condition
ArgumentNullException | If host or config are null.
InvalidConfigurationException | If config is not valid or is incorrect.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Plugins.SqlCommon (Module: ScrewTurn.Wiki.Plugins.SqlCommon) Version: 3.0.2.500 (3.0.2.500)

Assembly: SqlServerProviders (Module: SqlServerProviders) Version: 3.0.2.500 (3.0.2.500)


LogException Method (ex)

LogException Method (ex)
ScrewTurn Wiki ► ScrewTurn.Wiki.Plugins.SqlCommon ► SqlStorageProviderBase ► LogException(Exception)
Logs an exception.
Declaration Syntax
C# Visual Basic Visual C++
protected override void LogException(
    Exception ex
)
Protected Overrides Sub LogException ( _
    ex As Exception _
)
protected:
virtual void LogException(
    Exception^ ex
) override
Parameters
ex (Exception)
The exception.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Plugins.SqlCommon (Module: ScrewTurn.Wiki.Plugins.SqlCommon) Version: 3.0.2.500 (3.0.2.500)

Assembly: SqlServerProviders (Module: SqlServerProviders) Version: 3.0.2.500 (3.0.2.500)


Shutdown Method

Shutdown Method
ScrewTurn Wiki ► ScrewTurn.Wiki.Plugins.SqlCommon ► SqlStorageProviderBase ► Shutdown()()()
Method invoked on shutdown.
Declaration Syntax
C# Visual Basic Visual C++
public void Shutdown()
Public Sub Shutdown
public:
virtual void Shutdown() sealed
Remarks
This method might not be invoked in some cases.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Plugins.SqlCommon (Module: ScrewTurn.Wiki.Plugins.SqlCommon) Version: 3.0.2.500 (3.0.2.500)

Assembly: SqlServerProviders (Module: SqlServerProviders) Version: 3.0.2.500 (3.0.2.500)


TryLoadSettingsStorageProviderConfiguration Method

TryLoadSettingsStorageProviderConfiguration Method
ScrewTurn Wiki ► ScrewTurn.Wiki.Plugins.SqlCommon ► SqlStorageProviderBase ► TryLoadSettingsStorageProviderConfiguration()()()
Tries to load the configuration of the corresponding settings storage provider.
Declaration Syntax
C# Visual Basic Visual C++
protected abstract string TryLoadSettingsStorageProviderConfiguration()
Protected MustOverride Function TryLoadSettingsStorageProviderConfiguration As String
protected:
virtual String^ TryLoadSettingsStorageProviderConfiguration() abstract
Return Value
The configuration, or an empty string.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Plugins.SqlCommon (Module: ScrewTurn.Wiki.Plugins.SqlCommon) Version: 3.0.2.500 (3.0.2.500)

Assembly: SqlServerProviders (Module: SqlServerProviders) Version: 3.0.2.500 (3.0.2.500)


TryLoadV2Configuration Method

TryLoadV2Configuration Method
ScrewTurn Wiki ► ScrewTurn.Wiki.Plugins.SqlCommon ► SqlStorageProviderBase ► TryLoadV2Configuration()()()
Tries to load the configuration from a corresponding v2 provider.
Declaration Syntax
C# Visual Basic Visual C++
protected abstract string TryLoadV2Configuration()
Protected MustOverride Function TryLoadV2Configuration As String
protected:
virtual String^ TryLoadV2Configuration() abstract
Return Value
The configuration, or an empty string.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Plugins.SqlCommon (Module: ScrewTurn.Wiki.Plugins.SqlCommon) Version: 3.0.2.500 (3.0.2.500)

Assembly: SqlServerProviders (Module: SqlServerProviders) Version: 3.0.2.500 (3.0.2.500)


ValidateConnectionString Method (connString)

ValidateConnectionString Method (connString)
ScrewTurn Wiki ► ScrewTurn.Wiki.Plugins.SqlCommon ► SqlStorageProviderBase ► ValidateConnectionString(String)
Validates a connection string.
Declaration Syntax
C# Visual Basic Visual C++
protected abstract void ValidateConnectionString(
    string connString
)
Protected MustOverride Sub ValidateConnectionString ( _
    connString As String _
)
protected:
virtual void ValidateConnectionString(
    String^ connString
) abstract
Parameters
connString (String)
The connection string to validate.
Remarks
If the connection string is invalid, the method throws InvalidConfigurationException.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Plugins.SqlCommon (Module: ScrewTurn.Wiki.Plugins.SqlCommon) Version: 3.0.2.500 (3.0.2.500)

Assembly: SqlServerProviders (Module: SqlServerProviders) Version: 3.0.2.500 (3.0.2.500)


SqlUsersStorageProviderBase Class

SqlUsersStorageProviderBase Class
ScrewTurn Wiki ► ScrewTurn.Wiki.Plugins.SqlCommon ► SqlUsersStorageProviderBase
Implements a base class for a SQL users storage provider.
Declaration Syntax
C# Visual Basic Visual C++
public abstract class SqlUsersStorageProviderBase : SqlStorageProviderBase,
    IUsersStorageProviderV30, IProviderV30
Public MustInherit Class SqlUsersStorageProviderBase _
    Inherits SqlStorageProviderBase _
    Implements IUsersStorageProviderV30, IProviderV30
public ref class SqlUsersStorageProviderBase abstract : public SqlStorageProviderBase,
    IUsersStorageProviderV30, IProviderV30
Members
All Members | Constructors | Methods | Properties | Fields
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | SqlUsersStorageProviderBase()()() | Initializes a new instance of the SqlUsersStorageProviderBase class
 | AddUser(String, String, String, String, Boolean, DateTime) | Adds a new User.
 | AddUserGroup(String, String) | Adds a new user group.
 | BeginTransaction(DbConnection) | Begins a transaction. (Inherited from SqlClassBase.)
 | CloseConnection(DbConnection) | Closes a connection, swallowing all exceptions. (Inherited from SqlClassBase.)
 | CloseReader(DbCommand, DbDataReader) | Closes a reader, a command and the associated connection. (Inherited from SqlClassBase.)
 | CloseReader(DbDataReader) | Closes a reader. (Inherited from SqlClassBase.)
 | CommitTransaction(DbTransaction) | Commits a transaction. (Inherited from SqlClassBase.)
 | ConfigHelpHtml | Gets a brief summary of the configuration string format, in HTML. Returns null if no configuration is needed. (Inherited from SqlStorageProviderBase.)
 | connString | The connection string. (Inherited from SqlStorageProviderBase.)
 | CreateOrUpdateDatabaseIfNecessary()()() | Creates or updates the database schema if necessary. (Inherited from SqlStorageProviderBase.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | ExecuteNonQuery(DbCommand) | Executes a non-query command, then closes the connection. (Inherited from SqlClassBase.)
 | ExecuteNonQuery(DbCommand, Boolean) | Executes a non-query command, then closes the connection if requested. (Inherited from SqlClassBase.)
 | ExecuteNonQuery(DbCommand, Boolean, Boolean) | Executes a non-query command, then closes the connection if requested. (Inherited from SqlClassBase.)
 | ExecuteReader(DbCommand, Boolean) | Executes a reader command, leaving the connection open. (Inherited from SqlClassBase.)
 | ExecuteReader(DbCommand) | Executes a reader command, leaving the connection open. (Inherited from SqlClassBase.)
 | ExecuteScalar<(Of <(T>)>)(DbCommand, T) | Executes a scalar command, then closes the connection. (Inherited from SqlClassBase.)
 | ExecuteScalar<(Of <(T>)>)(DbCommand, T, Boolean) | Executes a scalar command, then closes the connection. (Inherited from SqlClassBase.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetBinaryColumn(DbDataReader, String, Int32) | Reads all the contents of a binary column. (Inherited from SqlClassBase.)
 | GetCommandBuilder()()() | Gets a new command builder object. (Inherited from SqlStorageProviderBase.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetNullableColumn<(Of <(T>)>)(DbDataReader, String, T) | Gets the value of a nullable column. (Inherited from SqlClassBase.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetUser(String) | Gets a user account.
 | GetUserByEmail(String) | Gets a user account.
 | GetUserGroups()()() | Gets all the user groups.
 | GetUsers()()() | Gets the complete list of Users.
 | GetUsersWithData(String) | Gets all the users that have the specified element in their data.
 | GroupMembershipReadOnly | Gets a value indicating whether group membership is read-only (if UserAccountsReadOnly is false, then this property must be false). If this property is true, the provider should return membership data compatible with default user groups.
 | host | The host. (Inherited from SqlStorageProviderBase.)
 | Information | Gets the Information about the Provider. (Inherited from SqlStorageProviderBase.)
 | Init(IHostV30, String) | Initializes the Storage Provider. (Inherited from SqlStorageProviderBase.)
 | IsDBNull(DbDataReader, String) | Gets a value indicating whether a column contains nonexistent or missing value. (Inherited from SqlClassBase.)
 | LogException(Exception) | Logs an exception. (Inherited from SqlStorageProviderBase.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ModifyUser(UserInfo, String, String, String, Boolean) | Modifies a User.
 | ModifyUserGroup(UserGroup, String) | Modifies a user group.
 | NotifyCookieLogin(UserInfo) | Notifies the provider that a user has logged in through the authentication cookie.
 | NotifyLogout(UserInfo) | Notifies the provider that a user has logged out.
 | ReadBinaryColumn(DbDataReader, String, Stream) | Copies all the contents of a binary column into a Stream. (Inherited from SqlClassBase.)
 | RemoveUser(UserInfo) | Removes a User.
 | RemoveUserGroup(UserGroup) | Removes a user group.
 | RetrieveAllUserData(UserInfo) | Retrieves all the user data elements for a user.
 | RetrieveUserData(UserInfo, String) | Gets a user data element, if any.
 | RollbackTransaction(DbTransaction) | Rolls back a transaction. (Inherited from SqlClassBase.)
 | SetUserMembership(UserInfo, array<String>[]()[]) | Sets the group memberships of a user account.
 | Shutdown()()() | Method invoked on shutdown. (Inherited from SqlStorageProviderBase.)
 | StoreUserData(UserInfo, String, String) | Stores a user data element, overwriting the previous one if present.
 | TestAccount(UserInfo, String) | Tests a Password for a User account.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | TryAutoLogin(HttpContext) | Tries to login a user directly through the provider using the current HttpContext and without username/password.
 | TryLoadSettingsStorageProviderConfiguration()()() | Tries to load the configuration of the corresponding settings storage provider. (Inherited from SqlStorageProviderBase.)
 | TryLoadV2Configuration()()() | Tries to load the configuration from a corresponding v2 provider. (Inherited from SqlStorageProviderBase.)
 | TryManualLogin(String, String) | Tries to login a user directly through the provider.
 | UserAccountsReadOnly | Gets a value indicating whether user accounts are read-only.
 | UserGroupsReadOnly | Gets a value indicating whether user groups are read-only. If so, the provider should support default user groups as defined in the wiki configuration.
 | UsersDataReadOnly | Gets a value indicating whether users' data is read-only.
 | ValidateConnectionString(String) | Validates a connection string. (Inherited from SqlStorageProviderBase.)
Inheritance Hierarchy
Object
 | SqlClassBase
 |  | SqlStorageProviderBase
 |  |  | SqlUsersStorageProviderBase
 |  |  |  | SqlServerUsersStorageProvider

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: SqlServerProviders (Module: SqlServerProviders) Version: 3.0.2.500 (3.0.2.500)

Assembly: ScrewTurn.Wiki.Plugins.SqlCommon (Module: ScrewTurn.Wiki.Plugins.SqlCommon) Version: 3.0.2.500 (3.0.2.500)


SqlUsersStorageProviderBase Constructor

SqlUsersStorageProviderBase Constructor
ScrewTurn Wiki ► ScrewTurn.Wiki.Plugins.SqlCommon ► SqlUsersStorageProviderBase ► SqlUsersStorageProviderBase()()()
Initializes a new instance of the SqlUsersStorageProviderBase class
Declaration Syntax
C# Visual Basic Visual C++
protected SqlUsersStorageProviderBase()
Protected Sub New
protected:
SqlUsersStorageProviderBase()

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: SqlServerProviders (Module: SqlServerProviders) Version: 3.0.2.500 (3.0.2.500)

Assembly: ScrewTurn.Wiki.Plugins.SqlCommon (Module: ScrewTurn.Wiki.Plugins.SqlCommon) Version: 3.0.2.500 (3.0.2.500)


AddUser Method (username, displayName, password, email, active, dateTime)

AddUser Method (username, displayName, password, email, active, dateTime)
ScrewTurn Wiki ► ScrewTurn.Wiki.Plugins.SqlCommon ► SqlUsersStorageProviderBase ► AddUser(String, String, String, String, Boolean, DateTime)
Adds a new User.
Declaration Syntax
C# Visual Basic Visual C++
public UserInfo AddUser(
    string username,
    string displayName,
    string password,
    string email,
    bool active,
    DateTime dateTime
)
Public Function AddUser ( _
    username As String, _
    displayName As String, _
    password As String, _
    email As String, _
    active As Boolean, _
    dateTime As DateTime _
) As UserInfo
public:
virtual UserInfo^ AddUser(
    String^ username,
    String^ displayName,
    String^ password,
    String^ email,
    bool active,
    DateTime dateTime
) sealed
Parameters
username (String)
The Username.
displayName (String)
The display name (can be null).
password (String)
The Password.
email (String)
The Email address.
active (Boolean)
A value indicating whether the account is active.
dateTime (DateTime)
The Account creation Date/Time.
Return Value
The correct UserInfo object or null.
Exceptions
Exception | Condition
ArgumentNullException | If username, password or email are null.
ArgumentException | If username, password or email are empty.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: SqlServerProviders (Module: SqlServerProviders) Version: 3.0.2.500 (3.0.2.500)

Assembly: ScrewTurn.Wiki.Plugins.SqlCommon (Module: ScrewTurn.Wiki.Plugins.SqlCommon) Version: 3.0.2.500 (3.0.2.500)


AddUserGroup Method (name, description)

AddUserGroup Method (name, description)
ScrewTurn Wiki ► ScrewTurn.Wiki.Plugins.SqlCommon ► SqlUsersStorageProviderBase ► AddUserGroup(String, String)
Adds a new user group.
Declaration Syntax
C# Visual Basic Visual C++
public UserGroup AddUserGroup(
    string name,
    string description
)
Public Function AddUserGroup ( _
    name As String, _
    description As String _
) As UserGroup
public:
virtual UserGroup^ AddUserGroup(
    String^ name,
    String^ description
) sealed
Parameters
name (String)
The name of the group.
description (String)
The description of the group.
Return Value
The correct UserGroup object or null.
Exceptions
Exception | Condition
ArgumentNullException | If name or description are null.
ArgumentException | If name is empty.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: SqlServerProviders (Module: SqlServerProviders) Version: 3.0.2.500 (3.0.2.500)

Assembly: ScrewTurn.Wiki.Plugins.SqlCommon (Module: ScrewTurn.Wiki.Plugins.SqlCommon) Version: 3.0.2.500 (3.0.2.500)


GetUser Method (username)

GetUser Method (username)
ScrewTurn Wiki ► ScrewTurn.Wiki.Plugins.SqlCommon ► SqlUsersStorageProviderBase ► GetUser(String)
Gets a user account.
Declaration Syntax
C# Visual Basic Visual C++
public UserInfo GetUser(
    string username
)
Public Function GetUser ( _
    username As String _
) As UserInfo
public:
virtual UserInfo^ GetUser(
    String^ username
) sealed
Parameters
username (String)
The username.
Return Value
The UserInfo, or null.
Exceptions
Exception | Condition
ArgumentNullException | If username is null.
ArgumentException | If username is empty.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: SqlServerProviders (Module: SqlServerProviders) Version: 3.0.2.500 (3.0.2.500)

Assembly: ScrewTurn.Wiki.Plugins.SqlCommon (Module: ScrewTurn.Wiki.Plugins.SqlCommon) Version: 3.0.2.500 (3.0.2.500)


GetUserByEmail Method (email)

GetUserByEmail Method (email)
ScrewTurn Wiki ► ScrewTurn.Wiki.Plugins.SqlCommon ► SqlUsersStorageProviderBase ► GetUserByEmail(String)
Gets a user account.
Declaration Syntax
C# Visual Basic Visual C++
public UserInfo GetUserByEmail(
    string email
)
Public Function GetUserByEmail ( _
    email As String _
) As UserInfo
public:
virtual UserInfo^ GetUserByEmail(
    String^ email
) sealed
Parameters
email (String)
The email address.
Return Value
The first user found with the specified email address, or null.
Exceptions
Exception | Condition
ArgumentNullException | If email is null.
ArgumentException | If email is empty.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: SqlServerProviders (Module: SqlServerProviders) Version: 3.0.2.500 (3.0.2.500)

Assembly: ScrewTurn.Wiki.Plugins.SqlCommon (Module: ScrewTurn.Wiki.Plugins.SqlCommon) Version: 3.0.2.500 (3.0.2.500)


GetUserGroups Method

GetUserGroups Method
ScrewTurn Wiki ► ScrewTurn.Wiki.Plugins.SqlCommon ► SqlUsersStorageProviderBase ► GetUserGroups()()()
Gets all the user groups.
Declaration Syntax
C# Visual Basic Visual C++
public UserGroup[] GetUserGroups()
Public Function GetUserGroups As UserGroup()
public:
virtual array<UserGroup^>^ GetUserGroups() sealed
Return Value
All the groups, sorted by name.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: SqlServerProviders (Module: SqlServerProviders) Version: 3.0.2.500 (3.0.2.500)

Assembly: ScrewTurn.Wiki.Plugins.SqlCommon (Module: ScrewTurn.Wiki.Plugins.SqlCommon) Version: 3.0.2.500 (3.0.2.500)


GetUsers Method

GetUsers Method
ScrewTurn Wiki ► ScrewTurn.Wiki.Plugins.SqlCommon ► SqlUsersStorageProviderBase ► GetUsers()()()
Gets the complete list of Users.
Declaration Syntax
C# Visual Basic Visual C++
public UserInfo[] GetUsers()
Public Function GetUsers As UserInfo()
public:
virtual array<UserInfo^>^ GetUsers() sealed
Return Value
All the Users, sorted by username.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: SqlServerProviders (Module: SqlServerProviders) Version: 3.0.2.500 (3.0.2.500)

Assembly: ScrewTurn.Wiki.Plugins.SqlCommon (Module: ScrewTurn.Wiki.Plugins.SqlCommon) Version: 3.0.2.500 (3.0.2.500)


GetUsersWithData Method (key)

GetUsersWithData Method (key)
ScrewTurn Wiki ► ScrewTurn.Wiki.Plugins.SqlCommon ► SqlUsersStorageProviderBase ► GetUsersWithData(String)
Gets all the users that have the specified element in their data.
Declaration Syntax
C# Visual Basic Visual C++
public IDictionary<UserInfo, string> GetUsersWithData(
    string key
)
Public Function GetUsersWithData ( _
    key As String _
) As IDictionary(Of UserInfo, String)
public:
virtual IDictionary<UserInfo^, String^>^ GetUsersWithData(
    String^ key
) sealed
Parameters
key (String)
The key of the data.
Return Value
The users and the data.
Exceptions
Exception | Condition
ArgumentNullException | If key is null.
ArgumentException | If key is empty.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: SqlServerProviders (Module: SqlServerProviders) Version: 3.0.2.500 (3.0.2.500)

Assembly: ScrewTurn.Wiki.Plugins.SqlCommon (Module: ScrewTurn.Wiki.Plugins.SqlCommon) Version: 3.0.2.500 (3.0.2.500)


GroupMembershipReadOnly Property

GroupMembershipReadOnly Property
ScrewTurn Wiki ► ScrewTurn.Wiki.Plugins.SqlCommon ► SqlUsersStorageProviderBase ► GroupMembershipReadOnly
Gets a value indicating whether group membership is read-only (if UserAccountsReadOnly is false, then this property must be false). If this property is true, the provider should return membership data compatible with default user groups.
Declaration Syntax
C# Visual Basic Visual C++
public bool GroupMembershipReadOnly { get; }
Public ReadOnly Property GroupMembershipReadOnly As Boolean
public:
virtual property bool GroupMembershipReadOnly {
    bool get () sealed;
}

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: SqlServerProviders (Module: SqlServerProviders) Version: 3.0.2.500 (3.0.2.500)

Assembly: ScrewTurn.Wiki.Plugins.SqlCommon (Module: ScrewTurn.Wiki.Plugins.SqlCommon) Version: 3.0.2.500 (3.0.2.500)


ModifyUser Method (user, newDisplayName, newPassword, newEmail, newActive)

ModifyUser Method (user, newDisplayName, newPassword, newEmail, newActive)
ScrewTurn Wiki ► ScrewTurn.Wiki.Plugins.SqlCommon ► SqlUsersStorageProviderBase ► ModifyUser(UserInfo, String, String, String, Boolean)
Modifies a User.
Declaration Syntax
C# Visual Basic Visual C++
public UserInfo ModifyUser(
    UserInfo user,
    string newDisplayName,
    string newPassword,
    string newEmail,
    bool newActive
)
Public Function ModifyUser ( _
    user As UserInfo, _
    newDisplayName As String, _
    newPassword As String, _
    newEmail As String, _
    newActive As Boolean _
) As UserInfo
public:
virtual UserInfo^ ModifyUser(
    UserInfo^ user,
    String^ newDisplayName,
    String^ newPassword,
    String^ newEmail,
    bool newActive
) sealed
Parameters
user (UserInfo)
The Username of the user to modify.
newDisplayName (String)
The new display name (can be null).
newPassword (String)
The new Password (null or blank to keep the current password).
newEmail (String)
The new Email address.
newActive (Boolean)
A value indicating whether the account is active.
Return Value
The correct UserInfo object or null.
Exceptions
Exception | Condition
ArgumentNullException | If user or newEmail are null.
ArgumentException | If newEmail is empty.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: SqlServerProviders (Module: SqlServerProviders) Version: 3.0.2.500 (3.0.2.500)

Assembly: ScrewTurn.Wiki.Plugins.SqlCommon (Module: ScrewTurn.Wiki.Plugins.SqlCommon) Version: 3.0.2.500 (3.0.2.500)


ModifyUserGroup Method (group, description)

ModifyUserGroup Method (group, description)
ScrewTurn Wiki ► ScrewTurn.Wiki.Plugins.SqlCommon ► SqlUsersStorageProviderBase ► ModifyUserGroup(UserGroup, String)
Modifies a user group.
Declaration Syntax
C# Visual Basic Visual C++
public UserGroup ModifyUserGroup(
    UserGroup group,
    string description
)
Public Function ModifyUserGroup ( _
    group As UserGroup, _
    description As String _
) As UserGroup
public:
virtual UserGroup^ ModifyUserGroup(
    UserGroup^ group,
    String^ description
) sealed
Parameters
group (UserGroup)
The group to modify.
description (String)
The new description of the group.
Return Value
The correct UserGroup object or null.
Exceptions
Exception | Condition
ArgumentNullException | If group or description are null.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: SqlServerProviders (Module: SqlServerProviders) Version: 3.0.2.500 (3.0.2.500)

Assembly: ScrewTurn.Wiki.Plugins.SqlCommon (Module: ScrewTurn.Wiki.Plugins.SqlCommon) Version: 3.0.2.500 (3.0.2.500)


NotifyCookieLogin Method (user)

NotifyCookieLogin Method (user)
ScrewTurn Wiki ► ScrewTurn.Wiki.Plugins.SqlCommon ► SqlUsersStorageProviderBase ► NotifyCookieLogin(UserInfo)
Notifies the provider that a user has logged in through the authentication cookie.
Declaration Syntax
C# Visual Basic Visual C++
public void NotifyCookieLogin(
    UserInfo user
)
Public Sub NotifyCookieLogin ( _
    user As UserInfo _
)
public:
virtual void NotifyCookieLogin(
    UserInfo^ user
) sealed
Parameters
user (UserInfo)
The user who has logged in.
Exceptions
Exception | Condition
ArgumentNullException | If user is null.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: SqlServerProviders (Module: SqlServerProviders) Version: 3.0.2.500 (3.0.2.500)

Assembly: ScrewTurn.Wiki.Plugins.SqlCommon (Module: ScrewTurn.Wiki.Plugins.SqlCommon) Version: 3.0.2.500 (3.0.2.500)


NotifyLogout Method (user)

NotifyLogout Method (user)
ScrewTurn Wiki ► ScrewTurn.Wiki.Plugins.SqlCommon ► SqlUsersStorageProviderBase ► NotifyLogout(UserInfo)
Notifies the provider that a user has logged out.
Declaration Syntax
C# Visual Basic Visual C++
public void NotifyLogout(
    UserInfo user
)
Public Sub NotifyLogout ( _
    user As UserInfo _
)
public:
virtual void NotifyLogout(
    UserInfo^ user
) sealed
Parameters
user (UserInfo)
The user who has logged out.
Exceptions
Exception | Condition
ArgumentNullException | If user is null.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: SqlServerProviders (Module: SqlServerProviders) Version: 3.0.2.500 (3.0.2.500)

Assembly: ScrewTurn.Wiki.Plugins.SqlCommon (Module: ScrewTurn.Wiki.Plugins.SqlCommon) Version: 3.0.2.500 (3.0.2.500)


RemoveUser Method (user)

RemoveUser Method (user)
ScrewTurn Wiki ► ScrewTurn.Wiki.Plugins.SqlCommon ► SqlUsersStorageProviderBase ► RemoveUser(UserInfo)
Removes a User.
Declaration Syntax
C# Visual Basic Visual C++
public bool RemoveUser(
    UserInfo user
)
Public Function RemoveUser ( _
    user As UserInfo _
) As Boolean
public:
virtual bool RemoveUser(
    UserInfo^ user
) sealed
Parameters
user (UserInfo)
The User to remove.
Return Value
True if the User has been removed successfully.
Exceptions
Exception | Condition
ArgumentNullException | If user is null.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: SqlServerProviders (Module: SqlServerProviders) Version: 3.0.2.500 (3.0.2.500)

Assembly: ScrewTurn.Wiki.Plugins.SqlCommon (Module: ScrewTurn.Wiki.Plugins.SqlCommon) Version: 3.0.2.500 (3.0.2.500)


RemoveUserGroup Method (group)

RemoveUserGroup Method (group)
ScrewTurn Wiki ► ScrewTurn.Wiki.Plugins.SqlCommon ► SqlUsersStorageProviderBase ► RemoveUserGroup(UserGroup)
Removes a user group.
Declaration Syntax
C# Visual Basic Visual C++
public bool RemoveUserGroup(
    UserGroup group
)
Public Function RemoveUserGroup ( _
    group As UserGroup _
) As Boolean
public:
virtual bool RemoveUserGroup(
    UserGroup^ group
) sealed
Parameters
group (UserGroup)
The group to remove.
Return Value
true if the group is removed, false otherwise.
Exceptions
Exception | Condition
ArgumentNullException | If group is null.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: SqlServerProviders (Module: SqlServerProviders) Version: 3.0.2.500 (3.0.2.500)

Assembly: ScrewTurn.Wiki.Plugins.SqlCommon (Module: ScrewTurn.Wiki.Plugins.SqlCommon) Version: 3.0.2.500 (3.0.2.500)


RetrieveAllUserData Method (user)

RetrieveAllUserData Method (user)
ScrewTurn Wiki ► ScrewTurn.Wiki.Plugins.SqlCommon ► SqlUsersStorageProviderBase ► RetrieveAllUserData(UserInfo)
Retrieves all the user data elements for a user.
Declaration Syntax
C# Visual Basic Visual C++
public IDictionary<string, string> RetrieveAllUserData(
    UserInfo user
)
Public Function RetrieveAllUserData ( _
    user As UserInfo _
) As IDictionary(Of String, String)
public:
virtual IDictionary<String^, String^>^ RetrieveAllUserData(
    UserInfo^ user
) sealed
Parameters
user (UserInfo)
The user.
Return Value
The user data elements (key->value).
Exceptions
Exception | Condition
ArgumentNullException | If user is null.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: SqlServerProviders (Module: SqlServerProviders) Version: 3.0.2.500 (3.0.2.500)

Assembly: ScrewTurn.Wiki.Plugins.SqlCommon (Module: ScrewTurn.Wiki.Plugins.SqlCommon) Version: 3.0.2.500 (3.0.2.500)


RetrieveUserData Method (user, key)

RetrieveUserData Method (user, key)
ScrewTurn Wiki ► ScrewTurn.Wiki.Plugins.SqlCommon ► SqlUsersStorageProviderBase ► RetrieveUserData(UserInfo, String)
Gets a user data element, if any.
Declaration Syntax
C# Visual Basic Visual C++
public string RetrieveUserData(
    UserInfo user,
    string key
)
Public Function RetrieveUserData ( _
    user As UserInfo, _
    key As String _
) As String
public:
virtual String^ RetrieveUserData(
    UserInfo^ user,
    String^ key
) sealed
Parameters
user (UserInfo)
The user the data belongs to.
key (String)
The key of the data element.
Return Value
The value of the data element, or null if the element is not found.
Exceptions
Exception | Condition
ArgumentNullException | If user or key are null.
ArgumentException | If key is empty.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: SqlServerProviders (Module: SqlServerProviders) Version: 3.0.2.500 (3.0.2.500)

Assembly: ScrewTurn.Wiki.Plugins.SqlCommon (Module: ScrewTurn.Wiki.Plugins.SqlCommon) Version: 3.0.2.500 (3.0.2.500)


SetUserMembership Method (user, groups)

SetUserMembership Method (user, groups)
ScrewTurn Wiki ► ScrewTurn.Wiki.Plugins.SqlCommon ► SqlUsersStorageProviderBase ► SetUserMembership(UserInfo, array<String>[]()[])
Sets the group memberships of a user account.
Declaration Syntax
C# Visual Basic Visual C++
public UserInfo SetUserMembership(
    UserInfo user,
    string[] groups
)
Public Function SetUserMembership ( _
    user As UserInfo, _
    groups As String() _
) As UserInfo
public:
virtual UserInfo^ SetUserMembership(
    UserInfo^ user,
    array<String^>^ groups
) sealed
Parameters
user (UserInfo)
The user account.
groups (array< String >[]()[][])
The groups the user account is member of.
Return Value
The correct UserGroup object or null.
Exceptions
Exception | Condition
ArgumentNullException | If user or groups are null.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: SqlServerProviders (Module: SqlServerProviders) Version: 3.0.2.500 (3.0.2.500)

Assembly: ScrewTurn.Wiki.Plugins.SqlCommon (Module: ScrewTurn.Wiki.Plugins.SqlCommon) Version: 3.0.2.500 (3.0.2.500)


StoreUserData Method (user, key, value)

StoreUserData Method (user, key, value)
ScrewTurn Wiki ► ScrewTurn.Wiki.Plugins.SqlCommon ► SqlUsersStorageProviderBase ► StoreUserData(UserInfo, String, String)
Stores a user data element, overwriting the previous one if present.
Declaration Syntax
C# Visual Basic Visual C++
public bool StoreUserData(
    UserInfo user,
    string key,
    string value
)
Public Function StoreUserData ( _
    user As UserInfo, _
    key As String, _
    value As String _
) As Boolean
public:
virtual bool StoreUserData(
    UserInfo^ user,
    String^ key,
    String^ value
) sealed
Parameters
user (UserInfo)
The user the data belongs to.
key (String)
The key of the data element (case insensitive).
value (String)
The value of the data element, null for deleting the data.
Return Value
true if the data element is stored, false otherwise.
Exceptions
Exception | Condition
ArgumentNullException | If user or key are null.
ArgumentException | If key is empty.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: SqlServerProviders (Module: SqlServerProviders) Version: 3.0.2.500 (3.0.2.500)

Assembly: ScrewTurn.Wiki.Plugins.SqlCommon (Module: ScrewTurn.Wiki.Plugins.SqlCommon) Version: 3.0.2.500 (3.0.2.500)


TestAccount Method (user, password)

TestAccount Method (user, password)
ScrewTurn Wiki ► ScrewTurn.Wiki.Plugins.SqlCommon ► SqlUsersStorageProviderBase ► TestAccount(UserInfo, String)
Tests a Password for a User account.
Declaration Syntax
C# Visual Basic Visual C++
public bool TestAccount(
    UserInfo user,
    string password
)
Public Function TestAccount ( _
    user As UserInfo, _
    password As String _
) As Boolean
public:
virtual bool TestAccount(
    UserInfo^ user,
    String^ password
) sealed
Parameters
user (UserInfo)
The User account.
password (String)
The Password to test.
Return Value
True if the Password is correct.
Exceptions
Exception | Condition
ArgumentNullException | If user or password are null.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: SqlServerProviders (Module: SqlServerProviders) Version: 3.0.2.500 (3.0.2.500)

Assembly: ScrewTurn.Wiki.Plugins.SqlCommon (Module: ScrewTurn.Wiki.Plugins.SqlCommon) Version: 3.0.2.500 (3.0.2.500)


TryAutoLogin Method (context)

TryAutoLogin Method (context)
ScrewTurn Wiki ► ScrewTurn.Wiki.Plugins.SqlCommon ► SqlUsersStorageProviderBase ► TryAutoLogin(HttpContext)
Tries to login a user directly through the provider using the current HttpContext and without username/password.
Declaration Syntax
C# Visual Basic Visual C++
public UserInfo TryAutoLogin(
    HttpContext context
)
Public Function TryAutoLogin ( _
    context As HttpContext _
) As UserInfo
public:
virtual UserInfo^ TryAutoLogin(
    HttpContext^ context
) sealed
Parameters
context (HttpContext)
The current HttpContext.
Return Value
The correct UserInfo object, or null.
Exceptions
Exception | Condition
ArgumentNullException | If context is null.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: SqlServerProviders (Module: SqlServerProviders) Version: 3.0.2.500 (3.0.2.500)

Assembly: ScrewTurn.Wiki.Plugins.SqlCommon (Module: ScrewTurn.Wiki.Plugins.SqlCommon) Version: 3.0.2.500 (3.0.2.500)


TryManualLogin Method (username, password)

TryManualLogin Method (username, password)
ScrewTurn Wiki ► ScrewTurn.Wiki.Plugins.SqlCommon ► SqlUsersStorageProviderBase ► TryManualLogin(String, String)
Tries to login a user directly through the provider.
Declaration Syntax
C# Visual Basic Visual C++
public UserInfo TryManualLogin(
    string username,
    string password
)
Public Function TryManualLogin ( _
    username As String, _
    password As String _
) As UserInfo
public:
virtual UserInfo^ TryManualLogin(
    String^ username,
    String^ password
) sealed
Parameters
username (String)
The username.
password (String)
The password.
Return Value
The correct UserInfo object, or null.
Exceptions
Exception | Condition
ArgumentNullException | If username or password are null.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: SqlServerProviders (Module: SqlServerProviders) Version: 3.0.2.500 (3.0.2.500)

Assembly: ScrewTurn.Wiki.Plugins.SqlCommon (Module: ScrewTurn.Wiki.Plugins.SqlCommon) Version: 3.0.2.500 (3.0.2.500)


UserAccountsReadOnly Property

UserAccountsReadOnly Property
ScrewTurn Wiki ► ScrewTurn.Wiki.Plugins.SqlCommon ► SqlUsersStorageProviderBase ► UserAccountsReadOnly
Gets a value indicating whether user accounts are read-only.
Declaration Syntax
C# Visual Basic Visual C++
public bool UserAccountsReadOnly { get; }
Public ReadOnly Property UserAccountsReadOnly As Boolean
public:
virtual property bool UserAccountsReadOnly {
    bool get () sealed;
}

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: SqlServerProviders (Module: SqlServerProviders) Version: 3.0.2.500 (3.0.2.500)

Assembly: ScrewTurn.Wiki.Plugins.SqlCommon (Module: ScrewTurn.Wiki.Plugins.SqlCommon) Version: 3.0.2.500 (3.0.2.500)


UserGroupsReadOnly Property

UserGroupsReadOnly Property
ScrewTurn Wiki ► ScrewTurn.Wiki.Plugins.SqlCommon ► SqlUsersStorageProviderBase ► UserGroupsReadOnly
Gets a value indicating whether user groups are read-only. If so, the provider should support default user groups as defined in the wiki configuration.
Declaration Syntax
C# Visual Basic Visual C++
public bool UserGroupsReadOnly { get; }
Public ReadOnly Property UserGroupsReadOnly As Boolean
public:
virtual property bool UserGroupsReadOnly {
    bool get () sealed;
}

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: SqlServerProviders (Module: SqlServerProviders) Version: 3.0.2.500 (3.0.2.500)

Assembly: ScrewTurn.Wiki.Plugins.SqlCommon (Module: ScrewTurn.Wiki.Plugins.SqlCommon) Version: 3.0.2.500 (3.0.2.500)


UsersDataReadOnly Property

UsersDataReadOnly Property
ScrewTurn Wiki ► ScrewTurn.Wiki.Plugins.SqlCommon ► SqlUsersStorageProviderBase ► UsersDataReadOnly
Gets a value indicating whether users' data is read-only.
Declaration Syntax
C# Visual Basic Visual C++
public bool UsersDataReadOnly { get; }
Public ReadOnly Property UsersDataReadOnly As Boolean
public:
virtual property bool UsersDataReadOnly {
    bool get () sealed;
}

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: SqlServerProviders (Module: SqlServerProviders) Version: 3.0.2.500 (3.0.2.500)

Assembly: ScrewTurn.Wiki.Plugins.SqlCommon (Module: ScrewTurn.Wiki.Plugins.SqlCommon) Version: 3.0.2.500 (3.0.2.500)


SqlWordFetcher Class

SqlWordFetcher Class
ScrewTurn Wiki ► ScrewTurn.Wiki.Plugins.SqlCommon ► SqlWordFetcher
Implements a word fetcher for a SQL-based index.
Declaration Syntax
C# Visual Basic Visual C++
public class SqlWordFetcher : IWordFetcher,
    IDisposable
Public Class SqlWordFetcher _
    Implements IWordFetcher, IDisposable
public ref class SqlWordFetcher : IWordFetcher,
    IDisposable
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | SqlWordFetcher(DbConnection, TryFindWord) | Initializes a new instance of the SqlWordFetcher class.
 | Dispose()()() | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | TryGetWord(String, Word%) | Tries to get a word.
Inheritance Hierarchy
Object
SqlWordFetcher

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Plugins.SqlCommon (Module: ScrewTurn.Wiki.Plugins.SqlCommon) Version: 3.0.2.500 (3.0.2.500)

Assembly: SqlServerProviders (Module: SqlServerProviders) Version: 3.0.2.500 (3.0.2.500)


SqlWordFetcher Constructor (connection, implementation)

SqlWordFetcher Constructor (connection, implementation)
ScrewTurn Wiki ► ScrewTurn.Wiki.Plugins.SqlCommon ► SqlWordFetcher ► SqlWordFetcher(DbConnection, TryFindWord)
Initializes a new instance of the SqlWordFetcher class.
Declaration Syntax
C# Visual Basic Visual C++
public SqlWordFetcher(
    DbConnection connection,
    TryFindWord implementation
)
Public Sub New ( _
    connection As DbConnection, _
    implementation As TryFindWord _
)
public:
SqlWordFetcher(
    DbConnection^ connection,
    TryFindWord^ implementation
)
Parameters
connection (DbConnection)
An open database connection.
implementation (TryFindWord)
The method implementation.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Plugins.SqlCommon (Module: ScrewTurn.Wiki.Plugins.SqlCommon) Version: 3.0.2.500 (3.0.2.500)

Assembly: SqlServerProviders (Module: SqlServerProviders) Version: 3.0.2.500 (3.0.2.500)


Dispose Method

Dispose Method
ScrewTurn Wiki ► ScrewTurn.Wiki.Plugins.SqlCommon ► SqlWordFetcher ► Dispose()()()
Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources.
Declaration Syntax
C# Visual Basic Visual C++
public void Dispose()
Public Sub Dispose
public:
virtual void Dispose() sealed

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Plugins.SqlCommon (Module: ScrewTurn.Wiki.Plugins.SqlCommon) Version: 3.0.2.500 (3.0.2.500)

Assembly: SqlServerProviders (Module: SqlServerProviders) Version: 3.0.2.500 (3.0.2.500)


TryGetWord Method (text, word)

TryGetWord Method (text, word)
ScrewTurn Wiki ► ScrewTurn.Wiki.Plugins.SqlCommon ► SqlWordFetcher ► TryGetWord(String, Word%)
Tries to get a word.
Declaration Syntax
C# Visual Basic Visual C++
public bool TryGetWord(
    string text,
    out Word word
)
Public Function TryGetWord ( _
    text As String, _
    <OutAttribute> ByRef word As Word _
) As Boolean
public:
virtual bool TryGetWord(
    String^ text,
    [OutAttribute] Word^% word
) sealed
Parameters
text (String)
The text of the word.
word ( Word %)
The found word, if any, null otherwise.
Return Value
true if the word is found, false otherwise.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Plugins.SqlCommon (Module: ScrewTurn.Wiki.Plugins.SqlCommon) Version: 3.0.2.500 (3.0.2.500)

Assembly: SqlServerProviders (Module: SqlServerProviders) Version: 3.0.2.500 (3.0.2.500)


StoreEntry Delegate

StoreEntry Delegate
ScrewTurn Wiki ► ScrewTurn.Wiki.Plugins.SqlCommon ► StoreEntry
Defines a delegate for a method that stores a ACL entry in the storage.
Declaration Syntax
C# Visual Basic Visual C++
public delegate bool StoreEntry(
    AclEntry entry
)
Public Delegate Function StoreEntry ( _
    entry As AclEntry _
) As Boolean
public delegate bool StoreEntry(
    AclEntry^ entry
)
Parameters
entry (AclEntry)
The entry to store.
Return Value
true if the entry was stored, false otherwise.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: SqlServerProviders (Module: SqlServerProviders) Version: 3.0.2.500 (3.0.2.500)

Assembly: ScrewTurn.Wiki.Plugins.SqlCommon (Module: ScrewTurn.Wiki.Plugins.SqlCommon) Version: 3.0.2.500 (3.0.2.500)


Tools Class

Tools Class
ScrewTurn Wiki ► ScrewTurn.Wiki.Plugins.SqlCommon ► Tools
Implements tools.
Declaration Syntax
C# Visual Basic Visual C++
public static class Tools
Public NotInheritable Class Tools
public ref class Tools abstract sealed
Members
All Members | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | ReadStream(Stream, array<Byte>[]()[]%, Int32) | Reads the contents of a Stream in a byte array, beginning at the current position through the end.
Inheritance Hierarchy
Object
Tools

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Plugins.SqlCommon (Module: ScrewTurn.Wiki.Plugins.SqlCommon) Version: 3.0.2.500 (3.0.2.500)

Assembly: SqlServerProviders (Module: SqlServerProviders) Version: 3.0.2.500 (3.0.2.500)


ReadStream Method (stream, buffer, maxSize)

ReadStream Method (stream, buffer, maxSize)
ScrewTurn Wiki ► ScrewTurn.Wiki.Plugins.SqlCommon ► Tools ► ReadStream(Stream, array<Byte>[]()[]%, Int32)
Reads the contents of a Stream in a byte array, beginning at the current position through the end.
Declaration Syntax
C# Visual Basic Visual C++
public static int ReadStream(
    Stream stream,
    ref byte[] buffer,
    int maxSize
)
Public Shared Function ReadStream ( _
    stream As Stream, _
    ByRef buffer As Byte(), _
    maxSize As Integer _
) As Integer
public:
static int ReadStream(
    Stream^ stream,
    array<unsigned char>^% buffer,
    int maxSize
)
Parameters
stream (Stream)
The Stream.
buffer ( array< Byte >[]()[][] %)
The output byte array (allocated by the method).
maxSize (Int32)
The max size to read.
Return Value
The number of bytes read, or -maxSize if the max size is exceeded.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Plugins.SqlCommon (Module: ScrewTurn.Wiki.Plugins.SqlCommon) Version: 3.0.2.500 (3.0.2.500)

Assembly: SqlServerProviders (Module: SqlServerProviders) Version: 3.0.2.500 (3.0.2.500)


TryFindWord Delegate

TryFindWord Delegate
ScrewTurn Wiki ► ScrewTurn.Wiki.Plugins.SqlCommon ► TryFindWord
Defines a delegate for a method for finding a word.
Declaration Syntax
C# Visual Basic Visual C++
public delegate bool TryFindWord(
    string text,
    out Word word,
    DbConnection connection
)
Public Delegate Function TryFindWord ( _
    text As String, _
    <OutAttribute> ByRef word As Word, _
    connection As DbConnection _
) As Boolean
public delegate bool TryFindWord(
    String^ text,
    [OutAttribute] Word^% word,
    DbConnection^ connection
)
Parameters
text (String)
The word text.
word ( Word %)
The returned word.
connection (DbConnection)
An open database connection.
Return Value
true if the word is found, false otherwise.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Plugins.SqlCommon (Module: ScrewTurn.Wiki.Plugins.SqlCommon) Version: 3.0.2.500 (3.0.2.500)

Assembly: SqlServerProviders (Module: SqlServerProviders) Version: 3.0.2.500 (3.0.2.500)


WhereOperator Enumeration

WhereOperator Enumeration
ScrewTurn Wiki ► ScrewTurn.Wiki.Plugins.SqlCommon ► WhereOperator
Lists WHERE operators.
Declaration Syntax
C# Visual Basic Visual C++
public enum WhereOperator
Public Enumeration WhereOperator
public enum class WhereOperator
Members
Member | Description
Like | LIKE.
Equals | =.
NotEquals | <>.
GreaterThan | >.
LessThan | <
GreaterThanOrEqualTo | >=.
LessThanOrEqualTo | <=.
IsNull | IS NULL.
IsNotNull | IS NOT NULL.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: SqlServerProviders (Module: SqlServerProviders) Version: 3.0.2.500 (3.0.2.500)

Assembly: ScrewTurn.Wiki.Plugins.SqlCommon (Module: ScrewTurn.Wiki.Plugins.SqlCommon) Version: 3.0.2.500 (3.0.2.500)


ScrewTurn.Wiki.Plugins.SqlServer Namespace

ScrewTurn.Wiki.Plugins.SqlServer Namespace
ScrewTurn Wiki ► ScrewTurn.Wiki.Plugins.SqlServer
Namespace containing SQL Server types.
Declaration Syntax
C# Visual Basic Visual C++
namespace ScrewTurn.Wiki.Plugins.SqlServer
Namespace ScrewTurn.Wiki.Plugins.SqlServer
namespace ScrewTurn.Wiki.Plugins.SqlServer
Types
All Types Classes
Icon | Type | Description
 | SqlServerCommandBuilder | Implements a command builder for SQL Server.
 | SqlServerFilesStorageProvider | Implements a SQL Server-based files storage provider.
 | SqlServerPagesStorageProvider | Implements a SQL Server-based users storage provider.
 | SqlServerSettingsStorageProvider | Implements a SQL Server-based settings storage provider.
 | SqlServerUsersStorageProvider | Implements a SQL Server-based users storage provider.


SqlServerCommandBuilder Class

SqlServerCommandBuilder Class
ScrewTurn Wiki ► ScrewTurn.Wiki.Plugins.SqlServer ► SqlServerCommandBuilder
Implements a command builder for SQL Server.
Declaration Syntax
C# Visual Basic Visual C++
public class SqlServerCommandBuilder : ICommandBuilder
Public Class SqlServerCommandBuilder _
    Implements ICommandBuilder
public ref class SqlServerCommandBuilder : ICommandBuilder
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | SqlServerCommandBuilder()()() | Initializes a new instance of the SqlServerCommandBuilder class
 | BatchQuerySeparator | Gets the string to use in order to separate queries in a batch.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetCommand(String, String, List<(Of <(Parameter>)>)) | Gets a properly built database command, with the underlying connection already open.
 | GetCommand(DbConnection, String, List<(Of <(Parameter>)>)) | Gets a properly built database command, re-using an open connection.
 | GetCommand(DbTransaction, String, List<(Of <(Parameter>)>)) | Gets a properly built database command, re-using an open connection and a begun transaction.
 | GetConnection(String) | Gets a new database connection, open.
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ObjectNamePrefix | Gets the table and column name prefix.
 | ObjectNameSuffix | Gets the table and column name suffix.
 | ParameterNamePrefix | Gets the parameter name prefix.
 | ParameterNameSuffix | Gets the parameter name suffix.
 | ParameterPlaceholder | Gets the parameter name placeholder.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | UseNamedParameters | Gets a value indicating whether to use named parameters. If false, parameter placeholders will be equal to ParameterPlaceholder.
Inheritance Hierarchy
Object
SqlServerCommandBuilder

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: SqlServerProviders (Module: SqlServerProviders) Version: 3.0.2.500 (3.0.2.500)


SqlServerCommandBuilder Constructor

SqlServerCommandBuilder Constructor
ScrewTurn Wiki ► ScrewTurn.Wiki.Plugins.SqlServer ► SqlServerCommandBuilder ► SqlServerCommandBuilder()()()
Initializes a new instance of the SqlServerCommandBuilder class
Declaration Syntax
C# Visual Basic Visual C++
public SqlServerCommandBuilder()
Public Sub New
public:
SqlServerCommandBuilder()

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: SqlServerProviders (Module: SqlServerProviders) Version: 3.0.2.500 (3.0.2.500)


BatchQuerySeparator Property

BatchQuerySeparator Property
ScrewTurn Wiki ► ScrewTurn.Wiki.Plugins.SqlServer ► SqlServerCommandBuilder ► BatchQuerySeparator
Gets the string to use in order to separate queries in a batch.
Declaration Syntax
C# Visual Basic Visual C++
public string BatchQuerySeparator { get; }
Public ReadOnly Property BatchQuerySeparator As String
public:
virtual property String^ BatchQuerySeparator {
    String^ get () sealed;
}

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: SqlServerProviders (Module: SqlServerProviders) Version: 3.0.2.500 (3.0.2.500)


GetCommand Method

GetCommand Method
ScrewTurn Wiki ► ScrewTurn.Wiki.Plugins.SqlServer ► SqlServerCommandBuilder ► GetCommand()()()
Members
Icon | Member | Description
 | GetCommand(String, String, List<(Of <(Parameter>)>)) | Gets a properly built database command, with the underlying connection already open.
 | GetCommand(DbConnection, String, List<(Of <(Parameter>)>)) | Gets a properly built database command, re-using an open connection.
 | GetCommand(DbTransaction, String, List<(Of <(Parameter>)>)) | Gets a properly built database command, re-using an open connection and a begun transaction.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: SqlServerProviders (Module: SqlServerProviders) Version: 3.0.2.500 (3.0.2.500)


GetCommand Method (connection, preparedQuery, parameters)

GetCommand Method (connection, preparedQuery, parameters)
ScrewTurn Wiki ► ScrewTurn.Wiki.Plugins.SqlServer ► SqlServerCommandBuilder ► GetCommand(DbConnection, String, List<(Of <(Parameter>)>))
Gets a properly built database command, re-using an open connection.
Declaration Syntax
C# Visual Basic Visual C++
public DbCommand GetCommand(
    DbConnection connection,
    string preparedQuery,
    List<Parameter> parameters
)
Public Function GetCommand ( _
    connection As DbConnection, _
    preparedQuery As String, _
    parameters As List(Of Parameter) _
) As DbCommand
public:
virtual DbCommand^ GetCommand(
    DbConnection^ connection,
    String^ preparedQuery,
    List<Parameter^>^ parameters
) sealed
Parameters
connection (DbConnection)
The open connection to use.
preparedQuery (String)
The prepared query.
parameters (List <(Of <(<' Parameter >)>)>)
The parameters, if any.
Return Value
The command.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: SqlServerProviders (Module: SqlServerProviders) Version: 3.0.2.500 (3.0.2.500)


GetCommand Method (transaction, preparedQuery, parameters)

GetCommand Method (transaction, preparedQuery, parameters)
ScrewTurn Wiki ► ScrewTurn.Wiki.Plugins.SqlServer ► SqlServerCommandBuilder ► GetCommand(DbTransaction, String, List<(Of <(Parameter>)>))
Gets a properly built database command, re-using an open connection and a begun transaction.
Declaration Syntax
C# Visual Basic Visual C++
public DbCommand GetCommand(
    DbTransaction transaction,
    string preparedQuery,
    List<Parameter> parameters
)
Public Function GetCommand ( _
    transaction As DbTransaction, _
    preparedQuery As String, _
    parameters As List(Of Parameter) _
) As DbCommand
public:
virtual DbCommand^ GetCommand(
    DbTransaction^ transaction,
    String^ preparedQuery,
    List<Parameter^>^ parameters
) sealed
Parameters
transaction (DbTransaction)
The transaction.
preparedQuery (String)
The prepared query.
parameters (List <(Of <(<' Parameter >)>)>)
The parameters, if any.
Return Value
The command.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: SqlServerProviders (Module: SqlServerProviders) Version: 3.0.2.500 (3.0.2.500)


GetCommand Method (connString, preparedQuery, parameters)

GetCommand Method (connString, preparedQuery, parameters)
ScrewTurn Wiki ► ScrewTurn.Wiki.Plugins.SqlServer ► SqlServerCommandBuilder ► GetCommand(String, String, List<(Of <(Parameter>)>))
Gets a properly built database command, with the underlying connection already open.
Declaration Syntax
C# Visual Basic Visual C++
public DbCommand GetCommand(
    string connString,
    string preparedQuery,
    List<Parameter> parameters
)
Public Function GetCommand ( _
    connString As String, _
    preparedQuery As String, _
    parameters As List(Of Parameter) _
) As DbCommand
public:
virtual DbCommand^ GetCommand(
    String^ connString,
    String^ preparedQuery,
    List<Parameter^>^ parameters
) sealed
Parameters
connString (String)
The connection string.
preparedQuery (String)
The prepared query.
parameters (List <(Of <(<' Parameter >)>)>)
The parameters, if any.
Return Value
The command.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: SqlServerProviders (Module: SqlServerProviders) Version: 3.0.2.500 (3.0.2.500)


GetConnection Method (connString)

GetConnection Method (connString)
ScrewTurn Wiki ► ScrewTurn.Wiki.Plugins.SqlServer ► SqlServerCommandBuilder ► GetConnection(String)
Gets a new database connection, open.
Declaration Syntax
C# Visual Basic Visual C++
public DbConnection GetConnection(
    string connString
)
Public Function GetConnection ( _
    connString As String _
) As DbConnection
public:
virtual DbConnection^ GetConnection(
    String^ connString
) sealed
Parameters
connString (String)
The connection string.
Return Value
The connection.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: SqlServerProviders (Module: SqlServerProviders) Version: 3.0.2.500 (3.0.2.500)


ObjectNamePrefix Property

ObjectNamePrefix Property
ScrewTurn Wiki ► ScrewTurn.Wiki.Plugins.SqlServer ► SqlServerCommandBuilder ► ObjectNamePrefix
Gets the table and column name prefix.
Declaration Syntax
C# Visual Basic Visual C++
public string ObjectNamePrefix { get; }
Public ReadOnly Property ObjectNamePrefix As String
public:
virtual property String^ ObjectNamePrefix {
    String^ get () sealed;
}

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: SqlServerProviders (Module: SqlServerProviders) Version: 3.0.2.500 (3.0.2.500)


ObjectNameSuffix Property

ObjectNameSuffix Property
ScrewTurn Wiki ► ScrewTurn.Wiki.Plugins.SqlServer ► SqlServerCommandBuilder ► ObjectNameSuffix
Gets the table and column name suffix.
Declaration Syntax
C# Visual Basic Visual C++
public string ObjectNameSuffix { get; }
Public ReadOnly Property ObjectNameSuffix As String
public:
virtual property String^ ObjectNameSuffix {
    String^ get () sealed;
}

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: SqlServerProviders (Module: SqlServerProviders) Version: 3.0.2.500 (3.0.2.500)


ParameterNamePrefix Property

ParameterNamePrefix Property
ScrewTurn Wiki ► ScrewTurn.Wiki.Plugins.SqlServer ► SqlServerCommandBuilder ► ParameterNamePrefix
Gets the parameter name prefix.
Declaration Syntax
C# Visual Basic Visual C++
public string ParameterNamePrefix { get; }
Public ReadOnly Property ParameterNamePrefix As String
public:
virtual property String^ ParameterNamePrefix {
    String^ get () sealed;
}

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: SqlServerProviders (Module: SqlServerProviders) Version: 3.0.2.500 (3.0.2.500)


ParameterNameSuffix Property

ParameterNameSuffix Property
ScrewTurn Wiki ► ScrewTurn.Wiki.Plugins.SqlServer ► SqlServerCommandBuilder ► ParameterNameSuffix
Gets the parameter name suffix.
Declaration Syntax
C# Visual Basic Visual C++
public string ParameterNameSuffix { get; }
Public ReadOnly Property ParameterNameSuffix As String
public:
virtual property String^ ParameterNameSuffix {
    String^ get () sealed;
}

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: SqlServerProviders (Module: SqlServerProviders) Version: 3.0.2.500 (3.0.2.500)


ParameterPlaceholder Property

ParameterPlaceholder Property
ScrewTurn Wiki ► ScrewTurn.Wiki.Plugins.SqlServer ► SqlServerCommandBuilder ► ParameterPlaceholder
Gets the parameter name placeholder.
Declaration Syntax
C# Visual Basic Visual C++
public string ParameterPlaceholder { get; }
Public ReadOnly Property ParameterPlaceholder As String
public:
virtual property String^ ParameterPlaceholder {
    String^ get () sealed;
}

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: SqlServerProviders (Module: SqlServerProviders) Version: 3.0.2.500 (3.0.2.500)


UseNamedParameters Property

UseNamedParameters Property
ScrewTurn Wiki ► ScrewTurn.Wiki.Plugins.SqlServer ► SqlServerCommandBuilder ► UseNamedParameters
Gets a value indicating whether to use named parameters. If false, parameter placeholders will be equal to ParameterPlaceholder.
Declaration Syntax
C# Visual Basic Visual C++
public bool UseNamedParameters { get; }
Public ReadOnly Property UseNamedParameters As Boolean
public:
virtual property bool UseNamedParameters {
    bool get () sealed;
}

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: SqlServerProviders (Module: SqlServerProviders) Version: 3.0.2.500 (3.0.2.500)


SqlServerFilesStorageProvider Class

SqlServerFilesStorageProvider Class
ScrewTurn Wiki ► ScrewTurn.Wiki.Plugins.SqlServer ► SqlServerFilesStorageProvider
Implements a SQL Server-based files storage provider.
Declaration Syntax
C# Visual Basic Visual C++
public class SqlServerFilesStorageProvider : SqlFilesStorageProviderBase
Public Class SqlServerFilesStorageProvider _
    Inherits SqlFilesStorageProviderBase
public ref class SqlServerFilesStorageProvider : public SqlFilesStorageProviderBase
Members
All Members | Constructors | Methods | Properties | Fields
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | SqlServerFilesStorageProvider()()() | Initializes a new instance of the SqlServerFilesStorageProvider class
 | BeginTransaction(DbConnection) | Begins a transaction. (Inherited from SqlClassBase.)
 | CloseConnection(DbConnection) | Closes a connection, swallowing all exceptions. (Inherited from SqlClassBase.)
 | CloseReader(DbCommand, DbDataReader) | Closes a reader, a command and the associated connection. (Inherited from SqlClassBase.)
 | CloseReader(DbDataReader) | Closes a reader. (Inherited from SqlClassBase.)
 | CommitTransaction(DbTransaction) | Commits a transaction. (Inherited from SqlClassBase.)
 | ConfigHelpHtml | Gets a brief summary of the configuration string format, in HTML. Returns null if no configuration is needed. (Overrides SqlStorageProviderBase.ConfigHelpHtml.)
 | connString | The connection string. (Inherited from SqlStorageProviderBase.)
 | CreateDirectory(String, String) | Creates a new Directory. (Inherited from SqlFilesStorageProviderBase.)
 | CreateOrUpdateDatabaseIfNecessary()()() | Creates or updates the database schema if necessary. (Overrides SqlStorageProviderBase.CreateOrUpdateDatabaseIfNecessary()()().)
 | DeleteDirectory(String) | Deletes a Directory and all of its content. (Inherited from SqlFilesStorageProviderBase.)
 | DeleteFile(String) | Deletes a File. (Inherited from SqlFilesStorageProviderBase.)
 | DeletePageAttachment(PageInfo, String) | Deletes a Page Attachment. (Inherited from SqlFilesStorageProviderBase.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | ExecuteNonQuery(DbCommand) | Executes a non-query command, then closes the connection. (Inherited from SqlClassBase.)
 | ExecuteNonQuery(DbCommand, Boolean) | Executes a non-query command, then closes the connection if requested. (Inherited from SqlClassBase.)
 | ExecuteNonQuery(DbCommand, Boolean, Boolean) | Executes a non-query command, then closes the connection if requested. (Inherited from SqlClassBase.)
 | ExecuteReader(DbCommand, Boolean) | Executes a reader command, leaving the connection open. (Inherited from SqlClassBase.)
 | ExecuteReader(DbCommand) | Executes a reader command, leaving the connection open. (Inherited from SqlClassBase.)
 | ExecuteScalar<(Of <(T>)>)(DbCommand, T) | Executes a scalar command, then closes the connection. (Inherited from SqlClassBase.)
 | ExecuteScalar<(Of <(T>)>)(DbCommand, T, Boolean) | Executes a scalar command, then closes the connection. (Inherited from SqlClassBase.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetBinaryColumn(DbDataReader, String, Int32) | Reads all the contents of a binary column. (Inherited from SqlClassBase.)
 | GetCommandBuilder()()() | Gets a new command builder object. (Overrides SqlStorageProviderBase.GetCommandBuilder()()().)
 | GetFileDetails(String) | Gets the details of a file. (Inherited from SqlFilesStorageProviderBase.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetNullableColumn<(Of <(T>)>)(DbDataReader, String, T) | Gets the value of a nullable column. (Inherited from SqlClassBase.)
 | GetPageAttachmentDetails(PageInfo, String) | Gets the details of a page attachment. (Inherited from SqlFilesStorageProviderBase.)
 | GetPagesWithAttachments()()() | The the names of the pages with attachments. (Inherited from SqlFilesStorageProviderBase.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | host | The host. (Inherited from SqlStorageProviderBase.)
 | Information | Gets the Information about the Provider. (Overrides SqlStorageProviderBase.Information.)
 | Init(IHostV30, String) | Initializes the Storage Provider. (Inherited from SqlStorageProviderBase.)
 | IsDBNull(DbDataReader, String) | Gets a value indicating whether a column contains nonexistent or missing value. (Inherited from SqlClassBase.)
 | ListDirectories(String) | Lists the Directories in the specified directory. (Inherited from SqlFilesStorageProviderBase.)
 | ListFiles(String) | Lists the Files in the specified Directory. (Inherited from SqlFilesStorageProviderBase.)
 | ListPageAttachments(PageInfo) | Returns the names of the Attachments of a Page. (Inherited from SqlFilesStorageProviderBase.)
 | LogException(Exception) | Logs an exception. (Inherited from SqlStorageProviderBase.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | NotifyPageRenaming(PageInfo, PageInfo) | Notifies the Provider that a Page has been renamed. (Inherited from SqlFilesStorageProviderBase.)
 | ReadBinaryColumn(DbDataReader, String, Stream) | Copies all the contents of a binary column into a Stream. (Inherited from SqlClassBase.)
 | ReadOnly | Gets a value specifying whether the provider is read-only, i.e. it can only provide data and not store it. (Inherited from SqlFilesStorageProviderBase.)
 | RenameDirectory(String, String) | Renames or moves a Directory. (Inherited from SqlFilesStorageProviderBase.)
 | RenameFile(String, String) | Renames or moves a File. (Inherited from SqlFilesStorageProviderBase.)
 | RenamePageAttachment(PageInfo, String, String) | Renames a Page Attachment. (Inherited from SqlFilesStorageProviderBase.)
 | RetrieveFile(String, Stream, Boolean) | Retrieves a File. (Inherited from SqlFilesStorageProviderBase.)
 | RetrievePageAttachment(PageInfo, String, Stream, Boolean) | Retrieves a Page Attachment. (Inherited from SqlFilesStorageProviderBase.)
 | RollbackTransaction(DbTransaction) | Rolls back a transaction. (Inherited from SqlClassBase.)
 | SetFileRetrievalCount(String, Int32) | Sets the number of times a file was retrieved. (Inherited from SqlFilesStorageProviderBase.)
 | SetPageAttachmentRetrievalCount(PageInfo, String, Int32) | Sets the number of times a page attachment was retrieved. (Inherited from SqlFilesStorageProviderBase.)
 | Shutdown()()() | Method invoked on shutdown. (Inherited from SqlStorageProviderBase.)
 | StoreFile(String, Stream, Boolean) | Stores a file. (Inherited from SqlFilesStorageProviderBase.)
 | StorePageAttachment(PageInfo, String, Stream, Boolean) | Stores a Page Attachment. (Inherited from SqlFilesStorageProviderBase.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | TryLoadSettingsStorageProviderConfiguration()()() | Tries to load the configuration of the corresponding settings storage provider. (Overrides SqlStorageProviderBase.TryLoadSettingsStorageProviderConfiguration()()().)
 | TryLoadV2Configuration()()() | Tries to load the configuration from a corresponding v2 provider. (Overrides SqlStorageProviderBase.TryLoadV2Configuration()()().)
 | ValidateConnectionString(String) | Validates a connection string. (Overrides SqlStorageProviderBase.ValidateConnectionString(String).)
Inheritance Hierarchy
Object
 | SqlClassBase
 |  | SqlStorageProviderBase
 |  |  | SqlFilesStorageProviderBase
 |  |  |  | SqlServerFilesStorageProvider

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: SqlServerProviders (Module: SqlServerProviders) Version: 3.0.2.500 (3.0.2.500)


SqlServerFilesStorageProvider Constructor

SqlServerFilesStorageProvider Constructor
ScrewTurn Wiki ► ScrewTurn.Wiki.Plugins.SqlServer ► SqlServerFilesStorageProvider ► SqlServerFilesStorageProvider()()()
Initializes a new instance of the SqlServerFilesStorageProvider class
Declaration Syntax
C# Visual Basic Visual C++
public SqlServerFilesStorageProvider()
Public Sub New
public:
SqlServerFilesStorageProvider()

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: SqlServerProviders (Module: SqlServerProviders) Version: 3.0.2.500 (3.0.2.500)


ConfigHelpHtml Property

ConfigHelpHtml Property
ScrewTurn Wiki ► ScrewTurn.Wiki.Plugins.SqlServer ► SqlServerFilesStorageProvider ► ConfigHelpHtml
Gets a brief summary of the configuration string format, in HTML. Returns null if no configuration is needed.
Declaration Syntax
C# Visual Basic Visual C++
public override string ConfigHelpHtml { get; }
Public Overrides ReadOnly Property ConfigHelpHtml As String
public:
virtual property String^ ConfigHelpHtml {
    String^ get () override;
}

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: SqlServerProviders (Module: SqlServerProviders) Version: 3.0.2.500 (3.0.2.500)


CreateOrUpdateDatabaseIfNecessary Method

CreateOrUpdateDatabaseIfNecessary Method
ScrewTurn Wiki ► ScrewTurn.Wiki.Plugins.SqlServer ► SqlServerFilesStorageProvider ► CreateOrUpdateDatabaseIfNecessary()()()
Creates or updates the database schema if necessary.
Declaration Syntax
C# Visual Basic Visual C++
protected override void CreateOrUpdateDatabaseIfNecessary()
Protected Overrides Sub CreateOrUpdateDatabaseIfNecessary
protected:
virtual void CreateOrUpdateDatabaseIfNecessary() override

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: SqlServerProviders (Module: SqlServerProviders) Version: 3.0.2.500 (3.0.2.500)


GetCommandBuilder Method

GetCommandBuilder Method
ScrewTurn Wiki ► ScrewTurn.Wiki.Plugins.SqlServer ► SqlServerFilesStorageProvider ► GetCommandBuilder()()()
Gets a new command builder object.
Declaration Syntax
C# Visual Basic Visual C++
protected override ICommandBuilder GetCommandBuilder()
Protected Overrides Function GetCommandBuilder As ICommandBuilder
protected:
virtual ICommandBuilder^ GetCommandBuilder() override
Return Value
The command builder.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: SqlServerProviders (Module: SqlServerProviders) Version: 3.0.2.500 (3.0.2.500)


Information Property

Information Property
ScrewTurn Wiki ► ScrewTurn.Wiki.Plugins.SqlServer ► SqlServerFilesStorageProvider ► Information
Gets the Information about the Provider.
Declaration Syntax
C# Visual Basic Visual C++
public override ComponentInformation Information { get; }
Public Overrides ReadOnly Property Information As ComponentInformation
public:
virtual property ComponentInformation^ Information {
    ComponentInformation^ get () override;
}

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: SqlServerProviders (Module: SqlServerProviders) Version: 3.0.2.500 (3.0.2.500)


TryLoadSettingsStorageProviderConfiguration Method

TryLoadSettingsStorageProviderConfiguration Method
ScrewTurn Wiki ► ScrewTurn.Wiki.Plugins.SqlServer ► SqlServerFilesStorageProvider ► TryLoadSettingsStorageProviderConfiguration()()()
Tries to load the configuration of the corresponding settings storage provider.
Declaration Syntax
C# Visual Basic Visual C++
protected override string TryLoadSettingsStorageProviderConfiguration()
Protected Overrides Function TryLoadSettingsStorageProviderConfiguration As String
protected:
virtual String^ TryLoadSettingsStorageProviderConfiguration() override
Return Value
The configuration, or an empty string.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: SqlServerProviders (Module: SqlServerProviders) Version: 3.0.2.500 (3.0.2.500)


TryLoadV2Configuration Method

TryLoadV2Configuration Method
ScrewTurn Wiki ► ScrewTurn.Wiki.Plugins.SqlServer ► SqlServerFilesStorageProvider ► TryLoadV2Configuration()()()
Tries to load the configuration from a corresponding v2 provider.
Declaration Syntax
C# Visual Basic Visual C++
protected override string TryLoadV2Configuration()
Protected Overrides Function TryLoadV2Configuration As String
protected:
virtual String^ TryLoadV2Configuration() override
Return Value
The configuration, or an empty string.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: SqlServerProviders (Module: SqlServerProviders) Version: 3.0.2.500 (3.0.2.500)


ValidateConnectionString Method (connString)

ValidateConnectionString Method (connString)
ScrewTurn Wiki ► ScrewTurn.Wiki.Plugins.SqlServer ► SqlServerFilesStorageProvider ► ValidateConnectionString(String)
Validates a connection string.
Declaration Syntax
C# Visual Basic Visual C++
protected override void ValidateConnectionString(
    string connString
)
Protected Overrides Sub ValidateConnectionString ( _
    connString As String _
)
protected:
virtual void ValidateConnectionString(
    String^ connString
) override
Parameters
connString (String)
The connection string to validate.
Remarks
If the connection string is invalid, the method throws InvalidConfigurationException.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: SqlServerProviders (Module: SqlServerProviders) Version: 3.0.2.500 (3.0.2.500)


SqlServerPagesStorageProvider Class

SqlServerPagesStorageProvider Class
ScrewTurn Wiki ► ScrewTurn.Wiki.Plugins.SqlServer ► SqlServerPagesStorageProvider
Implements a SQL Server-based users storage provider.
Declaration Syntax
C# Visual Basic Visual C++
public class SqlServerPagesStorageProvider : SqlPagesStorageProviderBase,
    IPagesStorageProviderV30, IStorageProviderV30, IProviderV30
Public Class SqlServerPagesStorageProvider _
    Inherits SqlPagesStorageProviderBase _
    Implements IPagesStorageProviderV30, IStorageProviderV30, IProviderV30
public ref class SqlServerPagesStorageProvider : public SqlPagesStorageProviderBase,
    IPagesStorageProviderV30, IStorageProviderV30, IProviderV30
Members
All Members | Constructors | Methods | Properties | Fields
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | SqlServerPagesStorageProvider()()() | Initializes a new instance of the SqlServerPagesStorageProvider class
 | AddCategory(String, String) | Adds a Category. (Inherited from SqlPagesStorageProviderBase.)
 | AddContentTemplate(String, String) | Adds a new content template. (Inherited from SqlPagesStorageProviderBase.)
 | AddMessage(PageInfo, String, String, DateTime, String, Int32) | Adds a new Message to a Page. (Inherited from SqlPagesStorageProviderBase.)
 | AddNamespace(String) | Adds a new namespace. (Inherited from SqlPagesStorageProviderBase.)
 | AddNavigationPath(String, String, array<PageInfo>[]()[]) | Adds a new Navigation Path. (Inherited from SqlPagesStorageProviderBase.)
 | AddPage(String, String, DateTime) | Adds a Page. (Inherited from SqlPagesStorageProviderBase.)
 | AddSnippet(String, String) | Adds a new snippet. (Inherited from SqlPagesStorageProviderBase.)
 | BeginTransaction(DbConnection) | Begins a transaction. (Inherited from SqlClassBase.)
 | BulkStoreMessages(PageInfo, array<Message>[]()[]) | Removes all messages for a page and stores the new messages. (Inherited from SqlPagesStorageProviderBase.)
 | CloseConnection(DbConnection) | Closes a connection, swallowing all exceptions. (Inherited from SqlClassBase.)
 | CloseReader(DbCommand, DbDataReader) | Closes a reader, a command and the associated connection. (Inherited from SqlClassBase.)
 | CloseReader(DbDataReader) | Closes a reader. (Inherited from SqlClassBase.)
 | CommitTransaction(DbTransaction) | Commits a transaction. (Inherited from SqlClassBase.)
 | ConfigHelpHtml | Gets a brief summary of the configuration string format, in HTML. Returns null if no configuration is needed. (Overrides SqlStorageProviderBase.ConfigHelpHtml.)
 | connString | The connection string. (Inherited from SqlStorageProviderBase.)
 | CreateOrUpdateDatabaseIfNecessary()()() | Creates or updates the database schema if necessary. (Overrides SqlStorageProviderBase.CreateOrUpdateDatabaseIfNecessary()()().)
 | DeleteBackups(PageInfo, Int32) | Deletes the Backups of a Page, up to a specified revision. (Inherited from SqlPagesStorageProviderBase.)
 | DeleteDraft(PageInfo) | Deletes a draft of a Page. (Inherited from SqlPagesStorageProviderBase.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | ExecuteNonQuery(DbCommand) | Executes a non-query command, then closes the connection. (Inherited from SqlClassBase.)
 | ExecuteNonQuery(DbCommand, Boolean) | Executes a non-query command, then closes the connection if requested. (Inherited from SqlClassBase.)
 | ExecuteNonQuery(DbCommand, Boolean, Boolean) | Executes a non-query command, then closes the connection if requested. (Inherited from SqlClassBase.)
 | ExecuteReader(DbCommand, Boolean) | Executes a reader command, leaving the connection open. (Inherited from SqlClassBase.)
 | ExecuteReader(DbCommand) | Executes a reader command, leaving the connection open. (Inherited from SqlClassBase.)
 | ExecuteScalar<(Of <(T>)>)(DbCommand, T) | Executes a scalar command, then closes the connection. (Inherited from SqlClassBase.)
 | ExecuteScalar<(Of <(T>)>)(DbCommand, T, Boolean) | Executes a scalar command, then closes the connection. (Inherited from SqlClassBase.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetBackupContent(PageInfo, Int32) | Gets the Content of a Backup of a Page. (Inherited from SqlPagesStorageProviderBase.)
 | GetBackups(PageInfo) | Gets the Backup/Revision numbers of a Page. (Inherited from SqlPagesStorageProviderBase.)
 | GetBinaryColumn(DbDataReader, String, Int32) | Reads all the contents of a binary column. (Inherited from SqlClassBase.)
 | GetCategories(NamespaceInfo) | Gets all the Categories in a namespace. (Inherited from SqlPagesStorageProviderBase.)
 | GetCategoriesForPage(PageInfo) | Gets all the categories of a page. (Inherited from SqlPagesStorageProviderBase.)
 | GetCategory(String) | Gets a category. (Inherited from SqlPagesStorageProviderBase.)
 | GetCommandBuilder()()() | Gets a new command builder object. (Overrides SqlStorageProviderBase.GetCommandBuilder()()().)
 | GetContent(PageInfo) | Gets the Content of a Page. (Inherited from SqlPagesStorageProviderBase.)
 | GetContentTemplates()()() | Gets all the content templates. (Inherited from SqlPagesStorageProviderBase.)
 | GetDraft(PageInfo) | Gets the content of a draft of a Page. (Inherited from SqlPagesStorageProviderBase.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetIndexStats(Int32%, Int32%, Int32%, Int64%) | Gets some statistics about the search engine index. (Inherited from SqlPagesStorageProviderBase.)
 | GetMessageCount(PageInfo) | Gets the total number of Messages in a Page Discussion. (Inherited from SqlPagesStorageProviderBase.)
 | GetMessages(PageInfo) | Gets the Page Messages. (Inherited from SqlPagesStorageProviderBase.)
 | GetNamespace(String) | Gets a namespace. (Inherited from SqlPagesStorageProviderBase.)
 | GetNamespaces()()() | Gets all the sub-namespaces. (Inherited from SqlPagesStorageProviderBase.)
 | GetNavigationPaths(NamespaceInfo) | Gets all the Navigation Paths in a Namespace. (Inherited from SqlPagesStorageProviderBase.)
 | GetNullableColumn<(Of <(T>)>)(DbDataReader, String, T) | Gets the value of a nullable column. (Inherited from SqlClassBase.)
 | GetPage(String) | Gets a page. (Inherited from SqlPagesStorageProviderBase.)
 | GetPages(NamespaceInfo) | Gets all the Pages in a namespace. (Inherited from SqlPagesStorageProviderBase.)
 | GetSnippets()()() | Gets all the snippets. (Inherited from SqlPagesStorageProviderBase.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetUncategorizedPages(NamespaceInfo) | Gets all the pages in a namespace that are bound to zero categories. (Inherited from SqlPagesStorageProviderBase.)
 | host | The host. (Inherited from SqlStorageProviderBase.)
 | Index | Gets the search index (only used for testing purposes). (Inherited from SqlPagesStorageProviderBase.)
 | Information | Gets the Information about the Provider. (Overrides SqlStorageProviderBase.Information.)
 | Init(IHostV30, String) | Initializes the Storage Provider. (Inherited from SqlPagesStorageProviderBase.)
 | IsDBNull(DbDataReader, String) | Gets a value indicating whether a column contains nonexistent or missing value. (Inherited from SqlClassBase.)
 | IsIndexCorrupted | Gets a value indicating whether the search engine index is corrupted and needs to be rebuilt. (Inherited from SqlPagesStorageProviderBase.)
 | LogException(Exception) | Logs an exception. (Inherited from SqlStorageProviderBase.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | MergeCategories(CategoryInfo, CategoryInfo) | Merges two Categories. (Inherited from SqlPagesStorageProviderBase.)
 | ModifyContentTemplate(String, String) | Modifies an existing content template. (Inherited from SqlPagesStorageProviderBase.)
 | ModifyMessage(PageInfo, Int32, String, String, DateTime, String) | Modifies a Message. (Inherited from SqlPagesStorageProviderBase.)
 | ModifyNavigationPath(NavigationPath, array<PageInfo>[]()[]) | Modifies an existing navigation path. (Inherited from SqlPagesStorageProviderBase.)
 | ModifyPage(PageInfo, String, String, DateTime, String, String, array<String>[]()[], String, SaveMode) | Modifies the Content of a Page. (Inherited from SqlPagesStorageProviderBase.)
 | ModifySnippet(String, String) | Modifies an existing snippet. (Inherited from SqlPagesStorageProviderBase.)
 | MovePage(PageInfo, NamespaceInfo, Boolean) | Moves a page from its namespace into another. (Inherited from SqlPagesStorageProviderBase.)
 | PerformSearch(SearchParameters) | Performs a search in the index. (Inherited from SqlPagesStorageProviderBase.)
 | ReadBinaryColumn(DbDataReader, String, Stream) | Copies all the contents of a binary column into a Stream. (Inherited from SqlClassBase.)
 | ReadOnly | Gets a value specifying whether the provider is read-only, i.e. it can only provide data and not store it. (Inherited from SqlPagesStorageProviderBase.)
 | RebindPage(PageInfo, array<String>[]()[]) | Binds a Page with one or more Categories. (Inherited from SqlPagesStorageProviderBase.)
 | RebuildIndex()()() | Rebuilds the search index. (Inherited from SqlPagesStorageProviderBase.)
 | RemoveCategory(CategoryInfo) | Removes a Category. (Inherited from SqlPagesStorageProviderBase.)
 | RemoveContentTemplate(String) | Removes a content template. (Inherited from SqlPagesStorageProviderBase.)
 | RemoveMessage(PageInfo, Int32, Boolean) | Removes a Message. (Inherited from SqlPagesStorageProviderBase.)
 | RemoveNamespace(NamespaceInfo) | Removes a namespace. (Inherited from SqlPagesStorageProviderBase.)
 | RemoveNavigationPath(NavigationPath) | Removes a Navigation Path. (Inherited from SqlPagesStorageProviderBase.)
 | RemovePage(PageInfo) | Removes a Page. (Inherited from SqlPagesStorageProviderBase.)
 | RemoveSnippet(String) | Removes a new Snippet. (Inherited from SqlPagesStorageProviderBase.)
 | RenameCategory(CategoryInfo, String) | Renames a Category. (Inherited from SqlPagesStorageProviderBase.)
 | RenameNamespace(NamespaceInfo, String) | Renames a namespace. (Inherited from SqlPagesStorageProviderBase.)
 | RenamePage(PageInfo, String) | Renames a Page. (Inherited from SqlPagesStorageProviderBase.)
 | RollbackPage(PageInfo, Int32) | Performs the rollback of a Page to a specified revision. (Inherited from SqlPagesStorageProviderBase.)
 | RollbackTransaction(DbTransaction) | Rolls back a transaction. (Inherited from SqlClassBase.)
 | SetBackupContent(PageContent, Int32) | Forces to overwrite or create a Backup. (Inherited from SqlPagesStorageProviderBase.)
 | SetFlags(Boolean) | Sets test flags (to be used only for tests). (Inherited from SqlPagesStorageProviderBase.)
 | SetNamespaceDefaultPage(NamespaceInfo, PageInfo) | Sets the default page of a namespace. (Inherited from SqlPagesStorageProviderBase.)
 | Shutdown()()() | Method invoked on shutdown. (Inherited from SqlStorageProviderBase.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | TryLoadSettingsStorageProviderConfiguration()()() | Tries to load the configuration of the corresponding settings storage provider. (Overrides SqlStorageProviderBase.TryLoadSettingsStorageProviderConfiguration()()().)
 | TryLoadV2Configuration()()() | Tries to load the configuration from a corresponding v2 provider. (Overrides SqlStorageProviderBase.TryLoadV2Configuration()()().)
 | ValidateConnectionString(String) | Validates a connection string. (Overrides SqlStorageProviderBase.ValidateConnectionString(String).)
Inheritance Hierarchy
Object
 | SqlClassBase
 |  | SqlStorageProviderBase
 |  |  | SqlPagesStorageProviderBase
 |  |  |  | SqlServerPagesStorageProvider

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: SqlServerProviders (Module: SqlServerProviders) Version: 3.0.2.500 (3.0.2.500)


SqlServerPagesStorageProvider Constructor

SqlServerPagesStorageProvider Constructor
ScrewTurn Wiki ► ScrewTurn.Wiki.Plugins.SqlServer ► SqlServerPagesStorageProvider ► SqlServerPagesStorageProvider()()()
Initializes a new instance of the SqlServerPagesStorageProvider class
Declaration Syntax
C# Visual Basic Visual C++
public SqlServerPagesStorageProvider()
Public Sub New
public:
SqlServerPagesStorageProvider()

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: SqlServerProviders (Module: SqlServerProviders) Version: 3.0.2.500 (3.0.2.500)


ConfigHelpHtml Property

ConfigHelpHtml Property
ScrewTurn Wiki ► ScrewTurn.Wiki.Plugins.SqlServer ► SqlServerPagesStorageProvider ► ConfigHelpHtml
Gets a brief summary of the configuration string format, in HTML. Returns null if no configuration is needed.
Declaration Syntax
C# Visual Basic Visual C++
public override string ConfigHelpHtml { get; }
Public Overrides ReadOnly Property ConfigHelpHtml As String
public:
virtual property String^ ConfigHelpHtml {
    String^ get () override;
}

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: SqlServerProviders (Module: SqlServerProviders) Version: 3.0.2.500 (3.0.2.500)


CreateOrUpdateDatabaseIfNecessary Method

CreateOrUpdateDatabaseIfNecessary Method
ScrewTurn Wiki ► ScrewTurn.Wiki.Plugins.SqlServer ► SqlServerPagesStorageProvider ► CreateOrUpdateDatabaseIfNecessary()()()
Creates or updates the database schema if necessary.
Declaration Syntax
C# Visual Basic Visual C++
protected override void CreateOrUpdateDatabaseIfNecessary()
Protected Overrides Sub CreateOrUpdateDatabaseIfNecessary
protected:
virtual void CreateOrUpdateDatabaseIfNecessary() override

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: SqlServerProviders (Module: SqlServerProviders) Version: 3.0.2.500 (3.0.2.500)


GetCommandBuilder Method

GetCommandBuilder Method
ScrewTurn Wiki ► ScrewTurn.Wiki.Plugins.SqlServer ► SqlServerPagesStorageProvider ► GetCommandBuilder()()()
Gets a new command builder object.
Declaration Syntax
C# Visual Basic Visual C++
protected override ICommandBuilder GetCommandBuilder()
Protected Overrides Function GetCommandBuilder As ICommandBuilder
protected:
virtual ICommandBuilder^ GetCommandBuilder() override
Return Value
The command builder.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: SqlServerProviders (Module: SqlServerProviders) Version: 3.0.2.500 (3.0.2.500)


Information Property

Information Property
ScrewTurn Wiki ► ScrewTurn.Wiki.Plugins.SqlServer ► SqlServerPagesStorageProvider ► Information
Gets the Information about the Provider.
Declaration Syntax
C# Visual Basic Visual C++
public override ComponentInformation Information { get; }
Public Overrides ReadOnly Property Information As ComponentInformation
public:
virtual property ComponentInformation^ Information {
    ComponentInformation^ get () override;
}

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: SqlServerProviders (Module: SqlServerProviders) Version: 3.0.2.500 (3.0.2.500)


TryLoadSettingsStorageProviderConfiguration Method

TryLoadSettingsStorageProviderConfiguration Method
ScrewTurn Wiki ► ScrewTurn.Wiki.Plugins.SqlServer ► SqlServerPagesStorageProvider ► TryLoadSettingsStorageProviderConfiguration()()()
Tries to load the configuration of the corresponding settings storage provider.
Declaration Syntax
C# Visual Basic Visual C++
protected override string TryLoadSettingsStorageProviderConfiguration()
Protected Overrides Function TryLoadSettingsStorageProviderConfiguration As String
protected:
virtual String^ TryLoadSettingsStorageProviderConfiguration() override
Return Value
The configuration, or an empty string.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: SqlServerProviders (Module: SqlServerProviders) Version: 3.0.2.500 (3.0.2.500)


TryLoadV2Configuration Method

TryLoadV2Configuration Method
ScrewTurn Wiki ► ScrewTurn.Wiki.Plugins.SqlServer ► SqlServerPagesStorageProvider ► TryLoadV2Configuration()()()
Tries to load the configuration from a corresponding v2 provider.
Declaration Syntax
C# Visual Basic Visual C++
protected override string TryLoadV2Configuration()
Protected Overrides Function TryLoadV2Configuration As String
protected:
virtual String^ TryLoadV2Configuration() override
Return Value
The configuration, or an empty string.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: SqlServerProviders (Module: SqlServerProviders) Version: 3.0.2.500 (3.0.2.500)


ValidateConnectionString Method (connString)

ValidateConnectionString Method (connString)
ScrewTurn Wiki ► ScrewTurn.Wiki.Plugins.SqlServer ► SqlServerPagesStorageProvider ► ValidateConnectionString(String)
Validates a connection string.
Declaration Syntax
C# Visual Basic Visual C++
protected override void ValidateConnectionString(
    string connString
)
Protected Overrides Sub ValidateConnectionString ( _
    connString As String _
)
protected:
virtual void ValidateConnectionString(
    String^ connString
) override
Parameters
connString (String)
The connection string to validate.
Remarks
If the connection string is invalid, the method throws InvalidConfigurationException.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: SqlServerProviders (Module: SqlServerProviders) Version: 3.0.2.500 (3.0.2.500)


SqlServerSettingsStorageProvider Class

SqlServerSettingsStorageProvider Class
ScrewTurn Wiki ► ScrewTurn.Wiki.Plugins.SqlServer ► SqlServerSettingsStorageProvider
Implements a SQL Server-based settings storage provider.
Declaration Syntax
C# Visual Basic Visual C++
public class SqlServerSettingsStorageProvider : SqlSettingsStorageProviderBase
Public Class SqlServerSettingsStorageProvider _
    Inherits SqlSettingsStorageProviderBase
public ref class SqlServerSettingsStorageProvider : public SqlSettingsStorageProviderBase
Members
All Members | Constructors | Methods | Properties | Fields
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | SqlServerSettingsStorageProvider()()() | Initializes a new instance of the SqlServerSettingsStorageProvider class
 | AclManager | Gets the ACL Manager instance. (Inherited from SqlSettingsStorageProviderBase.)
 | AddRecentChange(String, String, String, DateTime, String, Change, String) | Adds a new change. (Inherited from SqlSettingsStorageProviderBase.)
 | BeginBulkUpdate()()() | Starts a Bulk update of the Settings so that a bulk of settings can be set before storing them. (Inherited from SqlSettingsStorageProviderBase.)
 | BeginTransaction(DbConnection) | Begins a transaction. (Inherited from SqlClassBase.)
 | ClearLog()()() | Clear the Log. (Inherited from SqlSettingsStorageProviderBase.)
 | CloseConnection(DbConnection) | Closes a connection, swallowing all exceptions. (Inherited from SqlClassBase.)
 | CloseReader(DbCommand, DbDataReader) | Closes a reader, a command and the associated connection. (Inherited from SqlClassBase.)
 | CloseReader(DbDataReader) | Closes a reader. (Inherited from SqlClassBase.)
 | CommitTransaction(DbTransaction) | Commits a transaction. (Inherited from SqlClassBase.)
 | ConfigHelpHtml | Gets a brief summary of the configuration string format, in HTML. Returns null if no configuration is needed. (Overrides SqlStorageProviderBase.ConfigHelpHtml.)
 | connString | The connection string. (Inherited from SqlStorageProviderBase.)
 | CreateOrUpdateDatabaseIfNecessary()()() | Creates or updates the database schema if necessary. (Overrides SqlStorageProviderBase.CreateOrUpdateDatabaseIfNecessary()()().)
 | DefaultFilesStorageProvider | Gets the default files storage provider, when no value is stored in the database. (Overrides SqlSettingsStorageProviderBase.DefaultFilesStorageProvider.)
 | DefaultPagesStorageProvider | Gets the default pages storage provider, when no value is stored in the database. (Overrides SqlSettingsStorageProviderBase.DefaultPagesStorageProvider.)
 | DefaultUsersStorageProvider | Gets the default users storage provider, when no value is stored in the database. (Overrides SqlSettingsStorageProviderBase.DefaultUsersStorageProvider.)
 | DeleteOutgoingLinks(String) | Deletes the outgoing links of a page and all the target links that include the page. (Inherited from SqlSettingsStorageProviderBase.)
 | DeletePluginAssembly(String) | Removes a plugin's assembly. (Inherited from SqlSettingsStorageProviderBase.)
 | EndBulkUpdate()()() | Ends a Bulk update of the Settings and stores the settings. (Inherited from SqlSettingsStorageProviderBase.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | ExecuteNonQuery(DbCommand) | Executes a non-query command, then closes the connection. (Inherited from SqlClassBase.)
 | ExecuteNonQuery(DbCommand, Boolean) | Executes a non-query command, then closes the connection if requested. (Inherited from SqlClassBase.)
 | ExecuteNonQuery(DbCommand, Boolean, Boolean) | Executes a non-query command, then closes the connection if requested. (Inherited from SqlClassBase.)
 | ExecuteReader(DbCommand, Boolean) | Executes a reader command, leaving the connection open. (Inherited from SqlClassBase.)
 | ExecuteReader(DbCommand) | Executes a reader command, leaving the connection open. (Inherited from SqlClassBase.)
 | ExecuteScalar<(Of <(T>)>)(DbCommand, T) | Executes a scalar command, then closes the connection. (Inherited from SqlClassBase.)
 | ExecuteScalar<(Of <(T>)>)(DbCommand, T, Boolean) | Executes a scalar command, then closes the connection. (Inherited from SqlClassBase.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetAllOutgoingLinks()()() | Gets all the outgoing links stored. (Inherited from SqlSettingsStorageProviderBase.)
 | GetAllSettings()()() | Gets the all the setting values. (Inherited from SqlSettingsStorageProviderBase.)
 | GetBinaryColumn(DbDataReader, String, Int32) | Reads all the contents of a binary column. (Inherited from SqlClassBase.)
 | GetCommandBuilder()()() | Gets a new command builder object. (Overrides SqlStorageProviderBase.GetCommandBuilder()()().)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetLogEntries()()() | Gets all the Log Entries, sorted by date/time (oldest to newest). (Inherited from SqlSettingsStorageProviderBase.)
 | GetMetaDataItem(MetaDataItem, String) | Gets a meta-data item's content. (Inherited from SqlSettingsStorageProviderBase.)
 | GetNullableColumn<(Of <(T>)>)(DbDataReader, String, T) | Gets the value of a nullable column. (Inherited from SqlClassBase.)
 | GetOutgoingLinks(String) | Gets the outgoing links of a page. (Inherited from SqlSettingsStorageProviderBase.)
 | GetPluginConfiguration(String) | Gets the configuration of a plugin. (Inherited from SqlSettingsStorageProviderBase.)
 | GetPluginStatus(String) | Gets the status of a plugin. (Inherited from SqlSettingsStorageProviderBase.)
 | GetRecentChanges()()() | Gets the recent changes of the Wiki. (Inherited from SqlSettingsStorageProviderBase.)
 | GetSetting(String) | Retrieves the value of a Setting. (Inherited from SqlSettingsStorageProviderBase.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | host | The host. (Inherited from SqlStorageProviderBase.)
 | Information | Gets the Information about the Provider. (Overrides SqlStorageProviderBase.Information.)
 | Init(IHostV30, String) | Initializes the Storage Provider. (Inherited from SqlSettingsStorageProviderBase.)
 | IsDBNull(DbDataReader, String) | Gets a value indicating whether a column contains nonexistent or missing value. (Inherited from SqlClassBase.)
 | IsFirstApplicationStart()()() | Determines whether the application was started for the first time. (Inherited from SqlSettingsStorageProviderBase.)
 | isFirstStart | Holds a value indicating whether the application was started for the first time. (Inherited from SqlSettingsStorageProviderBase.)
 | ListPluginAssemblies()()() | Lists the stored plugin assemblies. (Inherited from SqlSettingsStorageProviderBase.)
 | LogEntry(String, EntryType, String) | Records a message to the System Log. (Inherited from SqlSettingsStorageProviderBase.)
 | LogException(Exception) | Logs an exception. (Inherited from SqlStorageProviderBase.)
 | LogSize | Gets the current size of the Log, in KB. (Inherited from SqlSettingsStorageProviderBase.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ReadBinaryColumn(DbDataReader, String, Stream) | Copies all the contents of a binary column into a Stream. (Inherited from SqlClassBase.)
 | RetrievePluginAssembly(String) | Retrieves a plugin's assembly. (Inherited from SqlSettingsStorageProviderBase.)
 | RollbackTransaction(DbTransaction) | Rolls back a transaction. (Inherited from SqlClassBase.)
 | SetMetaDataItem(MetaDataItem, String, String) | Sets a meta-data items' content. (Inherited from SqlSettingsStorageProviderBase.)
 | SetPluginConfiguration(String, String) | Sets the configuration of a plugin. (Inherited from SqlSettingsStorageProviderBase.)
 | SetPluginStatus(String, Boolean) | Sets the status of a plugin. (Inherited from SqlSettingsStorageProviderBase.)
 | SetSetting(String, String) | Stores the value of a Setting. (Inherited from SqlSettingsStorageProviderBase.)
 | Shutdown()()() | Method invoked on shutdown. (Inherited from SqlStorageProviderBase.)
 | StoreOutgoingLinks(String, array<String>[]()[]) | Stores the outgoing links of a page, overwriting existing data. (Inherited from SqlSettingsStorageProviderBase.)
 | StorePluginAssembly(String, array<Byte>[]()[]) | Stores a plugin's assembly, overwriting existing ones if present. (Inherited from SqlSettingsStorageProviderBase.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | TryLoadSettingsStorageProviderConfiguration()()() | Tries to load the configuration of the corresponding settings storage provider. (Overrides SqlStorageProviderBase.TryLoadSettingsStorageProviderConfiguration()()().)
 | TryLoadV2Configuration()()() | Tries to load the configuration from a corresponding v2 provider. (Overrides SqlStorageProviderBase.TryLoadV2Configuration()()().)
 | UpdateOutgoingLinksForRename(String, String) | Updates all outgoing links data for a page rename. (Inherited from SqlSettingsStorageProviderBase.)
 | ValidateConnectionString(String) | Validates a connection string. (Overrides SqlStorageProviderBase.ValidateConnectionString(String).)
Inheritance Hierarchy
Object
 | SqlClassBase
 |  | SqlStorageProviderBase
 |  |  | SqlSettingsStorageProviderBase
 |  |  |  | SqlServerSettingsStorageProvider

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: SqlServerProviders (Module: SqlServerProviders) Version: 3.0.2.500 (3.0.2.500)


SqlServerSettingsStorageProvider Constructor

SqlServerSettingsStorageProvider Constructor
ScrewTurn Wiki ► ScrewTurn.Wiki.Plugins.SqlServer ► SqlServerSettingsStorageProvider ► SqlServerSettingsStorageProvider()()()
Initializes a new instance of the SqlServerSettingsStorageProvider class
Declaration Syntax
C# Visual Basic Visual C++
public SqlServerSettingsStorageProvider()
Public Sub New
public:
SqlServerSettingsStorageProvider()

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: SqlServerProviders (Module: SqlServerProviders) Version: 3.0.2.500 (3.0.2.500)


ConfigHelpHtml Property

ConfigHelpHtml Property
ScrewTurn Wiki ► ScrewTurn.Wiki.Plugins.SqlServer ► SqlServerSettingsStorageProvider ► ConfigHelpHtml
Gets a brief summary of the configuration string format, in HTML. Returns null if no configuration is needed.
Declaration Syntax
C# Visual Basic Visual C++
public override string ConfigHelpHtml { get; }
Public Overrides ReadOnly Property ConfigHelpHtml As String
public:
virtual property String^ ConfigHelpHtml {
    String^ get () override;
}

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: SqlServerProviders (Module: SqlServerProviders) Version: 3.0.2.500 (3.0.2.500)


CreateOrUpdateDatabaseIfNecessary Method

CreateOrUpdateDatabaseIfNecessary Method
ScrewTurn Wiki ► ScrewTurn.Wiki.Plugins.SqlServer ► SqlServerSettingsStorageProvider ► CreateOrUpdateDatabaseIfNecessary()()()
Creates or updates the database schema if necessary.
Declaration Syntax
C# Visual Basic Visual C++
protected override void CreateOrUpdateDatabaseIfNecessary()
Protected Overrides Sub CreateOrUpdateDatabaseIfNecessary
protected:
virtual void CreateOrUpdateDatabaseIfNecessary() override

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: SqlServerProviders (Module: SqlServerProviders) Version: 3.0.2.500 (3.0.2.500)


DefaultFilesStorageProvider Property

DefaultFilesStorageProvider Property
ScrewTurn Wiki ► ScrewTurn.Wiki.Plugins.SqlServer ► SqlServerSettingsStorageProvider ► DefaultFilesStorageProvider
Gets the default files storage provider, when no value is stored in the database.
Declaration Syntax
C# Visual Basic Visual C++
protected override string DefaultFilesStorageProvider { get; }
Protected Overrides ReadOnly Property DefaultFilesStorageProvider As String
protected:
virtual property String^ DefaultFilesStorageProvider {
    String^ get () override;
}

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: SqlServerProviders (Module: SqlServerProviders) Version: 3.0.2.500 (3.0.2.500)


DefaultPagesStorageProvider Property

DefaultPagesStorageProvider Property
ScrewTurn Wiki ► ScrewTurn.Wiki.Plugins.SqlServer ► SqlServerSettingsStorageProvider ► DefaultPagesStorageProvider
Gets the default pages storage provider, when no value is stored in the database.
Declaration Syntax
C# Visual Basic Visual C++
protected override string DefaultPagesStorageProvider { get; }
Protected Overrides ReadOnly Property DefaultPagesStorageProvider As String
protected:
virtual property String^ DefaultPagesStorageProvider {
    String^ get () override;
}

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: SqlServerProviders (Module: SqlServerProviders) Version: 3.0.2.500 (3.0.2.500)


DefaultUsersStorageProvider Property

DefaultUsersStorageProvider Property
ScrewTurn Wiki ► ScrewTurn.Wiki.Plugins.SqlServer ► SqlServerSettingsStorageProvider ► DefaultUsersStorageProvider
Gets the default users storage provider, when no value is stored in the database.
Declaration Syntax
C# Visual Basic Visual C++
protected override string DefaultUsersStorageProvider { get; }
Protected Overrides ReadOnly Property DefaultUsersStorageProvider As String
protected:
virtual property String^ DefaultUsersStorageProvider {
    String^ get () override;
}

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: SqlServerProviders (Module: SqlServerProviders) Version: 3.0.2.500 (3.0.2.500)


GetCommandBuilder Method

GetCommandBuilder Method
ScrewTurn Wiki ► ScrewTurn.Wiki.Plugins.SqlServer ► SqlServerSettingsStorageProvider ► GetCommandBuilder()()()
Gets a new command builder object.
Declaration Syntax
C# Visual Basic Visual C++
protected override ICommandBuilder GetCommandBuilder()
Protected Overrides Function GetCommandBuilder As ICommandBuilder
protected:
virtual ICommandBuilder^ GetCommandBuilder() override
Return Value
The command builder.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: SqlServerProviders (Module: SqlServerProviders) Version: 3.0.2.500 (3.0.2.500)


Information Property

Information Property
ScrewTurn Wiki ► ScrewTurn.Wiki.Plugins.SqlServer ► SqlServerSettingsStorageProvider ► Information
Gets the Information about the Provider.
Declaration Syntax
C# Visual Basic Visual C++
public override ComponentInformation Information { get; }
Public Overrides ReadOnly Property Information As ComponentInformation
public:
virtual property ComponentInformation^ Information {
    ComponentInformation^ get () override;
}

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: SqlServerProviders (Module: SqlServerProviders) Version: 3.0.2.500 (3.0.2.500)


TryLoadSettingsStorageProviderConfiguration Method

TryLoadSettingsStorageProviderConfiguration Method
ScrewTurn Wiki ► ScrewTurn.Wiki.Plugins.SqlServer ► SqlServerSettingsStorageProvider ► TryLoadSettingsStorageProviderConfiguration()()()
Tries to load the configuration of the corresponding settings storage provider.
Declaration Syntax
C# Visual Basic Visual C++
protected override string TryLoadSettingsStorageProviderConfiguration()
Protected Overrides Function TryLoadSettingsStorageProviderConfiguration As String
protected:
virtual String^ TryLoadSettingsStorageProviderConfiguration() override
Return Value
The configuration, or an empty string.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: SqlServerProviders (Module: SqlServerProviders) Version: 3.0.2.500 (3.0.2.500)


TryLoadV2Configuration Method

TryLoadV2Configuration Method
ScrewTurn Wiki ► ScrewTurn.Wiki.Plugins.SqlServer ► SqlServerSettingsStorageProvider ► TryLoadV2Configuration()()()
Tries to load the configuration from a corresponding v2 provider.
Declaration Syntax
C# Visual Basic Visual C++
protected override string TryLoadV2Configuration()
Protected Overrides Function TryLoadV2Configuration As String
protected:
virtual String^ TryLoadV2Configuration() override
Return Value
The configuration, or an empty string.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: SqlServerProviders (Module: SqlServerProviders) Version: 3.0.2.500 (3.0.2.500)


ValidateConnectionString Method (connString)

ValidateConnectionString Method (connString)
ScrewTurn Wiki ► ScrewTurn.Wiki.Plugins.SqlServer ► SqlServerSettingsStorageProvider ► ValidateConnectionString(String)
Validates a connection string.
Declaration Syntax
C# Visual Basic Visual C++
protected override void ValidateConnectionString(
    string connString
)
Protected Overrides Sub ValidateConnectionString ( _
    connString As String _
)
protected:
virtual void ValidateConnectionString(
    String^ connString
) override
Parameters
connString (String)
The connection string to validate.
Remarks
If the connection string is invalid, the method throws InvalidConfigurationException.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: SqlServerProviders (Module: SqlServerProviders) Version: 3.0.2.500 (3.0.2.500)


SqlServerUsersStorageProvider Class

SqlServerUsersStorageProvider Class
ScrewTurn Wiki ► ScrewTurn.Wiki.Plugins.SqlServer ► SqlServerUsersStorageProvider
Implements a SQL Server-based users storage provider.
Declaration Syntax
C# Visual Basic Visual C++
public class SqlServerUsersStorageProvider : SqlUsersStorageProviderBase,
    IUsersStorageProviderV30, IProviderV30
Public Class SqlServerUsersStorageProvider _
    Inherits SqlUsersStorageProviderBase _
    Implements IUsersStorageProviderV30, IProviderV30
public ref class SqlServerUsersStorageProvider : public SqlUsersStorageProviderBase,
    IUsersStorageProviderV30, IProviderV30
Members
All Members | Constructors | Methods | Properties | Fields
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | SqlServerUsersStorageProvider()()() | Initializes a new instance of the SqlServerUsersStorageProvider class
 | AddUser(String, String, String, String, Boolean, DateTime) | Adds a new User. (Inherited from SqlUsersStorageProviderBase.)
 | AddUserGroup(String, String) | Adds a new user group. (Inherited from SqlUsersStorageProviderBase.)
 | BeginTransaction(DbConnection) | Begins a transaction. (Inherited from SqlClassBase.)
 | CloseConnection(DbConnection) | Closes a connection, swallowing all exceptions. (Inherited from SqlClassBase.)
 | CloseReader(DbCommand, DbDataReader) | Closes a reader, a command and the associated connection. (Inherited from SqlClassBase.)
 | CloseReader(DbDataReader) | Closes a reader. (Inherited from SqlClassBase.)
 | CommitTransaction(DbTransaction) | Commits a transaction. (Inherited from SqlClassBase.)
 | ConfigHelpHtml | Gets a brief summary of the configuration string format, in HTML. Returns null if no configuration is needed. (Overrides SqlStorageProviderBase.ConfigHelpHtml.)
 | connString | The connection string. (Inherited from SqlStorageProviderBase.)
 | CreateOrUpdateDatabaseIfNecessary()()() | Creates or updates the database schema if necessary. (Overrides SqlStorageProviderBase.CreateOrUpdateDatabaseIfNecessary()()().)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | ExecuteNonQuery(DbCommand) | Executes a non-query command, then closes the connection. (Inherited from SqlClassBase.)
 | ExecuteNonQuery(DbCommand, Boolean) | Executes a non-query command, then closes the connection if requested. (Inherited from SqlClassBase.)
 | ExecuteNonQuery(DbCommand, Boolean, Boolean) | Executes a non-query command, then closes the connection if requested. (Inherited from SqlClassBase.)
 | ExecuteReader(DbCommand, Boolean) | Executes a reader command, leaving the connection open. (Inherited from SqlClassBase.)
 | ExecuteReader(DbCommand) | Executes a reader command, leaving the connection open. (Inherited from SqlClassBase.)
 | ExecuteScalar<(Of <(T>)>)(DbCommand, T) | Executes a scalar command, then closes the connection. (Inherited from SqlClassBase.)
 | ExecuteScalar<(Of <(T>)>)(DbCommand, T, Boolean) | Executes a scalar command, then closes the connection. (Inherited from SqlClassBase.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetBinaryColumn(DbDataReader, String, Int32) | Reads all the contents of a binary column. (Inherited from SqlClassBase.)
 | GetCommandBuilder()()() | Gets a new command builder object. (Overrides SqlStorageProviderBase.GetCommandBuilder()()().)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetNullableColumn<(Of <(T>)>)(DbDataReader, String, T) | Gets the value of a nullable column. (Inherited from SqlClassBase.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetUser(String) | Gets a user account. (Inherited from SqlUsersStorageProviderBase.)
 | GetUserByEmail(String) | Gets a user account. (Inherited from SqlUsersStorageProviderBase.)
 | GetUserGroups()()() | Gets all the user groups. (Inherited from SqlUsersStorageProviderBase.)
 | GetUsers()()() | Gets the complete list of Users. (Inherited from SqlUsersStorageProviderBase.)
 | GetUsersWithData(String) | Gets all the users that have the specified element in their data. (Inherited from SqlUsersStorageProviderBase.)
 | GroupMembershipReadOnly | Gets a value indicating whether group membership is read-only (if UserAccountsReadOnly is false, then this property must be false). If this property is true, the provider should return membership data compatible with default user groups. (Inherited from SqlUsersStorageProviderBase.)
 | host | The host. (Inherited from SqlStorageProviderBase.)
 | Information | Gets the Information about the Provider. (Overrides SqlStorageProviderBase.Information.)
 | Init(IHostV30, String) | Initializes the Storage Provider. (Inherited from SqlStorageProviderBase.)
 | IsDBNull(DbDataReader, String) | Gets a value indicating whether a column contains nonexistent or missing value. (Inherited from SqlClassBase.)
 | LogException(Exception) | Logs an exception. (Inherited from SqlStorageProviderBase.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ModifyUser(UserInfo, String, String, String, Boolean) | Modifies a User. (Inherited from SqlUsersStorageProviderBase.)
 | ModifyUserGroup(UserGroup, String) | Modifies a user group. (Inherited from SqlUsersStorageProviderBase.)
 | NotifyCookieLogin(UserInfo) | Notifies the provider that a user has logged in through the authentication cookie. (Inherited from SqlUsersStorageProviderBase.)
 | NotifyLogout(UserInfo) | Notifies the provider that a user has logged out. (Inherited from SqlUsersStorageProviderBase.)
 | ReadBinaryColumn(DbDataReader, String, Stream) | Copies all the contents of a binary column into a Stream. (Inherited from SqlClassBase.)
 | RemoveUser(UserInfo) | Removes a User. (Inherited from SqlUsersStorageProviderBase.)
 | RemoveUserGroup(UserGroup) | Removes a user group. (Inherited from SqlUsersStorageProviderBase.)
 | RetrieveAllUserData(UserInfo) | Retrieves all the user data elements for a user. (Inherited from SqlUsersStorageProviderBase.)
 | RetrieveUserData(UserInfo, String) | Gets a user data element, if any. (Inherited from SqlUsersStorageProviderBase.)
 | RollbackTransaction(DbTransaction) | Rolls back a transaction. (Inherited from SqlClassBase.)
 | SetUserMembership(UserInfo, array<String>[]()[]) | Sets the group memberships of a user account. (Inherited from SqlUsersStorageProviderBase.)
 | Shutdown()()() | Method invoked on shutdown. (Inherited from SqlStorageProviderBase.)
 | StoreUserData(UserInfo, String, String) | Stores a user data element, overwriting the previous one if present. (Inherited from SqlUsersStorageProviderBase.)
 | TestAccount(UserInfo, String) | Tests a Password for a User account. (Inherited from SqlUsersStorageProviderBase.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | TryAutoLogin(HttpContext) | Tries to login a user directly through the provider using the current HttpContext and without username/password. (Inherited from SqlUsersStorageProviderBase.)
 | TryLoadSettingsStorageProviderConfiguration()()() | Tries to load the configuration of the corresponding settings storage provider. (Overrides SqlStorageProviderBase.TryLoadSettingsStorageProviderConfiguration()()().)
 | TryLoadV2Configuration()()() | Tries to load the configuration from a corresponding v2 provider. (Overrides SqlStorageProviderBase.TryLoadV2Configuration()()().)
 | TryManualLogin(String, String) | Tries to login a user directly through the provider. (Inherited from SqlUsersStorageProviderBase.)
 | UserAccountsReadOnly | Gets a value indicating whether user accounts are read-only. (Inherited from SqlUsersStorageProviderBase.)
 | UserGroupsReadOnly | Gets a value indicating whether user groups are read-only. If so, the provider should support default user groups as defined in the wiki configuration. (Inherited from SqlUsersStorageProviderBase.)
 | UsersDataReadOnly | Gets a value indicating whether users' data is read-only. (Inherited from SqlUsersStorageProviderBase.)
 | ValidateConnectionString(String) | Validates a connection string. (Overrides SqlStorageProviderBase.ValidateConnectionString(String).)
Inheritance Hierarchy
Object
 | SqlClassBase
 |  | SqlStorageProviderBase
 |  |  | SqlUsersStorageProviderBase
 |  |  |  | SqlServerUsersStorageProvider

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: SqlServerProviders (Module: SqlServerProviders) Version: 3.0.2.500 (3.0.2.500)


SqlServerUsersStorageProvider Constructor

SqlServerUsersStorageProvider Constructor
ScrewTurn Wiki ► ScrewTurn.Wiki.Plugins.SqlServer ► SqlServerUsersStorageProvider ► SqlServerUsersStorageProvider()()()
Initializes a new instance of the SqlServerUsersStorageProvider class
Declaration Syntax
C# Visual Basic Visual C++
public SqlServerUsersStorageProvider()
Public Sub New
public:
SqlServerUsersStorageProvider()

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: SqlServerProviders (Module: SqlServerProviders) Version: 3.0.2.500 (3.0.2.500)


ConfigHelpHtml Property

ConfigHelpHtml Property
ScrewTurn Wiki ► ScrewTurn.Wiki.Plugins.SqlServer ► SqlServerUsersStorageProvider ► ConfigHelpHtml
Gets a brief summary of the configuration string format, in HTML. Returns null if no configuration is needed.
Declaration Syntax
C# Visual Basic Visual C++
public override string ConfigHelpHtml { get; }
Public Overrides ReadOnly Property ConfigHelpHtml As String
public:
virtual property String^ ConfigHelpHtml {
    String^ get () override;
}

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: SqlServerProviders (Module: SqlServerProviders) Version: 3.0.2.500 (3.0.2.500)


CreateOrUpdateDatabaseIfNecessary Method

CreateOrUpdateDatabaseIfNecessary Method
ScrewTurn Wiki ► ScrewTurn.Wiki.Plugins.SqlServer ► SqlServerUsersStorageProvider ► CreateOrUpdateDatabaseIfNecessary()()()
Creates or updates the database schema if necessary.
Declaration Syntax
C# Visual Basic Visual C++
protected override void CreateOrUpdateDatabaseIfNecessary()
Protected Overrides Sub CreateOrUpdateDatabaseIfNecessary
protected:
virtual void CreateOrUpdateDatabaseIfNecessary() override

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: SqlServerProviders (Module: SqlServerProviders) Version: 3.0.2.500 (3.0.2.500)


GetCommandBuilder Method

GetCommandBuilder Method
ScrewTurn Wiki ► ScrewTurn.Wiki.Plugins.SqlServer ► SqlServerUsersStorageProvider ► GetCommandBuilder()()()
Gets a new command builder object.
Declaration Syntax
C# Visual Basic Visual C++
protected override ICommandBuilder GetCommandBuilder()
Protected Overrides Function GetCommandBuilder As ICommandBuilder
protected:
virtual ICommandBuilder^ GetCommandBuilder() override
Return Value
The command builder.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: SqlServerProviders (Module: SqlServerProviders) Version: 3.0.2.500 (3.0.2.500)


Information Property

Information Property
ScrewTurn Wiki ► ScrewTurn.Wiki.Plugins.SqlServer ► SqlServerUsersStorageProvider ► Information
Gets the Information about the Provider.
Declaration Syntax
C# Visual Basic Visual C++
public override ComponentInformation Information { get; }
Public Overrides ReadOnly Property Information As ComponentInformation
public:
virtual property ComponentInformation^ Information {
    ComponentInformation^ get () override;
}

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: SqlServerProviders (Module: SqlServerProviders) Version: 3.0.2.500 (3.0.2.500)


TryLoadSettingsStorageProviderConfiguration Method

TryLoadSettingsStorageProviderConfiguration Method
ScrewTurn Wiki ► ScrewTurn.Wiki.Plugins.SqlServer ► SqlServerUsersStorageProvider ► TryLoadSettingsStorageProviderConfiguration()()()
Tries to load the configuration of the corresponding settings storage provider.
Declaration Syntax
C# Visual Basic Visual C++
protected override string TryLoadSettingsStorageProviderConfiguration()
Protected Overrides Function TryLoadSettingsStorageProviderConfiguration As String
protected:
virtual String^ TryLoadSettingsStorageProviderConfiguration() override
Return Value
The configuration, or an empty string.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: SqlServerProviders (Module: SqlServerProviders) Version: 3.0.2.500 (3.0.2.500)


TryLoadV2Configuration Method

TryLoadV2Configuration Method
ScrewTurn Wiki ► ScrewTurn.Wiki.Plugins.SqlServer ► SqlServerUsersStorageProvider ► TryLoadV2Configuration()()()
Tries to load the configuration from a corresponding v2 provider.
Declaration Syntax
C# Visual Basic Visual C++
protected override string TryLoadV2Configuration()
Protected Overrides Function TryLoadV2Configuration As String
protected:
virtual String^ TryLoadV2Configuration() override
Return Value
The configuration, or an empty string.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: SqlServerProviders (Module: SqlServerProviders) Version: 3.0.2.500 (3.0.2.500)


ValidateConnectionString Method (connString)

ValidateConnectionString Method (connString)
ScrewTurn Wiki ► ScrewTurn.Wiki.Plugins.SqlServer ► SqlServerUsersStorageProvider ► ValidateConnectionString(String)
Validates a connection string.
Declaration Syntax
C# Visual Basic Visual C++
protected override void ValidateConnectionString(
    string connString
)
Protected Overrides Sub ValidateConnectionString ( _
    connString As String _
)
protected:
virtual void ValidateConnectionString(
    String^ connString
) override
Parameters
connString (String)
The connection string to validate.
Remarks
If the connection string is invalid, the method throws InvalidConfigurationException.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: SqlServerProviders (Module: SqlServerProviders) Version: 3.0.2.500 (3.0.2.500)


ScrewTurn.Wiki.SearchEngine Namespace

ScrewTurn.Wiki.SearchEngine Namespace
ScrewTurn Wiki ► ScrewTurn.Wiki.SearchEngine
Namespace containing Search Engine types.
Declaration Syntax
C# Visual Basic Visual C++
namespace ScrewTurn.Wiki.SearchEngine
Namespace ScrewTurn.Wiki.SearchEngine
namespace ScrewTurn.Wiki.SearchEngine
Types
All Types Classes Interfaces Enumerations Delegates
Icon | Type | Description
 | BasicWordInfo | Contains basic information about a word in a document.
 | BuildDocument | A delegate that is used for converting a DumpedDocument to an instance of a class implementing IDocument, while reading index data from a permanent storage.
 | DumpedChange | Represents a change occurred to the index, structured for easy dumping to disk or database.
 | DumpedDocument | Represents a document structured for easy dumped on disk or database.
 | DumpedWord | Represents a word structured for easy dumping to disk or database.
 | DumpedWordMapping | Contains a word mapping data, structured for easy dumping on disk or database.
 | IDocument | Defines the interface a generic document.
 | IIndex | Defines an interface for a search engine index.
 | IInMemoryIndex | Defines an interface for an in-memory index.
 | IndexChangedEventArgs | Contains arguments for the IndexChanged event of the IInMemoryIndex interface.
 | IndexChangeType | Lists valid index changes.
 | IndexStorerBase | Implements a base class for an index storer.
 | IndexStorerResult | Contains the results of an index storer operation.
 | InMemoryIndexBase | Implements a base class for the search index.
 | InMemoryIndexWordFetcher | Implements a word fetcher for use with the in-memory index.
 | IWordFetcher | Defines the interface for a component that fetches words.
 | OccurrenceDictionary | Implements a IDocument-SortedBasicWordInfo dictionary which treats IDocuments as value type.
 | Relevance | Represents the relevance of a search result with two states: non-finalized and finalized. When the state is non-finalized, the value of the relevance has an unknown meaning. When the state is finalized, the value of the relevance is a percentage value representing the relevance of a search result.
 | SearchOptions | Lists legal search options.
 | SearchParameters | Contains search parameters.
 | SearchResult | Represents a search result.
 | SearchResultCollection | Contains a collection of SearchResults, without duplicates.
 | SortedBasicWordInfoSet | Implements a sorted set of integers which can be accessed by index.
 | Tools | Implements useful methods.
 | Word | Represents a word in a document.
 | WordId | Describes the ID of a word.
 | WordInfo | Contains full information about a word in a document.
 | WordInfoCollection | Contains a collection of MatchInfo objects, sorted by index.
 | WordLocation | Describes the location of a word in a document.


BasicWordInfo Class

BasicWordInfo Class
ScrewTurn Wiki ► ScrewTurn.Wiki.SearchEngine ► BasicWordInfo
Contains basic information about a word in a document.
Declaration Syntax
C# Visual Basic Visual C++
public class BasicWordInfo : IEquatable<BasicWordInfo>,
    IComparable<BasicWordInfo>
Public Class BasicWordInfo _
    Implements IEquatable(Of BasicWordInfo), IComparable(Of BasicWordInfo)
public ref class BasicWordInfo : IEquatable<BasicWordInfo^>,
    IComparable<BasicWordInfo^>
Members
All Members | Constructors | Methods | Properties | Fields
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | BasicWordInfo(UInt16, UInt16, WordLocation) | Initializes a new instance of the BasicWordInfo class.
 | CompareTo(BasicWordInfo) | Compares the current instance with another instance.
 | Equality(BasicWordInfo, BasicWordInfo) | Applies the value-equality operator to two BasicWordInfo objects.
 | Equals(Object) | Determinates whether the current instance is equal to an instance of an object. (Overrides Object.Equals(Object).)
 | Equals(BasicWordInfo) | Determinates whether the current instance is value-equal to another.
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | firstCharIndex | The index in the original document the word starts at.
 | FirstCharIndex | Gets the index of the first character of the word in the document.
 | GetHashCode()()() | Gets the hash code of the current instance. (Overrides Object.GetHashCode()()().)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | Inequality(BasicWordInfo, BasicWordInfo) | Applies the value-inequality operator to two BasicWordInfo objects.
 | location | The location of the word in the document.
 | Location | Gets the location of the word in the document.
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | wordIndex | The index of the word in the document.
 | WordIndex | Gets the index of the word in the document.
Inheritance Hierarchy
Object
 | BasicWordInfo
 |  | WordInfo

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.SearchEngine (Module: ScrewTurn.Wiki.SearchEngine) Version: 3.0.2.500 (3.0.2.500)


BasicWordInfo Constructor (firstCharIndex, wordIndex, location)

BasicWordInfo Constructor (firstCharIndex, wordIndex, location)
ScrewTurn Wiki ► ScrewTurn.Wiki.SearchEngine ► BasicWordInfo ► BasicWordInfo(UInt16, UInt16, WordLocation)
Initializes a new instance of the BasicWordInfo class.
Declaration Syntax
C# Visual Basic Visual C++
public BasicWordInfo(
    ushort firstCharIndex,
    ushort wordIndex,
    WordLocation location
)
Public Sub New ( _
    firstCharIndex As UShort, _
    wordIndex As UShort, _
    location As WordLocation _
)
public:
BasicWordInfo(
    unsigned short firstCharIndex,
    unsigned short wordIndex,
    WordLocation^ location
)
Parameters
firstCharIndex (UInt16)
The index of the first character of the word in the document.
wordIndex (UInt16)
The index of the word in the document.
location (WordLocation)
The location of the word in the document.
Exceptions
Exception | Condition
ArgumentOutOfRangeException | If firstCharIndex or wordIndex are less than zero.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.SearchEngine (Module: ScrewTurn.Wiki.SearchEngine) Version: 3.0.2.500 (3.0.2.500)


CompareTo Method (other)

CompareTo Method (other)
ScrewTurn Wiki ► ScrewTurn.Wiki.SearchEngine ► BasicWordInfo ► CompareTo(BasicWordInfo)
Compares the current instance with another instance.
Declaration Syntax
C# Visual Basic Visual C++
public int CompareTo(
    BasicWordInfo other
)
Public Function CompareTo ( _
    other As BasicWordInfo _
) As Integer
public:
virtual int CompareTo(
    BasicWordInfo^ other
) sealed
Parameters
other (BasicWordInfo)
The other instance.
Return Value
The comparison result.
Remarks
The First Char Index does not partecipate to the comparison.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.SearchEngine (Module: ScrewTurn.Wiki.SearchEngine) Version: 3.0.2.500 (3.0.2.500)


Equality Operator

Equality Operator
ScrewTurn Wiki ► ScrewTurn.Wiki.SearchEngine ► BasicWordInfo ► Equality(BasicWordInfo, BasicWordInfo)
Applies the value-equality operator to two BasicWordInfo objects.
Declaration Syntax
C# Visual Basic Visual C++
public static bool operator ==(
    BasicWordInfo x,
    BasicWordInfo y
)
Public Shared Operator = ( _
    x As BasicWordInfo, _
    y As BasicWordInfo _
) As Boolean
public:
static bool operator ==(
    BasicWordInfo^ x,
    BasicWordInfo^ y
)
Parameters
x (BasicWordInfo)
The first object.
y (BasicWordInfo)
The second object.
Return Value
true if the objects are value-equal, false otherwise.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.SearchEngine (Module: ScrewTurn.Wiki.SearchEngine) Version: 3.0.2.500 (3.0.2.500)


Equals Method

Equals Method
ScrewTurn Wiki ► ScrewTurn.Wiki.SearchEngine ► BasicWordInfo ► Equals()()()
Members
Icon | Member | Description
 | Equals(Object) | Determinates whether the current instance is equal to an instance of an object. (Overrides Object.Equals(Object).)
 | Equals(BasicWordInfo) | Determinates whether the current instance is value-equal to another.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.SearchEngine (Module: ScrewTurn.Wiki.SearchEngine) Version: 3.0.2.500 (3.0.2.500)


Equals Method (other)

Equals Method (other)
ScrewTurn Wiki ► ScrewTurn.Wiki.SearchEngine ► BasicWordInfo ► Equals(BasicWordInfo)
Determinates whether the current instance is value-equal to another.
Declaration Syntax
C# Visual Basic Visual C++
public bool Equals(
    BasicWordInfo other
)
Public Function Equals ( _
    other As BasicWordInfo _
) As Boolean
public:
virtual bool Equals(
    BasicWordInfo^ other
) sealed
Parameters
other (BasicWordInfo)
The other instance.
Return Value
true if the instances are value-equal, false otherwise.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.SearchEngine (Module: ScrewTurn.Wiki.SearchEngine) Version: 3.0.2.500 (3.0.2.500)


Equals Method (other)

Equals Method (other)
ScrewTurn Wiki ► ScrewTurn.Wiki.SearchEngine ► BasicWordInfo ► Equals(Object)
Determinates whether the current instance is equal to an instance of an object.
Declaration Syntax
C# Visual Basic Visual C++
public override bool Equals(
    Object other
)
Public Overrides Function Equals ( _
    other As Object _
) As Boolean
public:
virtual bool Equals(
    Object^ other
) override
Parameters
other (Object)
The instance of the object.
Return Value
true if the instances are value-equal, false otherwise.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.SearchEngine (Module: ScrewTurn.Wiki.SearchEngine) Version: 3.0.2.500 (3.0.2.500)


firstCharIndex Field

firstCharIndex Field
ScrewTurn Wiki ► ScrewTurn.Wiki.SearchEngine ► BasicWordInfo ► firstCharIndex
The index in the original document the word starts at.
Declaration Syntax
C# Visual Basic Visual C++
protected ushort firstCharIndex
Protected firstCharIndex As UShort
protected:
unsigned short firstCharIndex

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.SearchEngine (Module: ScrewTurn.Wiki.SearchEngine) Version: 3.0.2.500 (3.0.2.500)


FirstCharIndex Property

FirstCharIndex Property
ScrewTurn Wiki ► ScrewTurn.Wiki.SearchEngine ► BasicWordInfo ► FirstCharIndex
Gets the index of the first character of the word in the document.
Declaration Syntax
C# Visual Basic Visual C++
public ushort FirstCharIndex { get; }
Public ReadOnly Property FirstCharIndex As UShort
public:
property unsigned short FirstCharIndex {
    unsigned short get ();
}

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.SearchEngine (Module: ScrewTurn.Wiki.SearchEngine) Version: 3.0.2.500 (3.0.2.500)


GetHashCode Method

GetHashCode Method
ScrewTurn Wiki ► ScrewTurn.Wiki.SearchEngine ► BasicWordInfo ► GetHashCode()()()
Gets the hash code of the current instance.
Declaration Syntax
C# Visual Basic Visual C++
public override int GetHashCode()
Public Overrides Function GetHashCode As Integer
public:
virtual int GetHashCode() override
Return Value
The hash code.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.SearchEngine (Module: ScrewTurn.Wiki.SearchEngine) Version: 3.0.2.500 (3.0.2.500)


Inequality Operator

Inequality Operator
ScrewTurn Wiki ► ScrewTurn.Wiki.SearchEngine ► BasicWordInfo ► Inequality(BasicWordInfo, BasicWordInfo)
Applies the value-inequality operator to two BasicWordInfo objects.
Declaration Syntax
C# Visual Basic Visual C++
public static bool operator !=(
    BasicWordInfo x,
    BasicWordInfo y
)
Public Shared Operator <> ( _
    x As BasicWordInfo, _
    y As BasicWordInfo _
) As Boolean
public:
static bool operator !=(
    BasicWordInfo^ x,
    BasicWordInfo^ y
)
Parameters
x (BasicWordInfo)
The first object.
y (BasicWordInfo)
The second object.
Return Value
true if the objects are not value-equal, false otherwise.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.SearchEngine (Module: ScrewTurn.Wiki.SearchEngine) Version: 3.0.2.500 (3.0.2.500)


location Field

location Field
ScrewTurn Wiki ► ScrewTurn.Wiki.SearchEngine ► BasicWordInfo ► location
The location of the word in the document.
Declaration Syntax
C# Visual Basic Visual C++
protected WordLocation location
Protected location As WordLocation
protected:
WordLocation^ location

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.SearchEngine (Module: ScrewTurn.Wiki.SearchEngine) Version: 3.0.2.500 (3.0.2.500)


Location Property

Location Property
ScrewTurn Wiki ► ScrewTurn.Wiki.SearchEngine ► BasicWordInfo ► Location
Gets the location of the word in the document.
Declaration Syntax
C# Visual Basic Visual C++
public WordLocation Location { get; }
Public ReadOnly Property Location As WordLocation
public:
property WordLocation^ Location {
    WordLocation^ get ();
}

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.SearchEngine (Module: ScrewTurn.Wiki.SearchEngine) Version: 3.0.2.500 (3.0.2.500)


wordIndex Field

wordIndex Field
ScrewTurn Wiki ► ScrewTurn.Wiki.SearchEngine ► BasicWordInfo ► wordIndex
The index of the word in the document.
Declaration Syntax
C# Visual Basic Visual C++
protected ushort wordIndex
Protected wordIndex As UShort
protected:
unsigned short wordIndex

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.SearchEngine (Module: ScrewTurn.Wiki.SearchEngine) Version: 3.0.2.500 (3.0.2.500)


WordIndex Property

WordIndex Property
ScrewTurn Wiki ► ScrewTurn.Wiki.SearchEngine ► BasicWordInfo ► WordIndex
Gets the index of the word in the document.
Declaration Syntax
C# Visual Basic Visual C++
public ushort WordIndex { get; }
Public ReadOnly Property WordIndex As UShort
public:
property unsigned short WordIndex {
    unsigned short get ();
}

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.SearchEngine (Module: ScrewTurn.Wiki.SearchEngine) Version: 3.0.2.500 (3.0.2.500)


BuildDocument Delegate

BuildDocument Delegate
ScrewTurn Wiki ► ScrewTurn.Wiki.SearchEngine ► BuildDocument
A delegate that is used for converting a DumpedDocument to an instance of a class implementing IDocument, while reading index data from a permanent storage.
Declaration Syntax
C# Visual Basic Visual C++
public delegate IDocument BuildDocument(
    DumpedDocument document
)
Public Delegate Function BuildDocument ( _
    document As DumpedDocument _
) As IDocument
public delegate IDocument^ BuildDocument(
    DumpedDocument^ document
)
Parameters
document (DumpedDocument)
The DumpedDocument to convert.
Return Value
The converted document implementing IDocument or null if no document is found.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.SearchEngine (Module: ScrewTurn.Wiki.SearchEngine) Version: 3.0.2.500 (3.0.2.500)


DumpedChange Class

DumpedChange Class
ScrewTurn Wiki ► ScrewTurn.Wiki.SearchEngine ► DumpedChange
Represents a change occurred to the index, structured for easy dumping to disk or database.
Declaration Syntax
C# Visual Basic Visual C++
public class DumpedChange
Public Class DumpedChange
public ref class DumpedChange
Members
All Members | Constructors | Methods | Properties | Fields
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | DumpedChange(DumpedDocument, List<(Of <(DumpedWord>)>), List<(Of <(DumpedWordMapping>)>)) | Initializes a new instance of the DumpedChange class.
 | document | The dumped document data.
 | Document | Gets the dumped document data.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | mappings | The list of dumped mappings data.
 | Mappings | Gets the list of dumped mappings data.
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | words | The list of dumped words data.
 | Words | Gets the list of dumped words data.
Remarks
The class is not thread-safe.
Inheritance Hierarchy
Object
DumpedChange

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.SearchEngine (Module: ScrewTurn.Wiki.SearchEngine) Version: 3.0.2.500 (3.0.2.500)


DumpedChange Constructor (document, words, mappings)

DumpedChange Constructor (document, words, mappings)
ScrewTurn Wiki ► ScrewTurn.Wiki.SearchEngine ► DumpedChange ► DumpedChange(DumpedDocument, List<(Of <(DumpedWord>)>), List<(Of <(DumpedWordMapping>)>))
Initializes a new instance of the DumpedChange class.
Declaration Syntax
C# Visual Basic Visual C++
public DumpedChange(
    DumpedDocument document,
    List<DumpedWord> words,
    List<DumpedWordMapping> mappings
)
Public Sub New ( _
    document As DumpedDocument, _
    words As List(Of DumpedWord), _
    mappings As List(Of DumpedWordMapping) _
)
public:
DumpedChange(
    DumpedDocument^ document,
    List<DumpedWord^>^ words,
    List<DumpedWordMapping^>^ mappings
)
Parameters
document (DumpedDocument)
The dumped document data.
words (List <(Of <(<' DumpedWord >)>)>)
The list of dumped words data.
mappings (List <(Of <(<' DumpedWordMapping >)>)>)
The list of dumped mappings data.
Exceptions
Exception | Condition
ArgumentNullException | If document, words or mappings are null.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.SearchEngine (Module: ScrewTurn.Wiki.SearchEngine) Version: 3.0.2.500 (3.0.2.500)


document Field

document Field
ScrewTurn Wiki ► ScrewTurn.Wiki.SearchEngine ► DumpedChange ► document
The dumped document data.
Declaration Syntax
C# Visual Basic Visual C++
protected DumpedDocument document
Protected document As DumpedDocument
protected:
DumpedDocument^ document

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.SearchEngine (Module: ScrewTurn.Wiki.SearchEngine) Version: 3.0.2.500 (3.0.2.500)


Document Property

Document Property
ScrewTurn Wiki ► ScrewTurn.Wiki.SearchEngine ► DumpedChange ► Document
Gets the dumped document data.
Declaration Syntax
C# Visual Basic Visual C++
public DumpedDocument Document { get; }
Public ReadOnly Property Document As DumpedDocument
public:
property DumpedDocument^ Document {
    DumpedDocument^ get ();
}

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.SearchEngine (Module: ScrewTurn.Wiki.SearchEngine) Version: 3.0.2.500 (3.0.2.500)


mappings Field

mappings Field
ScrewTurn Wiki ► ScrewTurn.Wiki.SearchEngine ► DumpedChange ► mappings
The list of dumped mappings data.
Declaration Syntax
C# Visual Basic Visual C++
protected List<DumpedWordMapping> mappings
Protected mappings As List(Of DumpedWordMapping)
protected:
List<DumpedWordMapping^>^ mappings

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.SearchEngine (Module: ScrewTurn.Wiki.SearchEngine) Version: 3.0.2.500 (3.0.2.500)


Mappings Property

Mappings Property
ScrewTurn Wiki ► ScrewTurn.Wiki.SearchEngine ► DumpedChange ► Mappings
Gets the list of dumped mappings data.
Declaration Syntax
C# Visual Basic Visual C++
public List<DumpedWordMapping> Mappings { get; }
Public ReadOnly Property Mappings As List(Of DumpedWordMapping)
public:
property List<DumpedWordMapping^>^ Mappings {
    List<DumpedWordMapping^>^ get ();
}

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.SearchEngine (Module: ScrewTurn.Wiki.SearchEngine) Version: 3.0.2.500 (3.0.2.500)


words Field

words Field
ScrewTurn Wiki ► ScrewTurn.Wiki.SearchEngine ► DumpedChange ► words
The list of dumped words data.
Declaration Syntax
C# Visual Basic Visual C++
protected List<DumpedWord> words
Protected words As List(Of DumpedWord)
protected:
List<DumpedWord^>^ words

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.SearchEngine (Module: ScrewTurn.Wiki.SearchEngine) Version: 3.0.2.500 (3.0.2.500)


Words Property

Words Property
ScrewTurn Wiki ► ScrewTurn.Wiki.SearchEngine ► DumpedChange ► Words
Gets the list of dumped words data.
Declaration Syntax
C# Visual Basic Visual C++
public List<DumpedWord> Words { get; }
Public ReadOnly Property Words As List(Of DumpedWord)
public:
property List<DumpedWord^>^ Words {
    List<DumpedWord^>^ get ();
}

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.SearchEngine (Module: ScrewTurn.Wiki.SearchEngine) Version: 3.0.2.500 (3.0.2.500)


DumpedDocument Class

DumpedDocument Class
ScrewTurn Wiki ► ScrewTurn.Wiki.SearchEngine ► DumpedDocument
Represents a document structured for easy dumped on disk or database.
Declaration Syntax
C# Visual Basic Visual C++
public class DumpedDocument
Public Class DumpedDocument
public ref class DumpedDocument
Members
All Members | Constructors | Methods | Properties | Fields
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | DumpedDocument(UInt32, String, String, String, DateTime) | Initializes a new instance of the DumpedDocument class.
 | DumpedDocument(IDocument) | Initializes a new instance of the DumpedDocument class.
 | dateTime | The document date/time.
 | DateTime | Gets the document date/time.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | id | The document unique ID.
 | ID | Gets or sets the document unique ID.
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | name | The document unique name.
 | Name | Gets the document unique name.
 | title | The document title.
 | Title | Gets the title of the document.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | typeTag | The document type tag.
 | TypeTag | Gets the document type tag.
Remarks
The class is not thread-safe.
Inheritance Hierarchy
Object
DumpedDocument

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.SearchEngine (Module: ScrewTurn.Wiki.SearchEngine) Version: 3.0.2.500 (3.0.2.500)


DumpedDocument Constructor

DumpedDocument Constructor
ScrewTurn Wiki ► ScrewTurn.Wiki.SearchEngine ► DumpedDocument ► DumpedDocument()()()
Members
Icon | Member | Description
 | DumpedDocument(UInt32, String, String, String, DateTime) | Initializes a new instance of the DumpedDocument class.
 | DumpedDocument(IDocument) | Initializes a new instance of the DumpedDocument class.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.SearchEngine (Module: ScrewTurn.Wiki.SearchEngine) Version: 3.0.2.500 (3.0.2.500)


DumpedDocument Constructor (document)

DumpedDocument Constructor (document)
ScrewTurn Wiki ► ScrewTurn.Wiki.SearchEngine ► DumpedDocument ► DumpedDocument(IDocument)
Initializes a new instance of the DumpedDocument class.
Declaration Syntax
C# Visual Basic Visual C++
public DumpedDocument(
    IDocument document
)
Public Sub New ( _
    document As IDocument _
)
public:
DumpedDocument(
    IDocument^ document
)
Parameters
document (IDocument)
The document do wrap for dumping.
Exceptions
Exception | Condition
ArgumentNullException | If document is null.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.SearchEngine (Module: ScrewTurn.Wiki.SearchEngine) Version: 3.0.2.500 (3.0.2.500)


DumpedDocument Constructor (id, name, title, typeTag, dateTime)

DumpedDocument Constructor (id, name, title, typeTag, dateTime)
ScrewTurn Wiki ► ScrewTurn.Wiki.SearchEngine ► DumpedDocument ► DumpedDocument(UInt32, String, String, String, DateTime)
Initializes a new instance of the DumpedDocument class.
Declaration Syntax
C# Visual Basic Visual C++
public DumpedDocument(
    uint id,
    string name,
    string title,
    string typeTag,
    DateTime dateTime
)
Public Sub New ( _
    id As UInteger, _
    name As String, _
    title As String, _
    typeTag As String, _
    dateTime As DateTime _
)
public:
DumpedDocument(
    unsigned int id,
    String^ name,
    String^ title,
    String^ typeTag,
    DateTime dateTime
)
Parameters
id (UInt32)
The document unique ID.
name (String)
The document unique name.
title (String)
The document title.
typeTag (String)
The document type tag.
dateTime (DateTime)
The document date/time.
Exceptions
Exception | Condition
ArgumentNullException | If name, title or typeTag are null.
ArgumentException | If name, title or typeTag are empty.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.SearchEngine (Module: ScrewTurn.Wiki.SearchEngine) Version: 3.0.2.500 (3.0.2.500)


dateTime Field

dateTime Field
ScrewTurn Wiki ► ScrewTurn.Wiki.SearchEngine ► DumpedDocument ► dateTime
The document date/time.
Declaration Syntax
C# Visual Basic Visual C++
protected DateTime dateTime
Protected dateTime As DateTime
protected:
DateTime dateTime

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.SearchEngine (Module: ScrewTurn.Wiki.SearchEngine) Version: 3.0.2.500 (3.0.2.500)


DateTime Property

DateTime Property
ScrewTurn Wiki ► ScrewTurn.Wiki.SearchEngine ► DumpedDocument ► DateTime
Gets the document date/time.
Declaration Syntax
C# Visual Basic Visual C++
public DateTime DateTime { get; }
Public ReadOnly Property DateTime As DateTime
public:
property DateTime DateTime {
    DateTime get ();
}

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.SearchEngine (Module: ScrewTurn.Wiki.SearchEngine) Version: 3.0.2.500 (3.0.2.500)


id Field

id Field
ScrewTurn Wiki ► ScrewTurn.Wiki.SearchEngine ► DumpedDocument ► id
The document unique ID.
Declaration Syntax
C# Visual Basic Visual C++
protected uint id
Protected id As UInteger
protected:
unsigned int id

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.SearchEngine (Module: ScrewTurn.Wiki.SearchEngine) Version: 3.0.2.500 (3.0.2.500)


ID Property

ID Property
ScrewTurn Wiki ► ScrewTurn.Wiki.SearchEngine ► DumpedDocument ► ID
Gets or sets the document unique ID.
Declaration Syntax
C# Visual Basic Visual C++
public uint ID { get; set; }
Public Property ID As UInteger
public:
property unsigned int ID {
    unsigned int get ();
    void set (unsigned int value);
}

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.SearchEngine (Module: ScrewTurn.Wiki.SearchEngine) Version: 3.0.2.500 (3.0.2.500)


name Field

name Field
ScrewTurn Wiki ► ScrewTurn.Wiki.SearchEngine ► DumpedDocument ► name
The document unique name.
Declaration Syntax
C# Visual Basic Visual C++
protected string name
Protected name As String
protected:
String^ name

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.SearchEngine (Module: ScrewTurn.Wiki.SearchEngine) Version: 3.0.2.500 (3.0.2.500)


Name Property

Name Property
ScrewTurn Wiki ► ScrewTurn.Wiki.SearchEngine ► DumpedDocument ► Name
Gets the document unique name.
Declaration Syntax
C# Visual Basic Visual C++
public string Name { get; }
Public ReadOnly Property Name As String
public:
property String^ Name {
    String^ get ();
}

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.SearchEngine (Module: ScrewTurn.Wiki.SearchEngine) Version: 3.0.2.500 (3.0.2.500)


title Field

title Field
ScrewTurn Wiki ► ScrewTurn.Wiki.SearchEngine ► DumpedDocument ► title
The document title.
Declaration Syntax
C# Visual Basic Visual C++
protected string title
Protected title As String
protected:
String^ title

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.SearchEngine (Module: ScrewTurn.Wiki.SearchEngine) Version: 3.0.2.500 (3.0.2.500)


Title Property

Title Property
ScrewTurn Wiki ► ScrewTurn.Wiki.SearchEngine ► DumpedDocument ► Title
Gets the title of the document.
Declaration Syntax
C# Visual Basic Visual C++
public string Title { get; }
Public ReadOnly Property Title As String
public:
property String^ Title {
    String^ get ();
}

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.SearchEngine (Module: ScrewTurn.Wiki.SearchEngine) Version: 3.0.2.500 (3.0.2.500)


typeTag Field

typeTag Field
ScrewTurn Wiki ► ScrewTurn.Wiki.SearchEngine ► DumpedDocument ► typeTag
The document type tag.
Declaration Syntax
C# Visual Basic Visual C++
protected string typeTag
Protected typeTag As String
protected:
String^ typeTag

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.SearchEngine (Module: ScrewTurn.Wiki.SearchEngine) Version: 3.0.2.500 (3.0.2.500)


TypeTag Property

TypeTag Property
ScrewTurn Wiki ► ScrewTurn.Wiki.SearchEngine ► DumpedDocument ► TypeTag
Gets the document type tag.
Declaration Syntax
C# Visual Basic Visual C++
public string TypeTag { get; }
Public ReadOnly Property TypeTag As String
public:
property String^ TypeTag {
    String^ get ();
}

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.SearchEngine (Module: ScrewTurn.Wiki.SearchEngine) Version: 3.0.2.500 (3.0.2.500)


DumpedWord Class

DumpedWord Class
ScrewTurn Wiki ► ScrewTurn.Wiki.SearchEngine ► DumpedWord
Represents a word structured for easy dumping to disk or database.
Declaration Syntax
C# Visual Basic Visual C++
public class DumpedWord
Public Class DumpedWord
public ref class DumpedWord
Members
All Members | Constructors | Methods | Properties | Fields
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | DumpedWord(UInt32, String) | Initializes a new instance of the DumpedWord class.
 | DumpedWord(Word) | Initializes a new instance of the DumpedWord class.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | id | The word unique ID.
 | ID | Gets or sets the word unique ID.
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | text | The word culture-invariant lowercase text.
 | Text | Gets the word culture-invariant lowercase text.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Remarks
The class is not thread-safe.
Inheritance Hierarchy
Object
DumpedWord

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.SearchEngine (Module: ScrewTurn.Wiki.SearchEngine) Version: 3.0.2.500 (3.0.2.500)


DumpedWord Constructor

DumpedWord Constructor
ScrewTurn Wiki ► ScrewTurn.Wiki.SearchEngine ► DumpedWord ► DumpedWord()()()
Members
Icon | Member | Description
 | DumpedWord(UInt32, String) | Initializes a new instance of the DumpedWord class.
 | DumpedWord(Word) | Initializes a new instance of the DumpedWord class.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.SearchEngine (Module: ScrewTurn.Wiki.SearchEngine) Version: 3.0.2.500 (3.0.2.500)


DumpedWord Constructor (word)

DumpedWord Constructor (word)
ScrewTurn Wiki ► ScrewTurn.Wiki.SearchEngine ► DumpedWord ► DumpedWord(Word)
Initializes a new instance of the DumpedWord class.
Declaration Syntax
C# Visual Basic Visual C++
public DumpedWord(
    Word word
)
Public Sub New ( _
    word As Word _
)
public:
DumpedWord(
    Word^ word
)
Parameters
word (Word)
The word to extract the information from.
Exceptions
Exception | Condition
ArgumentNullException | If word is null.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.SearchEngine (Module: ScrewTurn.Wiki.SearchEngine) Version: 3.0.2.500 (3.0.2.500)


DumpedWord Constructor (id, text)

DumpedWord Constructor (id, text)
ScrewTurn Wiki ► ScrewTurn.Wiki.SearchEngine ► DumpedWord ► DumpedWord(UInt32, String)
Initializes a new instance of the DumpedWord class.
Declaration Syntax
C# Visual Basic Visual C++
public DumpedWord(
    uint id,
    string text
)
Public Sub New ( _
    id As UInteger, _
    text As String _
)
public:
DumpedWord(
    unsigned int id,
    String^ text
)
Parameters
id (UInt32)
The unique word ID.
text (String)
The word culture-invariant lowercase text.
Exceptions
Exception | Condition
ArgumentNullException | If text is null.
ArgumentException | If text is empty.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.SearchEngine (Module: ScrewTurn.Wiki.SearchEngine) Version: 3.0.2.500 (3.0.2.500)


id Field

id Field
ScrewTurn Wiki ► ScrewTurn.Wiki.SearchEngine ► DumpedWord ► id
The word unique ID.
Declaration Syntax
C# Visual Basic Visual C++
protected uint id
Protected id As UInteger
protected:
unsigned int id

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.SearchEngine (Module: ScrewTurn.Wiki.SearchEngine) Version: 3.0.2.500 (3.0.2.500)


ID Property

ID Property
ScrewTurn Wiki ► ScrewTurn.Wiki.SearchEngine ► DumpedWord ► ID
Gets or sets the word unique ID.
Declaration Syntax
C# Visual Basic Visual C++
public uint ID { get; set; }
Public Property ID As UInteger
public:
property unsigned int ID {
    unsigned int get ();
    void set (unsigned int value);
}

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.SearchEngine (Module: ScrewTurn.Wiki.SearchEngine) Version: 3.0.2.500 (3.0.2.500)


text Field

text Field
ScrewTurn Wiki ► ScrewTurn.Wiki.SearchEngine ► DumpedWord ► text
The word culture-invariant lowercase text.
Declaration Syntax
C# Visual Basic Visual C++
protected string text
Protected text As String
protected:
String^ text

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.SearchEngine (Module: ScrewTurn.Wiki.SearchEngine) Version: 3.0.2.500 (3.0.2.500)


Text Property

Text Property
ScrewTurn Wiki ► ScrewTurn.Wiki.SearchEngine ► DumpedWord ► Text
Gets the word culture-invariant lowercase text.
Declaration Syntax
C# Visual Basic Visual C++
public string Text { get; }
Public ReadOnly Property Text As String
public:
property String^ Text {
    String^ get ();
}

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.SearchEngine (Module: ScrewTurn.Wiki.SearchEngine) Version: 3.0.2.500 (3.0.2.500)


DumpedWordMapping Class

DumpedWordMapping Class
ScrewTurn Wiki ► ScrewTurn.Wiki.SearchEngine ► DumpedWordMapping
Contains a word mapping data, structured for easy dumping on disk or database.
Declaration Syntax
C# Visual Basic Visual C++
public class DumpedWordMapping
Public Class DumpedWordMapping
public ref class DumpedWordMapping
Members
All Members | Constructors | Methods | Properties | Fields
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | DumpedWordMapping(UInt32, UInt32, UInt16, UInt16, Byte) | Initializes a new instance of the DumpedWordMapping class.
 | DumpedWordMapping(UInt32, UInt32, BasicWordInfo) | Initializes a new instance of the DumpedWordMapping class.
 | documentId | The document unique ID.
 | DocumentID | Gets the document unique ID.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | firstCharIndex | The index of the character of the word.
 | FirstCharIndex | Gets the index of the first character of the word.
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | location | The location identifier.
 | Location | Gets the location identifier.
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | wordId | The word unique ID.
 | WordID | Gets or sets the word unique ID.
 | wordIndex | The index of the word in the original document.
 | WordIndex | Gets the index of the word in the original document.
Remarks
The class is not thread-safe.
Inheritance Hierarchy
Object
DumpedWordMapping

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.SearchEngine (Module: ScrewTurn.Wiki.SearchEngine) Version: 3.0.2.500 (3.0.2.500)


DumpedWordMapping Constructor

DumpedWordMapping Constructor
ScrewTurn Wiki ► ScrewTurn.Wiki.SearchEngine ► DumpedWordMapping ► DumpedWordMapping()()()
Members
Icon | Member | Description
 | DumpedWordMapping(UInt32, UInt32, UInt16, UInt16, Byte) | Initializes a new instance of the DumpedWordMapping class.
 | DumpedWordMapping(UInt32, UInt32, BasicWordInfo) | Initializes a new instance of the DumpedWordMapping class.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.SearchEngine (Module: ScrewTurn.Wiki.SearchEngine) Version: 3.0.2.500 (3.0.2.500)


DumpedWordMapping Constructor (wordId, documentId, info)

DumpedWordMapping Constructor (wordId, documentId, info)
ScrewTurn Wiki ► ScrewTurn.Wiki.SearchEngine ► DumpedWordMapping ► DumpedWordMapping(UInt32, UInt32, BasicWordInfo)
Initializes a new instance of the DumpedWordMapping class.
Declaration Syntax
C# Visual Basic Visual C++
public DumpedWordMapping(
    uint wordId,
    uint documentId,
    BasicWordInfo info
)
Public Sub New ( _
    wordId As UInteger, _
    documentId As UInteger, _
    info As BasicWordInfo _
)
public:
DumpedWordMapping(
    unsigned int wordId,
    unsigned int documentId,
    BasicWordInfo^ info
)
Parameters
wordId (UInt32)
The word unique ID.
documentId (UInt32)
The document unique ID.
info (BasicWordInfo)
The BasicWordInfo.
Exceptions
Exception | Condition
ArgumentNullException | If info is null.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.SearchEngine (Module: ScrewTurn.Wiki.SearchEngine) Version: 3.0.2.500 (3.0.2.500)


DumpedWordMapping Constructor (wordId, documentId, firstCharIndex, wordIndex, location)

DumpedWordMapping Constructor (wordId, documentId, firstCharIndex, wordIndex, location)
ScrewTurn Wiki ► ScrewTurn.Wiki.SearchEngine ► DumpedWordMapping ► DumpedWordMapping(UInt32, UInt32, UInt16, UInt16, Byte)
Initializes a new instance of the DumpedWordMapping class.
Declaration Syntax
C# Visual Basic Visual C++
public DumpedWordMapping(
    uint wordId,
    uint documentId,
    ushort firstCharIndex,
    ushort wordIndex,
    byte location
)
Public Sub New ( _
    wordId As UInteger, _
    documentId As UInteger, _
    firstCharIndex As UShort, _
    wordIndex As UShort, _
    location As Byte _
)
public:
DumpedWordMapping(
    unsigned int wordId,
    unsigned int documentId,
    unsigned short firstCharIndex,
    unsigned short wordIndex,
    unsigned char location
)
Parameters
wordId (UInt32)
The word unique ID.
documentId (UInt32)
The document unique ID.
firstCharIndex (UInt16)
The index of the first character the word.
wordIndex (UInt16)
The index of the word in the original index.
location (Byte)
The location identifier.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.SearchEngine (Module: ScrewTurn.Wiki.SearchEngine) Version: 3.0.2.500 (3.0.2.500)


documentId Field

documentId Field
ScrewTurn Wiki ► ScrewTurn.Wiki.SearchEngine ► DumpedWordMapping ► documentId
The document unique ID.
Declaration Syntax
C# Visual Basic Visual C++
protected uint documentId
Protected documentId As UInteger
protected:
unsigned int documentId

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.SearchEngine (Module: ScrewTurn.Wiki.SearchEngine) Version: 3.0.2.500 (3.0.2.500)


DocumentID Property

DocumentID Property
ScrewTurn Wiki ► ScrewTurn.Wiki.SearchEngine ► DumpedWordMapping ► DocumentID
Gets the document unique ID.
Declaration Syntax
C# Visual Basic Visual C++
public uint DocumentID { get; }
Public ReadOnly Property DocumentID As UInteger
public:
property unsigned int DocumentID {
    unsigned int get ();
}

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.SearchEngine (Module: ScrewTurn.Wiki.SearchEngine) Version: 3.0.2.500 (3.0.2.500)


firstCharIndex Field

firstCharIndex Field
ScrewTurn Wiki ► ScrewTurn.Wiki.SearchEngine ► DumpedWordMapping ► firstCharIndex
The index of the character of the word.
Declaration Syntax
C# Visual Basic Visual C++
protected ushort firstCharIndex
Protected firstCharIndex As UShort
protected:
unsigned short firstCharIndex

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.SearchEngine (Module: ScrewTurn.Wiki.SearchEngine) Version: 3.0.2.500 (3.0.2.500)


FirstCharIndex Property

FirstCharIndex Property
ScrewTurn Wiki ► ScrewTurn.Wiki.SearchEngine ► DumpedWordMapping ► FirstCharIndex
Gets the index of the first character of the word.
Declaration Syntax
C# Visual Basic Visual C++
public ushort FirstCharIndex { get; }
Public ReadOnly Property FirstCharIndex As UShort
public:
property unsigned short FirstCharIndex {
    unsigned short get ();
}

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.SearchEngine (Module: ScrewTurn.Wiki.SearchEngine) Version: 3.0.2.500 (3.0.2.500)


location Field

location Field
ScrewTurn Wiki ► ScrewTurn.Wiki.SearchEngine ► DumpedWordMapping ► location
The location identifier.
Declaration Syntax
C# Visual Basic Visual C++
protected byte location
Protected location As Byte
protected:
unsigned char location

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.SearchEngine (Module: ScrewTurn.Wiki.SearchEngine) Version: 3.0.2.500 (3.0.2.500)


Location Property

Location Property
ScrewTurn Wiki ► ScrewTurn.Wiki.SearchEngine ► DumpedWordMapping ► Location
Gets the location identifier.
Declaration Syntax
C# Visual Basic Visual C++
public byte Location { get; }
Public ReadOnly Property Location As Byte
public:
property unsigned char Location {
    unsigned char get ();
}

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.SearchEngine (Module: ScrewTurn.Wiki.SearchEngine) Version: 3.0.2.500 (3.0.2.500)


wordId Field

wordId Field
ScrewTurn Wiki ► ScrewTurn.Wiki.SearchEngine ► DumpedWordMapping ► wordId
The word unique ID.
Declaration Syntax
C# Visual Basic Visual C++
protected uint wordId
Protected wordId As UInteger
protected:
unsigned int wordId

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.SearchEngine (Module: ScrewTurn.Wiki.SearchEngine) Version: 3.0.2.500 (3.0.2.500)


WordID Property

WordID Property
ScrewTurn Wiki ► ScrewTurn.Wiki.SearchEngine ► DumpedWordMapping ► WordID
Gets or sets the word unique ID.
Declaration Syntax
C# Visual Basic Visual C++
public uint WordID { get; set; }
Public Property WordID As UInteger
public:
property unsigned int WordID {
    unsigned int get ();
    void set (unsigned int value);
}

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.SearchEngine (Module: ScrewTurn.Wiki.SearchEngine) Version: 3.0.2.500 (3.0.2.500)


wordIndex Field

wordIndex Field
ScrewTurn Wiki ► ScrewTurn.Wiki.SearchEngine ► DumpedWordMapping ► wordIndex
The index of the word in the original document.
Declaration Syntax
C# Visual Basic Visual C++
protected ushort wordIndex
Protected wordIndex As UShort
protected:
unsigned short wordIndex

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.SearchEngine (Module: ScrewTurn.Wiki.SearchEngine) Version: 3.0.2.500 (3.0.2.500)


WordIndex Property

WordIndex Property
ScrewTurn Wiki ► ScrewTurn.Wiki.SearchEngine ► DumpedWordMapping ► WordIndex
Gets the index of the word in the original document.
Declaration Syntax
C# Visual Basic Visual C++
public ushort WordIndex { get; }
Public ReadOnly Property WordIndex As UShort
public:
property unsigned short WordIndex {
    unsigned short get ();
}

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.SearchEngine (Module: ScrewTurn.Wiki.SearchEngine) Version: 3.0.2.500 (3.0.2.500)


IDocument Interface

IDocument Interface
ScrewTurn Wiki ► ScrewTurn.Wiki.SearchEngine ► IDocument
Defines the interface a generic document.
Declaration Syntax
C# Visual Basic Visual C++
public interface IDocument
Public Interface IDocument
public interface class IDocument
Members
All Members | Methods | Properties
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | DateTime | Gets the document date/time.
 | ID | Gets or sets the globally unique ID of the document.
 | Name | Gets the globally-unique name of the document.
 | Title | Gets the title of the document, if any.
 | Tokenize(String) | Performs the tokenization of the document content.
 | TypeTag | Gets the tag for the document type.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.SearchEngine (Module: ScrewTurn.Wiki.SearchEngine) Version: 3.0.2.500 (3.0.2.500)


DateTime Property

DateTime Property
ScrewTurn Wiki ► ScrewTurn.Wiki.SearchEngine ► IDocument ► DateTime
Gets the document date/time.
Declaration Syntax
C# Visual Basic Visual C++
DateTime DateTime { get; }
ReadOnly Property DateTime As DateTime
property DateTime DateTime {
    DateTime get ();
}

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.SearchEngine (Module: ScrewTurn.Wiki.SearchEngine) Version: 3.0.2.500 (3.0.2.500)


ID Property

ID Property
ScrewTurn Wiki ► ScrewTurn.Wiki.SearchEngine ► IDocument ► ID
Gets or sets the globally unique ID of the document.
Declaration Syntax
C# Visual Basic Visual C++
uint ID { get; set; }
Property ID As UInteger
property unsigned int ID {
    unsigned int get ();
    void set (unsigned int value);
}

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.SearchEngine (Module: ScrewTurn.Wiki.SearchEngine) Version: 3.0.2.500 (3.0.2.500)


Name Property

Name Property
ScrewTurn Wiki ► ScrewTurn.Wiki.SearchEngine ► IDocument ► Name
Gets the globally-unique name of the document.
Declaration Syntax
C# Visual Basic Visual C++
string Name { get; }
ReadOnly Property Name As String
property String^ Name {
    String^ get ();
}

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.SearchEngine (Module: ScrewTurn.Wiki.SearchEngine) Version: 3.0.2.500 (3.0.2.500)


Title Property

Title Property
ScrewTurn Wiki ► ScrewTurn.Wiki.SearchEngine ► IDocument ► Title
Gets the title of the document, if any.
Declaration Syntax
C# Visual Basic Visual C++
string Title { get; }
ReadOnly Property Title As String
property String^ Title {
    String^ get ();
}

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.SearchEngine (Module: ScrewTurn.Wiki.SearchEngine) Version: 3.0.2.500 (3.0.2.500)


Tokenize Method (content)

Tokenize Method (content)
ScrewTurn Wiki ► ScrewTurn.Wiki.SearchEngine ► IDocument ► Tokenize(String)
Performs the tokenization of the document content.
Declaration Syntax
C# Visual Basic Visual C++
WordInfo[] Tokenize(
    string content
)
Function Tokenize ( _
    content As String _
) As WordInfo()
array<WordInfo^>^ Tokenize(
    String^ content
)
Parameters
content (String)
The content to tokenize.
Return Value
The extracted words and their positions.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.SearchEngine (Module: ScrewTurn.Wiki.SearchEngine) Version: 3.0.2.500 (3.0.2.500)


TypeTag Property

TypeTag Property
ScrewTurn Wiki ► ScrewTurn.Wiki.SearchEngine ► IDocument ► TypeTag
Gets the tag for the document type.
Declaration Syntax
C# Visual Basic Visual C++
string TypeTag { get; }
ReadOnly Property TypeTag As String
property String^ TypeTag {
    String^ get ();
}

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.SearchEngine (Module: ScrewTurn.Wiki.SearchEngine) Version: 3.0.2.500 (3.0.2.500)


IIndex Interface

IIndex Interface
ScrewTurn Wiki ► ScrewTurn.Wiki.SearchEngine ► IIndex
Defines an interface for a search engine index.
Declaration Syntax
C# Visual Basic Visual C++
public interface IIndex
Public Interface IIndex
public interface class IIndex
Members
All Members | Methods | Properties
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | Clear(Object) | Completely clears the index (stop words are not affected).
 | RemoveDocument(IDocument, Object) | Removes a document from the index.
 | Search(SearchParameters) | Performs a search in the index.
 | StopWords | Gets or sets the stop words to be used while indexing new content.
 | StoreDocument(IDocument, array<String>[]()[], String, Object) | Stores a document in the index.
 | TotalDocuments | Gets the total count of documents.
 | TotalOccurrences | Gets the total number of occurrences (count of words in each document).
 | TotalWords | Gets the total count of unique words.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.SearchEngine (Module: ScrewTurn.Wiki.SearchEngine) Version: 3.0.2.500 (3.0.2.500)


Clear Method (state)

Clear Method (state)
ScrewTurn Wiki ► ScrewTurn.Wiki.SearchEngine ► IIndex ► Clear(Object)
Completely clears the index (stop words are not affected).
Declaration Syntax
C# Visual Basic Visual C++
void Clear(
    Object state
)
Sub Clear ( _
    state As Object _
)
void Clear(
    Object^ state
)
Parameters
state (Object)
A state object that is passed to the IndexStorer SaveDate/DeleteData function.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.SearchEngine (Module: ScrewTurn.Wiki.SearchEngine) Version: 3.0.2.500 (3.0.2.500)


RemoveDocument Method (document, state)

RemoveDocument Method (document, state)
ScrewTurn Wiki ► ScrewTurn.Wiki.SearchEngine ► IIndex ► RemoveDocument(IDocument, Object)
Removes a document from the index.
Declaration Syntax
C# Visual Basic Visual C++
void RemoveDocument(
    IDocument document,
    Object state
)
Sub RemoveDocument ( _
    document As IDocument, _
    state As Object _
)
void RemoveDocument(
    IDocument^ document,
    Object^ state
)
Parameters
document (IDocument)
The document to remove.
state (Object)
A state object that is passed to the IndexStorer SaveDate/DeleteData function.
Exceptions
Exception | Condition
ArgumentNullException | If document is null.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.SearchEngine (Module: ScrewTurn.Wiki.SearchEngine) Version: 3.0.2.500 (3.0.2.500)


Search Method (parameters)

Search Method (parameters)
ScrewTurn Wiki ► ScrewTurn.Wiki.SearchEngine ► IIndex ► Search(SearchParameters)
Performs a search in the index.
Declaration Syntax
C# Visual Basic Visual C++
SearchResultCollection Search(
    SearchParameters parameters
)
Function Search ( _
    parameters As SearchParameters _
) As SearchResultCollection
SearchResultCollection^ Search(
    SearchParameters^ parameters
)
Parameters
parameters (SearchParameters)
The search parameters.
Return Value
The results.
Exceptions
Exception | Condition
ArgumentNullException | If parameters is null.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.SearchEngine (Module: ScrewTurn.Wiki.SearchEngine) Version: 3.0.2.500 (3.0.2.500)


StopWords Property

StopWords Property
ScrewTurn Wiki ► ScrewTurn.Wiki.SearchEngine ► IIndex ► StopWords
Gets or sets the stop words to be used while indexing new content.
Declaration Syntax
C# Visual Basic Visual C++
string[] StopWords { get; set; }
Property StopWords As String()
property array<String^>^ StopWords {
    array<String^>^ get ();
    void set (array<String^>^ value);
}

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.SearchEngine (Module: ScrewTurn.Wiki.SearchEngine) Version: 3.0.2.500 (3.0.2.500)


StoreDocument Method (document, keywords, content, state)

StoreDocument Method (document, keywords, content, state)
ScrewTurn Wiki ► ScrewTurn.Wiki.SearchEngine ► IIndex ► StoreDocument(IDocument, array<String>[]()[], String, Object)
Stores a document in the index.
Declaration Syntax
C# Visual Basic Visual C++
int StoreDocument(
    IDocument document,
    string[] keywords,
    string content,
    Object state
)
Function StoreDocument ( _
    document As IDocument, _
    keywords As String(), _
    content As String, _
    state As Object _
) As Integer
int StoreDocument(
    IDocument^ document,
    array<String^>^ keywords,
    String^ content,
    Object^ state
)
Parameters
document (IDocument)
The document.
keywords (array< String >[]()[][])
The document keywords, if any, an empty array or null otherwise.
content (String)
The content of the document.
state (Object)
A state object that is passed to the IndexStorer SaveDate/DeleteData function.
Return Value
The number of indexed words (including duplicates).
Remarks
Indexing the content of the document is O(n), where n is the total number of words in the document.
Exceptions
Exception | Condition
ArgumentNullException | If document or content are null.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.SearchEngine (Module: ScrewTurn.Wiki.SearchEngine) Version: 3.0.2.500 (3.0.2.500)


TotalDocuments Property

TotalDocuments Property
ScrewTurn Wiki ► ScrewTurn.Wiki.SearchEngine ► IIndex ► TotalDocuments
Gets the total count of documents.
Declaration Syntax
C# Visual Basic Visual C++
int TotalDocuments { get; }
ReadOnly Property TotalDocuments As Integer
property int TotalDocuments {
    int get ();
}
Remarks
Computing the result is O(n*m), where n is the number of words in the index and m is the number of documents.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.SearchEngine (Module: ScrewTurn.Wiki.SearchEngine) Version: 3.0.2.500 (3.0.2.500)


TotalOccurrences Property

TotalOccurrences Property
ScrewTurn Wiki ► ScrewTurn.Wiki.SearchEngine ► IIndex ► TotalOccurrences
Gets the total number of occurrences (count of words in each document).
Declaration Syntax
C# Visual Basic Visual C++
int TotalOccurrences { get; }
ReadOnly Property TotalOccurrences As Integer
property int TotalOccurrences {
    int get ();
}
Remarks
Computing the result is O(n), where n is the number of words in the index.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.SearchEngine (Module: ScrewTurn.Wiki.SearchEngine) Version: 3.0.2.500 (3.0.2.500)


TotalWords Property

TotalWords Property
ScrewTurn Wiki ► ScrewTurn.Wiki.SearchEngine ► IIndex ► TotalWords
Gets the total count of unique words.
Declaration Syntax
C# Visual Basic Visual C++
int TotalWords { get; }
ReadOnly Property TotalWords As Integer
property int TotalWords {
    int get ();
}
Remarks
Computing the result is O(1).

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.SearchEngine (Module: ScrewTurn.Wiki.SearchEngine) Version: 3.0.2.500 (3.0.2.500)


IInMemoryIndex Interface

IInMemoryIndex Interface
ScrewTurn Wiki ► ScrewTurn.Wiki.SearchEngine ► IInMemoryIndex
Defines an interface for an in-memory index.
Declaration Syntax
C# Visual Basic Visual C++
public interface IInMemoryIndex : IIndex
Public Interface IInMemoryIndex _
    Implements IIndex
public interface class IInMemoryIndex : IIndex
Members
All Members | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | Clear(Object) | Completely clears the index (stop words are not affected). (Inherited from IIndex.)
 | IndexChanged | An event fired when the index is changed.
 | InitializeData(array<DumpedDocument>[]()[], array<DumpedWord>[]()[], array<DumpedWordMapping>[]()[]) | Initializes index data by completely emptying the index catalog and storing the specified data.
 | RemoveDocument(IDocument, Object) | Removes a document from the index. (Inherited from IIndex.)
 | Search(SearchParameters) | Performs a search in the index. (Inherited from IIndex.)
 | SetBuildDocumentDelegate(BuildDocument) | Sets the delegate used for converting a DumpedDocument to an instance of a class implementing IDocument, while reading index data from a permanent storage.
 | StopWords | Gets or sets the stop words to be used while indexing new content. (Inherited from IIndex.)
 | StoreDocument(IDocument, array<String>[]()[], String, Object) | Stores a document in the index. (Inherited from IIndex.)
 | TotalDocuments | Gets the total count of documents. (Inherited from IIndex.)
 | TotalOccurrences | Gets the total number of occurrences (count of words in each document). (Inherited from IIndex.)
 | TotalWords | Gets the total count of unique words. (Inherited from IIndex.)

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.SearchEngine (Module: ScrewTurn.Wiki.SearchEngine) Version: 3.0.2.500 (3.0.2.500)


IndexChanged Event

IndexChanged Event
ScrewTurn Wiki ► ScrewTurn.Wiki.SearchEngine ► IInMemoryIndex ► IndexChanged
An event fired when the index is changed.
Declaration Syntax
C# Visual Basic Visual C++
event EventHandler<IndexChangedEventArgs> IndexChanged
Event IndexChanged As EventHandler(Of IndexChangedEventArgs)
 event EventHandler<IndexChangedEventArgs^>^ IndexChanged {
    void add (EventHandler<IndexChangedEventArgs^>^ value);
    void remove (EventHandler<IndexChangedEventArgs^>^ value);
}

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.SearchEngine (Module: ScrewTurn.Wiki.SearchEngine) Version: 3.0.2.500 (3.0.2.500)


InitializeData Method (documents, words, mappings)

InitializeData Method (documents, words, mappings)
ScrewTurn Wiki ► ScrewTurn.Wiki.SearchEngine ► IInMemoryIndex ► InitializeData(array<DumpedDocument>[]()[], array<DumpedWord>[]()[], array<DumpedWordMapping>[]()[])
Initializes index data by completely emptying the index catalog and storing the specified data.
Declaration Syntax
C# Visual Basic Visual C++
void InitializeData(
    DumpedDocument[] documents,
    DumpedWord[] words,
    DumpedWordMapping[] mappings
)
Sub InitializeData ( _
    documents As DumpedDocument(), _
    words As DumpedWord(), _
    mappings As DumpedWordMapping() _
)
void InitializeData(
    array<DumpedDocument^>^ documents,
    array<DumpedWord^>^ words,
    array<DumpedWordMapping^>^ mappings
)
Parameters
documents (array< DumpedDocument >[]()[][])
The documents.
words (array< DumpedWord >[]()[][])
The words.
mappings (array< DumpedWordMapping >[]()[][])
The mappings.
Remarks
The method does not check the consistency of the data passed as arguments.
Exceptions
Exception | Condition
ArgumentNullException | If documents, words or mappings are null.
InvalidOperationException | If [M:SetBuildDocumentDelegate] was not called.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.SearchEngine (Module: ScrewTurn.Wiki.SearchEngine) Version: 3.0.2.500 (3.0.2.500)


SetBuildDocumentDelegate Method (buildDocument)

SetBuildDocumentDelegate Method (buildDocument)
ScrewTurn Wiki ► ScrewTurn.Wiki.SearchEngine ► IInMemoryIndex ► SetBuildDocumentDelegate(BuildDocument)
Sets the delegate used for converting a DumpedDocument to an instance of a class implementing IDocument, while reading index data from a permanent storage.
Declaration Syntax
C# Visual Basic Visual C++
void SetBuildDocumentDelegate(
    BuildDocument buildDocument
)
Sub SetBuildDocumentDelegate ( _
    buildDocument As BuildDocument _
)
void SetBuildDocumentDelegate(
    BuildDocument^ buildDocument
)
Parameters
buildDocument (BuildDocument)
The delegate (cannot be null).
Remarks
This method must be called before invoking InitializeData(array<DumpedDocument>[]()[], array<DumpedWord>[]()[], array<DumpedWordMapping>[]()[]).
Exceptions
Exception | Condition
ArgumentNullException | If buildDocument is null.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.SearchEngine (Module: ScrewTurn.Wiki.SearchEngine) Version: 3.0.2.500 (3.0.2.500)


IndexChangedEventArgs Class

IndexChangedEventArgs Class
ScrewTurn Wiki ► ScrewTurn.Wiki.SearchEngine ► IndexChangedEventArgs
Contains arguments for the IndexChanged event of the IInMemoryIndex interface.
Declaration Syntax
C# Visual Basic Visual C++
public class IndexChangedEventArgs : EventArgs
Public Class IndexChangedEventArgs _
    Inherits EventArgs
public ref class IndexChangedEventArgs : public EventArgs
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | IndexChangedEventArgs(IDocument, IndexChangeType, DumpedChange, Object) | Initializes a new instance of the IndexChangedEventArgs class.
 | IndexChangedEventArgs(IDocument, IndexChangeType, DumpedChange, Object, IndexStorerResult) | Initializes a new instance of the IndexChangedEventArgs class.
 | Change | Gets the change performed.
 | ChangeData | Gets the dumped change data.
 | Document | Gets the affected document.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Result | Gets or sets the index storer result, if any.
 | State | Gets the state object that is passed to the IndexStorer SaveDate/DeleteData function.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | EventArgs
 |  | IndexChangedEventArgs

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.SearchEngine (Module: ScrewTurn.Wiki.SearchEngine) Version: 3.0.2.500 (3.0.2.500)


IndexChangedEventArgs Constructor

IndexChangedEventArgs Constructor
ScrewTurn Wiki ► ScrewTurn.Wiki.SearchEngine ► IndexChangedEventArgs ► IndexChangedEventArgs()()()
Members
Icon | Member | Description
 | IndexChangedEventArgs(IDocument, IndexChangeType, DumpedChange, Object) | Initializes a new instance of the IndexChangedEventArgs class.
 | IndexChangedEventArgs(IDocument, IndexChangeType, DumpedChange, Object, IndexStorerResult) | Initializes a new instance of the IndexChangedEventArgs class.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.SearchEngine (Module: ScrewTurn.Wiki.SearchEngine) Version: 3.0.2.500 (3.0.2.500)


IndexChangedEventArgs Constructor (document, change, changeData, state)

IndexChangedEventArgs Constructor (document, change, changeData, state)
ScrewTurn Wiki ► ScrewTurn.Wiki.SearchEngine ► IndexChangedEventArgs ► IndexChangedEventArgs(IDocument, IndexChangeType, DumpedChange, Object)
Initializes a new instance of the IndexChangedEventArgs class.
Declaration Syntax
C# Visual Basic Visual C++
public IndexChangedEventArgs(
    IDocument document,
    IndexChangeType change,
    DumpedChange changeData,
    Object state
)
Public Sub New ( _
    document As IDocument, _
    change As IndexChangeType, _
    changeData As DumpedChange, _
    state As Object _
)
public:
IndexChangedEventArgs(
    IDocument^ document,
    IndexChangeType change,
    DumpedChange^ changeData,
    Object^ state
)
Parameters
document (IDocument)
The affected document.
change (IndexChangeType)
The change performed.
changeData (DumpedChange)
The dumped change data.
state (Object)
A state object that is passed to the IndexStorer SaveDate/DeleteData function.
Exceptions
Exception | Condition
ArgumentNullException | If change is not IndexCleared and document or changeData are null.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.SearchEngine (Module: ScrewTurn.Wiki.SearchEngine) Version: 3.0.2.500 (3.0.2.500)


IndexChangedEventArgs Constructor (document, change, changeData, state, result)

IndexChangedEventArgs Constructor (document, change, changeData, state, result)
ScrewTurn Wiki ► ScrewTurn.Wiki.SearchEngine ► IndexChangedEventArgs ► IndexChangedEventArgs(IDocument, IndexChangeType, DumpedChange, Object, IndexStorerResult)
Initializes a new instance of the IndexChangedEventArgs class.
Declaration Syntax
C# Visual Basic Visual C++
public IndexChangedEventArgs(
    IDocument document,
    IndexChangeType change,
    DumpedChange changeData,
    Object state,
    IndexStorerResult result
)
Public Sub New ( _
    document As IDocument, _
    change As IndexChangeType, _
    changeData As DumpedChange, _
    state As Object, _
    result As IndexStorerResult _
)
public:
IndexChangedEventArgs(
    IDocument^ document,
    IndexChangeType change,
    DumpedChange^ changeData,
    Object^ state,
    IndexStorerResult^ result
)
Parameters
document (IDocument)
The affected document.
change (IndexChangeType)
The change performed.
changeData (DumpedChange)
The dumped change data.
state (Object)
A state object that is passed to the IndexStorer SaveDate/DeleteData function.
result (IndexStorerResult)
The storer result, if any.
Exceptions
Exception | Condition
ArgumentNullException | If change is not IndexCleared and document or changeData are null.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.SearchEngine (Module: ScrewTurn.Wiki.SearchEngine) Version: 3.0.2.500 (3.0.2.500)


Change Property

Change Property
ScrewTurn Wiki ► ScrewTurn.Wiki.SearchEngine ► IndexChangedEventArgs ► Change
Gets the change performed.
Declaration Syntax
C# Visual Basic Visual C++
public IndexChangeType Change { get; }
Public ReadOnly Property Change As IndexChangeType
public:
property IndexChangeType Change {
    IndexChangeType get ();
}

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.SearchEngine (Module: ScrewTurn.Wiki.SearchEngine) Version: 3.0.2.500 (3.0.2.500)


ChangeData Property

ChangeData Property
ScrewTurn Wiki ► ScrewTurn.Wiki.SearchEngine ► IndexChangedEventArgs ► ChangeData
Gets the dumped change data.
Declaration Syntax
C# Visual Basic Visual C++
public DumpedChange ChangeData { get; }
Public ReadOnly Property ChangeData As DumpedChange
public:
property DumpedChange^ ChangeData {
    DumpedChange^ get ();
}

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.SearchEngine (Module: ScrewTurn.Wiki.SearchEngine) Version: 3.0.2.500 (3.0.2.500)


Document Property

Document Property
ScrewTurn Wiki ► ScrewTurn.Wiki.SearchEngine ► IndexChangedEventArgs ► Document
Gets the affected document.
Declaration Syntax
C# Visual Basic Visual C++
public IDocument Document { get; }
Public ReadOnly Property Document As IDocument
public:
property IDocument^ Document {
    IDocument^ get ();
}

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.SearchEngine (Module: ScrewTurn.Wiki.SearchEngine) Version: 3.0.2.500 (3.0.2.500)


Result Property

Result Property
ScrewTurn Wiki ► ScrewTurn.Wiki.SearchEngine ► IndexChangedEventArgs ► Result
Gets or sets the index storer result, if any.
Declaration Syntax
C# Visual Basic Visual C++
public IndexStorerResult Result { get; set; }
Public Property Result As IndexStorerResult
public:
property IndexStorerResult^ Result {
    IndexStorerResult^ get ();
    void set (IndexStorerResult^ value);
}

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.SearchEngine (Module: ScrewTurn.Wiki.SearchEngine) Version: 3.0.2.500 (3.0.2.500)


State Property

State Property
ScrewTurn Wiki ► ScrewTurn.Wiki.SearchEngine ► IndexChangedEventArgs ► State
Gets the state object that is passed to the IndexStorer SaveDate/DeleteData function.
Declaration Syntax
C# Visual Basic Visual C++
public Object State { get; }
Public ReadOnly Property State As Object
public:
property Object^ State {
    Object^ get ();
}

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.SearchEngine (Module: ScrewTurn.Wiki.SearchEngine) Version: 3.0.2.500 (3.0.2.500)


IndexChangeType Enumeration

IndexChangeType Enumeration
ScrewTurn Wiki ► ScrewTurn.Wiki.SearchEngine ► IndexChangeType
Lists valid index changes.
Declaration Syntax
C# Visual Basic Visual C++
public enum IndexChangeType
Public Enumeration IndexChangeType
public enum class IndexChangeType
Members
Member | Description
DocumentAdded | A document is added.
DocumentRemoved | A document is removed.
IndexCleared | The index is cleared.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.SearchEngine (Module: ScrewTurn.Wiki.SearchEngine) Version: 3.0.2.500 (3.0.2.500)


IndexStorerBase Class

IndexStorerBase Class
ScrewTurn Wiki ► ScrewTurn.Wiki.SearchEngine ► IndexStorerBase
Implements a base class for an index storer.
Declaration Syntax
C# Visual Basic Visual C++
public abstract class IndexStorerBase : IDisposable
Public MustInherit Class IndexStorerBase _
    Implements IDisposable
public ref class IndexStorerBase abstract : IDisposable
Members
All Members | Constructors | Methods | Properties | Fields
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | IndexStorerBase(IInMemoryIndex) | Initializes a new instance of the IndexStorerBase class.
 | dataCorrupted | true if the index data seems corrupted.
 | DataCorrupted | Gets a value indicating whether the index data seems corrupted and cannot be used.
 | DeleteData(DumpedChange, Object) | Deletes data from the data storage.
 | Dispose()()() | Disposes the current object.
 | disposed | Indicates whether the object was disposed.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | Find(DumpedWordMapping, IEnumerable<(Of <(DumpedWordMapping>)>)) | Determines whether a DumpedWordMapping is contained in a list.
 | Find(DumpedWord, IEnumerable<(Of <(DumpedWord>)>)) | Determines whether a DumpedWord is contained in a list.
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | index | The index bound to this storer.
 | Index | Gets the index.
 | indexChangedHandler | The event handler for the IndexChanged of the bound index.
 | IndexChangedHandler(Object, IndexChangedEventArgs) | Handles the IndexChanged events.
 | InitDataStore(Object) | Initializes the data storage.
 | LoadIndex()()() | Loads the index from the data store the first time.
 | LoadIndexInternal(array<DumpedDocument>[]()[]%, array<DumpedWord>[]()[]%, array<DumpedWordMapping>[]()[]%) | Loads the index from the data store the first time.
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | reasonForDataCorruption | Contains the exception occurred during index setup.
 | ReasonForDataCorruption | Gets the exception that caused data corruption.
 | SaveData(DumpedChange, Object) | Stores new data into the data storage.
 | Size | Gets the approximate size, in bytes, of the search engine index.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Remarks
Instance and static members are thread-safe.
Inheritance Hierarchy
Object
 | IndexStorerBase
 |  | IndexStorer

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.SearchEngine (Module: ScrewTurn.Wiki.SearchEngine) Version: 3.0.2.500 (3.0.2.500)


IndexStorerBase Constructor (index)

IndexStorerBase Constructor (index)
ScrewTurn Wiki ► ScrewTurn.Wiki.SearchEngine ► IndexStorerBase ► IndexStorerBase(IInMemoryIndex)
Initializes a new instance of the IndexStorerBase class.
Declaration Syntax
C# Visual Basic Visual C++
public IndexStorerBase(
    IInMemoryIndex index
)
Public Sub New ( _
    index As IInMemoryIndex _
)
public:
IndexStorerBase(
    IInMemoryIndex^ index
)
Parameters
index (IInMemoryIndex)
The index to manage.
Exceptions
Exception | Condition
ArgumentNullException | If index is null.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.SearchEngine (Module: ScrewTurn.Wiki.SearchEngine) Version: 3.0.2.500 (3.0.2.500)


dataCorrupted Field

dataCorrupted Field
ScrewTurn Wiki ► ScrewTurn.Wiki.SearchEngine ► IndexStorerBase ► dataCorrupted
true if the index data seems corrupted.
Declaration Syntax
C# Visual Basic Visual C++
protected bool dataCorrupted
Protected dataCorrupted As Boolean
protected:
bool dataCorrupted

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.SearchEngine (Module: ScrewTurn.Wiki.SearchEngine) Version: 3.0.2.500 (3.0.2.500)


DataCorrupted Property

DataCorrupted Property
ScrewTurn Wiki ► ScrewTurn.Wiki.SearchEngine ► IndexStorerBase ► DataCorrupted
Gets a value indicating whether the index data seems corrupted and cannot be used.
Declaration Syntax
C# Visual Basic Visual C++
public bool DataCorrupted { get; }
Public ReadOnly Property DataCorrupted As Boolean
public:
property bool DataCorrupted {
    bool get ();
}

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.SearchEngine (Module: ScrewTurn.Wiki.SearchEngine) Version: 3.0.2.500 (3.0.2.500)


DeleteData Method (data, state)

DeleteData Method (data, state)
ScrewTurn Wiki ► ScrewTurn.Wiki.SearchEngine ► IndexStorerBase ► DeleteData(DumpedChange, Object)
Deletes data from the data storage.
Declaration Syntax
C# Visual Basic Visual C++
protected abstract void DeleteData(
    DumpedChange data,
    Object state
)
Protected MustOverride Sub DeleteData ( _
    data As DumpedChange, _
    state As Object _
)
protected:
virtual void DeleteData(
    DumpedChange^ data,
    Object^ state
) abstract
Parameters
data (DumpedChange)
The data to delete.
state (Object)
A state object passed from the index.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.SearchEngine (Module: ScrewTurn.Wiki.SearchEngine) Version: 3.0.2.500 (3.0.2.500)


Dispose Method

Dispose Method
ScrewTurn Wiki ► ScrewTurn.Wiki.SearchEngine ► IndexStorerBase ► Dispose()()()
Disposes the current object.
Declaration Syntax
C# Visual Basic Visual C++
public void Dispose()
Public Sub Dispose
public:
virtual void Dispose() sealed

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.SearchEngine (Module: ScrewTurn.Wiki.SearchEngine) Version: 3.0.2.500 (3.0.2.500)


disposed Field

disposed Field
ScrewTurn Wiki ► ScrewTurn.Wiki.SearchEngine ► IndexStorerBase ► disposed
Indicates whether the object was disposed.
Declaration Syntax
C# Visual Basic Visual C++
protected bool disposed
Protected disposed As Boolean
protected:
bool disposed

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.SearchEngine (Module: ScrewTurn.Wiki.SearchEngine) Version: 3.0.2.500 (3.0.2.500)


Find Method

Find Method
ScrewTurn Wiki ► ScrewTurn.Wiki.SearchEngine ► IndexStorerBase ► Find()()()
Members
Icon | Member | Description
 | Find(DumpedWordMapping, IEnumerable<(Of <(DumpedWordMapping>)>)) | Determines whether a DumpedWordMapping is contained in a list.
 | Find(DumpedWord, IEnumerable<(Of <(DumpedWord>)>)) | Determines whether a DumpedWord is contained in a list.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.SearchEngine (Module: ScrewTurn.Wiki.SearchEngine) Version: 3.0.2.500 (3.0.2.500)


Find Method (word, list)

Find Method (word, list)
ScrewTurn Wiki ► ScrewTurn.Wiki.SearchEngine ► IndexStorerBase ► Find(DumpedWord, IEnumerable<(Of <(DumpedWord>)>))
Determines whether a DumpedWord is contained in a list.
Declaration Syntax
C# Visual Basic Visual C++
protected static bool Find(
    DumpedWord word,
    IEnumerable<DumpedWord> list
)
Protected Shared Function Find ( _
    word As DumpedWord, _
    list As IEnumerable(Of DumpedWord) _
) As Boolean
protected:
static bool Find(
    DumpedWord^ word,
    IEnumerable<DumpedWord^>^ list
)
Parameters
word (DumpedWord)
The word.
list (IEnumerable <(Of <(<' DumpedWord >)>)>)
The list.
Return Value
true if the word is contained in the list, false orherwise.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.SearchEngine (Module: ScrewTurn.Wiki.SearchEngine) Version: 3.0.2.500 (3.0.2.500)


Find Method (mapping, list)

Find Method (mapping, list)
ScrewTurn Wiki ► ScrewTurn.Wiki.SearchEngine ► IndexStorerBase ► Find(DumpedWordMapping, IEnumerable<(Of <(DumpedWordMapping>)>))
Determines whether a DumpedWordMapping is contained in a list.
Declaration Syntax
C# Visual Basic Visual C++
protected static bool Find(
    DumpedWordMapping mapping,
    IEnumerable<DumpedWordMapping> list
)
Protected Shared Function Find ( _
    mapping As DumpedWordMapping, _
    list As IEnumerable(Of DumpedWordMapping) _
) As Boolean
protected:
static bool Find(
    DumpedWordMapping^ mapping,
    IEnumerable<DumpedWordMapping^>^ list
)
Parameters
mapping (DumpedWordMapping)
The mapping.
list (IEnumerable <(Of <(<' DumpedWordMapping >)>)>)
The list.
Return Value
true if the mapping is contained in the list, false otherwise.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.SearchEngine (Module: ScrewTurn.Wiki.SearchEngine) Version: 3.0.2.500 (3.0.2.500)


index Field

index Field
ScrewTurn Wiki ► ScrewTurn.Wiki.SearchEngine ► IndexStorerBase ► index
The index bound to this storer.
Declaration Syntax
C# Visual Basic Visual C++
protected IInMemoryIndex index
Protected index As IInMemoryIndex
protected:
IInMemoryIndex^ index

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.SearchEngine (Module: ScrewTurn.Wiki.SearchEngine) Version: 3.0.2.500 (3.0.2.500)


Index Property

Index Property
ScrewTurn Wiki ► ScrewTurn.Wiki.SearchEngine ► IndexStorerBase ► Index
Gets the index.
Declaration Syntax
C# Visual Basic Visual C++
public IInMemoryIndex Index { get; }
Public ReadOnly Property Index As IInMemoryIndex
public:
property IInMemoryIndex^ Index {
    IInMemoryIndex^ get ();
}

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.SearchEngine (Module: ScrewTurn.Wiki.SearchEngine) Version: 3.0.2.500 (3.0.2.500)


indexChangedHandler Field

indexChangedHandler Field
ScrewTurn Wiki ► ScrewTurn.Wiki.SearchEngine ► IndexStorerBase ► indexChangedHandler
The event handler for the IndexChanged of the bound index.
Declaration Syntax
C# Visual Basic Visual C++
protected EventHandler<IndexChangedEventArgs> indexChangedHandler
Protected indexChangedHandler As EventHandler(Of IndexChangedEventArgs)
protected:
EventHandler<IndexChangedEventArgs^>^ indexChangedHandler

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.SearchEngine (Module: ScrewTurn.Wiki.SearchEngine) Version: 3.0.2.500 (3.0.2.500)


IndexChangedHandler Method (sender, e)

IndexChangedHandler Method (sender, e)
ScrewTurn Wiki ► ScrewTurn.Wiki.SearchEngine ► IndexStorerBase ► IndexChangedHandler(Object, IndexChangedEventArgs)
Handles the IndexChanged events.
Declaration Syntax
C# Visual Basic Visual C++
protected void IndexChangedHandler(
    Object sender,
    IndexChangedEventArgs e
)
Protected Sub IndexChangedHandler ( _
    sender As Object, _
    e As IndexChangedEventArgs _
)
protected:
void IndexChangedHandler(
    Object^ sender,
    IndexChangedEventArgs^ e
)
Parameters
sender (Object)
The sender.
e (IndexChangedEventArgs)
The event arguments.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.SearchEngine (Module: ScrewTurn.Wiki.SearchEngine) Version: 3.0.2.500 (3.0.2.500)


InitDataStore Method (state)

InitDataStore Method (state)
ScrewTurn Wiki ► ScrewTurn.Wiki.SearchEngine ► IndexStorerBase ► InitDataStore(Object)
Initializes the data storage.
Declaration Syntax
C# Visual Basic Visual C++
protected abstract void InitDataStore(
    Object state
)
Protected MustOverride Sub InitDataStore ( _
    state As Object _
)
protected:
virtual void InitDataStore(
    Object^ state
) abstract
Parameters
state (Object)
A state object passed from the index.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.SearchEngine (Module: ScrewTurn.Wiki.SearchEngine) Version: 3.0.2.500 (3.0.2.500)


LoadIndex Method

LoadIndex Method
ScrewTurn Wiki ► ScrewTurn.Wiki.SearchEngine ► IndexStorerBase ► LoadIndex()()()
Loads the index from the data store the first time.
Declaration Syntax
C# Visual Basic Visual C++
public void LoadIndex()
Public Sub LoadIndex
public:
void LoadIndex()

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.SearchEngine (Module: ScrewTurn.Wiki.SearchEngine) Version: 3.0.2.500 (3.0.2.500)


LoadIndexInternal Method (documents, words, mappings)

LoadIndexInternal Method (documents, words, mappings)
ScrewTurn Wiki ► ScrewTurn.Wiki.SearchEngine ► IndexStorerBase ► LoadIndexInternal(array<DumpedDocument>[]()[]%, array<DumpedWord>[]()[]%, array<DumpedWordMapping>[]()[]%)
Loads the index from the data store the first time.
Declaration Syntax
C# Visual Basic Visual C++
protected abstract void LoadIndexInternal(
    out DumpedDocument[] documents,
    out DumpedWord[] words,
    out DumpedWordMapping[] mappings
)
Protected MustOverride Sub LoadIndexInternal ( _
    <OutAttribute> ByRef documents As DumpedDocument(), _
    <OutAttribute> ByRef words As DumpedWord(), _
    <OutAttribute> ByRef mappings As DumpedWordMapping() _
)
protected:
virtual void LoadIndexInternal(
    [OutAttribute] array<DumpedDocument^>^% documents,
    [OutAttribute] array<DumpedWord^>^% words,
    [OutAttribute] array<DumpedWordMapping^>^% mappings
) abstract
Parameters
documents ( array< DumpedDocument >[]()[][] %)
The dumped documents.
words ( array< DumpedWord >[]()[][] %)
The dumped words.
mappings ( array< DumpedWordMapping >[]()[][] %)
The dumped word mappings.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.SearchEngine (Module: ScrewTurn.Wiki.SearchEngine) Version: 3.0.2.500 (3.0.2.500)


reasonForDataCorruption Field

reasonForDataCorruption Field
ScrewTurn Wiki ► ScrewTurn.Wiki.SearchEngine ► IndexStorerBase ► reasonForDataCorruption
Contains the exception occurred during index setup.
Declaration Syntax
C# Visual Basic Visual C++
protected Exception reasonForDataCorruption
Protected reasonForDataCorruption As Exception
protected:
Exception^ reasonForDataCorruption

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.SearchEngine (Module: ScrewTurn.Wiki.SearchEngine) Version: 3.0.2.500 (3.0.2.500)


ReasonForDataCorruption Property

ReasonForDataCorruption Property
ScrewTurn Wiki ► ScrewTurn.Wiki.SearchEngine ► IndexStorerBase ► ReasonForDataCorruption
Gets the exception that caused data corruption.
Declaration Syntax
C# Visual Basic Visual C++
public Exception ReasonForDataCorruption { get; }
Public ReadOnly Property ReasonForDataCorruption As Exception
public:
property Exception^ ReasonForDataCorruption {
    Exception^ get ();
}

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.SearchEngine (Module: ScrewTurn.Wiki.SearchEngine) Version: 3.0.2.500 (3.0.2.500)


SaveData Method (data, state)

SaveData Method (data, state)
ScrewTurn Wiki ► ScrewTurn.Wiki.SearchEngine ► IndexStorerBase ► SaveData(DumpedChange, Object)
Stores new data into the data storage.
Declaration Syntax
C# Visual Basic Visual C++
protected abstract IndexStorerResult SaveData(
    DumpedChange data,
    Object state
)
Protected MustOverride Function SaveData ( _
    data As DumpedChange, _
    state As Object _
) As IndexStorerResult
protected:
virtual IndexStorerResult^ SaveData(
    DumpedChange^ data,
    Object^ state
) abstract
Parameters
data (DumpedChange)
The data to store.
state (Object)
A state object passed by the index.
Return Value
The storer result, if any.
Remarks
When saving a new document, the document ID in data.Mappings must be replaced with the currect document ID, generated by the concrete implementation of this method. data.Words should have IDs numbered from uint.MaxValue downwards. The method re-numbers the words appropriately.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.SearchEngine (Module: ScrewTurn.Wiki.SearchEngine) Version: 3.0.2.500 (3.0.2.500)


Size Property

Size Property
ScrewTurn Wiki ► ScrewTurn.Wiki.SearchEngine ► IndexStorerBase ► Size
Gets the approximate size, in bytes, of the search engine index.
Declaration Syntax
C# Visual Basic Visual C++
public abstract long Size { get; }
Public MustOverride ReadOnly Property Size As Long
public:
virtual property long long Size {
    long long get () abstract;
}

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.SearchEngine (Module: ScrewTurn.Wiki.SearchEngine) Version: 3.0.2.500 (3.0.2.500)


IndexStorerResult Class

IndexStorerResult Class
ScrewTurn Wiki ► ScrewTurn.Wiki.SearchEngine ► IndexStorerResult
Contains the results of an index storer operation.
Declaration Syntax
C# Visual Basic Visual C++
public class IndexStorerResult
Public Class IndexStorerResult
public ref class IndexStorerResult
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | IndexStorerResult(Nullable<(Of <(UInt32>)>), List<(Of <(WordId>)>)) | Initializes a new instance of the IndexStorerResult class.
 | DocumentID | Gets or sets the ID of the document just stored, if any.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | WordIDs | Gets or sets the IDs of the words
Inheritance Hierarchy
Object
IndexStorerResult

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.SearchEngine (Module: ScrewTurn.Wiki.SearchEngine) Version: 3.0.2.500 (3.0.2.500)


IndexStorerResult Constructor (documentId, wordIds)

IndexStorerResult Constructor (documentId, wordIds)
ScrewTurn Wiki ► ScrewTurn.Wiki.SearchEngine ► IndexStorerResult ► IndexStorerResult(Nullable<(Of <(UInt32>)>), List<(Of <(WordId>)>))
Initializes a new instance of the IndexStorerResult class.
Declaration Syntax
C# Visual Basic Visual C++
public IndexStorerResult(
    Nullable<uint> documentId,
    List<WordId> wordIds
)
Public Sub New ( _
    documentId As Nullable(Of UInteger), _
    wordIds As List(Of WordId) _
)
public:
IndexStorerResult(
    Nullable<unsigned int> documentId,
    List<WordId^>^ wordIds
)
Parameters
documentId (Nullable <(Of <(<' UInt32 >)>)>)
The ID of the document just stored, if any.
wordIds (List <(Of <(<' WordId >)>)>)
The IDs of the words just stored, if any.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.SearchEngine (Module: ScrewTurn.Wiki.SearchEngine) Version: 3.0.2.500 (3.0.2.500)


DocumentID Property

DocumentID Property
ScrewTurn Wiki ► ScrewTurn.Wiki.SearchEngine ► IndexStorerResult ► DocumentID
Gets or sets the ID of the document just stored, if any.
Declaration Syntax
C# Visual Basic Visual C++
public Nullable<uint> DocumentID { get; set; }
Public Property DocumentID As Nullable(Of UInteger)
public:
property Nullable<unsigned int> DocumentID {
    Nullable<unsigned int> get ();
    void set (Nullable<unsigned int> value);
}

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.SearchEngine (Module: ScrewTurn.Wiki.SearchEngine) Version: 3.0.2.500 (3.0.2.500)


WordIDs Property

WordIDs Property
ScrewTurn Wiki ► ScrewTurn.Wiki.SearchEngine ► IndexStorerResult ► WordIDs
Gets or sets the IDs of the words
Declaration Syntax
C# Visual Basic Visual C++
public List<WordId> WordIDs { get; set; }
Public Property WordIDs As List(Of WordId)
public:
property List<WordId^>^ WordIDs {
    List<WordId^>^ get ();
    void set (List<WordId^>^ value);
}

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.SearchEngine (Module: ScrewTurn.Wiki.SearchEngine) Version: 3.0.2.500 (3.0.2.500)


InMemoryIndexBase Class

InMemoryIndexBase Class
ScrewTurn Wiki ► ScrewTurn.Wiki.SearchEngine ► InMemoryIndexBase
Implements a base class for the search index.
Declaration Syntax
C# Visual Basic Visual C++
public abstract class InMemoryIndexBase : IInMemoryIndex,
    IIndex
Public MustInherit Class InMemoryIndexBase _
    Implements IInMemoryIndex, IIndex
public ref class InMemoryIndexBase abstract : IInMemoryIndex,
    IIndex
Members
All Members | Constructors | Methods | Properties | Fields | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | InMemoryIndexBase()()() | Initializes a new instance of the InMemoryIndexBase class.
 | buildDocument | The BuildDocument delegate.
 | catalog | Contains the index catalog.
 | Clear(Object) | Completely clears the index (stop words are not affected).
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | IndexChanged | An event fired when the index is changed.
 | InitializeData(array<DumpedDocument>[]()[], array<DumpedWord>[]()[], array<DumpedWordMapping>[]()[]) | Initializes index data by completely emptying the index catalog and storing the specified data.
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | OnIndexChange(IDocument, IndexChangeType, DumpedChange, Object) | Takes care of firing the IndexChanged event.
 | RemoveDocument(IDocument, Object) | Removes a document from the index.
 | RemoveDocumentInternal(IDocument) | Removes a document from the index and generates the dumped change data.
 | Search(SearchParameters) | Performs a search in the index.
 | SetBuildDocumentDelegate(BuildDocument) | Sets the delegate used for converting a DumpedDocument to an instance of a class implementing IDocument, while reading index data from a permanent storage.
 | stopWords | The stop words to be used while indexing new content.
 | StopWords | Gets or sets the stop words to be used while indexing new content.
 | StoreDocument(IDocument, array<String>[]()[], String, Object) | Stores a document in the index.
 | StoreWord(String, IDocument, UInt16, UInt16, WordLocation, Word%, DumpedWord%) | Stores a word in the catalog.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | TotalDocuments | Gets the total count of documents.
 | TotalOccurrences | Gets the total number of occurrences (count of words in each document).
 | TotalWords | Gets the total count of unique words.
Remarks
All instance and static members are thread-safe.
Inheritance Hierarchy
Object
 | InMemoryIndexBase
 |  | StandardIndex

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.SearchEngine (Module: ScrewTurn.Wiki.SearchEngine) Version: 3.0.2.500 (3.0.2.500)


InMemoryIndexBase Constructor

InMemoryIndexBase Constructor
ScrewTurn Wiki ► ScrewTurn.Wiki.SearchEngine ► InMemoryIndexBase ► InMemoryIndexBase()()()
Initializes a new instance of the InMemoryIndexBase class.
Declaration Syntax
C# Visual Basic Visual C++
public InMemoryIndexBase()
Public Sub New
public:
InMemoryIndexBase()

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.SearchEngine (Module: ScrewTurn.Wiki.SearchEngine) Version: 3.0.2.500 (3.0.2.500)


buildDocument Field

buildDocument Field
ScrewTurn Wiki ► ScrewTurn.Wiki.SearchEngine ► InMemoryIndexBase ► buildDocument
The BuildDocument delegate.
Declaration Syntax
C# Visual Basic Visual C++
protected BuildDocument buildDocument
Protected buildDocument As BuildDocument
protected:
BuildDocument^ buildDocument

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.SearchEngine (Module: ScrewTurn.Wiki.SearchEngine) Version: 3.0.2.500 (3.0.2.500)


catalog Field

catalog Field
ScrewTurn Wiki ► ScrewTurn.Wiki.SearchEngine ► InMemoryIndexBase ► catalog
Contains the index catalog.
Declaration Syntax
C# Visual Basic Visual C++
protected Dictionary<string, Word> catalog
Protected catalog As Dictionary(Of String, Word)
protected:
Dictionary<String^, Word^>^ catalog

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.SearchEngine (Module: ScrewTurn.Wiki.SearchEngine) Version: 3.0.2.500 (3.0.2.500)


Clear Method (state)

Clear Method (state)
ScrewTurn Wiki ► ScrewTurn.Wiki.SearchEngine ► InMemoryIndexBase ► Clear(Object)
Completely clears the index (stop words are not affected).
Declaration Syntax
C# Visual Basic Visual C++
public void Clear(
    Object state
)
Public Sub Clear ( _
    state As Object _
)
public:
virtual void Clear(
    Object^ state
) sealed
Parameters
state (Object)
A state object that is passed to the IndexStorer SaveDate/DeleteData function.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.SearchEngine (Module: ScrewTurn.Wiki.SearchEngine) Version: 3.0.2.500 (3.0.2.500)


IndexChanged Event

IndexChanged Event
ScrewTurn Wiki ► ScrewTurn.Wiki.SearchEngine ► InMemoryIndexBase ► IndexChanged
An event fired when the index is changed.
Declaration Syntax
C# Visual Basic Visual C++
public event EventHandler<IndexChangedEventArgs> IndexChanged
Public Event IndexChanged As EventHandler(Of IndexChangedEventArgs)
public:
virtual  event EventHandler<IndexChangedEventArgs^>^ IndexChanged {
    void add (EventHandler<IndexChangedEventArgs^>^ value);
    void remove (EventHandler<IndexChangedEventArgs^>^ value);
}

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.SearchEngine (Module: ScrewTurn.Wiki.SearchEngine) Version: 3.0.2.500 (3.0.2.500)


InitializeData Method (documents, words, mappings)

InitializeData Method (documents, words, mappings)
ScrewTurn Wiki ► ScrewTurn.Wiki.SearchEngine ► InMemoryIndexBase ► InitializeData(array<DumpedDocument>[]()[], array<DumpedWord>[]()[], array<DumpedWordMapping>[]()[])
Initializes index data by completely emptying the index catalog and storing the specified data.
Declaration Syntax
C# Visual Basic Visual C++
public void InitializeData(
    DumpedDocument[] documents,
    DumpedWord[] words,
    DumpedWordMapping[] mappings
)
Public Sub InitializeData ( _
    documents As DumpedDocument(), _
    words As DumpedWord(), _
    mappings As DumpedWordMapping() _
)
public:
virtual void InitializeData(
    array<DumpedDocument^>^ documents,
    array<DumpedWord^>^ words,
    array<DumpedWordMapping^>^ mappings
) sealed
Parameters
documents (array< DumpedDocument >[]()[][])
The documents.
words (array< DumpedWord >[]()[][])
The words.
mappings (array< DumpedWordMapping >[]()[][])
The mappings.
Remarks
The method does not check the consistency of the data passed as arguments.
Exceptions
Exception | Condition
ArgumentNullException | If documents, words or mappings are null.
InvalidOperationException | If [M:SetBuildDocumentDelegate] was not called.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.SearchEngine (Module: ScrewTurn.Wiki.SearchEngine) Version: 3.0.2.500 (3.0.2.500)


OnIndexChange Method (document, change, changeData, state)

OnIndexChange Method (document, change, changeData, state)
ScrewTurn Wiki ► ScrewTurn.Wiki.SearchEngine ► InMemoryIndexBase ► OnIndexChange(IDocument, IndexChangeType, DumpedChange, Object)
Takes care of firing the IndexChanged event.
Declaration Syntax
C# Visual Basic Visual C++
protected IndexStorerResult OnIndexChange(
    IDocument document,
    IndexChangeType change,
    DumpedChange changeData,
    Object state
)
Protected Function OnIndexChange ( _
    document As IDocument, _
    change As IndexChangeType, _
    changeData As DumpedChange, _
    state As Object _
) As IndexStorerResult
protected:
IndexStorerResult^ OnIndexChange(
    IDocument^ document,
    IndexChangeType change,
    DumpedChange^ changeData,
    Object^ state
)
Parameters
document (IDocument)
The affected document.
change (IndexChangeType)
The change performed.
changeData (DumpedChange)
The dumped change data.
state (Object)
A state object that is passed to the IndexStorer SaveDate/DeleteData function.
Return Value
The storage result or null.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.SearchEngine (Module: ScrewTurn.Wiki.SearchEngine) Version: 3.0.2.500 (3.0.2.500)


RemoveDocument Method (document, state)

RemoveDocument Method (document, state)
ScrewTurn Wiki ► ScrewTurn.Wiki.SearchEngine ► InMemoryIndexBase ► RemoveDocument(IDocument, Object)
Removes a document from the index.
Declaration Syntax
C# Visual Basic Visual C++
public void RemoveDocument(
    IDocument document,
    Object state
)
Public Sub RemoveDocument ( _
    document As IDocument, _
    state As Object _
)
public:
virtual void RemoveDocument(
    IDocument^ document,
    Object^ state
) sealed
Parameters
document (IDocument)
The document to remove.
state (Object)
A state object that is passed to the IndexStorer SaveDate/DeleteData function.
Exceptions
Exception | Condition
ArgumentNullException | If document is null.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.SearchEngine (Module: ScrewTurn.Wiki.SearchEngine) Version: 3.0.2.500 (3.0.2.500)


RemoveDocumentInternal Method (document)

RemoveDocumentInternal Method (document)
ScrewTurn Wiki ► ScrewTurn.Wiki.SearchEngine ► InMemoryIndexBase ► RemoveDocumentInternal(IDocument)
Removes a document from the index and generates the dumped change data.
Declaration Syntax
C# Visual Basic Visual C++
protected DumpedChange RemoveDocumentInternal(
    IDocument document
)
Protected Function RemoveDocumentInternal ( _
    document As IDocument _
) As DumpedChange
protected:
DumpedChange^ RemoveDocumentInternal(
    IDocument^ document
)
Parameters
document (IDocument)
The document to remove.
Return Value
The dumped change data, if any, null otherwise.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.SearchEngine (Module: ScrewTurn.Wiki.SearchEngine) Version: 3.0.2.500 (3.0.2.500)


Search Method (parameters)

Search Method (parameters)
ScrewTurn Wiki ► ScrewTurn.Wiki.SearchEngine ► InMemoryIndexBase ► Search(SearchParameters)
Performs a search in the index.
Declaration Syntax
C# Visual Basic Visual C++
public SearchResultCollection Search(
    SearchParameters parameters
)
Public Function Search ( _
    parameters As SearchParameters _
) As SearchResultCollection
public:
virtual SearchResultCollection^ Search(
    SearchParameters^ parameters
) sealed
Parameters
parameters (SearchParameters)
The search parameters.
Return Value
The results.
Exceptions
Exception | Condition
ArgumentNullException | If parameters is null.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.SearchEngine (Module: ScrewTurn.Wiki.SearchEngine) Version: 3.0.2.500 (3.0.2.500)


SetBuildDocumentDelegate Method (buildDocument)

SetBuildDocumentDelegate Method (buildDocument)
ScrewTurn Wiki ► ScrewTurn.Wiki.SearchEngine ► InMemoryIndexBase ► SetBuildDocumentDelegate(BuildDocument)
Sets the delegate used for converting a DumpedDocument to an instance of a class implementing IDocument, while reading index data from a permanent storage.
Declaration Syntax
C# Visual Basic Visual C++
public void SetBuildDocumentDelegate(
    BuildDocument buildDocument
)
Public Sub SetBuildDocumentDelegate ( _
    buildDocument As BuildDocument _
)
public:
virtual void SetBuildDocumentDelegate(
    BuildDocument^ buildDocument
) sealed
Parameters
buildDocument (BuildDocument)
The delegate (cannot be null).
Remarks
This method must be called before invoking InitializeData(array<DumpedDocument>[]()[], array<DumpedWord>[]()[], array<DumpedWordMapping>[]()[]).
Exceptions
Exception | Condition
ArgumentNullException | If buildDocument is null.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.SearchEngine (Module: ScrewTurn.Wiki.SearchEngine) Version: 3.0.2.500 (3.0.2.500)


stopWords Field

stopWords Field
ScrewTurn Wiki ► ScrewTurn.Wiki.SearchEngine ► InMemoryIndexBase ► stopWords
The stop words to be used while indexing new content.
Declaration Syntax
C# Visual Basic Visual C++
protected string[] stopWords
Protected stopWords As String()
protected:
array<String^>^ stopWords

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.SearchEngine (Module: ScrewTurn.Wiki.SearchEngine) Version: 3.0.2.500 (3.0.2.500)


StopWords Property

StopWords Property
ScrewTurn Wiki ► ScrewTurn.Wiki.SearchEngine ► InMemoryIndexBase ► StopWords
Gets or sets the stop words to be used while indexing new content.
Declaration Syntax
C# Visual Basic Visual C++
public string[] StopWords { get; set; }
Public Property StopWords As String()
public:
virtual property array<String^>^ StopWords {
    array<String^>^ get () sealed;
    void set (array<String^>^ value) sealed;
}

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.SearchEngine (Module: ScrewTurn.Wiki.SearchEngine) Version: 3.0.2.500 (3.0.2.500)


StoreDocument Method (document, keywords, content, state)

StoreDocument Method (document, keywords, content, state)
ScrewTurn Wiki ► ScrewTurn.Wiki.SearchEngine ► InMemoryIndexBase ► StoreDocument(IDocument, array<String>[]()[], String, Object)
Stores a document in the index.
Declaration Syntax
C# Visual Basic Visual C++
public int StoreDocument(
    IDocument document,
    string[] keywords,
    string content,
    Object state
)
Public Function StoreDocument ( _
    document As IDocument, _
    keywords As String(), _
    content As String, _
    state As Object _
) As Integer
public:
virtual int StoreDocument(
    IDocument^ document,
    array<String^>^ keywords,
    String^ content,
    Object^ state
) sealed
Parameters
document (IDocument)
The document.
keywords (array< String >[]()[][])
The document keywords, if any, an empty array or null otherwise.
content (String)
The content of the document.
state (Object)
A state object that is passed to the IndexStorer SaveDate/DeleteData function.
Return Value
The number of indexed words (including duplicates) in the document title and content.
Remarks
Indexing the content of the document is O(n), where n is the total number of words in the document. If the specified document was already in the index, all the old occurrences are deleted from the index.
Exceptions
Exception | Condition
ArgumentNullException | If document or content are null.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.SearchEngine (Module: ScrewTurn.Wiki.SearchEngine) Version: 3.0.2.500 (3.0.2.500)


StoreWord Method (wordText, document, firstCharIndex, wordIndex, location, newWord, dumpedWord)

StoreWord Method (wordText, document, firstCharIndex, wordIndex, location, newWord, dumpedWord)
ScrewTurn Wiki ► ScrewTurn.Wiki.SearchEngine ► InMemoryIndexBase ► StoreWord(String, IDocument, UInt16, UInt16, WordLocation, Word%, DumpedWord%)
Stores a word in the catalog.
Declaration Syntax
C# Visual Basic Visual C++
protected DumpedWordMapping StoreWord(
    string wordText,
    IDocument document,
    ushort firstCharIndex,
    ushort wordIndex,
    WordLocation location,
    out Word newWord,
    out DumpedWord dumpedWord
)
Protected Function StoreWord ( _
    wordText As String, _
    document As IDocument, _
    firstCharIndex As UShort, _
    wordIndex As UShort, _
    location As WordLocation, _
    <OutAttribute> ByRef newWord As Word, _
    <OutAttribute> ByRef dumpedWord As DumpedWord _
) As DumpedWordMapping
protected:
DumpedWordMapping^ StoreWord(
    String^ wordText,
    IDocument^ document,
    unsigned short firstCharIndex,
    unsigned short wordIndex,
    WordLocation^ location,
    [OutAttribute] Word^% newWord,
    [OutAttribute] DumpedWord^% dumpedWord
)
Parameters
wordText (String)
The word to store.
document (IDocument)
The document the word occurs in.
firstCharIndex (UInt16)
The index of the first character of the word in the document the word occurs at.
wordIndex (UInt16)
The index of the word in the document.
location (WordLocation)
The location of the word.
newWord ( Word %)
The new word, or null.
dumpedWord ( DumpedWord %)
The dumped word data, or null.
Return Value
The dumped word mapping data.
Remarks
Storing a word in the index is O(n log n), where n is the number of words already in the index.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.SearchEngine (Module: ScrewTurn.Wiki.SearchEngine) Version: 3.0.2.500 (3.0.2.500)


TotalDocuments Property

TotalDocuments Property
ScrewTurn Wiki ► ScrewTurn.Wiki.SearchEngine ► InMemoryIndexBase ► TotalDocuments
Gets the total count of documents.
Declaration Syntax
C# Visual Basic Visual C++
public int TotalDocuments { get; }
Public ReadOnly Property TotalDocuments As Integer
public:
virtual property int TotalDocuments {
    int get () sealed;
}
Remarks
Computing the result is O(n*m), where n is the number of words in the index and m is the number of documents.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.SearchEngine (Module: ScrewTurn.Wiki.SearchEngine) Version: 3.0.2.500 (3.0.2.500)


TotalOccurrences Property

TotalOccurrences Property
ScrewTurn Wiki ► ScrewTurn.Wiki.SearchEngine ► InMemoryIndexBase ► TotalOccurrences
Gets the total number of occurrences (count of words in each document).
Declaration Syntax
C# Visual Basic Visual C++
public int TotalOccurrences { get; }
Public ReadOnly Property TotalOccurrences As Integer
public:
virtual property int TotalOccurrences {
    int get () sealed;
}
Remarks
Computing the result is O(n), where n is the number of words in the index.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.SearchEngine (Module: ScrewTurn.Wiki.SearchEngine) Version: 3.0.2.500 (3.0.2.500)


TotalWords Property

TotalWords Property
ScrewTurn Wiki ► ScrewTurn.Wiki.SearchEngine ► InMemoryIndexBase ► TotalWords
Gets the total count of unique words.
Declaration Syntax
C# Visual Basic Visual C++
public int TotalWords { get; }
Public ReadOnly Property TotalWords As Integer
public:
virtual property int TotalWords {
    int get () sealed;
}
Remarks
Computing the result is O(1).

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.SearchEngine (Module: ScrewTurn.Wiki.SearchEngine) Version: 3.0.2.500 (3.0.2.500)


InMemoryIndexWordFetcher Class

InMemoryIndexWordFetcher Class
ScrewTurn Wiki ► ScrewTurn.Wiki.SearchEngine ► InMemoryIndexWordFetcher
Implements a word fetcher for use with the in-memory index.
Declaration Syntax
C# Visual Basic Visual C++
public class InMemoryIndexWordFetcher : IWordFetcher,
    IDisposable
Public Class InMemoryIndexWordFetcher _
    Implements IWordFetcher, IDisposable
public ref class InMemoryIndexWordFetcher : IWordFetcher,
    IDisposable
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | InMemoryIndexWordFetcher(Dictionary<(Of <(String, Word>)>)) | Initializes a new instance of the InMemoryWordFetcher class.
 | Dispose()()() | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | TryGetWord(String, Word%) | Tries to get a word.
Inheritance Hierarchy
Object
InMemoryIndexWordFetcher

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.SearchEngine (Module: ScrewTurn.Wiki.SearchEngine) Version: 3.0.2.500 (3.0.2.500)


InMemoryIndexWordFetcher Constructor (catalog)

InMemoryIndexWordFetcher Constructor (catalog)
ScrewTurn Wiki ► ScrewTurn.Wiki.SearchEngine ► InMemoryIndexWordFetcher ► InMemoryIndexWordFetcher(Dictionary<(Of <(String, Word>)>))
Initializes a new instance of the InMemoryWordFetcher class.
Declaration Syntax
C# Visual Basic Visual C++
public InMemoryIndexWordFetcher(
    Dictionary<string, Word> catalog
)
Public Sub New ( _
    catalog As Dictionary(Of String, Word) _
)
public:
InMemoryIndexWordFetcher(
    Dictionary<String^, Word^>^ catalog
)
Parameters
catalog (Dictionary <(Of <(<' String, Word >)>)>)
The index catalog.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.SearchEngine (Module: ScrewTurn.Wiki.SearchEngine) Version: 3.0.2.500 (3.0.2.500)


Dispose Method

Dispose Method
ScrewTurn Wiki ► ScrewTurn.Wiki.SearchEngine ► InMemoryIndexWordFetcher ► Dispose()()()
Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources.
Declaration Syntax
C# Visual Basic Visual C++
public void Dispose()
Public Sub Dispose
public:
virtual void Dispose() sealed

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.SearchEngine (Module: ScrewTurn.Wiki.SearchEngine) Version: 3.0.2.500 (3.0.2.500)


TryGetWord Method (text, word)

TryGetWord Method (text, word)
ScrewTurn Wiki ► ScrewTurn.Wiki.SearchEngine ► InMemoryIndexWordFetcher ► TryGetWord(String, Word%)
Tries to get a word.
Declaration Syntax
C# Visual Basic Visual C++
public bool TryGetWord(
    string text,
    out Word word
)
Public Function TryGetWord ( _
    text As String, _
    <OutAttribute> ByRef word As Word _
) As Boolean
public:
virtual bool TryGetWord(
    String^ text,
    [OutAttribute] Word^% word
) sealed
Parameters
text (String)
The text of the word.
word ( Word %)
The found word, if any, null otherwise.
Return Value
true if the word is found, false otherwise.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.SearchEngine (Module: ScrewTurn.Wiki.SearchEngine) Version: 3.0.2.500 (3.0.2.500)


IWordFetcher Interface

IWordFetcher Interface
ScrewTurn Wiki ► ScrewTurn.Wiki.SearchEngine ► IWordFetcher
Defines the interface for a component that fetches words.
Declaration Syntax
C# Visual Basic Visual C++
public interface IWordFetcher : IDisposable
Public Interface IWordFetcher _
    Implements IDisposable
public interface class IWordFetcher : IDisposable
Members
All Members | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | Dispose()()() | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
 | TryGetWord(String, Word%) | Tries to get a word.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.SearchEngine (Module: ScrewTurn.Wiki.SearchEngine) Version: 3.0.2.500 (3.0.2.500)


TryGetWord Method (text, word)

TryGetWord Method (text, word)
ScrewTurn Wiki ► ScrewTurn.Wiki.SearchEngine ► IWordFetcher ► TryGetWord(String, Word%)
Tries to get a word.
Declaration Syntax
C# Visual Basic Visual C++
bool TryGetWord(
    string text,
    out Word word
)
Function TryGetWord ( _
    text As String, _
    <OutAttribute> ByRef word As Word _
) As Boolean
bool TryGetWord(
    String^ text,
    [OutAttribute] Word^% word
)
Parameters
text (String)
The text of the word.
word ( Word %)
The found word, if any, null otherwise.
Return Value
true if the word is found, false otherwise.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.SearchEngine (Module: ScrewTurn.Wiki.SearchEngine) Version: 3.0.2.500 (3.0.2.500)


OccurrenceDictionary Class

OccurrenceDictionary Class
ScrewTurn Wiki ► ScrewTurn.Wiki.SearchEngine ► OccurrenceDictionary
Implements a IDocument-SortedBasicWordInfo dictionary which treats IDocuments as value type.
Declaration Syntax
C# Visual Basic Visual C++
public class OccurrenceDictionary : IDictionary<IDocument, SortedBasicWordInfoSet>,
    ICollection<KeyValuePair<IDocument, SortedBasicWordInfoSet>>, IEnumerable<KeyValuePair<IDocument, SortedBasicWordInfoSet>>,
    IEnumerable
Public Class OccurrenceDictionary _
    Implements IDictionary(Of IDocument, SortedBasicWordInfoSet),  _
    ICollection(Of KeyValuePair(Of IDocument, SortedBasicWordInfoSet)), IEnumerable(Of KeyValuePair(Of IDocument, SortedBasicWordInfoSet)),  _
    IEnumerable
public ref class OccurrenceDictionary : IDictionary<IDocument^, SortedBasicWordInfoSet^>,
    ICollection<KeyValuePair<IDocument^, SortedBasicWordInfoSet^>>, IEnumerable<KeyValuePair<IDocument^, SortedBasicWordInfoSet^>>,
    IEnumerable
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | OccurrenceDictionary(Int32) | Initializes a new instance of the OccurrenceDictionary class.
 | OccurrenceDictionary()()() | Initializes a new instance of the OccurrenceDictionary class.
 | Add(IDocument, SortedBasicWordInfoSet) | Adds the specified key and value to the dictionary.
 | Add(KeyValuePair<(Of <(IDocument, SortedBasicWordInfoSet>)>)) | Adds the specified key-value pair to the dictionary.
 | Clear()()() | Clears the dictionary.
 | Contains(KeyValuePair<(Of <(IDocument, SortedBasicWordInfoSet>)>)) | Determines whether the dictionary contains an element.
 | ContainsKey(IDocument) | Determines whether the dictionary contains the specified key.
 | CopyTo(array<KeyValuePair<(Of <(IDocument, SortedBasicWordInfoSet>)>)>[]()[], Int32) | Copies the content of the dictionary to a key-value pairs array.
 | Count | Gets the number of elements in the dictionary.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetEnumerator()()() | Returns an enumerator that iterates through the elements in the dictionary.
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | IsReadOnly | Gets a value indicating whether the dictionary is read-only.
 | Item[([(IDocument])]) | Gets or sets a value in the dictionary.
 | Keys | Gets the keys of the dictionary.
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Remove(IDocument) | Removes an element from the dictionary.
 | Remove(KeyValuePair<(Of <(IDocument, SortedBasicWordInfoSet>)>)) | Removes an element from the dictionary.
 | RemoveExtended(IDocument, UInt32) | Removes an element from the dictionary.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | TryGetValue(IDocument, SortedBasicWordInfoSet%) | Tries to retrieve a value from the dictionary.
 | Values | Gets the values of the dictionary.
Remarks
All instance members are not thread-safe.
Inheritance Hierarchy
Object
OccurrenceDictionary

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.SearchEngine (Module: ScrewTurn.Wiki.SearchEngine) Version: 3.0.2.500 (3.0.2.500)


OccurrenceDictionary Constructor

OccurrenceDictionary Constructor
ScrewTurn Wiki ► ScrewTurn.Wiki.SearchEngine ► OccurrenceDictionary ► OccurrenceDictionary()()()
Members
Icon | Member | Description
 | OccurrenceDictionary(Int32) | Initializes a new instance of the OccurrenceDictionary class.
 | OccurrenceDictionary()()() | Initializes a new instance of the OccurrenceDictionary class.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.SearchEngine (Module: ScrewTurn.Wiki.SearchEngine) Version: 3.0.2.500 (3.0.2.500)


OccurrenceDictionary Constructor

OccurrenceDictionary Constructor
ScrewTurn Wiki ► ScrewTurn.Wiki.SearchEngine ► OccurrenceDictionary ► OccurrenceDictionary()()()
Initializes a new instance of the OccurrenceDictionary class.
Declaration Syntax
C# Visual Basic Visual C++
public OccurrenceDictionary()
Public Sub New
public:
OccurrenceDictionary()

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.SearchEngine (Module: ScrewTurn.Wiki.SearchEngine) Version: 3.0.2.500 (3.0.2.500)


OccurrenceDictionary Constructor (capacity)

OccurrenceDictionary Constructor (capacity)
ScrewTurn Wiki ► ScrewTurn.Wiki.SearchEngine ► OccurrenceDictionary ► OccurrenceDictionary(Int32)
Initializes a new instance of the OccurrenceDictionary class.
Declaration Syntax
C# Visual Basic Visual C++
public OccurrenceDictionary(
    int capacity
)
Public Sub New ( _
    capacity As Integer _
)
public:
OccurrenceDictionary(
    int capacity
)
Parameters
capacity (Int32)
The initial capacity of the dictionary.
Exceptions
Exception | Condition
ArgumentOutOfRangeException | If capacity is less than or equal to zero.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.SearchEngine (Module: ScrewTurn.Wiki.SearchEngine) Version: 3.0.2.500 (3.0.2.500)


Add Method

Add Method
ScrewTurn Wiki ► ScrewTurn.Wiki.SearchEngine ► OccurrenceDictionary ► Add()()()
Members
Icon | Member | Description
 | Add(IDocument, SortedBasicWordInfoSet) | Adds the specified key and value to the dictionary.
 | Add(KeyValuePair<(Of <(IDocument, SortedBasicWordInfoSet>)>)) | Adds the specified key-value pair to the dictionary.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.SearchEngine (Module: ScrewTurn.Wiki.SearchEngine) Version: 3.0.2.500 (3.0.2.500)


Add Method (key, value)

Add Method (key, value)
ScrewTurn Wiki ► ScrewTurn.Wiki.SearchEngine ► OccurrenceDictionary ► Add(IDocument, SortedBasicWordInfoSet)
Adds the specified key and value to the dictionary.
Declaration Syntax
C# Visual Basic Visual C++
public void Add(
    IDocument key,
    SortedBasicWordInfoSet value
)
Public Sub Add ( _
    key As IDocument, _
    value As SortedBasicWordInfoSet _
)
public:
virtual void Add(
    IDocument^ key,
    SortedBasicWordInfoSet^ value
) sealed
Parameters
key (IDocument)
The key of the element to add.
value (SortedBasicWordInfoSet)
The value of the element to add.
Exceptions
Exception | Condition
ArgumentNullException | If key or value are null.
ArgumentException | If key is already present in the dictionary.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.SearchEngine (Module: ScrewTurn.Wiki.SearchEngine) Version: 3.0.2.500 (3.0.2.500)


Add Method (item)

Add Method (item)
ScrewTurn Wiki ► ScrewTurn.Wiki.SearchEngine ► OccurrenceDictionary ► Add(KeyValuePair<(Of <(IDocument, SortedBasicWordInfoSet>)>))
Adds the specified key-value pair to the dictionary.
Declaration Syntax
C# Visual Basic Visual C++
public void Add(
    KeyValuePair<IDocument, SortedBasicWordInfoSet> item
)
Public Sub Add ( _
    item As KeyValuePair(Of IDocument, SortedBasicWordInfoSet) _
)
public:
virtual void Add(
    KeyValuePair<IDocument^, SortedBasicWordInfoSet^> item
) sealed
Parameters
item (KeyValuePair <(Of <(<' IDocument, SortedBasicWordInfoSet >)>)>)
The key-value pair to add.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.SearchEngine (Module: ScrewTurn.Wiki.SearchEngine) Version: 3.0.2.500 (3.0.2.500)


Clear Method

Clear Method
ScrewTurn Wiki ► ScrewTurn.Wiki.SearchEngine ► OccurrenceDictionary ► Clear()()()
Clears the dictionary.
Declaration Syntax
C# Visual Basic Visual C++
public void Clear()
Public Sub Clear
public:
virtual void Clear() sealed

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.SearchEngine (Module: ScrewTurn.Wiki.SearchEngine) Version: 3.0.2.500 (3.0.2.500)


Contains Method (item)

Contains Method (item)
ScrewTurn Wiki ► ScrewTurn.Wiki.SearchEngine ► OccurrenceDictionary ► Contains(KeyValuePair<(Of <(IDocument, SortedBasicWordInfoSet>)>))
Determines whether the dictionary contains an element.
Declaration Syntax
C# Visual Basic Visual C++
public bool Contains(
    KeyValuePair<IDocument, SortedBasicWordInfoSet> item
)
Public Function Contains ( _
    item As KeyValuePair(Of IDocument, SortedBasicWordInfoSet) _
) As Boolean
public:
virtual bool Contains(
    KeyValuePair<IDocument^, SortedBasicWordInfoSet^> item
) sealed
Parameters
item (KeyValuePair <(Of <(<' IDocument, SortedBasicWordInfoSet >)>)>)
The key-value pair representing the element.
Return Value
true if the dictionary contains the element, false otherwise.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.SearchEngine (Module: ScrewTurn.Wiki.SearchEngine) Version: 3.0.2.500 (3.0.2.500)


ContainsKey Method (key)

ContainsKey Method (key)
ScrewTurn Wiki ► ScrewTurn.Wiki.SearchEngine ► OccurrenceDictionary ► ContainsKey(IDocument)
Determines whether the dictionary contains the specified key.
Declaration Syntax
C# Visual Basic Visual C++
public bool ContainsKey(
    IDocument key
)
Public Function ContainsKey ( _
    key As IDocument _
) As Boolean
public:
virtual bool ContainsKey(
    IDocument^ key
) sealed
Parameters
key (IDocument)
The key to locate.
Return Value
true if the dictionary contains the specified key, false otherwise.
Exceptions
Exception | Condition
ArgumentNullException | If key is null.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.SearchEngine (Module: ScrewTurn.Wiki.SearchEngine) Version: 3.0.2.500 (3.0.2.500)


CopyTo Method (array, arrayIndex)

CopyTo Method (array, arrayIndex)
ScrewTurn Wiki ► ScrewTurn.Wiki.SearchEngine ► OccurrenceDictionary ► CopyTo(array<KeyValuePair<(Of <(IDocument, SortedBasicWordInfoSet>)>)>[]()[], Int32)
Copies the content of the dictionary to a key-value pairs array.
Declaration Syntax
C# Visual Basic Visual C++
public void CopyTo(
    KeyValuePair<IDocument, SortedBasicWordInfoSet>[] array,
    int arrayIndex
)
Public Sub CopyTo ( _
    array As KeyValuePair(Of IDocument, SortedBasicWordInfoSet)(), _
    arrayIndex As Integer _
)
public:
virtual void CopyTo(
    array<KeyValuePair<IDocument^, SortedBasicWordInfoSet^>>^ array,
    int arrayIndex
) sealed
Parameters
array (array< KeyValuePair <(Of <(<' IDocument, SortedBasicWordInfoSet >)>)> >[]()[][])
The output array.
arrayIndex (Int32)
The index at which the copy begins.
Exceptions
Exception | Condition
ArgumentNullException | If array is null.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.SearchEngine (Module: ScrewTurn.Wiki.SearchEngine) Version: 3.0.2.500 (3.0.2.500)


Count Property

Count Property
ScrewTurn Wiki ► ScrewTurn.Wiki.SearchEngine ► OccurrenceDictionary ► Count
Gets the number of elements in the dictionary.
Declaration Syntax
C# Visual Basic Visual C++
public int Count { get; }
Public ReadOnly Property Count As Integer
public:
virtual property int Count {
    int get () sealed;
}

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.SearchEngine (Module: ScrewTurn.Wiki.SearchEngine) Version: 3.0.2.500 (3.0.2.500)


GetEnumerator Method

GetEnumerator Method
ScrewTurn Wiki ► ScrewTurn.Wiki.SearchEngine ► OccurrenceDictionary ► GetEnumerator()()()
Returns an enumerator that iterates through the elements in the dictionary.
Declaration Syntax
C# Visual Basic Visual C++
public IEnumerator<KeyValuePair<IDocument, SortedBasicWordInfoSet>> GetEnumerator()
Public Function GetEnumerator As IEnumerator(Of KeyValuePair(Of IDocument, SortedBasicWordInfoSet))
public:
virtual IEnumerator<KeyValuePair<IDocument^, SortedBasicWordInfoSet^>>^ GetEnumerator() sealed
Return Value
The iterator.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.SearchEngine (Module: ScrewTurn.Wiki.SearchEngine) Version: 3.0.2.500 (3.0.2.500)


IsReadOnly Property

IsReadOnly Property
ScrewTurn Wiki ► ScrewTurn.Wiki.SearchEngine ► OccurrenceDictionary ► IsReadOnly
Gets a value indicating whether the dictionary is read-only.
Declaration Syntax
C# Visual Basic Visual C++
public bool IsReadOnly { get; }
Public ReadOnly Property IsReadOnly As Boolean
public:
virtual property bool IsReadOnly {
    bool get () sealed;
}

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.SearchEngine (Module: ScrewTurn.Wiki.SearchEngine) Version: 3.0.2.500 (3.0.2.500)


Item Property (key)

Item Property (key)
ScrewTurn Wiki ► ScrewTurn.Wiki.SearchEngine ► OccurrenceDictionary ► Item[([(IDocument])])
Gets or sets a value in the dictionary.
Declaration Syntax
C# Visual Basic Visual C++
public SortedBasicWordInfoSet this[
    IDocument key
] { get; set; }
Public Default Property Item ( _
    key As IDocument _
) As SortedBasicWordInfoSet
public:
virtual property SortedBasicWordInfoSet^ default[IDocument^ key] {
    SortedBasicWordInfoSet^ get (IDocument^ key) sealed;
    void set (IDocument^ key, SortedBasicWordInfoSet^ value) sealed;
}
Parameters
key (IDocument)
The key of the value to ger or set.
Return Value
The value.
Exceptions
Exception | Condition
ArgumentNullException | If key is null.
IndexOutOfRangeException | If the key is not found.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.SearchEngine (Module: ScrewTurn.Wiki.SearchEngine) Version: 3.0.2.500 (3.0.2.500)


Keys Property

Keys Property
ScrewTurn Wiki ► ScrewTurn.Wiki.SearchEngine ► OccurrenceDictionary ► Keys
Gets the keys of the dictionary.
Declaration Syntax
C# Visual Basic Visual C++
public ICollection<IDocument> Keys { get; }
Public ReadOnly Property Keys As ICollection(Of IDocument)
public:
virtual property ICollection<IDocument^>^ Keys {
    ICollection<IDocument^>^ get () sealed;
}

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.SearchEngine (Module: ScrewTurn.Wiki.SearchEngine) Version: 3.0.2.500 (3.0.2.500)


Remove Method

Remove Method
ScrewTurn Wiki ► ScrewTurn.Wiki.SearchEngine ► OccurrenceDictionary ► Remove()()()
Members
Icon | Member | Description
 | Remove(IDocument) | Removes an element from the dictionary.
 | Remove(KeyValuePair<(Of <(IDocument, SortedBasicWordInfoSet>)>)) | Removes an element from the dictionary.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.SearchEngine (Module: ScrewTurn.Wiki.SearchEngine) Version: 3.0.2.500 (3.0.2.500)


Remove Method (key)

Remove Method (key)
ScrewTurn Wiki ► ScrewTurn.Wiki.SearchEngine ► OccurrenceDictionary ► Remove(IDocument)
Removes an element from the dictionary.
Declaration Syntax
C# Visual Basic Visual C++
public bool Remove(
    IDocument key
)
Public Function Remove ( _
    key As IDocument _
) As Boolean
public:
virtual bool Remove(
    IDocument^ key
) sealed
Parameters
key (IDocument)
The key of the element to remove.
Return Value
true if the element is removed, false otherwise.
Exceptions
Exception | Condition
ArgumentNullException | If key is null.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.SearchEngine (Module: ScrewTurn.Wiki.SearchEngine) Version: 3.0.2.500 (3.0.2.500)


Remove Method (item)

Remove Method (item)
ScrewTurn Wiki ► ScrewTurn.Wiki.SearchEngine ► OccurrenceDictionary ► Remove(KeyValuePair<(Of <(IDocument, SortedBasicWordInfoSet>)>))
Removes an element from the dictionary.
Declaration Syntax
C# Visual Basic Visual C++
public bool Remove(
    KeyValuePair<IDocument, SortedBasicWordInfoSet> item
)
Public Function Remove ( _
    item As KeyValuePair(Of IDocument, SortedBasicWordInfoSet) _
) As Boolean
public:
virtual bool Remove(
    KeyValuePair<IDocument^, SortedBasicWordInfoSet^> item
) sealed
Parameters
item (KeyValuePair <(Of <(<' IDocument, SortedBasicWordInfoSet >)>)>)
The element to remove.
Return Value
true if the element is removed, false otherwise.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.SearchEngine (Module: ScrewTurn.Wiki.SearchEngine) Version: 3.0.2.500 (3.0.2.500)


RemoveExtended Method (key, wordId)

RemoveExtended Method (key, wordId)
ScrewTurn Wiki ► ScrewTurn.Wiki.SearchEngine ► OccurrenceDictionary ► RemoveExtended(IDocument, UInt32)
Removes an element from the dictionary.
Declaration Syntax
C# Visual Basic Visual C++
public List<DumpedWordMapping> RemoveExtended(
    IDocument key,
    uint wordId
)
Public Function RemoveExtended ( _
    key As IDocument, _
    wordId As UInteger _
) As List(Of DumpedWordMapping)
public:
List<DumpedWordMapping^>^ RemoveExtended(
    IDocument^ key,
    unsigned int wordId
)
Parameters
key (IDocument)
The key of the element to remove.
wordId (UInt32)
The unique ID of the word that is being removed.
Return Value
The list of removed words mappings, in dumpable format.
Remarks
If key is not found, a KeyNotFoundException is thrown.
Exceptions
Exception | Condition
ArgumentNullException | If key is null.
KeyNotFoundException | If key is not present in the dictionary.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.SearchEngine (Module: ScrewTurn.Wiki.SearchEngine) Version: 3.0.2.500 (3.0.2.500)


TryGetValue Method (key, value)

TryGetValue Method (key, value)
ScrewTurn Wiki ► ScrewTurn.Wiki.SearchEngine ► OccurrenceDictionary ► TryGetValue(IDocument, SortedBasicWordInfoSet%)
Tries to retrieve a value from the dictionary.
Declaration Syntax
C# Visual Basic Visual C++
public bool TryGetValue(
    IDocument key,
    out SortedBasicWordInfoSet value
)
Public Function TryGetValue ( _
    key As IDocument, _
    <OutAttribute> ByRef value As SortedBasicWordInfoSet _
) As Boolean
public:
virtual bool TryGetValue(
    IDocument^ key,
    [OutAttribute] SortedBasicWordInfoSet^% value
) sealed
Parameters
key (IDocument)
The key of the value to retrieve.
value ( SortedBasicWordInfoSet %)
The resulting value, or null.
Return Value
true if the value is retrieved, false otherwise.
Exceptions
Exception | Condition
ArgumentNullException | If key is null.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.SearchEngine (Module: ScrewTurn.Wiki.SearchEngine) Version: 3.0.2.500 (3.0.2.500)


Values Property

Values Property
ScrewTurn Wiki ► ScrewTurn.Wiki.SearchEngine ► OccurrenceDictionary ► Values
Gets the values of the dictionary.
Declaration Syntax
C# Visual Basic Visual C++
public ICollection<SortedBasicWordInfoSet> Values { get; }
Public ReadOnly Property Values As ICollection(Of SortedBasicWordInfoSet)
public:
virtual property ICollection<SortedBasicWordInfoSet^>^ Values {
    ICollection<SortedBasicWordInfoSet^>^ get () sealed;
}

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.SearchEngine (Module: ScrewTurn.Wiki.SearchEngine) Version: 3.0.2.500 (3.0.2.500)


Relevance Class

Relevance Class
ScrewTurn Wiki ► ScrewTurn.Wiki.SearchEngine ► Relevance
Represents the relevance of a search result with two states: non-finalized and finalized. When the state is non-finalized, the value of the relevance has an unknown meaning. When the state is finalized, the value of the relevance is a percentage value representing the relevance of a search result.
Declaration Syntax
C# Visual Basic Visual C++
public class Relevance
Public Class Relevance
public ref class Relevance
Members
All Members | Constructors | Methods | Properties | Fields
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | Relevance()()() | Initializes a new instance of the Relevance class.
 | Relevance(Single) | Initializes a new instance of the Relevance class.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize(Single) | Finalizes the value of the relevance.
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | isFinalized | A value indicating whether the relevance value is finalized.
 | IsFinalized | Gets a value indicating whether the relevance value is finalized.
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | NormalizeAfterFinalization(Single) | Normalizes the relevance after finalization.
 | SetValue(Single) | Sets the non-finalized value of the relevance.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | value | The value of the relevance.
 | Value | Gets the value of the relevance.
Remarks
All members are not thread-safe.
Inheritance Hierarchy
Object
Relevance

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.SearchEngine (Module: ScrewTurn.Wiki.SearchEngine) Version: 3.0.2.500 (3.0.2.500)


Relevance Constructor

Relevance Constructor
ScrewTurn Wiki ► ScrewTurn.Wiki.SearchEngine ► Relevance ► Relevance()()()
Members
Icon | Member | Description
 | Relevance()()() | Initializes a new instance of the Relevance class.
 | Relevance(Single) | Initializes a new instance of the Relevance class.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.SearchEngine (Module: ScrewTurn.Wiki.SearchEngine) Version: 3.0.2.500 (3.0.2.500)


Relevance Constructor

Relevance Constructor
ScrewTurn Wiki ► ScrewTurn.Wiki.SearchEngine ► Relevance ► Relevance()()()
Initializes a new instance of the Relevance class.
Declaration Syntax
C# Visual Basic Visual C++
public Relevance()
Public Sub New
public:
Relevance()

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.SearchEngine (Module: ScrewTurn.Wiki.SearchEngine) Version: 3.0.2.500 (3.0.2.500)


Relevance Constructor (value)

Relevance Constructor (value)
ScrewTurn Wiki ► ScrewTurn.Wiki.SearchEngine ► Relevance ► Relevance(Single)
Initializes a new instance of the Relevance class.
Declaration Syntax
C# Visual Basic Visual C++
public Relevance(
    float value
)
Public Sub New ( _
    value As Single _
)
public:
Relevance(
    float value
)
Parameters
value (Single)
The initial relevance value, non-finalized.
Exceptions
Exception | Condition
ArgumentOutOfRangeException | If value is less than zero.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.SearchEngine (Module: ScrewTurn.Wiki.SearchEngine) Version: 3.0.2.500 (3.0.2.500)


Finalize Method (total)

Finalize Method (total)
ScrewTurn Wiki ► ScrewTurn.Wiki.SearchEngine ► Relevance ► Finalize(Single)
Finalizes the value of the relevance.
Declaration Syntax
C# Visual Basic Visual C++
public void Finalize(
    float total
)
Public Sub Finalize ( _
    total As Single _
)
public:
void Finalize(
    float total
)
Parameters
total (Single)
The global relevance value.
Remarks
The method sets the finalized value of the relevance to value / total * 100.
Exceptions
Exception | Condition
ArgumentOutOfRangeException | If total is less than zero.
InvalidOperationException | If IsFinalized is true ([M:Finalize] was called).

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.SearchEngine (Module: ScrewTurn.Wiki.SearchEngine) Version: 3.0.2.500 (3.0.2.500)


isFinalized Field

isFinalized Field
ScrewTurn Wiki ► ScrewTurn.Wiki.SearchEngine ► Relevance ► isFinalized
A value indicating whether the relevance value is finalized.
Declaration Syntax
C# Visual Basic Visual C++
protected bool isFinalized
Protected isFinalized As Boolean
protected:
bool isFinalized

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.SearchEngine (Module: ScrewTurn.Wiki.SearchEngine) Version: 3.0.2.500 (3.0.2.500)


IsFinalized Property

IsFinalized Property
ScrewTurn Wiki ► ScrewTurn.Wiki.SearchEngine ► Relevance ► IsFinalized
Gets a value indicating whether the relevance value is finalized.
Declaration Syntax
C# Visual Basic Visual C++
public bool IsFinalized { get; }
Public ReadOnly Property IsFinalized As Boolean
public:
property bool IsFinalized {
    bool get ();
}

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.SearchEngine (Module: ScrewTurn.Wiki.SearchEngine) Version: 3.0.2.500 (3.0.2.500)


NormalizeAfterFinalization Method (factor)

NormalizeAfterFinalization Method (factor)
ScrewTurn Wiki ► ScrewTurn.Wiki.SearchEngine ► Relevance ► NormalizeAfterFinalization(Single)
Normalizes the relevance after finalization.
Declaration Syntax
C# Visual Basic Visual C++
public void NormalizeAfterFinalization(
    float factor
)
Public Sub NormalizeAfterFinalization ( _
    factor As Single _
)
public:
void NormalizeAfterFinalization(
    float factor
)
Parameters
factor (Single)
The normalization factor.
Exceptions
Exception | Condition
InvalidOperationException | If IsFinalized is false ([M:Finalize] was not called).

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.SearchEngine (Module: ScrewTurn.Wiki.SearchEngine) Version: 3.0.2.500 (3.0.2.500)


SetValue Method (value)

SetValue Method (value)
ScrewTurn Wiki ► ScrewTurn.Wiki.SearchEngine ► Relevance ► SetValue(Single)
Sets the non-finalized value of the relevance.
Declaration Syntax
C# Visual Basic Visual C++
public void SetValue(
    float value
)
Public Sub SetValue ( _
    value As Single _
)
public:
void SetValue(
    float value
)
Parameters
value (Single)
The value.
Exceptions
Exception | Condition
ArgumentOutOfRangeException | If value is less than zero.
InvalidOperationException | If [M:IsFinalized] is true ([M:Finalize] was called).

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.SearchEngine (Module: ScrewTurn.Wiki.SearchEngine) Version: 3.0.2.500 (3.0.2.500)


value Field

value Field
ScrewTurn Wiki ► ScrewTurn.Wiki.SearchEngine ► Relevance ► value
The value of the relevance.
Declaration Syntax
C# Visual Basic Visual C++
protected float value
Protected value As Single
protected:
float value

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.SearchEngine (Module: ScrewTurn.Wiki.SearchEngine) Version: 3.0.2.500 (3.0.2.500)


Value Property

Value Property
ScrewTurn Wiki ► ScrewTurn.Wiki.SearchEngine ► Relevance ► Value
Gets the value of the relevance.
Declaration Syntax
C# Visual Basic Visual C++
public float Value { get; }
Public ReadOnly Property Value As Single
public:
property float Value {
    float get ();
}

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.SearchEngine (Module: ScrewTurn.Wiki.SearchEngine) Version: 3.0.2.500 (3.0.2.500)


SearchOptions Enumeration

SearchOptions Enumeration
ScrewTurn Wiki ► ScrewTurn.Wiki.SearchEngine ► SearchOptions
Lists legal search options.
Declaration Syntax
C# Visual Basic Visual C++
public enum SearchOptions
Public Enumeration SearchOptions
public enum class SearchOptions
Members
Member | Description
AtLeastOneWord | Search for at least one word of the search query.
AllWords | Search for all the words of the search query, in any order.
ExactPhrase | Search for an exact phrase.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.SearchEngine (Module: ScrewTurn.Wiki.SearchEngine) Version: 3.0.2.500 (3.0.2.500)


SearchParameters Class

SearchParameters Class
ScrewTurn Wiki ► ScrewTurn.Wiki.SearchEngine ► SearchParameters
Contains search parameters.
Declaration Syntax
C# Visual Basic Visual C++
public class SearchParameters
Public Class SearchParameters
public ref class SearchParameters
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | SearchParameters(String, array<String>[]()[], SearchOptions) | Initializes a new instance of the SearchParameters class.
 | SearchParameters(String) | Initializes a new instance of the SearchParameters class.
 | SearchParameters(String, array<String>[]()[]) | Initializes a new instance of the SearchParameters class.
 | SearchParameters(String, SearchOptions) | Initializes a new instance of the SearchParameters class.
 | DocumentTypeTags | Gets or sets the document type tags to include in the search, or null.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Options | Gets or sets the search options.
 | Query | Gets or sets the query.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
SearchParameters

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.SearchEngine (Module: ScrewTurn.Wiki.SearchEngine) Version: 3.0.2.500 (3.0.2.500)


SearchParameters Constructor

SearchParameters Constructor
ScrewTurn Wiki ► ScrewTurn.Wiki.SearchEngine ► SearchParameters ► SearchParameters()()()
Members
Icon | Member | Description
 | SearchParameters(String, array<String>[]()[], SearchOptions) | Initializes a new instance of the SearchParameters class.
 | SearchParameters(String) | Initializes a new instance of the SearchParameters class.
 | SearchParameters(String, array<String>[]()[]) | Initializes a new instance of the SearchParameters class.
 | SearchParameters(String, SearchOptions) | Initializes a new instance of the SearchParameters class.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.SearchEngine (Module: ScrewTurn.Wiki.SearchEngine) Version: 3.0.2.500 (3.0.2.500)


SearchParameters Constructor (query)

SearchParameters Constructor (query)
ScrewTurn Wiki ► ScrewTurn.Wiki.SearchEngine ► SearchParameters ► SearchParameters(String)
Initializes a new instance of the SearchParameters class.
Declaration Syntax
C# Visual Basic Visual C++
public SearchParameters(
    string query
)
Public Sub New ( _
    query As String _
)
public:
SearchParameters(
    String^ query
)
Parameters
query (String)
The search query.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.SearchEngine (Module: ScrewTurn.Wiki.SearchEngine) Version: 3.0.2.500 (3.0.2.500)


SearchParameters Constructor (query, options)

SearchParameters Constructor (query, options)
ScrewTurn Wiki ► ScrewTurn.Wiki.SearchEngine ► SearchParameters ► SearchParameters(String, SearchOptions)
Initializes a new instance of the SearchParameters class.
Declaration Syntax
C# Visual Basic Visual C++
public SearchParameters(
    string query,
    SearchOptions options
)
Public Sub New ( _
    query As String, _
    options As SearchOptions _
)
public:
SearchParameters(
    String^ query,
    SearchOptions options
)
Parameters
query (String)
The search query.
options (SearchOptions)
The search options.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.SearchEngine (Module: ScrewTurn.Wiki.SearchEngine) Version: 3.0.2.500 (3.0.2.500)


SearchParameters Constructor (query, documentTypeTags)

SearchParameters Constructor (query, documentTypeTags)
ScrewTurn Wiki ► ScrewTurn.Wiki.SearchEngine ► SearchParameters ► SearchParameters(String, array<String>[]()[])
Initializes a new instance of the SearchParameters class.
Declaration Syntax
C# Visual Basic Visual C++
public SearchParameters(
    string query,
    params string[] documentTypeTags
)
Public Sub New ( _
    query As String, _
    ParamArray documentTypeTags As String() _
)
public:
SearchParameters(
    String^ query,
    ... array<String^>^ documentTypeTags
)
Parameters
query (String)
The search query.
documentTypeTags (array< String >[]()[][])
The document type tags to include in the search, or null.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.SearchEngine (Module: ScrewTurn.Wiki.SearchEngine) Version: 3.0.2.500 (3.0.2.500)


SearchParameters Constructor (query, documentTypeTags, options)

SearchParameters Constructor (query, documentTypeTags, options)
ScrewTurn Wiki ► ScrewTurn.Wiki.SearchEngine ► SearchParameters ► SearchParameters(String, array<String>[]()[], SearchOptions)
Initializes a new instance of the SearchParameters class.
Declaration Syntax
C# Visual Basic Visual C++
public SearchParameters(
    string query,
    string[] documentTypeTags,
    SearchOptions options
)
Public Sub New ( _
    query As String, _
    documentTypeTags As String(), _
    options As SearchOptions _
)
public:
SearchParameters(
    String^ query,
    array<String^>^ documentTypeTags,
    SearchOptions options
)
Parameters
query (String)
The search query.
documentTypeTags (array< String >[]()[][])
The document type tags to include in the search, or null.
options (SearchOptions)
The search options.
Exceptions
Exception | Condition
ArgumentNullException | If query or one of the elements of documentTypeTags (when the array is not null) are null.
ArgumentException | If query or one of the elements of documentTypeTags (when the array is not null) are empty.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.SearchEngine (Module: ScrewTurn.Wiki.SearchEngine) Version: 3.0.2.500 (3.0.2.500)


DocumentTypeTags Property

DocumentTypeTags Property
ScrewTurn Wiki ► ScrewTurn.Wiki.SearchEngine ► SearchParameters ► DocumentTypeTags
Gets or sets the document type tags to include in the search, or null.
Declaration Syntax
C# Visual Basic Visual C++
public string[] DocumentTypeTags { get; set; }
Public Property DocumentTypeTags As String()
public:
property array<String^>^ DocumentTypeTags {
    array<String^>^ get ();
    void set (array<String^>^ value);
}

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.SearchEngine (Module: ScrewTurn.Wiki.SearchEngine) Version: 3.0.2.500 (3.0.2.500)


Options Property

Options Property
ScrewTurn Wiki ► ScrewTurn.Wiki.SearchEngine ► SearchParameters ► Options
Gets or sets the search options.
Declaration Syntax
C# Visual Basic Visual C++
public SearchOptions Options { get; set; }
Public Property Options As SearchOptions
public:
property SearchOptions Options {
    SearchOptions get ();
    void set (SearchOptions value);
}

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.SearchEngine (Module: ScrewTurn.Wiki.SearchEngine) Version: 3.0.2.500 (3.0.2.500)


Query Property

Query Property
ScrewTurn Wiki ► ScrewTurn.Wiki.SearchEngine ► SearchParameters ► Query
Gets or sets the query.
Declaration Syntax
C# Visual Basic Visual C++
public string Query { get; set; }
Public Property Query As String
public:
property String^ Query {
    String^ get ();
    void set (String^ value);
}

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.SearchEngine (Module: ScrewTurn.Wiki.SearchEngine) Version: 3.0.2.500 (3.0.2.500)


SearchResult Class

SearchResult Class
ScrewTurn Wiki ► ScrewTurn.Wiki.SearchEngine ► SearchResult
Represents a search result.
Declaration Syntax
C# Visual Basic Visual C++
public class SearchResult
Public Class SearchResult
public ref class SearchResult
Members
All Members | Constructors | Methods | Properties | Fields
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | SearchResult(IDocument) | Initializes a new instance of the SearchResult class.
 | document | The document the result refers to.
 | Document | Gets the document the result refers to.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | matches | The matches in the document.
 | Matches | Gets the matches in the document.
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | relevance | The result relevance.
 | Relevance | Gets the relevance of the search result.
 | ToString()()() | Gets a string representation of the current instance. (Overrides Object.ToString()()().)
Remarks
Instance and static members are not thread-safe.
Inheritance Hierarchy
Object
SearchResult

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.SearchEngine (Module: ScrewTurn.Wiki.SearchEngine) Version: 3.0.2.500 (3.0.2.500)


SearchResult Constructor (document)

SearchResult Constructor (document)
ScrewTurn Wiki ► ScrewTurn.Wiki.SearchEngine ► SearchResult ► SearchResult(IDocument)
Initializes a new instance of the SearchResult class.
Declaration Syntax
C# Visual Basic Visual C++
public SearchResult(
    IDocument document
)
Public Sub New ( _
    document As IDocument _
)
public:
SearchResult(
    IDocument^ document
)
Parameters
document (IDocument)
The document the result refers to.
Remarks
The relevance is initially set to 0.
Exceptions
Exception | Condition
ArgumentNullException | If document is null.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.SearchEngine (Module: ScrewTurn.Wiki.SearchEngine) Version: 3.0.2.500 (3.0.2.500)


document Field

document Field
ScrewTurn Wiki ► ScrewTurn.Wiki.SearchEngine ► SearchResult ► document
The document the result refers to.
Declaration Syntax
C# Visual Basic Visual C++
protected IDocument document
Protected document As IDocument
protected:
IDocument^ document

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.SearchEngine (Module: ScrewTurn.Wiki.SearchEngine) Version: 3.0.2.500 (3.0.2.500)


Document Property

Document Property
ScrewTurn Wiki ► ScrewTurn.Wiki.SearchEngine ► SearchResult ► Document
Gets the document the result refers to.
Declaration Syntax
C# Visual Basic Visual C++
public IDocument Document { get; }
Public ReadOnly Property Document As IDocument
public:
property IDocument^ Document {
    IDocument^ get ();
}

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.SearchEngine (Module: ScrewTurn.Wiki.SearchEngine) Version: 3.0.2.500 (3.0.2.500)


matches Field

matches Field
ScrewTurn Wiki ► ScrewTurn.Wiki.SearchEngine ► SearchResult ► matches
The matches in the document.
Declaration Syntax
C# Visual Basic Visual C++
protected WordInfoCollection matches
Protected matches As WordInfoCollection
protected:
WordInfoCollection^ matches

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.SearchEngine (Module: ScrewTurn.Wiki.SearchEngine) Version: 3.0.2.500 (3.0.2.500)


Matches Property

Matches Property
ScrewTurn Wiki ► ScrewTurn.Wiki.SearchEngine ► SearchResult ► Matches
Gets the matches in the document.
Declaration Syntax
C# Visual Basic Visual C++
public WordInfoCollection Matches { get; }
Public ReadOnly Property Matches As WordInfoCollection
public:
property WordInfoCollection^ Matches {
    WordInfoCollection^ get ();
}

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.SearchEngine (Module: ScrewTurn.Wiki.SearchEngine) Version: 3.0.2.500 (3.0.2.500)


relevance Field

relevance Field
ScrewTurn Wiki ► ScrewTurn.Wiki.SearchEngine ► SearchResult ► relevance
The result relevance.
Declaration Syntax
C# Visual Basic Visual C++
protected Relevance relevance
Protected relevance As Relevance
protected:
Relevance^ relevance

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.SearchEngine (Module: ScrewTurn.Wiki.SearchEngine) Version: 3.0.2.500 (3.0.2.500)


Relevance Property

Relevance Property
ScrewTurn Wiki ► ScrewTurn.Wiki.SearchEngine ► SearchResult ► Relevance
Gets the relevance of the search result.
Declaration Syntax
C# Visual Basic Visual C++
public Relevance Relevance { get; }
Public ReadOnly Property Relevance As Relevance
public:
property Relevance^ Relevance {
    Relevance^ get ();
}

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.SearchEngine (Module: ScrewTurn.Wiki.SearchEngine) Version: 3.0.2.500 (3.0.2.500)


ToString Method

ToString Method
ScrewTurn Wiki ► ScrewTurn.Wiki.SearchEngine ► SearchResult ► ToString()()()
Gets a string representation of the current instance.
Declaration Syntax
C# Visual Basic Visual C++
public override string ToString()
Public Overrides Function ToString As String
public:
virtual String^ ToString() override
Return Value
The string representation.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.SearchEngine (Module: ScrewTurn.Wiki.SearchEngine) Version: 3.0.2.500 (3.0.2.500)


SearchResultCollection Class

SearchResultCollection Class
ScrewTurn Wiki ► ScrewTurn.Wiki.SearchEngine ► SearchResultCollection
Contains a collection of SearchResults, without duplicates.
Declaration Syntax
C# Visual Basic Visual C++
public class SearchResultCollection : ICollection<SearchResult>,
    IEnumerable<SearchResult>, IEnumerable
Public Class SearchResultCollection _
    Implements ICollection(Of SearchResult), IEnumerable(Of SearchResult),  _
    IEnumerable
public ref class SearchResultCollection : ICollection<SearchResult^>,
    IEnumerable<SearchResult^>, IEnumerable
Members
All Members | Constructors | Methods | Properties | Fields
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | SearchResultCollection()()() | Initializes a new instance of the SearchResultCollection Class.
 | SearchResultCollection(Int32) | Initializes a new instance of the SearchResultCollection Class.
 | Add(SearchResult) | Adds an item to the collection.
 | Capacity | Gets the capacity of the collection.
 | Clear()()() | Clears the collection.
 | Contains(SearchResult) | Determines whether or not the collection contains an item.
 | CopyTo(array<SearchResult>[]()[], Int32) | Copies the collection to an array.
 | Count | Gets the total number of items in the collection.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetEnumerator()()() | Returns an enumerator that iterates through the items in the collection.
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetSearchResult(IDocument) | Retrieves the search result for a document (looking at document names).
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | IsReadOnly | Gets a value indicating whether the collection is read-only.
 | Item[([(Int32])]) | Gets an item from the collection.
 | items | Contains the collection items.
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Remove(SearchResult) | Removes an item from the collection.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Remarks
Instance and static members are not thread-safe.
Inheritance Hierarchy
Object
SearchResultCollection

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.SearchEngine (Module: ScrewTurn.Wiki.SearchEngine) Version: 3.0.2.500 (3.0.2.500)


SearchResultCollection Constructor

SearchResultCollection Constructor
ScrewTurn Wiki ► ScrewTurn.Wiki.SearchEngine ► SearchResultCollection ► SearchResultCollection()()()
Members
Icon | Member | Description
 | SearchResultCollection()()() | Initializes a new instance of the SearchResultCollection Class.
 | SearchResultCollection(Int32) | Initializes a new instance of the SearchResultCollection Class.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.SearchEngine (Module: ScrewTurn.Wiki.SearchEngine) Version: 3.0.2.500 (3.0.2.500)


SearchResultCollection Constructor

SearchResultCollection Constructor
ScrewTurn Wiki ► ScrewTurn.Wiki.SearchEngine ► SearchResultCollection ► SearchResultCollection()()()
Initializes a new instance of the SearchResultCollection Class.
Declaration Syntax
C# Visual Basic Visual C++
public SearchResultCollection()
Public Sub New
public:
SearchResultCollection()

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.SearchEngine (Module: ScrewTurn.Wiki.SearchEngine) Version: 3.0.2.500 (3.0.2.500)


SearchResultCollection Constructor (capacity)

SearchResultCollection Constructor (capacity)
ScrewTurn Wiki ► ScrewTurn.Wiki.SearchEngine ► SearchResultCollection ► SearchResultCollection(Int32)
Initializes a new instance of the SearchResultCollection Class.
Declaration Syntax
C# Visual Basic Visual C++
public SearchResultCollection(
    int capacity
)
Public Sub New ( _
    capacity As Integer _
)
public:
SearchResultCollection(
    int capacity
)
Parameters
capacity (Int32)
The initial capacity of the collection.
Exceptions
Exception | Condition
ArgumentOutOfRangeException | If capacity is less than or equal to zero.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.SearchEngine (Module: ScrewTurn.Wiki.SearchEngine) Version: 3.0.2.500 (3.0.2.500)


Add Method (item)

Add Method (item)
ScrewTurn Wiki ► ScrewTurn.Wiki.SearchEngine ► SearchResultCollection ► Add(SearchResult)
Adds an item to the collection.
Declaration Syntax
C# Visual Basic Visual C++
public void Add(
    SearchResult item
)
Public Sub Add ( _
    item As SearchResult _
)
public:
virtual void Add(
    SearchResult^ item
) sealed
Parameters
item (SearchResult)
The item to add.
Exceptions
Exception | Condition
ArgumentNullException | If item is null.
ArgumentException | If item is laredy present in the collection.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.SearchEngine (Module: ScrewTurn.Wiki.SearchEngine) Version: 3.0.2.500 (3.0.2.500)


Capacity Property

Capacity Property
ScrewTurn Wiki ► ScrewTurn.Wiki.SearchEngine ► SearchResultCollection ► Capacity
Gets the capacity of the collection.
Declaration Syntax
C# Visual Basic Visual C++
public int Capacity { get; }
Public ReadOnly Property Capacity As Integer
public:
property int Capacity {
    int get ();
}

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.SearchEngine (Module: ScrewTurn.Wiki.SearchEngine) Version: 3.0.2.500 (3.0.2.500)


Clear Method

Clear Method
ScrewTurn Wiki ► ScrewTurn.Wiki.SearchEngine ► SearchResultCollection ► Clear()()()
Clears the collection.
Declaration Syntax
C# Visual Basic Visual C++
public void Clear()
Public Sub Clear
public:
virtual void Clear() sealed

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.SearchEngine (Module: ScrewTurn.Wiki.SearchEngine) Version: 3.0.2.500 (3.0.2.500)


Contains Method (item)

Contains Method (item)
ScrewTurn Wiki ► ScrewTurn.Wiki.SearchEngine ► SearchResultCollection ► Contains(SearchResult)
Determines whether or not the collection contains an item.
Declaration Syntax
C# Visual Basic Visual C++
public bool Contains(
    SearchResult item
)
Public Function Contains ( _
    item As SearchResult _
) As Boolean
public:
virtual bool Contains(
    SearchResult^ item
) sealed
Parameters
item (SearchResult)
The item to check for.
Return Value
true if the collection contains item, false otherwise.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.SearchEngine (Module: ScrewTurn.Wiki.SearchEngine) Version: 3.0.2.500 (3.0.2.500)


CopyTo Method (array, arrayIndex)

CopyTo Method (array, arrayIndex)
ScrewTurn Wiki ► ScrewTurn.Wiki.SearchEngine ► SearchResultCollection ► CopyTo(array<SearchResult>[]()[], Int32)
Copies the collection to an array.
Declaration Syntax
C# Visual Basic Visual C++
public void CopyTo(
    SearchResult[] array,
    int arrayIndex
)
Public Sub CopyTo ( _
    array As SearchResult(), _
    arrayIndex As Integer _
)
public:
virtual void CopyTo(
    array<SearchResult^>^ array,
    int arrayIndex
) sealed
Parameters
array (array< SearchResult >[]()[][])
The destination array.
arrayIndex (Int32)
The zero-based array index at which the copy begins.
Exceptions
Exception | Condition
ArgumentOutOfRangeException | If arrayIndex is outside the bounds of array.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.SearchEngine (Module: ScrewTurn.Wiki.SearchEngine) Version: 3.0.2.500 (3.0.2.500)


Count Property

Count Property
ScrewTurn Wiki ► ScrewTurn.Wiki.SearchEngine ► SearchResultCollection ► Count
Gets the total number of items in the collection.
Declaration Syntax
C# Visual Basic Visual C++
public int Count { get; }
Public ReadOnly Property Count As Integer
public:
virtual property int Count {
    int get () sealed;
}

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.SearchEngine (Module: ScrewTurn.Wiki.SearchEngine) Version: 3.0.2.500 (3.0.2.500)


GetEnumerator Method

GetEnumerator Method
ScrewTurn Wiki ► ScrewTurn.Wiki.SearchEngine ► SearchResultCollection ► GetEnumerator()()()
Returns an enumerator that iterates through the items in the collection.
Declaration Syntax
C# Visual Basic Visual C++
public IEnumerator<SearchResult> GetEnumerator()
Public Function GetEnumerator As IEnumerator(Of SearchResult)
public:
virtual IEnumerator<SearchResult^>^ GetEnumerator() sealed
Return Value
The enumerator.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.SearchEngine (Module: ScrewTurn.Wiki.SearchEngine) Version: 3.0.2.500 (3.0.2.500)


GetSearchResult Method (document)

GetSearchResult Method (document)
ScrewTurn Wiki ► ScrewTurn.Wiki.SearchEngine ► SearchResultCollection ► GetSearchResult(IDocument)
Retrieves the search result for a document (looking at document names).
Declaration Syntax
C# Visual Basic Visual C++
public SearchResult GetSearchResult(
    IDocument document
)
Public Function GetSearchResult ( _
    document As IDocument _
) As SearchResult
public:
SearchResult^ GetSearchResult(
    IDocument^ document
)
Parameters
document (IDocument)
The document.
Return Value
The SearchResult object, if any, null otherwise.
Exceptions
Exception | Condition
ArgumentNullException | If document is null.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.SearchEngine (Module: ScrewTurn.Wiki.SearchEngine) Version: 3.0.2.500 (3.0.2.500)


IsReadOnly Property

IsReadOnly Property
ScrewTurn Wiki ► ScrewTurn.Wiki.SearchEngine ► SearchResultCollection ► IsReadOnly
Gets a value indicating whether the collection is read-only.
Declaration Syntax
C# Visual Basic Visual C++
public bool IsReadOnly { get; }
Public ReadOnly Property IsReadOnly As Boolean
public:
virtual property bool IsReadOnly {
    bool get () sealed;
}

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.SearchEngine (Module: ScrewTurn.Wiki.SearchEngine) Version: 3.0.2.500 (3.0.2.500)


Item Property (index)

Item Property (index)
ScrewTurn Wiki ► ScrewTurn.Wiki.SearchEngine ► SearchResultCollection ► Item[([(Int32])])
Gets an item from the collection.
Declaration Syntax
C# Visual Basic Visual C++
public SearchResult this[
    int index
] { get; }
Public ReadOnly Default Property Item ( _
    index As Integer _
) As SearchResult
public:
property SearchResult^ default[int index] {
    SearchResult^ get (int index);
}
Parameters
index (Int32)
The index of the item.
Return Value
The item.
Exceptions
Exception | Condition
IndexOutOfRangeException | If index is outside the bounds of the collection.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.SearchEngine (Module: ScrewTurn.Wiki.SearchEngine) Version: 3.0.2.500 (3.0.2.500)


items Field

items Field
ScrewTurn Wiki ► ScrewTurn.Wiki.SearchEngine ► SearchResultCollection ► items
Contains the collection items.
Declaration Syntax
C# Visual Basic Visual C++
protected List<SearchResult> items
Protected items As List(Of SearchResult)
protected:
List<SearchResult^>^ items

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.SearchEngine (Module: ScrewTurn.Wiki.SearchEngine) Version: 3.0.2.500 (3.0.2.500)


Remove Method (item)

Remove Method (item)
ScrewTurn Wiki ► ScrewTurn.Wiki.SearchEngine ► SearchResultCollection ► Remove(SearchResult)
Removes an item from the collection.
Declaration Syntax
C# Visual Basic Visual C++
public bool Remove(
    SearchResult item
)
Public Function Remove ( _
    item As SearchResult _
) As Boolean
public:
virtual bool Remove(
    SearchResult^ item
) sealed
Parameters
item (SearchResult)
The item to remove.
Return Value
true if the item is removed, false otherwise.
Exceptions
Exception | Condition
ArgumentNullException | If item is null.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.SearchEngine (Module: ScrewTurn.Wiki.SearchEngine) Version: 3.0.2.500 (3.0.2.500)


SortedBasicWordInfoSet Class

SortedBasicWordInfoSet Class
ScrewTurn Wiki ► ScrewTurn.Wiki.SearchEngine ► SortedBasicWordInfoSet
Implements a sorted set of integers which can be accessed by index.
Declaration Syntax
C# Visual Basic Visual C++
public class SortedBasicWordInfoSet : IEnumerable<BasicWordInfo>,
    IEnumerable
Public Class SortedBasicWordInfoSet _
    Implements IEnumerable(Of BasicWordInfo), IEnumerable
public ref class SortedBasicWordInfoSet : IEnumerable<BasicWordInfo^>,
    IEnumerable
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | SortedBasicWordInfoSet()()() | Initializes a new instance of the SortedBasicWordInfoSet class.
 | SortedBasicWordInfoSet(Int32) | Initializes a new instance of the SortedBasicWordInfoSet class.
 | Add(BasicWordInfo) | Adds a new item to the set.
 | Capacity | Gets the capacity of the set.
 | Clear()()() | Clears the set.
 | Contains(BasicWordInfo) | Determines whether the set contains an item.
 | Count | Gets the count if the items in the set.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | Item[([(Int32])]) | Gets an item from the set at a specific index.
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Remove(BasicWordInfo) | Removes an item from the set.
 | ToString()()() | Gets a string representation of the current instance. (Overrides Object.ToString()()().)
Remarks
Instance members are not thread-safe.
Inheritance Hierarchy
Object
SortedBasicWordInfoSet

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.SearchEngine (Module: ScrewTurn.Wiki.SearchEngine) Version: 3.0.2.500 (3.0.2.500)


SortedBasicWordInfoSet Constructor

SortedBasicWordInfoSet Constructor
ScrewTurn Wiki ► ScrewTurn.Wiki.SearchEngine ► SortedBasicWordInfoSet ► SortedBasicWordInfoSet()()()
Members
Icon | Member | Description
 | SortedBasicWordInfoSet()()() | Initializes a new instance of the SortedBasicWordInfoSet class.
 | SortedBasicWordInfoSet(Int32) | Initializes a new instance of the SortedBasicWordInfoSet class.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.SearchEngine (Module: ScrewTurn.Wiki.SearchEngine) Version: 3.0.2.500 (3.0.2.500)


SortedBasicWordInfoSet Constructor

SortedBasicWordInfoSet Constructor
ScrewTurn Wiki ► ScrewTurn.Wiki.SearchEngine ► SortedBasicWordInfoSet ► SortedBasicWordInfoSet()()()
Initializes a new instance of the SortedBasicWordInfoSet class.
Declaration Syntax
C# Visual Basic Visual C++
public SortedBasicWordInfoSet()
Public Sub New
public:
SortedBasicWordInfoSet()

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.SearchEngine (Module: ScrewTurn.Wiki.SearchEngine) Version: 3.0.2.500 (3.0.2.500)


SortedBasicWordInfoSet Constructor (capacity)

SortedBasicWordInfoSet Constructor (capacity)
ScrewTurn Wiki ► ScrewTurn.Wiki.SearchEngine ► SortedBasicWordInfoSet ► SortedBasicWordInfoSet(Int32)
Initializes a new instance of the SortedBasicWordInfoSet class.
Declaration Syntax
C# Visual Basic Visual C++
public SortedBasicWordInfoSet(
    int capacity
)
Public Sub New ( _
    capacity As Integer _
)
public:
SortedBasicWordInfoSet(
    int capacity
)
Parameters
capacity (Int32)
The initial capacity.
Exceptions
Exception | Condition
ArgumentOutOfRangeException | If capacity is null.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.SearchEngine (Module: ScrewTurn.Wiki.SearchEngine) Version: 3.0.2.500 (3.0.2.500)


Add Method (item)

Add Method (item)
ScrewTurn Wiki ► ScrewTurn.Wiki.SearchEngine ► SortedBasicWordInfoSet ► Add(BasicWordInfo)
Adds a new item to the set.
Declaration Syntax
C# Visual Basic Visual C++
public bool Add(
    BasicWordInfo item
)
Public Function Add ( _
    item As BasicWordInfo _
) As Boolean
public:
bool Add(
    BasicWordInfo^ item
)
Parameters
item (BasicWordInfo)
The item to add.
Return Value
true if the item is added, false otherwise.
Remarks
Adding an item is O(log n) if the item is already in the set, O(n) otherwise, where n is the number of items in the set.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.SearchEngine (Module: ScrewTurn.Wiki.SearchEngine) Version: 3.0.2.500 (3.0.2.500)


Capacity Property

Capacity Property
ScrewTurn Wiki ► ScrewTurn.Wiki.SearchEngine ► SortedBasicWordInfoSet ► Capacity
Gets the capacity of the set.
Declaration Syntax
C# Visual Basic Visual C++
public int Capacity { get; }
Public ReadOnly Property Capacity As Integer
public:
property int Capacity {
    int get ();
}

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.SearchEngine (Module: ScrewTurn.Wiki.SearchEngine) Version: 3.0.2.500 (3.0.2.500)


Clear Method

Clear Method
ScrewTurn Wiki ► ScrewTurn.Wiki.SearchEngine ► SortedBasicWordInfoSet ► Clear()()()
Clears the set.
Declaration Syntax
C# Visual Basic Visual C++
public void Clear()
Public Sub Clear
public:
void Clear()
Remarks
The operation is O(1).

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.SearchEngine (Module: ScrewTurn.Wiki.SearchEngine) Version: 3.0.2.500 (3.0.2.500)


Contains Method (item)

Contains Method (item)
ScrewTurn Wiki ► ScrewTurn.Wiki.SearchEngine ► SortedBasicWordInfoSet ► Contains(BasicWordInfo)
Determines whether the set contains an item.
Declaration Syntax
C# Visual Basic Visual C++
public bool Contains(
    BasicWordInfo item
)
Public Function Contains ( _
    item As BasicWordInfo _
) As Boolean
public:
bool Contains(
    BasicWordInfo^ item
)
Parameters
item (BasicWordInfo)
The item to look for.
Return Value
true if the set contains the specified item, false otherwise.
Remarks
The operation is O(log n), where n is the number of items in the set.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.SearchEngine (Module: ScrewTurn.Wiki.SearchEngine) Version: 3.0.2.500 (3.0.2.500)


Count Property

Count Property
ScrewTurn Wiki ► ScrewTurn.Wiki.SearchEngine ► SortedBasicWordInfoSet ► Count
Gets the count if the items in the set.
Declaration Syntax
C# Visual Basic Visual C++
public int Count { get; }
Public ReadOnly Property Count As Integer
public:
property int Count {
    int get ();
}

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.SearchEngine (Module: ScrewTurn.Wiki.SearchEngine) Version: 3.0.2.500 (3.0.2.500)


Item Property (index)

Item Property (index)
ScrewTurn Wiki ► ScrewTurn.Wiki.SearchEngine ► SortedBasicWordInfoSet ► Item[([(Int32])])
Gets an item from the set at a specific index.
Declaration Syntax
C# Visual Basic Visual C++
public BasicWordInfo this[
    int index
] { get; }
Public ReadOnly Default Property Item ( _
    index As Integer _
) As BasicWordInfo
public:
property BasicWordInfo^ default[int index] {
    BasicWordInfo^ get (int index);
}
Parameters
index (Int32)
The zero-based index of the element to get.
Return Value
The item at the specified index.
Exceptions
Exception | Condition
IndexOutOfRangeException | If index is outside the bounds of the collection.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.SearchEngine (Module: ScrewTurn.Wiki.SearchEngine) Version: 3.0.2.500 (3.0.2.500)


Remove Method (item)

Remove Method (item)
ScrewTurn Wiki ► ScrewTurn.Wiki.SearchEngine ► SortedBasicWordInfoSet ► Remove(BasicWordInfo)
Removes an item from the set.
Declaration Syntax
C# Visual Basic Visual C++
public bool Remove(
    BasicWordInfo item
)
Public Function Remove ( _
    item As BasicWordInfo _
) As Boolean
public:
bool Remove(
    BasicWordInfo^ item
)
Parameters
item (BasicWordInfo)
The item to remove.
Return Value
true if the item is removed, false otherwise.
Remarks
The operation is O(n), where n is the number of items in the set.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.SearchEngine (Module: ScrewTurn.Wiki.SearchEngine) Version: 3.0.2.500 (3.0.2.500)


ToString Method

ToString Method
ScrewTurn Wiki ► ScrewTurn.Wiki.SearchEngine ► SortedBasicWordInfoSet ► ToString()()()
Gets a string representation of the current instance.
Declaration Syntax
C# Visual Basic Visual C++
public override string ToString()
Public Overrides Function ToString As String
public:
virtual String^ ToString() override
Return Value
The string representation.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.SearchEngine (Module: ScrewTurn.Wiki.SearchEngine) Version: 3.0.2.500 (3.0.2.500)


Tools Class

Tools Class
ScrewTurn Wiki ► ScrewTurn.Wiki.SearchEngine ► Tools
Implements useful methods.
Declaration Syntax
C# Visual Basic Visual C++
public static class Tools
Public NotInheritable Class Tools
public ref class Tools abstract sealed
Members
All Members | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | CleanupKeywords(array<String>[]()[]) | Cleans up keyworks from invalid characters.
 | IsDocumentTypeTagIncluded(String, array<String>[]()[]) | Determines whether a document tag is contained in a tag array.
 | IsSplitChar(Char) | Determines whether a char is a split char.
 | PurgeResultsForAllWords(SearchResultCollection, array<String>[]()[]) | Purges the invalid results when SearchOptions is AllWords.
 | PurgeResultsForExactPhrase(SearchResultCollection, array<String>[]()[]) | Purges the invalid results when SearchOptions is ExactPhrase.
 | RemoveDiacriticsAndPunctuation(String, Boolean) | Removes "accents" and punctuation from a string, transforming it to lowercase (culture invariant).
 | RemoveStopWords(array<WordInfo>[]()[], array<String>[]()[]) | Removes stop words from a set of words (case insensitive).
 | SearchInternal(String, array<String>[]()[], Boolean, SearchOptions, IWordFetcher) | Performs a search in the index.
 | SkipSplitChars(UInt16, String) | Computes the index of the first non-split char given a start index.
 | Tokenize(String, WordLocation) | Tokenizes a string.
 | Tokenize(String) | Tokenizes a string.
Inheritance Hierarchy
Object
Tools

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.SearchEngine (Module: ScrewTurn.Wiki.SearchEngine) Version: 3.0.2.500 (3.0.2.500)


CleanupKeywords Method (keywords)

CleanupKeywords Method (keywords)
ScrewTurn Wiki ► ScrewTurn.Wiki.SearchEngine ► Tools ► CleanupKeywords(array<String>[]()[])
Cleans up keyworks from invalid characters.
Declaration Syntax
C# Visual Basic Visual C++
public static string[] CleanupKeywords(
    string[] keywords
)
Public Shared Function CleanupKeywords ( _
    keywords As String() _
) As String()
public:
static array<String^>^ CleanupKeywords(
    array<String^>^ keywords
)
Parameters
keywords (array< String >[]()[][])
The keywords to cleanup.
Return Value
The clean keywords.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.SearchEngine (Module: ScrewTurn.Wiki.SearchEngine) Version: 3.0.2.500 (3.0.2.500)


IsDocumentTypeTagIncluded Method (currentTag, includedTags)

IsDocumentTypeTagIncluded Method (currentTag, includedTags)
ScrewTurn Wiki ► ScrewTurn.Wiki.SearchEngine ► Tools ► IsDocumentTypeTagIncluded(String, array<String>[]()[])
Determines whether a document tag is contained in a tag array.
Declaration Syntax
C# Visual Basic Visual C++
public static bool IsDocumentTypeTagIncluded(
    string currentTag,
    string[] includedTags
)
Public Shared Function IsDocumentTypeTagIncluded ( _
    currentTag As String, _
    includedTags As String() _
) As Boolean
public:
static bool IsDocumentTypeTagIncluded(
    String^ currentTag,
    array<String^>^ includedTags
)
Parameters
currentTag (String)
The tag to check for.
includedTags (array< String >[]()[][])
The tag array.
Return Value
true if currentTag is contained in includedTags, false otherwise.
Remarks
The comparison is case-insensitive.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.SearchEngine (Module: ScrewTurn.Wiki.SearchEngine) Version: 3.0.2.500 (3.0.2.500)


IsSplitChar Method (current)

IsSplitChar Method (current)
ScrewTurn Wiki ► ScrewTurn.Wiki.SearchEngine ► Tools ► IsSplitChar(Char)
Determines whether a char is a split char.
Declaration Syntax
C# Visual Basic Visual C++
public static bool IsSplitChar(
    char current
)
Public Shared Function IsSplitChar ( _
    current As Char _
) As Boolean
public:
static bool IsSplitChar(
    wchar_t current
)
Parameters
current (Char)
The current char.
Return Value
true if the char is a split char, false otherwise.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.SearchEngine (Module: ScrewTurn.Wiki.SearchEngine) Version: 3.0.2.500 (3.0.2.500)


PurgeResultsForAllWords Method (results, queryWords)

PurgeResultsForAllWords Method (results, queryWords)
ScrewTurn Wiki ► ScrewTurn.Wiki.SearchEngine ► Tools ► PurgeResultsForAllWords(SearchResultCollection, array<String>[]()[])
Purges the invalid results when SearchOptions is AllWords.
Declaration Syntax
C# Visual Basic Visual C++
public static float PurgeResultsForAllWords(
    SearchResultCollection results,
    string[] queryWords
)
Public Shared Function PurgeResultsForAllWords ( _
    results As SearchResultCollection, _
    queryWords As String() _
) As Single
public:
static float PurgeResultsForAllWords(
    SearchResultCollection^ results,
    array<String^>^ queryWords
)
Parameters
results (SearchResultCollection)
The results to purge.
queryWords (array< String >[]()[][])
The query words.
Return Value
The relevance value of the removed matches.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.SearchEngine (Module: ScrewTurn.Wiki.SearchEngine) Version: 3.0.2.500 (3.0.2.500)


PurgeResultsForExactPhrase Method (results, queryWords)

PurgeResultsForExactPhrase Method (results, queryWords)
ScrewTurn Wiki ► ScrewTurn.Wiki.SearchEngine ► Tools ► PurgeResultsForExactPhrase(SearchResultCollection, array<String>[]()[])
Purges the invalid results when SearchOptions is ExactPhrase.
Declaration Syntax
C# Visual Basic Visual C++
public static float PurgeResultsForExactPhrase(
    SearchResultCollection results,
    string[] queryWords
)
Public Shared Function PurgeResultsForExactPhrase ( _
    results As SearchResultCollection, _
    queryWords As String() _
) As Single
public:
static float PurgeResultsForExactPhrase(
    SearchResultCollection^ results,
    array<String^>^ queryWords
)
Parameters
results (SearchResultCollection)
The results to purge.
queryWords (array< String >[]()[][])
The query words.
Return Value
The relevance value of the removed matches.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.SearchEngine (Module: ScrewTurn.Wiki.SearchEngine) Version: 3.0.2.500 (3.0.2.500)


RemoveDiacriticsAndPunctuation Method (input, isSingleWord)

RemoveDiacriticsAndPunctuation Method (input, isSingleWord)
ScrewTurn Wiki ► ScrewTurn.Wiki.SearchEngine ► Tools ► RemoveDiacriticsAndPunctuation(String, Boolean)
Removes "accents" and punctuation from a string, transforming it to lowercase (culture invariant).
Declaration Syntax
C# Visual Basic Visual C++
public static string RemoveDiacriticsAndPunctuation(
    string input,
    bool isSingleWord
)
Public Shared Function RemoveDiacriticsAndPunctuation ( _
    input As String, _
    isSingleWord As Boolean _
) As String
public:
static String^ RemoveDiacriticsAndPunctuation(
    String^ input,
    bool isSingleWord
)
Parameters
input (String)
The input string.
isSingleWord (Boolean)
A value indicating whether the input string is a single word.
Return Value
The normalized string (lowercase, culture invariant). Can be empty.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.SearchEngine (Module: ScrewTurn.Wiki.SearchEngine) Version: 3.0.2.500 (3.0.2.500)


RemoveStopWords Method (words, stopWords)

RemoveStopWords Method (words, stopWords)
ScrewTurn Wiki ► ScrewTurn.Wiki.SearchEngine ► Tools ► RemoveStopWords(array<WordInfo>[]()[], array<String>[]()[])
Removes stop words from a set of words (case insensitive).
Declaration Syntax
C# Visual Basic Visual C++
public static WordInfo[] RemoveStopWords(
    WordInfo[] words,
    string[] stopWords
)
Public Shared Function RemoveStopWords ( _
    words As WordInfo(), _
    stopWords As String() _
) As WordInfo()
public:
static array<WordInfo^>^ RemoveStopWords(
    array<WordInfo^>^ words,
    array<String^>^ stopWords
)
Parameters
words (array< WordInfo >[]()[][])
The input words.
stopWords (array< String >[]()[][])
The array of stop words.
Return Value
The input words without the stop words.
Exceptions
Exception | Condition
ArgumentNullException | If words or stopWords are null.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.SearchEngine (Module: ScrewTurn.Wiki.SearchEngine) Version: 3.0.2.500 (3.0.2.500)


SearchInternal Method (query, documentTypeTags, filterDocumentType, options, fetcher)

SearchInternal Method (query, documentTypeTags, filterDocumentType, options, fetcher)
ScrewTurn Wiki ► ScrewTurn.Wiki.SearchEngine ► Tools ► SearchInternal(String, array<String>[]()[], Boolean, SearchOptions, IWordFetcher)
Performs a search in the index.
Declaration Syntax
C# Visual Basic Visual C++
public static SearchResultCollection SearchInternal(
    string query,
    string[] documentTypeTags,
    bool filterDocumentType,
    SearchOptions options,
    IWordFetcher fetcher
)
Public Shared Function SearchInternal ( _
    query As String, _
    documentTypeTags As String(), _
    filterDocumentType As Boolean, _
    options As SearchOptions, _
    fetcher As IWordFetcher _
) As SearchResultCollection
public:
static SearchResultCollection^ SearchInternal(
    String^ query,
    array<String^>^ documentTypeTags,
    bool filterDocumentType,
    SearchOptions options,
    IWordFetcher^ fetcher
)
Parameters
query (String)
The search query.
documentTypeTags (array< String >[]()[][])
The document type tags to include in the search.
filterDocumentType (Boolean)
true to apply the filter on the document type.
options (SearchOptions)
The search options.
fetcher (IWordFetcher)
An object that is able to fetch words.
Return Value
The results.
Exceptions
Exception | Condition
ArgumentNullException | If query or fetcher are null.
ArgumentException | If query is empty.
ArgumentNullException | If filterDocumentType is true and documentTypeTags is null.
ArgumentException | If filterDocumentType is true and documentTypeTags is empty.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.SearchEngine (Module: ScrewTurn.Wiki.SearchEngine) Version: 3.0.2.500 (3.0.2.500)


SkipSplitChars Method (startIndex, content)

SkipSplitChars Method (startIndex, content)
ScrewTurn Wiki ► ScrewTurn.Wiki.SearchEngine ► Tools ► SkipSplitChars(UInt16, String)
Computes the index of the first non-split char given a start index.
Declaration Syntax
C# Visual Basic Visual C++
public static ushort SkipSplitChars(
    ushort startIndex,
    string content
)
Public Shared Function SkipSplitChars ( _
    startIndex As UShort, _
    content As String _
) As UShort
public:
static unsigned short SkipSplitChars(
    unsigned short startIndex,
    String^ content
)
Parameters
startIndex (UInt16)
The start index.
content (String)
The content.
Return Value
The index of the first non-split char.
Exceptions
Exception | Condition
ArgumentNullException | If content is null.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.SearchEngine (Module: ScrewTurn.Wiki.SearchEngine) Version: 3.0.2.500 (3.0.2.500)


Tokenize Method

Tokenize Method
ScrewTurn Wiki ► ScrewTurn.Wiki.SearchEngine ► Tools ► Tokenize()()()
Members
Icon | Member | Description
 | Tokenize(String, WordLocation) | Tokenizes a string.
 | Tokenize(String) | Tokenizes a string.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.SearchEngine (Module: ScrewTurn.Wiki.SearchEngine) Version: 3.0.2.500 (3.0.2.500)


Tokenize Method (text)

Tokenize Method (text)
ScrewTurn Wiki ► ScrewTurn.Wiki.SearchEngine ► Tools ► Tokenize(String)
Tokenizes a string.
Declaration Syntax
C# Visual Basic Visual C++
public static WordInfo[] Tokenize(
    string text
)
Public Shared Function Tokenize ( _
    text As String _
) As WordInfo()
public:
static array<WordInfo^>^ Tokenize(
    String^ text
)
Parameters
text (String)
The text to tokenize.
Return Value

[Missing <returns> documentation for "M:ScrewTurn.Wiki.SearchEngine.Tools.Tokenize(System.String)"]

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.SearchEngine (Module: ScrewTurn.Wiki.SearchEngine) Version: 3.0.2.500 (3.0.2.500)


Tokenize Method (text, location)

Tokenize Method (text, location)
ScrewTurn Wiki ► ScrewTurn.Wiki.SearchEngine ► Tools ► Tokenize(String, WordLocation)
Tokenizes a string.
Declaration Syntax
C# Visual Basic Visual C++
public static WordInfo[] Tokenize(
    string text,
    WordLocation location
)
Public Shared Function Tokenize ( _
    text As String, _
    location As WordLocation _
) As WordInfo()
public:
static array<WordInfo^>^ Tokenize(
    String^ text,
    WordLocation^ location
)
Parameters
text (String)
The text to tokenize.
location (WordLocation)
The location of the words that are extracted.
Return Value
The tokens.
Exceptions
Exception | Condition
ArgumentNullException | If text is null.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.SearchEngine (Module: ScrewTurn.Wiki.SearchEngine) Version: 3.0.2.500 (3.0.2.500)


Word Class

Word Class
ScrewTurn Wiki ► ScrewTurn.Wiki.SearchEngine ► Word
Represents a word in a document.
Declaration Syntax
C# Visual Basic Visual C++
public class Word
Public Class Word
public ref class Word
Members
All Members | Constructors | Methods | Properties | Fields
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | Word(UInt32, String) | Initializes a new instance of the Word class.
 | Word(UInt32, String, OccurrenceDictionary) | Initializes a new instance of the Word class.
 | AddOccurrence(IDocument, UInt16, UInt16, WordLocation) | Stores an occurrence.
 | BulkAddOccurrences(IDocument, SortedBasicWordInfoSet) | Adds a bulk of occurrences of the word in a document, removing all the old positions, if any.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | id | The word unique ID.
 | ID | Gets or sets the unique ID of the word.
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | occurrences | The occurrences.
 | Occurrences | Gets the occurrences.
 | RemoveOccurrences(IDocument) | Removes all the occurrences for a document.
 | text | The word text, lowercase.
 | Text | Gets the text of the word (lowercase).
 | ToString()()() | Gets a string representation of the current instance. (Overrides Object.ToString()()().)
 | TotalOccurrences | Gets the total occurrences.
Remarks
All instance and static members are thread-safe.
Inheritance Hierarchy
Object
Word

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.SearchEngine (Module: ScrewTurn.Wiki.SearchEngine) Version: 3.0.2.500 (3.0.2.500)


Word Constructor

Word Constructor
ScrewTurn Wiki ► ScrewTurn.Wiki.SearchEngine ► Word ► Word()()()
Members
Icon | Member | Description
 | Word(UInt32, String) | Initializes a new instance of the Word class.
 | Word(UInt32, String, OccurrenceDictionary) | Initializes a new instance of the Word class.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.SearchEngine (Module: ScrewTurn.Wiki.SearchEngine) Version: 3.0.2.500 (3.0.2.500)


Word Constructor (id, text)

Word Constructor (id, text)
ScrewTurn Wiki ► ScrewTurn.Wiki.SearchEngine ► Word ► Word(UInt32, String)
Initializes a new instance of the Word class.
Declaration Syntax
C# Visual Basic Visual C++
public Word(
    uint id,
    string text
)
Public Sub New ( _
    id As UInteger, _
    text As String _
)
public:
Word(
    unsigned int id,
    String^ text
)
Parameters
id (UInt32)
The word ID.
text (String)
The text of the word (lowercase).
Exceptions
Exception | Condition
ArgumentNullException | If text is null.
ArgumentException | If text is empty.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.SearchEngine (Module: ScrewTurn.Wiki.SearchEngine) Version: 3.0.2.500 (3.0.2.500)


Word Constructor (id, text, occurrences)

Word Constructor (id, text, occurrences)
ScrewTurn Wiki ► ScrewTurn.Wiki.SearchEngine ► Word ► Word(UInt32, String, OccurrenceDictionary)
Initializes a new instance of the Word class.
Declaration Syntax
C# Visual Basic Visual C++
public Word(
    uint id,
    string text,
    OccurrenceDictionary occurrences
)
Public Sub New ( _
    id As UInteger, _
    text As String, _
    occurrences As OccurrenceDictionary _
)
public:
Word(
    unsigned int id,
    String^ text,
    OccurrenceDictionary^ occurrences
)
Parameters
id (UInt32)
The word ID.
text (String)
The text of the word (lowercase).
occurrences (OccurrenceDictionary)
The occurrences.
Exceptions
Exception | Condition
ArgumentNullException | If text or occurrences are null.
ArgumentException | If text is empty.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.SearchEngine (Module: ScrewTurn.Wiki.SearchEngine) Version: 3.0.2.500 (3.0.2.500)


AddOccurrence Method (document, firstCharIndex, wordIndex, location)

AddOccurrence Method (document, firstCharIndex, wordIndex, location)
ScrewTurn Wiki ► ScrewTurn.Wiki.SearchEngine ► Word ► AddOccurrence(IDocument, UInt16, UInt16, WordLocation)
Stores an occurrence.
Declaration Syntax
C# Visual Basic Visual C++
public void AddOccurrence(
    IDocument document,
    ushort firstCharIndex,
    ushort wordIndex,
    WordLocation location
)
Public Sub AddOccurrence ( _
    document As IDocument, _
    firstCharIndex As UShort, _
    wordIndex As UShort, _
    location As WordLocation _
)
public:
void AddOccurrence(
    IDocument^ document,
    unsigned short firstCharIndex,
    unsigned short wordIndex,
    WordLocation^ location
)
Parameters
document (IDocument)
The document the occurrence is referred to.
firstCharIndex (UInt16)
The index of the first character of the word in the document.
wordIndex (UInt16)
The index of the word in the document.
location (WordLocation)
The location of the word.
Remarks
Adding an occurrence is O(n), where n is the number of occurrences of the word already stored for the same document. If there were no occurrences previously stored, the operation is O(1).
Exceptions
Exception | Condition
ArgumentNullException | If document is null.
ArgumentOutOfRangeException | If firstCharIndex or wordIndex are less than zero.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.SearchEngine (Module: ScrewTurn.Wiki.SearchEngine) Version: 3.0.2.500 (3.0.2.500)


BulkAddOccurrences Method (document, positions)

BulkAddOccurrences Method (document, positions)
ScrewTurn Wiki ► ScrewTurn.Wiki.SearchEngine ► Word ► BulkAddOccurrences(IDocument, SortedBasicWordInfoSet)
Adds a bulk of occurrences of the word in a document, removing all the old positions, if any.
Declaration Syntax
C# Visual Basic Visual C++
public void BulkAddOccurrences(
    IDocument document,
    SortedBasicWordInfoSet positions
)
Public Sub BulkAddOccurrences ( _
    document As IDocument, _
    positions As SortedBasicWordInfoSet _
)
public:
void BulkAddOccurrences(
    IDocument^ document,
    SortedBasicWordInfoSet^ positions
)
Parameters
document (IDocument)
The document.
positions (SortedBasicWordInfoSet)
The positions.
Remarks
If positions is empty, the effect of the invocation of the method is equal to that of RemoveOccurrences(IDocument) with the same document. Bulk-adding the occurrences is O(1).
Exceptions
Exception | Condition
ArgumentNullException | If document or positions are null.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.SearchEngine (Module: ScrewTurn.Wiki.SearchEngine) Version: 3.0.2.500 (3.0.2.500)


id Field

id Field
ScrewTurn Wiki ► ScrewTurn.Wiki.SearchEngine ► Word ► id
The word unique ID.
Declaration Syntax
C# Visual Basic Visual C++
protected uint id
Protected id As UInteger
protected:
unsigned int id

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.SearchEngine (Module: ScrewTurn.Wiki.SearchEngine) Version: 3.0.2.500 (3.0.2.500)


ID Property

ID Property
ScrewTurn Wiki ► ScrewTurn.Wiki.SearchEngine ► Word ► ID
Gets or sets the unique ID of the word.
Declaration Syntax
C# Visual Basic Visual C++
public uint ID { get; set; }
Public Property ID As UInteger
public:
property unsigned int ID {
    unsigned int get ();
    void set (unsigned int value);
}

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.SearchEngine (Module: ScrewTurn.Wiki.SearchEngine) Version: 3.0.2.500 (3.0.2.500)


occurrences Field

occurrences Field
ScrewTurn Wiki ► ScrewTurn.Wiki.SearchEngine ► Word ► occurrences
The occurrences.
Declaration Syntax
C# Visual Basic Visual C++
protected OccurrenceDictionary occurrences
Protected occurrences As OccurrenceDictionary
protected:
OccurrenceDictionary^ occurrences

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.SearchEngine (Module: ScrewTurn.Wiki.SearchEngine) Version: 3.0.2.500 (3.0.2.500)


Occurrences Property

Occurrences Property
ScrewTurn Wiki ► ScrewTurn.Wiki.SearchEngine ► Word ► Occurrences
Gets the occurrences.
Declaration Syntax
C# Visual Basic Visual C++
public OccurrenceDictionary Occurrences { get; }
Public ReadOnly Property Occurrences As OccurrenceDictionary
public:
property OccurrenceDictionary^ Occurrences {
    OccurrenceDictionary^ get ();
}

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.SearchEngine (Module: ScrewTurn.Wiki.SearchEngine) Version: 3.0.2.500 (3.0.2.500)


RemoveOccurrences Method (document)

RemoveOccurrences Method (document)
ScrewTurn Wiki ► ScrewTurn.Wiki.SearchEngine ► Word ► RemoveOccurrences(IDocument)
Removes all the occurrences for a document.
Declaration Syntax
C# Visual Basic Visual C++
public List<DumpedWordMapping> RemoveOccurrences(
    IDocument document
)
Public Function RemoveOccurrences ( _
    document As IDocument _
) As List(Of DumpedWordMapping)
public:
List<DumpedWordMapping^>^ RemoveOccurrences(
    IDocument^ document
)
Parameters
document (IDocument)
The document to remove the occurrences of.
Return Value
The dumped word mappings for the removed word occurrences.
Remarks
Removing the occurrences for the document is O(1).
Exceptions
Exception | Condition
ArgumentNullException | If document is null.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.SearchEngine (Module: ScrewTurn.Wiki.SearchEngine) Version: 3.0.2.500 (3.0.2.500)


text Field

text Field
ScrewTurn Wiki ► ScrewTurn.Wiki.SearchEngine ► Word ► text
The word text, lowercase.
Declaration Syntax
C# Visual Basic Visual C++
protected string text
Protected text As String
protected:
String^ text

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.SearchEngine (Module: ScrewTurn.Wiki.SearchEngine) Version: 3.0.2.500 (3.0.2.500)


Text Property

Text Property
ScrewTurn Wiki ► ScrewTurn.Wiki.SearchEngine ► Word ► Text
Gets the text of the word (lowercase).
Declaration Syntax
C# Visual Basic Visual C++
public string Text { get; }
Public ReadOnly Property Text As String
public:
property String^ Text {
    String^ get ();
}

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.SearchEngine (Module: ScrewTurn.Wiki.SearchEngine) Version: 3.0.2.500 (3.0.2.500)


ToString Method

ToString Method
ScrewTurn Wiki ► ScrewTurn.Wiki.SearchEngine ► Word ► ToString()()()
Gets a string representation of the current instance.
Declaration Syntax
C# Visual Basic Visual C++
public override string ToString()
Public Overrides Function ToString As String
public:
virtual String^ ToString() override
Return Value
The string representation.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.SearchEngine (Module: ScrewTurn.Wiki.SearchEngine) Version: 3.0.2.500 (3.0.2.500)


TotalOccurrences Property

TotalOccurrences Property
ScrewTurn Wiki ► ScrewTurn.Wiki.SearchEngine ► Word ► TotalOccurrences
Gets the total occurrences.
Declaration Syntax
C# Visual Basic Visual C++
public int TotalOccurrences { get; }
Public ReadOnly Property TotalOccurrences As Integer
public:
property int TotalOccurrences {
    int get ();
}
Remarks
Computing the result is O(n), where n is the number of documents the word occurs in at least one time.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.SearchEngine (Module: ScrewTurn.Wiki.SearchEngine) Version: 3.0.2.500 (3.0.2.500)


WordId Class

WordId Class
ScrewTurn Wiki ► ScrewTurn.Wiki.SearchEngine ► WordId
Describes the ID of a word.
Declaration Syntax
C# Visual Basic Visual C++
public class WordId
Public Class WordId
public ref class WordId
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | WordId(String, UInt32) | Initializes a new instance of the WordId class.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | ID | Gets the word ID.
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Text | Gets the word text.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
WordId

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.SearchEngine (Module: ScrewTurn.Wiki.SearchEngine) Version: 3.0.2.500 (3.0.2.500)


WordId Constructor (text, id)

WordId Constructor (text, id)
ScrewTurn Wiki ► ScrewTurn.Wiki.SearchEngine ► WordId ► WordId(String, UInt32)
Initializes a new instance of the WordId class.
Declaration Syntax
C# Visual Basic Visual C++
public WordId(
    string text,
    uint id
)
Public Sub New ( _
    text As String, _
    id As UInteger _
)
public:
WordId(
    String^ text,
    unsigned int id
)
Parameters
text (String)
The word text, lowercase.
id (UInt32)
The word ID.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.SearchEngine (Module: ScrewTurn.Wiki.SearchEngine) Version: 3.0.2.500 (3.0.2.500)


ID Property

ID Property
ScrewTurn Wiki ► ScrewTurn.Wiki.SearchEngine ► WordId ► ID
Gets the word ID.
Declaration Syntax
C# Visual Basic Visual C++
public uint ID { get; }
Public ReadOnly Property ID As UInteger
public:
property unsigned int ID {
    unsigned int get ();
}

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.SearchEngine (Module: ScrewTurn.Wiki.SearchEngine) Version: 3.0.2.500 (3.0.2.500)


Text Property

Text Property
ScrewTurn Wiki ► ScrewTurn.Wiki.SearchEngine ► WordId ► Text
Gets the word text.
Declaration Syntax
C# Visual Basic Visual C++
public string Text { get; }
Public ReadOnly Property Text As String
public:
property String^ Text {
    String^ get ();
}

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.SearchEngine (Module: ScrewTurn.Wiki.SearchEngine) Version: 3.0.2.500 (3.0.2.500)


WordInfo Class

WordInfo Class
ScrewTurn Wiki ► ScrewTurn.Wiki.SearchEngine ► WordInfo
Contains full information about a word in a document.
Declaration Syntax
C# Visual Basic Visual C++
public class WordInfo : BasicWordInfo, IEquatable<WordInfo>,
    IComparable<WordInfo>
Public Class WordInfo _
    Inherits BasicWordInfo _
    Implements IEquatable(Of WordInfo), IComparable(Of WordInfo)
public ref class WordInfo : public BasicWordInfo,
    IEquatable<WordInfo^>, IComparable<WordInfo^>
Members
All Members | Constructors | Methods | Properties | Fields
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | WordInfo(String, UInt16, UInt16, WordLocation) | Initializes a new instance of the WordInfo class.
 | CompareTo(WordInfo) | Compares the current instance with another instance.
 | CompareTo(BasicWordInfo) | Compares the current instance with another instance. (Inherited from BasicWordInfo.)
 | Equality(WordInfo, WordInfo) | Applies the value-equality operator to two WordInfo objects.
 | Equals(Object) | Determinates whether the current instance is equal to an instance of an object. (Overrides BasicWordInfo.Equals(Object).)
 | Equals(WordInfo) | Determinates whether the current instance is value-equal to another.
 | Equals(BasicWordInfo) | Determinates whether the current instance is value-equal to another. (Inherited from BasicWordInfo.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | firstCharIndex | The index in the original document the word starts at. (Inherited from BasicWordInfo.)
 | FirstCharIndex | Gets the index of the first character of the word in the document. (Inherited from BasicWordInfo.)
 | GetHashCode()()() | Gets the hash code of the current instance. (Overrides BasicWordInfo.GetHashCode()()().)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | Inequality(WordInfo, WordInfo) | Applies the value-equality operator to two WordInfo objects.
 | location | The location of the word in the document. (Inherited from BasicWordInfo.)
 | Location | Gets the location of the word in the document. (Inherited from BasicWordInfo.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | text | The word text.
 | Text | Gets the text of the word.
 | ToString()()() | Gets a string representation of the current instance. (Overrides Object.ToString()()().)
 | wordIndex | The index of the word in the document. (Inherited from BasicWordInfo.)
 | WordIndex | Gets the index of the word in the document. (Inherited from BasicWordInfo.)
Inheritance Hierarchy
Object
 | BasicWordInfo
 |  | WordInfo

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.SearchEngine (Module: ScrewTurn.Wiki.SearchEngine) Version: 3.0.2.500 (3.0.2.500)


WordInfo Constructor (text, firstCharIndex, wordIndex, location)

WordInfo Constructor (text, firstCharIndex, wordIndex, location)
ScrewTurn Wiki ► ScrewTurn.Wiki.SearchEngine ► WordInfo ► WordInfo(String, UInt16, UInt16, WordLocation)
Initializes a new instance of the WordInfo class.
Declaration Syntax
C# Visual Basic Visual C++
public WordInfo(
    string text,
    ushort firstCharIndex,
    ushort wordIndex,
    WordLocation location
)
Public Sub New ( _
    text As String, _
    firstCharIndex As UShort, _
    wordIndex As UShort, _
    location As WordLocation _
)
public:
WordInfo(
    String^ text,
    unsigned short firstCharIndex,
    unsigned short wordIndex,
    WordLocation^ location
)
Parameters
text (String)
The text of the word.
firstCharIndex (UInt16)
The index of the first character of the word in the document.
wordIndex (UInt16)
The index of the word in the document.
location (WordLocation)
The location of the word in the document.
Exceptions
Exception | Condition
ArgumentNullException | If text is null.
ArgumentException | If text is empty.
ArgumentOutOfRangeException | If firstCharIndex or wordIndex are less than zero.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.SearchEngine (Module: ScrewTurn.Wiki.SearchEngine) Version: 3.0.2.500 (3.0.2.500)


CompareTo Method (other)

CompareTo Method (other)
ScrewTurn Wiki ► ScrewTurn.Wiki.SearchEngine ► WordInfo ► CompareTo(WordInfo)
Compares the current instance with another instance.
Declaration Syntax
C# Visual Basic Visual C++
public int CompareTo(
    WordInfo other
)
Public Function CompareTo ( _
    other As WordInfo _
) As Integer
public:
virtual int CompareTo(
    WordInfo^ other
) sealed
Parameters
other (WordInfo)
The other instance.
Return Value
The comparison result.
Remarks
The First Char Index does not partecipate to the comparison.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.SearchEngine (Module: ScrewTurn.Wiki.SearchEngine) Version: 3.0.2.500 (3.0.2.500)


Equality Operator

Equality Operator
ScrewTurn Wiki ► ScrewTurn.Wiki.SearchEngine ► WordInfo ► Equality(WordInfo, WordInfo)
Applies the value-equality operator to two WordInfo objects.
Declaration Syntax
C# Visual Basic Visual C++
public static bool operator ==(
    WordInfo x,
    WordInfo y
)
Public Shared Operator = ( _
    x As WordInfo, _
    y As WordInfo _
) As Boolean
public:
static bool operator ==(
    WordInfo^ x,
    WordInfo^ y
)
Parameters
x (WordInfo)
The first object.
y (WordInfo)
The second object.
Return Value
true if the objects are value-equal, false otherwise.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.SearchEngine (Module: ScrewTurn.Wiki.SearchEngine) Version: 3.0.2.500 (3.0.2.500)


Equals Method

Equals Method
ScrewTurn Wiki ► ScrewTurn.Wiki.SearchEngine ► WordInfo ► Equals()()()
Members
Icon | Member | Description
 | Equals(Object) | Determinates whether the current instance is equal to an instance of an object. (Overrides BasicWordInfo.Equals(Object).)
 | Equals(WordInfo) | Determinates whether the current instance is value-equal to another.
 | Equals(BasicWordInfo) | Determinates whether the current instance is value-equal to another.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.SearchEngine (Module: ScrewTurn.Wiki.SearchEngine) Version: 3.0.2.500 (3.0.2.500)


Equals Method (other)

Equals Method (other)
ScrewTurn Wiki ► ScrewTurn.Wiki.SearchEngine ► WordInfo ► Equals(WordInfo)
Determinates whether the current instance is value-equal to another.
Declaration Syntax
C# Visual Basic Visual C++
public bool Equals(
    WordInfo other
)
Public Function Equals ( _
    other As WordInfo _
) As Boolean
public:
virtual bool Equals(
    WordInfo^ other
) sealed
Parameters
other (WordInfo)
The other instance.
Return Value
true if the instances are value-equal, false otherwise.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.SearchEngine (Module: ScrewTurn.Wiki.SearchEngine) Version: 3.0.2.500 (3.0.2.500)


Equals Method (other)

Equals Method (other)
ScrewTurn Wiki ► ScrewTurn.Wiki.SearchEngine ► WordInfo ► Equals(Object)
Determinates whether the current instance is equal to an instance of an object.
Declaration Syntax
C# Visual Basic Visual C++
public override bool Equals(
    Object other
)
Public Overrides Function Equals ( _
    other As Object _
) As Boolean
public:
virtual bool Equals(
    Object^ other
) override
Parameters
other (Object)
The instance of the object.
Return Value
true if the instances are value-equal, false otherwise.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.SearchEngine (Module: ScrewTurn.Wiki.SearchEngine) Version: 3.0.2.500 (3.0.2.500)


GetHashCode Method

GetHashCode Method
ScrewTurn Wiki ► ScrewTurn.Wiki.SearchEngine ► WordInfo ► GetHashCode()()()
Gets the hash code of the current instance.
Declaration Syntax
C# Visual Basic Visual C++
public override int GetHashCode()
Public Overrides Function GetHashCode As Integer
public:
virtual int GetHashCode() override
Return Value
The hash code.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.SearchEngine (Module: ScrewTurn.Wiki.SearchEngine) Version: 3.0.2.500 (3.0.2.500)


Inequality Operator

Inequality Operator
ScrewTurn Wiki ► ScrewTurn.Wiki.SearchEngine ► WordInfo ► Inequality(WordInfo, WordInfo)
Applies the value-equality operator to two WordInfo objects.
Declaration Syntax
C# Visual Basic Visual C++
public static bool operator !=(
    WordInfo x,
    WordInfo y
)
Public Shared Operator <> ( _
    x As WordInfo, _
    y As WordInfo _
) As Boolean
public:
static bool operator !=(
    WordInfo^ x,
    WordInfo^ y
)
Parameters
x (WordInfo)
The first object.
y (WordInfo)
The second object.
Return Value
true if the objects are not value-equal, false otherwise.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.SearchEngine (Module: ScrewTurn.Wiki.SearchEngine) Version: 3.0.2.500 (3.0.2.500)


text Field

text Field
ScrewTurn Wiki ► ScrewTurn.Wiki.SearchEngine ► WordInfo ► text
The word text.
Declaration Syntax
C# Visual Basic Visual C++
protected string text
Protected text As String
protected:
String^ text

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.SearchEngine (Module: ScrewTurn.Wiki.SearchEngine) Version: 3.0.2.500 (3.0.2.500)


Text Property

Text Property
ScrewTurn Wiki ► ScrewTurn.Wiki.SearchEngine ► WordInfo ► Text
Gets the text of the word.
Declaration Syntax
C# Visual Basic Visual C++
public string Text { get; }
Public ReadOnly Property Text As String
public:
property String^ Text {
    String^ get ();
}

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.SearchEngine (Module: ScrewTurn.Wiki.SearchEngine) Version: 3.0.2.500 (3.0.2.500)


ToString Method

ToString Method
ScrewTurn Wiki ► ScrewTurn.Wiki.SearchEngine ► WordInfo ► ToString()()()
Gets a string representation of the current instance.
Declaration Syntax
C# Visual Basic Visual C++
public override string ToString()
Public Overrides Function ToString As String
public:
virtual String^ ToString() override
Return Value
The string representation.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.SearchEngine (Module: ScrewTurn.Wiki.SearchEngine) Version: 3.0.2.500 (3.0.2.500)


WordInfoCollection Class

WordInfoCollection Class
ScrewTurn Wiki ► ScrewTurn.Wiki.SearchEngine ► WordInfoCollection
Contains a collection of MatchInfo objects, sorted by index.
Declaration Syntax
C# Visual Basic Visual C++
public class WordInfoCollection : ICollection<WordInfo>,
    IEnumerable<WordInfo>, IEnumerable
Public Class WordInfoCollection _
    Implements ICollection(Of WordInfo), IEnumerable(Of WordInfo),  _
    IEnumerable
public ref class WordInfoCollection : ICollection<WordInfo^>,
    IEnumerable<WordInfo^>, IEnumerable
Members
All Members | Constructors | Methods | Properties | Fields
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | WordInfoCollection()()() | Initializes a new instance of the WordInfoCollection class.
 | WordInfoCollection(Int32) | Initializes a new instance of the WordInfoCollection class.
 | Add(WordInfo) | Adds an item to the collection.
 | Capacity | Gets the capacity of the collection.
 | Clear()()() | Clears the collection.
 | Contains(WordInfo) | Determines whether an item is in the collection.
 | Contains(String) | Determines whether a word is in the collection.
 | ContainsOccurrence(String, Int32) | Determines whether a word occurrence is in the collection.
 | CopyTo(array<WordInfo>[]()[], Int32) | Copies the collection items to an array.
 | Count | Gets the number of items in the collection.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetEnumerator()()() | Returns an enumerator that iterates through the items of the collection.
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | IsReadOnly | Gets a value indicating whether the collection is read-only.
 | Item[([(Int32])]) | Gets an item of the collection.
 | items | The items of the collection.
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Remove(WordInfo) | Removes an item from the collection.
 | ToString()()() | Returns a string representation of the current instance. (Overrides Object.ToString()()().)
Inheritance Hierarchy
Object
WordInfoCollection

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.SearchEngine (Module: ScrewTurn.Wiki.SearchEngine) Version: 3.0.2.500 (3.0.2.500)


WordInfoCollection Constructor

WordInfoCollection Constructor
ScrewTurn Wiki ► ScrewTurn.Wiki.SearchEngine ► WordInfoCollection ► WordInfoCollection()()()
Members
Icon | Member | Description
 | WordInfoCollection()()() | Initializes a new instance of the WordInfoCollection class.
 | WordInfoCollection(Int32) | Initializes a new instance of the WordInfoCollection class.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.SearchEngine (Module: ScrewTurn.Wiki.SearchEngine) Version: 3.0.2.500 (3.0.2.500)


WordInfoCollection Constructor

WordInfoCollection Constructor
ScrewTurn Wiki ► ScrewTurn.Wiki.SearchEngine ► WordInfoCollection ► WordInfoCollection()()()
Initializes a new instance of the WordInfoCollection class.
Declaration Syntax
C# Visual Basic Visual C++
public WordInfoCollection()
Public Sub New
public:
WordInfoCollection()

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.SearchEngine (Module: ScrewTurn.Wiki.SearchEngine) Version: 3.0.2.500 (3.0.2.500)


WordInfoCollection Constructor (capacity)

WordInfoCollection Constructor (capacity)
ScrewTurn Wiki ► ScrewTurn.Wiki.SearchEngine ► WordInfoCollection ► WordInfoCollection(Int32)
Initializes a new instance of the WordInfoCollection class.
Declaration Syntax
C# Visual Basic Visual C++
public WordInfoCollection(
    int capacity
)
Public Sub New ( _
    capacity As Integer _
)
public:
WordInfoCollection(
    int capacity
)
Parameters
capacity (Int32)
The initial capacity of the collection.
Exceptions
Exception | Condition
ArgumentOutOfRangeException | If capacity is less than or equal to zero.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.SearchEngine (Module: ScrewTurn.Wiki.SearchEngine) Version: 3.0.2.500 (3.0.2.500)


Add Method (item)

Add Method (item)
ScrewTurn Wiki ► ScrewTurn.Wiki.SearchEngine ► WordInfoCollection ► Add(WordInfo)
Adds an item to the collection.
Declaration Syntax
C# Visual Basic Visual C++
public void Add(
    WordInfo item
)
Public Sub Add ( _
    item As WordInfo _
)
public:
virtual void Add(
    WordInfo^ item
) sealed
Parameters
item (WordInfo)
The item to add.
Exceptions
Exception | Condition
ArgumentNullException | If item is null.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.SearchEngine (Module: ScrewTurn.Wiki.SearchEngine) Version: 3.0.2.500 (3.0.2.500)


Capacity Property

Capacity Property
ScrewTurn Wiki ► ScrewTurn.Wiki.SearchEngine ► WordInfoCollection ► Capacity
Gets the capacity of the collection.
Declaration Syntax
C# Visual Basic Visual C++
public int Capacity { get; }
Public ReadOnly Property Capacity As Integer
public:
property int Capacity {
    int get ();
}

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.SearchEngine (Module: ScrewTurn.Wiki.SearchEngine) Version: 3.0.2.500 (3.0.2.500)


Clear Method

Clear Method
ScrewTurn Wiki ► ScrewTurn.Wiki.SearchEngine ► WordInfoCollection ► Clear()()()
Clears the collection.
Declaration Syntax
C# Visual Basic Visual C++
public void Clear()
Public Sub Clear
public:
virtual void Clear() sealed

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.SearchEngine (Module: ScrewTurn.Wiki.SearchEngine) Version: 3.0.2.500 (3.0.2.500)


Contains Method

Contains Method
ScrewTurn Wiki ► ScrewTurn.Wiki.SearchEngine ► WordInfoCollection ► Contains()()()
Members
Icon | Member | Description
 | Contains(WordInfo) | Determines whether an item is in the collection.
 | Contains(String) | Determines whether a word is in the collection.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.SearchEngine (Module: ScrewTurn.Wiki.SearchEngine) Version: 3.0.2.500 (3.0.2.500)


Contains Method (item)

Contains Method (item)
ScrewTurn Wiki ► ScrewTurn.Wiki.SearchEngine ► WordInfoCollection ► Contains(WordInfo)
Determines whether an item is in the collection.
Declaration Syntax
C# Visual Basic Visual C++
public bool Contains(
    WordInfo item
)
Public Function Contains ( _
    item As WordInfo _
) As Boolean
public:
virtual bool Contains(
    WordInfo^ item
) sealed
Parameters
item (WordInfo)
The item to check for.
Return Value
true if the item in the collection, false otherwise.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.SearchEngine (Module: ScrewTurn.Wiki.SearchEngine) Version: 3.0.2.500 (3.0.2.500)


Contains Method (word)

Contains Method (word)
ScrewTurn Wiki ► ScrewTurn.Wiki.SearchEngine ► WordInfoCollection ► Contains(String)
Determines whether a word is in the collection.
Declaration Syntax
C# Visual Basic Visual C++
public bool Contains(
    string word
)
Public Function Contains ( _
    word As String _
) As Boolean
public:
bool Contains(
    String^ word
)
Parameters
word (String)
The word.
Return Value
true if the word is in the collection, false otherwise.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.SearchEngine (Module: ScrewTurn.Wiki.SearchEngine) Version: 3.0.2.500 (3.0.2.500)


ContainsOccurrence Method (word, firstCharIndex)

ContainsOccurrence Method (word, firstCharIndex)
ScrewTurn Wiki ► ScrewTurn.Wiki.SearchEngine ► WordInfoCollection ► ContainsOccurrence(String, Int32)
Determines whether a word occurrence is in the collection.
Declaration Syntax
C# Visual Basic Visual C++
public bool ContainsOccurrence(
    string word,
    int firstCharIndex
)
Public Function ContainsOccurrence ( _
    word As String, _
    firstCharIndex As Integer _
) As Boolean
public:
bool ContainsOccurrence(
    String^ word,
    int firstCharIndex
)
Parameters
word (String)
The word.
firstCharIndex (Int32)
The index of the first character.
Return Value
True if the collection contains the occurrence, false otherwise.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.SearchEngine (Module: ScrewTurn.Wiki.SearchEngine) Version: 3.0.2.500 (3.0.2.500)


CopyTo Method (array, arrayIndex)

CopyTo Method (array, arrayIndex)
ScrewTurn Wiki ► ScrewTurn.Wiki.SearchEngine ► WordInfoCollection ► CopyTo(array<WordInfo>[]()[], Int32)
Copies the collection items to an array.
Declaration Syntax
C# Visual Basic Visual C++
public void CopyTo(
    WordInfo[] array,
    int arrayIndex
)
Public Sub CopyTo ( _
    array As WordInfo(), _
    arrayIndex As Integer _
)
public:
virtual void CopyTo(
    array<WordInfo^>^ array,
    int arrayIndex
) sealed
Parameters
array (array< WordInfo >[]()[][])
The destination array.
arrayIndex (Int32)
The zero-based array index at which the copy begins.
Exceptions
Exception | Condition
ArgumentOutOfRangeException | If arrayIndex is not within the bounds of array.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.SearchEngine (Module: ScrewTurn.Wiki.SearchEngine) Version: 3.0.2.500 (3.0.2.500)


Count Property

Count Property
ScrewTurn Wiki ► ScrewTurn.Wiki.SearchEngine ► WordInfoCollection ► Count
Gets the number of items in the collection.
Declaration Syntax
C# Visual Basic Visual C++
public int Count { get; }
Public ReadOnly Property Count As Integer
public:
virtual property int Count {
    int get () sealed;
}

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.SearchEngine (Module: ScrewTurn.Wiki.SearchEngine) Version: 3.0.2.500 (3.0.2.500)


GetEnumerator Method

GetEnumerator Method
ScrewTurn Wiki ► ScrewTurn.Wiki.SearchEngine ► WordInfoCollection ► GetEnumerator()()()
Returns an enumerator that iterates through the items of the collection.
Declaration Syntax
C# Visual Basic Visual C++
public IEnumerator<WordInfo> GetEnumerator()
Public Function GetEnumerator As IEnumerator(Of WordInfo)
public:
virtual IEnumerator<WordInfo^>^ GetEnumerator() sealed
Return Value
The enumerator.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.SearchEngine (Module: ScrewTurn.Wiki.SearchEngine) Version: 3.0.2.500 (3.0.2.500)


IsReadOnly Property

IsReadOnly Property
ScrewTurn Wiki ► ScrewTurn.Wiki.SearchEngine ► WordInfoCollection ► IsReadOnly
Gets a value indicating whether the collection is read-only.
Declaration Syntax
C# Visual Basic Visual C++
public bool IsReadOnly { get; }
Public ReadOnly Property IsReadOnly As Boolean
public:
virtual property bool IsReadOnly {
    bool get () sealed;
}

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.SearchEngine (Module: ScrewTurn.Wiki.SearchEngine) Version: 3.0.2.500 (3.0.2.500)


Item Property (index)

Item Property (index)
ScrewTurn Wiki ► ScrewTurn.Wiki.SearchEngine ► WordInfoCollection ► Item[([(Int32])])
Gets an item of the collection.
Declaration Syntax
C# Visual Basic Visual C++
public WordInfo this[
    int index
] { get; }
Public ReadOnly Default Property Item ( _
    index As Integer _
) As WordInfo
public:
property WordInfo^ default[int index] {
    WordInfo^ get (int index);
}
Parameters
index (Int32)
The index of the item to retrieve.
Return Value
The item.
Exceptions
Exception | Condition
IndexOutOfRangeException | If index is outside the bounds of the collection.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.SearchEngine (Module: ScrewTurn.Wiki.SearchEngine) Version: 3.0.2.500 (3.0.2.500)


items Field

items Field
ScrewTurn Wiki ► ScrewTurn.Wiki.SearchEngine ► WordInfoCollection ► items
The items of the collection.
Declaration Syntax
C# Visual Basic Visual C++
protected List<WordInfo> items
Protected items As List(Of WordInfo)
protected:
List<WordInfo^>^ items

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.SearchEngine (Module: ScrewTurn.Wiki.SearchEngine) Version: 3.0.2.500 (3.0.2.500)


Remove Method (item)

Remove Method (item)
ScrewTurn Wiki ► ScrewTurn.Wiki.SearchEngine ► WordInfoCollection ► Remove(WordInfo)
Removes an item from the collection.
Declaration Syntax
C# Visual Basic Visual C++
public bool Remove(
    WordInfo item
)
Public Function Remove ( _
    item As WordInfo _
) As Boolean
public:
virtual bool Remove(
    WordInfo^ item
) sealed
Parameters
item (WordInfo)
The item to remove.
Return Value
true if item is removed, false otherwise.
Exceptions
Exception | Condition
ArgumentNullException | If item is null.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.SearchEngine (Module: ScrewTurn.Wiki.SearchEngine) Version: 3.0.2.500 (3.0.2.500)


ToString Method

ToString Method
ScrewTurn Wiki ► ScrewTurn.Wiki.SearchEngine ► WordInfoCollection ► ToString()()()
Returns a string representation of the current instance.
Declaration Syntax
C# Visual Basic Visual C++
public override string ToString()
Public Overrides Function ToString As String
public:
virtual String^ ToString() override
Return Value
The string representation.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.SearchEngine (Module: ScrewTurn.Wiki.SearchEngine) Version: 3.0.2.500 (3.0.2.500)


WordLocation Class

WordLocation Class
ScrewTurn Wiki ► ScrewTurn.Wiki.SearchEngine ► WordLocation
Describes the location of a word in a document.
Declaration Syntax
C# Visual Basic Visual C++
public class WordLocation : IComparable<WordLocation>,
    IEquatable<WordLocation>
Public Class WordLocation _
    Implements IComparable(Of WordLocation), IEquatable(Of WordLocation)
public ref class WordLocation : IComparable<WordLocation^>,
    IEquatable<WordLocation^>
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | WordLocation(Byte, String, Single) | Initializes a new instance of the WordLocation class.
 | CompareTo(WordLocation) | Compares the current instance to another.
 | Content | Represents a word that is in the content of a document.
 | Equality(WordLocation, WordLocation) | Applies the value-equality operator to two WordLocation objects.
 | Equals(Object) | Determines whether the current instance equals an object. (Overrides Object.Equals(Object).)
 | Equals(WordLocation) | Determines whether the current instance equals another.
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Returns the hash code of the current instance. (Overrides Object.GetHashCode()()().)
 | GetInstance(Byte) | Gets the correct WordLocation instance from the location identifier.
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | Inequality(WordLocation, WordLocation) | Applies the value-inequality operator to two WordLocation objects.
 | Keywords | Represents a word that is in the keywords of a document.
 | Location | Gets the location identifier.
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | RelativeRelevance | Gets the relative relevance of the word location.
 | Title | Represents a word that is in the title of a document.
 | ToString()()() | Gets a string representation of the current instance. (Overrides Object.ToString()()().)
Inheritance Hierarchy
Object
WordLocation

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.SearchEngine (Module: ScrewTurn.Wiki.SearchEngine) Version: 3.0.2.500 (3.0.2.500)


WordLocation Constructor (location, label, relativeRelevance)

WordLocation Constructor (location, label, relativeRelevance)
ScrewTurn Wiki ► ScrewTurn.Wiki.SearchEngine ► WordLocation ► WordLocation(Byte, String, Single)
Initializes a new instance of the WordLocation class.
Declaration Syntax
C# Visual Basic Visual C++
protected WordLocation(
    byte location,
    string label,
    float relativeRelevance
)
Protected Sub New ( _
    location As Byte, _
    label As String, _
    relativeRelevance As Single _
)
protected:
WordLocation(
    unsigned char location,
    String^ label,
    float relativeRelevance
)
Parameters
location (Byte)
A number representing the location.
label (String)
The label of the instance.
relativeRelevance (Single)
The relative relevance of the instance.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.SearchEngine (Module: ScrewTurn.Wiki.SearchEngine) Version: 3.0.2.500 (3.0.2.500)


CompareTo Method (other)

CompareTo Method (other)
ScrewTurn Wiki ► ScrewTurn.Wiki.SearchEngine ► WordLocation ► CompareTo(WordLocation)
Compares the current instance to another.
Declaration Syntax
C# Visual Basic Visual C++
public int CompareTo(
    WordLocation other
)
Public Function CompareTo ( _
    other As WordLocation _
) As Integer
public:
virtual int CompareTo(
    WordLocation^ other
) sealed
Parameters
other (WordLocation)
The other instance.
Return Value
The comparison result.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.SearchEngine (Module: ScrewTurn.Wiki.SearchEngine) Version: 3.0.2.500 (3.0.2.500)


Content Property

Content Property
ScrewTurn Wiki ► ScrewTurn.Wiki.SearchEngine ► WordLocation ► Content
Represents a word that is in the content of a document.
Declaration Syntax
C# Visual Basic Visual C++
public static WordLocation Content { get; }
Public Shared ReadOnly Property Content As WordLocation
public:
static property WordLocation^ Content {
    WordLocation^ get ();
}

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.SearchEngine (Module: ScrewTurn.Wiki.SearchEngine) Version: 3.0.2.500 (3.0.2.500)


Equality Operator

Equality Operator
ScrewTurn Wiki ► ScrewTurn.Wiki.SearchEngine ► WordLocation ► Equality(WordLocation, WordLocation)
Applies the value-equality operator to two WordLocation objects.
Declaration Syntax
C# Visual Basic Visual C++
public static bool operator ==(
    WordLocation x,
    WordLocation y
)
Public Shared Operator = ( _
    x As WordLocation, _
    y As WordLocation _
) As Boolean
public:
static bool operator ==(
    WordLocation^ x,
    WordLocation^ y
)
Parameters
x (WordLocation)
The first object.
y (WordLocation)
The second object.
Return Value
true if the objects are value-equal, false otherwise.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.SearchEngine (Module: ScrewTurn.Wiki.SearchEngine) Version: 3.0.2.500 (3.0.2.500)


Equals Method

Equals Method
ScrewTurn Wiki ► ScrewTurn.Wiki.SearchEngine ► WordLocation ► Equals()()()
Members
Icon | Member | Description
 | Equals(Object) | Determines whether the current instance equals an object. (Overrides Object.Equals(Object).)
 | Equals(WordLocation) | Determines whether the current instance equals another.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.SearchEngine (Module: ScrewTurn.Wiki.SearchEngine) Version: 3.0.2.500 (3.0.2.500)


Equals Method (other)

Equals Method (other)
ScrewTurn Wiki ► ScrewTurn.Wiki.SearchEngine ► WordLocation ► Equals(WordLocation)
Determines whether the current instance equals another.
Declaration Syntax
C# Visual Basic Visual C++
public bool Equals(
    WordLocation other
)
Public Function Equals ( _
    other As WordLocation _
) As Boolean
public:
virtual bool Equals(
    WordLocation^ other
) sealed
Parameters
other (WordLocation)
The other instance.
Return Value
true if the current instance equals the other, false otherwise.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.SearchEngine (Module: ScrewTurn.Wiki.SearchEngine) Version: 3.0.2.500 (3.0.2.500)


Equals Method (obj)

Equals Method (obj)
ScrewTurn Wiki ► ScrewTurn.Wiki.SearchEngine ► WordLocation ► Equals(Object)
Determines whether the current instance equals an object.
Declaration Syntax
C# Visual Basic Visual C++
public override bool Equals(
    Object obj
)
Public Overrides Function Equals ( _
    obj As Object _
) As Boolean
public:
virtual bool Equals(
    Object^ obj
) override
Parameters
obj (Object)
The object.
Return Value
true if the current instance equals the object, false otherwise.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.SearchEngine (Module: ScrewTurn.Wiki.SearchEngine) Version: 3.0.2.500 (3.0.2.500)


GetHashCode Method

GetHashCode Method
ScrewTurn Wiki ► ScrewTurn.Wiki.SearchEngine ► WordLocation ► GetHashCode()()()
Returns the hash code of the current instance.
Declaration Syntax
C# Visual Basic Visual C++
public override int GetHashCode()
Public Overrides Function GetHashCode As Integer
public:
virtual int GetHashCode() override
Return Value
The hash code.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.SearchEngine (Module: ScrewTurn.Wiki.SearchEngine) Version: 3.0.2.500 (3.0.2.500)


GetInstance Method (location)

GetInstance Method (location)
ScrewTurn Wiki ► ScrewTurn.Wiki.SearchEngine ► WordLocation ► GetInstance(Byte)
Gets the correct WordLocation instance from the location identifier.
Declaration Syntax
C# Visual Basic Visual C++
public static WordLocation GetInstance(
    byte location
)
Public Shared Function GetInstance ( _
    location As Byte _
) As WordLocation
public:
static WordLocation^ GetInstance(
    unsigned char location
)
Parameters
location (Byte)
The location identifier.
Return Value
The correct instance.
Exceptions
Exception | Condition
ArgumentOutOfRangeException | If location is different from 1, 2, 3.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.SearchEngine (Module: ScrewTurn.Wiki.SearchEngine) Version: 3.0.2.500 (3.0.2.500)


Inequality Operator

Inequality Operator
ScrewTurn Wiki ► ScrewTurn.Wiki.SearchEngine ► WordLocation ► Inequality(WordLocation, WordLocation)
Applies the value-inequality operator to two WordLocation objects.
Declaration Syntax
C# Visual Basic Visual C++
public static bool operator !=(
    WordLocation x,
    WordLocation y
)
Public Shared Operator <> ( _
    x As WordLocation, _
    y As WordLocation _
) As Boolean
public:
static bool operator !=(
    WordLocation^ x,
    WordLocation^ y
)
Parameters
x (WordLocation)
The first object.
y (WordLocation)
The second object.
Return Value
true if the objects are not value-equal, false otherwise.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.SearchEngine (Module: ScrewTurn.Wiki.SearchEngine) Version: 3.0.2.500 (3.0.2.500)


Keywords Property

Keywords Property
ScrewTurn Wiki ► ScrewTurn.Wiki.SearchEngine ► WordLocation ► Keywords
Represents a word that is in the keywords of a document.
Declaration Syntax
C# Visual Basic Visual C++
public static WordLocation Keywords { get; }
Public Shared ReadOnly Property Keywords As WordLocation
public:
static property WordLocation^ Keywords {
    WordLocation^ get ();
}

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.SearchEngine (Module: ScrewTurn.Wiki.SearchEngine) Version: 3.0.2.500 (3.0.2.500)


Location Property

Location Property
ScrewTurn Wiki ► ScrewTurn.Wiki.SearchEngine ► WordLocation ► Location
Gets the location identifier.
Declaration Syntax
C# Visual Basic Visual C++
public byte Location { get; }
Public ReadOnly Property Location As Byte
public:
property unsigned char Location {
    unsigned char get ();
}
Remarks
This property should only be used for serialization purposes.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.SearchEngine (Module: ScrewTurn.Wiki.SearchEngine) Version: 3.0.2.500 (3.0.2.500)


RelativeRelevance Property

RelativeRelevance Property
ScrewTurn Wiki ► ScrewTurn.Wiki.SearchEngine ► WordLocation ► RelativeRelevance
Gets the relative relevance of the word location.
Declaration Syntax
C# Visual Basic Visual C++
public float RelativeRelevance { get; }
Public ReadOnly Property RelativeRelevance As Single
public:
property float RelativeRelevance {
    float get ();
}

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.SearchEngine (Module: ScrewTurn.Wiki.SearchEngine) Version: 3.0.2.500 (3.0.2.500)


Title Property

Title Property
ScrewTurn Wiki ► ScrewTurn.Wiki.SearchEngine ► WordLocation ► Title
Represents a word that is in the title of a document.
Declaration Syntax
C# Visual Basic Visual C++
public static WordLocation Title { get; }
Public Shared ReadOnly Property Title As WordLocation
public:
static property WordLocation^ Title {
    WordLocation^ get ();
}

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.SearchEngine (Module: ScrewTurn.Wiki.SearchEngine) Version: 3.0.2.500 (3.0.2.500)


ToString Method

ToString Method
ScrewTurn Wiki ► ScrewTurn.Wiki.SearchEngine ► WordLocation ► ToString()()()
Gets a string representation of the current instance.
Declaration Syntax
C# Visual Basic Visual C++
public override string ToString()
Public Overrides Function ToString As String
public:
virtual String^ ToString() override
Return Value
The string representation.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.SearchEngine (Module: ScrewTurn.Wiki.SearchEngine) Version: 3.0.2.500 (3.0.2.500)


CloseReader Method

CloseReader Method
ScrewTurn Wiki ► ScrewTurn.Wiki.Plugins.SqlServer ► SqlServerSettingsStorageProvider ► CloseReader()()()
Members
Icon | Member | Description
 | CloseReader(DbCommand, DbDataReader) | Closes a reader, a command and the associated connection.
 | CloseReader(DbDataReader) | Closes a reader.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: SqlServerProviders (Module: SqlServerProviders) Version: 3.0.2.500 (3.0.2.500)


CloseReader Method

CloseReader Method
ScrewTurn Wiki ► ScrewTurn.Wiki.Plugins.SqlCommon ► SqlSettingsStorageProviderBase ► CloseReader()()()
Members
Icon | Member | Description
 | CloseReader(DbCommand, DbDataReader) | Closes a reader, a command and the associated connection.
 | CloseReader(DbDataReader) | Closes a reader.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Plugins.SqlCommon (Module: ScrewTurn.Wiki.Plugins.SqlCommon) Version: 3.0.2.500 (3.0.2.500)

Assembly: SqlServerProviders (Module: SqlServerProviders) Version: 3.0.2.500 (3.0.2.500)


CloseReader Method

CloseReader Method
ScrewTurn Wiki ► ScrewTurn.Wiki.Plugins.SqlCommon ► SqlPagesStorageProviderBase ► CloseReader()()()
Members
Icon | Member | Description
 | CloseReader(DbCommand, DbDataReader) | Closes a reader, a command and the associated connection.
 | CloseReader(DbDataReader) | Closes a reader.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: SqlServerProviders (Module: SqlServerProviders) Version: 3.0.2.500 (3.0.2.500)

Assembly: ScrewTurn.Wiki.Plugins.SqlCommon (Module: ScrewTurn.Wiki.Plugins.SqlCommon) Version: 3.0.2.500 (3.0.2.500)


CloseReader Method

CloseReader Method
ScrewTurn Wiki ► ScrewTurn.Wiki.Plugins.SqlCommon ► SqlUsersStorageProviderBase ► CloseReader()()()
Members
Icon | Member | Description
 | CloseReader(DbCommand, DbDataReader) | Closes a reader, a command and the associated connection.
 | CloseReader(DbDataReader) | Closes a reader.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: SqlServerProviders (Module: SqlServerProviders) Version: 3.0.2.500 (3.0.2.500)

Assembly: ScrewTurn.Wiki.Plugins.SqlCommon (Module: ScrewTurn.Wiki.Plugins.SqlCommon) Version: 3.0.2.500 (3.0.2.500)


ExecuteScalar Method

ExecuteScalar Method
ScrewTurn Wiki ► ScrewTurn.Wiki.Plugins.SqlCommon ► SqlPagesStorageProviderBase ► ExecuteScalar()()()
Members
Icon | Member | Description
 | ExecuteScalar<(Of <(T>)>)(DbCommand, T) | Executes a scalar command, then closes the connection.
 | ExecuteScalar<(Of <(T>)>)(DbCommand, T, Boolean) | Executes a scalar command, then closes the connection.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: SqlServerProviders (Module: SqlServerProviders) Version: 3.0.2.500 (3.0.2.500)

Assembly: ScrewTurn.Wiki.Plugins.SqlCommon (Module: ScrewTurn.Wiki.Plugins.SqlCommon) Version: 3.0.2.500 (3.0.2.500)


ExecuteReader Method

ExecuteReader Method
ScrewTurn Wiki ► ScrewTurn.Wiki.Plugins.SqlServer ► SqlServerPagesStorageProvider ► ExecuteReader()()()
Members
Icon | Member | Description
 | ExecuteReader(DbCommand, Boolean) | Executes a reader command, leaving the connection open.
 | ExecuteReader(DbCommand) | Executes a reader command, leaving the connection open.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: SqlServerProviders (Module: SqlServerProviders) Version: 3.0.2.500 (3.0.2.500)


ExecuteNonQuery Method

ExecuteNonQuery Method
ScrewTurn Wiki ► ScrewTurn.Wiki.Plugins.SqlCommon ► SqlSettingsStorageProviderBase ► ExecuteNonQuery()()()
Members
Icon | Member | Description
 | ExecuteNonQuery(DbCommand) | Executes a non-query command, then closes the connection.
 | ExecuteNonQuery(DbCommand, Boolean) | Executes a non-query command, then closes the connection if requested.
 | ExecuteNonQuery(DbCommand, Boolean, Boolean) | Executes a non-query command, then closes the connection if requested.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Plugins.SqlCommon (Module: ScrewTurn.Wiki.Plugins.SqlCommon) Version: 3.0.2.500 (3.0.2.500)

Assembly: SqlServerProviders (Module: SqlServerProviders) Version: 3.0.2.500 (3.0.2.500)


ExecuteNonQuery Method

ExecuteNonQuery Method
ScrewTurn Wiki ► ScrewTurn.Wiki.Plugins.SqlCommon ► SqlPagesStorageProviderBase ► ExecuteNonQuery()()()
Members
Icon | Member | Description
 | ExecuteNonQuery(DbCommand) | Executes a non-query command, then closes the connection.
 | ExecuteNonQuery(DbCommand, Boolean) | Executes a non-query command, then closes the connection if requested.
 | ExecuteNonQuery(DbCommand, Boolean, Boolean) | Executes a non-query command, then closes the connection if requested.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: SqlServerProviders (Module: SqlServerProviders) Version: 3.0.2.500 (3.0.2.500)

Assembly: ScrewTurn.Wiki.Plugins.SqlCommon (Module: ScrewTurn.Wiki.Plugins.SqlCommon) Version: 3.0.2.500 (3.0.2.500)


ExecuteNonQuery Method

ExecuteNonQuery Method
ScrewTurn Wiki ► ScrewTurn.Wiki.Plugins.SqlCommon ► SqlUsersStorageProviderBase ► ExecuteNonQuery()()()
Members
Icon | Member | Description
 | ExecuteNonQuery(DbCommand) | Executes a non-query command, then closes the connection.
 | ExecuteNonQuery(DbCommand, Boolean) | Executes a non-query command, then closes the connection if requested.
 | ExecuteNonQuery(DbCommand, Boolean, Boolean) | Executes a non-query command, then closes the connection if requested.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: SqlServerProviders (Module: SqlServerProviders) Version: 3.0.2.500 (3.0.2.500)

Assembly: ScrewTurn.Wiki.Plugins.SqlCommon (Module: ScrewTurn.Wiki.Plugins.SqlCommon) Version: 3.0.2.500 (3.0.2.500)


CompareTo Method

CompareTo Method
ScrewTurn Wiki ► ScrewTurn.Wiki.SearchEngine ► WordInfo ► CompareTo()()()
Members
Icon | Member | Description
 | CompareTo(WordInfo) | Compares the current instance with another instance.
 | CompareTo(BasicWordInfo) | Compares the current instance with another instance.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.SearchEngine (Module: ScrewTurn.Wiki.SearchEngine) Version: 3.0.2.500 (3.0.2.500)


Finalize Method

Finalize Method
ScrewTurn Wiki ► ScrewTurn.Wiki.SearchEngine ► Relevance ► Finalize()()()
Members
Icon | Member | Description
 | Finalize(Single) | Finalizes the value of the relevance.
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.SearchEngine (Module: ScrewTurn.Wiki.SearchEngine) Version: 3.0.2.500 (3.0.2.500)


ExecuteScalar Method

ExecuteScalar Method
ScrewTurn Wiki ► ScrewTurn.Wiki.Plugins.SqlServer ► SqlServerPagesStorageProvider ► ExecuteScalar()()()
Members
Icon | Member | Description
 | ExecuteScalar<(Of <(T>)>)(DbCommand, T) | Executes a scalar command, then closes the connection.
 | ExecuteScalar<(Of <(T>)>)(DbCommand, T, Boolean) | Executes a scalar command, then closes the connection.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: SqlServerProviders (Module: SqlServerProviders) Version: 3.0.2.500 (3.0.2.500)


CloseReader Method

CloseReader Method
ScrewTurn Wiki ► ScrewTurn.Wiki.Plugins.SqlServer ► SqlServerPagesStorageProvider ► CloseReader()()()
Members
Icon | Member | Description
 | CloseReader(DbCommand, DbDataReader) | Closes a reader, a command and the associated connection.
 | CloseReader(DbDataReader) | Closes a reader.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: SqlServerProviders (Module: SqlServerProviders) Version: 3.0.2.500 (3.0.2.500)


ExecuteScalar Method

ExecuteScalar Method
ScrewTurn Wiki ► ScrewTurn.Wiki.Plugins.SqlServer ► SqlServerFilesStorageProvider ► ExecuteScalar()()()
Members
Icon | Member | Description
 | ExecuteScalar<(Of <(T>)>)(DbCommand, T) | Executes a scalar command, then closes the connection.
 | ExecuteScalar<(Of <(T>)>)(DbCommand, T, Boolean) | Executes a scalar command, then closes the connection.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: SqlServerProviders (Module: SqlServerProviders) Version: 3.0.2.500 (3.0.2.500)


ExecuteNonQuery Method

ExecuteNonQuery Method
ScrewTurn Wiki ► ScrewTurn.Wiki.Plugins.SqlServer ► SqlServerFilesStorageProvider ► ExecuteNonQuery()()()
Members
Icon | Member | Description
 | ExecuteNonQuery(DbCommand) | Executes a non-query command, then closes the connection.
 | ExecuteNonQuery(DbCommand, Boolean) | Executes a non-query command, then closes the connection if requested.
 | ExecuteNonQuery(DbCommand, Boolean, Boolean) | Executes a non-query command, then closes the connection if requested.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: SqlServerProviders (Module: SqlServerProviders) Version: 3.0.2.500 (3.0.2.500)


CloseReader Method

CloseReader Method
ScrewTurn Wiki ► ScrewTurn.Wiki.Plugins.SqlServer ► SqlServerUsersStorageProvider ► CloseReader()()()
Members
Icon | Member | Description
 | CloseReader(DbCommand, DbDataReader) | Closes a reader, a command and the associated connection.
 | CloseReader(DbDataReader) | Closes a reader.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: SqlServerProviders (Module: SqlServerProviders) Version: 3.0.2.500 (3.0.2.500)


ExecuteReader Method

ExecuteReader Method
ScrewTurn Wiki ► ScrewTurn.Wiki.Plugins.SqlCommon ► SqlUsersStorageProviderBase ► ExecuteReader()()()
Members
Icon | Member | Description
 | ExecuteReader(DbCommand, Boolean) | Executes a reader command, leaving the connection open.
 | ExecuteReader(DbCommand) | Executes a reader command, leaving the connection open.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: SqlServerProviders (Module: SqlServerProviders) Version: 3.0.2.500 (3.0.2.500)

Assembly: ScrewTurn.Wiki.Plugins.SqlCommon (Module: ScrewTurn.Wiki.Plugins.SqlCommon) Version: 3.0.2.500 (3.0.2.500)


ExecuteScalar Method

ExecuteScalar Method
ScrewTurn Wiki ► ScrewTurn.Wiki.Plugins.SqlCommon ► SqlFilesStorageProviderBase ► ExecuteScalar()()()
Members
Icon | Member | Description
 | ExecuteScalar<(Of <(T>)>)(DbCommand, T) | Executes a scalar command, then closes the connection.
 | ExecuteScalar<(Of <(T>)>)(DbCommand, T, Boolean) | Executes a scalar command, then closes the connection.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: SqlServerProviders (Module: SqlServerProviders) Version: 3.0.2.500 (3.0.2.500)

Assembly: ScrewTurn.Wiki.Plugins.SqlCommon (Module: ScrewTurn.Wiki.Plugins.SqlCommon) Version: 3.0.2.500 (3.0.2.500)


ExecuteReader Method

ExecuteReader Method
ScrewTurn Wiki ► ScrewTurn.Wiki.Plugins.SqlServer ► SqlServerFilesStorageProvider ► ExecuteReader()()()
Members
Icon | Member | Description
 | ExecuteReader(DbCommand, Boolean) | Executes a reader command, leaving the connection open.
 | ExecuteReader(DbCommand) | Executes a reader command, leaving the connection open.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: SqlServerProviders (Module: SqlServerProviders) Version: 3.0.2.500 (3.0.2.500)


ExecuteScalar Method

ExecuteScalar Method
ScrewTurn Wiki ► ScrewTurn.Wiki.Plugins.SqlCommon ► SqlSettingsStorageProviderBase ► ExecuteScalar()()()
Members
Icon | Member | Description
 | ExecuteScalar<(Of <(T>)>)(DbCommand, T) | Executes a scalar command, then closes the connection.
 | ExecuteScalar<(Of <(T>)>)(DbCommand, T, Boolean) | Executes a scalar command, then closes the connection.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Plugins.SqlCommon (Module: ScrewTurn.Wiki.Plugins.SqlCommon) Version: 3.0.2.500 (3.0.2.500)

Assembly: SqlServerProviders (Module: SqlServerProviders) Version: 3.0.2.500 (3.0.2.500)


ExecuteNonQuery Method

ExecuteNonQuery Method
ScrewTurn Wiki ► ScrewTurn.Wiki.Plugins.SqlServer ► SqlServerPagesStorageProvider ► ExecuteNonQuery()()()
Members
Icon | Member | Description
 | ExecuteNonQuery(DbCommand) | Executes a non-query command, then closes the connection.
 | ExecuteNonQuery(DbCommand, Boolean) | Executes a non-query command, then closes the connection if requested.
 | ExecuteNonQuery(DbCommand, Boolean, Boolean) | Executes a non-query command, then closes the connection if requested.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: SqlServerProviders (Module: SqlServerProviders) Version: 3.0.2.500 (3.0.2.500)


ExecuteNonQuery Method

ExecuteNonQuery Method
ScrewTurn Wiki ► ScrewTurn.Wiki.Plugins.SqlCommon ► SqlStorageProviderBase ► ExecuteNonQuery()()()
Members
Icon | Member | Description
 | ExecuteNonQuery(DbCommand) | Executes a non-query command, then closes the connection.
 | ExecuteNonQuery(DbCommand, Boolean) | Executes a non-query command, then closes the connection if requested.
 | ExecuteNonQuery(DbCommand, Boolean, Boolean) | Executes a non-query command, then closes the connection if requested.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Plugins.SqlCommon (Module: ScrewTurn.Wiki.Plugins.SqlCommon) Version: 3.0.2.500 (3.0.2.500)

Assembly: SqlServerProviders (Module: SqlServerProviders) Version: 3.0.2.500 (3.0.2.500)


ExecuteReader Method

ExecuteReader Method
ScrewTurn Wiki ► ScrewTurn.Wiki.Plugins.SqlServer ► SqlServerSettingsStorageProvider ► ExecuteReader()()()
Members
Icon | Member | Description
 | ExecuteReader(DbCommand, Boolean) | Executes a reader command, leaving the connection open.
 | ExecuteReader(DbCommand) | Executes a reader command, leaving the connection open.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: SqlServerProviders (Module: SqlServerProviders) Version: 3.0.2.500 (3.0.2.500)


CloseReader Method

CloseReader Method
ScrewTurn Wiki ► ScrewTurn.Wiki.Plugins.SqlCommon ► SqlFilesStorageProviderBase ► CloseReader()()()
Members
Icon | Member | Description
 | CloseReader(DbCommand, DbDataReader) | Closes a reader, a command and the associated connection.
 | CloseReader(DbDataReader) | Closes a reader.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: SqlServerProviders (Module: SqlServerProviders) Version: 3.0.2.500 (3.0.2.500)

Assembly: ScrewTurn.Wiki.Plugins.SqlCommon (Module: ScrewTurn.Wiki.Plugins.SqlCommon) Version: 3.0.2.500 (3.0.2.500)


ExecuteNonQuery Method

ExecuteNonQuery Method
ScrewTurn Wiki ► ScrewTurn.Wiki.Plugins.SqlServer ► SqlServerSettingsStorageProvider ► ExecuteNonQuery()()()
Members
Icon | Member | Description
 | ExecuteNonQuery(DbCommand) | Executes a non-query command, then closes the connection.
 | ExecuteNonQuery(DbCommand, Boolean) | Executes a non-query command, then closes the connection if requested.
 | ExecuteNonQuery(DbCommand, Boolean, Boolean) | Executes a non-query command, then closes the connection if requested.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: SqlServerProviders (Module: SqlServerProviders) Version: 3.0.2.500 (3.0.2.500)


ExecuteScalar Method

ExecuteScalar Method
ScrewTurn Wiki ► ScrewTurn.Wiki.Plugins.SqlCommon ► SqlUsersStorageProviderBase ► ExecuteScalar()()()
Members
Icon | Member | Description
 | ExecuteScalar<(Of <(T>)>)(DbCommand, T) | Executes a scalar command, then closes the connection.
 | ExecuteScalar<(Of <(T>)>)(DbCommand, T, Boolean) | Executes a scalar command, then closes the connection.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: SqlServerProviders (Module: SqlServerProviders) Version: 3.0.2.500 (3.0.2.500)

Assembly: ScrewTurn.Wiki.Plugins.SqlCommon (Module: ScrewTurn.Wiki.Plugins.SqlCommon) Version: 3.0.2.500 (3.0.2.500)


ExecuteNonQuery Method

ExecuteNonQuery Method
ScrewTurn Wiki ► ScrewTurn.Wiki.Plugins.SqlServer ► SqlServerUsersStorageProvider ► ExecuteNonQuery()()()
Members
Icon | Member | Description
 | ExecuteNonQuery(DbCommand) | Executes a non-query command, then closes the connection.
 | ExecuteNonQuery(DbCommand, Boolean) | Executes a non-query command, then closes the connection if requested.
 | ExecuteNonQuery(DbCommand, Boolean, Boolean) | Executes a non-query command, then closes the connection if requested.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: SqlServerProviders (Module: SqlServerProviders) Version: 3.0.2.500 (3.0.2.500)


ExecuteNonQuery Method

ExecuteNonQuery Method
ScrewTurn Wiki ► ScrewTurn.Wiki.Plugins.SqlCommon ► SqlFilesStorageProviderBase ► ExecuteNonQuery()()()
Members
Icon | Member | Description
 | ExecuteNonQuery(DbCommand) | Executes a non-query command, then closes the connection.
 | ExecuteNonQuery(DbCommand, Boolean) | Executes a non-query command, then closes the connection if requested.
 | ExecuteNonQuery(DbCommand, Boolean, Boolean) | Executes a non-query command, then closes the connection if requested.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: SqlServerProviders (Module: SqlServerProviders) Version: 3.0.2.500 (3.0.2.500)

Assembly: ScrewTurn.Wiki.Plugins.SqlCommon (Module: ScrewTurn.Wiki.Plugins.SqlCommon) Version: 3.0.2.500 (3.0.2.500)


ExecuteScalar Method

ExecuteScalar Method
ScrewTurn Wiki ► ScrewTurn.Wiki.Plugins.SqlCommon ► SqlStorageProviderBase ► ExecuteScalar()()()
Members
Icon | Member | Description
 | ExecuteScalar<(Of <(T>)>)(DbCommand, T) | Executes a scalar command, then closes the connection.
 | ExecuteScalar<(Of <(T>)>)(DbCommand, T, Boolean) | Executes a scalar command, then closes the connection.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Plugins.SqlCommon (Module: ScrewTurn.Wiki.Plugins.SqlCommon) Version: 3.0.2.500 (3.0.2.500)

Assembly: SqlServerProviders (Module: SqlServerProviders) Version: 3.0.2.500 (3.0.2.500)


ExecuteReader Method

ExecuteReader Method
ScrewTurn Wiki ► ScrewTurn.Wiki.Plugins.SqlCommon ► SqlFilesStorageProviderBase ► ExecuteReader()()()
Members
Icon | Member | Description
 | ExecuteReader(DbCommand, Boolean) | Executes a reader command, leaving the connection open.
 | ExecuteReader(DbCommand) | Executes a reader command, leaving the connection open.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: SqlServerProviders (Module: SqlServerProviders) Version: 3.0.2.500 (3.0.2.500)

Assembly: ScrewTurn.Wiki.Plugins.SqlCommon (Module: ScrewTurn.Wiki.Plugins.SqlCommon) Version: 3.0.2.500 (3.0.2.500)


ExecuteReader Method

ExecuteReader Method
ScrewTurn Wiki ► ScrewTurn.Wiki.Plugins.SqlServer ► SqlServerUsersStorageProvider ► ExecuteReader()()()
Members
Icon | Member | Description
 | ExecuteReader(DbCommand, Boolean) | Executes a reader command, leaving the connection open.
 | ExecuteReader(DbCommand) | Executes a reader command, leaving the connection open.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: SqlServerProviders (Module: SqlServerProviders) Version: 3.0.2.500 (3.0.2.500)


ExecuteScalar Method

ExecuteScalar Method
ScrewTurn Wiki ► ScrewTurn.Wiki.Plugins.SqlServer ► SqlServerUsersStorageProvider ► ExecuteScalar()()()
Members
Icon | Member | Description
 | ExecuteScalar<(Of <(T>)>)(DbCommand, T) | Executes a scalar command, then closes the connection.
 | ExecuteScalar<(Of <(T>)>)(DbCommand, T, Boolean) | Executes a scalar command, then closes the connection.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: SqlServerProviders (Module: SqlServerProviders) Version: 3.0.2.500 (3.0.2.500)


ExecuteScalar Method

ExecuteScalar Method
ScrewTurn Wiki ► ScrewTurn.Wiki.Plugins.SqlServer ► SqlServerSettingsStorageProvider ► ExecuteScalar()()()
Members
Icon | Member | Description
 | ExecuteScalar<(Of <(T>)>)(DbCommand, T) | Executes a scalar command, then closes the connection.
 | ExecuteScalar<(Of <(T>)>)(DbCommand, T, Boolean) | Executes a scalar command, then closes the connection.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: SqlServerProviders (Module: SqlServerProviders) Version: 3.0.2.500 (3.0.2.500)


ExecuteReader Method

ExecuteReader Method
ScrewTurn Wiki ► ScrewTurn.Wiki.Plugins.SqlCommon ► SqlSettingsStorageProviderBase ► ExecuteReader()()()
Members
Icon | Member | Description
 | ExecuteReader(DbCommand, Boolean) | Executes a reader command, leaving the connection open.
 | ExecuteReader(DbCommand) | Executes a reader command, leaving the connection open.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Plugins.SqlCommon (Module: ScrewTurn.Wiki.Plugins.SqlCommon) Version: 3.0.2.500 (3.0.2.500)

Assembly: SqlServerProviders (Module: SqlServerProviders) Version: 3.0.2.500 (3.0.2.500)


ExecuteReader Method

ExecuteReader Method
ScrewTurn Wiki ► ScrewTurn.Wiki.Plugins.SqlCommon ► SqlStorageProviderBase ► ExecuteReader()()()
Members
Icon | Member | Description
 | ExecuteReader(DbCommand, Boolean) | Executes a reader command, leaving the connection open.
 | ExecuteReader(DbCommand) | Executes a reader command, leaving the connection open.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Plugins.SqlCommon (Module: ScrewTurn.Wiki.Plugins.SqlCommon) Version: 3.0.2.500 (3.0.2.500)

Assembly: SqlServerProviders (Module: SqlServerProviders) Version: 3.0.2.500 (3.0.2.500)


CloseReader Method

CloseReader Method
ScrewTurn Wiki ► ScrewTurn.Wiki.Plugins.SqlServer ► SqlServerFilesStorageProvider ► CloseReader()()()
Members
Icon | Member | Description
 | CloseReader(DbCommand, DbDataReader) | Closes a reader, a command and the associated connection.
 | CloseReader(DbDataReader) | Closes a reader.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: SqlServerProviders (Module: SqlServerProviders) Version: 3.0.2.500 (3.0.2.500)


ExecuteReader Method

ExecuteReader Method
ScrewTurn Wiki ► ScrewTurn.Wiki.Plugins.SqlCommon ► SqlPagesStorageProviderBase ► ExecuteReader()()()
Members
Icon | Member | Description
 | ExecuteReader(DbCommand, Boolean) | Executes a reader command, leaving the connection open.
 | ExecuteReader(DbCommand) | Executes a reader command, leaving the connection open.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: SqlServerProviders (Module: SqlServerProviders) Version: 3.0.2.500 (3.0.2.500)

Assembly: ScrewTurn.Wiki.Plugins.SqlCommon (Module: ScrewTurn.Wiki.Plugins.SqlCommon) Version: 3.0.2.500 (3.0.2.500)


CloseReader Method

CloseReader Method
ScrewTurn Wiki ► ScrewTurn.Wiki.Plugins.SqlCommon ► SqlStorageProviderBase ► CloseReader()()()
Members
Icon | Member | Description
 | CloseReader(DbCommand, DbDataReader) | Closes a reader, a command and the associated connection.
 | CloseReader(DbDataReader) | Closes a reader.

Copyright (C) 2006-2010 Threeplicate Srl. All rights reserved.

Assembly: ScrewTurn.Wiki.Plugins.SqlCommon (Module: ScrewTurn.Wiki.Plugins.SqlCommon) Version: 3.0.2.500 (3.0.2.500)

Assembly: SqlServerProviders (Module: SqlServerProviders) Version: 3.0.2.500 (3.0.2.500)